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Legal information
Warning notice system

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger.

DANGER
indicates that death or severe personal injury will result if proper precautions are not taken.

WARNING
indicates that death or severe personal injury may result if proper precautions are not taken.

CAUTION
indicates that minor personal injury can result if proper precautions are not taken.

NOTICE
indicates that property damage can result if proper precautions are not taken.
If more than one degree of danger is present, the warning notice representing the highest degree of danger will be 
used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to property 
damage.

Qualified Personnel
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. Qualified 
personnel are those who, based on their training and experience, are capable of identifying risks and avoiding 
potential hazards when working with these products/systems.

Proper use of Siemens products
Note the following:

WARNING
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended or 
approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be complied with. The information in the relevant documentation must be observed.

Trademarks
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication 
may be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

Disclaimer of Liability
We have reviewed the contents of this publication to ensure consistency with the hardware and software described. 
Since variance cannot be precluded entirely, we cannot guarantee full consistency.  However, the information in 
this publication is reviewed regularly and any necessary corrections are included in subsequent editions.
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Product overview 1
1.1 Introduction to the Automation License Manager

Introduction
The Automation License Manager is a product of Siemens AG Industry Sector. It is used to 
manage license keys (the technical implementations of licenses). 

Software products requiring license keys automatically report this requirement to the 
Automation License Manager. When the Automation License Manager finds a valid license 
key for this software, the software can be used in conformity with the end user license 
agreement.

Definitions of terms used
The following table explains important terms used in context with the Automation License 
Manager.

Term Description
Software A product installed on hardware and used to process data
Hardware Computer (PC), device or module on which software runs.
License A license gives the user a legal right to use the product. 

Evidence of this right is provided by the following:
● the CoL (Certificate of License) and 
● the license key

CoL (Certificate of License) The CoL is the proof of the license. The product may only be used by 
the owner of the license or authorized persons. 

License key The license key is the "technical form" of the license ("electronic license 
stamp").

Storage Locations for License Keys
You can store license keys on storage media such as license key data media (authorization 
diskettes for authorizations), on removable drives (but not on CDs, CDRWs) and on USB 
memory sticks. 

License keys can be located locally on your own computer as well as on a connected computer.

Automation License Manager
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1.2 Overview of the functions

Functionality in the Automation License Manager 
You can execute the following functions with the Automation License Manager:

Function Description
Management of license 
keys

All functions required for managing license keys

Transferring license keys Moving license keys between storage locations (for example computers, 
USB memory sticks, folders…)

Displaying license keys Display detailed information of license keys (for example, validity, status, 
etc.)

Storing license keys Storing license keys locally on your own computer or a connected com‐
puter.

Checking license keys Determining the status of license keys (for example, OK, used, etc.)
Determining and displaying 
required license keys

Comparison between existing and required license keys

Checking out license keys License keys are temporarily transferred from a server for use on a con‐
nected computer.

Checking in license keys License keys are returned to the server from a connected computer.
Logging actions involving li‐
cense keys

Logging license key-specific actions on a computer

Blocking external access to 
license keys

Blocking external access when SIMATIC Logon is not available

Access protection support 
for license keys

If SIMATIC Logon is installed on the computer, the Automation License 
Manager can be used to activate access protection for license keys. (see 
note)

Access Protection for License Keys
To support access protection for license keys, certain requirements must be met. You will find 
additional information in: Access protection by SIMATIC Logon role management (Page 57)  

Opening the Online Help
The online help for the Automation License Manager provides you with all the necessary 
information on the functionality and handling of license keys.

After starting the Automation License Manager, you can open the online help as follows:

● with the F1 button or 

● the menu command "Help > Help on Automation License Manager".

Product overview
1.2 Overview of the functions
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1.3 Licenses in the Automation License Manager

Overview of the Standard License types
The standard license types listed below are available to you in the Automation License 
Manager:

Standard license types Description
Single Use of the software with this license is permitted on any computer. The 

type of use is governed by the Certificate of License.
Floating Use of the software with this license includes right of use for simultaneous 

usage. The software can be installed more than once.
Master Use of the software with this license is unlimited.
Upgrade Before an upgrade can be used, the system status may need to meet 

certain requirements:
● Using an upgrade license, a license of an older version can be 

converted to a newer version.
● An upgrade may become necessary, for example, when the 

configuration limits need to be expanded.

Overview of the License Types
The standard license types listed below are available to you in the Automation License 
Manager:

License types Description
Unlimited Use of the software with this license is unlimited.
Count relevant The use of the software with this license is restricted to:

● The number of tags named in the agreement.
Countable Objects The use of the software with this license is restricted to:

● The number of objects named in the agreement.
Rental The use of the software with this license is restricted to:

● The number of operating hours named in the agreement.
● The number of days from first use named in the agreement.
● The expiration date named in the agreement.
Note: You can see brief information on the time left for the rental license 
in the information area of the taskbar.

Product overview
1.3 Licenses in the Automation License Manager
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License types Description
Trial The use of the software with this license is restricted to:

● A period of validity, for example, a maximum of 14 days.
● A certain number of days from first usage.
● Use for tests and validation (disclaimer of warranty).

Demo The use of the software with this license is restricted to:
● The number of operating hours named in the agreement.
● The number of days from first use named in the agreement.
● The expiration date named in the agreement.
Note: You can see brief information on the time left for the demo license 
in the information area of the taskbar.

Missing License Keys 
License keys that are required by software but are not available in a "valid" form on the network 
are known as missing license keys.

Note that not all computers connected to the network will be searched, but only those 
computers added to the "Search list" in the Automation License Manager.

You set the computers to be searched in the network with the menu command File > Settings 
> Favorites.

See also
Determining and synchronizing license requirements (Page 42)

Settings in the Automation License Manager (Page 22)

1.4 Scope of delivery

Installation Software Included with Product
You will find the Automation License Manager on the installation medium of a software product 
requiring a license key (e.g. a CD-ROM, USB stick).

Components of the Automation License Manager
The Automation License Manager ships as follows:

Product overview
1.4 Scope of delivery
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Component Description Must be in‐
stalled

Can be instal‐
led

Automation Li‐
cense Manager

Contains the user interface for the Automation Li‐
cense Manager with all underlying services.

x -

Plug-in Contains product-specific adaptations to the Auto‐
mation License Manager.

- x

Note
Automation License Manager

The Automation License Manager itself does not require a license key.

1.5 Worldwide help from "Support for License Management"

Support for License Management
You can obtain support for license management with the following link: Support for License 
Management (http://support.automation.siemens.com/WW/view/en/772175) 

The teams at "Technical Support" and "Support for License Management" speak German and 
English.

Product overview
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Automation License Manager
Programming and Operating Manual, 09/2014, A5E32921785-AC 11

http://support.automation.siemens.com/WW/view/en/772175


Product overview
1.5 Worldwide help from "Support for License Management"

Automation License Manager
12 Programming and Operating Manual, 09/2014, A5E32921785-AC



Installation 2
2.1 Installation requirements

Hardware
You will find hardware requirements for using the Automation License Manager in the readme 
file that ships with this version.

Operating system
The Automation License Manager is a Windows program. You will find the approved operating 
systems for this version of the Automation License Manager in the supplied readme file. 

The software can operate with all language versions of the supported operating systems. 

Note
Opening the readme file

You can open the supplied Readme file after installing the Automation License Manager with 
Start > Programs > Siemens Automation > Documentation > Readmes.  Then select the 
readme file in your preferred language and then the Automation License Manager.

Product-Specific Plug-ins for Software Products and Components
When you install product-specific plug-ins, please note the information below.

NOTICE

Installation of Product-Specific Plug-ins

The Automation License Manager requires product-specific plug-ins for managing the license 
keys of some software products and components. These plug-ins are always delivered with 
the project when required and installed with their own setup.

2.2 Installing the Automation License Manager

Introduction
The Automation License Manager is installed using a setup program that guides you step by 
step through the installation process. You will find the installation software for the Automation 
License Manager on the product CD. 
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The software components included with the Automation License Manager are listed in the 
section "Scope of Delivery".

Requirement
● Before you can begin the installation, the operating system must be started; see "Installation 

requirements".

● Close all programs before starting the installation.

Procedure
To install the Automation License Manager, follow these steps: 

1. Connect the data medium containing the software to your PG/PC.
You do not require an external data storage medium if the software to be installed is already 
on the hard disk of the programming device or PC.

2. Double-click the "Setup.exe" file to start the setup program for the Automation License 
Manager.  
The program guides you step by step through the entire installation process. 

3. Follow the instructions displayed by the installation program. 

Note

During installation, you can return to the previous step or advance to the next step.

4. During the installation, you will be prompted to answer questions and make selections in 
dialog boxes. Choose the settings that are suitable for your requirements. Completion of 
the installation is displayed in the "Automation License Manager Setup" dialog.

5.  Click the "Finish" button to exit the setup program.

See also
Installation requirements (Page 13)

2.3 Uninstalling the Automation License Manager

Procedure
To uninstall the Automation License Manager, follow these steps:

1. Open the Control Panel by selecting "Start > Settings > Control Panel" from the Start menu 
of your computer.

2. Open "Add or Remove Programs" in the detailed view.

3. Select the "Automation License Manager" entry.

4. Click the "Remove" button.

Installation
2.3 Uninstalling the Automation License Manager
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5. Click "Yes" to confirm you want to uninstall the program.

6. Click "OK" when the program have been successfully uninstalled. 

Result: The Automation License Manager has been uninstalled.

2.4 Installing plug-ins

Installing Product-Specific Plug-ins
Plug-ins are installed using a product-specific setup program. Follow the relevant instructions 
in the setup program.

Note

The Automation License Manager requires product-specific plug-ins for managing the license 
keys of some applications and components. These plug-ins are supplied with the product if 
they are not already available to you.

2.5 Upgrade of licenses

Different License Upgrades
If you are upgrading a license key or an "old authorization" to allow you to use a new software 
version, the following distinction must be made:

● Upgrade of a license key to a new license key

● Upgrade of an authorization to a license key

● Upgrade of an authorization to a more recent authorization

Rules for License Upgrades
● Please note that both the "old" authorization or the "old" license key as well as the upgrade 

itself should be stored on the hard disk of the computer on which the upgrade will be 
performed.

● Note that upgrade license keys cannot be installed during setup.

Installation
2.5 Upgrade of licenses
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Requirement
To upgrade a license key or an "old authorization", the following requirements must be met:

● You require the CoL (certificate of license) and the license key or an "old authorization" on 
an authorization diskette for the software version you are upgrading.

● You also need the CoL and the upgrade license key or the upgrade authorization on an 
authorization diskette for the target version.

● The license keys or authorizations must be available on the local computer.

– If the upgrade target is a license key at one of the following storage locations: license 
key data medium or authorization disk, drive or USB memory stick.

– If the upgrade target is an authorization: only on authorization diskette.

Upgrading a License
To upgrade a license key (simply called a license key below even if the source or destination 
is an authorization), follow the steps below:

1.  Select the "View > Management" menu command.

2. In the navigation panel, select the location of the license key you want to upgrade.

3. In the object area, select the license key to be upgraded.

4. Select the "License Key > Upgrade" menu command.

– If there is only one possibility for an upgrade, the upgrade is made without further 
messages or prompts.

– If there are several possibilities for upgrading, the "License Key Upgrade" dialog opens.

– Select the upgrade you require and click the "Upgrade" button.

Note
Authorizations on 64-bit operating systems

Note that authorizations are no longer supported on 64-bit operating systems.

See also
Notes on use of "older software versions" (Page 17)

Installation
2.5 Upgrade of licenses
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2.6 Notes on use of "older software versions"

Software Products Activated with License Keys
Software products that can be activated for operation with license keys can also use newer 
license keys. The following applies to these products:

● "Newer" versions of license keys can always be used to operate different software versions. 

● It is not necessary to downgrade a license key to use "older" versions.

Note
How to Recognize License Keys

You can recognize a license key in the Automation License Manager in the "Management" 
view by its twenty-digit license number. 

Software products that can be activated with "old authorizations"
An authorization is required for software products that are activated with authorizations. These 
software products cannot be operated with a license key. License keys for later versions can 
only be used for software products that use a license key.

Upgrading an "old authorization" is described in the online help of the Automation License 
Manager in "Upgrade of Licenses".

Note
How to Recognize Authorizations

You can recognize an authorization in the Automation License Manager in the "Management" 
view by its ten-digit license number. 

See also
Upgrade of licenses (Page 15)

2.7 Notes on optimizing hard disks

Optimizing Hard Disks
When license keys are transferred, clusters are created on the drive (data medium or hard 
disk) that are labeled as "bad" by some utilities.

Installation
2.7 Notes on optimizing hard disks
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CAUTION

"Bad" clusters on hard disks

Do not attempt to restore clusters identified as "bad". Restoring them will destroy the license 
keys.

Rules for Optimizing Hard Disks

● If you use an optimization program that is capable of moving fixed blocks, you should first 
transfer the license keys from the hard disk to a license key data medium (for older programs 
an authorization diskette) before using this option.

● If a backup of your hard disk contains copies of license keys, there is the danger that 
restoring the disk from a backup will overwrite the currently valid license keys and destroy 
them. To avoid the risk of losing license keys in this way, it is strongly recommended that 
you either remove all license keys before making the backup or exclude them from the 
backup.

● Do not forget to remove the license keys before formatting, compressing or restoring your 
hard disk or installing a new operating system.

CAUTION

Defragmentation programs

The files used to store the license keys can be destroyed by defragmentation programs that 
move fixed blocks. 

Recommendation: Always exclude the license keys from the procedure before using 
defragmentation programs.

Excluding License Keys from Optimization
You have the option of excluding certain license keys or authorizations from the optimization 
if you want to optimize a hard disk.

● Prior to the optimization, transfer all license keys to the corresponding license key data 
medium.

● Prior to optimization, transfer all authorizations to the corresponding authorization diskette.

Installation
2.7 Notes on optimizing hard disks
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Working with the Automation License Manager 3
3.1 User interface

3.1.1 User Interface of the Automation License Manager

Introduction
The user interface of the Automation License Manager has the following structure:

Title bar: 
Contains the window title "Automation License Manager" and the icons for controlling the 
window.

Menu bar:
Contains all menus that are available in the Automation License Manager.

Toolbar:
Contains icons for fast execution of frequently used commands plus the currently selected 
view, here "License keys". 

Work area:
Contains the navigation panel on the left (shown in white above) and the associated object 
area on the right.

Status bar:
This is located at the bottom edge of the application and contains seven boxes for showing 
status information.

The displayed information depends on the currently selected view and the objects selected in 
the navigation panel.

Automation License Manager
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Navigation Panel
You will find the following objects in the navigation panel on the left:

View Objects in the navigation panel
Management Here you see the objects you can manage, such as  My Computer, connected 

computers, folders configured in the Automation License Manager, and li‐
cense key folders.

Find Here you can select the following search options:  Search term, Product, Stor‐
age location, Standard license type, License type, Status, Used by

Log Here you can select the corresponding computer as well as various filter cri‐
teria.

Object Area
Individual objects are displayed in the object area on the right depending on:

● The view set in the Automation License Manager

● The object selected in the navigation panel.

The object area consists of the following areas:

Area Description
Header The title allows the user to see the contents of the current view at a glance. 

Large icons help to identify the relevant folder quickly. 
Data area The data area shows all the elements within the folder selected in the naviga‐

tion panel.

Note
No objects exist

When there are no objects for display in the object area, a message to this effect is shown 
instead of objects.

3.1.2 Table columns in the object area

Introduction
When you open the Automation License Manager, you see the navigation panel on the left 
and the associated object area on the right. According to the displayed object, you will see 
columns with the corresponding information for:

● License keys or

● Software

The "License keys" view displays the license keys available on the selected drive along with 
the following related data in the object area on the right: 
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Column Description
Status Displays status information, such as  OK, Defective, Used.

See also: Status Icons in the Automation License Manager (Page 23)
Family Displays the relevant family, e.g., "SIMATIC STEP 7".
Product Displays the relevant product, e.g., "STEP 7"
Version Displays the version identifier of the software product, e.g., "5.4".
Number of license keys Displays the number of available license keys.
Article number Optional
Standard license type Indicates the standard type of the license, e.g.  Single, Floating, Master or 

Upgrade
License type The following licenses are available:

● Unlimited
● Count relevant (tag/s)
● Countable objects
● Rental (limited hours, limited days, expiration date)
● Trial (limited days)
● Demo (limited hours, limited days, expiration date)
● PowerPack 

Validity The following options are available for validity:
● Unlimited: Unlimited
● Count relevant: Number of variables or tags
● Countable objects:  Counts application-specific objects.

Booked counter reading is retained after the computer is restarted.
● Rental: Remaining time + unit / date
● Trial: Remaining time (total runtime) 
● Demo: Remaining time + unit / date
● Master: As stipulated in the agreement
● Upgrade: As stipulated in the agreement
● PowerPack: As stipulated in the agreement

License number Serial number of the software license
(10-digit = authorization; 20-digit = license key)

Optional columns:
Manufacturer For example, Siemens AG
Computer Name of the computer on which the license key is located.
License key Name of the license key.
Storage location Storage location: My Computer (local) or connected computer
Last used Currently, no function
User User of the license key
Computer used Computer that is using the license key.
HW serial number Displays the hardware serial number.
Amount of software Optional
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3.1.3 Settings in the Automation License Manager

Opening the "Settings" Dialog
Follow these steps:

1. Select the "File > Settings" menu command.
The "Settings" dialog opens.

2. Enter the settings you require.

3. Close the dialog with "OK".

You can make the following settings in the "Settings" dialog: 

Set what? Settings in: What to do:
Access protection "General" tab If you want to enable access protection, certain requirements must be met. 

See also: Access protection by SIMATIC Logon role management 
(Page 57)

Blocking of remote 
access 

"General" tab If you want to prevent:
● Connected computers from using a license key, select the "Forbid 

remote use of license keys" check box.
● License keys from being removed from the local computer, select the 

"Forbid license keys transfer from local computer" check box.
● License keys from being added to the local computer, select the "Forbid 

license keys transfer to local computer" check box.
All boxes can be combined.
The check boxes are disabled when SIMATIC Logon is installed and the 
"Activate SIMATIC Logon access protection" check box has been selected.
See also: "General" tab in the "Settings" dialog (Page 99)

Language "General" tab Select one of the available languages in the drop-down list.
See also: "General" tab in the "Settings" dialog (Page 99)

Search order "Favorites" tab The list of "Known computers" on the left of the "Favorites" tab displays the 
computers that have been connected to the local Automation License Man‐
ager at some point in the past.
License keys are only assigned on computers included in the "Search list" 
on the right-hand side. The search order is from top to bottom. Select the 
computers you want to be searched first for floating license keys and move 
them to the top of the list. 
See also: "Favorites" tab in the "Settings" dialog (Page 99)

Connection to other 
computers 

"Connection" tab Define the required connection settings in this tab. 
Remember that you will need to adapt your firewall settings to allow a con‐
nection to other computers.
See also: "Connection" tab in the "Settings" dialog (Page 100)
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Set what? Settings in: What to do:
User-defined set‐
tings

"Reset" tab In this tab, you can reset or delete the user-defined settings you have made.
See also:"Reset" tab in the "Settings" dialog (Page 101)

Upgrade check and 
checkout of license 
keys

"License keys" tab In this tab you enable:
● The upgrade check 
● The transfer mode for the checkout of license keys 
Notes: 
If you select the "Upgrade" option, your computer automatically checks for 
existing but as yet unused upgrade license keys when the program starts. 
If you select the "Check out" option, a license key transfer to a connected 
computer is logged as checking out. The checked out license keys can be 
used on the connected computer and then later transferred back to the 
computer that is acting as the server.
See also: "License keys" tab in the "Settings" dialog (Page 102)

 

3.1.4 Feedback if Program Execution is Delayed

Feedback if Program Execution is Delayed
When there is a delay in program execution, the program provides you with feedback. The 
following rules apply here: 

● If there is a minor delay of up to approximately 10 seconds, the mouse pointer is displayed 
as an "hourglass".

● If delays are longer and the time cannot be predicted, an animation indicates that the 
process is running.

Information on the Current Process
When the animation is displayed, a message is also displayed indicating the current processing 
step, for example, "Transfer license key...".

Canceling Processing
If cancellation of a function is permitted, you will see a "Cancel" button in the dialog.

3.1.5 Status Icons in the Automation License Manager

Status Icons in the Automation License Manager
The existing status icons and their significance for the license keys in the Automation License 
Manager are explained below.
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Note
Inactive icons

Some icons are labeled inactive in the Description column of the following table. License keys 
with these icons cannot be used. This may be caused by an incomplete offline transfer in which 
the activation code has not yet been received.

Meaning of the Status Icons for License Keys

Icon Meaning
Status of the license key unknown 

License key "OK"

License key was in use when queried

License key is corrupt 
(recover with support from hotline)
Inactive - status of the license key unknown 

Inactive - license key available but not activated 

Inactive - license key is damaged (recover with support from hotline)

Regular validity of a time-limited license key has expired

Additional grace period for use of a time-limited license key

Additional grace period for a time-limited license key that was being used at the time 
of the query.
Regular validity and additional grace period of a time-limited license key have fully 
expired
The license key counter has reached the limit; it cannot be decremented further.

The license key cannot be transferred.

Meaning of the Status Icons for installed Software

Icon Meaning
Basic icon for software on the computer 

Software with a valid license key exists

Software does not require a license key for use
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Icon Meaning
Software exists on the computer > license key is already being used

Software exists on the computer > there is no valid license key

Software exists on the computer > a license key is present but is corrupt

Meaning for the Status Icons in the "Log" View

Icon Meaning
Indicates information

Indicates a warning

Indicates an error

Meaning of the Folder

Icon Meaning
Indicates a folder in which computer connections can be stored.

Indicates a license key folder in which license keys can be stored.

3.1.6 Icons in the toolbar

Introduction
With the "View > Toolbar" menu command, you enable or disable the display of the toolbar in 
the Automation License Manager. In the figure below, you can see the toolbar in the Automation 
License Manager with the standard view "License keys".

Note
Display in the toolbar

A button shown as pressed indicates that a specific status is active (here, for example, the 
"Management" view). 

An icon with a dark gray background can have the following meaning:
● The function represented by the icon is not active 
● The function represented by the icon is not available.
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The following icons are available in the toolbar:

Icon Menu command Keyboard short‐
cut

Description

File > Export Ctrl + S Exports the information displayed in the object area.

File > Print Ctrl + P Prints the information displayed in the object area.

File > Print Pre‐
view

 Shows a preview of the printout of the current object 
area.

Edit > Cut Ctrl + X Moves the license keys selected in the object area 
to the clipboard.
Note: Use only in conjunction with "Paste".

Edit > Paste Ctrl + V Inserts the license keys stored on the clipboard.
Note: Use only in conjunction with "Cut".

Edit > Delete Del Deletes the objects selected in the object area.

View > Manage‐
ment

 Allows use of all the management tasks for license 
management.
Brings the "Management" view to the foreground.

View > Find  Shows a search screen and the results; this view is 
used to define special queries. 
Brings the "Find" view to the foreground.

View > Log  Displays the recorded log.
Brings the "Log" view to the foreground.

View > Define ...  Defines the content and appearance of the "Man‐
agement" view.

View > Update F5 Updates the information displayed in the object area.

Help > Context-
Sensitive Help

F1 Calls up context-sensitive help for the selected ob‐
ject or menu command.

3.1.7 Keyboard shortcuts

Overview of the Possible Keyboard Shortcuts
The keyboard shortcuts described below correspond to the MICROSOFT standard.

Shortcut key Effect
F1 Call up online help
F5 Update active window
Ctrl + A Select all
Ctrl + P Print current object view
Ctrl + X Cut
Ctrl + V Paste
Alt + spacebar Open the system menu of the active window
Alt + F4 Close active element or active program
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3.2 Views in the Automation License Manager

3.2.1 Standard views

Overview of the Standard Views
The following standard views are available in the Automation License Manager after 
installation: 

View Description
Search results Displays the search options in the "Find" view on the left and, following a 

successful search, the associated search results on the right.
License keys Displays all license keys that are available on the selected drive in the 

"Management" view.
Installed software Shows the installed software products on the selected computer that re‐

quire a license key. If a second value is indicated in brackets in the "Ver‐
sion" column when displaying the installed software, then the version of 
the license key shown in brackets is used for the installed product version. 

Missing License Keys Shows the installed software products that are missing license keys.
Licensed software Displays the installed software products for which a license key is available 

on the selected computer.

Note
Editing Standard Views

Please note the following: Standard views can only be copied; they cannot be deleted or 
changed.

3.2.2 Overview of the "Management", "Find", and "Log" views

Opening the Views in the Automation License Manager
You can open the various views in the Automation License Manager by selecting the "View > 
Management/Find/Log" menu command.

You have the choice of the following views:
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View Description
Management ● Displays a structure with computers and folders

● Allows all the management tasks for license management to be performed
Find ● Displays a search dialog and the results of the search
Log ● Displays local and connected computers

● Displays information about the transfer of license keys
● Displays log entries
● Displays transfer actions for the check out and check in of license keys

Working with Multiple Views
You can only work with one view at a time in the work area of the Automation License Manager 
(similar to Windows Explorer). However, the Automation License Manager can be started more 
than once. 

By the Automation License Manager more than once, you can move license keys within the 
application and between two windows.

Note
User-specific settings

The Automation License Manager has a session memory and user-specific settings are 
therefore saved automatically.

3.2.3 Working in the "Management" view.

Introduction
In the "Management" view, you can select and activate available views or define your own 
views. Several predefined standard views for the Management view are installed with the 
Automation License Manager. 

Follow these steps:

1. Select the view using the "View > Management" menu command.

2. The currently selected view in the drop-down list on the menu bar is used to display 
information in the object area.

3. Select the "View > Define" menu command.
The "Define View" dialog opens. Here, you can access information using existing views or 
define a new view.
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Meaning of the Buttons in "Define View"

Button Meaning
OK The view selected in the "Available views" list is used to display information in 

the object area.
Apply Views can be edited in the expanded "Edit view" area.

Changes become active when you click "Apply".
Cancel Closes the "Define View" dialog without applying the changes.
New Define a new view
Copy Copy an existing view
Delete Delete an existing view

"New", "Copy" and "Delete" buttons
The "New", "Copy" and "Delete" buttons operate on the views displayed in the "Available views" 
list. 

"Edit view" area
The name of the view is entered in the "Name" box. This name appears in the view as the title 
of the object area and in the drop-down list on the toolbar. 

You can use the radio buttons to preselect the filtered contents of a view to be displayed:

● License keys – only license key information is available for selection.

● Software - Only software information is available for selection.

You can define the content and layout of the views in the following tabs:
● The columns

● The filters

● The groups

● The sorting

3.2.4 Views drop-down list
The "Views" drop-down list shows the "view" set for the "Management" view.

You can find the available standard views in the section "Standard views". In the example 
shown, the standard view "License Keys" is active.
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3.2.5 Working in the "Find" View

Introduction
You can search for information on license keys and installed software in the "Find" view in the 
Automation License Manager.

Follow these steps:

1. Select the view using the "View > Find" menu command.

2. Make the following settings in the "Find" area:

– Enter a search term and/or product as necessary.

– Select criteria in the "Storage location", "Standard license type", "License type", "Status", 
and "Used by" lists.

– Click the "Find Now" button to begin the search.

Result: The search results are displayed in the object area.

Example: Find a License Key in the Network
Follow these steps:

1. Select the view using the "View > Find" menu command.

2. Make the following settings in the "Find" area:

– Enter the term "STEP 7" for example in the "Search Term" input box.

– Select "All" in the "Storage location" drop-down list.

– Click the "Find Now" button.

Result: All license keys are displayed that

● Contain the term "STEP 7"

● Are present on your own computer or a connected computer
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3.2.6 Working with the "Log" and "Check out log" views

Introduction
The "Log" view provides information on all operations that involve license keys (such as use 
of a license key by software, transfer of license keys,check out of license keys...).

To call up a log, follow these steps:

1. Open the view using the "View > Log" menu command.

2. Select the required view from the drop-down list: Log view or Check out view. 

3. In the object area, select the location (My Computer, connected computer) where you want 
to open a stored log. 

4. Select the number of entries you require or select the time period for which logs will be 
displayed.

5. Select the "System entries" check box if you want system entries to be displayed as well. 
System entries are additional entries that are relevant for customer support and the 
technology.

6. Select the "Filter" check box if you want to use a filter. Select the filter you require from the 
drop-down list.

7. Click the "Update" button.
Result: The log entries corresponding to the selected criteria are displayed for the selected 
view.

.

Note
Point to note about the check out log

The check out log displays all actions relating the check out of license keys that have not yet 
been completed. It shows all license keys checked out from the server that have not yet been 
checked in again.

If a license key has been checked out and then checked in again, the action has been 
completed and is therefore not shown in the check out log.

Printing the Log
Follow these steps:

1. Open a log.

2. To print the log, select the "File > Print" menu command.

3. Correct the settings if necessary and confirm the dialog with "OK".
Result:The displayed log entries are printed out.
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Archiving the Log
Follow these steps:

1. Open a log.

2. To archive the log, select the "File > Export" menu command.

3. Enter the drive and storage path.
Result: The displayed log entries are stored on the specified path in csv format.

Delete Log
Follow these steps:

1. To delete all the entries in the log, select the "Edit > Delete Log" menu command.
Result: All log entries of the selected computer are deleted.

3.3 Handling license keys

3.3.1 Installing License Keys

Installing License Keys
License keys can be installed during the installation of the software product

Some software products allow you to install the required license key during the installation 
(setup) of the program itself. The license key is then installed on the computer where the 
software is being installed.

Note
Upgrade license keys

Note that upgrade license keys cannot be installed during setup.

See also
Transferring license keys (Page 35)
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3.3.2 Displaying Installed License Keys

Procedure
You can list all installed license keys using the "View > Management" menu command. 

Follow these steps:

1. Select the view using the "View > Management" menu command.

2. In the navigation panel, select the computer (My Computer or connected computer) and 
the drive from which you want to see the installed license keys

3. Select the "View > Define" menu command.
The "Define View" dialog opens.

4. Select the "License keys" view and click "OK".
Result: The license keys installed on the computer are displayed.

Note
Unrecognized license keys

When available license keys are not recognized by corresponding components, check the 
following columns:
● Version
● Validity
● Status (select license keys, select "View > Update", then "License Key > Check")

Printing or Exporting the List of Installed License Keys
You can edit the list of installed license keys as follows:

1. Print using the "File > Print" menu command.

2. Export to a CSV file with the "File > Export" menu command.

See also
Status Icons in the Automation License Manager (Page 23)

3.3.3 Displaying Installed software

Procedure
You can list all installed software products that require a license key for operation by selecting 
the "View > Management" menu command.
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Follow these steps:

1. Select the view using the "View > Management" menu command.

2. Select the "View > Define" menu command.
The "Define View" dialog opens.

3. Select the "Installed software" view and click "OK".
Result: The Siemens AG software products installed on the computer that support the new 
license concept (using license keys) are displayed.

Note
Notes on the versions of license keys

If a second value is shown in brackets in the "Version" column when displaying the installed 
software, this means that the version of the license key shown in brackets is used for the 
installed product version.

Printing or Exporting the List of Installed Software
You can edit the list of installed software as follows:

1. Print using the "File > Print" menu command.

2. Export to a CSV file with the "File > Export" menu command.

See also
Status Icons in the Automation License Manager (Page 23)

3.3.4 Checking license keys

Procedure
Follow these steps:

1. Select the view using the "View > Management" menu command.

2. In the object area, select the storage location (My Computer, connected computer, license 
key folder) where the license key you want to check is stored.

3. Select the license key to be checked.

4. Select the License Key > Check menu command. 

Result: The selected license key is checked, and the result is displayed using a status icon for 
license keys.

See also
Status Icons in the Automation License Manager (Page 23)
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3.3.5 Transferring license keys

Procedure
The following options are available for transferring license keys between various storage 
locations (for example, computers, USB memory sticks and license key folders):

● Using drag-and-drop

● Using cut and paste

● Using the "License Key > Transfer" menu command.

● Using the "License Key > Offline Transfer" menu command, you can transfer the start code, 
request code, and activation code manually (see "License Key Offline Transfer" Dialog).

Transferring License Keys Using Drag-and-Drop
Follow these steps:

1. Select the view using the "View > Management" menu command.

2. Open the storage location on your own or a connected computer from which you want to 
remove license keys.

3. Select the license keys and holding down the left mouse button, drag them to the storage 
location where you want to insert the license keys.

Result: The license keys are transferred.

Transferring License Keys by Cutting and Pasting
Follow these steps:

1. Select the view using the "View > Management" menu command.

2. Open the storage location on your own or a connected computer from which you want to 
remove license keys. 

3. Select the license keys you want to transfer.

4. Select the "Edit > Cut" menu command.

5. Open the storage location on your own computer or a connected computer where you want 
to insert the license keys. 

6. Select the "Edit > Paste" menu command.

Result: The license keys are transferred.

Transferring License Keys with the "Transfer" Command
Follow these steps:

1. First, select the license keys you want to transfer to another storage location.

2. Open the "Transfer License Key" dialog with the "License Key > Transfer" menu command.
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3. Select the destination drive you require in the drop-down list or click the "Network..." button 
if the destination drive is on a different, connected computer.
The "Connect Computer" dialog opens

4. Enter the computer name or select the computer in the drop-down list.

5. As an alternative, click "Browse" to open the "Search for a Computer" dialog. 

– Click "Entire network", and then click "Microsoft Windows Network". 

– If the computer is located in a domain, select this domain.

– Then, select the computer you require and click "OK" to confirm your selection. Note 
that the Automation License Manager must also be installed on the selected computer.

– Click "OK" to confirm your selection and close the each of the dialogs.

Result: The license keys are transferred.

See also
"License Keys Offline Transfer" dialog (Page 95)

Browsing for existing license keys in the network (Page 52)

3.3.6 Recovering license keys

Procedure
With the License Key > Recover menu command, you open the dialog for recovering license 
keys.

Follow these steps:

1. Select the license key to be recovered and select the "License Key > Recover" menu 
command.

2. Connect to "Support for License Management" and transfer the data displayed in the dialog:

– The product name

– The license key number

– The license number

– The request code

3. Enter the supplied activation code and click "OK".

Result: The corrupt license key has been recovered and is now available for use.
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Note
Recovering license keys

Note that authorizations can only be recovered on diskettes and license keys only on hard 
disks.

See also
Transferring license keys (Page 35)

"Recover License Key" Dialog (Page 103)

Dialogs in the Recover Wizard (Page 105)

3.3.7 Recovering license keys with the wizard

Procedure
With the License Key > Recover Wizard menu command, you open the "Wizard for Recovering 
License Key(s)" dialog. 

You can use the "Recover Wizard" to repair one or more license keys that are no longer 
available due to loss or a defect on the hard drive. Help from A&D Customer Support is required 
to recover the license keys. 

The wizard guides you step by step through the entire process. The following dialogs are called:

● Recover Wizard: Select license key

● Recover Wizard: Enter repair codes

● Recover Wizard: Result

See also
Recover Wizard Select license key (Page 105)

Recover Wizard Enter repair codes (Page 105)

Recover Wizard Result (Page 106)
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3.3.8 Managing keys in folders

Storing and Managing License Keys
As of Version V5.2 of the Automation License Manager, special license key folders can be 
created for managing license keys.

The folders in the Automation License Manager are identified by the following icons:

Icon Description
Indicates a folder in which computer connections can be stored.

 Indicates a license key folder in which license keys can be stored.

Actions with License Key Folders
License key folders can be moved as usual by drag-and-drop, cutting and pasting and 
renaming.

Empty license key folders can also be deleted; this is, however, no longer possible if the folder 
contains a license key.

Storing License Keys in License Key Folders
By creating license key folders, you can store license keys in a hierarchically structured 
product- and version-specific system. This gives you a better overview of the existing license 
keys, as the following example shows:
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You can also save license keys without a folder structure, as shown in the figure above. If 
however, there is a license key folder present, it is shown first and then the individual license 
keys after it.

Displaying the Validity of Licenses
An additional advantage of the license key folders is that when you are using license keys of 
the type "Count relevant" or "Countable objects", the total number of available tags (variables 
or application-specific objects) is displayed in brackets after the folder name. As the following 
example shows, the opened folder contains several license keys with differing validity, which 
are displayed as a total in brackets after the folder name.

The first number indicates how many tags are still available, the second number after the colon 
indicates the total number of available tags.
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Note
Deleting license key folders

Please note that license key folders cannot be deleted if they contain license keys. License 
key folders can only be deleted when they are empty.

See also
Creating folders (Page 40)

3.3.9 Creating folders

Using folders for structured storage 
To achieve structured storage of existing computer connections and license keys, you can 
create folders. Computer connections are stored in general folders. Special license key folders 
are required to store license keys and these folders are identified by an additional icon.
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Conditions for creating new folders:

The new folder can be a general folder or a license key folder, depending on where it is created.

Icon Description
Indicates a folder in which computer connections can be stored.
Before creating such a folder, go to the navigation panel and select:
● My Desktop
Indicates a license key folder, in which license keys can be stored.
Before creating such a folder, go to the navigation panel and select one of the fol‐
lowing alternative objects:
● Local data medium
● Already existing license key folder

Creating folders
Follow these steps:

1. Select the "Management" view. 

2. In the drop-down list within the menu bar, select the "License keys" view. 

3. Selected the required object in the navigation panel, as described in the table above.

4. To create a general folder, select "My Desktop".

5. To create a license key folder, select a local data medium or an already existing license 
key folder.

6. Using the shortcut menu or the menu, select the command "Edit > New Folder".

7. Enter a name for the new folder in the "Insert a New Folder" dialog.

8. Click "OK" to confirm. 
Result: The new folder with the name you assigned is displayed in the navigation panel.

Note
Deleting license key folders

Please note that license key folders cannot be deleted if they contain license keys. License 
key folders can only be deleted when they are empty.

See also
Managing keys in folders (Page 38)
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3.3.10 Determining and synchronizing license requirements

Introduction
You can use the "Synchronize License Requirements" dialog box to license software products 
on your own computer that do not yet have license keys, provided that license keys are 
available.

Follow these steps:

1. Select one of the predefined views "Installed software", "Missing license keys", or "Licensed 
software" using the "View > Define" menu command.

2. Select the "License Key > Synchronize License Requirements" menu command.
Result: The "Synchronize License Requirements" dialog opens.

3. From the drop-down list, select the drive where you want to install the license keys.

4. Select the option for the source of the license keys to be transferred. You can use the 
"Network" button to navigate to any computer in the network.
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5. The "Which software products are to be licensed?" box displays the software products on 
your computer that lack a valid license. Already licensed software is listed but cannot be 
selected. Click the "+" to see which licenses are available for the particular software.

6. Select which of the displayed software products you want to license and click "OK". The 
"OK" button does not become active until you have selected a software product to be 
licensed.

Note
No licensing possible

If the selected software package could not be licensed because, for example, the specified 
source computer does not contain a valid license key, you will receive a message and the 
dialog will appear again.

3.3.11 Overview of the offline transfer of license keys

Introduction
With the "License Key > Offline Transfer" menu command, you open the dialog for offline 
transfer of license keys.

Note
Condition for offline transfer

To be able to transfer license keys offline, both the Automation License Manager as well as 
the software that uses the license key must be installed on both computers (source and target).

Overview of the Steps for Offline Transfer
The transfer is performed with the aid of a wizard. Select the offline transfer step you want to 
perform and click "Next". 

You have the following options:

● Generate start code

● Generate request code

● Generate activation code

● Activate license key(s)

The wizard for the offline transfer guides you step by step through the transfer.
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See also
Offline transfer - Generate start code (Page 44)

Offline transfer - Generate request code (Page 45)

Offline transfer - Generate activation code (Page 46)

Offline transfer - Activate license keys (Page 48)

3.3.12 Offline transfer - Generate start code

Generate start code
You perform this step on the source computer where a license key for the software exists.

Note
Condition for offline transfer

To be able to transfer license keys offline, both the Automation License Manager as well as 
the software using the license key must be installed on both computers (source and target).

Procedure
Follow these steps:

1. Select the drive where the required license key is located in the navigation panel. 

2. Select the "License Key > Offline Transfer" menu command.
The "License Keys Offline Transfer" dialog opens.

3. Select the "Generate start code" option and click "Next". 
The "Wizard for Sending License Key(s)" dialog opens. The list contains the start codes of 
all available license keys.

4. Select the license keys you want to transfer in the table and click the "Save" button.

5. Select the path and the license profile file in which the start codes will be saved and click 
"Save".

6. Click the "Next" button.

7. Transfer the start codes to the target computer. For example:

– The license profile file by e-mail 

– The start codes by phone 

– A printout by fax

8. If you want to close the dialog and enter the request codes later, click "Cancel".

Working with the Automation License Manager
3.3 Handling license keys

Automation License Manager
44 Programming and Operating Manual, 09/2014, A5E32921785-AC



See also
Overview of the offline transfer of license keys (Page 43)

Offline transfer - Generate request code (Page 45)

Offline transfer - Generate activation code (Page 46)

Offline transfer - Activate license keys (Page 48)

3.3.13 Offline transfer - Generate request code

Generate request code
You perform this step on the target computer to which the license keys for software will be 
transferred.

Note
Condition for offline transfer

To be able to transfer license keys offline, both the Automation License Manager as well as 
the software using the license key must be installed on both computers (source and target).

Procedure
Follow these steps:

1. Select the "License Key > Offline Transfer" menu command.
The "License Keys Offline Transfer" dialog opens.

2. Select the "Generate request code" option and click "Next". 
The "Wizard for Receiving License Key(s)" dialog opens with an "Enter start code" list.

3. Select the following steps depending on the type of data transfer:

Type of data transfer Steps
Data in electronic form (for 
example, on diskette or by 
e-mail) 

1. Click the "Load" button.
2. In the "Open" dialog, select the path and file name of the license 

profile file containing the start code.
3. Click the "Open" button.

The data is entered into the "Enter start code" list.
Data, for example as print‐
out, by fax or phone 

1. Double-click the first row of the "Start code" column in the dialog 
table.

2. Enter the start codes manually in the "Start code" column.

4. Click the "Next" button. 
The "Wizard for Receiving License Keys" dialog opens with a "Select license keys" list.

5. Select the license keys to be transferred to a drive on your own computer.
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6. In the "Which drive do you want to install the license keys to?" drop-down list, select the 
drive on your computer.

7. Click the "Next" button.
The "Wizard for Receiving License Key(s)" dialog opens with a "Display request code" list.

8. Click the "Save" button. Select the path and the license profile file in which the request 
codes will be saved and click "Save".

9. Click the "Next" button. 
The "Wizard for Receiving License Keys" dialog opens with the "Enter activation codes" 
list.

10.Transfer the request codes to the source computer. For example:

– The license profile file by e-mail 

– The request codes by phone 

– A printout by fax

11.If you want to close the dialog and enter the activation codes later, click "Cancel".

See also
Overview of the offline transfer of license keys (Page 43)

Offline transfer - Generate start code (Page 44)

Offline transfer - Generate activation code (Page 46)

Offline transfer - Activate license keys (Page 48)

3.3.14 Offline transfer - Generate activation code

Generate activation code
You perform this step on the source computer where a license key for the software exists.

Note
Condition for offline transfer

To be able to transfer license keys offline, both the Automation License Manager as well as 
the software using the license key must be installed on both computers (source and target).
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Procedure
Follow these steps:

1. Select the "License Key > Offline Transfer" menu command.
The "License Keys Offline Transfer" dialog opens.

2. Select the "Generate activation code" option and click "Next". 
The "Wizard for Sending License Keys" dialog opens with an "Enter request code" list.

3. Select the following steps depending on the type of data transfer:

Type of data transfer Steps
Data in electronic form (for 
example, on diskette or by 
e-mail) 

1. Click the "Load" button.
2. In the "Open" dialog, select the path and file name of the of the 

license profile file containing the request codes.
3. Click the "Open" button.

The data is entered in the "Enter request code" list.
Data, for example as print‐
out, by fax or phone 

1. Click the "Load" button.
2. In the "Open" dialog, select the path and file name of the of the 

license profile file containing the request code. 
3. Double-click the corresponding row of the "Request code" column 

in the dialog table.
4. Enter the request codes in the "Enter request code" list.

4. Click the "Next" button. 
The "Remove license key(s)" list opens.

5. Click the "Save" button. Select the path and the license profile file in which the activation 
codes will be saved and click "Save".

6. Click the "Next" button.
The "Calculate Activation Codes: Confirm" dialog window opens. 

7. Confirm the dialog with "Yes".
The license keys displayed in the "Remove license key(s)" list in the "Wizard for Sending 
License Key(s)" dialog are removed and the "Display activation codes" dialog opens.

8. Transfer the activation codes to the target computer. For example:

– The license profile file by e-mail 

– The activation codes by phone 

– A printout by fax

9. Click "Finish" to close the dialog.

See also
Overview of the offline transfer of license keys (Page 43)

Offline transfer - Generate start code (Page 44)
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Offline transfer - Generate request code (Page 45)

Offline transfer - Activate license keys (Page 48)

3.3.15 Offline transfer - Activate license keys

Activate license keys
You perform this step on the target computer where the license key for software will be 
transferred.

Note
Condition for offline transfer

To be able to transfer license keys offline, both the Automation License Manager as well as 
the software using the license key must be installed on both computers (source and target).

Procedure
Follow these steps:

1. Select the "License Key > Offline Transfer" menu command.
The "License Keys Offline Transfer" dialog opens.

2. Select the "Activate license key(s)" option and click "Next". 
The "Wizard for Receiving License Keys" dialog opens with the "Enter activation codes" 
list.

3. Select the following steps depending on the type of data transfer:

Type of data transfer Steps
Data in electronic form (for 
example, on diskette or by 
e-mail) 

1. Click the "Load" button.
2. In the "Open" dialog, select the path and file name of the of the 

license profile file containing the activation codes.
3. Click the "Open" button.

The data is entered in the "Enter activation codes" list.
Data, for example as print‐
out, by fax or phone 

1. Click the "Load" button.
2. In the "Open" dialog, select the path and file name of the of the 

license profile file containing the activation codes. 
3. Double-click in the corresponding row of the "Activation code" 

column in the dialog table.
4. Enter the activation codes in the "Enter activation codes" list.
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4. Click the "Next" button.

5. Click "Finish" to close the dialog.
Result: The activated license key is displayed in the "Result" list of the "Wizard for Receiving 
License Keys" dialog. The license key is transferred from the source computer to the target 
computer. 

Note
Error during transfer

If errors occur during transfer, the "Wizard for Receiving License Keys" dialog opens with an 
"Incorrect activation codes" list. 

In this case, contact "Support for License Management".

See also
Overview of the offline transfer of license keys (Page 43)

Offline transfer - Generate start code (Page 44)

Offline transfer - Generate request code (Page 45)

Offline transfer - Generate activation code (Page 46)

3.3.16 License profile files for the offline transfer of license keys

License profile files
A license profile file is used to exchange information for the offline transfer of license keys. 

The offline transfer is performed in various steps.

● Generate start code

● Generate request code

● Generate activation code

● Activate license key(s)

Different data is included in the license profile file for each step of the process. 

A license profile file can be transferred in electronic form (for example, on a diskette or by e-
mail).

Data of a License Profile File
The following data is saved in a license profile file for offline transfer:

● Product name - name of the component

● License number - specific number for the license key transfer
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● Start code 

● Request code 

● Activation code 

Note
Validity of a license profile file

License profile files are only valid for one-time transfer of a group of license keys. 

To repeat the transfer, new files are required.

See also
Overview of the offline transfer of license keys (Page 43)

3.4 Web license key download

3.4.1 Basics of Web license key download

Requirements for Web License Key Download
The software download allows you to access ordered license keys.

For access, you need:

● A personalized login that you can use to fetch all license keys assigned to "your company".

● An anonymous login that you can use to fetch an individual license key, and the 
corresponding CoL (Certificate of License). This document contains all data required for 
the anonymous download.

Overview of a Web License Key Download
If your computer is located in a stand-alone network or a network with a low security level, we 
recommend the following procedure:

● Install the Automation License Manager additionally on a computer with Internet access 
that is located outside of the automation system.

● Perform the Web license key download as described. 
See also: Downloading a Web License Key (Page 51).

● Transfer the license keys to a license key diskette and then from the license key diskette 
to the computers of the automation system. 
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NOTICE

Checking a Web license key download

Prior to the download, check that the transfer media are virus-free.

See also
Downloading a Web License Key (Page 51)

Overview of the buttons for a Web license key download (Page 52)

3.4.2 Downloading a Web License Key

Downloading a Web License Key
Please note the requirements for the download described in Basics of Web license key 
download (Page 50).

Follow these steps:

1. Set the "View > Management" view.

2. Click "Web License Key Download" in the navigation panel.
If the computer has Internet access, the Automation Download Manager opens the window 
in the object area.

3. Follow the instructions for downloading a license key in the download window.

Note
Error messages when downloading

If you receive an error message that the software download server is unavailable, check your 
firewall settings and, if necessary, contact your system administrator.

If you receive an error message that the software download server is not ready for operation 
at the moment, try again later.

See also
Basics of Web license key download (Page 50)

Overview of the buttons for a Web license key download (Page 52)
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3.4.3 Overview of the buttons for a Web license key download

Buttons for a Web License Key Download
The following buttons are available for the Web license key download:

Button Meaning
"Cancel" button 
Use the "Cancel" button to stop downloading the current page.
"Start page" button 
The "Start Page" button takes you to the start page of the "Web License Key 
Download".
"Forward" button
Use the "Forward" button to return to the previously displayed page.
Note: The "Forward" button is available for selection only after you have clicked 
the "Back" button.
"Back" button 
Use the "Back" button to return to the previously displayed page.
Note: The "Forward" button displays the page you had visited before clicking the 
"Back" button.

See also
Basics of Web license key download (Page 50)

Downloading a Web License Key (Page 51)

3.5 Using license keys in the network

3.5.1 Browsing for existing license keys in the network

Using Software with Free License Keys in the Network
A free floating license key (on a connected computer) allows the use of a protected software 
product when there is no free license locally. 

Note
Browsing for license keys

To browse for license keys on a connected computer, the connected computer must be entered 
in the Automation License Manager on the local computer.
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Recommendation for Faster Access to Floating License Keys
To be able to access the floating license keys more quickly, you should install all floating license 
keys of the plant on only a few computers.

Note
Displaying the connected computers

In the menu "File > Settings > Favorites" tab you will see the computers that have been 
connected to the local Automation License Manager at some point in the past under “Known 
computers”.

You can influence access to floating license keys as follows:

● Make sure that the computers where the floating license keys are located are entered in 
the "Search list". To do this, select the "Edit > Connect Computer" menu command.

● Move the computers where the floating license keys are located to the top positions in the 
"Search list" in the "Settings" dialog, and delete unnecessary entries.

The following buttons are available to you in the search list:

Button Meaning
"Shift up" button
Click this button to change the order in which the computer selected in the list will 
be searched for a floating license key. Shifts the computer to the next higher 
position (in the view: the top position corresponds to the 1st computer etc.)
"Shift down" button
Click this button to change the order in which the computer selected in the list will 
be searched for a floating license key. Shifts the computer to the next lower po‐
sition (in the view: the top position corresponds to the 1st computer etc.)
"Delete" button
Click this button to delete the computer selected in the list from the search for a 
floating license key.

See also
Connecting computers via a network (Page 54)

Failure of computer connections (Page 55)
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3.5.2 Connecting computers via a network

Connect Computer
The "Edit > Connect Computer" menu command opens the "Connect Computer" dialog. Here, 
you can establish a connection to a computer that is reachable via a network and enable the 
computer for the handling of license keys.

Note
Connect Computer

Only computers that have the Automation License Manager installed can be connected.

Procedure
Follow these steps:

1. In "Computer Name", enter the name of a reachable computer or select one from the drop-
down list. 
The following can be used for the computer name: "ComputerName", or 
"ComputerName.Domain" and "IP address".

2. To search for a computer in the network, click "Browse".

– Double-click on "Entire network".

– Double-click on "Microsoft Windows Network".  

– If the computer is located in a domain, select this domain.

– Select the computer and click "OK" to confirm your selection.

3. Under "Display name", you can enter any display name for the computer (default = 
computer name).

4. Select the "Always display in navigation window" check box if you want the entered 
computer to be available after a restart of the Automation License Manager.

5. Select the "Add to search list" check box if you want the entered computer to be included 
in the list of computers to be searched for license keys. 

6. Click "OK" to confirm.

See also
Browsing for existing license keys in the network (Page 52)

Failure of computer connections (Page 55)
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3.5.3 Browsing for computers in the network

Browsing for computers
In the dialog "Connect Computer" click "Browse" to open the dialog "Search for a Computer".

Follow these steps:

1. Double-click "Entire network".

2. Double-click on "Microsoft Windows Network". 

3. If the computer is located in a domain, select this domain.

4. Select the computer and click "OK" to confirm your selection.

5. Click "OK" to confirm your selection.

3.5.4 Failure of computer connections

Notes on the Failure of Computer Connections
Computers connected over a network connection can use floating license keys. 

The following description shows how a floating license key reacts to the failure of the computer 
connection.

License Key Server
A license key server is a computer on which a floating license key is stored.

License Key Client
A license key client is a computer that uses a floating license key from a server.

Types of Connection Failure
When a floating license key on a license key server is used by a software product on a license 
key client and the connection between the two computers fails, it may be due to the following:

● The software product has crashed

● The network connection has been interrupted.

● The license key client has crashed.

● The license key server has crashed.
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The Software Product has Crashed
The Automation License Manager on the license key client monitors the use of the license 
keys by the software product. If this crashes, the Automation License Manager immediately 
releases the relevant license keys on the license key server.

Network Connection was Interrupted
Following a failure of the network connection to the license key server, the software product 
on the license key client can continue to be used for up to 3 hours.

The floating license keys on the license key server remain "used" for a maximum of 3 hours.

The license key is, however, no longer found when the software product is restarted and 
therefore cannot be reassigned.

The following situations are possible:

● If the interruption lasts less than 3 hours, then:

– The Automation License Manager on the license key server detects both the license 
key client (the computer that used the license keys) and the "used" license keys.

– It allocates the still "used, previous" license keys to the detected license key client.

● If the interruption lasts more than 3 hours, then:

–  The license keys on the license key server are released.

–  License key clients are served the same as when initial contact is made. 

–  After 3 hours, the previously connected license key client automatically attempts to find 
a valid license key. If no license key is available, the application-specific reaction to 
unavailable license keys is started (for example, notification after a defined period).

License Key Client has Crashed
If the interruption last less than 3 hours, the license key client detects that the connection to 
the server is established and automatically requests the "used" license keys once again.

The license key on the license key server is released if the interruption lasts longer than 3 
hours. 

License Key Server has Crashed
If the interruption last less than 3 hours, the license key client detects that the connection to 
the server is established and automatically requests the "used" license keys once again.

If the interruption last more than 3 hours, the license key client automatically attempts to find 
a valid license key. When no license key is available, the application-specific reaction to 
unavailable license keys is started (for example, notification after a defined period).
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See also
Browsing for existing license keys in the network (Page 52)

Connecting computers via a network (Page 54)

3.6 Access protection for the Automation License Manager

3.6.1 Access protection by SIMATIC Logon role management

Role Management with SIMATIC Logon
With the role management of the "SIMATIC Logon" optional package, access by users and 
user groups to functions of the Automation License Manager can be controlled.

The access protection does not control access to the entire application but only to individual 
functions:

● The access protection forces users to log onto the system if they want to use the Automation 
License Manager and its functions.

● The role management is based on the users and user groups of the operating system.

● The assignment of specific tasks to roles (see table) allows simple assignment of rights to 
users and user groups. 

● If SIMATIC Logon is installed and access protection is activated, the applications check 
directly to determine whether the logged-on person has the right to use certain functions. 
To prevent duplicate administration and checking of these persons, the right to use license 
keys is granted to all persons.

Definition of terms for role management
Below, you will find explanations of the most important terminology in SIMATIC Logon Role 
Management:

Term Description
Rights Rights are defined by the SIMATIC Logon Role Management.

● Rights can neither be added or deleted.
Users / user groups The users and user groups are defined in user accounts on the computer. 
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Term Description
Access protection Access protection grants certain users and user groups the right to perform 

certain operations. To simplify management, this is done indirectly by using 
roles.

Roles A role includes the authorization for user groups/users to perform certain ac‐
tions within the Automation License Manager (for example, transfer data).
● Users and user groups can be assigned one or more roles. Users then 

have all the rights of these roles.
● Basic roles are supplied with the SIMATIC Logon role management.
● Custom roles can be added or deleted as required.
● Rights can be assigned to roles or revoked.

See also
Function rights and roles for the Automation License Manager (Page 58)

Calling and activating role management (Page 59)

3.6.2 Function rights and roles for the Automation License Manager

Introduction
The following function rights and roles are assigned for the Automation License Manager:

Function Role
 License issuer Administrator Main user User
Transfer license keys x x x  
Check license keys x x x x
Repair license keys x    
Upgrade / downgrade 
license keys

x x x  

Display license keys x x x x
Read the logbook x x x  
Delete the logbook x x   
Enable / disable ac‐
cess control

x x   

Modify projects x x   
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Note
Right to modify projects

The “Change projects” right means that you can assign roles and function rights for access to 
the Automation License Manager.

See also
Access protection by SIMATIC Logon role management (Page 57)

Calling and activating role management (Page 59)

3.6.3 Calling and activating role management

Requirements
To use role management and activate the access protection, the following requirements must 
be met:

● The users and user groups must be set up in Windows.

● The SIMATIC Logon optional package must be installed.

● The "Logon_Administrator" user group must have been set up (see online help for SIMATIC 
Logon).

● The user currently logged onto the computer must have the right "Activate/deactivate 
access protection" (File > Settings).

Calling and Activating SIMATIC Logon Role Management
Follow these steps:

1. Call up SIMATIC Logon Role Management with the "File > Role Management" menu 
command.
The "SIMATIC Logon Role Management" dialog opens.

2. Assign at least one user the role of "administrator".

3. Save your changes and close the "SIMATIC Logon Role Management" dialog.

Note
"SIMATIC Logon Role Management" dialog

You will find instructions for working in the "SIMATIC Logon Role Management" dialog in 
the online help for SIMATIC Logon in the "SIMATIC Logon Role Management" dialog.

4. Select the "File > Change Logon" menu command to open the "SIMATIC Logon Service" 
dialog, and log on with a user name that has at least the "administrator" role.
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5. Select the "File > Settings" menu command.
The "Settings" dialog opens.

6. Select the "Activate SIMATIC Logon access protection" check box.

Note
"Activate SIMATIC Logon access protection" option 

If the "Activate SIMATIC Logon access protection" check box not selected, all users can 
make changes in the role management.

If the "Activate SIMATIC Logon access protection" option is selected, only users with the 
“Activate/deactivate access protection” right can make changes in the role management.

7. Click "OK" to apply the settings.

See also
Access protection by SIMATIC Logon role management (Page 57)

Function rights and roles for the Automation License Manager (Page 58)
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Icons in the Automation License Manager 4
4.1 Icons in the toolbar

Introduction
With the "View > Toolbar" menu command, you enable or disable the display of the toolbar in 
the Automation License Manager. In the figure below, you can see the toolbar in the Automation 
License Manager with the standard view "License keys".

Note
Display in the toolbar

A button shown as pressed indicates that a specific status is active (here, for example, the 
"Management" view). 

An icon with a dark gray background can have the following meaning:
● The function represented by the icon is not active 
● The function represented by the icon is not available.

The following icons are available in the toolbar:

Icon Menu command Keyboard short‐
cut

Description

File > Export Ctrl + S Exports the information displayed in the object area.

File > Print Ctrl + P Prints the information displayed in the object area.

File > Print Pre‐
view

 Shows a preview of the printout of the current object 
area.

Edit > Cut Ctrl + X Moves the license keys selected in the object area 
to the clipboard.
Note: Use only in conjunction with "Paste".

Edit > Paste Ctrl + V Inserts the license keys stored on the clipboard.
Note: Use only in conjunction with "Cut".

Edit > Delete Del Deletes the objects selected in the object area.

View > Manage‐
ment

 Allows use of all the management tasks for license 
management.
Brings the "Management" view to the foreground.

View > Find  Shows a search screen and the results; this view is 
used to define special queries. 
Brings the "Find" view to the foreground.
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Icon Menu command Keyboard short‐
cut

Description

View > Log  Displays the recorded log.
Brings the "Log" view to the foreground.

View > Define ...  Defines the content and appearance of the "Man‐
agement" view.

View > Update F5 Updates the information displayed in the object area.

Help > Context-
Sensitive Help

F1 Calls up context-sensitive help for the selected ob‐
ject or menu command.

Icons in the Automation License Manager
4.1 Icons in the toolbar
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Menu commands in the Automation License Manager 5
5.1 Overview of the menu commands

Menu commands in the Automation License Manager
The following menu commands are available:

● "File" menu

● "Edit" menu

● "License Key" menu

● "View" menu

● "Help" menu

5.2 "File" menu

5.2.1 Overview of the "File" menu

Commands in the "File" menu 

The "File" menu contains the following commands:

● Export

● Page Setup

● Print Preview

● Print

● Settings

● Change Logon

● Role Management

● Exit
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Note
Calling up help

To obtain help on these menu commands, select the command and press F1.

See also
Export (File menu) (Page 64)

Page Setup (File menu) (Page 64)

Print Preview (File menu) (Page 65)

Print (File menu) (Page 65)

Settings (File menu) (Page 66)

Change Logon (File menu) (Page 66)

Role Management (File menu) (Page 67)

Exit (File menu) (Page 68)

5.2.2 Export (File menu)

Export

With the File > Export menu command, you export the current display in the object area in 
CSV format.

5.2.3 Page Setup (File menu)

Page Setup
The File > Page Setup menu command opens the "Page Setup" dialog where can select the 
following options:

● Set the paper format

● Select the paper source for the selected printer.

● Set the page orientation (portrait, landscape).

● Set the page margins.

● Select the printer with the "Printer" button.
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● Close the dialog with the "Cancel" button.

● Accept the page settings by clicking "OK".

5.2.4 Print Preview (File menu)

Print Preview

The File > Print Preview menu command displays a preview of the printout of the current object 
area so that you can check the expected print results.

5.2.5 Print (File menu)

Print

With the File > Print menu command, you to print out the data in the current view in the object 
area. 

The current view includes all data resulting from the selection in the navigation panel or a 
search. The settings for filter, sorting, grouping and column selection remain in effect. 

You have the following options in the "Print" dialog:

● Select the name of the printer in the "Name" list.

● Make settings for the specific printer using the "Properties" button.

● Save the documentation to a file by activating the "Print to file" option (for example, when 
there is no printer connected to the computer).

● Set the print range (all or selected pages).

● Set the number of copies to be printed.

● Close the dialog with the "Cancel" button.

● Send the data to the printer by clicking the "OK" button.
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5.2.6 Settings (File menu)

Settings
The File > Settings menu command opens the "Settings" dialog where you can make the 
following settings:  

In the "General" tab:

● Activate access protection. SIMATIC Logon must be installed on your computer for this.

● Select both options for blocking external access.

● Specify a language for the Automation License Manager.

In the "Favorites" Tab:

● On the left-hand side below "Known computers“, you can see the computers that were 
connected to the local Automation License Manager at least once in the past.

● On the right-hand side below “Search list”, set the search order for performing the search 
for floating license keys on connected computers.

In the "Connection" tab

● Here, you define the settings for connections to other computers.

In the "Reset" tab

● You can reset your user-defined settings to the defaults or delete them.

5.2.7 Change Logon (File menu)

Change Logon
The File > Change Logon menu command opens the "SIMATIC Logon Service" dialog. This 
menu command is only active if SIMATIC Logon is installed. 

Here, you change the user or the password for accessing the Automation License Manager.

Note
SIMATIC Logon optional package

You will find additional information on working with the SIMATIC Logon optional package in 
the online help for SIMATIC Logon.
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5.2.8 Role Management (File menu)

Role management
With the File > Role Management menu command, you specify which users are authorized for 
the Automation License Manager and in which roles. 

The SIMATIC Logon services are used for the role management of the Automation License 
Manager. This menu command is only active if SIMATIC Logon is installed. 

With the following dialog, roles and function rights can be assigned to the users set up in 
Windows (see note). Roles and rights can be assigned to each function.

You can assign the following roles and function rights for the Automation License Manager:

Function Roles:
 License issu‐

er
Administrator Main user User

Transfer license keys X X X  
Check license keys X X X X
Repair license keys X    
Upgrade / downgrade license keys X X X  
Display license keys X X X X
Read the logbook X X X  
Delete the logbook X X   
Enable / disable access control X X   
Modify projects
(This right means that you can assign 
roles and function rights for access to 
the Automation License Manager.)

X X   

If SIMATIC Logon is installed and access protection is activated, the applications check directly 
to determine whether the logged-on person has the right to use certain functions. 

To prevent duplicate administration and checking of these persons, the right to use license 
keys is granted to all persons.

Note
SIMATIC Logon optional package

You will find additional information on working with the SIMATIC Logon optional package in 
the online help for SIMATIC Logon.
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5.2.9 Exit (File menu)

Exit
With the File > Exit menu command, you close the Automation License Manager.

5.3 "Edit" menu

5.3.1 Overview of the "Edit" menu

Commands in the "Edit" menu 
The "Edit" menu contains the following commands:

● Undo

● Redo

● Connect Computer

● New Folder

● Cut

● Paste

● Rename

● Delete

● Delete Log

● Select All

● Reverse Selection

Note
Calling up help

To obtain help on these menu commands, select the command and press F1.

Note
Additional menu commands

Additional menu commands may be available if you have installed one or more plug-ins for 
the Automation License Manager.
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See also
Undo (Edit menu) (Page 69)

Redo (Edit menu) (Page 69)

Connect Computer (Edit menu) (Page 69)

New Folder (Edit menu) (Page 70)

Cut (Edit menu) (Page 71)

Paste (Edit menu) (Page 71)

Rename (Edit menu) (Page 72)

Delete (Edit menu) (Page 72)

Delete Log (Edit menu) (Page 72)

Select All (Edit menu) (Page 73)

Reverse Selection (Edit menu) (Page 73)

5.3.2 Undo (Edit menu)

Undo
With the Edit > Undo menu command, you undo the last action performed.

5.3.3 Redo (Edit menu)

Redo
With the Edit > Redo menu command, you to restore the status that existed prior to undoing 
an action (Edit > Undo).

5.3.4 Connect Computer (Edit menu)

Connect Computer
With the Edit > Connect Computer menu command, you open the "Connect Computer" dialog. 

Here, you can establish a connection to a computer that is reachable via a network and enable 
the computer for the handling of license keys.
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Note
Requirement

Only computers that have the Automation License Manager installed can be connected.

Further steps:

1. In "Computer Name", enter the name of a reachable computer or select one from the drop-
down list. The following can be used for the computer name: "ComputerName", or 
"ComputerName.Domain" and "IP address".

2. To search for a computer in the network, click "Browse".

– Double-click "Entire network".

– Double-click on "Microsoft Windows Network".

–  If the computer is located in a domain, select this domain.

– Select the computer and click "OK" to confirm your selection.

3. Under "Display name", you can enter any display name for the computer (default = 
computer name).

4. Select the "Always display in navigation window" check box if you want the entered 
computer to be available after a restart of the Automation License Manager.

5. Select the "Add to search list" check box if you want the entered computer to be included 
in the list of computers to be searched for license keys.

6. Click "OK" to confirm.

5.3.5 New Folder (Edit menu)

New Folder
With the Edit > New Folder menu command, you open the "Insert a New Folder" dialog. This 
creates a new folder, e.g., for creating work groups or for managing various license keys, 
depending on which object is selected on the left in the navigation panel.

Conditions for creating new folders:

The new folder can be a general folder or a license key folder, depending on where it is created. 
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Icon Description
Indicates a folder in which computer connections can be stored.
Before creating such a folder, go to the navigation panel and select "My Computer".
Indicates a license key folder, in which license keys can be stored.
Before creating such a folder, go to the navigation panel and select
● Local data medium
● Already existing license key folder

Further steps:

1. Select the "Management" view. 

2. In the drop-down list within the menu bar, select the "License keys" view. 

3. Selected the required object in the navigation panel, as described in the table above.

4. To create a general folder, select "My Desktop".

5. To create a license key folder, select a local data medium or an already existing license 
key folder.

6. Using the shortcut menu or the menu, select the command "Edit > New Folder".

7. Enter a name for the new folder in the "Insert a New Folder" dialog.

8. Click "OK" to confirm. 
Result:  The new folder with the name you assigned is displayed in the navigation panel.

5.3.6 Cut (Edit menu)

Cut

With the Edit > Cut menu command, you remove objects (folders, computers, and license 
keys). 

5.3.7 Paste (Edit menu)

Paste
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With the Edit > Paste menu command, you move objects that are on the clipboard. Objects 
are placed on the clipboard using the Edit > Cut command. 

You can paste the following objects:

● Folder 

● License key folder

● Computer 

● License keys

5.3.8 Rename (Edit menu)

Rename
With the Edit > Rename menu command, you change the names of objects (e.g., folders in 
the navigation panel).

5.3.9 Delete (Edit menu)

Delete

With the Edit > Delete menu command, you delete objects (e.g. delete folders, disconnect 
connected computers). 

License key folders can only be deleted if they are empty, i.e. no longer contain any license 
keys.

5.3.10 Delete Log (Edit menu)

Delete Log
With the Edit > Delete Log menu command (available only if "Log" view is in the foreground), 
you delete the contents of the log file.
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5.3.11 Select All (Edit menu)

Select All
With the Edit > Select All menu command, you select all objects in an area or list.

5.3.12 Reverse Selection (Edit menu)

Reverse Selection
With the Edit > Reverse Selection menu command, you reverse the selection of objects.

This menu command changes the selected objects in an area or list as follows:

● Selects all objects that were not previously selected.

● Deselects all objects previously selected.

5.4 "License Key" menu

5.4.1 Overview of the "License Key" menu

Commands in the "License Key" Menu
The "License Key" menu contains the following commands:

● Transfer

● Synchronize License Requirements

● Offline Transfer

● Check

● Recover

● Recover Wizard

● Upgrade

Note
Calling up help

To obtain help on these menu commands, select the command and press F1.
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Note
Additional menu commands

Additional menu commands may be available if you have installed one or more plug-ins for 
the Automation License Manager.

See also
Transfer (License Key menu) (Page 74)

Synchronize License Requirements (License Key menu) (Page 74)

Offline Transfer (License Key menu) (Page 75)

Check (License Key menu) (Page 75)

Recover (License Key menu) (Page 76)

Recover Wizard (License Key menu) (Page 76)

Upgrade (License Key menu) (Page 76)

5.4.2 Transfer (License Key menu)

Transfer
With the License Key > Transfer menu command, you open the "Transfer License Key" dialog. 
You use this dialog box to transfer license keys to another target drive. 

5.4.3 Synchronize License Requirements (License Key menu)

Synchronize License Requirements
With the License Key > Synchronize License Requirements menu command, you open the 
"Synchronize License Requirements" dialog. You use this dialog to license the software 
products on your own computer. 

Note
Floating license keys

Instead of license keys on your own computer, you can use floating license keys, provided 
they are available on the network.
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5.4.4 Offline Transfer (License Key menu)

Offline Transfer
With the License Key > Offline Transfer menu command, you open the "License Key Offline 
Transfer" dialog that leads you step-by-step through the offline transfer.

An offline transfer of license keys can only be performed between two computers. License 
profile files are transferred between the computers in five steps.

Note
Offline Transfer

Offline transfer means no connection (for example, via a network) is required to transfer the 
license keys.

Steps for offline transfer of license keys

The target computer is the computer requiring a license key for software.

The source computer is the computer where a license key for software is available.

1. On the target computer: 

– Identify software without license key

– Send a request for license keys (phone, fax, e-mail, etc.)

2. On the source computer: Generate start code

3. On the target computer: Generate request code

4. On the source computer: Generate activation code

5. On the target computer: Activate license keys

5.4.5 Check (License Key menu)

Check
With the License Key > Check menu command, you check the selected license keys. The 
result of the check is displayed in the "Check License Keys" dialog with the relevant status 
icon for license keys.
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5.4.6 Recover (License Key menu)

Recover
With the License Key > Recover menu command, you recover license keys that are unavailable 
due to loss or a defect on the hard drive. 

The menu command opens the "Recover License Key" dialog where you can recover the 
license key with the aid of "Support for License Management".

5.4.7 Recover Wizard (License Key menu)

Recover Wizard
With the License Key > Recover Wizard menu command, you open the "Wizard for Restoring 
License Key(s)" dialog. 

You can use the "Recover Wizard" to repair one or more license keys that are no longer 
available due to loss or a defect on the hard drive. Help from A&D Customer Support is required 
to recover the license keys. 

The wizard guides you step by step through the entire process. 

The following dialogs are called:

● Recover Wizard: Select license key

● Recover Wizard: Enter repair codes

● Recover Wizard: Result

5.4.8 Upgrade (License Key menu)

Upgrade
With the License Key > Upgrade menu command, you open the "License Key Upgrade" dialog. 
This dialog shows the license keys for which upgrade possibilities were found. 
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5.5 "View" menu

5.5.1 Overview of the "View" menu

Commands in the "View" menu
The "View" menu contains the following commands:

● Define

● Management

● Find

● Log

● Update

● Toolbar

● Status Bar

Note
Calling up help

To obtain help on these menu commands, select the command and press F1.

See also
Define (View menu) (Page 77)

Management (View menu) (Page 78)

Find (View menu) (Page 79)

Log (View menu) (Page 80)

Update (View menu) (Page 80)

Toolbar (View menu) (Page 80)

Status Bar (View menu) (Page 82)

5.5.2 Define (View menu)

Define
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With the View > Define menu command, you open the dialog for defining views. 

Here, you can:

● Select and activate available views.

● Define new views according to your requirements.

Several predefined standard views for the Management view are installed with the Automation 
License Manager.

5.5.3 Management (View menu)

Management

With the View > Management menu command, you open the "Management" view in the 
Automation License Manager.

This view is preset as the standard view. Information on the available license key data on the 
computer is displayed in this view. 

Select in the navigation panel, display in the object area

When a computer is selected in the navigation panel on the left, information about this computer 
is displayed in the object area on the right (for example, information on the license keys stored 
on this computer or the installed software).

● You will find the following folder structure in the navigation panel on the left:

Folder Description Subfolder
My Computer This is the local computer on which the user is 

working.
Diskette drives and hard disks it 
contains

Note: You can create additional objects (folders, license key folders and computers) in the navigation 
panel.

● Depending on the object selected on the left, in the object area on the right, you will see all 
elements belonging to the object in the form of icons in a table. The table can be printed 
and exported.

Icon Description
Icon for your own computer (My Computer) or a connected computer.

Icon for a diskette drive on your own computer or a connected computer.

Icon for a hard disk on your own computer or a connected computer.
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With the "Define View", dialog you select the information to be displayed here. Select the View 
> Define menu command to open this dialog.

5.5.4 Find (View menu)

Find

With the View > Find menu command, you open the "Find" view in the Automation License 
Manager. 

● You will find the boxes for search options in the navigation panel on the left. The following 
can be entered as search options:

Input box or option Description and possible selection
Search Term General search term 
Product Product-specific query option
Storage location Drive on a computer (all, own computer, connected computers)
Standard license type All, Master, Floating, Single, Upgrade
License type ● All

● Count relevant 
● Countable objects
● Demo
● Unlimited
● PowerPack 
● Rental
● Trial

Status Shows the status of a license key (select license key and then License 
Key > Check)
Examples of possible statuses: 
● License key OK 
● License key corrupt 
● License key in use 
● License key OK - Inactive (e.g., not yet activated with offline transfer)
● Installed software, no license key necessary …

Used by ● All
● Name of the user

● The table containing the search results is shown in the object area on the right. Each row 
is assigned an entry for the search criterion specified in the navigation panel on the left. 
The table can be printed and exported.
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5.5.5 Log (View menu)

Log

With the View > Log menu command, you open the "Log" view in the Automation License 
Manager. The logs contain information on all performed actions affecting the license keys (for 
example, use of license key by software, transfer of license keys, etc.).

You will find the available options in the navigation panel on the left

1. In the object area, select the location (My Computer, connected computer) where you want 
to open a stored log. 

2. Select the number of entries you require or select the time period for which logs will be 
displayed.

3. Select the "Filter" check box if you want to use a filter. Select the filter you require from the 
list.

4. Click the "Update" button.

You will find the table containing the logs in the object area on the right

The table corresponds to the options selected on the left and it can be printed and exported.

5.5.6 Update (View menu)

Update

With the View > Update menu command, update the contents displayed in the selected area 
of the dialog.

5.5.7 Toolbar (View menu)

Toolbar

With the View > Toolbar menu command, you activate or deactivate the view of the toolbar in 
the Automation License Manager.

Functions in the toolbar

In the figure below, the default view "License keys" is active.
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Note
Toolbar

A button shown as pressed indicates that a specific status is active (here, for example, the 
"Management" view). 

An icon with a dark gray background can have the following meaning:
● The function represented by the icon is not active 
● The function represented by the icon is not available.

The following functions are available in the toolbar:

Icon Menu command Keyboard 
shortcut

Description

File > Export Ctrl + S Exports information displayed in the object area.

File > Print Ctrl + P Prints information displayed in the object area.

File > Print Preview  Shows a preview of the printout for the current 
object area.

Edit > Cut Ctrl + X Moves license keys selected in the object area 
to the clipboard.
Note: Use only in conjunction with "Paste".

Edit > Paste Ctrl + V Inserts the license keys stored on the clipboard.
Note: Use only in conjunction with "Cut".

Edit > Delete Del Deletes the objects selected in the object area.

View > Management  Enables execution of all tasks for license man‐
agement.
Brings the "Management" view to the fore‐
ground

View > Find  Shows a search screen and the results; this 
view is used to define special queries etc. 
Brings the "Find" view to the foreground.

View > Log  Displays the recorded log.
Brings the "Log" view to the foreground

View > Define ...  Allows you to define the content and layout of 
the "Management" view.

View > Update F5 Updates the information displayed in the object 
area.

Help > Context-Sensitive 
Help

F1 Calls up context-sensitive help for the selected 
object or menu command.
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Functions in the toolbar for "Web License Key Download"

The following toolbar buttons are also available for a Web License Key Download:

Icon Description
Use this icon to call the previously displayed page of the "Web License Key Download".

Use this icon to call the page of the "Web License Key Download" that was displayed before 
the page you displayed with the "Back" button.
Use this icon to cancel the call of a page of the "Web License Key Download".

Use this icon to call the start page of the "Web License Key Download".

5.5.8 Status Bar (View menu)

Status Bar
The View > Status Bar menu command enables and disables the view of the status bar in the 
Automation License Manager. 

Displayed information

The status bar displays the following information in the various areas (from left to right):

Field Area name Description
1 Tooltips Displays tooltips for the selected object (buttons, etc.)
2 License key Displays the number of license keys in the selected window.

Displays a progress bar for an active Web license key download
3 User If SIMATIC Logon is installed, the user currently logged on via SIMATIC 

Logon is displayed.
If SIMATIC Logon is not installed, displays "Unknown".

4 Filter Indicates that a view with filter settings is active.
5 Shift key Displays the status of the Shift key (Shift lock, CAP).
6 Num key Displays the status of the Num key (Num lock, Num).
7 Scroll key Displays the status of the scroll key (Scroll lock, SCRL).
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5.6 "Help" menu

5.6.1 Help on Automation License Manager

Commands in the "Help" menu 
With the Help > Help on Automation License Manager menu command, you open the online 
help for the Automation License Manager.

See also
Context-sensitive help (Page 83)

About (Page 83)

5.6.2 Context-sensitive help

Context-sensitive help
With the Help > Context-Sensitive Help menu command, you activate the question mark cursor. 
If you click an object in the Automation License Manager with the activated question mark 
cursor, the online help for this object will be displayed.

5.6.3 About

About
With the Help > About menu command, you open the display dialog for the currently installed 
version of the Automation License Manager.
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Dialogs for the Automation License Manager 6
6.1 "Define View" dialog

Settings in the "Define View" dialog
With "View > Define" menu command, you open the "Define View" dialog. 

Here, you can select an available view or create and edit a new view.

Available views
The "Available views" list displays all the available views.
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In addition to the standard views mentioned above that exist automatically, views you yourself 
have created are also displayed here.

Note
Editing the views in the Automation License Manager

The automatically available standard views (Search results, License keys, Installed software, 
Missing license keys, and Licensed software) can be copied and changed, but they cannot be 
deleted.

You can delete any views that you have created as well as any copied or new views.

Meaning of the Buttons in "Define View" dialog

"New" button
Click this button if you want to create a new view. 

In the "Name" box, enter a name for the view and edit the view using the "Columns", "Filter", 
"Groups", and "Sort" tabs.

"Copy" Button
In "Available views", select the view you want to copy and then click "Copy". 

In the "Name" box, enter a name for the view and edit the view using the "Columns", "Filter", 
"Groups", and "Sort" tabs.

"Delete" button
In "Available views", select the view you want to delete and then click "Delete". 

Edit view
The view selected in "Available views" is entered in this box.

You can enter a new name for the view after clicking the "New" or "Copy" button. You can 
select the "License keys" or "Software" option depending on whether you want to create the 
new view for license keys or for software. The "Apply" button applies your entries.

"Columns" tab
In this tab, you configure the selection and order of the columns displayed in a view.

"Filter" tab
In this tab, you can configure two filters to limit the information displayed.

"Groups" tab
In this tab, you can define a grouping. 

"Sort" tab
In this tab, you specify the order for sorting.
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See also
"Columns" tab in the "Define View" dialog (Page 87)

"Filter" tab in the "Define View" dialog (Page 89)

"Groups" tab in the "Define View" dialog (Page 91)

"Sort" tab in the "Define View" dialog (Page 93)

6.2 "Columns" tab in the "Define View" dialog

Settings in the "Columns" tab
The "Columns" tab is part of the "Define View" dialog. 

In this tab, you configure the columns to be displayed and the order of the columns for a view 
that you have created or that you have copied and want to change.
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Available columns
The columns shown in the "Available columns" list can be added to the "New view". 

Selected columns
The columns shown in the "Selected columns" list will be displayed in the "New view".

The order (from top to bottom) corresponds to the displayed order of the columns (from left to 
right).

Use the buttons described below to add, delete, or move columns.
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Button Icon Description
Move right The columns selected in the "Selected columns" list can be moved by clicking the 

"Move right" icon.
Move left The columns selected in the "Selected columns" list can be moved by clicking the 

"Move left" icon.
Move up By clicking the "Move up" icon, you can move selected columns up in the "Select 

columns" list (display in the view: the top position corresponds to the 1st column 
etc.).

Move down By clicking the "Move down" icon, you can move selected columns down in the 
"Select columns" list (display in the view:  the top position corresponds to the 1st 
column etc.).

See also
"Define View" dialog (Page 85)

"Filter" tab in the "Define View" dialog (Page 89)

"Sort" tab in the "Define View" dialog (Page 93)

"Groups" tab in the "Define View" dialog (Page 91)

6.3 "Filter" tab in the "Define View" dialog

Settings in the "Filter" tab
The "Filter" tab is part of the "Define View" dialog.

 In this tab, you can configure two filters to limit the information displayed.
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Note
Filter settings

The values of a filter are linked by an OR operation.

If the "Use 1st Filter" and "Use 2nd Filter" check boxes are selected, these filters are linked by 
an AND operation.
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Using a Filter
To use a filter, follow these steps:

1. To use the filters, select the "Use filter" check boxes ("Use 1st Filter" and/or "Use 2nd Filter").

2. In the "Column" list, select the column to which the filter will be applied.

3. In the "Must contain:" list:

– If this list contains check boxes, you can make a selection (multiple selection is linked 
by an OR operation).

– If this list does not contain check boxes, you can enter search criteria of your choice (for 
example, the name of a user).

See also
"Define View" dialog (Page 85)

"Columns" tab in the "Define View" dialog (Page 87)

"Groups" tab in the "Define View" dialog (Page 91)

"Sort" tab in the "Define View" dialog (Page 93)

6.4 "Groups" tab in the "Define View" dialog

Settings in the "Groups" tab
The "Groups" tab is part of the "Define View" dialog. 

In this tab, you can define a grouping.
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Creating a group
In the "First group by" and "Then group by" drop-down lists, set the order in which search 
results are automatically grouped. You can choose between the following options:

● First group by:

● Then group by:

Priority between grouping and sorting
The priority between grouping and sorting is decided by the grouped display. 

If grouping and sorting are active, the results are put together in groups and shown sorted 
within the groups.
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See also
"Define View" dialog (Page 85)

"Columns" tab in the "Define View" dialog (Page 87)

"Filter" tab in the "Define View" dialog (Page 89)

"Sort" tab in the "Define View" dialog (Page 93)

6.5 "Sort" tab in the "Define View" dialog

Settings in the "Sort" tab
The "Sort" tab is part of the "Define View" dialog. 

In this tab, you can define the sorting.
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Sorting
In the "First/Then sort by" drop-down lists in the "Sort" tab, select the order in which search 
results will be sorted automatically. The sorting performed line by line:

● First sort by

● Then sort by

Priority between grouping and sorting
The priority between grouping and sorting is decided by the grouped display. 

If grouping and sorting are active, the results are put together in groups and shown sorted 
within the groups.

See also
"Define View" dialog (Page 85)

"Columns" tab in the "Define View" dialog (Page 87)

"Filter" tab in the "Define View" dialog (Page 89)

"Groups" tab in the "Define View" dialog (Page 91)

6.6 "Insert a New Folder" dialog

Settings in the "Insert a New Folder" Dialog
With the "Edit > New Folder" menu command, you open the "Insert a New Folder" dialog. 

Depending on where it is inserted, the new folder can be a general folder or a license key folder 
for managing license keys. License key folders are indicated by a special icon.

Follow these steps:

1. Enter a name for the new folder.

2. Click "OK". The new folder is inserted.

6.7 "Search in a Folder or Computer" dialog

Settings in the "Search in a Folder or Computer" dialog
In this dialog, you can select the folder or computer you want to search in.

Confirm the dialog with "OK".
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6.8 "About" dialog

Settings in the "About" dialog
The "Help > About" menu command opens the "About" dialog containing the version of the 
Automatic License Manager that is currently installed. You can obtain additional information 
by clicking "Details". 

You can also print this information.

6.9 "License Keys Offline Transfer" dialog

Settings in the "License Keys Offline Transfer" dialog
The "License Key > Offline Transfer" menu command opens the "License Keys Offline 
Transfer" dialog.

Select the offline transfer step you want to perform and then click "Next". You can make the 
following selections:

● Generate start code

● Generate request code

● Generate activation code

● Activate license key(s)

The wizard for the offline transfer guides you step by step through the transfer.

See also
Offline transfer - Generate start code (Page 44)

Offline transfer - Generate request code (Page 45)

Offline transfer - Generate activation code (Page 46)

Offline transfer - Activate license keys (Page 48)
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6.10 "Synchronize License Requirements" dialog

Settings in the "Synchronize License Requirements" Dialog
The "License Key > Synchronize License Requirements" menu command opens this dialog 
box. 

The dialog can only be opened if you have selected either the "Installed software", "Missing 
license keys", or "Licensed software" view. 

You use this dialog box to license software products on your own computer for which license 
keys are not yet available.

Which drive do you want to install the license keys to?
Select the drive from the drop-down list.
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From where do you want to transfer license keys?
Select the option you require. You can use the "Network" button to navigate to any computer 
in the network.

Which software products are to be licensed?
In this box, you see which software products on your computer lack valid license keys. Already 
licensed software is listed but cannot be selected. Click the "+" to see which license keys are 
available for the relevant software.

Here, you select the displayed software products to be licensed and then click "Synchronize". 
The "Synchronize" button does not become active until you have selected a software product 
to be licensed.

If the selected software package could not be licensed because, for example, the specified 
source computer does not contain a valid license key, you will receive a message and the 
dialog will appear again.

See also
Determining and synchronizing license requirements (Page 42)

6.11 "Transfer License Key" dialog

Settings in the "Transfer License Key" Dialog
With the "License Key > Transfer" menu command, you open the "Transfer License Key" 
dialog. 

This dialog can be used to transfer license keys from a computer to another storage location.

See also
Transferring license keys (Page 35)

6.12 "Settings" dialog

Possible Settings in the "Settings" Dialog
The "File > Settings" menu command opens the "Settings" dialog where you can make the 
following settings. 
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In the "General" tab:
● Activate/deactivate access protection for the Automation License Manager. (see note)

● Activate/deactivate the options for blocking external access. The check boxes are only 
active when SIMATIC Logon is installed and the "Activate SIMATIC Logon access 
protection" check box has been selected.

● Specify a language for the Automation License Manager.

Note
Setting the language in the Automation License Manager

In this case, certain requirements must be met. 

See "Role Management with SIMATIC Logon" for the requirements.

In the "Favorites" Tab:
● On the left-hand side under "Known computers", you can see the computers that were 

already connected to the local Automation License Manager at some time in the past.

● On the right-hand side under "Search list", you set the order for searching for floating license 
keys on connected computers.

In the "Connection" tab
● Here, you define the settings for connections to other computers.

In the "Reset" tab
● You can reset your user-defined settings to the defaults or delete them.

In the "License keys" tab
● Specify whether your computer will be searched for existing but as yet unused license keys 

when the program starts. Specify whether the transfer mode will be activated on your 
computer for the check out of license keys.

See also
"General" tab in the "Settings" dialog (Page 99)

"Favorites" tab in the "Settings" dialog (Page 99)

"Connection" tab in the "Settings" dialog (Page 100)

"Reset" tab in the "Settings" dialog (Page 101)

"License keys" tab in the "Settings" dialog (Page 102)

Access protection by SIMATIC Logon role management (Page 57)

Calling and activating role management (Page 59)
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6.13 "General" tab in the "Settings" dialog

Settings in the "General" Tab
The "File > Settings" menu command opens the "Settings" dialog where you can make the 
following settings in the "General" tab:

Access to remote computer Description
Activate SIMATIC Logon access pro‐
tection

If you want to activate the access protection, certain requirements need to be met. 
See "Role Management with SIMATIC Logon" for the requirements. 

Forbid remote use of license keys*  Select this check box If you want to prevent a connected computer from using a 
license key. 

Forbid license keys transfer from local 
computer*

Select this check box if you want to prevent license keys from being removed from 
the local computer.

Forbid license keys transfer to local 
computer*

Select this check box if you want to prevent license keys from being added to the 
local computer.

Language Select one of the available languages in the drop-down list.

Note
When SIMATIC Logon is installed

The check boxes marked with "*" are disabled when SIMATIC Logon is installed and the 
"Activate SIMATIC Logon access protection" check box has been selected.

See also
"Settings" dialog (Page 97)

"Favorites" tab in the "Settings" dialog (Page 99)

"Connection" tab in the "Settings" dialog (Page 100)

"Reset" tab in the "Settings" dialog (Page 101)

"License keys" tab in the "Settings" dialog (Page 102)

Access protection by SIMATIC Logon role management (Page 57)

Calling and activating role management (Page 59)

6.14 "Favorites" tab in the "Settings" dialog

Settings in the "Favorites" tab
The "File > Settings" menu command opens the "Settings" dialog where you can make the 
following settings in the "Favorites" tab.
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Display Function
Known computers Here, the computers that have been connected to the local Automation License Manager 

at some point in the past are displayed.
Search list A search for available floating license keys will be performed on the computers listed here.
"Add" button Use this button to move computers shown in the left pane to the right pane in order to include 

them in the search for available floating license keys.

"Remove" button Use this button to move computers shown in the right pane to the left pane if you do not 
want to include them in the search for available floating license keys.

"Upward" button Use this button to arrange the order of the computers in the right pane. The computer at the 
top of the list will be searched for valid floating license keys first.

"Downward" button Use this button to arrange the order of the computers in the right pane. The computer at the 
bottom of the list will be searched for valid floating license keys last.

"Delete" button Use this button to delete the selected computer.

See also
"Settings" dialog (Page 97)

"General" tab in the "Settings" dialog (Page 99)

"Connection" tab in the "Settings" dialog (Page 100)

"Reset" tab in the "Settings" dialog (Page 101)

"License keys" tab in the "Settings" dialog (Page 102)

6.15 "Connection" tab in the "Settings" dialog

Settings in the "Connection" tab
The "File > Settings" menu command opens the "Settings" dialog where you can make the 
following settings in the "Connection" tab.

Connection settings Description
Port Enter the port required for the connection setting under "New settings" if you want to 

change the default setting (port 4410) displayed under "Current". 
Allow remote connections Select the check box under "New settings" if you want to change the default setting 

displayed under "Current". 
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Connection settings Description
Compatibility mode with clients < V4.0 Select this check box to allow connection of computers with "older versions" (earlier 

than V4.0) of the Automation License Manager. 
Immediate restart of service This check box is only displayed in this dialog, if you have changed the displayed 

options under "New settings". 
Select this check box if you want your changes to take effect immediately.
If the check box is not selected, the changes you make will only take effect after you 
restart the Automation License Manager service or after you restart the computer.

Note
Settings in the Windows firewall

A computer connection is only possible if either the port you defined or the Automation License 
Manager Service is entered as an exception in your Windows firewall in the "Exceptions" tab. 

To make these settings, you require administrator privileges.

See also
"Settings" dialog (Page 97)

"General" tab in the "Settings" dialog (Page 99)

"Favorites" tab in the "Settings" dialog (Page 99)

"Reset" tab in the "Settings" dialog (Page 101)

"License keys" tab in the "Settings" dialog (Page 102)

6.16 "Reset" tab in the "Settings" dialog

Settings in the "Reset" tab
The "File > Settings" menu command opens the "Settings" dialog where you can make the 
following settings in the "Reset" tab:

User-defined settings Description
Set columns to standard width If you select this check box, all columns are reset to the default width and any 

changes you have made will be undone.
Reset dialogs to standard size If you select this check box, all dialogs are reset to the default size.
Reset sorting to standard views If you select this check box, all sorting settings are reset to the default views 

and any changes you have made will be undone.
Delete all self-defined views If you select this check box, all self-defined views are deleted. The standard 

views are retained.
Delete all permanently connected computers If you select this check box, all permanently connected computers are deleted.
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User-defined settings Description
Delete the list of "known computers" under 
"Settings > Favorites" 

If you select this check box, all the computers from the list of "Known com‐
puters" are deleted in the "Favorites" tab (menu command Settings > Favor‐
ites). 

Reset / delete all If you select this check box, all the user-defined settings listed in this tab are 
reset or deleted.

See also
"Settings" dialog (Page 97)

"General" tab in the "Settings" dialog (Page 99)

"Favorites" tab in the "Settings" dialog (Page 99)

"Connection" tab in the "Settings" dialog (Page 100)

"License keys" tab in the "Settings" dialog (Page 102)

6.17 "License keys" tab in the "Settings" dialog

Settings In the "License keys" Tab
The "File > Settings" menu command opens the "Settings" dialog where you can make the 
following settings in the "License keys" tab:

User-defined settings Description
Check on program start If you select this check box, your computer automatically checks for existing but 

as yet unused upgrade license keys when the program starts.
If such upgrade license keys are found, you will receive a message that you can 
now use them.

Check out If you enable this check box, the transfer mode for the check out of license keys 
is possible.

See also
"Settings" dialog (Page 97)

"General" tab in the "Settings" dialog (Page 99)

"Favorites" tab in the "Settings" dialog (Page 99)

"Connection" tab in the "Settings" dialog (Page 100)

"Reset" tab in the "Settings" dialog (Page 101)
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6.18 "Recover License Key" Dialog

Settings in the "Recover License Key" Dialog
The "License Key > Recover" menu command opens the dialog for recovering license keys.

Follow these steps:

1. Select the license key to be recovered and select the "License Key > Recover" menu 
command.

2. Connect to "Support for License Management" and transfer the data displayed in the dialog:

– The product

– The license key

– The license number

– The request code

3. Enter the supplied activation code and click "OK".

Result: The corrupt license key is restored and is now available.

Note
Repairing license keys

You can only authorizations on diskettes and license keys on hard disks.

See also
Transferring license keys (Page 35)

6.19 "Connect Computer" dialog

Settings in the "Connect Computer" dialog
The "Edit > Connect Computer" menu command opens the "Connect Computer" dialog. Here, 
you can establish a connection to a computer that can be accessed via a network.

Dialogs for the Automation License Manager
6.19 "Connect Computer" dialog

Automation License Manager
Programming and Operating Manual, 09/2014, A5E32921785-AC 103



Procedure
1. Under "Computer Name", enter the name of a reachable computer and the port you want 

to connect to or select a computer from the drop-down list box. 
The following can be used for the computer name, for example "ComputerName", or 
"ComputerName.Domain" and "IP address".
Port 4410 is defined as the default port. If you want to use this port, this port must be entered 
in your Windows firewall in the "Exceptions" tab. Instead of a special port number, you can 
also enter the Automation License Manager service as an "Exception" in your Windows 
firewall. To make these settings, you require administrator privileges.

2. To search for a computer in the network, click "Browse".

– Double-click "Entire network".

– Double-click on "Microsoft Windows Network". 

– If the computer is located in a domain, select this domain.

– Select the computer and click "OK" to confirm your selection.

3. Under "Display name", you can enter any display name for the computer (default = 
computer name).

4. Select the "Always display in navigation window" check box if you want the entered 
computer to be available after a restart of the Automation License Manager.

5. Select the "Add to search list" check box if you want the entered computer to be included 
in the list of computers to be searched for license keys. 
Computers included in the search list are indicated by a blue star in the navigation pane of 
the user interface.

6. Click "OK" to confirm

6.20 "Transfer Fixed Site License Key" dialog

Settings in the "Transfer Fixed Site License Key" Dialog
This dialog is displayed only if you require an activation code for transferring "fixed site license 
keys".

Procedure
If you require an activation code, follow these steps:

1. Connect to Support for License Management and transfer the data displayed in the dialog:

– The product name

– The license key number

– The license number

– The request code

2. Enter the supplied activation code and click "OK".
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Result: The fixed site license key is transferred and is available to you.

6.21 Dialogs in the Recover Wizard

6.21.1 Recover Wizard Select license key

Select license key
You can use the "Recover Wizard" to repair one or more license keys. Help from A&D Customer 
Support is required to recover the license keys.

"Support for License Management" can help you to recover license keys that are no longer 
available due to loss or defects on the hard disk.

"Wizard for Recovering License Keys – Select license keys" 

● Select license keys

● Select installation drive

Follow these steps:

1. Select the License Key > Recover Wizard menu command.
The "Wizard for Recovering License Key(s) - Select license keys" dialog opens.

2. Here, you select the license keys to be recovered. If there are license keys that need repair, 
they are displayed with the corresponding license numbers.

3. Select the installation drive on which the license keys will be recovered. 

4. Click the "Next" button.
The "Wizard for Recovering License Key(s) - Enter repair Codes" dialog opens.

See also
Recover Wizard Enter repair codes (Page 105)

Recover Wizard Result (Page 106)

6.21.2 Recover Wizard Enter repair codes

Enter repair codes
You can use the "Recover Wizard" to repair one or more license keys. Help from A&D Customer 
Support is required to recover the license keys.
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"Support for License Management" can help you to recover license keys that are no longer 
available due to loss or defects on the hard disk.

"Wizard for Recovering License Key(s) – Enter repair codes" dialog  

● Call Support for License Management

● Transfer request code

● Enter repair codes (activation code)

Follow these steps:

1. Contact "Support for License Management" (see above) and provide the displayed data for 
each license key to be repaired as follows:

– The product

– The license number

– The request code

2. Customer Support will then notify you of the corresponding repair codes (activation codes).

3. Enter the relevant activation code and click on the "Next" button.
The "Wizard for Restoring License Keys - Result" dialog opens.

See also
Recover Wizard Select license key (Page 105)

Recover Wizard Result (Page 106)

6.21.3 Recover Wizard Result

Result
You can use the "Recover Wizard" to repair one or more license keys. Help from A&D Customer 
Support is required to recover the license keys.

"Support for License Management" can help you to recover license keys that are no longer 
available due to loss or defects on the hard disk.

"Wizard for Recovering License Key(s) – Result" dialog 

● Display of recovered license keys

● Display of a status message

Follow these steps:

1. This dialog box displays the recovered license keys. Check the additional status information 
in the "Status" column.

2. To close the dialog, click the "Finish" button. This finishes the recovery operation and closes 
the wizard.
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See also
Recover Wizard Select license key (Page 105)

Recover Wizard Enter repair codes (Page 105)

6.22 Dialogs for offline transfer

6.22.1 "License Keys Offline Transfer" dialog

Settings in the "License Keys Offline Transfer" dialog
The "License Key > Offline Transfer" menu command opens the "License Keys Offline 
Transfer" dialog.

Select the offline transfer step you want to perform and then click "Next". You can make the 
following selections:

● Generate start code

● Generate request code

● Generate activation code

● Activate license key(s)

The wizard for the offline transfer guides you step by step through the transfer.

See also
Transferring offline Generate start code (Page 107)

Transferring offline Generate request code (Page 108)

Offline transfer: Generate activation code (Page 110)

Offline transfer: Activate license keys (Page 112)

6.22.2 Transferring offline Generate start code

Transferring offline Generate start code
You perform this step on the source computer where a license key for the software exists.
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"Wizard for Sending License Key(s)" dialog 

● Select license key

● Generate start code

Follow these steps:

1. Select the drive where the required license key is located in the navigation panel. 

2. Select the "License Key > Offline Transfer" menu command.
The "License Keys Offline Transfer" dialog opens.

3. Select the "Generate start code" option and click "Next".
The "Wizard for Sending License Key(s)" dialog opens. 
The list contains the start codes of all available license keys.

4. Select the license keys you want to transfer in the table.

5. Click the "Save" button. Select the path and the license profile file in which the start codes 
will be saved and click "Save".

6. Click the "Next" button.

7. Transfer the start codes to the target computer. For example:

– The license profile file by e-mail 

– The start codes by phone 

– A printout by fax

8. If you want to close the dialog and enter the request codes later, click "Cancel".

See also
"License Keys Offline Transfer" dialog (Page 107)

Transferring offline Generate request code (Page 108)

Offline transfer: Generate activation code (Page 110)

Offline transfer: Activate license keys (Page 112)

6.22.3 Transferring offline Generate request code

Transferring offline Generate request code
You perform this step on the target computer to which the license keys for software will be 
transferred.
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"Wizard for Receiving License Key(s)" dialog 

● Enter start codes

● Generate request code

Note
Offline transfer of license keys

To be able to transfer license keys offline, both the Automation License Manager as well as 
the software using the license key must be installed on both computers (source and target).

Follow these steps:

1. Select the "License Key > Offline Transfer" menu command.
The "License Keys Offline Transfer" dialog opens.

2. Select the "Generate request code" option and click "Next". 
The "Wizard for Receiving License Key(s)" dialog opens with an "Enter start code" list.

3. Select the following steps depending on the type of data transfer:

Type of data transfer Steps
Data transfer in electronic 
form (for example, on diskette 
or by e-mail)

1. Click the "Load" button.
2. In the "Open" dialog, select the path and file name of the license 

profile file containing the start code.
3. Click the "Open" button.

The data is entered into the "Enter start code" list.
Data transfer, e.g., in the form 
of a printout, by FAX or phone 
(data must be manually en‐
tered by the operator)

1. Double-click the first row of the "Start code" column in the dialog 
table.

2. Enter the start codes in the "Start code" column.

4. Click the "Next" button. The "Wizard for Receiving License Keys" dialog opens with a "Select 
license keys" list.

5. Select the license keys to be transferred to a drive on your own computer.

6. In the "Which drive do you want to install the license keys to?" drop-down list, select the 
drive on your computer.

7. Click the "Next" button. The "Wizard for Receiving License Key(s)" dialog opens with a 
"Display request code" list.

8. Click the "Save" button. Select the path and the license profile file in which the request 
codes will be saved and click "Save".

9. Click the "Next" button. The "Wizard for Receiving License Keys" dialog opens with the 
"Enter activation codes" list.
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10.Transfer the request codes to the source computer, for example:

– The license profile file by e-mail

– The request codes by phone

– A printout by fax

11.If you want to close the dialog and enter the activation codes later, click "Cancel".

See also
"License Keys Offline Transfer" dialog (Page 107)

Transferring offline Generate start code (Page 107)

Offline transfer: Generate activation code (Page 110)

Offline transfer: Activate license keys (Page 112)

6.22.4 Offline transfer: Generate activation code

Offline transfer: Generate activation code
You perform this step on the source computer where a license key for the software exists.

"Wizard for Sending License Key(s)" dialog

● Enter request code

● Remove license key

● Generate activation code

Follow these steps:

1. Select the "License Key > Offline Transfer" menu command.
The "License Keys Offline Transfer" dialog opens.

2. Select the "Generate activation code" option and click "Next". 
The "Wizard for Sending License Keys" dialog opens with an "Enter request code" list.
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3. Select the following steps depending on the type of data transfer:

Type of data transfer Steps
Data transfer in electronic 
form (for example, on diskette 
or by e-mail)

1. Click the "Load" button.
2. In the "Open" dialog, select the path and file name of the of the 

license profile file containing these request codes.
3. Click the "Open" button.
Result:The data is entered in the "Enter request code" list.

Data transfer, e.g., in the form 
of a printout, by FAX or phone 
(data must be manually en‐
tered by the operator)

1. Click the "Load" button.
2. In the "Open" dialog, select the path and file name of the of the 

license profile file containing these request codes.
3. Double-click the corresponding row of the "Request code" 

column in the dialog table.
4. Enter the request codes in the "Enter request code" list.

4. Click the "Next" button. The "Remove license key(s)" list opens.

5. Click the "Save" button. Select the path and the license profile file in which the activation 
codes will be saved and click "Save".

6. Click the "Next" button.
The "Calculate Activation Codes:  Confirm" dialog window opens. 

7. Confirm the dialog with "Yes".
The license keys displayed in the "Remove license key(s)" list in the "Wizard for Sending 
License Key(s)" dialog are removed and the "Display activation codes" dialog opens.

8. Transfer the activation codes to the target computer. For example:

– The license profile file by e-mail

– The activation codes by phone

– A printout by fax

9. Click "Finish" to close the dialog.

See also
"License Keys Offline Transfer" dialog (Page 107)

Transferring offline Generate start code (Page 107)

Transferring offline Generate request code (Page 108)

Offline transfer: Activate license keys (Page 112)
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6.22.5 Offline transfer: Activate license keys

Offline transfer: Activate license keys
You perform this step on the target computer where the license key for software will be 
transferred.

"Wizard for Receiving License Key(s)" dialog 

● Enter activation code

● Activate license keys

Follow these steps:

1. Select the "License Key > Offline Transfer" menu command.
The "License Keys Offline Transfer" dialog opens.

2. Select the "Activate license key(s)" option and click "Next". The "Wizard for Receiving 
License Key(s)" dialog opens with the "Enter activation codes" list.
Select the following steps depending on the type of data transfer:

Type of data transfer Steps
Data transfer in electronic 
form (for example, on diskette 
or by e-mail)

1. Click the "Load" button.
2. In the "Open" dialog, select the path and file name of the of the 

license profile file containing these activation codes.
3. Click the "Open" button.
Result:The data is entered in the "Enter activation code" list.

Data transfer, e.g., in the form 
of a printout, by FAX or phone 
(data must be manually en‐
tered by the operator)

1. Click the "Load" button.
2. In the "Open" dialog, select the path and file name of the of the 

license profile file containing these activation codes.
3. Double-click in the corresponding row of the "Activation code" 

column in the dialog table.

3. Select the following steps depending on the type of data transfer:

4. Click the "Next" button.

5. Click "Finish" to close the dialog.

Result: The activated license key is displayed in the "Result" list of the "Wizard for Receiving 
License Keys" dialog.

The license key is transferred from the source computer to the target computer. 

Error message
When an error occurs during transfer, the "Wizard for Receiving License Keys" dialog opens 
with an "Incorrect activation codes" list. In this case, contact 
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See also
"License Keys Offline Transfer" dialog (Page 107)

Transferring offline Generate start code (Page 107)

Transferring offline Generate request code (Page 108)

Offline transfer: Generate activation code (Page 110)

6.22.6 Transferring offline Remove license key

Transferring offline Remove license key
Follow these steps:

1. The "Remove license key(s)" list opens.

2. Click the "Save" button. 
Select the path and the license profile file in which the activation codes will be saved and 
click "Save".

3. Click the "Next" button.
The "Calculate Activation Codes: Confirm" dialog window opens.

4. Confirm the dialog with "Yes".
The license keys displayed in the "Remove license key(s)" list in the "Wizard for Sending 
License Key(s)" dialog are removed and the "Display activation codes" dialog opens.

5. Transfer the activation codes to the target computer. 

– For example as follows: 
The license profile file by e-mail 
The activation codes by phone 
A printout by fax

6. Click "Finish" to close the dialog.

6.22.7 Transferring offline Display activation codes

Transferring offline Display activation codes 
Follow these steps:

1. Send the activation codes to the target computer (for example, a license profile file by e-
mail or the activation codes by phone).

2. Click "Finish" to close the dialog.
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6.22.8 Transferring offline Activation code incorrect

Transferring offline Activation code incorrect
This dialog box is displayed if errors occur when the activation code is generated. 

Follow these steps:

● Check the information in the displayed error messages.

● Check the codes entered for the offline transfer.

● If necessary, consult the hotline.

6.22.9 Transferring offline Result activate license keys

Transferring offline Result activate license keys
This dialog displays the "Result" list from the "Wizard for Receiving License Key(s)".

6.22.10 Transferring offline Calculate Activation Codes

Transferring offline Calculate Activation Codes
This dialog prompts you to confirm the request to calculate the activation code.

NOTICE

Confirming calculation of the activation codes

After confirmation, the selected license keys will be deleted from the local computer.

6.22.11 Transferring offline Load data

Transferring offline Load data
This dialog prompts you to load a license profile file.
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NOTICE

Confirming loading of a license profile file

Manually entered codes will be overwritten.
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Glossary

"Define" view
Defines the content and appearance of the "Management" view.

Assignable license key
License key that can only be used on hardware with the specified hardware serial number. 
The licenses associated with the license key are assigned to the hardware.

Assigned license key
This license key is assigned to a system for its use.

Certificate of License (CoL)
Confirmation in writing of the license; documents the owner of the license in a legal sense. 
Contains the license number for unique identification of the license. 

Count relevant license
Use of the software with this license is limited to the number of tags named in the agreement.

Countable Objects License
The use of the software with this license is limited to the number of application-specific objects 
named in the agreement.

Demo license
Use of the software with this license is limited to the conditions for use named in the agreement.

Brief information on the time remaining for the demo license is displayed in the information 
area of the taskbar.

Embedded (runtime) System
Identifies a non-Windows system on which the runtime software is running and typically 
features special hardware.

Engineering software
Identifies software that is used to create, test and commission automation solutions.
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Floating license
Right to use software simultaneously for an unlimited period. The software can be installed 
more than once.

Installed software
Software that is installed on a computer.

License
Right of the license owner to use software according to the rules of the license agreement.

License key
Stored information that technically represents the ownership of one or more licenses.

License number
The license number is the unique identifier of a license.

Master License
Use of the software with this license is unlimited.

PG/PC
PG = programming device

PC = personal computer

Rental license
This license permits the use of the software limited to a period of operating hours or days or 
until a period expires as stipulated by the agreement.

Service pack
Officially available pack that eliminates errors in existing software; this does not require a new 
license.

Single license
The use of the software with this type of license is permitted on one computer for an unlimited 
period. The type of use is governed by the Certificate of License.
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Software option
From the point of view of license management, software that is technically dependent on other 
software or firmware.

Storage location for license keys
The following storage locations are suitable for license keys: Drive (hard disk, diskette drive, 
USB memory stick), computer (My Computer or connected computer) and license key folders 
where a license key is or can be stored.

Trial license
This license limits the use of the software to a specified number of days from the time it is first 
used. The software may only be used for purposes of testing and validation (liability excluded).

Unlimited license
This license allows unlimited use of the software.

Upgrade license
Using an upgrade license, a license of an older version can be converted to a newer version. 
An upgrade may demand specific requirements of the system status. An upgrade may be 
required if you want to expand the configuration limits.

Glossary

Automation License Manager
Programming and Operating Manual, 09/2014, A5E32921785-AC 119



Glossary

Automation License Manager
120 Programming and Operating Manual, 09/2014, A5E32921785-AC



Index

"
"About" dialog, 95
"Connect Computer" dialog, 103
"Define View" dialog, 85

Settings in the "Columns" tab, 87
Settings in the "Filter" tab, 89
Settings in the "Groups" tab, 91
Settings in the "Sort" tab, 93

"Edit" menu, 68
"File" menu, 63
"Help" menu, 83
"Insert a New Folder" dialog, 94
"License Key" menu, 73
"License Keys Offline Transfer" dialog, 95, 107
"Recover License Key" Dialog, 103
"Search in a Folder or Computer" dialog, 94
"Settings" dialog, 97

Settings in the "Connection" tab, 100
Settings in the "Favorites" tab, 99
Settings in the "General" Tab, 99
Settings In the "License keys" Tab, 102
Settings in the "Reset" tab, 101

"Synchronize License Requirements" dialog, 96
"Transfer Fixed Site License Key" dialog, 104
"Transfer License Key" dialog, 97
"View" menu, 77

A
Access protection by SIMATIC Logon role 
management, 57
Access to floating license keys, 53
Actions with License Key Folders, 38
Activate license keys, 48
Automation License Manager

"Help" menu, 83
Checking license keys, 34
Commands in the "Edit" menu, 68
Commands in the "File" menu, 63
Commands in the "License Key" Menu, 73
Commands in the "View" menu, 77
Creating folders, 40
Displaying Installed License Keys, 33
Function rights and role assignment, 58
Icons in the toolbar, (Toolbar), (Toolbar)
Installation requirements, 13

Installing, 13
Installing plug-ins, 15
Introduction, 7
Keyboard shortcuts, 26
License requirements, 42
Menu commands, 63
Navigation panel and object area, 20
Overview of the functions, 8
Overview of the Standard License types, 9
Recovering license keys, 36
Scope of delivery, 10
Support for License Management, 11
Transferring license keys, 35
Uninstalling, 14
Upgrade of licenses, 15
User interface, 19

B
Basics of Web license key download, 50
Browsing for computers in the network, 55
Browsing for existing license keys in the network, 52
Buttons for a Web License Key Download, 52

C
Calculate Activation Codes, 114
Calling and activating role management, 59
Checking license keys, 34
Commands in the "Edit" menu, 68
Commands in the "File" menu, 63
Commands in the "Help" menu, 83
Commands in the "License Key" Menu, 73
Commands in the "View" menu, 77
Components of the Automation License 
Manager, 10
Connect Computer, 54
Connecting computers via a network, 54
Creating folders, 40

D
Data of a License Profile File, 49
Definition of terms for role management, 57
Determining and synchronizing license 
requirements, 42
Display activation codes, 113
Displaying Installed License Keys, 33

Automation License Manager
Programming and Operating Manual, 09/2014, A5E32921785-AC 121



Displaying Installed software, 33
Displaying the Installed license keys, 33
Displaying the installed software, 33
Displaying the Validity of Licenses, 39
Downloading a Web License Key, 51

E
Enter repair codes, 105

F
Failure of computer connections, 55
Feedback if Program Execution is Delayed, 23
Function rights and role assignment in the Automation 
License Manager, 58
Functionality in the Automation License Manager, 8

G
Generate activation code, 46, 110
Generate request code, 45, 108
Generate start code, 44, 107

H
Help on Automation License Manager, 83

I
Icons in the toolbar, 25, 61
Information on the Current Process, 23
Installation requirements, 13
Installing license keys, 32
Installing License Keys, 32
Installing plug-ins, 15
Installing the Automation License Manager, 13
Introduction to the Automation License Manager, 7

L
License profile files, 49
License profile files for the offline transfer of license 
keys, 49
Licenses in the Automation License Manager, 9
Load data, 114

M
Main entry, 38
Management of license keys, 38
Meaning for the Status Icons in the "Log" View, 25
Meaning of the Folder, 25
Meaning of the Status Icons for installed 
Software, 24
Meaning of the Status Icons for License Keys, 24
Menu commands in the Automation License 
Manager, 63

N
Notes on optimizing hard disks, 17
Notes on the Failure of Computer Connections, 55
Notes on use of "older software versions", 17

O
Offline transfer - Activate license keys, 48
Offline transfer - Generate activation code, 46
Offline transfer - Generate request code, 45
Offline transfer - Generate start code, 44
Offline transfer of license keys, 43
Offline transfer: Activate license keys

Activate license keys, 112
Offline transfer: Generate activation code, 110
Opening the "Settings" Dialog, 22
Overview of a Web License Key Download, 50
Overview of the menu commands, 63
Overview of the Possible Keyboard Shortcuts, 26
Overview of the Standard Views, 27
Overview of the Steps for Offline Transfer, 43

R
Recover Wizard Enter repair codes, 105
Recover Wizard Result, 106
Recover Wizard Select license key, 105
Recovering license keys, 36
Recovering license keys with the wizard, 37
Remove license key, 113
Requirements for Web License Key Download, 50
Result activate license keys, 114
Role Management with SIMATIC Logon, 57
Rules for Optimizing Hard Disks, 18

Index

Automation License Manager
122 Programming and Operating Manual, 09/2014, A5E32921785-AC



S
Scope of delivery, 10
Select license key, 105
Settings in the "Columns" tab, 87
Settings in the "Connection" tab, 100
Settings in the "Define View" dialog, 85
Settings in the "Favorites" tab, 99
Settings in the "Filter" tab, 89
Settings in the "General" Tab, 99
Settings in the "Groups" tab, 91
Settings In the "License keys" Tab, 102
Settings in the "Reset" tab, 101
Settings in the "Sort" tab, 93
Settings in the Automation License Manager, 22
SIMATIC Logon role management

Calling and activating, (Requirements)
Software Products Activated with License Keys, 17
Software products that can be activated with "old 
authorizations", 17
Status Icons in the Automation License Manager, 23
Steps for offline transfer, 43
Storing and managing license keys in folders, 38
Storing License Keys in License Key Folders, 38

T
Table columns in the object area, 20
Transferring license keys, 35
Transferring License Keys by Cutting and 
Pasting, 35
Transferring License Keys Using Drag-and-Drop, 35
Transferring License Keys with the "Transfer" 
Command, 35
Transferring offline Activation code incorrect

Activation code incorrect, 114
Transferring offline Calculate Activation Codes, 114
Transferring offline Display activation codes, 113
Transferring offline Generate request code, 108
Transferring offline Generate start code, 107
Transferring offline Load data, 114
Transferring offline Remove license key, 113
Transferring offline Result activate license keys, 114

U
Uninstalling the Automation License Manager, 14
Upgrade of licenses, 15
User Interface of the Automation License 
Manager, 19

Using folders for structured storage, 40
Using Software with Free License Keys in the 
Network, 52

V
Validity of licenses, 39
Views in the Automation License Manager

"Find" view, 30
"Log" and "Check out log" view, 31
"Management" view, 28
Standard views, 27

W
Web license key download

Basics, 50
Meaning of the buttons, 52
Overview, 50

Wizard for recovering license keys, 37
Working in the "Find" View, 30
Working in the "Management" view, 28
Working with the "Log" and "Check out log" 
views, 31
Worldwide help from "Support for License 
Management", 11

Index

Automation License Manager
Programming and Operating Manual, 09/2014, A5E32921785-AC 123



Index

Automation License Manager
124 Programming and Operating Manual, 09/2014, A5E32921785-AC


	Automation License Manager
	Legal information - Warning notice system
	Table of contents
	1 Product overview
	1.1 Introduction to the Automation License Manager
	1.2 Overview of the functions
	1.3 Licenses in the Automation License Manager
	1.4 Scope of delivery
	1.5 Worldwide help from "Support for License Management"

	2 Installation
	2.1 Installation requirements
	2.2 Installing the Automation License Manager
	2.3 Uninstalling the Automation License Manager
	2.4 Installing plug-ins
	2.5 Upgrade of licenses
	2.6 Notes on use of "older software versions"
	2.7 Notes on optimizing hard disks

	3 Working with the Automation License Manager
	3.1 User interface
	3.1.1 User Interface of the Automation License Manager
	3.1.2 Table columns in the object area
	3.1.3 Settings in the Automation License Manager
	3.1.4 Feedback if Program Execution is Delayed
	3.1.5 Status Icons in the Automation License Manager
	3.1.6 Icons in the toolbar
	3.1.7 Keyboard shortcuts

	3.2 Views in the Automation License Manager
	3.2.1 Standard views
	3.2.2 Overview of the "Management", "Find", and "Log" views
	3.2.3 Working in the "Management" view.
	3.2.4 Views drop-down list
	3.2.5 Working in the "Find" View
	3.2.6 Working with the "Log" and "Check out log" views

	3.3 Handling license keys
	3.3.1 Installing License Keys
	3.3.2 Displaying Installed License Keys
	3.3.3 Displaying Installed software
	3.3.4 Checking license keys
	3.3.5 Transferring license keys
	3.3.6 Recovering license keys
	3.3.7 Recovering license keys with the wizard
	3.3.8 Managing keys in folders
	3.3.9 Creating folders
	3.3.10 Determining and synchronizing license requirements
	3.3.11 Overview of the offline transfer of license keys
	3.3.12 Offline transfer - Generate start code
	3.3.13 Offline transfer - Generate request code
	3.3.14 Offline transfer - Generate activation code
	3.3.15 Offline transfer - Activate license keys
	3.3.16 License profile files for the offline transfer of license keys

	3.4 Web license key download
	3.4.1 Basics of Web license key download
	3.4.2 Downloading a Web License Key
	3.4.3 Overview of the buttons for a Web license key download

	3.5 Using license keys in the network
	3.5.1 Browsing for existing license keys in the network
	3.5.2 Connecting computers via a network
	3.5.3 Browsing for computers in the network
	3.5.4 Failure of computer connections

	3.6 Access protection for the Automation License Manager
	3.6.1 Access protection by SIMATIC Logon role management
	3.6.2 Function rights and roles for the Automation License Manager
	3.6.3 Calling and activating role management


	4 Icons in the Automation License Manager
	4.1 Icons in the toolbar

	5 Menu commands in the Automation License Manager
	5.1 Overview of the menu commands
	5.2 "File" menu
	5.2.1 Overview of the "File" menu
	5.2.2 Export (File menu)
	5.2.3 Page Setup (File menu)
	5.2.4 Print Preview (File menu)
	5.2.5 Print (File menu)
	5.2.6 Settings (File menu)
	5.2.7 Change Logon (File menu)
	5.2.8 Role Management (File menu)
	5.2.9 Exit (File menu)

	5.3 "Edit" menu
	5.3.1 Overview of the "Edit" menu
	5.3.2 Undo (Edit menu)
	5.3.3 Redo (Edit menu)
	5.3.4 Connect Computer (Edit menu)
	5.3.5 New Folder (Edit menu)
	5.3.6 Cut (Edit menu)
	5.3.7 Paste (Edit menu)
	5.3.8 Rename (Edit menu)
	5.3.9 Delete (Edit menu)
	5.3.10 Delete Log (Edit menu)
	5.3.11 Select All (Edit menu)
	5.3.12 Reverse Selection (Edit menu)

	5.4 "License Key" menu
	5.4.1 Overview of the "License Key" menu
	5.4.2 Transfer (License Key menu)
	5.4.3 Synchronize License Requirements (License Key menu)
	5.4.4 Offline Transfer (License Key menu)
	5.4.5 Check (License Key menu)
	5.4.6 Recover (License Key menu)
	5.4.7 Recover Wizard (License Key menu)
	5.4.8 Upgrade (License Key menu)

	5.5 "View" menu
	5.5.1 Overview of the "View" menu
	5.5.2 Define (View menu)
	5.5.3 Management (View menu)
	5.5.4 Find (View menu)
	5.5.5 Log (View menu)
	5.5.6 Update (View menu)
	5.5.7 Toolbar (View menu)
	5.5.8 Status Bar (View menu)

	5.6 "Help" menu
	5.6.1 Help on Automation License Manager
	5.6.2 Context-sensitive help
	5.6.3 About


	6 Dialogs for the Automation License Manager
	6.1 "Define View" dialog
	6.2 "Columns" tab in the "Define View" dialog
	6.3 "Filter" tab in the "Define View" dialog
	6.4 "Groups" tab in the "Define View" dialog
	6.5 "Sort" tab in the "Define View" dialog
	6.6 "Insert a New Folder" dialog
	6.7 "Search in a Folder or Computer" dialog
	6.8 "About" dialog
	6.9 "License Keys Offline Transfer" dialog
	6.10 "Synchronize License Requirements" dialog
	6.11 "Transfer License Key" dialog
	6.12 "Settings" dialog
	6.13 "General" tab in the "Settings" dialog
	6.14 "Favorites" tab in the "Settings" dialog
	6.15 "Connection" tab in the "Settings" dialog
	6.16 "Reset" tab in the "Settings" dialog
	6.17 "License keys" tab in the "Settings" dialog
	6.18 "Recover License Key" Dialog
	6.19 "Connect Computer" dialog
	6.20 "Transfer Fixed Site License Key" dialog
	6.21 Dialogs in the Recover Wizard
	6.21.1 Recover Wizard Select license key
	6.21.2 Recover Wizard Enter repair codes
	6.21.3 Recover Wizard Result

	6.22 Dialogs for offline transfer
	6.22.1 "License Keys Offline Transfer" dialog
	6.22.2 Transferring offline Generate start code
	6.22.3 Transferring offline Generate request code
	6.22.4 Offline transfer: Generate activation code
	6.22.5 Offline transfer: Activate license keys
	6.22.6 Transferring offline Remove license key
	6.22.7 Transferring offline Display activation codes
	6.22.8 Transferring offline Activation code incorrect
	6.22.9 Transferring offline Result activate license keys
	6.22.10 Transferring offline Calculate Activation Codes
	6.22.11 Transferring offline Load data


	Glossary
	Index

