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This entry is from the Siemens Industry Online Support. The general terms of use
(http://www.siemens.com/terms_of_use) apply.

Security
Informati
on

Siemens provides products and solutions with industrial security functions that
support the secure operation of plants, solutions, machines, equipment and/or
networks. They are important components in a holistic industrial security
concept. With this in mind, Siemens’ products and solutions undergo continuous
development. Siemens recommends strongly that you regularly check for
product updates.

For the secure operation of Siemens products and solutions, it is necessary to
take suitable preventive action (cell protection concept, for example) and
integrate each component into a holistic, state-of-the-art industrial security
concept.  Third-party products that may be in use should also be considered.
For more information about industrial security, visit
http://www.siemens.com/industrialsecurity.

To stay informed about product updates as they occur, sign up for a product-
specific newsletter. For more information, visit
http://support.industry.siemens.com.
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1 Introduction
This document describes how to configure HART modules for connecting HART
devices in the TIA Portal and parameterize the HART devices with SIMATIC PDM.

Requirements
1. SIMATIC Field PG as Engineering Station with:

– TIA Portal: In this example we use STEP 7 V13 SP 1 Udp4 (TIA Portal).
– SIMATIC PDM: In this example we use SIMATIC PDM V8.2 SP1 in

"Standalone" mode without STEP 7.
2. PROFINET IO controller:

CPU 1516-3 PN/DP (article number: 6ES7516-3AN01-0AB0), for example.
3. PROFINET IO device, ET 200SP, for example, consisting of:

a. IM 155-6 PN HF (article number: 6ES7155-6AU00-0CN0)
b. AI 4xI 2-wire 4..20mA HART (article number: 6ES7134-6TD00-0CA1)

4. HART device: SITRANS TH300 (article number: 7NG3212-0NN00)
The following figure illustrates the hardware configuration.
Figure 1-1
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The IP address of the network card of the SIMATIC Field PG is in the same IP
subnet as the IP address of the PROFINET IO controller and the PROFINET IO
device. Set the following access point under "Set PG/PC Interface":
S7ONLINE (STEP 7) > Network card.TCPIP

Note Using a data record gateway, an Engineering Station with SIMATIC PDM can
reach field devices several subnets away. The entry below provides information
about which modules support the "Data Record Routing" function and which
therefore can be used as a data record gateway.

https://support.industry.siemens.com/cs/ww/en/view/7000978

https://support.industry.siemens.com/cs/ww/en/view/7000978
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2 Configuring the HART Module in the
TIA Portal
This chapter shows how to configure the HART module in the TIA Portal.
Table 2-1

No. Description

1. Open the TIA Portal and create a new project.
2. Add a new S7 CPU, for example CPU 1516-3 PN/DP.
3. As PROFINET IO device you configure the ET 200SP consisting of the modules

below:
 Interface module: IM 155-6 HF
 Analog input module: AI 4xI 2-wire 4..20mA HART

4. In the Device View of the ET 200SP you mark the HART module AI 4xI 2-wire
4..20mA HART. The properties of the HART module are displayed in the
inspector window.
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No. Description

5. In the "General" tab you navigate to "AI 4 > Inputs > Channel 0". For channel 0,
to which the HART device SITRANS TH300 is connected, you enable
diagnostics, set the parameters for measuring and enable the HART function.

6. Go to the "General" tab and navigate to "AI 4 > HART variables settings". Select
the relevant primary, secondary, tertiary and quaternary variables of the HART
device.
Up to 4 HART variables can be shown on the process image.
Detailed information about the HART variables is available in the manual of the
module AI 4xI 2-wire 4..20mA HART, in the section entitled HART variables.

https://support.industry.siemens.com/cs/ww/en/view/105037964/72241118091
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No. Description

7. Go to the "General" tab and navigate to "AI 4 > I/O addresses". Here you can
change the start address of the input addresses of the module "AI 4xI 4..20mA
HART" if it is outside the process image of the CPU, for example.

8. In the project tree you mark the device folder of the S7-CPU.
In the toolbar you click the "Download to device" button to download the
configuration and user program into the S7-CPU.
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3 Configuring and Parameterizing the HART
Device with SIMATIC PDM
This chapter shows:
 The configuration of the HART device (SITRANS TH300) in the SIMATIC

Manager.
 The parameterization of the HART device in SIMATIC PDM.

3.1 Configuration of the HART Device in the SIMATIC
Manager

Proceed as follows to configure the HART device in the SIMATIC Manager.
Table 3-1

No. Description

1. Open the SIMATIC Manager. This is supplied with SIMATIC PDM and is installed
when you install SIMATIC PDM.

2. Create a new project in the SIMATIC Manager.
3. In the SIMATIC Manager you open the Process Device Network View via the

menu "View > Process Device Network View".



3 Configuring and Parameterizing the HART Device with SIMATIC PDM

Configuring and Parameterizing HART modules
Entry ID: 109478959,    V1.0,    11/2015 8

Si
em

en
s

AG
20

15
Al

lr
ig

ht
s

re
se

rv
ed

No. Description

4. In the Process Device Network View you right-click the project name. Via the
pop-menu "Insert New Object > Networks" you insert the object "Networks".

5. Right-click the "Networks" object. Via the pop-menu "Insert New Object >
Communication Networks" you open the dialog "Insert Object – networks".

6. Click the "Assign Device Type" button. The "Insert Object – Assign Device Type"
dialog opens.
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No. Description

7. Under "Networks > PROFINET > PROFINET networks" you select the
PROFINET network. Click "OK" to close the dialog.

8. The object name "PROFINET network" is displayed in the "Insert Object –
networks" dialog. Click "OK" to close the dialog.
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No. Description

9. Right-click the "PROFINET network" object. Via the pop-menu "Insert New
Object > Object" you open the dialog "Insert Object – PROFINET network".

10. Click the "Assign Device Type" button. The "Insert Object – Assign Device Type"
dialog opens.
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No. Description

11. Under "Devices > PROFINET > Remote IO > Siemens AG > ET 200SP" you
select the relevant interface module. In this example we use an IM 155-6 High-
Feature V2.2 or higher. Click "OK" to close the dialog.

12. The object name "IM 155-6 High-Feature V2.2 or higher" is displayed in the
dialog "Insert Object – PROFINET network". Enter the IP address 192.168.0.4 of
the IM 155-6 PN HF. Click "OK" to close the dialog.
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No. Description

13. Right-click the object "IM 155-6 High-Feature V2.2 or higher". Via the pop-menu
"Insert New Object > Object" you open the dialog "Insert Object – IM 155-6 High-
Feature V2.2 or higher".

14. Click the "Assign Device Type" button. The "Insert Object – Assign Device Type"
dialog opens.
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No. Description

15. Under "Devices > PROFINET > Remote IO > Siemens AG > ET 200SP >
Module" you select the HART module. In this example we use an AI4 x 2-wire
HART. Click "OK" to close the dialog.

16. The object name "AI4 x 2-wire HART" is displayed in the dialog "Insert Object –
IM 155-6 High-Feature V2.2 or higher". The slot must match the slot of the
module in the TIA Portal. Click "OK" to close the dialog.
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No. Description

17. Right-click the object "Channel 0" of the HART module AI4 2-wire HART. Via the
pop-menu "Insert New Object > Object" you open the dialog "Insert Object –
Channel 0".

18. Click the "Assign Device Type" button. The "Insert Object – Assign Device Type"
dialog opens.
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No. Description

19. Select the HART device. In this example we us a SITRANS TH300. This HART
device is located under "Sensors > Temperature > Siemens AG". Click "OK" to
close the dialog.

Requirements
 The library entitled "PDM_Device_Library" must be installed.
 The device description of the HART device must be integrated in the "Device

Integration Manager" tool.
20. The object name "SITRANS" is displayed in the "Insert Object – Channel 0"

dialog. Click "OK" to close the dialog.
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No. Description

21. Right-click the "SITRANS" object. In the pop-up menu you select "Open object".
SIMATIC PDM opens.
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3.2 Parameterization of the HART Device in SIMATIC PDM

Proceed as follows to parameterize the HART device in SIMATIC PDM.
Table 3-2

No. Description

1. In SIMATIC PDM you set the parameters for the HART device SITRANS TH300.
Under "SITRANS > SITRANS TH300 > Setup > Sensor" you can set the type
and sensor connection, for example.
In this example we use the type Pt100 DIN IEC 751 and a two-wire sensor
connection.

2. Under "SITRANS > SITRANS TH300 > Setup > Mapping of Variables" you see
which values are assigned to the primary, secondary, tertiary and quaternary
variables. You can read these out later via the monitoring table in the TIA Portal
or you access the HART variables from the user program via the process image.
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No. Description

3. Under "SITRANS > SITRANS TH300 > Characteristics > Mechanical
Construction" you enter the installation date.
Then click the "Load to Devices" button. The "Load to Devices" dialog opens.

4. Click "Start". The parameterization is downloaded to the HART device -
SITRANS TH300, for example.
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No. Description

5. At the end of download the status "Load to device: Action finished." is displayed.
The HART device "SITRANS" is displayed green.
Click the "Close" button to end the dialog.
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No. Description

6. You can use SIMATIC PDM to access the HART device online. Select the menu
"View > Process Variables". The "SITRANS – Process Variables – (Online)"
dialog opens.

7. Here you get a display of the measured value, trend view, operating hours and
the min/max pointer of the SITRANS TH300 temperature sensor.
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No. Description

8. In the TIA Portal you can have the values of the HART variables displayed in the
monitoring table. You access the HART variables via the process image of the
inputs. Each HART variable consists of 4 Value bytes and one Quality Code
byte.
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4 Diagnostics
You can read out the diagnostics of the HART module in the TIA Portal.
In the Project tree you open the device folder of your CPU and then the subfolder
"Distributed I/O". Under "PROFINET I/O System (100): PN/IE_1 > IO Device_1"
you click the HART module "AI 4xI 2-wire 4..20mA HART". In the pop-up menu you
select "Online & diagnostics". The "Online & Diagnostics" dialog opens.
Figure 4-1

In the "Online & Diagnostics" dialog you get a display of the status and the channel
diagnostics of the HART module. In this module a wire break is displayed together
with the triggered HART communication error.
Figure 4-2
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5 Additional Information
More information is available at the following links.
Table 5-1

Entry Link

Manual: Analog Input
Module
AI 4xI 2-wire 4…20mA
HART

https://support.industry.siemens.com/cs/ww/en/view/105037964

Product News: SIMATIC
PDM V8.2

https://support.industry.siemens.com/cs/ww/en/view/92561254

Requirements for
SIMATIC PDM data
record routing

https://support.industry.siemens.com/cs/ww/en/view/7808062

Modules that support
the "Data Record
Routing" function

https://support.industry.siemens.com/cs/ww/en/view/7000978

https://support.industry.siemens.com/cs/ww/en/view/105037964
https://support.industry.siemens.com/cs/ww/en/view/92561254
https://support.industry.siemens.com/cs/ww/en/view/7808062
https://support.industry.siemens.com/cs/ww/en/view/7000978

	Configuring and Parameterizing HART Modules
	1 Introduction
	2 Configuring the HART Module in the TIA Portal
	3 Configuring and Parameterizing the HART Device with SIMATIC PDM
	3.1 Configuration of the HART Device in the SIMATIC Manager
	3.2 Parameterization of the HART Device in SIMATIC PDM

	4 Diagnostics
	5 Additional Information

