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Warranty and Liability 
 

Note The Application Examples are not binding and do not claim to be complete regarding the 
circuits shown, equipping and any eventuality. The Application Examples do not represent 
customer-specific solutions. They are only intended to provide support for typical 
applications. You are responsible for ensuring that the described products are used 
correctly. These Application Examples do not relieve you of the responsibility to use safe 
practices in application, installation, operation and maintenance. When using these 
Application Examples, you recognize that we cannot be made liable for any 
damage/claims beyond the liability clause described. We reserve the right to make 
changes to these Application Examples at any time without prior notice.  
If there are any deviations between the recommendations provided in these Application 
Examples and other Siemens publications – e.g. Catalogs – the contents of the other 
documents have priority. 

We do not accept any liability for the information contained in this document. 
Any claims against us – based on whatever legal reason – resulting from the use of 
the examples, information, programs, engineering and performance data etc., 
described in this Application Example shall be excluded. Such an exclusion shall 
not apply in the case of mandatory liability, e.g. under the German Product Liability 
Act (“Produkthaftungsgesetz”), in case of intent, gross negligence, or injury of life, 
body or health, guarantee for the quality of a product, fraudulent concealment of a 
deficiency or breach of a condition which goes to the root of the contract 
(“wesentliche Vertragspflichten”). The damages for a breach of a substantial 
contractual obligation are, however, limited to the foreseeable damage, typical for 
the type of contract, except in the event of intent or gross negligence or injury to 
life, body or health. The above provisions do not imply a change of the burden of 
proof to your detriment. 
Any form of duplication or distribution of these Application Examples or excerpts 
hereof is prohibited without the expressed consent of the Siemens AG. 

Security 
informa-
tion 

Siemens provides products and solutions with industrial security functions that support the 
secure operation of plants, systems, machines and networks. 
In order to protect plants, systems, machines and networks against cyber threats, it is 
necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial 
security concept. Siemens’ products and solutions only form one element of such a 
concept. 
Customer is responsible to prevent unauthorized access to its plants, systems, machines 
and networks. Systems, machines and components should only be connected to the 
enterprise network or the internet if and to the extent necessary and with appropriate 
security measures (e.g. use of firewalls and network segmentation) in place.  
Additionally, Siemens’ guidance on appropriate security measures should be taken into 
account. For more information about industrial security, please visit 
http://www.siemens.com/industrialsecurity. 

Siemens’ products and solutions undergo continuous development to make them more 
secure. Siemens strongly recommends to apply product updates as soon as available and 
to always use the latest product versions. Use of product versions that are no longer 
supported, and failure to apply latest updates may increase customer’s exposure to cyber 
threats. 
To stay informed about product updates, subscribe to the Siemens Industrial Security 
RSS Feed under http://www.siemens.com/industrialsecurity. 

 

http://www.siemens.com/industrialsecurity
http://www.siemens.com/industrialsecurity
http://www.siemens.com/industrialsecurity
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1 Introduction 

1.1 TIA Selection Tool (TST) 

Intelligent product catalogue 

The free TIA Selection Tool (TST) is an intelligent product catalogue for industry 
products. The included portfolio covers a broad scope of products: 

 SIMATIC controllers 

 Distributed pheripherals 

 Panels 

 Industry PCs 

 Motors and drives 

 Industrial sound technology 

 Software 

 Industrial communication 

 Connection technology 

 Power supply 

 SIMATIC Ident 

 Energy distribution and measurement 

 MindSphere 

 Accessories 

 

Locally or in the cloud 

The TST can either be used as local program on any PC (with Windows 7 or 
higher), or as browser-based web application in any browser. Created product lists 
and configurations can be saved as TST projects, either locally or in the TST cloud. 

Figure 1-1: TIA Selection Tool 

Projects

TIA Selection Tool

• Working locally on the 

PC, independently from 

the internet

• Saving projects locally 

or in the cloud

TIA Selection Tool cloud

• Browser-based version
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Configuring and ordering products 

The TST has extensive functions for intuitively creating hardware and software 
configurations. 

 Intelligent station configuration 
(only stations that are workable in reality can be configured) 

 Network configuration 

 Topology configuration 

 Accessory configuration 

 Order list 

 Direct order in the Industry Mall 

 

Note A description and tutorial videos can be found on the homepage of the TSTs. 

http://www.siemens.com/tst 

 

Exporting TST projects as AutomationML file 

By configuring the stations, the network and the topology, you have already 
created a detailed device setup of your plant. TST offers the possibility to export 
configurations as “Automation Markup Language” files. AutomationML is a neutral, 
XML-based file format for storing and exchanging engineering data. These AML 
files contain the following information: 

 Station configuration 

 Network configuration 

 Topology configuration 

 

The AML file exported by TST can be used for TIA Portal and ECAD programs. 

 

Importing TST projects as AML file into TIA Portal 

To commission automation devices, you need to configure and program them in 
TIA Portal. For this, you need to repeat the configurations that you already have 
performed in TST. 

With the release of TIA Portal V14 SP1, it is possible to import the AML files 
created by TST into TIA Portal projects. Thus, it is no longer necessary to perform 
the hardware configuration twice in both programs. This replacement allows data 
consistency throughout the entire engineering process. 

 

http://www.siemens.com/tst
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Importing TST projects as AML file into EPLAN Electric P8 

EPLAN Electric P8 is a widespread ECAD program used for the configuration, 
documentation and management of electrotechnical automation projects in 
industrial surroundings. In EPLAN Electric P8, all CAD models of Siemens 
automatisation components can be imported. 

 

Note CAX downloads of Siemens automation components: 

https://support.industry.siemens.com/My/ww/en/CAxOnline 

 

With the release of EPLAN Electric P8 2.7, it is possible to import the AML files 
created by TST into EPLAN projects. 

https://support.industry.siemens.com/My/ww/en/CAxOnline
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1.2 Mode of operation 

1.2.1 Overview of export and import options 

The following figure shows all import and export options of AML files. 

Figure 2-1: TST <-> AML file <-> TIA Portal V14 SP1 / EPLAN or higher 
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1. TST (or TST cloud) can import and export AML files. 
 

2. TIA Portal up to V14 SP1 or higher can import and export AML files. 

– Requirement: TIA Portal Openness as of V14 SP1 

– The import and export function in TIA Portal are executed on the basis of 
the TIA Portal Openness function. 

– TIA Portal Openness is a free part of every TIA Portal product (e.g. STEP 
7). The installation is done separately. 
 

3. EPLAN Electric P8 2.7 can import AML files from TST. 

 

4. EPLAN Electric P8 2.7 can export AML files. 

– Currently, the TST cannot process the export from EPLAN Electric P8. 
This will not be discussed further in this application example. 

 

Note Information on the import and export of AML files (created with EPLAN Electric 
P8 2.7) in TIA Portal can be found in the following application example: 

https://support.industry.siemens.com/cs/ww/en/view/109748224 

https://support.industry.siemens.com/cs/ww/en/view/109748224


1 Introduction 

 

Integration of planning data from TIA Selection Tool to TIA Portal or 
EPLAN Electric P8 
Entry ID: 109748223,    V1.0,    11/2017   8 
 


 S

ie
m

e
n

s
 A

G
 2

0
1

7
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

1.2.2 Structure of AML file (exported from TST) 

The structure of each AML file is standardized. Therefore, the structure is always 
the same. However, AML files can differ in content. It is a readable, XML-based file 
and can be opened with a text editor (e.g. XML Notepad or AutomationML Editor). 

Figure 3-1: Structure of AML file (exported from TST) 

1

2

 

1. Metadata 

– AML version 

– Created using TST, TIA Portal… 

– Manufacturer 

– Date 

2. Hierarchically structured HW configuration 

– Article number (with version) 

– Station configuration, 

– Network configuration, 

– Topology configuration 
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1.2.3 Different AML files for TIA Portal or ECAD programs 

With regards to the export of AML files, the TST distinguishes between two 
different export types: 

 TIA Portal 

 ECAD 

 

Figure 4-1: TST AML file export 

 

 

Table 1-1: Differences of the AML files 

TIA Portal ECAD 

Contains only product information that can 

be processed by TIA Portal. 

 Article numbers 

 Station configuration 

 Network configuration 

 Topology configuration 

Contains all product information that are 
contained in the TST project. 

 Article numbers 

 Station configuration 

 Network configuration 

 Topology configuration 

 

Further information: 

 Article numbers of accessories 

– Memory Cards 

– Front plugs of modules 

– Network cable 

– etc. 
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1.3 Components used 

This application example was created with the following software components: 

Table 1-5: Engineering PC/PG 

Component Number Article number Note 

STEP 7 Professional 
V14 SP1 Update 2 

1 6ES7822-1AE04-0YA5 
or 
6ES7822-1AA04-0YA5 

Download 
 
DVD 

 

TIA Openness 
V14 SP1 Update 2 

1 - Part of TIA Portal products 

Separate installation 

 

TIA Selection Tool 

V2017.3.0.56890 

 

or 

 

TIA Selection Tool 
cloud 

1 - Download 
http://www.siemens.com/tst 

 

 

http://www.siemens.com/tst
cloud 

 

EPLAN Electric P8 
2.7 

1 - http://www.eplan.de 

 

MS SQL Server 2014 
Express 

1 - https://www.microsoft.com 

 

Product is used as article 
database for EPLAN 
Electric P8. 

 

Alternative: 

MS Access file 

 

This application example consists of the following components: 

Table 2-1: Download 

Component File name Note 

TIA Selection Tool 
example project TIA 
Selection Tool 

 

109748223_TST_to_TIA_Portal_PROJ_v10.zip - 

Documentation 

 

109748223_TST_to_TIA_Portal_DOC_v10_en.pdf - 

 

http://www.siemens.com/tst
http://www.siemens.com/tstcloud
http://www.siemens.com/tstcloud
http://www.eplan.de/
https://www.microsoft./
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2 Engineering 

2.1 Restrictions on AML export with TST 

In general, only those products are supported for the import into TIA Portal that are 
contained in the HW catalogue of the TIA Portal. The following products are 
currently not supported: 

 HMI devices 

 Drives 

 Server module (ET 200SP stations) 
are added automatically by TIA Portal upon compiling the project. 

 

Note A list of the unsupported products can be found at the following entry: 

https://support.industry.siemens.com/cs/mdm/109477163?c=100378605579&lc=
en-WW 

 

2.2 Application case: Importing the TST project into TIA 
Portal 

2.2.1 Exporting the AML file from the TST project 

To import the TST project as AML file for TIA Portal, proceed as follows: 

1. Open the TIA Selection Tool. 
 

2. Go to the project view. 
 

3. Click the “Open project” button. 

 

 

https://support.industry.siemens.com/cs/mdm/109477163?c=100378605579&lc=en-WW
https://support.industry.siemens.com/cs/mdm/109477163?c=100378605579&lc=en-WW
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4. Click “Local”, then on “Browse” and navigate to the TST example project. 
Confirm the dialog with “Open”. 

 

 

5. In the menu bar, click on “Project > Export > TIA Portal or ECAD systems”. 

 

 

6. In the dialog, select “TIA Portal” and click on the “Export” button. 

 

 

7. Define the path and file name. 
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2.2.2 Importing the AML file into the TIA Portal project 

To import the TST project as AML file into the TIA Portal, proceed as follows: 

1. Open the TIA Portal. 
 

2. Go to the project view. 
 

3. Click the “New project” button. 

 

4. Define the path and file name. Click on the "Create" button. 
 

5. Click on “Tools > Import CAx data” in the menu bar. 

 

 

6. Navigate to the AML file exported by TST and click “Open”. 

Result 

TIA Portal imports the TST project with all device, network and topology 
configurations. 

Figure 1-2: TIA Portal project 

 

 

Note If you compile the project directly after the import, alarms and errors may occur. 
This is caused by several parameters in the hardware configuration that do not 
exist in TST. 
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2.3 Application case: Importing the TST project into 
EPLAN Electric P8 

2.3.1 Exporting the AML file from the TST project 

To import the TST project as AML file for EPLAN Electric P8, proceed as follows: 

1. Open the TIA Selection Tool. 
 

2. Go to the project view. 
 

3. Click the “Open project” button. 

 

 

4. Click “Local”, then on “Browse” and navigate to the TST example project. 
Confirm the dialog with “Open”. 
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5. In the menu bar, click on “Project > Export > TIA Portal or ECAD systems”. 

 

 

6. In the dialog, select “ECAD” and click on the “Export” button. 

 

7. Define the path and file name. 
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2.3.2 Downloading CAx macros with TST and CAx Download Manager  

EPLAN Electric P8 uses an MS SQL or MS Access database to manage all articles 
and their respective CAx macros. To create the circuit diagrams after the import of 
the AML files, you need the respective CAx macros. 

Prior to integrating the device configuration (which has been created with TST and 
exported as AML) into EPLAN Electric P8, make sure that all CAx macros of the 
devices are present in the EPLAN Electric P8 database. 

Via the TST, you can trigger the download of all devices of the corresponding TST 
project. This download is done via the CAx Download Manager in the Online 
Support. 

https://support.industry.siemens.com/My/ww/en/CAxOnline 
 

Note In case there are bundles like the ET 200SP (6ES7155-6AA00-0BN0) in the TST 
project, you need to manually download the EPLAN macros of each article. The 
CAx export currently only exports the bundle article numbers. The individual 
articles are required for further processing in EPLAN. 

 Interface Module (6ES7155-6AU00-0BN0) 

 Server Module (6ES7193-6PA00-0AA0) 

 Bus Adapter BA 2xRJ45 (6ES7193-6AR00-0AA0) 

 

The Siemens Image Database can be found under the following link. Here, 
product photos, product icons and CAx data can be downloaded: 

https://www.automation.siemens.com/bilddb 

 

 

1. Open the “Order list” in the project navigation. 
 

2. Click on the “Exporting” button. 

 

 

https://support.industry.siemens.com/My/ww/en/CAxOnline
https://www.automation.siemens.com/bilddb
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3. Your browser opens. Log into the CAx Download Manager or registrate as new 
user. 
 

4. The CAx Download Manager displays the transferred devices. Confirm the 
dialog with “OK”. Click “Continue”. 

 

 

5. Select “EPLAN Electric P8 macros” and click on “Continue”. 

 

 

6. Confirm the dialog with “Continue”. 
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7. Define a name for the download and click on the “Create CAx download” 
button. 

 

 

8. The final dialog informs you that the CAx download has been successfully 
created. Click on “To CAx download manager”. 

 

 

9. The current status of the CAx download is displayed. 

 

 

10. As soon as the download is ready, click on “Download”. 

 

 

11. Select the storage location, save and unzip the zip file. 

 

12. The CAx data can now be integrated into EPLAN Electric P8. 
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2.3.3 Integrating CAx macros into EPLAN Electric P8 

To integrate the downloaded CAx macros into EPLAN Electric P8, proceed as 
follows. 

1. Click on “Utilities > Parts > Management...” in the menu bar. 

 
 

2. Click on “Extras > Import...”. 
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3. In the dialog, set the following. 

– Select “EPLAN Data Portal exchange format (EDZ)” under “File type”. 

– Under “File name”, navigate to the macros to be imported 

– Select “Update existing records and add new ones”. 

– Confirm the dialog with “OK”. 

 

 

4. Close the following dialog with "Close”. 
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2.3.4 Importing the AML file into the EPLAN project 

To import a TST project as AML file into EPLAN, proceed as follows. 

1. Open EPLAN Electric P8. 
 

2. Create a new project and apply the default settings via “OK”. 

 

 

3. In the menu bar, select “Project data > PLC > Import data”. 
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4. In the dialog, set the following. 

– Select “Siemens SIMATIC STEP 7 TIA Portal V14 (AutomationML)” under 
“Format of export file”. 

– Under “File name”, navigate to the AML file exported by TST. 

– Click "OK". 

 

5. Open the PLC navigator under “Product data > PLC > Navigator”. Here, you 
can find all imported devices from the AML file. 

 

 

6. The import is completed and you can proceed with the creation of the circuit 
diagrams. 
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3 Annex 

3.1 Service & Support  

Industry Online Support 

Do you have any questions or need support?  

Siemens Industry Online Support offers access to our entire service and support 
know-how as well as to our services.  

Siemens Industry Online Support is the central address for information on our 
products, solutions and services.  

Product information, manuals, downloads, FAQs and application examples – all 
information is accessible with just a few mouse clicks at  
https://support.industry.siemens.com 

SITRAIN - Training for Industry  

Qualified employees are a key success factor for each company. Skills 
development and expertise ensure competitiveness and innovation. With our 
worldwide available training for the industry, we support you in this - in a pratical 
way with innovative learning methods and a tailored, customer-specific concept. 

www.siemens.com/sitrain 

Technical Support 

Siemens Industry's Technical Support offers quick and competent support 
regarding all technical queries with numerous tailor-made offers 
 – from basic support right up to individual support contracts. 

Please address your requests to the Technical Support via the web form:  
www.siemens.com/industry/supportrequest 

Service offer 

Our service offer comprises, among other things, the following services:  

 Product Training 

 Plant Data Services 

 Spare Parts Services 

 Repair Services  

 On Site and Maintenance Services 

 Retrofit and Modernization Services 

 Service Programs and Agreements  

Detailed information on our service offer is available in the Service Catalog: 
https://support.industry.siemens.com/cs/sc 

Industry Online Support app 

Thanks to the "Siemens Industry Online Support" app, you will get optimum 
support even when you are on the move. The app is available for Apple iOS, 
Android and Windows Phone. 
https://support.industry.siemens.com/cs/ww/en/sc/2067 

 

https://support.industry.siemens.com/cs/start?lc=en-WW
https://www.sitrain-learning.siemens.com/DE/en/index.do
https://support.industry.siemens.com/My/ww/en/requests
https://support.industry.siemens.com/cs/sc?lc=en-WW
https://support.industry.siemens.com/cs/ww/en/sc/2067
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3.2 Links and literature  

Table 1-2 

No. Topic 

\1\ Siemens Industry Online Support 

https://support.industry.siemens.com 

\2\ Link to the entry page of the application example  

https://support.industry.siemens.com/cs/ww/en/view/109748223 

\3\ TIA Selection Tool 

http://www.siemens.com/tst 

\4\ TST cloud 

http://www.siemens.com/tstcloud 

\5\ EPLAN Electric P8 2.7 

http://www.eplan.de 

\6\ MS SQL Server 2014 Express 

https://www.microsoft.com/ 

\7\ CAX downloads of Siemens automation components: 

https://support.industry.siemens.com/My/ww/en/CAxOnline 

\8\ AutomationML Editor 

https://www.automationml.org 

\9\ Automating SIMATIC projects via scripts 

Chapter “Export/Import > Import/Export hardware data” 

https://support.industry.siemens.com/cs/ww/en/view/109477163/100320415755 

 

3.3 Change documentation 

Table 3-4 

Version Date Modification 

V1.0 11/2017  First version 

 

https://support.industry.siemens.com/cs/start?lc=en-WW
https://support.industry.siemens.com/cs/ww/en/view/109748223
http://www.siemens.com/tst
http://www.siemens.com/tstcloud
http://www.eplan.de/
https://www.microsoft.com/
https://support.industry.siemens.com/My/ww/en/CAxOnline
https://www.automationml.org/
https://support.industry.siemens.com/cs/ww/en/view/109477163/100320415755
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