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Preface

ProTool/Lite is used to configure Operator Panels (OPs) having text based
displays for specific systems. The ProTool/Lite User’s Manual explains how
you run the configuring tool ProTool/Lite and what configuration means. The
manual is valid for configuring the following devices: 
– OP3 
– OP5 
– OP7 
– OP15 
– OP17 
– C7-623 
– C7-624

The manual is part of the SIMATIC MMI documentation. It includes the ma-
nuals for the configuring tool, the Operator Panels and communication bet-
ween the PLC and the OP. Below, you will find an overview diagram and a
description of when you require the different manuals.
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Document Type Target Group Contents

Getting Started 
Product Brief

Beginners This document guides you step by step
through the configuration of

� a screen containing static text

� a screen containing an input/output field 
and a bar graph

� changing from one screen to another

� a message

A document is available for each of the fol-
lowing:
– OP3, OP5, OP15
– OP7, OP17
– OP25, OP35, OP45

ProTool
User’s Manual

Configurer Provides information for working with the
ProTool configuring tool.

It contains

� basic rules for configuration

� a detailed description of objects and
functions that you can configure

� examples of configuring objects

This document is valid for OPs having
graphics displays.

ProTool/Lite
User’s Manual

Configurer Same contents as the ProTool User’s Manual.
This document is valid for OPs having text
based displays.

ProTool
Online Help

Configurer Provides information on your computer (PU
or PC)  screen for working with the ProTool
configuring tool. The online Help is context-
sensitive and contains

� a general description of the editors to be 
found in ProTool

� a detailed description of the different 
fields in the dialog boxes

� a comprehensive description of the func-
tions

Preface
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Document Type ContentsTarget Group

Example Application
Commissioning Instruc-
tions

Beginners Example configurations are supplied with Pro-
Tool together with the associated PLC pro-
grams. This document describes

� how you load the examples onto the OP 
and the PLC

� how you can run the example

� how you can upgrade the connection 
for your application

OP37
Equipment Manual

OP25, OP35, OP45
Equipment Manual

OP7, OP17
Equipment Manual

OP5, OP15
Equipment Manual

Commissioning engi-
neers, users

Describes the OP hardware and general opera-
tion. It contains

� installation and commissioning

� a description of the OP device

� electrical installation with connection
of the PLC, printer and configuration 
computer

� OP modes

� OP operation

� description of the standard screens supplied
with the software and their usage

� how to install options

� maintemance and replacement of spare 
parts

OP3
Equipment Manual

Commissioning engi-
neers, users,
programmers

Describes the OP hardware, generaloperation
and the connection to a SIMATIC S7.

Preface
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Document Type ContentsTarget Group

Communication 
User’s Manual

Programmers Provides information on connecting OPs to
the following PLCs:

� SIMATIC S5

� SIMATIC S7

� SIMATIC 500/505

� block drivers for other PLCs

This document describes

� the configuration and parameters required 
to connect the OP to the PLC and to the 
network

� the user data areas used for 
exchanging data between the OP and 
the PLC

Other PLCs
Online Help

Programmers Provides information for connecting OPs to
PLCs such as

� Mitsubishi

� Allen Bradley

� Telemecanique

The drivers for connections to these PLCs are
located on separate floppy disks and are re-
ferred to as NATIVE drivers. Installation of a
driver also installs the associated online Help.

Preface
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This manual comprises four parts:

Chapters 1–4 contain information of a general nature. This is information
about what ProTool/Lite does, what functions ProTool/Lite
supports, and how ProTool/Lite is installed and run under
Windows.

Chapter 5 describes the basic approach to configuration. You should
study this chapter before you embark on configuration.

Chapters 6–10 contain detailed information on how to configure different
objects. Instructions are given on a step-by-step basis.

Chapters 11–16provide instructions on doing any of the following

– create a configuration in different languages

– print your configuration

– transfer your configuration to the OP

– copy or archive your configuration

The following conventions are used in this manual:

VAR_23 Typewriting identifies inputs or outputs as shown on the
screen. They may be commands, filenames, entries in dia-
log boxes or system messages.

F1 Names of keys are shown in a different type for identifica-
tion purposes.

File → Menu items are shown in this form. The whole path is 
Print always specified, showing how the menu item is accessed.

Variable Dialog boxes as well as fields and buttons in dialog boxes
are shown in italic type.

The different issues of the User’s Manual apply to the following ProTool/Lite
versions:

Issue 06/95 Valid for ProTool/Lite versions up to and including 1.01

Issue 12/95 Extensions and revisions.
Valid for ProTool/Lite version 2.0 or later
and for ProTool version 2.0 or later

Issue 09/96 Extensions for the OP7 and the OP17
Valid for ProTool/Lite version 2.5 or later
and for ProTool version 2.5 or later

How the manual is
organized

Conventions

Applicability

Preface
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The following firmware releases are required for the Operator Panels:

– OP3 V1.00 or later

– OP5 V1.20 or later

– OP15 V2.20 or later

– OP7 V1.0 or later

– OP17 V1.0 or later

In the event of technical queries, please get into touch with your point of con-
tact at the Siemens agency or branch which takes care of your affairs. You
will find the addresses in Appendix D Siemens Worldwide. In addition, you
can call our hotline on +49 (911) 895-7000 (Fax 7001).

The abbreviations used in the ProTool/Lite User’s Guide have the following
meanings:

AG Automatisierungsgerät (German for ”PLC”)

AM Alarm Message

ANSI American National Standards Institute

AS 511 Driver of PU interface to the SIMATIC S5

ASCII American Standard Code for Information Interchange

DB Data Block (on PLC)

DW Data Word (on PLC)

EM Event Message

EM Equipment Manual

FW Flag Word (on PLC)

LED Light-Emitting Diode

MPI Multipoint Interface (SIMATIC S7)

OLE Object Linking and Embedding

OP Operator Panel

PC Personal Computer

PLC Programmable Logic Controller

PPI Point-to-Point Interface (SIMATIC S7)

PU Programming Unit

RAM Random Access Memory (working memory)

UM User’s Manual

Software and 
hardware versions

Obtaining 
product support

Abbreviations

Preface
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Introduction

ProTool/Lite is an easy-to-use configuration tool for Operator Panels (OPs).
It can run under Microsoft  Windows . You can use a mouse or the key-
board to execute most actions that have to be performed in ProTool/Lite.

Configuration consists in creating screens and messages and linking them to
the PLC program. This means that the processes in the PLC can be visualized
and manipulated.

Screens are used to create an image of the process with text and variables so
that the operator can quickly grasp the relationships and intervene in the pro-
cess, should this be necessary. Text explains individual elements on the
screen. Variables are directly linked to the PLC and are used to display cur-
rent values. By using variables, the operator can also write values to the PLC.

Messages draw the operator’s attention to certain operating states, or they
display malfunctions in process execution.

Screens have to be called. Messages are displayed automatically. They are
initiated by the PLC.

Operator Panels have a system keypad and a function keypad. The system
keypad contains the keys for operating the Operator Panel, such as cursor
control and inputs. Functions can be assigned to the function keys during
configuration. In this way the actual control sequence is implemented.

Configuration is performed on a PC or a programming unit (PU). 
The configuration then has to be compiled under ProTool/Lite and down-
loaded to the OP. If there is link to the PLC, the OP displays the current val-
ues of variables. Figure 1-1 shows the different phases in which work is per-
formed on configuration data.

ProTool/Lite

Configuration

Screens and 
Messages

Keys

Configuration data

1
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Figure 1-1 Configuration Phase, Download Phase and Process Control Phase

A configuration consists of different components, including:

– specification of the PLC and type of link

– general settings for the Operator Panel

– objects such as variables, screens and messages.

In ProTool/Lite, there is a separate editor for every type of object such as
messages or variables. Different objects, which are given a symbolic name,
are created under an object type. You have to specify this symbolic name
when you edit, reference or delete the object.

Part or all of the configuration can be printed under ProTool/Lite. Part means
that all the objects of a single object type, such as messages or variables, are
printed.

Components of a
configuration

Object types

Printing a
configuration

Introduction
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Installation

Table 2-1 shows the system requirements for running.

Table 2-1 System Requirements for ProTool/Lite 

Device Required

CPU 80486 SX/33 MHz

Main memory 8 MB

Free space on
hard disk

2 MB in Windows directory
10 MB for ProTool/Lite

Graphics card VGA

Floppy disk drive 3.5 ”

Microsoft Windows MS-Windows 3.1
MS-Windows for Workgroups 3.11
MS-Windows95

The system requirements depend on the operating system being used.

To improve performance, and thus speed, we recommend that you create
virtual memory for Windows.

Virtual memory should be of the Permanent  type and at least 15 MB.

Information is written temporarily from main memory to a file on your hard
disk. This file is a hidden file which reserves storage space on your hard disk.
When you require the information again, Windows loads it back into main
memory.

You have to install ProTool/Lite under Windows. You can install it either
from the floppy disks supplied to you or – for example, for networks – from
your hard disk.

System
requirements

Virtual
memory

Methods of
installation

2
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If STEP 7 version 2.0 programming software is available on your computer,
you can install ProTool/Lite integrated in STEP 7. The advantages of doing
this are as follows:

� You manage ProTool/Lite projects with the SIMATIC Manager, the same
tool as you use for managing your STEP 7 projects.

� You can select STEP 7 symbols and data blocks from a text or graphic list
as variables. The data type and the address are entered automatically.

� ProTool/Lite lists all the PLCs in your STEP 7 project and determines the
address parameters once a PLC has been selected.

Before installation proper begins, the system asks you what language and
options you wish to use. Installation begins in the same language in which
you installed Windows or in English. After you have selected the language in
which you want to have ProTool/Lite installed, installation is resumed in the
language you specified. You cannot change the ProTool/Lite language in On-
line mode. If you wish to be able to use the ProTool/Lite user interface in a
different language, you have to re-install ProTool/Lite.

To install ProTool/Lite, proceed as follows:

Step for Windows 3.0 or later for Windows95

1 Start Windows

2 Insert the first floppy disk into the drive.

3 Select in the File Manager the drive
in which the floppy disk is inserted
and double-click on the 
setup.exe  program

Select in the Explorer the drive in
which the floppy disk is inserted and
double-click on the setup.exe  pro-
gram

4 A dialog box appears in which you can click, under Options, the software
packages you wish to have installed. Perform modifications here only if you
have ordered optional software packages.

5 Under STEP 7 , select whether Pro-
Tool/Lite should be installed as Inte-
grated or Standalone.

6 Follow the setup instructions on the screen.

STEP 7 integration

Selecting
a language

Installing from
floppy disk

Installation
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Installation may be varied in its detail by installation options. With the op-
tions featured, the following components are installed:

ProTool/Lite is the program for creating configurations.

Optional PLC are drivers and examples for ”non-SIMATIC” PLCs
drivers  and have to be ordered separately.

To install ProTool/Lite from your hard disk, you must first copy the floppy
disks to hard disk. In doing so, you must observe certain conventions.

ProTool/Lite consists of two components, which are also labeled differently.
These components are:

� ProTool/Lite Software Labeled on floppy disk as 
ProTool/Lite

� Optional PLC drivers Labeled on floppy disk as 
Driver

Create a separate directory for all the different components and floppy disks,
containing the name of the component and the number of the floppy disk.
The directories have to be created in accordance with the labels on the floppy
disks.

This means that you create for the ProTool/Lite  software the directories
\ PROLITE\DISK n

where n is the number of the floppy disk. For floppy disk 1, you therefore
create a directory called \PROLITE\DISK1 ; for floppy disk 2 you create a
directory called \PROLITE\DISK2 , and so on.

For the Optional PLC Drivers, create a directory called \DRIVER\DISK1 .

ProTool/Lite is installed in a program group of its own. When installation has
been completed, you will see the following icons in the program group:

Double-clicking this icon launches ProTool/Lite.

For late breaking information about ProTool/Lite double-
click this icon.

To call online Help, double-click on this icon. Online Help
can also be called in ProTool/Lite by pressing key F1.

To modify Setup, double-click on this icon. You can modify
Setup to install an option.

Options

Installing from
hard disk

Icons in the
program group
in Windows 3.11

Installation
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With Windows95, you call ProTool/Lite by means of the taskbar. The icons
described under Windows 3.x will be found here as entries on the taskbar.

If you have installed ProTool/Lite to be Standalone, you will find it in the
Programs folder. If you have installed ProTool/Lite to be Integrated, you will
find it in the Simatic folder.

Note

Before you start work on a configuration, you should first read about the file
structure created for ProTool/Lite and the significance of the standard
screens supplied to you by consulting section 7.5.

The taskbar with
Windows95

Installation
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Device-Specific Functional Overview

The following tables present an overview of the

� objects (Table 3-1),

� general functions (Table 3-2)

that can be configured for the different devices.

Table 3-1 Configurable Objects

Objects

OP3 OP5
C7-623

OP7 OP15
C7-624

OP17

Screens Screen entries Soft keys
Information text

x
–

x
x

x
x

x
x

x
x

Input fields Variable
Scheduler

x
–

x
–

x
x

x
–

x
x

Output fields Variable
Date
Time

x
x
x

x
x
x

x
x
x

x
x
x

x
x
x

Input/output fields Variable x x x x x

Character format Flashing
Upper case

x
–

x
–

x
–

x
x1

x
x

Attributes Number
Directory
Start screen
Return to
Title
Information text

x
x
x
x2

x
–

x
x
x
x
x
x

x
x
x
x
x
x

x
x
x
x
x
x

x
x
x
x
x
x

Event
messages

Standby message Date
Time

x
x

x
x

x
x

x
x

x
x

Output fields Variable
Date
Time

x
x
x

x
x
x

x
x
x

x
x
x

x
x
x

Attributes Priority
Print

x
–

x
x

x
x

x
x

x
x

Information text – x x x x

Character format Flashing
Upper case

x
–

x
–

x
–

x
x1

x
x

1 With OP15C and C7-624 having 8*40 characters only
2 The only return possible is BACK.

In this chapter

3
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Table 3-1 Configurable Objects

Objects

OP17OP15
C7-624

OP7OP5
C7-623

OP3

Alarm
messages

Output fields Variable
Date
Time

–
–
–

x
x
x

x
x
x

x
x
x

x
x
x

Attributes Priority
Acknowledge
Print

–
–
–

x
x
x

x
x
x

x
x
x

x
x
x

Information text – x x x x

Character format Flashing
Upper case1

–
–

x
–

x
–

x
x1

x
x

Recipes Recipe entries Information text – x x x x

Input fields Variable – x x x x

Character format Flashing
Upper case

–
–

x
–

x
–

x
x1

x
x

Attributes Number
Directory
Return to
Title
Information text

–
–
–
–
–

x
x
x
x
x

x
x
x
x
x

x
x
x
x
x

x
x
x
x
x

Headers/
footers

Message log
EM chronological
EM  together
AM chronological
AM together
Overflow
Screen printout
Recipe

–
–
–
–
–
–
–
–

x
x
x
x
x
x
x
x

x
x
x
x
x
x
x
x

x
x
x
x
x
x
x
x

x
x
x
x
x
x
x
x

Output fields Date
Time
Page number

–
–
–

x
x
x

x
x
x

x
x
x

x
x
x

Character format Underlined
Italics

–
–

x
x

x
x

x
x

x
x

Scheduler Type
Scheduler time
Bit
Function

–
–
–
–

–
–
–
–

–
–
–
–

x
x
x
x

x
x
x
x

1 With OP15C and C7-624 having 8*40 characters only

Device-Specific Functional Overview
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Table 3-1 Configurable Objects

Objects

OP17OP15
C7-624

OP7OP5
C7-623

OP3

Output fields Usage Variable
Date
Time
Page number

x
x
x
–

x
x
x
x

x
x
x
x

x
x
x
x

x
x
x
x

Display Decimal
Hexadecimal
Binary
String
Decimal,decimal
Text symbol

x
x
x
x
x
x

x
x
x
x
x
x

x
x
x
x
x
x

x
x
x
x
x
x

x
x
x
x
x
x

Field length
i bl

x x x x xg
Variable x x x x x

Input fields Usage Variable
Date
Time
Scheduler

x
x
x
–

x
x
x
–

x
x
x
–

x
x
x
x

x
x
x
x

Display Decimal
Hexadecimal
Binary
String
Decimal,decimal
Text symbol

x
x
x
x
x
x

x
x
x
x
x
x

x
x
x
x
x
x

x
x
x
x
x
x

x
x
x
x
x
x

Field length x x x x xg
Variable
P d l l

x x x x x
Password level
Information text

x x
x

x
x

x
x

x
xInformation text – x x x x

Variables Format x x x x x
Length
P lli i

x x x x x
Polling time
Decimals

x
x

x
x

x
x

x
x

x
xDecimals

Address
x
x

x
x

x
x

x
x

x
xAddress

PLC
x
x

x
x

x
x

x
x

x
xPLC

Limit values
x
x

x
x

x
x

x
x

x
xLimit  values

Variable
x
–

x
–

x
x

x
–

x
x

Functions x – x – x

Soft keys Password level x x x x xy
Bit in variable
F i

x x x x x
Functions x x x x x

Function keys Password level
Function
Shift + Function
Set bit in LED assignment
Set bit in keyboard assignment

–
–
–
–
–

x
x
x
–
x

x
x
x
x
x

x
x
x
x
x

x
x
x
x
x

Device-Specific Functional Overview
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Table 3-2 Configurable General Settings

General Settings

OP3 OP5
C7-623

OP7 OP15
C7-624

OP17

PLC Standard clock pulse x x x x x

Drivers SIMATIC S5 – AS511
SIMATIC S5 – FAP
SIMATIC S5 – SINEC L2–DP
SIMATIC S7 – 300/400
SIMATIC S7 – 200
FREE SERIAL
SIMATIC 500/505

–
–
–
x
x
–
–

x1

x1

x1

x
x1

x1

x1

x
x
x
x
x
x
x

x1

x1

x1

x
x1

x1

x1

x
x
x
x
x
x
x

Parameters Depend on PLC x x x x x

Area pointer Interface area
User version

x x
x

x
x

x
x

x
xUser version

Screen number
–
x

x
x

x
x

x
x

x
xScreen number

Event messages
Al

x
x

x
x

x
x

x
x

x
x

Alarm messages
PLC acknowledge

–
–

x
x

x
x

x
x

x
xPLC acknowledge 

OP acknowledge
–
–

x
x
1

x
x

x
x
1

x
xg

Recipe number 
Data mailbox

– x1

x1
x
x

x1

x1
x
xData mailbox

Recipe mailbox
–
–

x1

x1
x
x

x1

x1
x
xRecipe mailbox

Successive recipe
ilb

–
x
x

x
x

x
x

x
x

mailbox 
System keyboard x x x x xSystem keyboard
Function keyboard
LED i

x
–

x
x

x
x

x
x

x
x

LED assignment – – x x x

Parameters Messages Printout

Alarm messages: 
– First/Last
– Separate/Together

Language-dependent charac-
ters for:
– Messages in buffer
– Information text

Warn on buffer overflow

–

–
–

–
–

–

x

x
x

x
x

x

x

x
x

x
x

x

x

x
x

x
x

x

x

x
x

x
x

x

Firmware Device and firmware release x x x x x

Miscellaneous User version
Time/date format
Superuser password
Contrast
Flashing input field 
Display system messages

–
x
x
–
x
x

x
x
x
x
x
x

x
x
x
x
x
x

x
x
x
x
x
x

x
x
x
x
x
x

1 Not with C7-623 and C7-624
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General Settings

OP17OP15
C7-624

OP7OP5
C7-623

OP3

Printer Interface Type
Data bits
Parity
Stop bits
Baud rate

–
–
–
–
–

x
x
x
x
x

x
x
x
x
x

x
x
x
x
x

x
x
x
x
x

Settings Select printer
Parameters

–
–

x
x

x
x

x
x

x
x

Languages Configuration 
possible in: German

English
French
Italian
Spanish
Russian

x
x
x
x
x
–

x
x
x
x
x
–

x
x
x
x
x
x

x
x
x
x
x
x1

x
x
x
x
x
x

Languages loaded 
simultaneously 
on the OP

3 configuration languages x x x x x

Download
using

Serial interface 
MPI

x
x

x2

x3
x
–

x2

x3
x
x

1 Not possible with OP15A
2 Not possible with C7-623 or C7-624
3 Possible with C7-623 and C7-624 only

Device-Specific Functional Overview
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Working with Pro Tool/Lite

This chapter contains a general description of how to run Pro Tool/Lite. This
description is not a substitute for the general Windows documentation.

4.1 General Remarks

Pro Tool/Lite is primarily designed to be run with a mouse. The different edi-
tors are provided with special tool bars that have editor-specific buttons.
These tool bars are shortcuts to frequently used functions.

You can also configure ProTool/Lite using the keyboard.

The following sections tell you how to handle mice and keyboards.

Under Pro Tool/Lite, you always use the left mouse button to operate the
mouse.

In the Pro Tool/Lite documentation, the following terms are used for working
with a mouse:

Click The mouse button is pressed and released.

Drag The mouse button is pressed and held down, the cursor is
moved to its new position, and the mouse button is released.

Double-click The mouse button is pressed twice in rapid succession.

If you work without a mouse, the same key conventions apply in ProTool/
Lite as in Windows.

The key combinations valid for ProTool/Lite have the following functions in
the message, screen and recipe editors:

SHIFT + left Select one character on left

SHIFT + right Select one character on right

Strg + Arrow Next configured message

Working with a
Mouse

Working without a
Mouse

4
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On some menus, the menu items are followed by details of keys and key
combinations. If you press this key or key combination, the menu item is ini-
tiated. You must not choose the menu in advance.

If menu items, symbols or buttons are displayed in gray, you cannot execute
these functions.

4.1.1 Opening Several Configurations and Editors

Under Pro Tool/Lite, you can open several configurations and editors simul-
taneously. You can copy data to and from a configuration via the Clipboard.
This facilitates work since you do not have to re-configure all the data.

The same applies to editors, for you can also open several editors simulta-
neously. You can also open an editor several times over, thus being able to
work at different points in the editor.

A window is opened every time you select a configuration or an editor.

You can always edit the active window. You can recognize an active window
by the color of its title bar, which is different from that of the other windows
(Figure 4-1).

Figure 4-1 Pro Tool/Lite Screen with Several Open Windows

Opening several
configurations

Opening several
editors

Active window

Working with Pro Tool/Lite
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4.1.2 Using Online Help

Online Help is a complete reference tool which you can choose at any time
while you are configuring. By using online Help, you obtain information in
dialog boxes about menus, ranges of values etc.

You can call online Help in several different ways:

F1 You can always press F1 in Pro Tool/Lite to consult on
line Help. Online Help is automatically called for the
editor in which you happen to be working or for the dia-
log box you selected.

Context-sensitive Clicking the Help button (↑?) on the tool bar transforms
the cursor into an arrow with a question mark.
Clicking this cursor in Pro Tool/Lite on an item about
which you would like to obtain more information calls
online Help, and the corresponding position in online
Help is displayed.

The items you click may be dialog boxes, menu items or
buttons on the ����� ���.

If you are not working with a mouse, you can activate
context-sensitive Help by pressing SHIFT + F1.

Help menu You can call online Help by choosing the Help  → Con-
tents menu. The first page of online Help is then dis-
played.

Figure 4-2 shows an example taken from Online Help:

Figure 4-2 Online-Help

Purpose

Calling online Help

Online Help
window

Working with Pro Tool/Lite
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A green, underlined topic identifies a button which references another topic.
If you click this button, the new topic is displayed in a different window.

A green, dotted underlined topic denotes a button which references a brief
explanation. Clicking the cursor on this button displays a window containing
the information. The window is hidden by clicking anywhere on its surface.

Furthermore, online Help frequently displays screen dumps of Pro Tool/Lite,
i.e. editors, dialog boxes, etc. There are buttons under many of these screen
dumps. If you press these buttons, you jump to other topics or call a superim-
posed window, where you can obtain further information.

If you click in online Help on a button or menu item in a screen dump which
causes the Pro Tool/Lite software to branch to a dialog box, online Help also
branches to the associated topic. If you click in online Help on a field in
which an entry has to be made in the Pro Tool/Lite software, a window con-
taining a description is superimposed.

To make the buttons in screen dumps visible, press the following key com-
binations:

CTRL + TAB All invisible buttons are displayed while you hold down
CTRL + TAB.

ESC + TAB The first invisible button is displayed. Every time you press
ESC + TAB, the next button is displayed. Pressing RE-
TURN pushes the button.

Green text

Jump in 
screen dumps

Displaying jumps

Working with Pro Tool/Lite
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4.1.3 Status Bar in Pro Tool/Lite

The status bar is the bar at the bottom of the screen. In Pro Tool/Lite, the sta-
tus bar displays general information and editor-specific details.

The general information includes such items as the OP that you have selected
or how you can call online Help. Editor-specific details, on the other hand,
might be the language and the assignment of a message in the area pointer.
Fig. 4-3 shows the status bar with messages.

Figure 4-3 Status Bar with Messages

In the status bar you can also display information about the functions of but-
tons or of menu items. To do so, click the item you require and press and
hold down the mouse button. During this time the corresponding information
will be displayed in the status bar. If you do not want to initiate the function,
continue to hold down the mouse button and drag the mouse away from the
selected item.

4.1.4 All Menus

There are various editing levels in the configuration. They are represented by
main menu items.

Figure 4-4 Menu Bar

All the editing actions of an editing level are arranged under one main menu
item. The main menu items are specifically:

File All editing actions concerning the entire configuration are
concentrated here. At this point you can, for example, open
and save files, compile files and transfer them to the OP etc.

Edit All editing actions concerning selected or highlighted sec-
tions of the configuration are concentrated under this main
menu item. At this point you can, for example, cut, copy,
insert etc. fields or text.

Purpose

Displaying 
information

Menu bar

Main menu bar

Working with Pro Tool/Lite
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Editors! All the editors used for configuring the OP are concentrated
here. At this point you can select the editor you want to
work with – for example, for screens, event messages etc.

System General settings for the OP are listed under this main menu
item. At this point you perform settings for the link to the
PLC program and PLC-specific settings, and you set area
pointers etc.

Options At this point you will find default settings and cross-refer-
ences.

Window All the editing actions for arranging the windows of Pro-
Tool/Lite are located here. You can select – for example –
the window you want to have in the foreground, or you can
arrange all open windows on the screen, etc.

Help By choosing Help, you go to online Help. You can find in-
formation by searching for Help topics (Contents).

Editor-dependent menu items appear only when the corresponding editor is
called. All the editing actions specific to that editor appear under these menu
items. The following menu items are involved:

Screen At this point you can, for example, select screen attributes,
create fields, define character formats, etc.

Messages Under Messages, you can, for example, edit variables or
information text, open additional windows, etc.

Headers/FootersHeaders and footers can be edited for the printout on the
OP.

Recipe This menu item allows you, for example, to create fields,
edit information text, recipe attributes and character for-
mats, etc.

Editor-dependent
menu items

Working with Pro Tool/Lite
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4.2 Tool Bar

Some functions can be accessed not only on menus but also directly on the
tool bar at the top border of the screen. The buttons are self-explanatory and
represent shortcuts.

Figure 4-5 Tool Bar in Screen Editor

Below, a description is given of all the buttons on tool bars:
 

New Open a project with the default settings.

Open Open an existing project. The File Open dialog box is
opened. You choose the project you require from the dialog
box.

Save Save a project under its name. If it is a new, unnamed proj-
ect, the Save As dialog box is opened.

Cut Cut highlighted fields or text from the project and store
them on the Clipboard.

Copy Copy highlighted fields or text in the project and store them
on the Clipboard.

Paste Paste fields or text in the project from the Clipboard.

Context- Show a special cursor. Click the cursor on the item about 
sensitive help which you require information. Online Help is chosen.

Character format You assign a character format to highlighted text: under-
lined, flashing, italic, upper case. With upper case, the let-
ters are two lines high (this attribute can be selected only
for the OP15C having 8x40 characters).

WYSIWYG Toggle display of fields between symbolic name and actual
mode length.

Purpose

Summary
of functions

Working with Pro Tool/Lite
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Information text The same editor can be used to configure information text
for messages, screen and recipe entries. You use this key to
toggle between edit mode and information text.

Insert field With messages, screen and recipe entries, and headers and
footers, you can also use fields. This button is used to insert
a field.

4.3 General Settings

You can customize Pro Tool/Lite while you are configuring. To do this, the
following menu items are available to you:

At this point you can modify the default settings of names and settings.

Select Reference Text and, for the active screen, the screen is displayed in
the reference language. When you press the Apply Text button on the refe-
rence screen, all text strings on the reference screen are applied to the active
screen.

This menu item is used to display and hide the attribute window. In this win-
dow, you set different options which apply to just one message. This is its
priority, for instance.

This menu item is used to display and hide the reference text window. Mes-
sage text is displayed in the reference language in this window.

This menu item is used to display and hide the reference text window. Recipe
text is displayed in the reference language in this window.

This menu item is used to display and hide the reference text window.  Hea-
der and footer text is displayed in the reference language in this window.

Window Under this menu item, you will find settings for customizing your screen.
This includes displaying more than one window on your screen simulta-
neously, for instance.

Menu items

Options →
Default Setting

Screen →
Reference Text

Messages → 
Attribute Window

Messages → 
Reference  Text

Recipe → 
Reference Text

Headers and 
Footers → 
Reference Text

Working with Pro Tool/Lite



4-9
ProTool/Lite User’s Manual
Release 09/96

4.4 Information Functions

Pro Tool/Lite contains functions that provide information about the entire
configuration. These items are listed below:

Here you will find general details relating to the project: Device, date crea
ted, author etc.

Following compilation or download of a configuration, the storage space re
quired for that configuration on the OP is displayed.

If there is a link to the OP, the current firmware release of the OP is dis
played.

The objects that refer to each other are displayed. If, for example, you wish
to delete a variable which is being used in a field, you find the associated
field by means of Cross-Reference. Double-click on the specified field to
have ProTool/Lite jump directly to the field.

Summary

File → 
Project Information

System → Memory
Requirements

System → 
Parameters → 
Firmware

Options → 
Cross–reference

Working with Pro Tool/Lite
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4.5 Dialog Boxes

When you open a dialog box, only the essential settings are visible initially.
Optional settings may be accessed by clicking a button. Clicking a button
opens yet another dialog box, which may contain more buttons.

An example of the structure of a dialog box is shown in Fig. 4-6.

Figure 4-6 Function Key Dialog Box

A description is given below of all the points that you have to remember
when you are using dialog boxes.

If there is an ellipsis (...) behind a name on a button – for example, in Fig.
4-6  Function... – ProTool/Lite branches to another dialog box when you
press the button.

If there is a check box in front of the name of the button, you branch by pres-
sing the button to an optional setting – for example, in Fig. 4-6 Function....
You can tell from the check box whether a configuration is available in the
dialog box: if there is a check mark in the check box, a configuration is avai-
lable; if the check box is not checked, no configuration is available.

Dialog boxes contain either OK and Cancel buttons or a Close button.

In the first case, you have two options for closing a dialog box – you can
close with or without saving.

To close a dialog box and to save any changes you may have made at the
same time, you have to exit from the dialog box by pressing the OK button.

Settings

Branching to other
dialog boxes 

Closing a dialog
box

Working with Pro Tool/Lite
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If you exit from the dialog box by pressing the Cancel button, any changes
you may have made are lost.

In the second case, the Close button is used to close the dialog box. In this
type of dialog box, any changes you may have made take immediate effect.
In other words, changes do not have to be explicitly saved.

Working with Pro Tool/Lite
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Configuring with ProTool/Lite

You configure the different OPs in basically the same manner. Before you
can start work on your configuration, you have to set the device type – for
example, OP5. You are now offered only the functions that are available with
this device type. You cannot modify the device type for this configuration
once it has been set.

With the menu item File  → Convert, you can convert configurations as fol-
lows:

� from an OP5 to an OP7 and

� from an OP15C to an OP17.

Note

Re-conversion is no longer possible.

The items that you configure are individual objects. We distinguish between
different types of object, such as messages, screens, variables, etc. A separate
editor is available for every type of object. 

The link to the PLC is established by means of variables. Variables are used
on screens and in recipes and messages to read values from the PLC and to
display them on the OP. Similarly, variables may be used to write values to
the PLC.

Information text can be configured to provide the OP operator with additional
information about individual objects.

General settings for the system and the communication areas in the PLC have
to be performed centrally.

Upon completion, the configuration has to be downloaded to the OP. In this
procedure the configuration is first compiled. Compile means that an OP-
readable version is created.

Device type

Object types

Variables

Information text

General settings

Compiling, 
downloading

5
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5.1 Procedure for Configuration

A configuration has to be created step by step. Certain steps are mandatory,
others are optional.

An explanation is provided in the following of the different configuration
steps in the order in which they have to be performed. This is followed by a
list of the settings required for configuring different functions.

Figure 5-1 shows the basic details that have to be provided in respect of the
Operator Panel and the Controller in a configuration. They in clude

– OP type,

– display resolution,

– type of PLC to which the OP will be connected,

– protocol which the PLC and OP will use to communicate with each
other,

– communcation areas.

OP type PLC
Communication

Display
resolution

Objects

Communication
data areas

Addresses

Hardware
and 
driver

General
settings

Process
visualization

Configuration: OP-specific
components

PLC-specific
components

Figure 5-1 Basic Structure of a Configuration

The visualization of the process is performed by using objects, such as
screens and messages. These objects are supplied with current values by the
PLC. The values are set by means of addresses.

Introduction

Required details

Objects

Configuring with ProTool/Lite
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You create your configuration on a PC or PU and then download it to the OP.
The procedure for configuration is specifically as follows:

1. Set device type.

After a new configuration has been opened, the dialog box for selecting
the device is opened. At this point you set the type of OP. The other items
displayed by ProTool/Lite thereafter are device-specific.

For the OP15C, you set the display resolution – the number of lines and
the number of characters per line – at this point.

2. Set PLC and communication protocol.

You must specify in the configuration the PLC to which the OP will be
connected and the protocol which the OP and the PLC will use to commu-
nicate with each other. This is done by choosing System → PLC from the
menu.

The PLC dialog box is displayed. All settings performed at this point are
saved under a symbolic PLC name. If you use a variable in an object, you
specify this symbolic name for the link to the PLC.

3. Enter communication areas (area pointers).

For the OP and the PLC to be able to communicate with each other, you
must define commonly used data areas. These data areas are termed com-
munication areas. They are entered by choosing System → Area Pointers
from the menu. The communication areas you enter depend on the types
of object that are being configured. Table 13-1 shows the dependencies.

It is vital that you create the interface area for the SIMATIC S5 PLC un-
der Area Pointers. You will find a detailed description in theCommunica-
tion User’s Manual.

4. Configure objects.

Now, configure the messages, screens and recipes required by your pro-
cess.

You will find a detailed description of how to configure screens, messages
and recipes in Chapters 7, 8 and 9.

You can create variables, which make the link to the PLC possible, either
directly by using the variables editor or you can leave them until such
time as you configure individual objects. If, for example, you create an
input field on a screen, you can call the dialog box for creating variables
by pressing the Edit button.

5. Compile configuration.

For the configuration to run on the OP, it must first be compiled. To do
this, choose in ProTool/Lite File → Compile from the menu.

During compilation, a check is made for inconsistencies in the configura-
tion. One inconsistency might be, for example, that a particular type of
object has been configured without the corresponding communication
area having been created.

Procedure

Configuring with ProTool/Lite
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6. Download configuration to OP.

You download the configuration to the OP by choosing File → Download
from the menu. Should there be a current, compiled version already, it is
downloaded. If a compiled version does not exist, the configuration is
first compiled and then downloaded.

To create a configuration for an OP5, proceed as follows:

1. Call the standard configuration for the OP5,  c:\prolite\stan-
dard\s_05.pdb , and rename it by calling File → Save As... from the
menu and save the standard configuration by giving it the project name
quickmix.pdb .

2. Choose System → PLC from the menu to set the PLC.

3. Press the Edit button. The Driver dialog box now appears. We want to
establish the connection is over AS511.

4. Press the Parameters button. The SIMATIC S5-AS511 dialog box is now
displayed.

5. Select in the SIMATIC S5-AS511 dialog box, for example, CPU Type:
S5 115 CPU944  
if you wish to connect the OP5 to that PLC.

6. If you close the dialog box by clicking  OK, the settings are applied. Do
exactly the same in all the other dialog boxes which you may have
opened in the meantime. Exit from the PLC dialog box by clicking the
Close button in order to apply all the settings.

7. Choose System → Area Pointers from the menu to configure the interface
area, DB-TDOP.

8. In the Type field, you will see that Interface Area has already been se-
lected. Press the Add key. A dialog box having the title Interface Area is
opened.

9. Enter the following values in the Interface Area dialog box:
DB: 51 , Length: 255 . This means that DB51 is the Interface Area.

10. Exit from the Interface Area and Area Pointers dialog boxes  by choosing
OK to save the settings.

11. Configure a screen (refer to chapter 12)

12. Choose File → Save from the menu to save the file.

13. Choose File → Compile from the menu to compile the configuration.

14. Connect the OP to your PC or PU. Choose File → Download from the
menu to download the configuration to the OP.

Example for
SIMATIC S5

Configuring with ProTool/Lite
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5.2 Special Features of STEP 7 Integration

If you have installed ProTool/Lite as being integrated, you can access the
same database with ProTool/Lite as with the engineering tools of STEP 7.
You assign your symbolism only once and use it everywhere. This saves you
repeated inputs.

The communication parameters of the PLC are applied directly to your confi-
guration. When you are configuring variables and area pointers, you access
the STEP 7 text or graphic list.

You call ProTool/Lite as follows:

1. Start the SIMATIC Manager.

2. Select an S7 project or create a new one.

3. Choose Insert → Hardware → COROS OP from the menu. The ProTool/
Lite project OP1 is created.

4. Double-click on OP1 to start ProTool/Lite.

You can copy, move and delete the ProTool/Lite project in the SIMATIC
Manager.

Note

The project name and the object name in STEP 7 must be different or else an
error message points out to you that the object cannot be saved.

When you are configuring variables, the STEP 7 symbol table is displayed
for you. When you click on a symbolic name, the name and the complete
address are applied automatically to the configuration.This is illustrated in
Figure 5-2.

STEP 7 integration

Calling ProTool/
Liteite

Using the 
symbol table

Configuring with ProTool/Lite
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Figure 5-2  Variable Dialog Box with Embedded STEP 7 Symbol Table

Select the PLC in the way you normally would. For the parameters, the
SIMATIC S7 – 300/400 dialog box (refer to Figure 5-3) displays all the net-
works, CPUs and FMs available in the STEP 7 project. Once you have selec-
ted the network and the CPU by means of symbolic names, the parameters
and addresses are entered for you automatically.

You can select the CPU symbolically only if you have placed it in an S7 sta-
tion using the SIMATIC Manager, assigned parameters to it and networked it.

Figure 5-3  SIMATIC S7 – 300/400 Dialog Box

If you have not yet created the configuration, you can type in the parameters.
To type in the parameters, select No Symbol.

Selecting 
the PLC

Configuring with ProTool/Lite
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The text or graphic lists and the address parameters are continuously updated
via the symbolic link. STEP 7 modifications are applied immediately.

Choose menu items File → New, File → Open and File → Save As...  in Pro-
Tool/Lite to open STEP 7 dialog boxes. By way of an example, Figure 5-4
shows the Open dialog box.

Figure 5-4  Open Dialog Box

In this dialog box, you can open ProTool/Lite projects. You can recognize
ProTool/Lite  projects by the icons preceding them

 . 
The dialog boxes for New and Save As... look alike, but they have different
functions.

When opening a ProTool/Lite project, specify in the Object Name entry field
an existing ProTool/Lite project. When creating a new ProTool/Lite project,
you can enter a new name having a length not exceeding 24 characters at this
point.

You cannot call projects under the SIMATIC Manager that have been created
as stand-alone projects. For these projects to be linked to a STEP 7 project,
they have to be integrated. To integrate these projects, choose in ProTool/Lite
File → Integrate from the menu. Give the ProTool/Lite project a different
name in the STEP 7 configuration from that in the original project.

ProTool/Lite can still be started as a stand-alone program if you call ProTool/
Lite setup and choose Standalone. If you wish to modify this setting in Setup,
ProTool/Lite is not re-installed, only the link to STEP 7 is canceled.

Updating

Menu File

Integrating 
projects

ProTool/Lite
Standalone

Configuring with ProTool/Lite



5-8
ProTool/Lite User’s Manual

Release 09/96

In this example, you will create a ProTool/Lite project, including all the pre-
liminary work for connecting the OP to the S7 PLC.

1. Create a new STEP 7 project called PROLITE in the SIMATIC Manager.

2. Select the PROLITE project. Then, choose  Insert → Hardware → SIMA-
TIC 300 Station from the menu. The SIMATIC 300 Station1 icon appears
in the SIMATIC Manager.

3. If, when you are creating the PROLITE STEP 7 project, the icon for an
MPI network does not appear, choose Insert → Subnet → MPI Network.

4. Select the SIMATIC 300 Station1 icon and choose Edit → Open Object
from the menu. The Hardware Configuration dialog box appears.

5. Open the hardware catalog by choosing View → Catalog from the menu.

6. In the hardware catalog, click the + sign preceding SIMATIC 300 and then
the + sign preceding RACK 300. Then, select Mounting Rail and drag it
into the empty, blue bar of the Hardware Configuration dialog box. The
first line (expansion slot 0) of the configuration table appears; the rail is
entered on it.

7. Click on the + sign preceding expansion slot 0 to open the configuration
table completely.

8. Click in the hardware catalog on the + sign preceding CPU-300. Select
CPU314 and drag it to expansion slot 2 of the configuration table.
CPU314 is entered in expansion slot 2, and the line remains selected.

9. Choose Edit → Object Properties. The Properties – CPU 314 dialog box
appears.

10. Click the MPI button on the Properties card. The Properties – MPI Node
dialog box is opened.

11. Enable the Networked list box by clicking it. Select the MPI Network 1 
entry beneath it.

12. Then, close all the dialog boxes by clicking OK or by saving. In this way
you have created and networked the PLC to the extent required for Pro-
Tool/Lite. The STEP 7 symbol table has been created automatically.

13. To open it, click first on the + sign preceding the PROLITE project, on
the + sign preceding SIMATIC 300 Station1, on the + sign preceding
CPU314 and on the + sign preceding S7 Programm1. Select SY and then
choose Edit → Open Object. The symbol table is opened.

14. Make the following entries:
Symbol: Mixer1
Address: I0.1
The BOOL data type is entered automatically.

15. Save and then close the symbol table. You can use the Mixer1 symbol
later to configure a variable.

16. Open the ProTool project containing the standard configurations which
were supplied to you. Copy object OP15C 8*40  to your PROLITE pro-
ject.

Example: Creating
a ProTool/Lite 
project

Configuring with ProTool/Lite
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17. Double-click the Copy OP15C 8 *40  icon. ProTool/Lite is started and
the standard configuration for the OP15C is opened.

18. Choose System → PLC from the menu. The PLC dialog box is opened.
By default, the SIMATIC S7-300/400 PLC is entered at this point in the
case of STEP 7 integration.

19. Now, first click the Edit button and then the Parameters button. The
SIMATIC S7 300/400 dialog box appears.

20. Select the entry MPI Network1 in the Connect OP to Network list box.
This entry now appears in the Select Communicating Peer list box.

21. Click in the Select Communicating Peer list box on the + sign preceding
the MPI Network1 entry. The entry CPU314 (S7 Program1) appears.

22. Select the CPU314 (S7 Program1) entry and close all the dialog boxes
dealing with the PLC by clicking OK or Close. The connection between
the OP and the PLC is thus established.

23. Double-click in the editor window on Variable. The Variable dialog box
appears.

24. In the PLC selection box, choose PLC_1. In the Symbol list box, you will
now see the Mixer1 symbol from the STEP 7 symbol table. Double-click
this symbol. The following values are applied to the dialog box:
Mixer 1  in the Name entry field
BOOL in the Type list box
I  in the Area list box
0 in the E entry field
1 in the Bit entry field

Configuring with ProTool/Lite
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5.3 The Most Important Objects and Their Settings

When a particular type of object – for example, messages – is configured, it
is not sufficient merely to edit the messages. Other inputs, concerning com-
munication, method of presentation on the OP and printout, have to be made.
Table 5-1 lists the most important types of object and the settings required for
them.

Table 5-1 Objects Used and the Necessary Settings

Objects Used Associated Settings Menu Item or Dialog Box

PLC PLC type, protocol
Interface data block
(SIMATIC S5 only)

System → PLC
System → Area Pointers

Event messages Event message area System → Area Pointers

Message display System → Parameters → Messages

Message printout Messages → Attributes window
System → Parameters → Messages

Message buffer System → Parameters → Messages

– Text

– Output

– Symbolic output

Edit text

Variable

Variable and text list

Messages → Edit/Insert Field

Messages → Edit/Insert Field

Alarm messages Alarm message area System → Area Pointers

Acknowledgment area System → Area Pointers

Message display System → Parameters → Messages

Message printout Messages → Attributes window
System → Parameters → Messages

Message buffer System → Parameters → Messages

– Text

– Output

– Symbolic output

Edit text

Variable

Variable and text list

Messages → Edit/Insert Field

Messages → Edit/Insert Field

Details of object
type

Configuring with ProTool/Lite
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Table 5-1 Objects Used and the Necessary Settings

Menu Item or Dialog BoxAssociated SettingsObjects Used

Screens

– Text

– Input/Output

– Symbolic
  Input/Output

– Functions

Edit text

Variable

Variable and text list

Soft key

 

Screen → Edit/Insert Field

Screen → Edit/Insert Field 

Fx button in screen entry

Call screen using

function keys 
or

soft key
or

Scheduler

System → Screen/Keys
Select Screen function

Select Screen function

Scheduler
Select Screen function

Recipes Data mailbox

Recipe number mailbox

Recipe mailbox

Successive recipe mailbox

System → Area Pointers

System → Area Pointers

System → Area Pointers

System → Area Pointers

– Text

– Input

– Symbolic input

Edit text

Variable

Variable and text list

Recipe → Edit/Insert Field

Recipe → Edit/Insert Field

Call recipe using

function keys 
or

soft key

System → Screen/Keys
Select Data Record function

Select Data Record function

Configuring with ProTool/Lite
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5.4 Editors for Different Object Types

A configuration consists of different objects. We distinguish between differ-
ent types of objects, such as event messages, alarm messages and screens.
ProTool/Lite makes a separate editor available for every type of object. There
are editors for

– screens,

– event messages,

– alarm messages,

– variables,

– recipes,

– scheduler,

– symbol lists,

– headers and footers.

Figure 5-5 shows the box from which you can choose the editors.

Figure 5-5 The Editors of ProTool/Lite

Objects such as screens, variables and text or graphic lists are saved under a
symbolic name. The symbolic name is valid only for that configuration. You
have to specify this symbolic name whenever you create, delete and edit ob-
jects or reference objects from within other objects. Symbolic object names
are displayed under Objects in the Editors box.

Symbolic object names may have default settings and may be numbered au-
tomatically. The default settings may be entered by choosing Options → 
Default Setting from the menu. Default settings were performed before Pro-
Tool/ Lite was shipped.

Editors in ProTool

Symbolic 
name
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Variables and symbol lists can also be configured directly for messages and
screens. If you wish to configure variables or symbol lists separately, select
the corresponding dialog boxes from the editors.

The user interface of the different editors is adapted to the specific configura-
tion of the various types of objects. A detailed description will be found else
where in this document. A brief summary is presented below.

A screen consists of several entries. Soft keys are assigned to every screen
entry and can be assigned with different functions for specific entries. Soft
keys are arranged directly beneath an entry. This means that the assignment
of screen entry and soft key is unambiguous.

Values are always based on variables which define the link to the PLC. The
OP reads a value from the PLC and displays it in its configured form. In the
case of inputs, a value is sent to the PLC. Fig. 5-6 shows a configured screen
with fields and assigned soft keys.

Variables

Figure 5-6 Configured Screen in Screen Editor (Example)

Event messages and alarm messages are used to display operating states and
malfunctions in the process. Values, too, can be output in event messages and
alarm messages.

Variables and 
symbol lists

Object types

Screens

Event and alarm
messages
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Figure 5-7 Configured Alarm Messages

Variables form the link to the PLC. They contain the address in the memory
area of the PLC. From these addresses, the OP reads values or it writes values
to them.

The Variable dialog box is PLC-specific. Depending on the PLC that you set,
the appropriate data types and addresses are presented to you. An example of
a variable configured for the SIMATIC S5 is shown in figure 5-8.

Figure 5-8 Variable Configured for the SIMATIC S5

Recipes are groups of technologically associated PLC setpoints for a specific
application. Data are assigned to the configured data structure on the OP. Fi-
gure 5-9 shows a configured recipe.

Variables

Recipes

Configuring with ProTool/Lite
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Figure 5-9 Configured Recipe

A scheduler defines a regularly recurring point in time at which a specific
function is required to be executed. The following types of scheduler times
are available:

� hourly,

� daily,

� weekly or

� annually.

Table 5-2 shows the time entries that are required for the different types of
scheduler.

Table 5-2 Time Entries Required for Different Types of 
Scheduler 

Scheduler Type Essential Time Entries

Hourly Minute

Daily Hour, minute

Weekly Day of week, hour, minute

Annually Month, day, hour, minute

Should you subsequently wish to modify or de-activate the scheduler time,
you can insert it in a screen entry. When a scheduler time has elapsed, the
corresponding scheduler bit is set on the PLC (in the interface area) and the
configured function is executed.

Scheduler

Configuring with ProTool/Lite
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The functions available are:

� Print event buffer

� Print alarm buffer

� Select screen

� Print screen

� Print recipe.

A function does not necessarily have to be configured. If no function is confi-
gured, only the scheduler bit is set when the scheduler elapses.

Figure 5-10 shows a configured scheduler time.

Figure 5-10Configured Scheduler Time

Symbol lists are required for symbolic input/output. In this instance text is
assigned to the value of a variable. The text appears on the OP.

Headers and footers can be edited on the OP for printout. Two lines contain-
ing 80 characters are available in both cases. You can use both text and
fields.

Symbol lists

Headers and 
footers

Configuring with ProTool/Lite



5-17
ProTool/Lite User’s Manual
Release 09/96

You can initiate different printouts on the OP. These printouts are for:

Message log
Every message that arrives, departs or is acknowledged is output to the
printer. For this, the Print attribute has to be checked for the message.

EM Chronological
The event buffer is printed in the chronological order of the messages.

EM Together
The event buffer is printed in message number order.

AM Chronological
The alarm buffer is printed in the chronological order of the messages.

AM Together
The alarm buffer is printed in message number order.

Overflow
Messages are deleted automatically when a buffer overflows. Depending on
the system setting, such messages are then output to the printer.

Print screen
A selected screen is printed.

Print recipe
A selected recipe is printed.

Configuring with ProTool/Lite
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5.5 Copying to and from the Clipboard

Sections of configurations can be copied to the Clipboard for pasting within
an editor or for pasting into other editors. You can even copy from one proj-
ect to another. This affects message text and screen entry text, as well as soft
key assignments. Variables cannot be copied between projects.

If you select text in a message, a screen entry or a recipe entry, you can copy,
cut and paste it in the same way as with other Windows applications. If you
select the whole message or the whole screen entry by clicking the number
area, attributes and information text are copied as well.

Selected parts can be moved and copied using drag and drop editing. Move
the mouse to the highlighted text and click the left mouse button.

� To move the text, proceed as follows:
Hold down the mouse button and drag the mouse pointer to the new loca-
tion.

� To copy text, proceed as follows:
Hold down the mouse button, press the CTRL key at the same time and
drag the mouse pointer to the new location.

Variables may be assigned to fields on screens or in messages. If you copy a
field from one configuration to another, the symbolic name of the variable is
retained. The values of variables are lost, however.

Let us assume that you are copying variable_XX from Configuration_1 to
Configuration_2.

� If there still is not a variable with this symbolic name in Configuration_2,
variable_XX is created with the default values of Configuration_2.

� If there is a variable with this symbolic name already, then that variable is
used.

Scope

Cutting,
copying,
pasting

Example of 
copying with 
variables
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5.6 Assigning Function Keys

You can assign functions to function keys in your configuration. Click the
function key displayed on the screen. The Function Key - Fx dialog box is
opened. With the Function button, select the function call you require for key
assignment from the list of functions.

You can assign two types of function key: global and local. Local assign-
ments have priority over global ones.

Global signifies that the assignment applies to the whole configura-
tion.

Local signifies that the assignment applies only to individual
screens. Function key assignments may vary from one
screen entry to another. In this way you can have functions
initiated in keeping with the situation.

A function key, whose assignment may vary depending on
the screen entry, is referred to as a soft key.

Always place functions that must always be at hand on function keys, never
on soft keys.

Soft keys are the keys that are directly located under the screen entry. You
can assign the following keys as soft keys on the different OPs:

OP3 Keys F1 to F5 of the function keyboard.

OP5 Keys F2 to F5 of the function keyboard.

OP7 Keys F1 to F4  and K1 to K4 beneath the 
display.

OP15 Keys F1 to F8 beneath the display.

OP17 Keys F1 to F8  and K1 to K8 beneath the 
display.

You assign soft keys in the editor. You can assign an icon to a soft key that is
labeled with text or a graphic.

Global function keys are assigned only by choosing System → Screen/Keys
from the menu. The following keys can be assigned as function keys for the
different operator panels:

OP5 Function keys  F1 to F6 .

OP7 Function keys  F1 to F4 and K1 to K4.

OP15 Function keys K1 to K16 .

Assigning

Soft keys

Function keys
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OP17 Function keys  F1 to F8 and K1 to K16.

Function keys may have two assignments:

– for single key operation

– for SHIFT + key operation.

You can note the functions you have assigned to keys on labeling strips.

The F and K keys of Operator Panels OP7 and OP17 can be configured as DP
direct keys. DP direct keys means that set bits are passed directly (unpacked)
over the L2-DP bus to the PLC. The response time in type mode is about
< 100 ms. DP direct keys are configured by means of STEP 7.

In order to be able to use the F and K keys as DP direct keys, set CPU type
SIMATIC S7-300/400 by choosing System → PLC → Edit from the menu.
Select communication type DP  by choosing Parameters  and then Profile.

Note

To use the DP direct keys, the OP7 or OP17 must have been configured as an
active DP slave in the L2-DP network.

You will find details of the assignment of PLC parameters for the connection
via L2-DP in the Communication User’s Manual.

DP direct keys

Configuring with ProTool/Lite
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Variables

Variables represent the lowest level in a configuration. You specify the ad-
dress on the PLC in variables. This means that variables are used to establish
the link to the PLC. Values are written to variables. This may be done from
the PLC or by means of an operator input.

Variables are used to display process values. They can be configured on
screens and in messages or recipes. To do this, you must insert a field to de-
fine how the variable is to be used. The variable itself defines only the ad-
dress on the PLC. The field defines how the variable is to be used – for input
or for output.

The setting for transferring the values of variables between the OP and the
PLC is as follows:

Polling time > 0 If a value greater than 0 is entered for the polling time of a
variable, the value of the variable is transferred within the
specified time.

Polling time is a multiple of the standard clock pulse in se-
conds. By default, the standard clock pulse is set to 200 ms.
If, for example, you enter a polling time of 0.8 s, it is four
times the value of the standard clock pulse. If you raise the
standard clock pulse to 400 ms by choosing System → PLC
from the menu, the specified polling time is increased to
1.6 s.

By raising the standard clock pulse, you can globally in-
crease the polling times of all the variables in a project.

Polling time = 0 If the polling time is entered as 0, the variable is read only
when a screen, message or recipe is called. It is then not
updated after that.

Definition

Usage

Updating

6
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6.1 Configuring a Variable

To configure a variable, select the Variables editor in the Editors dialog box.

In the Variable dialog box, enter the address from which the value you wish
to display will be read or to which it will be written.

When defining a field, you can use a variable that is already configured on a
screen, in a message or in a recipe. However, you can also configure the va-
riable when you define a field (see chapter 7, 8 or 9).

Apart from the address, you also have to set the PLC. Define the PLC under a
symbolic name by choosing System → PLC from the menu. You specify this
name in the Variable dialog box. The complete address setting depends on
the PLC you are using.

To configure a variable, proceed as follows:

1. Select the Variables editor in the Editors dialog box. The Variables dialog
box is opened.

Figure 6-1  Dialog Box

2. The Name field displays the symbolic name together with the next free
number. If you have still not configured any variables in this project,
Var_1  is displayed in this field.

Setting an address

Setting 
the PLC

Example for 
SIMATIC S5

Variables



6-3
ProTool/Lite User’s Manual
Release 09/96

3. Enter the following values in the Variable dialog box:
DB: 10
DW: 2
Format: KF
PLC: PLC_1

4. Exit from the Variable dialog box by clicking OK.

5. The entry VAR_1 appears under Objects in the right column of the Edi-
tors dialog box.

Variables
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6.2 Setting Limit Values of a Variable

For every variable, you can configure an upper limit value and a lower limit
value. If you enter a value outside the configured limit values, the input is not
accepted. Upper and lower limit values are set in the Limit Values dialog box.
Figure 6-2 shows the dialog box. Configured limit values are possible only in
input and input/output fields.

Figure 6-2 Limit Values Dialog Box

Under Upper/Lower Limit Values, you can choose whether there is to be an
upper limit value and/or a lower limit value for the variable that you config-
ured. By default, the setting is disabled. You can define whether the specified
limit value is determined by a constant or a variable  (OP3, OP7 and OP17
only). If you specify a limit value variable, it must have the same format as
the corresponding variable.

Limit values for variables are entered without a decimal point. Depending on
whether digits behind the decimal points are specified for the variable, the
constant for the limit value is interpreted in different ways. The same number
of digits behind the decimal points as specified is taken to be the number of
digits behind the decimal points for the limit value as well.

Configured Digits 
behind Decimal Points

Limit Value Input Interpretation
by ProTool

0 2222 2222

1 2222 222.2

2 2222 22.22

Upper and lower 
limit values

Interpretation of 
digits behind the
decimal points

Variables
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6.3 Using the STEP 7 Symbol Table

In STEP 7, you can assign informative symbolic names, called symbols, for
addresses. Symbols are stored together with the data type, address and com-
ments in a symbol table. You can use a symbol contained in the symbol table
in ProTool/Lite for configuring a variable.

A symbol contained in the symbol table may also be a structured data block,
which you can open by double-clicking.

The requirements for using the symbol table are as follows:

1. You have installed ProTool/Lite integrated into STEP 7 under Win-
dows95.

2. You have assigned parameters to an S7 PLC connection in ProTool/Lite
and selected an S7 CPU at that point (refer to section 5.2). This means
that the corresponding STEP 7 symbol table has been set.

3. Symbols have already been created in the STEP 7 symbol table.

To apply symbols from the STEP 7 symbol table, open the Variable dialog
box. The symbols contained in the symbol table are now listed in the Symbol
box.

The following entries are applied to the dialog box as soon as you select one
of the symbols:

� the symbol name, as the name of the variable

� the address and

� the data type.

You can modify the name of the variable later without the link to the symbol
table being lost. Modifications to the symbol table in STEP 7 are applied to
ProTool/Lite after the STEP 7 symbol table has been saved.

Figure 6-3 shows the Variable dialog box with the STEP 7 symbol table.

Definition

Requirements

Applying symbols
for setting varia-
bles

Variables



6-6
ProTool/Lite User’s Manual

Release 09/96

Figure 6-3  Variable Dialog Box with Embedded STEP 7 Symbol Table
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Screens

Screens represent a summary of process values for displaying process execu-
tion and specifying values for a process. Process values can be randomly
sorted according to subject matter. With screens, entered values are immedi-
ately transferred to the PLC.

A typical screen might be:

Figure 7-1 Configured Screen in ProTool/Lite

Screens are created with their own editor. Every screen is stored under a sym-
bolic name. The name is entered by choosing Screen → Attributes from the
menu. You must specify this name whenever you wish to edit, reference or
delete the screen. In addition, the screen is automatically given a number
which can be modified.

You can configure one or more screen entries on a screen. A screen is the
same size as the display. The entry numbers are shown in the left margin of
the Screens editor (refer to Figure 7-1). The maximum number of screen en-
tries on a screen depends on the OP you are using.

An entry consists of static text and/or fields. Fields may contain variables, the
date, time or a scheduler. Text such as variables can be freely configured.
The link to the PLC is established by means of variables.

Definition

Screen editor

Components of a
screen
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7.1 Configuring Fields

When configuring a screen entry, you can use the following field types:

Input fields With input fields, the operator enters a value on the OP
which is transferred to the PLC. The value can also be en-
tered in symbolic form as text.

Output fields With output fields, values are read from the PLC and dis-
played on the OP. The value can also be output in symbolic
form as text.

Fields for date and time are special fields which are not
linked to the PLC. In these fields, the OP date and time is
displayed.

Input/ With input/output fields, values are read from the PLC.
output fields Simultaneous inputs are possible in this type of field on the

OP. Symbolic inputs and outputs are possible here too.

The objects that can be entered in the different field types are shown in Table
7-1.

Table 7-1 Field Types Possible for the Different Objects

Field Type Used for Display

Output Variable Value,
symbol

Date Value

Time Value

Input Variable Value,
symbol

Scheduler Value

Input/output Variable Value,
symbol

Field types

Screens
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To configure fields, choose Screen → Edit/Insert Field from the menu. The
Input/Output dialog box appears (refer to Figure 7-2).

Figure 7-2 Input/Output Dialog Box

In this dialog box, you set how a field is displayed on the OP. To do this, you
have to specify the following three items:

Usage Here you set whether a link to the PLC exists by using a
variable or the field is used to display the date, time or a
scheduler.

Field type Here you set whether a field is an input field, an output field
or an input/output field.

Display Here you set how the contents of a field will be displayed –
as a value or a symbol. When values are set, you can choose
between different formats – for example, decimal, hexade-
cimal or string.

If you select the entry Text Symbol for Display, you can assign a symbolic
display to a field. In symbolic fields, text is displayed instead of values. Text
is assigned to the values of a variable in the configuration.

For example, to switch a motor on and off, the values of the variable are not
self-explanatory. Text is easier for the operator to understand. The assignment
of values and text might be as follows:

0 OFF
1 SLOW
2 FAST

The OP does not display a value 0 but the corresponding word – OFF.

Configuring 
fields

Configuring fields
with symbolic  dis-
play

Screens
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Symbolic inputs and outputs are entered by means of symbol lists. The dialog
box changes in the case of a symbolic field as shown in Figure 7-3.

Figure 7-3 Text Symbol Setting for Symbolic Display

To edit the symbol list, choose List and click the Edit button. The Symbol List
– Text dialog box is opened, and you can edit text in the dialog box. Figure
7-4 shows the dialog box in which the previous example was configured.

Figure 7-4 Symbol List – Text Dialog Box

Editing the symbol
list

Screens
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7.2 Integrating Screen with the Operating Process

For it to be possible to call a screen on the OP, it has to be integrated with the
operating process of the OP. There are two ways in which this can be done:

1. You assign the Select Screen function to a function key or soft key. Spec-
ify the name of the screen that you wish to call as the parameter. In doing
so, ensure that the configured function is valid only for the screen entry
concerned in the case of soft keys. With function keys, it applies to the
whole project.

2. The screen is included in the screen directory. To do this, call Screen →
Attributes on the menu. Check the Screen to Directory field. You can now
select the screen on the OP under the standard screen Screens → Edit.

When you choose the Title button, you can give the screen a name, which
will then appear in the screen directory.

One of the screens has to be declared as the start screen. This is the screen
which is called when you branch on the OP from message level to screen
level. To do this, call Screen → Attributes on the menu. Check the Start
Screen field.

Methods of 
selecting screens

Start screen

Screens
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7.3 Example of Configuring a Screen Entry

In this example you will configure a screen having a screen entry. This screen
will be the start screen.

1. Call the Screens editor.

2. Position the cursor on the first entry.

3. Edit the following text:
Speed, mixer: .

4. To insert an input field, choose Screen → Edit/Insert Field  from the
menu. The Input/Output dialog box appears.

Figure 7-5 Input/Output Dialog Box

5. Under Usage:, select Variable.

6. Under Field Type:, select Input.

7. Under Display:, select Decimal.

8. In the variables field, enter the symbolic name Var_1.  Click the Edit but
ton to edit a variable. The Variable dialog box appears.

Example for
SIMATIC S5

Screens
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Figure 7-6 Variable Dialog Box

9. In the Variable dialog box, enter the following values:
DB: 10
DW: 4
Format: KF
PLC: PLC_1

10. Exit from the Variable and Input/Output dialog boxes by clicking OK.

11. The screen entry now looks as follows:

12. Press RETURN and enter blanks until the cursor is located under VAR_1.

13. Now configure the output field. To insert an output field, choose Screen
→ Edit/Insert Field from the menu. The box Input/Output dialog box ap-
pears.

14. Under Field Type:, select Output.

15. Under Usage:, select Variable.

16. Under Display:, select  Decimal.

17. Enter the symbolic name Var_2 in the Variables field. Click the Edit but-
ton to edit a variable. The Variable dialog box appears.

18. Enter the following values in theVariable dialog box:
DB: 10
DW: 5
Format: KF
PLC: PLC_1

19. Exit from the Variable and Input/Output dialog boxes by clicking OK.

20. The screen entry now looks as follows:

Screens
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21. Choose  Screen → Attributes from the menu. Select the Start Screen
check box. This makes this screen the start screen.

Figure 7-7 Screen Attributes Dialog Box

Screens
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7.4 Assigning Soft Keys

You can assign soft keys for each screen entry. That means that you as sign a
function to a soft key. Soft keys can be used to call another function, for ex-
ample, to jump to a screen entry within a screen or to call the message buffer.

The soft keys are shown directly beneath a screen entry. Next to the func tion
key there is a check box. If you have already configured the function key, the
check box is checked. Figure 7-8 shows that in entry 2 function key F1 has
been configured.

Soft key F1 is configured

Figure 7-8 Identification of Soft-Key Assignment

To assign a soft key in a screen entry, click one of the Fx keys beneath the
screen entry. The Function Keys dialog box appears (refer to 7-9). You can
assign a bit in a variable and/or a function to a soft key.

Figure 7-9 Function Keys Dialog Box

Usage

Assigning

Screens



7-10
ProTool/Lite User’s Manual

Release 09/96

If you assign a bit to a soft key, the bit is set in the variable when you press
the key. The bit is reset by releasing the key. If the address of the variable
refers to a data word or a data byte, several keys can be assigned to a vari-
able. These keys can then be pressed simultaneously on the OP.

Click the Function... button in the Function key dialog box. The Functions
dialog box shown in figure 7-10 appears. In the dialog box, select a function.
A brief explanation of the function and its parameters is shown in the De-
scription field.

Figure 7-10 Example of Soft-Key Assignment

By way of an example, select the Select Screen function. With the Select
Screen function you can branch from one screen to another, thus establishing
your process-specific screen hierarchy. If you click on the key having the
double-headed arrow, the function is transferred to the display field on the
right. Click on the Parameters button and enter PIC_3, for example, as the
parameter. This screen must exist already; if it does not, you cannot select it.

If the operator has to be able immediately to recognize which function has
been assigned to the soft key, the description of the soft key is shown on the
display. There are several ways of doing this, for example.

� In the screen entry, text is arranged immediately above the key – for ex-
ample, ON, OFF.

� In the screen entry, a line denotes the key to which the lettering refers.

� The description of the soft keys is contained in information text
associated with the screen entry.

In any case, make sure that lettering and keys are clearly assigned. 
Figure 7-11 shows two ways in which you can describe soft keys.

Bit in variable

Functions

Description of soft
key

Screens
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Figure 7-11 Examples of Naming Soft Keys for OP15

On Operator Panels OP7 and OP17 there are two rows of soft keys. You can
use the superimposed keys to switch a drive on and off, for instance (Figure
7-12).

Figure 7-12Examples of Naming Soft Keys for OP7

Screens
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7.5 Using Standard Screens

When ProTool/Lite is installed, one of the items installed is a configuration
with ”standard screens”. You require this configuration if you wish to use
standard functions on the OP. The standard screens are listed in Chapter 16.

Note

If you do not build on top of the standard configuration, you have to config-
ure system function calls yourself.

If you wish to use one or more of the standard screens in your configuration,
you must proceed from the standard configuration for the OP concerned.
Since screens cannot be copied from one screen to another, copy your stan-
dard configuration. Use this copy for your work. You copy a configuration by
saving it under a different name in ProTool/Lite.

Standard screens are arranged hierarchically. You branch to all other standard
screens from the Z_SYSTEM_MEN standard screen. It thus suffices to assign
this Z_SYSTEM_MEN to a function key. You can then select all other stan-
dard screens on the OP. 

In the standard configuration supplied to you, the standard screen known as
Z_SYSTEM_MEN is configured as the start screen. When you edit your pro-
cess-specific configuration, you will most certainly wish to create your own
start screen. If you wish to use the standard screens, you have to integrate
them in  the configuration first. It is sufficient to call the standard screen
known as Z_SYSTEM_MEN by means of a soft key or a function key. Select
the ”Select Screen” function and specify Z_System_men  as the parameter.

Why
standard screens?

Standard screen
hierarchy

Screens
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7.6 Detecting a Called Screen on the PLC

To be able to detect on the PLC the screen that has just been called on the
OP, you have to create a Screen Number area on the PLC. The OP stores in-
formation in the screen number area about the screen called on the OP.

In this way it is possible to transfer information about the current display
contents of the OP to the PLC and to initiate specific reactions on the PLC –
for example, calling another screen or selecting an LED.

If you wish to use the screen number area, you have to specify it during
configuration as Area Pointer  – Type Screen Number.
It can be created only on one PLC – and once only.

The screen number area is transferred spontaneously to the PLC, i.e. a 
transfer takes place whenever a change is registered on the OP.

There is therefore no need to configure a polling time.

The screen number area is a data area having a fixed length of five data
words. The structure of the screen number area is displayed below.

Current screen type

Current entry No. Current input field No.

Current screen No.1st word

2nd word

Entry Assignment

Current screen type 1: Screen
2: Recipe
3: Function screen

Current screen/recipe number 1 to 99

Current entry number 1 to 99

Current input field number 0 to 8 (0: entry field number)

At message level, at menu level and when a directory is being displayed, all
the bytes of the screen number area are assigned with FF�.

With function screens, the screen number area is assigned as follows:

3 Function screen No.

FFH Current input field No.

1st word

2nd word

Application

Condition

Structure

Screens
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Messages

The user defines which messages are event messages and which are alarm
messages. Alarm messages have priority. Event messages and alarm messa-
ges are initiated by the PLC. They contain information about events and sta-
tes in the control process. Alarm messages have to be acknowledged on the
OP. After being issued, event messages and alarm messages are stored on the
OP in separate message buffers. Stored messages can be displayed on the OP
and output to an attached printer.

Event messages have a special feature – event message No. 0 is the standby
message.

Typical event messages and alarm messages might look as follows:

Figure 8-1 Configured Event Message in ProTool/Lite

Figure 8-2 Configured Alarm Message in ProTool/Lite

Separate editors are available for creating event messages and alarm messa-
ges. You can set the priority of a message or whether it should be acknowled-
ged or whether it should be printed in a separate Attributes dialog box.

A message consists of static text and/or variables. Text and variables can be
freely configured. Variables are used for the link to the PLC. Before you can
use variables in a message, you must first insert a field. Only output fields
can be used in messages.

Definition

Message editors

Components of a
message
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For event messages, an event  message area  must be defined in the configu-
ration, as must also an alarm message area for alarm messages. You set the
message area by choosing System → Area Pointers from the menu.

An event message or an alarm message can be configured for every bit in the
configured message area. When you create the address area for the message
area, the number of messages that can be created for it is displayed.

Every message area can be divided into several address areas. Table 8-1
shows the number of message areas for event messages and alarm messages,
the number of alarm message acknowledgment areas as well as the total
length of all the areas for the different OPs.

Table 8-1 OP Message Areas

Device Event Message Area Alarm Message Area and Alarm
Message Acknowledgment Area

Number Length ������� Total 
per Type

Overall Length 
per Type�������

OP3 4 32 – –

OP5 4 63 4 63

OP7 4 63 4 63

OP15 4 63 4 63

OP17 4 63 4 63

C7-623 4 63 4 63

C7-624 4 63 4 63

In the message editor, message numbers are listed in the left margin. A bit
number is assigned to every message number. Thus you can see immediately
the bit in the event or alarm message area to which a configured message
belongs. In addition, the address with which the message is associated is dis-
played on the status bar.

Message area

Message numbers

Messages
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Example for SIMATIC S5:
The association of the event message area and message numbers is shown in
the following with reference to an example. Let us assume that the following
event message area has been configured for the SIMATIC S5 PLC:

DB 60 Address 43 Length 5 (in DW)

Figure 8-3 shows the association of bit numbers and message numbers for
data words. Message numbers and bit numbers are associated automatically
on the OP.

�
�
� ����� �� ���

��	��
�
� ����� ��


��

�

�

�

���

Message number

Figure 8-3 SIMATIC S5:
Association of Bit Numbers and Message Numbers for Data Words

Example for the SIMATIC 500/505:
Let us assume that the following event message area has been configured for
the SIMATIC 500/505  PLC:

V 43 Length 5  (in words)

Figure 8-4 shows the assignment of all the 80 (5 �� 16) message numbers to the
individual bit numbers in the event message area of the PLC.

This assignment is performed automatically on the OP.

Data word 43 16�

80��Data word 47

�

�

�


�� 16�

����
��� ������

Figure 8-4 SIMATIC S500/505:
Association of Bit Numbers and Message Numbers for Data Words

Assigning mes-
sage numbers in
data words
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Example for SIMATIC S5:
The event message area can also be set in flag words. In the following exam-
ple, the event message area set is:

MW 50 Length 2 (in FW)

Figure 8-5 shows the association of message numbers and bit numbers for
flag words.


��
� ����� �� �


��
� ����� ��


��
� ��

Flag No. Message No.

F51.0 1
... ...
F51.7 8
F50.0 9
.. ...
F50.7 16
F53.0 17
... ...
F53.7 24
F52.0 25
... ...
F52.7 32

������	�������	


��
� ��

�


��
� ��

������	�������	


��
� ��

Figure 8-5 SIMATIC S5:
Association of Bit Numbers and Message Numbers for Flag Words

Assigning mes-
sage numbers in
flag words
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So that you can print messages on your printer, you have to check in your
configuration the Print attribute in the Attribute Window of the message 
editor for every message you want to have printed. By choosing System →
Parameters → Messages from the menu, you can perform the following set
tings for printing messages:

� Messages: The printing of all events is enabled.

� Off: Message printing is disabled.

� Overflow: When a message buffer is full, the OP deletes messages before
new ones are entered. If the Overflow field is checked, all the messages
are printed prior to deletion. This is done irrespective of whether the Print
attribute has been set.

If you choose System → Parameters → Messages from the menu and check
the Overflow Warning field, a warning is issued on the OP as soon as the
configured remaining space of the message buffer is reached or the space is
less than that configured. You can set the remaining buffer size.

Printout

Overflow warning

Messages
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8.1 Configuring Output Fields

With output fields, values are read from the PLC and displayed on the OP.
The value can also be output in symbolic form as text.

Output fields for the date and time are special fields that are not linked to the
PLC. These fields display the date or time of the OP.

The entries that can be performed for messages in output fields are shown in
Table 8-2.

Table 8-2 Possible Contents of Output Fields in  Messages

Field Type Used for Display

Output Variable Value,
symbol

Date Value

Time Value

To configure output fields, select Messages → Edit/Insert Field  from the
menu. The Output (Figure 8-6) dialog box appears.

Figure 8-6 Ouput Dialog Box

Output fields

Configuring 
output fields

Messages
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In this dialog box, you set how a field will be displayed on the OP. To do this,
you must specify the following three items:

Usage Here you set whether a link to the PLC exists by using a
variable or the field is used to display the date or time.

Field type At this point the only field type you can select is Output.

Display Here you set how the contents of a field will be displayed –
as a value or a symbol. When values are set, you can choose
between different formats – for example, decimal, hexade-
cimal or string.

If you select the Text Symbol entry for Display, you can assign a symbolic
display to a field. In symbolic fields, text is displayed instead of values. Text
is assigned to the values of a variable in the configuration.

To display the operating state, for example, of a motor in normal operating
mode or in the case of a malfunction, the values of the variables are not suffi-
ciently self-explanatory. Text is easier for the operator to understand. The
assignment of values and text might be as follows:

Event message Alarm message

0 OFF SWITCHED OFF

1 SLOW TOO HIGH

2 FAST TOO LOW

The OP does not display a value 0 but the corresponding word – OFF or
SWITCHED OFF.

Symbolic inputs are entered by means of symbol lists. The dialog box is mo-
dified as shown in Figure 8-7.

Configuring fields
with symbolic 
display

Messages
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Figure 8-7 Text Symbol Setting for Symbolic Display

To edit the symbol list, choose List and click the Edit button. The Symbol List
– Text dialog box is then opened, and you can edit text in the dialog box. Fig-
ure 8-8 shows the dialog box in which the previous example was configured.

Figure 8-8 Symbol List – Text Dialog Box

Editing the symbol
list

Messages
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8.2 Event Messages 

With event messages, the status of a bit in the PLC is evaluated by the OP. If
the bit is set in the PLC, an event message is initiated on the OP. The confi-
gurer defines the bits that will initiate an event message.

Event messages display a status such as

– Motor switched on

– Motor off

– Motor speed of xx/min reached

– PLC to manual mode

– Operating temperature of  xx reached

If a standby message having the number 0 is configured, it is interpreted to
be the standby message. The standby message is displayed whenever the
message level has been selected on the OP and neither an event message or
an alarm message is waiting.

The standby message is similarly displayed after an OP starts up. In the case
of the OP7 and OP17, it is displayed only when a start screen has not been
defined  in the configuration.

 The standby message may consist of text and/or fields. You can use just field
for date and time in the standby message.

In this example you will first configure the event message area, followed by
an event message with a field.

1. Choose System → Area Pointers from the menu to create the event mes-
sage area.

2. In the Type field, select the area pointer for Event Messages. Press the
Add key. The dialog box called Event Messages appears.

3. Enter the following values in the Event Messages dialog box:
DB: 12 , DW: 0, Length: 2. You have then created an event message
area for 32 event messages.

Definition

Usage

Standby message

Example for
SIMATIC S5
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4. Exit from the Event Messages dialog box by clicking OK to apply the
settings. Exit from the Area Pointers dialog box, similarly by clicking
OK.

5. Call the event message editor.

6. Position the cursor at message No. 1.

7. Edit the following message:
Motor speed of {Var_3}/min reached ,
where {Var_3}  is an output field.

8. To insert the output field, choose Screen → Edit/Insert Field from the
menu. The Output dialog box appears.

Figure 8-9 Output Dialog Box

Messages
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9. Under Usage:, select Variable.

10. Under Field Type:, select Output.

11. Under Display:, select Decimal.

12. Enter the symbolic name Var_3 in the Variables field. Click the Edit but
ton to edit a variable. The Variable dialog box is displayed.

Figure 8-10Variable Dialog Box

13. Enter the following values in the Variable dialog box:
DB: 10
DW: 3
Format: KF
PLC: PLC_1

14. Exit from the Variable and Output dialog boxes by clicking OK.

15. The following screen shows the edited event message.

Messages



8-12
ProTool/Lite User’s Manual

Release 09/96

8.3 Alarm Messages

With alarm messages, the status of a bit in the PLC is evaluated by the OP. If
the bit is set in the PLC, an alarm message is initiated on the OP. The confi-
gurer defines the bits which initiate an alarm message.

Alarm messages display an operating fault such as

– Motor temperature too high

– Coolant empty

– Valve will not open

– Fault, compressor 4

– Switch M208 open

Since alarm messages are used to display extraordinary operating states, they
have to be acknowledged. Alarm messages are acknowledged either by
means of an operator input on the OP or on the PLC.

The association of bit numbers and message numbers is exactly the same as
for event messages.

If the PLC is to be notified when an alarm message has been acknowledged
or when the PLC is required to acknowledge the alarm messages, you have to
create suitable acknowledgment areas by choosing System → Area Pointers
from the menu. The association of alarm messages and bit numbers in the
acknowledgment area is the same as for the alarm message area.

In the alarm message editor, message numbers are listed in the left margin. A
bit number is assigned to every message number. This means that you can
immediately see the bit in the alarm message area with which the configured
message is associated. In addition, the address with which the message is
associated is displayed on the status bar.

Definition
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Acknowledging

Acknowledgment
area

Message numbers

Messages



8-13
ProTool/Lite User’s Manual
Release 09/96

In this example you will first configure the alarm message area, followed by
an alarm message.

1. Choose System → Area Pointers from the menu to create the alarm mes-
sage area.

2. In the Type field, select the area pointer for Alarm Messages. Press the
Add key. The dialog box called Alarm Messages appears.

3. Enter the following values in the Alarm Messages dialog box:
DB: 12 , DW: 2, Length: 2. You have then created an alarm message area
for 32 alarm messages.

4. Exit from the Alarm Messages dialog box by clicking OK to apply the
settings. Exit from the Area Pointer dialog box, similarly by clicking OK.

5. Call the alarm message editor.

6. Position the cursor at message No. 1.

7. Edit the following message:
Motor temperature too high .

8. The following illustration shows the edited alarm message.

Example for
SIMATIC S5

Messages
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8.4 Options for Displaying Messages

Choose System → Parameters → Messages from the menu. Figure 8-11
shows the dialog box that is now opened. Here you will find one setting for
event messages and alarm messages and one setting for alarm messages.

��

�	��
�
�� ��������

Figure 8-11 System → Parameters → Messages Dialog Box

In your configuration, you can set whether you wish to display event messa-
ges and alarm messages together or separately.

Only one type of message is displayed at a time. Messages are shown accord-
ing to their priority. The order of priority is

1. Unacknowledged alarm messages

2. Event messages that have not yet departed

3. Alarm messages which have been acknowledged but have not yet de-
parted

The display is divided into areas for event messages and alarm messages.
Alarm messages and event messages are displayed simultaneously. Alarm
messages have the following priorities:

1. Unacknowledged alarm messages

2. Alarm messages which have been acknowledged but have not yet de-
parted

With this setting you set whether the last or first alarm message to be re-
ceived is displayed. This setting is important in cases where several alarm
messages are waiting.

Settings for 
message display

Setting event 
messages and 
alarm messages

Separate

Together

Setting alarm 
messages

Messages
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Recipes

Recipes are groups of variables for a specific application. The purpose of
recipes is to transfer several items of data en bloc to the PLC. In addition, the
OP and the PLC are synchronized.

In the configuration, the recipe defines the data structure. Data are assigned
to the structure on the OP. Since the data structure can be assigned several
times, we now speak of data records. Data records are stored on the OP, thus
saving storage space on the PLC.

A practical example of a recipe is the bottling machine of a fruit juice sys-
tem. Let us assume that orange nectar, an orange juice drink and orange juice
all have to be produced on the same bottling machine. The ratios of mixture
differ from drink to drink, but the ingredients are the same. To accomplish
this, the Mixture recipe, containing the following data structure, is created:

Name {Var_23}
Orange {Var_11} l
Water {Var_7} l
Sugar {Var_19} kg
Flavor {Var_21} g

The data records now contain the values for the different drinks. The data
records might look as follows:

Orange Drink Orange Nectar Orange Juice

Name Drink
Orange 90 l 
Water 10 l 
Sugar 1.5  kg 
Flavor 200 g

Name Nectar
Orange 70  l 
Water 30 l 
Sugar 1.5  kg 
Flavor 400 g

Name Juice
Orange 95  l 
Water 5 l 
Sugar 0.5  kg 
Flavor 100 g

A special editor is available for creating recipes. Every recipe is stored under
a symbolic name. You can enter a name by choosing Recipe → Attributes
from the menu. You specify this name whenever you edit, reference or delete
the recipe.

Recipes are also numbered; you can modify recipe numbers.

Definition

Example of a 
recipe

Recipe editor

9
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You can configure entries in a recipe. An entry consists of text and an input
field. Figure 9-1 shows the editor used to create recipes.

Figure 9-1 Editor for Creating Recipes

Data records are created on the OP by the operator entering them or by the
PLC reading them.

With recipes, an entry does not have the same size as the display. Table 9-1
shows the number of lines available for displaying data records on the OP.

Table 9-1 Display Capacity on OP

Operator Panel Lines Chars per Line

OP5 2 20

OP7 2 20

OP15A 1 40

OP15C 2 20

2 40

OP17 2 20

2 40

C7-623 2 20

C7-624 2 20

Variables used in recipes may also occur in other objects such as screens.
This presupposes that the corresponding fields have the same display format.
The following example shows one such application.

Ingredients of a
recipe

Recipes
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Let us assume that for each of the ingredients – orange, water etc. – there are
separate screens containing screen entries for the fill level of the storage tank,
for the status display of the valves, for display of the quantity consumed and
for other details. The screens contain input fields for setting the intake
amounts to the mixer. The ratios of mixture can thus be entered screen by
screen, and then the mixer can be started. This process has to be repeated for
every fruit juice. This process is beneficial when, for example, the system is
undergoing commissioning.

If the variables of input fields are combined to form a recipe, completed mix-
tures for the different fruit juices can be stored by creating data records on
the OP. Figure 9-2 illustrates how variables are used on screens and in a rec-
ipe.

If you now wish to produce a specific fruit juice, the corresponding data re-
cord is transferred to the PLC. This means that the requisite values are as-
signed to all of the variables.

���	
��� ������

Name {Var_23}
Orange {Var_11} l 
Water {Var_7} l
Sugar {Var_19} kg
Flavor {Var_21} g

Figure 9-2 Identical Variables in Screen Entries and a Recipe

Description of 
example

Identical variables
on screens and 
Recipes

Recipes



9-4
ProTool/Lite User’s Manual

Release 09/96

9.1 Configuring Input Fields

With input fields, the operator enters a value on the OP, and the value is
transferred to the PLC. The value may also be entered symbolically as text.

Table 9-2 shows you the entries you can make in recipe input fields.

Table 9-2 Entries Possible in Input Fields of Recipes

Field Type Usage Display

Input Variable Value,
symbol

To configure input fields, choose Recipe → Edit/Insert Field from the menu.
The Input dialog box (refer to Figure 9-3) appears.

Figure 9-3 Input Dialog Box

Input fields

Configuring input
fields

Recipes
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In this dialog box, you set the way in which an input field will be displayed
on the OP. Three items of information are required for this:

Usage You can only select Variable at this point.

Field Type The only field type that you can select at this point is ”In-
put”.

Display At this point you set how the contents of the field are to be
displayed, i.e., as a value or as a symbol. In the case of va-
lues, you can choose from different formats, such as Deci-
mal, Hexadecimal or String.

If you select the Text Symbol entry for Display, you can assign a symbolic
display to a field. With symbolic fields, text is displayed instead of a symbol-
ic value. Text is assigned to the values of a variable in the configuration.

With recipes, the symbolic display can be used to assign a name to the values
of variables – for example,

0 Drink
1 Nectar
2 Juice

The corresponding word Juice , not the value 0, is displayed on the OP.

Symbolic inputs are entered by means of text or graphic lists. The dialog box
is modified as shown in Figure 9-4.

Figure 9-4 Text Symbol Setting for Symbolic Display

Configuring fields
with symbolic dis-
play

Recipes
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To edit the text or graphic list, click under List on the Edit button. The Text
or Graphic List - Text dialog box, in which you can edit text, appears. Figure
9-5 shows the dialog box in which the aforementioned example is configured.

Figure 9-5 Text or Graphic List - Text Dialog Box

Editing a text or
graphic list

Recipes
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9.2 Creating and Transferring Data Records

A recipe is stored under a symbolic name and under a number in your config-
uration. You also select a recipe by its name or number on the OP. You can
modify the name and number of a recipe by choosing the Attributes button in
the Recipe dialog box.

On the OP You create a data record on the OP under a number and 
a symbolic name. The name is valid only on the OP. When 
transferring a data record to the PLC, the data record and 
recipe numbers are transfered.

On the PLC The OP writes the data record number and the number of
the corresponding recipe into a mailbox. On the SIMATIC
S5, this mailbox is called the ”recipe number mailbox”,
whereas on the SIMATIC S7 it is referred to as the ”data
mailbox”. You set the addresses of the recipe number mail-
box or the data mailbox by choosing System→ Area Pointer
from the menu. On the S5, data are written to a recipe mail-
box, whereas on the S7 data are written directly to the ad-
dresses.

You will find further information about the recipe number mailbox, data
mailbox and recipe mailbox in the Communication User Manual.

A major feature with recipes is that data transfer is synchronized and any
uncontrolled overwriting of data is inhibited. To insure a coordinated process
when data records are transferred, bits are set in the control and check-back
areas of the interface area.

The data records that you create on the OP are stored in FLASH memory. On
the OP15, they can be stored alternatively on a floppy disk.

Identifying a recipe
on the OP

Identifying
a data record

Synchronization
during transfer

Storing 
data records

Recipes
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9.3 Example of Recipes and Data Records for SIMATIC S5

This chapter takes you step by step through 
– creating a recipe, 
– creating data records on the OP and 
– transferring data records to the PLC.

In our example, you will create a recipe for the mixing unit of a fruit juice
system. You wish to mix different fruit juices on the same system. The ingre-
dients are identical, only the ratios of mixture are different. You first create a
recipe called Mixture, followed by a data record called Juice. This data re-
cord contains the ratio of mixture for orange juice. While the data record is
being transferred, the OP sets bits in the control and check-back areas. You
must then similarly set and reset bits in the PLC program to re-enable the
recipe mailbox.

You create the example recipe for an OP5, which is connected to the 
SIMATIC S5 by means of AS511. It is the AG115U with CPU 944.

Open the standard configuration called c:\prolite\standard\
s_05.pdb . Save this configuration under a new name – for example,
QUICKMIX.PDB.

Set the SIMATIC S5 PLC with driver AS511 by choosing System → PLC → 
from the menu. Keep the symbolic name PLC_1. Press the Parameters button
and select the following CPU: S5 115UCPU944 .

Call the editor for recipes and create the recipe described below. The recipe
is shown in Figure 9-6.

Figure 9-6 Editor for Creating Recipes

Description

Example system

Creating a 
recipe with 
ProTool/Lite

Recipes
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Create variable Var_23 as a Type KF variable. The variable is one data word
long. In the Display field, select Text Symbol  and then create the follow-
ing text or graphic list:

0 Drink

1 Nectar

2 Juice

Give the variable an address on the PLC – for example, DB 12, DW 0 ,
field length 7 (the number of characters of the longest word on the text or
graphic list). Specify PLC_1 as the PLC. This means that you can use the
variables on screens and in messages too.

Variables Var_11, Var_7, Var_19 and Var_21 are  Type KF variables, all being
one data word long. For the address, specify data block 12 too. With variable
Var_19, specify the digits behind the decimal point as 1.

You must now specify the name of the recipe and create the recipe number
mailbox and the recipe mailbox.

1. Choose Recipe → Attributes  from the menu. The Recipe Attributes dia-
log box appears (refer to Figure 9-7). At this point, modify the name of
the recipe to Mixture .

Bild 9-7  Recipe Attributes Dialog Box with Settings

2. For the name of the recipe to appear on the OP as well, you have to speci-
fy a title. Click the Title button. The following dialog box appears.

Other essential
settings

Recipes
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Bild 9-8 Title Dialog Box

3. Enter Mixture again.

Exit from the dialog boxes by clicking the OK button in each dialog box.
The name Mixture is now in the editor window under Recipes as an object
as well as on the title line of the open Recipes editor.

4. Choose System → Area Pointer from the menu. Set the interface area
here. Click Add. Set the following interface area: 
DB: 51
DW: 0
Length: 185

5. Choose Recipe Number Mailbox under Type: Click the Add button again.
Set the recipe number mailbox as follows: 
DB: 13
DW: 0
Length: 1.

6. Repeat the procedure for the Recipe Mailbox type. Set the recipe mailbox
as follows:
DB: 14
DW: 0
Length: 29 .
You have to start at DW0.

Figure 9-9 shows the aforementioned settings.

Bild 9-9  Area Pointer Dialog Box with Settings

Recipes
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Place the OP in Download mode. Save your configuration by choosing File
→ Save from the menu. Connect the OP to the PC or PU by means of the
connecting cable. Go to File → Download on the menu system. Confirm that
the configuration should be compiled first by answering Yes at the prompt.

After the download operation, the OP is at message level. The system dis-
plays the message S5 not available . Connect the OP to the CPU. The
system message then disappears.

To create data records, choose screen Basic Screen → Records → Edit.

Select the Mixture recipe. With the OP5 and the OP15, you can also choose
the recipe directly by pressing the SHIFT key and then the directory key.

Press ENTER. The OP shows the following output on the line display: 
01 Data record

Press ENTER again. The line display shows: 
01 Name: Drink

The cursor is positioned on 01 . Press the RIGHT arrow key. The cursor
moves to Drink . Press SHIFT. With the UP and DOWN arrow keys, you
can scroll through the symbolic names. Scroll until Juice  is displayed.
Press ENTER to save the first recipe entry.

Press the ENTER key to move to other recipe entries. Enter the mixture val-
ues for orange juice and save the values you enter by pressing ENTER after
every entry:

02 Orange 95
03 Water 5
04 Sugar 0.5
05 Flavor 100

Enter the mixture values for orange juice and save the values you enter by
pressing ENTER after every entry.

When you have finished work on the recipe entries, save the data record by
pressing ESC twice in succession. The following prompt appears on the dis-
play:

No. 1  
Name: Data Record
Save Data Record? Y

The cursor is positioned on 1. No modifications have to be performed at this
stage, since you have just edited the first data record. Press the RIGHT arrow
key. The cursor moves to Data Record .

Now assign a name to the data record. You can do this with keys 1–9 and
SHIFT + A .... F. Overwrite Data Record  with DE01 and delete the other
characters using the key combination SHIFT + DEL.

Press the ENTER key to save the name you entered. Then press the RIGHT
arrow key. The cursor moves to the Yes field. Press ENTER again. The fol-
lowing message appears on the OP.

Downloading the
configuration

Creating a 
data record on the
OP

Recipes
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No. 1  
Name: DE01
Overwrite? Y

Press the ENTER key. Data record No. 1 is saved. The following message
appears:

No. 1  
Name: DE01
Data record saved.

Press ESC. The data record number with the new name is displayed.

01     DE01

Before you can transfer a data record from the OP to the PLC, you must
create the following data blocks on the PLC:

� DB 12 for the variables in the recipe

� DB 13 for the recipe number mailbox

� DB 14 for the recipe mailbox

� DB 51 for the interface area.

You also require the following function blocks:

� FB 51;
it governs communication between the OP and the PLC.

� FB 42;
the OP and the PLC are synchronized in data word 64 of the interface
area. FB 42 performs synchronization and then distributes the data to the
addresses.

This means that organization blocks OB1 and OB20 to OB22 are structured
as follows:

� OB1
:L KY 51,0
:SPA FB 51
:T FW 100
:L KY 51,0
:SPA FB 42
:BE

� OB20/21/22
:L KF +1
:A DB 51
:T DW 64
:BE

PLC requirements
for transfer

Recipes
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Choose Basic Screen → Records → Transfer from the menu. 
Choose this menu item by means of a soft key. Recipe 01 – Mixture – 
appears.

Press ENTER. The following display appears on the OP:

Source: 00  Dest.: 00  
           Accept
PLC: 00/00    OP: 1

The cursor is located in the first field. Enter 1 for the source, since you want
to transfer the first data record. Press ENTER to apply the input.

Press the RIGHT arrow key twice. The cursor is now located in the Accept
field.

Then press ENTER to transfer the data record to the PLC. The following
display appears:

Source: 00  Dest.: 00  
           Accept
PLC: 01/01    OP: 1

Specifying 00  as the target means that the data record will be transferred
from the OP to the PLC. If 00  is shown as the source, the data record is
transferred from the PLC to the OP.

Function block FB42 distributes the values to the specified addresses.

Transferring the
data record from
the OP to the PLC

Result

Recipes
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Functions

ProTool/Lite features a series of functions which you can use in your config-
uration. Functions are used to:

� compile a process-specific configuration, such as branching from one
screen to another,

� use OP characteristics, such as display or print the message buffer,

� perform system settings in Online mode on the OP, such as modify inter-
face parameters.

Before you can use functions on the OP, they have to be assigned to function
keys or scheduler. They may be assigned to either soft keys or a global func-
tion key. Soft keys are assigned to screen entries and are located directly be-
neath the entry in the screen editor. You assign global function keys by
choosing System → Screen/ Keys from the menu.

You will find a list of all the functions available in ProTool/Lite and their
descriptions in Appendix A.

The OP3, OP7 and OP17 have a function which can be assigned to a variable.

If you wish to assign a function to a function key, click in the screen editor or
in the System → Screen/Keys dialog box on the displayed key. The Function
Keys dialog box appears. In the dialog box, click the Function button (or
SHIFT+Function in the case of global function keys). The dialog box shown
in figure 10-1 appears.

Purpose

Using functions

Special feature on
OP3, OP7, OP17

Assigning several
functions

10
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Figure 10-1 Functions Dialog Box

Select any one of the functions. If you click on the key having the double-
headed arrow, the function is transferred to the field on the right.

Some functions feature several settings. For example, the Mode function of-
fers several options. By means of the parameter, you then specify which of
the settings that are possible should be enabled. Pressing the function key on
the OP then initiates the function with its set parameters – for example,
Download mode. Figure 10-2 shows the setting of the parameter.

Figure 10-2 Dialog Box for Setting Function Parameters

Generally speaking, we differentiate between two different kinds of function:

– functions without parameters

– functions with parameters

Functions without parameters include, for example, Print Message Buffer or
Password Logout. A parameter is not required in this particular instance since
the assignment with the function is already clear.

Functions with parameters require specification of the object for which or the
setting with which the function is required to be executed. 

Parameter

Functions
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The functions which refer to an object include, for example, Select Screen or
Print Screen Entries. In this instance you have to specify the name of the
screen as the parameter. Whenever you wish to edit objects, use this kind of
function.

The functions with different settings include, for example, Message Log ON/
OFF and Mode. In this case, you assign precisely one setting to a function.
Should you wish to use several settings, you have to assign several keys to
this function, each with different parameters.

The Select Function Screen function accesses internal screens. These screens
are stored in the firmware and cannot be modified in the configuration. When
a function screen is called, the function is not executed directly. The operator
is shown a screen on which he can initiate the function. Function screens are
integrated into the configuration with the Select Function Screen function.

Some functions can be configured both directly by means of a function (one-
shot function) and by means of a function screen – for example, Message Log
ON/OFF. For the one-shot function, you specify a parameter. The function is
then directly initiated on the OP with the set parameter. In the case of func-
tion screens, the operator can select a parameter and then initiate the func-
tion.

If a function is present in your configuration as a one-shot function and as a
function screen, the current status of the function is displayed when the func-
tion screen is called.

All the available function screens are used in the standard screens supplied to
you.

The Alarms – Display First/Last function and the Last parameter have been
assigned to a soft key. When the key is pressed on the OP, the Last” setting is
applied. The Function Screen function and the First/last AM parameter have
been assigned to a function key. When the function key is pressed on the OP,
the function screen for setting alarm message display is called. It has the fol-
lowing appearance:

Message display:  Last

The function screen shows the current status, i.e. displays the last alarm mes-
sage to arrive.

Using the arrow keys, you can now select a different setting on the OP and
apply it by pressing ENTER.

The OP3, OP7 and OP17 have one function that can be assigned only to a
variable. This is the Scaling linear function.

Select Function
Screen   function 

Example

OP3, OP7, OP17:
Functions with
variables

Functions
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General Communication Areas

This chapter describes data areas used by the OP and the PLC to communi-
cate with each other. These data areas are required only when you wish to use
the corresponding OP functions. You then have to create the data areas on the
PLC and set them in the configuration.

11.1 Interface Area for Non-SIMATIC PLCs

The interface area described below applies to all PLCs except SIMATIC
PLCs. The interface area for SIMATIC PLCs is described in the Communica-
tion User’s Manual.

The interface area is required when you use the following functions:

– send PLC jobs to the OP

– synchronize date and time between the PLC and the OP

– test version number

– recipes (transfer of data records)

– detect OP startup in the PLC program

– evaluate the OP mode in the PLC program

– evaluate the OP life bit in the PLC program

Contents

Usage

11
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You set the interface area in ProTool/Lite by choosing System → Area Point-
ers from the menu. In addition, the area has to be available on the PLC. 
Figure 11-1 shows the structure of the interface area.

Data Word

Control bitsn+0

n+2
Job mailbox

n+6

n+25

Version number

Time

Date
n+11

Reserved

n+15

Reserved

n+1 Reserved

Acknowledgement bits

n+7
n+8
n+9

n+5

n+14

n+12

n+17
n+18

Scheduler bit

Figure 11-1 Structure of the Interface Area in Data Words

The counting direction of the bits in a data word depends on the PLC. It may
be clockwise, starting at 0, or counter-clockwise, starting at 1.

When data words are illustrated in the description that follows, there are al-
ways two illustrations. If only one bit is mentioned, its number is shown
– without parentheses for a clockwise direction 
– with parentheses for a counter-clockwise direction

Creating the 
interface area

Counting direction
of bits

General Communication Areas
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11.1.1 Control and Acknowledgement Bits

A word is available for every control and acknowledgement bit. Word n+0
contains the control bits. Control bits are written by the PLC and read by the
OP. Word n+6 contains the acknowledgement bits. They are written by the
OP and read by the PLC.

The following illustrations show the detailed structure of the control and
acknowledgement bits. This is followed by a description of achieving syn-
chronization of the OP with the PLC by setting bits.

7 6 5 4 3 2 1 089101112131415

Control bits word n+0

Error-free
transfer

Erroneous
transfer

7 6 5 4 3 2 1 089101112131415

Acknowledgement bits word n+6

Data transfer
complete

Data mailbox 
is disabled

Life bit

OP mode

OP startup

Figure 11-2 Control and Acknowledgement Bits for Clockwise Direction

Introduction

Detailed structure
of control and 
acknowledgement
bits

General Communication Areas
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9 10 11 12 13 14 15 1687654321

Control bits word n+0

Error-free
transfer

Erroneous
transfer

9 10 11 12 13 14 15 1687654321

Acknowledgement bits word n+6

Data transfer
complete

Data mailbox 
is disabled

Life bit

OP mode

OP startup

Figure 11-3  Control and Acknowledgement Bits for Counter-Clockwise Direction

Bit 0(16)1 in acknowledgement bits
1= OP has started
0 = OP is starting

The bit is set by the OP when startup has finished.

Bit 1(15) in acknowledgement bits
1 = OP is offline
0 = OP in normal mode

The bit is set if the OP is switched to Offline mode by the operator. In Online
mode, the bit is set to 0.

Bit 2(14) in acknowledgement bits 

The purpose of the life bit is to insure that any disruption of the connection
from the OP to the PLC is detected immediately. The OP inverts the life bit
in the interface area at regular intervals.

1 The number in brackets refers to the counter-clockwise direction

OP startup

OP mode

Life bit

General Communication Areas
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Control bits:

Bit 10(6)11 = Data record/variable is erroneous
0 = Evaluation not performed

Bit 9(7) 1 = Data record/variable is erroneous
0 = Evaluation not performed

Acknowledgement bits:

Bit 9(7) 1 = Data transfer ended
0 = Evaluation not performed

Bit 8(8) 1 = Data mailbox is disabled
0 = Data mailbox is vacant

The control and acknowledgement bits in the interface area synchronize the
transfer of data records. The standard case is that a transfer is initiated by
means of an operator input on the OP.

The following description deals with the process of setting sync bits by the
OP and the reaction to them by the PLC program.

Bit 8(8) of the acknowledgement bits is checked by the OP. If bit 8(8) is set
to 1 (= data mailbox disabled), the transfer is completed with a system error
message. If bit 8(8) is set to 0, the OP sets the bit to 1.

The OP enters the identifications in the data mailbox.

With a data record that is required to be transferred indirectly, the values of
the variables are also written to the data mailbox. With a data record that is
required to be transferred directly, the values of the variables are written to
the configured address.

The OP sets bit 9(7) of the acknowledgement bits to 1 
(= data transfer complete).

Acknowledge in the PLC program whether the transfer was error-free or erro-
neous.
Error-free: Bit 9(7) is set to 1
Erroneous: Bit 10(6) is set to 1

The OP resets bits 9(7) and 8(8) of the acknowledgement bits.

Bits 10(6) and 9(7) have to be reset in the PLC program.

1 The number in brackets refers to the counter-clockwise direction

Synchronizing 
the transfer of 
data records

Transferring 
OP → PLC
(OP initiated)

Step 1:

Step 2:

Step 3:

Step 4:

Step 5:

Step 6:

General Communication Areas
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11.1.2 Data Areas in the Interface Area

This section describes the structure and usage of user data areas located in
the interface area.

The PLC initiates an action on the OP via the job mailbox. All the other 
bytes are areas to which the OP writes data. These areas can be evaluated by
the PLC program. The bytes are described in detail below.

Word n+2 through n+5:
PLC jobs can be transferred to the OP via the job mailbox, thus initiating
actions on the OP.

The job mailbox consists of four words. The first word of the job mailbox
contains the job number. The job parameters (three at most) have to be en-
tered in the other words.

Job mailbox:

��� 	��� 
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If the first word of the job mailbox is not equal to zero, the OP evaluates the
PLC job. The OP resets this data word thereafter to zero. For this reason it is
necessary to enter the parameters in the job mailbox before entering the job
number.

The PLC jobs that are possible are listed with their job numbers and parame-
ters in Appendix C.

Word n+8

The OP enters the version number of the driver in word n+8. It can be 
evaluated by the PLC program.

General

Job mailbox

Version number

General Communication Areas
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Time = Words n+9 through n+11
Date = Words n+12 through n+14

PLC job 41 can initiate the transfer of time and date from the OP to the PLC.

Figure 11-4 shows the structure of the data area. All specifications are BCD-
coded.

Not assigned
16 9 8 1

 n+9

Left byte Right byte

Hour (0 to 23)

n+10

n+11

n+12

n+13

n+14

Minute (0 to 59) Second (0 to 59)

Not assigned

Not assigned Day (1 to 7)

Day (1 to 31) Month (1 to 12)

Year (0 to 99) Not assigned

Ti
m

e
D

at
e

Address

Figure 11-4 Structure of the Time and Date Data Area

To detect when the date and time were transferred, you should set the data
words to 0 before initiating the PLC job.

Date and time

General Communication Areas
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11.2 OP Keyboard and LED Assignments

Key operations on the OP can be transferred to the PLC and then evaluated.
In this way it is possible to draw the operator’s attention to the incorrect 
operation of a key by means of, say, a message.

The light-emitting diodes (LEDs) on the function keys of the OP can be
driven by the PLC. This means that it is possible, for example, to indicate to
the operator by means of a lit LED on a key, depending on the situation, that
he should press a specific key.

To be able to use this option, you have to create suitable data areas – called
assignments – on the PLC and to specify them as area pointers in your con-
figuration.

Keyboard assignments are transferred spontaneously to the PLC, meaning
that a transfer is performed whenever a modification has been registered on
the OP. There is therefore no need to configure a polling time.

Only a key that has been pressed is transferred.

All keys (apart from SHIFT)

While the corresponding key is pressed, its assigned bit in the keyboard 
assignment has 1 as its value; at all other times its value is 0.

Note

If the OP is switched off while the key is pressed or if it is separated from
the PLC, the corresponding bit will remain set in the keyboard assignment.

Usage

Condition

Transfer

Assigning values
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11.2.1 System Keyboard Assignment

The system keyboard assignment is a data area having a fixed length of two
data words. To be able to use the system keyboard assignment, you have to
create a system keyboard type data area under Area Pointers in your configu-
ration.

Precisely one bit is permanently assigned in the system keyboard assignment
to every key belonging to the system keyboard.

Keyboard assignment for OP5, OP15, C7-623 and C7-624
(counting clockwise):

�+,� .)*$

�($� .)*$

�%/")!*$� #)''-(&#!,&)(� "&,

����
��� 

���

���
��� �

�����


�� 
��
���
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���

�

����� ��� ��� ����

Keyboard assignment for OP7 and OP17 
(counting clockwise):

���

���
��� �

�����


�� 
��
���

��	
���

�

����� ��� ��� ����
�+,� .)*$

�($� .)*$

�%/")!*$� #)''-(&#!,&)(� "&,

Keyboard assignment for OP7 und OP17
(counting counter-clockwise):

���

���
����

�����


 � �
 � �
� � �

� � 	
� � �

�

���������������
�+,� .)*$

�($� .)*$

�%/")!*$� #)''-(&#!,&)(� "&,

Note

Unused bits must not be overwritten by the user program.

The keyboard communication bit is used as a check bit. It is set to 1 every
time the keyboard assignment is transferred from the OP to the PLC and
should be reset following evaluation of the data area by the user program.

By regular reading of the communication bit, it is possible to determine in
the user program whether the keyboard assignment has been re-transferred.

Structure

Keyboard commu-
nication bit

General Communication Areas
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11.2.2 Function Keyboard Assignment

The function keyboard assignment can be divided into separate data areas,
which are shown in the following table. To use the function keyboard assign-
ment, you have to create a function keyboard type data area in your configu-
ration under Area Pointers.

Data Areas All Devices

Maximum number �

Overall length of all data areas (words) �

The assignment of the different keys to the bits of the data areas is set when
the function keys are configured. In this context, the number within the 
assignment area is specified for every key.

The highest order bit of every data area is the keyboard communication bit.
It is used as a check bit. The keyboard communication bit is set to 1 every
time the keyboard assignment is transferred from the OP to the PLC. After
the data area has been evaluated by the user program, the keyboard commu-
nicaton bit should be reset.

By regular reading of the communication bit, it is possible to determine in
the user program whether a block has been re-transferred.

Data areas

Key assignment

Keyboard commu-
nication bit

General Communication Areas
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11.2.3 LED Assignment

The LED assignment can be divided into separate areas, as the following
table shows. To use the LED assignment, you have to create a LED assign-
ment type data area in your configuration under Area Pointers.

Data Areas All Devices

Maximum number �

Overall length of all data areas (words) �

If a polling time of 0 is specified for a data area, it is not transferred cycli-
cally to the OP. To drive the LEDs, PLC job No. 42 has to be used 
(refer to Appendix C).

The assignment of the different LEDs to the bits of the data areas is set when
the function keys are configured. In this context, the number of the
assignment area and the bit number within this area are specified for every
LED.

Bit number (n) denotes the first of two successive bits, which control a total
of four different LED states (refer to Table 11-1):

Table 11-1 LED Functions for the OP5, OP15, OP7 and C7-623 and C7-624 
(Counting Clockwise)

Bit n  + 1 Bit n LED Function

� � Off

� � Flashing at approx. 2 Hz

� � Flashing at approx. 0.5 Hz

� � Permanently on

Table 11-2 LED Functions for the OP5, OP15, OP7 and C7-623 and C7-624 
(Counting Counter-Clockwise)

Bit n  + 1 Bit n LED Function

� � Off

� � Flashing at approx. 0.5 Hz

� � Flashing at approx. 2 Hz

� � Permanently on

Data areas

Polling time

LED assignment
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On the OP17, the K keys have two-coloured LEDs (red/green). You will find
the resulting LED functions in Table 11-3.

Table 11-3 LED Functions for the OP17 (Counting Clockwise)

Bit n + 1 Bit n LED Function

� � Off

� � Flashing red

� � Permanently red

� � Permanently green

Table 11-4 LED-Funktionen für OP17 (zählweise links → rechts)

Bit n + 1 Bit n LED-Funktion

� � Off

� � Permanently red

� � Flashing red

� � Permanently green

General Communication Areas
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11.2.4 Hints on Optimization

The polling times specified in the configuration software for area pointers
and the polling times for variables are important aspects for the update times
actually achieved. The update time is polling time plus transfer time plus
processing time.

To achieve optimum update times, observe the following points when you are
configuring:

� Make the different data areas as small as possible and as large as neces-
sary.

� Define contiguous data areas when they belong together. The actual up-
date time improves if you create one large area as opposed to several
smaller ones.

� Polling times that have been dimensioned too short unnecessarily degrade
overall performance. Set the polling time commensurate with the speed of
variation of process values. The temperature variation of a furnace, for
example, is distinctly more inert than the variation in speed of an electric
drive.

Recommended value for polling time: approx. 1 second.

� Do without cyclic transfer of the user data areas, if necessary, to improve
update times (polling time 0). In its place, use PLC jobs to transfer the
user data areas spontaneously.

� Place the variables of a message or a screen without gaps in a data area.

� So that modifications on the PLC can be properly detected by the OP,
they must be present at least during the actual polling time.

Polling time and 
update time

General Communication Areas
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Configuring in Different Languages

With languages, we generally speaking distinguish between two display le-
vels. The levels are: 

� the user interface language of ProTool/Lite.
The user interface language is the language in which text is displayed in
the menus and dialog boxes of ProTool/Lite.

� the configuration language for the OP.
The configuration language is the language in which you create your con-
figuration. This is the language in which your configuration appears on
the OP.

The interface language has to be defined when ProTool/Lite is installed. You
can set the following languages:

– German,

– English,

– French,

– Italian and

– Spanish.

You can create the configuration in all of the above languages. With the OP7,
OP15C and OP17, Russian is possible as well. You can load up to three of the
possible configuration languages on the OP simultaneously.

When ProTool/Lite is called, the configuration language is the same as the
windows language. The configuration language is changed by choosing Edit
→ Language from the menu. If you wish to set a different configuration lan-
guage or if you have completed your configuration in one language and now
wish to configure the next one, choose this menu item.

The dialog box shown in figure 12-1 appears; here you set the editing lan-
guage and the reference language.

� The editing language is the current configuration language in which con-
figurable text is entered.

� The reference language should be regarded from the viewpoint of transla-
tion. If, for example, you are configuring your second language, you can
display the text of the first language as a reference language. This means
that you can view the first language as a basis for your translation.

Display levels

Interface language

Configuration 
language

Editing and refer-
ence languages

12
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Figure 12-1 Dialog Box for Language Settings

In the Languages dialog box, the language set as the default editing and refe-
rence language is the language in which you installed Windows on your PC.
If you wish to modify the editing or reference language, proceed as follows:

� If you have built on top of a standard configuration, you can simply as-
sign one of the following languages as the editing and reference language:

– German,

– English,

– French,

– Italian,

– Spanish.

Standard screens are available for every one of these five languages.

� If you have created a configuration without building on top of a standard
configuration, then only the default language is available. You have first
to add languages for selection.

To do this, call System → Language Assignment from the menu. The Lan-
guage Assignment dialog box appears, showing the default language.

Figure 12-2Language Assignment Dialog Box

Click the New... button. The Add Language dialog box appears.

Adding languages
for selection

Configuring in Different Languages
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Figure 12-3Add Language Dialog Box

Select the language you require and click OK. The Add Language dialog box
is closed. The language you selected is listed in the Language Assignment
dialog box under Languages. Close the Language Assignment dialog box as
well by clicking OK.

The new language you selected can now be set as the editing and reference
language and can also be applied as the OP language.

The following objects contain language-dependent text:

– event messages,

– alarm messages,

– screens,

– symbol lists and

– recipes,

– headers and footers.

Information text is similarly language-dependent. Information text can be
configured for:

– input fields,

– combined input/output fields,

– screens,

– screen entries,

– recipes,

– recipes entries and

– messages.

If you wish to create a configuration in several languages, you should first
configure just one language and then test your configuration with the PLC
program. When you have done this, you can enter your text in the other lan-
guages.

Objects with  
language- 
dependent text

Information text

Configuring in
several languages

Configuring in Different Languages
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Note

If you wish to modify a configuration that has already been created in va-
rious languages, then avoid having later to move configured fields in event
messages and alarm messages. As there is no permanent assignment between
a field and its position within text, not the fields but the text strings should
be moved, if necessary.

To enter Cyrillic characters, choose Edit → Language from the menu and
select Russian. You can now enter Cyrillic characters using all the lower-
case letters. You will find a table with assignments of Latin letters and Cyril
lic characters in Appendix B. Capital Latin letters and numerals are still
available on the keyboard.

When you select a language in the Editing Language input field by choosing
Edit → Languages... from the menu, the corresponding character set is loa-
ded and the key assignment is modified. If the editing language is different
from the Windows language, a keyboard assignment with the new key alloca-
tion appears on the screen (refer to Figure 12-4). You can now see where the
characters that are different are located on your keyboard and you can enter
them. Alternatively, you can click the cursor on the keys of the keyboard as-
signment to enter a character in an editor.

Figure 12-4Example of a Keyboard Assignment with French as the Editing Language

The keyboard assignment is hidden automatically when you change the edi-
ting language back to the Windows language. You can, however, deactivate it
by choosing Window → Keyboard from the menu.

Before the configuration is downloaded to the OP, set the OP languages by
choosing System → Language Assignment from the menu (Figure 12-5).

Configuring in
Russian

Foreign-language
keyboard 
assignment

Setting OP lan-
guages

Configuring in Different Languages
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Figure 12-5 Setting OP Languages

OP languages are the languages that you can select on the OP. Select up to
three of the existing configuration languages in succession as OP languages.
These languages are downloaded with the configuration to the OP in Down-
load mode. The first language to be entered is the one that is set subsequent
to OP start-up. You can switch to another language during routine operation.

With the � button you can select up to three OP languages in succession
from the list box on the left.

With the � button you can remove individual languages from the list of OP
languages.

You can change the OP languages in your configuration. If, for example, you
wish to load the same configuration on several OPs with different languages,
you can change the OP languages prior to Download.

Depending on the OP language that you set, the OP automatically accesses
the internal character set.

Note

Depending on the device, not all characters in the ANSI character set can be
displayed on the OP. You will find a table containing the device-specific
characters in Appendix B.

Configuring in Different Languages
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General Settings for the System

This chapter gives a brief account of all the settings concerning the OP. Some
of the settings have already been mentioned in other chapters when the con-
text made it necessary.

This chapter represents a summary of all the settings that are possible. Set-
tings are made by choosing System from the menu. You can then choose the
following from the submenus:

At this point you assign global function keys. Global means that the assign-
ment is valid for the whole configuration.

At this point you make general settings for the OP. The menu item is divided
into three submenu items. They are:

Messages
This menu item contains settings which are common to all editors. They in-
clude the printout of messages, display options for alarm messages, warning
on buffer overflow and language-dependent identification of messages in the
buffer.

Firmware
At this point you set the firmware for compilation. At the same time you are
also given details of the firmware on the connected OP.

Miscellaneous
At this point you make general settings, such as setting the password for the
superuser, the language-dependent time and date formats and defining the
user version of the configuration.

At this point you make all the settings for the printer connected to the OP.
They include the printer type and the interface parameters. The settings for
the OP are made in the following two submenu items:

Interface
At this point you set the interface parameters such as baud rate, level (TTY
or V.24) and the interface to which the printer is physically connected.

Settings
At this point you set the type of printer. You can define several 
printers as OP printers. For the OP, the first printer on the text list is the de-
fault printer. If a printer other than the default printer is attached, you must
change the printer type online on the OP by means of the Printer Setting
standard screen.

In this chapter

Screen/Keys

Parameters

Printer
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shows the amount of storage space your configuration will require in the OP
memory.

At this point you set the PLC to which the OP is connected. At the same time
you set the protocol and the protocol parameters used by the OP and the PLC
to communicate with each other.

At this point you set the data areas required for communication between the
OP and the PLC. The data areas must be present on the PLC. By choosing
Area Pointers, you announce to the PLC the data areas which it should ac-
cess. The data areas that have to be set depend on the objects you configured.
Table 13-1 contains an overview of the occasions when the different data
areas are required.

At this point you set the languages that you want to have at your disposal on
the OP. A configuration can be created in a maximum of six languages. Of
these languages, not more than three can be set as OP languages.

Table 13-1 shows who can read from and write to the different data areas
which can be configured under Area Pointers. The area pointers are sorted in
alphabetical order. The abbreviations ”R” and ”W” have the following mean-
ings:

R Read
W Write

Memory 
Requirements

PLC

Area Pointers

Language 
Assignment

Summary

General Settings for the System
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Table 13-1 Use of Area Pointers

Data Area Required for OP PLC

User  version Checking version by the PLC R W

Event messages Configured event messages R W

Screen number  area Evaluation by PLC as to
which screen is currently
open

W R

Function keyboard Evaluation by PLC as to
which function key was
pressed

W R

LED assignment Driving the LED by PLC R W

Acknowledgment PLC Acknowledgment of an
alarm message by PLC

R W

Acknowledgment  OP Message from OP to PLC
that an alarm message has
been acknowledged

W R

Recipe number Recipes;
Contains recipe number and
data record number

R1 W1

Data mailbox Recipes;
Contains recipe number and
data record number

W2 R2

Recipe mailbox Recipes;
Contains data record

W1 R1

Successive recipe mailbox Recipes;
Contains data record over-
flow from recipe mailbox

W1 R1

Interface  area Communication between 
OP and PLC (essential for
SIMATIC S5)

RW RW

Alarm messages Configured alarm messages R W

System keyboard Evaluation by PLC as to
which system key has been
pressed

W R

1 = SIMATIC S5 only
2 = SIMATIC S7 only

General Settings for the System
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Compiling and Downloading a
Configuration to the System

You have to compile a configuration before you can download it to the OP.
”Compile” means that a file that can be executed on the OP is created from
the configuration.

During the compilation process, consistency checks are made. If specifica-
tions are missing or incorrect, appropriate error messages are written to a log
window. If, for example, event messages have been configured but an event
message area has not been created under Area Pointers, an error message is
issued.

When compilation is over, you can determine, by choosing System →
Memory Requirements, how much storage space your configuration requires
on the OP. Figure 14-1 shows the dialog box. If the compiled file is larger
than the memory on the OP, you will have to make your configuration
smaller.

Figure 14-1 Memory Requirement Dialog Box

Configuration

Memory 
requirement
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14.1 Downloading the Configuration to the OP

The configuration can be downloaded in two different ways for specific de-
vices:

� serially, by means of a direct link from the PU or PC to the OP. 
The AS511 protocol is used for downloading. This type of download is
possible with the OP3, OP5, OP7, OP15 and OP17.

� by means of MPI network configuration.
In this particular instance, the PU or PC and the OP are located in the
MPI network configuration. The MPI protocol is used for downloading.
This type of download is possible with the OP3, C7-623 and C7-624.

Bear the following points in mind when setting the baud rate:

� With a cable set for level TTY (PU cable), the maximum baud rate you
can set is 9600 bauds. Higher baud rates can be used only with a cable set
for level V.24.

� With a low-performance PC or PU, you have to decrease the default baud
rate of 56000 bauds in steps until reliable downloading is possible. A low-
performance PC or PU means, for example, a 80386 processor and/or
clocking at 25 MHz.

14.2 Downloading Serial

The procedure is described here in general terms. You will find further details
in the device manual concerned.

To download the configuration from the PU or PC to the OP, do the follow-
ing:

1. Connect the OP with the interconnecting cable to the PC or PU.

2. Set the OP to Download mode.

3. Set the interface of the PU or PC by choosing File → PC Interface from
the menu.

4. Start downloading of the configuration by choosing File → Download
from the menu.

5. When downloading has finished, the OP starts up and issues the standby
message.

Device-specific
downloading

Baud rate

Procedure

Compiling and Downloading a Configuration to the System
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14.3 Downloading with MPI

To download the configuration from the PU or PC to the OP, do the follow-
ing:

1. Include the PU or PC in the MPI network configuration. To do this, there
must be a  MPI board in the PU or PC. Further, the STEP 7 software must
be installed.

2. Include the OP in the MPI network configuration. Take account of the
following notes for the MPI address.

3. Set the OP to Download mode.

4. Set the interface of the PU or PC by choosing File → PC Interface from
the menu.

5. Start downloading of the configuration by choosing File → Download
from the menu.

6. Specify the MPI address.

7. When downloading has finished, the OP starts up and issues the standby
message. With OP7 and OP17 the start screen is opened, if it has been
configured.

Figure 14-2 shows a MPI configuration with an OP. If you include in the MPI
configuration an OP on which a configuration has yet to be loaded, by default
it will have the MPI address 1.

���
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Figure 14-2 MPI Configuration with the OP

If you now load a configuration on the OP through the MPI, you must specify
MPI address 1. In the configuration choosing System → PLC, however, you
gave the OP MPI address 3. After the configuration has been downloaded,
the OP has the MPI address 3.

Procedure

Setting the MPI ad-
dress for the OP3

Compiling and Downloading a Configuration to the System
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If you wish to include several OPs in the MPI configuration, you must in-
clude them one by one. Connect one device physically first. Then download
the configuration. You can then physically connect the next device. If you
were to connect both devices physically first and then download the configu-
ration, this would result in conflicts of address. Both devices have the same
address. This is not allowed in the MPI configuration.

14.4 Troubleshooting Configuration Download Problems

When you are downloading the configuration to the OP, problems may occur.
In most cases, the reason is the simultaneous use of different drivers on the
PU or PC – for example, with a connection to a network. Table 14-1 lists pos-
sible problems and their reasons, and how to deal with them.

Table 14-1 Potential Download Problems and Their Reasons

Problem Reason Remedy

Download is
aborted after the
repeated occur-
rence of  the
message: Line
Error .

Another driver is active in the
background – for example, in
network operation.

Modify your  autoexec.bat
and config.sys  files.

Download does
not take place.

Your system.ini  file in the
Windows directory does not
contain the Windows standard
communications driver which
ProTool requires.

Check whether the sys-
tem.ini  file contains the fol-
lowing entry:
comm.drv= comm.drv .
If a different driver has been en-
tered, installed communication
programs for, say, a modem or
network are using another
driver.
Modify the configuration of
your PC or PU or install Pro-
Tool/Lite on a stand-alone PU
or PC.

Interrupt problems. 
Different boards are using the
same interrupt.

Modify the configuration of
your PC or PU, or install Pro-
Tool/Lite on a stand-alone PC
or PU.

Several OPs in MPI
configuration

Driver incompati-
bility

Compiling and Downloading a Configuration to the System
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Printing a Configuration

You can print all or part of the current configuration. Part means that you can
print either one or more chapters or individual pages of a chapter. The ex-
pression chapter refers to the type of object. All the objects of any one type
are printed in a separate chapter.

Some standard reports are featured in ProTool/Lite ex works. They are:

– Complete,

– Screens,

– Event messages,

– Alarm messages,

– Variables,

– Recipes,

– Area pointer.

Printing is initiated by choosing File → Print. Figure 15-1 shows the dialog
box. The printer and printer option settings automatically correspond to the
standard Windows functions which you set for your computer.

Figure 15-1 Print Dialog Box

In this chapter

Standard reports

Initiating printout
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In the editors for event messages, alarm messages, screens, recipes, headers
and footers, an editor-specific menu item is available on the menu bar. If you
choose Print at this point, the associated standard report is set.

You can also print to a file. For this, check in the Print dialog box the Print
to File field. If you now click the OK button, you are requested to specify the
file name. The configuration is then prepared in accordance with the printer
that you set and the data are written to the file.

You can also print separate pages of a chapter. To do this, click the corre-
sponding chapter in the Selection box and specify under Selection the pages
which you wish to print.

You can create your own style for printouts of the configuration. In this par-
ticular instance, you should remember that all settings for reports are com-
mon to all projects. The following settings are possible for reports:

– margins,

– text for headers and footers,

– parameters for individual chapters,

– creation of reports which you have defined yourself.

Pressing the Preview button provides a preview of the printout on the screen.
Here you will see how large the printout will be or the page on which an ob-
ject will appear. You can check your settings in exactly the same way.

Pressing the Reports button takes you to another dialog box, in which you
can make your settings for the reports. Make sure that you do not rename the
standard reports or delete or add chapters from or to them. Reports which you
have defined yourself must always be saved under a new name.

The parameters are special to a particular type of object. An object of an ob-
ject type comprises different components when it is configured. Some set-
tings are optional, others have to be entered. When printing, you can specify
whether all or just selected components of the objects should be printed. Fig-
ure 15-2 shows, by way of an example, the dialog box in which you can spec-
ify the parameters for variables.

Print to file

Printing separate
pages

Settings

Preview

Creating and
modifying reports

Printing a Configuration
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Figure 15-2 Variables Parameters Dialog Box

Note

Printer drivers – It might not be possible to print the configuration
if you are using CANON drivers. In this instance,
printing is aborted.

– With the Apple laser printer, the first line is omitted.
When the drivers for the HP LaserJet III
PostScript  or PostScript Printer  are used,
this problem does not occur.

ASCII With many printers it may not be sufficient to set the 
character set ASCII character set in the configuration only. Make sure

that the ASCII character set is set on the printer as well.

Printing a Configuration
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Managing the Configuration 

This chapter describes the file structure of ProTool/Lite and the functions of
the Project Manager.

If you have installed ProTool/Lite integrated into STEP 7, the Project Mana-
ger of the SIMATIC Manager is replaced. It now lets you copy, move, archi-
ve and de-archive projects in exactly the same way as your STEP 7 projects.

16.1 File Structure

Figure 16-1 shows the file structure as created in the default installation.

SAMPLES

PROLITE

������ ������
������

C

NAME.PDB �������������� ����

�������

��������

STANDARD 
���
��
� ��������������

TYPDAT.DP 
����� ����	� ����� �����

Figure 16-1 File Structure of ProTool/Lite

All files belonging to the ProTool/Lite program are installed in the C:\PRO-
LITE  directory. Furthermore, all entries required for initializing ProTool/Lite
are made in the Windows directory. ProTool/Lite is installed as separate pro-
gram group.

The directory called C:\PROLITE\STANDARD contains all the standard
configurations supplied for the different OPs; the standard screens are stored
in this directory.

In this chapter

Special features
with STEP 7 
integration

File structure of
default installation

PROLITE directory

PROLITE/
STANDARD 
directory

16



16-2
ProTool/Lite User’s Manual

Release 09/96

A separate standard configuration is available for every type of device. Table
16-1 shows the names under which standard configurations are installed.

Table 16-1 Standard Configurations 

Standard Configuration For OP

s_05.pdb OP5

s_07.pdb OP7

s_15a.pdb OP15A

s_15c4.pdb OP15C (Display 4x20)

s_15c8.pdb OP15C (Display 8x40)

s_17_4.pdb OP17 (Display 4x20)

s_17_8.pdb OP17 (Display 8x40)

s7mpi_03.pdb OP3 (for MPI connection)

s7ppi_03.pdb OP3 (for serial connection)

C7_623.pdb C7-623

C7_624_4.pdb C7-624 (Display 4x20)

C7_624_8.pdb C7-624 (Display 8x40)

The standard configurations already contain standard screens.
Table 16-2 shows the names of the standard screens and the functions imple-
mented in them.

Managing the Configuration
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Table 16-2 Standard Screens

Screen Name Function OP3 OP5
C7-623

OP7 OP15
C7-623

OP17

Z_SYSTEM_MEN Standard basic screen.
You can branch from this screen to other
standard screens

x x x x x

Z_MESS_EVENT Event messages:
– View
– Print
– Display total number
– Delete buffer
– Overflow warning ON/OFF
– Display text

– x x x x

Z_MESS_ALARM Alarm messages:
– View
– Print
– Display total number
– Delete buffer
– Overflow warning ON/OFF
– Display text

– x x x x

Z_SETTINGS  System settings:
–  Mode
– Display first/last alarm message
– Display system message buffer
– Change language
– Set date and time
– Printer parameters
– Interface parameters

x
–
x
x
x
x
x

x
x
x
x
x
x
x

x
x
x
x
x
x
x

x
x
x
x
x
x
x

x
x
x
x
x
x
x

Z_SCREEN Screens:
– Edit
– Print

x
–

x
x

x
x

x
x

x
x

Z_PASSWORD Password:
– Login
– Logout
– Edit

–
x
x

x
x
x

x
x
x

x
x
x

x
x
x

Z_RECORD Data records:
– Edit
– Print
– Transfer

–
–
–

x
x
x

x
x
x

x
x
x

x
x
x

Z_COUNTER Counter target/actual values for
S7-CPU314 or S7-CPU214:
– Set
– Display

x
x

–
–

–
–

–
–

–
–

Z_TIMER Integrated timer:
– Set
– Display

x
x

–
–

–
–

–
–

–
–

Symbolic names of variables in the standard configuration start with Z_ to
distinguish them from other configurations.

Working with standard screens on an OP is described in the Equipment
Manuals.

Managing the Configuration
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Note

Should you wish to use one or more of the standard screens in your configu-
ration, you must use the standard configuration.

When you compile your configuration, a file is created. The file is stored as
name.fud  in the same directory as the configuration file name.pdb .

Managing the Configuration
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16.2 Project Manager

The Project Manager contains functions for user-friendly management of the
configurations you create with ProTool/Lite. Using Project Manager your
project files can be

� backed,

� restored.

You call Project Manager by choosing File → Project Manager. Should you
have installed  ProTool/Lite integrated into STEP 7, this menu item is grayed
out and is therefore unavailable. The first time you call Project Manager, the
dialog box shown in figure 16-2 appears.

Figure 16-2 Search Dialog Box for Specifying Search Criteria

You specify your search criteria in this dialog box. In this case, you can
choose from the following file formats under Format:

– configurations (*.pdb ),

– backups (*.ar? ) and

– configurations/backups (*.pdb;*.ar? ).

Purpose

Calling Project
Manager

File formats

Managing the Configuration
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Under Selection,  you set your drive and directories that are important for
you. You click OK to go to the dialog box shown in figure 16-3. You select
the file here. This dialog box also appears if you call Project Manager again.
Clicking the Search button takes you back to the dialog box shown in figure
16-2.

Figure 16-3 Project Manager Dialog Box

When you select a project in the Project Manager dialog box, project-related
data are displayed.

For backing and restoring project files, Project Manager provides the func-
tions Backup and Restore. Project Manager supports data backup and restore
over several floppy disks. This is necessary, in particular, with large configu-
rations for which one floppy disk is too small.

The Backup and Restore dialog boxes are identical in structure. Figure 16-4
shows the Backup dialog box.

Selecting files

Project 
information

Backup and 
restore

Managing the Configuration
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Figure 16-4 Backup Dialog Box

When you wish to back up a configuration, you first choose the configuration
file in the Project Manager dialog box. In the Backup dialog box, you now
enter the destination drive and file name of the file you want to back up.
Backup is started by clicking the OK button.

ProTool/Lite automatically prompts you to replace the floppy disk, if neces-
sary. The backup procedure is interrupted until you insert another floppy disk
and confirm it in the displayed dialog box.

Note the floppy disk number on the floppy disk for backups involving more
than one floppy disk. This is the only successful way of reading in the backup
disks in the correct order.

You restore backups in a similar manner.

Starting Backup

Starting Restore

Managing the Configuration
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Description of Functions

This appendix contains a list of the functions featured in ProTool/Lite. This is
followed by a description of the functions.

The functions are listed in alphabetical order. The table similarly contains
details on the availability of the functions on the different OPs.

Table A-1 Functions in Alphabetical Order

Functions and Their Parameters

Function Parameters OP3 OP5 OP7 OP15 OP17 C7-623 C7-624

Alarms Buffer
Overflow

0 = OFF
1 = ON

–
–

x
x

x
x

x
x

x
x

x
x

x
x

Alarms - Delete
buffer

– – x x x x x x

Alarms – Display
First/Last

0 = First
1 = Last

–
–

x
x

x
x

x
x

x
x

x
x

x
x

Alarms - Print
buffer

0 = Chronological
1 = Together

–
–

x
x

x
x

x
x

x
x

x
x

x
x

Data Record:
OP→PLC

Recipe name
Data record number

–
–

x
x

x
x

x
x

x
x

x
x

x
x

Data Record:
PLC→OP

Recipe name
Data record number
overwrite y/n

–
–
–

x
x
x

x
x
x

x
x
x

x
x
x

x
x
x

x
x
x

Delete Data Re-
cord  

Recipe name
Data record number

–
–

x
x

x
x

x
x

x
x

x
x

x
x

Events Buffer
Overflow

0 = OFF
1 = ON

–
–

x
x

x
x

x
x

x
x

x
x

x
x

Events - Delete
buffer

– – x x x x x x

Events - Print
buffer

0 = Chronological
1 = Together

–
–

x
x

x
x

x
x

x
x

x
x

x
x

Jump within
screen

Entry number
Field number

x
x

x
x

x
x

x
x

x
x

x
x

x
x

Language 0 = Language 1
1 = Language 2
2 = Language 3

x
x
x

x
x
x

x
x
x

x
x
x

x
x
x

x
x
x

x
x
x

Message level – x x x x x x x

Message Log ON/
OFF

0 = OFF
1 = ON

–
–

x
x

x
x

x
x

x
x

x
x

x
x

In this chapter

A
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Table A-1 Functions in Alphabetical Order

Functions and Their Parameters

Function C7-624C7-623OP17OP15OP7OP5OP3Parameters

Mode 0 = Online
1 = Offline
2 = Download
3 = Loop-through connection
5 = S7 download

x
x
x
–
x

x
x
x
–
–

x
x
x
–
–

x
x
x
x
–

x
x
x
x
–

x
x
–
–
x

x
x
–
–
x

Password Logout – x x x x x x x

Print all data re-
cords

Recipe name – x x x x x x

Print all screens – – x x x x x x

Print record Recipe name
Data record number

–
–

x
x

x
x

x
x

x
x

x
x

x
x

Print Screen – – x x x x x x

Print screen 
entries

Screen Name – x x x x x x

Recipe directory 2 = Edit
5 = Print
7 = Transfer
11= Save to floppy disk
12= Load from floppy disk

–
–
–
–
–

x
x
x
x
x

x
x
x
x
x

x
x
x
x
x

x
x
x
x
x

x
x
x
x
x

x
x
x
x
x

Scaling linear Y = a*X + b
Constant a
Constant b

x – x – x – –

Select data recordRecipe name
Data record number
Entry number

–
–
–

x
x
x

x
x
x

x
x
x

x
x
x

x
x
x

x
x
x

Select Screen Screen Name
Screen entry
Field number

x
x
x

x
x
x

x
x
x

x
x
x

x
x
x

x
x
x

x
x
x

Select screen 
directory

1 = Edit
4 = Print

x
–

x
x

x
x

x
x

x
x

x
x

x
x

Description of Functions
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Table A-1 Functions in Alphabetical Order

Functions and Their Parameters

Function C7-624C7-623OP17OP15OP7OP5OP3Parameters

Select Function
Screen

Screen name; Field number
(for field number refer to table 
below)
Selections for screen name:
Display alarm buffer
Display total number of AMs
AM overflow warning
Delete AM buffer
Display EM buffer 
Display total number of EMs 
EM overflow warning
Delete EM buffer
Status variable
Force variable
Language
Language/contrast
Ch d

–
–
–
–
–
–
–
–
x
x
x
–

x
x
x
x
x
x
x
x
x
x
–
x

x
x
x
x
x
x
x
x
x
x
–
x

x
x
x
x
x
x
x
x
x
x
–
x

x
x
x
x
x
x
x
x
x
x
–
x

x
x
x
x
x
x
x
x
x
x
–
x

x
x
x
x
x
x
x
x
x
x
–
xg g

Change modes
Time/date
IF1
IF1A (RS232)
IF1A (TTY)
IF1B
IF2
IF2A/B
MPI address
Printer parameters
Display first/last AM
Display AM text
Display EM text
Display sys. msge. buffer
Login password 
Edit password

x
x
–
–
–
–
–
–
x
–
–
–
–
–
–
x

x
x
–
x
x
x
–
–
–
x
x
x
x
x
x
x

x
x
–
x
x
x
–
–
–
x
x
x
x
x
x
x

x
x
x
–
–
–
–
x
–
x
x
x
x
x
x
x

x
x
x
–
–
–
–
x
–
x
x
x
x
x
x
x

x
x
x
–
–
–
x
–
x
x
x
x
x
x
x
x

x
x
x
–
–
–
x
–
x
x
x
x
x
x
x
x

Table A-2 Fields in Function Screens

Fields in Function Screens

Function Screens Fields

Display alarm buffer –

Display total number of AMs –

AM overflow warning 1 = OFF/ON

Delete AM buffer 1 = Yes/No

Display EM buffer –

Display total number of EMs –

EM overflow warning 1 = OFF/ON

Delete EM buffer 1 = Yes/No

Description of Functions
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Table A-2 Fields in Function Screens

Fields in Function Screens

Function Screens Fields

Status variable –

Force variable –

Language 1 = Language 1/2/3

Language/contrast 1 = Contrast
2 = Language 1/2/3

Mode 1 = Online/Offline/Download/
Loop-through connection/
S7 download

Time/Date 1 = Date
2 = Time

IF1 1 = Baud rate
2 = Data bits
3 = Stop bits
4 = Parity

IF1A 1 = Baud rate
2 = Data bits
3 = Stop bits
4 = Parity
5 = PLC protocol

IF1B 1 = Baud rate
2 = Data bits
3 = Stop bits
4 = Parity
5 = PLC protocol

IF2A/B 1 = Baud rate
2 = Data bits
3 = Stop bits
4 = Parity

MPI address 1 = Address

Printer parameters 1 = Characters per line 
2 = Lines per page 
3 = Message log ON/OFF

Display first/last AM 1 = ON/OFF

Display AM text –

Display EM text –

Display sys. msge. buffer –

Login password 1 = Password

Edit password 1–20 = Passwords

Description of Functions
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A.1 Description of functions

Enables or disables the warning that the remaining buffer size has been
reached. If you press the key on the OP, the value set as the parameter be-
comes effective.

The contents of the alarm buffer are deleted.

The first or last message received is displayed. This setting is effective when
several alarm messages are queued.

The contents of the alarm buffer are printed. The parameters determine the
order in which messages are fetched from the buffer. With Chronological,
messages are printed in chronological order. With Together, messages having
the same message number are printed together.

The data record is transferred from the OP to the PLC.

The data record is tranferred from the PLC to the OP. The recipe and data
record are set by means of the parameter.

The data record will be deleted. The parameters determine the recipe and the
data record.

Enables or disables the warning that the remaining buffer size has been
reached. If you press the key on the OP, the value set as the parameter be-
comes effective.

The contents of the event buffer are deleted.

The contents of the event buffer are printed. The parameters determine the
order in which event messages are fetched from the buffer. With Chronolog-
ical, messages are printed in chronological order. With Together, messages
having the same message number are printed together.

This function allows you to go to a specific screen entry rather than having to
scroll through the screen entries. This applies to the currently selected screen
only. If you specify the field number, the cursor is already in this field. With
a field number of 0, the cursor is positioned at the beginning of the entry.

Alarms Buffer
Overflow

Alarms – Delete
buffer

Alarms – Display
First/Last

Alarms – Print
buffer

Data Record:
OP→PLC

Data Record:
PLC→OP

Delete Data Record

Events Buffer
Overflow

Events – Delete
buffer

Events – Print
buffer

Jump within
screen

Description of Functions
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The language is changed on the OP. If you press the key on the OP, the value
set as the parameter becomes effective.

Directly selects the message level.

Enables or disables automatic printing of messages. If you press the key on
the OP, the value set as the parameter becomes effective.

Changes the mode on the OP. When you press the key, the OP changes to the
mode specified as the parameter.

The user is logged out when the key is pressed. The display on the OP reverts
to message level. Password level 0 is now set.

All data records of the recipe specified under parameter are printed. The se-
quence of the printout depends on the data record number.

All screens are printed, in screen number order.

Prints the data record of a recipe. The parameters determine the recipe and
the data record.

The contents you can see on the display are printed.

Prints a screen with all screen entries.

Recipes are listed in numerical order. The parameters refer to the data re-
cords. First, select a recipe on the OP, then select the data record.
Depending on the parameters that have been set, the data record has to be
edited, it is printed or it is transferred to or from the PLC.
With the OP15, the data record can be saved to floppy disk or can be loaded
onto the OP from floppy disk.

Y = a*X + b ,  Y = display value/input value
The X value read from the PLC is converted linearly before being displayed
on the OP as Y. Y inputs on the OP are likewise converted to X before being
transferred as a value to the PLC.

Language

Message Level

Message Log
ON/OFF

Mode

Password Logout

Print all data 
records

Print all screens

Print record

Print Screen

Print screen
entries

Recipe directory

Scaling linear

Description of Functions
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Calls the data record of a recipe.
Specify the data record number to view the data record on the display. Speci-
fy the entry number to position the cursor in the entry of the data record. 
Specify –1 for the data record number or the entry number to position the
cursor on the first data record or in the first entry of the first data record.

A function screen is a screen stored in the firmware. It cannot be modified in
the configuration. Function screens implement functions which have already
been configured and which you can use to perform settings on the device.
When you specify –1  as the field number, the cursor is positioned on the first
input field.

Calls a screen.
By specifying the screen entries, you can immediately view the entry on the
display. When you specify the field number, the cursor is already positioned
in the field.
When you specify –1  as the screen entry and field number, the cursor is posi-
tioned in the first entry or first input field.

Lists the screens in numerical order.
With Edit, the selected screen is called and can be edited. With Print, the
selected screen is printed.

Select data record

Select Function
Screen

Select screen

Select screen
directory

Description of Functions
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Code Tables

When configuring text for

– messages,

– screens,

– recipes,

– information text,

– symbol lists,

– headers and footers

you can also use special characters and language-dependent characters. You
can see the characters on the screen.

The OPs cannot display all characters, however. For some versions, lan-
guage-dependent characters are also loaded with the language. Language-de-
pendent characters such as ä and é cannot be mixed. The following table lists
the characters that can be used with the different OPs. If you edit a character
that cannot be displayed on the OP, a blank is shown instead on the OP.

Special characters can be entered on the keypad. Enter ALT+0XXX, XXX be-
ing the ANSI code in the following table.

Using ALT + GR, you can convert the keyboard to graphic characters. By
choosing Window→ Keyboard from the menu, you can open a keyboard as-
signment on the screen. You then enter the graphic characters either by
means of the keyboard or the keyboard assignment, in which you click the
mouse on the corresponding keys.

The OP15C also has Cyrillic character capability. Russian text is configured
in ProTool/Lite in the same way as for other languages with the Windows
standard character set. If you set in ProTool/Lite the configuration language
to Russian, the keyboard behaves in the following manner:

– Lower-case letters and some special characters are shown as Cyrillic
characters in accordance with the following table.

– Upper-case letters and numerals are displayed in unmodified form.

Special characters
and language-
dependent charac-
ters

Characters not for
display

Entering special
characters

Cyrillic character
set

B
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In the following table, letters in parentheses indicate the language. This char-
acter is only available when that language is set. The letters stand for the fol-
lowing languages:

D for German

E for English

F for French

I for Italian

S for Spanish

Language 
identifiers

Code Tables
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PLC Jobs

This part of the Appendix contains a listing of all PLC jobs together with
their parameters.

PLC jobs enable functions such as the following to be triggered on the OP by
means of the PLC program:
– Display screen 
– Set date and time
– Change general settings

A PLC job consists of 4 data words. The first data word contains the job
number. Up to three parameters are transferred in data words 2 to 4, depend-
ing on the function. The basic structure of a PLC job is shown in Fig. C-1.

01st word

Left byte (LB) Right byte (RB)

Job no.

Parameter 1

Parameter 2

Parameter 3

Address

2nd word

3rd word

4th word

Figure C-1 Structure of a PLC job

The listing shows all the PLC jobs which can be programmed for the various
text displays and operator panels, together with their parameters. The No.
column specifies the PLC job number. Jobs can only ever be triggered by the
PLC if the TD/OP is in online mode.

No. Function

O
P

5
O

P
7

O
P

15
O

P
17

C
7-

62
3

C
7-

62
4

1 Operating mode selection for OP � � � � � �

Parameter 1 1: Offline
2: Transfer

Parameters 2, 3 –

The OP cannot be switched to online mode by means of a PLC job!

Description

Listing

C
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No.

C
7-

62
4

C
7-

62
3

O
P

17
O

P
15

O
P

7
O

P
5

Function

3 Printout � � � � � �

Parameters 1, 2, 3 –

5 Select directory

Parameter 1 1: Directory: screens, display
2: Directory: recipes, display
4: Directory: print screens
5: Directory: print recipes
7: Directory: recipes, data record transfer

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

Parameters 2, 3 –

7 Print all screens � � � � � �

Parameters 1, 2, 3 –

10 Print recipe with all data records � � � � � �

Parameter 1 Recipe number (1..99)

Parameters 2, 3 –

11 Select special screen

The following screens integrated in the firmware can be selected via their (fixed) object num-
bers.

Parameter 1 DL: Cursor inhibit (0 = off/1 = on)
DR: Special screen number

� � � � � �

Alarm buffer
1 Buffer output
2 Output number of messages
3 Overflow warning, on/off
4 Delete buffer, yes/no

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

Event buffer
5 Buffer output
6 Output number of messages
7 Overflow warning, on/off
8 Delete buffer, yes/no

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

PU functions
25 Status VAR
26 Control VAR

�

�

�

�

�

�

�

�

�

�

�

�

Special functions
30 Language selection, brightness (contrast)
31 Change operating mode

�

�

�

�

�

�

�

�

�

�

�

�

Settings
35 Set date/time
36 Internal interface (OP5/OP7: V.24; OP15/OP17: IF11) 
37 Module interface (OP5/OP7: TTY; OP15/OP17: IF2)
38 Printer parameters
40 Message type

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

�

Message texts
45 Display alarm texts
46 Display event texts

�

�

�

�

�

�

�

�

�

�

�

�

System messages
50 Output system message buffer � � � � � �

PLC Jobs
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No.

C
7-

62
4

C
7-

62
3

O
P

17
O

P
15

O
P

7
O

P
5

Function

Password
55 Login
56 Password entry

�

�

�

�

�

�

�

�

�

�

�

�

Parameters 2, 3 –

12 Enable/disable message log � � � � � �

Parameter 1 0: Off
1: On

Parameters 2, 3 –

13 Change language � � � � � �

Parameter 1 0: 1st language
1: 2nd language
2: 3rd language

Parameters 2, 3 –

14 Set time (BCD-coded) � � � � � �

Parameter 1 DL: –
DR: Hours (0..23)

Parameter 2 DL: Minutes (0..59)
DR: Seconds (0..59)

Parameter 3 –

15 Set date (BCD-coded) � � � � � �

Parameter 1 DL: –
DR: Day (1..7: Sunday...Saturday)

Parameter 2 DL: Date (1..31)
DR: Month (1..12)

Parameter 3 DL: Year

16 Internal interface parameters (OP5/OP7: V.24; OP15/OP17: IF1) � � � � � �

Parameter 1 Value for parameter 2

Baud rate (only for FAP and printer)
0:     300 baud
1:     600 baud
2:   1200 baud
3:   2400 baud
4:   4800 baud
5:   9600 baud
6: 19200 baud (only for FAP)

Data bits (only for FAP and printer)
0: 7 data bits
1: 8 data bits

Stop bits (only for FAP and printer)
0: 1 stop bit
1: 2 stop bits

Parity  (only for FAP and printer)
0: Even
1: Odd
2: None

PLC Jobs
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No.

C
7-

62
4

C
7-

62
3

O
P

17
O

P
15

O
P

7
O

P
5

Function

OP address 1..30 (only for SINEC L1)

Parameter 2 Interface parameters to be set
0: Baud rate
1: Data bits
2: Stop bits
3: Parity
4: OP address (only for SINEC L1)

Parameter 3 –

17 Module interface parameters (OP5/OP7: TTY; OP15/OP17: IF22) � � � � � �

Parameter 1 Value for parameter 2

Baud rate (only for FAP)
0:     300 baud
1:     600 baud
2:   1200 baud
3:   2400 baud
4:   4800 baud
5:   9600 baud
6: 19200 baud

Data bits (only for FAP)
0: 7 data bits
1: 8 data bits

Stop bits (only for FAP)
0: 1 stop bit
1: 2 stop bits

Parity  (only for FAP)
0: Even
1: Odd
2: None

OP address 3..122 (for SINEC L2-DP)

Parameter 2 Interface parameters to be set
0: Baud rate
1: Data bits
2: Stop bits
3: Parity
4: OP address

(only for SINEC L1, SINEC L2 and SINEC L2-DP)
5: PLC address (only for SINEC L2)
6: OP-SAP (only for SINEC L2)
7: PLC-SAP (only for SINEC L2)

Parameter 3 –

PLC Jobs
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C
7-

62
4

C
7-

62
3

O
P

17
O

P
15

O
P

7
O

P
5

Function

19 Printer parameters � � � � � �

Parameter 1 Value for parameter 2

Number of characters/line 
0: 20 characters/line
1: 40 characters/line
2: 80 characters/line

Number of lines/page
0: 60 lines/page
1: 61 lines/page
 ...
12: 72 lines/page

Parameter 2 Printer parameters to be set
0: Number of characters per line
1: Number of lines per page

Parameter 3 –

21 Type of display, alarm messages � � � � � �

Parameter 1 0: First value (oldest message)
1: Last value (latest message)

Parameters 2, 3 –

22 Set display contrast � � � � � �

Parameter 1 0..15

Parameters 2, 3 –

23 Set password level � � � � � �

Parameter 1 1..9
(1 = lowest password level,
9 = highest password level)

Parameters 2, 3 –

24 Password logout � � � � � �

Parameters 1, 2, 3 –

29 Print nproduction report � � � � � �

Parameters 1, 2, 3 –

31 Print alarm buffer � � � � � �

Parameter 1 0: Print chronologically 
1: Print together

Parameters 2, 3 –

32 Print event buffer � � � � � �

Parameter 1 0: Print chronologically 
1: Print together

Parameters 2, 3 –

Parameters 1, 2, 3 –

37 Enable/disable overflow warning for event messages � � � � � �

Parameter 1 0: Off
1: On

Parameters 2, 3 –

PLC Jobs
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C
7-

62
4

C
7-

62
3

O
P

17
O

P
15

O
P

7
O

P
5

Function

38 Enable/disable overflow warning for alarm messages � � � � � �

Parameter 1 0: Off
1: On

Parameters 2, 3 –

41 Transfer date/time to PLC � � � � � �

Triggering this job too often may overload the TD/OP since two transfers to the PLC are re-
quired for each job.

Parameters 1, 2, 3 –

42 Fetch LED area from PLC – � � � – �

Parameter 1 Block number 1..4

Parameters 2, 3 –

43 Fetch event bit area from PLC � � � � � �

Parameter 1 Block number: 1..4

Parameters 2, 3 –

44 Fetch alarm bit area from PLC � � � � � �

Parameter 1 Block number: 1..4

Parameters 2, 3 –

45 Fetch acknowledgment area from PLC � � � � � �

Parameter 1 Block number: 1..4

Parameters 2, 3 –

47 Transfer LED area directly to OP – � � � – �

Parameter 1 LED assignment area number: 1..4

Parameter 2 LED assignment: 1st word

Parameter 3 LED assignment: 2nd word

Unlike with job no. 42, the LED assignment is transferred directly with the PLC job, so that the
LEDs are driven faster. The specified LED area must not be configured larger than 2 DW!

49 Delete event buffer � � � � � �

Parameters 1, 2, 3 –

50 Delete alarm buffer � � � � � �

Parameters 1, 2, 3 –

51 Select screen � � � � � �

Parameter 1 DL: Cursor inhibit (0: off; 1: on)
DR: Screen number 1..99

�

�

�

�

�

�

�

�

�

�

�

�

Parameter 2 Entry number: 0..99
(0: Cursor positioned to first entry)

� � � � � �

Parameter 3 Field number: 0..8 
Output fields are ignored by the serial numbering system!

� � � � � �

PLC Jobs
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No.

C
7-

62
4

C
7-

62
3

O
P

17
O

P
15

O
P

7
O

P
5

Function

Note on:
The input fields of an entry are numbered consecutively:

0 Entry number field
1 First input field
:
n Last input field

The numbering of the input fields starts at 1 again for each entry.

52 Print screen � � � � � �

Parameter 1 Screen number (1..99), format: KY

Parameters 2, 3 –

53 Select recipe � � � � � �

Parameter 1 DL: Cursor inhibit (0: off; 1: on)
DR: Recipe number (1..99)

Parameter 2 Data record number (1..99)

Parameter 3 DL: Entry number (0..99)
(0: Cursor positioned to first entry)

DR: Field number (0/1)
The input fields of an entry are numbered consecutively:

0 Entry number field
1 First input field
:
n Last input field

The numbering of the input fields starts at 1 again for each entry.

Output fields are ignored by the serial numbering system!

54 Print recipe � � � � � �

Parameter 1 Recipe number (1..99)

Parameter 2 Data record number (1..99)

Parameter 3 –

69 Transfer recipe data record to OP � � � � � �

Parameter 1 Recipe number: 1..99

Parameter 2 Data record number: 1..99

Parameter 3 0,1
0: Data record is not overwritten.
1: Data record is overwritten.

70 Transfer recipe data record from OP to PLC � � � � � �

Parameter 1 Recipe number: 1..99

Parameter 2 Data record number: 1..99

Parameter 3 –

71 Partial screen update � � � � � �

Parameter 1 0: Off
1: On

Parameters 2, 3 –

Trigger this job only when no screen is selected.

PLC Jobs
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No.

C
7-

62
4

C
7-

62
3

O
P

17
O

P
15

O
P

7
O

P
5

Function

72 Cursor positioning on current screen or in current recipe � � � � � �

Parameter 1 Entry number: 0..99 � � � � � �

Parameter 2 Field number: 0..8 � � � � � �

Parameter 3 Cursor inhibit (0: off; 1: on) � � � � � �

73 Cursor positioning on current special screen � � � � � �

Parameter 1 Field number (0..8)

Parameter 2 Cursor inhibit (0: off; 1: on)

Parameter 3 –

74 Keyboard simulation � � � � � �

Parameter 1 DL: Keyboard number
1 internal function keyboard
2 system keyboard

DR: Password level
0: Is evaluated
1: Is not evaluated

Parameter 2 DL: First key code
DR: Second key code

(If only one key operation is to be simulated,
the second key code must be set to 0.)

A diagram of the key codes can be found in section C.2.

Parameter 3 –

When the keyboard is simulated by means of a PLC job, the transfer time from the PLC to the
OP is important. An acknowledgment of an alarm message by means of a keyboard simulation
in the PLC program, for example, may lead to an unwanted result if:
– This alarm message has already been acknowledged by

means of an operator action on the OP,
– A new alarm message or system message is received 

before the job is evaluated.

PLC Jobs
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C.1 Special Situations – PLC Jobs

The selected input field can no longer be exited with the arrow keys or the
ESC key if the ”cursor inhibited” parameter is not specified as 0 in one of
jobs 11, 51, 53, 72 and 73. The cursor inhibit cannot be canceled until one of
the following actions is taken:

� Repetition of the job with cursor inhibit = 0

� Another job which causes a change in the indication on the display

The system message “$400 Invalid entry ” is displayed if an attempt
is made to exit the entry field while the cursor is inhibited.

PLC jobs with 
cursor inhibited

PLC Jobs
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C.2 Key Codes

The key codes are shown below. These codes are required, for example, for PLC job no. 74 (keyboard
simulation).

OP5:
F1...F6: 1...6

OP7:
F1...F4: 1...4 
K1...K4 5...8

OP15, C7-623, C7-624:
F1...F16: 1...16

OP17:
F1...F8: 1...8
K1...K16 9...24

OP5 and OP15, C7-623 and C7-624:

7 8 9 INS
DEL

4 5 6
HARD
COPY

1 2 3

0 +/–

SHIFT

D E F

A B C

.

1

7

13

19

2

8

14

20

3

9

15

21

4

10

16

22

5

11

17

23

6

12

18

24HELP

ESC

ACK

ENTER

OP7 and OP17:

7 8 9 DEL
INS

4 5 6

1 2 3

0 +/–

SHIFT

D E F

A B C

.

1

7

13

19

2

8

14

20

3

9

15

21

4

10

16

22

5

11

17

23

6

12

18

24HELP

ACK

ESC

ENTER

Function keys

System keys

PLC Jobs
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Siemens Worldwide

In this appendix you will find a list of:

� All cities in the Federal Republic of Germany with Siemens Sales Offices
and

� All European and non-European Siemens Companies and Representatives

The following table lists all Siemens Sales Offices in the Federal Republic of
Germany.

Aachen

Augsburg

Bayreuth

Berlin

Bielefeld

Bonn

Bremen

Brunswick

Chemnitz

Coblenz

Cologne

Constance

Darmstadt

Dortmund

Dresden

Duisburg

Düsseldorf

Erfurt

Essen

Frankfurt am Main

Freiburg

Hamburg

Heilbronn

Karlsruhe

Kassel

Kempten/Allg.

Kiel

Laatzen

Leipzig

Lingen

Magdeburg

Mainz

Mannheim

Munich

Münster/Westf.

Nuremberg

Osnabrück

Regensburg

Rostock

Saarbrücken

Siegen

Stuttgart

Ulm

Wetzlar

Wilhelmshaven

Wuppertal

Würzburg

In this Appendix

Siemens Sales Of-
fices in the Federal
Republic of Ger-
many

D
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The following  table lists all European Siemens Companies and
Representatives.

Austria

Siemens AG Österreich

� Bregenz

� Graz

� Innsbruck

� Linz

� Salzburg

� Vienna

Belgium

Siemens S.A.

� Brussels

� Liège

Siemens N. V.

� Antwerp

Bosnia-Herzegovina

Generalexport Predstavnistvo Sarajevo

� Sarajevo

Bulgaria

Siemens AG, Bulgaria Representative

� Sofia

Croatia

Siemens d. o. o.

� Zagreb

Cyprus

GEVO Ltd.

or

Jolali Ltd.

� Nicosia

Czech Republic

Siemens AG

� Brno

� Mladá Boleslav

� Prague

Denmark

Siemens A/S

� Copenhagen, Ballerup

Finland

Siemens Oy

� Espoo, Helsinki

France

Siemens S.A.

� Haguenau

� Lille, Seclin

� Lyon, Caluire-et-Cuire

� Marseille

� Metz

� Paris, Saint-Denis

� Strasbourg

� Toulouse

Great Britain

Siemens plc

� Birmingham, Walsall

� Bristol, Clevedon

� Congleton

� Edinburgh

� Glasgow

� Leeds

� Liverpool

� London, Sunbury-on-Thames

� Manchester

� Newcastle

Greece

Siemens A.E.

� Athens, Amaroussio

� Thessaloniki

Hungaria

Siemens Kft

� Budapest

Iceland

Smith & Norland H/F

� Reykjavik

Ireland

Siemens Ltd.

� Dublin

European
Companies and
Representatives

Siemens Worldwide
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Italy

Siemens S.p.A.

� Bari

� Bologna

� Brescia

� Casoria

� Florence

� Genoa

� Milan

� Padua

� Rome

� Turin

Luxemburg

Siemens S.A.

� Luxemburg

Malta

J. R. Darmanin & Co. Ltd.

� Valletta

Netherlands

Siemens Nederland N.V.

� The Hague

� Rijswijk

Norway

Siemens A/S

� Bergen

� Oslo

� Stavanger

� Trondheim

Poland

Siemens GmbH

� Gdansk-Letnica

� Katowice

� Warsaw

Portugal

Siemens S.A.

� Albufeira

� Coímbra

� Lisbon, Amadora

� Matosinhos

� Porto

Romania

Siemens birou de consultatii tehnice

� Bukarest

Russia

Siemens AG

or

Mosmatic

� Moscow

Siemens AG

� Ekaterinburg

Slovak Republic

Siemens AG

� Bratislava

Slovenia

Siemens d. o. o.

� Ljubljana

Spain

Siemens S.A.

� Barcelona

� Bilbao

� Gijón

� Granada

� La Coruña

� Las Palmas de Gran Canaria

� León

� Madrid

� Málaga

� Murcia

� Palma de Mallorca

� Pamplona

� Sevilla

� Valencia

� Valladolid

� Vigo

� Zaragoza

Sweden

Siemens AB

� Göteborg

� Jönköping

� Malmö

� Sundsvall

� Upplands Väsby, Stockholm

Siemens Worldwide
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Switzerland

Siemens-Albis AG

� Basel

� Bern

� Zürich

Siemens-Albis S.A.

� Renens, Lausanne

Turkey

SIMKO

� Adana

� Ankara

� Bursa

� Istanbul

� Izmir

� Samsun

Ukraine

Siemens AG

� Kiev

The following table lists all non-European Siemens Companies and
Representatives of Siemens AG.

The following table lists all Siemens Companies and Representatives of
Siemens AG in Africa.

Algeria

Siemens Bureau d’Alger

� Alger

Angola

TECNIDATA

� Luanda

Bophuthatswana

Siemens Ltd.

� Mafekeng

Egypt

Siemens Technical Office

� Cairo-Mohandessin

Siemens Technical Office

� Alexandria

EGEMAC S.A.E.

� Cairo-Mattaria

Ethiopia

Addis Electrical Engineering Ltd.

� Addis Abeba

Ivory Coast

Siemens AG

� Abidjan

Libya

Siemens AG, Branch Libya

� Tripoli

Morocco

SETEL

Société Electrotechnique et de Télécommunications S.A.

� Casablanca

Mozambique

Siemens Liaison Office

� Maputo

Namibia

Siemens (Pty.) Ltd.

� Windhoek

Nigeria

Electro Technologies Nigeria Ltd. (ELTEC)

� Lagos

Rwanda

Etablissement Rwandais

� Kigali

Sambia

Electrical Maintenance Lusaka Ltd.

� Lusaka

Simbabwe

Electro Technologies Corporation (Pvt.) Ltd. (ETC)

� Harare

Non-European
Companies and
Representatives

Africa

Siemens Worldwide
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South Africa

Siemens Ltd.

� Cape Town

� Durban

� Johannesburg

� Middelburg

� Newcastle

� Port Elizabeth

� Pretoria

Sudan

National Electrical & Commercial Company (NECC)

� Khartoum

Swaziland

Siemens (Pty.) Ltd.

� Mbabane

Tanzania

Tanzania Electrical Services Ltd.

� Dar-es-Salaam

Tunesia

Sitelec S.A.

� Tunis

Zaire

SOFAMATEL S.P.R.L.

� Kinshasa

The following table lists all Siemens Companies and Representatives of
Siemens AG in America.

Argentina

Siemens S.A.

� Bahía Blanca

� Buenos Aires

� Còrdoba

� Mendoza

� Rosario

Bolivia

Sociedad Comercial é Industrial Hansa Ltda.

� La Paz

Brazil

Siemens S.A.

� Belém

� Belo Horizonte

� Brasilia

� Campinas

� Curitiba

� Fortaleza

� Pôrto Alegre

� Recife

� Rio de Janeiro

� Salvador de Bahia

� São Paulo

� Vitória

Canada

Siemens Electric Ltd.

� Montreal, Québec

� Toronto

Chile

INGELSAC

� Santiago de Chile

Colombia

Siemens S.A.

� Barranquilla

� Bogotá

� Cali

� Medellín

Costa Rica

Siemens S.A.

� Panama

� San José

Cuba

Respresentación

Consult iva EUMEDA

� La Habana

Ecuador

Siemens S.A.

� Quito

America

Siemens Worldwide
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El Salvador

Siemens S.A.

� San Salvador

Guatemala

Siemens S.A.

� Ciudad de Guatemala

Honduras

Representaciones Electroindustriales S de R.L. -
Relectro

� Tegucigalpa

Mexico

Siemens S.A. de CV

� Culiacán

� Gómez Palacio

� Guadalajara

� León

� México, D.F.

� Monterrey

� Puebla

Nicaragua

Siemens S.A.

� Managua

Paraguay

Rieder & Cia. S.A.C.I.

� Asunción

Peru

Siemsa

� Lima

United States of America

Siemens Industrial Automation Inc.

Automation Division

� Alpharetta, GA

Numeric Motion Control

� Elk Grove Village, Illinois

Uruguay

Conatel S.A.

� Montevideo

Venezuela

Siemens S.A.

� Caracas

� Valencia

The following table lists all Siemens Companies and Representatives of
Siemens AG in Asia.

Bahrain

Transitec Gulf

� Manama

Bangladesh

Siemens Bangladesh Ltd.

� Dhaka

Brunei

� Brunei Darussalam

Hong Kong

Siemens Ltd.

� Hong Kong

India

Siemens Limited

� Ahmedabad

� Bangalore

� Bombay

� Calcutta

� Madras

� New Delhi

� Secúnderabad

Indonesia

P.T. Siemens Indonesia, P.T. Siemens Dian-Grana
Elektrika, Representative Siemens AG

� Jakarta

Asia

Siemens Worldwide
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Iraq

Samhiry Bros. Co. Limited

or

Siemens AG (Iraq Branch)

� Baghdad

Iran

Siemens S.S.K.

� Teheran

Japan

Siemens K.K.

� Tokyo

Korea

Siemens Ltd.

� Changwon

� Seoul

� Ulsan

Kuwait

National & German Electrical and Electronic Services
Co. (NGEECO)

� Kuwait, Arabia

Lebanon

Ets. F.A. Kettaneh S.A.

� Beirut

Malaysia

Siemens Electrical Engineering Sdn. Bhd.

� Kuala Lumpur

Nepal

Amatya Enterprises (Pvt.) Ltd.

� Kathmandu

Oman

Waleed Associates

� Muscat

Pakistan

Siemens Pakistan Engineering Co., Ltd.

� Islamabad

� Karachi

� Lahore

� Peshawar

� Quetta

People’s Republic of China

Siemens AG Representation

� Beijing

� Guangzhou

� Shanghai

Philippine Islands

Maschinen & Technik Inc. (MATEC)

� Manila

Qatar

Trags Electrical Engineering and Air Conditioning Co.

� Doha

Saudi Arabia

Arabia Electric Ltd. (Equipment)

� Al-Khobar

� Jeddah

� Riyadh

Singapore

Siemens (Pte.) Ltd.

� Singapore

Sri Lanka

Dimo Limited

� Colombo

Syria

Siemens AG, Branch (A.S.T.E.)

� Damascus

Taiwan

Siemens Ltd., TELEUNION Engineering Ltd.

or

TAI Engineering Co., Ltd.

� Taichung

� Taipei

Thailand

Berti Jucker Co. Ltd.

� Bangkok

Siemens Worldwide
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United Arab Emirates

Electro Mechanical Co.

or

Siemens Resident Engineers

� Abu Dhabi

Scientechnic

or

Siemens Resident Engineers

� Dubai

Vietnam

OAV Representative Office

� Hanoi

Yemen (Arab. Republic)

Tihama Tractors & Engineering Co., Ltd.

or

Siemens Resident Engineers

� Sanaa

The following table lists all Siemens Companies and Representatives of
Siemens AG in Australia

Australia

Siemens Ltd.

� Adelaide

� Brisbane

� Melbourne

� Perth

� Sydney

New Zealand

Siemens Ltd.

� Auckland

� Wellington

Australia

Siemens Worldwide
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Index

A
Acknowledgement OP , 13-3
Acknowledgement PLC, 13-3
Acknowledgment area, 8-12
Active window, 4-2
Alarm, display type, C-5
Alarm message acknowledgment area, number,

8-2
Alarm message area, 8-2
Alarm messages, 3-2, 5-10, 5-13, 8-12, 13-3

first/last, 8-14
Alarms – Delete buffer, A-1, A-5
Alarms – Display First/Last, A-1, A-5
Alarms – Print buffer, A-1, A-5
Alarms Buffer Overflow, A-1, A-5
AM Chronological, 5-17
AM Together, 5-17
Archive, 16-6
Area pointer, screen number, 7-13
Area pointers, 3-4, 5-3, 13-2
ASCII character set, B-1
ASCII character set, 15-3
Assigning function keys, 5-19
Assigning soft keys, 7-9
Association, of messages in event message area,

8-3

B
Backup, 16-6
Basic screen, 7-12
Baud rate, 14-2
Bit in variable, 7-10
Bit number, 8-3, 11-11
Buffer overflow, 13-1

C
Cable set, 14-2
Call, online Help, 4-3
Call screen, 7-5
Cancel, 4-10
Change of text display, 5-16

Chapter, 15-1
Character format, 4-7
Character set

language-dependent, 12-5
of OP, B-1

Characters, B-1
per line, 5-3

Choose, dialog box, 4-10
Click, 4-1
Clipboard, 5-18
Close, dialog box, 4-10
Code tables, B-1
Communication areas, 5-3, 11-1
Compile, 5-1, 14-1

configuration, 5-3, 16-4
Components of a configuration, 1-2
Configurable objects, 3-1
Configuration, 1-1

compile, 5-3
components, 1-2
data, 1-1
download, 9-11
fields, 7-2
managing, 16-1, 16-5
phase, 1-1
print, 1-2
procedure, 5-2
step by step, 5-2
variable, 6-2

Configuration language, 12-1
Configuration printout, 15-1
Configure

in different languages, 12-1
in Russian, 12-4
menu items for settings, 5-10
output fields for messages, 8-6
settings, 5-10

Configuring, in several languages, 12-3
Configuring Input Fields, 9-4
Context-sensitive  help, 4-3
Control and acknowledgement bits, 11-3
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Copy, 5-18
button, 4-7
clipboard, 5-18
standard configuration, 7-12

CPU, 2-1
Create, recipe, 9-8
Created by, project, 4-9
Cross-reference, 4-9
Cursor

inhibit, C-9
positioning, C-8

Cut, 5-18
button, 4-7

Cyrillic characters, 12-4, B-1

D
Data areas, 13-2

date, 11-7
screen number area, 7-13
system keyboard assignment, 11-9
time, 11-7

Data bits, C-3, C-4
Data mailbox, 9-7, 13-3
Data record, 9-1, 9-7

create, 9-11
delete, A-1, A-5
name, 9-7
OP –> PLC, A-1, A-5, C-7
PLC –> OP, A-1, A-5, C-7
print, A-2
transfer, 9-12, 9-13

Data record transfer, synchronization, 11-5
Data records, creating, 9-7
Data structure, 9-1
Data transfer rate, C-3, C-4
Date created, project, 4-9
Date format, 13-1
Default printer, 13-1
Delete

alarm buffer, C-6
event buffer, C-6

Delete data record, A-1, A-5
Description, Working with ProTool/Lite, 4-1
Description of functions, A-1
Device, general details, 4-9
Device type, 5-1, 5-3
Device-Specific Functional Overview, 3-1

Dialog box
branching, 4-10
choose, 4-10
close, 4-10

Digits behind the decimal points, 6-4
Directory structure, 16-1
Display, 5-3, 7-3, 8-7, 9-5

contrast, C-5
Display levels, 12-1
Display options, 8-14
Display partitioning, 5-3
Double-click, 4-1
Download, 5-1, 14-1, 14-2

baud rate, 14-2
troubleshooting problems, 14-4

Download using, 3-5
Download phase, 1-1
Download problems, 14-4
Downloading

serial, 14-2
with MPI, 14-3

Downloading a configuration, 5-4, 14-2
DP direct keys, 5-20
Drag, 4-1
Drivers, 3-4

E
Edit, 4-5

languages, 12-1
Editing language, 12-1
Editing the symbol  list, 7-4
Editor

alarm messages, 5-13
event messages, 5-13
headers and footers, 5-16
messages, 8-1
Object types, 5-13
recipe, 9-1
recipes, 5-14
scheduler, 5-15
screens, 5-13
symbol lists, 5-13
variables, 5-13, 5-14

Editors, 4-6, 5-12
EM Chronological, 5-17
EM Together, 5-17

Index



Index-3
ProTool/Lite User’s Manual
Release 09/96

Enable/disable overflow warning for alarm mes-
sages, C-6

Event message area, 8-2
Event messages, 3-1, 5-10, 5-13, 8-9, 13-3
Events – Delete buffer, A-1, A-5
Events – Print buffer, A-1, A-5
Events buffer overflow, A-1, A-5
Exit, dialog box, 4-10

F
F1 key, 4-3
Fetch

acknowledgment area, C-6
alarm bit area, C-6
event bit area, C-6
LED area, C-6

Field configuration, 7-2
Field type, 7-3, 8-7, 9-5
Fields

date and time, 7-2, 8-6
display, 7-3, 8-7, 9-5
field type, 7-3, 8-7, 9-5
input, 7-2, 9-4
input/output, 7-2
output, 7-2, 8-6
settings, 7-3, 8-7, 9-5
usage, 7-3, 8-7, 9-5

File, 4-5
open, 4-7

File structure, 16-1
Firmware, 4-9, 13-1
Floppy disk drive, 2-1
Function

Data record: OP – PLC, A-1
Data record: PLC – OP, A-1
Delete data record, A-1
keys, C-10
Print all data records, A-2
Print record, A-2
Recipe-directory, A-2
Select data record, A-2
select screen, 7-5

Function key
assign, 11-10
assign functions, 10-1
assignment, 5-19
global assignment, 5-19
local assignment, 5-19

Function keyboard, 13-3
Function keys, 3-3

SHIFT+function, 5-20
Function screen, Screen number area , 7-13
Function screens, A-3
Functions, 7-10, 10-1, A-1

Alarms – Delete buffer, A-1
Alarms – Display first/last, A-1
Alarms – Print buffer, A-1
Alarms Buffer Overflow, A-1
device-specific, 3-1
Events – Delete buffer, A-1
Events – Print buffer, A-1
Events buffer overflow, A-1
Function screens, A-3
general, 3-1
Jump within screen, A-1
keys and  key combinations, 4-1
Language, A-1
Message level, A-1
Message Log ON/OFF, A-1
Mode, A-2
parameters, 10-2
Password logout, A-2
Print all screens, A-2
Print screen, A-2
Print screen entries, A-2
Scaling linear, 10-3, A-2
Scaling square, 10-3
Select function screen, 10-3, A-3
Select screen, A-2
Select screen directory, A-2
with parameters, 10-2
without parameters, 10-2

G
General

functions, 3-1
settings, 4-8

General settings, 5-1
Global assignment, 5-19
Graphic characters, enter, B-1
Graphics card, 2-1
Green text (topic), 4-4
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H
Hard disk, 2-1
Headers and footers, 3-2, 4-6, 4-8, 5-16

AM Chronological, 5-17
AM Together, 5-17
EM Chronological, 5-17
EM Together, 5-17
Message log, 5-17
Overflow, 5-17
Print recipe, 5-17
Print screen, 5-17

Help, 2-3, 4-6
button, 4-7
context-sensitive, 4-3
key F1, 4-3
menu, 4-3

Help topics, 4-6
Help with download problems, 14-4

I
Identification

data record, 9-7
recipe, 9-7

Information
configuration, 4-9
online, 4-3

Information functions, 4-9
Information text, 5-1

button, 4-8
language-dependent, 12-3

Inhibit, cursor, C-9
Input fields, 3-3, 7-2, 9-4
Input/output fields, 7-2
Insert field, button, 4-8
Installation

language, 2-2
options, 2-3
STEP 7 integration, 2-2

Installing
from floppy disk, 2-2
from hard disk, 2-3

Instructions for configuration, 5-2
Interface, parameters, C-3
Interface area, 11-1, 13-3
Interface parameters, 13-1

J
Job mailbox, 11-6
Jump, in screen dumps, 4-4
Jump within screen, A-1, A-5

K
Key assignment, function keyboard assignment,

11-10
Key codes, C-10
Key conventions, 4-1
Keyboard

assignment, 11-8
function keyboard, 11-10
system keyboard, 11-9
communication bit
function keyboard, 11-10
system keyboard, 11-9
simulation, C-8

Keyboard assignment, foreign-language, 12-4
Keys, 1-1

combinations, 4-1
functions, 4-1

L
Language, A-1, A-6

selection, 2-2
switchover, C-3

Language assignment, 12-4, 13-2
Language-dependent text, 12-3
Language-dependent characters, B-1
Languages, 3-5

configuration language, 12-1
configuring in different, 12-1
edit, 12-1
editing language, 12-1
on OP, 12-4
reference language, 12-1
set, 12-1
user interface language, 12-1

LED
assignment, 11-8, 11-11
bit number, 11-11
functions, 11-11

LED assignment, 13-3
LED-, Funktionen, 11-11, 11-12
Life bit, 11-4
Limit value, variable, 6-4
Limit values, 6-4
Link to the PLC, 6-1
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Local assignment, 5-19
Lower limit value, 6-4

M
Main memory, 2-1
Main menu items, 4-5
Manage, configurations, 16-1, 16-5
Memory

hard disk, 2-1
virtual, 2-1

Memory requirements, 4-9, 13-2
Menu

bar, 4-5
overview, 4-5

Menu items, editor–dependent, 4-6
Message

buffer, 8-5
log ON/OFF, C-3
printout, 8-5

Message editors, 8-1
Message level, A-1, A-6

Screen number area, 7-13
Message log, 5-17
Message log on/off, A-1, A-6
Message number, 8-1, 8-2, 8-12
Messages, 1-1, 4-6, 8-1, 8-5, 13-1

entries, 8-1
menu, 4-8
number, 8-1

Miscellaneous, 13-1
Mode, A-2, A-6
Module, interface, C-4
Mouse, operation, 4-1

N
Naming soft keys, 7-10
Necessary settings, 5-10
New, button, 4-7
Number area, 7-13

O
O/I fields, 7-2
Object configuration, 5-3
Object types, 5-1

Objects, 1-2, 5-1
configurable, 3-1

Objecttypes, 1-2
Online Help, 2-3, 4-6

green text, 4-4
Online help, 4-3
OP languages, 12-4
OP mode, 11-4
OP printer, 13-1

interface, 13-1
settings, 13-1

OP startup, 11-4
OP type, 5-3
OP language, add, 12-2
OP15C

characters per line, 5-3
Cyrillic character set, B-1
russian, B-1

OP3
Functions, 10-3
Scaling linear, A-2

Open
button, 4-7
several configurations, 4-2
several editors, 4-2

Operating mode selection, C-1
Optimization, 11-13
Options, 2-3, 4-6

menu, 4-8
Output field configuration for messages, 8-6
Output fields, 3-3, 7-2, 8-6
Overflow, 5-17
Overflow warning, 8-5
Overflow warning ON/OFF, C-5
Overview, Device-specific functions, 3-1

P
Parameters, 3-4, 13-1

functions, 10-2
Parity, C-3, C-4
Partial screen update, C-7
Password, 13-1
Password logout
Paste, 5-18

button, 4-7
Performance, 11-13
PU cable, 14-2
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PLC, 3-4, 5-10, 13-2
PLC job, C-7

alarm display type, C-5
cursor positioning, C-8
data record OP –> PLC, C-7
data record PLC –> OP, C-7
delete alarm buffer, C-6
delete event buffer, C-6
enable/disable oberflow warning for alarm

messages, C-6
fetch acknowledgment area, C-6
fetch alarm bit area, C-6
fetch event bit area, C-6
fetch LED area, C-6
interface parameters, C-3
key codes, C-10
keyboard simulation, C-8
language switchover, C-3
message log ON/OFF, C-3
module interface, C-4
operating mode selection, C-1
overflow warning ON/OFF, C-5
partial screen update, C-7
password logout, C-5
print alarm buffer, C-5
print all screens, C-2
print event buffer, C-5
print production report, C-5
print recipe, C-2
print screen, C-7
printer parameters, C-5
printout, C-2
select directory, C-2
select recipe, C-7
select screen, C-6
select special screen, C-2
set contrast, C-5
set date, C-3
set password level, C-5
set time, C-3
special situations, C-9
transfer date/time, C-6
transfer LED area directly to OP, C-6

Polling time, 11-13
area pointers, 11-13
hints, 11-13
LED assignment, 11-11
user data areas, 11-13

Print
alarm buffer, C-5
all screens, C-2
event buffer, C-5
preview, 15-2
production report, C-5
recipe, C-2, C-7
reports, 15-2
screen, C-7

Print all data records, A-2, A-6
Print all screens, A-2, A-6
Print recipe, 5-17
Print record, A-6
Print screen, 5-17, A-2, A-6
Print screen entries, A-2, A-6
Print to file, 15-2
Printed chapter, 15-1
Printer

drivers, 15-3
Settings, 3-5

Printer parameters, C-5
Printer type, 13-1
Printing a configuration, 15-1
Printout, 8-5, C-2
Procedure for configuration, 5-2
Procedure for download, 14-2
Process control phase, 1-1
Project, general details, 4-9
Project Manager

backup, 16-6
functions, 16-5
restore, 16-6

ProTool/Lite
calling by using SIMATIC Manager in the

case of STEP 7 integration, 5-5
calling as stand-alone program in the case of

STEP 7 integration, 5-5

R
Recipe

data record, 9-7
identification, 9-7
ingredients, 9-2
menu, 4-8

Recipe directory, A-2, A-6
Recipe editor, 9-1
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Recipe inhibit, C-7
Recipe mailbox, 9-7, 13-3
Recipe number, 13-3
Recipe number mailbox, 9-7
Recipes, 3-2, 5-11, 5-14, 9-1

menu, 4-6
Reference language, 12-1
Reference tool, 4-3
Remaining buffer size, 8-5
Remarks, General, 4-1
Replacing floppy disk, during backup and re-

store, 16-7
Report settings, 15-2
Restore, 16-6
Russian, 12-4, B-1

S
Save, button, 4-7
Scaling linear, A-2, A-6
Scheduler, 3-2, 5-15
Screen, 4-6

dumps, 4-4
menu, 4-8
number, 7-13

Screen directory, 7-5
Screen editor, 7-1
Screen entries, 3-1, 7-1
Screen name, 7-1
Screen number, 7-1
Screen number area, 13-3
Screen/Keys, 13-1
Screens, 1-1, 3-1, 5-11, 5-13, 7-1

entries, 7-1
name, 7-1
number, 7-1
screen directory, 7-5
soft keys, 7-9
standard screens, 7-12
start screen, 7-5

Select
directory, C-2
recipe, C-7
screen, C-6
special screen, C-2

Select data record, A-2, A-7
Select function screen, 10-3, A-3, A-7
Select protocol, 5-3
Select screen, 7-5, A-2, A-7
Select screen directory, A-2, A-7
Sequence of events in configuration, 5-3

Set
contrast, C-5
date, C-3
password level, C-5
time, C-3

Set communication protocol, 5-3
Set PLC, 5-3
Settings, 15-2

event messages and alarm messages 
separate, 8-14

event messages and alarm messages 
together, 8-14

general, 4-8
language, 12-1

Setup, 2-3
Several configurations open, 4-2
Several editors open, 4-2
SHIFT , 11-8
SHIFT + Function, 5-20, 10-1
Soft key, 5-19

definition, 5-19
Soft keys, 3-3, 5-19, 7-9

assign functions, 10-1
assignment, 7-9
names, 7-10

Speed, 2-1
Standalone, 5-7
Standard basic screen, 16-3
Standard clock pulse, 3-4
Standard configurations, 7-12, 16-1

copy, 7-12
Standard screens, 7-12, 16-3

basic screen, 7-12
names, 16-2, 7-12
system settings, 16-3
use, 7-12
Z_SYSTEM_MEN, 7-12

Standby message, 8-1, 8-9
Start screen, 7-5
Status bar, 4-5
STEP 7 integration, 5-5

integrating projects, 5-7
selecting PLC, 5-6
update, 5-7

Stop bits, C-3, C-4
Successive recipe mailbox, 13-3
Symbol, 7-3, 8-7, 9-5
Symbol  list, edit, 7-4, 8-8
Symbol lists, 5-16
Symbolic, name, 5-12
Symbolic display, 7-3, 8-7, 9-5
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Symbolic input/output, 5-16, 7-3, 8-7, 9-5
Symbolic names, 16-3
Synchronization, transferring data records, 9-7
System, 4-6

area pointers, 13-2
language assignment, 13-2
language assignment, 12-4
memory requirements, 13-2
parameters, 13-1
PLC, 13-2
printer, 13-1
screen/keys, 13-1

System key assignment, 11-9
System keyboard, 13-3
System messages, list, B-1, C-1
System requirements, 2-1
System settings, 16-3

T
Taskbar, 2-4
TD/OP address, C-4
Text, language-dependent, 12-3
Text entries, 3-2
Text instead of value, 9-5
Text instead of values, 5-16, 7-3, 8-7
Title bar, 4-2
Tool bar, 4-1, 4-7
Tools, menu, 5-1
Transfer

data records, 11-5
date/time, C-6

Transfer LED area directly to OP, C-6
TTY level, 14-2

U
Update, time, 11-13
Update time, 11-13
Updating, of variables, 6-1
Upper limit value, 6-4
Usage, 7-3, 8-7, 9-5
User  version, 13-3
User data areas, LED assignment, 11-11
User interface language, 12-1
Using online help, 4-3
Using standard screens, 7-12

V
V.24 level, 14-2
Variable

setting address, 6-2
setting limit values, 6-4
setting PLC, 6-2
using STEP 7 symbol list, 6-5

Variable configuration, 6-2
Variable single–shot updating, 6-1
Variables, 3-3, 5-1, 5-14, 6-1

limit values, 6-4
polling time, 6-1

Virtual memory, 2-1

W
Window, 4-6

active, 4-2
menu, 4-8

Windows95, Taskbar, 2-4
Working, with a mouse, 4-1
WYSIWYG mode, 4-7
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