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Preface

Purpose of the manual

The information in this manual tells you how to install COM PROFIBUS and carry
out complete configurations with COM PROFIBUS.

We use two full configuration examples to illustrate how to work with
COM PROFIBUS. These contain all the important functions of COM PROFIBUS
and can be easily followed:

* PROFIBUS-DP configuration example
* PROFIBUS-FMS configuration example

Target audience

This manual is aimed at those who use COM PROFIBUS for planning,
commissioning and diagnostics with PROFIBUS-DP and PROFIBUS-FMS bus
systems based on the EN 50170, Volume 2, PROFIBUS standard.

You will find product-specific configuration information on your PROFIBUS devices
in the product documentation.

Scope of validity
This manual is valid for COM PROFIBUS as of V 5.0.

It contains a description of the product’s functions that was correct at the time of
going to press. We reserve the right to describe new functions or changes in an
accompanying product information document.

Online help system

All the information you will need is offered in an online help system in

COM PROFIBUS. This contains full descriptions of all the functions of COM
PROFIBUS. In addition, you can also request context-sensitive information on any
open dialog box.

COM PROFIBUS
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Preface

Aids to accessing information

In order to facilitate rapid access to specific information, the manual contains the
following aids:

« A complete table of contents at the beginning of the manual

« Aglossary after the appendices, in which important technical terms used in the
manual are defined

« Athorough index at the end of the manual, which quickly enables you to find
the information you require

Further support

If you have any questions of a technical nature, please get in touch with your
contact at the Siemens representative or office assigned to you. You will find the
address in the manuals for the Siemens DP masters - for example, in the "Siemens
Worldwide" appendix of the manual S7-300 Programmable Controller; Hardware
and Installation, in catalogs and on CompuServe (GO AUTFORUM).

If you require device master files, you can obtain them as follows:
e By direct modem link on +49 (911) 737972

¢ On the Internet at http://www.ad.siemens.de/csi_e/gsd

Constantly updated information
You can obtain constantly updated information on SIMATIC products:
e On the Internet at http://www.ad.siemens.de/simatic
* By calling the fax polling number +49 8765-93 00 50 00

In addition, SIMATIC Customer Support provides you with current information and
downloads that can be of use to you with your SIMATIC products:

¢ On the Internet at http://www.ad.siemens.de/simatic-cs
e Atthe SIMATIC Customer Support Mailbox on +49 (911) 895-7100

To access the mailbox, use a V.34 (28.8 kbps) modem and set the following
parameters: 8, N, 1, ANSI. Alternatively, use ISDN (x.75, 64 kbps).

You can contact SIMATIC Customer Support by phone on +49 (911) 895-7000 and
by fax on +49 (911) 895-7002. You can also send inquiries by e-mail on the Internet
or to the above mailbox.

COM PROFIBUS
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1 Product overview

What is COM PROFIBUS?

The COM PROFIBUS configuration software makes it easy to configure and
commission PROFIBUS-DP and PROFIBUS-FMS bus systems.

COM PROFIBUS runs under MS Windows 9x/NT and offers you a graphical user
interface that allows you to:

» Configure masters and slaves easily

e Set transmission rates for the PROFIBUS bus system

» Transfer (export) the data directly to the master via the PROFIBUS bus system
e Commission the PROFIBUS bus system with the aid of diagnostic functions

» Display the status of inputs and outputs and set defined outputs

¢ Document the configuration in detail

Configuration with COM PROFIBUS
COM PROFIBUS is installed on the programming device/PC.

< COM
) @ PROFIBUS
Programming

doviee 1 PC.

|

NCM Export via
file PROFIBUS

i

85

Q3

s

<
B+

DP
master

e -C: SIMATIC
NET PC
module

f

il

Figure 1-1 Configuration with COM PROFIBUS

COM PROFIBUS
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Product overview

Configurable DP masters

The S5-115U, S5-135U or S5-155U with the IM 308-C as a DP master (up to
12 Mbps)

The S5-95U with a DP master interface (up to 1.5 Mbps)

The SIMATIC NET PC module CP 5412 (A2) as a DP master
Communication modules for connecting the SIMADYN D control system
The TELEPERM M programmable controllers AS 388 TM/488 TM

The SIMATIC TI1505-FIM field interface module for connecting the
SIMATIC TI505

The PROFIBUS-DP IM 180 master interface module

The SIMATIC NET PC modules CP 5511, CP 5611, CP 5611 Onboard (in the
PG 7x0 PIl) and CP 5411 as DP masters

Configurable DP slaves

ET 200 distributed I/O devices: the ET 200B, ET 200C, ET 200L, ET 200M,
ET 200S and ET 200X (up to 12 Mbps) and the ET 200U, ET 200L (up to 1.5
Mbps)

The S5-115U, S5-135U or S5-155U with the IM 308-C as a DP slave (up to 12
Mbps)

The S5-95U with a DP slave interface (up to 1.5 Mbps)
DP/AS-I Link as the interface to the actuator/sensor interface
The S7-200 with the CPU 215-2 DP or CP 242-8 as a DP slave
The S7-300 with the CPU 315-2 DP or CP 342-5 as a DP slave
The S7-400 with the CP 443-5 as a DP slave

Communication modules for connecting:

SIMOVERT master drives

SIMOREG converters

The SIMADYN D control system

SIMOCODE-DP low-voltage switchgear

Text displays and operator panels for machine-oriented operation/monitoring
MOBY identification systems

The SIMODRIVE sensor - absolute value sensor with PROFIBUS-DP
connection

SIPOS electric actuators
SIPART industrial/process controllers
The PROFIBUS-DP RBC interface module for connecting the SIMATIC T1505

COM PROFIBUS
EWA 4NEB 780 6035-02 02



Product overview

Configurable FMS masters
* The SIMATIC NET PC module CP 5412 (A2) as an FMS master

Configurable FMS stations
* The ET 200U DP/FMS distributed 1/O device
 SIMOCODE FMS low-voltage switchgear
e The SIMATIC NET PC module CP 5412 (A2) as an FMS station
* The CP 5431 FMS communication processor
* The S7-300 with the CP 343-5 as an FMS station
* The S7-400 with the CP 443-5 as an FMS station

Field devices of other vendors

COM PROFIBUS also allows you to parameterize the field devices of other
vendors. Device master files are generally supplied with the field devices. These
can be integrated in configuration tools and permit easy and user-friendly
parameterization. COM PROFIBUS can interpret these device master files provided
the files are created in accordance with the EN 50170, Volume 2, PROFIBUS
standard.

Configuring ET 200 devices for DP masters of other vendors

When ET 200 devices are connected to DP masters that are not parameterized
with COM PROFIBUS (DP masters of other vendors), a device master file with
predefined settings can be created with COM PROFIBUS in accordance with the
EN 50170, Volume 2, PROFIBUS standard.

This device master file is then loaded in the other vendor’s configuration software
and can be used to parameterize the ET 200 device with ease. The user-friendly
plain-text parameterization of COM PROFIBUS is used. Hexadecimal code entries
in the configuration software of the other vendor are not required.

Device master files for COM PROFIBUS

A device master file is required for every PROFIBUS device configured with
COM PROFIBUS.

Device master files for the above PROFIBUS devices (DP and FMS) are supplied

with COM PROFIBUS. The device master files of new Siemens I/O devices whose
device master files are not in COM PROFIBUS’s GSD directory are available from

the interface center. You can download them by modem on:

. Tel. +49 (911) 737972
. Tel. +49 (911) 730983

COM PROFIBUS
EWA 4NEB 780 6035-02 02 9



Product overview

Alternatively, you can download the device master files for SIEMENS devices on
the Internet. You will find all the device master files under "Downloads"” on the
SIMATIC Customer Support Web page at http://www.ad.siemens.de/csi_e/gsd.

Online help system

You can access all the information you need in the COM PROFIBUS online help
system. You call the help system by choosing the Help > Help topics menu
command in COM PROFIBUS.

COM PROFIBUS manual (electronic manual)

This COM PROFIBUS manual is provided in PDF format. It contains information for
those new to COM PROFIBUS and includes complete configuration examples.

What is described where?

The table below tells you where to find what in the COM PROFIBUS
documentation.

Table 1-1 Where to find what information on COM PROFIBUS

Information COM PROFIBUS | Online help
manual system
Area of application and prerequisites X X
Installation and startup X X
Elements of the user interface, structure of the editing X X
window
Examples: X

e Complete DP configuration example
¢ Complete FMS configuration example

Operating instructions (step-by-step instructions for all X
COM PROFIBUS functions)
Information on: X

e Dialog boxes
¢ Menu commands
e User interface elements

COM PROFIBUS
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2 Installation and uninstallation

Requirements for working with COM PROFIBUS

COM PROFIBUS runs under the MS Windows operating system. We assume that

you are familiar with MS Windows.

Requirements for running COM PROFIBUS
In order to run COM PROFIBUS without limitations, you need:
* An MS Windows 9x/NT operating system
* Atleast 32 MB free RAM
» Approx. 16 MB free hard disk space

» Atleast a 486 processor

Terms of the license agreement

See the software license agreement in the COM PROFIBUS setup procedure.

Readme file

Note

Read the constantly updated information on the installation, online operation and
functions of COM PROFIBUS in the README.WRI file.

To open the README.WRI file, do one of the following things:
» Double-click README.WRI on the COM PROFIBUS CD-ROM.

» Specify that it should be opened automatically once the installation of
COM PROFIBUS is completed.

*  From the Windows Start menu, choose:
Start > Prograns > Si enens COM PRCFI BUS > Vi ew Lat est
Readne | nfornmation

COM PROFIBUS
EWA 4NEB 780 6035-02 02
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Installation and uninstallation

Scope of the delivery package

The following are available on the COM PROFIBUS CD-ROM in German, English,
French, Spanish and Italian:

e« The COM PROFIBUS configuration software

e Drivers for the "Set PG/PC interface" and "Parameterize memory card"
functions (SIMATIC device drivers)

* Areadme file with important information on COM PROFIBUS
e« The COM PROFIBUS manual (PDF)
e ET 200 Distributed I/0O System manual

« Acrobat Reader V 3.01 for viewing the manuals and installation instructions in
PDF format

Online operation of the PC/programming device

COM PROFIBUS allows you to run your PC or programming device online on the
PROFIBUS bus system. This means that the PC/programming device takes part in
the data traffic on the PROFIBUS system as an active node.

You need online operation for the DP online functions of COM PROFIBUS (e.qg. the
diagnostic functions) or for the direct transfer of the configuration data to the DP
master via the PROFIBUS bus system.

Requirements for online operation

For online operation you need one of the following PROFIBUS cards for the
PC/programming device:

+ CP5411 card

+ CP5511 card (PCMCIA)

* CP5611 card (PCI)

e« CP5611 Onboard (for the PG 7X0 PII)

e CP5412 A2

* MPIISA card

« Integrated MPI/PROFIBUS interface (only for Siemens programming devices)

Note

Note that under COM PROFIBUS the MPI cards (MPI ISA card, integrated
MPI/PROFIBUS interface) can only be run up to a transmission rate of 1500 kbps.

COM PROFIBUS
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Installation and uninstallation

Installing COM PROFIBUS
If the CD-ROM drive’s AutoPlay function is switched on, proceed as follows:

1. Insertthe COM PROFIBUS CD-ROM in the CD-ROM drive of your
programming device/PC. Windows 9x/NT automatically looks for the setup.exe
installation program.

If the CD-ROM drive’s AutoPlay function is switched off, proceed as follows:

1. Start the Windows 9x/NT dialog for installing software by double-clicking the
"Add/Remove Programs" icon in "Control Panel".

2. Click "Install”.

3. Insert the COM PROFIBUS CD-ROM in the CD-ROM drive of your
programming device/PC, and then click "Next”. Windows 9x/NT looks for the
setup.exe installation program.

The program takes you step by step through the installation process. During the
installation process you are asked questions and offered options to select in dialog
boxes. Please also read the paragraphs that follow in order to be able to work
through the dialogs more quickly.

Result: On completion of installation, a program group is created for
COM PROFIBUS:
Start > Progranms > Sienens COM PROFIBUS > ...

On installing the manuals

At the beginning of the installation process you can decide whether you want the
manuals supplied on the CD-ROM in PDF format to be copied onto your computer.

If you do not have access to Acrobat Reader on your computer, please select the
option for installing Acrobat Reader.

After installation the manuals can be opened from the Windows Start menu:
Start > Prograns > Si enens COM PROFI BUS > COM PRCFI BUS nanual

On memory card parameterization
During installation, a program for parameterizing the memory card is also installed.

After installing COM PROFIBUS, you can start this program as follows from the
Windows Start menu:

Start > Prograns > Si enens COM PRCFI BUS > Menory Card
Par anmet er Assi gnment

Possible settings:
¢ If you are not using an EPROM driver, select the "No EPROM Driver" option.
» Otherwise, select the appropriate entry for your programming device.

« If you are using a PC, you can select a driver for an external PROM
programmer. You must also specify the interface (e.g. LPT1) to which the
PROM programmer is connected.

COM PROFIBUS
EWA 4NEB 780 6035-02 02 13



Installation and uninstallation

On setting the programming device/PC interface

During installation, a program for setting the PG/PC interface is also installed.

After installing COM PROFIBUS, you can start this program as follows from the
Windows Start menu:

Start > Prograns > Sienens COM PROFI BUS > Set for the PG PC
Interface

Possible settings:

e To run the programming device/PC online, set the access point of the
application to COM PROFIBUS and adapt the interface parameters of the
PROFIBUS card accordingly.

e Check whether the default interrupts and the default address areas on your
computer are free, and select free interrupts and/or address areas, if necessary
(you will find a detailed description in the online help system).

Uninstalling COM PROFIBUS

Use the standard Windows procedure to uninstall COM PROFIBUS:

1. Start the standard Windows dialog for uninstalling software by double-clicking
the "Add/Remove Programs” icon in "Control Panel”.

2. Select COM PROFIBUS from the list of installed software, and then click the
"Add/Remove" button to uninstall the software.

Starting COM PROFIBUS

14

You start COM PROFIBUS from the Windows Start menu:
Start > Prograns > Si enens COM PROFI BUS > COM PROFI BUS

After installation, you can also start COM PROFIBUS in Microsoft Windows
Explorer by double-clicking a program file with the extension *.pb5.

COM PROFIBUS
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3

User interface

Overview
The COM PROFIBUS user interface is Windows-like with the following standard
elements (example):
W dmat ~LC0OM PROFIBUS - [COMProl] M=] E3
Menu bar —File  Edit “iew Configure Service Documentation  Options  Window 2
D|=(E| &= [elal 7= 5| 2]
Toolbar > o ] :I
BB w]' DP-Master
B ) DP-Slave 2 | |
= F2)" FMS -t aster
......... ' CP 5412 [82) CP 5431 FMs
BE---EM2 o FM5-Station
Working
area <
CP 2412 (A2) ET 200U DPFMS
A _I;I
« I N KN | b

Status bar —

| OFFLIME

4

Hardware catalog for selecting
the masters and slaves

Window for setting up the bus
configuration graphically

Figure 3-1

Title bar

COM PROFIBUS
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Control elements of COM PROIFBUS

The title bar always contains only the name of the application, in this case
"COM PROFIBUS".

15




User interface

Status bar

The status bar contains a short description of the current command,
COM PROFIBUS'’s current activity or operating instructions.

Menu bar

The names of the various menus appear in the menu bar. The menus allow you to
call the following functions:

Table 3-1 Functions of the menus

Menu

Allows you to

File

Open, save and close program files
Read (import) master systems from a memory card, DP master,
binary file, NCM file or ASCII file

Transfer (export) master systems to a memory card, DP master,
binary file or NCM file

Open, read in or create device master files
Print documentation

Edit

Cut, copy, paste and delete selected DP slaves or FMS stations

View

Change between the view of a master system and the view of the
entire bus

Configure

Enter the bus, host and master parameters and the DP slave
parameters or FMS station properties

Service

Display the diagnostic overview and slave diagnosis

Display and control the signal states of the inputs/outputs of the
slaves

Change the PROFIBUS address of a slave via the PROFIBUS bus
system

Activate a parameter set after an export to the DP master
Set the parameters of the PROFIBUS card

Display the data cycle times

Switch the programming device/PC offline

Delete the memory card

Documentation

Output documentation

Options Set the language

Window Change the view on the screen
Open/close the hardware catalog

Help Access the help system

16
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User interface

Mouse ©>

The mouse buttons have the following functions in COM PROFIBUS:

Table 3-2 Functions of the mouse buttons

Do this To achieve this
Click the left mouse button once Select an item/object
Double-click the left mouse button Open the associated dialog box
Hold down the right mouse button Open the pop-up menu, which contains the most
important functions

Toolbar

The toolbar contains buttons corresponding to menu commands:

File > New

Creates a new program file.

|

File > Open

Opens an existing program file.

]

File > Save

Saves the configuration in the current program file.

=]

Edit > Cut
Cuts the selected PROFIBUS node to the clipboard.

E

Edit > Copy
Copies the selected PROFIBUS node to the clipboard.

Edit > Paste
Pastes the PROFIBUS node cut or copied to the clipboard.

[

Print

Prints the documentation of the open documentation window.

]

File > Export > Memory Card

Exports the current master system to a memory card.

File > Export > DP Master

Exports the current master system to the DP master.

COM PROFIBUS
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User interface

File > Import > DP Master

Imports the master system from the DP master to the current program

file.

? > Help Topics

Opens the online help system.

Hardware catalog (window on left)

The hardware catalog contains all the devices that can be configured using
COM PROFIBUS and presents them in the form of a tree structure. As in Microsoft
Windows Explorer, the various containers with the modules can be opened and

closed.

Only those devices for which there is an error-free device master file in
COM PROFIBUS's (...\gsd or ...\fmsgsd) directory are displayed.

You have to notify COM PROFIBUS about a new or changed device master file by
means of the File > Read in GSD Files menu command.

Table 3-3

Working with the hardware catalog

Do this

To achieve this

Press <+> (numeric keypad)

Open the whole catalog

Press <-> (numeric keypad)

Close the whole catalog

Drag and drop or double-click
the device

Move the device from the hardware catalog to the
window on the right for the bus configuration

Window containing the bus configuration (window on the right)

In this window you create a graphical representation of the bus configuration. You
drag and drop the devices from the hardware catalog in this window.

Table 3-4

Working in the window containing the bus configuration

Do this

To achieve this

Drag and drop

Change the arrangement of the devices in the
PROFIBUS bus system

Double-click the device

Open the dialog box for parameter assignment

Right-click the device

Open a pop-up menu containing the most important
functions

18
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4 PROFIBUS-DP configuration example

Purpose of the example

This chapter demonstrates all the important functions of COM PROFIBUS in a
sample configuration for PROFIBUS-DP.

The procedure suggested here for creating a DP configuration is designed to help
you become familiar with the COM PROFIBUS configuration software as quickly
and easily as possible.

The sequence in which the steps appear here is recommended rather than
absolutely necessary.

Sample structure of a DP configuration
The following PROFIBUS devices are used in the example described below:
 The IM 308-C as the DP master (S5-115U/CPU 945 host)
 The ET 200B as a compact DP slave (ET 200B-4/8Al)
* The ET 200M as a modular DP slave
* The ET 200S as a fine-step modular DP slave
« TheIM 308-C as a DP slave (S5-115U/CPU 945 host)

Transmission method

RS 485 transmission method for electrical networks on the basis of shielded
twisted-pair cables

Network components

No additional network components such as OLMs, RS 485 repeaters, etc.

Bus protocol

PROFIBUS-DP: This bus protocol applies when there are DP masters based on the
EN 50170, Volume 2, PROFIBUS standard on the bus.

COM PROFIBUS
EWA 4NEB 780 6035-02 02 19



PROFIBUS-DP configuration example

4.1

Starting configuration

Start COM PROFIBUS

From the Windows Start menu, choose:
Start > Prograns > Sienens COM PROFI BUS > COM PROFI BUS

Result: The COM PROFIBUS user interface appears and an empty program file is
created.

= COM PROFIBUS - [COMProl] M=l E3

File Edit “iew Configure Service [Documentation Options  Window 7
Ol(@| & |=(el|a] Z =] =] 2|
= 3]
~DE ' DP-Master
DB o} DP-Slave

@ FMS5-Mazter
2 FMS Station

[ |
LN Ry L |

[Window for
graphical
bus configuration]

/ N\

[Hardware
catalog]

(|
]

< | Llj

| OFFLINE 7

Figure 4-1  Configuration with COM PROFIBUS

Read in the device master files

20

Choose the File > Read in GSD Files menu command.

Result: All the configurable bus nodes are displayed in the hardware catalog.

Note

You only need to execute this function when a new device master file is copied to
COM PROFIBUS'’s ...\gsd subdirectory or an existing device master file in the
subdirectory is changed after the program is started up.

COM PROFIBUS
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PROFIBUS-DP configuration example

4.2 Setting up the bus configuration

You begin configuration by selecting and arranging the DP masters and DP slaves
in the window for the graphical bus configuration. Not until you have created all the
PROFIBUS nodes do you begin setting the parameters.

Several masters on the bus

The configuration for a master system is shown below. If there are several DP
masters on the bus, you can use the View > Network View and View >
Mastersystem <1> menu commands to switch between the view of the whole bus
and the view of a master system during configuration.

Set up the bus configuration graphically

Select the DP master and the associated DP slaves from the hardware catalog,
and drag and drop the modules one after the other to move them to the window on
the right for the graphical bus configuration (see Figure|4-1).

Tip 1: Double-click the modules in the catalog to set up the configuration more
quickly.

Tip 2: Press <+> and <-> on the numeric keypad to open and close the entire
catalog.

Select the following modules from the hardware catalog for the sample
configuration:

DP master > | M 308-C > S5-115U / CPU 945 (host)

DP slave > |/O > ET 200B > B-4/8Al-2 DP

DP slave > 1/0O > ET 200M > ET 200M (I M 153-1)

DP slave > I/O > ET 200S > ET 200S (I M 151)

DP slave > PLC > SIMATIC > | M 308-C DP sl ave >S5- 115U/ CPU945

Result: The bus configuration is created with icons for all the modules (Figure 4-2)

oP ET 2005 (M151)

5
" (I [

= =3-11 5|J JCPU 945
S5-1150 f CPU 945 ET 200M (IM133-1)

5

Sa-1150 S CPU 945

Figure 4-2  Structure of a sample DP configuration
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4.3 Entering bus parameters

Once you have set up the bus configuration graphically, you begin
parameterization. The bus parameters apply to the entire PROFIBUS bus system. If
your bus configuration includes a number of master systems, you only need to set
the bus parameters in one of them.

Enter the bus parameters

1. Choose Configure > Set bus parameters.

Result: The "Bus Parameters" dialog box appears.

Bus Parameters |
Bus Description: IF'FH:IFI BUS
~ Bus Mode
Bus Profile: |PROFIBUSDP 7] Baud Rate: [1500.0 x| kBaud

[T Fepeaters/0Ls

Cancel | Help Set Parameters...

Figure 4-3  The "Bus Parameters" dialog box

22

Select the "PROFIBUS-DP" bus profile.

"PROFIBUS-DP" applies when only DP masters that comply with the

EN 50170, Volume 2, PROFIBUS standard are on the bus. The bus profiles are
default sets of bus parameter settings for different PROFIBUS applications.
Each bus profile contains PROFIBUS bus parameters calculated and set by
COM PROFIBUS for a specific configuration, profile and transmission rate.

Tip: You can click the "Set Parameters" button to view the bus parameters
calculated by COM PROFIBUS. The calculated bus parameters can only be
changed if the "Adjustable" bus profile is selected.

Select a transmission rate of 12000.0 kbps.

The transmission rate set here applies to the entire PROFIBUS-DP bus
system. In other words, all nodes on the PROFIBUS-DP bus system must
support the selected transmission rate.

COM PROFIBUS
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4. Click "OK" to apply the bus parameters and exit the dialog box.

Result: The bus parameters are saved.

Repeaters/OLMs

If there are RS 485 repeaters in electrical networks or OLMs/OBTSs in optical
networks on the PROFIBUS-DP bus system, select the "Repeater/OLMs" check
box. The number of network components to be specified and the cable lengths are
taken into account by COM PROFIBUS when calculating the bus parameters.

Note

The network components configured in the network view of COM PROFIBUS
have no effect on the bus times calculated. If these network components are to be
taken into account, you must increase the number for "Repeaters/OLMs" in the
"Bus parameters" dialog box.

Change the bus parameters individually (optional)

Normally - i.e. when the DP masters are configured with COM PROFIBUS - you do
not need to change the default bus parameter settings in the bus profile.

However, if you do want to adapt the bus parameters yourself and have the
required PROFIBUS expertise, select the "Adjustable” bus profile and then click the
"Set Parameters" button. In the "Bus parameters" dialog box that appears you can
adapt the bus parameters yourself to suit your bus configuration. Please look up the
information on this in the online help system ("Help" button).

Note
Always set the slowest bus time of all bus nodes.

All the values for the bus parameters are specified in the unit t_bit (bit time). The bit
time depends on the transmission rate and is calculated using the following
formula: t_bit [us] = 1/transmission rate [1000 kbps].

Table 4-1 Bit time depending on the transmission rate

Transmission rate t_bit [us]

9.6 kbps 104.167
19.2 kbps 52.083
45.45 kbps 22.002
93.75 kbps 10.667
187.5 kbps 5.333
500 kbps 2.000
1500 kbps 0.667

COM PROFIBUS
EWA 4NEB 780 6035-02 02 23



PROFIBUS-DP configuration example

Transmission rate t_bit [us]
3000 kbps 0.333
6000 kbps 0.167
12000 kbps 0.083

Target rotation time "Ttr"

The bus parameter "Ttr" calculated by COM PROFIBUS and shown here does not
represent the real target rotation time; it represents a maximum permitted value
and thus cannot be used to determine response times on the PROFIBUS-DP bus

system.

4.4 Entering master parameters

You use the master parameters to specify how the distributed 1/0Os are addressed
and how the DP master is to respond in the event of errors on the PROFIBUS-DP

bus system.

Enter the master parameters

1. Double-click the IM 308-C "S5-115U / CPU 945" icon in the window for the

graphical bus configuration (see Figure 4-2).

Result: The "Master parameters" dialog box appears.

Master parameters E |

EROFIBS address: |1

Address mode: IF'_tiIe

Murnber of the Ik 308-C ||:| 'vI

[ Multiprocessor mode ZDP-Fenster-ddreszse: FEO0

Cancel
Station nare; |Masters_l,lstem<1 >
Help |
Station type: IIM a0a-C
Azsociated host: I HiostOfh astersystemns 1> j Host params.

— Defaults
¥ Eesponze monitoring for glaves

Error reporting mode; i~ Mone

@ o2  CPEU

Add. zpace
Groups

Zrontigurieren

i

Figure 4-4  The "Master parameters" dialog box
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2. Set the master parameters for the IM 308-C:

Parameter Value
PROFIBUS address Keep "1"
Address mode Set to "P tile"
Number of the IM 308-C Keep "0"
Multiprocessor mode Keep "Deactivated”
Response monitoring for slaves | Keep "Activated"
Error reporting mode Keep "QVvZ"

- You need the number of the IM 308-C for tile (page frame) addressing or
for addressing by means of the FB IM308C.

- You must activate multiprocessor mode for the IM 308-C if you are running
several CPUs and masters on a single host or if the address space
occupied by the FB IM308C is already being used for the CPs/IPs inserted
in the programmable controller.

- If "Response monitoring for slaves” is activated, it applies to all DP slaves
assigned to the DP master. For commissioning you can switch off response
monitoring for individual slaves during slave configuration.

Further support: Please also note the information on each master parameter in
the online help system ("Help" button).

3. Click "OK" to apply the master parameters and exit the dialog box.

Result: The master parameters are saved.

"Host params." button

This button opens a dialog box for protecting address areas (see Sectior 4.5).

"Add. space" button
This button opens the address space dialog box, which gives you an overview:
» Of all the host’s available address space
» Of the address areas occupied by configured slaves

» Of the address areas you reserved during host parameterization

"Groups" button

Opens a dialog box for defining the groups for the purpose of issuing the control
commands FREEZE and SYNC to DP slaves (see Section 4.10).

COM PROFIBUS
EWA 4NEB 780 6035-02 02 25



PROFIBUS-DP configuration example

4.5 Entering host parameters

A host is a system or device on which there are one or more masters. In our
example the CPU 945 is the host of the IM 308-C. If there is no system above the
master in the hierarchy - as in the case of the S5-95U with a DP master interface,
for example - the master is treated as a host.

You can use the host parameters to reserve input and output addresses for the
central /0O modules in the programmable controller and set the power-up delay of
the CPU 945 before all the DP slaves on the PROFIBUS bus system are
addressed.

Enter the host parameters

26

1. Double-click the IM 308-C "S5-115U / CPU 945" icon in the window for the
graphical bus configuration (see Figure 4-2).

2. Click the "Host params." button in the "Master parameters" dialog box.
Result: The "Host parameters” dialog box appears.
3. Enter arealistic time for the power-up delay.

The power-up delay can be between 20 s and 1200 s. If you specify no error
reporting mode for the IM 308-C when setting the master parameters, the CPU
starts up without a power-up delay.

4. Click the "Reserv. I." button in the "Host parameters" dialog box.

Result: The "Reserve address areas for inputs” dialog box appears.

Reserve address areas for inputs

=]
Start addrezzes End addreszes ak. I

Frarm: IF'22EI Ta: IF'EEE Cancel
From: I T I Help |
Fram: I Ta: |

From: I Tor I

Figure 4-5  The "Reserve address areas for inputs" dialog box

5. Specify to the IM 308-C the address areas for central input modules of the
CPU 945, and then click "OK" to close the dialog box.

For example: "P210" to "P218" ("P210" stands for byte 210 in the P area)

6. Reserve the address areas for central output modules in the same way (e.g.
"P220" to "P228").
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7. Click "OK" to apply the host parameters and close the dialog box.
Result: The host parameters are saved.

Further support: Please also note the information on each host parameter in the
online help system ("Help" button).

Note
In the case of P or Q tiling, the reserved areas apply to all tiles (page frames).

4.6 Entering slave parameters for the ET 200B

You can now configure and parameterize the DP slaves one after the other. In our
example we will begin with the ET 200B as a compact DP slave. In order to be able
to illustrate parameter assignment to you in detail, we have decided on the

ET 200B-4/8Al-2 analog module.

Enter the slave properties

1. Double-click the "B-4/8Al-2 DP" icon in the window for the graphical bus
configuration (see Figure 4-2).

Result: The "Slave properties” dialog box appears.

(5 Slave properties |
4
PROFIEUS address: I2 | I
Cancel |
Hame: I
S e B-4/8412 DP sy |
Order nurnber: |EE 57 134-0EH01-0E0
Device mazter file: |5iem8[l'l a.gzq Canfigure... |
= SrtEcapatle Parameterize. .. |

Control commandsz:

v | EFHEEZE- fal
7 CApEDE Sharedimaster... |

Param. assign. master. | #1. IM 308C, Mastersystem< 1> =l
[V Besponse monitaring

Errar reparting rode: i~ Maone (O il = S

Figure 4-6  The ET 200B "Slave properties" dialog box
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2. Set the slave properties for the ET 200B-4/8Al-2:

Parameter Value
PROFIBUS address Keep suggestion "2"
Control command "FREEZE capable" (unchangeable)
Param. assignment master Keep suggestion "1, IM 308-C, master system <1>"
Response monitoring Keep "Activated”
Error reporting mode Keep "QVvZ"

If there is more than one DP master on the PROFIBUS bus system, you
can use the "Param. assign. master"” list box to check the DP master that
parameterizes the DP slave and, if necessary, change it.

If "Response monitoring for slaves” is selected in the "Master parameters™
dialog box, you can switch response monitoring on and off here for each
DP slave (e.g. for commissioning).

"FREEZE-capable" indicates that the DP slave can execute this control
command of the DP master. COM PROFIBUS obtains this information from
the device master file.

Further support: Please also note the information on the slave properties in the
online help system ("Help" button).

Response monitoring

/N

If response monitoring is switched on, the DP slave will respond within the
configured response monitoring time (bus parameters) in the event of data traffic
with the DP master failing. After the response monitoring time elapses, the DP
slave switches to a safe state. In other words, all outputs are set to the signal state
"0" or (if the DP slave supports it) substitute values are output.

Danger

If you switch off response monitoring for a DP slave, in the event of a failure the
outputs of the DP slave may not be set to "0". This can lead to dangerous system
states.

Configure the DP slave

28

1. Click the "Configure" button in the "Slave properties" dialog box.
Result: The "Desired configuration" dialog box appears.

2. Accept "Configuration 1 8AI" by clicking "OK".
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(IS Configure: B-4/84A1-2 1] S

In the "Desired configuration” dialog box you make a selection for the address
identifiers in the configuration table that follows. This dialog box only appears if
there are different address types in the device master file for the slave.

Result: The "Configure" dialog box, also referred to as the configuration table,
appears. The address identifier "067, 071" appears at slot 4 for 8Al.

=
-

Cancel

adile:.

Earameters...

[Ielete

St &

Addr. zpace...

BT

Identifier Module Comment | | address | O address =

1 o4 Konfiguration 1. 8Al
2 o4 L.

3 o4 L.

4 OEF 071 ... ..

5

B

7

g

9

10

11

12

13

14

15

16

17T

Figure 4-7  The

3.

ET 200B "Configure" dialog box

Select the free cell in the "l address" column, and then click the "Auto addr."”
button.

Result: The address identifier is assigned to the next free input address of a P
tile. As of this address the 8 input channels of the ET 200B-4/8Al are
addressed in the P area (with word consistency). Note the addresses for
programming in the user program.

Tip: Before you click the "Auto addr." button, you can select a row, a column or
the whole table.

Tip: The "Identifier" pop-up menu command (which you access by right-clicking
the "Identifier" column) indicates the length and consistency of the address
area of an identifier.

Click "OK" to accept the configuration and close the dialog box.

Result: COM PROFIBUS stores the configuration data in the configuration of
the master system.

Further support: Please also note the information on working with the configuration
table in the online help system ("Help" button).

COM PROFIBUS
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Digital compact DP slaves

Note

For digital compact ET 200B distributed 1/0O devices, slave parameterization is
concluded at this point. No further settings are required. By default in the
"Parameterize" dialog box ("Parameterize" button), 5 bytes containing "00" are
specified that cannot be deleted or overwritten.

Parameterize the analog DP slave

1. Click the "Parameterize" button in the "Slave properties" dialog box.

Result: The "Parameterize" dialog box appears for the ET 200B-4/8AI-2. The
parameterizable parameters are displayed in the "Parameter name" column.
The current parameter values appear in the "Value" column. COM PROFIBUS
obtains these entries from the device master file of the DP slave.

I Parameterize: B-4/841-2 DP |

Parameter name Value - | ok, I

2.2 |Display Measured Value SIMATIC S5 Cancel |

24 Meas. Walue Display with S5 Complement of Twios

5.0 Disgnostics Enable  CHO-1 disahle Help |

g4 Disgnostics Enable  CH 2- 3 disahle

52 Disgnostics Enable  CH4-5 disahle

5.3 |Disgnostics Enable CHE-7 disable Select.. |

9.0 Enable VWire Bresk  CHO-1 dizable Hes

9.1 Enable VWire Bresk CH2- 3 dizable =

= Enzble Wire Break CH4-5 disahle [elete |

9.3 Enable Wire Bresk CHE- 7 dizable

1572 |Fndd af (Twele Llarm rli=ahla ;I

Figure 4-8  The ET 200B "Parameterize" dialog box
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2. Set the slave parameters for the ET 200B-4/8Al-2: To do this, click the relevant
row in the "Value" column and select the following parameter values from the
dialog box that appears:

Parameter Value
Measured value representation Keep "SIMATIC S5"
S5 measured value representation Keep "Twos complement"
Diagnostic enable Switch to "Enable”
Wire break enable Switch to "Enable"

COM PROFIBUS
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Parameter Value
Cycle end interrupt, Diagnostic interrupt, Limit Keep "Disable"
interrupt
Integration time Keep "20 ms for 50Hz"
Measurement type/Measurement range Keep "Voltage +/-1V"
Upper/Lower limit Keep "0"

- If you do not want to use a channel of the module, set the "Measurement
type/Measurement range" parameter to "Channel not activated".

Further support: Refer to the DP slave manual for information on the various
parameters of the DP slaves.

3. Click "OK" to apply the parameterization and close the dialog box.

Result: COM PROFIBUS stores the parameter data in the configuration of the
master system.

4.7 Entering slave parameters for the ET 200M

We are now going to parameterize the ET 200M as a modular DP slave fitted with
two S7-300 I/O modules (8DE, 4AA).

Enter the slave properties

4. Double-click the "ET 200M (IM153-1)" icon in the window for the graphical bus
configuration (see Figure 4-2).

Result: The "Slave properties” dialog box appears.

5 Slave properties |
Ok
PROFIELS address: I3 | I
Cancel |
Marme; I
Station type: |ET 200K [I153-1] Help |
Order number: |EE 57 1531448 0=B0
Device master file: |Siem8[l'| d.gzg Configure. . |
| SkEcapatle Parameterize. .. |

Control commatndsz:

W | FHEEZE- fil
7 CAEEDIE Eharedimaster... |

Param. assign. master: I#'I, I 3038-C, Mastersyztemnss j
[V Besponse monitaring

Errar reparting rode: i~ Maone (O il = S

Figure 4-9  The ET 200M "Slave properties" dialog box

COM PROFIBUS
EWA 4NEB 780 6035-02 02 31



PROFIBUS-DP configuration example

5. Set the slave properties for the ET 200M:

Parameter Value
PROFIBUS address Keep suggestion "3"
Param. assignment master Keep suggestion "1, IM 308-C, master system <1>"
Response monitoring Keep "Activated”
Error reporting mode Keep "QVvZ"

If there is more than one DP master on the PROFIBUS bus system, you
can use the "Param. assignment master" list box to assign the DP master
to parameterize the DP slave.

If "Response monitoring for slaves” is selected in the "Master parameters™
dialog box, you can switch response monitoring on and off here for each
DP slave (e.g. for commissioning).

Further support: Please also note the information on the slave properties in the
online help system ("Help" button).

Response monitoring

If response monitoring is switched on, the DP slave will respond within the
configured response monitoring time (bus parameters) in the event of data traffic
with the DP master failing. After the response monitoring time elapses, the DP
slave switches to a safe state. In other words, all outputs are set to the signal state
"0" or (if the S7-300 I/O modules support it) substitute values are output.

A Danger

If you switch off response monitoring for a DP slave, in the event of a failure the
outputs of the S7-300 I/0O modules may not be set to "0". This can lead to
dangerous system states.

Configure the DP slave
1. Click the "Configure" button in the "Slave properties” dialog box.

Result: The "Configure" dialog box, also referred to as the configuration table,
appears.

COM PROFIBUS
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Bl Configure: ET 200M [IM153-1]

Identifier Module Comment | address | O address [ Ok I
1 (004 Config far Slot1 ﬂl
2 004 Config far Slot
3004 Config far Slots Help |
4
5
B IEdule.. |
7

Earameters...

g
9 [lelete |
10
1 St &l |
12 Addr. zpace... |
13
14
15 L
16
= hd

Figure 4-10 The ET 200M "Configure" dialog box

2. Click the fourth cell in the "Module" column and then the "Module" button.

Result: A selection of all the configurable S7-300 I/O modules appears
together with their order numbers.

3. Select the I/0O modules one after another in the sequence in which they are
connected next to the ET 200M. In the example, we select the following:

- Slot 4: The 8DE digital input module (6ES7 321-1FF0*-0AAQ)
- Slot 5: The 4AA analog output module (6ES7 332-5RD00-0ABO)

Result: The I/0 modules are entered in the configuration table.

Note

The slot corresponds exactly to the slot of the I/O module in the ET 200M. The
slots must be assigned in ascending order. No slots should be skipped. If a slot
remains empty, an empty slot (identifier 0) must be configured for it.

4. Click "Close" to close the selection of S7-300 1/O modules.

5. Select the free cells in the "l address" and "O address" columns, and then click

the "Auto addr." button.

Result: The next free addresses of a P tile are assigned to the address
identifiers for 8DE and 4AA. The 8 digital inputs of the 8DE (with byte
consistency) and the 4 analog output channels of the 4AA (with word
consistency) are addressed as of this address.
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Tip 1: You can also write start addresses of your choice in the free cells under
"l address/O address".

Tip 2: The "Identifier" pop-up menu command (which you access by right-
clicking the "Identifier" column) indicates the length and consistency of the
address area of an identifier.

Tip 3: The "Address space" button provides you with an overview of the
address areas that are still available and those that are already assigned.

Note

Configuration is concluded at this point for most digital S7-300 1/0O modules. No
further settings are required. In the case of analog S7-300 I/0O modules, you still
have to set the parameters for the analog channels (continue with step 6).

6. Parameterize the 4AA analog module. Select the identifier "131", and then
choose "Parameters" from the pop-up menu (by right-clicking the "ldentifier"
column).

Result: The "Parameterize" dialog box appears for the 4AA. The
parameterizable parameters are displayed in the "Parameter name" column.
The current parameter values appear in the "Value" column. COM PROFIBUS
obtains these entries from the device master file of the DP slave.

1§ Parameterize: ET 200M [IM153-1]

Parameter name Value = | ]9 I
5 [Slottumber] 1 Cancel |
5.0 Diag: enable channel O la!
g4 Dizg: enable channel 1 la! Help |
52 Diag: enable channel 2 la!
5.3 Diag: enable channel 3 la!
106 |diagnostic alarm enakle Fo b Selest. |
1.0 |DuMalhald last value chan O [u] Ll
111 |Dutalhald last value chan 1 [u] =
11.2  |Dutalhold last walue chan 2 [ Dielete |
11.3  |DuMalhald last value chan 3 [u]
120 Imndtwnefranns channeal 1 i"rrErt A4 M mi ;I

Figure 4-11 The 4AA "Parameterize" dialog box
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7. Set the parameters for the 4AA. To do this, click the relevant row in the "Value"
column and select the following parameter values from the dialog box that
appears:
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Parameter Value
Diag: Enable channel Set "Yes"
Diagnostic interrupt enable Set "Yes"
Sub. value: Hold last value Set "Yes"
Output type/area channel Keep "Current 4 .. 20 mA"
Sub. value: Value channel Keep "-6912"

Further support: Refer to the $7-300 I/0O module manual for information on the

various parameters.

8. Click "OK" to apply the parameterization and close the dialog box.

9. Click "OK" to apply the configuration table and close the dialog box.

Result: COM PROFIBUS stores the parameter data and configuration data in
the configuration of the master system.

Further support: Please also note the information on working with the configuration
table in the online help system ("Help" button).

Parameterize the DP slave

[l Parameterize: ET 200M [IM153-1) 3 < |

1. Click the "Parameterize" button in the "Slave properties" dialog box.

Result: The "Parameterize" dialog box appears for the ET 200M.
COM PROFIBUS obtains the entries from the device master file of the DP

slave.

Ok

Parameter name Value
1.0 |=tart-up for ref factual conf. Mo
15 Disgnostics Alarm enakble
16 Process Alarm enahle
1.7 module change during operstion Mo
20 Analog-value farmat SIMATIC =7

Cancel

i

Help

Select...

Hex

Eelete

b

Figure 4-12 The ET 200M "Parameterize" dialog box

2. Set the slave parameters for the ET 200M: To do this, click the relevant row in
the "Value" column and select the following parameter values from the dialog

box that appears:
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Parameter Value
Start-up preset <> actual config | Set "Yes"
Diagnostic interrupt Keep "Enable"”
Process interrupt Keep "Enable"”
Module change in operation Keep "No"

Format presentation

Set "SIMATIC S5"

Further support: Refer to the DP slave manual for information on the various

parameters of the DP slaves.

Click "OK" to apply the parameterization and close the dialog box.

Result: COM PROFIBUS stores the parameter data in the configuration of the

master system.

4.8 Entering slave parameters for the ET 200S

We are now going to parameterize the ET 200S as an example of a fine-step DP
slave fitted with digital input/output modules.

Enter the slave properties

1.

Double-click the "ET 200S (IM151)" icon in the window for the graphical bus

configuration (see Figure 4-2).

Result: The "Slave properties" dialog box appears.

El§ Slave properties |

14
FROFIBS address: |4 | I
Canizel |
Mame: I
Station type: ET 2005 (IM151) Hip |
Order nurnber: |EES? 151-14400-0480
Dewice master file: |SiemBEIEa.gsg Lanfigure... |
I S apatle Parameterize. .. |

Control commands:

¥ | FREEZE -zapatle

Slared masfern. |

Param. aszigh. master:

¥ Eesponse moritaring

Errar reporting mode; " None = ovE OFEL

|#1. 1M 308-C. Mastersystem<1> =l

Figure 4-13 The ET 200S "Slave properties" dialog box
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2. Set the slave properties for the ET 200S:

Parameter Value
PROFIBUS address Keep suggestion "4"
Param. assignment master Keep suggestion "1, IM 308-C, master system <1>"
Response monitoring Keep "Activated”
Error reporting mode Keep "QvZ"
SYNC/FREEZE-capable Selected (unchangeable)

- If there is more than one DP master on the PROFIBUS bus system, you
can use the "Param. assignment master" list box to assign the DP master
to parameterize the DP slave.

- If "Response monitoring for slaves” is selected in the "Master parameters”
dialog box, you can switch response monitoring on and off here for each
DP slave (e.g. for commissioning).

- "SYNC/FREEZE-capable" indicates that the DP slave can execute this
control command of the DP master. COM PROFIBUS obtains this
information from the device master file.

Further support: Please also note the information on the slave properties in the
online help system ("Help" button).

Response monitoring

If response monitoring is switched on, the DP slave will respond within the
configured response monitoring time (bus parameters) in the event of data traffic
with the DP master failing. After the response monitoring time elapses, the DP
slave switches to a safe state. In other words, all outputs are set to the signal state
"0" or (if the output modules support it) substitute values are output.

A Danger

If you switch off response monitoring for a DP slave, in the event of a failure the
outputs of the output modules may not be set to "0". This can lead to dangerous
system states.

Configure the DP slave
1. Click the "Configure" button in the "Slave properties" dialog box.

Result: The "Configure” dialog box, also referred to as the configuration table,
appears.
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[ Configure: ET 2005 [IM151) 4 |

Identifier Module Comment | laddress | 0 address | = | Ok I

; Cancel |

3 Help |

4

5

g todule. . |

! Earameters... |

g

9 [Nelete |

10

11 St &l |

iz Addr. zpace... |

13

14

15 L

16

17T ;I

Figure 4-14 The ET 200S "Configure" dialog box

2. Click the first cell in the "Module" column and then the "Module" button.

Result: A selection of all the configurable ET 200S modules appears together
with their order numbers.

EI§ Module zelection for position 1

BEST 138-4CA00-0440 PM-E DC24Y
BES7 138-4CEBO0-04B0 PM-E AC230
BESY 121-4BBO0-0AB0 201 DC24Y
EES7 131-4BBO0-0AB0" 200 DC24W
BESY 132-4BBO0-04B0 200 DC24Y
BES7 132-4BBO0-0AB07 200 DC24Y
BESY 132-4BB30-04B0 200 DC24Y
BES7 132-4BB30-04B0° 200 DC24Y
EBES7 132-4HBO0-0ABD 200 Rel
BESY 132-4HBO0-0ABD" 200 Rel.
BES7 131-4EBO0-0AB0 2D 1200
BESY 131-4EBO0-04B07 200 1200
EBES7 131-4FBO0-04B0 201 2300
BEST 131-4FBO0-04B0" 2D 2300
BESY 132-4FBO0-05B0 200 2304 LI

Figure 4-15 The ET 200S "Module selection” dialog box

3. Select the modules one after another in the sequence in which they are
connected next to the ET 200S. In the example we will select several digital
modules in order to illustrate the granular channel configuration.

COM PROFIBUS
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Peculiarity of the ET 200S:

In the case of the ET 200S, certain electronic modules/load feeders can be
grouped together in a single byte in the input and output area of the process
image. You can identify these modules by the fact that they appear twice in the
list, once with "*" and once without. 2DI DC 24V example (see Figure 4-15):

- B6ES7 131-4BB00-0AAQ 2DI DC24V
- B6ES7 131-4BB00-0AAQ* 2DI DC24V
Principle:

When you start a new byte, select a module without "*". Select all the
subsequent modules in this byte with "*". If the byte is full (a maximum of 8
channels = 1 byte), a new byte must be started with the next module. In the
example we select 8 digital 2DI input modules and thus occupy a total of 3
bytes.

Result: The 2DI input modules appear in the configuration table (see
Figure 4-16).

Note

The slot corresponds exactly to the slot of the module in the ET 200S. The
modules grouped together in a byte must be inserted immediately next to each
other and be of the same module type (e.g. DI). There must not be more than 8
channels (1 byte) in total.

COM PROFIBUS

Click "Close" to close the module selection dialog box.

Select the free cells in the "l address" and "O address" columns, and then click
the "Auto addr." button.

Result: The next free addresses of a P tile are assigned to the address
identifiers. The digital input modules are addressed as of this address. In our
example the 2DI at slot 1 has the start address 209.0, and the 2Dl at slot has
the start address 209.2.

Tip 1: You can also write start addresses of your choice in the free cells under
"l address/O address".

Tip 3: The "Address space" button provides you with an overview of the
address areas that are still available and those that are already assigned.
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S Configure: ET 2005 [IM151) 4 |

Identifier Module Comment || addres | O address = Ok, I

1 a0l BE=Y 131-4BB00-0A80 2D] QopP209 Cancel |

2 000 BE=Y 131-4BB00-0AB0* 20|

3 |&D0 BE=Y 132-4BB00-0AB0 2D 0or200 Help |

4 000 BE=Y 132-4BB0O0-0AB0* 20

5

B Module. . |

7

g

| Delete |

10

1 St &l |

12 Addr. space... |

13

14

15 L

16

i hd

Figure 4-16 The ET 200S "Configure" dialog box

6. Parameterize the parameterizable modules of the ET 200S. Select the
corresponding identifier (e.g. 8DE for 2DI), and then choose "Parameters” from
the pop-up menu (by right-clicking the "ldentifier" column).

Result: The "Parameterize" dialog box appears for the 2DI. The
parameterizable parameters are displayed in the "Parameter name" column.
The current parameter values appear in the "Value" column. COM PROFIBUS
obtains these entries from the device master file of the DP slave.

Bl Parameterize: ET 2005 [IM151] #4 <> |
Parameter name Value = | Ok, I
202 |Input delay 3 ms Cancel |
210 |Diag.. =hort circuit to GRD dizable
Help |
Select... |
Hex...

Delete

:

Figure 4-17 The 2DI "Parameterize" dialog box

COM PROFIBUS
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7.

Set the parameters for the 2DI input module. To do this, click the relevant row
in the "Value" column and select the parameter values from the dialog box that
appears:

Parameter Value

Input delay Keep "3 ms"

Diag.: Short circuit to M Switch to "Enable"

Further support: Refer to the ET 200S manual for information on the various
parameters.

Click "OK" to apply the parameterization and close the dialog box.
Click "OK" to apply the configuration table and close the dialog box.

Result: COM PROFIBUS stores the parameter data and configuration data in
the configuration of the master system.

Further support: Please also note the information on working with the configuration
table in the online help system ("Help" button).

Parameterize the DP slave

1.

Click the "Parameterize" button in the "Slave properties” dialog box.

Result: The "Parameterize" dialog box appears for the ET 200S.
COM PROFIBUS obtains the entries from the device master file of the DP
slave.

EHPorometorice ET200S (M151) W4 |

Parameter name Value = | ok, I

1.0 |=tart-up preset==actual config dizable Cancel |

1.7 module change during operstion dizable

100 |Formst of the analog values SIMATIC =7 Help |

102 |Interf. frequency suppression a0 Hz

11.0 |=lot Reference junction 1 Maone ]

116 |Input Reference junction 1 RTD on channel 0 Select |

120 |20t Reference junction 2 Maone Hes |

126 |Input Reference junction 2 RTD on channel 0 —

130 |[=lot Reference junction 3 Maone [Delete |

136 |Input Reference junction 3 RTD on channel 0

14N Slrt Reference ininrtinn 4 Rlane ;I

Figure 4-18 The ET 200S "Parameterize" dialog box

2.

COM PROFIBUS

Set the slave parameters for the ET 200S: To do this, click the relevant row in
the "Value" column and select the following parameter values from the dialog
box that appears:
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Parameter Value

Start-up preset <> actual config | Set "Yes"

Module change in operation Keep "Disable”
Analog value format Set "SIMATIC S5"
Interference frequency Keep "50 Hz"

suppression

Reference junction slot 1 ... 8 Keep "None"

Reference junction input 1 ... 8 [ Keep "RTD on channel 0"

Further support: Refer to the DP slave manual for information on the various
parameters of the DP slaves.

3. Click "OK" to apply the parameterization and close the dialog box.

Result: COM PROFIBUS stores the parameter data in the configuration of the
master system.

4.9 Entering slave parameters for the IM 308-C DP slave

Finally, we are going to parameterize the IM 308-C as a DP slave. You use the IM 308-C
as a DP slave to transfer data quickly between two programmable controllers. We
assume that these IM 308-C modules are not being used as DP masters at the same
time.

Enter the slave properties

1. Double-click the upper "S5 115U / CPU 945" icon (PROFIBUS address 5) in
the window for the graphical bus configuration (see Figure 4-2).

Result: The "Slave properties” dialog box appears.

COM PROFIBUS
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(5 Slave properties |
Ok
PROFIEUS address: |5 | I
Cancel |
Hame: I
Station type: IM 305C DP-Slave Hep |
Order number; BES5 308-3UCT1
Device master file: |Siem8[l'l C.gs0 Canfigure... |
I SrilEcanatle Barametenze... |

Control commands:

" FREEZE-zapatle

Eihared mastern.. |

Error reporting mode:

Param. azgign. master:

¥ Fesponse monitaring
" Mone & ovE O FEL

[#1. 1M 308-C. Mastersysteme1> =l

Figure 4-19 The IM 308-C DP slave "Slave properties" dialog box

2. Set the slave properties for the IM 308-C DP slave:

Parameter

Value

PROFIBUS address

Keep suggestion "5"

Param. assignment master

Keep suggestion "1, IM 308-C, master system <1>"

Response monitoring

Keep "Activated”

Error reporting mode

Keep "QvZ"

If there is more than one DP master on the PROFIBUS bus system, you
can use the "Param. assignment master" list box to assign the DP master
to parameterize the DP slave.

If "Response monitoring for slaves" is selected in the "Master parameters"
dialog box, you can switch response monitoring on and off here for each
DP slave (e.g. for commissioning).

Further support: Please also note the information on the slave properties in the
online help system ("Help" button).

Response monitoring

When the IM 308-C as a DP slave is no longer addressed by the DP master and
response monitoring is activated, the IM 308-C goes into STOP mode after the
response monitoring time elapses. Inputs of the IM 308-C are set to "0".

COM PROFIBUS
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Configure the DP slave

1.

Click the "Configure” button in the "Slave properties” dialog box.

Result: The "Configure" dialog box, also referred to as the configuration table,
appears.

Ol Configure: IM 308-C DP-Slave #5 <>

Identifier

o
s

Module Comment | address | O address -

Cancel

todule. .

Earameters...

W~ mh| &L k= O

[Nelete

im]

10

St &l

11

Addr. zpace...

12

A S

13

14

13

1R

Figure 4-20 The IM 308-C DP slave "Configure" dialog box

44

In the configuration table you specify the size and the addresses of the DP
slave inputs and outputs of the IM 308-C. The following applies:

Inputs = input areas of the host CPU (IM 308-C DP slave)
Outputs = output areas of the host CPU (IM 308-C DP slave)

To do this, click a white field in the "Module" column followed by the "Module™
button.

Result: A selection of all the configurable identifiers appears.

Select the corresponding identifiers depending on the type, length and
consistency of the address areas, and then click "Close" to accept your
selection.

For example: "4 words A! /AO/consist. total" for the identifier 4AX

Note
Address areas with a maximum of 16 words can be created.

COM PROFIBUS
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4. Specify the identifiers for all the other address areas (DP slave inputs and DP
slave outputs) in the same way.

5. Enter the start addresses of the address areas in the free cells under "I
address/O address".

Tip: If specific addresses do not have to be specified, you can click the "Auto
addr.” button to assign the next free addresses automatically.

6. Click "OK" to apply the configuration and close the configuration table.

Result: COM PROFIBUS stores the configuration data in the configuration of
the master system. In addition, COM PROFIBUS creates a separate master
system for this IM 308-C.

Further support: Please also note the information on working with the configuration
table in the online help system ("Help" button).

Note

When you have completed the bus configuration, do not forget to export this
additional master system to the IM 308-C DP slave (see Section 4.14).

IM 308-C as DP slave, DP master not configured with COM PROFIBUS

What do you do when the IM 308-C is running as a DP slave in a master system
whose DP master is not contained in COM PROFIBUS?

Simply create a master system with a DP master of your choice and configure the
IM 308-C as a DP slave in this master system. COM PROFIBUS then automatically
creates a separate master system for the IM 308-C DP slave, which you can export
to the IM 308-C.

IM 308-C as a DP master and DP slave

The same IM 308-C can be run as a DP master and a DP slave provided there is
another DP master on the bus.

You begin by configuring the IM-308-C as a DP slave in a master system.
COM PROFIBUS then automatically creates a separate master system for the
IM 308-C, which you can configure for the IM 308-C as a DP master.

COM PROFIBUS
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410 Assigning groups

If you want to issue the FREEZE or SYNC control command from the DP master to
DP slaves, you must arrange the DP slaves in groups. A group consists of at least
one DP slave. Each DP slave can belong to several groups.

You can form up to 8 groups for each master system.

Requirement

The DP master must be able to issue the FREEZE and SYNC control commands,
and the DP slave must be able to execute them. COM PROFIBUS obtains the
relevant information from the device master file.

Specify group association

1. Double-click the "DP master: IM 308-C" icon in the window for the graphical
bus configuration (see Figure 4-2).

2. Click the "Groups" button in the "Master parameters" dialog box.

Result: The "Groups and their properties" dialog box appears.

Groups and their properties

Grl: [Group 1 ¥ FREEZE ¥ S¥NC
G2 [Group2 W FREEZE ¥ SYNC Cancel |
Gr3: [Group 3 ¥ EREEZE [+ 5wNC Help |
Grd: [Group 4 W FREEZE [ S¥NC
Gr & |Gmup5 [+ EREEZE |v S+¥MC Groupings |
GrB: [Group B ¥ FREEZE ¥ S¥NC
GrZ: |Group 7 W EREEZE ¥ SYNC
Gr8 |Group & ¥ EREEZE [# 5vMNC

Figure 4-21 The "Groups and their properties" dialog box

3. In this dialog box you specify whether a group is to evaluate FREEZE and/or
SYNC.

4. In the follow-on dialog box, "Groupings", you specify which DP slaves with
which PROFIBUS addresses are to belong to which group. To do this, click the
corresponding white fields.

COM PROFIBUS
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Parameter Value Association
Group 1 Keep "FREEZE" and ET 200B, ET 200M, ET 200S,
"SYNC" suggestion IM 308-C DP slave

5. Click "OK" to apply the entries.

Result: The DP slaves are now assigned to a group. You need the number of
this group, for example, to issue control commands in the STEP 5 user

program with the FB IM308C.

4.11 Saving the configuration

Our example is now fully configured. The configuration data has to be saved in a

program file.

Save the configuration

1. Choose the File > Save as menu command or E’

2. Enter a file name with the extension *.pb5, and then click "OK".

Result: The completed bus configuration is saved in the program file. You can
export the configuration data to the DP masters.

4.12 Documenting and printing the configuration

You can use the Documentation menu to obtain a variety of information on the
parameterized bus configuration. For example, you can display an overview of
which addresses are assigned to which DP slave or which device master files are
known to COM PROFIBUS. You can print out any overview you request.

In the following we request by way of example the assignment of the S5
addresses in order to check on the location of the input and output data of the DP

slaves for the STEP 5 user program.

Further support: Please also refer to the detailed description of all the
documentation options in the online help system (look under "Documentation™).

Request area-oriented address assignment

1. Choose Documentation > Area-oriented Address Assignment.

Result: The "Area-oriented Address Assignment" dialog box appears.

2. Select the desired host and the address area.

COM PROFIBUS
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Result: The address assignment of the parameterized bus configuration is
displayed to you as follows:

Area-oriented Address Assighment B

Mumber of Hosts: 1

Host 1

Host Description: Host Mastersystem=1>
Host Type: 25-115TT/ CPTT 245

Range Inputs: Linear

Address Remarks Station Slot Station Type 2
PO0S | 4 1 |3DI
ro04 | E 1 |3DI
Po00 | 2 1 3201

B

@ | l_ l_ l_ @ Arbeitsplatz

Figure 4-22 The "Area-oriented Address Assignment" overview

Print out the area-oriented address assignment

1. Choose the File > Print menu command or |§I
2. Specify the print properties, and then click "OK".
Result: The "Area-oriented Address Assignment” overview is printed out.

Tip: Note that large configurations can also lead to long printouts.

4.13 Commissioning the programming device/PC online on the
bus

To transfer the configuration to the DP masters or to use the DP online (diagnostic)
functions described below, you switch COM PROFIBUS online.

COM PROFIBUS
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Requirements

* The PC/programming device (with a PROFIBUS card) must be connected to
the PROFIBUS-DP bus system.

» The PC/programming device interface must be set (see Chapter 2).

* The memory card for the IM 308-C must be parameterized (see Chapter 2).

Switch COM PROFIBUS online/offline

When a DP online function (Section|4.13 t0/4.18) is executed, COM PROFIBUS is
switched online automatically.

To disconnect the programming device/PC from the PROFIBUS bus system again,
choose Service > Switch PG/PC Offline.

4.14 Transferring (exporting) the configuration to the DP
master

COM PROFIBUS exports only the data of one master system to the DP master. In
other words, you have to export the configuration data of the relevant master
system for each DP master one after the other.

Note

If your bus configuration consists of several master systems and you change the
parameterization of a master system, you also have to reparameterize the other
masters. Otherwise, there will be problems in the bus system, which may even fail
(e.g. due to a change in the response monitoring time).

Requirements

* The programming device/PC (with a PROFIBUS card) must be connected to
the PROFIBUS-DP bus system or directly to the DP master.

» The PC/programming device interface must be set (see Chapter 2),

*  When the IM 308-C is a DP master, and only then, the memory card must be
inserted.

Note

Since the default parameter set (IM 308-C: transmission rate = 19.2 kbps and
PROFIBUS address = 1) is stored on the DP master, there must be no other
PROFIBUS node with the PROFIBUS address 1 and no other transmission rate
must be set.

COM PROFIBUS
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Transfer the configuration to the DP master

50

1. Choose the File > Export > DP Master menu command or =
2. Specify the PROFIBUS address of the DP master, and then click "OK" (in the

example: PROFIBUS address 1).

Result: The "Export DP Master" dialog box appears. COM PROFIBUS
suggests a response monitoring time on the basis of the bus configuration and
the set transmission rate. You can accept this time or set a longer time.

Export DpMaster |

File: — I

—Response monitaring Cancel

¥ | Eesnanse manterm e sctatad

Help

Calculated by COM: 0.43 [5]

User defined: 0.44 [5]

Figure 4-23 The "Export DP Master" dialog box

Click "OK" to accept the suggested setting.

Result: A query appears, asking whether the DP master is to be switched to
STOP mode.

Click "OK" in response to the query.

Result: The DP master switches to STOP mode, regardless of the position of
its mode selector. COM PROFIBUS transfers the parameter set to the DP
master (IM 308-C: the "RN" and "IF" LEDs come on; the mode of the IM 308-C
remains the same). The DP master continues to work with the old parameter
set (IM 308-C: the "ST" and "IF" LEDs come on).

COM PROFIBUS then asks whether the transferred parameter set is to be
activated immediately in the DP master:

If there is only one DP master on the PROFIBUS bus, respond with "Yes" to
activate the parameter set.

Or

If there are at least two DP masters on the PROFIBUS bus, respond with "No".
Transfer all the configuration data to the individual DP masters, and then acti-
vate the configuration data by choosing Service > Activate Parameter Set.

COM PROFIBUS
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Result: The DP master(s) work(s) with the new parameter set.

Note

In the case of the IM 308-C, the parameter set is saved on the memory card. After
power off/power on, the IM 308-C always works with the last parameter set
transferred.

Transfer the configuration to the IM 308C DP slave

If the IM 308-C DP slave is run exclusively as a DP slave, the master system
created by COM PROFIBUS for this IM 308-C must be exported.

Select the lower "S5 115U / CPU 945" icon (PROFIBUS address 5) in the window
for the graphical bus configuration (see Figure 4-2) and proceed in exactly the
same way as when transferring the configuration to the DP master. Perform steps 2
to 5. Select the PROFIBUS address "5" for the IM 308-C DP slave.

4.15 Assigning a PROFIBUS address

Before you commission the PROFIBUS-DP bus system, you assign the DP slaves
their PROFIBUS addresses. The PROFIBUS address of some DP slaves is set by
means of a DIL switch on the module. In the case of other DP slaves, the
PROFIBUS address can be assigned by means of software. COM PROFIBUS
obtains the relevant information from the device master file.

Please refer to the DP slave manual to find out how the PROFIBUS address is
assigned to the DP slaves and follow the instructions you find there.

Set the PROFIBUS address for the ET 200B and ET 200S

Use the DIL switch to set "2" for the ET 200B and "3" for the ET 200S. You will find
the exact procedure described in the ET 200B and ET 200S manuals.

Assigning a PROFIBUS address using COM PROFIBUS

If the PROFIBUS address can be assigned by means of software, proceed as
follows:

Requirements

* The programming device/PC (with a PROFIBUS card) must be connected to
the PROFIBUS-DP bus system or directly to the DP slave.

» The PC/programming device interface must be set (see Chapter 2).

e The DP slave must comply with the EN 50170, Volume 2, PROFIBUS standard.

COM PROFIBUS
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e The DP slave must be in its "waiting for parameterization" state (its state after
being switched on). The DP slave must not be engaged in data transfer with the
DP master.

How to assign a DP slave its PROFIBUS address

1. Select the DP slave in the window for the graphical bus configuration (see
Figure|4-2).

2. Choose Service > Modify PROFIBUS Address.
Result: The dialog box for changing the PROFIBUS address appears.

3. Enter the old and new PROFIBUS addresses. At initial commissioning, the "old
PROFIBUS address" corresponds to the default address of 126.

4. Click "OK" to apply the change and close the dialog box.

Result: COM PROFIBUS assigns the slave a new PROFIBUS address. The
slave adopts the new PROFIBUS address immediately.

4.16 Testing the signal states of the individual DP slaves

Before you commission the entire PROFIBUS-DP bus system, we recommend that
you check the signal paths of the sensors and actuators connected to the DP
slaves. COM PROFIBUS allows you to carry out a signal test for the configured and
connected inputs and outputs.

Requirements

e The programming device/PC (with a PROFIBUS card) must be connected to
the PROFIBUS-DP bus system.

« The PC/programming device interface must be set (see Chapter 2)!
e The CPU must be in STOP mode.

Test the signal conversion
1. Select the DP slave in the window for the graphical bus configuration (see
Figure 4-2)|

2. Choose the Service > Observe/Control Inputs/Outputs menu command or,
alternatively, the corresponding command in the pop-up menu for the DP slave
(by right-clicking it).

Result: The corresponding dialog box appears. COM PROFIBUS continuously
updates the status of the inputs and outputs of the DP slave.

COM PROFIBUS
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Control: ET 200U DF #12 < [_[O] x]
| D | Remarks | lAddr. | O Addr. | Format | Inputs | Cutputs |
ﬂ|4m:| |00P212 | OOP208 | KH  |0006 000000000000 |00 0000 0000 0000
ﬂlBD}-{ | (00P220 | OOP216 | KH | 0 | i
ﬂ| 801 | |0o0P221 | L oKH | oo |
ﬂ|2m{ | (00P222 | OOP21G | KH | 0000 0000 | 0000 0000

Figure 4-24  The "Control" dialog box

3. Start the status display of the slave inputs/outputs by choosing Status from the
pop-up menu for the inputs/outputs (by right-clicking the table field).

4. Stop the status display by choosing Stop Updating from the pop-up menu.

After switching with Control Values in the pop-up menu, entere new control
values in the white fields in the "Outputs” column of the table.

6. Start control of the outputs with the new control values by choosing Control
from the pop-up menu. The communication between the DP slave and the DP
master (class 1) is interrupted. The programming device/PC (master class 2)
with COM PROFIBUS is the master for this period.

7. Choose Stop Updating from the pop-up menu to terminate the control of the
outputs. The connection to the DP master (class 1) is established again.

Note

If there is no DP master (class 1) on the bus, the "Status” function is not available.

The "Control" function is not available for the "MPI_ISA card" PROFIBUS card
and for the station types DP/AS-I Link and ET 200L-SC.

4.17 Commissioning the bus configuration

One you have checked the wiring to the sensors and actuators of the various DP
slaves by means of "Observe/Control Inputs/Outputs” (Status/Control) you

commission the bus configuration.

Switch on the stations on the PROFIBUS bus
1. Connect all the DP slaves and DP masters with the PROFIBUS bus cable.

2. Switch on the power supplies of the DP slaves.
3. Switch the STOP/RUN switch of the DP slaves, if there is one, to RUN.

COM PROFIBUS
EWA 4NEB 780 6035-02 02

53



PROFIBUS-DP configuration example

4. Switch the mode selector switch of the IM 308-C from OFF or ST to RN.
5. Switch on the power supply of the base units.

Result: The IM 308-C starts up (BF (bus fault) LED flashes) and transfers the
slave parameters entered in COM PROFIBUS to the DP slaves.

The IM 308-C then compares the configuration created using COM PROFIBUS
with the actual configuration.

The BF LEDs of the connected DP slaves must go off. If there is data transfer
between all the configured DP slaves and the IM 308-C, the BF LED of the IM
308-C also goes off.

6. Use COM PROFIBUS to check the diagnostic messages (see Sectior 4.17)| In
this way you can check whether user data transfer to the DP slaves is working.

7. |If appropriate, restart the CPU.

You will find more information on commissioning the IM 308-C as a DP master in
the ET 200 Distributed I/0O System manual.

4.18 Evaluating a diagnosis with COM PROFIBUS

The diagnostic overview indicates which DP slave has detected a malfunction and
reports a slave diagnosis. The slave diagnosis provides detailed device-specific
diagnostic information.

Requirements

* The programming device/PC (with a PROFIBUS card) must be connected to
the PROFIBUS-DP bus system.

« The PC/programming device interface must be set (see Chapter 2).

e The CPU must be in STOP mode.

Display the diagnostic overview
1. Choose Service > Diagnostic Overview.

Result: The "Overview Diagnostics" dialog box appears.

COM PROFIBUS
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E Overview Diagnostics #1

1 2 3 4 5 6 7 8 9 10
10 EMim | [vfw] [x s |mis
n20 s |
.30 0 L
L 11 I I A

Figure 4-25 The "Overview Diagnostics" dialog box

The diagnostic overview displays the following:

DP master of the master system with an indication of the master status.
The master status indicates the current mode of the master: RN=RUN,
CL=CLEAR or ST=STOP

DP slave that belongs to the master system and is configured and
parameterized by the DP master. There are no diagnostic messages
for it.

S

There is a slave diagnosis for this DP slave. You can display it in plain
text by using the pop-up menu for the cell (which you access by right-
clicking the cell).

There is no user data transfer with this DP slave. The DP slave is no
longer on the bus or the slave has a configuration error (e.g. because a
module has been removed).

s DP slave that does not belong to the master system but that has been
configured using COM PROFIBUS in a different master system of the
bus configuration.

m DP master that does not belong to the master system but that has been

configured using
COM PROFIBUS in a different master system of the bus configuration.

m+s DP master that does not belong to the master system but that has been
configured using
COM PROFIBUS in a different master system of the bus configuration
and that also functions as a DP slave in another master system (e.g. the
IM 308-C as a DP slave).

X DP Slave that belongs to the master system but was not configured with
COM PROFIBUS

Result: If you move the mouse pointer over a cell in the "Overview Diagnostics"
dialog box, the status of the DP master or DP slave is displayed in plain text in the
status bar of COM PROFIBUS.
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Display the slave diagnosis
1. Select the diagnostic overview (see above).

2. Right-click a DP slave on which diagnostic data is available, and then choose
Slave Diagnosis from the pop-up menu that appears.

Result: The slave diagnostics mode dialog box appears.

3. Specify whether you want to request the slave diagnosis from the DP master or
directly from the DP slave, and then click OK.

Result: The "Slave Diagnostics" dialog box with plain-text slave-specific
diagnostic information appears.

4. Click the button on the toolbar.

Result: The slave diagnosis is printed.

Example:

Slave Diagnostics: ET 200U DP #12 <> M=l E3

Hezadecimal output

oo 00 0O OO0 OO OO O2 OF

Devicespecific diagnostics

Slow Mode Active
Configuration Errar
Madule Errar =]

Figure 4-26 The "Slave Diagnostics" display window
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56 EWA 4NEB 780 6035-02 02



5 PROFIBUS-FMS configuration example

Purpose of the example
This chapter describes a complete FMS configuration with COM PROFIBUS.

The configuration example is intended to show you how to proceed when
configuring an FMS master system using COM PROFIBUS. The sequence in which
the steps appear here is recommended rather than absolutely necessary.

Sample structure of an FMS configuration
The following PROFIBUS devices are used in the example described below:
« The CP 5412 (A2) as an FMS master
* The S7-300 with the CP 343-5 as an FMS station
* The ET 200U DP/FMS as an FMS station

Transmission method

RS 485 transmission method for electrical networks on the basis of shielded
twisted-pair cables

Network components

No additional network components such as OLMs, RS 485 repeaters, etc.

Bus protocol

PROFIBUS-FMS: This bus protocol applies when there are FMS masters based on
the EN 50170, Volume 2, PROFIBUS standard on the bus.

PROFIBUS-DP and PROFIBUS-FMS use the same transmission technology and
standardized bus access methods and can therefore run simultaneously on a single
cable.
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5.1

Start COM PROFIBUS

Read in the device master files

58

Starting configuration

From the Windows Start menu, choose:
Start > Prograns > Sienens COM PROFI BUS > COM PROFI BUS

Result: The COM PROFIBUS user interface appears and a default program file is
created.

T=COM PROFIBUS - [COMPro3]
| Eile Edit “iew Corfigure Service Docummentation  Options:  Window 7 - |ﬁ‘|5|

=] E3

D& 2zeE 2= 8] 2]

[ E_”l‘ Pt aster
DB o} DP-Slave
- @ FS-Mazter
- B FMS-Station

)

[Hardware
catalog]

I

4

[Window for
graphical
bus configuration]

N\

E

Prezz F1 to open the help system.

»is

OFFLIME i

Figure 5-1

Configuration with COM PROFIBUS

Choose the File > Read in GSD Files menu command.

Result: All the configurable bus nodes are displayed in the hardware catalog.

Note

You only need to execute this function when a new device master file is copied to
COM PROFIBUS's .. \fmsgsd subdirectory or an existing device master file in the
subdirectory is changed after the program is started up.
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5.2 Setting up the bus configuration

You begin configuration by selecting and arranging the FMS masters and FMS
stations in the window for the graphical bus configuration. Not until you have
created all the PROFIBUS nodes do you begin setting the parameters.

Several masters on the bus

The configuration for a master system is shown below. If there are several DP
masters on the bus, you can use the View > Network View and View > FMS menu
commands to switch between the view of the whole bus and the view of a master
system during configuration.

Set up the bus configuration graphically

Select the FMS master and the associated FMS stations from the hardware
catalog, and drag and drop the modules one after the other to move them to the
window on the right for the graphical bus configuration (see Figure 5-1).

Tip 1: Double-click the modules in the catalog to set up the configuration more
quickly.

Tip 2: Press <+> and <-> on the numeric keypad to open and close the entire
catalog.

Select the following modules from the hardware catalog for the sample
configuration:

FMS master > CP 5412 (A2)
FMB station > S7-300 CP343-5 FMB
FMS station > ET 200U DP/ FMsS

Result: The bus configuration is created with icons for all the modules (without
text)

2
m FROFIBUS address: 2

' | Statior twpe: 57-300 CP343-5 FMS5
S7-300 CP343 Order number: BGEEF 343-5FAD0-0XED
Mame:

CP 3412 (AR ET 200U DPFMS

Figure 5-2  Sample structure of an FMS configuration
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5.3 Entering bus parameters

Once you have set up the bus configuration graphically, you begin
parameterization. The bus parameters apply to the entire PROFIBUS bus system.

Enter the bus parameters
1. Choose Configure > Set Bus Parameters.

Result: The "Bus Parameters" dialog box appears.

Bus Parameters |
Bus Description: IF'FH:IFI BUS
— Buz Mode
Bus Profile: |PROFIBUSDP 7] Baud Rate: |1500.0 ~| kBaud

[T Fepeaters/0Ls

Cancel | Help Set Parameters...

Figure 5-3  The "Bus Parameters" dialog box

2. Select the "Standard" bus profile.

"Standard" applies in the case of multimaster operation with fast bus nodes,
which also include the SIMATIC NET PC module CP 5412 (A2). The bus
profiles are default sets of bus parameter settings for different PROFIBUS
applications. Each bus profile contains the PROFIBUS bus parameters
calculated and set by COM PROFIBUS for a specific configuration, profile and
transmission rate.

Tip: You can click the "Set Parameters" button to view the bus parameters
calculated by COM PROFIBUS. The calculated bus parameters can only be
changed if the "Adjustable" bus profile is selected.

3. Select a transmission rate of 1500.0 kbps.

The transmission rate set here applies to the entire PROFIBUS bus system. In
other words, all nodes on the PROFIBUS bus system must support the
selected transmission rate.

COM PROFIBUS
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4. Click "OK" to apply the bus parameters and exit the dialog box.

Result: The bus parameters are saved.

Repeaters/OLMs

If there are RS 485 repeaters in electrical networks or OLMs/OBTSs in optical
networks on the PROFIBUS-DP bus system, select the "Repeater/OLMs" check
box. The number of network components to be specified and the cable lengths are
taken into account by COM PROFIBUS when calculating the bus parameters.

Note

The network components configured in the network view of COM PROFIBUS
have no effect on the bus times calculated. If these network components are to be
taken into account, you must increase the number for "Repeaters/OLMs" in the
"Bus parameters" dialog box.

Change the bus parameters individually (optional)

Normally - i.e. when the FMS masters are configured with COM PROFIBUS - you
do not need to change the default bus parameter settings in the bus profile.

However, if you do want to adapt the bus parameters yourself and have the
required PROFIBUS expertise, select the "Adjustable” bus profile and then click the
"Set Parameters" button. In the "Bus Parameters" dialog box that appears you can
adapt the bus parameters yourself to suit your bus configuration. Please look up the
information on this in the online help system ("Help" button).

Note
Always set the slowest bus time of all bus nodes.

All the values for the bus parameters are specified in the unit t_bit (bit time). The bit
time depends on the transmission rate and is calculated using the following
formula: t_bit [us] = 1/transmission rate [1000 kbps].

Table 5-1 Bit time depending on the transmission rate

Transmission rate t_bit [us]
9.6 kbps 104.167
19.2 kbps 52.083
93.75 kbps 10.667
187.5 kbps 5.333
500 kbps 2.000
1500 kbps 0.667
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Target rotation time "Ttr"

The bus parameter "Ttr" calculated by COM PROFIBUS and shown here does not
represent the real target rotation time; it represents a maximum permitted value
and thus cannot be used to determine response times on the PROFIBUS bus
system.

5.4 Entering master parameters

You use the master parameters to specify the PROFIBUS address of the CP 5412
(A2). From here you also start the configuration of the FMS connections to the FMS
stations.

Enter the master parameters

1. Double-click the "FMS master: CP 5412 (A2)" icon in the window for the
graphical bus configuration (see Figure 5-2).

Result: The "FMS master parameters" dialog box appears.

FHS master parameters [CP 5412 A2) |

— General
PROFIBUS address: |1
Cancel |
Skation name: |
Hep |
Station type: |CP 5412 (42)
LsaP.. |
VD .. |
LConnections ... |
Oeverview ... |

Figure 5-4  The "FMS master parameters" dialog box

2. Setthe PROFIBUS address for the CP 5412 (A2):

Parameter Value
PROFIBUS address Keep "1"

Further support: Please also note the information on the master parameters in
the online help system ("Help" button).
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Reserve the LSAPs

Local service access points (LSAPS) that cannot be used simultaneously by other
protocols are used at the FDL interface of the CP 5412 (A2). If you use several

protocols simultaneously, you have to disable in COM PROFIBUS those LSAPs
that are used by the FDL protocol.

1. Click the "LSAP" button in the "FMS master parameters” dialog box.

Result: The "Reserve LSAP" dialog box appears. All the LSAPs used for
PROFIBUS are grayed out and can no longer be selected.

2. Reserve the LSAPs for FDL:

o LSAPs that are used by the FDL protocol (must be set by you)
u LSAPs that are still unused
=

LSAPs that are used by PROFIBUS-FMS (unchangeable)
3. Click "OK" to apply the LSAP reservations and exit the dialog box.

Edit the VFDs

Each time an FMS master is configured, COM PROFIBUS automatically creates a

virtual field device (VFD). You can edit the properties of the VFD and create other
VFDs for the CP 5412 (A2).

1. Click the "FVD" button in the "FMS master parameters" dialog box.

Result: The "Edit VFD" dialog box appears. "VFD list" contains all the VFDs
configured so far. If you select a VFD, the properties that can be set for the

VFD are displayed in the "Edit selected VFD" area. You can create VFDs by
clicking the "New" button.
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Eeaveo g

—WFD list

]
Cancel

Help

)

Delete

i

—Edit zelected WFD

WED number: I'I vI

WFD name: [VFD <15

YWendor name: ISIEMENS Al

Beleasze: 1.0 FPrafile number: I 0 vI

Figure 5-5  The "Edit VFD" dialog box

2. Clock "OK" to accept the default properties of the VFD for the sample
configuration and exit the dialog box.

Further support: Please also note the information on the VFD properties in the
online help system ("Help" button).

Note

At least one VFD must be configured. In other words, it is not possible to delete
the last VFD. If an FMS connection references a VFD that is to be deleted,
COM PROFIBUS outputs a warning to this effect.

The "Connections" button

The "Connections" button allows you to configure the FMS connections to the FMS
stations. We recommend that you begin by parameterizing the FMS stations and
then define the FMS connections, as in the example.

For information on the dialog box for specifying the FMS connections, refer to
Section 5.6.

COM PROFIBUS
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5.5 Entering station parameters for the S7-300 CP 343-5 FMS

For the FMS stations you only need to check the PROFIBUS addresses and, if
necessary, change them. No further settings are required.

For the sample configuration we accept the default PROFIBUS address "2" for the
FMS station S7-300 CP 343-5 FMS.

How to change the PROFIBUS address of an FMS station

1. Double-click the "S7-300 CP343-5 FMS" icon in the window for the graphical
bus configuration (see Figure 5-2).

Result: The "FMS station parameters" dialog box appears.

FM5 station parameters [ x| |

— General

PROFIBUS address: |2

Cancel

Station name: | 4||

Help

Station type: |5?-3nn CP3435 FM5

Figure 5-6  The S7-300 CP 343-5 FMS "Station parameters" dialog box

2. Change the PROFIBUS address of the FMS station.
3. Click "OK" to accept the setting and close the dialog box.

Further support: Please also note the information on the FMS station parameters in
the online help system ("Help" button).

5.6 Setting FMS connections to the S7-300 CP 343-5 FMS

Now that you have parameterized FMS masters and FMS stations, you define the
FMS connections. COM PROFIBUS allows you to create, modify and delete FMS
connections to FMS stations.

Create the FMS connections

1. Double-click the icon for the FMS master "CP 5412 (A2)" in the window for the
graphical bus configuration (see Figure 5-2).
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2. Click the "Connections" button in the "FMS master parameters” dialog box.

Result: The "Edit FMS connections" dialog box appears. The "Connections" list
displays all the configured FMS connections to all the FMS stations. If you
select an FMS connection, the parameters that can be set for the FMS
connection are displayed in the lower part of the dialog box. You can create
FMS connections by clicking the "New" button.

Edit FMS connections |

— Connectionz K
CR: M arne; Partner addr.; 4|

Y ===

3 Connection to 57-300 CP343-5 < 3=

— Select interface parameters

CR: |3 vI WED nurmber: |1 vI

M ame: IEnnnectiDn_tn_S?-EEII] CP343-5 <3

— Select connection parameters

Connection prafile; ISimaticN et tandarnds, j Parameters ... |

Figure 5-7  The S7-300 CP 343-5 FMS "Edit FMS connections" dialog box

3. Click the "New" button.

Result: The "FMS partner station" dialog box appears. The possible connection
partners are listed here for you to select, identified by their PROFIBUS address
and station name (or station type, if there is no station name available).

4. Select"2/S7-300 CP 343-5 FMS", and then click "OK".

Result: We have created an FMS connection to the S7-300 CP 343-5 FMS
with the PROFIBUS address "2" (see the figure above).

5. Retain the default settings of the FMS connections under "Select interface
parameters" and "Select connection parameters" for the following:

VFD number: The FMS connection is assigned to a configured VFD here.
In our example there is only one VFD with the number "1" (see Figure 5-5).
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- Connection profile: The specific communication parameters of an FMS
station are grouped together in the connection profile. COM PROFIBUS
obtains the permissible connection profiles from the device master file. You
can display and, if necessary, change the specific communication
parameters by means of the "Parameters” button (this is described in the
paragraphs that follow).

Further support: Please also note the information on the interface parameters
and connection parameters in the online help system ("Help" button).

Set the communication parameters of the FMS connections

The settings of the communication parameters and services described below must
be checked and, if necessary, changed for each FMS connection.

1. Inthe "Edit FMS connections” dialog box, select the FMS connection
"Connection_to_S7-300 CP343-5 <3>" and then click the "Parameters" button.

Result: The "FMS connection - communication parameters" dialog box
appears. Here you specify the communication type and the LSAPSs.

FHS connection - communication parameters |
— Communication type —Addrezzes
Connection tupe: b b L ¥ Local Fiemate
_ PROFIBUS- Cancel |
% (astermaster commeston address: 2
£ (aster-slave conmection Help |
sttty eyclic data fransfer Len 2 I2
I it elawe initiative H : - T |
£ Breadcast communizaton 3 4 :
0 pulicash commumeation 4 5 SEIver SEIvViCes ... |
] B :
Connection attibute ID vI B j 7 LI Lzl . |

Figure 5-8  The S7-300 CP 343-5 FMS "FMS connection - communication parameters"
dialog box

2. Set the communication parameters:

Parameter Value
Connection type "MMAZ" (unchangeable)
Master-master connection "Without slave initiative" (unchangeable)
Connection attribute Keep "D"
LSAP Keep local="2", remote="2"
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Connection type: When you select the connection type, you determine
which communication services are available. COM PROFIBUS obtains the
permissible connection types from the device master file of the connection
partner. The radio buttons under "Connection type" indicate the meaning of
the connection type (see also the section below entitled "Connection
types"). "MMAZ" is preset as the connection partner for the S7-300 CP343-
5 FMS.

Connection attribute: The connection attribute specifies whether the FMS
connection contains a definite (D = Definite Connection) or indefinite (I =
Indefinite Connection) connection end point. "D" (D = Definite Connection)
is kept for the S7-300 CP343-5 FMS.

LSAP: The value "2" is kept as the LSAP for both the CP 5412 (A2) (local)
and the FMS station S7-300 CP343-5 FMS (remote).

Further support: Please also note the information on the various communication
parameters in the online help system ("Help" button).

Note

The same connection type must be set for both communication partners of the
FMS connection.

Connection types

68

The following table shows the connection types of the FMS connections and the
possible request types.

Table 5-2 Assignment of connection type to request type
Connection type Request type
MMAZ Master-master with EMS EMS
acyclical connection: master master
. ) WRITE >
Writing, reading and READ <&
reporting possible in
LI D et REREEREE - REPORT
both directions
- WRITE
— READ
REPORT -] >
MSAZ Mastgr-slave W'th FMS master FMS slave
acyclical connection:
Writing, reading and WRITE < —
o . READ <
reporting is possible
from the FMS master
REPORT ---f---------1 ===

COM PROFIBUS
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MSAZ_SI Master-slave with acyclical
connection and slave FMS master FMS slave
initiative*: WRITE >
- . READ =
Writing, reading and <] — REPORT
reporting is possible from
the FMS master The FMS
slave can also report if the REPORT --F------ -—
master has granted it the
appropriate authorization to
send.
MSzY Master-slave with cyclical EMS master EMS slave
connection:
- . WRITE >
Writing, reading and READ <&
reporting is possible from
the FMS master
REPORT -t------ r——
MSZY_SI Master-_slave with cyclical EMS master EMS slave
connection and slave
initiative*: WRITE =
o ] READ -
Writing, reading and PR - REPORT
reporting is possible from
the FMS master The FMS
slave can also report if the REPORT -r-=---- [
master has granted it the
appropriate authorization to
send.
BRCT Broadcast
) FMS master
A broadcast is sent to all.
REPORT .-
MULT Multicast
. ) FMS master
A multicast is sent to
several. REPORT . {-—-- »
* The slave initiative (SI) specifies that the slave can initiate requests on this connection itself.
— Confirmed request
~=® Unconfirmed request
:l Client function
:l Server function
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EWA 4NEB 780 6035-02

69



PROFIBUS-FMS configuration example

Check the client and server services

1. Inthe "FMS connection - communication parameters” dialog box, click the
"Client services" or "Server services" button.

Result: The "FMS connection - services (client)" or "FMS connection - services
(server)" dialog box appears.

FHE connection - services [client] |
Standard | Extended |
— Eeneral — Object directany
™| Emed addiess ™| GetEm (e
™| Unzalicited status
| Euton
—anables
v ﬂeacﬁ v Wit
™| Feadwith bpe = | wirite with bpe
™| Fhpsread ™| Phyzwrite
[ Information report ™| Lielete/define wanatle list
™| [t ation report with bipe

] I Cancel | Help

Figure 5-9  The S7-300 CP 343-5 FMS "FMS connection - services (client)" dialog box

2. Check the services and, if necessary, modify them (e.g. click "Information
report"):

Client services: Services that are to be used by the FMS master as a client
on the selected FMS connection (e.g. when the FMS master wants to send
read requests to the FMS station via the FMS connection).

Server services: Services that are to be used by the FMS master as a
server on the selected FMS connection (e.g. when the FMS master wants
to receive read requests from the FMS station via the FMS connection).

3. Click "OK" to accept the settings and close the dialog box.

Further support: Please also read the description of each service in the online help
system ("Help" button).

Note

An FMS connection is only set up when the connection partners support the same
services (client - server). For this reason you can change services here in order to
adjust them to the level of the weaker communication partner.
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Specify the details of the FMS connection

1. Inthe "FMS connection - communication parameters"” dialog box, click the
"Details" button.

Result: The "FMS connection - details" dialog box appears. Here you can set
other, seldom used parameters for an FMS connection. You normally do not
need to change the default parameters displayed. These parameters are
dependent on the connection profile and described in the PROFIBUS standard.

FHS connection - details |
— LLI attributes
LLI SAP: FMS - Controlinterval (10ms) | EDON |LI
Multiplier: I—‘I ﬂl
—Magimum PDU size—— — Marimum parallel zervices

Sending high prio: |_|:| bax SCC:
Sending low pric; Iﬁ tax BCC:
Receiving high prio: |_|:| bax SALC:
Receiving low pric; Iﬁ bl an BAL:

]

Figure 5-

10 The S7-300 CP 343-5 FMS "FMS connection - details" dialog box

2. Change the details of the FMS connection, if necessary.

COM PROFIBUS
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LLI attributes: LLI stands for lower layer interface. This interface
establishes the connection between the FMS user interface and the
underlying FDL services. You use the LLI attributes to specify the interface
to the application layer (FMS in the case of the CP 5412 (A2)) and the
properties of the LLI.

Maximum PDU size: Maximum possible lengths of the high-priority and
low-priority protocol data units (PDUSs) in the sending and receiving
directions.

Maximum parallel services: The maximum parallel services affect the
memory requirements on the CP 5412 (A2). Higher values require more
memory but also increase the throughput rate.
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3. Click "OK" to accept the settings and close the dialog box.

Result: The connection parameters for the connection to the S7-300 CP 343-5
FMS have now all been set.

Note

An FMS connection is not set up unless the settings specified here for the details
match those of the communication partner.

Further support: Please also read the description of the communication parameters
in the online help system ("Help" button).

5.7 Entering station parameters for the ET 200U DP/FMS

For the FMS stations, you only need to check the PROFIBUS addresses and, if
necessary, change them. No further settings are required.

For the sample configuration we accept the default PROFIBUS address "3" for the
FMS station ET 200U DP/FMS.

How to change the PROFIBUS address of an FMS station

1. Double-click the "ET 200U DP/FMS" icon in the window for the graphical bus
configuration (see Figure 5-2).

Result: The "FMS station parameters” dialog box appears.

FHS station parameters |

— aeneral

PROFIBUS address: |3

Cancel

Station name; | 4||

Help

Station type: |ET 200U DP/FMS

Figure 5-11 The ET 200U DP/FMS station parameters dialog box
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2. Change the PROFIBUS address of the FMS station.
3. Click "OK" to accept the setting and close the dialog box.

Further support: Please also note the information on the FMS station parameters in
the online help system ("Help" button).

5.8 Setting FMS connections to the ET 200U DP/FMS

Now that you have parameterized FMS masters and FMS stations, you define the
FMS connections. COM PROFIBUS allows you to create, modify and delete FMS
connections to FMS stations.

Create the FMS connections

1. Double-click the FMS master “CP 5412 (A2)" icon in the window for the
graphical bus configuration (see Figure 5-2).

2. Click the "Connections" button in the "FMS master parameters" dialog box.

Result: The "Edit FMS connections" dialog box appears. The "Connections" list
displays all the configured FMS connections to all the FMS stations. If you
select an FMS connection, the parameters that can be set for the FMS
connection are displayed in the lower part of the dialog box. You can create
FMS connections by clicking the "New" button.

Edit FM5 connections |

— Connectionz K
CR: I arne; Partner addr.: 4|
3 Connection to 57-300 CP343-5 <3 2 Cancel |
4 Connection to ET 2000 DPAFMS <45 i
Help |

Delete |
— Select interface parameters
CR: |4 vI YED nurber: |1 vI

Mame: IEDnnectiDn_tu:u_ET 2000 DP/FMS <4

— Select connection parameters

Connection prafile; ||:F| 2 M50y [L5AP 20) Fead j Parameters ... |

Figure 5-12 The ET 200U DP/FMS "Edit FMS connections" dialog box
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3. Click the "New" button.

Result: The "FMS partner station" dialog box appears. The possible connection
partners are listed here for you to select, identified by their PROFIBUS address
and station name (or station type, if there is no station name available).

4. Select"2/ET 200U DP/FMS", and then click "OK".

Result: We have created an FMS connection to the ET 200U DP/FMS with the
PROFIBUS address "3" (see the figure above).

5. Retain the default settings of the FMS connections under "Select interface
parameters” and "Select connection parameters” for the following:

VFD number: The FMS connection is assigned to a configured VFD here.
In our example there is only one VFD with the number "1" (see Figure 5-5).

Connection profile: The specific communication parameters of an FMS
station are grouped together in the connection profile. COM PROFIBUS
obtains the permissible connection profiles from the device master file. You
can display and, if necessary, change the specific communication
parameters by means of the "Parameters" button (this is described in the
paragraphs below).

Further support: Please also note the information on the interface parameters
and connection parameters in the online help system ("Help" button).

Set the communication parameters of the FMS connections
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The settings of the communication parameters and services described below must
be checked and, if necessary, changed for each FMS connection.

1. Inthe "Edit FMS connections” dialog box, select the FMS connection
"Connection_to_ET 200U DP/FMS" and then click the "Parameters” button.

Result: The "FMS connection - communication parameters" dialog box
appears. Here you specify the communication type and the LSAPs.
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FHS connection - communication parameters

— Communication type

Connection tupe: [ by >

£ Mastermaster conmestion

% aster-slave conmection
¥ ity eyclic data fransfer
I ithy elawe initiative

£ Breadcast communizaton

0 pulicash commumeation

=

Connection attibute

]|
—Addresses
Local Bemate
PROFIBUS- Cancel |
address: 3
Help |
L3AFR: |F'IIILL |2n

Client gervices ... |

Server semvices .. |

Detailz .. |

Figure 5-13 The ET 200U DP/FMS "FMS connection - communication parameters" dialog box

2. Set the communication parameters:

Parameter

Value

Connection type

"MSZY" (unchangeable)

Master-slave connection

"With cyclical data interchange" (unchangeable)

Connection attribute

"D" (unchangeable)

LSAP

Local "POLL", remote "20" (unchangeable)

Further

Connection type: When you select the connection type, you determine
which communication services are available. COM PROFIBUS obtains the
permissible connection types from the device master file of the connection
partner. The radio buttons under "Connection type" indicate the meaning of
the connection type (see also the section below entitled "Connection
types"). "MSZY" is preset as the connection partner for the ET 200U
DP/FMS.

Connection attribute: The connection attribute specifies whether the FMS
connection contains a definite (D = Definite Connection) or indefinite (I =
Indefinite Connection) connection end point. "D" is preset for the ET 200U
DP/FMS.

LSAP: The POLL list SAP is set as the LSAP for the CP 5412 (A2) (local),
and the value "20" is preset for the FMS station ET 200U DP/FMS
(remote).

support: Please also note the information on the various communication

parameters in the online help system ("Help" button).

Note

The same connection type must be set for both communication partners of the
FMS connection.
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Connection types
See table 5-2

Check the client services

1. Inthe "FMS connection - communication parameters” dialog box, click the
"Client services" button.

Result: The "FMS connection - services (client)" dialog box appears.

FHE connection - services [client] |
Standard | E:-:tenu:ledl
General Object directon
™| Emed addiess ™| GetEm (e
™| Unzalicited status
| Euton
—anables
v ﬂeacﬁ = rite
™| Feadwith bpe = | wirite with bpe
= Bhveread ™ Phys wiite
™| [rtarmation repart ™| Lielete/define wanatle list
™| [t ation report with bipe

] I Cancel Help

Figure 5-14 The ET 200U DP/FMS "FMS connection - services (client)" dialog box

2. You can view the client services supported here. In the case of the ET 200U
DP/FMS, the CP 5412 (A2) can send read requests via the FMS connection.

3. Click "OK" to accept the settings and close the dialog box.

Further support: Please also read the description of each service in the online help
system ("Help" button).

Specify the details of the FMS connection

1. Inthe "FMS connection - communication parameters" dialog box, click the
"Details" button.

Result: The "FMS connection - details" dialog box appears. Here you can set
other, seldom used parameters for an FMS connection. You normally do not
need to change the default parameters displayed. These parameters are
dependent on the connection profile and the selected services and described in
the PROFIBUS standard.
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FHS connection - details |
— LLI attributes
LLI S&P: 5 <] Controlinterval (10ms) | ENNN o |
Multiplier: I—‘I ﬂl
Help |
—Magimum PDU size—— — Marimum parallel zervices

Sending high prio: |_|:| bax SCC:
Sending low pric; Iﬁ tax BCC:
Receiving high prio: |_|:| bax SALC:
Receiving low pric; Iﬁ bl an BAL:

]

Figure 5-15 The ET 200U DP/FMS "FMS connection - details" dialog box

2. Change the details of the FMS connection, if necessary.

- LLI attributes: LLI stands for lower layer interface. This interface
establishes the connection between the FMS user interface and the
underlying FDL services. You use the LLI attributes to specify the interface
to the application layer (FMS in the case of the CP 5412 (A2)) and the
properties of the LLI.

- Maximum PDU size: Displays the maximum possible lengths of the high-
priority and low-priority protocol data units (PDUSs) in the sending and
receiving directions.

- Maximum parallel services: No parallel services possible.
3. Click "OK" to accept the settings and close the dialog box.

Result: The connection parameters for the connection to the ET 200U DP/FMS
have now all been set.

Note

An FMS connection is not set up unless the settings specified here for the details
match those of the communication partner.

Further support: Please also read the description of the communication parameters
in the online help system ("Help" button).
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5.9 Saving the configuration

Our example is now fully configured. The configuration data has to be saved in a
program file.

Save the configuration

1. Choose the File > Save as menu command or ‘E’
2. Enter a file name with the extension *.pb5, and then click "OK".

Result: The completed bus configuration is saved in the program file. You can
export the configuration data to the FMS masters.

5.10 Documenting and printing the configuration

You can use the Documentation menu to obtain a variety of information on the
parameterized bus configuration. You can, for example, display an overview
indicating which FMS stations are on the PROFIBUS bus (with their PROFIBUS
addresses) or which FMS connections have been configured. You can print out any
overview you have displayed.

In the following we display by way of example the connection overview (FMS) in
order to check the properties of the configured FMS connections.

Further support: Please also refer to the detailed description of all the
documentation options in the online help system (look under "Documentation™).

Display the connection overview (FMS)
1. Choose Documentation > Connection Overview (FMS).
Result: The "Connection overview (FMS)" dialog box appears.
2. Select the relevant FMS stations.

Result: The connection overview (FMS) of the FMS stations is displayed to you
as follows:
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| | n d
Connections List (FMS)
Fhis-Master: 1
FMS MMaster #5
Address: 5
station Type:  CP 2412 (AZ2)
COrder Mumber: 65E 1 541-2BA00
Address: o
station Type: CP D412 (A
COrder Mumber: 6EE 1 541-2BAN0
=tation Description: =]
|@ | I_ I_ I_ @ Arbeitzplatz o

Figure 5-16 The "Documentation Connections List (FMS)" overview

Print the connection overview (FMS)

1. Choose the File > Print menu command or |§I
2. Specify the print properties, and then click "OK".

Result: The "Documentation Connections List (FMS)" overview is printed out.

5.11 Transferring (exporting) the configuration to an NCM file

For the SIMATIC NET PC module CP 5412 (A2) you need a binary database (.Idb)
in NCM format.

COM PROFIBUS only exports the data of one master system to an NCM file.

Note

If your bus configuration consists of several master systems, and you change the
parameterization of one master system, you also have to export the configuration
data of the other master systems. Otherwise, there will be problems in the bus
system, which may even fail.
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Transfer the configuration to a binary database (NCM file)
1. Select the FMS master in the window for the graphical bus configuration.
2. Choose File > Export > NCM File.
Result: The "Export NCM file as" dialog box appears.

3. Choose a name for the NCM database, give it the extension ".LB", and click
"OK".

Result: The "Export NCM file" dialog box appears. COM PROFIBUS suggests
a response monitoring time on the basis of the bus configuration and the set
transmission rate. You can accept this time or set a longer time.

4. Click "OK" to accept the suggested setting.

Result: COM PROFIBUS converts the created configuration of the current
master system and creates the following files:

NCM file, loadable binary database (.LDB)
Error file (ERR)

5. Choose the File > Export > NCM File menu command to load the binary
database (NCM file) to the SIMATIC NET PC module.
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6 Running PROFIBUS-DP and PROFIBUS-FMS
in parallel

The EN 50 170, Volume 2, PROFIBUS standard allows PROFIBUS-DP and
PROFIBUS-FMS to be run on a shared physical bus line.

The SIMATIC NET communication processor CP 5412 (A2) permits PROFIBUS-
DP and PROFIBUS-FMS to be run simultaneously.

Proceed as follows:
1. Create a new master system by choosing File > New.

2. Select the CP 5412 (A2) from the hardware catalog as the DP master, and
then move it (by dragging and dropping_it) to the window on the right for the
graphical bus configuration (see Figure 4-1).

3. Select another CP 5412 (A2) from the hardware catalog as the FMS master,
and then move it too (by dragging and dropping it) to the window on the right
for the graphical bus configuration.

4. Double-click the icon of the second CP 5412 (A2) (FMS master).
Result: The master parameters dialog box appears.
5. Enter the PROFIBUS address of the first CP 5412 (A2) (DP master).

6. Respond with "Yes" to the query as to whether the CP 5412 (A2) is to be run in
parallel mode (DP and FMS).

Result: Both icons for the CP 5412 (A2) have the same PROFIBUS address.

COM PROFIBUS creates a separate master system under the same PROFIBUS
address for each log. The nodes you configure depend on which COM PROFIBUS
view you are in (master system <i> or FMS). In the master system <i> view you
configure the DP slaves, and in the FMS view you configure the FMS stations.

You will find information on configuring the DP slaves in Chapter 4 and on
configuring the FMS stations in Chapter 5.
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7 Importing configurations

Preliminary remark

Normally you work with an existing program file or create a new program file. Only
in exceptional cases, such as when the program file is lost or when data is imported
that was created using a different configuration tool (ASCII data), do you require the

import function.

Importing data

Depending on the master there are various ways of reading in or importing the data
of a master system using COM PROFIBUS:

File > Import >
DP Master

/

COM PROFIBUS

File > Import >
Memory card

/

File > Import >
NCM file

\

File > Import >
Binary file/ASCII file

N

From DP Master,
e. g.IM 308-C

From Memory
card, e. g. with
IM 308-C

From databases
created with
COML-FMS / -DP,
e. g. with

CP 5412 (A2)

From backup of
a master system
on PC/program-
ming device

Figure 7-1 Options for importing master systems

Note

COM PROFIBUS receives the data of one master system at each import.

Only if you read in all the master systems (from DP master, memory card, NCM
file and binary file) that together form the complete configuration of a bus system
can you reconstruct the entire configuration of the bus system and save it in an

overall program file.
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Importing data from a DP master
Before you can import the data directly from a DP master:

* The programming device/PC (with a PROFIBUS card) must be connected to
the PROFIBUS bus system or directly to the DP master.

« The PC/programming device interface must be set (see Chapter 2).
* A master system must have been transferred to the DP master.

« When the IM 308-C is a DP master, and only then, the memory card must be
inserted.

*  When the S5-95U is a DP master, and only then, the 32 K-EEPROM must be in
the S5-95U.

Choose File > Import > DP Master or to read in the data. During the import
process you are asked questions and offered options to select in dialog boxes. The
online help system supports you in this.

Result: The data of a master system is in the open program file.

Importing data from a memory card
Before you can import data from a memory card:
* The programming device must have a memory card interface, or

e The programming device must have an E(E)PROM slot with the associated
programming adapter, or

e The PC must have an external PROM programmer.
« The memory card must be parameterized (see Chapter|2).

e The memory card must be inserted in the memory card interface of the
programming device or PC.

Choose File > Import > Memory Card to read in the data. During the import
process you are asked questions and offered options to select in dialog boxes. The
online help system supports you in this.

Result: The data of a master system is in the open program file.

Importing data from an NCM file

The File > Import > NCM File function allows you to read databases into
COM PROFIBUS that you have created using the SIMATIC NET PC configuration
tools (e.g. COML-DP or COML-FMS).
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Importing data from a binary file

You only need this function if your original program file has got lost but was
previously saved as a binary file.

To read in data from a binary file:
1. Choose File > Import > Binary File:
2. Select a file with the extension ".2BF".

Result: The binary file is converted to a format that COM PROFIBUS can read, and
it is then read in. The contents of a binary file correspond to a master system. The
data of the binary file is in the open program file.
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Exporting data

The following options are available for exporting data with COM PROFIBUS.

File > Export >
DP Master

~

COM PROFIBUS

File > Export >
Memory card

/

File > Export >
NCM file

\

File > Export >
binary file/ASCII file

S

To DP Master,
e.g.IM 308-C

To memory
card, e. g. with
IM 308-C

To databases for
COML -FMS/ -DP,
e. g. with

CP 5412 (A2)

To backup of a
master system

on PC/program-

ming device

Figure 8-1 Options for exporting master systems

Note

COM PROFIBUS transfers the data of one master system at each export.

If your bus configuration consists of several master systems and you change the
parameterization of a master system, you also have to reparameterize the other

masters. Otherwise, there will be problems in the bus system, which may even fail
(e.g. due to a change in the response monitoring time).

Exporting data to a DP master

Before you can export the data directly to a DP master:

e The programming device/PC (with a PROFIBUS card) must be connected to
the PROFIBUS bus system or directly to the DP master.

» The PC/programming device interface must be set (see Chapter 2).

«  When the IM 308-C is a DP master, and only then, the memory card must be

inserted.

* When the S5-95U is a DP master, and only then, the 32 K-EEPROM must be in

the S5-95U.
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Choose File > Export > DP Master or = to transfer the data. During the export
process you are asked questions and offered options to select in dialog boxes. The
online help system supports you in this.

Result: The data of a master system is transferred to the DP master and may be
stored on the inserted storage medium (memory card or 32 K-EEPROM).

Note

Since the default parameter set (e.g. for the IM 308-C: transmission rate = 19.2
kbps and PROFIBUS address = 1) is stored on the DP master, there must be no
other node on the PROFIBUS bus with the default PROFIBUS address (e.g. 1)
and a different transmission rate must not be set.

Activating the parameter set

If you are running multiple master systems (multiple DP masters) on the
PROFIBUS bus, you should activate the new parameter sets synchronously. There
are two ways to do this:

* Onlyin the case of the last master system do you respond with "Yes" to the last
query as to whether you want to accept the parameter set when exporting.

* You respond with "No" to the query as to whether you want to accept the
parameter set when exporting all the master systems, and you then choose
Service > Activate Parameter Set.

Exporting data to a memory card
Before you can import data from a memory card:
e The programming device must have a memory card interface, or

e The programming device must have an E(E)PROM slot with the associated
programming adapter, or

e The PC must have an external PROM programmer.
« The memory card driver must be parameterized (see Chapter 2).

e The memory card must be inserted in the memory card interface of the
programming device or PC.

Choose File > Export > Memory Card to read in the data. During the export
process you are asked questions and offered options to select in dialog boxes. The
online help system supports you in this.

Result: The configuration data is stored on the memory card. You can then insert
the memory card in the IM 308-C, for example.
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Exporting data to an NCM file

You need binary databases in NCM format for SIMATIC NET PC modules (e.g. for
the CP 5412 (A2)).

The File > Export > NCM File function allows you to create databases in NCM
format with COM PROFIBUS. You can then use the Service > Setting the PG/PC
Interface function to load a database created in this way to a locally installed
module.

If you have installed a corresponding SIMATIC NET PC module, and one of the
following products is also installed, COM PROFIBUS offers you the Export and
Load NCM File functions in the pop-up menu for the module. This allows you to
create a database and load it to the module immediately without having to use the
Setting the PG/PC Interface function.

Product Version
PG-5412/Windows 98, NT 4.0 Asof V5.1
DP-5412/Windows 98, NT 4.0 Asof V5.1
FMS-5412/Windows 98, NT 4.0 Asof V5.1
SOFTNET-DP/ Windows 98,NT 4.0 Asof V5.1

Exporting data to a binary file

You only need this function for DP masters that cannot read a memory card or do
not support the function for exporting data to a DP master.

To save data in a binary file:
1. Choose File > Export > Binary File:
2. Enter a file name with the extension ".2BF".

Result: The data of the open master system is converted by COM PROFIBUS and
saved in a binary file.
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9 Device master files

A device master file is required for every PROFIBUS device so that it can be
integrated in COM PROFIBUS.

What is a device master file?

A device master file (GSD file) contains a device description in a uniform format
stipulated by the EN 50 170, Volume 2, PROFIBUS standard.

Device master files are located in COM PROFIBUS'’s "\GSD" directory.

Listing device master files

The Documentation > GSD Files menu command lists all the device master files
in COM PROFIBUS together with the device name and version in each case.

Reading in a device master file

If you copy new device master files to the "\GSD" directory while COM PROFIBUS
is running, you must then read the directory in again by means of File > Read in
GSD Files.

Creating a device master file

To enable DP slaves of the ET 200 family to be connected to DP masters of other
vendors, you can create device master files with the completed configuration data
of a DP slave (except for address assignment). You thus use the user-friendly
plain-text parameterization of COM PROFIBUS:

In COM PROFIBUS you create a master system with a default master. You then
select the DP slave in the graphical editing window and choose the File > Create
GSD File menu command. During the process of creating the file you are asked
questions and offered options to select in dialog boxes. The online help system
supports you in this.
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Result: The device master files created in this way are stored by COM PROFIBUS
in the ..\DATA directory.

You then copy the device master file to the device master file directory of the other
configuration tool. The DP slave is thus available in the other configuration tool with
fixed parameterization; only address assignment is still necessary.

ET 200 distributed 1/0 devices and Siemens field devices

To enable ET 200 distributed I/O devices and Siemens field devices to be
connected, COM PROFIBUS is shipped with the corresponding device master files.
The device master files of new Siemens I/O devices whose device master files are
not in COM PROFIBUS’s GSD directory are available from the interface center.
You can download them by modem on:

. Tel. +49 (911) 737972
. Tel. +49 (911) 730983

Alternatively, you can download the device master files for SIEMENS devices on
the Internet. You will find all the device master files under "Downloads"” on the
SIMATIC Customer Support Web page at http://www.ad.siemens.de/csi_e/gsd.

Field devices of other vendors

92

To enable field devices of other vendors to be connected, device master files that
can be integrated in the configuration tools are generally supplied with these field
devices. COM PROFIBUS can interpret these device master files provided the files
are created in accordance with the EN 50170, Volume 2, PROFIBUS standard.

Copy these device master files to the "\GSD" directory, and then choose File >
Read in GSD Files.
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10 Assigning shared input masters

Definition

Every DP slave with inputs can be read accessed not only by the parameter
assignment master but by other DP masters as well. These DP masters are known
as shared input masters. The DP slaves accessed by a shared input master are
known as shared input slaves.

Requirement

Before you assign the DP slave a shared input master, you must have configured
the DP slave fully in another master system and set all the slave properties.

Assigning a shared input master

1.
2.
3.

COM PROFIBUS

Select a DP slave from the module catalog, and

Drag it to the master system containing the shared input master.
Double-click the icon for the DP slave.

Result: The "Slave properties” dialog box appears.

Click the "Shared master" button.

Result: The "Selection: Shared master" dialog box appears.
Select the shared input master, and then click OK.

Result: The shared input master now has read access to the inputs of the DP
slave.
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11 Taking into account other masters that are
not contained in COM PROFIBUS

Definition

If there are other masters on the bus - in addition to the masters entered with
COM PROFIBUS - you must take these into account in the target rotation time.

Note

Once you have used COM PROFIBUS to configure all the masters that together
form a bus system, COM PROFIBUS calculates the total target rotation time
automatically. In this case, you do not have to take into account any other target
rotation times.

Taking into account non-COM PROFIBUS masters

In order to take into account the target rotation time of a master not contained in
COM PROFIBUS, proceed as follows:

1. Fully configure both master systems. This results in a target rotation time (TTR)
for each master system:

- TTR1: Calculated by COM PROFIBUS
- TTR2: Calculated by another software tool
The sum of the two target rotation times (TTR) is the final target rotation time.

2. Choose Configure > Set Bus Parameters in COM PROFIBUS, and then click
the "Set parameters” button.

Result: The "Bus Parameters" dialog box appears.
Note the target rotation time (TTR1) calculated by COM PROFIBUS.

4. Enter for the "Delta Ttr" parameter the time in bit time units that you have
calculated as the target rotation time (TTR2) for the non-COM PROFIBUS
master.

Result: When you click the "Calculate" button, COM PROFIBUS calculates the
new target rotation time (Ttr) in bit time units.
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5. Inthe non-COM PROFIBUS master system, add the target rotation time
(TTR1) noted under step 3 to the target rotation time (TTR2) of the non-COM
PROFIBUS master system.

6. You may need to modify additional bus parameters.

Subsequent changes

If you make changes after you have changed the target rotation time appropriately,
proceed as follows:

1. Obtain the target rotation times in all the master systems again.

2. To calculate the new target rotation time, carry out steps 1 to 5 above.

COM PROFIBUS
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12 Tips and tricks

How to find the PROFIBUS device in the hardware catalog

Select the area in the hardware catalog, and then press the key combination
<SHIFT> + <+> (on the numeric keypad).

Result: The entire catalog is displayed. You can find your PROFIBUS device
quickly by using the scroll bar.

Press the key combination <SHIFT> + <-> (on the numeric keypad) to close the
catalog again.

What to do if the PROFIBUS device does not appear in the hardware catalog
Proceed as follows:
1. Choose the File > Read in GSD Files menu command.
2. Choose the Documentation > GSD Files menu command.

Result: A list of all the device master files known to COM PROFIBUS appears
together with the path in the hardware catalog.

Look for your PROFIBUS device in the list.

4. If a device master file is not displayed for your PROFIBUS device, change to
Windows Explorer.

5. Check whether the device master file is in the ...\gsd, ...\fsmgsd directory. You
will find the name of the associated device master file in the documentation for
the device.

If the device master file is not there, you must obtain it from the vendor (see
Chapter 9).

How to display the data cycle times

If you choose Service > Data Cycle Times, COM PROFIBUS displays the data
cycle times such as the response monitoring time for the configuration entered.

How to take other masters into account

If there are other masters on the bus - in addition to the masters entered with
COM PROFIBUS - you must take these into account in the target rotation time.

Proceed as described in detail in Chapter 11.
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How to document a configuration

COM PROFIBUS provides you with the following lists for documenting the

completed configuration:

Table 12-1

Documenting the completed configuration

Documentation > ...
menu command

Shows ...

Bus Parameters

... the transmission rate, the bus profile and the bus times,
among other things.

Station List

... a list of all the stations on the bus, arranged by their
PROFIBUS addresses, with their names and the master or host
to which they are assigned.

Host/Master Systems

... the configuration of the host, the masters assigned to it, and
which PROFIBUS addresses of the DP slaves/FMS stations are
assigned to a master.

Group

... which DP slave is assigned to which group with what
properties (FREEZE, SYNC).

Station-oriented
Address Assignment

... which STEP 5 addresses are assigned to a DP slave.

Area-oriented Address
Assignment

... how the STEP 5 address area is split up among the different
DP slaves.

Connection Overview
(FMS)

... which FMS connections to an FMS station have been
configured (only in the case of FMS configuration)

GSD Files

... which device master files are in a directory known to COM
PROFIBUS and which station types which device master file is
assigned to.

To obtain a printout, click the desired documentation list and then choose

File > Print or .

How to activate a parameter set on a DP master

98

When you export the data of a master system directly to the DP master by means
of the File > Export > DP Master function, the new parameter set is not

immediately valid.

COM PROFIBUS asks whether the transferred parameter set is to be activated
immediately in the DP master:

» If there is only one DP master on the PROFIBUS bus, respond with "Yes" to
activate the parameter set immediately.

e If there are at least two DP masters on the PROFIBUS bus, respond with "No".
Transfer all the configuration data to the DP masters, and then activate the
configuration data by choosing Service > Activate Parameter Set.

It is thus possible to activate parameter sets synchronously.
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How to switch COM PROFIBUS offline/online

If programming devices/PCs are being run online on the PROFIBUS bus - for the
display of diagnostic messages or the status, for example - and you want to
disconnect the programming devices/PCs from the PROFIBUS bus, choose
Service > Switch PG/PC Offline.

What to do if you do not have the device master files you need
In the case of PROFIBUS devices of other vendors, please contact the vendor.

In the case of Siemens PROFIBUS devices, the device master files are available at
the interface center. You can download them by modem on:

«  Tel. +49 (911) 737972

. Tel. +49 (911) 730983

Alternatively, you can download the device master files on the Internet. You will find
all the device master files under "Downloads" on the SIMATIC Customer Support
Web page at http://www.ad.siemens.de/csi_e/gsd.
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Glossary

Address identifier

Binary file

Bus

The address identifier (also known simply as an identifier or ID) is a decimal
number in which the properties of the input and output areas of the slaves are
stored at DP configuration.

The binary encoding (identifier format) of the address identifier for DP slaves is
specified in the EN 50170, Volume 2, PROFIBUS standard.

File (with the extension .5BF) that contains all the parameters created with
COM PROFIBUS for a master system.

The format of the binary file corresponds to that of the memory card. Masters that
cannot read a memory card or do not support the function for exporting a
configuration to a DP master can be supplied by means of this binary file.

Directory: ...\DATA

The bus is the common transfer medium that connects all the nodes in the network.
A PROFIBUS bus is a two-wire cable or fiber-optic cable.

Client/server principle

In client/server data interchange, the client always issues the communication
requests and the server executes them.

Compact DP slave

The structure of a compact DP slave is unchangeable in the input and output areas
(e.g. ET 200B).
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Configuration

Selection and compilation of the components of a DP slave and assignment of
addresses to the various input and output areas of the components.

Device master file

The device master file contains the device master data (electronic data sheet) of
the PROFIBUS device and must be created by the manufacturer of the device.

The structure of the device master file is specified in the EN 50170, Volume 2,
PROFIBUS standard. The file is required in order to configure the PROFIBUS
device.

» Directory: ..\GSD for DP slaves and DP masters

e Directory: ..\FMSGSD for FMS stations and FMS masters

Diagnostic overview

The diagnostic overview shows all the DP master’'s DP slaves with which data
interchange is taking place and from which diagnostic data is available (slave
diagnosis).

DP master

Master that complies with the EN 50170, Volume 2, PROFIBUS standard with the
DP protocol (DP is the German abbreviation for distributed I/O).

DP slave

Slave that complies with the EN 50170, Volume 2, PROFIBUS standard and is
addressed by means of the DP bus protocol (DP is the German abbreviation for
distributed 1/O).

FMS connection

An FMS connection contains the descriptions of the communication relationship
between one PROFIBUS node and another PROFIBUS node. A communication
relationship is uniquely described by a name, the type of the FMS connection (for
management or users), the PROFIBUS addresses, the assigned VFDs and a
communication reference (CR).

COM PROFIBUS
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FMS master

Master that complies with the EN 50170, Volume 2, PROFIBUS standard with the
FMS protocol (FMS = Fieldbus Message Specification).

FMS station

Master or slave that complies with the EN 50170, Volume 2, PROFIBUS standard
and is addressed by means of the FMS bus protocol (FMS = Fieldbus Message
Specification).

FREEZE
Control command of the DP master to a group of DP slaves.

After receiving the FREEZE control command, the DP slave freezes the current
status of the inputs and transfers them cyclically to the DP master. The DP slave
freezes the status of the inputs again after each FREEZE control command. The
input data is not transferred cyclically from the DP slave to the DP master again
until the DP master sends the UNFREEZE control command.

Group

Group of DP slaves of a master system to which the FREEZE and/or SYNC control
command can be applied.

Group association

Membership of a DP slave in a group. Groups allow you to apply the control
commands of the DP master to a specific selection of slaves of a master system.

Hardware catalog

The hardware catalog is a selection window in the COM PROFIBUS user interface
that contains all the PROFIBUS devices that can be configured with COM
PROFIBUS. Only those devices for which there is an error-free device master file in
COM PROFIBUS’s GSD directory (...\gsd or ...\fmsgsd) are displayed.
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Host
System that contains at least one master. In the case of the IM 308-C master
interface module, a programmable controller with the S5-CPU represents the host.
In some cases (e.g.CP 5412 (A2), S5-95U) the master itself is the host.
Note: The masters in a PROFIBUS-DP bus system can be distributed across a
maximum of 32 hosts.

LSAP

An LSAP (Link Sevice Access Point) is a layer-2 access point (address).

Master system

A master system comprises a master and the slaves or FMS stations assigned to it.
Multiple master systems can be run in a PROFIBUS bus system.

Memory card

Storage module on which the configuration of a master system is stored.

Modular DP slave

In the case of modular DP slaves, the structure of the input and output areas used
is variable and is not defined until the DP slave is configured (e.g. ET 200M).

Module catalog

The module catalog is a selection window in the COM PROFIBUS user interface
that contains all the PROFIBUS devices that can be configured with COM
PROFIBUS. Only those devices for which there is an error-free device master file in
COM PROFIBUS’s ...\gsd directory are displayed.

NCM file

File (with the extension .LDB) that contains all the parameters created with
COM PROFIBUS for a master system. This file is required as a binary database for
the SIMATIC NET PC modules.

Directory: ...\NCM

COM PROFIBUS
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Offline

Status of a programming device/PC that is not directly connected to a PROFIBUS
node for the purpose of data transmission on the PROFIBUS bus.

Online

Status of a programming device/PC that is directly connected to a PROFIBUS node
for the purpose of data transmission on the PROFIBUS bus.

Online help system

You can access all the information you need in the COM PROFIBUS online help
system. You call the help system by choosing the Help menu in COM PROFIBUS.

Parameter assignment

The selection of settings that specify the responses of modules.

Parameter assignment master

Each DP slave has a parameter assignment master (class 1). At start-up the
parameter assignment master transfers the parameters to the DP slave. The
parameter assignment master has read and write access to the DP slave.

Power-up delay

The power-up of the CPU is suspended until the power-up delay time has elapsed
or all the configured DP slaves can be addressed. If not all the configured DP
slaves can be addressed before this time elapses, the CPU starts up anyway.

If "No error reporting mode" is selected, the CPU starts up without a power-up delay
time.

The power-up delay time is in the range from 20 s to 1200 s.
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PROFIBUS

PROcess Fleld BUS, a European process and field bus standard defined in
EN 50170, Volume 2, PROFIBUS. It specifies the functional, electrical and
mechanical properties of a bit-serial field bus.

PROFIBUS is available with the protocols DP (which is the German abbreviation for
distributed 1/0), FMS (Fieldbus Message Specification) and PA (Process
Automation).

PROFIBUS address

Each bus node must have a PROFIBUS address so that it can be identified
uniquely. The default bus address "0" is reserved for programming devices/PCs in
the PROFIBUS bus system. Addresses from 1 to 125 are available for the other
bus nodes.

PROFIBUS card
Interface card for connecting programming devices/PCs to the PROFIBUS bus.

PROFIBUS-DP

Field bus that connects all DP masters and DP slaves. The PROFIBUS-DP field
bus is based on the EN 50170, Volume 2, PROFIBUS standard with the DP
protocol (DP is the German abbreviation for distributed 1/0O).

PROFIBUS-FMS

Field bus that connects all FMS masters and FMS stations. The PROFIBUS-FMS
field bus is based on the EN 50170, Volume 2, PROFIBUS standard with the FMS
protocol (FMS = Fieldbus Message Specification).

Program file

File (with the extension .PB5) in which you save the configurations of all the master
systems in a PROFIBUS bus system in COM PROFIBUS. You can transfer the
configuration of a single master system from the program file to the DP master, a
memory card, a binary file or a binary database (only in the case of SIMATIC NET
PC modules).

Directory: ...\DATA

COM PROFIBUS
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Response monitoring

Monitoring time for a DP slave. If a DP slave is not addressed within the response
monitoring time, it switches to the safe state (i.e. it sets its outputs to "0").

Response monitoring can be switched on and off individually for each DP slave
during configuration.

Shared input master

Every DP slave assigned to a parameter assignment master can be read accessed
by other DP masters. These DP masters are known as shared input masters.

Slave diagnosis

Slot

Diagnostic data of a DP slave, structured as defined in the EN 50170, Volume 2,
PROFIBUS standard.

The slot (consecutive number) identifies an input or output area of the DP slave.

Station type

SYNC

You select the station type of the slave or master to be configured after the order
number and name.

Control command of the DP master to a group of DP slaves.

The DP master uses the SYNC control command to cause the DP slave to freeze
the statuses of the outputs at the current value. For the following frames, the DP
slave saves the output data, but the statuses of the outputs remain unchanged.
After each new SYNC control command, the DP slave sets the outputs that it has
saved as output data.

The outputs are not cyclically updated again until the DP master sends the
UNSYNC control command.
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Target rotation time

This is the maximum time available for token rotation. The difference between this
and the actual token rotation time determines how much time the master still has to
send its data frames to the slaves.

Transmission rate

Speed at which data is transmitted; specified in number of bits transmitted per
second (bps).

Transmission rates of 9.6 kbps to 12 Mbps are possible with PROFIBUS-DP and
rates of 9.6 kbps to 1.5 Mbps with PROFIBUS-FMS.

VFD

A VFD (virtual field device) is a representation of a real field device. Its purpose is
to provide a uniform view of any device.
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