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Safety Guidelines 

This manual contains notices intended to ensure personal safety, as well as to protect the products and 

connected equipment against damage. These notices are highlighted by the symbols shown below and 

graded according to severity by the following texts: 

 

!  
Danger 
indicates that death, severe personal injury or substantial property damage will result if proper 
precautions are not taken. 

 

!  
Warning 
indicates that death, severe personal injury or substantial property damage can result if proper 
precautions are not taken. 

 

!  
Caution 
indicates that minor personal injury can result if proper precautions are not taken. 

 
 Caution 

indicates that property damage can result if proper precautions are not taken. 

 
 Notice 

draws your attention to particularly important information on the product, handling the product, or to a 
particular part of the documentation. 

Qualified Personnel 

Only qualified personnel should be allowed to install and work on this equipment. Qualified persons 

are defined as persons who are authorized to commission, to ground and to tag circuits, equipment, and 
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Correct Usage 

Note the following: 

 

!  
Warning 
This device and its components may only be used for the applications described in the catalog or the 

technical description, and only in connection with devices or components from other manufacturers 

which have been approved or recommended by Siemens. 

 
This product can only function correctly and safely if it is transported, stored, set up, and installed 
correctly, and operated and maintained as recommended. 

Trademarks 

SIMATIC®, SIMATIC HMI® and SIMATIC NET® are registered trademarks of SIEMENS AG.  

Third parties using for their own purposes any other names in this document which refer to trademarks 

might infringe upon the rights of the trademark owners. 
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Preface 

Purpose of the Manual 

This manual describes how batch processes can be automated using the BATCH  
program package from SIMATIC PCS 7. 

Required Basic Knowledge 
To understand this manual, you require general experience in the field of 
automation engineering and process control.  

You must also be familiar with working with PCs or similar devices (for example 
programming devices) and the Windows 2000 operating system.  

Before you install PCS 7 components you should always read the readme.wri file 
of the current version of PCS 7. 

Where is this Manual valid? 

This manual is valid for the BATCH software V6.0 SP4 and the PCS 7 Process 
Control System V6.0 SP3.  

The electronic manual is largely identical to the content of the online help. Due to 
technical reasons involving the production of electronic manuals, there may be 
slight differences between the manual and online help systems. In such cases, the 
information in the online helps is more recent and takes precedence over the 
information in the manual. 

Further Support 

If you have any technical questions, please get in touch with your Siemens 
representative or agent responsible. 

http://www.siemens.com/automation/partner 

Training Centers 
Siemens offers a number of training courses to familiarize you with the SIMATIC 
S7 automation system. Please contact your regional training center or our central 
training center in D 90327 Nuremberg, Germany for details:  

Telephone:  +49 (911) 895-3200.  

Internet: http://www.sitrain.com 

http://www.siemens.com/automation/partner
http://www.sitrain.com
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A&D Technical Support 

Worldwide, available 24 hours a day:  

 
 

Beijing 
Peking 

 Nuernberg 

Johnson City 

 

 

Worldwide (Nuernberg) 

Technical Support  

 

24 hours a day, 365 days a year 

Phone: +49 (180) 5050-222 

Fax: +49 (180) 5050-223 

mailto:adsupport@siemens.com 

GMT: +1:00 

  

Europe / Africa (Nuernberg) 

Authorization 

 

Local time: Mon.-Fri. 8:00 to 5:00 PM 

Phone: +49 (180) 5050-222 

Fax: +49 (180) 5050-223 

mailto:adsupport@siemens.com 

GMT: +1:00 

United States (Johnson City) 

Technical Support and 
Authorization 

Local time: Mon.-Fri. 8:00 to 5:00 PM 

Phone: +1 (423) 262 2522 

Fax: +1 (423) 262 2289 

mailto:simatic.hotline@sea.siemens.com 

GMT: -5:00 

Asia / Australia (Beijing) 

Technical Support and 
Authorization 

Local time: Mon.-Fri. 8:00 to 5:00 PM 

Phone: +86 10 64 75 75 75 

Fax: +86 10 64 74 74 74 

mailto:adsupport.asia@siemens.com 

GMT: +8:00 

The languages of the SIMATIC Hotlines and the authorization hotline are generally German and English. 

 

mailto:adsupport@siemens.com
mailto:adsupport@siemens.com
mailto:simatic.hotline@sea.siemens.com
mailto:adsupport.asia@siemens.com
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Service & Support on the Internet 

In addition to our documentation, we offer our Know-how online on the internet at: 

http://www.siemens.com/automation/service&support 

where you will find the following: 

• The newsletter, which constantly provides you with up-to-date information on 
your products. 

• The right documents via our Search function in Service & Support. 

• A forum, where users and experts from all over the world exchange their 
experiences. 

• Your local representative for Automation & Drives. 

• Information on field service, repairs, spare parts and more under "Services". 

http://www.siemens.com/automation/service&support
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1 Product Introduction and Installation 

1.1 SIMATIC BATCH 

1.1.1 What is SIMATIC BATCH? 

What is SIMATIC BATCH? 

SIMATIC BATCH is a SIMATIC PCS 7 program package with which discontinuous 
processes, known as batch processes, can be configured, planned, controlled and 
logged. 

Simple batch processes with configurable sequential control systems are 
automated with the CFC and SFC tools included in the PCS 7 Engineering System.  
SIMATIC BATCH is used for high requirements with recipe control strategy. With 
SIMATIC BATCH, recipe structures are designed, modified, and started graphically 
on an operator station or on a separate PC. 

All process and operator data can be collected for a specific batch while it is being 
made and can then be processed and printed out in a batch log. 

Possible Applications of SIMATIC BATCH 

SIMATIC BATCH is suitable for batch processes of any complexity. It provides 
simple support for batch applications ranging from small to extremely large. 

The main features of SIMATIC BATCH are as follows: 

• Simple, graphic recipe creation 

• Control and monitoring of recipe execution in the same graphic representation 
as used in recipe creation 

• Control strategy with data from multiple programmable logic controllers 

• Integrated permission management with detailed access permissions 

• End-to-end logging of all events (including manual intervention) for 
comprehensive production documentation 

• Simple and clear batch planning, when required with interfacing to higher level 
PPS systems 

• Modular expandability 

• Application of NAMUR and ISA SP88 standards 
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1.1.2 Functions of SIMATIC BATCH 

SIMATIC BATCH supports you throughout all the stages involved in the 
automation of batch processes. The functions provided by SIMATIC BATCH can 
be divided into four basic areas: 

• Recipe system: 
Creation and management of any number of master recipes and library 
operations 

• Batch planning: 
Planning and replanning of batches and production orders 

• Batch control: 
Execution, visualization, and control of batches released for production and the 
corresponding control recipes as well as visualization of the current unit 
allocation 

• Batch data management: 
Acquisition, storage and logging of batch data 

1.1.3 Migration from Older Projects 

Migration 

Projects created with BATCH flexible V4.02 can be converted to SIMATIC BATCH 
V6.0. A migration tool is provided to help you migrate your existing SIMATIC 
BATCH applications to the new version. 

 

 Note: 

BATCH flexible V4.02 projects can be migrated so that they can continue to be 
used in SIMATIC BATCH V6.0 with all the functionality of the V4.02 version. 

 

BATCH flexible V4.02 and V6.0 use different interface blocks in the programmable 
controller for controlling the batch process. Migration can be performed in such a  
way that after migrating to V6.0, 

• you will not  have to interconnect the interface blocks again 

• · modify the content of the programmable controller 
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Migrated Data 

The migration tools enable you to move the following data from BATCH flexible 
V4.02 to V6.0: 

• Process cell data (including units of measure, user data types, and materials) 

• Unit recipes (now known as master recipes in V6.0:) 

The following data are not moved from the BATCH flexible V4.02 database to V6.0 
during a migration: 

• Production order data 

• Batch data (including control recipes) 

• Users/user permissions 

Further Information 

You will find information on migrating from V4.02 to V6.0 in the section "Migration 
V4.02 -> V6.0". This section describes the following in detail: 

• Migration requirements 

• Overview of the basic migration procedure 

• Migration step-by-step 

1.1.4 Components of SIMATIC BATCH 

SIMATIC BATCH consists of the following components: 

• Batch Control Center (BatchCC)  

• BATCH Recipe Editor  

• BATCH Report  

• BATCH Control Server  

• BATCH Interface Blocks  
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1.1.4.1 Batch Control Center (BatchCC) 

Definition 

The Batch Control Center (BatchCC) is the central component in SIMATIC BATCH 
for batch planning and batch control. BatchCC manages all the data relevant to 
SIMATIC BATCH. This means that all batch data is logged in BatchCC. 

The Batch Control Center is started on the run-time computers according to the 
settings made in the Batch Launch Coordinator. 
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Functions 

With the Batch Control Center (BatchCC), you can do the following: 

• Read in the process cell data from the basic control. 

• Specify the user permissions for all functions of BATCH. 

• Define the names and codes of the materials used. 

• Manage master recipes and start the BATCH Recipe Editor to configure the 
recipe structure. 

• Manage libraries with recipe elements (library operations). 

• Edit and manage the formula categories and corresponding formulas. 

• Plan production orders using master recipes and batches. 

• Start and control batch executions. 

• Monitor and troubleshoot batch executions. 

• Log recipes and batch data 
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1.1.4.2 BATCH Recipe Editor 

Definition 

The BATCH Recipe Editor is part of SIMATIC BATCH and provides you with a 
graphic user interface for creating and modifying master recipes and library 
operations. Recipe creation is based on the BATCH objects from the Batch 
process cell configuration in the engineering system of SIMATIC PCS 7, for 
example, units and equipment phases. 
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Functions 

With the BATCH Recipe Editor, you can do the following: 

• Create new master recipes and library operations. 

• Modify existing master recipes and library operations (structural or parameter 
modifications). 

• Log the master recipes and library operations. 

• Release master recipes and library operations for testing or for production. 

• Validate recipes. 

When working in the editor, the familiar functions known from MS Windows 
programs such as paste, cut, copy, undo and redo can be used on single or 
grouped objects. 
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1.1.4.3 BATCH Report 

Definition 

BATCH Report allows documentation of recipes and batch data in the form of logs. 

• The "off-the-shelf" recipe report contains all the data required for production. 
This includes the recipe header data, the input material and output material list 
and the procedural rules.  

• The batch report contains all the information required for the reproducibility of 
the batch process, the quality assurance and the fulfillment of legal 
requirements. These include the identification data, control recipe data, 
effective production data, chronological sequence of the steps, error and 
disturbance messages as well as operator intervention.  

BATCH Report is fully integrated in the user interface of BatchCC. The recipe 
reports and batch reports are created in BatchCC and can be displayed and 
printed out in BatchCC at any time. 

To be able to view recipe reports and batch reports on other computers, for 
example, at a later time, the Viewer of BATCH Report is available as a separate 
setup. 

Functions 

Within an open report (recipe or batch report) you can browse through the 
individual elements using a hierarchical table of contents: 

• Recipe/batch 

• Recipe unit procedure 

• Recipe operation 

• Recipe phase 

• Transition 
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1.1.4.4 BATCH Control Server 

Definition 

The BATCH Control server is a component of SIMATIC BATCH. The BATCH 
Control server handles communication with the process and controls and monitors 
execution of the current batches.  

The BATCH Control Server does not have its own user interface. The BATCH 
Control Server is started on the run-time computer. 

Functions 

Once a batch has been released and started, the BATCH Control server takes over 
monitoring of its execution. The batch data (online data) of SIMATIC BATCH are 
stored temporarily in the online data management of SIMATIC BATCH.  

To acquire batch data (messages), there is a connection to the message server 
and to the process data acquisition of the PCS 7 OS (WinCC). 
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1.1.4.5 BATCH Interface Blocks 

Introduction 

SIMATIC BATCH V6.0 can use the new functionality of the SFC types in the 
engineering system to define operation and phase types. As an alternative, 
SIMATIC BATCH V6.0 continues to provide special interface blocks as the 
communications interface to the processing programs on the programmable 
controller. These so-called BATCH interface blocks are supplied with a block library 
with SIMATIC BATCH (see also section "Using BATCH Interface Blocks"). 

Definition 

The BATCH interface blocks form the communications interface between SIMATIC 
BATCH and the processing programs of the process cell control system in the 
programmable controller. The BATCH interface blocks are implemented as CFC 
blocks and are inserted in the CFC charts according to their function and stored in 
the corresponding hierarchy folders in the plant view in the SIMATIC Manager. 

Functions 

Using the BATCH interface blocks along with SIMATIC BATCH  makes the 
following functions possible: 

• Controlling the Procedure: 
The IEPH/IEOP blocks are for this purpose. These provide the commands (for 
example start or hold) of the control recipe steps from the batch control to the 
processing blocks (for example: SFC_CTL or user blocks). The processing 
blocks report their current statuses back to the batch control. 

• Assigning and releasing a unit via a running control recipe: 
The IUNIT_BLOCK blocks are for this purpose. 

• Summing up actual values for the creation of transition conditions and for 
logging measured values in the batch log: 
The TAG_COLL blocks are for this purpose. 

• Transferring setpoint and actual values: 
The IEPAR blocks are for this purpose. The batch control writes the recipe 
parameters (setpoints) for the processing blocks into these blocks via the 
IEPH/IEOP blocks. The processing blocks write the result data (actual values) 
into the IEPAR blocks so that they can be stored as batch data by the batch 
control once again using the IEPH/IEOP blocks. 
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1.2 Configuration Options with SIMATIC BATCH 

1.2.1 Client/Server Architecture of SIMATIC BATCH 

Client/Server Architecture 

SIMATIC BATCH  is usually distributed on several BATCH clients and a BATCH 
server all working with the same process cell project. The BATCH Server provides 
the services for the BATCH clients that form the interface to the operator (the HMI) 
in other words function as operator control terminals. 

Interaction with PCS 7 OS  

SIMATIC BATCH is linked to the PCS 7 OS at run time.  

• Communication with the programmable controller (for example writing recipe 
parameters or reading process values) is handled by the data manager of the 
PCS 7 OS. In other words, SIMATIC BATCH does not have its own interface to 
the programmable controller. 

• The BATCH Server and the OS server of the PCS 7 operator stations generally 
run on separate computers. In the batch process cell configuration, the PCS 7 
operator stations that are relevant for the batches are made known to the 
BATCH Server. 

• BATCH Clients can run on a PC as well as together with  OS Clients on a 
computer. 
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Sample Configuration 

 
 

PCS 7 OS: OS client 1 
BATCH client 2 BATCH client 1 SIMATIC BATCH: 

BATCH Server 
(BATCH Control Server, 
data storage systems) 

 

Terminal bus 

Engineering 
station 

SIMATIC S7-400 

Process bus 

PCS 7 OS: 
OS server 1 

PCS 7 OS: 
OS server 2 

SIMATIC S7-400 

 

Large PCS 7 projects with distributed PCS 7 operator stations 

SIMATIC BATCH supports the model of distributed operator stations in large PCS 
7 projects. This means that with suitable configuration in the engineering system, 
SIMATIC BATCH can access all operator stations and therefore all programmable 
controllers in the PCS 7 project. 

Solution with One PCS 7 OS (No Distributed PCS 7 Operator Stations) 

The configuration described so far, applies to the concept of distributed PCS 7 
OSes. If one PCS 7 OS is used in a small configuration, this PCS 7 OS and the 
BATCH Server will be on the same computer. This computer then also has an 
interface to the SIMATIC S7-400. 

Configuring in the Engineering System 

BATCH Servers and BATCH clients are configured just like the OS servers and OS 
of the PCS 7 operator stations in the SIMATIC Manager of the Engineering Station 
and downloaded from there. 

Maximum Number of BATCH Clients 

A maximum of 32 BATCH clients can be connected to one BATCH server. 
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1.2.2 Distribution of the BATCH Applications 

SIMATIC BATCH provides a wide range of options for distributing BATCH 
applications on various computers: 

 

Variant Label Possible Configurations 

1 Standalone level 1 BATCH Control Server, all data storage,  
BATCH Client Application on one computer - 
together with a PCS 7 OS server and OS client. 

2 Standalone level 2 BATCH Control Server, all data storage,  
BATCH Client Application on one computer - 
separated from a PCS 7 OS server and OS client. 

3 Distributed system level 1 BATCH Control Server and all data storage on one 
computer, BATCH Client Application on the 
corresponding separated computer –  
separated from PCS 7 OS server and OS client 

Data Storage Systems 

SIMATIC BATCH operates with the following three databases: 

• Project DB: Data storage for user permissions 

• Offline DB: Data storage for recipes, formulas, materials 

• Online DB: Data storage for batches 

BATCH Server 

The BATCH Control Server and the Batch data management are always located 
on the BATCH Server. 

BATCH Clients 

The following BATCH client applications can be distributed on the BATCH clients 
as options: 

• Batch Control Center (BatchCC) 

• BATCH Recipe Editor 

• API Interface 

Further references 

You will find a detailed description of the possible distribution and installation of 
batch applications in the manual Process Control System PCS 7; PC Configuration 
and Authorization. 
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1.2.3 Interface to MES/ERP 

With the API interface optional package for SIMATIC BATCH, you can interface 
online and offline functions of SIMATIC BATCH directly to an OEM system or any 
MES/ERP application. The API interface provides both a C interface (CSV data 
format) as well as a COM interface (XML data format). 

Please check the readme and the online help on the optional software API 
interface for information on its usage and configuration options. 
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1.3 Installation 

1.3.1 The SIMATIC BATCH Product 

Introduction 

SIMATIC BATCH is available as a basic package with a series of optional 
packages for step-by-step expansion and optimization. 

Basic Package 

The basic package supports you throughout all the stages involved in the 
automation of batch processes. The basic package provides you with the following 
components:  

Basic Package

BATCH client applications

BATCH Recipe Editor
(flat recipes)

BATCH Control Center
(BatchCC)

BATCH Report

BATCH Control Server
batch data management

BATCH server applications

IEPH, IEOP, TAG_COLL,
IUNIT_BLOCK, IEPAR...

BATCH interface blocks

BATCH Engineering

• ES basic functionality up to 150 process objects

The engineering software of the basic package can be expanded in
three expansion stages to suit the the plant size:
• ES functionality up to 600 process objects
• ES functionality up to 1800 process objects
• ES functionality > 1800 process objects

 

 

 Note: 

BATCH Engineering: The number of process objects (PO) is the sum of the 
BATCH interface blocks (IEOP, IEPH, IUNIT_BLOCK).  

The number of Process objects are countable in the Engineering System (see 
Section "Counting Process Objects (PO)"). 
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Optional packages 

The following optional packages can also be installed in addition to the basic 
package: 

Optional Packages

Batch Planning

ROP Library
(library operations)

Hierarchical Recipes

Separation of
Procedure and Formula

API Interface

 

 

Component Application 

Batch Planning Allows configuration of batches in BatchCC 

Hierarchical Recipes Allows the creation of hierarchical recipes according to S88.01 
with RP, RUP, ROP and RPH 

ROP Library (library 
operations) 

Allows the creation and management of library operations 

Separation of 
Procedure/Formula 

Allows you to work with formulas and formula categories.  
n formulas can be created for a procedure. 

API Interface Powerful functions for online and offline operation, for example 
interfacing to MES 
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1.3.2 Requirements for Installation 

Hardware Requirements 

To be able to work with SIMATIC BATCH V6.0, the same hardware requirements 
must be met as for PCS7 V6.0.  

SIMATIC BATCH V6.0 also requires: 

• Approximately 260 Mbytes of free space on your hard disk to install files. 
Additional space is also required for projects and the database.  

• A printer for recipe reports. All printers with graphics capability supported by 
Windows 2000 are suitable.  

• The software was tested with the HP-Laser Jet. 

Software Requirements 

SIMATIC BATCH is a 32-bit application that requires MS Windows 2000 as 
operating system.  

To use SIMATIC BATCH V6.0 components, the following software requirements 
must be met: 

 

Component Property 

PC Operating System Microsoft Windows  2000 

Internet Explorer Microsoft Internet Explorer V6.0 (for displaying recipe reports) 

TCP/IP configured See Windows system settings 

Readme File 

 

 Note: 

Make sure that you read the latest information on SIMATIC BATCH in the PCS 7 
BATCH Base - readme.wri on the software CD. 
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1.3.3 Required Authorization 

Authorization 

To use the SIMATIC BATCH software, you require an authorization (right to use 
the software). This means that the software protected in this way can only be used 
properly when the authorization required for this software package is detected on 
the hard disk of the relevant PG/PC. Otherwise an irritating box keeps popping up. 

Different authorizations are required for the basic package, the three expansion 
stages of the basic package and the optional packages. 

Installing and Uninstalling the Authorization 

To install the authorization, you require the copy-protected authorization diskette 
supplied with the particular software package. The number of possible 
authorizations depends on an authorization counter on the authorization diskette. 
When you install an authorization, the counter is decremented by 1. Once the 
counter reaches the value 0, there are no more authorizations on the diskette.  

The authorizations for SIMATIC BATCH are installed and uninstalled in exactly the 
same way as for PCS 7 and the PCS 7 optional packages. You will find detailed 
information on installing and handling an authorization, for example in the basic 
help of the SIMATIC Manager. 

Readme File 

 

 Note: 

Make sure that you read the latest information on SIMATIC BATCH in the PCS 7 
BATCH Base - readme.wri on the software CD. 

 

Overview of the Required Authorizations 

You will find an overview of the authorizations required for the individual batch 
applications in the manual Process Control System PCS 7; PC Configuration and 
Authorization. 
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1.3.4 Installing the Components of SIMATIC BATCH 

Installation 

You can start the installation program of SIMATIC BATCH  within the general setup 
of PCS 7. On-screen prompts guide you step by step through the entire installation. 
The general setup of PCS 7 is started with the normal procedure under Windows  
2000 for installing software. 

 

 Note: 

Make sure that you read the information on installing SIMATIC BATCH in the PCS 
7 BATCH Base - readme.wri file. The readme file is on the same CD-ROM as 
SIMATIC BATCH. 

Options for Installing the Components 

When you install the components with the installation program of SIMATIC BATCH 
, you can decide whether you want a single-workplace installation with all 
components or whether you require a distributed installation on several BATCH 
client/server computers. If you require a distributed installation, start the installation 
program on each client/server computer.  

When you start to install the basic package, the following applications are offered 
for installation. You can select the applications you want to install. 

• SBBase (basic software, API; does not need to be selected and is installed 
automatically) 

• SBBUILDER (BATCH Engineering) 

• SBClient (Batch Control Center (BatchCC), BATCH Recipe Editor, BATCH 
Report) 

• SBServer (BATCH Control Server, Batch data management)  

• SBBLOCK (BATCH interface blocks) 

• SBWINCCOPTION (faceplates) 

• SBFastobjects (for database server) 

• Cluster Setup (for redundancy with Microsoft Cluster) 
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SBBUILDER (BATCH Engineering) 

 

 Note: 

• BATCH Engineering is only installed when PCS 7 (SIMATIC Manager) is 
already installed on the ES computer. 

• It is possible to install only BATCH Engineering on an ES computer (without 
client or server functionality). This installation is perfectly adequate for 
configuring batch objects and their distribution. When required, the BATCH 
interface blocks must be installed separately. 

Uninstalling 

 

 Note: 

If you uninstall SIMATIC BATCH, you must always do this before uninstalling the 
plant hierarchy (SIMATIC PH). 

Installation in a Redundant System 

 

 Note: 

Some special features are to be taken note of in a redundant PCS 7 System. For a 
detailed description of the installation, refer to the section "Redundancy". 
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BATCH Report 

On the one hand, BATCH Report is fully integrated in the user interface of 
BatchCC. The recipe reports and batch reports are created in BatchCC in XML 
format and can be displayed and printed out in BatchCC at any time. 

On the other hand, the Viewer of BATCH Report is available as a separate Setup 
SBReport on the Toolset CD. This allows you to view recipe reports and batch 
reports on other computers, for example, at a later time, without needing a 
BatchCC installation on the computer. You can copy and run the Setup SBReport 
on any Win2000 computer. 

After installation along with the basic package, start the Viewer as follows: 

Start > Simatic > SIMATIC BATCH > BATCH Report 

1.3.5 Readme File with the Latest Information 

Readme File 

 

 Note: 

Make sure that you read the latest information on SIMATIC BATCH in the PCS 7 
BATCH Base - readme.wri on the software CD. 

 

The readme file is opened as follows: 

• Double-click on PCS 7 BATCH Base - readme.wri on the CD-ROM or 

• from the Start menu of Windows: 
Start > Simatic > Note > PCS 7 BATCH Base - Readme.wir 
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2 Technological Basics According to 
ISA S88.01 

2.1 Which Standards is SIMATIC BATCH Based On? 

Standards 

SIMATIC BATCH was developed based on the ANSI/ISA S88.01 (1995) Batch 
Control, Part 1: Models and Terminology standard. 

Use of SFC 

In the "Technical Report" ISA-TR88.0.03-1996, the use of  SFC (Sequential 
Function Charts, DIN/IEC 1131) as a graphic language for describing recipe 
procedures is also recommended. The creation of recipes with the BATCH Recipe 
Editor follows the structures and functionalities described in this standard. 

2.2 Introduction to Technical Terminology  

The following definitions are mainly excerpts from the ANSI/ISA S88.01 (1995) 
standard Batch Control, Part 1. 

Batch process 

A process that leads to the production of finite quantities of material by subjecting 
quantities of input materials to an ordered set of processing activities over a finite 
period of time using one or more pieces of equipment.  

The product manufactured in a batch process is known as a batch. Batch 
processes are discontinuous processes. 
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Typical Equipment Phases of a Batch Process 

 

Time 

Clean Cool 
Empty React Heat 

Dose 

+ 

Temperature 

 

Batch 

• Material that is being produced or that has been produced by a single 
execution of a batch process. 

• An entity that represents the production of a material at any point in the 
process. 

Note: Batch means both the material created by and during the process as well as 
the unit that represents the manufacturing procedure for this material. Batch is 
used as an abstract contraction of the words "the production of a batch". 

Recipe 

The necessary set of information that uniquely defines the production requirements 
for a specific product. A recipe is the set of rules and information required to define 
how a product is manufactured. 

Two types of recipe are used in SIMATIC BATCH. 

• Master Recipe 

• Control recipe 
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contains

contains

Master Recipe

Control Recipe
Batch ID,quantity, process,

system or operator
information

Process cell-specific
information

is the
basis for

 

Master Recipe 

A type of recipe that accounts for equipment capabilities and may include process 
cell-specific information. A master recipe is an indispensable recipe level without 
which control recipes cannot be created or batches produced. 

Master recipes can contain material and production parameters as standardized, 
calculated, or fixed values. 

A master recipe can be derived from a general or site recipe from the enterprise 
level (refer to the standard IEC 61512-1: 1997). 

Control Recipe 

A type of recipe which, through its execution, defines the manufacture of a single 
batch of a specific product. 

The control recipe is a copy of a particular version of the master recipe that is then 
modified as necessary with information for planning and execution making it 
specific to a single batch. 

A control recipe can also be modified during the production of a batch. Examples: 

• Definition of  the equipment actually used in the control recipe at the start of 
the batch or at the time it becomes known. 

• Addition or modification of parameters on the basis of "As Dosed" qualities of 
raw materials or analyses during production of the batch. 

• Modification of the procedure due to an exceptional event. 

Control strategy 

Different and (in terms of the same run) mutually exclusive equipment phases of 
the same equipment module = control strategy of this equipment module. 

Process 

A sequence of chemical, physical, or biological activities for the conversion, 
transport, or storage of material or energy. 
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2.3 Basic Structure of a Recipe 

Components of a Recipe 

Recipes contain the following four categories of recipe information: 

Recipe Header

• recipe and product identification
• version number
• author and date created
• releases
• status

Material and Production Data (Formula)

• process inputs: resources for creating
product

• process outputs:expected results
• process parameters: global recipe

parameters

Unit Requirements

• requirements of the equipment for
manufacturing the product

Recipe Procedure

• describes the strategy (the procedure)
• is the description of the recipe

execution using the procedure
elements (SFC)
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2.4 Material and Production Data (Formula) 

Material and production data (formula) for recipe creation is comprised of: 

• Process Inputs 

• Process outputs 

• Process parameters 

Process Inputs 

Process inputs are the input materials (resources) required to make the product. 
Each input material has the following characteristics: 

• Name of parameter 

• Name of the input material 

• Lower limit value for the quantity 

• Set point for the quantity 

• Upper limit value for the quantity 

• Unit of measure 

• Name of the scaling algorithm 

Process Outputs 

The process outputs are the output materials (main, interim, by, and waste 
products) resulting from the manufacture of a product. Each output material has 
the following properties: 

• Name of parameter 

• Name of the product 

• Name of the output material 

• Lower limit value for the quantity 

• Set point for the quantity 

• Upper limit value for the quantity 

• Unit of measure 

• Name of the scaling algorithm 

Process Parameters 

Process parameters are physical parameters such as speed, pressure, 
temperature. 

Process parameters can also be logic parameters and character chains:  
For example, release number of loop of type integer or material information HCL of 
type string or bolean values e.g., releases. 
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2.5 Basic Structure of a Recipe Procedure 

Recipe procedure and its elements according to the standard: 

Can be an ordered set of

Recicpe
procedure

(RP)

Recipe unit
procedure

(RUP)

Recipe
operation

(ROP)

Recipe
phase
(RPH)

Can be an ordered set of

Can be an ordered set of
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2.6 Relationship between Recipe Procedure, Formula and 
Master Recipe 

How the Master Recipe is Formed 

By assigning formulas to a recipe procedure, different master recipes can be 
created for a process cell or a grouping of equipment belonging to a process cell. 
The schematic below illustrates this relationship. 

Formula #1

Quantity 500 kg
Temperature 70 °C
Flow 100 l/min
Duration 320 sec
Speed 120 rpm

Formula #2

Quantity 125 kg
Temperature 110 °C
Flow 80 l/min
Duration 200 sec
Speed 150 rpm

Recipe Procedure Formula

Master recipe #1

Master recipe #2

Master Recipe+

+

+

=

=

=

Procedure
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2.7 What is a Formula Category? 

Definition 

A formula category is a grouping of recipe formulas associated with a single master 
procedure each having the same attributes. The only differences between the 
formulas in a formula category are the concrete parameter values. 

The formula category is a therefore a "template" / a "type" for different material and 
production data records. 

The formula category contains the parameters that can be manipulated by the 
operator during batch planning. These parameters are included in the formula 
category with their data type and unit of measure.  

 

 Note: 

Formula categories can be defined independently of the recipe. 

Purpose 

Working with formula categories makes it much easier to maintain master recipes 
based on the same recipe procedures. Modifications only need to be made at one 
point (of a recipe procedure) and not in "n" recipe procedures!  

ISA S88.01 does not mention the formula category. The formula category does not, 
however, contradict the formula definition in ISA S88.01, but rather expands it (see 
also "Models of the ANSI/ISA S88.01 Standard"). 
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2.8 Internal and External Formulas 

To support you better when using formulas and formula categories, BATCH makes 
a distinction between internal and external formulas. 

Internal Formula 

If you want to keep your material and production data directly in the master recipe 
procedure, you can do this in the "internal" formula in the master recipe. The 
parameters can be set there during the creation of the master recipe procedure 
and modified during batch planning and/or also while a batch is executing. 

External Formula 

If you want to manage several material and production data lists separate from the 
master recipe procedure, you can do this using "external" formulas belonging to a 
formula category. You simply need to assign a master recipe procedure to the 
external formula to establish the association with the master recipe procedure. The 
parameters of external formulas can also be modified during batch planning and/or 
while a batch is executing. 
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2.9 Models of the ANSI/ISA S88.01 Standard 

2.9.1 Overview of the Models of the ISA S88.01 Standard 

Introduction 

The following sections describe the models of the ISA S88.01 standard that relate 
directly to the use of SIMATIC BATCH. You will find information on other topics in 
the standard itself. 

ISA S88.01 Models 

The following models of the ANSI/ISA S88.01 standard provide the foundation for 
batch-oriented control strategies with SIMATIC BATCH. 

• Procedural Control Model  

• Physical Model  

• Process Model  

Hierarchical Structure of the Models 

The figure below illustrates the hierarchical structure and relationship of the models 
– from the sequential control on the equipment as far as the processing 
functionality.  

 Procedural 
Control Model 

PPrroocceedduurraall    
EElleemmeennttss  

Procedure (s) 

Unit Procedure 
(s) 

Operation (s) 

Phase (s) 

Phase (s) 

combined 
with a 

combined 
with a 

combined  
with a 

combined 
with a 

combined 
with a 

Physical Model 

Process cell 

Unit 

Unit 

Unit 

EEqquuiippmmeenntt  

Equipment 
module 

Process 

Process stage 

Process 
operation 

Process 
action 

RReessuullttiinngg  PPrroocceessss  
FFuunnccttiioonnaalliittyy  

Process Model 

provides process 
functionality to  
carry out a 

provides process 
functionality to 
carry out a 

provides process 
functionality to 
carry out a 

provides process 
functionality to 
carry out a  

provides process 
functionality to  
carry out a  
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Implementation of the Models 

The hierarchical structure of the models is the basis for the configuration of the 
batch-oriented control strategies with PCS 7: 

• The plant hierarchy of your process cell is structured in the SIMATIC Manager 
(plant view) based on the S88.01 physical model. 

see section: Structure of the Plant Hierarchy  

• You structure the recipes for batch control with the BATCH Recipe Editor 
based on the S88.01 procedural control model. 

see sections: Structure of the Hierarchial Recipe  
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2.9.2 Procedural Control Model 

Procedural Control Model with Example – How Do We Want to Produce? 

Process

Unit
process

Operation

Phase

Produce PVC

Polymerize vinylchloride monomer
Recover residual vinylchloride
Dry PVC

Preparation: Evacuate reactor and coat reactor
walls with build-up suppressants

Fill: Distilled water and solvent
Reaction: Add VCM and catalyst,

heat and wait for pressure to drop

Add vinylchloride monomer
Add catalyst
Heat

is an ordered set of

is an ordered set of

is an ordered set of

 

Function 

A phase is the smallest element of procedural control that can accomplish a 
process-oriented task. The purpose of a phase is to define or cause a process-
oriented action. 

Characteristics of a phase: 

• Can be subdivided into smaller parts in the form of steps and transitions (as 
described in IEC 848: 1988) 

• A step can cause one or more actions 

• The execution of a phase can result in the following 

- Commands to basic control 

- Commands to other phases (either in the same or another equipment 
entity) 

- The collection of data 
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2.9.3 Physical Model 

Physical Model with Example – What Do We Use to Produce? 

Process cell

Unit

Equipment
module

Control
module

can include

can
include

can include

must include

Multipurpose
plant

Reaction plant

can
include  

Process cell 

A process cell contains all the equipment required to make a batch. Process cells 
are often divided into trains. A train is made up of all units and other equipment that 
can be used by a particular batch. Trains can be left unchanged from batch to 
batch or can be defined differently for each batch. 

Unit 

A unit is made up of equipment modules and control modules. A unit is an 
independent grouping of equipment usually centered around a major piece of 
processing equipment, such as a mixing tank or reactor.  

Characteristics of a unit: 

• A unit can execute one or more major processing activities, such as react, 
crystallize, and make a solution. 

• Units operate relatively independently of each other. 

• A unit often contains a complete batch of material at some point in the 
processing sequence of the batch.  

• A unit cannot process more than one batch at the same time. 
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Equipment Module 

An equipment module can be made up of control modules and subordinate 
equipment modules. An equipment module is usually centered on a piece of 
processing equipment, such as a filter. 

Characteristics of an equipment module: 

• Can be part of a unit or stand-alone grouping of equipment within a process 
cell 

• Can carry out a finite number of specific minor processing activities, such as 
dosing or weighing 

• Can, but does not need to contain the raw materials for a batch 

Control Module 

A control module is usually a collection of sensors, actuators, other control 
modules and associated processing equipment that can be operated as a single 
entity from the point of view of control engineering. 

A control module can also be made up of other control modules. As an example, a 
dosing control module could be defined as the combination of several automatic 
switching valve control modules. 

There is no figure for the individual control modules in the procedural model and 
the process model (see also figure in section "Overview of the Models of the ISA 
S88.01 Standard"). Therefore, it cannot be addressed in SIMATIC BATCH either. 
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2.9.4 Process Model 

Process Model with Example – What Do We Want to Produce? 
 

is an ordered set of

Production of polyvinylchloride by polymerization
of vinylchloride monomers

- Polymerization: Vinylchloride monomer is
polymerized to polyvinylchloride

- Recovery: Vinylchloride monomer
- Drying: Polyvinylchloride powder

- Preparation: Evacuate reactor
- Fill: Add distilled water and reagents
- Reaction: Add vinylchloride monomer + catalyst, 

heat to 120 °C and hold temperature 
until pressure drops

- Add : Amount of catalyst
- Add : Amount of vinylchloride monomer
- Heat : Heat reactor to 120 °C
- Hold temp.: Hold temperature until pressure drops

Process

Process
stage

Process
operation

Process
step

is an ordered set of

is an ordered set of
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3 Getting Started 

3.1 Getting Started 

Requirement 

The components of the basic package of SIMATIC BATCH are installed on the 
PG/PCs of the BATCH OS (BATCH Server, BATCH clients) and those of the 
engineering system. 

Basic Procedure  

If you are working with SIMATIC BATCH for the first time, you will find the following 
list of the most important steps a useful overview. 

 

Engineering  1. Configuring a Process Cell in the Engineering System (ES)  

2. Compiling Process Cell Data in Single-Project Engineering  

3. Downloading Process Cell Data to the Target System  

4. Reading Process Cell Data into BATCH 

Permissions 
management  

5. Specifying User Permissions  

Recipe Creation  
(Offline)  

6. Editing Materials  

7. Creating and Editing Master Recipes  

8. Creating and Editing Library Operations  

9. Validating Recipes  

10. Releasing Recipes for Production  

11. Creating a New Formula Category (with external formula only)  

12. Creating Formulas (with external formula only)  

13. Interconnecting Parameters between the Master Recipe and Formula 

Run time  14. Creating Production Orders  

15. Creating and Editing Batches  

16. Releasing Batches  

17. Starting Production of a Batch  

18. Controlling Production of a Batch  

19. Logging Batches  

20. Archiving Batches  
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Engineering 

Configuration of the batch process cell takes place along with the basic 
engineering of the S7-400 on the Engineering Station (ES) of SIMATIC PCS 7 in 
the SIMATIC Manager (for example phase and operation types, unit classes, user 
data types, units of measure etc.).  

The batch process cell data are compiled on the Engineering Station and are 
transferred to the database (project directory) of SIMATIC BATCH using the 
"Download target system" function. 

Using the "Read in process cell" or "Update process cell" function in BatchCC, the 
process cell data of BatchCC are read in to the BATCH clients. 

Permission Management 

SIMATIC BATCH  uses the central user management of PCS 7.  

You define user roles for SIMATIC BATCH (for example operator) and their 
assignment to the defined Windows user groups using the SIMATIC Logon 
software. Within SIMATIC BATCH (BatchCC), you can restrict the user 
permissions of a user role even further -  for a specific computer and for a specific 
unit: 

Recipe Creation (Offline) 

Reading in the Batch process cell data (Batch engineering data) on any BATCH 
client with BatchCC allows the creation of offline data. You create the materials, 
formula categories, and formulas with BatchCC. You create libraries and master 
recipes with the Recipe Editor. Releasing master recipes, library elements and 
formulas allows their use in the run-time mode. 

Runtime 

The first run-time function is batch planning. Here, a production order is created 
first. This is divided into individual batch orders (at least one) that are then released 
and started. The actual Batch processing programs (equipment phases) run on the 
programmable controller and are coordinated by the batch control (BATCH Control 
Server). Communication with the equipment phases is implemented by the WinCC 
data manager. 

The batch data management also makes use of individual WinCC components. 
From the measured value archive, the values for the required measured value 
sequences are obtained for the batch report and all batch-relevant messages are 
filtered out of the message archive. 

A further important run-time function is the operator control and monitoring of a 
batch or the control recipe. This takes place partly in SIMATIC BATCH itself and 
partly using Batch faceplates in WinCC. 



 

SIMATIC BATCH 
A5E00272803-01 4-1 

4 Configuration in the ES 

4.1 Introduction 

Engineering Basic Control 

A batch process is automated using the programs on the programmable logic 
controller (PLC). This so-called "basic control" is created with CFC and/or SFC for 
the specific PLC. The software charts to be created are managed in the plant 
hierarchy in the SIMATIC Manager. For SIMATIC BATCH fixed hierarchy levels  
must be kept to.  

Interface to the Processing Programs 

The interface between SIMATIC BATCH and the actual processing on the 
programmable controller is implemented as follows:  

• either using the SFC types that can be created with the SFC standard tools as 
of PCS 7 V6.0 (refer to the section "Using SFC Types")  

• or using the BATCH interface blocks (see section "Application of the BATCH 
Interface Blocks") 

In the Engineering System (ES), the equipment phases (for example dosing, 
agitating, heating) are interconnected and their parameter values set with the PLC 
structuring tools (CFC). 

 

 Note: 

Mixed use of both variants (SFC types, BATCH interface blocks) within a project is 
possible. 

 

Editing the Type Description of the Process Cell 

The data required by SIMATIC BATCH for creating recipes and for producing 
batches must be specified for a process cell. This data is also specified in the 
engineering system (ES). The type description for a process cell, for example unit 
classes or function types, can be edited in the SIMATIC Manager independent of 
the basic control. Before creating the process cell data for SIMATIC BATCH, the 
type description must be synchronized with the SFC types and the CFC charts 
(block instances). 
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Compiling and Downloading Process Cell Data 

To be able to download the process cell data distributed on the BATCH server and 
the BATCH clients according to the configured plant hierarchy, you create and 
configure SIMATIC PC stations with server and client applications in the SIMATIC 
Manager. The process cell data can then be derived from the plant hierarchy and 
downloaded to the BATCH server and the BATCH clients. Prior to downloading, 
the OS and batch process cell data must always be compiled. 

4.2 Difference between Single Project and Multiproject 
Engineering 

The engineering involved in a batch process cell can be done both on one 
computer (single project) or on several computers (multiproject). 

Single Project Engineering 

In small batch process cells and when only one configuration engineer is available, 
engineering is done in a single project; in other words, on one computer. 

Multiproject Engineering 

In larger batch process cells, simultaneous configuration is necessary on different 
computers and by different configuration engineers. This is made possible by 
multiproject engineering. Access to the data on the other computers is possible. 
The individual projects of the process cell are merged on a central ES computer 
using the "Multiproject" object. 
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4.3 Flowchart: Engineering Steps for a Single Project 

Introduction 

Below you will see a recommended  sequence of configuration steps. The order of 
the steps shown in the schematic is not absolutely necessary. We have selected a 
method on which the following more detailed description is oriented. 

Requirement 

The basic control has been created; in other words, the PLC hardware is 
configured, the CFC and SFC charts have been created and compiled. The 
information below relates only to the supplementary ES configuration for creating 
recipes and batch control with SIMATIC BATCH. 

Example of a Configuration for Single-Project Engineering 

Single project
Executable functions:
• S7 configuration
• Configuring BATCH clients
• Configuring BATCH servers
• Configuring SFC types
• Configuring PH

Executable functions in the
“Edit Batch process cell“ dialog:
• for the project:

• Settings: distribution, OS objects
• for the process cell:

• Transfer to OS
• Download

• for the Batch types:
• Edit
• Generate
• Synchronize

• for the Batch instances
• Compile
• Validation

 ES computer
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What is involved in the ES configuration for SIMATIC BATCH? 

 

•  S p e c ify in g  th e  m e ssa ge  O S  
a n d  B a tch -re le va n t O S  

•  I f n ec . U p d a ting  o f d is tr ibu tion  
a n d  p ro ces s  ce ll 

T ra n s fe r to  th e  O S  

V a lid a tion  e rro r?  
ye s  

n o  

B A T C H  se rve r 
lo ca l?  

ye s  
C h a n g e  to  re m o te  co m pu te r 

(B A T C H  se rve r)  

S ta rt P C S  7  O S  (W in C C ) a n d   
B A T C H  se rve r 

B A T C H  c lie n t  
lo ca l?  

n o  (d is tr ib u ted  co m pu te r s truc tu re ) 

ye s  

S ta rt B a tch C C  a n d   
re a d  in  p rocess  ce ll da ta  

C h a n g e  to  re m o te  co m pu te r 
(B A T C H  c lie n t) 

D e b u g  

n o  (d is tr ib u ted  co m pu te r s truc tu re ) 

C re a tin g  th e  p lan t h ie ra rch y  
 

S F C : C re a tin g  S F C  typ es  fo r  
S IM A T IC  B A T C H  

C F C : C re a tin g  C F C  
ch a rts  w ith  S F C  typ e  
in s ta n ce s  o rB A T C H  

in te rfa ce  b locks  

C o n fig u rin g  B A T C H  se rve r a nd   
B A T C H  c lie n ts  

 

C o m p iling  O S  
 

S IM A T IC  M a n a g e r 

G e n e ra tin g  an d  ed itin g  B a tch  typ e s  
 

B a tch  va lid a tio n  
 

C o m p iling  B a tc h  p ro cess  ce ll d a ta  
 

D o w n lo a d  B a tc h  p ro cess  ce ll d a ta  
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Updating the Process Cell Data 

 

 Note: 

If you modify the basic control (CFC/SFC charts, hardware configuration, plant 
hierarchy etc.), the process cell data must be updated again and downloaded to 
the target system (BATCH Server, BATCH clients) and batch-relevant data must 
be transferred to the operator stations. 

Prior to this, the OS must first be compiled and downloaded again. 

4.4 Flowchart: Engineering Steps for a Multiproject 

General Documentation on Multiproject Engineering 

The manual Process Control System PCS7; Engineering System provides an 
introduction to multiproject engineering with PCS 7.This documentation is on the 
"Electronic Manuals, PCS 7" CD. This is general documentation that describes the 
configuration of a multiproject and the interaction between individual S7 projects 
from a neutral perspective. 

You will find further information in the online help in PCS 7 in the topic "What you 
Should Know about Multiprojects". 

The following information relates to the additional engineering steps involved in 
configuring batch processes with the components of SIMATIC BATCH. 

Sample Configuration for a Centrally Managed Multiproject for SIMATIC BATCH 

The first step is to create a "Multiproject" object on a central ES computer in the 
SIMATIC Manager. You set up all the S7 projects along with drive information 
relating to the ES computers on which the S7 projects will be configured below the 
multiproject. The individual S7 projects can then be configured at the same time on 
the ES computers (computer 1, computer 2, computer 3, ...). The data for the 
BATCH Server is configured on one of the ES computers (computer 1). 

 

 Note: 

It is, of course, also possible to configure one of the projects on the central ES 
computer, for example the computer with the BATCH Server configuration. To 
keep the picture clear, however, the description that follows is based on the 
configuration shown in the schematic below. 
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Multiproject
Executable functions in “Edit Batch
process cell” dialog box:
• For the multiproject:

• Settings: Distribution,
OS objects, process cells

• For the process cell:
• Transfer to the OS
• Download

• For the Batch types:
• Edit
• Generate
• Propagate
• Synchronize

• For the Batch instances
• Merge/compile
• Validation

ES computer 2

S7Proj1 S7Proj2

ES computer 3

...

SIMATIC Manager

Multiproject

S7Proj1
S7Proj2

Central ES computer

... S7Proj3

Booked out
project without
editable Batch
types

Booked out
project with
editable Batch
types

Executable functions for a
booked in project:
• S7 configuration
• Configuring  BATCH clients
• Configuring BATCH server
• Configuring SFC types
• Configuring PH
Executable functions in the
"Edit Batch process cell" dialog
• For the Batch types:

• Update
• Read-only

• For the Batch instances
• Compile
• Validation

Executable functions
• S7 configuration
• Configuring BATCH clients
• Configuring BATCH server
• Configuring SFC types
• Configuring PH
Executable functions in “Edit
Batch process cell” dialog box:
• For the Batch types:

• Edit
• Generate

• For the Batch instances
• Compilation
• Validation

Executable functions:
• S7 configuration
• Configuring BATCH clients
• Configuring BATCH server
• Configuring SFC types
• Configuring PH
Executable functions in “Edit
Batch process cell” dialog box:
• For the Batch types:

• Read-only
• For the BATCH instances

• Compilation
• Validation
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What is involved in the ES configuration for SIMATIC BATCH in a multiproject? 

• Specify message OS and
Batch-relevante OS

• If nec. update distribution and
process cell

Transfer to OS

Validation error?
yes

no

Debug

Create plant hierarchy

SFC: Create SFC types for
SIMATIC BATCH

CFC: Create CFC charts
with a SFC type instances

or BATCH interface
blocks

Create multiproject with projects
(PCS 7 Wizard)

Compile OS

SIMATIC Manager

Generate and edit Batch types

Compile Batch process cell data

Batch validation

Download Batch process cell data

PCS 7 configuration (standard)

Configure BATCH server and
BATCH clients

Configuration for
the multiproject

Configuration for the
peer projects

Configuration for
the multiproject

Batch validation

Merge and compile Batch process
cell data

Runtime computer: Start PCS 7 OS
and BATCH server

Client computer: Start BatchCC
 and read in entire process cell data
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Updating the Process Cell Data 

 

 Note: 

If you modify the basic control (CFC/SFC charts, hardware configuration, plant 
hierarchy etc.), the process cell data must be compiled again, batch-relevant data 
must be transferred to the operator stations, and downloaded to the target system 
(DB server, BATCH Server, BATCH clients). 

Before data is transferred to the operator stations, the OS must be recompiled. 

Uniqueness of the Names 

 

 Note: 

Please note that if you distribute the configuration work on several ES computers, 
the project names and the names of the project objects contained must be unique 
on all ES computers. The process cell name must be identical in all projects. 

 

4.5 Using the PCS 7 Wizard 

When you create a new single multiproject, you can also use the PCS 7 wizard in 
the SIMATIC Manager. This allows you to create a single project or multiproject 
with one project including a PC station for the BATCH Server and a PC station for 
a BATCH client. 

Starting the Wizard 

In the SIMATIC Manager, select the menu command File > "New Project" Wizard 
and follow the instructions in the dialogs. 

Settings for SIMATIC BATCH 

In the 3rd dialog box "Which objects will be used in the project?", the "SIMATIC 
BATCH" option is available. Select this option and three further options appear on 
the right-hand side in the same dialog box. Select the project version you require. 
Once the PCS 7 wizard is completed, the PC stations are visible in the component 
view. 



 Configuration in the ES 

SIMATIC BATCH 
A5E00272803-01 4-9 

4.6 Configuring BATCH Servers and Clients 

4.6.1 Basics of Configuration 

Principle 

The BATCH Server and the BATCH clients of a process cell project generally run 
on different computers. To download the process cell data of a project and 
distribute it to these computers, a SIMATIC PC station is created for the BATCH 
server (BATCH control server, DB server) and each BATCH client in the 
component view of the SIMATIC Manager.  

 

!  
Warning 

Configuring applications (WinCC, SIMATIC BATCH, ...) on separate "SIMATIC PC 
station" objects and then merging them to create one PC station by assigning the 
same computer name to the "SIMATIC PC station" objects is not permitted! 

Structure of the Batch Project in the SIMATIC Manager (Component View) 
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Functions Available for BATCH Configuration 

 

Object Meaning Available Functions 

 BATCH Client Application • Configuring the BATCH Clients  

 BATCH Control Server or data 
storage system 

• Configuring the BATCH Server  

 Only in a redundant system: 

BATCH Control Server or data 
storage system standby 

• Configuration of the Redundant BATCH 
Server  

 

WinCC application on  
PCS 7 OS 

• Compiling the OS  

BATCH Application Client 

A "BATCH application client" stands for the BATCH Recipe Editor, the Batch 
Control Center (BatchCC), for batch operator control and monitoring, and batch 
data management. 

BATCH Application 

"BATCH application" is the representative for 

• "DB server project": Data storage for user permissions 

• DB server offline: Data storage for recipes, formulas, materials 

• DB server online: Data storage for batches 

• BATCH Control Server (BCS) 

BATCH application [stby] 

"BATCH application [stby]" stands for the redundant applications: 

• "DB server project": Data storage for user permissions 

• DB server offline: Data storage for recipes, formulas, materials 

• DB server online: Data storage for batches 

• BATCH Control Server (BCS) 
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4.6.2 Configuring the BATCH Server 

Rules 

• A SIMATIC PC station must be created and configured with a "BATCH 
application" in HW Config for the computer on which the BATCH server runs. 

• If you want to work locally on the ES computer with BATCH Server/clients 
(single project engineering), only one PC station with server and client 
application needs to be set up and in which the run-time computer name 
remains empty (or the local computer name is entered). 

 

!  
Warning 

Configuring applications (WinCC, SIMATIC BATCH, ...) on separate "SIMATIC PC 
station" objects and then merging them to create one PC station by assigning the 
same computer name to the "SIMATIC PC station" objects is not permitted! 

  

Follow the steps outlined below in the SIMATIC Manager:  

1. Select the project in the component view. 

2. Select the menu command Insert > Station > SIMATIC PC Station. 

Result: A new SIMATIC PC station is inserted in the current project.  

3. Set the computer name of the PC station: 

- Select the SIMATIC PC station. 

- Select the menu command Edit > Object Properties. 

- Enter the computer name in the last field. 

4. Configure this SIMATIC PC station in HW Config. 

- Select the SIMATIC PC station. 

- Select the menu command Edit > Open Object. 

Result: HW Config opens. 

- Insert a batch application from the hardware catalog: 

Path in the hardware catalog:   Standard > SIMATIC PC Station > HMI > 
BATCH Application. 

If you are using a redundant BATCH Server, select "BATCH application 
(stby)" instead. 
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5. Select the menu command Station > Save and Compile. 

Result: In the component view, the object  is displayed below 
the configured SIMATIC PC station.  
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4.6.3 Configuring the BATCH Clients 

Rules 

• A SIMATIC PC station must be created and configured with a "BATCH 
application client" in HW Config for every computer on which a BATCH client 
application runs. 

• BATCH clients can also run on PC stations on which no OS client (multiclient) 
is installed. 

Follow the steps outlined below in the SIMATIC Manager: 

1. Select the project in the component view. 

2. Select the menu command Insert > Station > SIMATIC PC Station. 

  Result: A new SIMATIC PC station is inserted in the current project. 

3. Set the computer name of the PC station. 

- Select the SIMATIC PC station. 

- Select the menu command Edit > Object Properties. 

- Enter the computer name in the last field. 

4. Follow the same procedure and install a further SIMATIC PC station for each 
BATCH client in the project. 

5. Configure these SIMATIC PC stations in HW Config. 

- Select the SIMATIC PC station. 

- Select the menu command Edit > Open Object. 

Result: HW Config opens. 

- Insert a batch client application from the hardware catalog: On a BATCH 
client, you insert an additional WinCC application if the BATCH client is 
operated along with an OS client on one computer. 

Path in the hardware catalog: Standard > SIMATIC PC Station > HMI > 
BATCH Application (client). 
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6. Select the menu command Station > Save and Compile. 

Result: In the component view, the object  is displayed 
below the configured SIMATIC PC station.  

4.6.4 Installing on BATCH Servers and BATCH Clients 

You will find an overview of the Batch applications that can be installed on BATCH 
servers and BATCH clients and the required authorizations in the manual  Process 
Control System PCS 7; PC Configuration and Authorization. 
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4.7 Basics of the Plant Hierarchy 

4.7.1 Structure of the Plant Hierarchy 

Introduction 

With the plant hierarchy, the Engineering System provides you with the means of 
recreating the technological structure of the process cell in the PCS 7 system. The 
objects such as CFC/SFC charts, OS reports, or OS operator pictures are added in 
the plant hierarchy.  

Structure of the Plant Hierarchy 

The highest level is fixed by the system when you create a new project. The next 
hierarchy levels can either be neutral folders or folders with configuration data for 
SIMATIC BATCH. This is decided in the object properties of the relevant hierarchy 
folder in the "S88 Type Definition" tab under the object type properties.  

In multiproject engineering, the top level is the "Multiproject" object, below that you 
will find the individual projects and the process cell below these projects. 

For the configuration data for SIMATIC BATCH, the three hierarchy folders shown 
in the schematic below are necessary (these are generally known as batch 
hierarchy folders): 

 

 

Three hierarchy folders for  
SIMATIC BATCH: 

• Process cell folder  

• Unit folder  

• Equipment module folder  
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Technological Significance of the Batch Hierarchy Folders 

The three batch hierarchy folders have the following defined technological 
significance according to the ANSI/ISA S88.01 (1995) standard: 

 

Batch  
hierarchy folder 

Level Meaning 

Process Cell Level 2 Within a project, only one process cell can currently be 
created. A recipe can therefore only access phases of this 
process cell. Examples of the process cell level might be 
polymerization plant, dyehouse, colored pigment plant, or 
multipurpose plant. 

Unit Level 3 Several units can be defined in one process cell. These 
units can be used within a recipe. Examples of units might 
be neutralization, extraction, distillation, or preparation. 

Equipment module Level 4 Several equipment modules such as a dosing or bottling 
machine can be defined in a unit. Equipment phases such 
as heating, cooling, ventilating, emptying can be created for 
the equipment modules. 

 

Included in the Naming Scheme (Yes/No) 

The name of the project exists once and is not included in the naming scheme for 
tags in WinCC. All other folders can be included in the naming scheme during 
configuration. 

 

 Note: 

As default, inclusion in the naming scheme is deactivated. This means that no 
hierarchy folder is included in the name. 

 

Storage of the Blocks 

The charts with the corresponding SFC type instances or BATCH interface blocks 
can be stored in the appropriate batch hierarchy folders according to their 
technological significance. Only TAG_COLL can be stored in the process cell 
folder. The IUNIT_BLOCKs along with EOPs, EPHs and TAG_COLLs can be 
stored in folders of the "Unit" object type. EPHs and TAG_COLLs can be stored in 
folders of the "Equipment Module" object type.  

The charts with the function blocks (valves, controllers etc.) and sequential controls 
(SFC) required for the automation task can also be stored in these BATCH 
hierarchy folders. You can also extend the structure specified by SIMATIC BATCH 
for the general function blocks using neutral hierarchy folders so that you produce 
the ideal plant structure for your requirements. 
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Example: 

 

4.7.2 Extending the Plant Hierarchy by Adding Neutral Folders 

Neutral Folders 

As already mentioned, the three-stage hierarchy for SIMATIC BATCH can be 
extended by adding neutral folders to improve the structuring of the project, for 
example to divide units into groups. The neutral folders can be created at any level. 
The total number of possible levels (batch hierarchy levels, levels with neutral 
folders) is limited to 5. 

Neutral folders can, for example, be inserted above the "Unit" level. This level can 
then be used, for example, as the area level. A further level could, for example, be 
inserted below the "Equipment Module" level. This level can then serve as a control 
module level. 
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Example 

 

 

Levels in the Example: 

• Process cell: Crop protection plant 

• Area: Subcells, production, tanks 

• Unit In the production area: V510, V520, V530, V540 

• Equipment Module In unit V510: aerate, dose, pump,... 

• Control Module P020, P021, P022, T390, Y400, Y405 

 

Batch allocations of the levels in the example: 

• Process cell: Data types/measured value types/phase types, unit 
classes, units of measure 

• Area: None (not relevant for batches) 

Areas are displayed during recipe creation as a filter 
criterion for unit allocation. 

• Unit Units and possibly equipment phases 

• Equipment Module Equipment phases 

• Control Module None (not relevant for batches) 
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4.7.3 Relationship between Plant Hierarchy, Blocks, and Recipes 

Introduction 

For recipe creation and processing, the process cell and unit levels must exist at 
least once. Whether or not you require the equipment module level depends on 
how you define the equipment procedural elements. 

Relationship Between Hierarchy Folders, Block Instances and Recipe Elements 
for a Hierarchical Recipe: 

 

TAG_COLL 
(CFC block) 

Process cell 

Unit 

Equipment 
module 

IEOP 

IEPH 

TAG_COLL 

IUNIT_BLOCK 1:1 assignment 

Hierarchy folder Block instances 

Consists of 0 to n , e.g. a process cell has 0 to n TAG_COLL blocks 
Directional  association 
Association 
one to n 
0 or 1 

Recipe elements 

RP 

TRP 

ROP 

RF 

Neutral 

uses 

IEPAR_ 

SFC type instance 
(EOP, EPH) 

uses 

SFC type instance 
(EOP, EPH) 

uses 
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Legend: 

 

Batch hierarchy folder of a process cell 

 

Process cell 

Unit 

Equipment module 

Neutral folder 

 

Block instances 

 

IEOP -> Interface Equipment Operation 

IEPH -> Interface Equipment Phase 

IUNIT_BLOCK -> Interface Unit Status and Allocation 

TAG_COLL -> Collection of Process Values 

 

 

Recipe Elements 

 

RP -> Recipe Procedure 

RUP -> Recipe Unit Procedure 

ROP -> Recipe Operation 

RPH -> Recipe Phase 
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4.7.4 Interface to the Technischen Function (CFC Charts) 

4.7.4.1 Introduction 

Interface to the Equipment Phase 

In SIMATIC BATCH, each terminal step (recipe phase) of a control recipe 
communicates during run time with a programmable controller equipment phase 
that implements the required phase of the recipe phase. Both setpoints and 
process values as well as the current status of the equipment phase or control 
commands of the recipe phase are exchanged. 

As of version V6.0, SIMATIC BATCH can use the new functionality of the SFC 
types in the Engineering System (see section "Use of the SFC Types"). As an 
alternative and to ensure compatibility, SIMATIC BATCH continues to provide the 
BATCH interface blocks as a communications interface to the processing programs 
on the programmable controller (refer to the section "Using the BATCH Interface 
Block") 

BATCH interface blocks - up to SIMATIC BATCH V6.0 

In the versions of SIMATIC BATCH lower than V6.0, communication between 
SIMATIC BATCH and the equipment phases on the programmable controller is 
implemented using interface blocks (IEPH, IEOP and IEPAR_xxx). These blocks 
are implemented as CFC blocks and are installed during the SIMATIC BATCH 
setup. They are interconnected with the appropriate inputs and outputs of the 
control block and technological blocks of the equipment phase in CFC charts.  

SFC types  – Use as of SIMATIC BATCH V6.0 

As of SIMATIC BATCH V6.0, there is a merging of interface block and equipment 
phase using the standard tools of SFC. An SFC type (= BATCH type block) with 
parameters is created for each equipment phase type in the SFC chart. Each 
BATCH type block is displayed in the "Other Blocks" block library or in the family 
assigned to the SFC type (for example batch) of CFC and can be inserted simply 
into the SFC chart. 

Storage in the Plant Hierarchy 

The BATCH interface blocks and BATCH type blocks are stored in the CFC charts 
according to their function in the corresponding hierarchy folders in the plant view 
in the SIMATIC Manager. 
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4.7.4.2 Use of the BATCH Interface Blocks 

Functions 

Using the BATCH interface blocks along with SIMATIC BATCH  makes the 
following functions possible: 

• Controlling the Procedure: 
The IEPH/IEOP blocks are for this purpose. These provide the commands (for 
example start or put on hold) of the recipe steps from the batch control to the 
processing blocks (for example : SFC CTL or user blocks). The processing 
blocks report their current statuses back to the batch control. 

• Assigning and releasing a unit via a running control recipe: 
The IUNIT_BLOCK blocks are for this purpose. 

• Collection of process values to be used in transition conditions of third-party 
units and for archiving and logging. 
The TAG_COLL blocks are for this purpose. 

• Transferring setpoint and actual values: 
The IEPAR blocks are for this purpose. The batch control writes the recipe 
parameters (setpoints) for the processing blocks into these blocks via the 
IEPH/IEOP blocks. The processing blocks write the result data (actual values) 
into the IEPAR blocks so that they can be stored as batch data by the batch 
control once again using the IEPH/IEOP blocks. 
The IEPAR blocks linked to the IEPH/IEOP blocks are also used to form 
transition conditions for the local unit. 

Overview of the BATCH Interface Blocks 

 

Block Application 

IEPH Control of simple processes 

IEOP Control of complex processes 

IUNIT_BLOCK Management of unit allocation 

TAG_COLL Collecting of process values for archiving, logging, and forming transitions 

IEPAR_DINT Parameter block for the data type double integer 

IEPAR_BOOL Parameter block for the data type Boolean (binary) 

IEPAR_REAL Parameter block for the data type real (floating point) 

IEPAR_STR Parameter block for the data type string (text) 

IEPAR_PI Parameter block for the data type process input 

IEPAR_PO Parameter block for the data type process output 

IEPAR_ENUM Parameter block for the data type enumeration type (user-defined 
enumeration type) 
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Online Help on the BATCH Interface Blocks 

You will find a detailed description of the function, operation, and input/output 
parameters for each individual BATCH interface block in the context-sensitive 
online help for the block in CFC. 

With a BATCH interface block selected in the CFC chart, simply press the F1 key 
to open the context-sensitive help.  

4.7.4.3 Using SFC types 

Functions 

Using the SFC types (SFC standard) along with SIMATIC BATCH makes the 
following functions possible: 

Controlling the Procedure: 
Here, you use the SFC type instances in the CFC charts (of the type EPH/EOP). 
These provide the commands (for example start or put on hold) of the recipe steps 
from the batch control to the internal processing. The status of the internal 
processing and the process values are reported back to batch control so that they 
can be stored by batch control as batch data. 

Supplementary Use of the BATCH Interface Block IUNIT_BLOCK 

The following function continues to use a BATCH interface block even after 
converting to SFC types: 

Assigning and releasing a unit via a running control recipe: 
The IUNIT_BLOCK interface blocks are used for this purpose. 

Supplementary Use of the TAG_COLL Function Block 

Even when using the SFC types, a standard FB is used for the following function: 

Collection of process values to be used in transition conditions and for archiving 
and logging: Here, the TAG_COLL blocks are used. 
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4.8 Creating the Plant Hierarchy 

4.8.1 Using the BATCH Hierarchy Folder 

4.8.2 "Process Cell" Hierarchy Folder 

Introduction 

Below the project you create the SIMATIC BATCH hierarchy folder of the object 
type "Process Cell". You set the object type in the properties of the hierarchy folder 
in the "S88 Type Definition" tab. 

Definition of a Process Cell 

A process cell is a logical grouping of facilities/devices (containers, actuators, 
sensors, etc.) for creating one or more batches. The process cell determines the 
spectrum of logical control options for a set of process equipment within a plant. 

Rules for the "Process Cell" Hierarchy Folder 

• Within a project, only one "Process Cell" hierarchy folder can be created. 
Examples of this might be a polymerization plant, dyehouse, multipurpose 
plant. 

• When creating a master recipe in SIMATIC BATCH, the data of this process 
cell are made available. This means that all the units and equipment phases 
required in a master recipe must be created below the process cell folder. 

Multiproject 

Each project of a multiproject contains the same "Process Cell" object. Below this, 
you can configure different units in the individual projects.  
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4.8.2.1  "Unit" Hierarchy Folder 

Introduction 

Below the process cell, you create the hierarchy folder with the object type "Unit". 

• If the unit folder is created directly below the process cell folder, the "Unit" 
object type is assigned automatically by the system when you create it. 

• If the unit folder is not created directly below the process cell folder but is 
inserted below a neutral folder, the inserted folder is automatically assumed to 
be a neutral folder. You can then set the "Unit" object type afterwards in the 
properties of the hierarchy folder in the "S88 Type Definition" tab. 

"Unit" Hierarchy Folder 

Several units can be defined in one process cell. Several units can be used within 
a master recipe. Examples at this level could be the division of a process cell into 
neutralization, extraction, distillation, or preparation. 

Assigning the Unit Class 

In the object properties of the "Unit" hierarchy folder, you assign the corresponding 
unit class (for example "Reactor") to each unit. You also enter concrete values for 
the unit parameters (for example "Coating = Glazed", "Volume = 500 l"). 

The unit parameters are used in SIMATIC BATCH when a batch is created in 
conjunction with the equipment requirements for restricting the possible candidates 
in unit selection. An example of the properties of a unit class might be the inner 
coating of the reactor, for example rubber coated, enameled, glazed etc. 

You can open this dialog from the Object Properties dialog of the "Process cell" 
hierarchy folder > "S88 Type Definition" tab > "Unit class" dialog box.  

Managing Unit Allocation with the IUNIT_BLOCK 

To map the unit on the programmable controller, there is exactly one instance of 
the BATCH interface block UNIT_BLOCK in one of the charts of the "Unit" 
hierarchy folder. The batch control enters the batch ID and the batch name in the 
IUNIT_BLOCK block so that the allocation of units can be managed. 

With suitable user configuration on the PLC, IUNIT_BLOCK can be used to prevent 
the use of a unit by batch control (input BA_EN, BATCH enable). 
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4.8.2.2  "Equipment Module" Hierarchy Folder 

 Introduction 

Below the unit, you create the hierarchy folder of the "equipment module" object 
type. 

• If the equipment folder is created directly below the unit folder, the "Equipment 
Module" object type is assigned automatically by the system when it is created. 

• If the equipment folder is not created directly below the unit folder but is 
inserted below a neutral folder, the inserted folder is automatically assumed to 
be a neutral folder. You can then set the "Equipment Module" object type 
afterwards in the properties of the hierarchy folder in the "S88 Type Definition" 
tab. 

"Equipment Module" Hierarchy Folder 

Several equipment modules such as a dosing or bottling machine can be defined in 
a unit. Equipment phases such as heating, cooling, ventilating, emptying can be 
created for the equipment modules.  
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4.8.3 Editing the Plant Hierarchy 

4.8.3.1 How to Create the Plant Hierarchy 

Information on Creating and Setting the Plant Hierarchy 

For detailed information on creating, modifying, and setting the properties of the 
plant hierarchy, refer to the manual Process Control System PCS 7; Engineering 
System. 

Below, only the additional and special settings for the batch configuration are 
described. 

Special Settings for Batch Configuration 

The following additional settings must be made or checked for batch configuration: 

• Specifying the Basic Settings for the Plant Hierarchy  

• Assigning the Object Type "Process Cell", "Unit" or "Equipment Phase" to 
Hierarchy Folders  

• Assigning a Unit Class to a Unit 

• Executable Functions in a Single Project  

• Executable Functions in a Multiproject  

• Inserting CFC Charts with EPHs/EOPs  
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4.8.3.2 Specifying the Basic Settings for the Plant Hierarchy 

Necessary Settings 

The following basic settings are necessary for the plant hierarchy of the current 
project: 

• Number of hierarchy levels 

• Whether or not the hierarchy names of an entire level will be included in the tag 
names (in WinCC) (HID = higher-level designation). 

Follow the steps outlined below in the SIMATIC Manager: 

Once you have created the first hierarchy folder, you can make the basic settings. 

1. Select any hierarchy folder in the plant view. 

2. Select the menu command Options > Plant Hierarchy > Customize. 

3. Make the following settings in the "Customize Plant Hierarchy"  dialog box: 

- Enter the maximum number of possible hierarchy levels that can occur in 
the project. For the BATCH hierarchy, only three hierarchy levels are 
relevant. If you decide to use neutral folders, up to 5 hierarchy levels are 
possible. 

- Using the "Include in designation" check box, you can decide whether the 
hierarchy folder name of any particular level will be included in the higher 
level designation (HID). 

You can decide whether the name of an individual hierarchy folder will be 
included in the HID in the operator control and monitoring attributes of 
each individual hierarchy folder (menu command Edit > Object Properties 
> Control and Monitoring Attributes"). 

4. Confirm with OK. 
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4.8.3.3 Assigning the "Process Cell", "Unit" or "Equipment Phase" 
Object Type 

To identify the BATCH hierarchy, each hierarchy folder is explicitly assigned the 
object type "Process Cell", "Unit", or "Equipment Phase". Depending on the object 
type, other BATCH attributes can then be set. 

After creating a new hierarchy folder, one of the object types "process cell", "unit", 
"equipment phase" or "neutral" is automatically assigned depending on the 
position. You can change the object type assigned to a hierarchy folder as follows: 

Follow the steps outlined below in the SIMATIC Manager:  

1. Select the hierarchy folder in the plant view. 

2. Select the menu command Edit > Object Properties. 

3. Change to the "S88 Type Definition" tab. 

4. Set the required type (process cell, unit, or equipment module) of the hierarchy 
folder for the "Object Type". If you select the "<neutral>" object type, the 
BATCH hierarchy will be deactivated again for this folder. 

5. Confirm with OK. 

Result: The graphic display of the hierarchy folder matches the selected object 
type. 

Neutral Folders 

The "<neutral>" object type deactivates the BATCH hierarchy for the "process cell" 
object. The lower-level BATCH hierarchy folders retain their object type but are no 
longer relevant for the SIMATIC BATCH configuration. In "Object type", the nested 
hierarchy folders no longer relevant for SIMATIC BATCH are displayed in round 
brackets, for example: (Unit).  
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4.8.3.4 Assigning Unit Classes to a Unit 

Introduction 

In the object properties of the "Unit" hierarchy folder, you assign the corresponding 
unit class (for example "Reactor") to each unit. You also enter concrete values for 
the unit parameters (for example "Coating = Glazed", "Volume = 500 l"). 

In the BATCH recipe editor, the options for selecting unit candidates and the 
corresponding equipment phases (of the type EOP/EPH) can then be restricted to 
a unit class. The great advantage of this is that when you convert the master recipe 
to the control recipe, the actual unit allocation is always successful since the 
master recipe contains only the permitted unit candidates. 

Follow the steps outlined below in the SIMATIC Manager:  

1. Select a "unit" hierarchy folder in the plant view. 

2. Select the menu command Edit > Object Properties. 

3. Change to the "S88 Type Definition" tab. 

4. Select an existing class for "unit class". 

  Note: You create new unit classes and the corresponding parameters for the 
entire process cell when specifying the type description with the menu 
command Options > SIMATIC BATCH: Batch Types -> Unit Classes. 

5. Assign the parameters values under "Unit class" in the table and confirm with 
OK. 
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4.8.3.5 Rules for Inserting CFC Charts 

Rules for Storing CFC Charts in the Plant Hierarchy 

The process cell model is created in the SIMATIC Manager based on the CFC 
charts and the configured plant hierarchy. When inserting CFC charts in the plant 
hierarchy, note the following: 

• The charts with the corresponding SFC type instances or BATCH interface 
blocks can be stored in the appropriate batch hierarchy folders according to 
their technological significance. Only TAG_COLL can be stored in the process 
cell folder. The IUNIT_BLOCKs along with EOPs, EPHs and TAG_COLLs can 
be stored in folders of the "Unit" object type. EPHs and TAG_COLLs can be 
stored in folders of the "Equipment Module" object type. 

• The CFC charts with the function blocks (valves, controllers etc.) and 
sequential controls (SFC) required for the automation task can also be stored 
in these BATCH hierarchy folders.  

• You can also extend the hierarchy specified by SIMATIC BATCH for the 
general function blocks using neutral hierarchy folders so that you produce the 
ideal plant structure for your requirements. 

 

Example: 
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4.9 Inserting BATCH Interface Blocks in CFC Charts 

4.9.1 Introduction 

You drag the BATCH interface blocks from the library PCS 7 Library > SIMATIC 
BATCH Blocks to the CFC chart. 

Engineering in CFC Charts 

The BATCH interface blocks are inserted in the CFC charts for the following 
engineering tasks: 

• Defining units 
A CFC chart is created for each unit and contains an instance of the 
IUNIT_BLOCK with assigned parameter values. 

• Linking process blocks with SIMATIC BATCH 
A uniform interface is created for each equipment phase or operation. This is 
achieved with an IEPH or IEOP block. This is inserted in the SFC chart along 
with the corresponding IEPAR_xxx parameter blocks and the processing block 
( using the SFC external view or user block). The control outputs QSTART, 
QHOLD, QABORT, QTERM, QRESET of the IEPH/IEOP block are 
interconnected with the corresponding inputs of the processing block (using the 
SFC external view or user block). 

• Collecting process values together to form transition conditions and defining 
measured variables 
For IEPARs that will be used in transition conditions in the BATCH Recipe 
Editor and are not available as IEPAR in the IEPH, the process values can be 
collected. Process tags can also be included as parameters to be used in the 
batch measured value acquisition. Alternatively, the measured value 
acquisition can also be specified in the type parameters of the Batch types 
(phase and operation types). 
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4.9.2 Rules for the IEPH and IEOP Interface Blocks 

Rules for Interconnection in CFC Charts 

• The IEPH, IEOP interface blocks for controlling the process must be inserted in 
sequences before the processing block in the CFC chart. 

• The IEPH block is used for a recipe step of the type RPH (recipe phase). The 
IEOP block is used for a recipe step of the type ROP (recipe operation). 

• To pass control commands from SIMATIC BATCH to the SFC, the following 
and connections between IEPH, IEOP and SFC external view must be 
configured:   

 

IEPH/IEOP SFC external view 

QBA_EN (OUT) BA_EN (IN) 

VSTEP_NO (OUT) STEP_NO (IN) 

VBA_ID (OUT) BA_ID (IN) 

VBA_NAME (OUT) BA_NA (IN) 

Q_OCCUPI (OUT) OCCUPIED (IN) 

QSTART (OUT) START (IN) 

QHOLD (OUT) HOLD (IN) 

QSTOP (OUT) STOP (IN) 

QABORT (OUT) ABORT (IN) 

QRESET (OUT) RESET (IN) 

QTERM (OUT) COMPLETE (IN) 

QCONT (OUT) CONT (IN) 

 

• For continuous operation of the equipment procedural element (CONTINUOUS 
mode), the following conditions must be satisfied for the SFC: 

- ENASTART = 1  

- SELFCOMP = 0   

• The equipment procedural element must return the actual status to SIMATIC 
BATCH. This requires the following interconnection:  

 

SFC external view IEPH/IEOP 

BA_STATE (OUT) USTAT_L (IN) 
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• The underlying parameter blocks (IEPAR_xxx) must be connected at the 
EPE_CONN output of the IEPH/IEOP blocks. The following parameter types 
are possible:  

IEPAR_REAL Floating point 

IEPAR_DINT Integer 

IEPAR_BOOL Binary value 

IEPAR_PI Input material 

IEPAR_PO Output materials 

IEPAR_STR String 

IEPAR_ENUM Enumeration 

  With the IEPAR_ENUM enumeration time, the data type name is specified at 
the "ENUM" block I/O. In the Batch types, the values are assigned to this data 
type (for example 1 = ON / 2 = OFF etc.). 

• Exactly one IEPAR block for the required data type is necessary for each 
parameter (setpoint/process value) of an IEOP/IEPH. 

• The phase/operation type name must be specified in each IEPH/IEOP block. 

• In all IEPAR blocks (apart from the Bool and Enum type) the lower and upper 
limit value and the default setpoint must be specified. The default value must 
be within the limits. 
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Example 
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Rules for Supplying the Equipment Procedural Elements with Batch Data 

Equipment procedural elements controlled by SIMATIC BATCH must be supplied 
with the batch data. The faceplates on the PCS 7 OS then indicate whether this 
equipment procedural element is being used by SIMATIC BATCH and which batch 
is running. The batch name and the batch ID are included in the messages to the 
PCS 7 OS.  

To allow this, the five following interconnections must be configured: 

 

IEPH/IEOP Automation Function  
for example SFC (external view), MEAS_MON, MOTOR... 

QBA_EN BA_EN 

QOCCUPI OCCUPIED 

VBA_ID BA_ID 

VBA_NAME BA_NA 

VSTEP_NO STEP_NO 
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Example 

Example of the interconnection between IEPH, a MOTOR block and a 
MEAS_MON block: 

 

Rules for Control Strategies with IEPH, IEOP 

In the CFC chart, an IEPAR_ENUM must be assigned to the BATCH interface 
block IEPH, IEOP to allow transfer of the control strategy number. The user data 
type, in this case the control strategy parameter name, must be specified at the 
"ENUM" block I/O.  

How configuration continues is described in the section "Specifying Control 
Strategies for a Type". 
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4.9.3 Rules for the IUNIT_BLOCK Interface Block 

Rules for Interconnection in CFC Charts 

• To map the unit on the PLC, there must be exactly one instance of the 
UNIT_BLOCK in one of the charts of the "Unit" hierarchy folder. 

• The block name must be entered otherwise no other settings or 
interconnections are absolutely necessary with the IUNIT_BLOCK. 

• At the "UNIT_NAME" input of the IUNIT_Block, a unit name can be specified 
that differs from the unit name in the plant hierarchy. This unit name is then 
used in the remaining SIMATIC BATCH configuration. 

Example 
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4.9.4 Rules for the TAG_COLL Interface Block 

Rules for Interconnection in CFC Charts 

• If process values of IEPAR blocks are queried in transitions and these are not 
available as IEPAR_xxx in the IEPH or IEOP, a TAG_COLL must be inserted 
in the CFC chart. This is, for example, the case when values of other units are 
queried. 

• The parameter blocks (IEPAR_xxx) must be connected to the EPE_CONN 
output of the TAG_COLL block. 

• A process tag type name must be specified for each TAG_COLL. 

Example 
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4.10 Creating and Inserting SFC Types in CFC Charts 

4.10.1 How to Work with SFC Types 

 

 Note: 

You create SFC types and their instances in the CFC charts for SIMATIC BATCH 
using SFC/CFC standard tools. SIMATIC BATCH does not need to be installed! 

 

Configuring an SFC Instance 

Below, you will find a recommended order for creating an SFC type (equipment 
phase) and an instance in the CFC chart. 

CFC:
• Insert SFC type in CFC chart
• interconnect instance of the SFC type

SFC:
• Create the SFC type
• Create parameters for the SFC type

SIMATIC Manager

 

Underlying Principle 

In the SFC, you create the following SFC types for SIMATIC BATCH: 

• EOP (equipment operation) 

• EPH (equipment phase) 

The type (EOP or EPH) and the type name are specified for the SFC type. This 
creates the interface to SIMATIC BATCH. 

The following can be created as characteristics of the SFC type: 

• The control strategies of the equipment operation/phase  

• The setpoints (parameters) of the equipment operation/phase 

The process values of the equipment operation/phase are derived from the 
setpoints. 

SFC types created in this way (= BATCH type blocks) are stored in the chart folder. 

In CFC, these BATCH type blocks are available in the other blocks library or the 
family assigned to the SFC type (for example batch) and can be dragged to the 
CFC chart and interconnected. 



 Configuration in the ES 

SIMATIC BATCH 
A5E00272803-01 4-41 

4.10.2 Creating a new SFC Type 

Follow the steps outlined below in the SIMATIC Manager (component view) 

1. Select the "S7 Program" object in the component view. 

2. Select the menu command Insert > Insert New Object > SFC Type. 

3. Mark the new object "SFC Type": . 

4. Select the menu command Edit > Object Properties. 

5. The "Properties SFC Type" dialog box opens.  

- Under Name, change the phase/operation tied name (Batch type). 

- You can also enter the required number for the FB number and the name 
of the block library for the family. 

- Change to the "Options" tab. 

- Under Category, set the version "EOP" or "EPH" and whether this 
operation type/phase type is allowed as an operator instruction. 

 

 Note: 

The "EOP" or "EPH" setting is necessary to generate the type description. Only 
these SFC types are read in the BATCH configuration dialog for the process cell 
(batch types)! 
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6. Select the menu command Edit > Open Object. 

Result: SFC is opened with the new SFC type: 

 

7. Here you can use the standard SFC tools to edit the sequential control of the 
equipment operation/phase. 

8. Change to the characteristics view by selecting the menu command Edit > 

Characteristics or click  

9. Enter your setpoints and control strategies here. 

 

 Note: 

With the INT and DINT data types, an enumeration data type can be assigned. 
This is stored as the system attribute "S7_enum" on the interface I/Os.  

The enumeration is then available for operator control and monitoring of SFC 
instances in SIMATIC BATCH. 

Further references 

For more detailed information on programming a sequential control and defining 
the SFC characteristics, refer to the online help of SFC (<F1> or menu command 
Help > Contents). 
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4.10.3 Specifying the Parameters 

Features 

You create setpoints (parameters) and control strategies that are relevant for 
SIMATIC BATCH in the characteristics view in SFC: 
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Overview of the Relevant Parameters 

The following parameters must be set for SIMATIC BATCH: 
 

Parameter Where to edit Meaning 

Setpoint Under "setpoints" 
characteristic 

Parameters for the equipment 
operation/phase; it is possible to assign 
previously defined control strategies. 

Input 
material/ 
Output 
materials 

Under the "Setpoint" 
characteristics: Data type 
PI/PO 

Input material/output material for the 
equipment operation/phase; it is possible to 
assign previously defined control strategies. 

Control 
strategy 

Under the "Control 
strategies" characteristic 

Control strategy name 

 

Follow the steps outlined below in SFC: 

1. Mark the new object "SFC Type": . 

2. Select the menu command Edit > Open Object. 

3. SFC opens with the new SFC type. 

4. Change to the characteristics view of SFC Select the menu command Edit  > 

Characteristics or press . 

5. The characteristics view of the SFC type opens. 

6. Here, you edit all the setpoints and control strategies relevant for SIMATIC 
BATCH by clicking on the characteristic in the left column, for example on 
"Setpoints". 

  On the right-hand side, you can now set the parameter with all the attributes relevant for 
SIMATIC BATCH. 

To assign setpoints for a control strategy: 

1. Select the setpoint in the characteristics view. 

2. Select the menu command Edit > Object Properties. 

3. The properties dialog (control strategy assignment)  z for the setpoint opens. 

4. Using the  button, assign the required (already created) control 
strategies in which the setpoint parameter is located. 

5. Confirm with the "Close" button. 
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4.10.4 Inserting an Instance of the SFC Type in the CFC Chart 

Introduction 

After creating the SFC type and storing it, the SFC type can now be dragged from 
the other blocks library or the family assigned to the SFC type (for example batch) 
and placed in the CFC chart. At the same time, the type FB is copied to the project 
or if it already exists, it is updated. A DB is created and therefore an instance of the 
SFC type. Remember the following rules: 

Rules 

• The SFC types in a chart container are displayed in CFC in the catalogs under 
other blocks or in the family assigned to the SFC type (for example batch).  

• If you create an instance of the SFC type, the SFC type (including the FB) is 
copied to the project (chart container). 

• After placing the SFC instance in a CFC chart, it can be interconnected.  

• The SFC instance is not displayed in the chart container (only the CFC chart). 

• The SFC instance is displayed in the CFC chart like a block with an interface.  

• If you select an instance of the type, you can open and edit it within the CFC 
chart using the "Open" context-sensitive menu. 

• The interconnection is possible with the control module level (CMs), the 
interlock logic, and batch control. 

• In the SFC, in addition to the name of the operation/phase type parameter, an 
I/O name must be specified in the characteristics view for setpoints. One 
setpoint results in several block I/Os: 

 
I/O name Meaning 

<name> (IN) Setpoint from SIMATIC BATCH or PCS 7 OS 

<name>_Q (OUT) Setpoint (valid value for SFC) 

<name>_AI (IN) Process value return input for process value 

<name>_ AO (OUT) Process value for SIMATIC BATCH and PCS 7 OS 

<name>_M (IN) Material code setpoint from SIMATIC BATCH* 

<name>_MQ (OUT) Material code (valid MatCode for SFC)* 

<name>_MAI (IN) Material code process value return input* 

<name>_MAO (OUT) Material code process value for PCS 7 OS* 

<name>_B (IN) Reserved for batch ID, not currently used 

<name>_BQ (OUT) Reserved for batch ID, not currently used 

<name>_BAI (IN) Reserved for batch ID, not currently used 

<name>_BAO (OUT) Reserved for batch ID, not currently used 

*    Only for PI or PO data types 
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• The following block I/Os exist for the control strategy: 

 
I/O name Meaning 

CS (IN) Control strategy from SIMATIC BATCH or PCS 7 OS 

QCS (OUT) Control strategy (valid control strategy for SFC) 

Example 
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Rules for Supplying the Equipment Procedural Elements with Batch Data 

Equipment procedural elements controlled by SIMATIC BATCH must be supplied 
with the batch data. The faceplates on the PCS 7 OS then indicate whether this 
equipment procedural element is being used by SIMATIC BATCH and which batch 
is running. The batch name and the batch ID are included in the messages to the 
PCS 7 OS. 

To allow this, the five following interconnections must be configured: 

 
SFC type equipment procedural element  for 

example MEAS_MON, MOTOR... 

QBA_EN BA_EN 

QOCCUPIED OCCUPIED 

QBA_ID BA_ID 

QBA_NA BA_NA 

QSTEP_NO STEP_NO 

4.10.5 Counting Process Objects (PO) 

If you want to know how many process objects (SFC types, IEOP, IEPH, and 
IUNIT_BLOCK instances) already exist, for example to order the correct 
license/authorization for SIMATIC BATCH, you can use the compilation function to 
find this out (refer also to the section "The SIMATIC BATCH Product"). 

Follow the steps outlined below in the SIMATIC Manager:  

1. Open the BATCH configuration dialog with the with the menu command 
Options > SIMATIC BATCH. 

2. Click the "Compile" button or "Validate". 

3. Under "Log", select the "Compile" or "Validate" option and click the "Display" 
button. 

Result: A window opens displaying the log data. The number of process objects is 
displayed under the "Process objects" title. 
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4.11 Creating and Inserting User Process Tag Types in CFC 
Charts 

Introduction 

Collecting measured values, for example to form transition conditions, is possible 
in two ways:  

• Using the BATCH interface block TAG_COLL (as in BATCH flexible V5.x) 

• Using the standard function block TAG_COLL, given the name 
TAG_COLLECT below to distinguish the two (new in SIMATIC BATCH V6.0) 

Individual measured values are created in the interface or standard function block. 
The process tag types are then generated in the BATCH configuration dialog within 
the context of the batch types ("Generate" button) from the 
TAG_COLL/TAG_COLLECT blocks. 

Using the TAG_COLL BATCH Interface Block 

When using BATCH interface blocks, the TAG_COLL block is used to collect 
process values to form transition conditions and for archiving and logging 
measured values: Description -> refer to section Rules for the TAG_COLL 
Interface Block), The process tag types that are then generated can be further 
processed and modified in the BATCH configuration dialog. 

Using the TAG_COLLECT Function Block 

If you configure with SFC types it is advisable to configure a TAG_COLLECT 
standard function block to collect process values. The process tag types that are 
then generated are read-only in the BATCH configuration dialog. Modifications to 
the process tag type can only be made in the function block. These are then 
adopted in any existing instances. After modification, the Batch types and therefore 
also the process tag types must be generated again. 

 

 Note: 

Points to note:  

• To allow a TAG_COLLECT FB/FC type to be read into the BATCH 
configuration dialog (generated) for the process cell, an instance of the 
TAG_COLLECT must have been created at least once in the CFC chart.  

• FB types are unique only within an S7 program or a CPU. For Batch 
configuration, however, the uniqueness throughout the entire project or the 
multiproject must be guaranteed. 
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There are two ways of creating process tag types: 

• Method 1: A new FB is created directly. 

• Method 2: A new CFC chart is created and then compiled as a block. 

Method 1: To create process tag types directly as FB types TAG_COLLECT  

1. In the component view of the SIMATIC Manager, create a new function block 
in an S7 program or a block folder by selecting the menu command Insert > 
Insert New Object > Function Block. 

2. Select the function block and select the menu command Edit > Open Object. 

3. Here, you can edit all the values that will be collected as measured values as 
input parameters.  

 

 Note: 

Use only the data types permitted with SIMATIC BATCH: 

Bool, Int, Dint, Real and String 

 

4. If required, assign the parameters the following attributes "S7_measval = true" 
for archiving or "S7_check = true" for checking and "S7_unit = unit of measure" 
(unit of measure is the name of the unit of measure). 

5. Select the function block and select the menu command Edit > Object 
Properties. 

6. Assign a symbolic name to the FB. 

7. Go to the "Attributes" tab in the open properties dialog of the function block. 

8. Here, set the attribute "S7_tagcollect" (process tags) to "true". 
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9. Accept the attributes with "OK". 

10. Open the CFC chart and insert the function block from the "S7 Program" folder 
into a CFC chart. 

  Result: The FB type TAG_COLLECT appears in the "Other Blocks" library or the family 
assigned to the FB (for example Batch) and can be used immediately for configuring further 
process tag types. 

 

 Note: 

The FB type TAG_COLLECT must be stored in the library, for example "Other 
Blocks" so that the measuring point types created in this way can be generated in 
the BATCH configuration dialog. 

 

11. Open the BATCH configuration dialog with the Options > SIMATIC BATCH 
menu command. 

12. Select the "Batch types" object in the left window. 

13. Click the "Generate" button in the right-hand area.  

14. Result: The new process tags that you have defined along with the set values 
(input parameters) are read in and displayed (read only). 

15. Confirm all settings with OK. 
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Result: These process tag types are available for use as process cell references in 
the transitions during recipe creation. If the "S7_measval" attribute was set for the 
parameters and the interconnection to the WinCC archive was established for the 
"Process variables" assigned to the process cells, these can be used in the 
"Process tags" tab for batch logging during recipe creation.  

 

 Note: 

The outputs of the standard blocks interconnected with the inputs of a 
TAG_COLLECT function block must all have the attribute "S7_m_c = true" set. 

 

Method 2: To create process tags using a CFC chart  

1. In the component view of the SIMATIC Manager, create a new CFC chart 
below a chart folder by selecting the menu command Insert > Insert New 
Object > CFC. 

2. Select the CFC chart and select the menu command Edit > Open Object. 

3. Open the I/O table with View > Chart I/Os. 

4. Here, you can edit all the values that will be collected as measured values as 
input parameters under IN.  

5. If required, assign the parameters the following attributes "S7_measval = true" 
for archiving or "S7_check = true" for checking,  and "S7_unit = unit of 
measure" (unit of measure is the name of the unit of measure) (in the 
"Properties - Variable" dialog box for the parameter: This is selected with the 
right mouse button and context-sensitive command Object Properties): 
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6. Confirm the settings with OK. 

7. Select the menu command Chart > Compile > Chart as Block Type. 

8. Specify the following in the "General" tab: FB name, symbolic name, and the 
family (for example BATCH) 

9. Change to the "Attribute" tab. 

10. Here, set the attribute "S7_tagcollect" (process tags) to "true". 
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11. Accept the setting with "OK". 

Result: The FB/FC type TAG_COLLECT you have created can be used 
immediately for configuring other process tag types. The procedure from now on is 
exactly the same as in Method 1 starting at Step 9. 
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4.12 Specifying the Type Description of the Process Cell 

4.12.1 Type Description of the Process Cell 

Introduction 

As the basis for creating recipes in SIMATIC BATCH, the type description of the 
process cell must be edited or generated and, where necessary, synchronized with 
the block instances of the CFC charts. The following types can be defined for 
creating recipes. 

Type Description of a Process Cell 

 
Type Editing Options and Results 

Data types The system specifies the standard data types floating point number, 
integer, string, input material, output material, material (V4), and 
Boolean.  

You can also create your own data types and modify their 
properties. 

Units of measure You can create new units of measure and change their properties. 

Unit classes You can create new unit classes and change their properties. 

Operation types,  
phase types and 
process tag types 

To allow recipe creation purely on the basis of types, types must be 
specified without the block instances for them existing. 

• Operation types: Type information for the equipment operations 
(EOP) 

• Phase types: Type information for the equipment phases (EPH) 

• Measured variable types: Type information of the TAG_Coll 
blocks  

Operation types and phase types can be assigned control strategy 
parameters. 

Configuring the Type Description 

The type description is configured in the SIMATIC Manager in the BATCH 
configuration dialog. How this is done depends on: 

• whether single or multiproject engineering is involved 

• whether you are using SFC types or BATCH interface blocks 
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4.12.2 Type Description in a Single Project 

Configuring the Type Description 

You configure the type description in the BATCH configuration dialog. You can 
open this dialog in the component view and in the plant view: 

• using the menu command Options > SIMATIC BATCH 

• by selecting any object and then the context menu command SIMATIC BATCH 

BATCH configuration dialog 

For the type description, the "Batch types" object must be selected on the left-hand 
side in the  BATCH configuration dialog.By expanding the object (click on "+"), you 
will see all the possible Batch type objects. The attributes of a type object are 
displayed on the right-hand side of the dialog under "Properties".  
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4.12.3 Executable Functions in a Single Project 

Functions Available in the BATCH Configuration Dialog 

 
Function Selected Object Description 

Generate Batch Types • SFC types: Operation/phase types are generated from the 
SFC types with the EOP/EPH IDs. 

• BATCH interface blocks: Batch types (units of measure, 
operation/phase types, process tag types) are generated from 
the instances of the BATCH interface blocks. 

Note: If Batch instances, SFC types or TAGCOLLECT FBs are 
modified, the "Generate" function must be run prior to compilation. 
The same applies to modifications in the PH, for example after 
moving or copying CFC charts. 

Synchronize Batch Types If, for example, IDs of units of measure, phase, operation, or 
process tag types, identifiers of type parameters etc. are modified 
in the BATCH configuration dialog, these changes are propagated 
to the individual instances in the CFC charts using the 
"Synchronize" function.  

If this button is not used explicitly, there is an automatic 
synchronization (following an operator prompt for confirmation) 
when you close the BATCH configuration dialog. 

This function ensures that the entire process cell remains 
validated following changes to types. 

New Data types 

User data type (if 
present) 

Units of measure 

Unit classes 

Phase types 

Operation types 

Process tag types 

Creation of new data types, user data types, units of measure, unit 
classes, phase, operation, and process tag types under the 
selected area and creation of the corresponding type parameters. 

Delete Data type 

User data type (if 
present) 

Units of measure 

Unit classes 

Phase types 

Operation types 

Process tag types 

Deletion of a selected Batch type or the corresponding type 
parameter. 

If type objects are inadvertently deleted, the action can be undone 
by closing the BATCH configuration dialog with "Cancel". 

Type objects that are in use cannot be deleted, for example units 
of measure, phase types etc. 

Edit User data type (if 
present) 

Units of measure 

Unit classes 

Phase types 

Operation types 

Process tag types 

Editing the attributes of the Batch types and type parameters 

Exception: SFC types and process tag types 

You will find a description of editing SFC types and process tag 
types in the section "Creating a New SFC Type". 
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Function Selected Object Description 

Additional  
functions 

• Copy 

• Paste 

• Import 

Batch Types • Copy: 
Copying Batch types to a library or another project 

• Paste 
Pasting Batch types from a library or from another project 

• Import 
Importing Batch types generated with the BATCH Migrator 
(BFMIG) from the V4.02 database. 

Additional 
functions 

• Display 

User data type (if 
present) 

Units of measure 

Unit classes 

Phase types 

Operation types 

Process tag types 

List of all instances that refer to this type object. Certain attributes 
can be selected using a filter. 

Log Batch Types Display of the logs of the executed functions "Generate" and 
"Synchronize" ("Synchronize" function is in preparation) 

First select executed function in the combo box and then click the 
"Display" button. 
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4.12.4 Type Description in a Multiproject 

Configuring the Type Description 

In a multiproject, the type description is configured only in the multiproject itself.  

The Batch types cannot be modified in any of the projects booked into the 
multiproject; in other words, no Batch types can be edited or added. 

If a project is booked out of the multiproject, you can specify whether or not the 
Batch types can then be modified in this project.  This applies to current Batch 
types and every project of the multiproject (activate the editing option). This allows 
you to adapt your own Batch types to those of the multiproject in every project; in 
other words, to update them.  

 

 Note: 

All projects in the multiproject have the same rights and priorities. 

At any one time, only one project can be booked out of a multiproject so that the 
Batch types can be edited. 

 

You configure the type description in the BATCH configuration dialog. You can 
open this dialog in the component view and in the plant view: 

• using the menu command Options > SIMATIC BATCH 

• by selecting the multiproject and then the context menu command SIMATIC 
BATCH 
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BATCH configuration dialog 

For the type description, the "Batch types" object must be selected on the left-hand 
side in the  BATCH configuration dialog. By expanding the object (click on "+"), you 
will see all the possible Batch type objects. The attributes of a type object are 
displayed on the right-hand side of the dialog under "Properties".  
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4.12.5 Executable Functions in a Multiproject 

Functions Available in the BATCH Configuration Dialog 

 
Function Selected Object Description 

Generate Batch Types • SFC types: Operation/phase types are generated from the 
SFC types with the EOP/EPH IDs. 

• BATCH interface blocks: Batch types (units of measure, 
operation/phase types, process tag types) are generated from 
the instances of the BATCH interface blocks. 

• In multiproject engineering, this command generates the 
batch types from the SFC types or BATCH interface blocks of 
all projects of the multiproject. 

Note: If Batch instances, SFC types or TAGCOLLECT FBs are 
modified, the "Generate" function must be run prior to compilation. 
The same applies to modifications in the PH, for example after 
moving or copying CFC charts. 

Propagate Batch Types The complete type description is distributed to the individual 
projects of the multiproject.  

After executing this function, you can select the projects to be 
involved in the propagation of the Batch types in a dialog box. The 
type descriptions of all selected projects are then consistent. 

Synchronize Batch Types If, for example, IDs of units of measure, phase, operation, or 
process tag types, identifiers of type parameters etc. are modified 
in the BATCH configuration dialog, these changes are propagated 
to the individual instances in the CFC charts using the 
"Synchronize" function.  

If this button is not used explicitly, there is an automatic 
synchronization (following an operator prompt for confirmation) 
when you close the BATCH configuration dialog. 

This function ensures that the entire process cell remains 
validated following changes to types. 

New Data types 

User data type (if 
present) 

Units of measure 

Unit classes 

Phase types 

Operation types 

Process tag types 

Creation of new data types, user data types, units of measure, unit 
classes, phase, operation, and process tag types under the 
selected area and creation of the corresponding type parameters. 

Delete Data type 

User data type (if 
present) 

Units of measure 

Unit classes 

Phase types 

Operation types 

Process tag types 

Deletion of a selected Batch type or the corresponding type 
parameter. 

If type objects are inadvertently deleted, the action can be undone 
by closing the BATCH configuration dialog with "Cancel". 

Type objects that are in use cannot be deleted, for example units 
of measure, phase types etc. 
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Function Selected Object Description 

Edit User data type (if 
present) 

Units of measure 

Unit classes 

Phase types 

Operation types 

Process tag types 

Editing the attributes of the Batch types and type parameters 

Exception: SFC types and process tag types 

You will find a description of editing SFC types and process tag 
types in the section "Creating a New SFC Type". 

Additional 
functions 

• Copy 

• Paste 

• Import 

Batch Types • Copy: 
Copying Batch types to a library or another project 

• Paste 
Pasting Batch types from a library or from another project 

• Import 
Importing Batch types generated with the BATCH Migrator 
(BFMIG) from the V4.02 database. 

Additional 
functions 

• Display 

User data type (if 
present) 

Units of measure 

Unit classes 

Phase types 

Operation types 

Process tag types 

List of all instances that refer to this type object. Certain attributes 
can be selected using a filter. 

Log Batch Types Display of the logs of the executed functions "Generate", 
"Propagate", and "Synchronize" ("Synchronize" function is in 
preparation) 

First select executed function in the combo box and then click the 
"Display" button. 
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4.12.6 Executable Functions in a Project of a Multiproject 

Functions Available in the BATCH Configuration Dialog 

 
Function Selected Object Description 

Additional 
functions 

• Display 

User data type (if 
present) 

Units of measure 

Unit classes 

Phase types 

Operation types 

Process tag types 

List of all instances that refer to this type object. Certain attributes 
can be selected using a filter. 

Log Batch Types Display of the logs of the executed functions "Generate" and 
"Synchronize" ("Synchronize" function is in preparation) 

First select executed function in the combo box and then click the 
"Display" button. 

Update Batch Types Updating of the Batch types in this project (reading in the Batch 
types of the multiproject) 
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4.12.7 Executable Functions in a Booked-out Project 

Functions in the Booked-out Project with Editable Batch Types 

 
Function Selected Object Description 

Generate Batch Types • SFC types: Operation/phase types are generated from the 
SFC types with the EOP/EPH IDs. 

• BATCH interface blocks: Batch types (units of measure, 
operation/phase types, process tag types) are generated from 
the instances of the BATCH interface blocks. 

• This command generates the batch types from the SFC types 
or BATCH interface blocks of the booked out project. 

Note: If Batch instances, SFC types or TAGCOLLECT FBs are 
modified, the "Generate" function must be run prior to compilation. 
The same applies to modifications in the PH, for example after 
moving or copying CFC charts. 

New Data types 

User data type (if 
present) 

Units of measure 

Unit classes 

Phase types 

Operation types 

Process tag types 

Creation of new data types, user data types, units of measure, unit 
classes, phase, operation, and process tag types under the 
selected area and creation of the corresponding type parameters. 

Delete Data type 

User data type (if 
present) 

Units of measure 

Unit classes 

Phase types 

Operation types 

Process tag types 

Deletion of a selected Batch type or the corresponding type 
parameter. 

If type objects are inadvertently deleted, the action can be undone 
by closing the BATCH configuration dialog with "Cancel". 

Type objects that are in use cannot be deleted, for example units 
of measure, phase types etc. 

Edit User data type (if 
present) 

Units of measure 

Unit classes 

Phase types 

Operation types 

Process tag types 

Editing the attributes of the Batch types and type parameters 

Exception: SFC types and process tag types 

You will find a description of editing SFC types and process tag 
types in the section "Creating a New SFC Type". 

Additional 
functions 

• Copy 

• Paste 

• Import 

Batch Types • Copy: 
Copying Batch types to a library or another project 

• Paste 
Pasting Batch types from a library or from another project 

• Import 
Importing Batch types generated with the BATCH Migrator 
(BFMIG) from the V4.02 database. 
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Function Selected Object Description 

Additional 
functions 

• Display 

User data type (if 
present) 

Units of measure 

Unit classes 

Phase types 

Operation types 

Process tag types 

List of all instances that refer to this type object. Certain attributes 
can be selected using a filter. 

Log Batch Types Display of the logs of the executed functions "Generate" 

First select executed function in the combo box and then click the 
"Display" button. 

 

Functions in the Booked-out Project with Read-only Batch Types 

 
Function Selected Object Description 

Additional 
functions 

• Copy 

Batch Types Copying Batch types to a library or another project 

Additional 
functions 

• Display 

User data type (if 
present) 

Units of measure 

Unit classes 

Phase types 

Operation types 

Process tag types 

List of all instances that refer to this type object. Certain attributes 
can be selected using a filter. 
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4.12.8 Specifying the Control Strategies for a Type 

Introduction 

Different and (in terms of the same run) mutually exclusive equipment 
phases/operations of the same equipment module are known as control strategies 
of this equipment module. 

Recipe phases/operations can be implemented with various control strategies (set 
of setpoints) that can be used in the manual mode or in the automatic mode (recipe 
mode). To be able to use the control strategies in the automatic mode, the recipe 
phases/operations must also be capable of the control strategies. The control 
strategies and their corresponding setpoint parameters are configured in the 
engineering system in the batch or SFC types.In the Recipe Editor, the control 
strategies defined in this way are available as a set of setpoints with a control 
strategy name. During parameter assignment in the recipe, only the parameters 
belonging to the control strategy are available. 

Basic Procedure 

• Using an SFC type: When you configure the SFC type, you can also specify 
the control strategy type to be valid for this equipment phase/operation using 
the characteristics function. In addition to this, the amount of parameters can 
also be put together based on the setpoints for each control strategy. 

• Using BATCH interface blocks: New control strategies are specified using new 
user data types ("Control Strategy" was selected in Properties) and assigning 
them as the data type for the control strategy parameter of operation 
types/phase types in the "Edit Batch process cell" dialog box. 

The control strategies and control strategy parameters are included in the process 
cell data when you compile and are therefore available later in the BATCH Recipe 
Editor. 

Follow the steps outlined below in SFC (SFC types) 

1. Mark the new object "SFC Type": . 

2. Select the menu command Edit > Open Object. 

SFC opens the SFC type. 

3. Change to the characteristics view of SFC Select the menu command Edit  > 

Characteristics or press . 

  The characteristics view of the SFC type opens. 
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4. Here, you edit all the control strategies relevant for SIMATIC BATCH by 
clicking on the "Control strategy" characteristic in the left column. 

5. Select a setpoint in the characteristics view to which one or more control 
strategies will be assigned. 

6. Select the menu command Edit > Object Properties. 

7. The properties dialog of the setpoint opens. 

8. Using the  button, assign the required (already created) control 
strategies in which the setpoint is located. 

9. Confirm with the "Close" button. 

Result: After reading in the type description in the BATCH configuration dialog with 
the "Generate" button, the control strategies you have edited in this way (read-only) 

are indicated by a red flag:  
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Follow the steps outlined below in the SIMATIC Manager (BATCH interface 
blocks) 

1. Open the BATCH configuration dialog with the with the menu command 
Options > SIMATIC BATCH. 

2. Define the control strategies using a new user data type, for example FW_heat 
(values: hot, normal, cold) Select the "Data types" object under "Batch types" 
and then click the "New" button. 

3. Result: A new control strategy is created. 

4. For operation/phase type, create a new parameter (for example fw_param). 
Select the required "Phase type" under "Phase types" in the left-hand window 
and then click the "New" button. 

5. Result: A new type parameter is created. 

6. Assign the correct control strategy (for example FW_Heat) on the right-hand 
side in the "Assigned data type" list box. 

7. Activate the "Control strategy parameters" check box. Click the "Edit" button to 
the right of the "Control strategy parameters" check box. Assign the setpoints 
(parameter data record) to every control strategy in the open properties dialog 
for the control strategies "Control Strategies of FW_heat". 

8. Close the Properties dialog with OK. 

Result: The new control strategy appears in the BATCH configuration dialog with 
the following icon:  

 

 Note: 

Only one control strategy parameter (in the example: fw_param) can be created 
per operation/phase type. 
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4.12.9 Propagating a Type Description to other Projects (Multiproject) 

To allow batch configuration in the individual projects of the multiproject and to 
compile unit data with the latest type description, the type description generated 
centrally in the multiproject can be distributed (propagated) to the individual 
projects of the multiproject. 

Follow the steps outlined below in the SIMATIC Manager:  

1. Select the "Batch types" object in the BATCH configuration dialog. 

2. Click the "Propagate" button.  

3. Result: The "Propagate types for entire process cell" dialog box opens. 

4. Activate all the projects to be propagated. 

5. Click the "Start" button. 

Result: The complete type description is distributed to the projects of the 
multiproject. After running this function, the Batch types are consistent in all 
selected projects. 
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4.12.10 Managing Type Descriptions in a Library or Project 

Introduction 

The type descriptions for SIMATIC BATCH can also be stored and managed in a 
standard library. You can save editing time by storing type descriptions you want to 
use again in a library.  

Principle 

The type description of a process cell can also be created and configured as an 
object  in a library: 

Using the "Copy" additional function in the BATCH configuration dialog within the 
context of Batch types, existing Batch types can be copied to a library or a project. 
You can also create a new "Batch types" object in a library.  

Using the "Paste" additional function in the BATCH configuration dialog within the 
context of Batch types, existing Batch types can be pasted from a library or a 
project. 

To insert an edited type description: 

1. Open the project with the existing Batch types. 

2. Select the menu command Options > SIMATIC BATCH. 

3. Select the "Batch types" object in the left window. 

4. Click the "Copy" button.  

5. Result: A dialog box opens in which you can select the required targets (library 
or project). 

6. Make your selection and confirm with OK. 

To create a new type description: 

1. Open the library or create a new library. 

2. Select the menu command Insert > Insert New Object > Batch Types. 

Result: A new object  is created.  
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4.13 Use of Archive Data from WinCC Archives 

4.13.1 Configuring Use of Archive Data from WinCC Archives 

Introduction 

The batch data also includes the values of important process variables over time. 
SIMATIC BATCH does not record these measured value sequences itself but 
fetches the values from the WinCC Measured Value Archives. To allow this, the 
instance parameters must be assigned to the WinCC archive tags. 

Requirement 

You have selected the "Archive measured variable" option for the parameters of 
the operation, phase, all process tag types that you intend to use as the measured 
value sequence: 

• When using BATCH interface blocks: Specified in the BATCH configuration 
dialog with the "Batch types" object. 

• When using SFC types: The "Archive" column of the characteristics for the 
setpoint is activated for the SFC type. 

Basic Procedure 

In the BATCH configuration dialog, the additional function "Instances -> Display" 
can be activated for the selected type parameter. All the instant parameters having 
a reference to this type parameter are displayed. In the next dialog, you can open 
the WinCC tag browser for each instance parameter in which the required WinCC 
archive tag can be assigned. 

Follow the steps outlined below in the SIMATIC Manager:  

1. Select the required type parameter in the BATCH configuration dialog. 

2. Click the "Display" button in the right-hand area. 

3. Result: The "Instances that use the <Name> type parameter" dialog box 
opens. 

4. Click on the row on the right-hand side and then once again on the arrow that 
appears. 

5. Result: The "WinCC archive tag for <Name>" dialog box opens. This displays 
all the operator stations and the archive tags. 

6. Display the individual hierarchies in the WinCC tag browser. 

7. Select the required WinCC archived tag. 

8. Click the "Apply" button. 
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4.14 Compiling the OS 

Introduction 

SIMATIC BATCH communicates with the programmable controller via the defined 
OS (message OS). As a result, on completion of configuration and following every 
change to the Batch process cell data, the OS must be compiled. This downloads 
all the Batch objects as WinCC tags to the appropriate OS. Only after compiling the 
OS is it possible to generate the correct full runtime name when generating the 
Batch process cell data. Before downloading the batch process cell data, the 
WinCC projects must first be downloaded. 

Follow the steps outlined below in the SIMATIC Manager:  

1. Select the menu commandOptions > OS > Compile. 

2. Make the entries in the subsequent dialogs as you would in standard PCS 7. 
There are no specific SIMATIC BATCH settings necessary. 

 

 Note: 

When using SIMATIC BATCH an S7 program can be assigned to only one batch-
relevant OS! 
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4.15 Compiling and Downloading Process Cell Data 

4.15.1 How to Compile and Download the Process Cell Data 

Basic Procedure 

SIMATIC  Manager

Compile the Batch process cell data
• On all ES computers with the individual

projects of the multiproject or
• On the central ES computer by merging and

compiling the multiproject

• Specify message OS and Batch-relevant
operator stations

• Transfer messages and Batch-relevant data
to the operator stations

Download WinCC projects
(1st target system OS)

Download Batch process cell data
(2nd target system BATCH server,

BATCH server Stby and BATCH clients)

Compile OS
(see "Compiling the OS")

 

Compiling Unit Data 

To allow SIMATIC BATCH to use the process cell data, this must be created 
(compiled) explicitly. After completing configuration of all the process cell data and 
following any change to the process cell data, these must be recompiled before 
downloading. 

You compile the process cell data using the "Compile" function. During this 
process, the process cell data are compiled and validated. Any possible errors are 
displayed and entered in a test log. If the data is not valid, it will not be compiled. 
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Specifying the Batch-Relevant Operator Stations, the Message and Transferring 
OS-Relevant Data to the OS 

In many Batch process cells, process automation is not exclusively recipe-
controlled. In other words, it is perfectly possible that there is one or more OS 
servers in the process cell that do not have any batch-relevant data. This means 
that the batch-relevant operator stations must be specified for SIMATIC BATCH. 
To achieve an optimum load distribution, you can select a message OS to which 
SIMATIC BATCH sends its messages. 

• Specifying Batch-Relevant Operator Stations 

You must specify the operator stations of the project that are relevant for SIMATIC 
BATCH. In other words, you specify the OS in which BATCH blocks 
(UNIT_BLOCK, EOP/EPH, IEOP/IEPH) are accessed using faceplates.  

• Specifying the Message OS 

You must select a suitable OS to which SIMATIC BATCH sends its messages. The 
message OS is also the communication OS for the BATCH server. 

• Transferring OS-Relevant Data to the OS 

The message texts of all BATCH messages and all OS-relevant data from 
SIMATIC BATCH are transferred automatically to the selected operator stations by 
the "Transfer to OS" function. 

Downloading WinCC Projects 

WinCC projects continue to be transferred to the operator stations independently of 
SIMATIC BATCH using the "PLC Download" function. The downloading of process 
cell data to the BATCH Server and BATCH clients is unaffected. You must, 
however, make sure that the WinCC projects are downloaded before you start the 
batch downloads 

Downloading Batch Process Cell Data 

After compiling the process cell data successfully, it is transferred to the BATCH 
Server, DB server and the BATCH clients. The process cell data is downloaded 
automatically using the "PLC Download" function. 

Reading in Batch Process Cell Data 

To ensure controlled copying of the process cell data to the batch system, this 
requires an explicit operator command. This can be entered at any BATCH client 
within BatchCC. There is an internal comparison and synchronization of the new 
with the old process cell data.  
For more information about reading in the process cell data, refer to the section 
"BatchCC". 
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4.15.2 Compiling the Batch Process Cell Data in Single-Project 
Engineering 

Introduction 

The process cell data is compiled by the "Compile" function in the BATCH 
configuration dialog. At the same time, the process cell data are checked for 
plausibility. Any possible errors are displayed and entered in a test log. If the data 
is not valid, it will not be compiled. 

Follow the steps outlined below in the SIMATIC Manager:  

1. Open the BATCH configuration dialog with the with the menu command 
Options > SIMATIC BATCH. 

2. Select the "Batch instances" folder under process cell data in the left window. 

3. Click the "Compile" button in the right-hand area. 

Result: If the validation is successful, the process cell data is compiled. A log is 
created that you can display as follows: 
In the BATCH configuration dialog: under Log >: "Compile" setting > "Display" 
button 

4. Select the process cell object under process cell data in the left window. 

5. Click the "Transfer to OS" button in the right-hand area. 

Result: A dialog opens with all operator stations of the project that were 
defined as Batch-relevant when the settings were made in the "OS objects" 
tab. In the "Status" column, you will see the current status displayed. Here, you 
can see whether or not the OS-relevant data has already been transferred.  

6. Click the "Start" button. 

Result: The messages and the OS-relevant data are transferred. A log is 
created that you can display as follows: 
In the BATCH configuration dialog: under Log >: "Transfer to OS" setting > 
"Display" button 
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4.15.3 Compiling the Process Cell Data in Multiproject Engineering 

Introduction 

The process cell data is compiled by the "Compile" function in the BATCH 
configuration dialog. At the same time, the process cell data are checked for 
plausibility. Any possible errors are displayed and entered in a test log. If the data 
is not valid, it will not be compiled. 

Follow the steps outlined below in the SIMATIC Manager: 

1. Open the BATCH configuration dialog with the with the menu command 
Options > SIMATIC BATCH. 

2. Select the "Batch instances" folder under process cell data in the left window. 

3. Click the "Merge" button in the right-hand area. 

Result: A dialog opens display all Batch-relevant projects. In this dialog, you can 
compile the Batch process cell data of all projects and then merge the data. 

4. Here, you select the projects whose process cell data will be included. 

With the central check boxes "Include" and "Compile" in the table header, all the 
settings for the individual projects are made automatically depending on the status. 
If, for example, the status for a project is "Types not up to date", the "Compile" 
check box is automatically selected as a result of including the project. 

   

 Note: 

Compilation is also possible in every individual project of the multiproject. 

 

   

 Note: 

If projects are booked out, the check boxes are inactive (gray). If process cell data 
compiled earlier for this project already exists, this data is also adopted. 

 

5. Click the "Start" button. 

6. Select the process cell object under process cell data in the left window of the 
BATCH configuration dialog. 

7. Click the "Transfer to OS" button in the right-hand area. 

Result: A dialog opens with all operator stations of all projects of the multiproject 
that were defined as Batch-relevant when the settings were made in the "OS 
objects" tab. 

8. Click the "Start" button. 

Result: All Batch-relevant data (messages and user data types) is downloaded to 
the appropriate operator stations. 
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Results:  

• If the validation is successful, the process cell data is compiled. A log is 
created that you can display as follows: 
In the BATCH configuration dialog: under Log >: "Merge" setting > "Display" 
button 

• The messages and the OS-relevant data are transferred. A log is created that 
you can display as follows: 
In the BATCH configuration dialog: under Log >: "Transfer to OS" setting > 
"Display" button 

Tip 

Do not forget to run the "Compile OS" function before compiling and downloading. 
This avoids the display of errors in the run-time names when you compile the 
process cell data. 
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4.15.4 Downloading the Process Cell Data to the Target System 

Introduction 

You download the process cell data to the BATCH Server, the DB server (data 
storage systems) and the BATCH clients using the "PLC -> Download" function. 

Order of the Downloads 

 

 Note: 

To ensure data consistency, the following order must be kept to when you 
download: 

• Download the OS server 

• Download the BATCH Server and BATCH clients 

 

Follow the steps outlined below in the SIMATIC Manager: 

1. Open the BATCH configuration dialog with the with the menu command 
Options > SIMATIC BATCH. 

2. Select the process cell object under process cell data in the left window. 

3. Click the "Download" button. 

  Result: In the "Download <process cell>" dialog box, all the PC stations for BATCH Servers 
(single, redundant), DP server and the BATCH clients are displayed along with their 
download status. 
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4. Click the "Start" button. 

Updating the Process Cell Data 

 

 Note: 

If you modify the basic control (CFC/SFC charts, hardware configuration, plant 
hierarchy etc.), the process cell data must be updated again and downloaded to 
the target system (BATCH Server, BATCH clients). 

Prior to this, the OS must first be compiled and downloaded. 
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4.15.5 Simultaneous Compilation and Download 

PCS 7 also provides a complete function "Compile and Download" for all PC 
stations (including operator stations) that can also be used for a batch process cell. 

Follow the steps outlined below in the SIMATIC Manager: 

1. In the component view or plant view, select the single project or multiproject 
and then select Target System > Compile and Download Objects in the 
context menu. 

The "Compile and Download Objects" dialog box opens.  

2. Select the "Process Cell" among the objects and then click the "Edit" button in 
the section "Settings for Compilation/Download". 

3. Make the following settings in the tabs: 

- In the multiproject in the "Merge/compile" tab: Here, select all projects to 
be included when generating the Batch process cell data. 

- In the single project/multiproject in the "Transfer" tab: Here, select the 
message OS and the Batch-relevant operator stations. 

- In the single project/multiproject in the "Download" tab: Here, select 
components to be downloaded (BATCH server, BATCH clients, DB server) 

4. Confirm with OK. 

In the "Compile" and "Download" columns of the "Compile and Downloads 
Objects" dialog box, specify the objects to be included in the compilation or 
download. 

5. Start the procedure with the "Start" button. 

 

 Note: 

In a multiproject, only the process cell below a project of the multiproject needs to 
be selected and the options "Compile" and "Download" only need to be specified 
for this project. 
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4.15.6 Working with Several Process Cell Projects 

Several Process Cells of Different S7 Projects 

With SIMATIC BATCH, it is also possible to generate BATCH Servers and BATCH 
clients in several S7 projects. It is, for example possible to run three S7 projects 
each with three PCS 7 operator stations and the save multiclient (with a BATCH 
client). The multiclient (with BATCH client) can communicate with the BATCH 
Server of each S7 project. 

The various process cell projects belonging to the S7 projects can be opened 
simultaneously by the BATCH client. In this case, the batch applications must be 
opened more than once. The display of several process cell projects within a batch 
application, for example within a BatchCC is, on the other hand, not possible. 

Working with Projects on one BATCH Server 

Different process cell projects can be run on one BATCH Server one after the 
other: Several projects can be loaded on the same BATCH Server PC. However, 
only one process cell project (in other words a BATCH Server) can be active at any 
one time. This is an advantage, for example when the "Correct" project and a test 
project need to be run separately without modifying the data of the other process 
cell project. 

By selecting the OS project (PCS 7 OS changes to runtime), a switchover is made 
on the BATCH Server PC. SIMATIC BATCH recognizes which process cell project 
belongs to which OS project. 

Switching Over the BATCH Client 

The assignment of the BATCH client <-> BATCH server is generally made during 
configuration in the engineering system. After reading in the process cell data, a 
BATCH client then operates with the process cell project of the corresponding 
BATCH Server. 

If there is information on more than one process cell project on the BATCH server, 
a selection dialog with all existing process cell projects is displayed on the BATCH 
client after selecting the menu command Program > Read in new process cell . 
By selecting a process cell project, you establish the connection to the BATCH 
Server (and therefore also to the required process cell project). 

One BATCH Server Per Project 

 

 Note: 

In the scenarios described above, the rule that there must be only one BATCH 
server per S7 project /multiproject still applies. 
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5 Batch Control Center (BatchCC) 

5.1 Starting and Working 

5.1.1 Starting BatchCC 

After you have installed SIMATIC BATCH, you will find the following components in 
the Start menu of Windows 2000 under Simatic > SIMATIC BATCH: 

• BATCH Control Center (simply called BatchCC from now on) 

• Recipe Editor (known as the BATCH Recipe Editor from now on) 

To start BatchCC: 

1. Go to the Start menu of Windows 2000 and select the menu command Start > 
Simatic > SIMATIC BATCH > BATCH Control Center. 

Result: If several local projects are found when you start BatchCC or if the link 
to the project cannot be established, a selection dialog appears. 

2. Select the project you require. 

Result: Once you have made a selection, BatchCC is started with the project 
selected. If you select a project that does not have a link, the application is 
closed. 

Language 

In both BatchCC and in the BATCH Recipe Editor, you can change languages 
using the menu command Options > Settings> "Languages" tab . 
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5.1.2 Getting Help 

Online Help 

There are various ways of getting online help:  

 
Call Type of Help 

Help menu Introductory information, description of the user interface, 
concrete instructions 

"Help" button or F1 key in a 
dialog box 

Context-sensitive help in every dialog box 

Selecting a menu command 
and pressing the F1 key 

Context-sensitive help for every menu command 

Screen Tips 

To display a brief text explaining the buttons in the toolbar, position the cursor on a 
button until the screen tip is displayed. 

Changing the Font Size 

With the menu command Options > Font in the help topic window, you can set the 
font size to "small", "normal" or "large. 

No help when starting from WinCC 

 

 Note: 

If the Batch Control Center or the BATCH Recipe Editor is started from WinCC, 
Help will not be available. 
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5.1.3 User Interface and Operation 

5.1.3.1 Layout of the Main Window 

The screen shot below shows the basic layout of the BatchCC user interface. On 
the left-hand side of the main window you will see the process cell as a tree 
structure. The mid section displays the batch objects in list form. On the right-hand 
side, you can create shortcuts. 

You can change the view with the View  menu in BatchCC. 

 

Overview lists depending 
on the context for 
• Library operations 
• Master recipes 
• Formulas 
• Production orders 
• Materials 
 

Editing window with Batch objects: 
• Libraries with library operations 
• Master recipes 
• Formula categories with formulas 
• Production orders 
• Input and output materials 
• Permission management 

Status bar 
with context-
sensitive 
information 

Title bar Menu bar Toolbar 
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Title Bar 

The title bar of the main window contains the system buttons with which you can: 

• exit BatchCC 

• minimize the main window to its icon, 

• restore the window to its normal size again, and 

• display the main window in full-screen size. 

Menu Bar 

The menu bar is located at the top edge of the main window. Its functions relate to 
the currently active window. You can only select menu commands that are feasible 
in the current status of the object. As an example, you can only select the menu 
command Edit > Delete when at least one object is selected. Menu items that 
cannot be selected are displayed in gray. 

Toolbar 

The toolbar is located below the menu bar. It contains a series of buttons that 
trigger the more commonly required functions of the menu bar. You can see which 
function is triggered by a button in the toolbar by positioning the mouse pointer on 
the button (without clicking). A box appears with the name of the button. In the 
status bar, you can see more detailed information about the function. Clicking the 
button triggers the function. Buttons that cannot be selected are displayed in gray. 

Status Bar 

At the lower edge of the user interface, you will see the status bar that displays 
important information and states. The information displayed changes depending on 
the particular operation and object status. 

 In the left part of the status bar, you will see context-sensitive information, for 
example explanations of menu commands, operator prompts or error messages. 

 In the right part of the status bar, you can see the current user and the current 
time. The connection status to the BATCH Control Server is also displayed here: 

• Online (there is a connection to the BATCH Control Server) 

• Offline (there is no connection to the BATCH Control Server). 

In some situations, a progress bar is also displayed for processes that require 
longer. 
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5.1.3.2 Creating and Manipulating Objects 

Selecting Functions 

All important functions relating to an object are available in the context-sensitive 
menu.  

As an alternative, the same functions are also available in the Edit  menu. 
Functions that cannot be executed in the current status of an object are 
deactivated (displayed in gray) in the Edit menu. 

Edit
menu

Context-sensitive
menu for the
object
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General Functions 

Some basic functions are common to all objects. These common functions are 
listed below. The descriptions of other functions assume that you know how to use 
these functions. 

The normal sequence of activities involving objects is as follows: 

• Creating the object 

• Selecting the object 

• Performing actions with the object (for example, open, delete). 

Creating Objects 

To create a new object, select the destination of the object in the editing window of 
the BATCH object window (for example the "Formulas" folder if you want to create 
a new formula category). To start the function, you then select the menu command 
Edit > New. 

Opening Objects 

There are several ways of opening an object: 

• Double or single click on the object icon 

• Select the object and then the menu command Edit > Open. This functions 
only with objects that are not folders, for example master recipes. 

After opening an object, you can create or modify its content.  

Properties of Objects 

Object properties are data belonging to the object that decide its behavior, for 
example the properties of a master recipe.  

The menu command Edit > Properties opens a dialog box in which you can see 
and set the properties of the selected object.  

Renaming Objects  

The names of batch objects are specified when the objects are created. This name 
can be changed by selecting the Rename command. 

The Rename command is not always available. For example with materials, 
qualities, or neutral folders, it is only possible to rename in the corresponding 
"Properties" dialog box. 
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Deleting Objects 

You can delete both folders and objects. It is only possible to delete most folders 
when they contain no elements. Exception: Orders - If an order only contains 
batches that can be deleted, the command is available for the order and you will be 
informed that n batches will also be deleted. 

Deleting is permanent and cannot be undone. If you are not sure whether or not 
you still need an object, it is advisable to archive the entire project before deleting. 

5.1.3.3 System Settings 

You can change the system settings for the BatchCC and the BATCH Recipe 
Editor in tabs. The system settings contain general selections and rules about the 
layout, dimensions, zoom, colors and fonts of the recipe elements. You can also 
specify the display of messages during the batch process, the display of measured 
values in the batch report, and the option for online modification of setpoints. 

To display the system settings dialog: 

• Select the menu command Options > Settings.  

This opens the dialog box shown below in which you can make individual settings. 
Use the context-sensitive help if you want more information about the possible 
settings ("Help" button). 
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5.1.3.4 Overviews 

The Purpose of Overviews 

Overviews are available in BatchCC both for greater clarity and to simplify the 
management of functions. 

Which Overviews are Available? 

Depending on the context, you can display the following overviews: 

• Library overview 

• Master recipe overview 

• Formula overview 

• Job overview lists 

• Batch overview lists 

• Material overview lists 

To select overviews: 

Select a folder in the editing window (for example a master recipe folder) and then 
select the menu command Edit > Details. 

Example 
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Working with Overviews 

By selecting an object from the list and then clicking the right mouse button, you 
display the context-sensitive menu with the functions available for the object. 

If you left-click a column header in the table, the content of the table is sorted 
alphabetically according to the content of the selected column. 

By entering a text in the input field below the column header, you can filter the 
table.  

You can also filter several columns at the same time. The individual filter conditions 
are then ANDed. This means that all the conditions entered must be satisfied 
before a list object appears in the table. If, for example, you enter the text "Wa" in 
the input field of the "Main Product" column, only the entries whose main product 
start with the letters "Wa" appear in the table. 

Anchoring overview lists. 

If you click the title bar with the right mouse button, a context-sensitive menu is 
opened with various options for anchoring the overview. 

Lists for batch planning, batch control, and batch data management 

There are more lists and special lists for orders and batches as listed below: 

 
List Description 

Order category list List with all order categories of the process cell. 

Before you select this, you must select the "Orders" folder in BatchCC. 

Production order list List with production orders: 

• If you had previously selected the "Order" folder, all production orders 
are displayed. 

• If you had previously selected an "order category" folder, only the 
production orders belonging to this category are displayed. 

Batch planning list List with all batches that are planned or released. Using the context-
sensitive menu for the batch planning list, you can control or start the 
batches. 

Note: The batch planning list normally displays only the planned or released 
batches. If you start a batch from this list, it remains visible in the list and is 
shown with its new status (for example, running). If you open the batch 
planning list again, however, this batch is no longer displayed (see batch 
status list). 

Batch Status List List with all batches with the released, running, held, waiting for unit, or error 
status. The display is updated dynamically. Using the context-sensitive 
menu for the batch status list, you can control the batches. 

Batch Result List List with all, completed, aborted, and canceled batches. The display is 
updated dynamically. Using the context-sensitive menu for the batch result 
list, you can archive closed batches and then remove them. 
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To select lists: 

Depending on the selection in the order hierarchy (an order, an order category, or 
all orders), you can open different batch overview lists with all batches of an order, 
of an order category, or all orders.  

Select the object in the "Orders" folder in the editing window and then select the 
required list in the Planning menu. 

Select All 

With CRTL+A or the menu command Edit > Select All you can select  all the 
objects of a list, for example, to release all batches using the context-sensitive 
menu. 

5.1.3.5 Window for Displaying Messages 

Requirement 

A PCS 7 OS (WinCC) runs on the BATCH client computer during run time. 

Display window 

All the messages for batch control (system messages, process messages, error 
messages) that are managed in the WinCC archives can also be displayed in 
BatchCC.  

To display these messages, you can open the message window of the PCS 7 OS 
(WinCC Alarm Control) in a separate display window.  

• You open the message window with the menu command View > Message 
window. 
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Customizing 

• You can customize the properties of the message window (familiar from 
WinCC), for example the columns displayed and the selection of messages. 

• User settings are entered in the global database and restored the next time 
you start BatchCC. Certain settings that are essential for SIMATIC BATCH are 
exceptions to this, for example selection of BATCH messages. 

• Using the Open control recipe menu command, the control recipe that 
matches the message can be opened. This function corresponds to the 
"LoopInAlarm" function in the WinCC message window. 

5.1.3.6 Logbook  

To document all deletions, you can display these in a logbook in BatchCC. 

To open the logbook in BatchCC: 

•  Select the menu command Options > Log. 

This function opens the dialog box shown below in which you can search for 
specific delete actions according to filter criteria. Enter the name, type, date range, 
user, and path and then click the "Filter" button. 

The current "Time window" is displayed on the right-hand side of the window. The 
zoom of the time window is automatically adapted to the required area of the 
applications and objects to be displayed. If you move the cursor over the time bar, 
a tooltip is displayed showing the time at which it was opened. 
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5.1.3.7 Window for Displaying Active Applications 

To check the active batch applications on the individual computers, you can display 
the applications in BatchCC. 

To open the display window with the active applications: 

• Select the menu command Options > Active applications. 

This function opens a dialog box with the currently active applications. You can see 
the duration and date/time at which the individual batch applications were in 
operation or are still in operation on computer x. The logged in users are also 
displayed.  
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5.1.4 Objects and Object Hierarchy 

The object hierarchy for library operations, master recipes, formulas and 
production orders can be structured in BatchCC in much the same way as the 
folder structure of the Windows Explorer with folders and files. 

The screen shot below shows the appearance and typical positioning of these 
objects within BatchCC. 

 
Objects Positioning in BatchCC 

 

 

 

 

 

• Process Cell  
(Process cell 
objects) 

• Libraries with library 
operations  

• Master Recipes  

• Formulas  

• Production orders  

• Materials  

• Permission 
Management  

 

 

User-Defined Structure of Objects and Folders 

As default, the objects are at one level below the libraries, master recipes, 
formulas, production orders, and materials folders. 

 

 Note: 

To allow a more suitable structure and adaptation to your plant, you can also 
create a different, user-defined hierarchy structure for the BATCH objects in 
BatchCC. 

The highest level cannot be changed or freely defined. This applies to "process 
cell", "libraries", "master recipes", "formulas", "orders", "materials", and "permission 
management". 

The following description, however, is based on the structure shown in the figure 
above. 
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Showing References between BATCH Objects 

With the menu command View > Related objects in tree view, the references to 
the other batch objects and the configured unit allocations are displayed below the 
library operation, master recipe and formula objects. 

5.1.4.1 Libraries with Library Operations 

You can use libraries to store recipe elements created with the BATCH Recipe 
Editor that you require often in the master recipes. You can store and manage 
recipe operations (for hierarchical recipes) and substructures (for flat recipes) in 
libraries. In the following descriptions, recipe operations or substructures from 
libraries are called library operations or library substructures. 

 
Available Functions Position of the objects  

 

• Opening and Editing Recipes 

• Specifying the Properties of 
Master Recipes  

 

• Validating Recipes 

• Releasing Recipes for Testing  

• Releasing Recipes for 
Production  

 

• Status of the Recipes and 
Status Changes   

 

Library 

Library 
operations 
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5.1.4.2 Master Recipes 

In this area, you can store the recipe procedures created with the BATCH Recipe 
Editor according to the technological structure of your process cell. With the 
reference (can be set in a dialog box) to a formula category and ultimately to a 
concrete formula, you have a complete master recipe. There are both flat and 
hierarchical master recipes. If you have large numbers of master recipes, these 
can be stored in different folders (without semantics) to achieve a better structure. 

 
Available Functions Position of the objects  

 

• Creating a New Master Recipe  

• Opening and Editing Recipes  

• Specifying the Properties of 
Master Recipes  

• Interconnecting Master Recipe 
Header Parameters with an 
External Formula  

• Working with the Recipe 
Overview  

 

• Validating Recipes  

• Releasing Recipes for Testing  

• Releasing Recipes for 
Production  

 

• Status of the Recipes and 
Status Changes  

 

 

 

Master recipes 
folder 

Master recipes 
(recipe 
procedures + 
reference to 
formula 
category) 
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5.1.4.3 Formulas 

In this area, you create the formula categories with the formulas belonging to them 
according to the technological needs of your plant. If you have large numbers of 
formulas of a category, these can be stored in different folders (without semantics) 
to achieve a better structure. 

 
Available Functions Position of the objects  

 

• Creating a New Formula 
Category  

• Specifying the Properties of the 
Formula Category  

• Creating a New External 
Formula  

• Specifying the Formulas of the 
Master Recipes  

• Interconnecting Master Recipe 
Header Parameters with an 
External Formula  

• Working with the Formula 
Overview  

 

• Validating Formulas  

 

Formula category

Formulas
with
status
indicators
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5.1.4.4 Production orders 

In this area, you create the production order categories with the lower level 
production orders. You can create batches for a production order. You also make 
the settings for batch processing, for example the start mode. 

 
Available Functions Position of the objects  

 

• Creating a New Production 
Order 

• Specifying the Properties of a 
Production Order  

• Adding Batches to a Production 
Order  

• Specifying the properties of a 
batch (e.g. quantity)  

• Setting the Start Mode for Batch 
Processing 

• Displaying and Modifying Unit 
Allocation  

• Setting the Order of Batches  

• Displaying the Running Time of 
a Batch  

• Working with Overviews  

 

• Status of the Batches   

 

Order category

batch status indicator

Production
order with
3 batches
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5.1.4.5 Materials 

To be able to use input and output materials in recipes and formulas, these must 
first be entered in BatchCC. 

 
Available Functions 

• Defining Materials  

• Changing the Quality  

5.1.4.6 Permission management 

Permission management is set up by the system administrator. Here, you can 
specify the user permissions of the user roles for specific computers and for 
specific units for all the functions of BatchCC and the BATCH Recipe Editor. This is 
only possible if the SIMATIC Logon PCS 7 software is installed. Without this 
additional product, every user in SIMATIC BATCH has all permissions (comparable 
with a "Super user"). 

 
Available Functions 

• Specifying User Permissions  

• Changing User Permissions  

• Displaying User Permissions  
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5.2 Setting User Permissions 

5.2.1 Introduction to Permission Management 

SIMATIC BATCH supports the central user management SIMATIC Logon of  
PCS 7, which in turn is based on the mechanisms of the user management in 
Windows 2000. 

Basic Procedure 

• You define users and user groups (available on the particular Windows server) 
and define passwords centrally in Windows.  

• You can define user roles for SIMATIC BATCH and assign them to Windows 
user groups using the Software SIMATIC Logon software. 

• Within SIMATIC BATCH (BatchCC), you can make the following extra 
specifications: 

- User permissions for one user role (global) 

- Permitted user roles per computer (computer-specific) 

- Permitted user roles per unit (unit-specific) 

• The components of SIMATIC BATCH contained in PCS 7 are provided with the 
data of users as they log in from a central logon service and are informed of 
logon changes etc. 

User Roles for SIMATIC BATCH 

The following user roles and associated user permissions are set as default for 
SIMATIC BATCH. These can be extended with further roles using SIMATIC Logon. 

 
User role (default) User permissions (default) 

Automation engineer Reading in an updating process cell data 

Factory manager Can edit, modify and release recipes and create batches 

Emergency operator No permissions (must be configured) 

Operator Can block batches 

Shift manager Can modify recipes, create batches 

Super user All functions including permission management 
(administrators) 

Process engineer Can create and modify recipes 

Super user 

The system administrator of SIMATIC BATCH takes on the role of "Super user". 
The super user has all user permissions in SIMATIC BATCH and only the super 
user can make changes in the permission management. 
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5.2.2 Specifying User Permissions 

Requirements 

SIMATIC Logon is installed on every computer with a batch application. SIMATIC 
Logon consists of two components:  

• Simatic Logon Admin Tool 

• SIMATIC Logon Service 

Basic requirements for working with SIMATIC Logon: 

• It is obligatory that you create the following groups in Windows 2000:  
"Logon_Administrator" and "Extended_Logon_Administrator".  
Only users of one of these two groups can open the Roles management and 
define user roles in BatchCC via the menu command Options  > Roles 
management. 

Defining Windows and user groups 

1. Select the menu command Start > Settings > Control Panel > Administrative 
Tools > Dialog "Computer Management" > System > Local Users and Groups 
> Users/Groups. 

2. With Action > New User/New Group, create all users (with passwords) and 
user groups in the Windows network (Windows server). 

To define user roles for SIMATIC BATCH: 

1. Open BatchCC: The logon dialog for SIMATIC Logon Service is displayed. 

2. Here, enter the user name, password and domain of Windows user, who is a 
member of the "Logon Administrator" group and confirm your entery with OK. 

3. Launch the Roles management dialog in BatchCC with the menu command 
Options  >  Roles management. 

  The dialog box "SIMATIC Logon Service" is displayed: 

- You can create user roles for SIMATIC BATCH in the upper half of the 
dialog box and then assign Windows user groups/Windows users to these 
user roles. This way, Windows users in SIMATIC BATCH  will receive the 
assigned rights of BATCH user roles. 

- In the lower half of the dialog box, you can browse through Windows user 
groups/Windows users in the available computers and domains. You can 
assign Windows user groups/Windows users to BATCH user roles using 
Drag&Drop, for example. 

4. Create user roles for SIMATIC BATCH and connect the user roles to a 
Windows user group/a Windows user.  

  The user roles listed here can be used as a template for creating a new role. Each default 
user role has defined user permissions within SIMATIC BATCH. The user permissions are 
passed on to the new user role. 
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 Note: 

You will find detailed information the procedure in the SIMATIC Logononline help 
and manual. You can find the manual via in the Windows Start menu via the menu 
command Start > SIMATIC > Documentation > "<Language>" > SIMATIC 
Logon. 

 

5.  Confirm your settings with OK. 

 

 Note: 

After you have restore  the backup files in BatchCC, the assignment of user roles 
(permissions management) made in the SIMATIC Logon must be repeated. 
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To define user permissions for SIMATIC BATCH: 

1. Log in with your "Super user" logon.  

 

 Note: 

As default, only members of the "Super user" group have the privilege of defining 
and changing user permissions. The right of editing user permissions can, however 
be assigned to a different user group from the "Super user" group.  

2. Click on the icon  in the toolbar of BatchCC (as an alternative: Menu 
command Options > Permission management or the command Open 

permission management in the context-sensitive menu for the  object in 
the tree structure). 

The "Permission management" dialog box appears. 

3. In the "Individual permissions" tab, you specify the user permissions for each 
user role: 
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4. In the "Computers and units" tab, you specify which user roles are possible on 
which computer or unit. 

- In the "All computers" folder, the computer names are displayed and the 
user roles below them. 

- In the "Units of the <Process cell>" folder, the units are displayed and the 
user roles below them. 

 

5. Save the new user permissions with "OK". 

Change of User 

To change the logon in a batch application (BATCH Recipe Editor, BatchCC), 
double-click on the logon display to the bottom right of the status line of the batch 
application. Result: The PCS 7 logon service is started and a new logon dialog is 
opened. 
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5.2.3 Changing User Permissions 

General 

The user permissions can be modified during operation, for example while creating 
a recipe or processing a batch. At any one time, the user rights can only be 
modified by one person (with the "Super user" user role). 

Follow the steps outlined below: 

1. Click on the icon  in the toolbar of BatchCC (as an alternative: Menu 
command Options > Permission management or the command Open 

permission management in the context-sensitive menu for the  object in 
the tree structure). 

Result: The "Permission management" dialog is opened. 

2. Make the changes you require to the user permissions: 

3. Save the new user permissions with "OK". 

5.2.4 Displaying User Permissions 

Follow the steps outlined below: 

1.  Click on the icon  in the toolbar of BatchCC (as an alternative: Menu 
command Options > Permission management or the command Display 

Permission management in the context-sensitive menu for the  object in 
the tree structure). 

Result: The "Permission management" dialog is opened. 

2. You can display information about the user permissions of the user roles in the 
"permissions" tab. 

3. In the "Computers and units" tab, you can see which user roles are possible on 
which computer or on which unit. 
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5.3 Reading in ES Data 

5.3.1 Reading Process Cell Data into SIMATIC BATCH 

Importing the Process Cell Data for the First Time 

When you first open BatchCC, no Batch objects are visible in the left editing 
window. To be able to use the batch-relevant process cell data created in the 
Engineering System (ES), they must first be read into SIMATIC BATCH. To do this 
, you create a new process cell object in BatchCC. 

Requirement 

The batch process cell data created in the Engineering System (ES) have been 
downloaded from the engineering station to the run time computer of the BATCH 
Server. 

Follow the steps outlined below: 

1. Select the menu command Program > New process cell. 

2. In the dialog, select the row for the process cell you want to read in and 
confirm with OK. 

Result: The process cell data are read in and are not available in BatchCC and in 
the BATCH Recipe Editor. You can now start to configure the recipes and plan the 
batches. 
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5.3.2 Updating Process Cell Data after Changes in the Engineering 
System 

Updating the Process Cell Data 

If you have made changes to the batch-relevant process cell data in the 
Engineering System (ES) or have entered new data (for example added a new 
unit), you must also make such changes known in SIMATIC BATCH by reading the 
process cell data into BatchCC again. When you do this, all the batch data is 
updated. 

 

 Note: 

The updating of the process cell data takes place only on the BATCH client on 
which this phase has just been started. All other BATCH clients continue to have 
access to the BATCH Server (batch process). 

Changes in master recipes, library operations, formulas, and formula categories 
are not, however, possible at this point. If you attempt this, a dialog indicates that it 
is not possible. 

Requirement 

The batch process cell data created in the Engineering System (ES) have been 
downloaded from the engineering station to the run time computer of the BATCH 
Server. 

What has been changed or added? 

Before you update the process cell data, you can print out a log containing all the 
changes, in other words, the differences between the old and new process cell 
data. This allows you to decide on a suitable time for the update. If the changes 
would be too great a risk at the current time you can simply abort the update. 

Effects on the Status of the Recipes and Formulas 

After updating, all the recipes (master recipes, library operations) and formulas of 
this process cell that were "released for production" and "released for testing" are 
changed to the "Testing release" status. After updating the process cell data, the 
objects in the "Testing release" status are checked automatically. If the check is 
successful, the objects are returned to their original status. If the check is 
unsuccessful, the objects are changed to the "Release invalid" status. They can 
now be edited and released again. 

In the overview lists you can, for example, release the recipes with one action by 
selecting several rows and the command Release for production (context-
sensitive menu). 
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Follow the steps outlined below: 

1. Select the menu command Edit > Updating the process cell. 

2. In the dialog, select the row with the modified process cell project and confirm 
with OK. 

Result: The "Update process cell" dialog appears. After confirming this dialog, the 
process cell data are updated. Changed object data are overwritten. New objects 
are added.  

Display of the assignments: 
 

 
not assigned 

 
element assigned and at least lower-level object not assigned 

 
element and all lower-level objects assigned 

3. If there are any assignments missing between the objects of the old and new 
process cell configuration, make the necessary assignments, as follows: 

- Return to a selected object in the process cell tree  -> a dialog appears 
with the objects that are not yet assigned. 

- Select the required object and make the assignment with Return. 

4. Confirm all added assignments with OK. 

Result: The process cell data is updated. Master recipes, library operations, and 
formulas in the "Release invalid" status must be modified and released again. 
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5.4 Specifying Materials 

5.4.1 Editing Materials 

Purpose 

At the start of batch planning, you must define the following in SIMATIC BATCH for 
materials (products, by-products, waste products): 

• The materials for input materials and output materials 

• The quality of the main product 

You define the materials in the list boxes displayed in the subsequent dialogs for 
recipe creation and batch planning.  

Materials and qualities must be assigned a unique alphanumeric code (for example 
an internal company code) in the form of a string. This code can, for example, be 
used to specify setpoint output and process value input at the interface blocks or 
SFC types to identify the material or product. 

 

 Note: 

If you have a central material management department in your company, you can 
also write the materials to the batch data management via the user interface (API) 
of SIMATIC BATCH. 

Rules 

• A material or quality can have a maximum of the 32 characters. 

• The material code is alphanumeric and can have a maximum of 16 characters. 

• The quality code is numeric and possible in the range 0 to 2147483647. 

• Both the material name and the material code must be unique. 

• The quality and the quality code must be unique within a material. 

• If a material is deleted, this is only deactivated. If you use the name again, it is 
reactivated along with its qualities. 

• When you delete a material, the system checks which recipes, libraries, and 
formulas contain use it. If the material still exists in one of these, it cannot be 
deleted. 
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To create a new material: 

1. Select the "Materials" folder in BatchCC. 

2. Select the menu command Edit > New. 

Result: the dialog box "Properties of <materials>" is opened. 

3. In the "Materials" tab, specify the following: 

- Name of the material 

- Unique alphanumeric code (string) for the material 

- Whether or not it is an input or output material 

4. Select the "Qualities" tab. 

5. Add new qualities with the "New" button. Several qualities are possible for a 
material. 

 

 Note: 

The definition of qualities for a material is optional. 

 

6. Confirm the new materials with OK. 

 

 Note: 

As an alternative, you can also make these settings with the commands New  and 
Propertiesin the context-sensitive menu for the "Materials" folder in the tree 
structure. 

Modifying and Deleting 

Using the context-sensitive commands Properties and Delete , you can modify or 
delete existing materials. 
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5.4.2 Changing the Quality 

Follow the steps outlined below: 

1. Select the quality BatchCC (in the "Materials" folder). 

2. Select the menu command Edit > Properties. 

3. Change the settings for the quality in the "Quality" dialog. 

4. Save you new input with OK. 

 

 Note: 

As an alternative, you can also perform this settings in the tree structure via the 
command Properties in the context-sensitive menu of the object {bmct 
Qualität_icon.bmp}. 
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5.5 Recipes 

5.5.1 Flowchart: How to Create and Edit a Master Recipe 

How to Create and Edit a Master Recipe 

 

Start  
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5.5.2 Flowchart: How to Create or Edit a Library Operation 

How to Create / Edit Library Operations and Insert them in Master Recipes 
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5.5.3 Basics of Recipe Creation 

5.5.3.1 Overview of the Properties of Master Recipes 

Definition 

By "Properties of Master Recipes", we mean all the information complying with the 
standard ISA S88.01 (1995) that must or can be specified for a recipe in addition to 
the recipe procedure. These properties include the recipe name/version/status, 
material and production data (formula), parameters, measured values and unit 
allocations. 

Selectable Master Recipe Properties 

The table below lists all the properties that can be displayed and/or modified for 
each master recipe in the "Properties of <Recipename>" dialog. These master 
recipe parameters are also known as recipe header parameters. 

 
Tab What is set or 

displayed 
Meaning/comment 

General Name and version  

Status 

Duration 
 
 

Category 

Name of the master recipe, cannot be changed 

Status display of the master recipe, e.g. "In progress" 

Here, the longest time for one execution of the recipe is 
calculated. It is the sum of the step times of the path 
through the recipe. 

There may be a reference to an existing formula 
category. 

Allocations Allocation Map The unit allocations of the recipe specified by the 
detailed configuration of the recipe unit procedures 
(RUP) are listed here along with the calculated start time 
and duration.  

In the "Start allocation" field, you can specify whether or 
not a unit will be occupied at the start of the batch." 

In a follow-on dialog, you can modify the unit class and 
preferred unit (along with the selection strategy). 

Product Product, Quality 

Reference quantity 
 
 
 

Minimum Scale, 
Maximum Scale 

 

Settings for the main product  

The reference quantity is meant for quantity scaling, this 
means, the parameters in the recipe relate to this value 
and they have to be adjusted in the event of 
discrepancies in the reference quantity. 

Limits the upper and lower limits of the batch quantity. In 
batch planning, the quantities specified are checked to 
make sure they are not lower/higher than the values 
entered here. 
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Tab What is set or 
displayed 

Meaning/comment 

Input Material Material List For the steps with the connection to EOP, EPH or for the 
operator dialogs, the entries for the basic automation  
are applied for the library reference from the library 
operation. New materials can also be created. Per input 
material, the material, quality, scaling function and 
concrete quantity are specified. 

Either concrete values (internal formula) or reference to 
values of an external formula 

Output Material Material List For the steps with the connection to EOP, EPH or for the 
operator dialogs, the entries for the basic automation 
are applied for the library reference from the library 
operation. New materials can also be created. Per 
output material, the material, quality, scaling function 
and concrete quantity are specified. 

Either concrete values (internal formula) or reference to 
values of an external formula 

Parameter Parameter list For the steps linked to EOPs, EPHs or for the operator 
dialogs, the parameters are taken from the basic control; 
for a library reference from the library operation. New 
parameters of the type real, bool, integer, string and 
enumeration can also be created. 

Either concrete values (internal formula) or reference to 
values of an external formula 

Measured Variables Measured variables that 
will be logged 

Measured variables for the batch report: 

You can select measured variables for archiving. As 
measured variables, the process values of the 
parameter blocks (EPAR_) linked via the EOP, EPH and 
TAG_COLL blocks are available. 

Change Log List of modifications List in which the modifications made to the recipe are 
documented. 

ESIG Electronic signature Specifying electronic signatures in compliance with FDA 
or 21 CFR Part 11: 

The "electronic signatures" function allows the operator 
to enter one or more signatures in the form of dialogs 
similar to the logon prompts normal in Windows at 
defined status changes or when operator input is made 
to recipes, recipe steps etc. 
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5.5.3.2 Relationship between Header Parameters, Formula Category 
and External Formula 

Header Parameters (internal formula) 

If you want to keep your material and production data directly in the master recipe, 
you can do this in the recipe header. This is then known as an internal formula. 
The material and production data can be set there during the creation of the master 
recipe and modified during batch planning and/or also while a batch is executing. 
These parameters can be passed on from the recipe header to individual recipe 
steps or from the recipe steps to the recipe header. 

Interaction between Header Parameters, Formula Category and External Formula 

If you want to manage several material and production data lists for a master 
recipe, you must do this outside the master recipe in "external" formulas belonging 
to a formula category. 

In this case, if a formula category is assigned to a master recipe and the 
parameters of the master recipe are then interconnected with those of the formula 
category, the parameters that can be manipulated by an operator using a formula 
during batch planning are effectively masked. In the formula category, the 
parameters are listed with the data type and physical unit. In the formula, the 
parameters have concrete values, a high and low limit and a reference to the 
procedure (master recipe). 

The parameters of external formulas can also be modified during batch planning 
and/or while a batch is executing. 

 

 Note: 

Internal and external formula must not be congruent, this means, all recipe header 
parameters must not be interconnected to an external formula. and not all the 
parameters of an external formula need to be used in a master recipe. 
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Example of Interaction 

Recipe Header Parameter

1 quantity

2 water

3 temperature

4 steam

5

6

7

flow

time

speed

8 min speed

500 kg

1000 kg

70 °C

100 l/min

320 sec

120 rpm

25 rpm

Parameters
from external formula

Formula Category

1

2

3

4

5

quantity

temperature

flow

tim

speed

real

real

real

real

real

kg

°

l/min

sec

rpm

Formula #27

1

2

3

4

5

Menge

Temperatur

Durchfluß

Zeit

Drehzahl

500

70

100

320

120

kg

°

l/min

sec

U/min

Formula #26

1

2

3

4

5

Menge

Temperatur

Durchfluß

Zeit

Drehzahl

500

70

100

320

120

kg

°

l/min

sec

U/min

Formula #25

1

2

3

4

5

quantity

temperature

flow

tim

speed

500

70

100

320

120

kg

°

l/min

sec

rpm

Master Recipe
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5.5.3.3 Interconnecting Parameters 

Interconnecting Parameters between the Master Recipe and External Formula 

After assigning the master recipe and formula category, the parameters for the 
input materials, output materials, and process parameters still need to be 
interconnected.  

The advantage of this is that you can use independent parameter names in the 
formula category of a master recipe. After assigning a formula category to a master 
recipe, you specify the reference to the parameters in the formula category in the 
Properties dialog. Parameters of the same data type and same physical unit are 
made available from the formula category. 

Typ LL Valu
1
2

HL
 80
12

3
4

Name
ab
cd
ef
gh

float
integer

2
0

string
float

1:m  Relation
Name Type
1 ab float
2 cd integer
3 ef string
4 gh float

Master recipes

External
formulas

Formula
category

No user-defined relation
Can be omitted!

Define formula
parameter
independent of recipe

Typ

floa
tstrin
gstrin
g

Name
1 ghi
2 abc
3 xyz
4 gsg floa

t

LL
2

HL
100

Valu
et80
zu

Sourc
gh
cd

ab

User-defined (soft)
reference to the
parameter in the
formula category

User-defined relation

50
10

ein
2  8050

zu
1002 80
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5.5.4 Editing Master Recipes 

5.5.4.1 How to Configure a Master Recipe 

 

 Note: 

The order of the steps shown in the schematic is not absolutely necessary. We 
have selected a method on which the more detailed description of the actions is 
oriented. 

 

 

 Note: 

You can also use master recipes without using the "formula category" and 
"formulas" objects. In this case, the material and production data (formula) are set 
in the properties of the master recipe.  

Configuring a Master Recipe 

The schematic below shows a recommended sequence for configuring a master 
recipe in BatchCC. Illustrates clearly how to configure the assignments between 
the master recipe, formula category and formula. 

You create the actual recipe structure and set the properties of the recipe elements 
(Step 2) in the BATCH Recipe Editor. All the other steps can be made in BatchCC.  
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Specify properties of master recipe:
• material and production data (formula)
• unit allocations
• measured values for logging
• reference to formula category

(only if formula category exists)

Create the formula category

Specify properties of formula category:
• parameter name
• data type (only for process parameters)
• unit of measure

Create formula
below formula category

Specify properties of formula:
• parameter values
• reference to master recipe

Add properties for master recipe:
• reference to new formula category

Expand properties of master recipe
• Interconnect parameters between master

recipe and formula

Create the master recipe

BATCH recipe editor:
• create SFC recipe structure
• specify properties of RUP, ROP, SUB and

transitions

BatchCC
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Underlying Principle 

You create the master recipes in the BATCH Recipe Editor  

• If you are using hierarchical recipes: as a structure of recipe unit procedures 
(RUPs), recipe operations (ROPs) and recipe phases (RPHs) 

• If you are using flat recipes: as a structure of substructures (SUBs) 

In BatchCC, you can specify the reference to a formula category in the properties 
of the master recipe (header parameters). In the properties of the formula, you 
specify the reference to the procedure (master recipe). After these steps, you have 
a complete master recipe for batch planning. 

5.5.4.2 Creating a New Master Recipe 

There are two ways of creating a new master recipe: 

• In the BATCH Recipe Editor: see "BATCH Recipe Editor" 

• In BatchCC: described below 

Follow the steps outlined below in BatchCC: 

1. Select the "Master Recipes" folder. 

2. Select the menu command Edit > New > Hierarchical/Flat. 

3. Enter the name and version of the new master recipe in the dialog displayed 
and confirm with OK.  

Result: The new master recipe is inserted as an object  . The master recipe is 
in the initial status "In Progress" and can now be edited. 

Editing 

You can now continue to edit the master recipe either using the context-sensitive 

menu for the object  or alternatively using the Edit menu of the menu bar: 

• Creating the Recipe Topology 

To edit the master recipe, open the object with the Open menu command. The 
BATCH Recipe Editor is then opened. In the BATCH Recipe Editor, you create the 
topology of the master recipe with steps and transitions and define the properties 
of the recipe elements (RUPs, ROPs, RPHs, SUBs and transitions). 

• Specifying the Master Recipe 

To specify the properties of the header parameters, select the Properties menu 
command. 
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• Working with the Recipe Overview 

As an alternative to the tree structure, the "master recipe" objects can also be 
edited in the recipe overview. Open the recipe overview list with the Details menu 
command. First select the folder with the desired master recipe in the tree 
structure. 

• Validating Recipes  

• Releasing Recipes for Testing 

• Releasing Recipes for Production 

5.5.4.3 Opening and Editing Recipes 

Editing Recipes 

The recipe procedures of the master recipes and the library operations are created 
with the BATCH Recipe Editor.  

With the exception of deleting that is only possible with the BatchCC, you can 
make any modifications to recipe procedures and library operations with the 
BATCH Recipe Editor. 

Follow the steps outlined below in BatchCC:  

To edit master recipes and library operations, the objects must first be opened: 

1. Select the master recipe or library operation in the BatchCC 

2. Select the menu command Edit > Open. 

Result: The BATCH Recipe Editor is opened displaying the graphic structure of the 
highest hierarchical level of the recipe object.  



Batch Control Center (BatchCC) 

 SIMATIC BATCH 
5-42 A5E00272803-01 

5.5.4.4 Specifying the Properties of Master Recipes 

Opening the Tab 

There are two ways in which you can open the "Properties of <Recipe name>" tab: 

• In the BATCH Recipe Editor: see "BATCH Recipe Editor" 

• In BatchCC: described below 

Follow the steps outlined below in BatchCC: 

1. Select the master recipe in the "Master Recipes" or in one of its subfolders in 
the BatchCC. 

2. Select the menu command Edit > Properties. 

Result: The "Properties of the <recipe name>" dialog is displayed with the 
header parameters. In the dialog tabs, all the Properties of the master recipe 
are available, which must/can be specified for a recipe in addition to the master 
recipe structure.  

Some of the properties (parameters) already have a fixed value due to the 
detailed configuration of the individual recipe elements (RUPs, ROPs, RPHs, 
SUBs transitions) based on the process cell configuration in the engineering 
system. You can recognize parameters or settings that can still be modified by 
the white editing fields. 

3. Make the settings you require in the tabs and confirm with OK.  
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Entering Properties 

You enter the properties of the master recipes in the following tab. Click the "Help" 
button for context-sensitive help on each individual input or output box in the tab. 

 

Reference to Formula Category 

With the "Category" input box in the "General" tab, you assign the formula category 
with the required structure for material and production data (formula) to the master 
recipe. It is assumed that the formula category has already been created. 

See section: Connection between the recipe header parameter, formula category 
and formula  

Interconnecting Parameters 

After assigning the master recipe and formula category, the parameters must still 
be interconnected. After assigning a formula category to a master recipe you 
specify the reference to the parameters in the formula category in the Properties 
dialog ("input materials", "output materials" and "parameters" tabs).  

See section: Interconnecting Parameters between Master Recipe and Formula  

Electronic Signatures 

Actions and status changes of recipes and recipe elements can be signed. You 
configure electronic signatures in the "ESIG" tab. 

See also section: Specifying the Electronic signature  
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5.5.4.5 Creating a New Formula Category 

Follow the steps outlined below in BatchCC: 

1. Select the "Formulas" folder. 

2. Select the menu command Edit > New. 

3. Enter the name of the new formula category in the dialog displayed and 
confirm with OK. 

Result: The new formula category is inserted as an object  . With the formula 
category, you can now create a class of formulas with the same raw material and 
production data structure.  

Editing 

You can now continue to edit the formulas as follows: 

• Specifying the Properties of the Formula Category  

• Creating a New External Formula  
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5.5.4.6 Specifying the Properties of the Formula Category 

Follow the steps outlined below in BatchCC: 

1. Select the formula category in the "Formulas" folder or in one of its subfolders. 

2. Select the menu command Edit > Properties. 

  Result: the dialog box "Properties of <category name>" is displayed. In the tab dialogs, the 
structure of the material and production data (formula) can be specially created for this 
formula category (external formula). 

3. Enter the structure of the formula category consisting of the parameter names, 
data type (only for process parameters) and physical unit and confirm with OK. 

Result: With the formula category, you can now create formulas with the same raw 
material and production data structure by creating new formulas under this formula 
category in the tree structure. 

Entering Properties 

You enter the properties of the formula category in the following tab. Click the 
"Help" button for context-sensitive help on each individual input or output box in the 
tab. 
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5.5.4.7 Creating a New External Formula 

Follow the steps outlined below in BatchCC: 

1. Select the required formula category in the "Formula" folder. If the formula 
does not match any formula category, you have to create the corresponding 
formula category first. 

2. Select the menu command Edit > New. 

3. Enter the name and version of the new formula in the dialog that follows. 

Result: The new formula is inserted as an object  . In the Properties dialog for 
the formula, you can now enter the concrete information on the materials, 
quantities and quality. |The parameters of the higher level formula category are 
displayed in each case. If parameters are missing, the formula category needs to 
be adapted. 

Editing 

You can now continue to edit the formulas as follows: 

• Specifying the Properties of a Formula  

• Interconnecting Master Recipe Header Parameters with an External Formula  

5.5.4.8 Specifying the Properties of a Formula 

Follow the steps outlined below in BatchCC: 

1. Select the formula under the formula category. 

2. Select the menu command Edit > Properties. 

  Result: the dialog box "Properties of <formula name>" is displayed. The possible range of 
values for the parameters of the formula are displayed as the upper and lower limits. 

3. Enter concrete parameter values and select the corresponding master recipe. 

 

 Note: 

The "Master recipe" input field you can select those master recipes to which the 
formula category of the present formula has already been assigned. If the required 
master recipe is not listed, change to the Properties dialog of the master recipe 
and enter the reference to the formula category there. 
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Entering Properties 

You enter the properties of the formula in the following tab. Click the "Help" button 
for context-sensitive help on each individual input or output box in the tab. 

  

Reference to the Master Recipe 

In the "Master recipe" input box in the "General" tab, you assign a specific master 
recipe to the formula. After these steps, you have a complete master recipe for 
batch planning. 

See section: Connection between the recipe header parameter, formula category 
and formula  
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5.5.4.9 Interconnecting Master Recipe Header Parameters with an 
External Formula 

Interconnecting Parameters 

After assigning the master recipe and formula category, the parameters of the input 
materials and process parameters must still be interconnected. Perform the 
parameter interconnection for the master recipe in the properties dialog, provided 
the formula category was assigned there (see also section Specifying the 
Properties of the Master Recipe ). 

Follow the steps outlined below: 

1. Select the master recipe in the "Master Recipes" or in one of its subfolders in 
the BatchCC. 

2. Select the menu command Edit > Properties. 

Result: the dialog box "Properties of <recipe name>" is displayed. 

3. Change to the tabs for input materials, output materials, or parameters. 

4. Create the reference to a parameter in the formula category in the "Source" 
column. 

- Left click: The list box contains all the formula parameters of the same data 
type and same physical unit for selection. It may be necessary to assign 
the unit first in the "Phys. unit" column. "E" is shown under Value indicating 
external (see figure). 

- Right click: A further dialog box opens. When creating new parameters, 
you can use this to check whether a parameter of the same name at a 
different level will be overwritten and if this is the case, you can see the 
level at which the parameter exists.  
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5. Confirm the references with OK. 

  The header parameter is connected to the parameter of the external formula via the 
parameter of the formula category provided this master recipe was already assigned to a 
formula (see also section Specifying the Properties of the Formula). The values of the 
formula are used in the parameters of the master recipe. 
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Display of Parameter Interconnection 

The interconnection is displayed in the properties dialog of the formula with a 
connection icon in the "Usage" column: 

: interconnected 

: not interconnected (or no longer connected) 
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5.5.4.10 Working with the Recipe Overview 

Recipe Overview 

The recipe overview provides you with a list of the master recipes of a selected 
area. Apart from the properties from the tree structure, this list also shows the 
author and date of the last modification. 

Using the context-sensitive menu with the object listed, you can select the 
available functions in the same way as in the tree structure (alternative editing 
method). 

 

Selecting the Recipe Overview 

• Select the required area by first selecting a master recipe folder in the tree 
structure and then selecting the menu command Edit > Details. 
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5.5.4.11 Working with the Formula Overview 

Formula Overview 

The formula overview provides you with a list of all the formulas of a selected area. 
Apart from the properties from the tree structure, this list also shows the author and 
date of the last modification. 

Using the context-sensitive menu with the object listed, you can select the 
available functions in the same way as in the tree structure (alternative editing 
method). 

 

Selecting the Formula Overview 

• Select the required area by first selecting a formula folder in the tree structure 
and then selecting the menu command Edit > Details. 
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5.5.5 Working with Libraries 

5.5.5.1 How to Configure Library Operations 

Configuring Library Operations 

The schematic below is a recommended sequence for configuring a library 
operation in the BATCH Recipe Editor. You manage library operations in the 
BatchCC. All the other steps can be made in the BATCH Recipe Manager.  

Create a new library operation
in the BATCH Recipe Editor

Create topology of the library operation:
• Create the recipe structure
• Specify the properties of the steps and

transitions

Specify the properties of the library operation:
• Material and production data (formula)
• Reference to unit class

Insert a library reference in
the master recipe in BATCH Recipe Editor

Save library operation in the <Library> folder
in BatchCC

BATCH Recipe Editor
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Underlying Principle 

You create reusable library operations in the BATCH Recipe Editor  

• In hierarchical recipes: as a structure of recipe phases (RPHs) 

• In flat recipes: as a structure of substructures, recipe operations (ROPs) and 
recipe phases (RPHs) 

A library operation for hierarchical recipes is created for each specific unit class. 
The unit class is referenced in the header of the library operation.  

In the BATCH Recipe Editor, you store the library operations created in this way in 
the "Libraries" folder in the BatchCC using a menu command.  

When you create the recipe structure in the BATCH Recipe Editor you insert the 
required library operation using a library reference. The library operation is not 
copied but a link to the library operation within the library is created.  

Any modifications required must always be made to the library operation stored in 
the library. Any changes made to the library operation always affect all links (library 
references) in the master recipes of the process cell. 

Multiple Use 

A library operation can be used in the following ways: 

• More than once in a process cell 

• More than once in a recipe procedure (RP) 

• More than once within a recipe unit procedure (RUP)  only with hierarchical 
recipes 

• More than once within a substructure (SUB)  only with flat recipes 

See also 

Specifying the Properties of Master Recipes  
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5.5.6 Status and Validity of Recipes 

Status Changes and Validation of Master Recipes and Library Operations 

The initial status of a newly created master recipe or library operation is always "In 
Progress". You can bring about status changes using the appropriate commands. 
For batch planning, the master recipe must be valid. 

 
Status Triggered by Meaning 

  

in progress

 

Menu command 
New 

 

A master recipe or a library operation always has the status 
In Progress after it has been created. 

  

validated

 

Menu command 
Validity 
check  

 

The plausibility (validity) of the parameters in the process 
cell data is checked. 

A results list or error list is displayed that indicates, for 
example, which parameter settings are missing. 

Requirement: 

The master recipe or library operation has header 
parameters and a recipe structure. 

  

  released

 

Menu Commands 
Release for testing 

Release for 
production  

The two releases differ only in that different permissions 
and different user routines can be used.  

Both releases can be started without first running the 
validation check. In this case, a validation is run 
automatically in the background. 

  

release
revoked

 

Menu command 
To revoke the 
release: 

 

If a master recipe or library operation had already been 
released for production, the release can be revoked (for 
example to make modifications).  

testing
release

 

release
invalid

 

When updating the 
process cell data 

 

 

 

After updating, all the recipes (master recipes, library 
operations) of this process cell that were "released for 
production" and "released for testing" are changed to the 
"Testing release" status. After updating the process cell 
data, the recipes and library operations in the "Testing 
release" status are checked automatically. If the check is 
successful, the master recipes and library operations are 
returned to their original status. If the check is 
unsuccessful, the elements are changed to the "release 
invalid" status. They can now be edited and released 
again. 
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Difference between Releasing for Testing and for Production 

In the validation for release of a recipe, you can include you own test routines. Due 
to the distinction between release for testing and release for production, separate 
test routines can be processed. You could, for example, only allow water as the 
product for recipes released for testing. Different user permissions can also be 
defined. 

Recipes released for testing can also be edited directly after revoking the release. 
If a recipe is released for production, editing is possible only with certain settings in 
BatchCC (Options > Settings). 

Validity of the Formula 

For batch planning, the formula (with assigned master recipe) must be validated. 

 
Status Triggered by Meaning 

  

in progress

 

Menu command  
New 

 

A formula always has the status In progress after it has 
been created. 

  

validated

 

Menu command 
Validity 
check  

 

The assignment of a master recipe and the validity of the 
formula parameters are checked. A result or error list is 
displayed that indicates, for example, which parameters are 
not interconnected.  

Requirements 

• ·• A master recipe released for testing or production 
is assigned to the formula. 

• • The formula parameters were interconnected 
successfully 

The formula parameters are within the upper and lower 
limit values 

  

  released

 

Menu 
commandRelease 

The release can be started without first running the 
validation check. In this case, a validation is run 
automatically in the background. 

  

release
revoked

 

Menu command 
To revoke the 
release: 

 

If a formula had already been released, the release can be 
revoked (for example to make modifications). This is also 
the status if you make modifications in the Properties 
dialogs. 
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Requirements for Batch Control 

 

 Note: 

Only validated formulas with master recipes released for production can be used 
for batch control.  

Only test batches (for example, test operation with water) can be created with the 
master recipes and library operations released for testing. 

 

5.5.6.1 Validating Recipes 

Definition 

The validation covers the consistency of the library operations and process cell 
data used in the created recipe.  

Requirement: 

This is only possible when the recipe is edited with the elements step, transition, 
and structure elements along with the corresponding configuration of the recipe 
data (header). 

Follow the steps outlined below in BatchCC: 

1. Select the recipe you want to validate (master recipe or library operation) in the 
tree structure. 

2. Select the menu command Edit > Validate. 

Result: A results list or error list is displayed that indicates whether or not the recipe 
header is completed, whether materials exist, whether steps and transitions in the 
recipe are configured and whether the normalized batch quantity is correct. 
Validation is also possible in the BATCH Recipe Editor. 

 

 Note: 

If the recipe is open in the BATCH Recipe Editor, you can also jump to the part of 
the recipe that caused the problem by double-clicking the entry in the error list. 

 

 

 Note: 

You can use the validation function at any time. Validation does not change the 
recipe status. 
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5.5.6.2 Releasing Recipes for Testing 

Requirement: 

The requirement for this function is the validation of the recipe. The validity of the 
recipe is first checked automatically when you start this command. 

Follow the steps outlined below in BatchCC: 

1. Select the recipe (master recipe or library operation) in the tree structure. 

2. Select the menu command Edit > Release for Testing. 

Result: After it has been released, the recipe has the status "Released for testing" 
. If errors occur in the validation, the problems are displayed and the 

recipe status remains "In Progress...". Release is also possible in the BATCH 
Recipe Editor. 

 

 Note: 

If the recipe is open in the BATCH Recipe Editor, you can also jump to the part of 
the recipe that caused the problem by double-clicking the entry in the error list. 

5.5.6.3 Releasing Recipes for Production 

Requirement: 

The requirement for this function is the validation of the recipe. The validity of the 
recipe is first checked automatically when you start this command. 

Follow the steps outlined below in BatchCC: 

1. Select the recipe (master recipe or library operation) in the tree structure. 

2. Select the menu command Edit > Release for Production. 

Result: After it has been released, the recipe has the status "Released for 

production" . If errors occur in the validation, the problems are displayed 
and the recipe status remains "In Progress...". Release is also possible in the 
BATCH Recipe Editor. 

 

 Note: 

If the recipe is open in the BATCH Recipe Editor, you can also jump to the part of 
the recipe that caused the problem by double-clicking the entry in the error list. 
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5.5.6.4 Validating Formulas 

Definition 

During validation, the formula is checked to make sure that a released master 
recipe is assigned. The consistency of the formula parameters and their 
interconnections with the parameters of the master recipe are also checked. 

Requirements: 

• A master recipe released for testing or production is assigned. 

• The formula parameters were interconnected successfully 

• The formula parameters are within the upper and lower limit values 

Follow the steps outlined below in BatchCC: 

1. Select the formula you want to check in the tree structure. 

2. Select the menu command Edit > Validate. 

Result: A result or error list is displayed that indicates, for example, whether or not 
the assigned master recipe is released. 

 

 Note: 

You can use the validation function at any time. The validation does not change 
the status of the assigned master recipe. 
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5.5.6.5 Status of the Recipes and Status Changes 

The initial status of a new recipe is always "In progress". You can bring about 
status changes using the appropriate commands. You must first open the context-
sensitive menu and select the appropriate commands to change the recipe. 

Meaning of the icon: On the left is the status icon (for example, released/release 
revoked/ ....), on the right is the type icon (for example hierarchical / flat). 

Status Displays of the Recipes and Their Meaning 

 
Status Meaning 

In progress Initial status of a newly created and status after modifying a 
recipe. 

Released for testing Recipes that have been released for testing can be used for 
creating a batch for test purposes. If the function is given 
graded permissions, a distinction can be made between testing 
the functionality (for example a test mode with water...) and 
production. 

Released for production This status indicates that the recipe has been tested for normal 
production. Following the command Revoke Release, or 
Configure Process Cell, the recipe changes to the "Release 
Revoked" status. 

 Release revoked If a recipe has already been released for production, it can be 
changed to this status using "Revoke release", for example to 
correct errors. 

testing release After updating, all the recipes (master recipes, library 
operations) of this process cell that were "released for 
production" and "released for testing" are changed to the 
"Testing release" status.  

release invalid After updating the process cell data, the recipes and library 
operations in the "Testing release" status are checked 
automatically. If the check is unsuccessful, the elements are 
changed to the "release invalid" status.  

 

A recipe that is already open and being edited is locked for other employees. This 
is indicated by an additional icon locked . 

Released recipes are displayed in the BatchCC when you create batches. 
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5.5.6.6 Status of the Formula and Status Changes 

The initial status of a new formula is always "In progress". You can bring about 
status changes using the appropriate commands. You must first open the context-
sensitive menu and select the appropriate commands to change the formula. 

Meaning of the icon: On the left is the status icon (for example, released/release 
revoked/ ....), on the right is the type icon. 

Status Displays of the Formula and Their Meaning 

 
Status Meaning 

In progress Initial status of a newly created formula. 

Released for production This status indicates that the formula is intended for normal 
production. Following the command Revoke Release, or 
Configure Process Cell, the recipe changes to the "Release 
Revoked" status. 

 Release revoked If a formula has already been released for production, it can be 
changed to this status using "Revoke release", for example to 
correct errors. 

 

A formula that is already open and being edited is locked for other employees. This 
is indicated by an additional icon locked . 
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5.5.7 Recipe Reports 

5.5.7.1 Recipe Reports 

Definition of a Recipe Report 

The "off-the-shelf" recipe report contains all the data required for production. These 
include the recipe header data, the recipe topology, the input materials, the output 
materials, the parameter list and the procedural rules. 

Principle 

The recipe report data is available centrally in the batch database.  In BatchCC, 
you can print out the recipe report as documentation or view a print preview. 

Follow the steps outlined below in the BatchCC: 

1. Select the menu command Edit > Print preview in BatchCC with a master 
recipe selected (in the tree structure). As an alternative, you can also select a 
print preview with the right mouse button when the master recipe is selected. 

Result: The user interface of BATCH Report is opened. The recipe report for the 
master recipe is displayed. On the left-hand side of BATCH Report you can see the 
structure of the content of the master recipe with the RUPs, ROPs, RPHs and 
transitions. 

2. Double-click on one of these recipe elements. 

The report data belonging to the recipe element are displayed in the right-hand 
window of BATCH Report. 

3. You can print out the displayed report data to provide documentation with the 
menu command Edit > Print. 

Printing a Recipe Directly 

In BatchCC, you can print the entire report data of a recipe without a print preview. 
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5.6 Planning Batches 

5.6.1 Flowchart: How to Create/Edit a Batch 

BatchCC

Start BatchCC

Create new production order

Assign formula to each batch

Set start mode of the batches

If nec. change formula and unit
allocation

Chain
batches?

yes

no

Release batches

Result:
Control recipe for making
batches is created

Set quantities for the batches

Specify order of batch
processing

der Chargen festlegen

Create batches for
production order
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What can be planned? 

A production order specifies which product will be manufactured. Batches can be 
assigned to a production order manually or automatically. 

The recipe on which the batch is based specifies the production process and the 
duration of the unit allocation.  

The following can also be selected for a specific batch: 

• Batch quantity 

• Formula/master recipe 

• Units used 

• Start mode and start time 

The sequence in which batches are executed can be selected by chaining the 
batches. 

5.6.2 Order of Batch Processing 

Order of Processing 

In SIMATIC BATCH , the order in which created batches (status: planned) are 
processed is decided by the order in which they are released. All released batches 
are included in batch control in the order or their releases. Batches that do not use 
the same units and equipment modules can also be processed at the same time. 

The batches are started when the units and the start of the control recipe are free 
depending on the selected start mode immediately, time-driven or after manual 
intervention by the operator. If "time-driven" is set, the set time is started. Once the 
time has elapsed, the batch whose start time is furthest in the past is started first. 

Scenario based on an example: If A "Start allocation" was selected for a unit, the 
batch starts only when it can occupy unit A. If the unit is allocated to another batch, 
the batch does not change to the "in progress" or "waiting" status. Different 
response when "Start allocation" was not selected: The batch then changes to the 
"waiting" status. In other words, the batch starts and waits until unit A is released.  

Chaining Batches 

If you want the batches to be processed in a specific order (regardless of the order 
in which they were released), you can also chain batches. For each planned batch, 
you can specify which batch must be started and which batch must be completed 
before the planned batch is started (see "Chaining Batches."). 
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5.6.3 Planning Batches 

5.6.3.1 How to Configure Batches 

 

 Note 

You can create batches by using master recipes or formulas (with assigned master 
recipes). The procedure is identical in both cases. The procedure for working with 
formulas is described below. 

Configuring Batches 

With SIMATIC BATCH, you can plan batches and specify the chronological order 
of several batches without having to release the batches immediately for 
production. Batches can be derived from production orders.  

The sequence shown below is the recommended order for configuring production 
orders with batches in BatchCC. The diagram shows which settings must be made 
for batches.  

Specify the properties of the order:
• Order name
• Total quantity for the order
• Earliest start and latest completion

Create a new production order

Specify properties for each batch:
• Change preset quantity
• Start mode and time (if time-driven)
• Reference to formula (with assigned

master recipe)
• If nec, change formula, unit allocation
• If nec. change processing sequence by

chaining with other batches
 

Check:
• Total quantity over all batches
• Run time of each individual batch
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Underlying Principle 

You create the batches for the production orders in BatchCC. By defining and 
selecting a master batch, numerous batches with similar properties can be created 
quickly. In the properties of each batch, you specify the reference to a released 
formula with assigned master recipe or to a released master recipe without a 
formula category assignment. You can specify the batch quantity and start mode 
for every batch. By chaining the batches, you can define the order in which they 
are processed.  

5.6.3.2 Creating a New Production Order 

Follow the steps outlined below in BatchCC: 

1. Select the "Orders" folder. 

2. Select the menu command Edit > New. 

A dialog with the "General" and "Batches" tabs is opened. 

  

3. Make the following settings for the production order in the "General" tab: 

- Name of the production order 

- Planned total batch quantity for the order 

- Earliest start and latest end of the batches 
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4. You then have two options as to how you continue the configuration. 

Option 1: 

You do not want to create concrete batches yet. Simply confirm the settings made 
up to now with OK at this point. 

Result: The production order is inserted asl an object  in BatchCC. Later, you 
can add batches to this order and set the actual properties for each batch. 

See also section: Batches for production order supplemented  

Option 2: 

You move on immediately to the "Batches" tab. 

For further settings: 

See section: Assigning Batches to a Production order  
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5.6.3.3 Assigning Batches to a Production Order 

Follow the steps outlined below in BatchCC: 

1. While creating a new order, change to the "Batches" tab (properties dialog for 
the order). 

 

2. Create the batches for the production order as follows: 

- You can create new batches with the "New" button. You then make the 
settings for the batch quantity, start mode, formula etc. 

- To work with a master batch: Select a batch in the table and then click the 
"Copy" button so that the selected batch is given the status of a master 
batch and all batches created afterwards have the properties of the master 
batch.  

- Automatic: Using the "Automatic" button is a convenient method of 
calculating batches for a specific amount of material. 

3. If necessary, change the assignment to a unit or to a master recipe or formula 
by clicking on one of the table cells "Allocations", "Product", or 
"Recipe/Formula". 
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Result:  

- In this dialog, you enter the product, the formula or the formula category. 
As a result, all the assignments with a released master recipe and/or 
validated formula are listed. 

- Select the row with the correct assignment and confirm with OK. 

Result: The batch is assigned to the new formula/master recipe in the "Batches" 
tab. 

Tip: First set all the properties (batch quantity, start mode, formula) of the master 
batch in the "Batches" tab or make another batch the master batch by selecting it 
and then create the further batches with the "Copy" button. 

4. Set the batch quantity in the "Quantity" cell. The reference scale standard 
quantity is already entered. If you set a value outside the limits set by the 
minimum and maximum scale, the value is corrected to the limit value. 

5. If necessary, change the start mode and start time in the "Mode" and "Start" 
table cells. 

6. Confirm all your entries with OK. 

Result: The information about the number of batches and the total batch quantity of 
the production order is updated in the "General" tab. The batches are created as 

 objects below the production order. The batches are in the "Planned" status. 

Creating Batches Automatically 

In the "Batches" tab, you can also create batches automatically using the 
"Automatic" button.  

To create batches automatically: 

1. Select a batch as the master batch. 

2. Click the "Automatic" button.Result: The dialog for selecting the formula/master 
recipe is displayed. 

3. Here, you select the formula/master recipe and confirm with OK. 

4. Result: The "Generate batches" dialog appears.  

5. Make all the required entries and confirm with OK. 

Result: The number of batches and the amount of each batch is calculated 
automatically and created so that the total amount is produced. 
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5.6.3.4 Displaying the Properties of a Production Order 

Follow the steps outlined below in BatchCC: 

1. Select the production order in the "Orders" folder in BatchCC. 

2. Select the menu command Edit > Properties. 

Result: You can see the current status of the production order in the dialog. All the 
batches created for the order are listed with their properties in the "Batches" tab. 
The "General" tab contains the following properties of the order. 

Properties of the Production Order 

 
Property Meaning Modifiable 

Name Name of the order Can be modified with 
Rename 

Status Processing status of the order This is updated by BatchCC. 

Planned Size Planned total batch quantity for the 
order 

Cannot be modified 

Current quantity Batch quantity: Here, the sum of all the 
quantities of all batches of the order is 
displayed 

This is updated by BatchCC. 

Unit of measure Unit of measure for the amounts** This is updated by BatchCC. 

Earliest start and 
latest end of the 
batches 

Time window for processing the 
batches 

Cannot be modified 

Batches Number of batches for this order This is updated by BatchCC. 

 

* Changes can only be made with the creation of a new production order. 

** If batches have different units or different materials, "***" is displayed. 
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5.6.3.5 Adding Batches to a Production Order 

There are several ways in which you can add batches to the production order. 

• When creating a new production order: see Section "Assigning Batches to a 
Production Order"  

• By adding batches to an existing production order as described below. 

Follow the steps outlined below in BatchCC: 

1. Select the production order in the "Orders" folder. 

2. Select the menu command Edit > New. 

Result: The "Batches" properties dialog for the production order appears. 

 

3. Follow the same procedure as described in the section "Assigning Batches to a 
Production Order". 
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5.6.3.6 Specifying the Properties of the Batch 

There are three ways in which you can specify the properties of batches: 

• When creating a new production order: see Section "Assigning Batches to a 
Production Order"  

• When adding a Batch to the production order: see Section Adding Batches to 
the Production Order  

• Afterwards for an existing batch as described below. 

Follow the steps outlined below in BatchCC: 

1. Select the "Batch" object below the production order in the "Orders" folder in 
BatchCC. 

2. Select the menu command Edit > Properties. 

Result: the dialog box "Properties of <Batch name>" is displayed. In this dialog, 
you can do the following: 

- Display and, if required, modify the batch quantity 

- Setting the Start Mode for Batch Processing  

- Displaying and Modifying Unit Allocation  

- Displaying and Modifying Formula Parameters  

- Displaying and, if necessary, Modifying the Batch  

- Displaying the Running Time of a Batch  

3. Make all the settings you require for the batch and confirm with OK. 

Result: After it is enabled, the batch can be processed depending on the selected 
start mode and the unit allocation. 
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Entering Properties 

You enter the properties of the batches in the following dialog. Click the "Help" 
button for context-sensitive help on each individual input or output box in the tab. 

 



Batch Control Center (BatchCC) 

 SIMATIC BATCH 
5-74 A5E00272803-01 

5.6.3.7 Setting the Start Mode for Batch Processing 

Follow the steps outlined below in BatchCC: 

1. Select the "Batch" object below the production order in the "Orders" folder in 
BatchCC. 

2. Select the menu command Edit > Properties. 

Result: the dialog box "Properties of <Batch name>" is displayed.  

3. In the "Start Mode" input field, select either manual, immediate, or time-
driven.  

4. You must also set a start time and start date. 

5. Confirm with OK. 

Possible Start Modes 

 
Start Mode Meaning 

Manual You can start the released Batch with the menu command Control > 
Start . 

Immediately The batch is started when it is released as soon as the units required at 
the start of the control recipe are free. 

Time-driven The batch is started on a particular day at a particular time. The start time 
and date must be specified. 

 

 Note 

Batches with the "immediate" start mode are started beforebatches with the "time-
driven" start mode (have higher priority) if the same units are involved. 
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5.6.3.8 Displaying and Modifying Unit Allocation 

Unit Allocation and Duration 

A unit can only ever be involved in the production of one batch at any one time. 
The unit allocation is displayed along with the duration of the allocation and is not 
related to any particular recipe. The length of time required by units involved in a 
batch is set when the recipe is created. The times are relative to the start of the 
batch and take into account the actual quantity of the batch. 

If necessary, you can adapt the unit allocation in the Properties dialog of the batch. 

 

 Note 

The allocation times of the units are planning values used to optimize the use of 
facilities. Please remember that these allocation times are not exactly the same as 
the actual times required for batch control. 

Follow the steps outlined below in BatchCC: 

1. Select the "Batch" object below the production order in the "Orders" folder in 
BatchCC. 

2. Select the menu command Edit > Properties. 
Result: the dialog box "Properties of <Batch name>" is displayed.  

3. Select the "Allocation" tab. 
Result: The units reserved for the recipes are displayed in the table. 

4. If required, modify the unit allocation. The "Unit" list box shows only the units 
that also have the recipe phases being used.  

5. Confirm your changes with OK. 

Overview of the Unit Allocations 

Eine Übersicht (read only) über die Teilanlagenbelegungen können Sie auch mit 
dem Menübefehl Planung > Teilanlagenbelegung öffnen. 
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5.6.3.9 Displaying and Modifying Formula Parameters 

Changing a Formula 

In the properties dialog for the batch, you can make the final modifications to the 
formula parameters.  

 

 Note 

Formula parameters modified at this point apply only to this batch. The parameter 
values are not changed in the formula used or in the master recipe used in the tree 
structure of BatchCC. 

Follow the steps outlined below in BatchCC: 

1. Select the "Batch" object below the production order in the "Orders" folder in 
BatchCC. 

2. Select the menu command Edit > Properties. 
Result: the dialog box "Properties of <Batch name>" is displayed.  

3. Change to the "Input material", "Output material", or "Parameters" tab. 
Result: Tables are opened displaying all the header parameters of the master 
recipe with the current values of the formula parameters. 

4. If required, change the values of the formula parameters. The possible range 
of values are displayed as the upper and lower limits. 

5. Confirm your changes with OK. 
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5.6.3.10 Setting the Order of Batches 

Chaining 

If you want to make sure that a batch is only started after a previous batch has 
been completed, you can also chain planned and not yet released batches. You 
can, for example, specify a predecessor batch and specify whether the 
predecessor batch must already be started or already be completed. 

Follow the steps outlined below in BatchCC: 

1. Select the menu command Planning > Set batch order. 
Result: The "Set batch order" dialog appears. All batches and their start and 
end times are displayed on the left-hand side. 

2. Select the correct time area on the right. 

3. Select a planned batch  in the time window that will be chained with another 
batch. 

4. Select one of the commands Chain with predecessor or Chain with 
successor in the context-sensitive menu. 

5. Then select the predecessor or the successor batch. 

Result: Chained batches are displayed with a connecting line in the time window. 
By selecting the batches and then the context-sensitive menu command Cancel 
connection to predecessor, the chaining is broken again.  

 

 Note 

Tips:  

• You can zoom the time scale CTRL and the right mouse button. 

• If you select a Batch and display  in the context-sensitive menu command, the 
time slice belonging to the batch is displayed in the time window. 

• If you select a batch and then the Go to  predecessor context-sensitive 
command, you can jump to the predecessor in the time window. 

Chaining Mode 

Using the Propertiescommand (context-sensitive menu) in the "Chaining" tab, you 
can also specify the following modes for the chaining of the batch: 

• Start chaining: This batch starts up as soon as the predecessor batch is 
started. 

• End chaining: This batch starts up as soon only after the predecessor batch is 
completed. If the charge is aborted or stopped, a query is displayed asking 
whether the next batch should be started. 



Batch Control Center (BatchCC) 

 SIMATIC BATCH 
5-78 A5E00272803-01 

5.6.3.11 Displaying the Running Time of a Batch 

Follow the steps outlined below in BatchCC: 

1. Select the "Batch" object below the production order in the "Orders" folder in 
BatchCC. 

2. Select the menu command Edit > Properties. 

Result: the dialog box "Properties of <Batch name>" is displayed. The duration of 
the control recipe calculated from the individual step times in the recipe editor is 
displayed in the "Running time" box. 

 

 Note 

These batch running times can be used to optimize planning. Please remember 
that these times are not exactly the same as the actual times required for batch 
control. 
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5.6.3.12 Planning the Unit Allocation 

Unit Allocation 

An overview dialog provides you with a complete overview of all batches and their 
unit allocation. Symbols indicate whether or not there is a conflict or will be a 
conflict in the future due to double allocation of the units by pending batches. 

To select the unit allocation overview: 

• Select the menu command Planning > Unit allocation.  

In the upper left area, you can display the units and corresponding batches. In the 
lower left area, the batches are displayed at the first level and then the required 
units. This allows you to optimize the unit allocation with various options. A time 
conflict is indicated by the icon  . Time conflicts can be eliminated in this 
overview dialog by simply moving the batches in the right-hand time window. 
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Meaning of the Symbols 

• Yellow bar: Unit without conflict 

• Gray bar: Batches with a run time longer than 6 hours. The symbol to the left of 
the bar indicates the current status of the batch. 

• Blue bar: Batches with a run time shorter than 6 hours. These batches are 
always displayed with the same length. In other words, zooming does not 
enlarge/reduce the size of the time elements of these batches. 

• Red bar: Unit with conflict. The same unit is planned to be used by more than 
one batch at the same time. 

 

 Note 

As long as a batch is in the "planned" status, it can be dragged and dropped in a 
horizontal direction (time scale) in this view. 

Below a unit, all the batches that have not yet completed and for which the unit is 
used are displayed. A batch can therefore occur more than once under "Units". 

Moving the Time Scale 

The time range can be moved using the button symbols at the left and right ends of 
the scale: 

• Left arrow: Moves the time scale towards the past. 

• Right arrow: Moves the time scale towards the future. 

As an alternative, the time range can also be moved by clicking on the area 
between the two arrows. 

Continuous Expansion and Reduction of the Time Scale 

The visible time range (for example one week) can be reduced (for example two 
hours) or expanded (for example ten days). 

By clicking on the area between the two arrows while holding down the "Ctrl" 
button at the same time you can zoom the time scale. 

• Move the mouse left: The time scale is reduced 

• Move the mouse right: The time scale is expanded 
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5.6.4 Opening the Control Recipe for the Batch 

Even during the batch planning, you can open the graphic recipe structure of the 
control recipe to check it. In this case (batch is still planned), a validation is 
performed when it is opened! If the batch is released, there is no validation. 

Follow the steps outlined below in BatchCC: 

1. Select the "Batch" object below the production order in the "Orders" folder in 
BatchCC. 

2. Select the menu command Control > Open control recipe. 

5.6.4.1 Overview of the Control Recipe 

In BatchCC, you can open not only the control recipe but also a structural overview 
of the control recipe ( View > Overview of control recipe ). With more complex 
control recipes, you can go to the relevant point in the control recipe window by 
clicking on a recipe element in the overview. 

A recipe element shown in the table with a cross can have the following properties: 

 

 
Electronic signature necessary 

 
Operator dialog exists 

 
Recipe element locked (being processed) 

 
Recipe element running 

 
Breakpoint set 

 
Error 

 
Path of the recipe element 

 

Comment on the property 



Batch Control Center (BatchCC) 

 SIMATIC BATCH 
5-82 A5E00272803-01 

5.6.5 Status of Batches 

The status of the batch provides you with information about the current processing 
of the batch (batch completed or aborted?). The status is updated in the tree 
structure and in the list display. 

 
Status Meaning 

planned The batch was recreated in batch planning  
again. 

release prepared While releasing the batch, an error occurred in 
communication between BatchCC and the BATCH 
Server (Batch Control Server). 

released The batch has been created and released. A control 
recipe exists. 

locked The batch has been created and released but was 
locked by batch control to prevent it being started. 

canceled The batch was canceled. Further processing is no 
longer possible. 

waiting The batch was started and is now waiting for the unit or 
units required at the start of the recipe to become free. 

running The batch was started or resumed and is being 
processed. 

paused The batch was paused, the steps currently being 
executed are completed. 

held The batch was held. 

aborted The batch was aborted by operator intervention. 
Processing can no longer be resumed. 

stopped The Batch was stopped due to a operation. Resumption 
is no longer possible 

completed The batch was completed correctly. 

testing release After updating the process cell data, released batches 
change to the "testing release" status. 

After the update, the batches in the "testing release" 
status are checked automatically. If the check is 
successful, the batches are returned to their original 
status. If the check is unsuccessful, the elements are 
changed to the "release invalid" status. Such batches 
must no longer be used and can only be deleted! 

release invalid  

   Operator prompt Queued operationrequests in the control recipe: 

• Operator instruction/ dialog or  

• Electronic signature (ESIG) or  

• Breakpoints 
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Additional Status 

The following icons indicate other statuses in addition to those listed above. These 
icons are superimposed on the batch icon. 

 

chained The batch is chained with a predecessor. 

  closed The batch is closed and can be archived. 

archived 
The batch is archived. The batch can now be deleted. 

error At least one recipe phase in the control recipe of the 
batch has reported an error or the batch control itself is in 
an exceptional state. 

locked The batch is locked for processing (already open and in 
progress) 

 

5.6.5.1 Status of Production Orders 

The status of the production order provides the first information about the 
execution of the batch for an order. The status is updated in the tree structure and 
in the list display. 

 
Status Meaning 

empty The order does not contain any batches. 

planned There is or was no corresponding batch active; in other words, 
the batches have the status planned, released, release invalid, 
or canceled. 

running • At least onebatch belonging to the order is active 

• At least one Batch was already active and planned/released 
Batches still exist. 

Active means waiting, running, holding, held, pausing, paused, 
stopping, aborting, and completing. 

completed All corresponding batches are completed, aborted, or stopped. 

Additional Status 

The following icons indicate other statuses in addition to the production order 
status listed above. These icons are superimposed on the order icon. 

 

   Operator prompt Queued operator prompts of a Batch of a production 
order: 

• Operator instruction/ dialog or  

• Electronic signature (ESIG) or  

• Breakpoints 

  closed All batches in the job are completed. 

  archived All batches in the job are archived. 
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5.6.5.2 Releasing Batches 

Follow the steps outlined below: 

1. Select the batch in the batch overview list or in the tree structure (BatchCC). 

2. Select the menu command Control > Release. 

Result: The batch is released for production . If errors occur in the validation, the 
problems are displayed and the recipe status remains "planned". If no errors occur, 
the control recipe is compiled. Processing of the batch is started depending on the 
start mode. This assumes that the units required at the start of the control recipe 
are free. 

If errors occur in communication between BatchCC and the BATCH Server (Batch 
Control Server), the batch only changes to the "release prepared" status. After 
communication between BatchCC and BATCH Server (Batch Control Server) is 
functioning again, the release can be completed by executing "Release" again. 

5.6.5.3 Locking a Batch 

To prevent a released batch being started (by operator command or automatically), 
you can lock it. 

Follow the steps outlined below: 

1. Select the batch in the batch overview list or in the tree structure (BatchCC). 

2. Select the menu command Control > Lock. 

Result: The batch changes to the "locked" state . 

With the menu command Control > Cancel lock, you can return a locked batch to 
the "Released" status again. 

5.6.5.4 Canceling a Batch 

Batches can also be canceled. After it has been canceled, the batch can no longer 
be released or started. 

Follow the steps outlined below: 

1. Select the batch in the batch overview list or in the tree structure (BatchCC). 

2. Select the menu command Control > Cancel. 

Result: The batch changes to the "canceled" state . 
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5.7 Electronic Signature 

5.7.1 Specifying Electronic Signatures 

SIMATIC BATCH supports the function "Electronic signature" according to the 
requirements as regards FDA or 21 CFR Part 11.  

The function "Electronic signature" offers the user the possibility of entering one or 
more signatures in form of dialogs according to usual logon entry prompt for 
defined status transitions of Batches, recipe phases etc. or for Batch objects 
(recipes, Batches etc.) actions defined by the operator. 

The entered signature data is saved in the batch history or in the relevant object 
being manipulated and is available for subsequent evaluation (logging). 

The actions or status transitions of objects, for which the function "Electronic 
signature" is to be activated can be defined via the "ESIG" dialog box subject to the 
user roles (permissions). The acronym "ESIG" stands for "Electronic Signature". 

Requirement 

The logon data is verified based on the SIMATIC Logon Service software. This 
assumes that the SIMATIC Logon Service software is installed on the BATCH 
clients. 

What can be signed? 

• Status changes of batches, control recipes, unit recipes, recipe operations, 
recipe phases, and transitions 

• Operator action relating to batches, control recipes, unit recipes, recipe 
operations, recipe phases, and transitions 

The possible status changes and operator actions can be selected in the "ESIG" 
dialog box. 

Follow the steps outlined below: 

1. Select the batch, the master recipe, or library operation in BatchCC and select 
the menu command Edit > Properties. 

or 

In the BATCH Recipe Editor, select the recipe procedure, the recipe unit 
procedure, the recipe operation, the recipe phase, or the transition and then select 
the menu command Edit > Object Properties. 

Result: the dialog box "Properties of <Object name>" is displayed. 

2. Change to the "ESIG" tab. 

3. Select the "Activate" check box. 

4. Click the "New" button. 
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Result: The upper table displays all the possible operator actions that can be 
signed. 

5. Select the actions that you want to have signatures for in the "Active" column. 

6. Enter the time within which all the necessary signatures must be entered after 
the action in the "Time" column. If the time expires, a message to this effect is 
displayed in the message window of the PCS 7 OS. 

7. In the "sequence" column, select the actions for which the signatures must be 
entered in a specific order per action (assuming that more than one signature 
is required per action). 

8. In the "All at once" column, select the conditions, for which - if several 
signatures are to be made per operator input – all signatures are to be entered 
simultaneously, this means, in one opened signing dialog box. 

9. Click in the "Roles" column to define the signatures that must be entered 
based on the user roles. 

Result: The "Configure roles" dialog appears. 

10. Select the user roles here: 
 

 

 

... with this symbol, you move the "available roles" to the "configured roles" or 
back again to cancel already configured user roles. 

         

... with this button, you specify the sequence in which multiple signatures must 
entered. First click on a user role in the "Configured roles" list. 

11. Confirm the settings with OK. 

Result: All the signatures required and the necessary sequence of signatures are 
displayed in the "Configured roles" table in the  "ESIG" dialog box. 

12. Follow the same procedure for status changes (step 4 to 11). You make these 
settings in the second table of the "ESIG" dialog box. 

- Click in the "From" and "To" columns to select the status change to be 
signed. You can only select status changes that are possible for the 
BATCH object. 

- Using the "New" button, you can add further rows for status changes. 

13. When you have completed configuration, click OK. 

Result: When the object runs (batch, RPH, ROP, RUP, transition), the "SIMATIC 
BATCH: Sign" dialog box opens after each operator action or status change. To 
find out how to enter the electronic signature, refer to section "Signing operator 
actions and status changes". 
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5.7.2 Signing Operator Actions and Status Changes 

When the object runs (batch, RPH, ROP, RUP, transition), the "SIMATIC BATCH: 
Sign" dialog box opens after each operator action or status change  

The signature requirement of the corresponding object is also visualized in the 

control recipe with the symbols   and in the BatchCC tree structure view with 
the symbol . With a right-mouse click on the object to be signed and the context-
sensitive menu command Sign, this dialog box can also be opened.  

Via the "Sign" button in the dialog box "SIMATIC BATCH: Sign", you can start the 
signature entry. assuming that you have configured electronic signatures for the 
object. 

Requirement 

The logon data is verified based on the SIMATIC Logon Service software. This 
assumes that the SIMATIC Logon Service software is installed on the BATCH 
clients. 

Initial situation: 

After an operator action or during a status change, the "SIMATIC BATCH: Sign" 
dialog box opens automatically. As the representative of a user role, you are 
prompted to sign the action. 

Follow the steps outlined below: 

Your user role appears in the "Signatures" table of the "SIMATIC BATCH: Sign" 
dialog box: 

1. Click the "Sign" button. 

Result: the "SIMATIC Logon Service - Signature" dialog box opens. 

2. Enter your user name and your password and then select the correct domain 
or correct computer. 

3. Confirm with OK. 

Result: The information for the signature is displayed in the "Signatures" table. 

- If several signatures are required and the "All" option is active, all the 
signatures must be entered at the same time in one open "SIMATIC Logon 
Service - Signature" dialog box before clicking "OK". 

- If several signatures are required and the "Individually" option is active, the 
open "SIMATIC Logon Service - Signature"  dialog box can be closed 
again with "OK" after entering a signature. 

In both cases, the signature is complete, only when all signatures have been 
entered. 

4. Confirm the "SIMATIC Logon Service - Signature" dialog box with OK. 

 

 Note: 

Remember that it may be necessary to complete the signatures within a specified 
time. The time available and the expiry of the time is displayed in the "Times" 
group in the "SIMATIC Logon Service - Signature" dialog box. 
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5.8 Batch Control 

5.8.1 Requirements for Making Batches 

Requirements 

Batch control with SIMATIC BATCH requires the PCS 7 OS (WinCC) system. 
Before a batch can be made, the following requirements must be met: 

• The PCS 7 OS system must be operating in the runtime mode (online). 

• The SFC type instances or BATCH-interface blocks must be known to the PCS 
7 OS data manager. 

• The bus connection between the PCS 7 operator stations and the 
programmable controllers (PLC) must be active. 

• The batches for the control recipes must have been generated already; in other 
words, the batches have the "Released" status. 

• The operator has the necessary permissions for batch control in the user 
management of SIMATIC BATCH. 

5.8.2 Starting the BATCH Server 

Startup 

When you start the computer on which the BATCH Server (BATCH Control Server, 
batch data management) is installed, the SIMATIC BATCH Start Coordinator, the 
Batch Control Server, and batch data management are started automatically. 

The Batch Control Server and the batch data management are then in the 
"READY" status. 
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Changing the BATCH Server to the "RUNNING" Status 

How the BATCH Server changes from "READY" to "RUNNING" is set with the 
SIMATIC BATCH Start Coordinator. 

1. Right-click on the "SIMATIC BATCH Start Coordinator" in the status bar 
(bottom right) of the Windows window. 

2. Select the context-sensitive menu command Settings and select one of the 
following start options: 

 
Setting Meaning 

SIMATIC BATCH starts automatically 
after WinCC starts: 

Each time WinCC is started up online, the Batch Control 
Server and batch data management change to "RUNNING" 
automatically. 

SIMATIC BATCH starts automatically 
regardless of WinCC 

The Batch Control Server and batch data management change 
to "RUNNING" automatically whenever the computer starts up 
regardless of WinCC. 

SIMATIC BATCH is started manually  The Batch Control Server and batch data management change 
to "RUNNING" when this is triggered manually using the 
context-sensitive command Startup/shut down regardless of 
WinCC. 

 

 Note: 

Requirement: The batch process cell data is valid, correctly compiled, and 
downloaded. 

 

3. Following this, you can start a BATCH client application, for example BatchCC 
using the menu command Start > Simatic > SIMATIC BATCH > Batch 
Control Center. 

Behavior in a Distributed System 

If BATCH and PCS 7 OS run on separate computers in a distributed system, the 
BATCH Server automatically starts up completely after the computer starts up if 
one of the following options is set for the SIMATIC BATCH Start Coordinator:  

• SIMATIC BATCH starts automatically after WinCC starts: 

• SIMATIC BATCH starts automatically regardless of WinCC 

This means, the BATCH Server changes to RUNNING regardless of the WinCC 
status on the other computer. 

BATCH Server and BATCH Client on a Computer 

 

 Note: 

If the BATCH Server PC is used additionally as an operating and monitoring 
station (BATCH Client), this may reduce performance during certain functions (e.g. 
when printing out a large Batch log). 
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5.8.3 Flowchart: How is a Batch Started and Controlled? 

How is a Batch Started and Controlled? 

BatchCC / Batch Overview List

Release batch

Open control recipe for
batch (optional)

Automatic
mode

yes

no

Batch is started
automatically

View of control recipe with buttons
for control

Press “Start“
button

Visualization of the steps and
transitions with setpoint display
and status displays

Op. control
of batch

yes

no Press one of the buttons:
“- Pause“
- “Hold“
- “Resumed“
- “Abort“
- "Stop"

Batch is closed

Change
parameters

yes

no Change the parameter values in
the object properties

Op. control
of step

yes

no Press one of the buttons:
“- Pause“
- “Hold“
- “Resume step“
- “Complete step“
- "Abort step"
- "Stop step"
- "Reset step"

 



 Batch Control Center (BatchCC) 

SIMATIC BATCH 
A5E00272803-01 5-91 

The activities involved in batch control are as follows: 

• Opening the Control Recipe 

• Starting Production of a Batch 

• Changing Setpoints 

• Commands for Controlling Batches  

• Commands for Recipe Steps  

• Locking a Batch 

• Canceling a Batch 
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5.8.4 Basics of Batch Control 

5.8.4.1 Principle of Batch Control 

Definition 

By batch control, we mean the following: 

• Executing the Batches 

• Visualization and control of the batches on the PCS 7 OS 

Executing the Batches 

The program checks which units are required to start each released batch. Based 
on the IUNIT_BLOCK interface blocks, a check is made to find out whether the 
units required by SIMATIC BATCH are released and are not allocated to other 
batches. If the units are free and released, the batch can be started, otherwise the 
relevant parameters are reported for monitoring. 

Batch control is always ready to receive OS messages about parameter changes. 
If a monitored parameter changes, batch control is informed and takes the required 
action.  

Visualization and Operator Control of the Batches 

In BatchCC, the control recipe for a batch can be opened. The presentation of the 
control recipe represents that of the BATCH Recipe Editor. While a batch is being 
made, the states of steps and transitions are displayed color-coded. The dynamic 
display of events on the monitor also allows an operator to intervene. 
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5.8.4.2 Processing the Recipe Structure 

Principle 

The recipe structure of a control recipe is executed on the predecessor-successor 
principle at all hierarchical levels. This means, when the execution of a recipe 
element is completed, the execution of the successor step in the sequence is 
activated.  

Hierarchical recipe: Within a recipe unit procedure (RUP), the individual recipe 
operations (ROPs) are also executed sequentially. If the ROPs of different RUPs of 
a recipe procedure are synchronized, several recipe operations (in different RUPs) 
can be started at the same time. Within a recipe operation, the individual steps 
(recipe phases -> EPHs) and transitions (step enabling conditions) also execute 
sequentially.  

Example of a Hierarchical Recipe 

The following schematic shows the color coding used to visualize the execution of 
a control recipe with a typical hierarchical recipe structure. A synchronization is 
currently active in the left window. In the right-hand window you can see the 
execution of a recipe operation. This recipe operation is given the status complete 
only when the synchronization is satisfied. 
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5.8.4.3 Status Changes of a Batch 

The schematic below shows the possible statuses and status changes of a batch 
depending on the existing status.  
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5.8.4.4 State Transition Diagram of an Equipment Phase 

To execute a recipe, SIMATIC BATCH uses equipment procedural elements 
(EPE). This can be of the type EPH or EOP.  

To ensure problem-free cooperation with the overlying control, the equipment 
phase must provide the following basic states, the transitional states (framed with a 
broken line) are optional and not absolutely necessary:  

 

IDLE 
 

HOLDING 
 

STARTING 

RESUMING 
 

HELD 

ARBORTED STOPPED 

STOPPING 

START 

RESUME 

READY TO 
COMPLETE 

COMPLETING 

COMPLETED 

COMPLETE 

RESET 

START RUNNING 

ABORTING 

HOLD 

not self-terminating 

self-terminating 

HOLD 

ABORT STOP 

 

READY TO COMPLETE and COMPLETED 

As regards, equipment phase, the following distinction must be made: 

• A self-terminating equipment phase 

After it has run, such a phase changes to the COMPLETED status 

• Non-self-terminating equipment phase 

Once it has run, such a phase changes to the READY TO COMPLETE status. In 
the READY TO COMPLETE status, an EPE signals that it must be terminated 
actively by the control. 

Control in the Manual Mode ("Operation" Start Mode) 

Via the Recipe steps operating commands you can manually execute these state 
transitions, for example, during commissioning. 
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5.8.4.5 Self-terminating and Non Self-terminating Recipe Phase 

Self-terminating Recipe Phase 

For a self-terminating recipe phase, the normal transitions are from IDLE through 
RUNNING to COMPLETED. The diagram shown below illustrates a self-
terminating recipe phase: 
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Non Self-terminating Recipe Phase 

A non self-terminating recipe phase changes from IDLE through RUNNING to 
READY TO COMPLETE and then waits for the TERMINATE command from the 
overlying controller. With the READY TO COMPLETE status, the recipe phase 
signals that it needs to be terminated actively by the control (non self-terminating 
recipe phase). Below, you can see the flowchart of a non self-terminating recipe 
phase: 
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5.8.4.6 Parameter Trigger and Start Lock 

For the control strategy change function, the equipment phase must be capable of 
checking new setpoints and if necessary preventing the start. 

If the start lock is already set after the equipment phase is allocated, the recipe 
phase only rights the setpoints without the ISTART input. Instead, the recipe 
phase writes the IPARAM input to inform the equipment phase that there are new 
setpoints. The equipment phase then checks the setpoints and resets the IPARAM 
input and the start lock. 

Even when the equipment phase reaches the HELD status, it can still set the start 
lock to prevent a RESUME. No parameter trigger is necessary because the recipe 
phase does not permit a parameter change while a step is active. 
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5.8.4.7 Continuous Operation of Equipment Phases 

With SIMATIC BATCH V6.0 it is possible to 

• set different parameters for an equipment phase within the recipe without 
having to deactivate the equipment phase and reactivate it again afterwards. 

• to continue secondary activities such as agitating, temperature control or 
pressure control beyond the end of recipe operations. This means, for 
example, that an agitator does not need to be turned off at the end of an ROP 
and turned on again at the beginning of the next ROP. 

Technical Implementation of Continuous Operation 

If you want the equipment phase to continue after the end of the recipe phase, you 
must check the "Continue" box in the properties dialog of the recipe phase when 
creating the recipe.  

As soon as the equipment phase signals READY TO COMPLETE during execution 
of the recipe, the batch control sets the CONTINUOUS status ID in the block and 
resets this as soon as another recipe phase occupies the same equipment phase. 

READY TO
COMPLETE

COMPLETING

COMPLETED

TERMINATE

CONTINUOUS

CONT = 0

RUNNING not self-terminating

self-terminating
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Flowchart 

Below, you can see the flow chart of a non self-terminating equipment phase set to 
continuous operation: 

During the changeover, the equipment phase remains in the READY TO 
COMPLETE status. Instead of terminating the equipment phase, the first recipe 
phase simply sets the CONTINUOUS ID via the ICONT input in addition to the 
basis status. The setpoints/actual values are read prior to this. The sequence 
logic handles CONTINUOUS and READY TO COMPLETE in the same way as 
COMPLETED, in other words the recipe continues.  

Because the CONTINUOUS ID is set, the second recipe phase can occupy the 
equipment phase although its status is not IDLE. Once it is occupied, the 
CONTINUOUS ID is reset. To allow the second recipe phase to start the 
equipment phase, it is possible to START from READY TO COMPLETE in the 
equipment phase status transition diagram. 
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5.8.5 Starting Batch Control 

5.8.5.1 Working with Lists for Batch Control 

Selecting Lists for Batch Control 

Select an object in the "Orders" folder in the editing window and then select the 
required list in the Planning > ...menu. 

• Batch planning list 

• Batch Status List 

• Batch Result List 

Batch planning list 

The Batch planning list shows all planned and released Batches. You can also 
start the Batches via the Batch planning list context-sensitive menu command. 
When a Batch is started, this Batch remains visible in the Batch planning list and 
gets a new status (e.g. running). However, when you reopen the Batch planning 
list, this Batch will no longer be displayed.  

If you want to display all batches during batch control, work with the batch status 
list. 

Batch Status List 

The batch status list shows the processing status of each individual batch and 
allows the batches to be controlled using the context-sensitive menu for the listed 
object (right mouse button) or using the Control menu. 

As an alternative, you can, of course, select all the functions relating to batches in 
the tree structure (once again using the context-sensitive menu for the object). 
Working in the tree structure can, for example, be an advantage if a control recipe 
window is open at the same time. 
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Batch Result List 

The Batch result list shows all the completed, aborted, stopped and cancelled 
Batches. The display is updated dynamically. Using the context-sensitive menu for 
the batch result list, you can archive closed batches and then remove them. 
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5.8.5.2 Opening the Control Recipe 

You can see detailed information about the processing of the batch in the control 
recipe window. The control recipe of the batch is displayed as it was created in the 
BATCH Recipe Editor. 

Follow the steps outlined below: 

1. Select the batch in the batch status list or in the tree structure. 

2. Select the command Control recipe Open in the context-sensitive menu for 
the batch (right mouse button) or in the Control menu. 

 Result: The corresponding control recipe is opened and displayed graphically 
(analogous to the view in the BATCH Recipe Editor). The toolbar of BatchCC 
displays buttons for controlling the processing of the batch. When planned batches 
are opened, a validation check is run! 

Overview of the Control Recipe 

In BatchCC, you can open not only the control recipe but also a structural overview 
of the control recipe. With more complex control recipes, you can go to the relevant 
point in the control recipe window by clicking on a recipe element in the overview. 

• Select the menu command View > Overview of control recipe. 

Result: The overview belonging to the active control recipe window is opened (in 
the screen shot below: bottom left). If no control recipe is open, the overview 
remains empty (gray). 
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Example 
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5.8.5.3 Starting Production of a Batch 

Starting a Batch 

Only released batches can be started. Batches in the "immediate" and "time-
driven" start modes are started automatically (a manual start is also possible in 
these situations and has the same effect as a batch with the "operator" start mode). 
Batches with the "operator" start mode must be started explicitly in BatchCC. 
Below, you will find the options available for the "operator" start mode. 

 

 Note: 

You cannot start a batch if it is chained to another batch and this predecessor 
batch has not yet started or is not completed (depending on the chaining mode)! 

Starting the Entire Control Recipe (Batch) 

1. Open the control recipe. 

2. Click the  button or select the menu command Control > Start. 

Result: The batch is started. The execution of the control recipe is visualized by the 
color coding of the individual steps and transitions. 
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Starting Individual Recipe Elements 

To do this, select the recipe element in the control recipe and via the context-
sensitive menu, select Start step. 

Rules 

• A recipe element within a control recipe can only be started when the recipe 
element in the next higher hierarchy level has already been started. For 
example, a ROP at the next level down from a RUP can only be started when 
the RUP has already been started. 

• It is always possible to abort or halt a lower level recipe element. 

• Within a sequence, only one recipe element can be executing. This means, for 
example, that if a recipe operation (ROP) is active, no further ROP can be 
started at the same time in the same sequence within the same RUP. An 
attempt to start a further ROP would be rejected with an error message. 
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5.8.6 Operation During Batch Control 

5.8.6.1 Commands for Controlling Batches 

With the commands for controlling batches, you can start (only in the "operator" 
start mode), hold, resume or abort (only in the "operator" start mode) the selected 
batch.  

Buttons for Controlling a Batch (also available in the context-sensitive menu of 
the batch) 

 

Start  
(Start batch) 

Pause Abort 
(resume no 
longer possible) 

Hold Resume Stop  
(resume 
no longer 
possible) 
  

Controlling a Batch 

The following table describes the functions of the control buttons and the reaction 
of the batches. 

 
Button Meaning Reaction 

Start Starts execution of the 
control recipe 

With this command, you can start a released batch in the 
"Operation" start mode. Batches with the start mode 
"immediately" and "time-driven" are started automatically.  

You cannot start a batch if the batch is chained to another 
batch and the preceding batch has not yet been started! 

Pause Control recipe 
execution is being 
held, the steps in 
progress will be 
completed 

You can pause active batches using the "Pause" command. In 
contrast to the "Hold" command, this command simply prevents 
the control recipe from passing control to the next step. Active 
recipe phases are not affected and continue until they are 
complete.  

Batch control waits with the processing of the next transition or 
the start of the next recipe step until the Resume command is 
received. 

Hold Control recipe 
execution is being 
held, the steps in 
progress will not be 
completed 

You can stop batches immediately with the "Hold" command. In 
contrast to the "Pause" command, not only the batch itself but 
also all the recipe phases currently active in the control recipe 
are held. 

Resume Execution of the 
control recipe is 
resumed at the point 
at which it was 
stopped. 

This command resumes batches that have been held in the 
batch control. If the recipe phases were also stopped, these 
also return to the "Active" state. 
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Button Meaning Reaction 

Stop Execution of the 
control recipe is 
aborted 

The "Stop" command terminates batches that cannot be 
completed correctly.  

Stopped: You cannot resume stopped batches! When batches 
are stopped, remnants may remain in the units used for the 
batch!  

 

Caution: 

When you stop a batch, all the units occupied by the batch are 
released. First remove any remnants of the batch from the 
units involved before you use the "Stop" function in batch 
control so that the units can then be used by a later batch. 

Cancel Execution of the 
control recipe is 
aborted 

The "Abort" command terminates batches that cannot be 
completed correctly.  

You cannot resume aborted batches! When batches are 
aborted, remnants may remain in the units used for the batch!  

 

Caution: 

When you abort a batch, all the units occupied by the batch are 
released. First remove any remnants of the batch from the 
units involved before you use the "Abort" function in batch 
control so that the units can then be used by a later batch. 

Completing a Batch 

A batch is completed: 

• automatically when all the recipe steps of the batch were executed 
successfully 

• with the operator command "Abort" or "Stop" 
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Example of Controlling Batch Processing 
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5.8.6.2 Commands for Recipe Steps 

During the commissioning phase, you can also hold, resume or abort all the recipe 
procedural elements (RUP, ROP, NOP, RPH) within the hierarchical control recipe. 
The commands "Complete step" and "Reset step" are also available. With these 
commands, you can also force transitions to enable the next step. 

Menu Commands for Controlling Individual Recipe Elements 

Select any recipe procedural element (RUP, ROP, RPH, transition) within the 
control recipe and select the required command in the context-sensitive menu. 
Commands that are not possible in the current status of the element are gray and 
cannot be activated. 

 

Stop step, cannot be resumed 
Abort step, cannot be resumed 

Start step 

Pause 
Hold 
Resume step 
Close step 

Reset step, cancel allocated ID 
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Controlling Steps 

The following table describes the functions of the buttons and the reaction of the 
recipe steps. 

 
Button Meaning Reaction 

Start step Start execution of the 
control recipe at this 
step 

Inactive or completed steps (RUP, ROP, EPH, transition) can 
be restarted with this command. 

Pause The execution of the 
control recipe 
is held at this step, the 
currently active step is 
executed until it is 
completed. 

You can stop active steps (RUP, SUB, ROP) immediately with 
the "Pause" command. In contrast to the "Hold" command, this 
command simply prevents the control recipe from passing 
control to the next step. Active recipe phases of the step are 
not stopped but continue until they are finished. 

Batch control before evaluating the next transition or starting 
the next recipe step in the same level (RUP, SUB, ROP) until 
the "Resume step" command is received. 

Hold The execution of the 
control recipe 
is held at this step, the 
currently active step 
will not be completed. 

You can stop active steps (RUP, SUB, ROP, RPH, transition) 
immediately with the "Hold" command. All the active recipe 
phases in the step are held. 

Resume step Execution of the 
control recipe is 
resumed at the held 
step. 

The "Resume step" command resumes steps on hold (RUP, 
SUB, ROP). If the recipe phases were also stopped, these also 
return to the "Active" state. 

Note: 

Steps in the error state can be reactivated with "Resume step". 

Complete 
step 

Execution of the step 
is terminated 

This command terminates the recipe phase of a step (RUP, 
SUB, ROP, RPH) that are not self-terminating (requirement: 
READY status) 

Stop step Execution of the 
control recipe is 
stopped at this step 

Use the "Stop step" command to terminate steps (RUP, SUB, 
ROP, RPH, transition) that cannot be terminated correctly.  

Stopped steps cannot be resumed! When steps are stopped, 
remnants may remain in the units used for the step!  

Abort step Execution of the 
control recipe is 
aborted at this step 

Use the "Abort step" command to terminate steps (RUP, SUB, 
ROP, RPH, transition) that cannot be terminated correctly.  

You cannot resume aborted steps! When steps are aborted, 
remnants may remain in the units used for the step!  

Reset step Execution of the step 
is reset 

Following an abort, the unit or the equipment modules of the 
step are normally still allocated. "Reset step" cancels the 
allocation IDs of all the recipe phases in the step (RUP, SUB, 
ROP, RPH). 
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Example of Controlling Recipe Steps 
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5.8.6.3 Entering Comments on a Running Batch 

During or after batch control, the operator can enter comments for each control 
recipe element (RUP, SUB, ROP, RPH) or for the entire batch (control recipe 
header) without  needing to put the batch on hold (for example entry of laboratory 
values or comments on important events). 

Rules 

• Comments made on a current batch do not change or delete the original recipe 
comments. 

• Multiple comments can be entered for the control recipe elements or the entire 
Batch, for example, to correct errors or to add new information. 

• The previous recipe comment appears "Read only" beside the input field for 
new texts. 

• You can enter comments on running batches until the batch is closed. 

Follow the steps outlined below: 

1. Open the control recipe for the running batches (if not already open). 

2. Select a control recipe element or the entire control recipe (appears on a light 
blue background). 

3. Select the Comment on batch command or Comment on batch element in 
the context-sensitive menu. 

4. Enter any text you require in the dialog box and close the dialog box with OK. 
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5.8.6.4 Displaying Operator Dialogs During Run Time 

Using the "Operator instruction" recipe structure element, you can display 
instructions for the operator while batches are running or configure the information 
for manual intervention (for example manual dosing).  

Requirements 

• The Operator instruction was configured during creation of the master recipe 
as described in section Operator instruction (Insert Menu). 

• The control recipe is open. 

Principle 

An operator instruction during run time is displayed on all active BatchCCs on 
which the control recipe is open. On all other BatchCCs, there is simply a display in 
the message window. An operator confirms responsibility for the operator 
instruction by clicking the Accept button (input is then locked in the dialogs on the 
other BatchCCs).  

All other operators who are not responsible for acting on the operator instruction 
can minimize or close the dialog. This means that the operator dialog disappears 
from their screens but nevertheless remains for the process.  

After the operator has executed the operator instruction and, for example entered 
required process values, the operator confirms with "OK" in the operator dialog to 
indicate that the instruction has been executed. Once the operator dialog is 
acknowledged in this way, it disappears automatically from all the message 
windows. A process value can be entered in the "Input Material", "Output Material", 
and "Parameters" tabs of the operator dialog (refer to the figure below). 

As an option, acknowledgment by the operator can be configured as a condition for 
continuing the batch. Actual values that have been entered can be used in steps 
and transitions during the remaining execution of the recipe. 

Display in WinCC 

In WinCC, an operator request appears indicating that operator intervention is 
required. The operator is therefore informed of operator requests even when the 
control recipe is closed. 
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Branching after the Operator Dialog 

After the operator has entered the actual values, it is possible to branch in the 
control recipe after the operator dialog. 

Parameter 1
 == 4711

1 2 3

Parameter 1
 == 4712

Parameter 1
 == 4714

Operatordialog

 

5.8.6.5 Operator Requests using Group Displays in WinCC 

Requests to the operator regarding processing of the batch are displayed in 
WinCC using the group display. The operator can then open BatchCC and take the 
requested action.  

The following requests are triggered using a group display: 

• Acknowledge operator dialog 

• Enter the Electronic signature (ESIG) 

• Acknowledge breakpoint 

How it Works 

1. The BATCH Control Server determines that an Operator dialog or a Breakpoint 
is to be acknowledged or that an Electronic signature is required. 

2. From the unit recipe, the Batch Control Server finds out the unit involved and 
sets an input to trigger a WinCC message (entering state) of the type "Operator 
Request" in IUNIT_BLOCK. 

3. In the WinCC picture, a group display is interconnected with 
Unitname.EventState so that the operator request is visible. 

4. Using the corresponding IUNIT_BLOCK faceplate, the operator can open 
BatchCC and take the action required. 

5. The Batch Control Server then resets the input in IUNIT_BLOCK that in turn 
triggers an operator request (exiting state). 
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 Note: 

The area-specific group display can only indicate SIMATIC BATCH operator 
prompts that occur within a unit recipe. 

With flat recipes, the group display appears only with operator instructions when 
these were configured with unit allocation. 

 

 

 Note: 

Breakpoints cause a group display when they are within a unit recipe in 
hierarchical recipes. With flat recipes, this is unfortunately not possible because 
the unit allocation is linked to the individual steps. 

Configuring Pictures 

Within the WinCC picture tree, there are group displays interconnected with the 
individual IUNIT_BLOCK blocks (Unitname.EventState tag).  

As a practical measure, there should also be a button in a unit group display that 
displays the IUNIT_BLOCK faceplate. 

5.8.6.6 Setting Breakpoints 

During batch control, the operator can set breakpoints for each control recipe 
element in the open control recipe. The breakpoint appears as a red dot beside the 
control recipe element. If execution of the recipe reaches a recipe element with a 
breakpoint, the recipe is not activated. Only the run marker is set and the 

breakpoint is turned into a control button . The recipe element can be 
started with this button and the control recipe continued. It is also possible to 
activate the element with the start command for the recipe step. 

Follow the steps outlined below: 

1. Open the control recipe for the running batches (if not already open). 

2. Select a control recipe element. 

3. Select the Breakpoint > Set command in the context-sensitive menu. 

Result: The breakpoint appears as a red dot beside the control recipe element. 
With the Breakpoint > Remove  menu command, you can clear the breakpoint 
again. 

Note: When an active breakpoint is removed (the control button is displayed), the 
corresponding recipe element is started automatically. 
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5.8.6.7 States of a Transition 

A transition can adopt the following states: 

UNDEFINED

RUNNING
Transition checks

its conditions

EDITED
Transition

without
conditions

IDLE
Transition

with
conditions

HELD
Transition does

not evaluate
conditions

STOPPED
Transition
stopped

ABORTED
Transition
aborted

READY
Transition occupies

successor

COMPLETING
Transition terminates

predecessor

COMPLETED
Transition
complete

Transition with
conditions, e.g. in

HELD state

 

 

 Note: 

You can change the colors with the menu command Options> Settings. 
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5.8.6.8 States of the Batch Steps 

The state of a batch step is influenced from two sides: 

• On the one hand, by a processing block for the step functions in the controller:  

This sets the states: Running, completed, terminated, error, held, aborted  

• On the other hand, by the batch control: 

This sets the states: Waiting for unit, unit allocated, activated, (terminated), passed 

Structure of the Status Display of a Batch Step 

There are two basic parallel statuses and additional status identifiers: 

• Allocation status 

• Basic status 

• Added status identifiers 

HeatAllocation status

Basic status

Blocks

Error,
Manual,

Run time exceeded

Comment ID,
waiting for user routine

Operator prompts

Indicators for subobjects:
blocks, waiting, conditions

Breakpoint,
pending command
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Display of the Allocation Status - Hierarchical Recipe 

 
Appearance Label Meaning 

RUP
Mixer

 

waiting for unit The control wants to allocate the unit 
required by the RUP 

RUP
Mixer

 

unit allocated The control has allocated the unit to the 
RUP 

ROP

 

ROP running The control has allocated the ROP 

RPH

 

waiting for equipment 
phase 

The control wants to allocate the 
equipment phase required by the RPH 

RPH

 

equipment phase 
allocated 

The control has allocated the RPH 

RPH

 

Allocation error Allocation error or connection down 

Display of the Allocation Status – Flat Recipe 

 
Appearance Label Meaning 

RPH

 

waiting for unit The control wants to allocate the unit 
required by the RPH 

RPH

 

unit allocated The control has allocated the unit 
required by the RPH 

RPH

 

unit allocated and 
waiting of equipment 
phase 

The control wants to allocate the 
equipment phase required by the RPH 

RPH

 

unit and equipment 
phase allocated 

The control has allocated the RPH 

RPH

 

Allocation error Allocation error or connection down 
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Display of the Basic Status 

IDLE

Heat

CONTINUOUS

Heat

STARTING

Heat

HOLDING

Heat

HELD

Heat

READY

Heat

COMPLETED

Heat

PAUSING

Heat

STOPPED

Heat

UNDEFINED

Heat

EDITED

Heat

RUN

Heat

RESUMING

Heat

PAUSED

Heat

STOPPING

Heat

ABORTED

Heat

ABORTING

Heat

COMPLETING

Heat

Unlabeled icon =
transitional status
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Additional Status IDs - Breakpoint and Command 

The icon of the breakpoint operator button corresponds to the start button in the 
toolbar. The pending command is displayed with an icon corresponding to the 
operator button. The batch control sets the transitional state (for example 
HOLDING), only when this is sent by the block. 

Breakpoint buttonBreakpoint

Heat Heat

Example:
HOLD command

Heat

 

Additional Status Identifiers - Locks 

Priority: Write lock before start lock 

The write lock is set when a BATCH client is currently making online parameter 
changes or input in operator dialogs. The start lock is set when the PLC block 
signals the LOCK flag. 

Start lock

HeatHeat

Write lock
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Additional Status Identifiers - Operator Prompts 

Priority: Signature before operator dialog 

Heat

Electronic signature
required

Operator dialog to
acknowledge

HeizenHeat

 

Additional Status Identifiers - Command, Wait for User Routine and Comment  

Priority: User routine before comment 

waiting for user routine

Heat

comment added

Heat
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Additional Status Identifiers - Group Display (Traffic Light) for Container Objects 

With container objects, the group display provides information as to whether 
individual objects in the container are preventing processing: 

• Locks are displayed on the left: The lower-level object is held, aborted, or 
stopped. 

• Operator prompts are displayed on the right: The lower-level object is waiting 
for input (operator dialog, breakpoint, electronic signature) 

• Waiting events are displayed in the middle: The lower-level object is waiting for 
an external event (equipment module allocation, end of a user routine).  

Group display for hindering
subobjects

ROP

 

Additional Status Identifiers - Error, Manual, Run Time Exceeded 

Priority: Error before run time exceeded before manual  

Note: These icons can be displayed one superimposed on the other (for example 
error + manual). 

Heat

ERROR ID in basic status RUNNING
and ALLOCATED

Heat

ERROR ID occupying equipment phase

Run time exceededManual
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 Note: 

Note the following points about status visualization: 

• If at least one recipe element in a level has the "In progress" status, the recipe 
elements of the higher levels are also indicated as "In progress". 

• If no recipe element is in the "In progress" status, the highest priority state is 
reported to the higher levels. The only higher priority state reported is "Hold". 

• If a recipe element changes to the "Error" status, this state is reported to the 
higher levels immediately. If the entire batch is to be discontinued, this must be 
aborted at the batch level. 

 

 

 Note: 

You can change the colors with the menu command Options> Settings. 
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5.8.7 Changes During Batch Processing 

5.8.7.1 Changing Setpoints 

Introduction 

During batch control, the parameters (setpoints) of the control recipe can be 
modified by the operator (for example the speed of an agitator can be changed 
without stopping it). The following parameter values can be changed: 

• Input materials 

• Output materials 

• Process parameters 

Provided the online modification was configured for the corresponding parameter 
during recipe creation (see section "Allowing Online Modification of Setpoints") 

How Modification Affects RPHs and the Operator Dialog 

The new values are immediately available for all Recipe phases (EPH, EOP) and 
Operator dialogs not yet active. 

If recipe phases (EPH, EOP) and operator dialogs are running, this has the 
following effects: 

• Parameters is "modifiable": 
If the recipe step is currently being processed there will be no reaction to the 
operator modifying the parameter. The modified parameter only becomes 
effective when the step is processed again. 

• Parameter will be "Effective immediately": 
If the recipe step is currently being processed, parameter values changed by 
the operator will become effective immediately; in other words, they are 
transferred from the running recipe step in the control recipe directly to the 
controller where they take effect in the executing block. 

How Modification Affects ROPs and the RUPs 

The new values are available immediately for all not yet active recipe elements 
(ROP, RUP) and operator dialogs. 

Parameters is "modifiable": 
If the recipe element is currently being processed there will be no reaction after 
modifying the parameter via the operator. Modified parameter values only take 
effect the next time the element is executed (for example positioning within a loop). 

 

 Note: 

If another BatchCC currently has the recipe element open, not modification can be 
made on other BatchCCs. 
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Changing Setpoints 

You make the setpoint changes during batch control in the Properties dialog of the 
recipe element. The screen shot below is an example of the dialog for changing the 
parameters of the "Agitate1" recipe step.  

You open the properties dialog by selecting the recipe element and the Properties 
command in the context-sensitive menu. 

Then only the "Input materials", "Output materials" and "Parameters" tabs are 
displayed if there are parameters. 

If you press the "Modify" button, the parameter fields with the option "Modifiable" 
becomes editable (displayed in white). If applicable, modify the Setpoint value and 
then press the "OK" button. 

Beside the parameter fields, there is a check box. If the setpoints are changed, this 
check box is set. Only setpoints with an activated check box are transferred to 
batch control with a changed value. If you do not want the change to become 
effective immediately, deactivate this check box temporarily. 

Result: the modified setpoint values are applied. Depending on the settings, the 
setpoints take effect immediately or when the recipe element is processed again. 
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Response with Parameter References 

With parameter references (data source, data target), the response is as follows: 

• If parameters are marked as "Modifiable", the operator is permitted to enter 
new values.  

• Implicit modification by the control recipe remains possible for parameters not 
marked as modifiable. If, for example, an interconnected parameter in a recipe 
phase is not modifiable, it can nevertheless be modified by an operator making 
a change in the recipe operation.  

Even if the parameter is locked against modification in the recipe operation, a 
modification by target interconnections is still possible. 
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5.8.8 Displaying and Reacting to Status Messages 

5.8.8.1 Displaying Messages 

Requirement 

A PCS 7 OS (WinCC) runs on the BATCH client computer during run time. In other 
words, either an OS client application and/or an OS server application runs on the 
BATCH client computer. 

Principle 

All the messages for batch control (system messages, process messages, error 
messages) that are managed in the WinCC archives can also be displayed in 
BatchCC.  

To display these messages, you can open the message window of the PCS 7 OS 
(WinCC Alarm Control) in BatchCC in a separate display window.  

Displaying Messages 

• You can open the message window of the PCS 7 OS (WinCC Alarm Control) 
with the menu command View > Output window. 

Setting the WinCC Alarm Control 

To allow messages to be displayed, the PCS 7 OS must still be assigned. Follow 
the steps below: 

1. Right-click in the message window and select Properties. context menu 
command. 

Result: The "Properties of WinCC Alarm Control" dialog box opens. 

2. Select the "Selection" button under "Server Selection". 

Result: The "Select Server" dialog box opens. 

3. Here, select the PCS 7 OS (message OS). 

4. Confirm your selection with OK. 
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Customizing 

• You can customize the properties of the message window (familiar from 
WinCC), for example the columns displayed and the selection of messages. 

• User settings are entered in the global database and restored the next time 
you start BatchCC. Certain settings that are essential for SIMATIC BATCH are 
exceptions to this, for example selection of BATCH messages. 

• Using the Open control recipe menu command, the control recipe that 
matches the message can be opened. This function corresponds to the 
"LoopInAlarm" function in the WinCC message window. 

Example 
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5.9 Batch Management 

5.9.1 Batch Reports 

Definition of a Batch Report 

The batch report contains all the information required for the reproducibility of the 
batch process, the quality assurance and the fulfillment of legal requirements. 
These include the identification data, control recipe data, effective production data, 
chronological sequence of the steps, status, error and disturbance messages as 
well as operator intervention. 

Principle 

The batch report can be viewed or printed out at any time from the planning of a 
batch until its completion. This means that the report always includes the data up 
to the latest completed control recipe phase including the corresponding messages 
and measured values. 

Note: There is a delay when collecting the data for messages and measured 
values. Die Verzögerungszeit beträgt fünf Minuten.  

The batch report can be opened and printed in BatchCC by selecting the batch in 
BatchCC and opening the context-sensitive menu: 

• Print preview > Complete: Preview of the batch report 

• Print preview > Summary: Preview of the summary batch report 

• Print > Complete: The batch report is printed immediately without a preview 

• Print > Summary: Summary batch report is printed immediately without a 
preview.  

Batch Summary Report 

The batch summary report is an excerpt of the complete batch report and contains 
the report data from the top level (recipe). Das Chargensummenprotokoll ist eine 
Übersicht über  der Charge.  
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Time-of-day synchronization 

 

 Note: 

The batch management collects all messages from the start of the batch until the 
message "Batch closed". The start and close messages include the time of day of 
the computer on which the batch data management is running. To allow all 
messages to be detected in this time window, the time of day of all network nodes 
must be synchronized. 

Time-of-day synchronization: See manual PC Configuration and Authorization 

Display of Messages and Measured Values 

The display of messages and measured values for BATCH Report can be set in 
BatchCC using the menu commands Options > Settings > Batch 
messages/measured values tab: 

Possible Settings for Displaying Messages: 
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Possible Selection of Measured Value Trends: 

 

The batch report lists the minimum and maximum values of the process tags in a 
table for each of the levels listed above for the time for which the level was active; 
this is then followed by the trend diagrams. 

Displaying Batch Reports on Computers without SIMATIC BATCH Installation 

The application BATCH Report integrated in BatchCC converts the data from the 
archived Batch data to a Batch report. This application can also run on a computer, 
on which no SIMATIC BATCH is installed (on PCS 7 CD_3 under 
Additional_Products). 

Start the program via Start > Simatic > BATCH > SBReport. 

A window,in which you can select the file with the Batch data from the archive can 
be opened via File> Open. A Batch report is then created from this file. 

The displayed Batch report can be printed to a printer via File> Print Report. 
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5.9.2 Archiving Batches 

Introduction 

In BatchCC, you can also archive batches in long-term archives. These archives 
are used for long-term storage of batch data in compliance with FDA rules and 
these are not imported back into SIMATIC BATCH. 

You can only archive closed batches. 

Archiving Individual Objects 

With the context-sensitive menu, you can archive each closed batch individually by 
selecting the object in the tree structure and then selecting the menu command 
Archive in the context-sensitive menu (right mouse button). 

Archiving Several Objects 

You can also archive several closed batches at one time by opening a batch 
overview list and selecting the batches to be archived. You then select the Archive 
menu command in the context-sensitive menu (right mouse button). 

Defaults in BatchCC 

Date is archived on a configured storage path that can be set or modified globally 
in the "Settings" > "Archive" tab. 

You can make the following settings in the "Archive" tab: 

• Archive batches in XML format: You specify the target path (computer) 

• Archive batches in an ODBC (user data source): You specify the user data 
source 

You can open the "Settings" dialog with the  Options > Settings menu command. 
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5.9.3 Archiving with SQL Server 

If the batches in an ODBC (user data source) are to be archived, set the user data 
source, for example, Sybase SQL server in BatchCC before starting the archiving. 

Follow the steps outlined below: 

1. Open the SQL Server Enterprise Manager with the menu command Start > 
Programs > MS SQL Server > Enterprise Manager. 

2. Create a local user in the SQL Server Enterprise Manager.  

3. Open the dialog box "SQL Server Login Properties  <User>" of the new user. 

4. Assign the user role (SQL server) to the new user and define access to the 
data source (BATCH). 

5. Start BatchCC. 

6. Select the Options > Settings menu command in BatchCC. 

7. Change to the "Archive" tab. 

8. Select the "ODBC" option in the "Technology" tab. 

9. Click on the button to the right of the "Data source" field. 

10. In the "SQL Server Login" dialog box, select the SQL server and enter your 
login and password. 

11. Click the "Options" button. 

12. Enter the computer name. 

13. Start archiving the Batches: see Section Archiving Batches  

14. Result: In the Windows Explorer, the archived batches are stored under 
...\siemens. The archived batches can be queried in the SQL Query Analyzer. 
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5.10 Data Backup 

5.10.1 Backup (Options Menu) 

Using this menu command, you can create a complete backup of your configured 
data (Libraries, Master recipes, Materials, user rights etc.) as a backup file in XML 
format: 

With the Options > Restore menu command, you can restore the backup files in 
BatchCC. 

5.10.2 Restore (Options Menu) 

With this command, you can completely restore backup data (command Options > 
Backup) from a backup file (XML). This assumes that the batch database is still 
empty (does not yet exist). The restore function can only be used if this is the 
situation. 

Follow the steps outlined below: 

To execute the Restore function, the following steps are necessary: 

1. Start BatchCC.  

Result: The editing window in BatchCC is still empty. 

2. Select the menu command Options > Restore. Select the backup file (XML) 
you require. 

3. Click the "Open" button. 

Result: The data is restored in BatchCC. The current database for SIMATIC 
BATCH is recreated with the data of the backup file. 

 

 Note: 

After you have restored the backup files in BatchCC, the assignment of user roles 
(permissions management) made in the SIMATIC Logon must be repeated 
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6 BATCH Recipe Editor 

6.1 Introduction 

The BATCH Recipe Editor allows the graphic creation and modification of recipes.  

When editing recipes, a distinction is made between the following: 

• Flat recipes  

• Hierarchical recipes 

• Library object: Recipe operations 

• Library object: Substructure 

Flat Recipe 

A flat recipe is made up of substructures. The substructure is used to make large 
recipes clearer to read.  

The recipe steps of a substructure can be as follows: 

• A further substructure 

• A reference to a library object: Substructure 

• ROP (recipe operation) with direct access to a recipe phase of the type EOP 
(equipment operation) 

• RPH (recipe phase) with direct access to a recipe phase of the type EPH 
(equipment phase) 

• Operator instruction: Recipe phases of the type EOP and EPH configured for 
the operator instruction and NOP for a simple operator instruction 

 

 Note: 

The run-time properties of the recipe are not influenced by the substructures. 
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Hierarchical Recipe 

A hierarchical recipe consists of recipe unit procedures (RUP) that are assigned to 
a unit. The recipe unit procedures are processed parallel to each other in a recipe. 
The execution of the recipe unit procedures can be coordinated using graphic 
synchronization lines.  

The recipe steps of a RUP can be as follows: 

• ROP (recipe operation) with direct access to a recipe phase of the type EOP 
(equipment operation) 

• ROP with an underlying sequence of recipe steps of the type RPH (recipe 
phase). 

- RPH with direct access to a recipe phase of the type EPH (equipment 
phase) or  

- Operator instruction with or without direct access to a recipe phases of the 
type EPH  

• Operator instruction: Recipe phases of the type EOP and EPH configured for 
the operator instruction and NOP for a simple operator instruction 

• Library reference 

Library Object: Recipe Operations 

 A library of library operations can be created for hierarchical . A library operation 
is an ROP consisting of steps of the type RPH. When creating the library step 
sequence, this is assigned to a unit class so that the recipe steps access the 
equipment phases (EPH) of this unit class. The unit allocation is made when you 
bind in the recipe step sequence of a recipe unit procedure (RUP). 

Library Object: Substructure 

A library consisting of substructures, in turn consisting of operator instructions, 
recipe operations of the type EOP or recipe phases of the type EPH can be 
created for flat recipes . Different unit classes/units can be assigned to the recipe 
steps of the substructure.  
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6.2 Starting and Operating 

6.2.1 Starting the BATCH Recipe Editor 

There are three different ways in which you can start the BATCH Recipe Editor: 

• From the Start menu of Windows 

• Using the menu command in BatchCC 

• Automatically by opening a recipe in BatchCC 

Starting in the Start Menu of Windows 

• Go to the Start menu of Windows and select the menu command Start> 
Simatic > SIMATIC BATCH > BATCH Recipe Editor . 

Starting in BatchCC 

• In BatchCC select the  button or the menu command Options > Start 
Recipe Editor to open the Batch  Recipe Editor. 

• If you select a master recipe or a library object in BatchCC and then select the 
Open command (right mouse button) or double-click, the BATCH Recipe 
Editor is automatically started with the recipe. 

 

 Note: 

With the exception of deleting and renaming recipes that is only possible with 
BatchCC, you can make all possible modifications to recipes using the BATCH 
Recipe Editor. 
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6.2.2 Requirements for Working with the BATCH Recipe Editor 

Before you can work with the BATCH Recipe Editor, the following requirements 
must be met: 

• A recipe operates on the basis of the block instances of the SFC types or the 
BATCH interface blocks IUNIT_BLOCK, IEOP, IEPH, IEPAR_xxx and 
TAG_COLL created in the CFC charts and the additional data in the batch 
hierarchy folders (SIMATIC Manager).  

The Process cell data created this way has to be downloaded to the Batch Server 
and read in BatchCC via the menu command Program > New process cell  or 
with the menu command Edit > Updating the process cell  after modifying the 
Process cell data. 

 

 Note: 

It is possible to create recipes before configuration of the block instances is 
completed. To allow this, you can edit the type description (batch types) the first 
time manually (without a CFC synchronization) and download it as part of the 
process cell data to the BATCH Server.  

At a later point in time when the CFC charts have been finalized, you must then 
repeat the menu command Edit > Update process cell in BatchCC. 

 

• You must have the relevant permissions with an entry in the user list (user 
rights) allowing you to use recipe creation functions. 
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6.2.3 User Interface and Operation 

6.2.3.1 Layout of the Main Window 

The basic layout of the user interface of the BATCH Recipe Editor is shown in the 
figure below which illustrates an example of a hierarchical recipe. You can create 
or modify recipes in the editing windows using the structure elements of the Insert 
menu.  

The first editing window displays either the structure of a recipe or a library object 
(editing level 1). In the other editing windows, you can edit the lower-level ROP 
sequences (in hierarchical recipes this is editing level 2) or substructures (in flat 
recipes this is editing layer 2 to 10). 

 Title bar Toolbar Buttons for  
changing the view 

Menu bar 

Status bar with 
context-sensitive 
information 

Editing window with recipe 
structure of a hierarchical master 
recipe with ROPs 
(editing level 1) 

Editing window with a ROP 
sequence (editing level 2) 
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Title Bar 

The title bar of the main window displays the name of the master recipe, the recipe 
operation (ROP) or the library object. Here, you will also find system buttons with 
which you can do the following: 

• Close the BATCH Recipe Editor, 

• minimize the main window to its icon, 

• restore the window to its normal size again, and 

• maximize the display of the main window. 

Menu Bar 

The menu bar is located at the top edge of the main window. Its functions relate to 
the currently editing window. You can only select menu commands that are 
feasible in the current status of the object. As an example, you can only select the 
menu command Edit > Delete when at least one object is selected. Menu items 
that cannot be selected are displayed in gray. 

Toolbar 

The toolbar is located below the menu bar. It contains a series of buttons that 
trigger the more commonly required functions of the menu bar. You can see which 
function is triggered by a button in the toolbar by positioning the mouse pointer on 
the button (without clicking). A box appears with the name of the button. In the 
status bar, you can see more detailed information about the function. Clicking the 
button triggers the function. Buttons that cannot be selected are displayed in gray. 

Status Bar 

At the lower edge of the user interface, you will see the status bar that displays 
important information and statuses. The information displayed changes depending 
on the particular operation and object status. 

In the left part of the status bar you will see context-sensitive information, for 
example explanations of menu commands, operator prompts or error messages. 

In the right part of the status bar, you can see the current user and the current 
time. In some situations, a progress bar is also displayed for processes that require 
longer. 

Context-Sensitive Menu 

With the right mouse button, you can display the context-sensitive menu containing 
functions from the menu bar frequently required in the current situation. Only the 
functions that are feasible for recipe element can be selected, all others are 
displayed in gray.  
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Assigning Names to Recipe Elements 

Beside each recipe element, there is a number that, in conjunction with the freely 
selected name of the recipe element chosen by the user, forms the unique system 
name. Even if the same name is assigned, the name within the system will still be 
unique. 

6.2.3.2 Options for Customizing the Editing Window 

Changing the View 

Stufenweises Vergößern, bis die gewünschte Größe erreicht ist.

Stufenweises Verkleinern, bis die gewünschte Größe erreicht ist.

mittlere Zoomstufe (Normalgröße) einstellen

Einpassen auf genutzte Fläche

übergeordnete Ebene wird angezeigt

Zoomausschnitt wählen für optimale Anpassung an Fenstergröße

Direkthilfe einschalten
 

In addition to the functions shown above, you can also use the View > Fit 
automatically menu command to activate automatic window adaptation. If you 
increase the size of the recipe structure or the editing window, the content is 
automatically increased or reduced in size. 

Zoom Bar 

This is an extra zoom bar with which you can adapt the size quickly. To save 
space, you can also hide the zoom bar. 

Zoom in stages

Close zoom bar

Display of zoom

Zoom slider
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6.2.3.3 Creating and Manipulating Objects 

Selecting Functions 

All important functions relating to an object are available in the context-sensitive 
menu.  

As an alternative, the same functions are also available in the Edit  menu. 
Functions that cannot be executed in the current status of an object are 
deactivated (displayed in gray) in the Edit menu. 

General Functions 

Some basic functions are common to all objects. These common functions are 
listed below. The descriptions of other functions assume that you know how to use 
these functions. 

The normal sequence of activities involving objects is as follows: 

• Creating the object 

• Selecting the object 

• Performing actions with the object (for example, open, delete). 

Creating Objects 

All objects of the master recipe are created with the Insert menu.  

As an alternative, you can also use the corresponding object icons in the toolbar. 
You display the toolbar with View > Toolbars > Insert. 

Opening Objects 

There are several ways of opening an object: 

• Double-click on the object icon 

• Select the object and then the menu command Edit > Open object. 

After opening an object, you can create or modify its content.  

Properties of Objects 

Object properties are data belonging to the object that decide its behavior, for 
example the properties of a recipe operation.  

The menu command Edit > Object properties opens a dialog box in which you 
can see and set the properties of the selected object.  
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Cut, Paste or Copy 

You can also cut, paste, or copy most objects as normal in Windows. The menu 
commands for this are in the "Edit" menu.  

You can also copy objects using (Drag-and-drop). If you point to an illegal target, 
the cursor changes to a forbidden sign.  

When you copy an object, the entire hierarchy below it is also copied. As a result 
you have wide options open to you if you want to use your developed components 
more than once.  

 

 Note: 

When you insert, the target position must be specified by mouse click. 

Renaming Objects  

You can change the name of an object at a later point in time in the Object 
Properties. 

Deleting Objects 

You can delete all objects. Deleting can be undone. A master recipe or a library 
operation can only be deleted in BatchCC. 

Undoing/Redoing Actions 

With the Undo/Redo menu commands, you can reverse modifications step-by-step.  

After undoing "n" actions, you can also redo "n" actions.  
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6.2.3.4 Selecting Objects 

Selecting by Clicking 

If you activate the selection mode with , you have the following options: 

• By simply clicking with the mouse, all objects (Structure Elements), which were 
selected, will be deselected. 

• You can select RUPs, ROPs, RPHs, SUBs, library references, and transitions 
by simply clicking on them with the left mouse button. 

• Select sequences, diverging sequences and loops not by clicking a step or a 
transition but on the line between the step and transition (to select a 
sequence), on the upper or lower horizontal line (to select a simultaneous or 
alternative sequence) or on the upper or lower horizontal line of the return path 
(to select a loop). 

• Select an open ROP by selecting the initial step, the final step or the sequence 
containing the initial or final step. 

• When you make a selection, other selected objects are deselected. 

Selecting with a Lasso 

To open a lasso, drag the mouse while holding down the left mouse button. All the 
elements completely enclosed in the lasso frame are selected when you release 
the mouse button. Previously selected elements are deselected if they are outside 
the lasso frame. 

Selecting Further Objects 

If you want to select several objects, hold down the CTRL key and click the objects 
with the mouse. The element you have clicked is selected without deselecting 
previously selected elements. 

Deselecting 

If you have accidentally selected an object, you can deselect it by clicking it again 
while holding down the CTRL key. 
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6.3 Topology of Recipes 

6.3.1 Flat Recipes 

Flat Recipes 

With the BATCH Recipe Editor, you create flat recipes. To make the structure 
clearer, you can move existing sequences of recipe elements into a substructure.  

 

 Note: 

The run-time properties of the recipe are not influenced by the substructures. 

Basic Structure 

The following figure illustrates the basic structure of a flat recipe that can contain 
both recipe operations (ROPs) that use EOPs, as well as recipe operations made 
up of recipe phases (RPHs) and that use EPHs. These EOPs and EPHs are 
created during engineering of the basic control (refer to the section on configuring 
the ES). 

Recipe
procedure

(RP)

Recipe
operation

(ROP)

 is an ordered set of

Recipe
phase
(RPH)

Equipment
operation

(block EOP)

Equipment
phase

(block EPH)

 is an ordered set of is an ordered set of (optional)
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6.3.1.1 Using Substructures in the BATCH Recipe Editor 

Principle 

The schematic below shows the basic use of substructures when editing flat 
recipes with the BATCH Recipe Editor. A substructure itself can be made up of 
other substructures.  

The structure of a flat recipe can be edited in a maximum of 10 levels when using 
substructures. 

Editing level 1 
Recipe procedure (RP) with  

substructures (SUB), ROP and 
RPH 

SUB RF 

End 

SUB 

SUB 

ROP 

Start 

SUB 

Editing level 2 
Substructure (SUB) with  

substructures (SUB), 
ROP and RPH 

 

SUB 

ROP RF 

Start 

End 

Editing levels
3 ... 10 

 

 

  

 

 

Synchronization 

 

Using the synchronization functions, you can coordinate the execution of recipe 
sequences. In flat recipes, synchronization in sequences of the same simultaneous 
sequence are possible. 

At each synchronization point, you can decide whether or not the sequence is 
halted. If you select lock, the sequence waits until the other sequences involved 
have reached the synchronization line or have already passed it. If you do not 
select a lock, the sequence does not wait for the other sequences. The fact that the 
synchronization point was reached is nevertheless recorded. 
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6.3.2 Hierarchical Recipes 

Hierarchical Recipes 

With the BATCH Recipe Editor, you create hierarchical recipes. The following 
recipes are possible: 

• Hierarchical Recipes with ROPs  

• Hierarchical Recipes with RPHs  

• Hierarchical Recipes with ROPs and RPHs  

6.3.2.1 Hierarchical Recipes with ROPs 

The schematic below shows the basic structure of a hierarchical recipe with EOPs. 
Below the recipe unit procedure (RUP), there may be several recipe operations 
(ROPs). The recipe operations use the EOP blocks directly. These EOPs are 
created during engineering of the basic control (refer to the section on configuring 
the ES). 
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6.3.2.2 Hierarchical Recipes with RPHs 

The schematic below shows the basic structure of a hierarchical recipe with recipe 
phases RPHs. In this model, the process cell is structured in greater detail during 
engineering with the ES. A unit has several equipment modules that can contain 
several EPHs. 

No recipe phases are possible directly below a recipe unit procedure (RUP). 
Recipe phases can, however, be used in the underlying substructure of the ROP. 
EPHs are assigned to these recipe phases. 
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6.3.2.3 Hierarchical Recipes with ROPs and RPHs 

With SIMATIC BATCH, you can also create recipes that contain both recipe 
operations (ROPs) that use EOPs as well as recipe operations that are made up of 
recipe phases (RPHs). 
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6.3.2.4 Representation of the Hierarchy in the BATCH Recipe Editor 

Principle 

The schematic below shows the basic representation of the hierarchical structure 
when editing with the BATCH Recipe Editor. The structure of a hierarchical recipe 
is edited at two levels (editing level 1 and 2). 

 

ROP 

ROP 

ROP 

ROP 

Start 

Editing  level 1 
Recipe procedure (RP) 

(with recipe unit procedures 
(RUP 1 ...)) 

ROP 

RPH 

RPH RPH 
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Recipe operation 

(ROP) 

Start 

End 

RUP  2 RUP  1 

End 
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Editing Level 1 

Editing level 1 is intended for the plant view in which the processes of several cells 
can be synchronized. A recipe unit procedure (RUP) is made up of recipe 
operations (ROPs). To structure the process, you can use double lines to 
synchronize. This allows you to synchronize the timing of ROPs in different units. 

 

 Note: 

Free editing mode: 

In this mode, you can use all the structure elements of editing level 2 at editing 
level 1 (parallel ROPs, loops, transitions,...).  

Since this mode does not correspond to the standard, this mode will not be 
described in any greater detail. The way in which the structure elements function is 
the same at both editing levels. 
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Editing Level 2 

Editing level 2 is used to create ROP sequences. An ROP sequence begins with a 
Start step. The Start step is followed by a transition that defines the start 
conditions. Every ROP sequence ends with an End step. A transition that defines 
the end condition precedes every end step. 

Implementation in the BATCH Recipe Editor 

 

1. Recipe unit procedure 
(RUP 1) with ROPs and 

recipe operations 

2. Recipe unit procedure 
(RUP 2) with ROPs  

and recipe operations 
ROP sequence with the 
SFC structure elements, 
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branches etc. A RUP is always shown within column, i.e.  

the ROPs are arranged vertically. 

Editing level 1 Editing level 2 

Synchroni- 
zation line  
between 

RUPs 
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6.3.2.5 Synchronization between Recipe Unit Procedures 

Principle 

Using synchronization, you can synchronize the ROPs of several recipe unit 
procedures (RUPs) with each other at editing level 1. Each position where a 
synchronization line connects a recipe unit procedure can have a blocking or non-
blocking effect. If blocking is required, the recipe unit procedure continues only 
when all recipe unit procedures involved in the synchronization have reached the 
synchronization point. 

Example of Synchronization (Blocking) 

In the screen chart shown below, the synchronization lines (blocking) between the 
two recipe unit procedures (RUPs) shown cause the following reactions: 

• Line 1: ROP 10 and ROP 6 start steps 20, 5, 13 

• Line 0: ROP 5 and ROP 14  start steps 11, 16 
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Changing Over Between Blocking and Non-Blocking 

You can change the blocking or non-blocking effect of each synchronization point. 
Follow the steps outlined below: 

1. Select the synchronization point. 

2. Select the Properties command in the synchronization point context-sensitive 
menu. 

3. Enable or disable the "Blocking" check box. 

4. Confirm with OK. 

Result: The synchronization point is displayed with a single line . ROPs/NOPs in 
the sequence following this are started immediately (without waiting for 
synchronization). 

Example of Synchronization (Non-Blocking) 

The non-blocking positions below "Material entry 10" means 

• that ROP 20 is processed further by RUP "Dosing setpoint" Immediately when 
ROP 10 is completed. 

• that ROP 5 and ROP 13 are only started when ROP 10 and ROP 6 are 
completed. 
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6.3.3 Necessary and Possible Structure Elements in Recipes 

6.3.3.1 Structure Elements of Recipes 

The following structure elements can be inserted in the sequences:  

 

Structure Element Inserted with Button/Menu Command ... 

Recipe Procedure (RP)  Recipe > New 

Recipe Unit Procedure (RUP)     Recipe procedural element (Insert Menu) 

Recipe Operation (ROP)     Recipe procedural element (Insert Menu) 

Recipe phase (RPH)     Recipe procedural element (Insert Menu) 

    Recipe phase (Insert Menu)  

Substructure (only for flat recipes)     Recipe procedural element (Insert Menu) 

Library reference      Library reference (Insert Menu) 

Operator instruction      Operator instruction (Insert Menu)  

Transition      Transition (Insert Menu)  

Simultaneous Sequence     Simultaneous sequence (Insert Menu)  

Alternative Sequence     Alternative sequence (Insert Menu)  

Synchronization line  Synchronization (Insert Menu)  

Synchronization point  Synchronization (Insert Menu)  

Loop      Loop (Insert Menu)  

  

Step Placeholder (automatically by BATCH Recipe Editor) 

Transition Placeholder  (automatically by BATCH Recipe Editor) 

Working with Sequences 

The structure elements are inserted in sequences. A sequence is a vertical series 
of structure elements. The elements in the sequence are separated by a vertical 
line. 

Meaning: 

Actions to be executed one after the other must be arranged vertically in a 
sequence. A transition is evaluated only when the recipe phase above is 
completed (ready to complete, or similar). The next recipe step is only triggered 
when the transition above it evaluates to true. 
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6.3.3.2 Recipe Procedure (RP) 

The recipe procedure includes the procedural elements required for the process 
engineering in a process cell. When creating a recipe procedure, the equipment-
related procedural elements are used that are provided by the basic control. 

Recipe Procedure Window 

The recipe procedure window displays the required units in columns. The structure 
elements, steps, transitions, loops etc. that determine the process sequence can 
be included in the columns. The processes in the unit are coordinated by the 
"synchronization line" structure element. 

Properties 

The properties of the recipe procedure reflect the header parameters of a recipe. 
This includes specifications such as the product, parameters, reference scale, 
input and output materials,.... 

6.3.3.3 Recipe Unit Procedure (RUP) 

The recipe unit procedure includes the procedural elements required for the 
process engineering in a unit.  

The recipe unit procedures are the columns in the recipe procedure window. The 
recipe operations of the unit are the steps in the recipe procedure window. The 
name and selected unit are displayed in the column title. By double-clicking the 
column title, the properties dialog of the recipe unit procedure is opened.  

The steps in a recipe unit procedure can have the following functions: 

• Steps with access to a recipe phase of the type EOP 

• Substitute for a step sequence for this unit integrated in the recipe 

• Library reference for a library operation 

• Operator instruction 

6.3.3.4 Recipe Operation (ROP) 

The recipe operation includes the procedural elements required for the process 
engineering of a recipe operation. When creating a recipe procedure, the 
equipment-related procedural elements are used that are provided by the basic 
control. 

Steps can take the following forms: 

• Operator instruction 

• Steps with access to a recipe phase of the type EPH 
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6.3.3.5 Recipe Steps in a Recipe Operation (RPH) 

At this level, recipe phases are entered in the form of operator instructions or 
recipe phases of the type EPH. 

6.3.3.6 Substructure 

A flat recipe is made up of substructures. The substructure is used to make large 
recipes clearer to read. Units of the recipe that belong together can be moved to 
their own section and abstracted using the substructure box SUB. 

A substructure can consist of recipe steps in the form of operator instructions, 
recipe operations of the type EOP or recipe phases of the type EPH. A different 
unit can be assigned to every recipe step. 

 

 Note: 

The run-time properties of the recipe are not influenced by the substructures. 

 

6.3.3.7 Library reference 

A library operation is not linked directly into a recipe procedure (RUP) but uses a 
library reference. The library operation cannot be modified within the master recipe; 
the library operation must always be opened explicitly in the BATCH Recipe Editor. 

6.3.3.8 Operator instruction 

The operator instruction allows instructions for the operator to be displayed during 
the processing of a recipe. A distinction is made between output of 

• pure instructions (NOP step): 

- - without acknowledgment; in other words the recipe is not stopped.  
Example: Please put on protective glasses! 

- - with acknowledgment; in other words, the recipe is stopped until the 
operator acknowledges.  
Example: Please close valve V127. 

• an instruction with input option (operator dialog) 

- - No acknowledgment 
Example: Entry of analysis process values. 

- - With acknowledgment 
Example "manual dosing": The operator is instructed which material and 
how much to add. The operator then enters the actual values that have 
been added and confirms the input (acknowledgment). 

Entered values (actual values) can be used as setpoints for subsequent recipe 
phases/operations. The actual values can also be evaluated in transitions, 
example: Sample good? yes/no. In this case, an acknowledgment must be set in 
the parameters 
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6.3.3.9 Transition 

Along with the step, a transition is a second element type used in structuring a 
recipe. It contains the step enabling conditions between the steps. 

6.3.3.10 Simultaneous Sequence 

A simultaneous sequence consists of at least two horizontally arranged sequences 
joined at top and bottom by double lines. 

Function: 

A simultaneous sequence leads to simultaneous processing of several sequences. 
This allows processes to be executed at the same time. 

With simultaneous sequences, the sequence paths are processed only when all 
paths can be processed. This ensures, for example, that it is only possible to "heat" 
when the "agitator" is active.  

 

 Note: 

If 2 equipment phases of the same unit are installed in one simultaneous sequence 
and one of the two phases is in automatic mode and the other in manual, during 
processing, the unit will be occupied by the equipment phase in automatic mode.  

At this point, execution of the simultaneous sequence stops. Even the equipment 
phase in the automatic mode, that is occupying the unit is not processed. 

Synchronization Lines 

Another method of coordinating sequences is to create synchronization 
linesbetween the recipe steps. 

6.3.3.11 Alternative Sequence 

An alternative sequence consists of at least two vertically arranged sequences 
joined at top and bottom by a single horizontal line.  

Function: 

With alternative sequences, you can adapt the execution of the recipe to states in 
the process. The conditions in the top transitions of the sequences decide which 
sequence is executed. 

6.3.3.12 Synchronization line 

The synchronization lines coordinate the execution of recipe sequences in the units 
or of the recipe operations (ROPs) between the units.  

6.3.3.13 Synchronization point 

In each synchronization point, you can decide whether execution is continued or 
halted. 
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6.3.3.14 Loop 

A loop consists of a sequence with at least one recipe step and a return path with a 
transition. 

Meaning: 

The loop allows multiple iteration of a sequence structure. 

The transitions following the loop and in the return path decide how often the 
sequence is repeated. If the condition in the transition following the loop is 
satisfied, control exits the loop. The conditions of the two transitions should be 
mutually exclusive so that it is not the order in which the transitions are evaluated 
that is relevant but rather the logic itself. 

6.3.3.15 Step Placeholder 

Incomplete structures must be completed dynamically so that they are always 
syntactically correct and complete. To make sure this is done, the BATCH Recipe 
Editor automatically inserts placeholders for recipe phases and transitions. 

A recipe phase placeholder appears like an empty recipe phase. By double-clicking 
or inserting a recipe phase using the menu or the toolbar, the placeholder becomes 
a recipe phase. 

These dynamically generated placeholders are removed again when they are no 
longer required or they become NOP (no operation) recipe phases when the recipe 
is saved. 

NOP elements can also be used, for example to specify a defined runtime. 

6.3.3.16 Transition Placeholder 

Incomplete structures must be completed dynamically so that they are always 
syntactically correct and complete. The recipe editor therefore automatically inserts 
placeholders recipe phases and transitions. 

A transition placeholder has the appearance of an empty transition. 

To convert a transition placeholder to a transition, simply double-click on symbol, 
or insert a transition into the placeholder  via the Insert menu or the Toolbar. 
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6.4 Recipe Creation 

6.4.1 How to Edit a Flat Recipe 

Follow the steps outlined below in the BATCH Recipe Editor: 

1. Select the menu command Recipe > New  > Flat recipe (for a master recipe) or 
Library element: Substructure . 

Result: A new editing window is displayed for editing level 1. 

2. Enter the topological structure of the recipe in editing window 1 and any nested 
editing windows (substructures).  
Required substructures (= SUB) can be created with the "recipe procedural 
element". By double-clicking on a "SUB", opens the editing window for the 
substructure. 

- To create a new recipe element, select one of the following buttons in the 
toolbar:  

 

Result: The element attaches to the mouse pointer. 

- Move the mouse to the required position in the editing window and click. 

Result. The element is inserted. The icon for the recipe element is still 
attached to the mouse pointer. The function of the mouse pointer changes 
only when you select a different element. 

- Click  (selection arrow) or press the ESC button to change from the 
editing to the select mode again. 

3. Assign the unit to a unit class in the Properties dialog for each recipe step. 
Select with the Object properties command in the context-sensitive menu for 
the recipe step. 

4. Select the recipe elements one after the other and make the other settings you 
require in the corresponding Properties dialog By selecting the Object 
properties command in the relevant context-sensitive menu (selected with the 
right mouse button). 

5. Check the validity of the recipes By selecting the menu command Recipe > 
Validate. 

6. Save the recipe at the required location in the tree structure of BatchCC By 
selecting the menu command Recipe > Save As. 

Result: After creating/inserting the recipe, its status is "in progress". In this status, it 
can be modified at any time or can be released for testing or production. 
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Help 

Make use of the integrated online help when editing recipes: 

• Each Properties dialog has a "Help" button. 

• You can obtain direct help on any structure element by selecting the recipe 

element in the editing window + <F1> or with  

Options when Editing Recipes 

You edit the recipe and the recipe elements generally using either the context-
sensitive menu for the object or using the Edit menu of the menu bar: 

• Assignment of the Unit with a Flat Recipe  

• Necessary and possible recipe structure elements  

• Setting the Properties of the Header Parameters  

• Setting the Properties of Steps  

• Setting the Properties of Transitions  

• Validating Recipes  

• Releasing a Recipe for Testing or Production  

• Revoking a Release  
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6.4.2 How to Edit a Hierarchical Recipe 

Follow the steps outlined below in the BATCH Recipe Editor: 

1. Select the menu command Recipe > New  > Hierarchical recipe (for a master 
recipe)  or Library element: Recipe operation . 

Result: When you create a hierarchical recipe, a new editing window for an RUP is 
displayed (editing level 1). When you create a recipe operation, a window is 
displayed with a basic ROP structure (with Start and End) (editing level 2). 

2. If you have a hierarchical recipe, first insert a recipe procedural element (Insert 
> Recipe procedural element). 

The first RUP is displayed. 

3. Assign the unit to a unit class in the Properties dialog for the recipe unit 
procedure (RUP) Select with the command Properties in the RUP or Library 
operation context-sensitive menu ("Assignment" tab). 

 

 Note: 

Always make the assignment between the unit class and unit before configuring 
the individual recipe steps. As a result, only the phases actually available in the 
unit class/unit are displayed for selection in the Properties dialogs of the phases. 

 

4. Enter the remaining topological structure of the recipe in the editing windows.  

- Select one of the following buttons in the toolbar:  

 

Result: The element attaches to the mouse pointer. 

- Move the mouse to the required position in the editing window and click. 

Result. The element is inserted. The icon for the recipe element is still 
attached to the mouse pointer. The function of the mouse pointer changes 
only when you select a different element. 

- Click  (selection arrow) or press the ESC button to change from the 
editing to the select mode again. 

5. Select the recipe elements one after the other and make the settings you 
require in the corresponding Properties dialog By selecting the Object 
properties command in the relevant context-sensitive menu (selected with the 
right mouse button). 

6. Check the validity of the recipes By selecting the menu command Recipe > 
Validate. 

7. Save the recipe at the required location in the tree structure of BatchCC By 
selecting the menu command Recipe > Save As. 

Result: After creating/inserting the recipe, its status is "in progress". In this status, 
you can modify it at any time or released it for testing or production. 
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Help 

Make use of the integrated online help when editing recipes: 

• Each Properties dialog has a "Help" button. 

• You can obtain direct help on any structure element by selecting the recipe 

element in the editing window + <F1> or with  

Options when Editing Recipes 

You edit the recipe and the recipe elements generally using either the context-
sensitive menu for the object or using the Edit menu of the menu bar: 

• Assignment of the Unit with a Hierarchical Recipe  

• Necessary and possible recipe structure elements  

• Setting the Properties of the Header Parameters  

• Setting the Properties of Steps  

• Setting the Properties of Transitions  

• Validating Recipes  

• Releasing a Recipe for Testing or Production  

• Revoking a Release 
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6.4.3 Unit Assignment 

6.4.3.1 Assignment of the Unit with a Flat Recipe 

The unit class and the unit are specified individually in the object properties for 
each recipe step. The unit assignment is made according to the structure of the 
plant hierarchy in the engineering system. This means that when additional levels 
were added to the 3-level batch hierarchy, for example an area level between 
process cell and unit, these are also available as selection criteria in the unit 
assignment to help make the hierarchy clearer. 

If you are not using the online assignment of a unit, proceed as described below. 

Steps Required in the BATCH Recipe Editor 

1. Open the recipe. 

2. Select a recipe step. 

3. Select the Object properties command in the context-sensitive menu (with the 
right mouse button). 

4. Select the "New assignment" button. 

The "Allocations" dialog opens. 

5. First select the representation of the tree structure: 

- Class view: All unit classes without an area structure are listed in the "Unit 
selection" field. 

- Area view: All areas with the units they contain are listed in the "Unit 
selection" field. 

- Class view without instances: All unit classes (without the units they 
contain) are displayed. This setting allows recipes to be created even when 
no units are configured in the basic engineering. 

6. Select the unit class in the "Unit selection" field and deselect the units (unit 
candidates) that are not suitable for this recipe unit procedure.  

The unit classes and units available originate from the basic engineering. By 
selecting a unit class and then deselecting the unit candidates, you restrict the 
phases that can be used in the execution of this recipe unit procedure (displayed in 
the "Available functions" field). 

7. If necessary, select a preferred unit in the "Preferred unit" field. 

If no other allocation is made before creating a batch, the unit specified as 
preferred will be used to make the batch. 

8. Confirm your selection with OK. 

Result: This assignment is displayed in the Properties dialog of the recipe element. 
When assigning phases to the recipe element only the phases that can be 
executed by all the units selected are available. 
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6.4.3.2 Assignment of the Unit with a Hierarchical Recipe 

A recipe unit procedure (RUP) is designed for a unit class and a specific unit. The 
unit class and the unit are specified in the object properties of the RUP. The unit 
assignment is made according to the structure of the plant hierarchy in the 
engineering system. This means that when additional levels were added to the 3-
level batch hierarchy, for example an area level between process cell and unit, 
these are also available as selection criteria in the unit assignment to help make 
the hierarchy clearer. 

If you are not using the online assignment of a unit , proceed as described below. 

Steps Required in the BATCH Recipe Editor 

1. Open the recipe. 

2. Select a RUP (the column is shown on a light blue background). 

3. Select the Object properties command in the context-sensitive menu (with the 
right mouse button). 

4. Select the "Allocation" tab. 

5. First select the representation of the tree structure: 

- Class view: All unit classes without an area structure are listed in the "Unit 
selection" field. 

- Area view: All areas with the units they contain are listed in the "Unit 
selection" field. 

6. Select the unit class in the "Unit selection" field and deselect the units (unit 
candidates) that are not suitable for this recipe unit procedure.  

The unit classes and units available originate from the basic engineering. By 
selecting a unit class and then deselecting the unit candidates, you restrict the 
phases that can be used in the execution of this recipe unit procedure (displayed in 
the "Available functions" field). 

7. If necessary, select a preferred unit in the "Preferred unit" field. 

If no other allocation is made before creating a batch, the unit specified as 
preferred will be used to make the batch. 

8. Confirm your selection with OK. 

Result: This allocation is displayed in the Properties dialog of the recipe elements 
shown (where it cannot be changed). When assigning phases, only the phases that 
can be executed by the units still selected are available. 
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6.4.3.3 Process Cell Optimization with Online Assignment of a Unit 

Definition 

When optimizing the process cell with online assignment, the unit recipe is 
assigned to the unit at the last possible moment. If the unit is not assigned when 
the batch is being made, the "online assignment" function becomes active.  

"Online assignment" provides the following three options (strategies) for optimizing 
the utilization of units: 

• Default unit: If no other selection is made before the batch is created, the 
default unit is used for the batch. 

• Unit longest not used: The unit longest out of use is used 

• Process parameter: The variable selected in the process parameter field 
decides the unit to be used.  

Steps Required in the BATCH Recipe Editor 

1. Open the recipe. 

2. Select  

- the recipe step of a flat recipe 

- the RUP of a hierarchical recipe (column shown on a light blue 
background). 

3. Select the Object propertiescommand in the context-sensitive menu (with the 
right mouse button). 

4. Select the "Allocation" tab. 

5. In the "Strategy" box, enter one of the options described above for online 
assignment. 

6. If you select the process parameter option, select the relevant formula 
parameter.  

You can select the parameter with the "Unit" data type from a list box that will 
decide which unit is selected when the batch is made. 

7. Confirm your selection with OK. 
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6.4.4 Inseting and Labeling Recipe Elements 

6.4.4.1 Recipe procedural element (Insert Menu) 

With this function, you can insert recipe steps of the type recipe procedural 
element within a recipe. This step element is a substitute object for the steps and 
step sequences stored within the nested hierarchy level. 

• Hierarchical recipe: RUP, ROP, RPH 

• Flat recipe: Substructure 

Open or double-click: 

The window for editing the recipe steps or step sequences in the nested hierarchy 
level is opened for the selected object. 

Properties 

The properties of the step elements and the underlying step sequence are 
identical. The data in the "General", "Input material", "Output material", 
"Parameters" (process parameters), and "Process tags" tabs can be edited. 

• Hierarchical Recipe  
By installing it in the corresponding unit column, the unit class and, if selected, 
a preferred unit for creating a batch are specified.  

• Flat Recipe 
The unit class/unit can be assigned singly (even a different unit class/unit) to 
each recipe step in the "General" tab. 

Insert function: 

The insert function is closed for this object by clicking the selection arrow or a 
different object to be inserted (menu or toolbar) or with ESC. 
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6.4.4.2 Library reference (Insert Menu) 

With this function, you can insert recipe steps of the type library reference within a 
recipe unit procedure (RUP). This step element is the substitute object for a 
sequence (library operation) stored in the recipe library. In the Properties window 
of the library reference, you specify the link to the library operation. You can only 
select the library operations available for the selected unit class. 

Open: 

The window displaying the recipe step sequence stored in the library is opened for 
the selected object. To change the step chain in the library, you have to open it via 
Open library object... (Recipe menu).  

Properties 

The properties of the step elements and the underlying step sequence are 
identical. By installing it in the corresponding unit column of a hierarchical recipe, 
the unit class and, if selected, a preferred unit for creating a batch are specified. 
The data in the "General", "Input material", "Output material", "Parameters" 
(process parameters), and "Process tags" tabs can be edited. 

Insert function: 

The insert function is closed for this object by clicking the selection arrow or a 
different object to be inserted (menu or toolbar) or with ESC. 
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6.4.4.3 Recipe phase (Insert Menu) 

This function inserts recipe steps of the recipe phase type (RPH). In the Properties 
dialog in the sequence window for the recipe unit procedure, you can link a step 
with a recipe phase of the type EOP or EPH. In the sequence window for the 
recipe operation or a single level recipe, you can link a step with a recipe phase of 
the type EPH.  

Properties 

By installing it in the corresponding unit column of a hierarchical recipe, the unit 
class and, if selected, a preferred unit for creating a batch are specified. The data 
in the "General", "Input material", "Output material", "Parameters" (process 
parameters), and "Process tags" tabs can be edited. 

To link the recipe steps with the data of the basic control, the configuration data of 
the corresponding process cell must be read in or updated with the BATCH object 
manager. 

Insert function: 

The insert function is closed for this object by clicking the selection arrow or a 
different object to be inserted (menu or toolbar) or with ESC. 
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6.4.4.4 Operator instruction (Insert Menu) 

This function inserts recipe steps of the operator instruction type.  

The operator instruction allows instructions to be displayed to operators during the 
processing of a recipe. A distinction is made between output of 

• pure instructions (NOP step): 

- without acknowledgment; in other words the recipe is not stopped. 
Example: Please put on protective glasses! 

- with acknowledgment; in other words, the recipe is stopped until the 
operator acknowledges. Example: Please close valve V127. 

• an instruction with input option (operator dialog) 

- without acknowledgment, example: input of actual analysis values. 

- with acknowledgment, example "manual dosing": The operator sees which 
material and how much should be added. The operator enters the actual 
values of the material added and confirms (acknowledges). 

Entered values (actual values) can be used as setpoints for subsequent recipe 
phases/operations. The actual values can also be evaluated in transitions, 
example: Sample good? yes/no. In this case, an acknowledgment must be set in 
the parameters 

Properties 

Regardless of the unit, only those phases are available that were released for 
operator instructions in the engineering system. It is advisable to configure special 
manual operations with the Engineering System that are then available for all units.  

The data in the "Instruction", "General", "Input materials", "Output materials",  and 
"Parameters" (process parameters), and tabs can be edited. 

Depending on the phase selected in the "General" tab, it is possible for the 
operator to enter parameter values (= instruction with input option). The parameter 
values set in the "Input material", "Output material", "Parameter" (process 
parameter) tabs are then the setpoints for the operator.  

Insert function: 

The insert function is closed for this object by clicking the selection arrow or a 
different object to be inserted (menu or toolbar) or with ESC. 
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6.4.4.5 Transition (Insert Menu) 

With this function, you can insert a Transition in the BATCH recipe editor. 

In the recipe window with the units, the recipe operations can be executed without 
a transition. You can, however, also insert several transitions between steps and 
synchronization points. 

In the sequence window for the recipe operation, when you insert a transition, you 
also insert a step so that there is always a step between two transitions. 
Depending on the point at which you insert the transition, the order of the step and 
transition may be reversed. 

Properties 

Data in the "General" and "Condition" tabs can be edited. To form the transition 
conditions, the process variables defined in the corresponding recipe level 
(parameters from the properties of a ROP or RUP), fixed values and all the values 
acquired with the TAG_COLL block can be used. 
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6.4.4.6 Simultaneous sequence (Insert Menu) 

In the BATCH Recipe Editor, this function inserts an AND divergence. The steps 
and transitions of the Simultaneous sequences are executed at the same time. 
Control is passed to the successor transition or successor step only when the last 
steps and transitions of the simultaneous sequences have been executed or are 
satisfied. 

With simultaneous sequences, the sequence paths are processed only when all 
paths can be processed. This ensures, for example, that it is only possible to "heat" 
when the "agitator" is active.  

 

 Note: 

If 2 equipment phases of the same unit are installed in one simultaneous sequence 
and one of the two phases is in automatic mode and the other in manual, during 
processing, the unit will be occupied by the equipment phase in automatic mode.  

At this point, execution of the simultaneous sequence stops. Even the equipment 
phase in the automatic mode, that is occupying the unit is not processed. 

Selection: 

Clicking the double line selects the entire simultaneous sequence. If you click one 
of the lines that join the double lines from within the simultaneous sequence, you 
select a sequence. 

To select an parallel sequence with a lasso, both double lines and a certain 
amount of space to the right and left between the individual objects (structure 
elements) must be included within the lasso frame. 

Inserting: 

Follow the steps below to insert simultaneous sequences in the diagram in the 
BATCH Recipe Editor: 

1. Select the menu command Insert > Simultaneous sequence or click the 
corresponding button in the toolbar.  

2. Click between two objects in the diagram. 
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Follow the steps below if you require a parallel procedure to an existing structure in 
the BATCH Recipe Editor: 

1. Select the menu command Insert > Simultaneous sequence or click the 
corresponding button in the toolbar.  

2. Position the mouse pointer above the first object for which you require a 
simultaneous sequence. 

3. Hold down the mouse button and drag the mouse pointer below the last object 
to be enclosed in the simultaneous sequence. 

Notes: 

• While you drag the mouse pointer, a line is displayed that indicates which parts 
will be included if you release the button at the present position. 

• Depending on whether you release the button to the left or right of the vertical 
line, a new simultaneous sequence is added to the left or right. 

• You can cancel this operation by returning the mouse pointer to the initial 
position or by pressing the ESC key. 
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6.4.4.7 Alternative sequence (Insert Menu) 

In the BATCH Recipe Editor, this function inserts an OR divergence. 

An alternative sequence consists of at least two vertically arranged sequences 
joined at top and bottom by a single horizontal line. Each alternative sequence 
begins with a transition whose evaluation decides whether the sequence is 
executed or not. The transitions should be created so that the results select only 
one path. 

Selection: 

If you click one of the two horizontal lines, you select the entire alternative 
sequence. If you click one of the lines that join the horizontal lines, a sequence is 
selected. 

To select an alternative sequence with a lasso, both horizontal lines and a certain 
amount of space to the right and left of the individual objects (Structure Elements  
must be included in the lasso frame. ) must be included in the lasso frame. 

Inserting: 

Follow the steps below to insert alternative sequences in the diagram in the 
BATCH Recipe Editor: 

1. Select the menu command Insert > Alternative sequence or click the 
corresponding button in the toolbar.  

2. Click between two objects in the diagram. 

 

If you require an alternative  procedure to an existing structure in the BATCH 
Recipe Editor, follow the steps outlined below: 

1. Select the menu command  Insert > Alternative sequence or click the 
corresponding button in the toolbar.  

2. Position the mouse pointer above the first object for which you require an 
alternative sequence. 

3. Hold down the mouse button and drag the mouse pointer below the last object 
to be included in the alternative sequence. 

Notes: 

• While you drag the mouse pointer, a line is displayed that indicates which parts 
will be included if you release the button at the present position. 

• Depending on whether you release the button to the left or right of the vertical 
line, a new alternative sequence is added to the left or right. 

• You can cancel this operation by returning the mouse pointer to the initial 
position or by pressing the ESC key. 
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6.4.4.8 Synchronization (Insert Menu) 

With synchronization, you can coordinate the execution of recipe sequences in the 
units and between the units (hierarchical recipe). Synchronization is also possible 
in the sequences of the same simultaneous sequence (hierarchical recipe, flat 
recipe). 

At each synchronization point, you can decide whether or not the sequence is 
halted. If you select Blocking , the sequence waits until the other involved 
sequences have reached or had reached the synchronization line (may have 
continued during). if Blocking is not selected, the sequence does not wait for the 
other sequences. The fact that the synchronization point was reached is 
nevertheless recorded. 

Inserting: 

Follow the steps outlined below if you require synchronization between the units of 
a hierarchical recipe in the BATCH Recipe Editor: 

1. Select the menu command Insert > Synchronization or click the 
corresponding button in the toolbar.  

2. Drag the mouse starting between two objects of the first recipe unit procedure 
(RUP) to a point between two objects of the recipe unit procedure (RUP) you 
want to synchronize. If there are other sequences between the RUPs, these 
are not included in the synchronization. 

Extending: 

1. Select the menu command Insert > Synchronization or click the 
corresponding button in the toolbar.  

2. Beginning at a synchronization point (junction between the sequence line and 
synchronization lines) drag the mouse pointer until it is located between two 
objects of the recipe unit procedure (RUP) you want to add in to the 
synchronization.  

To remove a synchronization point: 

You can select and delete individual synchronization points or the synchronization 
line. 

Properties 

You can assign a name to the synchronization and decide whether or not 
execution is to be halted individually for each synchronization point. 
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Appearance of the synchronization point: 

Synchronization point is displayed as a double line and the sequence line is 
interrupted if a synchronization point is for the sequence and lock was selected. 

A Synchronization point is displayed as a single line, if it is a Synchronization point 
for the sequence and if the property lock was not not selected. 

A synchronization point is displayed as a double line and the sequence line is not 
interrupted if it is not a synchronization point for the sequence. 

 

 Note: 

A synchronization line cannot begin or end in alternative sequences, simultaneous 
sequences or loops. All intersections must be located directly in the RUPs or in 
sequences of the same simultaneous sequence 
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6.4.4.9 Loop (Insert Menu) 

With this function, you can insert a loop in the Batch Recipe Editor . In the return 
path, a transition is inserted first. In the straight sequence, there must also be a 
transition following the loop. In these transitions, you must define conditions that 
clearly specify the sequence. 

Inserting: 

Follow the steps below to insert loops in the diagram in the BATCH Recipe Editor: 

1. Select the menu command Insert > Loop or click the corresponding button in 
the toolbar.  

2. Click between two individual objects (structure elements) to insert a loop with a 
step placeholder and a transition in the return path. By selecting the required 
recipe element and clicking on the placeholder, this is replaced by the required 
function. 

 

Follow the steps below if you want to iterate an existing sequence of objects with a 
loop in the BATCH Recipe Editor: 

1. Select the menu command Insert > Loop or click the corresponding button in 
the toolbar. 

2. Press the left mouse button with the pointer located in the gap after the last 
object to be included in the loop. 

3. Hold down the button and drag the mouse pointer upwards until all the required 
objects are included and then release the mouse button. 

Deleting: 

Select the entire loop and press the delete key to delete the content. If you only 
select the transition in the return path, the loop body remains after deleting. 

Notes: 

• While you drag the mouse pointer, a line is displayed that indicates which parts 
will be included if you release the button at the present position. 

• You can cancel this operation by returning the mouse pointer to the initial 
position or by pressing the ESC key. 

Select: 

You can select a loop  as follows: 

• by clicking on one of the horizontal lines at the top or bottom, 

• by clicking on the return path line, 

• by clicking on one of the lines of the sequence in the body of the loop, or 

• by opening a lasso while holding down the left mouse button that includes the 
entire body of the loop as well as the transition in the return path. 
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6.4.4.10 Working with Substructures 

By clicking on the icon or selecting with a lasso, you can select a substructure. To 
change to the substructure, double-click on the icon of the substructure. A new 
window opens showing the content of the substructure. 

 

 Note: 

Substructures can only be created in flat recipes! 

 

 Note: 

Substructures have the same functional possibilities as ROPs in hierarchical 
recipes (parameter assignment options, process tag definition, upload and 
download formula parameters in the recipe, library objects) 

Inserting: 

Follow the steps below to insert substructures in the BATCH Recipe Editor: 

1. Select the menu command Insert > Recipe procedural element or click the 
corresponding button in the toolbar. 

2. Click between two individual objects (structure elements) or on a substructure 
placeholder. 

Deleting: 

Select the substructure box and press the delete key to delete the content. 

If you do not want to delete the content of the substructure, select the menu 
command Edit > Resolve substructure. The content of the substructure is then 
embedded in the diagram instead of the substructure box. 

Nesting depth: 

A substructure itself can contain other substructures. The permitted nesting depth 
can be set with the menu command Options > Settings. 

Once the maximum depth is reached, two reactions can be configured: 

• The action (pasting from the clipboard, inserting a substructure, including in a 
substructure) is rejected with an error message, 

• the deepest substructures are resolved (embedded). 

The latter can lead to an inserted substructure disappearing again before it 
becomes visible because it would cause the nesting depth to be exceeded. 
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6.4.4.11 Adding Comments to Structure Elements 

With the menu command Edit > Text, you open a dialog box in the BATCH Recipe 
Editor in which you can enter a comment for the object (structure element) selected 
in the recipe. 

 

 Note: 

The text of the comment is displayed beside the objects if you activate the object 
comments with the menu command View >Comment. 
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6.4.5 Setting Recipe Properties 

6.4.5.1 Passing Formula Parameters in the Recipe 

Passing Formula Parameters in the Recipe 

The same formula parameter can be used more than once in different recipe steps 
of various types. A formula parameter can also be used at the same time in 
transition conditions. 

The schematic below shows the possible use of a formula parameter. 

Name

Value

Recipe procedure

Name

Value

Formula

Name

Value

Name

Target

Recipe phase

Name

Value

Name

Target

Recipe operation

Name

Value

Name

Target

Recipe unit proc.

Name

Value

Equip. phase
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6.4.5.2 Uploading and Downloading Formula Parameters in the Recipe 

Uploading and Downloading Formula Parameters in the Recipe (= defer relations) 

Parameter values (setpoint and process value) can be passed between the 
structure elements of the recipe hierarchy in both directions while the recipe is 
executing. During the creation of the Recipe properties and the individual recipe 
steps, you can enter the corresponding comment for each input material/output 
material and process parameters:  

• Source 

• Target 

Reference to Source 

A source (setpoints) from the next higher level can be assigned for the recipe 
objects RUP, ROP, RPH and SUB.  

Example: An input material in RUP can be the source for an input material in a 
ROP. The name of the input material is referenced. 

Source = recipe procedure (RP) 

 

 Note: 

Only parameters of the recipe steps and transitions that reference the level of the 
recipe procedure as the source ("uploaded" recipe header parameters) can be 
used as formula parameters for batch planning. 

Reference to Target 

For the RUP, ROP, RPH, and SUB recipe objects, the recorded process values 
can be passed on to the next higher level.  

Example: A process value in the ROP can have a parameter in a RUP as its target. 
This allows the process value of a step to be used as the setpoint for a subsequent 
step. The name of the parameter is referenced. 

 

 Note: 

Parameters with a reference to a data source cannot be used as target 
parameters. 
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Example of a Hierarchical Recipe 

Name ABC

Value

Source

Target

Recipe operation 1 (ROP)

Name

Name XYZ

Value

Source

Target

Recipe unit procedure(RUP)

Name

Name ABC

Value

Source

Target

Name

Recipe operation 2 (ROP)

1

2

Recipe operation 1 uploads the process
value fetched from the equipment phase to
the recipe unit procedure

Recipe operation 2 reads the setpoint used
as recipe phase parameter or transition
variable from the recipe unit procedure
(download)

1

2
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6.4.5.3 Setting the Properties of the Header Parameters 

In the properties of the recipe header (recipe header parameter), configure the 
Properties of the recipe . The material and production data and the process 
parameters contain all the parameters passed up for operator instructions (formula) 
from those in the recipe procedure elements (RUPs, ROPs and RPHs) lower in the 
hierarchy. Further parameters can be added to these. 

Opening the Tab 

There are two ways in which you can open the "Properties of <Recipe name>" tab: 

• in the BATCH Control Center: See the section on "BatchCC" 

• In the BATCH Recipe Editor: As described below 

Follow the steps outlined below in the BATCH Recipe Editor: 

1. Open the recipe.  

2. Select the menu command Recipe > Header parameters. 

Result: The "Properties of the <recipe name>" dialog is displayed with the header 
parameters. In the dialog tabs, all the Properties of the recipe are available, which 
must/can be specified for a recipe in addition to the recipe structure. This is the 
same Properties dialog that you can select with the Edit > Properties menu 
command in BatchCC. 

Some of the properties (parameters) already have a fixed value due to the detailed 
configuration of the individual recipe elements (RUPs, ROP, EPHs, transitions) 
following the basic control. You can recognize parameters or settings that can still 
be modified by the white editing fields. 

3. Make the settings you require in the tabs and confirm with OK.  
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Entering Properties 

You enter the properties of the recipes in the following tab. Click the "Help" button 
for context-sensitive help on each individual input or output box in the tab. 

 

Reference to Formula Category 

With the "Category" input box in the "General" tab, you assign the formula category 
with the required structure for material and production data (formula) to the master 
recipe. This is only possible when the formula category has already been created 
in BatchCC. You can set this option in BatchCC later. 

See section: Connection between the recipe header parameter, formula category 
and formula  

Electronic Signatures 

Actions and status changes of recipes can be signed. You configure electronic 
signatures in the "ESIG" tab. 

See also section: Specifying the Electronic signature  



BATCH Recipe Editor 

 SIMATIC BATCH 
6-50 A5E00272803-01 

6.4.5.4 Setting the Properties of Steps 

Properties of the Steps 

In the object properties of the recipe procedure elements (RUP, ROP, NOP, RPH, 
SUB) you define the material and production data (formula) and the parameters for 
each individual element. The parameters for input materials, output materials and 
process parameters for the recipe phases in the sequences are specified by 
assigning the recipe phase (of the type EOP, EPH). Further parameters can be 
added to these. 

Follow the steps outlined below in the BATCH Recipe Editor: 

1. Open the master recipe.  

2. Select a recipe procedure element. 

3. Select the Object properties command in the context-sensitive menu (with the 
right mouse button). 

  Result: the dialog box "Properties of <Batch name>" is displayed. The tabs in the dialog 
contain all the properties that must or can be specified for the relevant recipe procedural 
element. 

4. Make the settings you require in the tabs and confirm with OK.  
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Entering Properties 

You enter the properties of the steps in the tabs displayed. Click the "Help" button 
for context-sensitive help on each individual input or output box in the tab. 

 

Passing Parameters 

Using the "Source" and "Target" table columns, you can interconnect the 
parameters of different hierarchical levels in both directions (mouse click on the 
button beside the parameter): 

• For the recipe objects RUP, ROP, and  RPH, you can select a source from the 
next higher level. Example: A parameter in the recipe procedure can be the 
source for a parameter in an RUP.  

 

 Note: 

Parameters of the recipe steps that reference the recipe procedure level as the 
source ("uploaded" header parameters) can be used as formula parameters for 
batch planning. 
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• For the RUP, ROP, RPH, and SUB recipe objects, the recorded process 
values can be passed on to the next higher level. Example: A process value in 
the RUP can have a parameter in the recipe procedure as its destination. This 
allows the process value of a step to be used as the setpoint for a subsequent 
step. 

 

 Note: 

Parameters can only be passed when the parameter types and units of measure 
match. 

 

 

 Note: 

Parameters with a reference to a data source cannot be used as target 
parameters. 

Properties of Library References 

 

 Note: 

In the Properties dialog of a library reference, most properties of the library 
operation are displayed and cannot be modified. To modify the properties, you 
must open the library operation explicitly in the BATCH Recipe Editor. 

Scaling with Minimum and Maximum Limit 

The physical limits of the process cell instance is displayed as limit values. If you 
the setpoint value is adjusted, the possible minimum and maximum setpoint values 
are displayed additionally in the tool tip.  

If you remain within these limits (tooltip), the permissible quantities of a Batch 
between the "minimum quantity of a Batch" and the  "maximum quantity of a Batch" 
is guaranteed.  

Setpoints outside the limits specified in the tooltip are also possible. In the event of 
this, warnings are issued during Plausibility and the quantity of a Batch is limited. 

Minimum limit: 

This displays the minimum value of the parameter that would be of practical value 
as the setpoint. If a discrete parameter type or text parameter is set for this 
parameter (in other words not "floating point" type!), there is no minimum limit since 
only permitted entries are displayed as the value. If scaling is selected, the value 
depends on the reference scale and the minimum limit of the actual amount from 
the recipe header. 

The minimum limit is calculated so that the parameter value cannot fall below the 
lower limit of the block following scaling. 
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Value: 

Here, you can enter the set point. A default value is displayed that is taken from the 
data of the basic control. The value entered must be between the upper and lower 
limits.  

There are several possible reasons for a violation of the limits: 

• The limits in the process cell data are too narrow. 

• Scaling is too extreme. 

• The limits for the batch quantity (see header parameters) are too far away from 
the reference quantity. 

Upper limit: 

This displays the maximum value of the parameter that would be of practical value 
as the setpoint. If a discrete parameter type or text parameter is set for this 
parameter (in other words not "floating point" or "integer" type!), there is no upper 
limit since only permitted entries are displayed as the value. If scaling is selected, 
the value depends on the reference scale and the upper limit of the actual amount 
from the recipe header. 

The upper limit is calculated so that the parameter value cannot exceed the upper 
limit of the block following scaling. 

If the upper limit is lower than the lower limit so that it is not possible to enter a 
correct value, the reason is that the range between the upper and lower limit in the 
header parameters is too great or that the scaling used would push the value 
beyond the limits.  

Electronic Signatures 

Actions and status changes of recipes steps can be signed. You configure 
electronic signatures in the "ESIG" tab. 

See also section: Specifying the Electronic signature  
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6.4.5.5 Setting a Recipe Phase for "Continuous Operation" 

During creation of a recipe, a flag can be set to define a recipe phase that is not 
self-terminating so that this recipe phase (equipment phase) is not terminated in 
run time until it receives a termination command from another recipe phase or until 
the unit recipe procedure that it is in completes. 

• This is necessary when an equipment phase (for example, agitating) is 
required to continue after recipe operations.  

• A second application is the setting of different parameters for the equipment 
phase without having to turn it off and on again (for example during a flying 
control strategy change). 

Follow the steps outlined below in the BATCH Recipe Editor: 

1. Open the master recipe.  

2. Select a recipe procedure element. 

3. Select the Object properties command in the context-sensitive menu (with the 
right mouse button). 

Result: the dialog box "Properties of <Batch name>" is displayed. 

4. Activate the "Continue" check box 

5. Confirm with OK. 
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6.4.5.6 Setting the Control Strategy of a Recipe Phase 

Recipe phases can be implemented with various control strategies (set of 
setpoints) that can be used by in the manual mode or in the automatic mode 
(recipe mode). The control strategies are configured along with their parameters in 
the engineering system. In the Recipe Editor, the control strategies defined in this 
way are available in plain language under the name of the control strategy. During 
parameter assignment, only the parameters belonging to the selected control 
strategy are displayed. 

Follow the steps outlined below in the BATCH Recipe Editor: 

1. Open the master recipe.  

2. Select a recipe procedure element. 

3. Select the command Object Properties in the context-sensitive menu 
(selection via right-mouse button). 

Result: the dialog box "Properties of <Batch name>" is displayed. 

4. Select the required control strategy of the recipe step in the "Control strategies" 
field. 

Result: In the tabs "Input material", "Output material" and "Parameters", only the 
parameter values belonging to the selected control strategy and thus the valid 
parameter for this recipe step are displayed. 

5. Confirm with OK. 
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6.4.5.7 Allowing Online Modification of Setpoints 

Introduction 

During batch control, the parameters (setpoints) of the control recipe can be 
modified by the operator (for example the speed of an agitator can be changed 
without stopping it). The following parameter values can be changed: 

• Input materials 

• Output materials 

• Process parameters 

How Modification Affects RPHs and the Operator Dialog 

The new values are immediately available for all recipe phases (EPH, EOP) and 
operator dialogs not yet active. 

If recipe phases (EPH, EOP) and operator dialogs are running, you can choose 
between the following two options: 

• If the recipe step is currently being processed there will be no reaction to the 
operator modifying the parameter. The modified parameter only will become 
effective when the step is processed again. 

• If the recipe step is currently being processed, parameter values changed by 
the operator will become effective immediately; in other words, they are 
transferred from the running recipe step in the control recipe directly to the 
controller where they take effect in the executing block. 

How Modification Affects ROPs and the RUPs 

The new values are available immediately for all not yet active recipe elements 
(ROP, RUP) and operator dialogs. 

If the recipe element is currently being executed, there is no immediate reaction to 
the parameter change. Modified parameter values only take effect the next time the 
element is executed (for example positioning within a loop). 
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Specifying Whether Parameters can be modified for RPHs, Operator Dialogs, 
ROPs and RUPs 

You specify whether or not parameter values can be modified in the Properties 
dialogs of the recipe elements RPH, operator dialog, ROP and RUP.  

You open the properties dialog by selecting the recipe element and the Properties 
command in the context-sensitive menu.  

You make the settings governing online changes to parameter values in the "Input 
materials", "Output materials" or "Process parameters" tabs in the "Modifiable" and 
"Effective immediately" columns (extra only for RPH and operator dialog).  

Tip: via the system settings (Options> Settings), you can set the default value in 
the "Modifiable" and "Effective immediately" columns in the "General" tab of the 
properties dialogs of new parameters. 

Result: During batch control, the parameter input fields can be edited and 
parameter values modified. 

Online Response with Parameter References 

With parameter references (data source, data target), the response is as follows: 

• If parameters are marked as "Modifiable", the operator is permitted to enter 
new values.  

• Implicit modification by the control recipe remains possible for parameters not 
marked as modifiable. If, for example, an interconnected parameter in a recipe 
phase is not modifiable, it can nevertheless be modified by an operator making 
a change in the recipe operation.  

Even if the parameter is locked against modification in the recipe operation, a 
modification by target interconnections is still possible. 

Modifications in Transitions 

Process parameters updated at runtime can also be used in the evaluation of 
transitions. 

You can specify that the modification should take immediate effect in the 
Properties dialog of the transition. Using the "Effective immediately" column for 
address 1 and 2, you can specify that the value of the process parameter will take 
immediate effect if it is changed.  
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6.4.5.8 Setting the Properties of Transitions 

Properties of Transitions 

In the properties of the transitions, you configure the step enabling conditions. The 
step enabling conditions are specified as Boolean expressions. A single condition 
always consists of two addresses (first address = variable, second address = 
variable or number) logically combined by a comparison operator. 

Follow the steps outlined below in the BATCH Recipe Editor: 

1. Open the recipe.  

2. Select a transition. 

3. Select the command Object Properties in the context-sensitive menu 
(selection via right-mouse button). 

  Result: the dialog box "Properties of <transition name>" is displayed. Configure the step 
enabling conditions in the "Condition" tab dialog. 

4. Make the settings you require and confirm with OK. 

Entering Properties 

You enter the properties of the transitions in the tabs displayed. Click the "Help" 
button for context-sensitive help on each individual input or output box in the tab. 
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Parameter selection, independent of units 

If you right-click when the pointer is on a new parameter and select "Variable" > 
Edit Cell, the "Select Address" dialog appears. Here you can select the parameters 
from basic control regardless of the units. When the batch is made, the required 
unit is selected along with the parameters specific to the unit. 

Electronic Signatures 

Actions and status changes of transitions can be signed. You configure electronic 
signatures in the "ESIG" tab. 

See also section: Specifying the Electronic signature  

6.4.5.9 Specifying the Properties of the Library Objects 

Properties of Steps and Transitions 

The properties of the steps and transitions within the library objects are entered in 
the relevant properties dialogs in the same way as with master recipes: 

• Setting the Properties of Steps  

• Setting the Properties of Transitions  

Properties of the Header Parameters 

The header parameters of the library operation in hierarchical recipes differ from 
those of master recipes only in the following way: 

Unit class 

A library operation is always created for a specific unit class. When you create a 
recipe in the BATCH Recipe Editor, the unit class is referenced in the "General" tab 
of the Properties dialog. A unit is not allocated. This occurs only when the 
operation is bound into the recipe unit procedure (RUP) of a master recipe as a 
library reference. 

All other header parameters are configured in the same way as for a master recipe: 

Setting the Properties of the Header Parameters  
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6.5 Other Functions 

6.5.1 Saving Recipes and Library Objects 

A new recipe is always opened with a default name after opening it with the menu 
command New. Before you complete editing, the recipe must be saved.  

Follow the steps outlined below: 

1. When you save for the first time, select the menu command Recipe > Save 
As. 

2. In the next dialog you enter the name and version.  

Result: The next time you save, you can use the Save command unless you want 
to change the name or version. 

6.5.2 Validating Recipes 

Definition 

The validation covers the consistency of the library operations and process cell 
data used in the created recipe.  

Requirement: 

This is only possible when the recipe is edited with the elements step, transition, 
and structure element along with the corresponding configuration of the recipe data 
(header). 

Steps Required in the BATCH Recipe Editor 

1. Open the recipe you want to validate (master recipe or library object). 

2. Select the menu command Recipe > Validate. 

Result: A results list or error list is displayed that indicates whether or not the recipe 
header is completed, whether materials exist, whether steps and transitions in the 
recipe are configured and whether the normalized batch quantity is correct. 
Incorrect elements are displayed in red in the graphic recipe structure. Validation is 
also possible in BatchCC. 

 

 Note: 

By double-clicking an entry in the error list, you can jump to the part of the recipe 
that caused the problem. 

 

 

 Note: 

You can use the validation function at any time. Validation does not change the 
recipe status. 
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6.5.3 Releasing a Recipe for Testing or Production 

Requirement: 

The requirement for this function is the validation of the recipe. The validity of the 
recipe is first checked automatically when you start this command. 

Follow the steps outlined below in the BATCH Recipe Editor: 

1. Open the recipe you want to validate (master recipe or library object).  

2. Select the menu command Recipe > Release for Testing or Release for 
Production. 

Result: When it is released, the recipe has the status "released for testing" or 
"released for production". If errors occur in the validation, the problems are 
displayed and the recipe status remains "In Progress...". You can also release a 
recipe in BatchCC. 

 

 Note: 

By double-clicking an entry in the error list, you can jump to the part of the recipe 
that caused the problem. 
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6.5.4 Revoking a Release 

 

 Note: 

Only recipes that have not been released can be edited. If you want to edit master 
recipes or recipe objects that have already been released, the release must be 
revoked explicitly. 

This is possible only when the option "Allow editing of recipes in the "Release 
revoked" status" is activated in the general settings of BatchCC. Navigate to this 
option via the menu command Options > Settings in the "General" tab. 

Follow the steps outlined below in the BATCH Recipe Editor: 

1. Open the recipe (master recipe or library objects). 

2. Select the menu command Recipe > Revoke release. 

Result: After revoking the release, a recipe released for testing has the status 
"being processed" and recipe released for production has the status "Release 
revoked" and can be edited.  

You can also revoke a release in BatchCC. 
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7 Redundancy 

7.1 Introduction 

Availability 

To increase the availability of the batch control and to allow a software update 
during operation, SIMATIC BATCH provides the option of installing a redundant 
BATCH Server. If there is a failure in the redundant system, there is a 
standby/master failover between the redundant BATCH Servers.  

Redundancy is achieved with redundant BATCH Servers each with local data 
management. To safeguard data and to allow the batch applications to access the 
current data, the data is constantly synchronized between the two local data 
management systems (data replication). 

It is guaranteed that after the failure of one BATCH Control Server or DB server, 
the redundant server can continue to work with the same data. 

Configuration and Commissioning 

 

 Note: 

To establish the software and hardware requirements and when configuring and 
commissioning redundant servers with the cluster solution in the PCS 7 V6.0 
system, you should always consult your Siemens contact. 

 

Further Reading Redundant PCS 7 OS 

The manual Process Control System PCS 7; fault-tolerant process control systems 
contains an introduction to the general redundancy mechanisms in PCS 7. This 
documentation is on the "PCS 7; Electronic Manuals" CD. This is general 
documentation describing the overall concept of availability in PCS 7. This also 
includes, for example, more information on the redundant PCS 7 OS.  
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7.2 Sample Configuration - Fault-Tolerant Batch Control 

The picture below shows a sample configuration with a redundant BATCH server 
and redundant PCS 7 OS (WinCC): 

 
 PCS 7 OS: OS client 1 

BATCH client 2 BATCH client 1 

Engineering 
station 

SIMATIC S7-400 

Process bus 

SIMATIC S7-400 

SIMATIC BATCH: 
BATCH server 2 

(BATCH contr. server) 
DB server 

SIMATIC BATCH: 
BATCH server 1 

(BATCH contr. server 
DB server) 

 

 

Terminal bus 

PCS 7 OS:  
OS-Server 1 

PCS 7 OS:  
OS-Server 2 
(redundant) (2) 

(1) 

 

 (1) Redundant BATCH Server 

Redundancy is achieved with two BATCH Servers with a standby/master failover. 
The redundancy of the BATCH Servers guarantees that if a BATCH Server fails  

• all BATCH clients (with the BATCH Recipe Editor and BatchCC (batch 
planning, batch control)) are immediately operable again following the failover 
and 

• permanent acquisition of the batch data continues. 

(2) OS Redundancy of the Standard PCS 7 Operator Stations 

The redundancy of the distributed PCS 7 operator stations with an interface to the 
SIMATIC S7-400 is achieved by interconnected OS servers with data 
synchronization and backup of the archive data. The WinCC archives of the 
redundant OS servers are synchronized and contain the same data. The 
functionality is implemented with the "Redundancy" optional software of WinCC. 
For a description of the "Redundancy" optional software, refer to the manual 
SIMATIC HMI; Options. 

The redundancy of the PCS 7 operator stations guarantees that the batch 
processes continue uninterrupted even if one of the two OS servers fails and the 
operator remains informed about the status of the process cell and can still 
intervene in the process. 
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7.3 Response in Run Time 

Failover of the BATCH Server 

The BATCH Control Server and batch data management are permanently active 
on both redundant BATCH Servers. From the prospective of the BATCH Server, 
there is no preferred server; in other words, both BATCH Servers access the same 
OS server when there are no failures in the system. 

If the BATCH Server configured as the master fails, there is a failover to the 
BATCH Server (standby). This then becomes the master. 

Possible Causes of a Failover 

• Failure of the BATCH server PC (master), for example hardware fault or blue 
screen 

• Failure of the network connection of the BATCH Server PC (BATCH Server no 
longer detects a client or its redundant BATCH Server) 

• Failure of an application (BATCH Control Server, batch data management, 
Launch Coordinator) 

Failover of the BATCH Clients 

If BATCH Server (master) fails, the BATCH clients automatically fail over to the 
standby BATCH Server. 

Startup, Restart of the BATCH Clients 

 

 Note: 

Following a failover of the BATCH Servers, the BATCH clients can only be 
operated again after a certain time has elapsed. 

A message window opens informing you that the BATCH Server is currently not 
obtainable. Once the failover is completed, the message window disappears 
indicating that the server application is operational again. 

As long as the message window is displayed, the BATCH client cannot be 
operated. You can, however, close the client application by clicking the "Quit 
application" button. On completion of the failover, the BATCH client can be started 
again. 
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Loss of Data 

 

 Note: 

During a BATCH Server failover, data can be lost. The states that can be lost are 
those 

• resulting from operator intervention on the PCS 7 OS client (for example due to 
an operator setting a binary value twice with one setting canceling out the 
other) or 

• are generated from data of the programmable controllers and that cannot be 
recorded during the failover. 

 

Example: During the failover, the limit value of a process value is exceeded but the 
value returns within the limits during the time required for the failover. If this limit 
violation is queried in a transition condition, the transition must be triggered 
manually by the operator. 

Process Control Messages 

In the event of a failover, a process control message is displayed on the message 
OS. 
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7.4 Data Synchronization with Data Replication 

Data Synchronization with Data Replication 

In this solution, each of the two redundant BATCH Servers 1 and 2 has its own 
local database. The databases are synchronized with each other and therefore 
have the same data. With this solution, no additional hardware or software is 
necessary. 

 

 Note: 

A BATCH Control Server always works with the DB servers assigned in the 
configuration. In other words, if a BATCH Control Server (master) fails and the 
standby BATCH Control Server takes over the master role, it continues to work 
with the standby DB servers. 
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7.5 Configuration of the Redundant BATCH Server 

 

!   
Warning 

Configuring applications (WinCC, SIMATIC BATCH, ...) on separate "SIMATIC PC 
station" objects and then merging them to create one PC station by assigning the 
same computer name to the "SIMATIC PC station" objects is not permitted! 

Follow the steps outlined below in the SIMATIC Manager: 

1. Select the project in the component view. 

2. Select the menu command Insert > Station > SIMATIC PC Station. 

  Result: A new SIMATIC PC station is inserted in the current project. 

3. Set the computer name of the PC station. 

- Select the SIMATIC PC station. 

- Select the menu command Edit > Object Properties. 

- Enter the computer name in the last field. 

4. Configure this SIMATIC PC station in HW Config. 

- Select the SIMATIC PC station. 

- Select the menu command Edit > Open Object. 

Result: HW Config opens. 

- Insert a batch application from the hardware catalog: 

Path in the hardware catalog: Standard > SIMATIC PC Station > HMI > 
BATCH Application (stby). 
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5. Select the menu command Station > Save and Compile. 

Result: In the component view, the object  is displayed 
below the configured SIMATIC PC station.  
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7.6 Time Monitoring on the PCS 7 OS 

Time Monitoring 

When configuring the time monitoring on the distributed PCS 7 operator stations, 
take the the following points into consideration:  

• The times involved in a failover 

• The critical times in the process 

The time monitoring for the batch functionality on the PCS 7 OS (batch control) is 
adopted along with the UNIT blocks IUNIT_BLOCK (FB 251) (UNIT watchdog). 

UNIT Watchdog 

The time monitoring of the IUNIT_BLOCK blocks is controlled by the BATCH 
Control Server. If the update does not take place, IUNIT_BLOCK signals a 
connection abort to which the programmable controller can react. Time monitoring 
is active only when the unit is occupied by a batch. If a unit is occupied manually 
using the UNIT faceplate, the UNIT watchdog is not activated. 

Using the UNIT Watchdog 

The watchdog supplements the redundancy concept of the PCS 7 OS, it can, 
however, be used without OS redundancy (for example when the PCS 7 OS is 
operated in the stand alone mode). It is also unnecessary to activate the watchdog 
for a failover. The watchdog should be used in particular to protect a critical 
automation process. 

Setting the UNIT Watchdog 

 

 Note: 

If both mechanisms (redundancy and UNIT watchdog) are active, please 
remember the following points when setting the watchdog interval: 

The watchdog interval should always be selected to suit the process tolerance so 
that a significant delay in the failover time is always detected so that a suitable 
reaction can be started.  

Depending on the backup measures of the process initiated as a result, the 
synchronization of batches by batch control may take longer following the failover 
or is no longer possible automatically. In this case, the operator will need to 
intervene manually to continue the batches. 
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8 Migration V4.02 -> V6.0 

8.1 Basics of Migration 

Introduction 

 

 Note: 

A BATCH flexible V4.02 project can be migrated to SIMATIC BATCH V6.0.  All the 
functions configured in the V4.02 project can continue to be used in SIMATIC 
BATCH V 6.0.  

 

The basis for migration is the BATCH flexible V4.02 database. This contains the 
required batch data. This topic describes how to migrate the batch data. 

In addition to migration of the batch data, the STEP 7 project must also be adapted 
to PCS 7 V6.0. You will find more detailed information on this topic in the 
documentation Process Control System PCS 7; Software Update on the PCS 7 
toolset CD. 

Adopted data 

The following data is adopted from the BATCH flexible V4.02 database in SIMATIC 
BATCH V6.0:  

• Process cell data (including units of measure, user data types, and materials) 

• Unit recipes (now known as master recipes in V6.0:) 

Data that is Not Adopted 

The following data is not adopted from the BATCH flexible V4.02 database to 
SIMATIC BATCH V6.0:  
 

• Production orders 

• Batches (including control recipe) 

• Users/user permissions 
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 Note: 

• Since the batches are not migrated, you should save these in the form of a 
batch report on paper or in PDF format! 

• If the migration is on the same computer, you must save the batch data before 
installing SIMATIC BATCH V6.0! 

• Any exported unit recipes that no longer exist in the V4.02 database but that 
you will require in the future must be imported again prior to migration! 

 

Other Conditions for Migration 

• BATCH flexible V4.02 blocks remain usable after migration (unchanged) 

• Mixed operation of BATCH flexible V4.02 and SIMATIC BATCH V6.0 blocks 
within a unit is possible.  

• Instances of a phase, operation or process tag type cannot be mixed; in other 
words a type has either V4.02 or V6.0 instances.  

• Flat V4.02 recipes are automatically converted to flat V6.0 recipes. 

• Flat V4.02 recipes can only be converted to hierarchical V6.0 recipes manually! 

Options for Conversion 

Based on the conditions listed above, the following options are open when 
migrating a V4.02 project to SIMATIC BATCH V6.0: 

 
Option Aim Consequences 

1 Continuing with V4.02 Functionality 
Only 

no  
extensions are made to the project 

 

AS data is retained, 
 This means that 

• recompilation of the charts is not necessary 

• new download to the PLC not necessary 

• new compilation of the OS not necessary 

• recommissioning not necessary 

• revalidation of the PLC not necessary 

2 Using the New V6 Functions 

Gradual conversion to the V6 
functionality, old functions remain 
implemented with V4.02 blocks, 
expansions will be made with V6.0 
blocks (mixed operation of V4.02 and 
V6.0 blocks possible) 

It is also possible to extend a project 
using V4.02 blocks or to make 
changes to the existing V4.02 
configuration. 

Mixed operation with V4.02 and V6.0 blocks, i.e. 

• Charts must be recompiled 

• New download to the PLC necessary 

• New compilation of the OS necessary 
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8.2 Migration Requirements 

Data Compatibility 

 

 Note: 

If you kept to the rules for data compatibility in the BATCH flexible V4.02 project 
(also described in the BATCH flexible V4.02 readme), you can migrate the batch 
data with the support of the migration tool  "SIMATIC BATCH Migrator".  

If these guidelines are kept to, it is possible to migrate without compiling the OS or 
downloading again to the programmable controller! 

If you did not keep to the guidelines, the project must be converted manually 
according to the guidelines before you can start the actual migration. 

 

Principle 

To avoid having to recompile the OS, download to the programmable controller 
again, and adapt the WinCC pictures, you must make sure that the "Compiled" 
WinCC tags do not change.  

To achieve this, you either kept to the guidelines in the BATCH flexible V4.02 
project as described below or you must make adaptations to meet these 
requirements before you start the actual migration.  

If these requirements are not met, it will not  be possible to avoid subsequent 
compilation of the OS, downloading to the PLC, and adaptation of the WinCC 
pictures! 

Rule 1: Use of the UNIT block 

There must not be more than one instance of this block below the "Unit" plant 
hierarchy.  

Rule 2: Use of the TRANS block 

• There must only be instances of TRANS blocks in a CFC chart if these are 
assigned to a unit.  

• The value of the UNITNAME attribute must always correspond to the 
UNITNAME of the UNIT block. 

• The chart must be located below the plant hierarchy folder of the 
corresponding unit. 

• There must be no AF_x blocks or a UNIT block located in the chart that are 
assigned to another unit. 
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Rule 3: Use of the AF_x blocks 

• There must only be instances of AF_X blocks in a CFC chart if these are 
assigned to a unit.  

• The value of the UNITNAME attribute must always correspond to the 
UNITNAME of the UNIT block. 

• The chart must be located below the plant hierarchy folder of the 
corresponding unit. 

• There must be no TRANS blocks or a UNIT block located in the chart that are 
assigned to another unit. 

Plant Hierarchy 

In the BATCH flexible V4.02  readme, it was also recommended that you configure 
the plant hierarchy of the batch process cell in the SIMATIC Manager. The top 
level corresponds to the project: The next three hierarchy levels must be as 
follows: 

• Level 2 must have the technological significance of a process cell (S88.01). 

• Level 3 must have the technological significance of a unit (S88.01). 

• Level 4 must have the technological significance of an equipment module 
((S88.01). 

All charts belonging to a unit or equipment module in terms of technology must be 
located below the corresponding hierarchy folder. 

Result: If your batch process cell V4.02 already has the structure in the plant 
hierarchy as described above, this will make migration much easier. The next topic 
describes which migration step that you can omit if this is the case.  
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8.3 Basic Procedure 

Overview of Basic Procedure for Migration 

  
V4.02 Database 

Use of the  
SIMATIC BATCH Migrator 

Generate the 
Archiv.xml file with 

the recipe data 

Generate the 
batch.orl file with the 

type description 

Copy batch.orl to suitable 
subfolder of the project 

folder 

Compile Batch process 
cell data and download  

to target system 

*.eqm 

*.xml 

Anlagendaten 
Unit recipes  (and process 
cell data with batch types  

and  instances)* 

Batch types 

Adapt the  
STEP 7 project 

Adaptation of the V4.02 
project according to the 
guidelines for later data 
compatibility  
(when necessary) 

Update Batch process cell 
data in BatchCC with  

Edit > Update process cell 

Import process cell recipes  
in BatchCC with  

 Options > Restore 

*:  The Archiv.xml file contains not only the recipe data but also the process cell data and 
instances. If no expansions whatsoever are made to the project, you only need to import the 
Archiv.xml in BatchCC . In this case, omit step 7. 

1. 

3. 

4. 

5. 

6. 

7. 

2. 

 



Migration V4.02 -> V6.0 

 SIMATIC BATCH 
8-6 A5E00272803-01 

8.4 Migrating Step-by-Step 

Follow the steps outlined below: 

1. Create a backup of your project data so that you have a current version of 
your: BATCH flexible V4.02 database and STEP 7 project 

2. Update the software of your STEP 7 project to PCS 7 V6.0. This is described in 
detail in the documentation Process Control System PCS 7; Updating Software 
on the PCS 7 toolset CD. 

3. After successfully converting the STEP 7 project, adapt the plant hierarchy for 
SIMATIC BATCH: 

 

 Note: 

You only have to perform step 3 if you havenotyet configured a plant hierarchy for 
your Batch process cell in SIMATIC Manager (see also section "Requirements for 
Migration". 

 

- Select the first object below the S7 project name in the plant hierarchy and 
assign the object type "Process cell" to it using the context-sensitive 
command Object Properties > "BATCH Attributes" tab. 

- Insert the "Batch types" object below the process cell in the plant 
hierarchy. To do this, select the "Process cell" object and then select the 
context-sensitive menu command New Object Insert > Batch Types. 

4. Create a SIMATIC PC station for the BATCH Server and each of the BATCH 
clients in the component view and configure them with HW Config with the 
BATCH Server application or BATCH client application. 

5. Create a SIMATIC PC station for each PCS 7 operator station in the 
component view and configure them with the WinCC applications using HW 
Config. 

6. Delete the automatically generated OS below the WinCC application in the 
component view. 

7. Include the original OS below the WinCC application. 

8. Insert a "Unit" folder with any name (recommended: Name of the UNIT block 
instance) for each UNIT block in the plant hierarchy.  

9. Then insert all the CFC charts with the blocks of the corresponding unit in the 
individual unit folders. 
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 Note: 

If a CFC chart contains more than one UNIT block or more than one AF-/TRANS 
instances belonging to different units, these must be split since only blocks of the 
unit itself are permitted below a unit. 

If this step is necessary, it will not be possible to avoid a download to the PLC and 
compiling the OS since this step will change the tag names.  

If, however, you kept to the guidelines described in Section "Requirements for 
Migration", this problem should not occur! 

 

10. Make sure that all hierarchy folders are marked as forming part of the HID or 
not exactly as they were in your original project (select Options > Plant 
Hierarchy > Settings). 

This is important because the WinCC tag names could otherwise change and the 
references to modified WinCC tags, for example in the OS pictures would be lost 
when the OS is recompiled! 

11. Export the type information, process cell data and recipe data from the 
SIMATIC BATCH V4.02 database and import this into the converted STEP 7 
project: 

- Open the SIMATIC BATCH Migrator tool from the Toolset CD PCS 7 V6.0 
(path ...\siemens\BATCHflexible\BFMIGRATION 

- Enter the path of the BATCH flexible V4.02 database. 

- Enter a destination path for storage of the migration data. 

- Specify the OS name of the WinCC project. 

- Select the "Process cell data type information (batch.orl)" option to 
generate the batch.orl file with the type description.  

- Select the "Process cell/recipe instances (archiv.xml)" option to generate 
the Archiv.xml file with the recipe data. 

- Click the "Start" button. 

Result: New batch.orl and archiv.xml files are generated and stored on the 
destination path. 

- Copy the batch.orl file to the relevant folder of the STEP 7 project 
directory. Procedure: Search for the batch.orl file in the STEP 7 project and 
overwrite it with the new batch.orl file. 

- Open the SIMATIC Manager. 

- Open the type dialog by selecting the "Batch Types object in the plant 
hierarchy under process cell and then selecting the context-sensitive 
command Open Object. 

Result: All batch types of the V4.02 project are displayed. A dummy unit class was 
created automatically in the "Unit classes" folder. The process tag types are also 
displayed. 

12. Assign the dummy unit class to each unit folder in the plant hierarchy by 
selecting the unit folder and then selecting the context-sensitive menu 
command Object Properties > "BATCH attributes" tab. 

13. Configure the process tags from the WinCC archives:  
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- To configure the tags, the Migrator automatically creates the Tagimport.txt 
text file. This text file contains the assignment of the type parameter to the 
WinCC tags. 

- In the plant view, select the menu command Options > SIMATIC BATCH 
> Edit measured variables. Here, you then assign the type parameters to 
the WinCC archive tags. You will see the assignments in the Tagimport.txt 
file. 

Before making the batch archive assignment, it is advisable to run a 
validation. This provides you with information about the instance 
parameters that require assignment to WinCC archive tags. 

14. Start the validation to check the batch data by selecting the process cell in the 
plant hierarchy and then selecting the context-sensitive menu command 
SIMATIC BATCH validation. 

Result: If the validation does not report any further errors, the conversion of the 
PCS7 project is complete.On this basis, the batch process cell data must now the 
compiled with the standard functions in the SIMATIC Manager and downloaded to 
the target systems. If error messages occur, the causes must first be eliminated 
and the validation run again. 

If no further validation errors occur, you can start BatchCC after "Downloading to 
the target systems" and update the recipe data with the menu command Options > 
Restore and then the process cell data with the menu command Edit > Update 
process cell.  

Assignment List for TRANS Block Instances 

After migration, the file TransImport.txt is also available. This contains a list of the 
TRANS block instances used BATCH flexible V4.02 referencing them to the 
SIMATIC BATCH generated TRANS types. 
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A Appendix 

A.1 Abbrevations 

 

Abbrevation Meaning 

AS Programmable logic controller (PLC) 

CFC Continuous Function Chart 

EPE Equipment Procedural Element 

ES Engineering system 

NOP Placeholder (empty step / empty transition) 

OS Operator station 

RPH Recipe Phase 

ROP -Recipe Operation 

RP -Recipe Procedure 

SFC Sequential Function Chart 

EPH Equipment Phase 

EOP Equipment Operation 

RUP Recipe Unit Procedure 

VAB Processing block 
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A.2 S88 Terms German - English 

  

German English  German English 

 Ablaufsteuerung sequential control  Prozedurmodell procedural model 

Process Cell process cell  Prozedursteuerung procedural control 

Anlagenkomplex area  Prozess process 

 Anpassroutine scaling function  Prozessabschnitt process stage 

 Basisautomatisierung basic control  Prozessausstoß process output 

Bediener operator   Prozesseinsatz process input 

Belegung allocation  Prozessoperation process operation 

Belegung resource  Prozessparameter process parameter 

Charge batch  Prozessschritt process action 

 Chargenplan  batch schedule  Rezept recipe 

 Chargenprotokoll batch report  Rezeptersteller recipe creator 

Chargenprozess batch process  Rezepterstellung recipe creation 

Chargensteuerung batch control  Rezeptfunktion recipe phase 

Einrichtung equipment   Rezeptkopf recipe header 

Einsatzstoff(e) input material   Rezeptoperation recipe operation 

 Einzelsteuereinheit control module  Rezeptprozedur recipe procedure 

 Fahrweise mode of operation  Rezeptverwaltung recipe management 

Formula Formula  Sollwert setpoint 

Formula category formula category  Steuerfunktion control recipe phase 

Phase phase  Steueroperation control recipe operation 

Geräte process equipment  Steuerrezept control recipe 

Grundfunktion master recipe phase  Stoff material 

Grundoperation master recipe operation   Stoffausstoß output material 

Master Recipe master recipe  Strang line 

Istwert process value  Techn. Einrichtung equipment modul 

Messstelle tag  Technische Funktion equipment phase 

Nebenprodukt by-product  Technische Operation equipment operation 

Normansatz reference scale  Teilanlage unit 

Operation operation  Teilanlagenprozedur equipment unit procedure 

Produktionsauftrag production order  Teilprozedur unit procedure 

Produktionsstrang line  Teilrezept unit recipe 

Prozedur procedure  Teilrezeptprozedur recipe unit procedure 

Prozedurelement procedural element  Verfahrensrezept general recipe 

Prozedurmodell procedural model  Werksrezept site recipe 
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Sequential control 

Control in which device-oriented actions are controlled in an ordered fashion to 
allow a process-oriented task to be performed. 

 Alternative sequence 

Structure element of a recipe with which an OR branch or an OR divergence is 
achieved. An alternative sequence consists of at least two vertically arranged 
sequences joined at top and bottom by a single horizontal line. With alternative 
sequences, you can adapt the execution of the recipe to states in the process. The 
conditions in the top transitions of the sequences decide which sequence is 
executed. 

Process cell 

A logical grouping of facilities/devices that includes the equipment for creating one 
or more batches. It determines the spectrum of logical control options for a set of 
process equipment within a plant.  

Within the plant hierarchy, the process cell is the highest level. This is followed by 
units and equipment phases. 

Area 

An area consists of several equal-ranked or interacting industrial processes with 
corresponding auxiliaries (according to DIN 28004). This is part of a factory with 
batch production that is defined by physical, geographical or logical boundaries 
within the factory. 

Scaling function 

Using scaling functions, you can influence the quantities used. Depending on the 
concrete quantity for the batch, the parameters are corrected using the selected 
scaling function. As default, there are two scaling routines available: 

• Linear: The value is multiplied by the quotient batch quantity/reference quantity. 

• Quadratic: The value is multiplied twice with the quotient batch quantity/reference 
quantity. 

Programmable logic controller (PLC) 

A programmable controller (PLC) consisting of a central rack, a CPU and various 
input/output modules. 
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Abbreviation: PLC 

Basic control 

Basic control means the configuration of the programmable controller system. This 
must be done separately from the recipe control strategy. As tools, you have the 
CFC or SFC editor available. 

Batch Control Center (BatchCC) 

The Batch Control Center (BatchCC) is a component of SIMATIC BATCH and 
provides you with a graphic user interface for monitoring and controlling batch 
processes. The Batch Control Center manages all the data relevant to SIMATIC 
BATCH. 

BATCH Control Server 

The BATCH Control server is a component of SIMATIC BATCH. The BATCH 
Control server handles communication with the process and controls and monitors 
execution of the current batches. 

The BATCH Control Server does not have its own user interface. The BATCH 
Control Server is started on the run-time computer. 

BATCH Report 

BATCH Report is a component of SIMATIC BATCH and is responsible for 
documentation of the recipes and batch data in the form of reports: The recipe 
report with its predefined layout contains all the data required for production. The 
batch report contains all the information required for the reproducibility of the batch 
process, the quality assurance and the fulfillment of legal requirements. 

BATCH Recipe Editor 

The BATCH Recipe Editor is a component of SIMATIC BATCH and provides you 
with a graphic user interface for creating and modifying master recipes and library 
operations. Recipe creation is based on the BATCH objects from the Batch 
process cell configuration in the engineering system of SIMATIC PCS 7, for 
example, units and equipment phases. 

BatchCC 

See Batch Control Center (BatchCC) 

Operator 

see Operator 
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Resource 

Resources are units (including transport and cleaning equipment, input materials, 
products etc. and even personnel) 

Library operation 

You can use libraries to store recipe elements created with the BATCH Recipe 
Editor that you require often in the recipes of the process cell. Only recipe 
operations (ROPs) can be stored as recipe elements. Recipe operations that are 
managed in libraries are known as library operations. 

Library reference 

A library operation is not linked directly into a recipe procedure (RUP) but uses a 
library reference. The library operation cannot be modified within the master recipe; 
the library operation must always be opened explicitly in the BATCH Recipe Editor. 

CFC 

Continuous Function Chart (CFC): Programming language for convenient 
description of continuous processes by graphic interconnection of complex 
functions. 

Batch 

• Material that is being produced or that has been produced by a single execution of a 
batch process. 

• An "imaginary" object representing the procedure for producing material at any point 
within the process. 

Note: Batch means both the material created by and during the process as well as 
the unit that represents the manufacturing procedure for this material. Batch is 
used as an abstract contraction of the words "the production of a batch". 

Production order 

A production order contains information on the product, quantity, required quality, 
and deadline. 

Batch plan 

A list of batches to be produced in a specific process cell. This contains information 
about when and in which order batches representing the required quantity of a 
product will be produced and which equipment will be used. 

Batch report 

A selection of data relating to one or more batches. A batch report documents the 
manufacture of a batch and contains selected recipe data, process data, and 
events. 
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Batch process 

A discontinuous process in which a required product is manufactured in a 
chronological sequence of production tasks involving one or more batches 
according to a set of rules (recipe). 

Batch control 

Allows online monitoring and control and execution of the control recipe. 

Unit of measure 

The unit of measure is a dimension or quantity with a specific value. Examples of 
units of measure: 1 m, 1 kg, 1 DM. 

Equipment 

Generic term for: process sells, units, equipment phases, and control modules 

Input material 

Raw material or other resource required to manufacture a product. 

Control module 

The lowest level of the grouping of equipment in the physical model that can 
implement basic control. 

Engineering station 

PC station on which the process control system is adapted to the task in hand 
using the engineering system (ES). 

Engineering System 

Configuration system (ES) PC-based with which the process control system can be 
adapted visually to the task in hand. 

Control strategy 

Different equipment phases that are mutually exclusive in terms of simultaneous 
operation belonging to the same equipment module are known as the control 
strategies of this equipment module, for example, 

Equipment module: Inertization 

CS 1: Pressure overlay 

CS 2: Rinsing 
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Formula 

Material and production data: Part of the recipe containing the following recipe 
information: input materials (resources for creating the product), output materials: 
(expected results), process parameter is (global recipe parameters). 

Formula category 

A formula category can be assigned a class of formulas with the same raw material 
and production data structure. The only differences between the formulas of a 
formula category are the concrete parameter values. 

The formula category contains the parameters that can be controlled by the 
operator during batch planning with SIMATIC BATCH using the formula. These 
parameters are included in the formula category with their data type and unit of 
measure. 

Phase 

The smallest element of a procedural control that can execute a process-oriented 
task. 

Device 

See equipment module 

Master Recipe 

Recipe stage that takes into account the capabilities of the equipment and contains 
process cell-specific information. A master recipe is an indispensable recipe level 
without which control recipes cannot be created or batches produced. 

Master recipe is can contain material and collection parameters as normalized, 
calculated, or fixed values. A master recipe can be derived from a general or site 
recipe from the enterprise level (refer to the standard IEC 61512-1: 1997). 

Pause 

A batch (control recipe execution) is paused, all active steps continue until they are 
completed, no new steps are started. In contrast to the "Hold" command, this 
command simply prevents the control recipe from passing control to the next step. 

Hold 

The batch (control recipe execution) is held and all active steps are also held. 

Hierarchy folder 

The hierarchy folder is used to achieve hierarchical structuring of a process cell (of 
a project). It can contain further hierarchy folders or objects such as CFC/SFC 
charts, pictures, reports and additional documentation. 
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Reference quantity 

The reference scale is the reference quantity for quantity scaling. All quantity-
dependent values in the recipe relate to this quantity.  

The quantity scaling back to results from the ratio of the concrete quantity to be 
produced and the reference quantity. 

Operation 

A procedural element that controls an independent processing activity consisting of 
the required algorithms for triggering, organizing, and controlling phases. 

Operator 

The operator is the user of this software coordinates the batch during run time. 

Operator station 

Operator control and monitoring station 

Acronym: OS 

Operator instruction 

The operator instruction allows instructions to be displayed to the operator during 
execution of a recipe. A distinction is made between the display of pure instructions 
(NOP step) and an instruction that allows operator input (operator dialog). The 
operator may also be required to acknowledge the instruction. 

Operator dialog 

Input and display option for an operator instruction 

• No acknowledgment 
Example: Entry of analysis process values. 

• With acknowledgment 
Example "manual dosing": The operator is instructed which material and how much to 
add. The operator then enters the actual values that have been added and confirms the 
input (acknowledgment). 

Simultaneous sequence 

Structure element of a recipe that implements an AND branch or an AND 
divergence. A simultaneous sequence consists of at least two horizontally 
arranged sequences connected and the top and bottom by double lines. A 
simultaneous sequence results in the simultaneous execution of more than one 
sequence. This allows processes to be executed at the same time. 
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Product 

Contains the specified production order data to produce a certain quantity of a 
product with a certain required quality at a certain time. 

Project 

A container for all objects of an automation solution regardless of the number of 
stations, modules and how they are networked. 

Procedure 

The strategy according to which a process is executed. This can relate to the 
production of a batch or to a non-productive process, for example a cleaning 
process. 

Procedural element 

A block for procedural control defined by the model of the procedural control. 

Procedural control 

A control that controls equipment-oriented actions in an ordered fashion to allow 
execution of a process-oriented task. 

Process 

A sequence of chemical, physical, or biological activities for the conversion, 
transportation, or storage of material or energy. 

Process stage 

A part of a process that normally executes independent of other process stages 
and results in a planned sequence of chemical and physical conversions of the 
material being processed. 

Process output 

The name and amount of material or energy expected as the result of executing a 
recipe. 

Process input 

The name and quantity of a raw material or other resource required to manufacture 
a product. 
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Process operation 

A larger processing activity that usually involves a chemical or physical conversion 
of the material being processed and that is specified without taking into account the 
target equipment configuration to be used. 

Process parameter 

Information required to manufacture a material that does not fall into the category 
of input material or output material. Typical information in the process parameters 
includes temperature, pressure, and time. 

Process step 

Smaller processing activities that are combined to form a process operation. 

Recipe 

The required amount of information necessary to define the production 
requirements for a specific product. A recipe is the set of rules and information 
required to define how a product is manufactured. The following recipes exist: 
General recipe, site recipe, master recipe, and control recipe. 

In SIMATIC BATCH, the following recipe types are used: 

• Master Recipe 

• Control recipe 

Recipe control strategy 

In a recipe control strategy, the sequence of production steps for making a product 
can vary from one batch to the next. 

The essential aspect of a genuine recipe control strategy is that new recipes can 
be specified and executed ... 

• by the chemist or process technician (not a programmer or control system specialist) 

• using a user interface adapted to his/her needs (not using the 
programming/configuration user interface of the control system) 

• without interventions in the software structure of the control system (in other words, 
without the risk of changing interlocks or validated structures) 

• during operation (without reloading/restarting) of the control system. 

 Such changes, nevertheless, mean changes in the sequences of the process 
steps and not simply changes to parameter values. 

Recipe phase 

A phase that is part of a recipe procedure in a master or control recipe. Depending 
on the recipe type, this becomes the master recipe phase or the control recipe 
phase. 

Acronym: RPH 
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Recipe header 

Information on the purpose, the source, and the version of the recipe, for example 
recipe and product identification, author, and output date. 

Recipe operation 

An operation that is part of a recipe procedure in a master or control recipe. 
Depending on the recipe type, this becomes the master recipe operation or the 
control recipe operation. 

Acronym: ROP 

Recipe procedure 

The part of a recipe that describes the strategy for producing a batch. 

Acronym: RP 

Loop 

Structure element of a recipe consisting of a sequence with at least one recipe step 
and one return path with a transition. 

Step 

A step is the smallest functional unit of an SFC chart. The smallest structural unit in 
a recipe is known as a recipe step. 

SFC 

Sequential Function Chart (SFC): A graphic representation of a sequential program 
consisting of interconnected steps, actions, and specific links with step enabling 
conditions. 

SFC is a suitable method of representation (description of the processing 
sequence) of the entire procedural rules with sequential and parallel steps 
providing clarity in the process controls. 

Control recipe 

A type of recipe which, through its execution, defines the manufacture of a single 
batch of a specific product. 

The control recipe is a copy of a particular version of the master recipe that is then 
modified as necessary with information for planning and execution making it 
specific to a single batch. 

Output material 

A material (product, by-product, or waste product) expected as the result of 
executing a recipe. 
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Structure element 

Structure elements of a recipe consist of an arrangement of basic elements. These 
include, for example, simultaneous sequences, alternative sequences and loops. 

Synchronization line 

The synchronization lines coordinate the execution of recipe sequences in the units 
or of the recipe operations (ROPs) between the units. 

Synchronization point 

At each synchronization point, it is possible to decide whether the execution of the 
recipe sequence should be held. 

Equipment module 

A functional grouping of equipment that can execute a limited number of specific 
smaller processing activities. 

Plant hierarchy 

The plant hierarchy consists of hierarchy folders that in turn can contain further 
hierarchy folders, CFC/SFC charts, pictures, reports, and additional 
documentation. It represents the functional structured hierarchy of the plant 
regardless of the assignment of programmable controllers or operator control and 
monitoring systems. This is displayed in the plant view of the SIMATIC Manager. 

Unit 

A grouping of related control modules and/or equipment modules and their 
equipment in which one or more larger processing activities can be performed.  

Only one batch is ever processed at any one time in a unit. Units generally operate 
independent of each other. Examples of larger units include caustic soda, carbene 
addition, extraction, distillation. 

Unit class 

Each unit can be assigned to a unit class in the plant hierarchy. 

In the BATCH Recipe Editor, the candidates that can be selected as the unit and 
the possible associated phases (EOP/EPH) is restricted to a unit class. The great 
advantage of this is that when you convert the master recipe to the control recipe, 
the actual unit allocation is always successful since the master recipe contains only 
the permitted unit candidates. 

Unit procedure 

A strategy for executing a related process within a unit. It consists of a sequence of 
operations and the required algorithms for triggering, organizing and controlling 
these operations. 
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Unit recipe 

A part of a (control) recipe that uniquely specifies the sequence of production 
requirements for a unit. The unit recipe contains the unit procedure and the 
corresponding material and production parameters, recipe header, requirements of 
the equipment and other information. 

Recipe unit procedure 

A unit procedure that is part of a recipe procedure in a master or control recipe. 

Acronym: RUP 

Transition 

A transition contains conditions that must be satisfied so that the controller can 
move on from one state to the next or pass control from one step to the next. 

Process 

Definiert in DIN 28004: Ablauf von chemischen, physikalischen oder biologischen 
Vorgängen zur Gewinnung, Herstellung oder Beseitigung von Stoffen oder 
Produkten. 

In everyday language a process is a method of achieving a target. In industry a 
process is used along with chemical, physical, and biological knowledge and 
methods to obtain, produce, convert or eliminate materials. Example: Synthesis of 
ammoniac according to Haber and Bosch. 

General recipe 

Recipe type describing processing requirements independent of equipment and 
location. 

Processing block 

The equipment phase/operation in SIMATIC BATCH consists of the BATCH 
interface block (CFC) and the processing block (usually SFC). 

Site recipe 

A site-specific recipe type. Site recipes can be derived from general recipes taking 
into account regional constraints such as language or available materials. 

WinCC 

WinCC is a neutral Windows-based system for solving visualization and process 
control tasks in production and process automation.  

WinCC provides function modules designed for industry for graphic representation, 
messaging, archiving and logging. With its powerful process interface, fast picture 
updating and secure data archiving, it guarantees high availability. 
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