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Question

How do | configure the S5-compatible communication to the SIMATIC S5
for the SIMATIC NET OPC server via Industrial Ethernet with the SIMATIC
NET PC software?

Answer

The instructions and notes listed in this document provide a detailed
answer to this question
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Assignment of tasks

In this example, a CP 1613 is used that implements the S5-compatible
communication over the OPC server with an S5 controller on Industrial
Ethernet.

The same procedure applies to the CP 1613 A2, CP 1612, CP 1512
communication processor and to normal Ethernet network cards.

Condition

It is assumed that one of the two following configuration tools is installed:
* NCMPC

NCM PC is supplied with the SIMATIC NET CD and allows you to create
PC projects and open STEP 7 projects. It is, however, not possible to edit
S7 blocks in the STEP 7 project with this software.

« STEP7

STEP 7 is a separate software package with which you can create S7-400,
S7-300 and PC projects. S7 blocks can be edited with this software.

Only one of these tools can be installed.

In chapter 2 “Configuration of the PC station” is described the configuration
of PC station so that you can use the S5-compatible communication via
Industrial Ethernet to exchange data between PC station und S5.

V1.0
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2 Configuration of the PC station

After successful installation of the hardware and software of the SIMATIC
NET CD and also of the configuration tool comprehending a restarting of
your computer, start NCM PC or STEP 7 with Start > (in Windows XP: All
Programs—>) SIMATIC - SIMATIC Manager or SIMATIC NCM PC
Manager" or using the desktop icon of the same name.

Create a new project with "File > New"

Figure 2-1 Giving the project a name
x

Uzer projects l

Marme ] Storage path
@ Example F:\Program Files\SIEMEMNS\SIMATIC.MCM\S 7prof\E xampls

4| | 2]

Mame:
|Pc_5tatiorl

Storage location

Cocd | beb |

Confirm the project name you have entered (in the example: "PC_Station")
with OK. An empty STEP 7 or NCM PC project is then created.
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Figure 2-2 Inserting the PC station

|24 SIMATIC NCM PC Manager - PC_Station =10l x|

file Edt Insert PLC Wew Options Window Help

Dc|8?] % [%|e| dol 2of sEdE| 2 [<NoFie > =19 28| BB(ml A2l
BEMPI)

Press F1 to get Help, [cPss11(MPI) | 4

With the menu command "Insert > Station > SIMATIC PC Station", insert
the PC station.

Figure 2-3 Adapting the name of the PC station

[ sIMATIC NCM PC Manager - PC_Station =101x|

Fle Edt Insert PLC Wiew Options Window Help

Dlc(E?| % (e[| sl o) Eldi| & [<Norae> 7| % =B el

'E: PC_Station -- C:\Program Files', SIEMENS\ SIMATIC.NCM'\S7proji\PC_Skaki - I Ellll
£R PC_Station PLC_Station u; MPIT)
Press F1 to oet Help, CPS611(MPT} I ~

Assign the PC station you have just inserted the name of your computer (in
the example: "PC_Station").

V1.0
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Now open the hardware configuration of the PC station by selecting the PC
station. Select the PC station, then press the right mouse button and select
"Open Project" (STEP 7: "Open Object").

Figure 2-4 Hardware Configuration of the PC Station

[[SIMATIC NCM PC Config - [PC_Station (Configuration) - PC_Station] I =] eS|
Bl Station Edt Insert PLC View Options Window Help I |
Dls(e-{2 (% & e snleaf[@] %) el
fl Bxl
:
| fd | _'I_"’"= L
2
2 _J
4 @
5 B2 PROFIBLS-PA.
B - B2 PROFINET IO
7 | -8 SIMATIC PC Station
[-]

«5|orc

Index Module Order number Fim... | M..| C.

=
v

||~ @] ||

PROFIBUS-DP slaves for SIMATIC §7. M7, and C7 E
(distributed rack) 5

—_
o
4

Press F1 to get Help. Tz

You will see an empty Rack. If the hardware catalog is missing click on the
button marked in red.
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Figure 2-5 Selecting the Modules from the Hardware Catalog

[ Hw Config - [PC Station {Configuration) -- FAQprojekt_IE_S7H]

By station Edt [nsert PLC View Options Window Help -| =3
D[22 (%] & (2] doldal 2= %] a2
= — o
1 _ Find: ﬁﬁ: y
2
3 Profile: ICurrent Modules \ersion 08.200 »
4 + ¥ PROFIBUS DP -~
3 222 PROFIBUS PA
8 + B2 PROFINET 10
7 = + [ SIMATIC 300
a >N B SIMATIC 400
< > =B, SIMATIC PC Station
# (] Controller
:J:J 0) PC =@ CP Industrial Ethemet
+ (] CP 1411
Index Module Order pum... | Fi.. | M... | Comment | # (1 CP1413
1 ~ =g cPisn
2 = crP1s12
3 + (] CP1604
4 = CPi1g12
5 = acrPiez
3 ... SWVEDSPY
7
g + (] CP1E1E v
L BGKT 16138400 Ly
SIMATIC NET CP 1613 Industrial —
1 Ethemet, IS0, TCPAP, 57 connections, H
12 A communication, TCP connections, PG
Press F1 to get Help.

Now place your PC modules in this rack (for example by dragging them
from the catalog).

If you use a normal Ethernet network card, a CP1612 or a CP1512 in your
PC station, select in the STEP 7 hardware catalog the IE General instead
of CP 1613.

The following dialog box appears automatically after you insert the module
in the PC station:

V1.0
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Figure 2-6 Address Assignment Dialog Box

Properties - Ethernet interface CP 1613 (RO/59) i ) X

General  Patameters ]

[ | Set AT address Ause 50 protocsl

: 00-06-07-00- If & subnet is selected,
BAC addce: (050000 the next available address is suggested.

[~ IP protocol is being used

|P address: [l5zes01 E_a‘“"‘a"
& o ot Lse router
Subnet mask: T ;

Subnet:

== 1ot netwiorked -

Froperties

[elete

oK Cancel | Hep |

Deselect the "IP Protocol is being used" check box and select "MAC
address". Please enter the MAC address of the CP1613 and choose under
subnet the already existing Ethernet network.

To create a new Industrial Ethernet network click on the “New” button. A
further dialog will open which you have to confirm with “OK” (Figure 2-7
Setting up an Ethernet Network in STEP 7 or NCM PC).

Figure 2-7 Setting up an Ethernet Network in STEP 7 or NCM PC

x|

General I

Narme:

57 subnet ID: [ooos - [ome

Project path: |

zf?{?w [C\Program Fies\SIEMENS \SIMATIC NCMNS 7pio)PC_Stal

Author: |

Date created: 26.01.2004 132309

Last modified: 26.01.2004 13:2309

Comment: ﬂ
=

CeE] |
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The CP1613 is now fully configured and networked. Confirm the parameter
assignment with OK.

Figure 2-8 The CP1613 placed in the PC Station

[ Hw Config - [PC-Station (Configuration) -- FAQproject |E_S7H]

Station Edit Insert PLC Yiew oOptions Window Help = =X
DIS(e-® % 8| oo djdal @ 2w
A = =
8,(0)PC Eind: nj_ "tl
z A Profie: [ Standard |
o
z] + SIMATIC PC Based Control 300/4 A
4 - &, SIMATIC PC Station
5 + (] Controller
B =1 CP Industrial Ethemet
JEs AL s A AR
7 . SwW VB O SPY
8 CP1411
ERE TEE 3 w1 CP1413
v CP1511
< 5 cPisi2
CP1612
- (] CP1s13
&= o _SWVEDSP
Oider number ... | Fimware | MP1 addiess SWVBOSPS..
|E General
SIMATIC HMI IE
+ (] CPPROFIBUS
= 0 HMI
WinCC flexible BT v
< >
P e |
| Industrial =
| giiCF'IBTS BGK1 161-38400 VE.0.5 Ethemet, 150, TCPAP. 57
¥ |connections, H communication. TCP
|
T mmbinm mmmmibala e

The module is now plugged in a PC Station slot.

Copyright © Siemens AG 2007 Al rights reserved
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Figure 2-9 Editing OPC Server

B HW Config - [PC-Station (Configuration) -- FAQproject_IE_STH]
[y Station Edit Insert PLC ‘“iew Options Window Help

D|@(e® % &| B)e| daldl B 28 w2l

Profie:  |Standard
2 [

+ FROFIEUS DP
$ PROFIEUS-PA

+ [l SIMATIC 300

+ [l SIMATIC 400

+ 8, SIMATIC HMI Station

i CP 1613 = B SIMATIC PC Station

+ (] Controller

+ (] CP Industrial Ethemet

+ (] CPPROFIBUS

¥ wHm

=1 {Z0 User Application
Application

Rl R - (L] OFC Server

A ... SWVE0SP4

Index E Maodule Order number Fi... | M... | Comment | [ swveosPs .

1 A~ 4 swvel..
OFC Server V6.1,

= O (00 [~ || o |0

=)
<

< >

2
3
4
L3
3
7l
8
9

3440 57 [between different subnets),
Hi: EP 1613 .BGK1 181 0 /6.0 ¥ |ISO/TCP, SHMP, DP master class o

Chose the OPC server from the hardware catalog and move it with "drag &
drop" into the slot.

Figure 2-10 NetPro Symbol

D[e(~[® %] & Bl u|ss| [ 2](R8]) 2]

Open the program NetPro. Use the symbol which is marked in red in the
Toolbar (see Figure 2-10 NetPro Symbol).

In the next step, you configure the ISO transport connection between the
SIMATIC S5 station and the OPC server.

+ SIMATIC PC Based Control 300/400

OPC Server ~ E
OPC Server for the DP, FDL, FMS, t
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Figure 2-11 Insert a new connection in NetPro with STEP 7

Copyright © Siemens AG 2007 Al rights reserved
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iaNetPro - [PC_Station (Network) - C-\Program Files\...\57proj\PC_Stati] o [=] ]
G betwork Edt | Jnset PLC Wiew Ogtions Window el =18]>
q | 2
Local ID Partner D |Partner |Type E
‘| | >
e e [ —" T R TR T =—""r

To insert a connection, select the OPC server. With "Insert > New
Connection", you create a connection.

Figure 2-12 Inserting a new connection in NetPro

Insert New Connection
~ Connection Partner

X

=] -;_n_—| In the current project
= 8 PC_Station
....... [Unzpecified]
-------- All broadcast stations
-------- All multicast stations
P In unknown projsct

[ ok | e |

Cancel |

Help |

V1.0

09.12.2007



Copyright © Siemens AG 2007 Al rights reserved

Guide_SRS5_OPC_e.doc

SIEMENS

S5-compatible communication via IE

Beitrags-ID: 16667875

Select "unspecified" and use "ISO transport connection” as the connection
type.

Unspecified means that the partner (the S5 station) of the connection is not
configured in the same STEP 7 / NCM PC project like the PC station.

Exit the dialog with "Apply". The properties dialog of the connection opens.

Figure 2-13 Properties Dialog of the connection - tab “General Information”

Properties - IS0 transport connection ll
General Information | Addresses | Options| OPC | Overview |

Local Endpoint

MName (ID}: IISD connectionl|

Houte... |

[~ Active connection establishment
Estab. Details...

ViaCP:  [CP1613

cocd | _teo_|

The properties dialog of the connection appears.
e Specify the connection name in the tab "General Information”.

e In our example, the SIMATIC S5 establishes the connection. You
should therefore uncheck "Active connection establishment".

Then change to the tab “Addresses”.
Figure 2-14 Entering Addresses

Properties - IS0 transport connection 3 il

General Information Addresses IUp!iors] OPC | Overview |

Local Remote
MAC (HEXE 08-00-06-01-00-00 {05.00-06-01-2AFE ]
ISAP(ASCIE  {SERFAQPC | (SIMATICS ]
TSAP [hex) [53455246.41.515043  [5349.4D.41.54.49.4335
TSAP length: 8 g

Cancel Hep |
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Exit the dialog with "OK" and the dialog shown in Figure 2-12 Inserting a

new connection in NetPro with "Close".

The address information must be included in the connection configuration
at the S5 end. Enter the MAC address of the S5 CP 1430. The TSAPs

are used to identify the connection between the PC and S5.

If you mark the OPC server in the SIMATIC PC station the ISO-Transport
connection you have just created will be displayed in the connection table.

Figure 2-15 connection table with created ISO-Transport connection

Eéz:ENelPru - [PC_Station (Network) -- C:\Program Files\...\S7proj\PC_Stati] =18 x|
S Metwork Edit Insert PLC View Options Window Help =18 x|

(9 (%) 8| /@] dalis 8] 5|2 Blz| L] M|

PC_Station

(L= CP
LT 1613

-
| | 3

Local ID Partner ID Partner IType IActl.ve connedionﬁ
S0 connection] Unknown IS0 transport connection Mo ]

| | _’];‘

Ready [PCinternal (local) [1 from 1 selected [Chg |

After the ISO-Transport connection has been created the configuration is

done. Save and compile the project (“Network > Save and Compile”).

Proceeding that way the information in the project will be updated.

V1.0
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Figure 2-16 Save and Compile

Save and Compile ﬂ

Compde
' Compide and check evemthing

" Compde changes only

1] 4 Cancel Help

Warning indications can be displayed while proceeding with the “Save
and Compile” of a project. Warnings serve as piece of information and
have no functional effect. In case error warnings occur, search for
possible divergences in the previous steps of the instructions.

After the configuration is finished successful you have two possibilities to
download the configuration on the PC station.

Configuration and download from STEP7 or NCM PC

With this function it is possible to perform a configuration completely from a
remote computer, if a network connection (standard Ethernet) to the target
PC station is available. It is assumed that the PC station can be reached

via network connection. The project engineering can be downloaded after
that.

Configuration and Download via “Import Station”

With this function it is possible to download the configuration and project
engineering at once also without a connection to the target PC station.
Depending on the application, other configurations can be loaded.

Open the “Station Configuration Editor”. You will find its icon on your
desktop and also in the system tray.

V1.0
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Figure 2-17 Station Configuration Editor

Station Configuration Editor - [OFFLINE] ] 1‘
Components | Diagnestics | Configuration Info |

Station:  PC_Station Mode: UN_P

i

;Nw diagnostic entry amived!
Add.. | Edi, | Delsie, | Ainaon |

Station Name... | { Import Station... ) Disable Station_ |

Click on the button "Import station ..." marked in red.

Figure 2-18 Import station

Station Configuration Editor

- The station will be restated.

- Make sure that no communication is active over the
components mvolved.

Do pow weank bo import the station?

I%

Click on the button "Yes" marked in red.
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Import XDB file

Look jn: | ) %DBs

sl e @k

[ Desktop
@pcsﬂ;_ L-.ﬂ,_':j My Documents
'Y My Computer
M 3% Floppy (&)
< SYSTEM [C:)
|7) Program Files
) SIEMENS
I Step?
) s7proj
) FAQproje
= Y-<DB=
e DATA (D:)

File name|

Files of ty

Beitrags-ID: 16667875

2|

In the dropdown choose the directory which contains the *.xdb file. The
XDB file is generated by STEP 7. The XDB file is always set in the project
directory “.../SIEMENS/STEP 7/S7PROJ” (see Figure 2-1 Giving the

project a name)

Figure 2-20 Information from the XDB file

Configuration for XDB Import

X]

[ Statml Ermor

Index | Name |_Tgpe
1

2 aDF‘ESeweﬂ OPC Server
3

4

5

E

7

8

s IF crie13 CP1613
10

n

12

13

14

15

1=

@ The XDB import is possible. Refer ta the list above for the configuration.

™ Work in offline mode [a download to this station is then not possible]

Cancel | Help

09.12.2007
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Information about the concerning components and application in the XDB
will be shown. Confirm this dialog box with "OK"

Figure 2-21 PC station is now configured

S ot e v, S

Companents | Diagnostics | Configuration Info |

Stationr  PC_Station Mode: RUN_P

Index | MName Type Ring | Status | Run/Step | Conn | A
3
2 [1 oPcseve OPC Server ! 3|
3
4
5
[
7
3 —
a F crisia CP 1613 B
10
n
12
13
14
15
16 <
17

New diagnostic entiy anived

sod. | | | |
Station Name... | mpon Station .. | Disable Station
e

The import is now completed and the configuration is loaded. The
connection column shows that the connection is also loaded.
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3 Configuration of the SIMATIC S5

3.1 Initialization of the CP 1430 and creating the Send/Receive
connections
Start STEP 5 with "Start > SIMATIC > STEP 5.
Press the "F9" key to change to the configuration tool of the CP 1430
"SINEC NCM COM 1430".

NOTE The "SINEC NCM COM 1430" configuration tool is additional software
integrated in STEP 5 to configure the CP 1430. This software is not
included in the standard STEP 5 package and must be ordered
separately. Initialize the CP using the "Edit > CP_lInit" menu.

Figure 3-1 Initializing the CP

COM 1
CP Basic Initialization Source: OC:ABABSI <(OFFLIMNE»

MAC address C(HEX)> HEl W8 BAB6B1AAFE
SIMATIC details
Baze SSHR

Interface
communication (Pr /B> =
SS5NR offset H

Copyright © Siemens AG 2007 Al rights reserved
Guide_SRS5_OPC_e.doc

Informative parameters:

Card type = Databasze size
Hodule ID = CP1438TF

Firmware version H Date created
Plant designation

g 9 § 4§ 4§ g [
1 2 3 4 L 6

e The MAC address of the CP 1430 must match the MAC address
configured in NetPro (see Figure 2-14 Entering Addresses).

e The Base SSNR specifies the CP in the rack. This interface number
must be used in the block calls in the S5 program.

Apply the settings with "F7".
Open the "Edit > Connections - Transport Connections" dialog.
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Figure 3-2 Creating a Send Connection

e

COM 1430 TF4Y
Transport Connection Source: C:f COFFLINE)

SSHR offset = ANR :
Job type = Activefpassive (ASP) 2 []

Priority T H Read/write (Y/H)
Humber of jobs per TSAP 1 of

Transport addresses:
Loc. parameters: Rem. parameters:

MAC address C(}E
EL R A I STHATILS TSAP CASC) : QLI
TSAP CHEX) : TENCEAC LIBTEIAE TSAP CHEX) :
TSAP length: [ TSAP length: [
*IIIFIFlll!lml‘!ﬂ”lhHMH!PIHIIIIINuleumHLlﬁmml
1+ 7 - 3 4 5 6 7 g 3

The address information must be synchronized with the settings made in
NetPro.r

e Enter "SEND" for the job type and enter 2 for "Number of jobs per
TSAP".

¢ In the local parameters, enter the TSAP used in NetPro (see Figure 2-
14 Entering Addresses).

¢ In the remote parameters, enter the MAC address of the CP 1613 and
the TSAP specified in NetPro for the CP 1613 (see Figure 2-14 Entering
Addresses).

As the second job, configure the "Receive" job as shown in the following
screenshot (see Figure 3-3 Creating a RECEIVE Connection). Then apply
the settings with "F7".

V1.0
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Figure 3-3 Creating a RECEIVE Connection

[\ ISTEP 5 i

COM 1430 TF
Transport Connection Source: C:IA COFFLIHE)

SSHR offset : AHR

Job type 3 Activefpassive (ASP) =

Priority = Read/write (Y/H)
Humber of jobs per TSAP
Transport addresses:
Loc. parameters: Rem parameters:
MAC address C(HEX) : D8DDD&D10D0D
TSAP C(ASC) = SIMATICS TSAP C(ASC) = SERFAQPC

TSAP CHEX) = 53 4% &0 &1 5& 4% 43 35| TSAP CHEX) - 53 45 52 &6 &1 51 50 43
TSAP length: 8 TSAP length: &

s s e (21 o 110 o e — |

Then download the configuration to the CP 1430 with "Transfer > FD >
CP".

Return to the STEP 5 configuration dialog with "File - Exit" and "ESC".

Description of the S5-CPU program

Synchronization of the CP 1430 with the CPU using the SYNCHRON call in the
start-up OBs

Insert the start-up OBs OB20, OB21, and OB22 in your STEP 5 project.

In these OBs, program the FB125 "SYNCHRON" call that synchronizes the
CPU and CP

Figure 3-4 SYNCHRON Call

V1.0
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Calling the SEND/RECEIVE block in OB1
Create OB1.

Form an RLO = 1 with the two statements:
e OFO0.0
e ONFO0.0

Insert the SEND block call (FB120).
Figure 3-5 Calling SEND in Segment 1 of OB1

C:HTB1358T.550

Interface number
Job number
displavword

Source type
datablock number
Begin of sendbuffer
Length of sendbuffe

NOTICE  Specify the length of the send and receive area in words.

Form an RLO = 1 with the two statements:
e OFO0.0
e ONFO.0

Then add the RECEIVE block call (FB121) after this.
Figure 3-6 Calling RECEIVE in Segment 1 of OB1

Copyright © Siemens AG 2007 Al rights reserved
Guide_SRS5_OPC_e.doc

Seqment 1 3 : STLNE
=H |

<JU FB 121

0,8 Interface number

0,2 Job number

104 displayword

DB Destination type

0,10 datablock number

+0 begin of receivebuffer
;gh Length of receivebuffer
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Hinweis  The "SEND" and "RECEIVE" blocks are executed only when RLO =1
prior to the call.

Calling the "SEND_ALL/RECEIVE_ALL" block in OB1
Insert a further segment.

Program the "SEND_ALL" (FB126) and "RECEIVE_ALL" (FB127) block
calls in this segment.

Figure 3-7 Calling "SEND_ALL" and "RECEIVE_ALL" in Segment 2 of OB1

[csTEP 5§

Save OB1 with "F7".
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Creating the send and receive buffer

Since the send and receive buffer is located in DB10, this must be created
in the project and declared with an adequate length. Then download the
entire program to the S5.
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4 Establishing the connection with the OPC Scout

You can now start the OPC Scout with "Start > (Windows XP: Start > All
Programs—>) SIMATIC - SIMATIC NET - OPC Scout".

Connect to the OPC server by double-clicking on "OPC.SimaticNet". In the
dialog that appears, enter a suitable group name and confirm this with OK.

Figure 4-1 Connecting to the OPC server and creating a group

[FJoPC Scout - New Project 1

File Yiew Server
=| b & [& 2]
|Servers and groups itemz incl. status information
= ﬁ- Server(s) Item Names
[=l s"E& Local Server(s) 1
= ﬁf‘ElF'C.SinaIicNET

Broscow £
- Group Propeties: 1
Eriter a 'Group Name" i
[sAl |

|

|

|

=

Create new group active 72

Requested update rate in ms IE":"':I Li '

[ Extended oK Cancel | Apply |

Once the group has been created, double-click on it and the "OPC
Navigator" opens. You will now see your protocols in the OPC Navigator.

Double-click on "SR". So the connection name you configured in NetPro
appears.
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Figure 4-2 OPC Navigator

MNodes
= & Connections
B4 \SR:
1 150 connection
#& send
#& receive
+ @@ alases
=l \SHMP
@ \FOL:
) § \DP:
@ “FMS:
@ \DP2:
[+ (i \ST:

2 Lstatepathwal]) SR:[IS0 ..

K I Ji|

(150 cornectiant s selecied
If you double-click again on the connection, you can define the items for
communication or add existing items.

If you select "send", an item appears in the middle section. Move this
"send" item to the right with the "->" button.

Double-click on the item on the right-hand side
Figure 4-3 “send” item in the OPC Navigator

Borcrovgotor

Nodes | Leaves | Item Mam... |
= & Connections © send SR:(ISO .
5O \SR:
B 150 connection
[+ I:J send

\SNMP:  Enter an item with the following Syntax:

\Fm.': [Devicenama]itemname

“ ¢ \FMS:|SRISO connection! Jsend

\S7: Modiy ltem Gl |

‘ _.fEihetH&Klﬁamﬂ|

| send is selected [2s082003| 1027

Change the item name as shown in the screenshot below and click on
"Modify ltem".

[Enter an ltem
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Figure 4-4 Modifying an item

x
Enter an iterm with the following Syntas;
[Devicename)ltemnanme

]S R:[150 connection Jzend10,B80.10

Moy Item Cancel

[Enter an ltem

The item "...send 10, BO, ..." means that a send buffer of 10 bytes is
reserved on the PC. The size of the receive buffer on the S5 is
specified in words (see Figure 3-6 Calling RECEIVE in Segment 1 of
OB1). The Parameter ZLAE is defined in the following way:

ZLAE = +5 = 5 words.

Double-click on the "receive" folder in the tree structure and add the
existing item to the list with ">". Exit the dialog with "OK".

With the “receive” item, it is not necessary to specify the data area.

Figure 4-5 Adding the receive Item

X
Nodes o [ltemNem,| | Thelstedlien(s) wilbe added o
= g Connections ) . y SR:(IS0 connection] eceve
D] ASR: - SRS SR[I50 connection] Jsend10,80,1¢
=-i_{ 150 connection
{7 send
[ receive
[+ @ aliases
WENMP: -
\FDL: 2]
SDF:
WFMS: £
‘DP2:
\ST:
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| recaive iz selected |25.08.2002 | 10:28

£

The items are adopted in the OPC Scout. If the quality is good, the
connection is established and it is possible to read and write respectively
the items.
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NOTE The quality of the "Send Item" is valid only after values have been written
the first time.
Figure 4-6 OPC Scout
File Miew _Serve_r Group Il:e_m ? P
=| &l 8| [T 9| +-
|Servers and groups fitems incl status infomation
g Sewverls) | ltem Names . Value [Quality
= % Lﬂ:l:‘dl Serve(s) 1 |SRI50 connection] ieceive Q1ROI0I0I0K gaod
-4 OPC SimaticNET 2 | SREIS0 connection Jsend] 080,10 {000010010K good
SR 3
%y, [New group] T
& OPC SimaticNET.DP
& OPC SimaticNET.PD
o OPCServerWinCC
=l g Fiemate Servers)
\‘S; Add Remote Servers(
By double-clicking on the Value column of the "send" item, you can write
values to the send buffer.
Figure 4-7 Writing Values
EWrite Yalue(s) to the Ttem(s) i x|
Value
{11 I0I0IDIDIDIOION0}
~ Formatconversion———— e S
= Original " Azync wite
" Hex
" Bmen
[ ok | e | aow |
The default structure of the value input ("{0|0}") must not be modified. Only
the values themselves may be modified ("{1]|1}")
Figure 4-8 successful write job
Item Names | Value Qualityle Re Error
1 |SR.IS0 connection] receive 1]1)000J0]0)( qood
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With Send/Receive, successful writing of data must be checked in the
columns "Write Result" and "Error". The "Write Result" and "Error" columns
can be made visible in the "View > Options" menu.
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5 Basic configuration instructions
5.1 TSAP rules

e The TSAP should always be 8 characters.

e The characters permitted for TSAPs are letters, numbers, hyphens, and
underscores.

¢ You should only use upper case letters.
e The local and remote TSAP can be the same.
e The TSAPs must be unique per connection.

e To check the TSAPs, use the output of the character string in
hexadecimal format.

5.2 Interface number (SSNR)
e The interface number of the CP is assigned in the configuration tool of

the CP 1430 "SINEC NCM COM 1430" in the (Edit > CP Init) dialog.

e The SSNR must be specified as a parameter in all communication
blocks of the CPU (FB120, FB121, FB125, FB126, FB127).

e The interface number must be divisible by 4 (0, 4, 8, 16...).

5.3 SEND (FB120) and RECEIVE (FB121), SEND_A (FB126) and
RECV_A (FB127), SYNCHRON (FB125)

¢ The values specified for QLAE and ZLAE are word values (QLAE =0,
10 - send 10 words; ZLAE = 0, 10 - receive 10 words).

o The PAFE and ANZW parameters are output parameters. These are
used for diagnostics and job monitoring. For more detailed information,
refer to the manuals on the CPs.

e The job number (A-NR) specifies the connection configured on the CP
(see Figure 3-5 Calling SEND in Segment 1 of OB1 and Figure 3-6
Calling RECEIVE in Segment 1 of OB1).

e The blocks must be called using unconditional calls (for example JU
FB120).

54 Rules for connection establishment

e A connection is established actively by one station. The partner station
must then establish the connection passively.
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On the S5, the type of connection establishment is linked to the job
type.

- Send = active connection establishment

- Receive = passive connection establishment

The type of connection establishment (active or passive) is decided by
the first job on a connection when there are two jobs ("Number of jobs 1
of 2"). In our example, the first job is "send" and therefore the
connection is established actively by the S5.

The type of connection establishment has no influence on the jobs.
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