
 

 
 

Multi-project/multi-

user engineering 

 
SIMATIC PCS 7 V9.0 
 

https://support.industry.siemens.com/cs/ww/en/view/22258951 

  
 

Siemens 

Industry 

Online 

Support 

https://support.industry.siemens.com/cs/ww/en/view/22258951


Legal information 

 

Multi-project/multi-user engineering 
Entry ID: 22258951,    V7.0,    07/2018   2 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
1

8
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

Legal information 
Use of application examples 

Application examples illustrate the solution of automation tasks through an interaction of several 
components in the form of text, graphics and/or software modules. The application examples are 
a free service by Siemens AG and/or a subsidiary of Siemens AG ("Siemens"). They are 
non-binding and make no claim to completeness or functionality regarding configuration and 
equipment. The application examples merely offer help with typical tasks; they do not constitute 
customer-specific solutions. You yourself are responsible for the proper and safe operation of the 
products in accordance with applicable regulations and must also check the function of the 
respective application example and customize it for your system. 
Siemens grants you the non-exclusive, non-sublicensable and non-transferable right to have the 
application examples used by technically trained personnel. Any change to the application 
examples is your responsibility. Sharing the application examples with third parties or copying the 
application examples or excerpts thereof is permitted only in combination with your own products. 
The application examples are not required to undergo the customary tests and quality inspections 
of a chargeable product; they may have functional and performance defects as well as errors. It is 
your responsibility to use them in such a manner that any malfunctions that may occur do not 
result in property damage or injury to persons. 
 

Disclaimer of liability 
Siemens shall not assume any liability, for any legal reason whatsoever, including, without 
limitation, liability for the usability, availability, completeness and freedom from defects of the 
application examples as well as for related information, configuration and performance data and 
any damage caused thereby. This shall not apply in cases of mandatory liability, for example 
under the German Product Liability Act, or in cases of intent, gross negligence, or culpable loss of 
life, bodily injury or damage to health, non-compliance with a guarantee, fraudulent 
non-disclosure of a defect, or culpable breach of material contractual obligations. Claims for 
damages arising from a breach of material contractual obligations shall however be limited to the 
foreseeable damage typical of the type of agreement, unless liability arises from intent or gross 
negligence or is based on loss of life, bodily injury or damage to health. The foregoing provisions 
do not imply any change in the burden of proof to your detriment. You shall indemnify Siemens 
against existing or future claims of third parties in this connection except where Siemens is 
mandatorily liable. 
By using the application examples you acknowledge that Siemens cannot be held liable for any 
damage beyond the liability provisions described. 
 

Other information 
Siemens reserves the right to make changes to the application examples at any time without 
notice. In case of discrepancies between the suggestions in the application examples and other 
Siemens publications such as catalogs, the content of the other documentation shall have 
precedence.  
The Siemens terms of use (https://support.industry.siemens.com) shall also apply.  
 

Security information 
Siemens provides products and solutions with Industrial Security functions that support the secure 
operation of plants, systems, machines and networks. 
In order to protect plants, systems, machines and networks against cyber threats, it is necessary 
to implement – and continuously maintain – a holistic, state-of-the-art industrial security concept. 
Siemens’ products and solutions constitute one element of such a concept. 
Customers are responsible for preventing unauthorized access to their plants, systems, machines 
and networks. Such systems, machines and components should only be connected to an 
enterprise network or the Internet if and to the extent such a connection is necessary and only 
when appropriate security measures (e.g. firewalls and/or network segmentation) are in place.  
For additional information on industrial security measures that may be implemented, please visit 
https://www.siemens.com/industrialsecurity. 
Siemens’ products and solutions undergo continuous development to make them more secure. 
Siemens strongly recommends that product updates are applied as soon as they are available 
and that the latest product versions are used. Use of product versions that are no longer 
supported, and failure to apply the latest updates may increase customer’s exposure to cyber 
threats. 
To stay informed about product updates, subscribe to the Siemens Industrial Security RSS Feed 
at: https://www.siemens.com/industrialsecurity. 
 

https://support.industry.siemens.com/
https://www.siemens.com/industrialsecurity
https://www.siemens.com/industrialsecurity
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Preface 
This document provides an overview of the different variants and positioning of 
multi-project and multi-user engineering. 

Multiproject engineering allows systems to be configured flexibly and at several 
locations. To facilitate this, the automation solution is divided technologically into 
several projects. The projects are created in a multiproject on a central engineering 
station. In addition to the projects, the master data library is also managed here. It 
contains all shared objects. For decentralized processing, individual AS projects of 
the multi-project can be temporarily distributed to other engineering stations. 

Multi-

project

Engineering Server

ES 1

ES 2

Project AS1

Project AS2

 

 

In addition, multiuser engineering offers the possibility of working on the same 
user program (CFC/SFC of an AS project) or OS project (different process pictures, 
reports) in parallel. This saves valuable time. The project in question can remain in 
its storage location. It is opened and processed simultaneously from several 
engineering stations via a network. 

Engineering Server

Project AS1

Project OS1

ES 1

ES 2

Project AS1

Project OS1

Multi-

project

 

 

Both concepts are basically independent, but they combine to form efficient and 
flexible engineering. 
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1 Multiproject engineering 

1.1 General information 

The multi-project functionality of SIMATIC PCS 7 offers the possibility of flexible 
and high-performance system planning. The focus is on time-saving, parallel 
processing of projects, which can be managed, separated and merged with system 
support. 

The principle of a multiproject 

The multi-project is a superimposed structure in the SIMATIC Manager of the 
central engineering server. It includes all projects of an automation solution with 
their subordinate objects (automation systems (AS), operator stations (OS), 
programs, plans, etc.) as well as the master data library. 

To process the contained projects, they are distributed to decentralized 
engineering stations (ES). By using the additional memory resources and computer 
performance, the engineering process is optimized. The projects can remain in the 
multi-project or be detached for the duration of the processing. The engineering 
server on which the multi-project is stored also represents a fully-fledged 
engineering station on which a project or the master data library can be edited. 

Figure 1-1 

Engineering Server

ES 1 ES 2 ES 3

OS ServerMultiproject

Project 1

Master Data Library

Project 4

AS 4

AS 2

AS 6

AS 3 AS 5

Project 2 Project 3 Project 5

Project 6

 

Despite the decentralized storage, projects can contain cross-project relationships 
such as S7 connections. 
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Benefits of the multiproject 

If projects are part of a multi-project, they can be smaller and more manageable in 
scope. Cross-project mechanisms ensure that a multi-project is used as a single 
project. 

Examples of such cross-project mechanisms are: 

• Master data library for central data storage of block types, measuring point 
types and sample solutions for all projects 

• Comparison of the technological hierarchy across all projects or for selected 
projects 

• Consideration of all related AS and OS parts in the entire multi-project with the 
functions "Create/Update Device Symbols" and "Create/Update Diagnostic 
Images" (for TH structures of the same name) 

• Merging of subnets and connections with textual references of all containing 
projects 

• OS translation with project planning data of several projects 

• Save As (copy of the multi-project with all projects) 

• Archiving (ZIP archive of the multi-project with all projects) 

 

Note In the PCS 7 environment, it is always recommended to create a multi-project 
with master data library, even if only one project is included. 
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1.2 System requirements 

Engineering Server  

• For performance reasons, it is recommended to use a supported operating 
system of the type Windows Server on the Engineering Server. 

• Write permissions must be set up for the project managers of the decentralized 
engineering stations on the Engineering Server and especially on the project 
folder. 

• No administrator rights are required for engineering activities. These are only 
required to install software and to set up and customize the operating system. 
The exact user rights for a PCS 7 system are described in the manual 
"SIMATIC Process Control System PCS 7 – PC Configuration (V9.0 SP1)" 

• Parts of the STEP 7 project planning data are stored in a database. Access to 
this data is executed and coordinated via the Sybase server. A running Sybase 
server is therefore absolutely necessary. After installing STEP 7, this Sybase 
server runs in the context of the logged in user and is automatically started 
when the user logs in. To avoid the constraints of a logged on user on the 
engineering server, you can use the "setsybserv.exe" application to set up the 
Sybase server as a service. The procedure is described in the manual 
"SIMATIC Process Control System PCS 7 – PC Configuration (V9.0 SP1)" 

• For performance reasons, PCs with higher clock rates, main memory and 
faster disk drives (e.g. SSD) are recommended for the engineering stations. 
Further information on the recommended hardware expansion can be found in 
the readme file "SIMATIC Process Control System PCS 7-Readme V9.0 incl. 
SP1 (Online)" 

• For performance reasons it is recommended to reduce the size of the SQL 
database file (*.ldf) of an OS project. Instructions can be found in the article 
"How do you reduce the size of the transaction file (*.LDF) of the database of a 
WinCC project?" 

 

Distributed engineering stations 

• The same PCS 7 version with the same options as installed on the engineering 
server must be installed on all engineering stations. 

• With regard to HW Config and PDM, the same field device descriptions must 
be integrated on all ES. 

• The licenses installed locally or non-occupied licenses used can be accessed 
via network (license type "Floating").  
The floating licenses can be stored on the engineering server or on an 
additional license server. To test OS functions, the necessary RT licenses 
must be installed locally. 

To use one editor on several ES at the same time, the corresponding license is 
required several times. 

https://support.industry.siemens.com/cs/ww/en/view/109754983
https://support.industry.siemens.com/cs/ww/en/view/109754983
https://support.industry.siemens.com/cs/ww/en/view/109750097
https://support.industry.siemens.com/cs/ww/en/view/109750097
https://support.industry.siemens.com/cs/ww/en/view/37333378
https://support.industry.siemens.com/cs/ww/en/view/37333378
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Network structure 

• To load the AS or to test OS functions, the engineering stations in question 
must be connected directly to the plant bus (routing through the Engineering 
Server is not possible). 

• A stable network connection must exist between the engineering stations 
involved. All stations must see each other in the network environment or in 
SIMATIC Shell. 

• Especially for parallel work with multi-user engineering, it is recommended to 
design the network between the engineering stations as Gigabit Ethernet. 

• To avoid unnecessary network load, we recommend that you use a WINS 
server or maintain the LMHOSTS files for name resolution. 
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1.3 Project structures 

The structure of a multi-project is essentially divided into project-specific and 
station-specific structures. 

In practice, a combination of both variants is often recommended, as shown in the 
following example: 

Figure 1-2 

 

 

Note For more information on creating a multiproject, see the document "SIMATIC 

Process Control System PCS 7 Compendium Part A - Configuration Guidelines (V9.0)" 
 and in the manual "SIMATIC Process Control System PCS 7 Engineering System 

(V9.0 SP1)") 

https://support.industry.siemens.com/cs/ww/en/view/109756485
https://support.industry.siemens.com/cs/ww/en/view/109756485
https://support.industry.siemens.com/cs/ww/en/view/109754984
https://support.industry.siemens.com/cs/ww/en/view/109754984
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1.3.1 Boundary conditions 

In order to be able to carry out the later project work as efficiently as possible, 
some preliminary considerations are necessary. 

The question of how the overall task can be suitably separated into sub-projects 
requires consideration of the individual circumstances of the project itself, as well 
as those of the available engineering environment. Here are a few examples: 

• Number of project engineers: How many automation systems must be 
planned and in what time? Where can ratio effects be used in project planning?  

• The number of available engineering stations: Each project planner 
responsible for one or more automation systems has an ES available. 

• Networking of the engineering stations: Normally, all ES should be 
connected to each other via the terminal bus. 

• Project complexity How many trades are to be automated in the multi-
project? In how many buildings will an ES or OS server be positioned? Which 
automation systems are assigned to which OS server? 

• Duration/expenditure of project planning: The duration can be controlled by 
the number of scheduled project engineers. 

 

The following rules apply: 

• Only those project components (AS, OS) should be temporarily moved to a 
decentralized ES that are required for the respective decentralized processing. 

• Only entire projects can be moved to a decentralized ES. If you want to edit 
and test individual areas of the technological hierarchy separately from the 
project, you can use the "Branch & Merge" concept (see manual "SIMATIC 
Process Control System PCS 7 Engineering System (V9.0 SP1)"). 

• For each Operator Station an ES is defined from which the OS translation and 
OS project download is to be performed. 

On the basis of these considerations and the background information from the 
above comparison, the structure of the multi-project can be determined. 

 

https://support.industry.siemens.com/cs/ww/en/view/109754984
https://support.industry.siemens.com/cs/ww/en/view/109754984
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1.3.2 Station-specific structure 

Figure 1-3 

AS

OS Server

Engineering OS Control Room OS Clients

OS Area 1
Test Client

Project

OS Server

OS Area 2
Test Client

AS AS

Engineering Server

 
 

In the station-specific structure, an OS and the assigned AS are stored in separate 
projects. The distribution of the automation systems depends on the number of 
project engineers or the number of trades. For OS clients, e.g. in a central control 
room, a separate project is recommended, as well as for all engineering stations. 

 

Figure 1-4 

OS Project

AS Project

Frei verwendbar
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There are therefore no OS objects (images, reports,...) in the AS project and no AS 
objects (CFC, SFC,...) in the OS project. 

Figure 1-5 

AS Project
AS Project

OS Project

OS Project

 

Advantages 

• The largest possible distribution ensures the highest flexibility in the 
assignment of individual projects to the project managers and also offers the 
best performance in processing speed. 

• Engineering stations can be added or removed during commissioning (IBS) in 
order to be able to react flexibly to varying staff availability. 

Please note 

• Tests of AS and OS during project planning are performed on separate ES (if 
decentralization has taken place). 

• Changes to the technological hierarchies (TH) of projects must be reconciled in 
the multi-project after processing. 

• It is not possible to copy complete subsystems including the update of OS 
objects. 
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1.3.3 Project-specific structure 

Figure 1-6 

AS

OS Server

OS Clients

Area 1

OS Server
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AS

Engineering Server

ES

Project

ES

 

 

In the project-specific structure, a project includes all operating stations for an area 
as well as the assigned ASs. The area is completely independent. OS clients can 
be contained in the same project or in a separate project for a central control room. 

Figure 1-7 
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As the following figure shows, the project contains both AS objects (CFC, SFC,...) 
and OS objects (screens, reports,...) from a technological point of view. 

Figure 1-8 

 

Advantages 

• It can be planned and tested completely in the project with AS and OS. 

• The method of operation during project planning and commissioning is the 
same. 

• Copying of complete subsystems including update of OS objects is possible. 

• There is a unified view of the technological hierarchy that includes AS and OS 
in a project. 

Please note 

All AS plans can only be assigned to the available OS in the same project via the 
technological hierarchy. 

A later separation (outsourcing of individual AS or OS from a project) requires 
detailed knowledge of the necessary work steps. Therefore, the project should be 
split as far as possible right from the start. 
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1.4 Decentralized project archive 

Decentralized storage of projects is ideal for larger project planning work. The 
efficiency is higher if every project planner has the relevant project parts locally 
available on his computer. In this way, he can carry out the work assigned to him 
independently of the overall project. 
 

Figure 1-9 

Engineering Server

Project AS2

Project AS3
Project AS1

ES 1 ES 2

Multi-

project

 

 

For the period in which projects are outsourced, the availability of the 
communication partners must be taken into account, especially for cross-project 
actions such as setting up AS-AS communication or OS translation. 

In the following, decentralized project planning with and without network 
connection is considered. 

 

Note The steps for moving the projects can be found in the manual "SIMATIC Process 
Control System PCS 7 Engineering System (V9.0 SP1)". 

https://support.industry.siemens.com/cs/ww/en/view/109754984
https://support.industry.siemens.com/cs/ww/en/view/109754984
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1.4.1 Division within network connection 

If the network is permanently available, project parts can be moved to 
decentralized engineering stations for processing and still remain in the multi-
project. 

The project engineers can access all components of the multi-project at any time. 
In addition to the necessary network connection, all PCs that manage such 
components must be switched on and released accordingly. 
 

Figure 1-10 

ES 1..n

Multi-

project

Engineering Server

Project AS1

Terminal bus  

 

To move a project, use the system function "Save as..." with the option that the 
project included in the multi-project is replaced by the copy created. 

Advantages 

• An OS server can be translated at any time with the data from AS stations of 
other projects. 

• All program parts used are in the master data library, which can be accessed 
via the network. 

• The Engineering Server makes it easy to archive the entire project, including 
all decentralized projects. 

• A largely station-specific project structure and its decentralized distribution with 
permanent network availability represent the most flexible project planning 
option. 

Please note 

• If, contrary to expectations, a project is not available in the network, this leads 
to a corresponding waiting time. 

• When performing cross-project functions, it must be agreed with the project 
managers to ensure that no work is being carried out on any of the projects 
involved at this time. Otherwise, this could lead to conflicts. 
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1.4.2 Division without network connection 

The multi-project functions of SIMATIC PCS 7 are based on the permanent 
availability of all included projects. 

If an ES is disconnected from the network and thus from the ES server, you 
release the projects for decentralized processing from the multi-project in advance. 
Reasons for this are, for example, that not all ES are permanently in the network or 
that the projects are deliberately processed outside. 
(e.g. award to engineering office / system integrator). 

Figure 1-11 

Project AS1

ES 1..n

Multi-

project

Engineering Server

Project AS1

Terminal bus

Remove from multiproject Transfer

 

The projects can be removed using the system function "Remove from multi-
project...". Projects can be integrated using the "Insert into multiproject..." function. 

Advantages 

• There are no unexpected delays and waiting times due to missing projects. 

• You cannot accidentally access the project during decentralized processing 
(for example, when executing cross-project functions). 

Please note 

• When working with NetPro, warning messages can be generated due to the 
missing communication partners. New connections can only be created 
unspecified for the duration of the project split using references. 

• To translate an OS server, all relevant projects (AS projects and corresponding 
OS project) must be reunited centrally. 

• The master data library is not included in the project. Only the blocks already 
used, which are stored in the blocks folder, are available. To use the functions 
of the master data library on the decentralized ES, it must be managed as a 
local backup. 

• The projects must be archived locally. 
 

Note It is recommended that cross-project functions are only performed if all user 
projects are resumed on the Engineering Server in the multi-project. 
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1.4.3 Distributing the multi-project without network connection 

With this variant, you distribute the multi-project including the master data library 
and the project that the project planner is to plan.  

Figure 1-12 

Multiproject

ES x

Multi-

project

Engineering Server

Multiproject

- Project AS1

Terminal bus

Archive multiproject Transfer

 

To distribute the multi-project, archive it and move the generated ZIP archive to the 
decentral ES using Windows tools.  

After archiving on the decentralized ES, remove the projects that are not required 
from the multiproject and delete them. 

After processing, the project is removed from the multiproject on the decentralized 
ES, archived and reintegrated into the original multiproject on the Engineering 
Server. 

Advantages 

• The project developer can access the master data library. 

• The functions of the Import/Export Assistant (IEA) are available. 

• Control Module Types (CMT) are available. 

• During decentralized processing, no unwanted accesses can occur on the 
engineering server (for example, by executing cross-project functions). 

Please note 

• Changes to the master data library may only be made on the Engineering 
Server. The changes must then be made to all decentralized ES. 

• If all unneeded projects have been deleted after the recommendation, warning 
messages can be generated when working with NetPro due to the missing 
communication partners. New connections can only be created unspecified for 
the duration of the project split using references. 

• To translate an OS server, all relevant projects (AS projects and corresponding 
OS projects) must be reunited centrally. 
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1.5 Distributed editing 

General information on cross-project activities 

The actual processing of projects is decentralized. Cross-project data 
synchronization and functions, however, are always performed in the SIMATIC 
Manager of the central engineering server, where the multi-project is managed. 
These activities can be carried out before the project is distributed or after the 
projects have been reintegrated into the multi-project, i.e. when all projects are in 
the multi-project and no work is being done on them. 

Whether the projects to be processed decentrally remain in a multi-project or are 
detached depends on the extent to which a stable network between the PCs can 
be guaranteed. 

Overview of the configuration steps 

An overview of the work processes required in multi-project engineering is to be 
given here. We recommend the following workflow, but it can vary according to 
individual circumstances and experience. These steps are described in more detail 
in the following chapters. 

Table 1-1 

 Activity Location 

1.  Project planning: 

• Determining the number of project engineers 

• Determining the available ES -PCs 

• Connecting the ES PCs to the network 

• Determining the complexity of the project 

 

2.  Project set-up: 

• Creating the multiproject 

• Configuring the SIMATIC and PC stations 

• Creating and synchronizing the technological hierarchy (TH) 

• Generating cross-project networks 

• Creating cross-project connections 

• Mass data engineering  

Engineering 
Server 

3.  Dividing the projects: 

• Moving projects within the network 

• Removing projects from the multiproject 

• Distributing the project including the multiproject 

Engineering 
Server 

4.  Decentralized project editing  

• Editing and completing charts 

Decentralize
d ES 

5.  Merging the projects: 

• Moving projects back to the multiproject 

• Reconnecting projects in the multiproject 

Engineering 
Server 

6.  Final project operations: 

• Adjustment of the Technological Hierarchy (TH) 

• Merging referenced connections 

• Checking cross-project consistency 

• Compiling and loading 

Engineering 
Server 
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Note The individual work steps are described in detail in the manual "SIMATIC 
Process Control System PCS 7 Engineering System (V9.0 SP1)" 

 

1.5.1 Project planning 

You have determined the following sizes using the boundary conditions in chapter 
1.3 

• Number of automation systems 

• Number of operator stations or OS servers 

• Number of project engineers 

• Number of available engineering stations  

• Connecting the engineering stations 

• Configuration duration 

You have now decided on the site-specific or project-specific structure of the multi-
project. 

https://support.industry.siemens.com/cs/ww/en/view/109754984
https://support.industry.siemens.com/cs/ww/en/view/109754984
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1.5.2 Preparatory project work 

Create new multi-project 

The PCS 7 Assistant creates a multi-project with a subproject whose objects (AS, 
OS, programs, plans, etc.) can be integrated using user queries if required. In 
addition, a master data library is created with the following content: 

• An S7 program with the folders for sources, blocks and plans (component 
view) 

• One folder each for measurement loop types and sample solutions 
(technological hierarchy) 

• Shared declarations 

 

Start the PCS 7 Wizard via "File >'New Project' Wizard...)".  

Figure 1-13 

 

The wizard guides you through 4 steps to create the multi-project. 

1. Introduction and project preview 

 

2. Configure the automation system 
Here you can select an existing AS of your system in advance. 

 

3. Technological hierarchy and operator station 
In this step you determine the number of hierarchy levels and can also 
determine whether an OS is created. If you want to set up your multi-project on 
a station-specific basis, do not select a PCS 7 OS here. 
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4. Project name and storage location 
In this step, name your project and select the directory for saving the multi-
project. 

 

Note It is recommended to choose a directory that is not on the system partition (C:). 

Use the planned structure to create further projects in the multi-project. Select the 
menu function "File > Multiproject > Create in Multiproject...". In addition, you can 
select the multiproject and select it via the context menu "Multiproject > Create in 
Multiproject..." to create a new project. 

Figure 1-14 
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Configuring SIMATIC and PC stations 

Configure the individual stations and their network connection according to your 
project planning and the hardware conditions. 

Create the required stations with the menu function "Insert > Station > ...", or use 
the PCS 7 wizard "Insert > Preconfigured Station...". 

Figure 1-15 

 

 

Note You can also use the PCS 7 Assistant for manually created projects to create 
preconfigured stations. For existing projects start the wizard with the menu 
function "Insert > Preconfigured Station...". 
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Projecting a Technological Hierarchy 

Starting with version 6.1 of PCS 7, handling of the TH in a multi-project is 
simplified. If the folders of the TH are to be created identically, at least in parts, in 
all or individual projects of the multi-project, this step is only necessary once in a 
project. The other projects then take over the TH when carrying out a comparison. 

In the individual projects, hierarchy folders with different names are newly created 
and provided with the properties of the template folder. Hierarchy folders of the 
same name are recognized and not newly created, but also receive the properties 
of the template folders. 

1. Project the complete technological hierarchy in one project. 

2. Select the multi-project and select the menu function "Tools > Technological 
hierarchy > Synchronize in multi-project...". ("Options > Plant Hierarchy > 
Update in the Multiproject...").  

 

Two options are available for comparing the technological hierarchy: 

• "Merge the TH of all projects in the multiproject" 
The TH is calibrated throughout the entire multi-project. 

• "Export the PH of one project in other projects” 
The TH of a selected project is compared with the TH of the target projects. 
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Figure 1-16 

 

If the technological hierarchy of referenced projects is to be changed, the link must 
first be removed. You can do this with the function "Tools > Technological 
hierarchy > Remove link" ("Options > Plant Hierarchy > Cancel Assignment"). You 
can deselect the multiproject-wide TH link by selecting the multiproject or 
deselecting the corresponding project. 

Generating cross-project networks 

In order for the stations of the individual projects to communicate with each other in 
PCS 7, their subnets must be merged. Cross-project networks are created for this 
purpose in the multi-project. 
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You reach the dialog for merging subnets via the menu function "File > Multiproject 
> Synchronize projects..." ("File > Multiproject > Adjust Projects...") or from within 
NetPro via "Edit > Merge / Unmerge Subnets > ...". 

1. Select the option "Merge / Disconnect Subnets > Ethernet-") ("Industrial 
Ethernet" ("Ethernet") (1). Click the "Run" button (2). 

1

2

 

2. Select the subnets that you want to merge into a global network (1). Use the"-
>" (right arrow) button (2) to add it to the global network. 

1

2

 

3. Click "OK" to confirm your selection. 

Frei verwendbar
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Creating cross-project connections 

You can now create the cross-project connections between AS - AS, OS - AS or 
ES - AS (to test the function of the OS on the ES using the OS simulation) as 
usual. 

If the subsequent decentralized project planning takes place in a multi-project, the 
connections can also be created after the projects have been split. 

If projects remote from the multi-project are to be processed, we recommend that 
you create the known connections in advance. Later, you can add unspecified 
connections using textual references. The links can be closed on the central 
engineering server after the projects have been included in the multi-project. 

Figure 1-17 
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1.5.3 Dividing the projects 

Depending on whether the decentralized processing of the projects is to take place 
in a multi-project with network connection, in a multi-project without network 
connection or without a multi-project and without network connection (project only), 
three ways of project distribution are described in the following. 

However, we recommend that you use the variant in which you copy and distribute 
the multiproject. 

Distributing a project including the multiproject 

This option describes how you distribute the multiproject among the decentralized 
ES. This has the advantage that the project planner has unlimited access to the 
master data library and can use the Import/Export Assistant (IEA) for project 
planning. 

In this variant, a copy of the multi-project is distributed. The projects that are not 
required are then removed from the multi-project on the decentralized ES. Proceed 
as follows: 

1. Archive the multi-project via "File > Archive...". 

2. Copy or move the archived multi-project to an external data carrier. On the 
decentralized ES unpack the multiproject via "File > Retrieve...". 

3. Remove all projects from the multiproject that the project developer does not 
need via "File > Multiproject > Remove from Multiproject" ("File > Multiproject > 
Remove From Multiproject"). 

Note You must not change the master data library on the decentralized ES, since it 
can no longer be returned to the multi-project of the Engineering Server. 

The master data library should only be changed on the Engineering Server by an 
authorized person. After a change has been made, it must be redistributed to the 
decentralized ES. 
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Moving a project within the network 

A project within a multi-project is then moved from the central engineering server 
via the network to a remote ES. A copy of the project is created on the remote ES 
and included in the multi-project. The original is removed from the multi-project and 
can physically remain on the hard disk of the central engineering server as a 
backup copy. 

1. Select the project that is to be moved to a decentral ES in the SIMATIC 
Manager. 

2. Select the menu command "File > Save As...". 

1 2

3

4

 

3. Make the following settings in the "Save As" dialog: 

– Set the option "Add to multiproject" (1) 

– "Select "Current multiproject" from the drop-down menu (2) 

– Set the option "Replace Current project" (3) 

– Select storage location (4) 

4. Save the project with the "OK" button. 

The existing original project was removed from the multi-project and stored on the 
central engineering server. It can remain there for backup or be deleted. The 
backup copy can be removed using the menu item "File > Delete..." of the 
SIMATIC Manager . 
  



1 Multiproject engineering 

1.5 Distributed editing 
 

Multi-project/multi-user engineering 
Entry ID: 22258951,    V7.0,    07/2018   30 
 

C
o
p

y
ri

g
h

t 
©

 S
ie

m
e

n
s
 A

G
 2

0
1

8
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

The component view provides you with an exact overview of which projects are 
included in the multi-project. The "UNC path" column provides information on which 
ES the projects are stored. 

Figure 1-18 

 

Note The UNC path must be set for each project in the notation 
\\Computername\ShareName\... must be filled in correctly so that moving the 
projects in the network works. Please also note the system requirements for 
networking in chapter 2.2. 

Removing a project from the multiproject 

This removes a project from the multi-project. The remote project can then be 
moved to an external data carrier for transport purposes. 

1. Select the project to be removed from the multi-project. 

2. Select the menu command "File > Multiproject > Remove From Multiproject". 

Even if the project has been removed from the multi-project, it is still stored as a 
project in the folder created during creation. To transfer the project to an external 
medium, it must be archived. 

3. Execute the menu function "File > Archive...". 

4. Select the project in the "Multiprojects" tab. 

5. Start archiving with the "OK" button. 

After these steps, the project removed from the multi-project is on the drive on 
which it was created, both in its original form and as a ZIP archive. Both can 
remain here as backup copies or be deleted. The original project can be deleted 
using the menu item "File > Delete...". You can delete, move or save the ZIP 
archive using Windows tools. 

To enable the project planner on the decentralized ES to access the master data 
library, you must also copy this to the decentralized ES. However, changes to the 
master data library should only be made to the Engineering Server. The library 
must then be redistributed to the decentralized ES. 
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You can distribute the master data library as follows: 

1. Execute the menu function "File > Archive...". 

2. In the "Libraries" tab, select the master data library of the multi-project. Master 
data libraries are marked with a blue book symbol. 

3. Start archiving with the "OK" button. 

 

You can copy the ZIP archive of the master data library to all decentralized ES via 
an external data carrier as usual. After archiving to the decentralized ES, you can 
use the master data library like a normal library. 

Note For temporary network connections between the engineering stations, SIMATIC 
Manager provides additional functionality. 

If the project is selected, it can also be moved to the remote ES via "File > 
Multiproject > Remove for editing..." and simultaneously removed from the 
multiproject. In the multi-project, the project is marked as "Project removed for 
editing" and displayed in gray. 

On the one hand, you save the deletion process and, on the other, the 
resumption after processing is simplified because the original storage path is 
remembered (reduction of administrative effort). 
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1.5.4 Decentralized project editing 

Editing projects without network connection 

These functions are possible when processing projects on the decentralized ES: 

• Functions that do not span across projects 

• Editing processes 

• Compiling and loading an AS via a fixed parameterized PG/PC interface (e.g. 
CP1613[ISO]) 

If you want to load the AS from the decentralized ES via the "PC internal (local)" 
interface module, you must first carry out the following work: 

1. Insert a local PC station with suitable CP into the project. 

2. Configure the S7 connection between AS and OS 
 

If you want to test an OS on the decentralized ES in process operation (OS 
simulation), you must adapt the computer name in WinCC Explorer. 

Note Before the project is copied or moved back to the Engineering Server, the 
changes you made for loading (via "PC internal (local)") must be undone.   

 

Editing projects within network connection  

The decentralized processing of projects of a multi-project with permanent and fast 
network connection largely corresponds to the processing of several projects on 
one and the same engineering station. 

The backup of the multi-project on the engineering server also includes the 
distributed projects. During archiving, no work is allowed at the decentralized 
engineering stations on the project. 

As of PCS 7 V6.1 SP1, the Version Trail option package is also available. This 
allows project data, i.e. complete multi-projects, single projects or libraries, to be 
archived and the data to be given a version identification and a comment. 
Furthermore, you can unarchive and reuse project data that has already been 
versioned. Version Trail also takes over the complete administration of the version 
history. This means, for example, that you can no longer change a version once it 
has been completed. 

As of PCS 7 V8.1, automatic archiving is possible after successful loading of the 
user program (version trail must be available). 
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1.5.5 Merging the projects: 

After the projects have been processed decentrally, they must be combined again 
in the multi-project. 

Moving a project within the network 

A project within a multi-project is then moved from a remote ES to the Engineering 
Server. A copy of the decentrally processed project is created on the engineering 
server and included in the multi-project. The decentrally processed project on the 
remote ES is removed from the multi-project and can physically remain on the hard 
disk of the decentralized ES as a backup copy. 

 

Note The project must be located "physically" on the decentralized ES and be 
integrated in the multi-project on the engineering server.  

The decentralized ES is accessible via the network. 

1. If necessary: Delete the existing project of the same name (status before 
moving to the decentralized ES) on the engineering server. 

2. Open the project from the Engineering Server on the decentralized ES with the 
menu command "File > Open..." ("File > Open...") in the SIMATIC Manager. 

3. Click on the "Browse..." button. 

4. In the "Browse" menu in the "Find in directory" field, enter the path of the 
project to be moved in "UNC notation". 

5. Click the "Start search" button. The project is displayed in the "User projects" 
tab. 

6. Select the required project in this tab and click "OK". The project opens. 

7. Select the menu command "File > Save As...". 

8. Select the following settings: 

– Activate the "With reorganization (slow)" option box. 

– Activate the "Add to multiproject" option box. 

– Select the entry "Current multiproject" in the corresponding drop-down list. 

– Activate the "Replace current project" option box. 

9. Click the "OK" button. 



1 Multiproject engineering 

1.5 Distributed editing 
 

Multi-project/multi-user engineering 
Entry ID: 22258951,    V7.0,    07/2018   34 
 

C
o
p

y
ri

g
h

t 
©

 S
ie

m
e

n
s
 A

G
 2

0
1

8
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

Adding and reintegrating a project into a multiproject 

A project that has been edited on a remote ES is then re-inserted into the multi-
project. A distinction is made between the methods "Insert into multiproject" and 
"Restart after editing". 

 

Note The choice of insert/record method depends on the method used to remove from 
the multi-project. See chapter 1.5.3 "Dividing the projects"  

 

Reintegrate the project after editing: 

1. On the Engineering Server, select the project marked as "Project removed for 
editing" (grayed out). 

2. Select the menu command "File > Multiproject > Reapply after Editing". 

 

Note A temporary network connection between the remote ES and the Engineering 
Server is required for the resumption. 

 

Insert the project into a multi-project: 

3. Archive the edited user project on the decentralized ES. 

4. Copy the repository to the engineering server. 

5. Select the menu command "File > Retrieve" on the Engineering Server in the 
SIMATIC Manager. 

6. Select the project to be dearchived from the menu ("Retrieving - Select an 
archive"). Then click "Open". 

7. Select the directory in which your multi-project is stored in the "Select 
destination directory" menu and click "OK". 

8. On the Engineering Server in the SIMATIC Manager, open the multi-project 
into which the user project is to be inserted. 

9. Select the multiproject and select the menu command "File > Multiproject > 
Insert into Multiproject...". 

10. In the "Add to Multiproject" menu, select the user project you want to insert and 
click "OK". 
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1.5.6 Final project work 

After you have merged the decentralized projects, you can complete the overall 
project planning by executing cross-project functions for the first time or repeatedly. 

Adjusting the Technological Hierarchy (TH) 

If you want to keep the TH of all projects identical, but changed it during 
decentralized processing in a project (for example, by inserting a new hierarchy 
folder), you can adjust the other projects with it again. 

Select the multi-project and select the menu function "Tools > Technological 
hierarchy > Synchronize in multi-project...". (Options > Plant Hierarchy > Update in 
the Multiproject..."). 

Merge cross-project connections 

Connections that were created at the decentralized engineering stations with a text 
reference can be closed on the Engineering Server after the projects have been 
integrated into the multi-project: 

There are two procedures for merging cross-project connections. 

To merge the cross-project connections across multiple projects, proceed as 
follows: 

1. Select the menu command "File > Multiproject > Synchronize projects..." in the 
SIMATIC Manager. (File > Multiproject > Adjust Multiproject..."). 

2. In the tree view, select the entry "Merge connections" (1). 

3. Click "Execute" (2) The "Result" section (3) displays all cross-project 
connections that can be merged. 

4. Click on the "Apply" button (4). This will merge all displayed connections. 

Frei verwendbar

1

2

3

4

 

To merge the cross-project connections of individual projects, proceed as follows: 

1. Select the project whose connections you want to merge in the SIMATIC 
Manager. 

2. Start "NetPro". 

3. Select the menu command "Edit > Merge Connections...". 

4. Select the connections you want to merge (1) and click the "Merge" button (2). 
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After the connections have been successfully merged, the status changes to 
Merged. 

 

Compiling and loading 

Perform the following activities in accordance with the manual "SIMATIC Process 
Control System PCS 7 Engineering System (V9.0 SP1)" 

1. AS Program compilation 
You can skip this step if the program has already been translated to the 
decentral ES. 

2. Compiling the OS servers with access to the associated AS components 

3. Assigning the OS server to the OS clients 
(Must be carried out once manually. When the OS clients are loaded onto the 
target computers, the OS server data is also loaded. Subsequent changes to 
server configuration are automatically applied to the clients) 

4. Downloading all target systems 

https://support.industry.siemens.com/cs/ww/en/view/109754984
https://support.industry.siemens.com/cs/ww/en/view/109754984
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2 Multiuser engineering 

2.1 Function mechanisms 

In multi-user engineering, several project engineers work on one and the same 
project, regardless of the selected project structure and distribution. The 
corresponding project is located on an Engineering Server, which allows access to 
individual engineering stations via network. It does not matter whether it is part of a 
multi-project or whether it was hung out and moved for editing (e.g. to 
decentralized ES). 

Figure 2-1 

Engineering Server
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OS ServerMultiproject

Master Data Library

Project for AS
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Real multi-user engineering is currently only available for processing CFC/SFC. 
These objects can be changed in parallel by different project designers, whereby 
changes are written directly to the system database. If a plan is opened by one 
project engineer and another project engineer wants to open this plan, he receives 
a message indicating that this plan is already open by another project engineer. 

Figure 2-2 

 

If two projectors have opened the same schedule at the same time and one of 
them makes changes, the other will only see these changes when he updates the 
display (F5 key). 

When editing different objects (e.g. CFC plans), there is usually no conflict in the 
same project. However, caution is required when performing project-wide actions 
such as AS translation. If a project developer tries to change a CFC plan while the 
AS program is being translated, a conflict occurs with a corresponding message 
window. 

The following applies for all other objects in the PCS 7 project: If several project 
engineers access the same object, e.g. the symbol table, it can only be edited by 
one project engineer. The other projectors can only open the symbol table read-
only. 
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It does not matter how an object is opened.  
You can open the symbol table from the component view, the process object view, 
or the menu option of an editor (for example, SCL editor). The table is always 
displayed and edited in the symbol editor. 

Figure 2-3 

Multi-

project

(Share)

Engineering Server ES 1 ES 2

Terminal bus

Symbol

table

Symbol

table

(read only)

Project AS1 Project AS1

 

Basically, all objects can be opened in read mode by all users, but may only be 
edited in write mode by one user. The user who first made a change has the right 
to save the change made. All other users receive the message that the object is 
already being edited and that you can only save your changes using the "Save 
as..." function. Only after the change has been saved by the project engineer can 
the object in question be edited again by another user. 

Starting with PCS 7 V8.1, the multi-user engineering function can be activated for 
the OS project. If this function is activated, the OS project can be opened several 
times remotely. A distinction is made between file-based and database-based 
access. 

Project 

• On each station, either the multi-project or the individual project is opened via 
network. It is important that the network share has already been activated 
before creating the multi-project. 

• To increase performance, projects with AS stations can be stored on their own 
ES for the duration of the project planning using the "Save as" function without 
being removed from the multi-project. This increases the performance. If the 
"Save As" option is unfavorable due to the project situation, performance can 
also be increased by remote access to the ES Server (see also chapter 3.4 
Remote access to the Engineering Server). 

Note Working over a network increases the potential risks for a smooth workflow. If 
the network connection fails during a write operation, long waiting times and 
possible inconsistencies in data storage may occur. In this case, close all open 
projects in SIMATIC Manager before you continue working. 
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2.2 Overview of the configuration steps 

In general, the first project planning steps, such as creating the multi-project, must 
take place on the Engineering Server.  

The following workflow is recommended, but may vary according to individual 
circumstances and experience. 

Figure 2-4 Procedure Multiuser engineering 
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Archive multiproject
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Define a team leader (lead engineer) who is responsible for cross-project functions 
and manages the ES Server. 

Working over the network can increase the risk of data inconsistencies. Therefore, 
a stable network connection between the engineering stations is absolutely 
essential for multi-user engineering. 

We recommend that you perform cross-project functions on the Engineering Server 
where the project or multi-project is managed. 

• Creating and Adjusting the Technological Hierarchy (TH) 

• Managing the master data library 

• Merging subnets and connections 

• Creating and updating the block symbols 

• Compiling and loading all contained components (AS, OS, ...) 

 

Note When you execute cross-project functions, you need to make arrangements, 
since you cannot work on the projects at this point. The individual work steps are 
described in detail in the manual "SIMATIC Process Control System PCS 7 
Engineering System (V9.0 SP1)" 

 

 

https://support.industry.siemens.com/cs/ww/en/view/109754984
https://support.industry.siemens.com/cs/ww/en/view/109754984
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2.3 Working in parallel 

For the parallel work of several projectors, the multi-project, or individual projects of 
the multi-project, is opened via network access at several engineering stations. The 
engineering server on which the project is stored can also serve as a work 
computer. 

Access scenarios / special features 

There are different cases for editing objects in the same project: 

• Different objects at several engineering stations 

• Different objects of an AS at several engineering stations 

• The same object at different engineering stations 

• Different objects of one OS at several engineering stations 

When machining different objects at several engineering stations, no obstruction is 
to be expected for AS Engineering. 

However, if several projectors are working on the same plan, this can lead to 
mutual obstruction. For example, if two project designers are in the same input 
mask at the same time within a CFC plan, its action is executed, the last to press 
"Apply" or the dialog ends with "OK". This procedure is therefore not 
recommended. 

When working with different objects of one OS at several stations, no obstructions 
are to be expected. The individual editors or images can only be opened by one 
user at a time. In some cases, Read-Only mode is also possible for viewing the 
configured data when editors are already open. 

 

CAUTION If several project engineers are working on the same object, update the 
view by pressing F5 before carrying out any further steps. This ensures 
that the real actual state is displayed. 

 

Try to avoid this mode of operation by coordinating the work. You should not 
access the same resources simultaneously, for example, parameterizing the same 
connections of a particular device type. In the case of long read or write actions, 
the project engineers must coordinate with each other. 
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Tools 

PCS 7 offers various tools for editing plans of the same station or in the same 
project, the use of which can considerably reduce possible conflicts: 

 

• Version: Activate the versioning of the plans in order to recognize whether 
something has changed in the plan based on the version number and the 
change date.  

• Author: Register as the author of the plans if you are responsible for them 
or are working on them. 

• Write protection: Activate the write protection on a single chart or all 
charts together as soon as certain areas are finalized. 

• Change log: Activate the ES change logbook when using SIMATIC Logon 
(for details see manual "SIMATIC Process Control System PCS 7 
Engineering System (V9.0 SP1)"). 

• Access control: Use SIMATIC Logon Role Administration to define who 
may open which project (for details see manual "SIMATIC Process Control 
System PCS 7 Engineering System (V9.0 SP1)"). 

Conflict handling 

A typical conflict situation is, for example, a parallel change to the same object. The 
project engineer always has the right to save the change that made it first. All other 
projectors usually receive a message that the object is write-protected or occupied 
by another process. 

Figure 2-5 

 

Opening (reading) objects or their properties in parallel usually does not lead to a 
conflict and can be performed by all users. 

 

https://support.industry.siemens.com/cs/ww/en/view/109754984
https://support.industry.siemens.com/cs/ww/en/view/109754984
https://support.industry.siemens.com/cs/ww/en/view/109754984
https://support.industry.siemens.com/cs/ww/en/view/109754984
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2.3.1 Charts (CFC/SFC) 

Summary 

Table 2-1 

Action Restrictions 

Processing of different plans of an AS at 
different ES. 

None 

Editing the same charts of an AS on various 
ES. 

Restricted, changes of the other project 
engineer only visible after updating the view 
(F5 key). 

Prioritizing actions 

The individual transactions are assigned different priorities. Basically, the higher-
priority action is always executed in the event of an access conflict. The low-priority 
action is terminated in this case. A short read action has the lowest priority and a 
long write action has the highest priority. 

Table 2-2 

Action type Read/write action Behavior 

Short read actions 
(without resource 
allocation) are: 

• Opening charts 

• Opening run sequence 

• Opening dialog boxes 

If further short read actions are carried 
out in addition, no impairments are to 
be expected. 

If a short or long write action is 
performed in parallel, an access 
conflict can occur, that is, the short 
read action is terminated. 

Short write 
actions (without 
resource 
reservation): 

• Instantiation, 
parameter 
assignment, 
interconnection, etc. 

• Close dialog box with 
OK 

If a short or long write action is 
performed in parallel, an access 
conflict may occur for the action started 
later. 

Long read actions 
(with resource 
allocation) are: 

• AS-OS data transfer 
(OS compilation) 

If an access conflict does not occur 
immediately when the long read action 
is triggered, for example, because a 
write action is already being performed 
in parallel, this action runs through 
without an access conflict. 
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Action type Read/write action Behavior 

Long write actions 
(with resource 
allocation) are: 

• Optimizing the run 
sequence 

• Compiling and 
downloading (AS and 
OS) 

• Type import and block 
type update or clean-
up 

• Synchronizing shared 
declarations 

• Generating module 
drivers 

• Reading back 

• Creating block icons 

• Creating diagnostics 
screens 

• Synchronizing TH in 
multiproject 

• Import/Export 
Functions of the IEA 
and the Process 
Object View 

• Import/export functions 
of ES objects of the 
VCM 

If an access conflict does not occur 
immediately when the long write action 
is triggered, for example, because a 
write action is already being performed 
in parallel, the action runs without an 
access conflict. 

 

Signaling conflicts 

The same plan (CFC or SFC) can theoretically be worked on by several projectors 
at the same time. However, only one project developer can write to the database at 
any one time. If an action cannot be executed, the following message appears, for 
example: 

Figure 2-6 
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Due to the short time required to write to the database, such conflicts are extremely 
rare. 

Note 

 

How CFC/SFC processing works 
When opening an already opened CFC/SFC, a message box appears stating 
that the chart is already open. The project developer must then decide whether 
to open the plan again. 

If projectors are working on the same CFC/SFC plan at the same time, they 
should coordinate with each other.  

In general, project engineers should coordinate their work on the same CFC/SFC 
plans. In the event of a conflict at the latest, the project engineers must decide 
among themselves which changes are to be saved. 

Long read and long write operations are better only performed on the ES Server, 
or where the respective project is stored, after consultation with all project 
managers. This prevents conflicts automatically.  

 

 

Access conflicts 
If access conflicts occur outside the CFC/SFC, the operation is rejected (no 
multi-user-compliant message). Simultaneous working in the SIMATIC Manager 
outside the PCS 7 ES is not supported. 

 Conflict behavior 
Further information on how the system reacts to conflicts can be found in the 
function manual "SIMATIC Process Control System PCS 7 CFC for SIMATIC S7 
(V9.0 SP1)" in Chapter 7 "Multi-user Engineering" under the heading "Notes on 
system behavior". 

Here you will find information about: 

• Conflicts when accessing the same resources outside the CFC 

Conflicts when using the test mode 

 

CAUTION Ensure that all work has been completed on the AS program when loading 
the automation system. This guarantees that when compiling, a 
consistently checked S7 program is downloaded to the AS. 

 

CAUTION A selective downloading of charts is possible since PCS 7 V8.1. When 
downloading an edited chart, the depending charts are also downloaded. 
This increases the risk that one of the dependent charts is currently being 
edited by a different project engineer. Coordinate the activity with the other 
project engineers. You will find more detailed information on this topic in 
the function manual "SIMATIC Process Control System PCS 7 CFC for 
SIMATIC S7 (V9.0 SP1)". 

With regard to projects that have been created from the very beginning 
with PCS 7 V8.1, there should be no dependencies. 

 

https://support.industry.siemens.com/cs/ww/en/view/109755021
https://support.industry.siemens.com/cs/ww/en/view/109755021
https://support.industry.siemens.com/cs/ww/en/view/109755021
https://support.industry.siemens.com/cs/ww/en/view/109755021
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Interlocking mechanism 

Each transaction has an ID and is backed up (allocated) using it. This means that 
further write actions are locked in the same place in the database. 

Note In the process object view, the actions for the individual program units are 
allocated line by line. 

 

2.3.2 Process object view 

Description 

Two project engineers can make changes to different objects simultaneously in the 
process object view without interfering with each other. The input field in the 
process object view is a simple field; the change is only saved when you leave the 
field (Return, Tab, arrow keys, and so on).  

Note that the values are not automatically updated when working on the same 
plans. Projector 1 can change a value and Projector 2 can immediately change the 
value again. 

Restrictions 

• Case 1: Obstructions only occur when both project managers have access to 
the same plan. For example, the project engineer on ES1 changes values in 
plan A and the project engineer on ES2 also changes values in plan A. If the 
same field is accessed simultaneously at random, the message "Data can only 
be read" appears. 

• Case 2: Several project engineers add a new comment in chart A. The project 
engineer of ES1 starts the action first. The project engineer of ES2 starts the 
action first. The configurator on ES2 receives the message "The data are 
currently being processed by another application, Application: SIMATIC 
Manager, Computer: ES1, User name: Login name of the project engineer on 
ES1". The data edited on the ES1 is saved The data processed on ES2 is 
discarded. 

 

• Case 3: Editing plans of different ASs on different ASs is possible without 
hindrance if only one project planner processes an AS at a time. 

 

Note If you are working on the same plan simultaneously in the process object view 
and in the CFC editor, data update problems occur. 
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Summary 

Table 2-3 

Action Restrictions 

Editing of different objects of a project on 
different ES. 

None 

Editing of different objects of an AS on 
different ES. 

None 

The same object of an AS is processed at 
different ES. 

Restricted, changes of the other 
configurator only visible after updating the 
view (F5 key) 

 

2.3.3 NetPro 

NetPro is best edited from the central engineering station after creating the multi-
project. This prevents possible inconsistencies and restrictions when compiling 
from NetPro. 

Applications 

• Project-wide configuration in NetPro on ES Server 

• Changes can only be carried out at one station 

Summary 

Table 2-4 

Action Constraint 

Edit NetPro configurations of different 
projects on different ES. 

None 

Edit the same NetPro configuration of a 
project on different ES. 

Restricted. The first person to open the 
NetPro configuration can edit the 
configuration. All other projectors get read 
access. Changes visible after updating the 
view (F5 key). 

 

2.3.4 HW Config 

In principle, it is possible to allow several project engineers to configure and edit 
the hardware components. If a hardware object is opened and changed in HW 
Config, this object is locked against changes by other configuration engineers. 
They can only open the object as write-protected. 

As long as the HW Config changes on the ES1 are not stored, the message 
"Unable to make the changes. Save your changes in other applications" is 
displayed on the ES2 and the actions are locked on the ES2. 

Changes on the ES2 are only possible after the HW Config has been saved on 
ES1. 

Alternatively, the person accessing the HW Config receives the message "The 
station has been changed by another application and will now update" and an 
automatic update follows.  
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Figure 2-7 

 

 

Note We recommend to always change the hardware configuration of an AS on one 
ES. Other ES can be used in parallel, both offline and online, for read-only 
access. If you want to download a configuration, no other ES may have 
established an online connection to the AS. 

 

CAUTION If CiR is enabled, then the work must be conducted in accordance with the 
CiR conditions. (See "SIMATIC Process Control System PCS 7 Engineering 
System (V9.0 SP1)") 

Summary 

Table 2-5 

Action Restrictions 

Edit different HW config of a project on 
different ES. 

None 

Edit the same hardware config on different 
ES. 

Restricted. The first person to open the 
object in HW Config can edit the 
configuration. All other projectors have read 
access. Write access is only possible after 
saving the change.  

Changes can only be done apply after 
updating the view (F5 key). 

 

2.3.5 Icon table 

The following cases may occur during project planning 

• Project engineers on ES1 and project engineers on ES2 want to edit the 
symbol table of AS1 at the same time. 

• Projector on ES1 opens the AS1 symbol table and makes a change. 

• Projector on ES2 also opens the AS1 symbol table and receives the message 
"the symbol table is occupied by another process". 

https://support.industry.siemens.com/cs/ww/en/view/109754984
https://support.industry.siemens.com/cs/ww/en/view/109754984
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Summary 

Table 2-6 

Action Restrictions 

Editing various icon tables of a project on 
several ES. 

None 

Editing the same icon table on several ES. Restricted. The first person to open the 
symbol table has full access. All other 
project engineers gain read-only access. 

Changes are only visible after updating the 
view (F5 key). 

 

2.3.6 Process Device Manager (SIMATIC PDM) 

The following applications can occur with SIMATIC PDM 

• Different field devices from different AS can be processed on several ES. 

• Different field devices from one AS can be processed independently on several 
ES. 

• Working on the same field device on several ES: Under PCS 7 V7.1 (PDM V6) 
this is prevented by SIMATIC PDM. A device can only be opened on one ES.  
As of PCS 7 V8.0 (PDM V8.0) it is possible to open a field device several times 
and to perform online reading functions on the field device. Write operations in 
the field device or in the project are prevented by a message box. This is only 
possible if only one ES opens the field device with PDM. 

• Restrictions apply when inserting or deleting devices, see the chapter entitled 
"HW Config". 

• It is recommended to open existing devices via PDM device view or PDM 
network view to avoid dependencies with HW Config. 

Requirement 

To parameterize a field device with PDM, the necessary device configuration file 
must be installed on each ES in the same way. If the project with configured PDM 
device is loaded on an ES without an installed device configuration file, a message 
indicating the missing software appears when opening the HW Config. The HW 
Config can then only be opened with read access. Changes in the HW Config 
cannot be saved. 
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Parameter assignment 

A specific field device that has been configured with the Process Device Manager 
can only be opened for editing by a project engineer. Other project engineers can 
only open the device configuration as read-only. 

Figure 2-8 PDM V8.0 

 

Recommendation 

If you open the field device via a SIMATIC Manager PDM view instead of via HW 
Config, you avoid restrictions in the HW Config on another ES. 

Summary 

Table 2-7 

Action Restrictions 

Editing various field devices of a project on 
several ES. 

None 

Editing various field devices of an AS on 
several ES. 

None 

Editing the same field device of an AS on 
several ES. 

Restricted as of PCS 7 V8.0 (PDM V8.0). 
As of PDM V8.0, simultaneous read access 
to the same field device is possible from 
several ES. When writing from one ES to a 
field device, only one ES may open the field 
device via PDM. 
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2.3.7 Additional ES components 

For the following objects in the PCS 7 project, the project engineer who was the 
first to make a change can save the change. As long as the change is not saved, 
all other project engineers only get read-only access to the object. This is indicated 
by an appropriate message. 

• Connections 

• Sources (AWL, SCL, KOP, FUP) 

• Blocks 

• Icon table 

Figure 2-9 
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2.3.8 OS project 

Since PCS 7 V8.1 it is possible to open an OS project remotely from all connected 
engineering stations. This functionality must be activated in the SIMATIC Manager 
for the OS projects contained in the multi-project. 

Summary 

Table 2-8 

Access scenario Remarks 

Opening of database-based resources (e.g. 
variable budget) 

The first computer to open the resource has 
full access. The others gain no access or 
read-only. 

Open file-based resources (e.g. process 
images). 

Files that are already open cannot be 
accessed. 

Activating the OS multiuser engineering 

You activate the "OS Multiuser Engineering" functionality in the SIMATIC Manager 
at the engineering station where the multi-project is located (Engineering Server). 
This is done via "Tools > Central OS Settings > OS Multi-User Engineering" 

("Options > Central OS settings > OS Multiuser engineering") 

Figure 2-10 

1

2

 

After the activation of OS Multiuser Engineering in the SIMATIC Manager, the 
checkbox "Multiuser Engineering" in WinCC Explorer is automatically activated in 
the project properties of the Operator Station. 
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Note The checkbox "Multiuser engineering" cannot be activated or deactivated in 
WinCC Explorer. 

Figure 2-11 

 

 

Data consistency 

Data consistency is ensured by marking resources used as reserved in the 
database. This ensures that no data can be changed by two users at the same 
time. 

In the project properties the currently used resources can be displayed via the 
"Resources" button. Reserved resources are marked with user names and host 
names. 

In special circumstances, resources may be marked as reserved even though they 
are not. In this case, the resources can be released manually using the "Enable" 
button. 

 

Note To avoid inconsistencies in the data, make sure that the resources are actually 
no longer being used before manual release. 
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Figure 2-12 

 

Opening the OS project 

To open an OS project on another engineering station, navigate in the SIMATIC 
Manager under "File > Open..." via the network to the Engineering Station where 
the project is stored. Select the storage location and select the project using the 
"Browse..." button. 

Figure 2-13 
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Figure 2-14 

 

Engineering the OS project 

After connecting to the Remote Engineering Station in the SIMATIC Manager, you 
can now open and edit the OS project in WinCC Explorer. 

The system ensures that no resource can be opened by two projectors at the same 
time. 

Depending on the desired resource, the resource can then be opened read-only. 
The project engineer is informed by which user und from which computer the resource 

is already occupied. 

Figure 2-15 
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Plant images can only be opened by a project engineer. If, when attempting to 
open a system image remotely, this image is already opened by another 
engineering station, it cannot be opened. The following message is shown. 

Figure 2-16 

 

 

Note Parallel read-only opening of the image from the Graphics Designer of another 
OS project is possible. 

 

Figure 2-17 

 

Note Always perform OS engineering for an OS project at the same engineering 
station. During the project planning phase, this should be the ES server. 
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2.3.9 Parallel AS and OS engineering 

Application case 

One or more project engineers are busy with AS Engineering, while another project 
engineer updates or completes the process images in the corresponding OS in the 
Graphics Designer. 

In doing so, the OS project planner can access blocks already configured in the 
AS, even if they have not yet been explicitly and completely created using OS 
translation. It uses the so-called "ES variables" in the Graphics Designer variable 
selection. 

Figure 2-18 

 

This means that there are no delays in the project planning due to a pending OS 
translation. This can be done after the AS project planning has been completed. 

 

Note Implicit translation by selecting ES variables is only available for station-specific 
structure and not for project-specific structure. This means that AS and OS must 
be included in different projects. 

Name changes in the TH are not automatically updated when ES variables are 
used. 
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2.3.10 Compiling and downloading objects 

Options 

In PCS 7 you can start the functions for translating and loading from various 
editors. There are differences in the range of functions. The following table gives 
you an overview of the options for translating and loading PCS 7 components: 

Table 2-9 

Editor Function 

HW Config Compiling and downloading the hardware configuration 

NetPro Translation and loading of network and connection planning and 
hardware configurations 

Charts (CFC/SFC) Compiling and downloading the AS program 

SIMATIC 
Manager 

Translate and load individual or all objects of a multi-project via 
selection window 

After the initial total translation and total loading, a change translation is usually 
sufficient. 

Compiling and downloading individual stations 

Basically AS-Translation and -Loading is possible on different ES. For performance 
reasons, we recommend that you perform AS translation and loading on the ES 
that stored the project in question locally - usually the ES server. For better 
performance, remote access to the ES Server is recommended, as described in 
the chapter 3.4. 

The OS change translation should always be performed by the same station, select 
the ES Server during the configuration phase. 

Before each AS translation, stop working on the relevant AS on other ES to avoid 
conflicts. 
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Selection window " Compile and load objects"  

The "Translate and load objects" selection window in the context menu of a 
project/multi-project allows you to translate and load all connections and programs 
project-wide or, if required, multi-project-wide. At the same time, the status / 
operating status of the target stations can also be checked.  

Especially for an OS change loading to be done, you can use it to translate and 
load all changed plans and the associated OS project the changes in one process. 

For large multi-projects, we recommend selecting the "Translate and load objects" 
dialog only for the project in question and not for the entire multi-project. 

 

Note We recommend that you always translate and load all objects from the 
Engineering Server. Talk to the other project managers as well. The multi-project 
or the integrated projects must not be open on all ES, otherwise a conflict will 
occur and the overall translation will be terminated. 

 

Note Always compile and load the OS for an OS project at the same engineering 
station. 
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3 Overriding Topics 

3.1 Central operating station for several PCS 7 systems 

Depending on the installed PCS 7 versions, SIMATIC PCS 7 offers two different 
approaches for operating several PCS 7 systems from a common control room. 
It is assumed that a separate multi-project exists for each plant. 

Cross-multiproject OS clients 

If the PCS 7 versions in the systems are identical, the central control room, for 
example, can be equipped with multi-project OS clients. The following article is 
available for the project planning of these special OS clients: 

"In PCS 7, how do I configure multi-project cross-project access to OS servers 
(multi-client operation) for an OS client?" 

Web server / web client 

If different PCS 7 versions are used in the systems, the control room can be set up 
via a Web Server/Web Client solution. A web server of the appropriate PCS 7 
version is added to each system. The higher-level Web client can connect to all 
Web servers if it is compatible with the most current Web server. 

As an example, a Web Client based on PCS 7 V9.0 SP1 can connect to the 
following stations: 

• Web Server V8.x 

• Without the use of SFC functions 

• Web Server V7.x 

The setting up of PCS 7 web servers and web clients is described in the manual 
"SIMATIC Process Control System PCS 7 Web Option for OS (V9.0 SP1)" 

https://support.industry.siemens.com/cs/ww/en/view/67261722
https://support.industry.siemens.com/cs/ww/en/view/67261722
https://support.industry.siemens.com/cs/ww/en/view/109754978
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3.2 Licensing 

The PCS 7 Engineering licenses are of the "Floating" type (1), i.e. they can be 
used by several ES over a network. They can also be cumulated and are visible in 
the "Number" column of the Automation License Manager. 

All licenses for one operator station are of the "Single" type (2), i.e. they must be 
available on the respective target station. 

Figure 3-1 Function "Connect computer..." in PCS 7 V8.0 environment 

1

2

1

 

Applications 

For larger systems, it is a good idea to set up the ES Server as a central license 
station from which to manage all licenses.  

In the Automation License Manager of the ES Server, add the other ESs using the 
"Connect Computer..." function. ("Connect Computer...". In this way, the required 
"Single" type licenses can then be transferred to the operating stations. 

In Automation License Manager, add the ES Server as an additional computer to 
each ES so that floating licenses can be used for engineering on the other ES over 
the network. 

When engineering several project engineers simultaneously, however, a complete 
license set must be available on the ES server for each ES. 
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3.3 Archiving 

Archive the project status regularly in a defined location. To do this, adjust the 
settings in SIMATIC Manager with regard to archiving to your requirements in 
advance. 

Due to the division into projects, it is sufficient to save only the respective project in 
case of changes within a project, instead of archiving the entire multi-project. This 
is only necessary if cross-project functions have been performed. 

Application cases for the ES server 

• Archiving of the multi-project in intervals to be defined when all work is stopped 
and all projects are available 
(Recommendation: all projects are stored locally.) 

• Archiving a project, e.g. daily, when all work has been stopped or after each 
AS change load. 

Application cases for a decentralized ES 

• Archiving a project stored in the decentralized ES  
This usually only applies to projects with AS. 

General notices 

If you receive a message when archiving projects that objects are still locked. You 
can find out which objects are locked by clicking on "Details". The following objects 
are often the cause of the message: 

• The SIMATIC PDM ASSET service is not in the "Stopped" state. 

– Under Details you will find the entry that "pdmdata.db" or "pdmlock.db" files 
are used by another application. 

– Open the "SIMATIC PDM ASSET Service Manager" tool. 

– Click on "Stop" in the "SIMATIC PDM Asset Service Manager" menu. 

– Restart the archiving process. 

• OS database files are not yet separated from the SQL server. 

– Under Details you will find the entry that "*.ldf" or "*.mdf" files are used by 
another application. 

– Open the corresponding OS project again in WinCC Explorer. 

– Close the project in WinCC Explorer using the menu command 
"File > Close". 

– Close WinCC Explorer. 

– Restart the archiving process. 

You can also find information about locked files in the Windows computer 
management under "Shared folders > Open files > Number of locks column". Here, 
the value should not be greater than "0". 

 

For performance reasons it is recommended not to archive projects/multiprojects of 
the ES Server via network. Instead, you can open a VNC connection to the ES 
Server and use it to start archiving on the ES Server (see also chapter 3.4 Remote 
access to the Engineering Server). 
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Tools 

The PCS 7 Version Trail option allows you to create version statuses of multi-
projects, projects and libraries. Further functions of the Version Trail are automatic 
archiving and automatic readback. 

Reference 

• Project engineering manual "SIMATIC PCS 7 Engineering System" 

• Article "Why is it sometimes impossible to archive a PCS 7 project via the 
SIMATIC Manager or SIMATIC Version Trail?" 

3.4 Remote access to the Engineering Server 

In certain situations - e.g. you are not working on the ES server yourself - it is 
advantageous to start certain actions on the ES server while you are already 
working on another ES. This saves time and network load.  

To connect to the ES Server, RealVNC can be used in PCS 7 V9.0 SP1, for 
example. 

Possible functions 

The following actions can be started remotely on the ES Server, for example, if you 
follow the instructions described in the chapter 2.3 "Working in parallel". 

• AS compiling and downloading 

• Compiling the OS 

• Archiving the project 

For all cross-project functions, e.g. archiving multi-projects, it is generally 
recommended not to work in parallel and to exit all editors in advance. 

Reference 

The installation and parameterization of RealVNC can be found in the article: "How 
do you access WinCC and PCS 7 plants with "RealVNC"?" 

 

https://support.industry.siemens.com/cs/ww/en/view/109754984
https://support.industry.siemens.com/cs/ww/en/view/67598869
https://support.industry.siemens.com/cs/ww/en/view/67598869
https://support.industry.siemens.com/cs/ww/en/view/55422236
https://support.industry.siemens.com/cs/ww/en/view/55422236
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4 Appendix 

4.1 Service and support 

Industry Online Support 

Do you have any questions or need assistance?  

Siemens Industry Online Support offers round the clock access to our entire 
service and support know-how and portfolio. 

The Industry Online Support is the central address for information about our 
products, solutions and services.  

Product information, manuals, downloads, FAQs, application examples and videos 
– all information is accessible with just a few mouse clicks: 
https://support.industry.siemens.com 
 

Technical Support 

The Technical Support of Siemens Industry provides you fast and competent 
support regarding all technical queries with numerous tailor-made offers  
– ranging from basic support to individual support contracts. Please send queries 
to Technical Support via Web form: 
www.siemens.com/industry/supportrequest 
 

SITRAIN – Training for Industry  

We support you with our globally available training courses for industry with 
practical experience, innovative learning methods and a concept that’s tailored to 
the customer’s specific needs. 

For more information on our offered trainings and courses, as well as their 
locations and dates, refer to our web page: 
www.siemens.com/sitrain  
 

Service offer 

Our range of services includes the following:  

• Plant data services 

• Spare parts services 

• Repair services 

• On-site and maintenance services 

• Retrofitting and modernization services 

• Service programs and contracts 

You can find detailed information on our range of services in the service catalog 
web page: 
https://support.industry.siemens.com/cs/sc 
 

Industry Online Support app 

You will receive optimum support wherever you are with the "Siemens Industry 
Online Support" app. The app is available for Apple iOS, Android and Windows 
Phone:  
https://support.industry.siemens.com/cs/ww/en/sc/2067 

https://support.industry.siemens.com/
http://www.siemens.com/industry/supportrequest
http://www.siemens.com/sitrain
https://support.industry.siemens.com/cs/sc
https://support.industry.siemens.com/cs/ww/en/sc/2067
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4.2 Links and literature 

Table 4-1 

No. Topic 

\1\ Siemens Industry Online Support 

https://support.industry.siemens.com 

\2\ Link to the entry page for the Application Example  

https://support.industry.siemens.com/cs/ww/en/view/22258951 

\3\ Manual "SIMATIC Process Control System PCS 7 CFC for SIMATIC S7 (V9.0 
SP1)" 

https://support.industry.siemens.com/cs/ww/en/view/109755021  

\4\ Manual "SIMATIC Process Control System PCS 7 Engineering System (V9.0 SP1)" 

https://support.industry.siemens.com/cs/ww/en/view/109754984  

\5\ SIMATIC Process Control System PCS 7 Compendium Part A - Project Planning 
Guide (V9.0) 

https://support.industry.siemens.com/cs/ww/en/view/109756485  

\6\ Multiproject Engineering with SIMATIC BATCH 

https://support.industry.siemens.com/cs/de/en/view/23785345 

4.3 Change documentation 

Table 4-2 

Version Date Modifications 

V1.0 09/2007 First edition on the PCS 7 V7.0 SP1 DVD 

V2.0 11/2009 Layout adjustment on applications & tools design 

V3.0 11/2011 Multi-user engineering for CFC/SFC extended by additional 
ES/OS components 

V3.1 07/2012 Base PCS 7 V7.1 SP3: Chapter supplemented or extended 

V4.0 07/2013 Basic PCS 7 V8.0 SP1: Revised version 

V5.0 05/2015 Base PCS 7 V8.1: Revised version, chapter supplemented 
or extended 

V6.0 06/2016 Base PCS 7 V8.2: Revised version 

V7.0 07/2018 PCS 7 V9.0 SP1 Revision 

 

https://support.industry.siemens.com/
https://support.industry.siemens.com/cs/ww/en/view/22258951
https://support.industry.siemens.com/cs/ww/en/view/109755021
https://support.industry.siemens.com/cs/ww/en/view/109754984
https://support.industry.siemens.com/cs/ww/en/view/109756485
https://support.industry.siemens.com/cs/de/en/view/23785345
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