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Question

This entry originates from the Service & Support Portal of Siemens AG, Sector
Industry, Industry Automation and Drive Technologies. The conditions of use
specified there apply (www.siemens.com/nutzungsbedingungen).

Go to the following link to download this document.
http://support.automation.siemens.com/WW/view/de/23800567

Caution

The functions and solutions described in this article confine themselves
predominantly to the realization of the automation task. Furthermore, please take
into account that corresponding protective measures have to be taken in the
context of Industrial Security when connecting your equipment to other parts of the
plant, the enterprise network or the internet. Further information can be found in
Entry ID: 150203404!.

http://support.automation.siemens.com/\WW/view/de/50203404

Question

How can you transfer a WinCC flexible project via Ethernet to a Windows-based
panel?

Answer

Follow the instructions and notes listed in this document for a detailed answer to
the above question.

Ethernet Transfer bei WinCC flexible
2 Version V 1.0, Entry ID: 23800567


http://www.siemens.com/nutzungsbedingungen�
http://support.automation.siemens.com/WW/view/de/23800567�
http://support.automation.siemens.com/WW/view/de/50203404�

Contents

Contents
1 INSTFUCHIONS . 4
2 Settings on the Operator Panel...........cccccooviiiiiiiiii e, 5
3 Settings on the Configuration Computer...........ccccceeeiiiiiiiiiiiee e 7
3.1 Settings iNn WINAOWS 7 ......uviiiiiiee ettt e e 7
3.1.1 Non-integrated Project ..........cooociiiiiiiii e 7
3.1.2 Integrated Project...........coo i 9
3.2 Settings in WINAOWS XP .......eeiiiiie e 12
3.2.1 Non-integrated Project ... 12
3.2.2 Integrated Project...........cuooi i 14
3.3 Checking the Ethernet Connection ..........ccccceveiiiiiieiniic e, 17
3.3.1 Check the Connection to the Panel............cccocveviiiiiiiiiee e, 17
3.3.2 Check the Settings on the Operator Panel ..........ccccccoecveviineennen. 18
4 Settings in WIinCC flexible ..........cccoviiiiiiiiii e 20
4.1.1 Non-integrated Project ..........ccooviiiiiiiiei e 20
4.1.2 Integrated Project ... 22

Ethernet Transfer bei WinCC flexible
Version V 1.0, Entry ID: 23800567 3



1 Instructions

1

Notes

Instructions

For transfer of a WinCC flexible configuration via Ethernet you must make settings
on the operator panel and on the configuration PC.

It is not possible to transfer a project to a Micro Panel, because the Micro Panel does
not have an Ethernet interface.

Transfer via Ethernet is possible with an OP270 / TP270. Since these two devices
have no onboard Ethernet interface you need an NE2000-compatible CF card with
Ethernet interface.

Information about which panels support Ethernet transfer is available in the relevant
manual of each operator panel or in the entry entitled "What transfer options are
available in the various operator panels?", Entry ID: 19109408

If you wish to integrate your configuration computer into an existing Ethernet network,

you must transfer the parameters of the existing Ethernet network. Please note that
the IP address of the PC on the Ethernet network must be unique.

In the case of a direct connection without any other active components such as hub,
switch or router you need a crossover patch cable.
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2 Settings on the Operator Panel

2 Settings on the Operator Panel

The illustrations below are from MP 377 and might differ from operator panel to
operator panel, because not all the functions are available for each operator panel.

Table 2-1
No. Action Screen
"w " H H " m\i
1. Open "the Transfer" dialog in the "Control > BB & P = D s 4
Panel". g, Cotcas Do ruPne lerat  Keppoxd  lss ol stk D08
B ® = 9 @ &
Password Printer PROFINET REQ\DM\ S7-Transfer ScreenSaver  System Transfer \/u\ume&
2. Transfer via Ethernet is enabled under Transfer Settings
Channel 2. Select "Ethernet" for Channel 2. ; i
Directaries
For Channel 2 you also set a check mark for
"Enable Channel" and if you wish, "Remote Channel 1:
n
Control". setialivia R5232/PPI Multi-Master Cable
Enable Channel Remote Control
Notes [ He
The "Remote Control" option permits Channel 2:
automatic termination of Runtime on the panel [ETHERNET =]
when transfer is triggered via the development Erable Charnel T9 Remate Cortral
environment of WinCC flexible. The panel HeblE SEnne FHtE SO | Advanced
then automatically switches to Transfer mode.
3. Open the advanced settings by clicking the
"Advanced" button.
4. Double-click the "Ethernet driver". | File Edit View Advanced
o4l
L I
ERTEC400
5. If you do not take the IP address from a P e — [oK]
DHCP server, select "Specify an IP address” 1P Ackress [jame Sarvers | Ethemet Parametes |
and specify the IP address and the subnet
An 1P address can be (O Cbtain an IP address via DHCP
maSk Of the panel. autornatically assigned to this

computer. If your metwark (@ Bperify an 1P address:

does not automatically assign ,
IP addresses, ask your network P e s 150,150,150 20

Note admiristrator for an address, cubnet Mask:
. . and then type it in the space =
The IP address must be unique, in other provided. Defatt Gateweay: [ .|

words, it must not be used by any other node
in the network.

6. Close the dialog box with "OK".
7. Click the "System" icon to open the "System o ? 9= H @
Properties” dialog window. e L
Change the name of the operator panel B ¢ = 9 @ EH 8,
(“HM'_Panel_mp377", for example)_ Password Printer PROFINET gzlt]é;n;s\ 5753;;1;91 ScreenSaver | System Transfer ups
% [System Properties [oK]
WINCC General | Memary | Device Name
e These ngs ae used ta identify your Windows CE device to
Note Q) BTl st e sroon
. . . Device name: [HMI_Panel_mp377
If you are using multiple panels in one Id T |
Ethernet network, you should always change

the name of the panel. Note that the device
name must be unique, in other words, it must
not already be used by another device.
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2 Settings on the Operator Panel

No. Action Screen
Close the dialog box with "OK".
Close the "Control Panel" as well.
10. Select the "Transfer" button in the "Runtime
Loader".
Panel
Ethernet Transfer bei WinCC flexible
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3 Settings on the Configuration Computer

3 Settings on the Configuration Computer

Depending on your operating system you select either "Settings in Windows 7" or "Settings in
Windows XP".

3.1 Settings in Windows 7

The required settings on the configuration computer are described below.

311 Non-integrated Project

Table 3-1

No. Action Screen
1, Open the "Network and Sharing Center" menu e
in the Control Panel of your configuration Q)=+ Cort » AIC. » - 4] Search ControlPane 2]
Computer. File Edit View Tools Help

Adjust your computer's settings View by:  Small icons ~
¥ Action Center £ Administrative Tools
=g AutoPlay W Backup and Restore
B BitLocker Drive Encryption K3 Color Management
[E Credential Manager Date and Time
(@ Default Programs [ Desktop Gadgets i
) Device Manager 3 Devices and Printers 1
B Display (@ Ease of Access Center
§ Folder Options A Fonts
2] Getting Started & HomeGroup
&= Indexing Options €1 Internet Options
@ Keyboard [ Location and Other Sensors
B Mail Bl Memory Card Parameter Assignmen
7 Mouse L2 hetwork and Sharing Center |
B Notification Area lcons & parental Controls
M Performance Information and Tools & personalization
{5 Phone and Modem B Power Options
i Proarams and Features £ Recovery 2

Ethernet Transfer bei WinCC flexible
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3 Settings on the Configuration Computer

No. Action Screen
2. In the "Network and Sharing Center" you click =8 e x|
"Change adapter settings". Double-click the () [ « AIC. » Netwar.. =[] [ Seorch ContralFanel 2]
relevant "Network" and then click the Ele Edi View Toos Help )
"Properties" button to open the Properties Control Panel Home ®-

View your basic network

window of that network. information and set up connections

. See full ma)
Change advanced sharing i’ " p
= g
WIN-43K... Internet
(This co...

View your active netw... -~ Connect to a network |~
You are currently not connected to any netwo...

Change your networking settings

e Set up a new connection or network
™ Set up a wireless, broadband, dial-up,

ad hoc, or VPN connection; or set up
a router o access point. L4

See also 's_ Connect to a network
HomeGroup Connect or reconnect to a wireless,
Itent Options i, di-up, or VPN ntwrk
Windows Firewall
o, Choose homegroup and sharing -
U LAN-Verbindung Status (=
@vaw <« Net| | General
File Edit View To{ | connecton
Organize +  Disal IPv4 Connectivity: No Internet access
IPV6 Connectivity: No Internet access
Ry AN Yerbin Media State: Enabled
R
"’:a;r:,- {:‘;T;;‘s:g Duration: 00:42:09
- 1 Speed: 1.0 Gbps
Activity
sent A Received
ST
Packets: 84 864
| [ propertes || Bpsable | [ Dagnose |
" H "
3. Mark "Internet Protocol Version 4 (TCP/IPv4) J LAN-Verbindung Properties ==
d th lick the "P ies" b
and then click the "Properties" button.
Networking
Connect using:

l_-'l" Intel{R) PRO/1000 MT-Netzwercverbindung

-4 PROFINET 10 RT-Protocol V1.0 -

-4 SIMATIC Industrial Ethemet (150)

-2 PROFINET 10 RT-Protacol {LLDP)
B ]

This connection uses the following items:

W i gtemet Protocal Version & (TCP/|PyE)
M intemet Protocol Version 4 (TCP/IPv4) |1 3
Wapper /0 Driver

1

& Link-Layer Topology Discovery Responder
4| 1 | »

Description

Transmission Cortrol Protocol/Intemet Protocol. The default
wide area network protocol that provides communication
across diverse interconnected networks.

0K | [ Canesl

Ethernet Transfer bei WinCC flexible
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3 Settings on the Configuration Computer

No.

Action

Screen

Assign a valid IP address and subnet mask.

Note

The IP address must be unique. In other
words, it must not be used by another node
(socket) in the network.

(7 sl

Internet Protocol Version 4 (TCP/IPwd] Properties

General

‘fou can get IP settings assigned automatically if your network supports
this capability. Otherwise, you need to ask your network administrator
for the appropriate IP settings.

() Obtain an IP address automatically
@ Use the following IP address:

IP address: 150 . 150 . 150 . 10|
Subnet mask: 255,255 .255. 0
Default gateway:

Obtain DNS server address automatically
(@ Use the following DNS server addresses:
Preferred DNS server:

Alternate DNS server:

[ validate settings upon exit

Close the Properties dialog and all other
dialogs with "OK".

3.1.2

Table 3-2

Integrated Project

No.

Action

Screen

Open the "Set PG/PC Interface" menu in the
Control Panel of your configuration computer.

[E=SEeh =

QQ [E s Cont.. » ANC.. »

File Edit View Tools Help

Adjust your computer’s settings

B Display
& Folder Options
5| Getting Started

&3 Indexing Options

- [ 4 ][ search ©

Viewby: Smallicons =

(@ Fase of Access Center
A Fonts

& HomeGroup

€1 Internet Options

& Keyboard (¥ Location and Other Sensors
B Mail B Memoary Card Parameter Assignmen
¥ Mouse % Network and Sharing Center

2 Notification Area Icons

M Performance Information and Tools

[ Phone and Modem
[ Programs and Features
# Region and Language
% Sound

@ Sync Center

LA Taskbar and Start Menu

& Parental Controls
& personalization
B Power Options

i Recovery

% RemoteApp and Desktop Connections

“% Signal Unit Configuration
& Speech Recagnition
1B System

[ Troubleshooting

ol

m
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3 Settings on the Configuration Computer

No. Action Screen
2. Alternatively you can also open the PG/PC T
interface through the SIMATIC Manager. D= 22| sl Ssore= e AT ]
Tgm_ Text Libraries »
Cisplay Language... WP
Manage Multiingual Texts
Rewire.,
Run-Time Propertiss,..
Compare Blocks,
Reference Data »:
Define Global Data
Configure Network
Simulate Modules
Configure Process Diagnostics
3. If you have an internal Ethernet |_nterface, you St PO/ Intertace =
can select the TCP/IP adapter without CP.
Access Path | LLDP
You can use any NDIS Ethernet card —
. [S?ONLINE (STEP7)  —> TCP/IP > Intel{R) PRO/1000 MT-N.. v]
for transfer via Ethernet.
ERa=r)
Note' Interface Parameter Assignment Used:
- . . . TCP/IP -= Intel(R) PRO/1000 MT-N...
If none of the interfaces listed above is shown, B
. . . <None: =
you can install them manually by clicking the Clcd Db oy Do
"Select..." button in the "Interfaces" [ P/IP > ImelR) PRO/1000 MT-H_| Copy
"Add/Remove:" field. | r/iTuo) > el PRGTTE Delste
4 i} »
(Assigning Parameters to Your NDIS CPs
Click the "Properties" button. wih TCP/IP Protocal (RFC-1006))
Interfaces
Add/Remove: Select
4. Enable "'.:as_t ACk'.'IOW|edge" if you are Properties - TCP/IP -> Intel(R) PRO/1000 MT-N... ==
communicating with an S5 or S7 and are . .
. . TCP/IP network | Details |
operating less than 16 connections
simultaneously. Fast Acknowiedge
. . Fast Acknowledge is meant forthe communication ta
Click the "Network pl‘Opel'tIeS..." button. SIMATIC S7 or S5 only if less than 16 connections are to be
used at the same time.
Connection maonitoring
Timeout: 10sec h
Cocs | Heb
Ethernet Transfer bei WinCC flexible
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3 Settings on the Configuration Computer

No. Action Screen
5. Double-click the relevant "Network" and then |  LAN-Verbindung Status =
click the "Properties" button to open the G )o[# < net| [ Gl |
Properties window of that network. File Edit View Tol | Comection
Organize v Disal IPv4 Connectivity: No Internet access
IPv6 Connectivity: No Internet access
| LAN-Verbin Media State: Enabled
S Ir:‘;l:‘tp';‘s:g Duration: 00:42:09
Speed: 1.0 Gbps
Activity
Sent L‘:E Received
c=d
Packets: 84 864
| [ propertes || Bpsable | [ Dagnose |
" H "
6. Mark Interpet Prolt‘ocol Ve!'3|c|)ln 4 (TCP/IPv4) 1 LAN-Verbindung Properties =
and then click the "Properties" button.
Networking
Connect using:

l_-'l" Intel{R) PRO/1000 MT-Netzwercverbindung

-4 PROFINET 10 RT-Protocol V1.0 -
-4 SIMATIC Industrial Ethemet (150)
-2 PROFINET 10 RT-Protacol {LLDP)

This connection uses the following items:

Wapper /0 Driver
& Link-Layer Topology Discovery Responder
4| 11 | [3

Description

Transmission Cortrol Protocol/Intemet Protocol. The default
wide area network protocol that provides communication
across diverse interconnected networks.

1

0K | [ canesl |
7. Assign a valid |IP address and subnet mask. Internet Protocol Version & (TCP/IPvd) Properties 2=
General
‘fou can get IP settings assigned automatically if your network supports
Note this capability. Otherwise, you need to ask your network administrator
) for the appropriate IP settings.
The IP address must be unique. In other
words, it must not be used by another node © Obtain an 1P address automatically
(SOCket) in the network (@ Use the following IP address:
IP address: 150 . 150 . 150 . 10|
Subnet mask: 255,255,255, 0
Default gateway:
Obtain DNS server address automatically
@ Use the following DNS server addresses:
Preferred DNS server:
Alternate DNS server:
[ validate settings upon exit
8. Close the Properties dialog and all other

dialogs with "OK".

Ethernet Transfer bei WinCC flexible
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3 Settings on the Configuration Computer

3.2

Settings in Windows XP

The required settings on the configuration computer are described below.

3.21 Non-integrated Project
Table 3-3
No. Action Screen

1. Open the "Network Connections" menu in the
Control Panel of your configuration computer.

2. Right-click on the relevant Ethernet network 52
adapter (1) to open the adapter dialog — - 28 |
window. hhor i Spei et
Open the Ethernet adapter's Properties = )
window by clicking the "Properties" (2) button.

I 2

3. Mark "Internet Protocol (TCP/'P)" and click the -i- Local Area Connection Properties |

Propertles button. General | Authentication | Advanced
Connect uzing:
I B8 Broadcom Metxtreme Gigabit Etherne
Thiz connection uzes the fallawing items:
3= FPROFINET 10 RT-Protacal -]
T SIMATIC Industrial Ethernet [150)
(G rtemet Pratocal TCPAIP]
4| | »
Inztall.. | Uhimztall | ( Froperties "
r— Description
Transmizsion Control Protocol/Antermet Protocol. The default
wide area network pratocol that provides communication
across diverse interconnected networks.
[~ Show icon in notification area when connected
v Motify me when thiz connection haz limited or no connectivi
oK Cancel
Ethernet Transfer bei WinCC flexible
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3 Settings on the Configuration Computer

No. Action Screen
4, Assign a valid IP address and subnet mask. Internet Protocol (TCP/IP) Properties 20 x|
General
*Y'ou can get IP settings assigned automatically if pour network. supports
this capability. Otherwize, you need to ask pour network administrator for
Note the apprapriate [P settings.
The IP address must be unique, in other
words, it must not be used by any other node :: E"‘a': "':‘ :|P "'_dd'lep“ ::I‘ma“ca"”
in the network. se the following IP addiess:
IP address: 150 150 150 . 10
Subnet mask: I 285 BB 2R O
Default gateway: I . .
| (btain DMS server address automatically
—{% LUze the following DMS server addressess————————————————————
Preferred DNS server I . .
Alternate DMS server: I . .
Advanced... |
Cavel_|
5. Close the Properties dialog and all other
dialogs with "OK".

Ethernet Transfer bei WinCC flexible
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3 Settings on the Configuration Computer

3.2.2

Table 3-4

Integrated Project

No.

Action

Screen

Open the "Set PG/PC Interface" menu in the
Control Panel of your configuration computer.

¥ Control Panel

Fle Edi Vew Fovortes Took Help
Folders | [Z]+

DBtk - D - (3 | Psearch
address [T Control Panel

3 ; = =1 B '] )
Control Panel B U] e
sccessbiity  Add Hardware Addor Remove Administrative  Appliation  Date and Time
[ Switchto Category View Options Programs Todls Panel
3 i E [+ ] Y
Seelso B = s [l e
Folder Options ~ Forts Game Inkel(R) GMA  Intel(R) Internet
@) Help and Support Controlers ~ Driver for .. Storage ity Options
r h2 2N
= 0 B O e L
Keyboard Mail Memory Card Mouse: Metwork. Phone and
Parameter. Connections  Modem Optiors
. Ch i I 9 (!
= ) 4 =4
Printers and Program Realkek HD  Regionaland Remote Control Run Advertised
Downlo. .. Sound EFf... Language ...
B2 2 ¢
SAP-Korfigur... Scannersand  Scheduled  Security Center | Set PGIPC SIMATIC
Comeras Tasks Interface | Arbeisplate

9 ¥ B9 B R =
‘Sounds and Speech System Systems Taskbar and  User Accounts
‘Audio Devices Management  Start Menu
@ &€ <
< ¢
wWindows ‘Wireless Link Wireless
Firewall Mekwork Set.

Alternatively you can also open the PG/PC
interface through the SIMATIC Manager.

X5l SIMATIC Manager - [Neu - Dz

EPFie Edt Insert PLC View | Options Window Help

Customize.... Cer+al+E

o Fiker > 1%

Display Language... 5]
Manage Multlingual Texts

=2 s o
-

Revire..,
Run-Tiime Properties, ..

Corrpare Blocks,

Reference Data 3
Defirie Global Bzt

Configure Netwark

Simulate Modules
Configure Process Diagnostics

If you have an internal Ethernet interface, you
can select the TCP/IP adapter without CP.

You can use any NDIS Ethernet card
for transfer via Ethernet.

Note:

If none of the interfaces listed above is shown,
you can install them manually by clicking the
"Select..." button in the "Interfaces"
"Add/Remove:" field.

Click the "Properties" button.

Set PG/PC Interface

Access Path |

Access Paint of the Application:
o miein S
uS?DNLINE [STER 7). = TCRAR >
[Standard for STEP 7]

Interface Parameter Azzignment U zed:

|TCRAP -

Froperties... |
Diagnostics... |

Copy... |
[elete |

g PC/PPI cable(PPI)

TCRAP -> 1334 Net Adapter —

TCRAP -» Broadcom Ne%tremeiill
. —

[Azzigning Parameters to Your MDIS CPs
with TCF/IP Protocol (RFC-1008))

Interface:
’7 Add/Remove:

Select... |

Cancel |

Help |

14
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3 Settings on the Configuration Computer

No. Action Screen
" LU
4. Enable "Fast Acknowledge” if you are Properties - TCP/IP -> Intel(R) PRO/1000 MT-N... ===
communicating with an S5 or S7 and are : .
. . TCP/IP network | Details |
operating less than 16 connections
simultaneously. Fast Acknowiedge
o =
. " . " Fast Acknowledge is meant for the communication to
Click the "Network properties..." button. SIMATIC 57 or 55 only if less than 16 connections are to be
used at the same time.
Connection manitoring
Timeout: 10sec -
s | _ber |
5. Right-click on the relevant Ethernet network 3
. Doeck - ) - (¥ | O see
ac_japter (1) to open the adapter dialog (15 S - - p—
window.
ErEe T e e )
Open the Ethernet adapter's Properties
window by clicking the "Properties" (2) button.
2
6. Mark "Internet Protocol (TCP/IP)" and click the 2].x]
n H n
PrOpertleS bUtton' General |Authentication Advanced
Connect using:
I B8 Broadcom Metxtreme Gigabit Etherne
This connection uses the following items:
%~ PROFINET 100 RT-Protocal -
T SIMATIC Industrial Ethernet [I50)
(G rtemet Pratocal (TCPAP]
«| | ¥
Inztall... | Whinstall | |
r— Description
Transmission Contral ProtocolAntemet Protocol. The default
wide area network protocol that provides communication
actoss diverse interconnected networks.
™ Show icon in notification area when connected
[v Motify me when this connection hag limited of no connectiviy
[1]3 Cancel

Ethernet Transfer bei WinCC flexible
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3 Settings on the Configuration Computer

No.

Action

Screen

Assign a valid IP address and subnet mask.

Note

The IP address must be unique, in other
words, it must not be used by any other node
in the network.

Internet Protocol (TCP/IP) Properties

2l

General

Y'ou can get IP settings assigned automatically if pour network. supports
thiz capability. Othenwize, you need to ask pour netwark administratar for
the appropriate [P settings.

" [Obtain an IP address automaticaly
—(* Use the fallowing IP addiess:

IP address: 150 . 150 . 150 . 10
Subnet mask: I 2Bh  ZBR ZBR . O

Default gateway:

e

| [btain DMS server address automatically

—(*  Use the fallowing DMS server addresses:

Preferred DNS server I . .

Advanced... |
Cancel |

Alternate DMS server:

Close the Properties dialog and all other
dialogs with "OK".

16
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3 Settings on the Configuration Computer

3.3 Checking the Ethernet Connection

3.31 Check the Connection to the Panel
Table 3-5
No. Action Screen
1. Enter "CMD" in the Windows 7 dialog field Calculator
"Search programs and files". Click the result e
found Sticky Motes
’ _ Games
k‘—k% Snipping Tool
Computer
."‘(\ Remote Desktop Connection
gt Control Panel
\% Magnifier . .
Devices and Printers
.’_-_i,. Solitaire Default Programs
»  AllPrograms Help and Support
Programs (1)
' See more results
CMD * | Shut down | ¥ |
2. Enter the "ping" command and the IP address
of the panel, "150.150.150.20", for example. R oSV HEUTISREay
Confirm Wlth "Enter" Pinging 158.158.150.28 vith 32 bytes of data:
' henly fron dmadsaea: e v T
You can see the assigned IP addresses in revly from 150115015020 bur s
Table 2.5.
NOte . . IC:\Docunents and Setting: DZVKLBNDesktop>_
If you have already integrated the PLC into
the network, you should also verify this via the
"ping" command.

Ethernet Transfer bei WinCC flexible
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3 Settings on the Configuration Computer

No. Action Screen
3. If the time is exceeded (no reply from node),
then check the following points:
e Check and if necessary, replace the
Ethernet cable (uncrossed patch cable,
when using a hub or switch, for example).
e  Check the IP address and subnet mask
on the panel and on the configuration PC.
e Select and enable the correct Ethernet
adapter.
e  Check the Transfer settings in "Control
Panel > Transfer Settings".
e If necessary, check the firewall settings
on the configuration PC.
4. If the time is not exceeded, the connection
configuration at operating system level is OK
and you can close the Windows command
console.
Table 3-6
IP address Subnet mask Node
150.150.150.10 255.255.255.0 Configuration computer
150.150.150.20 255.255.255.0 HMI operator panel
150.150.150.30 255.255.255.0 SIMATIC station (CPU, for
example)
3.3.2 Check the Settings on the Operator Panel

You can also test the Ethernet connection from the operator panel. Proceed as follows.

Table 3-7

No.

Action

Screen

1.

In Windows CE you open the panel's on-
screen keyboard via "Start > Programs > Soft
keyboard".

Then start the Windows CE command console
via "Start > Programs > Command Prompt".

2. Enter the "ping" command and the IP address -
of the panel, "150.150.150.10", for example.
Confirm with the Enter key.
Note . . "[1]2[s]4]s[6[7[s[o]o]-[=]< [FLL]
If you have already integrated the PLC into —[alwle[r[t]y]uli]o]p[L]] s o 2
the network, you should also verify this via the o [als[dlflalnli[x]o];] ]y J= o oy
"ping"command. ﬁ|\|z|x|c|v|b|n|m|,|.|/|ﬁ esc | nm | A

[ - | E RS
3. If the time is exceeded (no reply from node),

then check the following points:

18
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3 Settings on the Configuration Computer

No. Action Screen

e Check and if necessary, replace the
Ethernet cable (uncrossed patch cable,
when using a hub or switch, for example).

e  Check the IP address and subnet mask
on the panel and on the configuration PC.

e Select and enable the correct Ethernet
adapter.

e  Check the Transfer settings in "Control
Panel > Transfer Settings".

e If necessary, check the firewall settings
on the configuration PC.

4. If the time is not exceeded, the connection

configuration at operating system level is OK
and you can close the Windows CE command
console.

Ethernet Transfer bei WinCC flexible
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4

Settings in WinCC flexible

As an option you can also integrate the WinCC flexible project into a STEP 7 project.

411

Table 4-1

Non-integrated Project

No.

Action

1.

In the project tree structure under
"Communication" you select the
"Connections" tab.

In WinCC flexible you insert a new connection
in the menu under "Insert > New Object -
Connection".

Alternatively you can double-click an empty
field in the table in the "Connections" tab and
create a new connection.

Define the relevant parameters that you have
already specified in the panel and in the
PG/PC interface. For communication via
Ethernet you must change the interface in
WinCC flexible to "Ethernet" or "HMI IE".

Note

Also make sure that the expansion slot and
rack are also correctly specified for SIMATIC
stations and that the access point is correct.

Note

If you do not implement an S7-300/400 CPU
as communications partner, then change the
communication driver.

The following communication drivers that
support the Ethernet protocol are available.

e Modicon MODBUS TCP/IP
e OPC

e  SIMATIC HMI http Protocol
e SIMATIC S7200

e SIMATIC S7 300/400

e SIMOTION
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4 Settings in WinCC flexible

No.

Action

Open the dialog window under "Project >
Transfer > Transfer Settings...". Alternatively
you can also open the transfer settings via the
toolbar (1).

In the "Transfer Settings" dialog you select the
relevant operator panel (2) - only necessary in
the case of multiple operator panels.

Select Ethernet as the Transfer mode (3) and
enter the IP address or the computer
name/operator panel name.

Note

If you specify the device name of a Windows
CE panel, a DNS server is required, because
Windows CE does not directly support the
name resolution. The configuration computer
can also be used as DNS server. More
information is available in the entry entitled >
How do you integrate an HMI operator panel
into a local network?

Note

For the possible transfer options please refer
to the relevant operator panel manual or the
entry entitled >-What transfer options are
available in the various operator panels?

With the "Transfer" button (4) you can now
transfer your configuration to the panel.

Note

If you do not want to transfer yet, you can
save the settings with "Apply". With the first
transfer of the project to an operator panel you
should disable the "Delta transfer" option and
enable the "Overwrite password list" option (if
necessary, also the "Overwrite recipe data
records" option).

Note
After transfer the panel applies the
parameters set in the "Connections" tab.

Ethernet Transfer bei WinCC flexible
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4 Settings in WinCC flexible

41.2 Integrated Project
Table 4-2
No. Action Screen
1. If you have not already inserted the project in

the SIMATIC Manager, you can insert the
project from WinCC flexible into any STEP 7
project with the menu "Project > Integrate in

STEP 7...".
2. For this in the SIMATIC Manager you open
the Hardware Configuration of the S7. Here
you mark the appropriate SIMATIC HMI
Station (1) and double-click "Configuration"
2).
3. Click and mark the fifth slot (1) of the panel. R
DISE-E (R 8| ol il 2 |
=1 (0) Ml S
| i —
Profile: Standard
PROFIBUS DF
s
i e——
W V6.0 SP4
the next avallable addresses are suggested. g azrm:’;ﬁg
{3 User Application
SIMATIC PC Based Control 300/400
B, SIMATIC PC Station
SIMOTION Diive-based
4. Insert the Ethernet module (2) under

"SIMATIC HMI Station > CP Industrial
Ethernet > HMI IE".

5. Double-click the Ethernet module inserted in
the subrack to open the Properties window.
Enter the IP address and subnet mask (3) that
you have already specified in the panel.

6. Link the HMI IE module with the existing
Ethernet network (4).

Note

You can use the "New..." button to add more
subnets. Note here that the HMI station and
associated SIMATIC station must be in the
same subnet. Project transfer via Ethernet
with S7 Routing is not supported.

Close the dialog window with "OK".

Save and compile your configuration via the
"Station > Save and compile..." menu.

Ethernet Transfer bei WinCC flexible
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4 Settings in WinCC flexible

No.

Action

Via the corresponding subnet you select the
station with which the operator panel is to
communicate.

10.

Open the dialog window under "Project >
Transfer > Transfer Settings...". Alternatively
you can also open the transfer settings via the
toolbar (1).

11.

In the "Transfer Settings" dialog you select the
relevant operator panel (2) - only necessary in
the case of multiple operator panels.

12.

Select Ethernet as the Transfer mode (3) and
enter the IP address or the computer
name/operator panel name.

Note

If you specify the device name of a Windows
CE panel, a DNS server is required, because
Windows CE does not directly support the
name resolution. The configuration computer
can also be used as DNS server. More
information is available in the entry entitled
"How do you integrate an HMI operator panel
into a local network?" in Entry ID: 13336639

Note

For the possible transfer options please refer
to the relevant operator panel manual or the
entry entitled "What transfer options are
available in the various operator panels?" in
Entry ID: 19109408.

Ethernet Transfer bei WinCC flexible
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4 Settings in WinCC flexible

No.

Action

Screen

13.

With the "Transfer" button (4) you can now
transfer your configuration to the panel.

Note

If you do not want to transfer yet, you can
save the settings with "Apply". With the first
transfer of the project to an operator panel you
should disable the "Delta transfer" option and
enable the "Overwrite password list" option (if
necessary, also the "Overwrite recipe data
records" option).

Note
After transfer the panel applies the
parameters set in the "Connections" tab.
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