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This entry is from the Siemens Industry Online Support. The general terms of use
(http://www.siemens.com/terms_of_use) apply.

Security
informa-
tion

Siemens provides products and solutions with industrial security functions that
support the secure operation of plants, solutions, machines, equipment and/or
networks. They are important components in a holistic industrial security
concept. With this in mind, Siemens’ products and solutions undergo continuous
development. Siemens recommends strongly that you regularly check for
product updates.

For the secure operation of Siemens products and solutions, it is necessary to
take suitable preventive action (e.g. cell protection concept) and integrate each
component into a holistic, state-of-the-art industrial security concept.  Third-party
products that may be in use should also be considered.  For more information
about industrial security, visit http://www.siemens.com/industrialsecurity.

To stay informed about product updates as they occur, sign up for a product-
specific newsletter. For more information, visit
http://support.automation.siemens.com.
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1 Introduction
This document shows you how to connect a PC station to an S7-1200 using OPC.
Using the SIMATIC NCM PC tool or STEP 7 V5.5 SP3
 You configure a PC station
 You establish an S7 connection between the SIMATIC NET OPC server and

the S7-1200.
You configure the S7-1200 in the TIA Portal.
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2 Configuring the S7-1200 in the TIA Portal
You configure the S7-1200 in the TIA Portal.
Then you create the user program and define which data is to be monitored over
the S7 connection of the OPC server.

2.1 Creating a Project

In Windows, select the menu "Start > All Programs > Siemens Automation > TIA
Portal V12" to start the TIA Portal.
In the Portal view, select the "Create new project" action.
Enter the project name in the appropriate field.
Figure 2-1

Click the "Create" button to create a new project.
Figure 2-2
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Use the "Project View" link to switch to the Project View.
Figure 2-3
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2.2 Configuring the Hardware

Add an S7-1200 Station
In the project tree, double-click the "Add new device" item. The "Add new device"
dialog opens.
Figure 2-4

Click the Controllers button in the working area. Go to "Controllers > SIMATIC S7-
1200 > CPU" and select the required controller. Click the "OK" button to add the
selected S7-1200 CPU to your project.
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Figure 2-5
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Define IP address and assign subnet
In the project tree, double-click the "Devices & networks" item. The devices and
networks editor opens.
Figure 2-6

In the Network View or Device View of the devices and networks editor you click
the PROFINET interface of the S7-1200 CPU.
In the inspector window you switch to the "Properties" tab. Select the "Ethernet
addresses" item in the area navigation.
In this example you enter the IP address 172.16.43.1 and the subnet mask
255.255.0.0 for the PROFINET interface of the S7-1200 CPU.
Then assign a subnet to the PROFINET interface. Click the "Add new subnet"
button to insert a new subnet.
Figure 2-7
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The connection between the subnet, PN/IE_1, for example, and the S7-1200 is
now displayed in the "Network View" of the devices and networks editor.
Figure 2-8

2.3 Creating a User Program

Add a data block
In the project tree, navigate to the device folder of the S7-1200 CPU, "PLC_1 [CPU
1212C …]", for example. The device folder contains structured objects and actions
that belong to the device.
In the device folder you navigate to the "Program blocks" subfolder and double-
click the "Add new block" action. The "Add new block" dialog opens.
Figure 2-9

Click the "DB Data block" button. Enter the name of the data block and enable the
"Automatic" option to assign the number of the data block automatically. If you
enable the "Manual" option, you can assign the number of the data block manually.
Apply the settings with "OK".
The data block DB1 "OPC_DATA" is created in this example.
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Figure 2-10

In the Properties of the data block you go to "Attributes" and disable the "Optimized
block access" option.
Data blocks with standard access have a fixed structure. The data elements in the
declaration include both symbolic names and a fixed address in the block. The
address is displayed in the "Offset" column. You can address the tags in this block
both symbolically and absolutely.
Figure 2-11
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Define static variables in the data block
Define the static variable "static_01" of the "Bool" data type in the DB1
"OPC_DATA".
Figure 2-12

Create Main [OB1]
In the "Program blocks" folder, you double-click the "Main [OB1]" block to open the
corresponding dialog window.
Figure 2-13

Create the program as shown in Figure 2-14. The bit links are in the "Instructions"
task card under "Basic instructions > Bit links".
Use drag-and-drop to add the normally open contact, the flip-flop and the
Assignment to Network 1 of the "Main [OB1]" block.
Assign the variables below to the flip-flop, to the normally open contact at inputs S
and R of the flip-flop and to the assignment at output Q of the flip-flop.



2 Configuring the S7-1200 in the TIA Portal

Connecting a PC Station to an S7-1200 using OPC
Entry-ID: 39960679,    V1.1,    01/2015 12

Si
em

en
s

AG
20

15
Al

lr
ig

ht
s

re
se

rv
ed

Table 2-1

Variable Description

M1.0 SR flip-flop input S: NO contact
M1.1 SR flip-flop input R: NO contact
DB1.DBX0.0 SR variable
M2.0 SR flip-flop output Q: Assignment

Figure 2-14

Note The "%" character before the absolute address is added automatically by TIA
Portal.

Click the "Compile" button.
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2.4 Downloading the Hardware Configuration and User
Program
Follow the instructions below to download the configuration and the user program
into the S7-1200 CPU.

Figure 2-15

No. Action

1. In the project navigation you mark the device folder of the S7-1200 CPU. Click the "Compile"
button in the toolbar. The hardware configuration and the software of the S7-1200 are
compiled.

2. In the project navigation you mark the device folder of the S7-1200 CPU.
Select the menu "Online > Go online".
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No. Action

3. In the project navigation you click the arrow on the left of the device folder of the S7-1200
CPU to display the objects and actions of the device.
Double-click the "Online & diagnostics" item.

4. In the "Online tools" task card you open the "CPU operator panel" palette.
If the S7-1200 CPU is in "RUN" mode, click the "STOP" button to put the S7-1200 CPU into
"STOP" mode.



2 Configuring the S7-1200 in the TIA Portal

Connecting a PC Station to an S7-1200 using OPC
Entry-ID: 39960679,    V1.1,    01/2015 15

Si
em

en
s

AG
20

15
Al

lr
ig

ht
s

re
se

rv
ed

No. Action

5. Disconnect the online connection to the S7-1200 CPU in order to be able to download the
hardware configuration and the software into S7-1200 CPU.

6. In the project navigation you mark the device folder of the S7-1200 CPU. Click the "Download
to device" button in the toolbar. The hardware configuration and the software are downloaded
to the S7-1200 CPU.
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No. Action

7. The "Extended download to device" dialog opens automatically only if the access path from
the PG/PC to the S7-1200 CPU has to be set.
Make the following settings:
 Type of the PG/PC interface: PN/IE
 PG/PC interface: network card of the PG/PC
 Connection to subnet: subnet to which the S7-1200 CPU is connected

From the list of compatible devices you select the S7-1200 CPU and click the "Load" button.
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No. Action

8. In the "Load preview" dialog you click the "Load" button to start the loading procedure.

9. In the "Load results" dialog you click the "Finish" button to finish the loading procedure.
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3 Configuration of the PC Station
Before you start configuring the PC station in NCM PC or STEP 7 V5.5 SP3,
determine or change the IP address of the network card that you are using in your
PC station. You enter the IP address and subnet mask of the network card when
you configure the PC station in NCM PC or STEP 7 V5.5 SP3.

Determine and change the IP address and subnet mask of the network card
In Windows you open the "Network and Sharing Center" and select the "Change
adapter settings" functions. Open the Properties dialog of the network card to
which the S7-1200 is connected.
In this example the network card receives the IP address 172.16.40.11 and subnet
mask 255.255.0.0.

Note The IP address configured for the PC station in NCM PC or in STEP 7 V5.5 SP3
must match the IP address set in Windows. If you are not using a router, the IP
addresses of the PC station and the S7-1200 must be in the same subnet.

Figure 3-1
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3.1 Creating a Project
In Windows, select the menu "Start > All Programs > Siemens Automation >
SIMATIC > SIMATIC Manager" to start the SIMATIC Manager from NCM PC or in
STEP 7 V5.5 SP3.
In the SIMATIC Manager, you create a new project with the menu "File > New".
In the SIMATIC Manager, you add a SIMATIC PC station with the menu "Insert >
Station > SIMATIC PC Station".
Figure 3-2

Change the name of the SIMATIC PC station as required. We use the name
"SIMATIC PC Station" in this example.

3.2 Configuring the Hardware

Double-click the "SIMATIC PC Station" object and then the "Configuration" object.
The "HW Config" dialog open to edit the station configuration.
Figure 3-3

Use drag-and-drop to insert the modules below into the configuration table of the
SIMATIC PC station, which represent the structure of the real PC. The modules are
in the "Hardware Catalog" window under "SIMATIC PC Station".
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Table 3-1

Component Description

IE General Because the SIMATIC PC Station is connected to the S7-1200 by
means of an Industrial Ethernet network card, you insert the "IE
General" module in the configuration table at Slot 1, for example.

OPC server In this example we use the SIMATIC NET OPC server so that an
OPC client can access variables of the S7-1200 through a configured
S7 connection. Insert the "OPC Server" module in the configuration
table at Slot 2, for example.
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3.3 Defining the IP Address and Subnet Mask and
Assigning the Subnet

Configure the IP address of the PC station in the hardware configuration.
In the configuration table you double-click the "IE General" module. The Properties
dialog of the "IE General" module opens. In the "General" tab you click the
"Properties" button. A dialog opens in which you enter the IP address and subnet
mask of the network card and assign a subnet to the network card.

Figure 3-4

In this example you enter the IP address 172.16.40.11 and subnet mask
255.255.0.0 for the network card.
Click the "New" button to insert a new Ethernet subnet and select the newly
created Ethernet subnet.
Click the "OK" button to transfer the IP address and subnet mask and assign the
selected subnet.
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Figure 3-5

Note The IP address configured for the PC station in the hardware configuration of
STEP 7 V5.5 SP3 must match the IP address set in Windows. If you are not
using a router, the IP addresses of the PC station and the S7-1200 CPU must be
in the same subnet.

In the hardware configuration you click the "Save and Compile" button. The
configuration of the PC station is saved and compiled.
Close the hardware configuration.
Figure 3-6
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3.4 Configuring the S7 Connection

Open NetPro
You configure the S7 connection in NetPro.
In the SIMATIC Manager you open NetPro with the menu "Options > Configure
Network".

Figure 3-7
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Configuring the S7 Connection
Mark the OPC server in the PC station.
In NetPro you select the menu "Insert > New Connection". The "Insert New
Connection" dialog opens.

Figure 3-8

Under "Connection Partner" you select the "(Unspecified)" item, because the
connection partner, the S7-1200 CPU, is not configured in the same project as the
PC station.
Select "S7 connection" as the connection type.
Then click the "Apply" button to apply the connection partner and type settings. The
Properties dialog of the unspecified S7 connection opens.
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Figure 3-9

For the PC station to actively establish the unspecified S7 connection you enable
the "Establish an active connection" option for the local connection end point.
You enter the IP address 172.16.43.1 of the S7-1200 CPU for the partner.
Click the "Address Details..." button. The "Address Details" dialog opens.
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Figure 3-10

For the partner you enter the Slot 1 of the S7-1200 CPU. In this way the following
TSAP is set for the partner: 03.01.
Close the "Address Details" dialog box with "OK".
Figure 3-11
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Click the "OK" button to close the Properties dialog of the S7 connection.
Click the "Close" button to close the "Insert New Connection" dialog.

Mark the OPC server in the PC station. The inserted unspecified S7 connection is
now displayed in the connection table.
Figure 3-12

In NetPro, you mark the PC station and click the "Save and compile" button. The
configuration of the PC station including the connection configuration is saved and
compiled.
Figure 3-13
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3.5 Downloading the PC Station Configuration

3.5.1 Installing the Station Configuration Editor

In Windows you select the menu "Start > All Programs > Siemens Automation >
Station Configuration Editor" to open the Station Configuration Editor.

Enter the station name
Click the "Station Name..." button and in the "Station Name" dialog you enter the
same name for the PC station as in the SIMATIC Manager.
The name of the PC station is displayed in the Station Configuration Editor. We use
the name "SIMATIC PC Station" in this example.
Figure 3-14

Insert modules
In the Station Configuration Editor you insert the modules in accordance with the
hardware configuration of the PC station.
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Click the "Add..." button. The "Add Component" dialog opens.
Figure 3-15

Select "IE General" for type and "1" for index to insert the "IE General" module at
Slot 1.
Click "OK" to close the dialog box.
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Figure 3-16

In the Station Configuration Editor you click the "Add..." button once again to insert
another module. The "Add Component" dialog opens.
Select "OPC Server" for type and "2" for index to insert the "OPC Server" module
at Slot 2.
Close the dialog box with "OK".
Figure 3-17

The "IE General" and "OPC Server" modules must be inserted in the same slots in
the Station Configuration Editor as in the hardware configuration of the PC station.
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Figure 3-18

3.5.2 Setting the PG/PC Interface

In the SIMATIC Manager you use the menu "Tools > Set PG/PC Interface..." to
open the "Set PG/PC Interface" dialog.
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Figure 3-19

In the "Access Path" tab you parameterize the network card as the access point
through which the PC station is connected with the S7-1200 CPU and can
exchange data.
Click "OK" to close the dialog.
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Figure 3-20

3.5.3 Downloading the PC Station Configuration

In NetPro, you mark the PC station and click the "Download" button. The
configuration of the PC station including the connection configuration is
downloaded into the Station Configuration Editor.



3 Configuration of the PC Station

Connecting a PC Station to an S7-1200 using OPC
Entry-ID: 39960679,    V1.1,    01/2015 34

Si
em

en
s

AG
20

15
Al

lr
ig

ht
s

re
se

rv
ed

Figure 3-21

Acknowledge the subsequent message with "OK".
Figure 3-22

In the "Run/Stop" and "Conn" columns symbols show whether the "IE General" and
"OPC Server" modules are in "Run" mode and the configured connection is
downloaded.
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Figure 3-23
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4 OPC Scout V10
In this example the OPC Scout V10 is used as the OPC client. Using the OPC
client you can access the data of the S7-1200 CPU over the OPC server.
Start the OPC Scout V10 by means of the Windows menu "Start > All Programs >
Siemens Automation > SIMATIC > SIMATIC NET > OPC Scout V10".

Establish connection to the OPC server
In the Server Explorer you double-click the "OPC.SimaticNET" item to establish a
connection to the OPC server.
Figure 4-1

The configured S7 connection named "S7_Connection_1" is displayed in the
Server Explorer under OPC.SimaticNET in the "\S7" folder.
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Figure 4-2

Create OPC items
Add the items below to the DA view.

Table 4-1

OPC item Description

S7:[S7_Connection_1]MX1.0 By means of the OPC item you monitor and control
the marker bit M1.0 in the S7-1200 CPU.

S7:[S7_Connection_1]MX1.1 By means of the OPC item you monitor and control
the marker bit M1.1 in the S7-1200 CPU.

S7:[S7_Connection_1]MX2.0 By means of the OPC item you monitor the marker
bit M2.0 in the S7-1200 CPU.

S7:[S7_Connection_1]DB1, X0.0 By means of the OPC item you monitor Bit 0.0 of the
DB1 data block in the S7-1200 CPU.

Figure 4-3

Monitor OPC items
Click the "Monitoring ON" button to monitor the values of the OPC items. The
values of the OPC items are displayed in the "Value" column.
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Figure 4-4

Write values
In the "New value" column you enter the value that you want to write to the
S7-1200 CPU.
Enter the values below in the "New value" column (see Table 4-2).
Click the "Write" button. The marker bit M2.0 and Bit 0 in DB1 are given the value
"True".
The results of the write procedure are displayed in the "Value" column.
Table 4-2

OPC item Value

S7:[S7_Connection_1]MX1.0 True
S7:[S7_Connection_1]MX1.1 False

Figure 4-5

Enter the values below in the "New value" column (see Table 4-3).
Click the "Write" button. The marker bit M2.0 and Bit 0 in DB1 are reset to the
value "False".
The results of the write procedure are displayed in the "Value" column.
Table 4-3

OPC item Value

S7:[S7 connection_1]MX1.0 False
S7:[S7 connection_1]MX1.1 True

Figure 4-6
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