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Legal information

Warning notice system

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are
graded according to the degree of danger.

A\DANGER
indicates that death or severe personal injury will result if proper precautions are not taken.

A WARNING
indicates that death or severe personal injury may result if proper precautions are not taken.

A\CAUTION
with a safety alert symbol, indicates that minor personal injury can result if proper precautions are not taken.

CAUTION
without a safety alert symbol, indicates that property damage can result if proper precautions are not taken.

NOTICE

indicates that an unintended result or situation can occur if the corresponding information is not taken into
account.

If more than one degree of danger is present, the warning notice representing the highest degree of danger will
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to
property damage.

Qualified Personnel

The product/system described in this documentation may be operated only by personnel qualified for the specific
task in accordance with the relevant documentation for the specific task, in particular its warning notices and
safety instructions. Qualified personnel are those who, based on their training and experience, are capable of
identifying risks and avoiding potential hazards when working with these products/systems.

Proper use of Siemens products

Trademarks

Note the following:

A WARNING

Siemens products may only be used for the applications described in the catalog and in the relevant technical
documentation. If products and components from other manufacturers are used, these must be recommended
or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and
maintenance are required to ensure that the products operate safely and without any problems. The permissible
ambient conditions must be adhered to. The information in the relevant documentation must be observed.

All names identified by ® are registered trademarks of the Siemens AG. The remaining trademarks in this
publication may be trademarks whose use by third parties for their own purposes could violate the rights of the
owner.

Disclaimer of Liability

We have reviewed the contents of this publication to ensure consistency with the hardware and software
described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the
information in this publication is reviewed regularly and any necessary corrections are included in subsequent
editions.
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Preface

Purpose

This manual provides a complete overview of programming with STEP 7. It is designed to support
you when installing and commissioning the software. It explains how to proceed when creating
programs and describes the components of user programs.

The manual is intended for people who are involved in carrying out control tasks using STEP 7 and
SIMATIC S7 automation systems.

We recommend that you familiarize yourself with the examples in the manual "Working with
STEP 7 V5.5, Getting Started." These examples provide an easy introduction to the topic
"Programming with STEP 7".

Basic Knowledge Required
In order to understand this manual, general knowledge of automation technology is required.

In addition, you must be familiar with using computers or PC-similar tools (for example,
programming devices) with the MS Windows XP, MS Windows Server 2003 or MS Windows 7
operating system.

Scope of the Manual
This manual is valid for release 5.5 of the STEP 7 programming software package.
You can find the latest information on the service packs:
e inthe "readme.rtf" file
e inthe updated STEP 7 online help.

The topic "What's new?" in the online help offers an excellent introduction and overview of the
newest STEP 7 innovations.

Programming with STEP 7
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STEP 7 Documentation Packages

This manual is part of the documentation package "STEP 7 Basic Information®.

The following table displays an overview of the STEP 7 documentation:

Documentation

Purpose

Order Number

STEP 7 Basic Information with

Working with STEP 7,
Getting Started Manual

Programming with STEP 7

Configuring Hardware and
Communication Connections,
STEP 7

From S5 to S7, Converter Manual

Basic information for technical
personnel describing the methods of
implementing control tasks with
STEP 7 and the S7-300/400
programmable controllers.

6ES7810-4CA10-8BWO

STEP 7 Reference with

Ladder Logic (LAD) / Function Block
Diagram (FDB) / Statement List (STL) for
S7-300/400 manuals

Standard and System Function
for S7-300/400
Volume 1 and Volume 2

Provides reference information and
describes the programming
languages LAD, FBD and STL, and
standard and system function
extending the scope of the

STEP 7 basic information.

6ES7810-4CA10-8BW1

Online Helps

Purpose

Order Number

Help on STEP 7

Basic information on programming
and configuring hardware with
STEP 7 in the form of an online
help.

Part of the STEP 7
Standard software.

Reference helps on AWL/KOP/FUP
Reference help on SFBs/SFCs
Reference help on Organization Blocks

Context-sensitive reference
information.

Part of the STEP 7
Standard software.

Programming with STEP 7
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Online Help
The manual is complemented by an online help which is integrated in the software.
This online help is intended to provide you with detailed support when using the software.
The help system is integrated in the software via a number of interfaces:

e There are several menu commands which you can select in the Help menu:
The Contents command opens the index for the Help on STEP 7.

e Using Help provides detailed instructions on using the online help.

e The context-sensitive help offers information on the current context, for example, an open
dialog box or an active window. You can open the contextsensitive help by clicking the "Help"
button or by pressing F1.

e The status bar offers another form of context-sensitive help. It displays a short explanation for
each menu command when the mouse pointer is positioned on the menu command.

o A brief explanation is also displayed for each icon in the toolbar when the mouse pointer is
positioned on the icon for a short time.

If you prefer to read the information from the online help in printed format, you can print out
individual help topics, books, or the entire online help.

This manual, as well as the manuals "Configuring Hardware and Communication Connections
STEP 7", "Modifiying the System During Operation via CiR" and "Automation System S7-400H -
Fault-Tolerant Systems" is an extract from the HTML-based Help on STEP 7. For detailed
procedures please refer to the STEP 7 help. As the manuals and the online help share an almost
identical structure, it is easy to switch between the manuals and the online help.

You can find the electronic manuals after installing STEP 7 via the Windows Start menu: Start >
SIMATIC > Documentation.

Programming with STEP 7
Manual, 05/2010, A5E02789666-01 7
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Further Support

If you have any technical questions, please get in touch with your Siemens representative or
responsible agent.

You will find your contact person at:
http://www.siemens.com/automation/partner

You will find a guide to the technical documentation offered for the individual SIMATIC Products
and Systems at:

http://www.siemens.com/simatic-tech-doku-portal
The online catalog and order system is found under:

http://mall.automation.siemens.com/

Training Centers

Siemens offers a number of training courses to familiarize you with the SIMATIC S7 automation
system. Please contact your regional training center or our central training center in D 90026
Nuremberg, Germany for details:

Internet:  http://www.sitrain.com

Programming with STEP 7
8 Manual, 05/2010, A5E02789666-01
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Technical Support
You can reach the Technical Support for all Industry Automation and Drive Technology products

Via the Web formula for the Support Request
http://www.siemens.com/automation/support-request

Additional information about our Technical Support can be found on the Internet pages
http://www.siemens.com/automation/service

Service & Support on the Internet
In addition to our documentation, we offer our Know-how online on the internet at:

http://www.siemens.com/automation/service&support

where you will find the following:

The newsletter, which constantly provides you with up-to-date information on your products.
The right documents via our Search function in Service & Support.

A forum, where users and experts from all over the world exchange their experiences.

Your local representative for Industry Automation and Drive Technology.

Information on field service, repairs, spare parts and consulting.

Programming with STEP 7
Manual, 05/2010, A5E02789666-01 9



Preface

Programming with STEP 7
10 Manual, 05/2010, ASE02789666-01



Contents

1 Introducing the Product and Installing the SOftWare...........cciiiiiii e 23
1.1 OVEIVIEW OF STEP 7.t e e et e e e e e e s e e anbraae e e as 23
1.2 The STEP 7 Standard PaCKage.........ccuua ittt a e 28
1.3 What's New in STEP 7, VEIrSION 5.57 ....eeiiiiiiiii ettt 33
1.4 Extended Uses of the STEP 7 Standard Package ...........ccccvveeiieiiie it 35
1.4.1 =g T [ =T=T g Ta o TR 0T ] F PSSRt 37
142 RUN-TIME SOMWAIE ...ttt s e e nnneenes 39
143 Human Maching INtErfACE...........cuiiiiiie e 41

2 Ta I = 11 E= 1A o] o T PO TR OP RSP PR PPRP PPN 43
2.1 AUtOMALION LICENSE MENAGET ... .eeeiieiitiiiee ittt ettt ettt e e st e e e s stbe e e e s sibe e e e s sabneeeeaas 43
211 User Rights Through The Automation License Manager ...........coocuveeeeiiieeeiniieee e 43
21.2 Installing the Automation LICENSE MaNAJET ..........ueiiiiiiiiieiiiiie ettt nereee e 46
2.13 Guidelines for Handling LICENSE KEYS .......uuiiiiiieiiiiiiiiiee et e e 47
2.2 INSTAING STEP 7 ..ottt et et a et e s bb e e st e e e sabe e e be e e sabe e e abbeesnbeesnnes 48
221 INSTAIALION PrOCEAUIE .....eiiiiiiee ettt et e s e e e e s sarn e enees 50
2.2.2 Setting the PG/PC INTEITACE ......uvviiiiei et e s e e e e e e e e e rnraeeeaaa e 53
2.3 UNINSEAIING STEP 7 ..ottt e e e e e e st e e e e e e e s s e b e e e e e e s e s satbeeeeeeeesnnnnes 55
2.4 L0 LYo g = {0 ) PR UPRURR 55
2.4.1 User Rights in MS Windows XP/Server 2003..........coeieeiiiiiiiiiiieeeeeeessiirieeseeessssnnsnneeeseesseannns 55
2.4.2 User RightS iN MS WINAOWS 7 .....coooiiiieiiee ettt s s e e e e e s e s sae e e e e e e s s snnananeeaeeeenannns 56

3 Working Out the AUtOMAatioN CONCEPT....eiiie it e e e e e e e s e e e e e e s e e snnreeeeeeeeennnne 59
3.1 Basic Procedure for Planning an Automation Project............ccccceovuiiiiiiiiieie i 59
3.2 Dividing the Process into TASKS ANnd AlEAS .........cicuuiiiiiiiiiiie ittt 60
3.3 Describing the Individual FUNCLIONAl AFEAS ..........uuiiiiiiiiiiiiiiiiee e 62
3.4 Listing Inputs, OUPULS, aNd INJOULS .........ccoiiuiiiiiiiiiiie et 64
3.5 Creating an 1/0 Diagram for the MOTOIS...........cuuiiiiiiiiieii e 65
3.6 Creating an 1/0 Diagram for the VaIVES...........ccuviiiiiiiii e 66
3.7 Establishing the Safety REQUIFEMENTS..........ooi it 67
3.8 Describing the Required Operator Displays and CONtrolS............coouiiiiiiiiieiiniiiiieeeee e 68
3.9 Creating a Configuration DIGgram .........cccuveeiieee i e e s r e e e e s e e e e e e e s s nannreareaaee s 69

4 Basics of DeSigNing @ Program SITUCTUIE .....cciciiiiiciiiiiee e et e e e ettt e e e e e e s s stntae e e e e e e e s sennnnrneeaeeaean 71
4.1 Programs iN @ CPU ...ttt e e e e st e e e e e e e e s et e e e e e e s e s snsenneeeeeeannrne 71
4.2 BIOCKS IN the USEI PrOGIaM .....coiiiiiiiiiiiiiiee ettt ettt e e sbb e e s snbe e e e s nabnee e 72
421 Organization Blocks and Program STTUCLUIE ..........ccueiiiiiiiieeiiiie e 73
422 Call Hierarchy in the USEr PrOgram ........cuueiiiiiiiieeiiiiee ettt 80
4.2.3 =] [oTod QN Y/ o 1= PP UPUP R TUPPTPPRN 82
4231 Organization Block for Cyclic Program Processing (OB1) ..........cciuiiriiiiiiiiieeieeeeeeiiiieeeeeeens 82
4.2.3.2 FUNCHONS (FC) .iiitiiieite ettt ettt et e e e e ek bbbt e e e e e e e s nbbbe e e e e e e e e sanbbbeeeeaaannnnes 88
4.2.3.3 T To Lo T 2] (o Ted S (ol = T EERRRRS 90
4234 INSLANCE DALA BIOCKS ...ttt e e nn e 93
4.2.3.5 Shared Data BIOCKS (DB)......cccuuiiiiiiieeeiiiiiieee e e e e e s se sttt e e e e e e s s st e e e e e e e s s snssaearaeeeessnnnnnnenneeaees 96
4.2.3.6 System Function Blocks (SFB) and System FuNctions (SFC) ........coovvviciiiiiiieee e iiiiiieeeeeeen 97

Programming with STEP 7
Manual, 05/2010, A5E02789666-01 11



Contents

12

4.2.4 Organization Blocks for Interrupt-Driven Program Processing..........cccccceeeeiiiiiiiiieieieeeneiiis 99
4241 Time-of-Day Interrupt Organization Blocks (OB10 t0 OBL7).....cccoiiuiiiiiiiiieiiiiiiiiiiieeee e 100
4.2.4.2 Time-Delay Interrupt Organization Blocks (OB20 t0 OB23) ........cccoccviiiieeeee e e, 102
4.2.4.3 Cyclic Interrupt Organization Blocks (OB30 t0 OB38).........cceeeeiiiiiiiiiiieiee e cciinieeeee e e e 103
4.2.4.4 Hardware Interrupt Organization Blocks (OB40 t0 OBA47).......ccccvveeeeeeeeeiiiiniieeee e e e e e seeiinveens 105
4.2.4.5 Startup Organization Blocks (OB100 / OB101 / OBL102) ......cccoviicviiiieieeeeeiiiiiineee e e e e e s 106
4.2.4.6 Background Organization BIOCK (OB90).........cuiiiieiiiiiiiiiiieee e e e e e 108
4.2.4.7 Error Handling Organization Blocks (OB70 to OB87 / OB121 to OB122) ........ccccccevvevvvvnnnnn 110
ST La (0T o= g o I @] oX=T =1 4 o] o [ PO RP R ROPPPPOTPIY 113
5.1 SEAMING STEP 7 .oeeeii ettt ettt e et e s sttt e e et e e e e st e e e s s bt e e e e ansbeeeeasraeeesraeeeen, 113
5.2 Starting STEP 7 with Default Start Parameters ... 114
5.3 Calling the Help FUNCHONS .......oooiiiiieii ettt e e e e e e e 117
5.4 Objects and Object HIErarChy ........ ... e 118
54.1 [ (0] [Tt A @ o] = ox F TP PPPPPPPPROTRIY 119
5.4.2 [T o] = 1V © ] ] [T o U PURRPRY 121
5.4.3 ) = i[04 1O =T o PR PPRRY 122
5.4.4 Programmable Module ODJECT ..........ciiiii i e e e e e 124
5.4.5 STIMT Program ODJECL ......uuuiiiie it e e e e s e e e e e e s s nrn e eeeeeeeennn ] 126
5.4.6 (21 oTod 1 o] [0 [T g @ o] = ox (PSRRI 128
547 Source File FOIder ODJECT ......ccoiuuiiiiiiiiiie e e e 131
5.4.8 S7/M7 Program without @ Station OF CPU ..........c.ooiiiiiiiiiiiiieciee e 132
5.5 User Interface and OPEIatiON..........cocuueiiiiiiiiieiiiiie et e e e 133
5.5.1 Operating PhIlOSOPNY .........u e a e eee e e e e e ean] 133
5.5.2 WINAOW AFTANGEIMENT ....oiiiiiiiiiiieie ettt ettt e e e e e e s e b e b et et e e e e e s s abnbeeeeaaaeeeaannnbneeeans) 134
5.5.3 Elements in DIalog BOXES ......coiuiuiiiiiiaee ettt ettt e e e e e e e e e e e e e s ennraeea 135
5.5.4 Creating and Managing ODjJECLS ........uuiiiiiiiiiiie e e e e 136
5.5.5 Selecting Objects iN @ DIalog BOX.......uueiiieeiiiiiiiiiiiiee e e cciiiee e e e e s e ssierae e e e e e e e e ssannaeeeeaeeeeenand 142
5.5.6 SESSION MEMIOIY .eeiiieeii ittt e e e e e e e e e e e s et e e e e e e e s se st e be e e e eeeessaaaeabaeeeeaeessaasnsrnaeeeaeessane] 143
5.5.7 Changing the WINdOW ArrangemeENt..........ccieicuriiiiieeeeieiiiiiieee e e e e s s sssvseeeree e e s s snnssnnneeeeeeessnnn] 143
5.5.8 Saving and Restoring the Window Arrangement..............uvveiveeeeiiiciiiiieeee e s sciieieeee e e e e 144
5.6 ()Y oo =T (o @ o =T -1 1o o PSRRI 145
56.1 KeYDOAIA CONIIOL.......eiiiiiiiiii ettt et e e e e snenneeene ] 145
5.6.2 Key Combinations for Menu COmMMANGS ..........cuueiiiiiiiiieiiiiiee et 145
5.6.3 Key Combinations for Moving the CUISOF ...........ueiiiiiiiiiiiii et 147
5.6.4 Key Combinations for SEleCting TeXE.........uuueiiiiiii e 149
5.6.5 Key Combinations for Access to ONliNg Help ... 149
5.6.6 Key Combinations for Toggling between WINAOWS ...t 150
Setting Up and Editing the ProjeCt ...ttt a e 153
6.1 [ (o1t S {0 (o (1 (U PURRPRY 153
6.2 What You Should Know About ACCESS ProteCtON.........uueviiiiiiiie it 155
6.3 What You Should Know About The Change LOg........cuuieeiiiiiiiiiieiieee et e e seeee e 158
6.4 Using Foreign-Language Character SEtS ........uuuiieeiiiiiiiiiiiiie st e e e e e ssrnreeen e e e e e e 159
6.5 Setting the MS WINAOWS LANQUAGE.........cooiiuuiiieiiiiiie ittt sttt e e sneee e 162
6.6 SettiNG UP @ PIOJECT.....eiiiiiiieiie ettt ettt e e et e e e be e 163
6.6.1 CreatiNg 8 PrOJECT ...ttt s et e st e s e et e e e b 163
6.6.2 INSEIING STALIONS ....eieiiiiie ittt e e e e et b e et e e e s e e anbbae e e e e e e e e e snnbnneeeeesnd 165
6.6.3 INSErtiNg @n S7/M7 PrOQIaM .. ...u ittt e ettt e e e e e e e s s aanbbe e e e e e e e e e annbnneeeend 166
6.7 o110 o J= T o (0] (=T o! SR PP UOPPPUPPPPPRY 168
6.7.1 Checking Projects for Software Packages USed ...........cceevveveiiiiiiiiieiiee e 169
6.7.2 Managing MUItIlINQUAI TEXES .........uuiiiieieeiiiiiieieee e s e e e e st e e e e e e s s re e e e e e e e e senrnnead 169
6.7.2.1 Types of MURIINQUAT TEXES ..vviiiiiiiiiieiie e e e e e e e e e s s e e e e e e e e e ean ] 172
6.7.2.2 Structure of the EXPOrt FIle ..o e e e e e e e 173

Programming with STEP 7
Manual, 05/2010, A5E02789666-01



Conftents

6.7.2.3 INformation 0N the LOQ File .....cooo et 175
6.7.2.4 Managing User Texts Whose Language Font is Not Installed .............ccooiiiiiiiiiiiiiennenen, 176
6.7.2.5 Optimizing the Source for TranSIation ... e 177
6.7.2.6 Optimizing the Translation PrOCESS ........ccuuiiiiii e e e e e ae e e 178
6.7.2.7 Hiding Texts in Selected LanQUAgES ........uueiieeeeiiiiiiiieieeee ettt esirree e e e e e s santaaeeeee e 179
6.7.3 Micro Memory Card (MMC) as @ Data Carrier...........uuvveeeieiiiieiieeeeee e seiiieeee e e e e s s ssnnnneeeeeee s 180
6.7.3.1 What You Should Know About Micro Memory Cards (MMC)........ccccuvveeeeeeeeiiiiiieieeeee e 180
6.7.3.2 Using a Micro Memory Card as a Data Carrier ..........cuveeiiiiiiiiiieeiee e ccsiieees e e e s sssinvneeeeeee s 182
6.7.3.3 MEMOIY Card FlE .....ooiiiiiieiieee et e e e e 182
6.7.3.4 Storing Project Data on a Micro Memory Card (MMC)........coocovieiiiiiieiiiieeeeiee e 183
7 Editing Projects with Different Versions 0f STEP 7.t e e en e 185
7.1 Editing Version 2 Projects and LIDraries. ... 185
7.2 Expanding DP Slaves That Were Created with Previous Versions of STEP 7 .................... 185
7.3 Editing Current Configurations with Previous Versions of STEP 7 ........cccccccceiiiiiiiiiiiinneaenn, 187
7.4 Appending SIMATIC PC Configurations of Previous VErsions ..........cccccccevvveveiiciieeesiineennns 188
7.5 Displaying Modules Configured with Later STEP 7 Versions or Optional Packages........... 190
8 DefiNiNg SYMDOIS ...t e e et e e ekt e e e st e e e s abr e e e s anbe e e e e nnnns 193
8.1 Absolute and Symbolic AAAreSSIiNg ......cceeeeeiiiiiiiiiiiie e e e e e e 193
8.2 Shared and LOCal SYMDOIS.........uuiiiiiii e e e e e 195
8.3 Displaying Shared or Local SYMDOIS .........ccooiiiiiiii e 196
8.4 Setting the Address Priority (Symbolic/ADSOIULE) ........ccoouiiiiiiiii e, 197
8.5 Symbol Table for Shared SYMDOIS .........c.ooiiiiii e 200
8.5.1 Structure and Components of the Symbol Table............ccccooiiiii 200
8.5.2 Addresses and Data Types Permitted in the Symbol Table............cccoiiiiiiis 203
8.5.3 Incomplete and Non-Unique Symbols in the Symbol Table ... 204
8.6 Entering Shared SYMDBOIS ..........oooiii e 205
8.6.1 General Tips on ENtering SYMDBOIS .........uuiiiiiii e arrrer e 205
8.6.2 Entering Single Shared Symbols in @ Dialog BOX........ccceeiiiiiiiiiieiieee e iciiiieeeee e eeiivieeee e 206
8.6.3 Entering Multiple Shared Symbols in the Symbol Table..........cccccccoviiiii e, 207
8.6.4 Using Upper and Lower Case for SYmbols ..........ccvvveiiiiiiiiiicece e 208
8.6.5 Exporting and Importing Symbol TableS.........coooiiiiiiiie e 210
8.6.6 File Formats for Importing/Exporting a Symbol Table ... 211
8.6.7 Editing Areas in SYyMbDOl TabIES ........ooi i 214
9 Creating BIOCKS @nd LiDIaries ...ttt et e e e 215
9.1 Selecting an Editing MethOQ .........oooi i 215
9.2 Selecting the Programming LANQUAGE .........ccueieiiiiiiiiiiiiaa e aiieieee e et e e e e e s siibeeeeeaa s 216
9.2.1 Ladder Logic Programming Language (LAD) .........uuuiiiii it 218
9.2.2 Function Block Diagram Programming Language (FBD) .......cccccceeeiiiiiiiiiiiiee e 219
9.2.3 Statement List Programming Language (STL) ...coccciiieieiee e et e e e e e snnranne e e 220
9.24 S7 SCL Programming LANQUAGE .........cccuuuiieeieeeeeeiiitiieeeeeeesssnssianeeeeeeessssnsseseeseeessesnnnssneseeees 221
9.2.5 S7-GRAPH Programming Language (Sequential Control).........ccccceeviviiiiiiieeeeeesiiciiiieeeeens 222
9.2.6 S7 HiGraph Programming Language (State Graph) ..........ccccvveeiieeeeiiiiiiieieee e ceieieeeee s 223
9.2.7 S7 CFC Programming LANGQUATE ........coouueeeiiiiieeeiiiiee ettt e e ssiteeeesstreeessnneeesssbeeessnnneeeeennens 224
9.3 CreatiNg BIOCKS ...ttt ettt s e s 225
9.3.1 2 o Tod L o] [ USROS 225
9.3.2 User-Defined Data TYPES (UDT) .ottt e e e e e e s e naneeaeeeaaas 226
9.3.3 2] ToTod 1 0] o 1= 1 1= T PP PUPPP RPN 227
9.34 Displaying BIOCK LENGLNS.........eiiiiiiiiiee ettt e e e e be e e e e e 230
9.3.5 (070] 131 o F= 1T o 1 53 1o Tox 1< P PRPRPP 231
9.3.6 Y1 1 o PP ORPRRR 234
9.3.7 Attributes for BIOCKS and Parameters ..........c.uuiiiiiiiiieiiiiiie et 234

Programming with STEP 7
Manual, 05/2010, A5E02789666-01 13



Contents

10

14

9.4 WOrKiNG WIth LIDFAr@S.....cooieeeeeiee ettt e e e e e e ee e e e e 235
9.4.1 Hierarchical Structure of LIDIraries. ..o 237
9.4.2 Overview of the Standard LIDraries. ..., 237
Basics of Creating LOQIC BIOCKS ......uuiiiiiiiiiiee ettt e e e e e et e e e e e s nnne ] 239
10.1.1 Structure of the Program Editor WINAOW ...........ceoiiiiiiiiiiiiiieeee et e e e e 239
10.1.2 Basic Procedure for Creating LOgIC BIOCKS .......cciceiiiiiiiiiiiiiee et 241
10.1.3 Default Settings for the LAD/STL/FBD Program EditOr...........cccccvviiieeee i 242
10.1.4 Access Rights to BIOCKS and SOUICE FilES .......cooicuiiiiiiiiee e 242
10.1.5 Instructions from the Program Elements Table ... 243
10.2 Editing the Variable DeClaration.............cooueeiiiiiiiiiiiie e 244
10.2.1 Using the Variable Declaration in LOGIC BIOCKS ...........eiiiiiiiiiiiiiiiiciiieee e 244
10.2.2 Interaction Between The Variable Detail View And The Instruction LiSt .............ccccuveeeeeeenn. 245
10.2.3 Structure of the Variable Declaration Window ..............oociiiiiiiiiiiiiiiee e 246
10.3 Multiple Instances in the Variable Declaration.................coiiiiiiiiiieee e 247
10.3.1 USING MURIPIE INSTANCES ....ooei it e e e e e e e e s st e e e e e e e e s snnnrrenesd 247
10.3.2 Rules for Declaring Multiple INStANCES ...........eeeviieiiiiiiiiieece e e 248
10.3.3 Entering a Multiple Instance in the Variable Declaration Window .............ccccovvveveeeiinicinnnend 248
10.4 General Notes on Entering Statements and COMMENLS ........ccoovvvvieiereeeeeiiieiieee e e e e e 249
104.1 Structure of the COdE SECLION........coiiiiiiiii i s sabee s 249
10.4.2 Procedure for ENtering STatemMENTS .........ocuueiiiiiiiiieiiiie ettt 250
10.4.3 Entering Shared SymboIS in @ Program ... 251
10.4.4 Title and Comments for BIOCKS and NEtWOIKS........ccooeiiiiiiiiiiiieie e 251
10.4.5 Entering Block Comments and Network COMMENTS. ........ccuiiiiiiiiiiiiieiee e eeiieieee e e 253
10.4.6 Working with Network TEMPIALES .......c.cuviiiiiieeeee e 253
10.4.7 Search Function for Errors in the Code Section ...........c..uueeiiiiiiiiiiiiii e 254
10.5 Editing LAD Elements in the Code SECHON .......ccceoiiiiiiiiiiieiie ettt e e e e e 255
10.5.1 Settings for Ladder LogiC Programming ........cc.ueeeeeeeiiiiiiiieeeeeeeesssiiineeeee e e e s ssinnreeeeeeeessnnsnnnnd 255
10.5.2 Rules for Entering Ladder LOGQIC EIEMENLS .......ccoeeiiiiiiiiiiieiee ettt e e e 256
10.5.3 lllegal Logic Operations in LAAUEN ...........cuiiiieiiiiiiiiiiiee e e e e e e nnaeee e e e e, 258
10.6 Editing FBD Elements in the Code SECHON .........ccoiiiiiiiiiiiie e 259
10.6.1 Settings for Function Block Diagram Programming.........cccccceeeeeviiiciieieeeeeesessiieneeee e e e e e 259
10.6.2 Rules for Entering FBD EIEMENTS ........cooiiiiiiiiiiiii ettt 260
10.7 Editing STL Statements in the Code SECHON...........ocuiiiiiiiiiii e 262
10.7.1 Settings for Statement LiSt Programming ...........cc.eeeeiieeeeiiieee e e e esseeeees) 262
10.7.2 Rules for Entering STL STAtEMENTS ......ooiiiiiiiiiiie e e e 262
10.8 Updating BIOCK CallS........ooiiiiiiiie ettt e e e e e e nbnaeeeend 263
10.8.1 Changing INTEITACES ... ..t e e e e e e e e e e 264
10.9 SaVING LOGIC BIOCKS .......uiiiiiiiiie ettt e e e e e e e e e e e e e s s nrnre e e e e e e e e ennad 265

Programming with STEP 7
Manual, 05/2010, A5E02789666-01



Conftents

11 Creating Data BIOCKS .......coiiiiiiiiiiiii ittt ettt et e e sabb e e e sabb e e e snbe e e e s nnneeend 267
111 Basic Information on Creating Data BIOCKS .............uuiiiiiiiiiiiii e 267
11.2 Declaration View of Data BIOCKS. .........icuiiiiiiiiiie it e s snnee e 268
11.3 Data View Of Data BIOCKS .........coiiiiiiiiiiiiiie ettt e e 269
114 Editing and Saving Data BIOCKS..........cc.uuuiiiiie et e e e e e e e e 270
11.4.1 Entering the Data Structure of Shared Data BIOCKS ............ccccvvieieiiiiiiiecec e 270
11.4.2 Entering and Displaying the Data Structure of Data Blocks Referencing an FB (Instance

]2 PO PRSP 271
11.4.3 Entering the Data Structure of User-Defined Data Types (UDT) .....coovvviiereiniiineeiniieeeeenes 273
1144 Entering and Displaying the Structure of Data Blocks Referencing a UDT...........ccccceeeennnee, 274
1145 Editing Data Values in the Data VIEW ..........oocuuiiiiiiiiie ettt 275
11.4.6 Resetting Data Values to their Initial ValuESs .............ooiiiiiiiiiiii e 275
11.4.7 SAVING DAta BIOCKS .......eeiiiiiiiiie ittt e e e e e e r e e e e e e s e nnnreeend 276

12 Parameter Assignment for Data BIOCKS ........coiiiiiiiiiiiiice ettt 277
12.1 Assigning Parameters to Technological FUNCLIONS...........cccceeeieiiiiiiiiiiccce e 278

13 Creating STL SOUICE FIlES ... ettt e e e e e s e st et e e e e e e e e e sannbeeeaaeeeaaannnes 279
13.1 Basic Information on Programming in STL Source Files.........cccccceeviiiiiiiieeeee e 279
13.2 Rules for Programming in STL SOUICE FIlES ......ccuuviiiiiiee e eee e 280
13.2.1 Rules for Entering Statements in STL SOUrce FileS ..........ooccvviieiiii i 280
13.2.2 Rules for Declaring Variables in STL SOUrce FileS........ccuviiiiiiiiiiiiie e 281
13.2.3 Rules for Block Order in STL SOUICE FileS.......coiiiiiiiiieee e 282
13.24 Rules for Setting System Attributes in STL Source Files .......cccccoveeiiiiiiiiiiiiie e, 282
13.2.5 Rules for Setting Block Properties in STL Source Files ..., 283
13.2.6 Permitted Block Properties for Each BIOCK TYPE ......ueeiiiiiiiiiiiiiiiieiee e 285
13.3 Structure of BIOCKS IN STL SOUICE FlES ......ceiiiiiiiiiiiiiee e 286
13.3.1 Structure of Logic Blocks in STL S0OUrce FileS ........uviiviiiiiiiiiiiiieee e 286
13.3.2 Structure of Data Blocks in STL SOUICE FIlES .......ccuvviiiiiiiieiciie e 287
13.3.3 Structure of User-Defined Data Types in STL Source FileS.......ccccccovviiiiviiiiieee i 287
13.4 Syntax and Formats for BIOCkS in STL SOUICe Fil€S .......ccooviviiiiieiie e 288
13.4.1 Format Table of Organization BIOCKS ...........ccueiiiiiiiiiiiic e 288
13.4.2 Format Table of FUNCHION BIOCKS ........coiuiiiiiiiiiiie et 289
13.4.3 Format Table Of FUNCHONS ........coiii e e e e e e 290
13.4.4 Format Table of Data BIOCKS .........coiiiiiiiiiiiiee e a e 291
135 Creating STL SOUICE FilES.........uiii i) 292
1351 Creating STL SOUICE FlES..... .. it e e e e e e s e aaneeeend 292
13.5.2 Editing S7 SOUICE FIlES . ...ttt e e ea e e e 292
13.5.3 Setting The Layout of SOUICe COE TEXL......cuiiiiiiiiiiiiii et ebeeee e 293
1354 Inserting Block Templates in STL SOUICE Fil€S........ccciiiiiiiiiieiie e 293
1355 Inserting the Contents of Other STL Source Files..........cccuviiiiieiiiiiiiieeee e 293
13.5.6 Inserting Source Code from Existing Blocks in STL Source FileS.......cccceeeviiiciviiieeeeeeiiiinnns 294
13.5.7 Inserting EXternal SOUICE FIlES..........uuuiiiiii i e e e e e e e e 294
13.5.8 Generating STL Source Files from BIOCKS...........occuiiiiiiiei e 295
13.5.9 IMPOItING SOUICE FIlES ..ottt sbre e 295
13.5.10 EXPOrting SOUICE FIlES.....oiiiiiiiiieiiie ettt s e 295
13.6 Saving and Compiling STL Source Files and Executing a Consistency Check.................... 296
13.6.1 SaVING STL SOUICE FlES ... a e aeeaa s 296
13.6.2 Checking Consistency in STL SOUICE FIlES.......ooouuiiiiiiiieiiieieee et 296
13.6.3 Debugging STL SOUICE FlES .....eeiiiiiiiiiieiit ettt e e e e e e eeaeeeand 296
13.6.4 ComPpiliNg STL SOUICE FilES ....uuiiiiiiee et e e e e e e s e e e e e e s e sanrraaeeeeens 297
13.7 Examples Of STL SOUICE FilES .....ccoio ittt e e e e e raeee e e e 298
13.7.1 Examples of Declaring Variables in STL Source Files .........cccocveeiiiiiiiiiieeccce e 298

Programming with STEP 7
Manual, 05/2010, A5E02789666-01 15



Contents

14

15

16

16

13.7.2 Example of Organization Blocks in STL Source Files ... 299
13.7.3 Example of FUNCIONS IN STL SOUICE FlES......coiiiiiiiiieii e 301
13.7.4 Example of Function BIOCKS in STL SOUICE FilES .......ccuvvieiieeiiiiiiiiieece et 304
13.7.5 Example of Data Blocks in STL SOUICe FileS .........ccccuiiiiiiiii e 307
13.7.6 Example of User-Defined Data Types in STL Source Files........ccoccceeeeiiiiiiiiieieeee e 308
Displaying REFEIENCE DAt .....ccicciiiiiiiiiieiie ettt e e e e e e s e e st r e e e e e e s s st e teeeeaeeeesantnteeaeeesesnnnnd 309
141 Overview of the Available Reference Data.........cccoeeviiieieiiiiii e, 309
141.1 CroSS-RETEIENCE LISt ...ueiiiiiiiiiiiiiiie ettt st e e e a e e e e ntee e, 311
14.1.2 Program STTUCTUIE........uieiiiii e e e e e e e s s e e e e e e e s sennreneed 312
14.1.3 ASSIGNMIENT LIST. ..ttt ettt ettt e e st e e e s sab bt e e s snbb e e e e snbneeeesrneed 314
14.1.4 UNUSEA SYMDOIS ...t e e snnnee e 316
14.1.5 Addresses Without SYMDOIS ... 317
14.1.6 Displaying Block Information for LAD, FBD, and STL .......ccoooiiiiiiiiiiiiiaiiieeeee e 317
14.2 Working With REfErenCe DAta .........cooiiiiiiiiiiie e e e e e 318
14.2.1 Ways of Displaying Reference Data...........ceeviieiiiiiiiiiiiicee et a e sanraaee e 318
14.2.2 Displaying Lists in Additional Working WIiNAOWS .............cceeeeiiiiiiiiiiieece e e e 318
14.2.3 Generating and Displaying Reference Data ...........ccoooiciiiiiieeeciiiciiiieeeee e e e 319
14.2.4 Finding Address Locations in the Program QUICKIY .........ccoeeiiiiiiiiiiiiieeo e e 320
14.2.5 Example of Working with Address LOCAtIONS...........ccccuvviiiieeeeeiiiiieer e e e s e e e e 321
Checking Block Consistency and Time Stamps as a Block Property ........cccocvvvveee e, 325
151 Checking BIOCK CONSISIEINCY........utiiiiiiiieiiiiie ettt sttt e e nbee e e 325
15.2 Time Stamps as a Block Property and Time Stamp ConfliCtS .........coooviiiiiiiieiiiniieeeiieen 327
15.3 Time Stamps iN LOGIC BIOCKS.......cooiiiiiiieii et a e 328
154 Time Stamps in Shared Data BIOCKS .........cooiiiiiiiiieie e 329
155 Time Stamps in Instance Data BIOCKS .............cooiiiiiiiii e 329
15.6 Time Stamps in UDTs and Data Blocks Derived from UDTS ......ccccvevviiiieeeiiiieeesiiieee e 330
15.7 Correcting the Interfaces in a Function, Function Block, or UDT ........c.cccooviiiiiiiieeennnniiinnnnd 330
15.8 Avoiding Errors when Calling BIOCKS ..........uoiiiii i 331
CONTIGUITNG IMESSAGES ..vveiiiiiiiiiie ittt e ittt e sttt e e s st e e e st e e e s stae e e s abbe e e s ansbe e e e e sbeeeessbbeeeeanbbeeesnsbeaeeanteeaen) 333
16.1 BN R A= TSIST Vo L= @ (o =T o | SRR UPPPSSR 333
16.1.1 What Are the Different Messaging Methods? ..., 333
16.1.2 Choosing a Messaging Method ............coooiiiiiiiiii e 335
16.1.3 SIMATIC COMPONENTS ....ctiieiiieee ettt e et e e e s et e e e e s s s s ssnrrereeeaeesnansnnn ] 337
16.1.4 PartS Of @ MESSAGE .....ciiiiiiiii ettt sttt 338
16.1.5 Which Message Blocks Are Available? ...........ooo e 339
16.1.6 Formal Parameters, System Attributes, and Message BIOCKS ... 341
16.1.7 MeSSAgE TYPE QNG MESSAGES ... uuueeeieeeeeiiiiiiteiee e e e e e e ettt et e e e e e e s aaasbbeeeeaaa e e s s asnbaeeeeaaeeseaannsenned 342
16.1.8 How to Generate an STL Source File from Message-Type BIOCKS..........cccocveeveeeiiiiiciinnnnns. 344
16.1.9 ASSIgNING MESSAJE NUIMDEIS ...uviiiiiii et e e e e s e e e e e e s e s e e e e e e e e s e s nanreneeeeend 344
16.1.10 Differences Between Project-Oriented and CPU-Oriented Assignment

Of MESSAQGE NUMDEIS ... e s e e e e e s s ner e e e e e e e e e enn ] 345
16.1.11 Options for Modifying the Message Number Assignment of a Project..........ccccceveeevivinennnend 346
16.2 Project-Oriented Message Configuration..............cooiviiioiiieiie e 347
16.2.1 How to Assign Project-Oriented Message NUMDETS ........c.oviiiiiiieiiiiiie e 347
16.2.2 Assigning and Editing Block-Related MeSSages ..........cocuviiiiiiiiiiiiiiieiicee e 347
16.2.2.1 How to Create Block-Related Messages (Project-Oriented) ..........cceeeiiiiiiiieieeeeeeenenniienend 348
16.2.2.2 How to Edit Block-Related Messages (Project-Oriented)..........ccuueeeiieariiiiiiiiiieiee e 350
16.2.2.3 How to Configure PCS 7 Messages (Project-Oriented) ..........ooocuviieieiiiiiiniiiiieeeee e 351
16.2.3 Assigning and Editing Symbol-Related MESSAQES .......c.ccoviiiiiiiiiiiieeee it 352
16.2.3.1 How to Assign and Edit Symbol-Related Messages (Project-Oriented)........ccccceeeeviiivinnnns, 352
16.2.4 Creating and Editing User-Defined DiagnostiC MESSAQES...........ccccuvriiieieeeeiiiiiiirneeeeee e e e el 353

Programming with STEP 7
Manual, 05/2010, A5E02789666-01



Conftents

16.3 CPU-Oriented Message CoNfIQUIALION .........couiiiiiiiiiiieia e e e 354
16.3.1 How to Assign CPU-Oriented Message NUMDEIS.........ooiiiiiiiiiiiieaie e 354
16.3.2 Assigning and Editing Block-Related MESSAQES ........ccooviviiiiiiiieeieiiiiieeee e e e 355
16.3.2.1 How to Create Block-Related Messages (CPU-Oriented)........cccceeeviiiiiiiieeeee e cccciiieeeeeennd 355
16.3.2.2 How to Edit Block-Related Messages (CPU-Oriented) .........cccccveveeeeiiiiiiiieeieee e ccciiineee e 358
16.3.2.3 How to Configure PCS 7 Messages (CPU-Oriented) .........ccuvuivereeeiiicciiiieeeee e seviveeeeeeee s 358
16.3.3 Assigning and Editing Symbol-Related MeSSages........cccuvvvevieeeiiiiciiiiiieece e 360
16.3.3.1 How to Assign and Edit Symbol-Related Messages (CPU-Oriented) ........ccccceevvvvcvvvieeneeennn, 360
16.3.4 Creating and Editing User-Defined Diagnostic MESSAJES ........cccovvueiiiiiiiieeiniiee e, 361
16.4 TIPS fOr EQItING MESSAUES ...ceeiiuiiieieiiiiie ettt ettt ettt ettt ettt e et e e e e st e e e s sbaeeeesnnreeeeea 362
16.4.1 Adding Associated Values t0 MESSAGES ........cieiiiiiiiiiiiiiieiiiee ettt 362
16.4.2 Integrating Texts from Text Libraries into MeSSAgEs. .........uuiiiiiiiiiiiiiiiiiieiee e 365
16.4.3 Deleting ASSOCIAtEd VAIUES .......ccooiiiiiiiiiiii et a e ee e e e 365
16.5 Translating and Editing Operator Related TeXtS ........c.uuuiiiiiiiiiiiiiiiieiiee e 366
16.5.1 Translating and Editing USEr TEXES.......ccciiiiiiiiiiiee e iiciiiee e e e sssnre e e e e e s ssnaraeee e e e e e s s snnnneees 366
16.6 Translating and Editing Text LIBraries ... 368
16.6.1 USEI TEXE LIDFAIES. ..ccc ittt st e s st e e s snbne e e e snneeas 368
16.6.2 Creating User TeXt LIDIariES .......uuuiiie ettt e e st e e e e e e en e e e e e e s e naneneeed 368
16.6.3 How to Edit USer TeXt LIDIAriES .......ueiiiiiiiieiieee ettt 369
16.6.4 SYStEM TEXE LIDFAIES ... 369
16.6.5 Translating TeXt LIDIaries ... 370
16.7 Transferring Message Configuration Data to the Programmable Controller ........................ 372
16.7.1 Transferring Configuration Data to the Programmable Controller.............cccoeeieiinnniinnen, 372
16.8 Displaying CPU Messages and User-Defined Diagnostic MESSages ........cccceevvvivuiieeeeanenn, 373
16.8.1 ConfIUIING CPU MESSAUES ....euveeeiiiaieiiiiiiietet e e e e ettt ee e e e e e s sabebe et e e e e e s aanbabaeeaaaaseaannrsaeeeaans 376
16.8.2 Displaying Stored CPU MESSAJES. ......ccuuuuiriieeeeeiiiitiiereeeeeesiitsiaeeeesesssssssstessesassssassnsssssseseens 376
16.9 Configuring the 'Reporting of SYStEM EITOIS' .........cvviiiiiie e 377
16.9.1 Overview oOf 'RepPOIt SYSIEM EITOr ... e e e s e s arraaeeeee s 377
16.9.2 Configuring the 'Reporting of SYStEM EITOrS' .........vviiiiiiee e e e e e 377
16.9.3 Supported Components and FUNCLIONAl SCOPE........uuuiiiiieiiiiiiieiii e 379
16.9.4 Settings for "RePOrt SYStEM EFTOr ..........vviiiiie e e e e e e s e e e e e e s snrrnee e e e 383
16.9.5 Generating Blocks for Reporting SyStem ErrOrsS.........ccooviiiiiiiiiiee e 385
16.9.6 GENEIALEU EITON OBS....iiiiiiieiiiiiiieeie e sttt e e e e s e te e e e e e s s e ae et e e e e e e s snnsntbeeeeaaeeesannsnreeeend 386
16.9.7 LCT=T =T = 11 To [ = 0T 2P SRRP SRR 388
16.9.8 Assignment of System Errors t0 ErfOr CIASSES .....cviiiiiiiiiiiiiieiie et 390
16.9.9 Generating Foreign-Language Message Texts in 'Report System Error'...........occcuvveeeeeenn, 392
17  Controlling and Monitoring Variables ...........eei ittt 395
17.1 Configuring Variables for Operator Control and MoONItoring ...........ccccoevvvvieeeeeeeeiiiiiiieeeeeeens 395
17.2 Configuring Operator Control and Monitoring Attributes with Statement List,
Ladder Logic, and Function BIOCK Diagram..........ccc.uueiieeeriiiiiiiieieeee e cssieeee e e e e e s s snsvnneneeeens 397
17.3 Configuring Operator Control and Monitoring Attributes via the Symbol Table ................... 398
17.4 Changing Operator Control and Monitoring Attributes with CFC ...........ccocceveviiiiiiiiieeee, 399
17.5 Transferring Configuration Data to the Operator Interface Programmable Controller ......... 400

Programming with STEP 7
Manual, 05/2010, A5E02789666-01 17



Contents

18

19

20

18

Establishing an Online Connection and Making CPU SettingsS .......c.coveiiiiieiiiiiieiniieee i 401
18.1 Establishing Online CONNECHONS ........coiiiiiiiiiiie et 401
18.1.1 Establishing an Online Connection via the "Accessible Nodes" Window................ccccvvvvee.. 401
18.1.2 Establishing an Online Connection via the Online Window of the Project .................c...... 402
18.1.3 Online Access to PLCS in @ MUIIPIOJECT.......ccuvviiiiiie e e e e e 403
18.1.4 Password Protection for Access to Programmable Controllers..........ccccoveccvvviveeeeeeeviccininnnn, 405
18.1.5 Updating the WINAOW CONEENTS ......coiiiieeiiiiiiiiieeee e et e e e e e e s sibeee e s e e e e s ssnnrenee e e e e e s ennnnend 407
18.2 Displaying and Changing the Operating MOde..............uuvivieeiiiiiciieece e 408
18.3 Displaying and Setting the Time and DAt ...........ccoiiiiiieiiiiiie e 409
18.3.1 CPU Clocks with Time Zone Setting and Summer/Winter TiMe ........cccccovvveeeiniieeenniieeeen, 409
18.4 Updating the FIMMWAIE........coiiiiiiii ettt e e snnnee e 411
18.4.1 Updating Firmware in Modules and Submodules Online ... 411
Downloading and UPIO@AING .......ueeiiiiiiiiii ettt sttt s e e e e s e e snsnee e e e 415
19.1 Downloading from the PG/PC to the Programmable Controller ..............cccoeieiiieiinniinnnnd 415
19.1.1 Requirements for DOWNIOAAING. .........ccoiiiiiiiiiiiee e e e e e e e e e e s s annraees 415
19.1.2 Differences Between Saving and Downloading BIOCKS ............ccccuvieiiiieiiiiiciiiieece e 417
19.1.3 Load Memory and Work Memory in the CPU ... 418
19.1.4 Download Methods Dependent on the Load MemOIY ..........ccooiviiviiieeiee i e e 420
19.1.5 Updating Firmware in Modules and Submodules Online ...........ccccccceveee i 421
19.1.6 Downloading a Program t0 the S7 CPU ........cooiiiiiii e 424
19.1.6.1 Downloading with Project Management ...........cuuiiiiiiiieiiiiiie et 424
19.1.6.2 Downloading without Project Management ...........cooueiiiiiieie it 424
19.1.6.3 Reloading Blocks in the Programmable Controller ... 424
19.1.6.4 Saving Downloaded Blocks on Integrated EPROM..........ccoooiiiiiiiiiieee e 425
19.1.6.5 Downloading via EPROM MeMOrY CardsS........ccuueuiiiiiiiiiiaeaeee ettt a e eieiieee e e e senneeeead 426
19.2 Compiling and Downloading Several Objects fromthe PG..........cccccceeeiiiiiiiiieeee e 427
19.2.1 Requirements for and Notes on DOwWNIOading ..........ccccuviiieiieecii e e 427
19.2.2 Compiling and Downloading ODJECES..........ccccuiiiiiie e e e e 429
19.3 Uploading from the Programmable Controller to the PG/PC.........ccccceeiiviiciiieeieee e 431
19.3.1 10T 0] o= To [T T = ] = L1 o] o TSSO 433
19.3.2 Uploading BIOCKS from @n S7 CPU .......cooi it s e seeee e e e e e 434
19.3.3 Editing Uploaded BIOCKS iN the PG/PC........coooiiiiiiiiiie et ] 434
19.3.3.1 Editing Uploaded Blocks if the User Program is on the PG/PC...........ccccooiiiieiiiiiiieinieeeen, 435
19.3.3.2 Editing Uploaded Blocks if the User Program is Not on the PG/PC............ccccoeiiiiiniiinennnd 435
19.4 Deleting on the Programmable CONtroller ... 436
19.4.1 Erasing the Load/Work Memory and Resetting the CPU ... 436
19.4.2 Deleting S7 Blocks on the Programmable Controller ... 437
195 Compressing the User Memory (RAM)......coo i sree e e e e s e ae e e e e e e e 438
19.5.1 Gaps in the User MemOry (RAM)......uciiii ittt e e e s st e e e e e e s saaaba e e e e e e e e s ennnneed 438
19.5.2 Compressing the Memory Contents of an S7 CPU ..........cccveiiiiiiiiieiene e 439
Testing With the Variable Table......... e e e e s sareraeeead 441
20.1 Introduction to Testing with Variable Tables...........cccocveeiiiicc e, 441
20.2 Basic Procedure when Monitoring and Modifying with the Variable Table..............ccccc.... 442
20.3 Editing and Saving Variable Tables..........c..ooi i 443
20.3.1 Creating and Opening a Variable Table ... 443
20.3.11 How to Create and Open a Variable Table ... 444
20.3.2 Copying/Moving Variable TabIes ..........ooi e 445
20.3.3 Saving a Variable TabIle ... 445
20.4 Entering Variables in Variable Table ... 446
20.4.1 Inserting Addresses or Symbols in a Variable Table...........cccovieiiieiiiiiiie e, 446
20.4.2 Inserting a Contiguous Address Range in a Variable Table............ccccoiviiiieeiiiiiiiiieeeeeeen, 449

Programming with STEP 7
Manual, 05/2010, A5E02789666-01



Conftents

20.4.3 INSErting MOIfY VAIUES .......coiiiiiiieee et e e e e e e e e e e e snneed 449
20.4.4 Upper Limits for ENtEriNg TIMEIS ..ottt e e e e e e annaeeeeeae s 450
20.4.5 Upper Limits for ENEriNg COUNLETS .........uuiiiieieiiiiiiiiieie e e e e e secitireee e e e e e s s ssisnreae e e e e e e s e snnnnaeeeeeens 451
20.4.6 INSErtiNg COMMENT LINES ....uviiiiii e i it ee et e e e e e e e e e e s e st r e e e e e e s e s nnnrnraeeeeeeesannns 451
20.4.7 =0 ] o] 1= SRS 452
20.4.7.1 Example of Entering Addresses in Variable Tables ... 452
20.4.7.2 Example of Entering a Contiguous AddreSS RANGE .........coccuvviieiiieeee et e e e seneeeeeee s 453
20.4.7.3 Examples of Entering Modify and FOrce Values...........cccoovviiiiiiiiei et 454
20.5 Establishing @ Connection t0 the CPU..........occiiiiiiiii e 456
20.6 MONItONNG VAIADIES ...t 457
20.6.1 Introduction to Monitoring Variables ..........ooueiiiiiiiiii e 457
20.6.2 Defining the Trigger for Monitoring Variables ... 457
20.7 MOdIfyING VariabIEs. ..o e 459
20.7.1 Introduction to Modifying VariabIes............oou i 459
20.7.2 Defining the Trigger for Modifying Variables ............cccccoiiiiiiiiii e 460
20.8 o (ol To I £= T4 =1 o] =TSSP 462
20.8.1 Safety Measures When Forcing Variables ... sereee a1 462
20.8.2 Introduction to FOrcing Variables ...........coueeiiiiiiiiiiee e e e e e 463
20.8.3 Differences Between Forcing and Modifying Variables..........cccccceeiiiiiiiiiieii e 465
21 Testing USING Program StAtUS ........coiccviiiiiiei s ie e e e s s e e e e e e s s s st ee e e s e e e s s e snnnaeaeeeeeeeessnnnteneeaeeeanns 467
211 Program Status DISPIAY .........ueeiiiiiiiiieiiiiie ettt 468
21.2 What You Should Know About Testing in Single-Step Mode/Breakpoints...........ccccccevuveees, 470
21.3 What You Should Know About the HOLD MOAE .........oooiiiiiiiiiieee e 472
21.4 Program Status of Data BIOCKS...........uuuiiiiiiee e e e 473
21.4.1 Setting the Display for Program STAtUS..........coouoiiiiiiiieiieaee e e e eiiieeeeee e 474
22 Testing using the Simulation Program (Optional Package) .........cccuuiiiiiiiiiiiiiiii e 475
22.1 Testing using the Simulation Program S7 PLCSIM (Optional Package).........cccccccoevvuvvnneee. 475
2 T B - To | ¢ o 1S3 £ [od= PR UOPPPPPRPPT 477
23.1 Hardware Diagnostics and TroubleShooting............uueviieiiiiiiiiiiiiiiee e 477
23.2 Diagnostics Symbols in the ONlINE VIEW ........ccoiiiiiiiiiiicc e 479
23.3 Diagnosing Hardware: QUICK VIEW ..........uuiiiiiiiiiiiiiiie e e e e e sanvaaen e e e 481
23.3.1 Calling the QUICK VIBW ........iiiiiiiiie ittt sttt st b e e s eebe e e e 481
23.3.2 Information Functions in the QUICK VIEW ...........uueiiiiie i 481
23.4 Diagnosing Hardware: DIagnNOStIC VIEW ........uueiiiiiiiiieiiiiie it 482
23.4.1 Calling the DIAgGNOSLIC VIBW ........eiiiiieiiiiiiieet ettt e e e e e e e et e e e e e e e s s nnbbeeeaaaeend 482
23.4.2 Information Functions in the DIagNOSHIC VIEW........cciiiiiiiiiiiieiiee e 484
23.5 [ [e o (WL [a]{o] 4 g T=11Te] o NPT PP P URPPPPPPR 485
23.5.1 Options for Displaying the Module INformation............ccccccoeiiiiiiiiiei e 485
23.5.2 Module INformation FUNCLIONS .........uviiiiiiiiie et e e e e e e 486
23.5.3 Scope of the Module Type-Dependent INfOrmation.............cccvvveveeeeei i 488
23.5.4 Displaying the Module Status of PA Field Devices and DP Slaves After a Y-Link............... 490
23.6 Diagnosing iN STOP MOGE .....cuvviiieiiiiiiiiiiee ettt e e e s e e e e e e e s e e e e e e e s e annrraneeeeens 492
23.6.1 Basic Procedure for Determining the Cause 0of & STOP ........cccccviiiiiiiiiieeciee e, 492
23.6.2 Stack Contents iN STOP MOGE.........ccoi ittt e e e e e s e snnaeaeeeeee s 493
23.7 Checking Scan Cycle Times to Avoid Time ErrOrs.........ccooveiiiiiieiiniiiie e 494
23.7.1 Checking Scan Cycle Times to AVOid TiME EITOrS.......cccouiiiiiiiiiieiaeeieiiiiiieee e 494
23.8 Flow of DiagnostiC INFOIMALION .......coooiiiiiiiiiieee et e e 495
23.8.1 SYSIEM SEALUS LISE SSL ...uviiiiiiiiie ettt e e et e e e s stre e e et e e e e sntae e e e ansaeeeeeneees 496
23.8.2 Sending Your Own DiagnNOStiC MESSAQES ....cceeeeiiiiiiiiiiiieeeieiiiiree et e e e e e s sintereeeee e e s e snansrnaeeeee s 499
23.8.3 (DT To | g To 1S3 (ol w0 LT i o o F= SRR PSRR 500
23.9 Program Measures for Handling ErrOrS.........ccoooiiiiiiiiic et irveen e 501

Programming with STEP 7
Manual, 05/2010, A5E02789666-01 19



Contents

24

25

20

23.9.1 Evaluating the Output Parameter RET VAL .....coooiiiiiiiiiee e 502
23.9.2 Error OBs as a Reaction to Detected ErTOrS. ... 503
23.9.3 Inserting Substitute Values for Error DetECHION..........uuviiieiii it 508
23.9.4 I/O Redundancy Error (OB70) ... iiiiiieiie e e e e sttt e e e e s s s siire e e e e e e e s e santaaeeeaee e s e s snnnnnneeeend 510
23.9.5 CPU Redundancy EITOr (OB72).......uuueiiieeiiiiiiieeie e e e s esitteee e e e e e s s ssiaae s s e e e e s sssanraeneaaeeesennnnnned 511
23.9.6 B eI = 0T (@232 ) TSR SPPRRRY 512
23.9.7 Power SUPPIY Error (OBB8L) ......ccuviiiiiiie e ie ittt e e s s sttt e e e e s st e e e e e e e s s nnnnnneeeeaeeeenennnend 513
23.9.8 Diagnostic INterrupt (OBB82) .......uuviiiiieei it e e r e e e e e s s r e e e e e e s nnnnrnees 514
23.9.9 Insert/Remove Module INterrupt (OB83)......cuuiiii ittt 515
23.9.10 CPU Hardware Fault (OBB84) .........ccoiiiiiiiiiiee ettt ettt et e e 516
23.9.11 Program Sequence Error (OBB85) ........cuiiiiiiiiiiiiiii ettt 516
23.9.12 RACK FAIlUIE (OBB8B) .....ccvveiieiiiiiie ittt e sttt e sttt e st et e e e st e e e st e e e ssbeeeesnsaeeesssaeeesnned 517
23.9.13 Communication Error (OB87) .........uueiiiiiee ittt e e e ee e e e e e e e e nane ] 517
23.9.14 Programming Error (OBL21).........uueiiiiieiiiiiieie ettt e e e et e e e e e e e e e nnnenand 518
23.9.15 [/O ACCESS EITOr (OBL22) .......uuuiiiieeeee ittt e e e e ettt e e e e e e e sttt e e e e e e e e s s atataeeeaaeeesennnnnreneees) 518
23.10 System Diagnostics with 'Report SYyStem Error............occcvieeiie i) 519
23.10.1 Graphical Output of DIagnOStIC EVENTS.........cccuviiiiiiee ittt e e e e 519
23.10.2 [T |1 1S (o] = L SRR 519
23.10.2.1  Overview of the DIagnoStiC STAtUS ........uuviiieeiiiiiiiiiii e e e e e s sanrerrr e e e e e e e 519
23.10.2.2 PROFIBUS DiagnOStIC STALUS.......cceiitiiieiiiiiee ittt ettt sttt e et e s e snbe e s snbnee e 519
23.10.2.3 Example of a DB 125 With @ DP SIQVE .........ccooiiiiiiiiiiiee i 523
23.10.2.4 Example of a Request for the PROFIBUS DP DB.........ccooiiiiiiiiiiiieeeiiee e 523
23.10.2.5 PROFINET DiagnOSHC StATUS.......uuieiiiiireiiiiieeeiiiieeesnireeessiteresssieeesssssaeesssssesessnsssnesssssnees, 525
23.10.2.6 Example of a DB126 with an IO System 100 and Devices with Device Numbers 2, 3

=1 T I U OPPPPRPROPPTRPTY 528
23.10.2.7 Example of a Request for the PROFINET IO DB .......cooiiiiiiiiiiie et e e 529
23.10.2.8 DiagnoStiC StAtUS DB ..........cuuiiiiieiiiiiiiiiie e e s e e e e s s e e e e e e e s e raraaeeeeannd 530
23.10.2.9 Example of a Diagnostic Status DB QUETY .......cccuuviiiieeeiiiiiiiiieeee e e e ecttere e e e e e s snrnre e e e e e e e 533
23.10.2.10 Importing Error and HEIP TEXES......cccuuuuiiieeeeiiiiiiiieeee e e e e s ssstiee e e e e e e s ssnatae e e e e e e s snnnnnreeeeeeeeesnnnnd 536
Printing @nd ATCHIVING ..oooiiieiie ettt e e sttt e e s bbb e e e s snbe e e s snneeeeesseaeeessneeeesane] 539
24.1 Printing Project DOCUMENTALION .......ciiieeiiiiiieieee e s e e e e e e st e e e e e e e e ennnnneed 539
24.1.1 Basic Procedure When PriNTING ........oc.eeiiiiiii et 540
24.1.2 PHNE FUNCHIONS .ot e e e e e e s ettt e e e e e e s s nnbnteeeeeaeeessnnsnneeeend 540
24.1.3 Special Note on Printing the ODJECE TIEE ......ccoiiiiiiiiiie e 541
24.2 Archiving Projects and LIDFaries ........oooueiiiiiiii et 542
24.2.1 Uses for SaviNg/AICRIVING ...t e e eeaeeeeea 543
24.2.2 RequiremMents fOr ArCRIVING........c..uieiiiei et e e e e e e e anereeea 544
24.2.3 Procedure for ArchivVing/REtHEVING .......cooiiiiiiiiieie et e e et r e e e e e e e ennnead 544
Working with M7 Programmable Control SYSTEMS .......ooii i 545
25.1 Procedure fOr M7 SYSIEIMS ......uuiiiiiie e e e e s r e e e e e s e s rer e e e e e e e e annrnneeeend 545
25.2 Optional Software for M7 Programming .......cc.eeeeieeeoiiiiiiieieee e sssiieee e e e e s sssnneeee e e e e e s nnnnned 547
25.3 M7-300/M7-400 Operating SYSIEIMS ......cccicuriieiieie e i iecitreee e e e e e s s s srteer e e e e e e s e sanraeeeeeeeeseennnnenned 549

Programming with STEP 7
Manual, 05/2010, A5E02789666-01



Conftents

26

27

TIPS AN THICKS ittt ettt e ettt e e skt e e e ab bt e e e s ahb et e e e aabe e e e e sbeeeessabeeeeesnbneeeen 551
26.1 Exchanging Modules in the Configuration Table ... 551
26.2 Projects with a Large Number of Networked Stations...........ccccceveeeiiiiiiiiiieece e 551
26.3 Y= 14 = o |1 o [P PSPPSRI 552
26.4 Editing Symbols Across Multiple NetwWOrKS ..........ccuviiiiiiiiiiee e 552
26.5 Testing with the Variable Table ...........oooo e 553
26.6 Modifying Variables With the Program EdItOr............ccovviiiiiiiiiiiiiiee e 554
26.7 YT (0 E= YAV o Q1Y 1= 11T SRR 555
N ] 0 1= g o 13 SRR 557
27.1 OPErAtiNg MOUES ......eeiiiiiieii ettt e s e e e s bt e e e nb e e e e anbae e e s annbeee e 557
27.11 Operating Modes and Mode TranSitioNS ........c..eeeiiiieieiiiiiie e 557
27.1.2 STOP MOUE ....ceeeieecteeee ettt et e e e ettt e e s e st e e e e ssbe e e e e sbaeaeannsaeeeaansbeeeeansreeennnns 560
27.1.3 STARTUP MOE ...ttt ettt e e sttt e e et e e e s st e e e e ntaeeeeansaeeeeansbeeeeanns 561
27.1.4 [ N Y To L= T RSP SPTRRR 569
27.1.5 [ (O T 1V o T [ PP BRSSP 570
27.2 MeEMOTY Areas Of S7 CPUS.......uuiiiiiiiiiiiiiiiiiiiiir e 571
27.2.1 Distribution of the MEMOIY ATEAS ........ccuuiiiiiee et e e e e e e s e saarraaeeeae s 571
27.2.2 Load Memory and WOrK MEMOTY .......cc.uuuiiiiiee e it ie e e e e e s s e e e e e e s st e s e e e e s e snnnnanaeeeees 572
27.2.3 YA (=] 0 4 I\ 1[0 YRR 574
27.2.3.1 UsSiNg the SYStem MEMIOIY AFEAS .....ccciiuuiiieiiiiiieeiiieee ettt et sibre e s anbe e s enbe e e e eeees 574
27.2.3.2 Process-Image INpUt/OULPUL TaDIES .........oviiiiiiiiii e 576
27.2.3.3 [T LI = = ] = Lo G PSPPSR 580
27.2.3.4 INEEITUPT STACK.....eeiiiee ittt e ettt e e e e e s st bbb e e e e e e e e e sannbbbbeeaaaeeesnnneens 581
27.2.3.5 2] (0T od 2 7 T PSPPSR 582
27.2.3.6 (D] F=To | a1 1] (ol = TU 1 = SO PUPU PP UPPPPPRPN 583
27.2.3.7 Evaluating the DiagnoStiC BUTEN............uuuiiiiiei e 583
27.2.3.8 Retentive Memory Areas 0N S7-300 CPUS .........ccciiiiiei et a e sanraane e 585
27.2.3.9 Retentive Memory Areas 0N S7-400 CPUS .........cccuiiiiiee et a e sanraaee e 586
27.2.3.10 Configurable Memory Objects in the WOrk MEmMOIY ........ccvveeiiiiiiiiiiieiee e e e 587
27.3 Data Types and Parameter TYPES.....cccuuuiiiiie e eicieieeee e e e e e ss st r e e e e e s s ssnsteee e e e e e e s e nnnseneeeeeens 588
27.3.1 Introduction to Data Types and Parameter TYPES......coccccvireieeieeeisiiiieieeee e e s e s sninneeneeee s e 588
27.3.2 Elementary Dat@ TYPES .....ooiiuiiieiiiieee ittt ettt sttt e e st e e s eabbe e e s annbe e e e anbe e e e e nees 589
27.3.2.1 Format of the Data Type INT (16-Bit INEJEIS) ....cuuveiiiiiiiiiiiiie e 590
27.3.2.2 Format of the Data Type DINT (32-Bit INtEJEIS) ......eviiiiiiiieiiiiie it 590
27.3.2.3 Format of the Data Type REAL (Floating-Point NUMDErS) ... 591
27.3.2.4 Format of the Data Types WORD and DWORD in Binary Coded Decimal Numbers.......... 595
27.3.25 Format of the Data Type S5TIME (Time DUration)...........ooocuveiieeieianniiiiiiee e 596
27.3.3 (000] 101 0] (Y D= L v= B Y =T SRR 597
27.3.3.1 (000] 101 0] () D= L v= B Y =T SRR 597
27.3.3.2 Format of the Data Type DATE_AND _TIME .........c.ouuiiiiieii e e e sneeee e e 598
27.3.3.3 USING COMPIEX DAA TYPES ..uvvreiiiieeeiiiiiiiieiee e e e e e sttt ee e e e e e s s stabaeee e e e e e s snnnnreneeeaeessaannnteenneeeens 600
27.3.3.4 USING Arrays t0 ACCESS DAA .....cciiiieiiiiiiiiiiiiee e st tr e e e s s s e e e e e e e s s r e e e e e e s e annrrenneeaens 601
27.3.35 USiNg SEructures t0 ACCESS DAta.......ccovuuiiiiiiiiiieiiiii et 604
27.3.3.6 Using User-Defined Data Types t0 ACCESS Data.........coccuveieiiiiiieiiiiiie e 606

Programming with STEP 7
Manual, 05/2010, A5E02789666-01 21



Contents

22

27.3.4
27.34.1
27.3.4.2
27.3.4.3
27.3.4.4
27.3.4.5
27.3.4.6
27.3.4.7
27.3.4.8
27.3.4.9
27.4
27.4.1
27.4.2
27.4.3
27.5
27.5.1
27.6
27.6.1
27.6.2
27.6.2.1
27.6.2.2
27.6.2.3
27.6.2.4
27.6.2.5
27.6.3
27.6.3.1
27.6.3.2
27.6.3.3
27.6.3.4
27.6.4
27.6.4.1
27.6.4.2
27.6.4.3
27.6.4.4
27.6.4.5

27.6.4.6

27.7

27.7.1
27.7.2
27.8

27.8.1
27.8.2
27.8.3
27.8.4

ParamMeEter TYPES .. 609
Format of the Parameter Types BLOCK, COUNTER, TIMER ........ccccccooiiiiiiiiiiiiaiiniiennd 610
Format of the Parameter Type POINTER........cooiiiiiiiiiiec e 610
Using the Parameter Type POINTER ...t sstreee e e 611
Block for Changing the POINLET .........cciiiiiiiieeec e e e e e e neneead 613
Format of the Parameter TYPE ANY ....cooiiiiiiiiiiei e e e e e e e e e e e e e ennned 616
Using the Parameter TYPE ANY ... it e e e e s er e e e e e s s e e e e e e e s e nnnnraneed 619
Assigning Data Types to Local Data of LogiC BIOCKS ..........ccccviieeieeei i 622
Permitted Data Types when Transferring Parameters ... 624
Transferring to IN_OUT Parameters of a Function BIOCK.............cccccoviiiiiiiiiiiniiec e, 629
WOrKing With Older PrOJECES. .....ciiiiiiiiii ittt e e e e 630
Converting VErsion 2 PIrOJECES ........uuuiiiiiaaiiiiieie ettt et e e e e e e s s ranbbeeeeeae e e s e snnne] 630
Editing Version 2 Projects and LIDraries. ... 631
Notes on STEP 7 V.2.1 Projects with GD CommuniCation..............cceeeeeiiiiiiiieeeeeeeeiiiiieeen, 631
Expanding DP Slaves That Were Created with Previous Versions of STEP 7 .................... 632
DP-Slaves with Missing or Faulty GSD Fil€S..........cooiiiiiiiiiie e 633
SAMPIE PrOGIAMS ...ooooiiiiiiiei et e e e e e e e e s e st e e e e e e e e s aateaaeeeeeeseasannrraneeaeessesnnnd 634
Sample Projects and Sample Programs............ueeeiiieiiiiiciiiieeee s s ssieeee e e e e s s s snneeeeeee e e e s 634
Sample Program for an Industrial Blending ProCess.........cuuvvveiiiiiciiieeieeee s cesieeeeeee e s e 636
DefiniNg LOGIC BIOCKS........veiiiiiiieii et 639
ASSIgNING SYMDBDOIC NAIMES .....eeiiiiiiiiie et e e sne e e e s eaeed 640
Creating the FB for the MOTOT ........ccoiiiiiiiiiiee e 642
Creating the FC for the VaIVES...........eiiii e 646
CrEatiNng OB ...ttt e e e e e bbb et e e e e e e e bbbb e e e e e e e e e e nnbrreeaaaaeaeaanee] 648
Example of Handling Time-of-Day INtEITUPLS. .......cooiiiiiiiiiiee i 654
Structure of the User Program "Time-of-Day INterrupts” ...........ooocviveerieeeiiiiiiieeee e 654
3112 RS URPOPPPPOTPRPY 656
(@] 3 0 PSPPSRI 658
OBL1 QN0 OBBO.......ceiiiiuiiiieiiiieee ettt sttt sttt e sttt e e s st e e e s abe e e e s sttt e e s anbbe e e e anbe e e e enbaeeeennneeen) 660
Example of Handling Time-Delay INterTUPLS .......cccoiiiiiiiiiiiiee e e e e 662
Structure of the User Program "Time-Delay INterrupts”..........cooovviiieereeeie i 662
(@] 0 PSPPSRI 664
L] 3 SR UPRPOTRROPPI 666
Example of Masking and Unmasking Synchronous EIrors ..........ccccvvieiiiiienniiiee e 668
Example of Disabling and Enabling Interrupts and Asynchronous Errors
(SR O3C 1 - Ta Lo IR 0 1 ) SRS TPRRRSPI 672
Example of the Delayed Processing of Interrupts and Asynchronous Errors
(SFCAL @NA SFCA2) ...ueeeieiiieie ettt ettt e et e e st e e s e st e e s enbbee e s enbeeeeennreeeen, 673
Accessing Process and /0O Data AFBaS.......ceeeeeeiiiiuririieeeeeeiiiiiiieeeeeeeeesssiasraeeeeeeessesnsnsaneeeeend 674
Accessing the ProCeSS Data AT a .......ccuuuviieieeeeeiiciiiieiee e e e e s sesee e e e e e e s s ssneee e e e e e e s e nnnraeneeeend 674
Accessing the Peripheral Data Al a..........ueuvveeeiiiiciiiiiiiieee e ee e e e s e e e e e e e s s ennrenneeeeees) 676
Setting the Operating BENAVION...........cuiiiii i e e e 678
Changing the Behavior and Properties of MOAUIES ..........ccuiiiiiiiiiiiiiie e 679
Updating the Firmware (of the Operating System) in Modules and Submodules Offline.....681
USING the CIOCK FUNCHONS .....couiiiiiiiiiie ettt e e 682
Using Clock MemOry @nd TIMEIS . ...cciii ittt e ettt e ettt e e e e e e e s e e e e e e e e s e annreeend 683
.................................................................................................................................................. 685

Programming with STEP 7
Manual, 05/2010, A5E02789666-01



1 Introducing the Product and Installing the Software

1.1 Overview of STEP 7

What is STEP 7?

STEP 7 is the standard software package used for configuring and programming SIMATIC
programmable logic controllers. It is part of the SIMATIC industry software. There are the following
versions of the STEP 7 Standard package:

e STEP 7 Micro/DOS and STEP 7 Micro/Win for simpler stand-alone applications on the
SIMATIC S7-200.

e STEP 7 for applications on SIMATIC S7-300/S7-400, SIMATIC M7-300/M7-400, and
SIMATIC C7 with a wider range of functions:

Can be extended as an option by the software products in the SIMATIC Industry Software
(see also Extended Uses of the STEP 7 Standard Package)

Opportunity of assigning parameters to function modules and communications processors
Forcing and multicomputing mode

Global data communication

Event-driven data transfer using communication function blocks

Configuring connections

STEP 7 is the subject of this documentation, STEP 7 Micro is described in the "STEP 7
Micro/DOS" documentation.

Basic Tasks

When you create an automation solution with STEP 7, there are a series of basic tasks. The
following figure shows the tasks that need to be performed for most projects and assigns them to a
basic procedure. It refers you to the relevant chapter thus giving you the opportunity of moving
through the manual to find task-related information.
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1.1 Overview of STEP 7

Alternative Procedures

As shown in the figure above, you have two alternative procedures:

You can configure the hardware first and then program the blocks.

You can, however, program the blocks first without configuring the hardware. This is
recommended for service and maintenance work, for example, to integrate programmed blocks
into in an existing project.

Brief Description of the Individual Steps

Install STEP 7 and license keys
The first time you use STEP 7, install it and transfer the license keys from diskette to the hard
disk (see also Installing STEP 7 and Authorization).

Plan your controller

Before you work with STEP 7, plan your automation solution from dividing the process into
individual tasks to creating a configuration diagram (see also Basic Procedure for Planning an
Automation Project).

Design the program structure
Turn the tasks described in the draft of your controller design into a program structure using the
blocks available in STEP 7 (see also Blocks in the User Program).

Start STEP 7
You start STEP 7 from the Windows user interface (see also Starting STEP 7).

Create a project structure

A project is like a folder in which all data are stored in a hierarchical structure and are available
to you at any time. After you have created a project, all other tasks are executed in this project
(see also Project Structure).

Configure a station
When you configure the station you specify the programmable controller you want to use; for
example, SIMATIC 300, SIMATIC 400, SIMATIC S5 (see also Inserting Stations).

Configure hardware

When you configure the hardware you specify in a configuration table which modules you want
to use for your automation solution and which addresses are to be used to access the modules
from the user program. The properties of the modules can also be assigned using parameters
(see also Basic Procedure for Configuring Hardware).

Configure networks and communication connections

The basis for communication is a pre-configured network. For this, you will need to create the
subnets required for your automation networks, set the subnet properties, and set the network
connection properties and any communication connections required for the networked stations
(see also Procedure for Configuring a Subnet).

Define symbols
You can define local or shared symbols, which have more descriptive names, in a symbol table
to use instead of absolute addresses in your user program (see also Creating a Symbol Table).

Create the program
Using one of the available programming languages create a program linked to a module or
independent of a module and store it as blocks, source files, or charts (see also Basic
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Procedure for Creating Logic Blocks and Basic Information on Programming in STL Source
Files).

e S7 only: generate and evaluate reference data
You can make use of these reference data to make debugging and modifying your user
program easier (see also Overview of the Available Reference Data).

e Configure messages
You create block-related messages, for example, with their texts and attributes. Using the
transfer program you transfer the message configuration data created to the operator interface
system database (for example, SIMATIC WiInCC, SIMATIC ProTool), see also Configuring
Messages.

e Configure operator control and monitoring variables
You create operator control and monitoring variables once in STEP 7 and assign them the
required attributes. Using the transfer program you transfer the operator control and monitoring
variables created to the database of the operator interface system WinCC (see also
Configuring Variables for Operator Control and Monitoring).

e Download programs to the programmable controller
S7 only: after all configuration, parameter assignment, and programming tasks are completed,
you can download your entire user program or individual blocks from it to the programmable
controller (programmable module for your hardware solution). (See also Requirements for
Downloading.) The CPU already contains the operating system.
M7 only: choose a suitable operating system for your automation solution from a number of
different operating systems and transfer this on its own or together with the user program to the
required data medium of the M7 programmable control system.

e Test programs
S7 only: for testing you can either display the values of variables from your user program or a
CPU, assign values to the variables, or create a variable table for the variables that you want to
display or modify (see also Introduction to Testing with the Variable Table).
M7 only: test the user program with a high-level language-debugging tool.

e Monitor operation, diagnose hardware
You determine the cause of a module fault by displaying online information about a module.
You determine the causes for errors in user program processing with the help of the diagnostic
buffer and the stack contents. You can also check whether a user program can run on a
particular CPU (see also Hardware Diagnostics and Displaying Module Information).

e Document the plant
After you have created a project/plant, it makes sense to produce clear documentation of the
project data to make further editing of the project and any service activities easier (see also
Printing Project Documentation). DOCPRO, the optional tool for creating and managing plant
documentation, allows you to structure the project data, put it into wiring manual form, and print
it out in a common format.
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Specialized Topics

When you create an automation solution there are a number of special topics that may be of
interest to you:

e Multicomputing - Synchronous Operation of Several CPUs (see also Multicomputing -
Synchronous Operation of Several CPUs)

e More than One User Working in a Project (see also More than One User Editing Projects)

e Working with M7 Systems (see also Procedure for M7 Systems)
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1.2 The STEP 7 Standard Package

Standards Used

The SIMATIC programming languages integrated in STEP 7 are compliant with EN 61131-3. The
standard package matches the graphic and object oriented operating philosophy of Windows and
runs under the operating systems MS Windows XP Professional (simply Windows XP below), MS
Windows Server 2003 and MS Windows 7 Business, Ultimate and Enterprise.

Functions of the standard package

The standard software supports you in all phases of the creation process of an automation task,
such as:

Setting up and managing projects

Configuring and assigning parameters to hardware and communications
Managing symbols

Creating programs, for example, for S7 programmable controllers
Downloading programs to programmable controllers

Testing the automation system

Diagnosing plant failures

The STEP 7 software user interface has been designed to meet the latest state-of-the-art
ergonomics and makes it easy for you to get started.

The documentation for the STEP 7 software product provides all the information online in the online
Help and in electronic manuals in PDF format.
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Applications in STEP 7

The STEP 7 Standard package provides a series of applications (tools) within the software:

standard Package

NMETFRC
Symbol Editor SIMATIC Manaqger Communication
Configuraticn
H.ardware- Programming Languages T e
Configuration i i
q LAD FBD aTL Diagnostics

You do not need to open the tools separately; they are started automatically when you select the
corresponding function or open an object.
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SIMATIC Manager

The SIMATIC Manager manages all the data that belong to an automation project — regardless of
which programmable control system (S7/M7/C7) they are designed for. The tools needed to edit
the selected data are started automatically by the SIMATIC Manager.

ESIHATIE Manager - ZEn01_08_STEP7__ Mix

File Edt |nzett PLC “iew Options Window Help

I =] E3

O|2|8%5] & |c=|a| ﬂl I‘E'_El o S

System D ata

-5 ZEnM_07_STERP?__Dist_10
=-El SIMATIC 300(1)
=-[@ CPU315-2DP
[El-{zz] S7-Program(1]
-{B] Source Files
423 Blocks

28 ZEnD1_D8_STEP7_ Mix

=B SIMATIC 300-5tation(1)
=- [ CPU314(1)

=-{zz] 57-Program(1]

Prezs F1 far help.

'EEZEnIH_I]?_STEP?_Dist_ID - C:ASIEMENSASTEP?. . H[=] E3

'EEEZEnIH_I]B_STEP?_Hix -- CASIEMENSASTEPTAE:. ..

System Data

[ < NoFier »

Zmlll

Symbol Editor

With the Symbol Editor you manage all the shared symbols. The following functions are available:

e Setting symbolic names and comments for the process signals (inputs/outputs), bit memory,

and blocks
e Sort functions

e Import/export to/from other Windows programs

The symbol table created with this tool is available to all the other tools. Any changes to the
properties of a symbol are therefore recognized automatically by all tools.
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Diagnosing Hardware

These functions provide you with an overview of the status of the programmable controller. An
overview can display symbols to show whether every module has a fault or not. A double-click on
the faulty module displays detailed information about the fault. The scope of this information
depends on the individual module:

e Display general information about the module (for example, order number, version, name) and
the status of the module (for example, faulty)

e Display the module faults (for example, channel fault) for the central I/O and DP slaves
e Display messages from the diagnostic buffer

For CPUs the following additional information is displayed:

e Causes of faults in the processing of a user program

e Display the cycle duration (of the longest, shortest, and last cycle)

e MPI communication possibilities and load

e Display performance data (humber of possible inputs/outputs, bit memory, counters, timers,
and blocks)

Programming Languages

The programming languages Ladder Logic, Statement List, and Function Block Diagram for S7-300
and S7-400 are an integral part of the standard package.

e Ladder Logic (or LAD) is a graphic representation of the STEP 7 programming language. Its
syntax for the instructions is similar to a relay ladder logic diagram: Ladder allows you to track
the power flow between power rails as it passes through various contacts, complex elements,
and output coils.

e Statement List (or STL) is a textual representation of the STEP 7 programming language,
similar to machine code. If a program is written in Statement List, the individual instructions
correspond to the steps with which the CPU executes the program. To make programming
easier, Statement List has been extended to include some high-level language constructions
(such as structured data access and block parameters).

e Function Block Diagram (FBD) is a graphic representation of the STEP 7 programming
language and uses the logic boxes familiar from Boolean algebra to represent the logic.
Complex functions (for example, math functions) can be represented directly in conjunction
with the logic boxes.

Other programming languages are available as optional packages.
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Hardware Configuration

You use this tool to configure and assign parameters to the hardware of an automation project. The
following functions are available:

To configure the programmable controller you select racks from an electronic catalog and
arrange the selected modules in the required slots in the racks.

Configuring the distributed I/O is identical to the configuration of the central I/O.

In the course of assigning parameters to the CPU you can set properties such as startup
behavior and scan cycle time monitoring guided by menus. Multicomputing is supported. The
data entered are stored in system data blocks.

In the course of assigning parameters to the modules, all the parameters you can set are set
using dialog boxes. There are no settings to be made using DIP switches. The assignment of
parameters to the modules is done automatically during startup of the CPU. This means, for
example, that a module can be exchanged without assigning new parameters.

Assigning parameters to function modules (FMs) and communications processors (CPs) is also
done within the Hardware Configuration tool in exactly the same way as for the other modules.
Module-specific dialog boxes and rules exist for every FM and CP (included in the scope of the
FM/CP function package). The system prevents incorrect entries by only offering valid options
in the dialog boxes.

NetPro (Network Configuration)

32

Using NetPro time-driven cyclic data transfer via the MPI is possible where you:

Select the communication nodes

Enter the data source and data target in a table; all blocks (SDBs) to be downloaded are
generated automatically and completely downloaded to all CPUs automatically

Event-driven data transfer is also possible where you:

Set the communication connections
Select the communication or function blocks from the integrated block library

Assign parameters to the selected communication or function blocks in your chosen
programming language
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1.3 What's New in STEP 7, Version 5.5?

The following subject areas have been updated:

e Operating Systems

e Configuring and Diagnosing Hardware

e Configuration Changes during Ongoing Operation (CiR)
e Standard Libraries

e Report System Error

e Diagnostics

e Setting the PG/PC Interface

Operating systems

As of STEP 7 V5.5, the operating systems MS Windows 7 Professional, Ultimate and Enterprise
(standard installation) are supported.

Configuring and Diagnosing Hardware
e Asof STEP 7 V5.5, you can create I-devices from numerous IO controllers.
e Asof STEP 7 V5.5, you can use the PROFINET shared device function.
e Asof STEP 7 V5.5, you can assign the IP addresses and device names dynamically.
e Asof STEP 7 V5.5, you can configure media redundancy for multiple domains.
e Asof STEP 7 V5.5, you can you can configure the isochronous mode for 10 devices.
e Asof STEP 7 V5.5, you can install hardware updates directly from the "Windows Start menu".
e Asof STEP 7 V5.5, you can manage user rights for the Web server.
e Asof STEP 7 V5.5, you can access Web pages of the CPU via a secure HTTPS connection.
e Asof STEP 7 V5.5, you can configure keepalive times for TCP connections.

e Asof STEP 7 V5.5, you can download I&M data for more than one module at the same time
(using multiselection).

Configuration Changes during Ongoing Operation (CiR)

The restrictions in STEP 7 versions up to and including V5.4 regarding hardware configuration in
RUN (CiR) for PROFIBUS when upgrading the STEP version no longer apply in V5.5.
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Standard Libraries

e Asof STEP 7 V5.5, the system functions have been expanded by the addition of SFB104
"IP_CONF" for program-controlled configuration of the integrated PROFINET interface of your
CPU.

e Asof STEP 7 V5.5, the system functions have been expanded by the addition of SFC99
"WWW" for enabling or synchronizing user Web pages.

e Asof STEP 7 V5.5, the system functions have been expanded by the addition of SFB73
"RCVREC" for receiving data records and SFB74 "PRVREC" for making data records available
on an I-device. These SFBs are only valid for S7-300 CPUs.

e Asof STEP 7 V5.5, the system status list with SSL-ID W#16#xy9C has been expanded. This
provides information on the configured tool changer and its tools.

e Asof STEP 7 V5.5, the following FBs of S7 communication are included: FB28 "USEND_E",
FB29 "URCV_E", FB34 "GET_E", FB35 "PUT_E". These are only for S7-300 CPUs and only
on connections via the integrated PN interface.

e Asof STEP 7 V5.5, the following two FBs for open communication via Industrial Ethernet have
new names: FB 210 (previous name: "S5FW_TCP") is now called "FW_TCP", FB 220
(previous name: "S5FW_IOT") is now called "FW_IOT".

Report System Error

e Asof STEP 7 V5.5, you can choose whether or not the status of slaves is evaluated when the
CPU starts up.

e Asof STEP 7 V5.5, the additional texts of messages are displayed or implemented in the
"Message Preview", "Print" and "Print Preview" dialogs.

e Asof STEP 7 V5.5, you can also download blocks generated by 'Report System Error' in HW
Config

System diagnostics

e Asof STEP 7 V5.5, there are two "Diagnostics in Hexadecimal Format" dialogs: one for
PROFIBUS slaves and one for PROFINET devices.

Setting the PG/PC Interface

As of STEP 7 V5.5, you can use the USB prommer without needing to install additional software.
The required functionality is integrated in STEP 7.
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1.4  Extended Uses of the STEP 7 Standard Package

The standard package can be extended by optional software packages that are grouped into the
following three software classes:

Engineering Tools;
these are higher-level programming languages and technology-oriented software.

Run-Time Software;
these contain off-the-shelf run-time software for the production process.

Human Machine Interfaces (HMI);
this is software especially for operator control and monitoring.

The following table shows the optional software you can use depending on your programmable
control system:

STEP 7

S7-300
S7-400

M7-300
M7-400

C7-620

Engineering Tools

Borland C/C++

CFC

1)

2)

DOCPRO

HARDPRO

M7 ProC/C++

S7 GRAPH

S7 HiGraph

S7 PDIAG

S7 PLCSIM

S7 SCL

Teleservice

Run-Time Software

Fuzzy Control

M7-DDE Server

M7-SYS RT

Modular PID Control

PC-DDE Server

PRODAVE MPI

Standard PID Control

+ |+ |+ |+
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STEP 7
S7-300 M7-300 C7-620
S7-400 M7-400
Human Machine Interface
e  ProAgent
e SIMATIC ProTool
e  SIMATIC ProTool/Lite 0

e SIMATIC WinCC

o = obligatory
+ = optional

D = recommended from S7-400
upwards

2 = not recommended for C7-620
% = not for C programs
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1.4.1 Engineering Tools

Engineering Tools are task-oriented tools that can be used to extend the standard package.
Engineering Tools include:

High-level languages for programmers
Graphic languages for technical staff

Supplementary software for diagnostics, simulation, remote maintenance, plant documentation
etc.

Engineering Tools

High-level languages Graphic languages
S7-50L S7-GRAFH CFC
S7-HiGraph

Supplementary software

hAT-F raCic ++ S7-PDIAG S7-PLCSIM

TeleService DOoOCPRO HARDFPRO

High-Level Languages

The following languages are available as optional packages for use in programming the SIMATIC
S7-300/S7-400 programmable logic controllers:

S7 GRAPH is a programming language used to program sequential controls (steps and
transitions). In this language, the process sequence is divided into steps. The steps contain
actions to control the outputs. The transition from one step to another is controlled by switching
conditions.

S7 HiGraph is a programming language used to describe asynchronous, non-sequential
processes in the form of state graphs. To do this, the plant is broken down into individual
functional units which can each take on different states. The functional units can be
synchronized by exchanging messages between the graphs.

S7 SCL is a high-level text-based language to EN 61131-3 (IEC 1131-3). It contains language
constructs similar to those found in the programming languages C and Pascal. S7 SCL is
therefore particularly suitable for users familiar with high-level language programming. S7 SCL
can be used, for example, to program complex or frequently recurring functions.

Programming with STEP 7
Manual, 05/2010, ASE02789666-01 37



Introducing the Product and Installing the Software

1.4 Extended Uses of the STEP 7 Standard Package

Graphic Language

CFC for S7 and M7 is a programming language for interconnecting functions graphically. These
functions cover a wide range of simple logic operations through to complex controls and control
circuits. A large number of such function blocks are available in the form of blocks in a library. You
program by copying the blocks into a chart and interconnecting the blocks with connecting lines.

Supplementary Software

38

Borland C++ (M7 only) contains the Borland development environment.

With DOCPRO you can organize all configuration data created under STEP 7 into wiring
manuals. These wiring manuals make it easy to manage the configuration data and allow the
information to be prepared for printing according to specific standards.

HARDPRO is the hardware configuration system for S7-300 with user support for large-scale
configuration of complex automation tasks.

M7 ProC/C++ (M7 only) allows integration of the Borland development environment for the
programming languages C and C++ into the STEP 7 development environment.

You can use S7 PLCSIM (S7 only) to simulate S7 programmable controllers connected to the
programming device or PC for purposes of testing.

S7 PDIAG (S7 only) allows standardized configuration of process diagnostics for SIMATIC
S7-300/S7-400. Process diagnostics let you detect faults and faulty states of PLC I/O (for
example, limit switch not reached).

TeleService is a solution providing functions for online programming and servicing of remote
S7 and M7 PLCs via the telecommunications network with your PG/PC.
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142 Run-Time Software
Runtime software provides ready-to-use solutions you can call in user program and is directly
implemented in the automation solution. It includes:
e Controllers for SIMATIC S7, for example, standard, modular and fuzzy logic control
e Tools for linking the programmable controllers with Windows applications

e A real-time operating system for SIMATIC M7

Funtime Softeare

Controllers
Standard PID Cortrol| | Modular PID Contral Fuzzy Control
Tools far linking with W ind cees Real-tirme operating system
FROD&AVE MPI| [MF-DDE-Server M7-5YS RT

Controllers for SIMATIC S7

e Standard PID Control allows you to integrate closed-loop controllers, pulse controllers, and
step controllers into the user program. The parameter assignment tool with integrated controller
setting allows you to set the controller up for optimum use in a very short time.

e Modular PID Control comes into play if a simple PID controller is not sufficient to solve your
automation task. You can interconnect the included standard function blocks to create almost
any controller structure.

e With Fuzzy Control you can create fuzzy logic systems. These systems are used if the
mathematical definition of processes is impossible or highly complex, if processes and
sequencers do not react as expected, if linearity errors occur and if, on the other hand,
information on the process is available.
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Tools for Linking with Windows

PRODAVE MPI is a toolbox for process data traffic between SIMATIC S7, SIMATIC M7, and

]
SIMATIC C7. It automatically controls the data flow across the MPI interface.

An M7 DDE server (Dynamic Data Exchange) can be used to link Windows applications to
process variables in SIMATIC M7, without additional programming effort.

Real-Time Operating System

e M7-SYS RT contains the operating system M7 RMOS 32 and system programs. Itis a
prerequisite for the use of the M7-ProC/C++ and CFC for SIMATIC M7 packages.

Programming with STEP 7
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1.4.3 Human Machine Interface
Human Machine Interface (HMI) is a software especially designed for operator control and
monitoring in SIMATIC.

e The open process visualization systems SIMATIC WinCC and SIMATIC WinCC flexible are
basic systems that are not restricted to specific industrial sectors or technology and provide all
the important operator control and monitoring functions.

e SIMATIC ProTool and SIMATIC ProTool/Lite are modern tools for configuring SIMATIC
operator panels (OPs) and SIMATIC C7 compact devices.

e ProAgentis a diagnostics software that acquires information on the location and cause of
errors in plants and machinery and thus offers fast and aimed process diagnostics.

Hurnan Machine Irterface

SIMATIC WinCC SIMATIC PraTaoal Profgert

SIMATIC WinC Cflexible SIMATIC ProToalfLite
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2.1

2.1.1

Installation

Automation License Manager

User Rights Through The Automation License Manager

Automation License Manager

Licenses

To use STEP 7 programming software, you require a product-specific license key (user rights).
Starting with STEP 7 V5.3, this key is installed with the Automation License Manager.

The Automation License Manager is a software product from Siemens AG. It is used to manage the
license keys (license modules) for all systems.

The Automation License Manager is located in the following places:

e On the installation device for a software product requiring a license key

¢ On a separate installation device

e As adownload from the Internet page of A&D Customer Support at Siemens AG

The Automation License Manager has its own integrated online help. To obtain help after the
license manager is installed, press F1 or select the Help > Help on License Manager. This online
help contains detailed information on the functionality and operation of the Automation License
Manager.

Licenses are required to use STEP 7 program packages whose legal use is protected by licenses.
A license gives the user a legal right to use the product. Evidence of this right is provided by the
following:

e The ColL (Certificate of License), and

e The license key

Certificate of License (Col)

The "Certificate of License" that is included with a product is the legal evidence that a right to use
this product exists. This product may only be used by the owner of the Certificate of License (ColL)
or by those persons authorized to do so by the owner.
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License Keys
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The license key is the technical representation (an electronic "license stamp") of a license to use
software.

SIEMENS AG issues a license key for all of its software that is protected by a license. When the
computer has been started, such software can only be used in accordance with the applicable
license and terms of use after the presence of a valid license key has been verified.

Notes

e You can use the standard software without a license key to familiarize yourself with the user interface and
functions.

o However, a license is required and necessary for full, unrestricted use of the STEP 7 software in
accordance with the license agreement

e If you have not installed the license key, you will be prompted to do so at regular intervals.

License Keys can be stored and transferred among various types of storage devices as follows:
e On license key diskettes or USB memory stick

e On the local hard disk

e On network hard disk

If software products for which no license is available are installed, you can then determine which
license key is needed and order it as required.

For further information on obtaining and using license keys, please refer to the online help for the
Automation License Manager.
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2.1 Automation License Manager

The following different types of application-oriented user licenses are available for software
products from Siemens AG. The actual behavior of the software is determined by which type
license key is installed for it. The type of use can be found on the accompanying Certificate of

License.

License Type

Description

Single License

The software can be used on any single computer desired for an unlimited amount of time.

Floating License

The software can be used on a computer network ("remote use") for an unlimited amount
of time.

Trial License

The software can be used subject to the following restrictions:
e A period of validity of up to a maximum of 14 days,

e Atotal number of operating days after the day of first use,
e A use for tests and validation (exemption from liability).

Rental License

The software can be used subject to the following restrictions:
e A period of validity of up to a maximum of 50 hours.

Upgrade License

Certain requirements in the existing system may apply with regard to software upgrades:

e Anupgrade license may be used to convert an "old version X" of the software to a
newer version X+.

e An upgrade may be necessary due to an increase in the volume of data being handled
in the given system.
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2.1.2

Installing the Automation License Manager
The Automation License Manager is installed by means of an MSI setup process. The installation
software for the Automation License Manager is included on the STEP 7 product CD.

You can install the Automation License Manager at the same time you install STEP 7 or at a later
time.

Notes
« For detailed information on how to install the Automation License Manager, please refer to the
current Readme file

« The online help for the Automation License Manager contains all the information you need on
the function and handling of License Keys.

Subsequent installation of license keys

If you start the STEP 7 software and no license keys are available, a warning message indicating
this condition will be displayed.

Notes

« You can use the standard software without a license key to familiarize yourself with the user
interface and functions.

« However, a license is required and necessary for full, unrestricted use of the STEP 7 software
in accordance with the license agreement

« If you have not installed the license key, you will be prompted to do so at regular intervals.

You can subsequently install license keys in the following ways:
e Install license keys from diskettes or USB memory stick

¢ Install license keys downloaded from the Internet. In this case, the license keys must be
ordered first.

e Use floating license keys available in a network

For detailed information on installing license keys, refer to the online help for the Automation
License Manager. To access this help, press F1 or select the Help > Help on License Manager
menu command.

Notes

In Windows XP/Server 2003, license keys will only be operational if they are installed on a local
hard disk and have write-access status.

Floating licenses can also be used within a network ("remote" use).
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2.1.3 Guidelines for Handling License Keys

A Caution

Please note the information on handling license keys that is available in the online help on the
Automation License Manager and also in the STEP 7 Readme file on the installation CD-ROM. If you
do not follow these guidelines, the license keys may be irretrievably lost.

To access online help for the Automation License Manager, press F1 for context-sensitive help or
select the Help > Help on License Manager menu command.

This help section contains all the information you need on the function and handling of license
keys.
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2.2 Installing STEP 7

The STEP 7 Setup program performs an automatic installation. The complete installation
procedure is menu controlled. Execute Setup using the standard Windows XP/7/Server 2003
software installation procedure.

The major stages in the installation are:
e Copying the data to your programming device
e Configuration of EPROM and communication drivers

e Installing the license keys (if desired)

Note

Siemens programming devices are shipped with the STEP 7 software on the hard disk ready for
installation.

Installation requirements

48

e Operating system:
Microsoft Windows XP, Windows Server 2003, MS Windows 7 Professional and Enterprise
(standard installation).

e Basic hardware:
Programming device or PC with:

e Pentium processor (600 MHz)
e Atleast512 MB RAM.
e Color monitor, keyboard and mouse, all of which are supported by Microsoft Windows

A programming device (PG) is a PC with a special compact design for industrial use. It is fully
equipped for programming SIMATIC PLCs.

e Hard disk space:
Refer to the Readme file for information on required hard disk space.

e MPI interface (optional):
An MPI interface is only required to interconnect the PG/PC and the PLC if you want to use it
for communication with the PLC under STEP 7.
In this case you require:

e A PC USB adapter that is connected to the communications port of your device, or

e An MPI module (for example, CP 5611) that is installed in your device.
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2.2 Installing STEP 7

PGs are supplied with an MPI interface.

e External prommer (optional)
An external prommer is only required if you want to program EPROMSs with a PC.

Note
Refer to the information on STEP 7 installation in the Readme file and the "List of SIMATIC
Software Packages compatible to the versions of the standard STEP 7 software package."

You can find the Readme file in the start menu under Start > Simatic > Product Notes.

The compatibility list is found via the Start menu, under Start > Simatic > Documentation.

Programming with STEP 7
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Installation Procedure

Preparing for Installation

The operating system (Windows XP, Server 2003 or Windows 7) must be started before you can
start your software installation.

e You do not require an external storage medium if the installable STEP 7 software is already
stored on the hard disk of the PG.

e Toinstall from CD-ROM, insert the CD-ROM in the CD-ROM drive of your PC.

Starting the Installation Program

To install the software, proceed as follows:
1. Insert the CD-ROM and double click on the file "SETUP.EXE".
2. Follow the on-screen step-by-step instructions of the installation program.

The program guides you through all steps of the installation. You can go to the next step or return
to the previous step.

During installation, the dialog boxes prompt you to make your choice from the displayed options.
The following notes will help you to quickly and easily find the right answers.

If a Version of STEP 7 Is Already Installed...

If Setup detects another version of STEP 7 on the programming device, a corresponding message
is displayed. You can then choose to:

e Abort the installation (so that you can uninstall the old STEP 7 version under Windows and
then restart Setup, or

e Continue Setup and overwrite the previous version.

For well organized software management you should always uninstall any older versions before
installing the new version. the disadvantage of overwriting previous versions with a new version is
that when you subsequently uninstall the old software version some components of the old version
may not be removed.

Selecting the Installation Options

50

You have three was to select the scope of the installation:

e Standard setup: all dialog languages for the user interface, all applications, and all examples.
Refer to the current Product Information for information on memory space required for this type
of configuration.

e Basic setup: only one dialog language, no examples. Refer to the current Product Information
for information on memaory space required for this type of configuration.

e User-defined ("custom") setup: you can determine the scope of the installation, e.g. the
programs, databases, examples, and communication functions.
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ID Number

You will be prompted during setup to enter an ID number (found on the Software Product
Certificate or on your license key storage medium).

Installing License Keys

During setup, the program checks to see whether a corresponding license key is installed on the
hard disk. If no valid license key is found, a message stating that the software can be used only
with a license key is displayed. If you want, you can install the license key immediately or continue
setup and then install the key later. If you want to install the license key now, insert the
authorization diskette or use the A&D license stick when prompted to do so.

PG/PC Interface Settings

During installation, a dialog box is displayed where you can assign parameters to the programming
device/PC interface. You will find more information on it in "Setting the PG/PC Interface."

Assigning Parameters to Memory Cards
During installation, a dialog box is displayed where you can assign parameters to Memory Cards.

¢ You do not need an EPROM driver if you are not using any Memory Cards . Select the option
"No EPROM Driver".

e Otherwise, select the entry which applies to your PG.

e If you are using a PC, you can select a driver for an external prommer. Here you must specify
the port to which the prommer is connected (for example, LPT1).

You can change the set parameters after installation by calling the program "Memory Card
Parameter Assignment" in the STEP 7 program group or in the Control Panel.

Flash-File Systems

In the dialog box for assigning memory card parameters, you can select to install a flash-file
system.

The flash-file system is required, for example under SIMATIC M7 when you write individual files to
an EPROM memory card without changing other contents of the Memory Card.

If you are using a suitable programming device (PG 720/PG 740/PG 760, Field PG and Power PG)
or external prommer and you want to use this function, install the flash-file system.
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If Errors Occur during the Installation

Setup may be cancelled due to the following errors:

e If an initialization error occurs immediately after the start of Setup, more than likely setup was
not started under Windows.

e Insufficient hard disk space: For the basic software, you require approximately 650 MB to
900 MB of free space on your hard disk depending on the scope of your installation.

e Bad CD-ROM: If the CD is faulty, please contact your local Siemens representative.

e Operator error: Restart setup follow the instructions carefully.

After the installation has been completed...

52

An on-screen message reports the successful installation.

If any changes were made to system files during the installation, you are prompted to restart
Windows. After this restart (warm restart) you can start the STEP 7 application, the SIMATIC
Manager.

After successful installation, a program group for STEP 7 has been set up.
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2.2 Installing STEP 7

Setting the PG/PC Interface

Here you configure the communication between the PG/PC and the PLC. During installation, you
are displayed a dialog for assigning parameters to the PG/PC interface. You can also open this
dialog box after installation, by calling the program "Setting PG/PC Interface" in the STEP 7
program group. This enables you to modify the interface parameters at a later time, independently
of the installation.

Basic Procedure

To operate an interface, you will require the following:
e Configurations in the operating system
e A suitable interface configuration

If you are using a PC with an MPI card or communications processors (CP), you should check the
interrupt and address assignments in the Windows "Control Panel" to ensure that there are no
interrupt conflicts and no address areas overlap.

In Windows 2000, Windows XP and Server 2003, the ISA component MPI-ISA card is no longer
supported and therefore no longer offered for installation.

In order to make it easier to assign parameters to the programming device/PC interface, a dialog
box will display a selection list of default basic parameter sets (interface configurations).

Assigning Parameters to the PG/PC Interface

Procedure (Detail are found in the Online Help):
1. Double-click on "Setting PG/PC Interface" in the "Control Panel" of Windows.
2. Set the "Access Point of Application" to "S7ONLINE."

3. Inthe list "Interface parameter set used", select the required interface parameter set. If the
required interface parameter set is not displayed, you must first install a module or protocol via
the "Select" button. The interface parameter set is then generated automatically. On
plug-and-play systems, you can not install plug and play CPs manually (CP 5611 and CP
5511). They are integrated automatically in "Setting PG/PC Interface" after you have installed
the hardware in your PG/PC.

- If you select an interface which is capable of automatic recognition of bus parameters
(for example, CP 5611 (Auto)), you can connect the programming device or the PC to the
MPI or PROFIBUS without having to set bus parameters. If the transmission rate is < 187.5
Kbps, there may be a delay of up to one minute while the bus parameters are read.
Requirement for automatic recognition: Masters who broadcast bus parameters
cyclically are connected to the bus. All new MPI components do this; for PROFIBUS
subnets the cyclic broadcast of bus parameters must be enabled (default PROFIBUS
network setting).

4. |If you select an interface which does not automatically recognize the bus parameters, you
can display the properties and adapt them to match the subnet.
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Changes will also be necessary if conflicts with other settings arise (for example, interrupt or
address assignments). In this case, make the appropriate changes with the hardware recognition
and Control Panel in Windows (see below).

A Caution

Do not remove any "TCP/IP" parameters from your interface configuration.

This could cause malfunctioning of other applications.

Checking the Interrupt and Address Assignments

If you use a PC with an MPI card, you should always check whether the default interrupt and the
default address area are free.
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2.3 Uninstalling STEP 7

Uninstalling STEP 7

Use the standard Windows method to uninstall STEP 7:

1. Double-click on the "Add/Remove Programs" icon in the "Control Panel." to start the Windows
software installation dialog box.

2. Selectthe STEP 7 entry in the displayed list of installed software. Click the button to
"Add/Remove" the software.

3. If the "Remove Shared File" dialog box appears, click the "No" button if you are uncertain.

User Rights

User Rights in MS Windows XP/Server 2003

Note the following points relating to user rights:
To be able to work with STEP 7, you must log in at least as a user (no guest login).

To install the STEP 7 software and HSPs, set up modules and change settings with the "Set
PG/PC Interface" application, you require administrator privileges.

To use optional packages, check which rights are required for the specific optional package.

If projects are stored on NTFS drives, users must also be allowed full access here. This also
applies to the folder with the HSP updates (default: C\HWUPDATES). Access within the default
project directory S7TPROJ is enabled automatically for all users.

Note

Working with user rights is enabled only for STEP 7 itself. There is no guarantee that user rights
are adequate for optional packages. Here, administrator or power user rights may be necessary.

After installing / uninstalling new hardware, the computer must be started up at least once with
administrator privileges.
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2.4.2 User Rights in MS Windows 7

Specifying Access Rights in the Operating System

When you install STEP 7 in MS Windows 7, the user group "Siemens TIA Engineer" is created
automatically. This allows the users entered there to configure the PG/PC interface and to install
selected Hardware Support Packages. To allow manual IP configuration (for PROFINET without
DHCP), the user must also be included in the "Network Configuration Operators" group that is
preinstalled by the operating system.

These rights can only be assigned to the user by the administrator.

Including users in the user groups "Siemens TIA Engineer" and "Network Configuration
Operators”

Enter the local users who can access STEP 7 with their login in the "Siemens TIA Engineer" group.
Follow the steps below:

1. Open the Control Panel in Windows and select "User Accounts".

2. Inthe navigation window, select the entry "Manage User Accounts."

3. Inthe "Advanced" tab, select the "Advanced" entry in the "Advanced User Management"
section.

4. In the navigation window, select the entry "Local Users and Groups > Users". All users are
displayed in the data window.

5. Using the context menu, open the "New User" and create an account with the same login for
every user that needs to access STEP 7.

6. Select the "Properties” context menu command for each user you create.
7. Inthe dialog box that opens, select the "Member of* and the click the "Add..." button.

8. Inthe "Select Groups" dialog, enter the user group "Siemens TIA Engineer" in the "Enter the
object names to select" box and confirm with "OK".

9. Follow the same procedure for the users to be included in the "Network Configuration
Operators" user group.
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Creating the global domain user group "Siemens TIA Engineer"

When working in a domain, you have the alternative of creating a global domain user group that is
then mapped to the local user groups "Siemens TIA Engineer" and "Network Configuration
Operators".

The following requirements must be met first:
e The domain administrator has created a global domain user group.

e The domain administrator has included the users with whose login STEP 7 can be accessed in
the global domain user group.
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3 Working Out the Automation Concept

3.1 Basic Procedure for Planning an Automation Project

This chapter outlines the basic tasks involved in planning an automation project for a
programmable controller (PLC). Based on an example of automating an industrial blending
process, you are guided step by step through the procedure.

There are many ways of planning an automation project. The basic procedure that you can use for
any project is illustrated in the following figure.

Divide the process into tazks.

¥

Dezcribe the individual areas.

¥

Define the safety requirements.

¥

Dezeribe the required operator dizplav: and controls.

¥

Create configuration diagrams of wour programmable controller.
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3.2 Dividing the Process into Tasks and Areas

An automation process consists of a number of individual tasks. By identifying groups of related
tasks within a process and then breaking these groups down into smaller tasks, even the most
complex process can be defined.

The following example of an industrial blending process can be used to illustrate how to organize a
process into functional areas and individual tasks:

Example: Industrial Blending Process

Agtator maotar
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Inlet Feed Feed F lomae
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Ingredient B
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Determining the Areas of a Process

After defining the process to be controlled, divide the project into related groups or areas:

Inlet Feed Feed F It

kA

Swvitch for tanlk !
leniel measzuring:

[
______________ J
A r=1--r-------- Sl i
Inlet Feed Feed ! Arear drain I
walve purnp  wahe I i
1
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AN g !
| Drain valve :

As each group is divided into smaller tasks, the tasks required for controlling that part of the
process become less complicated.

In our example of an industrial blending process you can identify four distinct areas (see table
below). In this example, the area for ingredient A contains the same equipment as the area for

ingredient B.

Functional Area Equipment Used

Ingredient A Feed pump for ingredient A
Inlet valve for ingredient A
Feed valve for ingredient A
Flow sensor for ingredient A

Ingredient B Feed pump for ingredient B
Inlet valve for ingredient B
Feed valve for ingredient B
Flow sensor for ingredient B

Mixing tank Agitator motor
Switch for tank level measurement

Drain Drain valve
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Describing the Individual Functional Areas
As you describe each area and task within your process, you define not only the operation of each
area, but also the various elements that control the area. These include:
e Electrical, mechanical, and logical inputs and outputs for each task

¢ Interlocks and dependencies between the individual tasks

The sample industrial blending process uses pumps, motors, and valves. These must be described

precisely to identify the operating characteristics and type of interlocks required during operation.
The following tables provide examples of the description of the equipment used in an industrial
blending process. When you have completed description, you could also use it to order the
required equipment.

Ingredients A/B: Feed Pump Motors

The feed pump motors convey ingredients A and B to the mixing tank.
e Flow rate: 400 | (100 gallons) per minute
e Rating: 100 kW (134 hp) at 1200 rpm

The pumps are controlled (start/stop) from an operator station located near the mixing tank. The number of
starts is counted for maintenance purposes. Both the counters and the display can be reset with one button.

The following conditions must be satisfied for the pumps to operate:
e  The mixing tank is not full.

e The drain valve of the mixing tank is closed.

e The emergency off is not activated.

The pumps are switched off if the following condition is satisfied:
e The flow sensor signals no flow 7 seconds after the pump motor is started.
e The flow sensor signals that the flow has ceased.

Ingredients A/B: Inlet and Feed Valves

The inlet and feed valves for ingredients A and B allow or prevent the flow of the ingredients into the mixing
tank. The valves have a solenoid with a spring return.

e When the solenoid is activated, the valve is opened.
e When the solenoid is deactivated, the valve is closed.

The inlet and feed valves are controlled by the user program.

For the valves to be activated, the following condition must be satisfied:
e The feed pump motor has been running for at least 1 second.

The pumps are switched off if the following condition is satisfied:
e The flow sensor signals no flow.
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Agitator Motor

The agitator motor mixes ingredient A with ingredient B in the mixing tank.
e Rating: 100 kW (134 hp) at 1200 rpm

The agitator motor is controlled (start/stop) from an operator station located near the mixing tank. The number
of starts is counted for maintenance purposes. Both the counters and the display can be reset with one button.

The following conditions must be satisfied for the pumps to operate:
e The tank level sensor is not signaling "Tank below minimum."
e The drain valve of the mixing tank is closed.

e The emergency off is not activated.

The pumps are switched off if the following condition is satisfied:

e The tachometer does not indicate that the rated speed has been reached within 10 seconds of starting the
motor.

Drain Valve

The drain valve allows the mixture to drain (using gravity feed) to the next stage in the process. The valve has
a solenoid with a spring return.

e If the solenoid is activated, the outlet valve is opened.
e If the solenoid is deactivated, the outlet valve is closed.

The outlet valve is controlled (open/close) from an operator station.

The drain valve can be opened under the following conditions:
e  The agitator motor is off.

e The tank level sensor is not signaling "Tank empty."

e The emergency off is not activated.

The pumps are switched off if the following condition is satisfied:
e The tank level sensor is indicating "Tank empty."

Switches for Tank Level Measurement

The switches in the mixing tank indicate the level in the tank and are used to interlock the feed pumps and the
agitator motor.
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Listing Inputs, Outputs, and In/Outs

After writing a physical description of each device to be controlled, draw diagrams of the inputs and
outputs for each device or task area.

[nput 1
|
|
!
[hput ki
[nfout 1
I

1
[riaut n

Inputi Qutput Diagram

Device

Cutput 1

Outﬁut h

These diagrams correspond to the logic blocks to be programmed.
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3.5 Creating an I/O Diagram for the Motors

Two feed pumps and one agitator are used in our example of an industrial blending process. Each
motor is controlled by its own "motor block" that is the same for all three devices. This block

requires six inputs: two to start or stop the motor, one to reset the maintenance display, one for the

motor response signal (motor running / not running), one for the time during which the response
signal must be received, and one for the number of the timer used to measure the time.

The logic block also requires four outputs: two to indicate the operating state of the motor, one to
indicate faults, and one to indicate that the motor is due for maintenance.

An in/out is also necessary to activate the motor. It is used to control the motor but at the same
time is also edited and modified in the program for the "motor block."

Start

[ Diagram of the "hWotor Block”

Stop
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Creating an 1/0O Diagram for the Valves

Each valve is controlled by its own "valve block" that is the same for all valves used. The logic
block has two inputs: one to open the valve and one to close the valve. It also has two outputs: one
to indicate that the valve is open and the other to indicate that it is closed.

The block has an in/out to activate the valve. It is used to control the valve but at the same time is
also edited and modified in the program for the "valve block."

/0 Diagram of the Walve Block
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3.7 Establishing the Safety Requirements

Decide which additional elements are needed to ensure the safety of the process - based on legal
requirements and corporate health and safety policy. In your description, you should also include
any influences that the safety elements have on your process areas.

Defining Safety Requirements

Find out which devices require hardwired circuits to meet safety requirements. By definition, these
safety circuits operate independently of the programmable controller (although the safety circuit
generally provides an 1/O interface to allow coordination with the user program). Normally, you
configure a matrix to connect every actuator with its own emergency off range. This matrix is the
basis for the circuit diagrams of the safety circuits.

To design safety mechanisms, proceed as follows:

e Determine the logical and mechanical/electrical interlocks between the individual automation
tasks.

e Design circuits to allow the devices belonging to the process to be operated manually in an
emergency.

e Establish any further safety requirements for safe operation of the process.

Creating a Safety Circuit

The sample industrial blending process uses the following logic for its safety circuit:

e One emergency off switch shuts down the following devices independent of the programmable
controller (PLC):

Feed pump for ingredient A
Feed pump for ingredient B
Agitator motor

Valves

e The emergency off switch is located on the operator station.

e Aninput to the controller indicates the state of the emergency off switch.
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3.8 Describing the Required Operator Displays and Controls

Every process requires an operator interface that allows human intervention in the process. Part of
the design specification includes the design of the operator console.

Defining an Operator Console

In the industrial blending process described in our example, each device can be started or stopped
by a pushbutton located on the operator console. This operator console includes indicators to show
the status of the operation (see figure below).

Ingr. A Ingr. B Start O pen
ztart ‘ start ‘ agitator ‘ Tank drain
full
Ikar. A Ingr. B Stop Cloze
stop stop agitator Tank drain
bl rmin.
Fezet
maintenance dizplay
hlaint. M aint. hlaint. Tank
purmp A purmp B agitator ermphy
@ EMERGEMCY STOP

The console also includes display lamps for the devices that require maintenance after a certain
number of starts and the emergency off switch with which the process can be stopped immediately.
The console also has a reset button for the maintenance display of the three motors. Using this,
you can turn off the maintenance display lamps for the motors due for maintenance and reset the
corresponding counters to 0.
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3.9 Creating a Configuration Diagram
After you have documented the design requirements, you must then decide on the type of control
equipment required for the project.

By deciding which modules you want to use, you also specify the structure of the programmable
controller. Create a configuration diagram specifying the following aspects:

e Type of CPU
e Number and type of I/O modules
e Configuration of the physical inputs and outputs

The following figure illustrates an example of an S7 configuration for the industrial blending
process.
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4.1 Programs in a CPU

A CPU will principally run two different programs:
e The operating system and

e The user program.

Operating System

Every CPU comes with an integrated operating system that organizes all CPU functions and
sequences not associated with a specific control task. The tasks of the operating system include
the following:

e Handling restart (warm start) and hot restart

e Update of the process image table of the inputs and output of the process image table of the
outputs

e Calling the user program

e Acquisition of interrupt information and calling interrupt OBs

e Recognition of errors and error handling

¢ Management of the memory areas

e Communication with programming devices and other communication partners

You can influence CPU reactions in certain areas by modifying the operating system parameters
(operating system default settings).

User Program

You create the user program and download it to the CPU. It contains all the functions required to
process your specific automation task. The tasks of the user program include:

e Specifying the conditions for a restart (warm start) and hot restart on the CPU (for example,
initializing signals with a particular value)

e Processing process data (for example, generating logical links of binary signals, fetching and
evaluating analog signals, specifying binary signals for output, output of analog values)

e Reaction to interrupts

e Handling disturbances in the normal program cycle.
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4.2 Blocks in the User Program

Blocks in the User Program

The STEP 7 programming software allows you to structure your user program, in other words to
break down the program into individual, self-contained program sections. This has the following

e Extensive programs are easier to understand.

¢ Individual program sections can be standardized.

e ltis easier to make modifications to the program.

e Debugging is simplified since you can test separate sections.

e Commissioning your system is made much easier.

The example of an industrial blending process illustrated the advantages of breaking down an
automation process into individual tasks. The program sections of a structured user program
correspond to these individual tasks and are known as the blocks of a program.

4.2

advantages:

e Program organization is simplified.
Block Types

72

There are several different types of blocks you can use within an S7 user program:

Block

Brief Description of Function

See Also

Organization blocks (OB)

OBs determine the structure of the user
program.

Organization Blocks and
Program Structure

System function blocks (SFB)
and system functions (SFC)

SFBs and SFCs are integrated in the S7 CPU
and allow you access to some important system
functions.

System Function Blocks
(SFB) and System
Functions (SFC)

Function blocks (FB)

FBs are blocks with a "memory" which you can
program yourself.

Function Blocks (FB)

Functions (FC)

FCs contain program routines for frequently
used functions.

Functions (FC)

Instance data blocks
(instance DB)

Instance DBs are associated with the block
when an FB/SFB is called. They are created
automatically during compilation.

Instance Data Blocks

Data blocks (DB)

DBs are data areas for storing user data. In
addition to the data that are assigned to a
function block, shared data can also be defined
and used by any blocks.

Shared Data Blocks (DB)

OBs, FBs, SFBs, FCs, and SFCs contain sections of the program and are therefore also known as
logic blocks. The permitted number of blocks per block type and the permitted length of the blocks

is CPU-specific.
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4.2.1 Organization Blocks and Program Structure

4.2 Blocks in the User Program

Organization blocks (OBs) represent the interface between the operating system and the user
program. Called by the operating system, they control cyclic and interrupt-driven program
execution, startup behavior of the PLC and error handling. You can program the organization

blocks to determine CPU behavior.

Organization Block Prio

rity

Organization blocks determine the sequence (start events) by which individual program sections
are executed. An OB call can interrupt the execution of another OB. Which OB is allowed to
interrupt another OB depends on its priority. Higher priority OBs can interrupt lower priority OBs.

The background OB has the lowest priority.

Types of Interrupt and Priority Classes

Start events triggering an OB call are known as interrupts. The following table shows the types of
interrupt in STEP 7 and the priority of the organization blocks assigned to them. Not all
organization blocks listed and their priority classes are available in all S7 CPUs (see "S7-300
Programmable Controller, Hardware and Installation Manual" and "S7-400, M7-400 Programmable
Controllers Module Specifications Reference Manual”).

Type of Interrupt | Organization Block Priority Class See also
(Default)

Main program OB1 1 Organization Block for Cyclic Program
scan Processing (OB1)
Time-of-day OB10to OB17 2 Time-of-Day Interrupt Organization
interrupts Blocks (OB10 to OB17)
Time-delay 0OB20 3 Time-Delay Interrupt Organization
interrupts OB21 4 Blocks (OB20 to OB23)

0oB22 5

0B23 6
Cyclic interrupts | OB30 7 Cyclic Interrupt Organization Blocks

0OB31 8 (OB30 to OB38)

0oB32 9

OB33 10

OB34 11

OB35 12

OB36 13

oB37 14

OB38 15
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OB82 Diagnostic Interrupt

OB83 Insert/Remove Module
Interrupt

0B84 CPU Hardware Fault
OB 85 Program Cycle Error
OB86 Rack Failure

OB87 Communication Error

asynchronous error
OB exists in the
startup program)

Type of Interrupt | Organization Block Priority Class See also
(Default)

Hardware OB40 16 Hardware Interrupt Organization
interrupts 0OB41 17 Blocks (OB40 to OB47)

0B42 18

OB43 19

OB44 20

0OB45 21

OB46 22

0oB47 23
DPV1 interrupts | OB 55 2 Programming DPV1 Devices

OB 56 2

OB 57 2
Multicomputing OB60 Multicomputing 25 Multicomputing - Synchronous
interrupt Operation of Several CPUs
Synchronous OB 61 25 Configuring Short and Equal-Length
cycle interrupt OB 62 Process Reaction Times on

OB 63 PROFIBUS-DP

OB 64
Redundancy OB70 I/0 Redundancy Error 25 "Error Handling Organization Blocks
errors (only in H systems) (OB70 to OB87 / OB121 to OB122)"

OB72 CPU Redundancy Error | 28

(only in H systems)
Asynchronous OB80 Time Error 25 Error Handling Organization Blocks
errors OB81 Power Supply Error (or 28 if the (OB70 to OB87 / OB121 to OB122)

0OB102 Cold Restart

Background cycle | OB90 29 Y Background Organization Block
(OB90)
Startup OB100 Restart 27 Startup Organization Blocks
(Warm start) 27 (OB100/0B101/0B102)
OB101 Hot Restart 27
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Type of Interrupt | Organization Block Priority Class See also
yp p 9 y
(Default)

Synchronous OB121 Programming Error Priority of the OB Error Handling Organization Blocks
errors OB122 Access Error that caused the (OB70 to OB87 / OB121 to OB122)
error
Y The priority class 29 corresponds to priority 0.29. The background cycle has a lower priority than the free

cycle.

Programming with STEP 7
Manual, 05/2010, A5E02789666-01 75



Basics of Designing a Program Structure

4.2 Blocks in the User Program

Changing the Priority

Interrupts can be assigned parameters with STEP 7. With the parameter assignment you can for
example, deselect interrupt OBs or priority classes in the parameter blocks: time-of-day interrupts,
time-delay interrupts, cyclic interrupts, and hardware interrupts.

The priority of organization blocks on S7-300 CPUs is fixed.

With S7-400 CPUs (and the CPU 318) you can change the priority of the following organization
blocks with STEP 7:

e OB10to OB47

e OB70to OB72 (only H CPUs) and OB81 to OB87 in RUN mode.
The following priority classes are permitted:

e Priority classes 2 to 23 for OB10 to OB47

e Priority classes 2 to 28 for OB70 to OB72

e Priority classes 24 to 26 for OB81 to OB87; for CPUs as of approx. The middle of 2001
(Firmware Version 3.0) the ranges where extended: Priority classes 2 to 26 can be set for OB
81 to OB 84 as well as for OB 86 and OB 87.

You can assign the same priority to several OBs. OBs with the same priority are processed in the
order in which their start events occur.

Error OBs started by synchronous errors are executed in the same priority class as the block being
executed when the error occurred.

Local Data

When creating logic blocks (OBs, FCs, FBs), you can declare temporary local data. The local data
area on the CPU is divided among the priority classes.

On S7-400, you can change the amount of local data per priority class in the "priority classes"
parameter block using STEP 7.

Start Information of an OB

Every organization block has start information of 20 bytes of local data that the operating system
supplies when an OB is started. The start information specifies the start event of the OB, the date
and time of the OB start, errors that have occurred, and diagnostic events.

For example, OB40, a hardware interrupt OB, contains the address of the module that generated
the interrupt in its start information.
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Deselected Interrupt OBs

If you assign priority class O or assign less than 20 bytes of local data to a priority class, the
corresponding interrupt OB is deselected. The handling of deselected interrupt OBs is restricted as
follows:

¢ In RUN mode, they cannot be copied or linked into your user program.

e In STOP mode, they can be copied or linked into your user program, but when the CPU goes
through a restart (warm start) they stop the startup and an entry is made in the diagnostic
buffer.

By deselecting interrupt OBs that you do not require, you increase the amount of local data area
available, and this can be used to save temporary data in other priority classes.

Cyclic Program Processing

Cyclic program processing is the "normal” type of program execution on programmable logic
controllers, meaning the operating system runs in a program loop (the cycle) and calls the
organization block OB1 once in every loop in the main program. The user program in OB1 is
therefore executed cyclically.

Operating system  User program
—- [ .
Cwcle main
program
-— ~—
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Event-Driven Program Processing

Cyclic program processing can be interrupted by certain events (interrupts). If such an event
occurs, the block currently being executed is interrupted at a command boundary and a different
organization block that is assigned to the particular event is called. Once the organization block has
been executed, the cyclic program is resumed at the point at which it was interrupted.

Qperating syztem lser program
* / Starup
— \ prograr

l hlain

— . —— |
prograrm
o / [mterrupt
Irterrupte| =i B ragrarm
ruption | Preo
rier- (| e
rro - ruption \ handlung
— e f— -q—l

This means it is possible to process parts of the user program that do not have to be processed
cyclically only when needed. The user program can be divided up into "subroutines" and distributed
among different organization blocks. If the user program is to react to an important signal that
occurs relatively seldom (for example, a limit value sensor for measuring the level in a tank reports
that the maximum level has been reached), the subroutine that is to be processed when the signal
is output can be located in an OB whose processing is event-driven.
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Linear Versus Structured Programming

You can write your entire user program in OB1 (linear programming). This is only advisable with
simple programs written for the S7-300 CPU and requiring little memory.

Complex automation tasks can be controlled more easily by dividing them into smaller tasks
reflecting the technological functions of the process or that can be used more than once. These
tasks are represented by corresponding program sections, known as the blocks (structured
programming).

Linear programming Structured programming
hain progranm hdain progran
=0E1
2B

FE 1

FCA

A A

Programming with STEP 7
Manual, 05/2010, ASE02789666-01 79



Basics of Designing a Program Structure

4.2 Blocks in the User Program

4.2.2 Call Hierarchy in the User Program

For the user program to function, the blocks that make up the user program must be called. This is
done using special STEP 7 instructions, the block calls, that can only be programmed and started
in logic blocks.

Order and Nesting Depth

The order and nesting of the block calls is known as the call hierarchy. The number of blocks that
can be nested (the nesting depth) depends on the particular CPU.

The following figure illustrates the order and nesting depth of the block calls within a scan cycle.

Start of |— Nesting depth —|
cyde - - 1
FE 1 FC 1
OB 1
= ‘q
% InFance DE 1
ED - — e -
B FE 2 FE 1 3F G
i | |
& [Instance DB 2| [Ingance DE 1
- DE
FC1
-

There is a set order for creating blocks:
e You create the blocks from top to bottom, so you start with the top row of blocks.

e Every block that is called must already exist, meaning that within a row of blocks the order for
creating them is from right to left.

e The last block to be created is OB1.

Putting these rules into practice for the example in the figure produces the following sequence for
creating the blocks:

FC1 > FB1 + instance DB1 > DB1 > SFC1 > FB2 + instance DB2 > OB1

Note

If the nesting is too deep (too many levels), the local data stack may overflow (Also refer to Local Data
Stack).
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Block Calls

The following figure shows the sequence of a block call within a user program. The program calls
the second block whose instructions are then executed completely. Once the second or called
block has been executed, execution of the interrupted block that made the call is resumed at the
instruction following the block call.

Calling hlock Called block
(OB, FB, FC) . FE, FC, SFB or SFC)
Frogram
execution
Frogram
Instruction that calls execution
another block

/Vl/i ' Elack end

Before you program a block, you must specify which data will be used by your program, in other
words, you must declare the variables of the block.

Note
OUT parameters must be described for each block call.

Note

The operating system resets the instances of SFB3 "TP" when a cold restart is performed. If you want
to initialize instances of this SFB after a cold restart, you must call up the relevant instances of the
SFB with PT = 0 ms via OB100. You can do this, for example, by performing an initialization routine in
the blocks which contain instances of the SFB.
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4.2.3 Block Types

4.2.3.1 Organization Block for Cyclic Program Processing (OB1)

Cyclic program processing is the "normal" type of program execution on programmable logic
controllers. The operating system calls OB1 cyclically and with this call it starts cyclic execution of
the user program.

Sequence of Cyclic Program Processing

The following table shows the phases of cyclic program processing:

Step Sequence in CPUs to 10/98 Sequence in CPUs from 10/98

1 The operating system starts the cycle monitoring | The operating system starts the cycle monitoring
time. time.

2 The CPU reads the state of the inputs of the The CPU writes the values from the process
input modules and updates the process image image table of the outputs to the output modules.
table of the inputs.

3 The CPU processes the user program and The CPU reads the state of the inputs of the
executes the instructions contained in the input modules and updates the process image
program. table of the inputs.

4 The CPU writes the values from the process The CPU processes the user program and
image table of the outputs to the output modules. | executes the instructions contained in the

program.

5 At the end of a cycle, the operating system At the end of a cycle, the operating system
executes any tasks that are pending, for example | executes any tasks that are pending, for example
downloading and deleting blocks, receiving and | downloading and deleting blocks, receiving and
sending global data. sending global data.

6 Finally, the CPU returns to the start of the cycle | Finally, the CPU returns to the start of the cycle
and restarts the cycle monitoring time. and restarts the cycle monitoring time.

Process Images

So that the CPU has a consistent image of the process signals during cyclic program processing,
the CPU does not address the input (I) and output (Q) address areas directly on the I1/0O modules

but rather accesses an internal memory area of the CPU that contains an image of the inputs and
outputs.

Programming Cyclic Program Processing

You program cyclic program processing by writing your user program in OB1 and in the blocks
called within OB1 using STEP 7.

Cyclic program processing begins as soon as the startup program is completed without errors.
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Cyclic program processing can be interrupted by the following:

An interrupt

A STOP command (mode selector, menu option on the programming device, SFC46 STP,
SFB20 STOP)

A power outage

The occurrence of a fault or program error

Scan Cycle Time

The scan cycle time is the time required by the operating system to run the cyclic program and all
the program sections that interrupt the cycle (for example, executing other organization blocks) and
system activities (for example, updating the process image). This time is monitored.

The scan cycle time (TC) is not the same in every cycle. The following figures show different scan
cycle times (TC1 = TC2) for CPUs up to 10/98 and CPUs from 10/98:

Different Scan Cyele Times for CPUs to 10053
Current Cyicle Mext Cycle Mext Cycle
T Tz
QB0
Updates Updates Updates Updates: pdates
process DB } €OB1 process pIDCESS Q81| process prOCESS OEH'!
imageinput image output | image input image output | _image input r
Different Scan Cyele Times for CPUs from 100538
Current Cycle Mext Cyele Mext Cyele
T Tz
IDE10
pdates pdates Updates Updates Lpdates Upda
process process OB OE| process process OB1| pmocess proc
image output | image irput image output | imageinpot image output foutp

In

the current cycle, OBL1 is interrupted by a time-of-day interrupt.
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Cycle Monitoring Time

With STEP 7, you can modify the default maximum cycle monitoring time. If this time expires, the
CPU either changes to STOP mode or OB80 is called in which you can specify how the CPU
should react to this error.

Minimum Cycle Time

With STEP 7, you can set a minimum cycle time for S7-400 CPUs and the CPU 318. This is useful
in the following situations:

e When the interval at which program execution starts in OB1 (main program scan) should
always be the same or

e When the process image tables would be updated unnecessarily often if the cycle time is too
short.

The following figures show the function of the cycle monitoring time in program processing in CPUs
up to 10/98 and in CPUs from 10/98.

Cyile Monitoring Time for CPU s to 1052

PG

pCo?

P

Current cycle Mlext cycle
. Trriax . I
- Feserve }

Trriiry . I
» T Cl Tovait N

OBAD
IDE1] B0
Opdating of the Updating of the Updating ofths
process image [J61 DB1| process image process image (OB
inpLt table output table input table
JBEI§ DESO :'BEIT

PCA

_[rlgin

FC

Tmax = Maximum cyele time that can be set
= Minimumm cycle time that can be set
= Actual zean cvele time
Twvait = Difference between Tmin and actual scan cycle time. |n thiz tirme, occurred interrupts and

the background OB can be procreszed

= Priority clasz
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Cwele Monitoring Time for CPUs from 10/93

Current cycle Mext cycle
|
. Trmax N
- Feserve |
Trrir L :
» TC e Toait L
PCAE
B0
PCoy B0 IDE10
Updaing ofthe | Updating of the Updating ofthe | Jpd
piocessimage |processimage (D61 OB processimage |p
output table input table output table oLt
PO
)BEI§ JBEI? DBEI?

PC29
Trrax = Mazirmurm cycle time that can be set
%ﬂin =Mdinirmuim cycle tirme that can be set
[ = Actual zcan cycle time
Twait = Difference between Tmin and actual scan cycle time. |n thiz tirme, occurred interrupts and

the background OB can be procressed
PC  =Priority class

Updating the Process Image
During cyclic program processing by the CPU, the process image is updated automatically. With
the S7-400 CPUs and the CPU 318 you can deselect the update of the process image if you want
to:

e Access the I/O directly instead or

e Update one or more process image input or output sections at a different point in the program
using system functions SFC26 UPDAT_PI and SFC27 UPDAT_PO.

Communication Load

You can use the CPU parameter "Scan Cycle Load from Communication" to control within a given
framework the duration of communication processes that always increase the scan cycle time.
Examples of communication processes include transmitting data to another CPU by means of MPI

or loading blocks by means of a programming device.

Test functions with a programming device are barely influenced by this parameter. However, you
can increase the scan cycle time considerably. In the process mode, you can limit the time set for
test functions (S7-300 only).
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How the Parameter works

The operating system of the CPU constantly provides the communication with the configured
percent of the entire CPU processing capacity (time slice technique). If this processing capacity is
not needed for the communication, it is available to the rest of the processing.

Effect on the Actual Scan Cycle Time

Without additional asynchronous events, the OB1 scan cycle time is extended by a factor that can
be calculated according to the following formula:

100

100 - "Scan cycle load from communication (%)"

Example 1 (no additional asynchronous events):

When you set the load added to the cycle by communication to 50%, the OB1 scan cycle time can
be doubled.

At the same time, the OB1 scan cycle time is also influenced by asynchronous events (such as
hardware interrupts or cyclic interrupts). From a statistical point of view, even more asynchronous
events occur within an OB1 scan cycle because of the extension of the scan cycle time by the
communication portion. This causes an additional increase in the OB1 scan cycle. This increase
depends on how many events occur per OB1 scan cycle and on the duration of event processing.

Example 2 (additional asynchronous events considered):

For a pure OB1 execution time of 500 ms, a communication load of 50% can result in an actual
scan cycle time of up to 1000 ms (provided that the CPU always has enough communication jobs
to process). If, parallel to this, a cyclic interrupt with 20 ms processing time is executed every 100
ms, this cyclic interrupt would extend the scan cycle by a total of 520 ms = 100 ms without
communication load. That is, the actual scan cycle time would be 600 ms. Because a cyclic
interrupt also interrupts communication, it affects the scan cycle time by 10 * 20 ms with 50%
communication load. That is, in this case, the actual scan cycle time amounts to 1200 ms instead
of 1000 ms.

Note

Check the effects of changing the value of the "Scan Cycle Load from Communication" parameter
while the system is running.

The communication load must be taken into account when setting the minimum scan cycle time;
otherwise time errors will occur.
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Recommendations
e Where possible, apply the default value.

¢ Increase this value only if you are using the CPU primarily for communication purposes and
your user program is not time critical.

e In all other cases, only reduce the value.

e Set the process mode (S7-300 only), and limit the time needed there for test functions.
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4.2.3.2 Functions (FC)
Functions (FCs) belong to the blocks that you program yourself. A function is a logic block "without
memory." Temporary variables belonging to the FC are saved in the local data stack. This data is
then lost when the FC has been executed. To save data permanently, functions can also use
shared data blocks.
Since an FC does not have any memory of its own, you must always specify actual parameters for
it. You cannot assign initial values for the local data of an FC.

Application

An FC contains a program section that is always executed when the FC is called by a different
logic block. You can use functions for the following purposes:

e To return a function value to the calling block (example: math functions)

e To execute a technological function (example: single control function with a bit logic operation).

Assigning Actual Parameters to the Formal Parameters

A formal parameter is a dummy for the "actual” parameter. Actual parameters replace the formal
parameters when the function is called. You must always assign actual parameters to the formal
parameters of an FC (for example, an actual parameter "I 3.6" to the formal parameter "Start"). The
input, output and in/out parameters used by the FC are saved as pointers to the actual parameters
of the logic block that called the FC.

Important Differences Between the Output Parameters of FCs and FBs

88

In function blocks (FB), a copy of the actual parameters in the instance DB is used when accessing
the parameters. If an input parameter is not transferred or an output parameter is not write
accessed when a FB is called, the older values still stored in the instance DB /Instance DB =
memory of the FBs) will be used.

Functions (FC) have no memory. Contrary to FBs, the assignment of formal parameters to these
FCs is therefore not optional, but rather essentially. FC parameters are accessed via addresses
(pointers to targets across area boundaries). When an address of the data area (data block) or a
local variable of the calling block is used as actual parameter, a copy of the actual parameter is
saved temporarily to local data area of the calling block for the transfer of the parameter.

Caution

In this case, if no data are written to an OUTPUT parameter in an FC, the block may output random
values!

As the calling block's local data area which is reserved for the copy is not assigned to the OUTPUT
parameter, no data will be written to this area. It will therefore remain unchanged and the random
value stored at this location will be output, because local data are not automatically set to "0" by
default, for example.
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Thus, observe the following points:
e If possible, initialize the OUTPUT parameters.

e Set and reset instructions depend on RLO. When these instructions are used to determine the
value at an OUTPUT parameter, no value is generated if the result of a previous logic
operation (RLO) = 0.

e Always ensure that data are written to the OUTPUT parameters - irrespective of any program
paths in the block. Pay special attention to jump instructions, to the ENO output in LAD and
FBD as well as to BEC (Block End Conditional) and the influence of MCR (Master Control
Relay) instructions.

Note

Although the OUTPUT parameters of an FB or the INOUT parameters of an FC and FB will not output
random values (the old output value - or input value as output value - is going to be maintained even if
no data are written to the parameter) you should still observe the points above in order to avoid
unintentional processing of "old" values.
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4.2.3.3 Function Blocks (FB)

Function blocks (FBs) belong to the blocks that you program yourself. A function block is a block
"with memory." It is assigned a data block as its memory (instance data block). The parameters
that are transferred to the FB and the static variables are saved in the instance DB. Temporary
variables are saved in the local data stack.

Data saved in the instance DB are not lost when execution of the FB is complete. Data saved in the
local data stack are, however, lost when execution of the FB is completed.

Note

To avoid errors when working with FBs, read Permitted Data Types when Transferring Parameters in
the Appendix.

Application

An FB contains a program that is always executed when the FB is called by a different logic block.
Function blocks make it much easier to program frequently occurring, complex functions.

Function Blocks and Instance Data Blocks
An instance data block is assigned to every function block call that transfers parameters.

By calling more than one instance of an FB, you can control more than one device with one FB. An
FB for a motor type, can, for example, control various motors by using a different set of instance
data for each different motor. The data for each motor (for example, speed, ramping, accumulated
operating time etc.) can be saved in one or more instance DBs.

The following figure shows the formal parameters of an FB that uses the actual parameters saved
in the instance DB.

Farmal parameter Actual pararmeter
Irteger (16 Bits): start
Start IMT 1M - ger { :
Speed IMT M —f Integer {16 Bits), speed
History DT IM_OUT
Run_Tirme TME IN_OUT ™9 ] Date and time (45 Bits):
- pointerto the address of the histaony
/I,/\ Time (32 Bits): run time

FB20:hotor DBE202 hotor_2
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Variables of the Data Type FB

If your user program is structured so that an FB contains calls for further already existing function
blocks, you can include the FBs to be called as static variables of the data type FB in the variable
declaration table of the calling FB. This technique allows you to nest variables and concentrate the
instance data in one instance data block (multiple instance).

Assigning Actual Parameters to the Formal Parameters

It is not generally necessary in STEP 7 to assign actual parameters to the formal parameters of an
FB. There are, however, exceptions to this. Actual parameters must be assigned in the following
situations:

e For an infout parameter of a complex data type (for example, STRING, ARRAY or
DATE_AND_TIME)

e For all parameter types (for example TIMER, COUNTER, or POINTER)
STEP 7 assigns the actual parameters to the formal parameters of an FB as follows:

e When you specify actual parameters in the call statement: the instructions of the FB use the
actual parameters provided.

e When you do not specify actual parameters in the call statement: the instructions of the FB use
the value saved in the instance DB.

The following table shows which variables of the FB must be assigned actual parameters.

Data Type
Variable Elementary Data Type Complex Data Type Parameter Type
Input No parameter required No parameter required Actual parameter required
Output No parameter required No parameter required Actual parameter required
In/out No parameter required Actual parameter required —
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Assigning Initial Values to Formal Parameters

92

You can assign initial values to the formal parameters in the declaration section of the FB. These
values are written into the instance DB associated with the FB.

If you do not assign actual parameters to the formal parameters in the call statement, STEP 7 uses
the values saved in the instance DB. These values can also be the initial values that were entered

in the variable declaration table of an FB.

The following table shows which variables can be assigned an initial value. Since the temporary
data are lost after the block has been executed, you cannot assign any values to them.

Data Type
Variable Elementary Data Type Complex Data Type Parameter Type
Input Initial value permitted Initial value permitted -
Output Initial value permitted Initial value permitted —
In/out Initial value permitted - -
Static Initial value permitted Initial value permitted —
Temporary - - -
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4234 Instance Data Blocks

An instance data block is assigned to every function block call that transfers parameters. The
actual parameters and the static data of the FB are saved in the instance DB. The variables
declared in the FB determine the structure of the instance data block. Instance means a function
block call. If, for example, a function block is called five times in the S7 user program, there are five
instances of this block.

Creating an Instance DB

Before you create an instance data block, the corresponding FB must already exist. You specify
the number of the FB when you create the instance data block.

One Instance DB for Each Separate Instance

If you assign several instance data blocks to a function block (FB) that controls a motor, you can
use this FB to control different motors.

The data for each specific motor (for example, speed, run-up time, total operating time) are saved
in different data blocks. The DB associated with the FB when it is called determines which motor is
controlled. With this technique, only one function block is necessary for several motors (see the
following figure).

Call FBEZ,DBEZ201 uzes

DB Motor_1 data for motor 1

Call FEZ2,DB202 uzes

FEZZ2Motars DE0ZMotor 2 | Jote far matar 2

) Call FBZ2Z,DBZ202 uzes
DIEZYER TS data for matar 3
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4.2 Blocks in the User Program

One Instance DB for Several Instances of an FB (Multiple Instances)

You can also transfer the instance data for several motors at the same time in one instance DB. To
do this, you must program the calls for the motor controllers in a further FB and declare static

FB.

variables with the data type FB for the individual instances in the declaration section of the calling

If you use one instance DB for several instances of an FB, you save memory and optimize the use

of data blocks.

In the following figure, the calling FB is FB21 "Motor processing," the variables are of data type
FB22, and the instances are identified by Motor_1, Motor_2, and Motor_3.

F B21:Motor processing

“Wariahle declaration:
gtat, Wotar_1, FB 22
gtat, Motar 2, FB 22
gtat, Motor_3, FB 22

Jn--
el

DBE100

Data for hotar_1

Data for hiotor_2

Data forhiotor_3

FBZZ: hotors

Call FB 21 fram a logic block
CALL FBZ1,DB100

transfers data for hdotor_1,
hdotor 2, Motor_3

Call FB 22 framsz FB 21:
CALL Motor_1

CALL Motor_2

CALL Motor_3

In this example, FB22 does not need its own instance data block, since its instance data are saved
in the instance data block of the calling FB.
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One Instance DB for Several Instances of Different FBs (Multiple Instances)

In a function block you can call the instances of other existing FBs. You can assign the instance
data required for this to the instance data block of the calling FB, meaning you do not need any
additional data blocks for the called FBs in this case.

For these multiple instances in one instance data block, you must declare static variables with the
data type of the called function block for each individual instance in the declaration section of the
calling function block. The call within the function block does not then require an instance data
block, only the symbolic name of the variable.

In the example in this figure, the assigned instance data are stored in a common instance DB.

FB12:haotor o= L2 Mot or Acrezs anly for FE12, call:
it CALL FE12, DE12

| D1 3:Pump Access only for FEB 13,call:

at, Motor 10, FBE12
at, Pumpe_10, FE13

Drata fior Motor 10

: o
FE13:Pump CALL FE13, DE13
i
. DE14 Accezzfor FE 14, FBE 13 and
5 .‘— i
FB1 & Agitator — FE12, call;
. o aTar agator CALL FE14, DE14
Watiable dedaration: transfers datafor agitatar,

Mator_10 und Pump_10

Call FB 12 from FE 14
CALL Motar 10
Dtafor Pump 10 Call FE 13 from FE 1<
CALL Pumpe_1
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4.2.3.5

Shared Data Blocks (DB)

In contrast to logic blocks, data blocks do not contain STEP 7 instructions. They are used to store
user data, in other words, data blocks contain variable data with which the user program works.
Shared data blocks are used to store user data that can be accessed by all other blocks.

The size of DBs can vary. Refer to the description of your CPU for the maximum possible size.

You can structure shared data blocks in any way to suit your particular requirements.

Shared Data Blocks in the User Program

96

If a logic block (FC, FB, or OB) is called, it can occupy space in the local data area (L stack)
temporarily. In addition to this local data area, a logic block can open a memory area in the form of
a DB. In contrast to the data in the local data area, the data in a DB are not deleted when the DB is
closed, in other words, after the corresponding logic block has been executed.

Each FB, FC, or OB can read the data from a shared DB or write data to a shared DB. This data
remains in the DB after the DB is exited.

A shared DB and an instance DB can be opened at the same time. The following figure shows the
different methods of access to data blocks.
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Shared Access by all
| )= blocks
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4.2.3.6  System Function Blocks (SFB) and System Functions (SFC)

Preprogrammed Blocks

You do not need to program every function yourself. S7 CPUs provide you with preprogrammed
blocks that you can call in your user program.

Further information can be found in the reference help on system blocks and system functions
(Jumps to Language Descriptions and Help on Blocks and System Attributes).

System Function Blocks

A system function block (SFB) is a function block integrated on the S7 CPU. SFBs are part of the
operating system and are not loaded as part of the program. Like FBs, SFBs are blocks "with
memory." You must also create instance data blocks for SFBs and download them to the CPU as
part of the program.

S7 CPUs provide the following SFBs:

For communication via configured connections

For integrated special functions (for example, SFB29 "HS_COUNT" on the CPU 312 IFM and
the CPU 314 IFM).

System Functions

A system function is a preprogrammed function that is integrated on the S7 CPU. You can call the
SFC in your program. SFCs are part of the operating system and are not loaded as part of the
program. Like FCs, SFCs are blocks "without memory."

S7 CPUs provide SFCs for the following functions:

Copying and block functions

Checking the program

Handling the clock and run-time meters

Transferring data sets

Transferring events from a CPU to all other CPUs in multicomputing mode
Handling time-of-day and time-delay interrupts

Handling synchronous errors, interrupts, and asynchronous errors
Information on static and dynamic system data, for example, diagnostics
Process image updating and bit field processing

Addressing modules

Distributed I/O

Global data communication

Communication via non-configured connections

Generating block-related messages
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Additional Information

For more detailed information about SFBs and SFCs, refer to the "System Software for S7-300 and
S7-400, System and Standard Functions" Reference Manual. The "S7-300 Programmable
Controller, Hardware and Installation Manual" and "S7-400, M7-400 Programmable Controllers
Module Specifications Reference Manual" explain which SFBs and SFCs are available.
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4.2.4 Organization Blocks for Interrupt-Driven Program Processing

By providing interrupt OBs, the S7 CPUs allow the following:

e Program sections can be executed at certain times or intervals (time-driven)

e Your program can react to external signals from the process.

The cyclic user program does not need to query whether or not interrupt events have occurred. If
an interrupt does occur, the operating system makes sure that the user program in the interrupt OB
is executed so that there is a programmed reaction to the interrupt by the programmable logic

controller.

Interrupt Types and Applications

The following table shows how the different types of interrupt can be used.

Type of Interrupt

Interrupt OBs

Application Examples

Time-of-day interrupt

OB10 to OB17

Calculation of the total flow into a blending process at the end of
a shift

Time-delay interrupt

0OB20 to OB23

Controlling a fan that must continue to run for 20 seconds after a
motor is switched off

Cyclic interrupt

OB30 to OB38

Scanning a signal level for a closed loop control system

Hardware interrupt

0OB40 to OB47

Signaling that the maximum level of a tank has been reached
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Time-of-Day Interrupt Organization Blocks (OB10 to OB17)

The S7 CPUs provide the Time-Of-Day interrupt OBs that can be executed at a specified date or at
certain intervals.

Time-Of-Day interrupts can be triggered as follows:
e Once at a particular time (specified in absolute form with the date)

e Periodically by specifying the start time and the interval at which the interrupt should be
repeated (for example, every minute, every hour, daily).

Rules for Time-of-Day Interrupts

Time-Of-Day interrupts can only be executed when the interrupt has been assigned parameters
and a corresponding organization block exists in the user program. If this is not the case, an error
message is entered in the diagnostic buffer and asynchronous error handling is executed (OB80,
see Error Handling Organization Blocks (OB70 to OB87 / OB121 to OB122)).

Periodic Time-Of-Day interrupts must correspond to a real date. Repeating an OB10 monthly
starting on January 31st is not possible. In this case, the OB would only be started in the months
that actually have 31 days (that is, not in February, April, June, etc.).

A Time-Of-Day interrupt activated during startup (restart (warm restart) or hot restart) is only
executed after the startup is completed.

Time-Of-Day interrupt OBs that are deselected by the parameter assignment cannot be started.
The CPU recognizes a programming error and changes to STOP mode.

Following a restart (warm restart), Time-Of-Day interrupts must be set again (for example, using
SFC30 ACT_TINT in the startup program).

Starting the Time-of-Day Interrupt

To allow the CPU to start a Time-Of-Day interrupt, you must first set and then activate the
Time-Of-Day interrupt. There are three ways of starting the interrupt:

e Automatic start of the Time-Of-Day interrupt by assigning appropriate parameters with STEP 7
(parameter block "Time-Of-Day interrupts")

e Setting and activating the Time-Of-Day interrupt with SFC28 SET_TINT and SFC30 ACT_TINT
from within the user program

e Setting the Time-Of-Day interrupt by assigning parameters with STEP 7 and activating the
Time-Of-Day interrupt with SFC30 ACT_TINT in the user program.

Querying the Time-of-Day Interrupt

100

To query which Time-Of-Day interrupts are set and when they are set to occur, you can do one of
the following:

e Call SFC31 QRY_TINT

e Request the list "interrupt status" of the system status list.
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Deactivating the Time-of-Day Interrupt

You can deactivate Time-Of-Day interrupts that have not yet been executed with SFC29
CAN_TINT. Deactivated Time-Of-Day interrupts can be set again using SFC28 SET_TINT and
activated with SFC30 ACT_TINT.

Priority of the Time-of-Day Interrupt OBs

All eight Time-Of-Day interrupt OBs have the same priority class (2) as default and are therefore
processed in the order in which their start event occurs. You can, however, change the priority
class by selecting suitable parameters.

Changing the Set Time
You can change the Time-Of-Day set for the interrupt as follows:
e A clock master synchronizes the time for masters and slaves.

e SFCO SET_CLK can be called in the user program to set a new time.

Reaction to Changing the Time

The following table shows how Time-Of-Day interrupts react after the time has been changed.

If... Then...
you move the time ahead and one or more OB80 is started and the Time-Of-Day interrupts that
Time-Of-Day interrupts were skipped, were skipped are entered in the start information of
0OB80.
you have not deactivated the skipped Time-Of-Day the skipped Time-Of-Day interrupts are no longer
interrupts in OB80, executed.
you have not deactivated the skipped Time-Of-Day the first skipped Time-Of-Day interrupt is executed, the
interrupts in OB80, other skipped Time-Of-Day interrupts are ignored.
you move the time back, the start events for the the execution of the Time-Of-Day interrupt is repeated
Time-Of-Day interrupts occur again, with S7-300-CPUs
and not
repeated for S7-400-CPUs and CPU 318.
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4.2.4.2

Time-Delay Interrupt Organization Blocks (OB20 to OB23)

The S7 CPUs provide time delay OBs with which you can program the delayed execution of parts
of your user program.

Rules for Time-Delay Interrupts

Time delay interrupts can only be executed when the corresponding organization block exists in the
CPU program. If this is not the case, an error message is entered in the diagnostic buffer and
asynchronous error handling is executed (OB80, see Error Handling Organization Blocks (OB70 to
OB87/0B121 to OB122)).

Time delay interrupt OBs that were deselected by the parameter assignment cannot be started.
The CPU recognizes a programming error and changes to STOP mode.

Time delay interrupts are triggered when the delay time specified in SFC32 SRT_DINT has
expired.

Starting the Time-Delay Interrupt

To start a time delay interrupt, you must specify the delay time in SFC32 after which the
corresponding time delay interrupt OB is called. Refer to the "S7-300 Programmable Controller,
Hardware and Installation Manual" and "S7-400, M7-400 Programmable Controllers Module
Specifications Reference Manual" for the maximum permitted length of the delay time.

Priority of the Time-Delay Interrupt OBs
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The default priority for the time-delay interrupt OBs is priority class 3 to 6. You can assign
parameters to change the priority classes.
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Cyclic Interrupt Organization Blocks (OB30 to OB38)

The S7 CPUs provide cyclic interrupt OBs that interrupt cyclic program processing at certain
intervals.

Cyclic interrupts are triggered at intervals. The time at which the interval starts is the mode
transition from STOP to RUN.

Rules for Cyclic Interrupts

When you specify the intervals, make sure that there is enough time between the start events of
the individual cyclic interrupts for processing the cyclic interrupts themselves.

If you assign parameters to deselect cyclic interrupt OBs, they can no longer be started. The CPU
recognizes a programming error and changes to STOP mode.

Starting the Cyclic Interrupt

To start a cyclic interrupt, you must specify the interval in the cyclic interrupts parameter block
using STEP 7. The interval is always a whole multiple of the basic clock rate of 1 ms.

Interval = n x basic clock rate 1 ms

Each of the nine available cyclic interrupt OBs has a default interval (see the following table). The
default interval becomes effective when the cyclic interrupt OB assigned to it is loaded. You can,
however, assign parameters to change the default values. Refer to your "S7-300 Programmable
Controller, Hardware and Installation Manual" and your "S7-400, M7-400 Programmable
Controllers Module Specifications Reference Manual" for the upper limit.

Phase Offset in Cyclic Interrupts

To avoid cyclic interrupts of different cyclic interrupt OBs being started at the same point and
possibly causing a time error (cycle time exceeded) you can specify a phase offset. The phase
offset ensures that the execution of a cyclic interrupt is delayed by a certain time after the interval
has expired.

Phase offset = m x basic clock rate (where 0 < m < n)

The following figure shows how a cyclic interrupt OB with phase offset (OB37) is executed in
contrast to a cyclic interrupt without phase offset (OB38).
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Priority of the Cyclic Interrupt OBs
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The following table shows the default intervals and priority classes of the cyclic interrupt OBs. You

can assign parameters to change the interval and the priority class.

Cyclic Interrupt OB

Interval in ms

Priority Class

0OB30 5000 7
OB31 2000 8
OB32 1000 9
OB33 500 10
OB34 200 11
OB35 100 12
OB36 50 13
OB37 20 14
OB38 10 15
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Hardware Interrupt Organization Blocks (OB40 to OB47)

The S7 CPUs provide hardware interrupt OBs that react to signals from the modules (for example,
signal modules (SMs), communications processors (CPs), function modules (FMs)). With STEP 7,
you can decide which signal from a configurable digital or analog module starts the OB. With CPs
and FMs, use the appropriate parameter assignment dialogs.

Hardware interrupts are triggered when a signal module with hardware interrupt capability and with
an enabled hardware interrupt passes on a received process signal to the CPU or when a function
module of the CPU signals an interrupt.

Rules for Hardware Interrupts

Hardware interrupts can only be executed when the corresponding organization block exists in the
CPU program. If this is not the case, an error message is entered in the diagnostic buffer and
asynchronous error handling is executed (OB80, see Error Handling Organization Blocks (OB70 to
OB87/0B121 to OB122)).

If you have deselected hardware interrupt OBs in the parameter assignment, these cannot be
started. The CPU recognizes a programming error and changes to STOP mode.

Assigning Parameters to Signal Modules with Hardware Interrupt Capability

Each channel of a signal module with hardware interrupt capability can trigger a hardware interrupt.
For this reason, you must specify the following in the parameter sets of signal modules with
hardware interrupt capability using STEP 7:

e What will trigger a hardware interrupt.

e Which hardware interrupt OB will be executed (the default for executing all hardware interrupts
is OB40).

Using STEP 7, you activate the generation of hardware interrupts on the function blocks. You
assign the remaining parameters in the parameter assignment dialogs of these function modules.

Priority of the Hardware Interrupt OBs

The default priority for the hardware interrupt OBs is priority class 16 to 23. You can assign
parameters to change the priority classes.
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Startup Organization Blocks (OB100/OB101/ OB102)

Startup Types

There are three distinct types of startup:

e Hot restart (not in S7-300 and S7-400H)
e Restart (warm restart)

e Cold restart

The following table shows which OB the operating system calls in each startup type.

Startup Type Related OB

Hot restart OB101
Restart (warm restart) 0OB100
Cold restart 0OB102

Start Events for Startup OBs

The CPU executes a startup after the following events:

e After power up

e After you switch the mode selector from STOP to RUN/RUN-P
e After a request from a communication function

e After synchronizing in multicomputing mode

e In an H system after link-up (only on the standby CPU)

Depending on the start event, the CPU used, and its set parameters the relevant startup OB
(OB100, OB101, or OB102) is called.

Startup Program

You can specify the conditions for starting up your CPU (initialization values for RUN, startup
values for I/O modules) by writing your program for the startup in the organization blocks OB100 for
restart (warm restart), OB101 for hot restart, or OB102 for cold restart.

There are no restrictions to the length of the startup program and no time limit since the cycle
monitoring is not active. Time-driven or interrupt-driven execution is not possible in the startup
program. During the startup, all digital outputs have the signal state 0.

Startup Type After Manual Restart
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On S7-300 CPUs only a manual restart (warm restart) or cold restart (CPU 318-2 only) is possible.

On some S7-400 CPUs, you can restart manually using the mode selector and the startup type
switch (CRST/WRST) if this is permitted by the parameter assignment you made with STEP 7. A
manual restart (warm restart) is possible without specifically assigning parameters.
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Startup Type After Automatic Restart
On S7-300 CPUs, only a restart (warm restart) is possible following power up.

On S7-400 CPUs, you can specify whether an automatic startup following power up leads to a
restart (warm restart) or a hot restart.

Clearing the Process Image

When an S7-400 CPU is restarted, the remaining cycle is executed, and as default, the process
image output table is cleared. You can prevent the process image being cleared if you want the
user program to continue with the old values following a restart.

Module Exists/Type Monitoring

In the parameters, you can decide whether the modules in the configuration table are checked to
make sure they exist and that the module type matches before the startup.

If the module check is activated, the CPU will not start up if a discrepancy is found between the
configuration table and the actual configuration.

Monitoring Times

To make sure that the programmable controller starts up without errors, you can select the
following monitoring times:

e The maximum permitted time for transferring parameters to the modules

e The maximum permitted time for the modules to signal that they are ready for operation after
power up

e On S7-400 CPUs, the maximum time of an interruption during which a hot restart is permitted.

Once the monitoring times expire, the CPU either changes to STOP, or only a restart (warm
restart) is possible.
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4.2.4.6

Background Organization Block (OB90)

If you have specified a minimum scan cycle time with STEP 7 and this is longer than the actual
scan cycle time, the CPU still has processing time available at the end of the cyclic program. This
time is used to execute the background OB. If OB90 does not exist on your CPU, the CPU waits
until the specified minimum scan cycle time has elapsed. You can therefore use OB90 to allow
processes where time is not critical to run and thus avoid wait times.

Priority of the Background OB

108

The background OB has priority class 29, which corresponds to priority 0.29. It is therefore the OB
with the lowest priority. Its priority class cannot be changed by reassigning parameters.

The following figure shows an example of processing the background cycle, the main program
cycle, and OB10 (in CPUs as of 10/98).
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Programming OB90

The run time of OB90 is not monitored by the CPU operating system so that you can program
loops of any length in OB90. Ensure that the data you use in the background program are
consistent by observing the following when programming:

e The reset events of OB90 (see the "System Software for S7-300 and S7-400, System and
Standard Functions" Reference Manual)

e The process image update asynchronous to OB90.
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4.2.4.7

Error Handling Organization Blocks (OB70 to OB87 / OB121 to OB122)

Types of Errors

110

The errors that can be detected by the S7 CPUs and to which you can react with the help of
organization blocks can be divided into two basic categories:

e Synchronous errors: these errors can be assigned to a specific part of the user program. The
error occurs during the execution of a particular instruction. If the corresponding synchronous
error OB is not loaded, the CPU changes to STOP mode when the error occurs.

e Asynchronous errors: these errors cannot be directly assigned to the user program being
executed. These are priority class errors, faults on the programmable logic controller (for
example, a defective module), or redundancy errors. If the corresponding asynchronous error
OB is not loaded, the CPU changes to STOP mode when the error occurs (exceptions: OB70,

OB72, OB81, OB 87).

The following table shows the types of errors that can occur, divided up into the categories of the

error OBs.

Asynchronous Errors/Redundancy Errors

Synchronous Errors

OB70 I/0 Redundancy Error (only H CPUSs)

OB121 Programming Error (for example, DB is not
loaded)

OB72 CPU Redundancy Error (only in H CPUs, for
example, failure of a CPU)

OB122 1/0 Access Error (for example, access to a
signal module that does not exist)

OB80 Time Error (for example, scan cycle time
exceeded)

OB81 Power Supply Error (for example, battery
failure)

OB82 Diagnostic Interrupt (for example, short circuit in
the input module)

0OB83 Remove/lnsert Interrupt (for example, removing
an input module)

OB84 CPU Hardware Fault (fault at the interface to
the MPI network)

OB85 Priority Class Error (for example, OB is not
loaded)

0OB86 Rack Failure

OB87 Communication Error (for example, incorrect
message frame ID for global data communication)
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Using OBs for Synchronous Errors

Synchronous errors occur during the execution of a particular instruction. When these errors occur,
the operating system makes an entry in the | stack and starts the OB for synchronous errors.

The error OBs called as a result of synchronous errors are executed as part of the program in the
same priority class as the block that was being executed when the error was detected. The details
about the error that triggered the OB call are in the start information for the OB. You can use this
information to react to the error condition and then to return to processing your program (for
example, if an access error occurs on an analog input module, you can specify a substitute value in
OB122 using SFC44 RPL_VAL). The local data of the error OBs, do, however, take up additional
space in the L stack of this priority class.

With S7-400 CPUs, one synchronous error OB can start a further synchronous error OB. This is
not possible with S7-300 CPUs.

Using OBs for Asynchronous Errors

If the operating system of the CPU detects an asynchronous error, it starts the corresponding error
OB (OB70 to OB73 and OB80 to OB87). The OBs for asynchronous errors have the highest priority
as default and they cannot be interrupted by other OBs if all asynchronous error OBs have the
same priority. If more than one asynchronous error OB with the same priority occurs
simultaneously, they are processed in the order they occurred.

Masking Start Events

Using system functions (SFCs), you can mask, delay, or disable the start events for several OBs.
For more detailed information about these SFCs and the organization blocks, refer to the "System
Software for S7-300 and S7-400, System and Standard Functions" Reference Manual.

Type of Error OB SFC Function of the SFC
Synchronous error OBs SFC36 MSK_FLT Masks individual synchronous errors. Masked errors do
not start an error OB and do not trigger programmed
reactions
SFC37 DMSK_FLT Unmasks synchronous errors
Asynchronous error OBs SFC39 DIS_IRT Disables all interrupts and asynchronous errors.

Disabled errors do not start an error OB in any of the
subsequent CPU cycles and do not trigger programmed

reactions
SFC40 EN_IRT Enables interrupts and asynchronous errors
SFC41 DIS_AIRT Delays higher priority interrupts and asynchronous

errors until the end of the OB

SFC42 EN_AIRT Enables higher priority interrupts and asynchronous
errors

Note

If you want interrupts to be ignored, it is more effective to disable them using an SFC, rather than to
download an empty OB (with the contents BE).
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5 Startup and Operation

5.1 Starting STEP 7

@ When you start Windows, you will find an icon for the SIMATIC Manager, the starting point for
the STEP 7 software on the Windows interface.

The quickest method to start STEP 7 is to position the cursor on the icon and double-click. The
window containing the SIMATIC Manager is then opened. From here you can access all the
functions you have installed for the standard package and any optional packages.

Alternatively you can also start the SIMATIC Manager via the "Start" button in the taskbar of the
operating system. You will find the entry under "Simatic".

Note

You will find more information about standard Windows operation and options in your Windows user's
guide or in the online help of your Windows operating system.

SIMATIC Manager

The SIMATIC Manager is the basic application for configuring and programming. You can perform
the following functions in the SIMATIC Manager:

e Setup projects

e Configure and assign parameters to hardware

e Configure hardware networks

e Program blocks

e Debug and commission your programs

Access to the various functions is designed to be object oriented, and intuitive and easy to learn.
You can work with the SIMATIC Manager in one of two ways:

e Offline, without a programmable controller connected

e Online, with a programmable controller connected

Note the relevant safety notices in each case.

How to Proceed from Here

You create automation tasks in the form of "Projects.” You will make it easier for yourself if you
read up on the following basic topics before you start work:

e User interface
e Some basic operating steps
e Online help
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5.2

114

Starting STEP 7 with Default Start Parameters

From STEP 7 V5.0 onwards, you can create several symbols in the SIMATIC Manager and specify
start parameters in the call line. By doing this, you can cause the SIMATIC Manager to position on
the object described by these parameters. This allows you to jump to the corresponding locations
in a project immediately just by double-clicking.

On calling s7tgtopx.exe, you can specify the following start parameters:
/e <complete physical project path>

/o <logical path of the object, on which you want to position>

/h <ObjectID>

/onl

The start parameter /onl causes the project to be opened online and the specified path to be
called.

loff

The start parameter /off causes the project to be opened offline and the specified path to be called.
/keep

The start parameter /keep causes the following to occur:

If the SIMATIC Manager is open, the already displayed projects are opened in addition to the new
project to be explicitly opened by means of the command line. If the SIMATIC Manager is not yet
open, then the new project is opened along with the projects stored in the session memory of the
SIMATIC Manager. If this start parameter is not specified, the opened projects are closed first, the
session memory is ignored and only the one specified project is opened.

The easiest way to establish suitable parameters is described below.
Establishing Parameters by Copying and Pasting
Proceed as follows:

1. On your desktop, create a new link to the file s7tgtopx.exe. This file is located in the installation
directory under S7bin.

Display the properties dialog box.

Select the "Link" tab. The entry under "Target" should now be expanded as follows.
Select the required object in the SIMATIC Manager.

Copy the object to the clipboard using the key combination CTRL+ALT+C.

Position the cursor at the end of the "Target" entry in the "Link" tab.

Paste the contents of the clipboard using the key combination CTRL+V.

® N o oA wN

Close the dialog box by confirming with "OK."

Example of Parameters:

/e F\SIEMENS\STEP7\S7proj\MyConfig\MyConfig.s7p /keep

/o "1,8:MyConfig\SIMATIC 400(1)\CPU416-1\S7-Program(1)\Blocks\FB1"
/h T00112001;129;T00116001;1;T00116101;16e /keep
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Note on the Structure of the Project Path

The project path is the physical path in the file system.

The complete logical path has the following structure:

[View ID,online ID]:project name\{object name\}*\ object name

Example: /o 1.8:MyConfig\SIMATIC 400(1)\CPU416-1\S7-Program(1)\Blocks\FB1

The path of network drives must be specified in UNC notation (= Universal Naming Convention, in
other words \\<servername>\<share>\...).

Example: \\<servername>\<share>\SIEMENS\STEP7\S7proj\MyConfig\MyConfig.s7p /keep

Note on the Structure of the Logical Path

The complete logical path and the Object ID can only be created using the copy and paste
functions.

However, it is also possible to specify the path which can be read by the user. In the example
above, that would be:

/o "MyConfig\SIMATIC 400(1)\CPU416-1\S7-Program(1)\Blocks\FB1". By adding /onl or /off the
user can specify whether the path is valid in the online or offline window. You do not need to
specify this if you use the copy and paste functions.

Important: If the path contains blanks, it must be placed within quotation marks.
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5.3 Calling the Help Functions

Online Help

The online help system provides you with information at the point where you can use it most
efficiently. You can use the online help to access information quickly and directly without having to
search through manuals. You will find the following types of information in the online help:

Contents: offers a number of different ways of displaying help information

Context-sensitive Help (F1 key): with the F1 key you access information on the object you
just selected with the mouse or on the active dialog box or window

Introduction: gives a brief introduction to the use, the main features, and the functional scope
of an application

Getting Started: summarizes the basic steps you need to execute to get started with the
application

Using Help: provides a description of ways of finding specific information in the online help

About: provides information on the current version of the application

Via the Help menu you can also access topics which relate to the current dialog situation from
every window.

Calling the Online Help

You can call the online help in one of the following ways:

Select a menu command in the Help menu in the menu bar.
Click the "Help" button in a dialog box. You are then shown help on this dialog box.

Position the cursor in a window or dialog box on the topic you need help with and press the F1
key or select the menu command Help > Context-sensitive Help.

Use the question mark cursor in Windows.

The last three of these ways of accessing the online help are known as context-sensitive help.

Calling the Quick Help

A quick help on buttons in the toolbar is displayed when you position the cursor on a button and
leave it there for a moment.
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5.4 Objects and Object Hierarchy

In the same way that the Windows Explorer shows the directory structure of folders and files, the
object hierarchy for projects and libraries in STEP 7 is shown in the SIMATIC Manager.

The following figure shows an example of an object hierarchy.

e  Project Object
Z)  Projedt . :
e  Station Object
Rl Station

e  Programmable Module Object
E|--- Frogr. Module

EI ST Program e  S7/M7 Program Object
@ Soutce Files e Source File Folder Object
il Blocks o Block Folder Object_

Objects have the following functions:
e Carriers of object properties,
e Folders,

e Carriers of functions (for example, to start a particular application).

Objects as Carriers of Properties

Objects can carry both functions and properties (such as settings). When you select an object, you
can perform one of the following functions with it:

o Edit the object using the menu command Edit > Open Object.

e Open a dialog box using the menu command Edit > Object Properties and set object-specific
options.

A folder can also be a carrier of properties.

Objects as Folders

A folder (directory) can contain other folders or objects. These are displayed when you open the
folder.

Objects as Carriers of Functions
When you open an object, a window is displayed in which you can edit the object.

An object is either a folder or a carrier of functions. An exception to this is stations: they are both
folders (for programmable modules) and carriers of functions (used to configure the hardware).

e If you double-click a station, the objects contained in it are displayed: the programmable
modules and the station configuration (station as a folder).

e If you open a station with the menu command Edit > Open Object, you can configure this
station and assign parameters to it (station as the carrier of a function). The menu command
has the same effect as a double-click on the "Hardware" object.
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5.4.1 Project Object

The project represents the entirety of all the data and programs in an automation solution, and is
located at the top of an object hierarchy.

Position in the Project View

e  Project Object
E)  Projed . .
e  Station Object
E‘" =tation e Programmable Module Object
: e  S7/M7 Program Object
e Source File Folder Object
e Block Folder Object

E| Progr. Module

El S¥ Program

----- @ Source Files

“{H Blocks
Symbol Object Folder Selection of Important Functions
% Project e Creating a Project

e Archiving Projects and Libraries

e  Printing Project Documentation

e Managing Multilingual Texts

e  Checking Projects for Optional Packages Used
e Rearranging

e Translating and Editing Operator Related Texts
e Inserting Operator Station Objects

e More than One User Editing Projects

e Converting Version 2 Projects

e  Setting the PG/PC Interface
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Symbol

Objects in the Project
Level

Selection of Important Objects

Station:

SIMATIC 300 station
SIMATIC 400 station

e Inserting Stations

e  Stations are both objects (project level) and object folder
(station level). Other functions can be found under Station
Object

57

EIgE)

7

S7 program

M7 program

e  S7/M7 Program without a Station or CPU

e  S7/M7 programs are both objects (project level) and object
folders (program level). Other functions can be found under
S7/M7 Program Object

Network for starting the tool
for network configuration
and setting the network
properties.

e  Properties of Subnets and Communication Nodes
e  Overview: Global Data Communication
e Procedure for Configuring Global Data Communication
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5.4.2 Library Object

A library can contain S7/M7 programs and is used to store blocks. A library is located at the top of
an object hierarchy.

e Library Object

e  S7/M7 Program Object

e Source File Folder Object
e Block Folder Object

Symbol Object Folder Selection of Important Functions

:'ﬂ Library e Overview of the Standard Libraries
e  Working with Libraries

e Archiving Projects and Libraries

Symbol Objects in the Library Selection of Important Functions
Level
S7 program e Inserting an S7/M7 Program
e  S7/M7 programs are both objects (project level) and object
folders (program level). Other functions can be found under
S7/M7 Program Object
M7 program
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5.4.3 Station Object

A SIMATIC 300/400 station represents a S7 hardware configuration with one or more

programmable modules.

Position in the Project View

122

B Projed

Iél-- Station

E| Progr. Module

El SY Program

----- @ Source Files

e Project Object
e Station Object

e Programmable Module Object

e  S7/M7 Program Object

e Source File Folder Object
e  Block Folder Object

Symbol Object Folder

Selection of Important Functions

” Station

Inserting a Station

Uploading a Station

Downloading a Configuration to a Programmable Controller
Uploading a Configuration from a Station

Displaying CPU Messages and User-Defined Diagnostic
Messages

Configuring the 'Reporting of System Errors'

Diagnosing Hardware and Displaying Module Information
Displaying and Changing the Operating Mode

Displaying and Setting the Time and Date

Erasing the Load/Work Memory and Resetting the CPU

SIMATIC PC Station
- (Not assigned)

Creating and Assigning Parameters to SIMATIC PC Stations
Configuring Connections for a SIMATIC PC Station
Uploading a SIMATIC PC Station

SIMATIC PC Station
(Assigned)

e

Highlighting the SIMATIC PC Station to be Configured in the
Network View
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Symbol Objects in the Station Selection of Important Functions
Level
Iﬂqn Hardware e Basic Procedure for Configuring Hardware
e Basic Steps for Configuring a Station

e  Overview: Procedure for Configuring and Assigning Parameters
to a Local Configuration

e Basic Procedure for Configuring a DP Master System
e Configuring Multicomputing Operation

I Programmable module e Programmable modules are both objects (station level) and
o object folders ("Programmable Modules" level). Other functions
can be found under Programmable Module Object
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5.4.4 Programmable Module Object

A programmable module represents the parameter assignment data of a programmable module
(CPUxxx, FMxxx, CPxxx). The system data of modules with no retentive memory (for example,
CP441) are loaded via the CPU of the station. For this reason, no "system data" object is assigned

to such modules and they are not displayed in the project hierarchy.

Position in the Project View

124

B Projed

=El Station
E| Progr. Module

El SY Program

----- @ Source Files

e Project Object
e  Station Object

e S7/M7 Program Object
e Source File Folder Object
e Block Folder Object

e Programmable Module Object

Symbol Object Folder Selection of Important Functions
Programmable module e Overview: Procedure for Configuring and Assigning Parameters
By I to a Local Configuration

e Displaying CPU Messages and User-Defined Diagnostic

Messages

e Configuring 'Reporting of System Errors'

e Diagnosing Hardware and Displaying Module Information

e Downloading via EPROM Memory Cards

e Password Protection for Access to Programmable Controllers
e Displaying the Force Values Window

e Displaying and Changing the Operating Mode

e Displaying and Setting the Time and Date

e Setting the Operating Behavior

e  FErasing the Load/Work Memory and Resetting the CPU
e Diagnostics Symbols in the Online View

e Division of the Memory Areas

e Saving Downloaded Blocks on Integrated EPROM
e Updating the Operating System on the Programmable Logic

Controller

2 I Object representing a

programmable module

e Displaying Modules Configured with Later STEP 7 Versions_
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Symbol Objects in the Selection of Important Functions
"Programmable
Modules" level

Connections for defining |e  Networking Stations within a Project
connections within the
network

Programs: e Inserting an S7/M7 Program
. e  S7/M7 programs are both objects (project level) and object
s/ S7 program folders (program level). Other functions can be found under
S7/M7 Program Object
M7 program
E’ Program

e Connection Types and Connection Partners

e  What You Should Know About the Different Connection Types
e Entering a New Connection

e  Configuring Connections for Modules in a SIMATIC Station
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5.4.5

S7/M7 Program Object

A (S7/M7) program folder contains software for S7/M7 CPU modules or software for non-CPU
modules (for example, programmable CP or FM modules).

Position in the Project View

126

B Projed

=El Station
E| Progr. Module

El SY Program

----- @ Source Files

e Project Object

e  Station Object

e  Programmable Module Object
e S7/M7 Program Object

e Source File Folder Object

e Block Folder Object

Symbol Object Folder

Selection of Important Functions

S7 Program
°

Inserting an S7-/M7-Program

Setting the Address Priority

Basic Procedure for Creating Logic Blocks
Assigning Message Numbers

How to Assign and Edit User-Specific Diagnostics Messages
(Project-Oriented)

How to Assign and Edit User-Specific Diagnostics Messages
(CPU-Oriented)

Translating and Editing Operator Related Texts
Managing Multilingual Texts

Displaying CPU Messages and User-Defined Diagnostic
Messages

Program Measures for Handling Errors

M7 program
M prog

Procedure for M7 Systems

Program

|

Creating the Software in the Project (General)
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Symbol Objects in the Program | Selection of Important Functions
Level

Source file folder e  Other functions can be found under Source File Folder Object
Block folder e  Other functions can be found under Block Folder Object
Text libraries folder e User Text Libraries

Symbol table for assigning |e  Absolute and Symbolic Addressing

symbols to signals and e  Structure and Components of the Symbol Table
other variables

e Entering Shared Symbols
e General Tips on Entering Symbols

e How to Assign and Edit Symbol-Related Messages
(Project-Oriented)

e How to Assign and Edit Symbol-Related Messages
(CPU-Criented)

e Translating and Editing Operator Related Texts

e  Configuring Operator Control and Monitoring Attributes via the
Symbol Table

e Editing the Communication Attribute

e  Exporting and Importing Symbol Tables
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5.4.6 Block Folder Object

A block folder of an offline view can contain: logic blocks (OB, FB, FC, SFB, SFC), data blocks
(DB), user-defined data types (UDT) and variable tables. The system data object represents
system data blocks.

The block folder of an online view contains the executable program parts that have been
downloaded to the programmable controller.

Position in the Project View

% Projekt e Project Object
El Ctati e  Station Object
i ation

El Programmierb. Baugruppe e Programmable Module Object

- SR 1
= roaramm 1] e S7/M7 Program Object

“{gH Bausteine e Source File Folder Object
e  Block Folder Object

Symbol | Object Selection of Important Functions
Folder

Blocks e Downloading with Project Management

¢ Downloading without Project Management

e Overview of the Available Reference Data

e Rewiring

e Comparing Blocks

e Translating and Editing Operator Related Texts

e Jumps to Language Descriptions and Help on Blocks, System Attributes

Symbol | Objects in Selection of Important Functions

the Block

Folder

Blocks in e Basic Procedure for Creating Logic Blocks
general e Creating Blocks

e Basic Information on Programming in STL Source Files
e Comparing Blocks

D Organization | Additional Functions:

Block (OB) e Introduction to Data Types and Parameter Types

e Requirements for Downloading

e Testing using Program Status

e What You Should Know About Testing in Single-Step Mode/Breakpoints
e Rewiring

e Help on Blocks
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Symbol |Objects in Selection of Important Functions
the Block
Folder

D Function (FC) | Additional Functions:

e Introduction to Data Types and Parameter Types
e Requirements for Downloading

e Testing using Program Status

e What You Should Know About Testing in Single-Step Mode/Breakpoints

e Rewiring
e  Attributes for Blocks and Parameters
D Function Additional Functions:
Block (FB) e Introduction to Data Types and Parameter Types

e Using Multiple Instances

¢ Requirements for Downloading

e Testing Using Program Status

e What You Should Know about Testing in Single-Step Mode/Breakpoints
e Rewiring

e Attributes for Blocks and Parameters

e How to Assign and Edit Block-Related Messages (Project-Oriented)
e How to Create Block-Related Messages (CPU-Oriented)

e How to Configure PCS 7 Messages (Project-Oriented)

e How to Configure PCS 7 Messages (CPU-Oriented)

e Translating and Editing Operator Related Texts

e Assigning Monitor/Control Attributes to Function Block Parameters
D User-Defined |e  Creating Blocks

Data Type e Basic Information on Programming in STL Source Files

(UDT) e Introduction to Data Types and Parameter Types

e Using User-Defined Data Types to Access Data

e  Attributes for Blocks and Parameters

D DB (Global e Data View of Data Blocks

Data Blocks) |e  Declaration View of Data Blocks

e Requirements for Downloading

e Program Status of Data Blocks

e Introduction to Data Types and Parameter Types

e Using Multiple Instances
e Attributes for Blocks and Parameters

e How to Assign and Edit Block-Related Messages (Project-Oriented) (Instance
DBs Only)

o How to Assign and Edit Block-Related Messages (CPU-Oriented) (Instance
DBs Only)

e How to Configure PCS7 Messages (Project-Oriented) (Instance DBs Only)
e How to Configure PCS7 Messages (CPU-Oriented) (Instance DBs Only)
e Translating and Editing Operator Related Texts (Instance Data Blocks Only)
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Symbol |Objects in Selection of Important Functions
the Block
Folder

D System ¢ Requirements for Downloading
Function e Attributes for Blocks and Parameters
(SFC)

e Help on Blocks

T

SFB (System

e Requirements for Downloading

Function e Attributes for Blocks and Parameters
Blocks) e How to Assign and Edit Block-Related Messages (Project-Oriented)
e How to Create Block-Related Messages (CPU-Oriented)
e How to Configure PCS7 Messages (Project-Oriented)
e How to Configure PCS7 Messages (CPU-Oriented)
e Translating and Editing Operator Related Texts
e Help on Blocks
Block with e Rules for Defining Block Properties in STL Sources
KNOW_ HOW |,  Block Properties
protection

Diagnostic-ca

Additional information is available in the documentation for the S7-PDIAG optional

DR B

pable block package.
Block was Additional information is available in the documentation for the S7 Distributed Safety
created with | optional package.
the
F-FBD/-LAD/-
STL/-DB
programming
language
KA Variable e Basic Procedure when Monitoring and Modifying with the Variable Table
== Table (VAT) |4 |ntroduction to Testing with the Variable Table

e Introduction to Monitoring Variables
e Introduction to Modifying Variables
e Introduction to Forcing Variables

System Data
Block

(SDB)

System data blocks (SDBs) are only edited indirectly via functions:
e Introduction to Configuring Hardware

e  Properties of Subnets and Communication Nodes

e Overview: Global Data Communication

e Assigning and Editing Symbol-Related Messages

e Requirements for Downloading
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5.4.7 Source File Folder Object

A source file folder contains source programs in text format.

Position in the Project View

) e Project Object
% Project e  Station Object
Bl Ststion
e Programmable Module Object
|f_|--- Progr. Module
E‘" =7 Program e  S7/M7 Program Object
EI source Files e Source File Folder Object
..... D Blocks e  Block Folder Object
Symbol Object Folder Selection of Important Functions
Source File Folder e Basic Information on Programming in STL Source Files
e  Exporting Source Files
e Importing Source Files
Symbol Objects in Source File Selection of Important Functions
Folder
[ Source file e Basic Information on Programming in STL Source Files
(_for example, STL source |,  Creating STL Source Files
file) e Inserting Block Templates in STL Source Files
e Inserting Source Code from Existing Blocks in STL Source Files
e Checking Consistency in STL Source Files
e  Compiling STL Source Files
e Generating STL Source Files from Blocks
e Exporting Source Files
e Importing Source Files
||1+_<3 Network template e Working with Network Templates
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5.4.8 S7/M7 Program without a Station or CPU

You can create programs without having configured a SIMATIC station beforehand. This means
that you can initially work independently of the module and module settings you intend to program.

Creating an S7/M7 Program

1. Open the relevant project using the menu command File > Open or activate the project
window.

2. Select the project in the project window of the offline view.

3. Select one of the following menu commands, depending on which programmable controller the
program is being created for:
Insert > Program > S7 Program, if your program is to run on a SIMATIC S7 device.
Insert > Program > M7 Program, if your program is to run on a SIMATIC M7 device.

The S7/M7 program is added and arranged directly below the project in the project window. It
contains a folder for the blocks and an empty symbol table. You can now create and program
blocks.

Assigning a Program to a Programmable Module

When you insert programs that are not dependent on a particular module, you can easily assign
them to a module later on by copying or moving these programs to the module symbol using the
drag and drop function.

Adding a Program to a Library

If the program is to be used for a SIMATIC S7 programmable controller and you want to use it
many times as a "software pool,” you can also insert it in a library. However, when testing, the
programs must lie directly under a project, because this is the only way in which to establish a
connection to the programmable controller.

Accessing a Programmable Controller

Select the online view of the project. You can make the address settings in the dialog box
containing the program properties.

Note

When deleting stations or programmable modules, you will be asked if you also want to delete the program
contained within. If you choose not to delete the program, it will be attached directly below the project as a
program without a station.
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5.5.1

5.5 User Inferface and Operation

User Interface and Operation

Operating Philosophy

The aim: Easy Operation

It is the aim of the graphic user interface to provide maximum and intuitive operating comfort. You
will therefore find objects you already know from your daily work, e.g. stations, modules, programs,
blocks.

Actions you perform under STEP 7 include the creation, selection and manipulation of such
objects.

Differences to Tool-Based Operation

When starting work with conventional tools, the first thing you have to do is to choose the
appropriate tool for a specific solution and then call this tool.

The basic procedure of object-oriented operation is to select an object and then open it for editing.

Object oriented operation does not require knowledge of special instruction syntax. On the GUI,
icons you can open via menu command or mouse click represent objects.

When you open an object, the application automatically calls the appropriate software component
for displaying or editing the content of the object.

Continue ...

Below we describe the basic actions for editing objects. Please pay proper attention to this topic, as
all subsequent topics will be based on these basic operations.
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5.5.2 Window Arrangement

The standard components of a window are shown in the following figure:

Systermn menu Title of active ~ Buttonsfor
M aximizel Close etc.}/ndu:w Minimize Maximize Close
l —— |
LLCEE Sl ! SIMATIC Manager M=l E3

Menu hat —= File PLC Miew Options Window Help

Toolbar — D|=|&= EIE'

Status har — = Presz F1 to get Help. [z

Title Bar and Menu Bar

The title bar and menu bar are always found at the top of a window. The title bar contains the title
of the window and icons for controlling the window. The menu bar contains all menus available in
the window.

Toolbar
The toolbar contains icons (or tool buttons) which provide shortcuts to frequently used and
currently available menu bar commands available with a single mouse click. A brief description of
the function of the respective button is displayed together with additional information in the status
bar when you position the cursor briefly on the button.
If access to a button is not possible in the current configuration, the button is grayed out.

Status Bar

The status bar displays context-specific information.
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5.5.3 Elements in Dialog Boxes

Making Entries in Dialog Boxes

In dialog boxes you can enter information which is required for executing a particular task. The
components which appear most frequently in dialog boxes are explained using the example in the
following figure.

S P |
enter texd usingthe Search For: Replace Wiith:
keyboard —= [ oo [ ozo

b ole WordiCell only

In hiatch case
Crption boxes to seled r Search — Onhy Search In
one ofa number of  — s | g From Cursor Down E
choices O Fram Cursar Up " 1 Component

i Wwhole Tahle ™ 2 Component
Check boxesto O Sdedion [T 3. Component
selgd OneE ar more = ™ 4.Component
Eleleles — Searchin Column ——— | | S.Component

[y L=l
Buttons — s | seach | | Beplace | [Replzce 2n | Cancel Help |

List Boxes and Combination Boxes

Text boxes sometimes have an arrow pointing downwards beside them. This arrow shows that
there are more options available to choose from for this box. Click on the arrow to open a list box or
combination box. If you click on an entry in the list, it is automatically displayed in the text box.

Tabs in Dialog Boxes

The content of some dialog boxes is organized using tabs to improve the clarity of the information
by dividing the dialog box into tab cards (see figure below).

hladule Information

Path: test'Program (onling) CPU Operating Mode:  STOP
Status fodule Cperaing Mode:
Tahs — = Gepgl bagmsﬂ:ﬂmarlllemﬂn.f |l::n,cle Time |Trne5'-.rs'en4Ferbmawe |l:-:mmuba1:m| Shcks
Eueat;
Mo, Time | Dae | Evert -
1 091Z22842 11129 Power-on retentive ]
2 180022378 081295 STOP dueto pover failure

The names of the tab cards are shown on tabs along the top edge of the dialog box. To bring a
particular tab card to the foreground, you simply click on its tab.

Programming with STEP 7
Manual, 05/2010, ASE02789666-01 135



Startup and Operation

5.5 User Inferface and Operation

5.5.4 Creating and Managing Objects

Some basic processing steps are the same for all objects and do not depend on the object type.
These standard handling sequences are summarized here. This knowledge of standard procedures
is required to move on to other sections in the manual.

The usual sequence of steps when handling objects is:
e Create an object
e Select an object

e Perform actions with the object (for example, copy, delete).

Setting the Path to Create New Projects/Libraries

New user projects, libraries and multiprojects are stored in the default folder
"\Siemens\Step7\S7proj". If you want to store them in another folder, you should set your custom
path for these objects before you save projects, libraries and multiprojects for the first time. To do
this, select the menu command Options > Customize. In the "General" tab of the dialog box
displayed you can specify the path name under which you want to store new projects or libraries.

Creating Objects

136

The STEP 7 wizard "New Project" offers support with creating a new project and inserting objects.
Use the menu command File > "New Project"” Wizard to open the wizard. In the dialog boxes
displayed you can set the structure of your project and then have the wizard create the project for
you.

If you do not wish to use the wizard, you can create projects and libraries using the menu
command File > New. These objects form the starting point of an object hierarchy. You can create
all other objects in the hierarchy using the commands in the Insert menu, provided they are not
created automatically. The exception to this are the modules in a SIMATIC station which are
created when you configure the hardware or by using the "New Project" wizard.
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Opening Objects
There are a number of ways to open an object in the detailed view:
e Double-click on the object icon

e Select the object and then the menu command Edit > Open Object. This only works for
objects that are not folders.

Once you have opened an object, you can create or change its contents.

When you open an object that does not contain other objects, its contents are represented by a
suitable software component in a new window for editing purposes. You cannot change objects
whose contents are already being used elsewhere.

Note

Exception: Stations appear as folders for programmable modules (when you double-click them) and

for the station configuration. If you double-click the "Hardware" object, the application for configuring
hardware is started. Selecting the station and selecting the menu command Edit > Open Object has
the same effect.

Building an Object Hierarchy

Use the "New Project” wizard to create the object hierarchy. When you open a folder, the objects it
contains are displayed on the screen. You can now create more objects in the folder using the
Insert menu, for example, additional stations in a project. Only the commands for those objects
which can be inserted in the current folder are active in the Insert menu.

Setting Object Properties

Object properties are data belonging to the object which determine its behavior. The dialog box for
setting object properties appears automatically when you create a new object and properties have
to be set. The properties can also be changed at a later date.

Using the menu command Edit > Object Properties, a dialog box is opened in which you can
display or set the properties for the selected object.

Using the menu command Edit > Special Object Properties, you can open dialog boxes and
enter data required for operator control and monitoring functions and for configuring messages.

For example, in order to display the special object properties of a block for operator control and
monitoring, the block must be marked as being relevant for operator control and monitoring,
meaning that the system attribute "s7_m_c" must be set to the value "true" in the "Attributes” tab of
the block properties.
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Note

Properties of the "System Data" folder and the "Hardware" object cannot be displayed or
changed.

You cannot write in the dialog boxes for object properties of a read-only project. In this case,
the input boxes are grayed out.

If you display the properties of programmable modules, you cannot edit the displayed
parameters for reasons of consistency. To edit the parameters you must open the "Configuring
Hardware" application.

If you change the settings for objects on the programming device (for example, the
configuration data of a module), they are not yet effective in the target system, because the
system data blocks in which the settings are saved have to be in the target system.

If you load an entire user program, the system data blocks are also automatically transferred. If
you change the settings after having loaded the program, you can reload the "System data"
object in order to transfer the settings to the target system.

It is strongly recommended to edit the folders exclusively with STEP 7, since they can be
physically structured in a different way than you see in the SIMATIC Manager.

Cutting, Pasting, Copying

138

Most objects can be cut, pasted, or copied as usual under Windows. The menu commands for
these functions are found in the Edit menu.

You can also copy objects by dragging and dropping. If you attempt to move or copy to an illegal
destination, the cursor displays a prohibited sign as a warning.

When you copy an object, the whole hierarchy beneath it is also copied. This enables components
you create in an automation task to be used again and again.

Note

The connection table in the "Connections" folder cannot be copied. Note that when you copy lists of
operator-relevant texts, only those languages installed in the destination object are accepted.

You will find a step-by-step guide to copying under Copying Objects.
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Renaming Objects

The SIMATIC Manager assigns standard names to some new objects. These names are generally
formed from the type of object (if a number of objects of this type can be created in the same
folder) and a number.

For example, the first S7 program will be named "S7 Program(1)", the second "S7 Program(2)" etc.
The symbol table is simply called "Symbols" as it can only exist once in each folder.

You can change the names of most objects and assign them names which are more relevant to
their content.

With projects, the directory names in the path must not have more than 8 characters. Otherwise,
there may be problems when archiving and using "C for M7" (Borland compiler).

You can change the name of an object directly or using the object properties.
Directly:

When you slowly click twice on the name of a selected object, a frame appears around the text.
You can then edit the name using the keyboard.

Using the menu:

Select the required object in the project window and select the menu command Edit > Rename. A
frame appears around the text. You can then edit the name using the keyboard.

If you are not allowed to change the name:

If you are not allowed to change the name of an object, the input field is shown in gray in the dialog
box, the current name is displayed, and text entries are not possible.

Note

If you move the mouse pointer out of the name box while editing the name and execute another action
(for example, select a menu command), the edit procedure is terminated. The changed name is
accepted and entered if it is allowed.

You will find a step-by-step guide to renaming under Renaming Objects.
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Moving Objects

With the SIMATIC Manager you can move objects from one folder to another even if the
destination is in another project. When you move a folder its contents are all moved as well.

Note
You cannot move the following objects:

e Connections
e System data blocks (SIB) in the online view

e System functions (SFC) and system function blocks (SFB) in the online view

You will find a step-by-step guide to moving under Moving Objects.

Sorting Objects

You can sort objects in the detailed view (menu command View > Details) according to their
attributes. To do this, click on the corresponding header of the required attribute. When you click
again, the sort order is reversed. Blocks of one type are sorted according to their numerical order,
for example, FB1, FB2, FB11, FB12, FB21, FC1.

Default Sort Order

When you re-open a project, the objects in the detailed view are displayed according to a default
sort order. Examples:

e Blocks are shown in the order "System data, OB, FB, FC, DB, DUTY, VAT, SFB, SFC."
e Ina project, all stations are shown first and then the S7 programs.

The default is not therefore an alphanumeric ascending or descending sort order in the detailed
view.

Restoring the Default Sort Order

After resorting, for example, by clicking on the column header "Object Name," you can restore the
default order if you proceed as follows:

e Click the column header "Type" in the detailed view.

e Close the project and open it again.
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Deleting Objects

You can delete folders and objects. If you delete a folder, all the objects contained in it are also
deleted.

You cannot undo the delete procedure. If you are not sure whether you really no longer need an
object, it is better to archive the whole project first.

Note
You cannot delete the following objects:

e Connections
e System data blocks (SIB) in the online view

e System functions (SFC) and system function blocks (SFB) in the online view

You will find a step-by-step guide to deleting under Deleting Objects.
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5.5.5 Selecting Objects in a Dialog Box

Selecting objects in a dialog box (browser) is an action which you will need regularly for a large
number of different edit steps.

Calling the Browser

You call the browser dialog in the hardware configuration application, for example, using menu

commands such as Station > New/Open (one exception is the basic application window "SIMATIC
Manager").

Structure of a Browser Dialog

In the browser you have the following selection options as shown in the following figure.
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5.5.6 Session Memory

The SIMATIC Manager can save the contents of windows (that is, the projects and libraries open),
and the layout of the windows.

e Using the menu command Options > Customize, you define whether the window contents
and layout are to be saved at the end of a session. At the start of the next session, these
window contents and layout are restored. In the open projects, the cursor is positioned on the
last folder selected.

e Using the menu command Window > Save Settings you save the current window contents
and the window arrangement.

e Using the menu command Window > Restore Settings you restore the window contents and
layout that you saved with the menu command Window > Save Settings. In the open projects,
the cursor is positioned on the last folder selected.

Note
The window contents of online projects, the contents of the "Accessible Nodes" window, and the
contents of the "S7 Memory Card" window are not saved.

Any passwords you may have entered for access to programmable controllers (S7-300/S7-400) are
not saved at the end of a session.

5.5.7 Changing the Window Arrangement

To cascade all the displayed windows one behind the other, select one of the following options:
e Select the menu command Window > Arrange > Cascade.
e Press the key combination SHIFT + Fb5.

To arrange all the displayed windows from top to bottom on the screen, select the menu command
Window > Arrange > Horizontally.

To arrange all the displayed windows from left to right on the screen, select the menu command
Window > Arrange > Vertically.
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5.5.8 Saving and Restoring the Window Arrangement

The STEP 7 applications have a feature which enables you to save the current window
arrangement and restore it at a later stage. You can make the setting using the menu command
Options > Customize in the "General" tab.

What Is Saved?
When you save the window layout the following information is recorded:
e Position of the main window
e Opened projects and libraries and their respective window positions

e Order of any cascaded windows

Note

The window content of online projects, the content of the "Accessible Nodes" window, and the content
of the "S7 Memory Card" window are not saved.

Saving the Window Layout

To save the current window arrangement, select the menu command Window > Save Settings.

Restoring the Window Layout

To restore the saved window arrangement, select the menu command Window > Restore
Settings.

Note

When you restore a window, only the part of the hierarchy containing the object that was selected when the
window arrangement was saved is displayed in detail.
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5.6.1 Keyboard Control

5.6 Keyboard Operation

International Key Names German Key Names
HOME POS1

END ENDE

PAGE UP BILD AUF

PAGE DOWN BILD AB

CTRL STRG

ENTER Eingabetaste

DEL ENTF

INSERT EINFG

5.6.2 Key Combinations for Menu Commands

Every menu command can be selected by typing a key combination with the ALT key.

Press the following keys in the order shown:

e ALTkey

e The letter underlined in the menu name you require (for example, ALT, F for the menu "File" - if

the menu "File" is included in the menu bar). The menu is opened.

e The letter underlined in the menu command you require (for example, N for the menu
command "New"). If the menu command has a submenu, the submenu is also opened.
Proceed as above until you have selected the whole menu command by typing the relevant

letters.

Once you have entered the last letter in the key combination, the menu command is executed.

Examples:
Menu Command

File > Archive

Window > Arrange > Cascade
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ALT, F, A
ALT, W, A, C
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Shortcuts for Menu Commands

146

Command Shortcut

New (File Menu) CTRL+N

Open (File Menu) CTRL+O

Save as ("File" Menu) CTRL+S

Print > Object Table ("File" Menu) CTRL+P

Print > Object Content ("File" Menu) CTRL+ALT+P

Exit ("File" Menu) ALT+F4

Cut ("Edit" Menu) CTRL+X

Copy ("Edit" Menu) CTRL+C

Paste ("Edit" Menu) CTRL+V

Delete ("Edit" Menu) DEL

Select All ("Edit" Menu) CTRL+A

Rename ("Edit" Menu) F2

Object Properties ("Edit" Menu) ALT+RETURN

Open Object ("Edit" Menu) CTRL+ALT+O

Compile ("Edit" Menu) CTRL+B

Download (PLC Menu) CTRL+L

Diagnostics/Setting CTRL+D

> Module Status ("PLC" Menu)

Diagnostics/Setting CTRL+I

> Operating Mode ("PLC" Menu)

Update ("View" Menu) F5

Updates the status display of the visible CPUs in the online view CTRL+F5

Customize ("Options" Menu) CTRL+ALT+E

Reference Data > Show ("Options" Menu) CTRL+ALT+R

Arrange > Cascade (Window Menu) SHIFT+F5

Arrange > Horizontally (Window Menu) SHIFT+F2

Arrange > Vertically (Window Menu) SHIFT+F3

Context-Sensitive Help (Help Menu) F1
(If there is a current context, for example,
a selected menu command, the relevant
help topic is opened. Otherwise the help
contents page is displayed.)
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Key Combinations for Moving the Cursor

Moving the Cursor in the Menu Bar/Pop-Up Menus

To Press
move to the menu bar F10
move to the pop-up menu SHIFT+F10

move to the menu that contains the letter or number
underlined which you typed in

ALT+underlined character in a menu title

select the menu command whose underlined letter or
number corresponds to the letter you have typed

Underlined character in the menu command

move one menu command to the left LEFT ARROW
move one menu command to the right RIGHT ARROW
move one menu command up UP ARROW
move one menu command down DOWN ARROW
activate the selected menu command ENTER
deselect the menu name or close the open menu and | ESC
return to the text

Moving the Cursor When Editing Text
To move Press
one line up or one character to the left in a text UP ARROW

consisting of only one line

one line down or one character to the right in a text
consisting of only one line

DOWN ARROW

one character to the right RIGHT ARROW

one character to the left LEFT ARROW

one word to the right CTRL+RIGHT ARROW
one word to the left CTRL+LEFT ARROW
to the beginning of the line HOME

to the end of the line END

to the previous screen PAGE UP

to the next screen PAGE DOWN

to the beginning of the text CTRL+HOME

to the end of the text CTRL+END
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Moving the Cursor When Editing Tables

To move Press

One row up UP ARROW

One row down DOWN ARROW

One character or cell to the left RIGHT ARROW

One character or cell to the right LEFT ARROW

To the beginning of the row CTRL+RIGHT ARROW

To the end of the row CTRL+LEFT ARROW

To the beginning of the cell HOME

To the end of the cell END

To the previous screen PAGE-UP

To the next screen PAGE-DOWN

To the beginning of the table CTRL+HOME

To the end of the table CTRL+END

In the symbol table only: to the "Symbol" column SHIFT+HOME

In the symbol table only: to the "Comment" column SHIFT+END
Moving the Cursor in Dialog Boxes

To Press

move from one input box to the next (from left to right | TAB

and from top to bottom)

move one input box in the reverse direction SHIFT+TAB

or number underlined which you typed in

move to the input box or option that contains the letter

ALT+underlined character in a menu title

select in a list of options

an arrow key

open a list of options

ALT+DOWN ARROW

("Cancel" button)

select or deselect an item in a list SPACEBAR
confirm the entries and close the dialog box ("OK" ENTER
button)

close the dialog box without saving the changes ESC
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To select or deselect text

Press

one character at a time to the right

SHIFT+RIGHT ARROW

one character to the left

SHIFT+LEFT ARROW

to the beginning of a comment line

SHIFT+HOME

to the end of a comment line

SHIFT+END

one row in a table

SHIFT+SPACE

one line of text up

SHIFT+UP ARROW

one line of text down

SHIFT+DOWN ARROW

to the previous screen

SHIFT+PAGE UP

to the next screen

SHIFT+PAGE DOWN

the text to the beginning of the file

CTRL+SHIFT+HOME

the text to the end of the file

CTRL+SHIFT+END

5.6.5 Key Combinations for Access to Online Help

To

Press

open the Help

F1

(If there is a current context, for example, a
selected menu command, the relevant help topic
is opened. Otherwise the help contents page is
displayed.)

activate the question mark symbol for context-sensitive SHIFT+F1
help
close the Help window and return to the application ALT+F4
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Key Combinations for Toggling between Windows

To Press
toggle between the panes in a window F6

return to the previous pane, if there is no dockable window | Shift+F6
toggle between the document window and a dockable Shift+F6
window in the document (for example, variable declaration

window).

If there are no dockable windows, you can use this key

combination to return to the previous pane.

toggle between document windows Ctrl+F6
return to the previous document window Shift+Ctrl+F6
toggle between non-document windows (application Alt+F6
framework and dockable windows in the application

framework;

when you return to the framework, this key combination

activates the document window that was last active)

return to the previous non-document window Shift+Alt+F6
close the active window Ctrl+F4
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Project Structure

Projects are used to store the data and programs which are created when you put together an
automation solution. The data collected together in a project include:

e Configuration data on the hardware structure and parameters for modules,

e Configuration data for communication in networks, and

e Programs for programmable modules.

The main task when you create a project is preparing these data for programming.

Data are stored in a project in object form. The objects in a project are arranged in a tree structure
(project hierarchy). The display of the hierarchy in the project window is similar to that of the
Windows Explorer. Only the object icons have a different appearance.

The top end of the project hierarchy is structured as follows:

1. 1stlLevel: Project
2. 2nd Level: Subnets, stations, or S7/M7 programs
3. 3rd Level: depends on the object in level 2.

Programming with STEP 7
Manual, 05/2010, A5E02789666-01 153



Setting Up and Editing the Project

6.1 Project Structure

Project Window

The project window is split into two halves. The left half shows the tree structure of the project. The
right half shows the objects that are contained in the object open in the left half in the selected view
(large symbols, small symbols, list, or details).

Click in the left half of the window on the box containing a plus sign to display the full tree structure
of the project. The resulting structure will look something like the following figure.

At the top of the object hierarchy is the object "S7_Prol" as the icon for the whole project. It can be
used to display the project properties and serves as a folder for networks (for configuring
networks), stations (for configuring the hardware), and for S7 or M7 programs (for creating
software). The objects in the project are displayed in the right half of the project window when you
select the project icon. The objects at the top of this type of object hierarchy (libraries as well as
projects) form the starting point in dialog boxes used to select objects.

Project View

You can display the project structure for the data available on the programming device in the
component view "offline" and for the data available on the programmable control system in the
component view "online" in project windows.

An additional view you can set is available if the respective optional package is installed: the plant
view.

Note
Configuring hardware and networks can only be done in the "offline" view.
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6.2 What You Should Know About Access Protection

As of STEP 7 V5.4, you have the option of restricting access to projects and libraries by assigning
a project password. This functionality is available only if SIMATIC Logon is installed.

You can also enable, disable and display a change log.

If SIMATIC Logon is installed on your computer, the following dynamic menu commands are
available in the SIMATIC Manager. You can use these commands to manage access protection for
a project or library:

e Access Protection, Enable

e Access Protection, Disable

e Access Protection, Manage

e Access Protection, Adjust in Multiproject

e Remove Access Protection and Change Log

You activate access protection in SIMATIC Manager with the menu command Options > Access
Protection > Enable. If you enable access protection for the first time with this menu command, a
dialog opens in which you will need to log on with SIMATIC Logon. You will then be prompted to
assign a project password. The relevant project or library can then only be edited by an
authenticated user or after entering the project password.

The Remove Access Protection and Change Log menu command removes access protection
as well as the change log for a password-protected project or library. After removing the access
protection, you can once again edit projects with a STEP 7 version prior to V5.4.
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Opening and Closing Access-protected Projects
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The following situations can be distinguished:

PC with STEP 7 and SIMATIC
Logon

PC with STEP 7 and
SIMATIC Logon

PC with STEP 7 (no SIMATIC
Logon present)

The user logs on using
SIMATIC Logon with a user
name and password.

The project with access
protection is opened by
another user.

The user opens the access-protected
project by entering the project
password.

The project with access
protection is opened.

Editing of the project is possible,
however without the functions of
SIMATIC Logon.

The project is edited.

The project is edited.

After closing and reopening the
project, users must authenticate
themselves again with the project
password.

Closing the project does not
mean logging off in SIMATIC
Logon.

Closing the project does not
mean logging off in SIMATIC
Logon.

The user must log off with
Options > SIMATIC Logon
Services >"Log Off" button.
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Note

To disable access protection, you must be authorized in SIMATIC Logon as project administrator.

The first time you enable access protection, the project format is changed. You will receive a
message indicating that the modified project can no longer be edited with older STEP 7 versions.

The Options > Access Protection >Remove Access Protection and Change Log function
allows the project or the library to be used with a STEP 7 version lower than V5.4. You do,
however, lose the information on the users that are allowed access to this project or library and all
change logs.

The user currently logged on is displayed in the status bar of the SIMATIC Manager.

The currently logged on Logon user who enables access protection is entered as the project
administrator and is requested to assign the project password the first time access protection is
enabled.

To open an access protected project, you must be authenticated in SIMATIC Logon as project
administrator or project user or you must know the password.

Remember that a logged-on user is entered in the project as project administrator when a project
is opened with the project password.

If the project/library access protection is active, the icon has a red key. If the multiproject only
contains projects/libraries with active access protection, the icon also has a red key.

If the project/library access protection is disabled, the icon has a white key. If the multiproject
contains projects/libraries both with active and deactivated access protection or projects/libraries
with deactivated access protection, the icon is also displayed with a white key.
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What You Should Know About The Change Log

As of STEP 7 V5.4, after setting up access protection for projects and libraries, you have the option
of keeping a change log that records online actions.

Examples include:

e Activate / deactivate / configure the access protection and change log
e Open/ close projects and libraries

e Download to PLC (system data)

e Selected operations for loading and copying blocks

e Activities for changing the operating mode

e Clear/reset

You can display the change log and enter comments such as those explaining changes that you
have made. This functionality is available only if SIMATIC Logon is installed.

To enable the change log, go to the SIMATIC Manager and select the menu command Options >
Change Log > Enable. After you have enabled the change log, your can view it with the
appropriate menu command or disable it again.

Depending on the object you have selected in the project structure (for example project folder or
lower-level station), the corresponding change log is displayed.

Note

The Options > Access Protection >Remove Access Protection and Change Log function
allows the project or the library to be used with a STEP 7 version lower than V5.4. You do,
however, lose the information on the users that are allowed access to this project or library and all
change logs.

To use this function, you must be authenticated in SIMATIC Logon as project administrator and
access protection must be enabled for this project.
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6.4 Using Foreign-Language Character Sets

As of STEP 7 V5.3 SP2, you can enter texts in foreign languages in projects and libraries even if
these languages do not match the language that has been set for STEP 7. To do this, the
corresponding Windows language must be set in the Control Panel of the operating system. This
makes it possible, for example, to operate STEP 7 in the STEP 7 language English on a
Chinese-language version of Windows but still allows Chinese text be entered.

In this case, the following types and options for language settings must be distinguished:

Windows Language Setting

This setting is made in the Windows Control Panel. Texts pertaining to the operating system are
displayed in the language selected, and you can enter texts in foreign-language character strings.

Project Language

The project language is the language that is set in the Window Control Panel when a project is first
created. Once chosen, this project language cannot be changed. However, with the
"language-neutral” setting it is still possible to open a project on computers with other language
settings in Windows. Before changing the project language to "language-neutral”, make sure that
only characters from the English-language character set (ASCII characters Ox2a - 0x7f) were
previously used in the project when entering text.

To find out the project language for a project or a library, select the Edit > Object Properties menu
command. In the dialog box that is then displayed you can also select the "Can be opened under
any Windows language setting (language-neutral)" option.

If you copy a project by means of the Save As menu command and the project language is not the
same as the current Windows language setting, you can then change the project language in the
copied project to the language currently set in Windows. This will be useful in cases such as when
you want to create language-specific variants of a project. In this case, the master project should
contain only characters from the English-language character set (ASCII characters 0x2a - 0x7f).
This will ensure that data corruption will not occur when the language-specific project is edited
further in the respective language.

STEP 7 Language

The STEP 7 language is the one that you set in the SIMATIC Manager by using the Options >
Customize menu command. This language is the one use for interface elements, menu command,
dialog boxes and error messages in STEP 7.

If you are using another Windows language such as German, English, French, Italian or Spanish,
you can ensure that the STEP 7 interface is correctly displayed by selecting English as the
STEP 7 language.
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Rules
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If you will be editing your projects or libraries on computers that have different language settings,
be sure to observe the following "rules and regulations” to prevent incompatibilities or data
corruption from occurring when using a foreign-language character set:

Install STEP 7 only in folders with names that contain the characters of the English character
set (ASCII characters 0x2a - 0x7f).

Only use project names and project paths with names that contain the characters of the
English character set (ASCII characters 0x2a - 0x7f). For example, if you use German umlauts,
Cyrillic or Chinese characters, then the project can only be opened on computers that have a
compatible language setting in Windows.

In multiprojects, only use projects and libraries with the same project language or those that
are identified as being language-neutral ones. The multiproject itself is language-neutral.

When creating libraries, always make them language-neutral to ensure than they can be used
on computers with different Windows language settings. When assigning names to library
projects, entering comments, or creating symbol names, etc. be sure to only use ASCII
characters

(Ox2a - 0x7f) so that the libraries can be used without any problems.

When importing/exporting hardware configurations or symbol tables, make sure that you only
import/export language-compatible files.

In the names of user-defined attributes, use only characters from the English-language
character set (ASCII characters 0x2a - 0x7f).

If, in an STL source, you are using characters that are not in the English character set (ASCII
characters 0x2a - 0x7f) for the TITLE, AUTHOR, FAMILY block properties, then place these
entries in single quote marks.
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Notes

« If you change or copy projects or libraries that were created on a computer that is identified as
being language-neutral with respect to the Windows language setting but is not compatible with
the setting on the computer currently being used, data corruption may occur if characters that are
not contained in the English character set (ASCII characters 0x2a - Ox7f) were used in the project
or library.

For this reason, before editing "foreign” projects or libraries, make sure to check whether the
Windows language setting on your computer matches the project language.

« If you export hardware configurations or symbol tables that are to be imported in another Windows
language setting, make sure that only characters from the English-language character set (ASCII
characters Ox2a - 0x7f) were previously used and that no other language-specific characters such
as German umlauts, Japanese characters or Cyrillic characters are present.

« Exported hardware configurations or symbol tables that contain language-specific characters such
as German umlauts, Japanese characters or Cyrillic characters may only be imported in the same
Windows language setting from which they were exported. This means that if you import older
symbol tables that might contain such language-specific characters, be sure to check the results
carefully: the symbols must be unique, must not contain any question marks or other incorrect
characters, and must be plausible.

« If symbol tables contain special characters that are not defined in ("known to") the current
Windows language setting, then the question marks or other incorrect characters now part of the
symbol names may cause problems and errors when sorting by names and comments.

« Please note that with symbolic addressing the symbolic names must be written in quotation marks
("<Symbolic Name>").

Basic Procedure

To be able to enter text in foreign-language character sets in projects and libraries, proceed as
follows:

1. Inthe Windows Control Panel, set the language setting to the language desired.
2. Create a project.
3. Enter the text in foreign-language characters.

For project and libraries that were created before STEP 7 V5.3 SP2, the project language is "not
yet specified”. In this case, you can select the Edit > Object Properties menu command to set the
project language to the language currently set in Windows. Before doing so, make sure that the
project does not contain any characters that are not defined in ("known to") the current Windows
language setting.
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6.5 Setting the MS Windows Language

To set the Windows language, proceed as follows:

Setting the Language in Windows XP and Windows Server 2003:

1. To set the desired display language for programs that do not support Unicode, select the
following menu command sequence:
Control Panel > Regional and Language Options > Advanced > Language for
non-Unicode programs.

2. To set the input language (standard regional settings properties), select the following menu
command sequence:
Control Panel > Regional and Language Options > Languages > Details.

3. To set the input language (standard regional settings properties), select the following menu
command sequence:
Control Panel > Regional and Language Options > Regional Settings (Standards and
Formats).

Setting the Language in Windows 7:

e Using Control Panel > Clock, Language and Region > Region and Language > Formats >
Format, set the required display language.

e Using Control Panel > Clock, Language and Region > Region and Language >Keyboards
and Languages > Change Keyboards, add the required input language.

e Using Control Panel > Clock, Language and Region > Region and Language >
Administrative Tools > Change System Locale..., set the display language for programs that
do not support unicode.

You can enter texts in the desired language and display them correctly only after you have made
all of these settings.
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6.6  Setting Up a Project

6.6.1 Creating a Project

To construct a solution to your automation task using the framework of a project management, you
will need to create a new project. The new project is created in the directory you set for projects in
the "General" tab when you selected the menu command Options > Customize.

Note

The SIMATIC Manager allows names that are longer than eight characters. The name of the project

directory is, however, cut off to eight characters. Project names must therefore differ in their first eight
characters. The names are not case-sensitive.

You will find a step-by-step guide to creating a project under Creating a Project Manually or under
Creating a Project Using the Wizard.

Creating a Project Using the Wizard

The easiest way to create a new project is using the "New Project" wizard. Use the menu
command File > "New Project" Wizard to open the wizard. The wizard prompts you to enter the
required details in dialog boxes and then creates the project for you. In addition to the station, CPU,

program folder, source file folder, block folder, and OB1 you can even select existing OBs for error
and alarm processing.

The following figure shows an example of a project created with the wizard.

12757 _Pro1 — C:ASIEMENSASTEP7%S 7proj\s.. =]

57 Pl
= SIMATIC 300 Station
=1-[§ CPU3T4(1)
[=-{z5] S7 Pragram(1)
{1 Source Files
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Creating a Project Manually

You can also create a new project using the menu command File > New in the SIMATIC Manager.
It already contains the "MPI Subnet" object.

Alternative Procedures

When editing a project, you are flexible as to the order in which you perform most of the tasks.
Once you have created a project, you can choose one of the following methods:

e First configure the hardware and then create the software for it, or

e Start by creating the software independent of any configured hardware.

Alternative 1: Configure the Hardware First

If you want to configure the hardware first, proceed as described in Volume 2 of the Configuring
Hardware with STEP 7 Manual. When you have done this, the "S7 Program" and "M7 Program"
folders required to create software are already inserted. Then continue by inserting the objects
required to create programs. Then create the software for the programmable modules.

Alternative 2: Create Software First

You can also create software without first having to configure the hardware; this can be done later.
The hardware structure of a station does not have to be set for you to enter your programs.

The basic procedure is as follows:

1. Insert the required software folders (S7/M7 Program without a Station or CPU) in your project.
Here you are simply deciding whether the program folder is to contain S7 hardware or M7
hardware.

Then create the software for the programmable modules.
Configure your hardware.

4. Once you have configured the hardware, you can link the M7 or S7 program to a CPU.
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6.6.2 Inserting Stations
In a project, the station represents the hardware structure of a programmable controller and
contains the data for configuring and assigning parameters to individual modules.

New projects created with the "New Project” wizard already contain a station. Otherwise you can
create the station using the menu command Insert > Station.

You can choose between the following stations:

e SIMATIC 300 station

e SIMATIC 400 station

e SIMATIC H station

e SIMATIC PC station

e PC/programming device

e SIMATIC S5

e Other stations, meaning non- SIMATIC S7/M7 and SIMATIC S5

The station is inserted with a preset name (for example, SIMATIC 300 Station(1), SIMATIC 300
Station(2), etc.). You can replace the name of the stations with a relevant name, if you wish.

You will find a step-by-step guide to inserting a station under Inserting a Station.

Configure the Hardware

When you configure the hardware you specify the CPU and all the modules in your programmable
controller with the aid of a module catalog. You start the hardware configuration application by
double-clicking the station.

For each programmable module you create in your configuration, an S7 or M7 program and a
connection table ("Connections" object) are created automatically once you have saved and exited
the hardware configuration. Projects created with the "New Project" wizard already contain these
objects.

You will find a step-by-step guide to configuring under Configuring the Hardware, and detailed
information under Basic Steps for Configuring a Station.

Creating a Connection Table

An (empty) connection table ("Connections" object) is created automatically for each
programmable module. The connection table is used to define communication connections
between programmable modules in a network. When it is opened, a window is displayed containing
a table in which you define connections between programmable modules.

You will find detailed information under Networking Stations within a Project.

Next Steps

Once you have created the hardware configuration, you can create the software for your
programmable modules (Also refer to Inserting a S7/M7 Program).
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6.6.3

Inserting an S7/M7 Program

The software for programmable modules is stored in object folders. For SIMATIC S7 modules this
object folder is called "S7 Program," for SIMATIC M7 modules it is called "M7 Program."

The following figure shows an example of an S7 program in a programmable module in a
SIMATIC 300 station.

= Project
E|_. SIMATIC 300 Station

El Programmable Module
454 57 Program

Existing Components

An S7/M7 program is created automatically for each programmable module as a container for the
software:

The following objects already exist in a newly created S7 program:
e Symbol table ("Symbols" object)

e "Blocks" folder for containing the first block

e "Source Files" folder for source files

The following objects already exist in a newly created M7 program:
e Symbol table ("Symbols" object)

e "Blocks" folder

Creating S7 Blocks

166

You want to create Statement List, Ladder Logic, or Function Block Diagram programs. To do this,
select the existing "Blocks" object and then select the menu command Insert > S7 Block. In the
submenu, you can select the type of block you want to create (such as a data block, User-defined
Data Type (UDT), function, function block, organization block, or variable table).

You can now open the (empty) block and start entering the Statement List, Ladder Logic, or
Function Block Diagram program. You will find more information on this in Basic Procedure for
Creating Logic Blocks and in the Statement List, Ladder Logic, and Function Block Diagram
manuals.

Note

The object "System Data" (SDB) which may exist in a user program was created by the system. You
can open it, but you cannot make changes to it for reasons of consistency. It is used to make changes
to the configuration once you have loaded a program and to download the changes to the
programmable controller.
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Using Blocks from Standard Libraries

You can also use blocks from the standard libraries supplied with the software to create user
programs. You access the libraries using the menu command File > Open. You will find further
information on using standard libraries and on creating your own libraries in Working with Libraries
and in the online help.

Creating Source Files/CFC Charts

You want to create a source file in a particular programming language or a CFC chart. To do this,
select the "Source Files" or "Charts" object in the S7 program and then select the menu command
Insert > S7 Software. In the submenu, you can select the source file that matches your
programming language. You can now open the empty source file and start entering your program.
You will find more information under Basic Information on Programming in STL Source Files.

Creating Programs for M7

You want to create programs for the operating system RMOS for a programmable module from the
M7 range. To do this, select the M7 program and then select the menu command Insert > M7
Software. In the submenu, you can select the object that matches your programming language or
operating system. You can now open the object you created to access the relevant programming
environment.

Creating a Symbol Table

An (empty) symbol table ("Symbols" object) is created automatically when the S7/M7 program is
created. When you open the symbol table, the "Symbol Editor" window opens displaying a symbol
table where you can define symbols. You will find more information under Entering Multiple Shared
Symbols in the Symbol Table.

Inserting External Source Files

You can create and edit source files with any ASCII editor. You can then import these files into your
project and compile them to create individual blocks.

The blocks created when the imported source file is compiled are stored in the "Blocks" folder.

You will find more information under Inserting External Source Files.
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6.7 Editing a Project

Opening a Project

To open an existing project, enter the menu command File > Open. Then select a project in the
dialog boxes that follow. The project window is then opened.

Note

If the project you require is not displayed in the project list, click on the "Browse" button. In the browser
you can then search for other projects and include any projects you find in the project list. You can
change the entries in the project list using the menu command File > Manage.

Copying a Project
You copy a project by saving it under another name using the menu command File > Save As.

You copy parts of a project such as stations, programs, blocks etc. using the menu command Edit
> Copy.

You will find a step-by-step guide to copying a project under Copying a Project and Copying Part of
a Project.

Deleting a Project
You delete a project using the menu command File > Delete.

You delete parts of a project such as stations, programs, blocks etc. using the menu command
Edit > Delete.

You will find a step-by-step guide to deleting a project under Deleting a Project and Deleting Part of
a Project.
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6.7.1 Checking Projects for Software Packages Used

If a project that you are editing contains objects that were created with another software package,
this software package is required to edit this project.

No matter what programming device you are using to work with multiprojects, projects or libraries,
STEP 7 assists you by showing you what software packages and versions are required to do so.

This information on the software packages required is complete under the following conditions:

o If the project (or all projects in a multiproject) or library was created in STEP 7 as of V5.2.

e If you yourself have checked the project for any software packages used in creating it. To do
this, first go to the SIMATIC Manager and select the project concerned. Then select the menu
command Edit > Object Properties. In the dialog box that is displayed, select the "Required
software packages" tab. The information in this tab will tell you whether you should check the
project for software packages.

6.7.2 Managing Multilingual Texts

STEP 7 offers the possibility of exporting text that has been created in a project in one language,
having it translated, re-importing it, and displaying it in the translated language.

The following text types can be managed in more than one language:

e Titles and comments

Block titles and block comments
Network titles and network comments
Line comments from STL programs

Comments from symbol tables, variable declaration tables, user-defined data types, and
data blocks

Comments, state names, and transition names in HiGraph programs

Extensions of step hames and step comments in S7-Graph programs

e Display texts

Message texts generated by STEP 7, S7-Graph, S7-HiGraph, S7-PDIAG or ProTool
System text libraries

User-specific text libraries

Operator-relevant texts

User texts
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Export

Exporting is done for all blocks and symbol tables located under the selected object. An export file
is created for each text type. This file contains a column for the source language and a column for
the target language. Text in the source language must not be changed.

Import

During import, the contents of the target-language columns (right-hand column) are integrated into
the project to which the selected object belongs. Only those translations whose source text
(exported text) matches an existing text in the "Source Language column are accepted.

Note

When you import the translated texts, these texts are replaced in the entire project. If, for example,
you have translated texts belonging to a certain CPU and these texts occur at other places in the
project, all the occurrences in the project will be replaced.

Changing Languages

When changing languages, you can choose from all the languages that were specified during
import into the selected project. The language change for "Title and Comments" is only applied to
the selected object. A language change for "Display Texts" is always applied to the complete
project.

Deleting a Language
When a language is deleted all the texts in this language are deleted from the internal database.

One language should always be available as a reference language in your project. This can, for
example, be your local language. This language should not be deleted. During exporting and
importing always specify this reference language as the source language. The target language can
be set as desired.

Reorganize

During reorganization, the language is changed to the language currently set. The currently set
language is the language that you selected as the "Language for future blocks". Reorganization
only affects titles and comments.

Comment Management

You can specify how comments for blocks should be managed in projects with texts being
managed in many languages.
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Basic Procedure

Create the export files for the franslation {menu
cotmnmand O ptionz = hanage Multiingual
Texts = Exporf).

+

Tranzlate the text.

v

lrnpart the translated filez (menu command
Options = Manage Multilingual Textz = [mport).

¥

Selectthe language in which the text iz o be
dizplayed {menu command Options = Manage
hAultiingual Texts = Change Languages).
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6.7.2.1

172

Types of Multilingual Texts

For export, a separate file will be created for each type of text. This file will have the text type as its
name and the export format as its extension (texttype.format: for example, SymbolComment.CSV

or SymbolComment.XLS). Files that do not satisfy the naming convention cannot be used as

source or target.

The translatable text within a project is divided into the following text types:

Text Type Description
BlockTitle Block title
BlockComment Block comments
NetworkTitle Network title
NetworkComment Network comments

LineComment

Line comments in STL

InterfaceComment

Var_Section comments (declaration tables in code blocks) and
UDT comments (user-defined data types) and
Data block comments

SymbolComment

Symbol comments

S7UserTexts Texts entered by the user which can be output on display devices

S7SystemTextLibrary Texts of system libraries which are integrated into messages can be updated
dynamically during runtime, and displayed on the PG or other display devices

S7UserTextLibrary Texts of user libraries which are integrated into messages can be updated

dynamically during runtime, and displayed on the PG or other display devices

HiGraphStateName
HiGraphStateComment

HiGraphTansitionName
HiGraphTransitionComment

S7-HiGraph
State name
State comment

Transition name
Transition comment

S7GraphStateName
S7GraphStateComment

S7-Graph
Step name extension
Step comment

Editors in other optional packages (such as ProTool, WIinCC, etc.) may have other
application-specific text types that are not described here.
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6.7.2.2  Structure of the Export File

The export file is structured as follows:

Example:

% Languages
F1Y Englizh (LISA) 5017 Englizh (LISA)
$ Type(MeteorkTitle)

Ihlaximum text length:

G4 characters
i$_Export on 16.11.2005 13:14:34

Firzt character sequence to be Tranzlation testl37_Programi{1)\Bloclks\0B1
tranzlated
Second character sequence Tranzlation teztS7_Programi] nBlocks\OE
to be tranzlated
Character sequence that is not testl37_Programi1)Blocls\0B1
to be dizplayed in the tranzlation

Source Language Target Language

Fundamentally, the following applies:
1. The following may not be changed, overwritten, or deleted:
- Fields beginning with "$_" (these are keywords)

- The numbers for the language (in the example above: 9(1) for the source language English
(USA) and 7(1) for the target language German).

2. Each file holds the text for just a single test type. In the example, the text type is NetworkTitle
($_Type(NetworkTitle). The rules for the translator who will edit this file are contained in the
introductory text of the export file itself.

3. Additional information regarding the text or comments must always appear before the type
definition ($_Type...) or after the last column.

Note

If the column for the target language has been overwritten with "512(32) $_Undefined," no target language was
specified when the file was exported. To obtain a better overview, you can replace this text with the target
language, for example, "9(1) English (US)" When importing the translated files, you must verify the proposed
target language and, if necessary, select the correct language.

You can hide text not to be displayed in the target language by entering the keyword $_hide. This does not apply
to comments on variables (InterfaceComment) and to symbols (SymbolComment).
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Export File Format
You specify the format in which export files are to be saved.

If you have decided to use CSV format, you must keep in mind when editing in Excel that a CSV
file can be only opened properly in Excel if the Open dialog is used. Opening a CSV file by
double-clicking in Explorer often results in an unusable file. You will find it easier to work with
CSV files in Excel if you use the following procedure:

1. Open the export file in Excel

2. Save the files as XLS files

3. Translate the text in the XLS files

4. Save the XLS files in Excel in CSV format.

Note
Export files may not be renamed.
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6.7.2.3 Information on the Log File

Error messages and warnings that appear when working with text managed in many languages are
output in a log file (TXT format). This file is stored in the same folder as the export files.

In general, the messages are self-explanatory. Any further explanations are listed below:

Warning: The Text 'xyz' in the 'xyz' file already exists. Further occurrences of the text were ignored.

Explanation

Regardless of its language, a text is used as the basis for the translation. If an identical text is used
for different terms in more than one language or more than once in one language, it can no longer
be uniquely identified and will thus not be translated.

Example:

$ Languages
711 Deutsch (Deutschland 01y English (T3 4)
kein 10ne
keine 10ne
keiner 10ne
7 N
Source language Target language

This only applies to titles and comments.

Remedy

Rename the texts concerned in the exported file (in the example, a single German word must be
used instead of three different ones), and then re-import the texts.
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6.7.2.4

176

Managing User Texts Whose Language Font is Not Installed

You can export user texts whose language font is not installed in your operating system, have them
translated and then import them back in and save them for use in your project.

However, such texts can only be displayed on a computer that has the appropriate language font
installed on it.

For example, if you have user texts that have to be translated into Russian and do not have a
Cyrillic font installed on you operating system, proceed as follows:

1.

Export the user text to be translated with the source language "English" and target language
"Russian”.

Send the export files to the translator, who will definitely have a Cyrillic font available.

Import the translated export files.
Result: The project is now available in English and Russian on you computer.

Save the whole project and send it to the customer who will use the Russian texts and will thus
have a Cyrillic font available to display them.
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6.7.2.5 Optimizing the Source for Translation

You can prepare the source material for translation by combining different terms and expressions.

Example

Before preparation (export file):

$ Language
511 Englizh {LJ5A) 5 (13 English (LS4
$ TywpelSyrmbolComment)
Auto-enah.

Automatic enable

Auto-—enahble

/ N

Source Language Target Language

Combining to a single expression:

$ _Languages

S (1) English (LISA) S (1) Englizh (LISA)
§ TyvpelSymbalCaormment)

Auto-enab. Auto-enahle
Autamatic enable Auto-enable
Auto-enable Auto-enable

~

Source Language Target Language

After preparation (that is, after import and subsequent export):

§_Lanouages
971 English {LISA) 9 (1) English (LISA)
F_TypelSyrmbolC ormiment)
Auto-enable Auto-enable
Source Language Target Language
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6.7.2.6  Optimizing the Translation Process

If you have projects where the structure and text are similar to a previous project, you can optimize
the translation process.

In particular, the following procedure is recommended for projects that were created by copying
and then modifying.

Prerequisite

There must be an existing translated export target.

Procedure
1. Copy the export files into the project folder for the new project to be translated.

2. Open the new project and export the text (menu command Options > Manage Multilingual
Texts > Export). Since the export target already exists, you will be asked whether the export
target should be extended or overwritten.

3. Click on the Add button.
4. Have the export files translated (only new text needs to be translated).

5. Then import the translated files.
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6.7.2.7

Example:

Hiding Texts in Selected Languages

Texts you do not want displayed in the target language can be hidden with the "$_hide" keyword.

6.7 Editing a Project

This does not apply to comments on variables (InterfaceComment) and symbols

(SymbolComment).

% Languages

Ty Enghsh (U5A)

{7y Enghsh (U054

B Type(MetworkTitle)

IMhdaximuim text length:
G4 characters

i _Export on 161120058 13:14:34

to be tranzlated

First character sequence to be Tranzlation test57_Programi1Blacks\OB1
tranzlated
Second character sequence Tranzlation tezfiS7_ProgramilBlocks OB

Character sequence that iz not
to be dizplayed in the tranzlation

testlS7_Programi1)\Blockz\OB1

Source Language
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6.7.3 Micro Memory Card (MMC) as a Data Carrier

6.7.3.1 What You Should Know About Micro Memory Cards (MMC)

Micro Memory Cards (MMC) are plug-in memory cards, for example, for a CPU 31xC or an
IM 151/CPU (ET 200S). Their most distinguishing feature is the highly compact design.

A new memory concept has been introduced for MMCs. It is briefly described below.

Content of the MMCs

The MMC serves as both the load memory and a data storage device (data carrier).

MMC as Load Memory

The MMCs contain the complete load memory for an MMC-compatible CPU. The load memory
contains the program with the blocks (OBs, DBs, FCs, ...) as well as the hardware configuration.
The contents of the load memory influence the functioning of the CPU. In the MMC's function as
load memory, blocks and the hardware configuration with loading functions can be transferred from
it (i.e. Download to CPU). Blocks downloaded to the CPU take effect immediately; however, the
hardware configuration does so only after the CPU is restarted.

Response to Memory Reset

The blocks stored on the MMC are retained after a memory reset.

Loading and Deleting
You can overwrite the blocks on the MMC.
You can erase the blocks on the MMC.

You cannot restore overwritten or erased blocks.

Programming with STEP 7
180 Manual, 05/2010, A5E02789666-01



Setting Up and Editing the Project
6.7 Editing a Project

Accessing Data Blocks on the MMC

On the MMC, you can use data blocks and data block contents to handle larger quantities of data
or data rather scarcely required in the user program. New system operations are available for that
purpose:

e SFC 82: creating data blocks in the load memory
e SFC 83: reading from the data block in the load memory

e SFC 84: writing to a data block in the load memory

MMC and Password Protection

If a CPU (i.e. a CPU in the 300-C family) that is fitted with a Micro Memory Card (MMC) is
password-protected, then the user will also be prompted to enter this password when opening this
MMC in the SIMATIC Manager (on a programming device/PC).

Displaying Memory Assignment in STEP 7

The display of the load memory assignment in the module status dialog ("Memory" tab) shows both
the EPROM and the RAM area.

Blocks on MMCs show a 100% EPROM behavior.
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6.7.3.2

6.7.3.3
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Using a Micro Memory Card as a Data Carrier

A SIMATIC Micro Memory Card (MMC) can be used with STEP 7 in the same manner as any
other type of external data storage medium.

After you have determined that the MMC has enough capacity to accommodate all the data to be
stored, you can transfer any data visible in the operating system's file explorer to the MMC.

In this way, you can make additional drawings, service instructions and functional descriptions
pertaining to your plant available to other personnel.

Memory Card File

Memory Card files (*.wld) are generated for the
e Software PLC WinLC (WinAC Basis and WinAC RTX) and
e SlotPLCs CPU 41x-2 PCI (WIinAC Slot 412 and WIinAC Slot 416).

The blocks and system data for a WinLC or CPU 41x-2 PCI can be saved in a Memory Card file as
in an S7-Memory Card. The contents of these files then correspond to the contents of a
corresponding Memory Card for a S7-CPU.

This file can then be downloaded by a menu command of the operating panel of the WinLC or CPU
41x-2 PCl into their download memories, corresponding to the downloading of the user program
with STEP 7.

In the case of the CPUs 41x-2 PCI this file can be downloaded automatically when the PC
operating system is started up, if the CPU 41x-2 PCl is not buffered and is only operated with a
RAM Card ("Autoload" function).

Memory Card files are "normal” files in the sense of Windows, which can be moved, deleted or
transported with a data medium with the Explorer.

For further information please refer to the corresponding documentation of the WinAC products.
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6.7.3.4  Storing Project Data on a Micro Memory Card (MMC)

With STEP 7 you can store the data for your STEP 7 project as well as any other kind of data (such
as WORD or Excel files) on a SIMATIC Micro Memory Card (MMC) in a suitable CPU or a
programming device (PG)/PC. This allows you to access project data with programming devices
that do not have the project saved on them.

Requirements

You can only store project data on an MMC if it is inserted in the slot of a suitable CPU or a
programming device (PG)/PC and there is an online connection established.

Be sure that the MMC has enough capacity to accommodate all the data to be stored on it.

Data that can be stored on an MMC

After you have determined that the MMC has enough capacity to accommodate all the data to be
stored, you can transfer all data visible in the operating system's file explorer to the MMC. These
data can include the following:

e Complete project data for STEP 7
e Station configurations

e Symbol tables

e Blocks and sources

e Texts managed in many languages

e Any other kinds of data, such as WORD or Excel files
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7 Editing Projects with Different Versions of STEP 7

7.1 Editing Version 2 Projects and Libraries

Version V5.2 of STEP 7 no longer supports Changes in V2 Projects. When you edit V2 projects
or libraries, inconsistencies can occur such that V2 projects or libraries can no longer be edited
with older versions of STEP 7.

In order to continue to edit V2 projects or libraries, a STEP 7 version older that V5.1 must be used.

7.2 Expanding DP Slaves That Were Created with Previous Versions
of STEP 7

Constellations That Can Be Formed by Importing New *.GSD Files

New DP slaves can be accepted by the HW Config if you install new device database files (*.GSD
files) into the Hardware Catalog. After installation, they are available in the Other Field Devices
folder.

You cannot reconfigure or expand a modular DP slave in the usual manner if all of the following
conditions exist:

e The slave was configured with a previous version of STEP 7.
e The slave was represented in the Hardware Catalog by a type file rather than a *.GSD file.

e A new *.GSD file was installed over the slave.

Remedy
If you want to use the DP slave with new modules that are described in the *.GSD file:

e Delete the DP slave and configure it again. Then the DP slave is described completely by the
*.GSD file, not by the type file.

If you do not want to use any new modules that are described only in the *.GSD file:

e Under PROFIBUS-DP in the Hardware Catalog window, select the "Other FIELD
DEVICES/Compatible PROFIBUS-DP Slaves" folder. STEP 7 moves the "old" type files into
this folder when they are replaced by new *.GSD files. In this folder you will find the modules
with which you can expand the already configured DP slave.
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7.2 Expanding DP Slaves That Were Created with Previous Versions of STEP 7

Constellation after Replacement of Type Files by GSD Files in STEP 7 V5.1 Service Pack 4

As of STEP 7 V5.1, Service Pack 4, the type files have been either updated or largely replaced by
GSD files. This replacement only affects the catalog profiles supplied with STEP 7, not any catalog
profiles that you may have created yourself.

DP slaves whose properties were previously determined by type files and are now determined by
GSD files are still located in the same place in the hardware catalog.

The "old" type files were not deleted but moved to another place in the hardware catalog. They are
now located in the catalog folder "Other field devices\Compatible PROFIBUS DP slaves\...".

Expanding an Existing DP Configuration with STEP 7, as of V5.1 Service Pack 4

If you edit a project that was created with a previous version of STEP 7 (earlier than V5.1, SP4)
and you want to expand a modular DP slave, then you cannot use the modules or submodules
taken from the usual place in the hardware catalog. In this case, use the DP slave found at "Other
FIELD DEVICES\Compatible PROFIBUS DP slaves\...".

Editing a DP Configuration with an Earlier Version of STEP 7 V5.1, SP4)

186

If you configure an "updated" DP slave with STEP 7 as of V5.1, Service Pack 4 and then edit the
project with a previous version of STEP 7 (earlier than STEP 7 V5.1, SP4), you will not be able to
edit this DP slave since the GSD file used is unknown to the previous version.

Remedy: You can install the required GSD file in the previous version of STEP 7. In this case, the
GSD file is stored in the project. If the project is subsequently edited with the current STEP 7
version will use the newly installed GSD file for the configuration.
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7.3 Editing Current Configurations with Previous Versions of STEP 7

7.3  Editing Current Configurations with Previous Versions of STEP 7

Configuring Direct Data Exchange (Lateral Communication)
Configuring direct data exchange with a DP master without a DP master system:
e Not possible with STEP 7 V5.0, Service Pack 2 (or older version)
e Possible with STEP 7 V5.0, as of Service Pack 3 and as of STEP 7 V5.1

If you save a DP master without its own DP master system with configured assignments for direct
data exchange and you continue to edit this project with an older version of STEP 7 V5 (STEP 7
V5.0, Service Pack 2 (or older)), the following effects can occur:

e A DP master system is displayed with slaves that are used for a STEP 7-internal data storage
area of the assignments for direct data exchange. These DP slaves do not belong to the
displayed DP master system.

e You cannot connect a new or an orphaned DP master system to this DP master.

Online Connection to the CPU by Means of a PROFIBUS-DP Interface
Configuring the PROFIBUS-DP interface without a DP master system:

e STEP 7 V5.0, Service Pack 2 (or older): a connection to the CPU by means of this interface is
not possible.

e Asof STEP 7 V5.0, Service Pack 3: During compilation, system data for the PROFIBUS-DP
interface are generated; a connection to the CPU by means of this interface is possible after
downloading.
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7.4  Appending SIMATIC PC Configurations of Previous Versions

PC Configurations of STEP 7 V5.1 Projects (up to SP 1)

As of STEP 7 V5.1, Service Pack 2 you can download communications to the PC station in the
same way as to an S7-300 or S7-400 station (without having to take the roundabout via
configuration file). Nevertheless, a configuration file is always generated during a storing or
compiling operation in order to enable the transmission of the configuration to the target PC station
using this method.

This bears the consequence that "older" PC stations cannot interpret some of the information
included in the newly generated configuration files. STEP 7 automatically adapts itself to this
circumstance:

e If you create a new SIMATIC PC station configuration with STEP 7 as of V5.1, Service Pack 2,
STEP 7 assumes that the target PC station was configured with the help of SIMATIC NET CD
as of 7/2001, that is, under the presumption that STRTM (Runtime Manager) is installed. The
configuration files are generated in such a way that they can be interpreted by a "new" PC
station.

e If you append a SIMATIC PC station configuration of a previous version (for example, the PC
station was configured with STEP 7 V5.1, Service Pack 1),. STEP 7 does not presume that the
target PC station was configured with the help of SIMATIC NET CD as of 7/2001. Those
configuration files are then generated in such a way that they can be interpreted by an "old" PC
station.

If this default behavior does not match your requirements, you can modify it as described below:

Setting in the Context Menu "Configuring Hardware ":
e Open the PC station hardware configuration
¢ Right-click on the station window (white area)
e Select the context-sensitive menu "Station Properties"

e Check or clear the "Compatibility" checkbox.

Setting in the Context Menu "Configuring Networks"
e Open the network configuration
Highlight the PC station

Select the menu command Edit > Object properties

In the dialog, select the "Configuration" tab

Check or clear the "Compatibility" checkbox.
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7.4 Appending SIMATIC PC Configurations of Previous Versions

PC Configurations of STEP 7 V5.0 Projects

You must convert the station if you want to edit a SIMATIC PC station configuration with STEP 7 as
of V5.0, Service Pack 3 to configure new components that are only supported by Service Pack 3 or
higher:

¢ Inthe SIMATIC Manager, highlight the SIMATIC PC station and select the menu command
Edit > Object properties.

¢ Inthe "Functions" tab of the properties dialog, click on the "Expand" button.
The SIMATIC PC station is then converted. Now, it can only be edited with STEP 7 V5.0,
Service Pack 3 or later versions.
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7.5 Displaying Modules Configured with Later STEP 7 Versions or

Optional Packages

As of STEP 7 V5.1 Service Pack 3, all modules are displayed, even those that were configured
with a later STEP 7 version and are thus unknown to the "older" STEP 7. Modules configured with
an optional package are also displayed, even if the required corresponding optional package is not
installed on the programming device (PG) used to open the given project.

In previous STEP 7 versions, such modules and their subordinate objects were not displayed. In
the current version, these objects are visible and can be edited to certain extent. For example, you
can use this function to also change user programs, even if the project was created on another
computer running a newer version of STEP 7 and the module (such as a CPU) cannot be
configured with the existing earlier STEP 7 version because this module has new properties and

new parameters.

The module "unknown" to STEP 7 is displayed as a generic, dummy module with the following

icon:

If you open the project with the appropriate STEP 7 version or with a compatible optional package,
all modules are displayed their standard way and there are no restrictions on editing.

PG with latest STEP 7 / with
optional package

PG with older STEP 7 / without
optional package

=

—_—

>>>---Project data--->>>

Represented by "known", latest

Represents the latest module as an

module "unknown" module
S = 0
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Working with a Dummy Module in the SIMATIC Manager

The dummy module is visible below the station level. All subordinate objects at this level such as
user programs, system data and connection tables are visible and can be downloaded from the
SIMATIC Manager.

You also open, edit, compile and load the user program (such as its blocks).
However, the following restrictions apply to projects with dummy blocks:
e You cannot copy a station containing a dummy block.

¢ Inthe menu command "Save project as..." the option "with reorganization" cannot be applied
completely.
The dummy module and all references and subordinate objects of these modules will be
missing in the copied and reorganized project (for example, the user program).

Working with a Dummy Module in the Hardware Configuration
The dummy module is displayed at the slot where it was configured.

You can open this module, but you cannot change its parameters or download to it. The module
properties are limited to those given in the "Dummy" tab property sheet. The station configuration
cannot be changed (such as by adding new modules).

Hardware diagnostics (such as opening a station online) are also possible (to a limited extent: new
diagnostic options and texts are not recognized.).

Working with a Dummy Module in the Network Configuration

The dummy module is also displayed in NetPro. In this case, the name of the module on the station
is preceded by question mark.

A project with a dummy module can only be opened write-protected in NetPro.

If you open the project in write-protected mode, you can display and print the network
configuration. You can also obtain the connection status, which will at least contain the information
supported by the STEP 7 version being used.

In general, however, you cannot make any changes or save, compile or download them.

Subsequent Installation of Modules

If the module is from a later version of STEP 7 and there is a HW update available for it, you can
replace the dummy module with the "real" one. Upon opening the station, you receive information
on the necessary HW updates or optional packages, and you can install them using the dialog. As
an alternative, you can install the modules from the start menu or in HW Config by selecting the
menu command Options > Install HW Updates.

Programming with STEP 7
Manual, 05/2010, A5E02789666-01 191



Editing Projects with Different Versions of STEP 7

7.5 Displaying Modules Configured with Later STEP 7 Versions or Optional Packages

Programming with STEP 7
192 Manual, 05/2010, A5E02789666-01



8.1

Defining Symbols

Absolute and Symbolic Addressing

Ina STEP 7 program you work with addresses such as I/O signals, bit memory, counters, timers,
data blocks, and function blocks. You can access these addresses in your program absolutely, but
your programs will be much easier to read if you use symbols for the addresses (for example,
Motor_A_On, or other identifiers according to the code system used within your company or
industry). An address in your user program can then be accessed via this symbol.

Absolute Addresses

An absolute address comprises an address identifier and a memory location (for example, Q 4.0,
11.1, M 2.0, FB21).

Symbolic Addresses

You can make your program easier to read and simplify troubleshooting if you assign symbolic
names to the absolute addresses.

STEP 7 can translate the symbolic names into the required absolute addresses automatically. If
you would prefer to access ARRAYs, STRUCTS, data blocks, local data, logic blocks, and
user-defined data types using symbolic names, you must first assign symbolic names to the
absolute addresses before you can address the data symbolically.

You can, for example, assign the symbolic name MOTOR_ON to the address Q 4.0 and then use
MOTOR_ON as an address in a program statement. Using symbolic addresses it is easier to
recognize to what extent the elements in the program match the components of your process
control project.

Note

Two consecutive underline characters (for example, MOTOR__ON) are not permitted in a symbolic
name (variable ID).
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Support with Programming

In the programming languages Ladder Logic, Function Block Diagram, and Statement List you can
enter addresses, parameters, and block names as absolute addresses or as symbols.

Using the menu command View > Display > Symbolic Representation you can toggle between
the absolute and symbolic representation of addresses.

To make it easier to program using symbolic addresses you can display the absolute address and
the symbol comment that belongs with the symbol. You can activate this information using the
menu command View > Display > Symbol Information. This means that the line comment
following every STL statement contains more information. You cannot edit the display; you must
make any changes in the symbol table or the variable declaration table.

The following figure shows you the symbol information in STL.

FB1003 : ntemupt Trigger
Network 1 ;727

U "Sensorl™ "H.0 Temperstire owerange"
UM "Switchz™ "N.2  Fault adinowled gment”
= "Lighton" "04.0 Intermupt signal”

When you print out a block, the current screen representation with statement comments or symbol
comments is printed.
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8.2 Shared and Local Symbols

8.2 Shared and Local Symbols

A symbol allows you to work with meaningful symbolic names instead of absolute addresses. The
combination of short symbols and longer comments can be used effectively to make programming
easier and program documentation better.

You should distinguish between local (block-specific) and shared symbols.

Shared Symbols

Local Symbols

Validity e |svalid in the whole user program, e  Only known to the block in which
e Can be used by all blocks, it was defined,
e Has the same meaning in all blocks, ¢  The same symbol can be used in
e Must be uni in the whol r oroaram different blocks for different
ust be unique e whole user program. purposes.
Permitted e Letters, numbers, special characters, o Letters,
characters e Accents other than 0x00, OxFF, and quotation |e  Numbers,
marks,
e  The symbol must be placed within quotation e Underscore ().
marks if you use special characters.
Use You can define shared symbols for:

e 1/Osignals (I, IB, IW, ID, Q, QB, QW, QD)
e 1/Oinputs and outputs (PI, PQ)

e Bit memory (M, MB, MW, MD)

e Timers (T)/ counters (C)

e Logic blocks (OB, FB, FC, SFB, SFC)

e Data blocks (DB)

e User-defined data types (UDT)

e Variable table (VAT)

e You can define local symbols for:

e Block parameters (input,
output, and in/out parameters),

e  Static data of a block,
e Temporary data of a block.

Defined where?

Symbol table

Variable declaration table for the
block
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8.3

196

Displaying Shared or Local Symbols

You can distinguish between shared and local symbols in the code section of a program as follows:

e Symbols from the symbol table (shared) are shown in quotation marks "..".

e Symbols from the variable declaration table of the block (local) are preceded by the character
H

You do not have to enter the quotation marks or the "#". When you enter your program in Ladder,

FBD, or STL the syntax check adds these characters automatically.

If you are concerned that there may be some confusion because, for example, the same symbols
are used in both the symbol table and the variable declaration, you must code the shared symbol
explicitly when you want to use it. Any symbols without the respective coding are interpreted as
block-specific (local) variables in this case.

Coding shared symbols is also necessary if the symbol contains blanks.

When programming in an STL source file the same special characters and guidelines for their use
apply. Code characters are not added automatically in free-edit mode, but they are still necessary if
you wish to avoid confusion.

Note

Using the menu command View > Display > Symbolic Representation you can toggle the display
between the declared shared symbolic and the absolute addresses.
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8.4  Setting the Address Priority (Symbolic/Absolute)

The address priority helps you to adapt the program code as you see fit when making changes in
the symbol table, changing parameter names of data blocks or function blocks or when changing
UDTs referring to component names or changing multiple instances

When making changes in the following situations, be sure to set the address priority carefully and
with a definite purpose in mind. In order for you to benefit from address priority, each change
procedure must be completed in itself before you start with another type of change.

To set the address priority, go to the SIMATIC Manager and select the block folder and then select
the menu command Edit > Object Properties. In the "Address Priority" tab, you can make the
settings that you deem appropriate.

Making optimal settings in address priority requires that the following situations for making a
change be distinguished:

e Correction of Individual Names
e Switching Names or Assignments

¢ New Symbols, Variables, Parameters or Components

Note

Please be aware that the absolute block number is the determining factor when making block calls ("Call FC" or
"Call FB, DB") for the logic block — even when symbolic address priority has been set!

Correction of Individual Names
Examples:

In the symbol table or in the program editor/block editor a spelling error in a name has to be
corrected. This applies to all names in the symbol table as well as to all the names of parameters,
variables or components that can be changed with the program editor/block editor.
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Setting the Address Priority:

Tracking Changes:

In the SIMATIC Manager, select the block folder and then select the menu command Edit > Check
Block Consistency. The "Check block consistency' function make the changes necessary in the
individual blocks.

Switching Names or Assignments
Examples:
e The names of existing assignments in the symbol table are switched.
e Existing assignments in the symbol table are assigned new addresses.

e Variable names, parameter names or component names are switched in the program
editor/block editor.
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8.4 Setting the Address Priority (Symbolic/Absolute)

Setting the Address Priority:

Tracking Changes:

In the SIMATIC Manager, select the block folder and then select the menu command Edit > Check
Block Consistency. The "Check block consistency" function makes the changes necessary in the
individual blocks.

New Symbols, Variables, Parameters or Components

Examples:
e You are creating new symbols for addresses used in the program.
e You are adding new variable or parameters to data blocks, UDTs or function blocks.

Setting the Address Priority:
e For changes in the symbol table.

e For changes in the program/block editor.
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Tracking Changes:

In the SIMATIC Manager, select the block folder and then select the menu command Edit > Check
Block Consistency. The "Check block consistency' function make the changes necessary in the
individual blocks.

8.5 Symbol Table for Shared Symbols

Shared symbols are defined in the symbol table.

An (empty) symbol table ("Symbols" object) is created automatically when you create an S7 or M7
program.

Validity
The symbol table is only valid for the module to which you link the program. If you want to use the
same symbols in a number of different CPUs, you yourself must ensure that the entries in the
various symbol tables all match up (for example, by copying the table).

8.5.1 Structure and Components of the Symbol Table

Structure of the Symbol Table
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8.5 Symbol Table for Shared Symbols

'&'1 Symbol Editor - 57-Program[1)[Symbols]-ZEn01_01_STEP7 _STL_1-9._. =]

Symbal Table Edit  |nsert

Wigw Optionz  Window  Help

EHE & & ER| o o ansmos % K2
=i 57-Program{1](Symbols])--ZEnD1_01_STEP7__STL_1-9ASIMATIC 300(1)\CPU314
Statuz[R | O | M | C | S| Symbal £ Address [ata type | Comment
1 CIOC I [ Adtomstic_Mode (@ 42 |BOOL Fetentive output
2 IO E W | Automstic_On I 05 BOOL Far the memary funci
3 T IE | |DE_Actusl_Speed (MY 4 |INT Actual speed for dies
4 T IE [ |DE_Failure I 1B BOOL Diezel engine failure
5 T |CE_Fan_on @ 56 |BOoL Cotnmand for swwitchi
E T [ DE_Fallovw_On T Z TIMER: Fuallowe-on time: for die
Fress F1 to get Help. | |HUM | L
Row
o If the columns for "Special Object Properties” were hidden (the menu command View >

Columns O, M, C, R, CC was deselected), this symbol appears in the row if the row concerned
has at least one "Special Object Property" set for it.

"Status" Column

- The symbol name or address is identical to another entry in the symbol table.

ot The symbol is still incomplete (the symbol name or the address is missing).

Programming with STEP 7
Manual, 05/2010, A5E02789666-01

201



Defining Symbols

8.5 Symbol Table for Shared Symbols

R/O/M/C/CC Columns

The columns R/O/M/CC show whether a symbol was assigned special object properties
(attributes):

R (monitoring) means that error definitions for process diagnostics were created for the symbol
with the optional package S7-PDIAG (V5).

O means that the symbol can be operated and monitored with WinCC.
M means that a symbol-related message (SCAN) was assigned to the symbol.
C means that the symbol is assigned communication properties.

CC means that the symbol can be quickly and directly monitored and controlled in the program
editor ('Control at Contact’).

Click on the check box to enable or disable these "special object properties”. You can also edit the
"special object properties" via Edit > Special Object Properties menu command

"Symbol" Column

The symbolic name must not be longer than 24 characters.

You cannot assign symbols in the symbol table for addresses in data blocks (DBD, DBW, DBB,
DBX). Their names are assigned in the data block declaration.

For organization blocks (OB) and some system function blocks (SFB) and system functions (SFC),
predefined symbol table entries already exist which you can import into the table when you edit the
symbol table of your S7 program. The import file is stored in the STEP 7 directory under
...\S7data\Symbol\Symbol.sdf.

"Address" Column

An address is the identifier for a particular memory area and memory location.
Example: Input | 12.1

The syntax of the address is checked as it is entered.

"Data Type" Column

You can choose between a number of data types available in STEP 7. The data type field already
contains a default data type that you may change, if necessary. If the change you make is not
suitable for the address or its syntax is incorrect, an error message appears as you exit the field.

"Comment" Column

You can assign comments to all symbols. The combination of brief symbolic names and more
detailed comments makes creating programs more effective and makes your program
documentation more complete. A comment can be up to 80 characters in length.

202

Programming with STEP 7
Manual, 05/2010, A5E02789666-01



Defining Symbols

8.5 Symbol Table for Shared Symbols

Converting to C Variables

You can select symbols in the symbol table for an M7 program and convert them to corresponding
C variables in conjunction with the ProC/C++ software option.

8.5.2

Addresses and Data Types Permitted in the Symbol Table

Only one set of mnemonics can be used throughout a symbol table. Switching between SIMATIC
(German) and IEC (English) mnemonics must be done in the SIMATIC Manager using the menu
command Options > Customize in the "Language" tab.

IEC | SIMATIC |Description Data Type Address
Range

| E Input bit BOOL 0.0 to 65535.7
1B EB Input byte BYTE, CHAR 0 to 65535

W EW Input word WORD, INT, S5TIME, DATE 0 to 65534

ID ED Input double word DWORD, DINT, REAL, TOD, TIME 0 to 65532

Q A Output bit BOOL 0.0 to 65535.7
QB AB Output byte BYTE, CHAR 0 to 65535
QW |[AW Output word WORD, INT, S5TIME, DATE 0 to 65534
QD AD Output double word DWORD, DINT, REAL, TOD, TIME 0 to 65532

M M Memory bit BOOL 0.0 to 65535.7
MB MB Memory byte BYTE, CHAR 0 to 65535
MW | MW Memory word WORD, INT, S5TIME, DATE 0 to 65534
MD MD Memory double word DWORD, DINT, REAL, TOD, TIME 0 to 65532
PIB PEB Peripheral input byte BYTE, CHAR 0 to 65535
PQB |PAB Peripheral output byte BYTE, CHAR 0 to 65535
PIW | PEW Peripheral input word WORD, INT, S5TIME, DATE 0 to 65534
PQW | PAW Peripheral output word WORD, INT, S5TIME, DATE 0 to 65534
PID PED Peripheral input double word DWORD, DINT, REAL, TOD, TIME 0 to 65532
PQD | PAD Peripheral output double word DWORD, DINT, REAL, TOD, TIME 0 to 65532

T T Timer TIMER 0 to 65535

C z Counter COUNTER 0 to 65535

FB FB Function block FB 0 to 65535
OB OB Organization block OB 1 to 65535
DB DB Data block DB, FB, SFB, UDT 1 to 65535

FC FC Function FC 0 to 65535
SFB | SFB System function block SFB 0 to 65535
SFC |SFC System function SFC 0 to 65535
VAT | VAT Variable table 0 to 65535
UDT |UDT User-defined data type uDT 0 to 65535
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8.5.3

Incomplete and Non-Unique Symbols in the Symbol Table

Incomplete Symbols

It is also possible to store incomplete symbols. You can, for example, enter only the symbol name
first and then add the corresponding address at a later date. This means you can interrupt your
work on the symbol table at any time, save the interim result, and complete your work another time.
Incomplete symbols are identified in the "Status" column by the * symbol. When you come to use
the symbol for creating software (without an error message appearing), you must have entered the
symbolic name, the address, and the data type.

How Ambiguous Symbols Occur

Ambiguous symbols occur when you insert a symbol in the symbol table whose symbolic name
and/or address was already used in another symbol row. This means both the new symbol and the

existing symbol are ambiguous. This status is indicated by the symbol = in the "Status" column.

This happens, for example, when you copy and paste a symbol in order to change the details in the
copy slightly.

Identification of Ambiguous Symbols

In the symbol table, ambiguous symbols are identified by highlighting them graphically (color, font).
This change in their representation means they still require editing. You can either display all
symbols or filter the view so that only unique or ambiguous symbols are displayed.

Making Symbols Unique
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An ambiguous symbol becomes unique when you change the component (symbol and/or address)
which caused this status. If two symbols are ambiguous and you change one of them to make it
unique, the other one also becomes unique.
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8.6  Entering Shared Symbols

There are three methods of entering symbols that can be used for programming at a later stage:

e Via Dialog Box
You can open a dialog box in the window where you are entering a program and define a new
symbol or redefine an existing symbol. This procedure is recommended for defining individual
symbols, for example, if you realize that a symbol is missing or you want to correct one while
you are writing the program. This saves you displaying the whole symbol table.

e Directly in the Symbol Table
You can enter symbols and their absolute addresses directly in a symbol table. This procedure
is recommended if you want to enter a number of symbols and for when you create the symbol
table for a project because you have the symbols which were already assigned displayed on
the screen, making it easier to keep an overview of the symbols.

e Import Symbol Tables from Other Table Editors
You can create the data for the symbol table in any table editor you are comfortable with (for
example, Microsoft Excel) and then import the file you created into the symbol table.

8.6.1 General Tips on Entering Symbols

To enter new symbols in the symbol table, position the cursor in the first empty row of the table and
fill out the cells. You can insert new rows before the current row in the symbol table using the menu
command Insert > Symbol. If the row before the cursor position already contains an address, you
will be supported when inserting new symbols by a presetting of the "Address" and "Data Type"
columns. The address is derived from the previous row; the default data type is entered as data

type.

You can copy and modify existing entries using the commands in the Edit menu. Save and then
close the symbol table. You can also save symbols which have not been completely defined.

When you enter the symbols, you should note the following points:

Column Note

Symbol The name must be unique within the whole symbol table. When you confirm the entry in this
field or exit the field, a non-unigue symbol is marked. The symbol can contain up to 24
characters. Quotation marks (") are not permitted.

Address When you confirm the entry in this field or exit the field, a check is made as to whether the
address entered is allowed.

Data Type When you enter the address, this field is automatically assigned a default data type. If you
change this default, the program checks whether the new data type matches the address.

Comment You can enter comments here to briefly explain the functions of the symbols (max. 80
characters). Entering a comment is optional.
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8.6.2 Entering Single Shared Symbols in a Dialog Box
The procedure described below shows you how you can change symbols or define new symbols in
a dialog box while programming blocks without having to display the symbol table.

This procedure is useful if you only want to edit a single symbol. If you want to edit a number of
symbols, you should open the symbol table and work in it directly.

Activating Symbol Display in a Block

You activate the display of symbols in the block window of an open block using the menu
command View > Display > Symbolic Representation. A check mark is displayed in front of the
menu command to show that the symbolic representation is active.

Defining Symbols When Entering Programs

1. Make certain that the symbolic representation is switched on in the block window (menu
command View > Display > Symbolic Representation.)

2. Select the absolute address in the code section of your program to which you want to assign a
symbol.

Select the menu command Edit > Symbol.

4. Fill out the dialog box and close it, confirming your entries with "OK" and making sure you enter
a symbol.

The defined symbol is entered in the symbol table. Any entries that would lead to non-unique
symbols are rejected with an error message.

Editing in the Symbol Table

Using the menu command Options > Symbol Table you can open the symbol table to edit it.
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8.6.3 Entering Multiple Shared Symbols in the Symbol Table

Opening the Symbol Table
There are a number of ways of opening a symbol table:
e Double-click the symbol table in the project window.

e Select the symbol table in the project window and select the menu command Edit > Open
Object.

The symbol table for the active program is displayed in its own window. You can now create
symbols or edit them. When you open a symbol table for the first time after it was created, it is

empty.

Entering Symbols

To enter new symbols in the symbol table, position the cursor in the first empty row of the table and
fill out the cells. You can insert new empty rows before the current row in the symbol table using
the menu command Insert > Symbol. You can copy and modify existing entries using the
commands in the Edit menu. Save and then close the symbol table. You can also save symbols
that have not been completely defined.

Sorting Symbols

The data records in the symbol table can be sorted alphabetically according to symbol, address,
data type, or comment.

You can change the way the table is sorted by using the menu command View > Sort to open a
dialog box and define the sorted view.

Filtering Symbols
You can use a filter to select a subset of the records in a symbol table.
Using the menu command View > Filter you open the "Filter" dialog box.

You can define criteria that the records must fulfill in order to be included in the filtered view. You
can filter according to:

e Symbol names, addresses, data types, comments

e Symbols with operator control and monitoring attribute, symbols with communication
properties, symbols for binary variables for messages (bit memory or process input)

e Symbols with the status "valid,"” "invalid (hon-unique, incomplete)"

The individual criteria are linked by an AND operation. The filtered records start with the specified
strings.

If you want to know more about the options in the "Filter" dialog box, open the context-sensitive
online help by pressing F1.
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8.6.4

Using Upper and Lower Case for Symbols

No Distinction between Upper and Lower Case Characters

Effects on

Previously it was possible to define symbols in STEP 7 which differed from one another only in the
case used for individual characters. This was changed in STEP 7, V4.02. It is now no longer
possible to distinguish between symbols on the basis of the case used.

This change was made in response to the wishes of our customers, and will greatly reduce the risk
of errors occurring in a program. The restrictions which have been made to the symbol definition
also support the aims of the PLCopen forum to define a standard for transferable programs.

Symbol definition based solely on a distinction between upper and lower case characters is now no
longer supported. Previously, for example, the following definition was possible in the symbol table:

Motorl =10.0
motorl =11.0

The symbols were distinguished on the basis of the case used for the first letter. This type of
differentiation carries with it a significant risk of confusion. The new definition eliminates this
possible source of errors.

Existing Programs

If you have been using this criterion to distinguish between different symbols you may experience
difficulties with the new definition if:

e Symbols differ from one another only in their use of upper and lower case characters
o Parameters differ from one another only in their use of upper and lower case characters
e Symbols differ from parameters only in their use of upper and lower case characters

All three of these conflicts can, however, be analyzed and resolved as described below.

Symbols which Differ from One Another Only in their Use of Upper and Lower Case Characters
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Conflict:

If the symbol table has not yet been edited with the current version of the software, the first of the
non-unique symbols in the table is used when source files are compiled.

If the symbol table has already been edited, such symbols are invalid; this means that the symbols
are not displayed when blocks are opened and source files containing these symbols can no longer
be compiled without errors.

Remedy:

Check your symbol table for conflicts by opening the table and saving it again. This action enables
the non-unique symbols to be recognized. You can then display the non-unigue symbols using the
filter "Non-Unique Symbols" and correct them. You should also correct any source files which
contain conflicts. You do not need to make any further changes to the blocks, as the current (now
conflict-free) version of the symbol table is automatically used or displayed when a block is opened.
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Parameters which Differ from One Another Only in their Use of Upper and Lower Case
Characters

Conflict:

Source files containing such interfaces can no longer be compiled without errors. Blocks with such
interfaces can be opened, but access to the second of these parameters is no longer possible.
When you try to access the second parameter, the program automatically returns to the first
parameter when the block is saved.

Remedy:

To check which blocks contain such conflicts, it is advisable to generate a source file for all the
blocks of a program using the function "Generate Source File." If errors occur when you attempt to
compile the source file you have created, there must be a conflict.

Correct your source files by ensuring that the parameters are unique; for example, by means of the
"Find and Replace" function. Then compile the files again.

Symbols which Differ from Parameters Only in their Use of Upper and Lower Case Characters
Conflict:

If shared and local symbols in a source file only differ from one another in their use of upper and
lower case characters, and is no initial characters have been used to identify shared ("symbol
name") or local (#symbol name) symbols, the local symbol will always be used during compilation.
This results in a modified machine code.

Remedy:

In this case it is advisable to generate a new source file from all of the blocks. This will
automatically assign local and shared access with the corresponding initial characters and will
ensure that they are handled correctly during future compilation procedures.
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8.6.5 Exporting and Importing Symbol Tables

You can export the current symbol table to a text file in order to be able to edit it with any text
editor.

You can also import tables created using another application into your symbol table and continue to
edit them there. The import function can be used, for example, to include in the symbol table
assignment lists created with STEP5/ST following conversion.

The file formats *.SDF, *.ASC, *.DIF, and *.SEQ are available to choose from.

Rules for Exporting
You can export the whole symbol table, a filtered subset of the symbol table, or rows selected in
the table view.

The properties of symbols that you can set using the menu command Edit > Special Object
Properties are not exported.

Rules for Importing

e For frequently used system function blocks (SFBs), system functions (SFCs)and organization
blocks (OBs)predefined symbol table entries already exist in the file
..\S7TDATA\SYMBOL\SYMBOL.SDF which you can import as required.

e The properties of symbols that you can set using the menu command Edit > Special Object
Properties are not taken into consideration when exporting and importing.

Programming with STEP 7
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8.6.6 File Formats for Importing/Exporting a Symbol Table

The following file formats can be imported into or exported out from the symbol table:
e ASCII file format (ASC)

e Data Interchange Format (DIF)
You can open, edit, and save DIF files in Microsoft Excel.

e System Data Format (SDF)
You can open, edit, and save SDF files in Microsoft Access.

To import and export data to and from the Microsoft Access application, use the SDF file
format.

In Access, select the file format "Text (with delimiters)".
Use the double inverted comma (") as the text delimiter.

Use the comma (,) as the cell delimiter.

e Assignment list (SEQ)
Caution: When exporting the symbol table to a file of the type .SEQ comments that are longer
than 40 characters are truncated after the 40th character.

ASCII File Format (ASC)

File Type * ASC

Structure: Record length, delimiter comma, record

Example: 126, green_phase_ped. T 2 TIMER Duration of green phase for pedestrians
126, red_ped. Q 0.0 BOOL Red for pedestrians
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Data Interchange Format (DIF)

File Type * DIF
Structure: A DIF file consists of the file header and the data:
Header TABLE Start of a DIF File
0,1
"<Title>" Comment string
VECTORS Number of records in the file

0,<No. of records>

TUPLES

Number of data fields in a record

0,<No. of columns>

DATA

ID for the end of the header and start of the data

0,0

Data (per record)

<type>,<numeric value>

ID for the data type, humeric value

<String>

Alphanumeric part or

\Y

if the alphanumeric part is not used

Header: the file header must contain the record types TABLE, VECTORS, TUPLES, and DATA in
the order specified. Before DATA, DIF files can contain further, optional record types. These are,
however, ignored by the Symbol Editor.

Data: in the data part, each entry consists of three parts: the ID for the Type (data type), a numeric
value, and an alphanumeric part.

You can open, edit, and save DIF files in Microsoft Excel. You should not use accents, umlauts, or
other special language characters.

212
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System Data Format (SDF)

File Type *.SDF

Structure: Strings in quotation marks, parts separated by commas

Example: "green_phase_ped.", T 2, TIMER","Duration of green phase for pedestrians"
"red_ped.", "Q 0.0 "BOOL","Red for pedestrians"

To open an SDF file in Microsoft Access you should select the file format "Text (with delimiter)'. Use
the double quotation mark (") as the text delimiter and the comma (,) as the field delimiter.

Assignment List (SEQ)

File Type *.SEQ

Structure: TAB Address TAB Symbol TAB Comment CR

Example: T2  green_phase_ped. Duration of green phase for pedestrians
Q 0.0 red_ped. Red for pedestrians

TAB stands for the tabulator key (09H),
CR stands for carriage return with the RETURN key (ODH).
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8.6.7

214

Editing Areas in Symbol Tables

As of STEP 7 V5.3, you can now select and edit contiguous areas within a symbol table. This
means that you can copy and/or cut parts of one symbol table and insert them into another symbol
table or delete them as required.

This makes it easier to update symbol tables by quickly transferring data from one symbol table to
another.

Areas that can be selected:

You can select entire rows as soon as you click in the first column in the row. If you want to
select all the fields, ranging from the "Status" column to the "Comments" column, then these
are also part of the selected row.

You can select one or more contiguous fields as an overall area. To be able to select this area,
all fields must belong to the "Symbol", "Address", "Data Type" and "Comments" columns. If you
make an invalid selection, the menu commands for editing will not be available.

The R, O, M, C, CC columns contain the special object properties for the respective symbols
and are only copied if the "Also copy special object properties” check box is selected in the
"Customize" dialog box (menu command Options > Customize).

The contents of the R, O, M, C, CC columns are copied if these columns are displayed. To
show or hide these columns, select the View > R, O, M, C, CC Columns menu command.

To edit a symbol table, proceed as follows:

1.

Select the area that you want to edit in the symbol table by using either of the following
methods:

- Using the mouse, click in the starting cell, and while keeping the left mouse button
depressed, move the mouse over the area that you want to select.

- Using the keyboard, select the area by pressing the shift key and then the cursor (arrow)
keys.

The selected area is shown in reverse video. The cell selected first is shown in normal display
and is surrounded by a frame.

Edit the area selected as required.
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Selecting an Editing Method

Depending on the programming language you use to create a program, you can enter your
program either in incremental input mode and/or free-edit (text) mode.

Incremental Editors for the Programming Languages Ladder Logic (LAD), Function Block
Diagram (FBD), Statement List (STL), or S7-GRAPH

In the incremental input mode editors for Ladder, FBD, STL, and S7-GRAPH, you create blocks
that are stored in the user program. You should choose to use incremental input mode if you want
to check what you have entered immediately. This edit mode is particularly suitable for beginners.
In incremental input mode, the syntax of each line or element is checked immediately after it has
been entered. Any errors are indicated and must be corrected before completing the entry. Entries
with correct syntax are automatically compiled and stored in the user program.

Any symbols used must be defined before editing the statements. If certain symbols are not
available, the block can not be fully compiled; this inconsistent interim version can, however, be
saved.

Source Code (Text) Editors for the Programming Languages STL, S7 SCL, or S7 HiGraph

In source code editors, you create source code files for subsequent compilation to generate
blocks.

We recommend you use source code editing, as this is a highly efficient program editing and
monitoring method.

The source code of the program or block is edited in a text file and then compiled.

The text files (source files) are stored in the sources folder of your S7 program, for example, as an
STL source file or SCL source file. A source file can contain code for one or multiple blocks. The
STL and SCL text editors allow you to generate source code for OBs, FBs, FCs, DBs, and UDTs
(user-defined data types), though you can use them to create a complete user program. One such
text file may contain the complete program (that is, all blocks) for a CPU.

When you compile the source file, the corresponding blocks will be generated and written to the
user program. All symbols used must be defined before you can compile them. Data errors are not
reported until the respective compiler interprets the source file.

It is imperative for compilation to stay conform with the prescribed syntax of the programming
language. A syntax check is only performed on account of a user instruction or when the source file
is compiled into blocks.
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9.2 Selecting the Programming Language

Setting the Programming Language for the Editor

Before you you generate a particular block or a source file, select the programming language and
editor via the object properties. This selection determines which editor is started when the block or
source file is opened.

Starting the Editor

Start the appropriate language editor either in SIMATIC Manager with a double-click on the
corresponding object (block, source file, etc.), by selecting the menu command Edit > Open
Object or click on the corresponding toolbar button.

To create an S7 program, the programming languages listed in the table are available to you. The
STEP 7 programming languages LAD, FBD, and STL are supplied with the standard STEP 7
software package. You can purchase other programming languages as optional software

packages.

You then have the choice of a number of different programming philosophies (Ladder Logic,
Function Block Diagram, Statement List, standard language, sequential control, or status graph)
and whether to use a text-based or a graphic programming language.

Select a programming language to determine the input mode (X).

Programming User Group Application Incremental Free-Ed | Block can be
Language Input it Mode | Documented
Back from the
CPU
Statement List STL | Users who prefer Programs X X X
programming in a optimized in
language similar to terms of run time
machine code and memory
requirements
Ladder Logic LAD | Users who are Programming of | X - X
accustomed to working | logic controls
with circuit diagrams
Function Block Users who are familiar | Programming of | X - X
Diagram FBD with the logic boxes of | logic controls
Boolean algebra
F-LAD, F-FBD Users who are familiar | Programming of | X - X
with the programming | safety programs
Optional package languages LAD and for F-systems
FDB.
SCL (Structured Users who have Programming - X -
Control Language) | programmed in data processing
high-level languages tasks
Optional package | Such as PASCAL or C
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programming/PLCs

Programming User Group Application Incremental Free-Ed | Block can be
Language Input it Mode | Documented
Back from the
CPU
S7-GRAPH Users who want to work | Convenient X - X
oriented on the description of
technological functions | sequential
Optional package | @nd do not have processes
extensive knowledge of
programming/PLCs
HiGraph Users who want to work | Convenient - X -
oriented on the description of
technological functions | asynchronous,
Optional package | @nd do not have non-sequential
extensive knowledge of | processes

CFC

Optional package

Users who want to work
oriented on the
technological functions
without extensive
programming or PLC
experience

Description of
continuous
processes

If blocks contain no errors, you can switch between Ladder Logic, Function Block Diagram, or
Statement List format. Program parts that cannot be displayed in the target language are shown in
Statement List format.

Under STL, you can generate blocks from source files and vice versa.
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9.21 Ladder Logic Programming Language (LAD)

The graphic programming language Ladder Logic (LAD) is based on the representation of circuit
diagrams. The elements of a circuit diagram, e.g. normally open contacts and normally closed
contacts, are combined to form networks. The code section of a logic block represents one or more

networks.

Example of Networks in LAD

MHetwark 1: Enable conditions
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The programming language LAD is supplied with the standard STEP 7 software package.
Programs are created under LAD with an incremental editor.
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9.2 Selecting the Programming Language

The programming language Function Block Diagram (FBD) is based on graphic logic symbols also

known in Boolean algebra. Complex functions such as math functions can also be displayed

directly in combination with the logic boxes.

The programming language FBD is supplied with the standard STEP 7 software package.

Example of a Network in FBD

==

0.0 —
101 —

TE—1

Metwork 1. Green phase for pedestrians

==1

hAD.0—

T4 —4

Programs are created in FBD with an incremental editor.
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9.2.3

Statement List Programming Language (STL)

The programming language STL is a text-based programming language with a structure similar to
machine code. Each statement represents a program processing operation of the CPU. Multiple

statements can be linked to form networks.

Example of Networks in Statement List
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The programming language STL is supplied with the standard STEP 7 software package. With this
programming language, you can use incremental editors to edit S7 blocks and you can create and
compile STL program source files in a source code editor to generate blocks.
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9.2.4 S7 SCL Programming Language

The programming language SCL (Structured Control Language) is available as an optional
package. This is a high-level text-based language whose global language definition conforms to
IEC 1131-3. The language closely resembles PASCAL and, other than in STL, simplifies the
programming of loops and conditional branches due to its high-level language commands, for
example. SCL is therefore suitable for calculating equations, complex optimization algorithms, or
the management of large data volume.

S7 SCL programs are written in the source code editor.

Example:
FUNCTION_BLOCK FB20
VAR_INPUT
ENDVAL: INT;
END_VAR
VAR_IN_OUT
Q1 : REAL;
END_VAR
VAR
INDEX: INT;

END_VAR

BEGIN

CONTROL:=FALSE;

FOR INDEX:= 1 TO ENDVALUE DO
IQ1:= 1Q1 * 2;
IF 1Q1 >10000 THEN

CONTROL = TRUE

END_IF

END_FOR;

END_FUNCTION_BLOCK
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9.25 S7-GRAPH Programming Language (Sequential Control)

The graphic programming language S7-GRAPH is available as optional package. It allows you to
program sequential controls. This includes the creation of sequencers and the specification of
corresponding step contents and transitions. You program the contents of the steps in a special
programming language (similar to STL). Transitions are programmed in a Ladder Logic Editor (a
light version of LAD).

S7-GRAPH displays even complex sequences very clearly and makes programming and
troubleshooting more effective.

Example of a Sequential Control in S7-GRAPH
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Blocks Created

With the S7-GRAPH editor you program the function block that contains the sequencer. A
corresponding instance DB contains the data for the sequencer, e.g. the FB parameters, step and
transition conditions. You can generate this instance DB automatically in the S7-GRAPH editor.

Source File

A text-based source file (GRAPH source file) can be generated from a function block created in
S7-GRAPH which can be interpreted by OPs or text-based displays for displaying the sequencer.
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S7 HiGraph Programming Language (State Graph)

The graphic programming language S7 HiGraph is available as an optional package. It allows you
to program a number of the blocks in your program as status graphs. Here you split your system
into dedicated functional units which can acquire different states and you define the transition
conditions between states. You describe the actions assigned to the states and the conditions for
the transitions between the states in a zoom-type language similar to Statement List.

You create a graph for each functional unit that describes the response of this functional unit. The
plant graphs are gathered in graph groups. The graphs can communicate to synchronize functional
units.

The well arranged view of the status transitions of a functional unit allows systematic programming
and simplifies debugging. The difference between S7-GRAPH and S7-HiGraph is, that the latter
acquires only one state (in S7-GRAPH: "step”) at any one time. The figure below shows how to
create graphs for functional units (example).

Position -
carm-operated switch
12 4 Counter- Coordinator
Inde withdrawn clockwise
v |/ E"
\ |' / w Workpiece
- W |
| A (
Clockwise
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9.2.7
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A graph group is stored in a HiGraph source file in the "Source" folder of the S7 program. This
source file is then compiled to generate S7 blocks for the user program.

Syntax and formal parameters are checked after the last entry was made in a graph (when the
working window is closed). Addresses and symbols are not checked until the source file is being
compiled.

S7 CFC Programming Language

The optional software package CFC (Continuous Function Chart) is a programming language used
to link complex functions graphically.

You use the programming language S7 CFC to link existing functions. You do not need to program
many standard functions yourself, instead you can use libraries containing standard blocks (for
example, for logic, math, control, and data processing functions). To use CFC you do not require
any detailed programming knowledge or specific knowledge of programmable control, and you can
concentrate on the technology used in your branch of industry.

The program created is stored in the form of CFC charts. These are stored in the "Charts" folder
beneath the S7 program. These charts are then compiled to form the S7 blocks for the user
program.

You may want to create blocks to be connected yourself, in which case you program them for
SIMATIC S7 with one of the S7 programming languages, and for SIMATIC M7 with C/C++.
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9.3

9.3.1

9.3 Creating Blocks

Creating Blocks

Blocks Folder

You can create the program for an S7 CPU in the form of:

e Blocks

e Source files

The folder "Blocks" is available under the S7 program for storing blocks.

This block folder contains the blocks you need to download to the S7 CPU for your automation
task. These loadable blocks include logic blocks (OBs, FBs, FCs) and data blocks (DB). An empty
organization block OB1 is automatically created with the block folder because you will always need
this block to execute your program in the S7 CPU.

The block folder also contains the following objects:

e The user-defined data types (UDT) you created. These make programming easier but are not
downloaded to the CPU.

e The variable tables (VAT) that you can create to monitor and modify variables for debugging
your program. Variable tables are not downloaded to the CPU.

e The object "System Data" (system data blocks) that contains the system information (system
configuration, system parameters). These system data blocks are created and supplied with
data when you configure the hardware.

e The system functions (SFC) and system function blocks (SFB) that you need to call in your
user program. You cannot edit the SFCs and SFBs yourself.

With the exception of the system data blocks (which can only be created and edited via the
configuration of the programmable logic controller), the blocks in the user program are all edited
using the respective editor. This editor is started automatically by double-clicking the respective
block.

Note
The blocks you programmed as source files and then compiled are also stored in the block folder.
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9.3.2

User-Defined Data Types (UDT)

User-defined data types are special data structures you create yourself that you can use in the
whole S7 program once they have been defined.

e User-defined data types can be used like elementary data types or complex data types in the
variable declaration of logic blocks (FC, FB, OB) or as a data type for variables in a data block
(DB). You then have the advantage that you only need to define a special data structure once
to be able to use it as many times as you wish and assign it any number of variables.

e User-defined data types can be used as a template for creating data blocks with the same data
structure, meaning you create the structure once and then create the required data blocks by
simply assigning the user-defined data type (Example: Recipes: The structure of the data block
is always the same, only the amounts used are different.)

User-defined data types are created in the SIMATIC Manager or the incremental editor — just like
other blocks.

Note

If you call a block created in the S7-SCL programming language that contains a UDT parameter in the
program editor, this can result in a type conflict. You should therefore avoid using blocks created in
SCL if you use UDTs.

Structure of a User-Defined Data Type

226

When you open a user-defined data type, a new working window is displayed showing the
declaration view of this user-defined data type in table form.

e The first and the last row already contain the declarations STRUCT and END_STRUCT for the
start and the end of the user-defined data type. You cannot edit these rows.

e You edit the user-defined data type by typing your entries in from the second row of the
declaration table in the respective columns.

e You can structure user-defined data types from:
- Elementary data types
- Complex data types
- Existing user-defined data types

The user-defined data types in the S7 user program are not downloaded to the S7 CPU. They are
either created directly using an incremental input editor and edited, or they are created when
source files are compiled.
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Block Properties

You can more easily identify the blocks you created if you use block properties and you can also
protect these blocks from unauthorized changes.

You should edit the block properties when the block is open. In addition to the properties you can
edit, the properties dialog box also displays data for your information only: you cannot edit this
information.

The block properties and system attributes are also displayed in the SIMATIC Manager in the
object properties for a block. Here you can only edit the properties NAME, FAMILY, AUTHOR, and
VERSION.

You edit the object properties after you insert the block via the SIMATIC Manager. If a block was
created using one of the editors and not in the SIMATIC Manager, these entries (programming
language) are saved automatically in the object properties.

Note

The mnemonics you want to use to program your S7 blocks can be set in the SIMATIC Manager using
the menu command Options > Customize and the "Language" tab.

Table of Block Properties

When entering block properties, you should observe the input sequence shown in the following
table:

Keyword / Property Meaning Example

[KNOW_HOW_PROTECT] Block protection; a block compiled with KNOW_HOW_PROTECT

this option does not allow its code
section to be viewed. The interface for
the block can be viewed, but it cannot be

changed.
[AUTHOR:] Name of author: company name, AUTHOR : Siemens, but no
department name, or other name keyword
(max. 8 characters without blanks)
[FAMILY:] Name of block family: for example, FAMILY : controllers, but no
controllers keyword
(max. 8 characters without blanks)
[NAME:] Block name (max. 8 characters) NAME : PID, but no keyword
[VERSION: int1 . int2] Version number of block VERSION : 3.10

(both numbers between 0 and 15,
meaning 0.0 to 15.15)

[CODE_VERSION1] ID whether a function block can have CODE_VERSION1

multiple instances declared or not. If you
want to declare multiple instances, the
function block should not have this

property
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Keyword / Property

Meaning

Example

[UNLINKED] for DBs only!

Data blocks with the UNLINKED property
are only stored in the load memory. They
take up no space in the working memory
and are not linked to the program. They
cannot be accessed with MC7
commands. Depending on the specific
CPU, the contents of such a DB can be
transferred to the working memory only
with SFC 20 BLKMOV or SFC 83
READ_DBL.

[Non-Retain]

Data blocks with this attribute are reset
to the load values after every power OFF
and power ON and after every
STOP-RUN transition of the CPU.

[READ_ONLY] for DBs only

Write protection for data blocks; its data
can only be read and cannot be changed

READ_ONLY

Read-only block

A copy of a block that is stored in
read-only status for reference purposes.
This property can only be assigned in
the program editor by selecting File >
Store Read-Only menu command.

The block protection KNOW_HOW_PROTECT has the following consequences:

e If you want to view a compiled block at a later stage in the incremental STL, FBD, or Ladder
editors, the code section of the block cannot be displayed.

e The variable declaration table for the block displays only the variables of the declaration types
var_in, var_out, and var_in_out. The variables of the declaration types var_stat and var_temp

remain hidden.
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Assignment: Block Property to Block Type

9.3 Creating Blocks

The following table shows which block properties can be declared for which block types:

Property

o8

FC

UDT

PN

KNOW_HOW_PROTECT

AUTHOR

FAMILY

NAME

VERSION

UNLINKED

READ_ONLY

Non-Retain

Read-only block

The KNOW_HOW_PROTECT property can be set in a source file when you program the block. It
is displayed in the "Block Properties" dialog box but cannot be changed.
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9.34 Displaying Block Lengths

Block lengths are displayed in "bytes."

Display in the Block Folder Properties
The following lengths are displayed in the block folder properties in the offline view:
e Size (sum of all blocks without system data) in the load memory of the programmable controller

e Size (sum of all blocks without system data) in the work memory of the programmable
controller

e Block lengths on the programming device (PG/PC) are not displayed in the block folder
properties.

Display in the Block Properties
The following are displayed in the block properties:
e Required number of local data: size of the local data in bytes
e MCY7: size of the MC7 code in bytes, or size of the DB user data
e Size of the load memory in the programmable controller

e Size of the work memory in the programmable controller: only displayed if hardware
assignment is recognized.

For display purposes, it does not matter whether the block is located in the window of an online
view or an offline view.

Display in the SIMATIC Manager (Details View)

If a block folder is opened and the "Details View" selected, the work memory requirement is
displayed in the project window, irrespective of whether the block folder is located in the window of
an online view or an offline view.

You can calculate the sum of the block lengths by selecting all the relevant blocks. In this case, the
sum of the selected blocks is displayed in the status bar of the SIMATIC Manager.

No lengths are displayed for blocks which cannot be downloaded to the programmable controller
(for example, variable tables).

Block lengths on the programming device (PG/PC) are not displayed in the Details view.
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9.3.5 Comparing Blocks

Introduction

To compare blocks that are in different locations, you can start the block comparison process in
either of the following ways:

e Go to the SIMATIC Manager and select the Options > Compare Blocks menu command. In
the "Compare Blocks - Results" dialog box that is displayed, click the "Go to" button. The
results of the comparison will appear in the program editor (LAD/FBD/STL) in the "Comparison"
tab

e Go to the program editor. Select the Options > Compare On-/Offline Partners menu
command.

The following sections explain how the block-comparison process functions. In the following
discussion, a distinction is maintained between logic blocks (OBs, FBs, FCs) and data blocks
(DBs).

The effect of the "Including SDBs" option during an ONLINE/offline comparison of blocks in the
SIMATIC Manager is described in the section: Comparing System Data Blocks (SDBS)

How Block Comparison Works: Logic Blocks

In the first step of the process, STEP 7 compares the time stamps for the interfaces of the logic
blocks to be compared. If these time stamps are identical, STEP 7 assumes that the interfaces are
identical.

If the time stamps are different, STEP 7 then compares the data types in the interfaces
step-by-step by section. When a difference is found, STEP 7 determines the first difference in a
section; that is, in each case the first difference in the respective declaration ranges.
Multi-instances and UDTs are also included in the comparison. If the data types in the sections are
the same, STEP 7 then compares the initial values of the variables. All differences are displayed.

In the second step, STEP 7 checks the code by network by network (in case the "Execute code
comparison" option was not selected, the code will still be compared if the "Go to" button in the
Program Editor is clicked.).

First, the inserted or deleted networks are detected. The results of the comparison will show
networks that are only present in one block. These will have the comment "only in".

Then, the remaining networks are compared until the first difference in statements is found.
Statements are compared in the following manner:

e For the setting "Absolute address has priority", based on the absolute address

e For the setting "Symbol has priority", based on the symbol
Note: If the blocks have symbolic priority and therefore also need to be compared in terms of
symbols, the "Perform detailed comparison" option should be enabled.

Statements are considered to identical if their operators and addresses are the same.

If the blocks to be compared were programmed in different programming languages, STEP 7
performs the comparison based on the STL language.

Special feature of offline-offline comparisons:
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In contrast to an offline-online comparison, in an offline-offline comparison, STEP 7also detects the
presence of different variable names. This additional step is not possible for an offline-offline
comparison since only replacement symbols are available online.

Comments for block networks and lines as well as other block attributes (such as S7-PDIAG
information and messages) are excluded from comparisons.

How Block Comparison Works: Data Blocks

In the first step of the process, STEP 7 compares the time stamps for the interfaces of the data
blocks to be compared (as for logic blocks). If these time stamps are identical, STEP 7 assumes
that the data structures are identical.

If the interface time stamps are different, STEP 7 then compares the data structures until the first
difference is found. If the data structures are in the sections are identical, STEP 7 then compares
the initial values and current values. All differences are displayed.

Special feature of offline-offline comparisons:

In contrast to an offline-online comparison, in an offline-offline comparison, STEP 7 also detects
the presence of different variable names. This additional step is not possible for an offline-offline
comparison since only replacement symbols are available online.

Comments and structures for UDTSs that are used in a data block are excluded from comparisons.

How Block Comparison Works: Data Types (UDT)

In the first step of the process, STEP 7 compares the time stamps for the interfaces of the data
types to be compared (as for data blocks). If these time stamps are identical, STEP 7 assumes that
the data structures are identical.

If the interface time stamps are different, STEP 7 then compares the data structures until the first
difference is found. If the data structures are in the sections are identical, STEP 7 then compares
the initial values. All differences are displayed.

How Block Comparison Works: Comparison in the Program Editor
1. Open the block to be compared to the loaded version.
2. Select the Options > Compare On-/Offline Parthers menu command.

- If the online partner is accessible, then the results of the comparisons will be displayed in
the lower section of the program editor window in the "7:Comparison" tab.

- Tip: If two networks are determined to be "different”, then you can open the relevant
network simply by double-clicking in its row.
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How Block Comparison Works: Comparison in the SIMATIC Manager

1. Inthe SIMATIC Manager, select the block folder or the blocks to be compared.

2. Select the Options > Compare Blocks menu command.

3. Inthe "Compare Blocks" dialog box that is displayed, select the type of comparison
(ONLINE/offline or Pathl/Path2).

4. For a Pathl/Path2 comparison: In the SIMATIC Manager, select the block folder or the blocks
to be compared. These blocks are then automatically entered in the dialog box.

5. If also want to compare SDBs, select the "Including SDBs" check box.

6. If you also want to compare code, select the "Execute code comparison” check box. In a
detailed comparison, in addition to the execution-related parts of the block (interface and code),
any changes in the names for local variables and parameters are displayed. In addition, you
can select the "Including blocks created in different programming languages" check box to
compare blocks created in different programming languages (e.g. AWL, FUP....). In this case,
the blocks are compared based on STL.

7. Confirm your settings in the dialog box by clicking "OK".

The results of the comparison are displayed in the "Compare Blocks - Results" dialog box.

8. To display the properties (i.e. time of last modification, checksum, etc.) of the compared blocks,
click on the "Details" button in this dialog box
To open the program editor, in which the results of the comparison are displayed in the lower
portion of the window, click the "Go to" button.

Note

When comparing an offline block folder with an online one, only loadable block types (OB, FB, ...
are compared.

When comparing offline/online or Path1/Path2, all blocks included in a multiple selection are
compared, even if some of then are not loadable ones (i.e. variable tables or UDTSs).
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9.3.6 Rewiring

The following blocks and addresses can be rewired:

Inputs, outputs
Memory bits, timers, counters

Functions, function blocks

To rewire:

1.

5.

Select the "Blocks" folder that contains the individual blocks you want to rewire in the SIMATIC
Manager.

Select the menu command Options > Rewire.

Enter the required replacements (old address/new address) in the table in the "Rewire" dialog
box.

Select the option "All addresses within the specified address area" if you want to rewire
address areas (BYTE, WORD, DWORD).

Example: You enter IW0 and IW4 as the address areas. The addresses 10.0 — 11.7 are then
rewired to the addresses 14.0 — 15.7. Addresses from the rewired area (for example, 10.1) can
then no longer be entered in the table individually.

Click the "OK" button.

This starts the rewire process. After rewiring is completed, you can specify in a dialog box whether
you want to see the info file on rewiring. This info file contains the address lists "Old address" and
"New address." The individual blocks are listed with the number of wiring processes that have been
carried out in each one.

When rewiring, the following should be noted:

When you rewire (that is, rename) a block, the new block cannot currently exist. If the block
exists, the process is interrupted.

When you rewire a function block (FB), the instance data block is automatically assigned to the
rewired FB. The instance DB does not change, that is, the DB number is retained.

9.3.7 Attributes for Blocks and Parameters

A description of the attributes can be found in the reference help on system attributes:

234

Jumps to Language Descriptions and Help on Blocks and System Attributes
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9.4  Working with Libraries

Libraries serve to store reusable program components for SIMATIC S7/M7. The program
components can be copied to the library from existing projects or created directly in the library
independently of other projects.

You can save yourself a lot of programming time and effort if you store blocks which you want to
use many times in a library in an S7 program. You can copy them from there to the user program
where they are required.

To create S7/M7 programs in a library, the same functions apply as for projects — with the
exception of debugging.

Creating Libraries

You can create libraries just like projects using the menu command File > New. The new library is
created in the directory you set for libraries in the "General" tab when you selected the menu
command Options > Customize.

Note

The SIMATIC Manager allows names that are longer than eight characters. The name of the library
directory is, however, cut off to eight characters. Library names must therefore differ in their first eight
characters. The names are not case-sensitive. When this directory is opened in the Browser, the full
name is displayed again, but when browsing for the directory, only the shortened name appears.

Note that you cannot use blocks from libraries of a new STEP 7 version in projects of an older
STEP 7 version.

Opening Libraries

To open an existing library, enter the menu command File > Open. Then select a library in the
dialog boxes that follow. The library window is then opened.

Note

If you cannot find the library you require in the library list, click the "Browse" button in the "Open"
dialog box. The standard Windows browser then displays the directory structure in which you can
search for the library.

Note that the name of the file always corresponds to the original name of the library when it was
created, meaning any name changes made in the SIMATIC Manager are not made at file level.

When you select a library it is added to the library list. You can change the entries in the library list
using the menu command File > Manage.
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Copying Libraries
You copy a library by saving it under another name using the menu command File > Save As.

You copy parts of a library such as programs, blocks, source files etc. using the menu command
Edit > Copy.

Deleting a Library
You delete a library using the menu command File > Delete.

You delete parts of a library such as programs, blocks, source files etc. using the menu command
Edit > Delete.
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94.1 Hierarchical Structure of Libraries

Libraries are structured in a hierarchical manner, just like projects:

Libraries can contain S7/M7 programs.

An S7 program can contain one "Blocks" folder (user program), one "Source Files" folder, one
"Charts" folder, and one "Symbols" object (symbol table).

An M7 program can contain charts and C programs for programmable M7 modules as well as a
"Symbols" object (symbol table) and a "Blocks" folder for data blocks and variable tables.

The "Blocks" folder contains the blocks that can be downloaded to the S7 CPU. The variable
tables (VAT) and user-defined data types in the folder are not downloaded to the CPU.

The "Source Files" folder contains the source files for the programs created in the various
programming languages.

The "Charts" folder contains the CFC charts (only if the S7 CFC optional software is installed).

When you insert a new S7/M7 program, a "Blocks" folder, "Source Files" folder (S7 only), and a
"Symbols" object are inserted automatically in it.

9.4.2 Overview of the Standard Libraries

The STEP 7 standard software package contains the following standard libraries

System Function Blocks: System Function Blocks (SFBs) and System Functions (SFCs)
S5-S7 Converting Blocks: Blocks for converting STEP 5 programs

IEC Function Blocks: Blocks for IEC functions, e.g. for processing time and date information,
comparison operations, string processing and selecting the min./max. values

Organization Blocks: Default organization blocks (OB)s

PID Control Blocks: Function Blocks (FBs) for PID control

Communication Blocks: Functions (FCs) and function blocks for SIMATICNET CPs.
TI-S7 Converting Blocks: Standard functions for general use

Miscellaneous Blocks: Blocks for time stamping and for TOD synchronization

When you install optional software packages, other libraries may be added.

Deleting and Installing the Supplied Libraries

You can delete the supplied libraries in SIMATIC Manager and then reinstall them. Run STPE 7
Setup to install the libraries.

Note

When you install STEP 7, the supplied libraries are always copied. If you edit these libraries, the
modified libraries will be overwritten with the originals when STEP 7 is installed again.

For this reason, you should copy the supplied libraries before making any changes and then only edit
the copies.
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10.1 Basics of Creating Logic Blocks

10.1.1 Structure of the Program Editor Window

The window of the program editor is split into the following areas:

Tables

The "Program Elements" tab displays a table of the program elements you can insert into your
LAD, FBD or STL program. The "Call Structure" tab shows the call hierarchy of the blocks in the
current S7 program.

Variable Declaration
The variable declaration is split in to the sections "Variable Table" and "Variable Detail View".

Instructions

The instruction list shows the block code that is to be processed by the PLC. It consists of one or
several networks.
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Details

The various tabs in the "Details" window provide functions, for example, for displaying error
messages, editing symbols, providing address information, controlling addresses, comparing
blocks and for editing error definitions for hardware diagnostics.
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10.1.2 Basic Procedure for Creating Logic Blocks

Logic blocks (OBs, FBs, FCs) consist of a variable declaration section, a code section as well as
their properties. When programming, you must edit the following three parts:

e Variable declaration: In the variable declaration you specify the parameters, system attributes
for parameters, and local block-specific variables.

e Code section: In the code section you program the block code to be processed by the
programmable controller. This consists of one or more networks. To create networks you can
use, for example, the programming languages Ladder Logic (LAD), Function Block Diagram
(FBD), or Statement List (STL).

e Block properties: The block properties contain additional information such as a time stamp or
path that is entered by the system. In addition, you can enter your own details such as name,
family, version, and author and you can assign system attributes for blocks.

In principle it does not matter in which order you edit the parts of a logic block. You can, of course,
also correct them and add to them.

Procedure for Prograrmiming Logic Blocks in STL

Create a logic block (FB, FC or QB) in
the SIMATIC Manager

Incremental STL Editar

Edit the varnable declaration table
for the bloclk.

}

Edit the code zection.

l

Editthe block properties.

Save the block
(rmeruy command File = Save)

|

Note

If you want to make use of symbols in the symbol table, you should first check that they are
complete and make any necessary corrections.
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10.1.3

10.1.4

242

Default Settings for the LAD/STL/FBD Program Editor
Before you start programming, you should make yourself familiar with the settings in the editor in
order to make it easier and more comfortable for you when programming.

Using the menu command Options > Customize you open a tabbed dialog box. In the various
tabs you can make the following default settings for programming blocks, e.g. in the "General" tab:

e The fonts (type and size) for text and tables.
e Whether you want symbols and comments to be displayed with a new block.

You can change the settings for language, comments, and symbols during editing using the
commands in the View >... menu.

You can change the colors used for highlighting, for example, networks or statement lines in the
"LAD/FBD" tab.

Access Rights to Blocks and Source Files

When editing a project, a common database is often used, meaning that a number of personnel
may want to access the same block or data source at the same time.

The read/write access rights are assigned as follows:

e Offline editing:
When you attempt to open a block/source file, a check is made to see whether you have 'write
access to the object. If the block/source file is already open, you can only work with a copy. If
you then attempt to save the copy, the system queries whether you want to overwrite the
original or save the copy under a new name.

e Online editing:
When you open an online block via a configured connection, the corresponding offline block is
disabled, preventing it from being edited simultaneously.
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10.1.5

Instructions from the Program Elements Table

9.4 Working with Libraries

The "Program elements" tab in the overview window provides LAD and FBD elements as well as

already declared multiple instances, pre-configured blocks and blocks from libraries. You can
access the tab via menu command View > Tables. You can also insert program elements in the

code section using the menu command Insert > Program Elements.

Example of the "Program Elements” Tab in LAD

E LAD/STL/FBD - [FB2 -- ZEnD1_05_STEP7__LAD_1-9\SIMATIC 300(... [M[=] E3
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----- -1 -MOTE-
..... <7 ..[ ]

..... <7 ..[ﬁ;]..

..... <7 .[H]

..... <7 .[S]

..... E [=1=8
..... E =

..... <3 .[N]
..... <3 ..[P]..
----- <> ~{SAVE)

-] Comparator
H-{ag] Converter
H-{#1] Counter
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5] Jurmps
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T IN_OUT
----- Il STAT
----- d& TEMP
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10.2

10.2.1

Editing the Variable Declaration

Using the Variable Declaration in Logic Blocks

After you open a logic block, a window opens that contains in the upper section the variable table
and the variable detail view for the block as well as the instruction list in the lower section in which
you edit the actual block code.

Example: Variable Views and Instruction List in STL
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ELAD!STL!FBD -[FB1 - ZEn01_02_STEP7__STL_1-10ASIMATIC 3... |H[=] E3

i+ File Edit |nsett PLC Debug “iew Options “Window Help _|ﬁ’|£|
| Contents OF 'EnvironmentsnterfaceN'
Interface [Mame Data Type |Address |Initial Value
=3 1N ‘= |Switch_0On  |Bool 0.0
Sk - ich O = Swith_Of _|Boal 01
- E“‘_’l't':h—'z'” '@ Failure Boal 0.2
=B Fallure
B Actual_Speed|int 2.0
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-l STAT
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1] | i
FE1 : Function Elock for Controlling the Engine :
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10.2 Editing the Variable Declaration

In the variable detail view, you specify the local variables and the formal parameters for the block
as well as the system attributes for parameters. This has the following effects:

e During declaration, sufficient memory space is reserved for temporary variables in the local
data stack, and in the case of function blocks, for static variables in the instance DB to be

associated later.

e When setting input, output, and in/out parameters you also specify the "interface" for the call of

a block in the program.

e When you declare the variables in a function block, these variables (with the exception of the
temporary variables) also determine the data structure for every instance DB that is associated

with the function block.

e By setting system attributes you assign special properties, for example, for the configuration of
message and connection functions, for operator control and monitoring functions and the

process control configuration.

Interaction Between The Variable Detail View And The Instruction List

The variable declaration and instruction list of logic blocks are closely related, because for
programming the names specified in the variable declaration are used in the instruction list. All
changes in the variable declaration will therefore influence the entire instruction list.

Action in the Variable Declaration

Reaction in the Code Section

Correct new entry

If invalid code present, previously undeclared variable
now becomes valid

Correct name change without type change

Symbol is immediately shown everywhere with its new
name

Correct name is changed to an invalid name

Code remains unchanged

Invalid name is changed to a correct name

If invalid code is present, it becomes valid

Type change

If invalid code is present, it becomes valid and if valid
code is present, this may become invalid

Deleting a variable (symbolic name) used in the code

Valid code becomes invalid

Change to comments, faulty input of a new variable, change to an initial value, or deleting an
unused variable has no effect on the instruction list.
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10.2.3 Structure of the Variable Declaration Window

The variable declaration window consists of the overview of variables and of the variable detalil
view.

ELAD!STL!FBD -[FB1 - ZEn01_02_STEP7__STL_1-10ASIMATIC 300(... |M[=] E3

i+ File Edit |nsett PLC Debug “iew Options “Wwindow Help _|5’|£|
| Contents OF 'EnvironmentsnterfaceN'
Interface [Mame Data Type |Address [Initial value |
=3 1N ‘= |Switch_0On  |Bool 0.0
Sk - ich O = Swith_Of _|Boal 01
- E“‘_’l't':h—'z'” '@ Failure Boal 0.2
=B Fallure
B Actual_Speed|int 2.0
B Actual_Speed . 5=
+-d0 OUT
-2 [M_OUT
-l STAT
TEMP
el «| | N

After you have generated and opened a new code block, a default variable table is displayed. It
lists only the declaration types (in, out, in_out, stat, temp) permitted for the selected block, namely
in the prescribed order. You can edit the default variable declaration that is displayed after you
have generated a new OB.

Permitted data types of local data for the various block types are found under Assigning the Data
Typs To Local Data Of Code Blocks.
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10.3 Multiple Instances in the Variable Declaration

10.3.1

Using Multiple Instances

It is possible that you may want to or have to use a restricted number of data blocks for instance
data owing to the performance (for example, memory capacity) of the S7 CPUs you are using. If
other existing function blocks are called in an FB in your user program (call hierarchy of FBs), you
can call these other function blocks without their own (additional) instance data blocks.

Use the following solution:

¢ Include the function blocks you want to call as static variables in the variable declaration of the
calling function block.

e In this function block, call other function blocks without their own (additional) instance data
blocks.

e This concentrates the instance data in one instance data block, meaning you can use the
available number of data blocks more effectively.

The following example illustrates the solution described: FB2 and FB3 use the instance DB of the
function block FB1 from which they were called.

FB 1 — Instance DB of FB 1
Declaration section: ___,....---"'"""ﬂ
static wariable of the
twpe "FBz to be called"
(FEZ, FE3)
FBz
iztance 1; FB 2 (uzes inztance DB
instance 2 FE 3 S—
FB-call:
CALL#nztance_1 -
CALL#nztance_ 2 FE 3
fuzesz instance DB
of FB 11

Only requirement: You must "tell" the calling function block which instances you are calling and
what (FB) type these instances are. These details must be entered in the declaration window of the
calling function block. The function block used must have at least one variable or parameter from
the data area (VAR_TEMP cannot be used).

Do not use multiple instance data blocks if online changes are expected while the CPU is running.
Surge-free reloading is only guaranteed when using instance data blocks.
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10.3.2

10.3.3

Rules for Declaring Multiple Instances

The following rules apply to the declaration of multiple instances:

Declaring multiple instances is only possible in function blocks that were created with STEP 7
from Version 2 onwards (see Block Attribute in the properties of the function block).

In order to declare multiple instances, the function block must be created as a function block
with multiple instance capability (default setting from STEP 7 Version x.x; can be deactivated in
the editor using Options > Customize).

An instance data block must be assigned to the function block in which a multiple instance is
declared.

A multiple instance can only be declared as a static variable (declaration type "stat").

Note

You can also create multiple instances for system function blocks.

If the function block was not created as being able to have multiple instances and you want it to have
this property, you can generate a source file from the function block in which you then delete the block
property CODE_VERSION1 and then compile the function block again.

Entering a Multiple Instance in the Variable Declaration Window

1.
2.

Open the function block from which the subordinate function blocks are to be called.

Define a static variable in the variable declaration of the calling function block for each call of a
function block for whose instance you do not want to use an instance data block.

- Inthe variable table, select hierarchy level "STAT".
- Enter a name for the FB call in the "Name" column of the variable detail view

- Enter the function block you want to call in the "Data type" column as an absolute address
or with its symbolic name.

- You can enter any explanations required in the comment column.

Calls in the Code Section

248

When you have declared multiple instances, you can use FB calls without specifying an instance

DB.

Example: If the static variable "Name: Motor_1, Data type: FB20" is defined, the instance can be
called as follows:

Call Motor_1 /I Call of FB20 without instance DB

Programming with STEP 7
Manual, 05/2010, A5E02789666-01



Basics of Creating Logic Blocks
10.4 General Nofes on Enfering Statements and Comments

104 General Notes on Entering Statements and Comments

10.4.1 Structure of the Code Section

In the code section you program the sequence for your logic block by entering the appropriate
statements in networks, depending on the programming language chosen. After a statement is
entered, the editor runs an immediate syntax check and displays any errors in red and italics.

The code section for a logic block generally comprises a number of networks that are made up of a
list of statements.

In a code section you can edit the block title, block comments, network title, network comments,
and statement lines within the networks.

Structure of the Code Section Using the STL Programming Language as an Example

& FBTD- <Offling:

el FETS : Engine Contrisl Pregram =

Bleck

comment _

Medwark

—_—
comment
A1 14 FBEComment
Staterpens ——» [ A @24
AN | 248
=a04

Matwork Z: FEF
Metwork title ———»
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10.4.2

250

Procedure for Entering Statements

You can edit the parts of the code section in any order. We recommend you proceed as follows
when you program a block for the first time:

Enter block title {optianal)

Y

Enter hlock comment (optional

5

Edit networks

Enter netwark: title {(optional)

Y

Enter netwark comment (optional)

L

Enter statements

Enter statermernt comments (optional)

Y

You can make changes in either overwrite mode or insert mode. You switch between modes using

the INSERT key.
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10.4.4

10.4 General Nofes on Enfering Statements and Comments

Entering Shared Symbols in a Program

Using the menu command Insert > Symbol you can insert symbols in the code section of your
program. If the cursor is positioned at the beginning, the end, or within a string, the symbol is
already selected that starts with this string - if such a symbol exists. If you change the string, the
selection is updated in the list.

Separators for the beginning and end of a string are, for example, blank, period, colon. No
separators are interpreted within shared symbols.

To enter symbols, proceed as follows:
1. Enter the first letter of the required symbol in the program.

2. Press CTRL and J simultaneously to display a list of symbols. The first symbol starting with the
letter you entered is already selected.

3. Enter the symbol by pressing RETURN or select another symbol.
The symbol enclosed in quotation marks is then entered instead of the first letter.

In general the following applies: if the cursor is located at the beginning, the end, or within a string,
this string is replaced by the symbol enclosed in quotation marks when inserting a symbol.

Title and Comments for Blocks and Networks
Comments make your user program easier to read and therefore make commissioning and

troubleshooting easier and more effective. They are an important part of the program
documentation and should certainly be made use of.

Comments in LAD, FBD and STL Programs

The following comments are available:

e Block title: title for a block (max. 64 characters)

e Block comment: documents the whole logic block, for example, the purpose of the block
e Network title: title for a network (max. 64 characters)

¢ Network comment: documents the functions of a single network

e Comment column in the variable detail view: comments the declared local data

e Symbol comment: comments that were entered for an address when its symbolic name was
defined in the symbol table.
You can display these comments using the menu command View > Display with > Symbol
Information.

In the code section of a logic block you can enter the block title and network title, and block
comments or network comments.
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Block Title or Network Title

To enter a block or network title, position the cursor on the word "Title" to the right of the block
name or network name (for example, Network 1: Title:). A text box is opened in which you can
enter the title. This can be up to 64 characters long.

Block comments pertain to the whole logic block. There they can comment the function of the

block. Network comments pertain to the individual networks and document details about the
network.

1. Metwork 2 Title:

‘--...._\__

2. Metwork 2; |The netwaork title is displayed here

Miouse click

To assign network titles automatically, select menu command Options > Settings and click on the
option "Automatic Assignment of Network Title" in the "General" tab. The symbol comment of the
first address entered will then be applied as network title.

Block Comments and Network Comments

252

You can toggle the view of the gray comment fields on and off using the menu command View >
Display with > Comments. A double-click on the comment field opens the text box in which you

can now enter your remarks. You are allowed 64 Kbytes per block for block comments and network
comments.

.,
H"“"-Mnuse click

2. Camtment far netwark ar block
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10.4.5 Entering Block Comments and Network Comments

1.

Activate the comments with the menu command View > Display with > Comments (a check
mark is visible in front of the menu command).

Position the cursor in the gray field below the block name or below the network name by
clicking with the mouse. The gray comment field appears white and has a border.

Enter your comment in the open text box. You are allowed 64 Kbytes per block for block
comments and network comments.

Exit the text box by clicking with the mouse outside the text box, by pressing the TAB key, or
using the key combination SHIFT+TAB.

If you select the menu command View > Display with > Comments again, you can switch off
the comments again (the check mark disappears).

10.4.6 Working with Network Templates

When programming blocks, if you would like to use networks multiple times, you can store these
networks in a library as network templates, complete with wildcards, if appropriate (for example, for
addresses). The library must be available before you create the network template.

Creating a Network Template

Create a new library in the SIMATIC Manager if necessary. Select the menu command Insert >
Program > S7 Program to insert a program into the library.

1.
2.

N o g s~ ow

Open the block that contains the network(s) from which you want to create a network template.

In the opened block, replace the title, comment, or addresses with wildcards as required. You
can use the strings %00 to %99 as wildcards. Wildcards for addresses are displayed in red.
This is not a problem here because you will not be saving the block after you create the
network template. You can replace the wildcards later with appropriate addresses when you
insert the network template into a block.

Select "Network <No.>" of the network(s) you want to include in the network template.
Select the menu command Edit > Create Network Template.

Enter a meaningful comment for each wildcard used in the dialog box displayed.
Click the "OK" button.

Select the source file folder of the S7 program in your network template library in the browser
that appears and enter a name for the network template.

Confirm your entry by clicking the "OK" button. The network template is stored in the selected
library.

Close the block without saving it.
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Inserting a Network Template in a Program

1. Open the block in which you want to insert the new network.

N

In the opened block, click in the network after which you want to insert a new network based on
the network template.

Open the "Program Elements" tab (menu command Insert > Program Elements).
Open the "S7 Program" folder of the relevant library in the catalog.
Double-click the network template.

In the dialog box, enter the required replacements for the wildcards in the network template.

N o g s~ ow

Click the "OK" button. The network template is then inserted after the current network.

Note
You can also drag and drop the template from the tab to the editor window.

10.4.7 Search Function for Errors in the Code Section

Errors in the code section are easy to recognize by their red color. To make it easier to navigate to
errors that lie outside the visible area on the screen, the editor offers two search functions Edit >
Go To > Previous Error/Next Error.

The search for errors goes beyond one network. This means that the whole code section is
searched and not just one network or the area currently visible on the screen.

If you activate the status bar using the menu command View > Status Bar, notes on the errors
found are displayed there.

You can also correct errors and make changes in overwrite mode. You toggle between insert mode
and overwrite mode using the INSERT key.
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10.5 Editing LAD Elements in the Code Section

10.5.1 Settings for Ladder Logic Programming

Setting the Ladder Logic Layout

You can set the layout for creating programs in the Ladder Logic representation type. The format
you select (A4 portrait/landscape/maximum size) affects the number of Ladder elements that can
be displayed in one rung.

1. Select the menu command Options > Customize.
2. Select the "LAD/FBD" tab in the following dialog box.

3. Select the required format from the "Layout” list box. Enter the required format size.

Settings for Printing

If you want to print out the Ladder code section, you should set the appropriate page format before
you start to program the code section.

Settings in the "LAD/FBD" Tab

In the "LAD/FBD" tab which is accessed using the menu command Options > Customize you can
make basic settings, e.g. concerning layout and address field width.
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10.5.2

Rules for Entering Ladder Logic Elements
You will find a description of the Ladder Logic programming language representation in the "Ladder
Logic for S7-300/400 - Programming Blocks" manual or in the Ladder Logic online help.

A Ladder network can consist of a number of elements in several branches. All elements and
branches must be connected; the left power rail does not count as a connection (IEC 1131-3).

When programming in Ladder you must observe a number of guidelines. Error messages will
inform you of any errors you make.

Closing a Ladder Network

Every Ladder network must be closed using a coil or a box. The following Ladder elements must
not be used to close a network:

e Comparator boxes
e Coils for midline outputs _/(#)_/

e Coils for positive _/(P)_/ or negative _/(N)_/ edge evaluation

Positioning Boxes

The starting point of the branch for a box connection must always be the left power rail. Logic
operations or other boxes can be present in the branch before the box.

Positioning Coils

256

Coils are positioned automatically at the right edge of the network where they form the end of a
branch.

Exceptions: Coils for midline outputs _/(#)_/ and positive _/(P)_/ or negative _/(N)_/ edge
evaluation cannot be placed either to the extreme left or the extreme right in a branch. Neither are
they permitted in parallel branches.

Some coils require a Boolean logic operation and some coils must not have a Boolean logic
operation.

e Coils which require Boolean logic:
- Output _/(), set output _/(S), reset output _/(R)
- Midline output _/(#)_/, positive edge /(P)_/, negative edge /(N) _/
- All counter and timer coils
- Jump if Not _/(JMPN)
- Master Control Relay On _/(MCR<)
- Save RLO into BR Memory /(SAVE)
- Return _/(RET)
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Coils which do not permit Boolean logic:

- Master Control Relay Activate _/(MCRA)

- Master Control Relay Deactivate _/(MCRD)
- Open Data Block _/(OPN)

- Master Control Relay Off _/(MCR>)

All other coils can either have Boolean logic operations or not.

The following coils must not be used as parallel outputs:

Jump if Not _/(JMPN)
Jump _/(IMP)

Call from Coil _/(CALL)
Return _/(RET)

Enable Input/Enable Output

The enable input "EN" and enable output "ENO" of boxes can be connected but this is not
obligatory.

Removing and Overwriting

If a branch consists of only one element, the whole branch is removed when the element is
deleted.

When a box is deleted, all branches which are connected to the Boolean inputs of the box are also
removed with the exception of the main branch.

The overwrite mode can be used to simply overwrite elements of the same type.

Parallel Branches

Constants

Draw OR branches from left to right.

Parallel branches are opened downwards and closed upwards.

A parallel branch is always opened after the selected Ladder element.
A parallel branch is always closed after the selected Ladder element.

To delete a parallel branch, delete all the elements in the branch. When the last element in the
branch is deleted, the branch is removed automatically.

Binary links cannot be assigned constants (i.e. TRUE or FALSE). Instead, use addresses of the
data type BOOL.

Programming with STEP 7
Manual, 05/2010, A5E02789666-01 257



Basics of Creating Logic Blocks

10.5 Editing LAD Elements in the Code Section

10.5.3 lllegal Logic Operations in Ladder

Power Flow from Right to Left

No branches may be created which may cause power to flow in the reverse direction. The following
figure shows an example: With signal state "0" at | 1.4 a power flow from right to left would result
at | 6.8. This is not permitted.

2.6 5.8

)e

~a lllegal power flowd
4.4 I| El.B

Short Circuit

No branches may be created which cause a short circuit. The following figure shows an example:

lMegal short circuit!
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10.6 Editing FBD Elements in the Code Section

10.6.1 Settings for Function Block Diagram Programming

Setting the Function Block Diagram Layout

You can set the layout for creating programs in the Function Block Diagram representation type.
The format you select (A4 portrait/landscape/maximum size) affects the number of FBD elements
that can be displayed in one rung.

1. Select the menu command Options > Customize.
2. Select the "LAD/FBD" tab in the following dialog box.

3. Select the required format from the "Layout” list box. Enter the required format size.

Settings for Printing

If you want to print out the FBD code section, you should set the appropriate page format before
you start to program the code section.

Settings in the "LAD/FBD" Tab

In the "LAD/FBD" tab which is accessed using the menu command Options > Customize you can
make basic settings, e.g. concerning layout and address field width.
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10.6.2

Rules for Entering FBD Elements
You will find a description of the programming language "FBD" in the "Function Block Diagram for
S7-300/400 - Programming Blocks" manual or in the FBD online help.

An FBD network can consist of a number of elements. All elements must be interconnected
(IEC 1131-3).

When programming in FBD, you must observe a number of rules. Error messages will inform you
of any errors you make.

Entering and Editing Addresses and Parameters

When an FBD element is inserted, the characters ??? and ... are used as token characters for
addresses and parameters.

e The red characters ??? stand for addresses and parameters which must be connected.
e The black characters ... stand for addresses and parameters which can be connected.

If you position the mouse pointer on the token characters, the expected data type is displayed.

Positioning Boxes

260

You can add standard boxes (flip flops, counters, timers, math operations, etc.) to boxes with
binary logic operations (&, >=1, XOR). The exceptions to this rule are comparison boxes.

No separate logic operations with separate outputs can be programmed in a network. You can,
however, assign a number of assignments to a string of logic operations with the help of a branch.
The following figure shows a network with two assignments.

H#ztart =
saner —g ==1 T branch
#eondition — —a &
#_next_red_car___| #oondition
#_dur_r_car | EI
==1

#ocond_02

#car —of _EI

The following boxes can only be placed at the right edge of the logic string where they close the
string:

e Set counter value
e Assign parameters and count up, assign parameters and count down
e Assign pulse timer parameters and start, assign extended pulse timer parameters and start

e Assign on-delay/off-delay timer parameters and start
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Some boxes require a Boolean logic operation and some boxes must not have a Boolean logic
operation.

Boxes which require Boolean logic:

Output, set output, reset output _/[R]

Midline output _/[#]_/, positive edge _/[P]_/, negative edge /[N]_/
All counter and timer boxes

Jump if Not _/[JMPN]

Master Control Relay On _/[MCR<]

Save RLO into BR Memory _/[SAVE]

Return _/[RET]

Boxes which do not permit Boolean logic:

Master Control Relay Activate [MCRA]
Master Control Relay Deactivate [MCRD]
Open Data Block [OPN]

Master Control Relay Off [MCR>]

All other boxes can either have Boolean logic operations or not.

Enable Input/Enable Output

The enable input "EN" and enable output "ENO" of boxes can be connected but this is not
obligatory.

Removing and Overwriting

When a box is deleted, all branches which are connected to the Boolean inputs of the box are also
removed with the exception of the main branch.

The overwrite mode can be used to simply overwrite elements of the same type.

Constants

Binary links cannot be assigned constants (i.e. TRUE or FALSE). Instead, use addresses of the
data type BOOL.
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10.7 Editing STL Statements in the Code Section

10.7.1 Settings for Statement List Programming

Setting the Mnemonics
You can choose between two sets of mnemonics:
e German
e English.

You set the mnemonics in the SIMATIC Manager with the menu command Options > Customize
in the "Language" tab before opening a block. While editing a block you cannot change the
mnemonics.

You edit the block properties in their own dialog box.

In the editor you can have a number of blocks open and edit them alternately as required.

10.7.2 Rules for Entering STL Statements

You will find a description of the Statement List programming language representation in the
"Statement List for S7-300/400 - Programming Blocks" manual or in the STL online help (Language
Descriptions).

When you enter statements in STL in incremental input mode, you must observe the following
basic guidelines:

e The order in which you program your blocks is important. Called blocks must be programmed
before calling blocks.

e A statement is made up of a label (optional), instruction, address, and comment (optional).
Example: M001: A 11.0 //[Comment

e Every statement has its own line.
e You can enter up to 999 networks in a block.

e Each network can have up to approximately 2000 lines. If you zoom in or out, you can enter
more or fewer lines accordingly.

e When entering instructions or absolute addresses, there is no distinction made between lower
and upper case.
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10.8 Updating Block Calls

You can use the menu command Edit > Block Call > Update in "LAD/STL/FBD - Programming S7
Blocks" to automatically update block calls which have become invalid. After you have carried out
the following interface changes, you must perform an update:

Inserted new formal parameters

Deleted formal parameters

Changed the name of formal parameters
Changed the type of formal parameters

Changed the order of formal parameters.

When assigning formal and actual parameters, you must follow the following rules in the order
specified:

1.

Same parameter names:

The actual parameters are assigned automatically, if the name of the formal parameter has
remained the same.

Special case: In Ladder Logic and Function Block Diagram, the preceding link for binary input
parameters can only be assigned automatically if the data type (BOOL) is the same. If the data
type has been changed, the preceding link is retained as an open branch.

Same parameter data types:

After the parameters with the same name have been assigned, as yet unassigned actual
parameters are assigned to formal parameters with the same data type as the "old" formal
parameter.

Same parameter position:

After you have carried out rules 1 and 2, any actual parameters which have still not been
assigned are now assigned to the formal parameters according to their parameter position in
the "old" interface.

If actual parameters cannot be assigned using the three rules described above, they are
deleted or, in the case of binary preceding links in Ladder Logic or Function Block Diagram,
they are retained as open branches.

After carrying out this function, check the changes you have made in the variable declaration table
and in the code section of the program.
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10.8.1

264

Changing Interfaces

You can also use the incremental Editor to modify the interfaces of offline blocks that have been
edited with STEP 7, version 5:

1. Make sure that all the blocks have been compiled with STEP 7, version 5. To do this, generate
a source file for all the blocks and compile it.
2. Modify the interface of the relevant block.
3. Now open all the calling blocks one after another - the corresponding calls are displayed in red.
4. Select the menu command Edit > Block Call > Update.
5. Generate the relevant instance data blocks again.
Note

Interface changes to a block opened online may cause the CPU to go into STOP mode.

Rewiring block calls
First modify the numbers of the called blocks and then execute the Rewire function to match up the calls.
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10.9 Saving Logic Blocks

To enter newly created blocks or changes in the code section of logic blocks or in declaration
tables in the programming device database, you must save the respective block. The data are then
written to the hard disk of the programming device.

To save blocks on the hard disk of the programming device:
1. Activate the working window of the block you want to save.
2. Select one of the following menu commands:
- File > Save saves the block under the same name.

- File > Save As saves the block under a different S7 user program or under a different
name. Enter the new path or new block name in the dialog box which then appears.

In both cases the block is saved only if its syntax contains no errors. Syntax errors are identified
immediately when the block is created and are then displayed in red. These errors must be
corrected before the block can be saved.

Note
e You can also save blocks or source files beneath other projects or libraries in the
SIMATIC Manager (by dragging & dropping, for example).
e You can only save blocks or complete user programs to a memory card in the SIMATIC Manager.

e If problems occur when saving or compiling large blocks, you should reorganize the project. Use
the menu command File > Reorganize in the SIMATIC Manager to do this. Then try to save or
compile again.
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11.1

Creating Data Blocks

Basic Information on Creating Data Blocks

The data block (DB) is a block in which you can, for example, store values for your machine or
plant to access. In contrast to a logic block that is programmed with one of the programming
languages Ladder Logic, Statement List, or Function Block Diagram, a data block contains only the
variable declaration section. This means the code section is irrelevant here and so is programming
networks.

When you open a data block, you can either view the block in the declaration view or in the data
view. You can toggle between the two views with the menu commands View > Declaration View
and View > Data View.

Declaration View

Data View

You use the declaration view if you want to:

e View or determine the data structure of shared data blocks,

e View the data structure of data blocks with an associated user-defined data type (UDT), or
e View the data structure of data blocks with an associated function block (FB).

The structure of data blocks that are associated with a function block or user-defined data type
cannot be modified. To modify them you must first modify the associated FB or UDT and then
create a new data block.

You use the data view if you want to modify data. You can only display, enter, or change the actual
value of each element in the data view. In the data view of data blocks, the elements of variables
with complex data types are listed individually with their full names.

Differences between Instance Data Blocks and Shared Data Blocks

A shared data block is not assigned to a logic block. It contains values required by the plant or
machine and can be called directly at any point in the program.

An instance data block is a block that is assigned directly to a logic block, such as a function block.
The instance data block contains the data that were stored in a function block in the variable
declaration table.
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11.2 Declaration View of Data Blocks

With data blocks that are not globally shared, the declaration view cannot be changed.

Column Explanation

Address Displays the address that STEP 7 automatically assigns for the variable when you finish
entering a declaration.

Declaration This column is only displayed for instance data blocks. It shows you how the variables in the
variable declaration of the function block are declared:

e Input parameter (IN)

e  Output parameter (OUT)

e In/out parameter (IN_OUT)
e  Static data (STAT)

Name Enter the symbolic nhame you have to assign to each variable here.

Type Enter the data type you want to assign to the variable (BOOL, INT, WORD, ARRAY, etc.).
The variables can have elementary data types, complex data types, or user-defined data
types.

Initial Value Here you can enter the initial value if you do not want the software to use the default value for

the data type entered. All values must be compatible with the data type.

When you save a block for the first time, the initial value is used as the current value if you
have not explicitly defined actual values for the variables.

Please note: Initial values cannot be downloaded to the CPU.

Comment Enter a comment in this field helps to document the variables. The comment can have up to
79 characters.

Programming with STEP 7
268 Manual, 05/2010, A5E02789666-01



Creating Data Blocks

11.3 Data View of Data Blocks

11.3 Data View of Data Blocks

The data view shows you the current values of all variables in the data block. You can only change
these values in the data view. The table representation in this view is the same for all shared data
blocks. For instance data blocks an additional "Declaration” column is displayed.

For variables with complex data types or user-defined data types, all elements are displayed in
their own row with their full symbolic name in the data view. If the elements are in the IN_OUT area
of an instance data block, the pointer points to the complex or user-defined data type in the "Actual
Value" column.

The data view displays the following columns:

Column

Explanation

Address

Displays the address that STEP 7 automatically assigns for the variable.

Declaration

This column is only displayed for instance data blocks. It shows you how the variables in the
variable declaration of the function block are declared:

e Input parameter (IN)

e  Output parameter (OUT)

e In/out parameter (IN_OUT)
e  Static data (STAT)

Name

The symbolic name assigned in the variable declaration for the variable. You cannot edit
this field in the data view.

Type

Displays the data type defined for the variable.

For shared data blocks, only the elementary data types are listed here because the
elements are listed individually in the data view for variables with complex or user-defined
data types.

For instance data blocks the parameter types are also displayed, for in/out parameters

(IN_OUT) with complex or user-defined data types, a pointer points to the data type in the
"Actual Value" column.

Initial Value

The initial value that you entered for the variable if you do not want the software to use the
default value for the specified data type.

When you save a data block for the first time, the initial value is used as the current value if
you have not explicitly defined actual values for the variables.

Please note: Unlike with actual values, initial values cannot be downloaded to the CPU.

Actual Value

Offline: The value that the variable had when the data block was opened or to which you
last changed it and saved it (even if you opened the data block online, this display is not
updated).

Online: The current value on opening the data block is displayed but not updated
automatically. To update the view, press F5.

You can edit this field if it does not belong to an in/out parameter (IN_OUT) with a complex
or user-defined data type. All values must be compatible with the data type.

Please note. Only current values can be downloaded to the CPU/

Comment

The comment entered to document the variable. You cannot edit this field in the data view.
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11.4 Editing and Saving Data Blocks

11.4.1 Entering the Data Structure of Shared Data Blocks

If you open a data block which is not assigned to a user-defined data type or function block, you
can define its structure in the declaration view of the data block. With data blocks which are not
shared, the declaration view cannot be changed.

1. Open a shared data block, meaning a block which is not associated with a UDT or FB.
2. Display the declaration view of the data block if this view is not set already.
3. Define the structure by filling out the table displayed in accordance with the information below.

With data blocks which are not shared, the declaration view cannot be modified.

Column Explanation

Address Displays the address which STEP 7 automatically assigns for the variable when you finish
entering a declaration.

Name Enter the symbolic name you have to assign to each variable here.

Type Enter the data type you want to assign to the variable (BOOL, INT, WORD, ARRAY, etc.). The

variables can have elementary data types, complex data types, or user-defined data types.

Initial Value Here you can enter the initial value if you do not want the software to use the default value for
the data type entered. All values must be compatible with the data type.

When you save a block for the first time, the initial value is used as the actual value if you have
not explicitly defined actual values for the variables.

Comment Entering an optional comment in this field helps to document the variable. The comment can
have up to 79 characters.
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11.4.2

Input

Display

11.4 Editing and Saving Data Blocks

Entering and Displaying the Data Structure of Data Blocks Referencing an
FB (Instance DBS)

When you associate a data block with a function block (instance DB), the variable declaration of
the function block defines the structure of the data block. Any changes can only be made in the
associated function block.

1. Open the associated function block (FB).
2. Edit the variable declaration of the function block.

3. Create the instance data block again.

In the declaration view of the instance data block you can display how the variables in the function
block were declared.

1. Open the data block.
2. Display the declaration view of the data block if this view is not set already.
3. See below for more information on the table displayed.

With data blocks which are not shared, the declaration view cannot be changed.

Column Explanation

Address Displays the address which STEP 7 automatically assigns for the variable.

Declaration This column shows you how the variables in the variable declaration of the function block are
declared:

e Input parameter (IN)

e  Output parameter (OUT)

e In/out parameter (IN_OUT)

e  Static data (STAT)

The declared temporary local data of the function block are not in the instance data block.

Name The symbolic name assigned in the variable declaration of the function block.

Type Displays the data type assigned in the variable declaration of the function block. The variables

can have elementary data types, complex data types, or user-defined data types.

If additional function blocks are called within the function block for whose call static variables
have been declared, a function block or a system function block (SFB) can also be specified
here as the data type.

Initial Value The initial value that you entered for the variable in the variable declaration of the function

block if you do not want the software to use the default value.

When you save a data block for the first time, the initial value is used as the actual value if
you have not explicitly defined actual values for the variables.

Comment The comment entered in the variable declaration for the function block to document the data

element. You cannot edit this field.
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Note

For data blocks that are assigned to a function block, you can only edit the actual values for the
variables. To enter actual values for the variables, you must be in the data view of data blocks.
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11.4.3 Entering the Data Structure of User-Defined Data Types (UDT)

1. Open the user-defined data type (UDT).

2. Display the declaration view if this view is not set already.

3. Define the structure of the UDT by determining the sequence of variables, their data type, and
an initial value if required using the information in the table below.

4. You complete the entry of a variable by exiting the row with the TAB key or RETURN.

Column Explanation

Address Displays the address which STEP 7 automatically assigns for the variable when you finish
entering a declaration.

Name Enter the symbolic name you have to assign to each variable here.

Type Enter the data type you want to assign to the variable (BOOL, INT, WORD, ARRAY, etc.).
The variables can have elementary data types, complex data types, or their own user-defined
data types.

Initial Value Here you can enter the initial value if you do not want the software to use the default value for
the data type entered. All values must be compatible with the data type.

When you save an instance of the user-defined data type (or a variable, or a data block) for
the first time, the initial value is used as the actual value if you have not explicitly defined
actual values for the variables.

Comment Entering a comment in this field helps to document the variables. The comment can have up
to 79 characters.
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11.4.4 Entering and Displaying the Structure of Data Blocks Referencing a UDT

Input

When you assign a data block to a user-defined data type, the data structure of the user-defined
data type defines the structure of the data block. Any changes can only be made in the associated
user-defined data type.

1. Open the user-defined data type (UDT).

2. Edit the structure of the user-defined data type.

3. Create the data block again.

Display

You can only display how the variables were declared in the user-defined data type in the
declaration view of the data block.

1. Open the data block.

2. Display the declaration view of the data block if this view is not set already.

3. See below for more information on the table displayed.

The declaration view cannot be modified. Any changes can only be made in the associated
user-defined data type.

Column Explanation

Address Displays the address which STEP 7 automatically assigns for the variable.

Name The symbolic name assigned in the variable declaration of the user data type.

Type Displays the data types assigned in the variable declaration of the user-defined data type.
The variables can have elementary data types, complex data types, or user-defined data
types.

Initial Value The initial value that you entered for the variable in the user-defined data type if you do not
want the software to use the default value.

When you save a data block for the first time, the initial value is used as the actual value if
you have not explicitly defined actual values for the variables.

Comment The comment entered in the variable declaration for the user-defined data type to document
the data element.

Note

For data blocks that are assigned to a user-defined data type, you can only edit the actual values
for the variables. To enter actual values for the variables, you must be in the data view of data

blocks.
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11.4.6

11.4 Editing and Saving Data Blocks

Editing Data Values in the Data View

Editing actual values is only possible in the data view of data blocks.

1. If necessary, toggle to the table display in the data view using the menu command View >
Data View.

2. Enter the required actual values for the data elements in the fields of the column "Actual
Value." The actual values must be compatible with the data type of the data elements.

Any incorrect entries (for example, if an actual value entered is not compatible with the data type)
made during editing are recognized immediately and shown in red. These errors must be corrected
before saving the data block.

Note
Any changes to the data values are only retained once the data block has been saved.

Resetting Data Values to their Initial Values

Resetting data values is only possible in the data view of data blocks.

1. If necessary, toggle to the table display in the data view using the menu command View >
Data View.

2. Select the menu command Edit > Initialize Data Block to do this.

All variables are assigned their intended initial value again, meaning the actual values of all
variables are overwritten by their respective initial value.

Note
Any changes to the data values are only retained once the data block has been saved.
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11.4.7 Saving Data Blocks

To enter newly created blocks or changed data values in data blocks in the programming device
database, you must save the respective block. The data are then written to the hard disk of the
programming device.

To save blocks on the hard disk of the programming device:
1. Activate the working window of the block you want to save.
2. Select one of the following menu commands:
- File > Save saves the block under the same name.

- File > Save As saves the block under a different S7 user program or under a different
name. Enter the new path or new block name in the dialog box which then appears. With
data blocks, you may not use the name DBO because this number is reserved for the
system.

In both cases the block is saved only if its syntax contains no errors. Syntax errors are identified
immediately when the block is created and are then displayed in red. These errors must be
corrected before the block can be saved.

Note

You can also save blocks or source files beneath other projects or libraries in the SIMATIC Manager (by dragging
& dropping, for example).

You can only save blocks or complete user programs to a memory card in the SIMATIC Manager.

If problems occur when saving or compiling large blocks, you should reorganize the project. Use the menu
command File > Reorganize in the SIMATIC Manager to do this. Then try to save or compile again.
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The function "Parameter Assignment for Data Blocks" allows you to do the following outside the
LAD/STL/FBD program editor:

Procedure:

Edit and download the actual values of instance data blocks to the PLC, without having to load
the entire data block.

Monitor instance data blocks online.

Use the "S7_techparam" system attribute (Technological Functions) to easily assign
parameters to instance data blocks and multiple instances and monitor them online.

In the SIMATIC Manager, double-click the instance data block to open it.

Answer the prompt asking if you want to open the function "Parameter Assignment for Data
Blocks" with "Yes". Result: the instance DB is opened in the "Parameter Assignment for Data
Blocks" application.

Choose the view in which the data block should be displayed by selecting the menu command
View > Data View or View > Declaration View.In the case of instance data blocks or multiple
instances with the "S7_techparam" system attribute, the "technological parameters"” view is
automatically opened.

Edit the instance date block as needed. Any pertinent information, warnings or errors will be
displayed in the message window. To go to the location of a warning or error, double-click on
the corresponding warning or error.

Download the changed actual value from the programming device (PG) to the CPU that you
have assigned to the current S7 program (menu command PLC > Download Parameter
Setting Data).

Select the menu command Debug > Monitor to display the program status for the opened
blocks and then monitor the editing of the loaded actual values online.

Note

You can recognize data blocks that have the "S7_techparam" system. To determine whether a block
has this system attribute, go to the SIMATIC Manager and select the block. Then select the menu
command Edit > Object Properties and open the "Attributes"” tab.
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12.1 Assigning Parameters to Technological Functions

With the function "Parameter Assignment for Data Blocks" you can easily assign parameters to the
temperature controller blocks FB 58 "TCONT_CP" and FB 59 "TCONT_S" that are supplied in the
standard library and monitor them online.

To do so, proceed as follows:

1.

In the SIMATIC Manager, open the STEP 7 standard library by selecting the menu command
File > Open > Libraries.

Select "PID Control Blocks" and then click on "Blocks". Here you will find the following function
blocks with the attribute "S7_techparam™:

-  FB 58 "TCONT_CP": Temperature controller for actuators with continuous or pulsing input
signals

- FB 59 "TCONT_S": Temperature controller for integral-type actuators

Copy the appropriate function block (FB 58 or FB 59) from the standard library into your
project.

Select the menu command Insert > S7 Block > Data Block to create an instance DB for the
FB that you selected.

In the SIMATIC Manager, double-click the instance DB to open it and start the function
"Parameter Assignment for Data Blocks".

Result: The instance DB is opened in the technological view. You can now easily assign
parameters to the instance DB and monitor it online.

Enter suitable controller values in the technological view. Any pertinent information, warnings
or errors will be displayed in the message window. To go to the location of a warning or error,
double-click on the corresponding warning or error.

Note

You can determine if blocks that have the system attribute "S7_techparam" by selecting a block in the
SIMATIC Manager, selecting the menu command Edit > Object Properties and then opening the
"Attributes" tab.
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13.1 Basic Information on Programming in STL Source Files

You can enter your program or parts of it as an STL source file and then compile it into blocks in
one step. The source file can contain the code for a number of blocks, which are then compiled as
blocks in one compilation run.

Creating programs using a source file has the following advantages:

e You can create and edit the source file with any ASCII editor, then import it and compile it into
blocks using this application. The compilation process creates the individual blocks and stores
them in the S7 user program.

e You can program a number of blocks in one source file.

e You can save a source file even if it contains syntax errors. This is not possible if you create
logic blocks using an incremental syntax check. However, the syntax errors are only reported
once you compile the source file.

The source file is created in the syntax of the programming language representation Statement List
(STL). The source file is given its structure of blocks, variable declaration, and networks using
keywords.

When you create blocks in STL source files you should note the following:
e Guidelines for Programming STL Source Files
e Syntax and Formats for Blocks in STL Source Files

e Structure of Blocks in STL Source Files
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13.2 Rules for Programming in STL Source Files

13.2.1 Rules for Entering Statements in STL Source Files

An STL source file consists mainly of continuous text. To enable the file to be compiled into blocks,
you must observe certain structures and syntax rules.

The following general guidelines apply to creating user programs as STL source files:

Topic Rule

Syntax The syntax of the STL statements is the same as in the incremental Statement List
editor. One exception to this is the CALL instruction.

CALL In a source file, you enter parameters in brackets. The individual parameters are

separated by a comma.

Example: FC call (one line)

CALL FC10 (paraml :=10.0,param2 :=10.1);
Example: FB call (one line)

CALL FB10, DB100 (paral :=10.0,para2 :=10.1);

Example: FB call (more than one line)
CALL FB10, DB100 (

paral :=10.0,

para2 :=10.1);

Note:

When calling a block, transfer the parameters in the defined order in the ASCII Editor.
Otherwise the comment assignment for these lines may not match in the STL and
source file views.

Upper/lower case

The editor in this application is not case-sensitive, the exception to this being system
attributes and jump labels. When entering strings (data type STRING) you must also
observe upper and lower case.

Keywords are shown in upper case. When compiled, upper and lower case are not
observed; therefore you can enter keywords in upper or lower case or a mixture of the
two.

Semicolon

Designate the end of every STL statement and every variable declaration with a
semicolon (;). You can enter more than one statement per line.

Double slash (//)

Begin every comment with a double slash (//) and end the comment with RETURN (or
line feed).
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13.2 Rules for Programming in STL Source Files

Rules for Declaring Variables in STL Source Files

For every block in the source file you must declare the required variables.
The variable declaration section comes before the code section of the block.

The variables must - if they are being used - be declared in the correct sequence for declaration
types. This means all variables of one declaration type are together.

For Ladder, Function Block Diagram, and Statement List you fill out a variable declaration table, but
here you have to work with the relevant keywords.

Keywords for Variable Declaration

Declaration Type

Keywords Valid for...

Input parameters

"VAR_INPUT" FBs, FCs
Declaration list
"END VAR"

Output parameters

"VAR_OUTPUT" FBs, FCs
Declaration list
"END VAR"

In/out parameters

"VAR_IN_OUT" FBs, FCs
Declaration list
"END VAR"

Static variables "VAR" FBs

Declaration list
"END_VAR"

Temporary variables

"VAR_TEMP" OBs, FBs, FCs
Declaration list

END_VAR

The keyword END_VAR denotes the end of a declaration list.

The declaration list is a list of the variables of a declaration type in which default values can be
assigned to the variables (exception: VAR_TEMP). The following example shows the structure of
an entry in the declaration list:

Duration_Motorl : S5TIME = S5T#1H_30M ;
Variable Data type Default value
Note

The variable symbol must start with a letter. You may not assign a symbolic name for a variable that is the same

as one of the reserved keywords.

If variable symbols are identical in the local declarations and in the symbol table, you can code local variables by
placing # in front of the name and putting variables in the symbol table in quotation marks. Otherwise, the block

interprets the variable as a local variable.
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13.2.3 Rules for Block Order in STL Source Files

Called blocks precede the calling blocks. This means:

The OB1 used in most cases, which calls other blocks, comes last. Blocks that are called from
OB1 must precede it.

User-defined data types (UDT) precede the blocks in which they are used.

Data blocks with an associated user-defined data type (UDT) follow the user-defined data type.
Shared data blocks precede all blocks from which they are called.

Instance data blocks follow the associated function block.

DBO is reserved. You cannot create a data block with this name.

13.2.4 Rules for Setting System Attributes in STL Source Files

System attributes can be assigned to blocks and parameters. They control the message
configuration and connection configuration, operator interface functions, and process control
configuration.

The following applies when entering system attributes in source files:

The keywords for system attributes always start with S7_.
The system attributes are placed in braces (curly brackets).
Syntax: {S7_identifier := 'string'}

a number of identifiers are separated by ";".

System attributes for blocks come before the block properties and after the keywords
ORGANIZATION_ and TITLE.

System attributes for parameters are included with the parameter declaration, meaning before
the colon for the data declaration.

A distinction is made between upper and lower case characters. This means that the correct
use of upper and lower case characters is important when entering system attributes.

The system attributes for blocks can be checked or changed in incremental input mode using the
menu command File > Properties under the "Attributes" tab.

The system attributes for parameters can be checked or changed in incremental input mode using
the menu command Edit > Object Properties. The cursor must be positioned in the name field of
the parameter declaration.
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13.2.5 Rules for Setting Block Properties in STL Source Files

You can more easily identify the blocks you created if you use block properties and you can also
protect these blocks from unauthorized changes.

The block properties can be checked or changed in incremental input mode using the menu
command File > Properties under the "General - Part 1" and "General - Part 2" tabs.

The other block properties can only be entered in the source file.

The following applies in source files:

Block properties precede the variable declaration section.
Each block property has a line of its own.

The line ends with a semicolon.

The block properties are specified using keywords.

If you enter block properties, they must appear in the sequence shown in the Table of Block
Properties.

The block properties valid for each block type are listed in the Assignment: Block Property to
Block Type.

Note

The block properties are also displayed in the SIMATIC Manager in the object properties for a block.
The properties AUTHOR, FAMILY, NAME, and VERSION can also be edited there.
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Block Properties and Block Order

When entering block properties, you should observe the input sequence shown in the following

table:

Order

Keyword / Property

Meaning

Example

1.

[KNOW_HOW_PROTECT]

Block protection; a block compiled with
this option does not allow its code
section to be viewed. The interface for
the block can be viewed, but it cannot
be changed.

KNOW_HOW_PROTECT

[AUTHOR:]

Name of author: company name,
department name, or other name
(max. 8 characters without blanks)

AUTHOR : Siemens, but no
keyword

[FAMILY?]

Name of block family: for example,
controllers
(max. 8 characters without blanks)

FAMILY : controllers, but no
keyword

[NAME]

Block name (max. 8 characters)

NAME : PID, but no
keyword

[VERSION: intl . int2]

Version number of block
(both numbers between 0 and 15,
meaning 0.0 to 15.15)

VERSION : 3.10

[CODE_VERSION1]

ID whether a function block can have
multiple instances declared or not. If
you want to declare multiple instances,
the function block should not have this

property

CODE_VERSION1

[UNLINKED] for DBs only

Data blocks with the UNLINKED
property are only stored in the load
memory. They take up no space in the
working memory and are not linked to
the program. They cannot be accessed
with MC7 commands. The contents of
such a DB can be transferred to the
working memory only with SFC 20
BLKMOV (S7-300. S7-400) or SFC 83
READ_DBL (S7-300C).

[NON_RETAIN]

This option is only effective if the CPU
supports the Retain property of DBs. A
data block with the "Non-Retain"
property is not stored in retentive
memory in such a CPU (for example
CPU 317 V2.1) and is therefore reset to
the load values at each power cycle
and after every change from STOP to
RUN.

READ_ONLY] only for DBs!

Write protection for data blocks; its data
can only be read and not changed.

FAMILY= Examples
VERSION= 3.10
READ_ONLY
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13.2.6 Permitted Block Properties for Each Block Type

The following table shows which block properties can be declared for which block types:

Property

OB

FB

FC

DB

ubT

KNOW_HOW_PROTECT

AUTHOR

FAMILY

NAME

VERSION

UNLINKED

NON_RETAIN

READ_ONLY

Setting Block Protection with KNOW_HOW_PROTECT

You can protect your blocks from unauthorized users by setting block protection using the keyword

KNOW_HOW_PROTECT when you program the block in the STL source file.

This block protection has the following consequences:

e If you want to view a compiled block at a later stage in the incremental STL, FBD, or Ladder
editors, the code section of the block cannot be displayed.

e The variable declaration list for the block displays only the variables of the declaration types
var_in, var_out, and var_in_out. The variables of the declaration types var_stat and var_temp

remain hidden.

e The keyword KNOW_HOW_PROTECT is entered before any other block properties.

Setting Write Protection for Data Blocks with READ_ONLY

For data blocks, you can set up write protection so that the block is not overwritten during program

processing. The data block must exist in the form of an STL source file to do this.

Use the keyword READ_ONLY in the source file to set write protection. This keyword must appear

immediately before the variable declarations in a line on its own.
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13.3 Structure of Blocks in STL Source Files

The blocks in STL source files are structured using keywords. Depending on the type of block,
there are differences in the structure of:

e Logic blocks
e Data blocks

e User-defined data types (UDT)

13.3.1 Structure of Logic Blocks in STL Source Files
A logic block is made up of the following sections, each of which is identified by the corresponding
keyword:
e Block start,
o identified by keyword and block number or block name, for example
- "ORGANIZATION_BLOCK OB1" for an organization block,
- "FUNCTION_BLOCK FB6" for a function block, or

- "FUNCTION FC1 : INT" for a function. With functions the function type is also specified.
This can be an elementary or complex data type (with the exception of ARRAY and
STRUCT) and defines the data type of the return value (RET_VAL). If no value is to be
returned, the keyword VOID is given.

e Optional block title introduced by the keyword "TITLE" (max. length of title: 64 characters)
e Additional comments, beginning with a double slash // at the start of the line

e Block properties (optional)

e Variable declaration section

e Code section, beginning with "BEGIN." The code section consists of one or more networks that
are identified by "NETWORK." You cannot enter a network number.

e Optional network for each network used, introduced by the keyword "TITLE =" (max. length of
title: 64 characters)

e Additional comments for each network, beginning with a double slash // at the start of the line

e Block end, identified by END_ORGANIZATION_BLOCK, END_FUNCTION_BLOCK, or
END_FUNCTION

e A blank must be placed between the block type and the block number. The symbolic block
name can be identified by quotation marks to ensure that the symbolic names of local variables
and names in the symbol table remain unique.
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13.3.3

13.3 Structure of Blocks in STL Source Files

Structure of Data Blocks in STL Source Files

A data block consists of the following areas that are introduced by their respective keywords:

e Block start, identified by keyword and block number or block name, for example,
DATA_BLOCK DB26

¢ Reference to an associated UDT or function block (optional)

e Optional block title introduced by the keyword TITLE = (entries longer than 64 characters are
cut off)

e Optional block comment, beginning with a double slash //

e Block properties (optional)

e Variable declaration section (optional)

e Assignment section with default values, beginning with BEGIN (optional)
e Block end, identified by END_DATA_ BLOCK

There are three types of data block:
e Data blocks, user-defined
e Data blocks with an associated user-defined data type (UDT)

e Data blocks with an associated function block (known as "instance" data blocks)

Structure of User-Defined Data Types in STL Source Files

A user-defined data type consists of the following areas that are introduced by their respective
keywords:

e Block start, identified by keyword TYPE and number or name, for example, TYPE UDT20
e Structured data type

e Block end, identified by END_TYPE

When you enter a user-defined data type, you must ensure that user-defined data types precede
the blocks in which they are used.
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13.4 Syntax and Formats for Blocks in STL Source Files
The format tables show the syntax and formats that you should observe when programming STL
source files. The syntax is represented as follows:
e Each element is described in the right column.
e Any elements that must be entered are shown in quotation marks.
e The square brackets [...] mean that the contents of these brackets are optional.

e Keywords are given in upper case letters.

13.4.1 Format Table of Organization Blocks

The following table shows a brief list of the format for organization blocks in an STL source file:

Structure Description

"ORGANIZATION_BLOCK" ob_no or ob_no is the block number, for example: OB1;

ob_name ob_name is the symbolic name of the block as defined in the
symbol table

[TITLE=] Block title (entries longer than 64 characters are cut off)

[Block comment] Comments can be entered after "//"

[System attributes for blocks] System attributes for blocks

[Block properties] Block properties

Variable declaration section Declaration of temporary variables

"BEGIN" Keyword to separate the variable declaration section from the
list of STL instructions

NETWORK Start of a network

[TITLE=] Network title (max. 64 characters)

[Network comment] Comments can be entered after "//"

List of STL instructions Block instructions

"END_ORGANIZATION_BLOCK" Keyword to end organization block
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13.4.2 Format Table of Function Blocks

The following table shows a brief list of the format for function blocks in an STL source file:

Structure

Description

"FUNCTION_BLOCK" fb_no or fo_name

fb_no is the block number, for example FB6;

fb_name is the symbolic name of the block as defined in the
symbol table

[TITLE=]

Block title (entries longer than 64 characters are cut off)

[Block comment]

Comments can be entered after "//"

[System attributes for blocks]

System attributes for blocks

[Block properties]

Block properties

Variable declaration section

Declaration of input, output, and in/out parameters, and
temporary or static variables

The declaration of the parameters may also contain the
declarations of the system attributes for parameters.

"BEGIN" Keyword to separate the variable declaration section from the
list of STL instructions

NETWORK Start of a network

[TITLE=] Network title (max. 64 characters)

[Network comment]

Comments can be entered after "//"

List of STL instructions

Block instructions

"END_FUNCTION_BLOCK

Keyword to end function block
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13.4.3
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Format Table of Functions

The following table shows a brief list of the format for functions in an STL source file:

Structure

Description

"FUNCTION" fc_no : fc_type or
fc_name : fc_type

fc_no is the block number, for example FCS5;

fc_name is the symbolic name of the block as defined in the
symbol table;

fc_type is the data type of the return value (RET_VAL) of the
function. This can be an elementary or complex data type (with
the exception of ARRAY and STRUCT) or VOID.

If you want to use system attributes

for the return value (RET_VAL), you must enter the system
attributes for parameters in front of the colon for the data
declaration.

[TITLE=]

Block title (entries longer than 64 characters are cut off)

[Block comment]

Comments can be entered after "//"

[System attributes for blocks]

System attributes for blocks

[Block properties]

Block properties

Variable declaration section

Declaration of input, output, and in/out parameters, and
temporary variables

"BEGIN" Keyword to separate the variable declaration section from the
list of STL instructions

NETWORK Start of a network

[TITLE=] Network title (max. 64 characters)

[Network comment]

Comments can be entered after "//"

List of STL instructions

Block instructions

"END_FUNCTION"

Keyword to end function
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13.4 Syntax and Formats for Blocks in STL Source Files

The following table shows a brief list of the format for data blocks in an STL source file:

Structure

Description

"DATA_BLOCK" db_no or db_name

db_no is the block number, for example DB5;

db_name is the symbolic name of the block as defined in the
symbol table

[TITLE=]

Block title (entries longer than 64 characters are cut off)

[Block comment]

Comments can be entered after "//"

[System attributes for blocks]

System attributes for blocks

[Block properties]

Block properties

Declaration section

Instance DB: specifies UDT or FB to which the block relates as
block number or name according to the symbol table.

Global DB: specifies the variables with their data type and start
value (optional)

"BEGIN"

Keyword to separate the declaration section from the list of
value assighments

[Assignment of current values]

Variables can have specific current values assigned. Individual
variables either have constants assigned or a reference is
made to other blocks.

"END_DATA_BLOCK"

Keyword to end data block
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13.5 Creating STL Source Files

13.5.1 Creating STL Source Files

The source file must be created in the source file folder beneath the S7 program. You can create
source files in the SIMATIC Manager or the editor window.

Creating Source Files in the SIMATIC Manager
1. Open the appropriate "Source Files" folder by double-clicking on it.

2. Toinsert an STL source file select the menu command Insert > S7 Software > STL Source
File.

Creating Source Files in the Editor Window
1. Select the menu command File > New.

2. Inthe dialog box, select the source file folder of the same S7 program that contains the user
program with the blocks.

3. Enter a name for the new source file.
4. Confirm with "OK".

The source file is created under the name you entered and is displayed in a window for editing.

13.5.2 Editing S7 Source Files

The programming language and editor with which a source file is edited can be set in the object
properties for the source file. This ensures that the correct editor and the correct programming
language are started when the source file is opened for editing. The STEP 7 Standard package
supports programming in STL source files.

Other programming languages are also available as optional packages. You can only select the
menu command to insert the source file if the corresponding software option is loaded on your
computer.

To edit an S7 source file, proceed as follows:
1. Open the appropriate "Source Files" folder by double-clicking on it.
2. Start the editor required for editing as follows:
- Double-click the required source file in the right half of the window.

- Select the required source file in the right half of the window and select the menu
command Edit > Open Object.
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13.5.5

13.5 Creating STL Source Files

Setting The Layout of Source Code Text

To improve readability of text in source files, select menu command Options > Settings and the
"Source Code" tab. Specify the font, font style and color for the various elements of the source
code.

For example, you can specify to display line numbers and to display keywords in upper case
letters.

Inserting Block Templates in STL Source Files

Block templates for organization blocks (OB), function blocks (FB), functions (FC), data blocks
(DB), instance data blocks, data blocks with associated user-defined data types, and user-defined
data types (UDT) are available for programming in STL source files. The block templates make it
easier to enter blocks in your source file and to observe syntax and structure guidelines.

To insert a block template, proceed as follows:
1. Activate the window of the source file in which you want to insert a block template.
2. Position the cursor at the point in the file after which you want to insert the block template.

3. Select one of the menu commands Insert > Block Template > OB/FB/FC/DB/Instance DB/DB
Referencing UDT/UDT.

The block template is inserted in the file after the cursor position.

Inserting the Contents of Other STL Source Files

You can insert the contents of other source files into your STL source file.
Proceed as follows:

1. Activate the window of the source file in which you want to insert the contents of another
source file.

2. Position the cursor at the location in the file after which you want to insert the source file.
3. Select the menu command Insert > Object > File.
4. Select the required source file in the dialog box which appears.

The contents of the selected source file are inserted after the cursor position. Line feeds (carriage
returns) are retained.
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13.5.6

13.5.7
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Inserting Source Code from Existing Blocks in STL Source Files

You can insert the source code from other blocks into your STL source file which were created in
Ladder, Function Block Diagram, or Statement List. This is possible for organization blocks (OB),
function blocks (FB), functions (FC), data blocks (DB), and user-defined data types (UDT).

Proceed as follows:
1. Activate the window of the source file in which you want to insert a block.

2. Position the cursor at the location in the file after which you want to insert the source code from
the block.

3. Select the menu command Insert > Object > Block.
4. Select the required block in the dialog box which appears.

An equivalent source file is generated from the block. The contents of the source file are inserted
after the cursor position.

Inserting External Source Files

You can create and edit a source file with any ASCII editor, then import it into a project and compile
it into individual blocks using this application. To do this, you must import the source files into the
"Source Files" folder of the S7 program in whose S7 user program the blocks created during
compilation are to be stored.

To insert an external source file, proceed as follows:

1. Select the source file folder of the S7 program in which the external source files are to be
imported.

2. Select the menu command Insert > External Source File.
3. Inthe dialog box which appears, enter the source file you want to import.

The file name of the source file you are importing must have a valid file extension. STEP 7 uses the
file extension to determine the source file type. This means, for example, that STEP 7 creates an
STL source file when it imports a file with the extension .AWL. Valid file 