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Legal information 
Use of application examples 

Application examples illustrate the solution of automation tasks through an interaction of several 
components in the form of text, graphics and/or software modules. The application examples are 
a free service by Siemens AG and/or a subsidiary of Siemens AG ("Siemens"). They are non-
binding and make no claim to completeness or functionality regarding configuration and 
equipment. The application examples merely offer help with typical tasks; they do not constitute 
customer-specific solutions. You yourself are responsible for the proper and safe operation of the 
products in accordance with applicable regulations and must also check the function of the 
respective application example and customize it for your system. 

Siemens grants you the non-exclusive, non-sublicensable and non-transferable right to have the 
application examples used by technically trained personnel. Any change to the application 
examples is your responsibility. Sharing the application examples with third parties or copying the 
application examples or excerpts thereof is permitted only in combination with your own products. 
The application examples are not required to undergo the customary tests and quality inspections 
of a chargeable product; they may have functional and performance defects as well as errors. It is 
your responsibility to use them in such a manner that any malfunctions that may occur do not 
result in property damage or injury to persons. 
 

Disclaimer of liability 
Siemens shall not assume any liability, for any legal reason whatsoever, including, without 
limitation, liability for the usability, availability, completeness and freedom from defects of the 
application examples as well as for related information, configuration and performance data and 
any damage caused thereby. This shall not apply in cases of mandatory liability, for example 
under the German Product Liability Act, or in cases of intent, gross negligence, or culpable loss of 
life, bodily injury or damage to health, non-compliance with a guarantee, fraudulent 
non-disclosure of a defect, or culpable breach of material contractual obligations. Claims for 
damages arising from a breach of material contractual obligations shall however be limited to the 
foreseeable damage typical of the type of agreement, unless liability arises from intent or gross 
negligence or is based on loss of life, bodily injury or damage to health. The foregoing provisions 
do not imply any change in the burden of proof to your detriment. You shall indemnify Siemens 
against existing or future claims of third parties in this connection except where Siemens is 
mandatorily liable. 

By using the application examples you acknowledge that Siemens cannot be held liable for any 
damage beyond the liability provisions described. 
 

Other information 
Siemens reserves the right to make changes to the application examples at any time without 
notice. In case of discrepancies between the suggestions in the application examples and other 
Siemens publications such as catalogs, the content of the other documentation shall have 
precedence.  

The Siemens terms of use (https://support.industry.siemens.com) shall also apply.  
 

Security information 
Siemens provides products and solutions with industrial security functions that support the secure 
operation of plants, systems, machines and networks. 

In order to protect plants, systems, machines and networks against cyber threats, it is necessary 
to implement – and continuously maintain – a holistic, state-of-the-art industrial security concept. 
Siemens’ products and solutions constitute one element of such a concept. 

Customers are responsible for preventing unauthorized access to their plants, systems, machines 
and networks. Such systems, machines and components should only be connected to an 
enterprise network or the internet if and to the extent such a connection is necessary and only 
when appropriate security measures (e.g. firewalls and/or network segmentation) are in place.  

For additional information on industrial security measures that may be implemented, please visit 
https://www.siemens.com/industrialsecurity. 

Siemens’ products and solutions undergo continuous development to make them more secure. 
Siemens strongly recommends that product updates are applied as soon as they are available 
and that the latest product versions are used. Use of product versions that are no longer 
supported, and failure to apply the latest updates may increase customer’s exposure to cyber 
threats. 

To stay informed about product updates, subscribe to the Siemens Industrial Security RSS Feed 
at: http://www.siemens.com/industrialsecurity. 

https://support.industry.siemens.com/
https://www.siemens.com/industrialsecurity
http://www.siemens.com/industrialsecurity
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Preface 
 

SIMATIC PCS 7 offers a wide range of setting options for texts and languages. The 
following chapters describe in detail how they are correctly configured, adjusted or 
changed. 

Purpose of the document 

This description helps to provide information on safe handling of the configuration 
options of texts and languages in a PCS 7 project. 

Main contents 

This document looks at the following key elements: 

 general information on texts and languages in the PCS 7 project 

 language settings in PCS 7 for AS/OS engineering 

 language settings based on different configuration scenarios 

Validity 

Valid for SIMATIC PCS 7 V9.0 
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1 Overview 

1.1 Texts and languages in PCS 7 project 

The schematic display below shows in which places the texts and languages 
matter in a SIMATIC PCS 7 project. 

Figure 1-1 
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1.2 Basics 

1.2.1 Explanation of terms 

For assigning byte values to text characters, a number of different, mostly 
incompatible sets of characters exist - aside from Unicode. Probably the most 
important character encoding for the Internet is the "American Standard Code for 
Information Interchange" (ASCII). In ASCII each character is coded with 7 bits; so a 
maximum of 128 characters are possible. The ASCII comprises – apart from some 
control characters – mainly English letters of the Latin alphabet and Arabic 
numbers. Many of the accented characters and umlauts of the many European 
languages are not contained in the ASCII characters set, not even to mention 
characters of other alphabets. Numerous character sets that are larger than the 
ASCII and that comprise more characters have therefore been developed in the 
course of time. In order to provide a larger character supply, the individual 
characters of these character sets are encoded with more than 7 bits.  

However, even with an 8 bit encoding per character only 256 different characters 
can be encoded. This is why characters sets have been introduced that use more 
than one byte for the encoding of each text character. Character sets that use two 
bytes to display their characters are called "Double Byte Character Set" (DBCS).  

ASCII Code 

The ASCII encoding was published in June 17, 1963 and 1967 as standard (ASA 
X3.4-1963), and finally updated in 1968 (ANSI X3.4-1968). Each character is 
assigned a bit pattern of 7 bits. Since every bit can take on two values, this results 
in 2

7
 = 128 different bit patterns that can also be interpreted as whole numbers 0–

127 (hexadecimal 00–7F). 

The character encoding defines 128 characters consisting of 33 non-printable ones 
and 95 printable ones. The latter ones are starting with the blank: 

 !"#$%&'()*+,-./0123456789:;<=>?  

@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_ 

`abcdefghijklmnopqrstuvwxyz{|}~ 

The printable characters comprise the Latin alphabet in upper and lower case 
letters, the ten Arabic numbers as well as some punctuation characters. The 
character repertoire corresponds largely to that of an English keyboard or 
typewriter. In computers and other electronic devices that display text it is usually 
stored additionally, in accordance with ASCII or downward compatible (ISO 8859, 
Unicode). 
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Unicode 

Conventional computer characters codes comprise only a limited repertoire of 
characters, for western character encodings this limit is 128 (7 bit) code positions –
 just as for the very well known ASCII standard – or 256 (8 bit) positions, such as, 
for example, for ISO 8859-1 (also known as Latin-1) or EBCDIC. Once the Control 
characters have been deducted, 95 elements can be displayed as characters and 
Special characters for ASCII and 191 elements for the 8 bit ISO character sets. 
This Character encoding enables the simultaneous representation of only few 
languages in the same text, unless deciding to use different fonts with different 
Character sets. 
Unicode is a brand name for an alphanumerical character set ("Character 
Encoding Scheme"; CES); a system standardized by the international 
standardization organization ISO for encoding text characters (letters, syllables, 
ideograms, punctuation characters, special characters, numbers). The official 
name for the Unicode character set is "Universal Character Set". Unicode attempts 
to summarize all known text character in one character set, this means not only the 
letters of the Latin alphabet but also the Greek, Cyrillic, Arabic, Hebrew, Thai 
alphabet and the so called CJK scripts, i.e. the different Chinese (traditional CN 
and simplified CN), Japanese (Katakana, Hiragana and Kanji) and Korean (Hangul) 
scripts. Furthermore, mathematical, economical and technical special characters 
can be encoded in Unicode.  

Note The use of European and Asia languages still depends on installation in 
SIMATIC PCS 7. 

 

Double Byte Character Set 

Double Byte Character Set (DBCS) is a character set that uses a maximum of two 
byte to display all characters. This results in a maximum of 65,536 different 
characters that can be represented. As opposed to this, character sets which only 
require one byte per character are also referred to as Single Byte Character Set 
(SBCS). DBCS is a special case of the Multibyte Character Sets (MBCS) which 
uses a variable number of bytes to encode a character. 

Multilingual operating system (MUI) 

Microsoft is marketing system expansions for the Windows operating system and 
Office suite, which make it possible to use the user interface (incl. help texts) of the 
respective programs in several languages under the term Multilingual User 
Interface (MUI) in one installation. An English language product must have been 
installed as a basis each time. If a MUI is installed, the desired language can be set 
in the Control Panel under the Regional and Language Options. 

 

http://de.wikipedia.org/wiki/Microsoft
http://de.wikipedia.org/wiki/Microsoft_Windows
http://de.wikipedia.org/wiki/Microsoft_Office
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1.2.2 PCS 7 versions 

SIMATIC PCS 7 can be ordered in two different versions. 

European  

Contains the following default languages: 

 English (US) 

 German 

 French 

 Italian 

 Spanish 

Asian 

Contains the following default languages: 

 Chinese (Simplified) 

 English (US) 

 

Note Depending on what version of PCS 7 is installed, the default libraries will be 
available in the respective languages. 

It already comprises all messages and operator control texts in the default 
languages which are contained in the respective version. 
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2 Windows Installation and Settings 
 

Figure 2-1: Influence of the operating system language 

 

Selection of the operating system 

The product bundle PCs of PCS 7 are delivered with a multilingual operating 
system. 

On those, the default language is English. Other language packages for German, 
French, Italian, Spanish (European version) and Chinese (simplified) are 
preinstalled. 

If you install a PC yourself, the following is recommended for the selection of the 
operating system: 

 If only one language is to be used on the PC, select the operating system in 
the language for the configuration/process management. 

 If several languages are to be used, select a multilingual operating system 
(default: English) and additionally install the Multilingual User Interface Packs 
(MUI). 

Note Details can be found in the manual 
"Process Control System PCS 7 – PC Configuration and Authorization" in 
chapter "Installing PC stations". 

 

Language settings in Windows operating system 

The table below shows where the language settings can be made in the operating 
system. 

Table 2-1 

Language setting Effect Chapter 

Regional Options Depending on location and details of PCS 7 plant 2.1.1 

Languages Windows user interface (menus, dialogs and help) and input 
texts in different languages 

2.1.2 

Non-Unicode languages PCS 7 project language 2.1.3 
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2.1 Regional settings 

The language setting for menus and dialogs can be made as follows: 

Start > Control Panel > Clock, Language, and Region > Region and Language 

This setting specifies the display of numbers, currencies, date and time. 

Note Adjust this setting in the specifications of the local PCS 7 plant. 

So that numbers, currency, time and date are displayed according to the plant 
location. PCS 7 will access these values. This is why they should be correct, so 
that no errors are caused in the process operation of the plant (for example, due 
to an incorrect time or a wrong date). 

 

Figure 2-2: Regional Options 

 

 

NOTE If you have selected English (United States) as format you also have to keep a 
dot {.} as a decimal sparator in "Additional settings …". Otherwise there may be 
errors when compiling HW-Config. 



2 Windows Installation and Settings 

 

 

Configuration of Texts and Languages in PCS 7 
Entry-ID: 56248153,    V4.0,    12/2017   12 
 


 S

ie
m

e
n

s
 A

G
 2

0
1

7
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

2.2 Languages 

The language of the user interface of the operating system and the text input 
options can be set under the following menu option: 
Start > Control Panel > Clock, Language, and Region > Region and Language > 
Keyboards and Language 

Example 

If you would like to enter Chinese texts in your PCS 7 project, you have to enter 
"Chinese" as input language. 

Figure 2-3: Languages 
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2.3 Non-Unicode language (PCS 7 project language) 

For programs that do not support Unicode, you also have to set the desired 
language. You can do this through menu option: 

Start > Control Panel > Clock, Language, and Region > Region and Language > 
Administrative 

Note You should select the language first, before you create the PCS 7 project. This is 
due to the fact that the non-Unicode language is set as the project language at 
the time of creating the PCS 7 project.  
Changing to another project language later is not possible. 

If you would like to open a PCS 7 project which has been configured in another 
(not a neutral) project language, for example, Japanese than you have to adjust 
the language for non-Unicode programs in this language first, otherwise you 
cannot open the project. 

 

Figure 2-4: Language for non-Unicode program 
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Figure 2-5: Project language 

 

 

The PCS 7 project language is the language that was selected as non-Unicode 
language when creating the project. 

If you are planning to open and process projects or libraries under any Windows 
language setting, you have to identify them as language neutral. If the 
projects/libraries contain texts with special characters, umlauts or similar, that are 
not defined under the respective Windows language setting, the characters may 
not be displayed correctly when showing the projects/libraries and there may be 
data corruption when changing or copying objects. 
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This is why projects or libraries may only be identified as language neutral if it is 
ensured that all texts contained therein are restricted to the ASCII character 
repertoire (English character set without special characters). STEP 7 cannot 
determine whether this condition was maintained – this is the responsibility of the 
user. 

If the language neutral setting was selected in PCS 7, it is possible to open the 
project under other non-Unicode language settings. 

For this purpose, select the project in the WinCC Explorer and open 
"Object Properties… > General > Can be opened under any Windows language 
settings (language neutral)" via the context menu. 

 

Note When creating the projects and libraries make sure that only texts from the ASCII 
character repertoire were used. 

 

Figure 2-6: Project properties 
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3 Configuration Rules/Settings 

3.1 Configuration instructions 

 The characters { ‘ } { . } { % } { \ } { * } { ? } { : } { blank } within a name are 
converted into the substitute character { $ } during OS compilation. The ES 
separator { \ } is converted to character { / }. 

 The maximum length of a tag name is 128 characters. Note that in OS, 128 
characters are not shown in their entirety in many editing windows. You 
therefore need to restrict the length of the HLD. 

 Note that the national special characters occupy two characters and that the 
maximum length of the name is therefore restricted accordingly. 

 Note that the length of the transferred texts depends on the maximum text 
length of the target block in the OS (Tag Logging e.g. event 50 character; 
origin 32 characters). When compiling the OS, texts of a maximum length of up 
to 255 characters are transferred. 
Remedy: 
Enlarge the maximum character length of the user text block or select a shorter 
PIC. 

 In the mnemonic area it generally has to be determined whether the I/O 
address concept for the multi-project to be created, is on the basis of German 
or English. 

 For all projects in the multi-project the language setting for the display devices 
must be checked. Here, set all languages that are to be used in engineering 
and on the OS.  
For projects that contain an OS server this has to be performed before the first 
compilation, so that the texts are created in all languages in the OS. 

 

Note The configuration in PCS 7 is mainly in the SIMATIC manager. The configuration 
data is transferred via "Compile OS" in the respective OS project. 

In the OS, only the configuration of the images takes place, apart from the 
general configurations. 

In multilingual projects it is recommended to insert the translations already in the 
SIMATIC manager. The translated texts are automatically inserted via "Compile 
OS" in the OS. 

Later changes directly in the OS can lead to inconsistencies in the data 
management. 

Some texts can only be set monolingual by engineering. If these texts have to be 
made multilingual in the OS text library, this should take place later, to avoid 
inconsistencies and overwriting. 
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3.2 Language settings in SIMATIC Manager 

Figure 3-1 

 

 

The following menu options are found in the SIMATIC Manager: 

 Options > Customize... > Language 
This is where the language for the interface is set. You can furthermore specify 
the language for the mnemonic, with which you want to program the S7 blocks. 
If all languages are installed during the installation, then subsequently all these 
languages are available in this dialog setting. 

 Options > Language for Display Device 
In the dialog field "Add/Delete Language, Set Default Language" you can 
select the languages in which the configured texts can be generated. This 
setting is project-specific.  

Note When changing the language for the display devices, attention needs to be paid, 
that this language is used as reference language for the OS text library. 

The reference language is used to check whether a text already exists in the text 
library when performing "Compile OS". 

 

NOTICE The reference language should not be changed. The modification process and 
the subsequent OS compilation may cause inconsistencies or even loss of 
already translated texts in the text library. 

 

 Options > Manage Multilingual Texts > Change Languages... 

After the text types of the project have been translated and imported, you can 
use this dialog field to select the language in which to display these text types. 
You can select whether the language is changed for title and comments or 
display texts or both. This language change is object related, i.e. you can 
trigger a language change separately for projects, stations, programmable 
modules, S7/M7 programs, symbol tables, block folders and all blocks.  

The languages which are available in this context depend on the selection 
under Options > Language for Display Devices. All languages installed in the 
project can be selected here. 
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Note The language change for "Title and comments" is only executed for the selected 
object. The language change for "Display texts" always causes a language 
change in the entire project.  

A change of language of the "Display texts" always also changes the "Default" 
language for the display devices. 

 

The area-oriented OS compilation 

In the "area-oriented" mode, the OS assignment of the areas in the plant hierarchy 
is decisive when creating the tags, messages and data for the SFC visualization. 
You can only select this mode if a configured plant hierarchy is available. This 
mode is preset for new projects from V6.1. 

For the driver blocks, not assigned in the Plant Hierarchy, the tag names in the OS 
are composed of <program_name>/<chart_name>/<block>. 

The AS-oriented OS compilation 

In "AS-oriented" mode the S7 programs assigned to the operator station or the 
operator stations are ruling. This mode is default for PCS 7 projects < V6.1 and for 
projects without configured Plant Hierarchy. The program name becomes part of 
the OS tag name. 

Symbols and faceplates in the OS display the tag name. For "area-oriented OS 
compilation" the program name is displayed in the asset management. 

Note Multilingualism is not possible here. 
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3.3 Language settings in OS project 

The language settings in the system (SIMATIC Manager, WinCC) must be uniform 
during OS compilation. Make sure that you have selected the same configuration 
or default language in the SIMATIC Manager and WinCC.  

3.3.1 Language settings in WinCC 

The following menu options are found in the WinCC Explorer: 

 Tools > Language... 
This is where you set the language for the interface.  

 Computer > Properties > Properties > Parameters 
Here you can set the language for runtime. The language for the printout of the 
project documentation in WinCC is set via this field. 

 

The following menu option is available in the GraphicsDesigner: 

 View > Language... 
For the configuration of the pictures, you have to select the language first 
under which the pictures are then shown in runtime. 

 

The following menu option can be found in AlarmLogging: 

 View > Input language… 
Manually configured message texts must be created in the language used in 
the project. 

 

Language settings for Runtime: 

 Button to change language: 
This is where you can set the current display language in runtime. For this 
purpose all switchable parts have to be configured in the respective languages. 
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3.3.2 WinCC interface language 

This changes the interface language of the WinCC Explorer and of the editors. 

Figure 3-2: Language settings in WinCC Explorer 

 

 

3.3.3 WinCC project language(s) (configuration language) 

The project language is the language that is to be provided for the project at 
runtime. It is possible to store several languages so that they are available for 
selection in the runtime. 

Difference between WinCC interface languages and WinCC configuration language 

The WinCC project language is directly selected in the editor which is used for the 
configuration, for example, in Graphics Designer. After changing the language, the 
interface language does not change but only the texts in the configured pictures. 

The following figure displays the Graphics Designer with English as project 
language. 
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Figure 3-3: Project language in Graphics Designer 

 

 

In addition to the installed languages, you can use other languages supported by 
WinCC. If you are using a project language that is not available in WinCC, then the 
default texts are not copied in the selected project language. 

Note WinCC only supports the primary languages. 

Examples: 

 English (USA), but not English (GB) 

 German (Germany), but not German (Austrian) 

 

3.3.4 Runtime language 

The Runtime language is the language in which the project is displayed in the 
runtime.  

Language settings at runtime 

Select the language with which the project is to be enabled on the selected 
computer. 

For this purpose, select the "Computer" in the WinCC Explorer and open 
"Properties > Properties > Parameters" via the context menu. 

In "Runtime Language" you select your desired language. 

Default runtime language 

The runtime uses the text of this language if there is no text in the set runtime 
language. 
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Note If the associated translations are not available in the default runtime language 
either, "???" is output. 

"Runtime Language" and "Default Runtime Language" should differ (e.g. 
language setting at runtime German and default Runtime language English 
(USA) ). 

 

Figure 3-4: Language settings in WinCC Explorer 
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4 Languages in AS Engineering 

4.1 Texts in SIMATIC Manager / Multiproject 

In the SIMATIC Manager itself or its configuration tools, texts and/or languages can 
be configured in various places.  

 General configuration rules in SIMATIC Manager 

 Project language 

 Language for display devices 

 

Table 4-1: Texts in multiproject 

Text Type Meaning Notes 

Multiproject Name of multiproject See chapter 4.1.2 

Project Name of project See chapter 4.1.3 

Station Name of station See chapter 4.1.4 and chapter 4.1.15 

Connections Connection names in NetPro No relevance for multilingualism 

HW configuration  See chapter 4.1.5 

S7 program Program folder See chapter 4.1.7 

Messages Message configuration See chapter 4.1.9 and 4.4 

Attributes Block attributes See chapter 4.1.9 

Charts CFC charts See chapter 4.1.10 

Symbols Symbolic name See chapter 4.1.13 

Declarations  See chapter 4.1.14 

Enumerations  See chapter 4.1.14 

Units  See chapter 4.1.14 

Libraries  See chapter 4.2 

Plant hierarchy  See chapter 4.3 
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4.1.1 Export and import of "multilingual" texts in SIMATIC Manager 

An individual file is created for each text type during export. It has the text type as 
name and the export format as ending (Texttyp.Format: for example, 
SymbolComment.csv or BlockTitle.xls) 

Files that do not fulfill the name convention cannot be entered as source or target. 

The translatable texts within a project are divided in the following text types: 

 

Table 4-2: Export and import of texts in SIMATIC Manager 

Text Type Meaning PCS 7 OS Relevance 

BlockTitle Block title comment No, display only in 
SIMATIC Manager 

BlockComment Block comment No 

NetworkTitle Network title No 

NetworkComment Network comment No 

LineComment Line comment in STL No 

InterfaceComment Var_Section comment (declaration table in code 
blocks) and UDT comment (user-defined data 
types), data block comment and block 
connection comment 

No, display only in 
SIMATIC Manager 

SymbolComment Symbol comment No, display only in symbol 
table 

S7UserTexts Texts entered by user, that can be output on 
display devices 

Process messages 

OS picture names 

S7SystemTextLibrary Texts from system text libraries that can be 
integrated in messages, updated dynamically at 
runtime and displayed on the PG or other 
display devices. 

System messages 

They must not be 
changed. 

S7UserTextLibrary Texts from user text libraries that can be 
integrated in messages, updated dynamically at 
runtime and displayed on the PG or other 
display devices. 

Process messages 
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Export or import is performed either on project or on library level. If subordinate 
levels are selected, there will only be a partial export. 

For this purpose, select the Object, which you want to export and open "Options > 
Manage Multilingual Texts > Export" and select a target language. 

If exported texts are to be imported again, then the texts in the source language 
must not be changed. Only translations where the source texts (exported texts) 
match an existing entry in the "source language" column are accepted. 

Figure 4-1: Exporting user texts 
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Figure 4-2: Example of exported texts  

 

 

Note The export of texts is only possible as an orderly pair of source language and 
target language. 

During the import, the text is compared by means of the source language, i.e. 
when editing, only the target language must be changed. 

When importing the translated texts, these texts are replaced in the entire 
project. If you have, for example, translated texts that belong to a certain CPU 
and these texts also appear in other places of the project, then all the text 
passages in the project are replaced! 
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4.1.2 Multiproject 

Name conventions 

For the naming of the multproject, the following specifications apply: 

 names for multiprojects can be freely assigned. PCS 7 automatically creates a 
path on Windows level, where the data is stored. 

 special characters and umlauts should be avoided. 

 Not allowed are: { \ } { / } { . } { : } { , } { ; }  { " } { = } { ? } { + } { * } { [ } { ] } { | } 
{ Leerzeichen } 

 Asian characters are not permitted 

 no language can be specified for multiprojects. 

Note The name of the multiproject is not language relevant. 

 

When selecting the multiproject, the project language for the individual projects is 
displayed in the detail window. 

The project language shows the language that was, or is set through the control 
panel in the WINDOWS language setting as "non-Unicode language" when the 
project or the library was created or is being created. 

4.1.3 Projects 

Note The same rules apply for the name of projects as for the multiproject. 

 special characters and umlauts should be avoided 

 Asian characters are not permitted 

The name of the project is not language relevant. 

 

The SIMATIC Manager allows names that are longer than 8 characters. However, 
the name of the project directory is shortened to 8 characters. 

NOTICE Project names have to differ in the first 8 characters. 

There is no case sensitivity. 
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4.1.4 SIMATIC 400 stations: 

 The AS name is entered in the Plant Asset Management (if configured).  

 The name is stored in the OS text library. 

 Spaces in the AS name are replaced by "_" characters in the OS tag 
management. 

NOTICE The station name also has an effect on existing connections. 

Make sure to readjust and reload existing connections when you rename a 
station. 

Language adjustment is not possible. 

 

4.1.5 Components of HW Config 

Name conventions 

For the naming of all components in HW Config, the following specifications apply: 

 the name must not be longer than 14 characters.  

 when creating the module driver (compile CFC) the names from the HW Config 
are used for the CFC block instances.  

 Name of CFC blocks can be max. 16 characters.  

 the module group wizard shortens the name of the HW Config to 14 characters 
and always adds "_1". 

 make sure the specified name is unique. There is no case sensitivity, since this 
is not observed during OS compilation. 

 

Note The blocks inserted by the driver generator receive the name of the assigned 
module. 

Process control messages that appear in the WinCC messages system contain 
the name of their origin. In this case, this is the name of the block name and 
therefore also the name of the monitored module. 

If the process control messages are supposed to contain a certain text, you can 
alter the name of the module accordingly in the HW Config. This text is then part 
of the process control message. 

 

NOTICE The name of HW Config components is part of the respective Asset tag; this is 
why it must be unique and monolingual. Furthermore, the display of the name is 
created from a tag and not from the text library, therefore multilingualism is not 
possible. 
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Comments 

As of PCS 7 V7.0, the comments of the components in the faceplate are displayed 
in the Asset Management.  

The comment is stored in the OS text library. 

Names of SNMP nodes 

Rules: 

 no spaces  

 no special characters 

 only use upper case letters 

Note They are added as Asset tags to the OS and for this reason they are 
monolingual. 

 

4.1.6 Names of connections in NetPro 

Local ID 

For SIMATIC PC stations (applications) enter a string of up to 24 characters. 

Note No relevance for multilingualism in the OS. 

 

4.1.7 S7 program folder / S7 programs 

To avoid confusion, it is recommended to assign unique names to the S7 program 
folders of various SIMATIC 400 stations. 

 When "AS-oriented OS compilation" takes place, the name becomes part of 
the tag name in the OS. 

 When "area-oriented OS compilation" takes place, the name of the program 
folder is only used for the driver blocks. 

The tag name is displayed in the OS in various places: 

 Block icon 

 ToolTip text at block icon 

 Faceplate 

 Process value archiving 

Note The name of S7 program folder / S7 programs is monolingual. 
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4.1.8 Sources 

As of PCS 7 V6.1 SP1 you can enter foreign-language texts in the S7 SCL sources 
that do not correspond to the set STEP 7 language. Thus, it is possible, for 
example, to operate STEP 7 with S7-SCL in the STEP 7 language English, in 
Chinese Windows and to enter Chinese texts in the S7 SCL source. 

Rules for foreign language text in S7-SCL 

 S7-SCL V5.3 SP1 allows foreign language characters in the following areas of 
the sources: 

– global symbols that are contained in the STEP 7 symbol table 

– string constants and block attributes (TITLE = '...', AUTHOR: '...', 
FAMILY: '...'.) 

– user-defined attributes 

– Comments 

 The length of the string constants generally has to be restricted to 254 bytes. 
For the block attributes AUTHOR and FAMILY, a length of 8 bytes applies. 
The following elements must only have characters from the English character 
set (ASCII characters 0x2a - 0x7F): 

– IEC string functions 

– block parameters and local symbols 

– constructs, that make up the S7-SCL language (e.g., instructions) 

 

4.1.9 Blocks 

Note Adjust the used blocks before starting the configuration in master data library. In 
the properties as well as in the language. 

 

Symbolic name 

The system limit for symbolic names of function blocks is 16 characters. If possible, 
assign the symbolic name with no more than 8 characters and identical to the bock 
names, so that they are same. Additional characters for the symbolic name will be 
cut off when they are displayed in the CFC editor. 

Note The symbolic name is stored in the OS text library. The internal tags 
<Tagprefix>.#blocktype refer to the symbolic name and are displayed in the loop 
view of the faceplate. 

The symbolic block name is monolingual in the SIMATIC Manager. 

In mandatory cases, the translation of the symbolic block name can be performed 
in the OS text library. 

Block connection names 

When selecting the name, bear in mind that only the first eight characters will be 
visible when all contacts in CFC are displayed at the same time. Long connection 
(port) names are only visible as tooltip text in full length in the CFC chart.  
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To ensure differentiability, uniqueness and consistency, specify a name convention 
at the beginning of the configuration. Depending on the characteristic, several 
connections are generated when creating the interface connections. The 
connection names are each added a postfix, to give the connections a unique 
name. 

Rules for the length of the connection name: 

 Setpoint values and times: 16 characters 

 Block contact: 10 characters 

 All other characteristics: 24 characters 

Note The tag management in the OS is monolingual  

The block connection names are part of the tag and therefore monolingual. 

 

Block comments 

The comment can be any text that appears in the block header and in the OS in 
the opened faceplate in the window bar. A max. of 14 characters are displayed in 
the block header. For small blocks the comment is not displayed. The block name 
is monolingual in the SIMATIC Manager. 

The block comment is entered in the text library in the OS. Through the library, the 
comment can be made multilingual in the OS, if required. 

 

Block attributes 

For the labeling of binary displays, analog value displays, combination fields, option 
boxes and operator protocols, the texts from the block instances are read out from 
the parameter attributes.  

Part of it can be translated through export and import in the SIMATIC Manager. All 
static texts in the faceplates have to be exported, translated and subsequently re-
imported with the help of the text distributer. 

Note, that the default texts in ES are configured in the default library in English for 
the "s7_shortcut", "s7_unit", "S7_string_0" and "S7_string_1" attributes. Configure 
these texts in the language that is intended for the operator (plant operator) on the 
OS.  

If you would also like to have these texts provided in additional languages on the 
OS, you have to translate them in the text library of WinCC. When using the APL 
the fields "s7_shortcut", "S7_string_0" and "S7_string_1" are empty. In this case, 
the texts are stored multilingual in the faceplate. When these fields are filled, only 
this text is available which then has to be translated in the text library, just as with 
the default blocks. 

Note Lettering from the PCS 7 default library that corresponds to the block connection 
names (e.g. PV) is completely capitalized in faceplate and displayed identical in 
all languages. 
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Figure 4-3: 

 

 

Block messages 

The messages can be adjusted to the language through export and import of the 
S7UserTexts. Keywords and parameters for format instructions are reserved for, 
for example, origin, OS area and associated message values. (e.g. $$AKZ$$ or 
@1%s@...). Make sure that special characters in messages do not overlap with 
keywords. 

Note Information on configuration of messages and associated message values in 
CFC can be found under the following FAQ "How do you configure additional 
messages with texts and message-associated values in CFC?" 
https://support.industry.siemens.com/cs/ww/en/view/770488 

 

NOTICE Leave all system and driver blocks unchanged. 

 

https://support.industry.siemens.com/cs/ww/en/view/770488
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4.1.10 CFC charts 

Names of CFC charts 

When naming, make sure that the tag name is not longer than 128 characters 
during OS compilation. 

The name is composed of the names of the folders in the hierarchy path, the chart 
name, the block name, the separator (full stop) and the connection name. 

Rules: 

 Maximum 22 characters 

 Not allowed are: { \ } { / } { . } { " } { % } 
 

Note The CFC chart name is part of the tag name and is monolingual. 

 

Comments 

Chart comments are not transferred to the OS. 

 

4.1.11 Block instances 

Figure 4-4: S7 program 

 

Block instances 

The instance of a block has to be unique throughout the chart. The uniqueness is 
checked by CFC.  

Rules: 

 The name can be up to 16 characters. 

 Illegal characters are: { / } { \ } { . } { " } { % } 

Note The instance name is part of the tag name in the OS and is therefore 
monolingual. 
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Block messages 

Figure 4-5: After OS Compile the messages are contained in the text library 

 

 

Figure 4-6: Messages of adjusted instances after updating the block 

 

 

These instance-specific messages can be translated or adjusted through 
export/import in the SIMATIC Manager. 

NOTICE Instance-specific adjustment of the messages is not overwritten in the individual 
charts when the block types are updated from the Master Library. 

Units and codes 

The unit and operator control texts of block types from the default libraries (e.g. 
PCS 7 Library) included in delivery, are fully in English and partially translated in 
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the respective default languages. However, a translation of the missing texts can 
be performed in the text library. 

The units and codes of the APL blocks are fully stored for all default languages. 

4.1.12 SFC charts/types 

Names of SFC types 

The max. length for the names of SFC types is 16 characters.  

Rules: 

 No special characters apart from: { _ } 

 not allowed: { \ } {.} { / } { " } { % } 

 No umlauts 

 Maximum length: 16 characters 

Names of SFC charts  

When naming, make sure that the tag name is not longer than 128 characters 
during OS compilation. 

The name is composed of the names of the folders in the hierarchy path, the chart 
name, the separator (full stop) and the connection name.  

Rules: 

 The chart name must not be longer than max. 22 characters.  

 The following characters are not allowed: { \ } { / } { . } { " } { % } 

Because the SFC chart name is part of the tag management it has to be 
monolingual, however, on the OS side, it can be adjusted by the text library. 

Chain, step and transition names 

Here, the following rules apply: 

 Maximum length: 16 characters 

 Has to contain at least one letter 

The contents of SFC (within SFC Controls) are not totally accessible in engineering 
and for this reason they can only be adjusted to a limited extent in the language. 

The display name of the setpoint values, the control strategies and the parameters 
can be adjusted in the language. For this purpose, the display name property has 
to be adjusted for the respective language. 

Comments in SFC charts/types 

Here, the following rules apply: 

 Maximum length: 80 characters 

 only visible in the characteristics dialog 
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OS comments in SFC charts/types 

You can enter an OS comment of max. 256 characters for the SFC chart/SFC type 
under any condition. This comment can then be found in the OS for the respective 
step or the respective transition under comment. 

Note The OS comment can not be managed multilingual. It has to be written in the 
language that is intended for the operator. 

 

SFC visualization 

Note The control elements for the SFC are OCX elements and can not be adjusted to 
their language. They are available in the default languages of PCS 7. 

 

4.1.13 Symbol table 

Work with symbolic names in PCS 7 projects. A symbolic name makes it possible 
for you to work with a descriptive name instead of absolute addresses.  

Note Symbolic names must be unique and therefore monolingual. 

 

4.1.14 Global declarations 

Changes in names for units, enumerations or equipment properties in the template 
have the effect that they are recreated in the target project when they are 
synchronized. The global declarations used so far remain at their locations. 

Deleted units, enumerations or equipment properties in the template are not taken 
into account when they are synchronized in the target project, i.e. they remain 
where they are. 

Enumerations 

The enumerations are created in the project language and transferred with the 
compilation of the OS in the text library. This is where the texts can be translated in 
all languages. 

Note You can find further information about language settings for enumerations under 
the FAQ "How can you use the texts of enumerations (under Shared 
Declarations in the SIMATIC Manager) for display in WinCC?". 
https://support.industry.siemens.com/cs/ww/en/view/27147567 

https://support.industry.siemens.com/cs/ww/en/view/27147567
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Units 

Units are defined in the global declarations (max. 16 characters) and are used in 
process images for the visualization of values of the block connections. 

 

Note Default library: 
Units are stored in the text library during OS compilation. The entries in the text 
library are not case sensitive (i.e. no distinction between lower and upper case). 

APL: 
If there is "0" at PV_Unit, the S7_Unit is used, otherwise the unit is provided by a 
DLL. 

 

4.1.15 SIMATIC PC stations 

The symbolic PC name specifies the server prefix and therefore the server data. 
This is decisive for the OS server client communication. 

Note The setting can only be made for the first configuration. It is used and displayed 
for the name of the server within the "SIMATIC Server View" layout. 

 Avoid national special characters. 

 Multilingualism is not possible here. 
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4.2 Names and texts in libraries 

The SIMATIC Manager allows names that are longer than 8 characters. However, 
the name of the library directory is limited to 8 characters. This is why library 
names have to differ in the first 8 characters.  

There is no case sensitivity. 

Note Names of libraries are not language relevant. 

 

4.2.1 Blocks 

Figure 4-7: Using blocks 
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The default languages are included in delivery for all PCS 7 libraries. If you want to 
use a different language, the translation has to take place in the master data library 
and in the project. This can take place in the selected language directly on the 
block or with the help of export and import.  

Once the translated texts have been imported, the new language or the changes in 
the project can be published through "Update block types". 

 

Note The instance-specific adjustment of the messages is not overwritten in the 
individual charts when the block types are updated from the Master Library. 

 

4.3 Names and texts of the plant hierarchy 

4.3.1 Hierarchy folder 

Description 

The name of the plant hierarchy (PH) folder is part of the tags and is monolingual.  

The following special characters must not be used in the name of the hierarchy 
folder: { . } { % } { / } { \ } { " }. 

The container name in the plant hierarchy can be specified in the object properties 
of the hierarchy folder. 

For the naming of the Hierarchy Folder, the following specifications apply: 

 The characters { ‘ } { . } { % } { \ } { * } { ? } { : } { blank } within a name are 
converted into the substitute character { $ } during OS compilation. The ES 
separator { \ } is converted to character { / }. 

 The maximum length of a tag name is 128 characters. Note that in OS, 128 
characters are not shown in their entirety in many editing windows. You 
therefore need to restrict the length of the HID. 

 Note that the national special characters occupy two characters and that the 
maximum length of the name is therefore restricted accordingly. 

 Note that the length of the transferred texts depends on the maximum text 
length of the target block in the OS (Tag Logging e.g. event 50 character; 
origin 32 characters). When compiling the OS, texts of a maximum length of up 
to 255 characters are transferred. 
Remedy: 
Enlarge the maximum character length of the user text block or select a shorter 
HID. 

 Maximum length: 24 characters 

 

NOTE The maximum number of characters permitted for the name of a hierarchy folder 
you can set (1 to 24) under "Options > Plant Hierarchy > Settings..." for each 
level. 

 

Note With the help of the export and import wizard in the SIMATIC Manager, you can 
configure the container names in several languages. 
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4.3.2 OS area IDs 

Figure 4-8: PH folder name or OS area ID via OS compilation in text library 

 

 

Description 

It is possible to indicate or change the displayed text in the OS area ID. A 
translation can take place through export and import of the S7UserTexts file in the 
SIMATIC Manager.  

Note The realization in several languages should take place before the first OS 
compilation. 

 

Configuration 

To be able to change the OS area ID, right click on the respective PH folder and 
select the "Control and Monitoring Attributes" tab. 
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Figure 4-9: Hierarchy folder properties 

 

4.3.3 Process pictures 

Make sure that the length of the image name is no longer than 24 characters. 
Image name and container name (i.e. names in PictureTree) are independent of 
each other. 

Note The name of the process image (file name) must be unique and therefore 
monolingual. File names should not contain special characters or umlauts. 
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4.4 Names and texts of the process object view 

In the process object view the messages of the instances can be adjusted under 
the respectively set language. In all other tabs multilingual administration is not 
possible.  

Texts and messages can be exported and imported just as in the plant hierarchy or 
the component view.  

Figure 4-10: Process Object View 
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5 Languages in OS Engineering 
With PCS 7 you can configure your projects in several languages. In the process, 
PCS 7 OS supports the multilingual configuration of virtually all objects, whose 
texts are visible in Runtime. 

In addition to the direct text entry, PCS 7 OS offers you comfortable export and 
import options to translate your configuration with the text distributor. This is 
especially of advantage when you configure large projects with a high proportion of 
text. 

Table 5-1: Texts in OS project 

Text Type Language relevance 

OS project name See chapter 4.1.15 

Tag management Tags are monolingual 

Screens See chapter 5.2 

Messages See chapter 5.3 

Message archive See chapter 5.3 

Curves No relevance for multilingualism 

Curve archive See chapter 5.4 

Reports See chapter 5.5 

Text library See chapter 5.6 

User Administration See chapter 5.7 

PictureTree No relevance for multilingualism 

OS project editor No relevance for multilingualism 

Scripts See chapter 5.10 

 

5.1 Tag management 

Tags are monolingual. The language cannot be changed. 
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5.2 Process pictures 

All images can be processed in the Graphics Designer and can therefore be 
managed in several languages. Texts in images and on picture elements (e.g. 
static texts  
or labeling of buttons) are not translated in the text library but directly in the 
respective picture. By means of the text distributor you can also translate texts in 
pictures and picture elements in several languages. You may have to adjust the 
size of the picture elements. Each element has to be large enough so that the 
space is still enough for the language with the longest terms. 

Figure 5-1: Language settings for texts in pictures in the Graphics Designer 
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5.3 Messages/message archive 

The message texts of blocks have to be translated in the SIMATIC Manager. 

Note If no default language is used, you should set the "Default Language at Runtime" 
to "English (United States)" to display, for example, the WinCC system 
messages. 

 

Figure 5-2: Default Language at Runtime 

 

Note Restriction: 

The type of message is displayed in the language which was the language at 
runtime at the time of occurrence. 



5 Languages in OS Engineering 

 

 

Configuration of Texts and Languages in PCS 7 
Entry-ID: 56248153,    V4.0,    12/2017   46 
 


 S

ie
m

e
n

s
 A

G
 2

0
1

7
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

5.4 Curves/curve archive 

Curves or curve archives are only monolingual. 

 

5.5 Reports 

5.5.1 Layout 

There are language-specific folders for layouts in which the respective layout is 
stored for each language. In addition, there is a folder for language-neutral layout. 
Static texts are saved in the layout.  

The layouts are used dynamically for the reports, depending on the set runtime 
language. Dynamic objects in the layouts are inserted, also depending on the 
respective runtime language. 

A further language can be added with the following menu command: 

WinCCExplorer > ReportDesigner > "Rechtsklick auf Layouts" > Sprache 
hinzufügen 

Note An added layout language cannot be deleted again. 

 

Figure 5-3: Layout language setting 
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5.5.2 Print job 

When configuring a report and selecting the desired layout, it becomes instantly 
apparent whether the respective layout is language neutral (available for all 
languages) or not (only available for particular languages). 

Figure 5-4: Print Job Properties 

 

 

Legend 

Table 5-2 

Symbol Discription 

 
Language neutral layout 

 
Layout available in all configured languages 

 

Layout not available in all configured languages 

 

Note If a report is ordered to be printed and it is not available in the current runtime 
language, then the default language, set up in WinCC is used. 
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5.6 Text library and text distributor 

Text library 

The text library contains the dynamic objects and can either be edited directly in 
the column or by export and import. 

Text distributor 

The text distributor can edit all texts of images and faceplates. For this purpose, an 
export and import has to be carried out.  

It is important to observe the format of the exported file. For processing in MS 
Excel, it is recommended to export everything as ".txt".  

More information, as well as instructions on how to successfully export and import 
can be found in FAQ with the entry ID: 29419870. 

Note Changes in the text library of the OS should only be made once the configuration 
has been completed. 

 

5.7 User administrator 

The names of the created user groups in the Windows operating system and in the 
OS user administrator have to be written in exactly the same way. Observe case 
sensitivity. 

Note User names have to be monolingual. 

 

5.8 Picture Tree Manager 

The Picture Tree Manager is irrelevant for the multilingualism of PCS 7. 

 

5.9 OS project editor 

The OS project editor is irrelevant for the multilingualism of PCS 7. 
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5.10 Scripts 

Scripts are usually monolingual.  

 

Note If texts have to be processed in scripts, this can be realized, for example, 
through the deviation of a "text tag" with a reference to the text library.  

The following code of the script has to consider this multilingualism. 
 

 

NOTICE ANSI-C has no mechanisms for monitoring char arrays (character strings). 
Incorrect programming can lead to the overwriting of non-assigned memory 
areas. 
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6 Use Cases 
Regarding multilingual PCS 7 projects, exemplary use cases show the approach 
and the settings before and during the configuration. 

Note For a distributed (worldwide) configuration, a joint project language has to be 
agreed upon before the start (preferably English). 

 

6.1 Monolingual configuration: English (US) 

Requirement 

 Windows 7 (English version or English language package) 

 Regional and language settings: All English (see chapter 2) 
Start > Control Panel > Clock, Language, and Region > Tab Administrative 

 

Figure 6-1: Regional and language options 
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For languages in programs that do not support Unicode, select English (US) as 
default in the selection tab. Also adjust the regional and language settings to 
English.  

The input language is irrelevant; however, at least the input of Latin characters 
should be possible. 

Note When using only one language, attention needs to be paid that this language is 
set as default in the operating system in the SIMATIC Manager and in WinCC. 

Procedure 

1. Start the SIMATIC Manager and check the language setting (see chapter 3.2). 
Options > Customize > Tab Language 

Figure 6-2: Setting of national language and mnemonics 

 

 

If necessary, set the language setting to English. This requires a restart of the 
SIMATIC Manager. 

2. Create your project. 
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3. Check the display languages and adjust them if necessary: 

Options > Language for Display Devices 

– Add English (US) to the installed project languages. 

– Set English (US) as default language 

Figure 6-3: Setting of display language 

 

Note You can remove or keep the other languages. 

 

4. Create the master data library 

5. Configure the hardware and the program. 

6. Create the master data library. 

7. Compile the charts and if necessary enable the Asset Management. 

8. Compile the OS (see chapter 3.3). 

9. Open the OS project and check the language settings. They all have to be set 
to English. 

– Tools > Language > English (US) (Figure 3-2). 

– Computer >Properties> Parameters > Runtime Language > English (US) 

– Open the Graphics Designer and also set the language to English:  
View > Language > English (US) (Figure 3-3) 

10. Start processing the OS project. All performed steps are now stored in the 
English language list. 
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6.2 Multilingual configuration: English / German 

For multilingual configuration, a language has to be defined throughout as default 
in the operating system, in the SIMATIC Manager and in WinCC. In this example, 
English is to be available as configuration language and German as second 
language. 

Requirement 

 Windows 7 (MUI English and German) 

 Regional and language settings: All English 
Start > Control Panel > Clock, Language, and Region > Tab Administrative 

Figure 6-4: Regional and language settings 
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For programs that are not Unicode capable, you have to select English (US) as 
language in the "Advanced" tab. The regional and language settings should also be 
adjusted to English. 

The input language is irrelevant. However, the input of Latin characters should be 
possible. 

Procedure 

1. Start the SIMATIC Manager and check the language setting (see chapter 3.2). 
Options > Customize > Tab Language 

Figure 6-5: Setting of national language and mnemonics 

 

Check, whether the language settings for English is enabled. 
If this is not the case, reset it to English. Afterwards the SIMATIC Manager 
needs to be restarted. 

 

2. Create your project. 
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3. Check the display languages and adjust them if necessary:  

Options > Language for Display Devices (Figure 6 6). 

– Add English (US) to the installed project languages. 

– Also add German as additional language. 

– Set English (US) as default language. 

Figure 6-6: Setting of display language 

 

Note You can remove or keep the other languages. 

 

4. Create the master data library. 

5. Adjust the blocks in the master data library in German and in English. 
For this purpose, the master data library has to be exported, adjusted and re-
imported in the SIMATIC Manager (see chapter 4.1.1). 

6. Configure the hardware and the S7 program. 

7. Compile the S7 program and if necessary enable the Asset Management. 

Note All default messages and texts already exist in the system in the default 
languages. However, translations can be adjusted and used, for example, for 
user-generated blocks.  

For this purpose, you have to export, process and compile all texts and re-import 
them.  
Export takes place through: Options > Multilingual Texts > Export 

In the context menu that opens up, it is important that the source language and 
the target language are selected correctly.  

Import takes place through: Options > Multilingual Texts > Import 

 

NOTICE No changes must be made in the source language column. 
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8. Compile the OS (see chapter 3.3). 

9. Open the OS project and check the language settings. They all have to be set 
to English. 

– Tools > Language > English (US) (Figure 3-2). 

– Computer >Properties> Parameters > Runtime Language > English (US) 

– Open the Graphics Designer and also set the language to English:  
View > Language > English (US) (Figure 3-3) 

Note Missing texts can be directly translated in the text library or you export, translate 
and import them. 

 

10. The processing of OS has to take place in English as well as in German. There 
are two options: 

– Make all text changes in the Graphics Designer in English and in German. 
Process and save the language settings in English and in German for each 
image. 

– Create all texts in the Graphics Designer only in English. Once you have 
completed the OS processing, perform an export with the text distributor, 
translate the texts and re-import them. 

Note User-defined texts have to be configured multilingual. 
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6.3 Monolingual configuration: Chinese (Simplified) 

NOTE All procedures, descriptions and screenshots relevant for PCS 7 are based on 
the PCS 7 V7.1 and are applicable to the PCS 7 V8.1 without restrictions. 

Exemplary configuration of an ASIA project. 

Requirement 

 Windows 7 MUI with Chinese language package (Simplified) 

 SIMATIC PCS 7 ASIA Installation 

 Regional and language settings (see chapter 2): 

– Menus: English 

– Input language: English and Chinese 

– Language for non-Unicode program: Chinese 

Procedure 

1. Start the SIMATIC Manager and check the language setting. (see chapter 3.2) 
Options > Customize > Language (Figure 6-5) 

You can select either English or Chinese as interface language for the 
SIMATIC Manager. In this example, English is used. 

2. Creating the PCS 7 project. 

3. Adjust the display languages. 
Options > Language for Display Devices 

Here, you can choose between English (US) and Chinese as default language 
at the beginning. 

Note In this context, it must be kept in mind that all Text0, Text1, and Shortcut texts 
are stored in Chinese (Simplified) in the blocks of the ASIA version.  

If you choose, for example, English as default display language, these texts have 
to be adjusted in the SIMATIC Manager. If this is only performed in the text 
library, then all texts are stored in Chinese again in the English column the next 
time the text is compiled. 

 

Note For new projects it is recommended to set the default display language to 
Chinese (provided you have Chinese language skills). 

 

4. Create the master data library. 

5. Adjust the blocks in the master data library to English. 
For this purpose, the master data library has to be exported, adjusted and re-
imported in the SIMATIC Manager (see chapter 4.1.1). 

6. Configure the hardware and the S7 program. 

7. Compile the S7 program and if necessary enable the Asset Management. 
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Note All default messages and texts already exist in Chinese and English in the 
system. However, translations can be adjusted and configured, for example, for 
user-generated blocks. For this project, all texts have to be exported, edited and 
re-imported. 

Options > Multilingual Texts > Export 

In the context menu that opens up, it is important that the source language and 
the target language is selected correctly.  

After successful export, the files can be, for example, with the help of Excel, 
edited, translated and subsequently re-imported. Import is performed as follows: 

Options > Multilingual Texts > Import 

 

NOTICE No changes must be made in the source language column. 

 

8. Compile the OS. (see chapter 3.3) 

9. If you have worked with default PCS 7 resources, everything will be in Chinese 
as well as English. Before processing with OS can be started, the language 
settings also have to be checked first of all. 

– WinCCExplorer > Options > Language 

– WinCCExplorer > Computer > Properties > Parameters > Runtime 

Language > Chinese 

– Open the Graphics Designer and also set the language to English:  
View > Language > English (US) (Figure 3-3) 

Now you can translate everything in the text library that is still missing (for 
example, S7_Text0, S7_Text1 and S7_Shortcut block texts). The changes can 
be either made directly in the text library or you export them, translate them 
and re-import them. 

10. The processing of OS has to be performed in English as well as in Chinese. 
There are two options: 

– Make all text changes in the Graphics Designer in English and in Chinese. 
Process and save the language settings in English and in Chinese for each 
image. 

– Create all texts in the Graphics Designer in English or Chinese. Once you 
have completed the OS processing, perform an export with the text 
distributor, translate the texts and re-import them. 

Note User-defined texts have to be configured multilingual. 
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6.4 Converting projects from English to Chinese 
(Simplified) 

NOTE All procedures, descriptions and screenshots relevant for PCS 7 are based on 
the PCS 7 V7.1 and are applicable to the PCS 7 V8.1 without restrictions. 

In this example, a project that was configured with the EU Version of PCS 7 is to 
be ported to the ASIA version. The project was configured in English and all other 
EU default languages are also kept. 

When opening a neutral project, the following message will always be displayed: 
Figure 6-7 

 

 

NOTICE The project and the master data library can only be opened and edited, if the 
PCS 7 project language was previously set to language neutral. 

Requirement 

 Windows 7 MUI with Chinese language package (Simplified) 

 Regional and language settings (see chapter 2):  

– Menus: English 

– Formats: Chinese 

– Input language: English and Chinese 

– Language for non-Unicode program: Chinese 
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Procedure 

1. Open the SIMATIC Manager and check the language setting (see chapter 3.2). 
Options > Customize > Language 

Select English as interface language for the SIMATIC Manager. 

2. Dearchive the respective project. 

3. Select the project and adjust the display language. 
Options > Language for Display Devices 

Add Chinese (PRC) and keep English as default language (see figure 6-13). 

 

Note In this context, it must be kept in mind that all Text0, Text1, and Shortcut texts 
are stored in Chinese in the blocks of the ASIA version.  

If you choose, for example, English as default display language, these texts have 
to be adjusted in the SIMATIC Manager. If this is only performed in the text 
library, then all texts are stored in Chinese again in the English column the next 
time the text is compiled. 

 

Note For new projects it is recommended to set the default display language to 
Chinese (provided you have Chinese language skills). 

 

Figure 6-8 

 

 

4. Perform the same procedure again for the master data library. 
Thus, the blocks in the master data library are replaced with those of the ASIA 
version. 



6 Use Cases 
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Figure 6-9 

 

 

Figure 6-10 

 

 

NOTICE When replacing the blocks, you should keep the English text otherwise the 
Chinese texts for S7_Text0, S7_Text1 and S7_Shortcut are entered in the 
English language column. 

 

5. Upgrade the master data library by the new language by exporting, processing 
and importing it (see chapter 4.1.1). 

6. Update the blocks to introduce the changes in the project. 
The Chinese texts and messages are added. 

7. Export the texts of the project, adjust them and carry out an import. 

8. Compile and load the S7 program. 

9. Compile the OS (see chapter 3.3). 
Thus, the new language was automatically added in the OS. 



6 Use Cases 
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10. If you have worked with default PCS 7 resources, everything will be in Chinese 
as well as English. Before processing can be started in OS, the language 
settings have to be checked first of all. 

– "WinCCExplorer > Options > Language" 

–  "WinCCExplorer > Computer > Properties > Parameters > Language 
Setting at Runtime" 

– Open the Graphics Designer and also set the language to English:  
View > Language > English (US) (Figure 3-3) 

Now you can translate everything in the text library that is still missing (for 
example, S7_Text0, S7_Text1 and S7_Shortcut block texts). The changes can 
be either made directly in the text library or you export them, translate them 
and re-import them. 

11. The processing of OS has to be performed in English as well as in Chinese. 
There are two options: 

– Make all text changes in the Graphics Designer in English and in Chinese. 
Process and save the language settings in English and in Chinese for each 
image. 

– Create all texts in the Graphics Designer in English or Chinese. Once you 
have completed the OS processing, perform an export with the text 
distributor, translate the texts and re-import them. 

Note User-defined texts have to be configured multilingual. 



7 Appendix 
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7 Appendix 

7.1 Service and Support 

Industry Online Support 

Do you have any questions or need assistance?  

Siemens Industry Online Support offers round the clock access to our entire 
service and support know-how and portfolio. 

The Industry Online Support is the central address for information about our 
products, solutions and services.  

Product information, manuals, downloads, FAQs, application examples and videos 
– all information is accessible with just a few mouse clicks at: 
https://support.industry.siemens.com 
 

Technical Support 

The Technical Support of Siemens Industry provides you fast and competent 
support regarding all technical queries with numerous tailor-made offers  
– ranging from basic support to individual support contracts. You send queries to 
Technical Support via Web form: 
www.siemens.com/industry/supportrequest 
 

SITRAIN – Training for Industry  

With our globally available training courses for our products and solutions, we help 
you achieve with practical experience, innovative learning methods and a concept 
that’s tailored to the customer’s specific needs. 

For more information on our offered trainings and courses, as well as their 
locations and dates, refer to: 
www.siemens.com/sitrain  
 

Service offer 

Our range of services includes the following:  

 Plant data services 

 Spare parts services 

 Repair services 

 On-site and maintenance services 

 Retrofitting and modernization services 

 Service programs and contracts 

You can find detailed information on our range of services in the service catalog: 
https://support.industry.siemens.com/cs/sc 
 

Industry Online Support app 

You will receive optimum support wherever you are with the "Siemens Industry 
Online Support" app. The app is available for Apple iOS, Android and Windows 
Phone:  
https://support.industry.siemens.com/cs/ww/en/sc/2067 

https://support.industry.siemens.com/
http://www.siemens.com/industry/supportrequest
http://www.siemens.com/sitrain
https://support.industry.siemens.com/cs/sc
https://support.industry.siemens.com/cs/ww/en/sc/2067
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7.2 Links and Literature 

Table 7-1 

No. Topic 

\1\ Siemens Industry Online Support 

https://support.industry.siemens.com 

\2\ Link to this entry page of this application example 

https://support.industry.siemens.com/cs/ww/en/view/56248153 

\3\ How can you configure the "Report System Error" functionality of an S7 station to 
be multilingual? 

https://support.industry.siemens.com/cs/ww/en/view/23596958 

\4\ How can you configure multilingual texts in process screens? 

https://support.industry.siemens.com/cs/ww/en/view/29419870 

\5\ What are the options for setting languages in PCS 7? 

https://support.industry.siemens.com/cs/ww/en/view/8763245 

\6\ How can you configure process screens in multiple languages with WinCC text 
reference tags?  

https://support.industry.siemens.com/cs/ww/en/view/29419661 

\7\ Russian Localization for PCS 7 (System expansion for process visualization in 
Russian) 

https://support.industry.siemens.com/cs/ww/en/view/35221749 

\8\ How can you use the texts of enumerations (under Shared Declarations in the 
SIMATIC Manager) for display in WinCC? 

https://support.industry.siemens.com/cs/ww/en/view/27147567 

 

 

7.3 History 

Table 7-2 

Version Date Modifications 

V1.0 12/2011 First version for PCS 7 V7.1 

V2.0 06/2013 Update to PCS 7 V8.0 SP1 

V3.0 03/2015  Update to PCS 7 V8.1 

 Update chapter 2.1 to Windows 7 

V4.0 12/2017 Update to PCS 7 V9.0 

 

 

https://support.industry.siemens.com/
https://support.industry.siemens.com/cs/ww/en/view/56248153
https://support.industry.siemens.com/cs/ww/en/view/23596958
https://support.industry.siemens.com/cs/ww/en/view/29419870
https://support.industry.siemens.com/cs/ww/en/view/8763245
https://support.industry.siemens.com/cs/ww/en/view/29419661
https://support.industry.siemens.com/cs/ww/en/view/35221749
https://support.industry.siemens.com/cs/ww/en/view/27147567
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