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Legal information 
Warning notice system 

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger. 

 DANGER 
indicates that death or severe personal injury will result if proper precautions are not taken. 

 

 WARNING 
indicates that death or severe personal injury may result if proper precautions are not taken. 

 

 CAUTION 
indicates that minor personal injury can result if proper precautions are not taken. 

 

 NOTICE 
indicates that property damage can result if proper precautions are not taken. 

If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
property damage. 

Qualified Personnel 
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. 
Qualified personnel are those who, based on their training and experience, are capable of identifying risks and 
avoiding potential hazards when working with these products/systems. 

Proper use of Siemens products 
Note the following: 

 WARNING 
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended 
or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be complied with. The information in the relevant documentation must be observed. 

Trademarks 
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication 
may be trademarks whose use by third parties for their own purposes could violate the rights of the owner. 

Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and software 
described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the 
information in this publication is reviewed regularly and any necessary corrections are included in subsequent 
editions. 
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 Warranty and liability 1 
 

 
 

 Note 

The application examples are not binding and do not claim to be complete with regard to 
configuration, equipment or any contingencies. The application examples do not represent 
customer-specific solutions. They are only intended to provide support for typical 
applications, you are responsible for the correct operation of the described products.  
These application examples do not relieve you from responsibilities of using, installing, 
operating and servicing the equipment safely and professionally. When using these 
application examples, you recognize that we are not liable for any damage/claims beyond 
the liability clauses described. 

We reserve the right to make changes to these application examples at any time and without 
prior notice. If there are any deviations in the recommendations provided in this application 
example and other Siemens publications, for example catalogs, the contents of the other 
documents shall have priority. 

 

We do not accept any liability for the information contained in this document. Any claims 
against us – based on whatever legal reason – resulting from the use of the examples, 
information, programs, engineering and performance data etc., described in this application 
example shall be excluded. Such an exclusion shall not apply in the case of mandatory 
liability, for example under the German Product Liability Act ("Produkthaftungsgesetz"), in 
case of intent, gross negligence, or injury of life, body or health, guarantee for the quality of a 
product, fraudulent concealment of a deficiency or breach of fundamental contractual 
obligations ("wesentliche Vertragspflichten"). 

The compensation for damages due to a breach of a fundamental contractual obligation is, 
however, limited to the foreseeable damage, typical for the type of contract, except in the 
event of intent or gross negligence or injury to life, body or health. The above provisions do 
not imply a change of the burden of proof to your detriment. Any form of duplication or 
distribution of these application examples or excerpts hereof is prohibited without the 
expressed consent of Siemens AG. 
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1.1 Security information 
Siemens provides products and solutions with industrial security functions that support the 
secure operation of plants, systems, machines and networks. 

In order to protect plants, systems, machines and networks against cyber threats, it is 
necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial 
security concept. Siemens’ products and solutions only form one element of such a concept. 

Customer is responsible to prevent unauthorized access to its plants, systems, machines 
and networks. Systems, machines and components should only be connected to the 
enterprise network or the internet if and to the extent necessary and with appropriate security 
measures (e.g. use of firewalls and network segmentation) in place. 

Additionally, Siemens’ guidance on appropriate security measures should be taken into 
account. For more information about industrial security, please visit: 
http://www.siemens.com/industrialsecurity 

Siemens’ products and solutions undergo continuous development to make them more 
secure. Siemens strongly recommends to apply product updates as soon as available and to 
always use the latest product versions. Use of product versions that are no longer supported, 
and failure to apply latest updates may increase customer’s exposure to cyber threats. 

To stay informed about product updates, subscribe to the Siemens Industrial Security RSS 
Feed under: 
http://www.siemens.com/industrialsecurity 
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 Preface 2 
 

 

Purpose of this document 
This document describes SITOP UPS1600 Block Library for SIMATIC STEP 7 V5.5, STEP 7 
Professional V14 SP1, WinCC Flexible, WinCC V7.3, WinCC Comfort/Advanced V14 SP1 
and WinCC Professional V14 SP1. The block library provides tested code with clearly 
defined interfaces. You can use it as the basis for the task you wish to realize. 

The main focus of this document is to describe: 

● All Function Blocks (FB) pertaining to the block library. 

● The functionality implemented through these blocks. 

The documentation furthermore illustrates the possible operating conditions and applications 
of the block library for SIMATIC STEP 7 V5.5, STEP 7 Professional V14 SP1, WinCC 
Flexible, WinCC V7.3, WinCC Comfort/Advanced V14 SP1 and WinCC Professional V14 
SP1. 

References 
For more information on SITOP UPS1600 manuals and related documentation, refer the 
following links, 

● Siemens Industry Online Support  
(https://support.industry.siemens.com/cs/start?lc=en-US) 

● SITOP UPS1600 Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415) 

● STEP 7 Professional V13 System Manual 
(https://support.industry.siemens.com/cs/ww/en/view/109011420) 

● WinCC Advanced V14.0 SP1 System Manual 
(https://support.industry.siemens.com/cs/ww/en/view/109091876) 

● SIMATIC Programming with SIMATIC STEP 7 V5.5 
(https://support.industry.siemens.com/cs/ww/en/view/45531107) 

● WinCC flexible 2008 System Manual 
(https://support.industry.siemens.com/cs/ww/en/view/18796010) 

● WinCC System Manual  
(https://support.industry.siemens.com/cs/ww/en/view/102754925) 

● GSD for SITOP UPS1600 for integration into SIMATIC STEP 7 V5.5 
(https://support.industry.siemens.com/cs/ww/en/view/75854605) 

● HSP for SITOP UPS1600 for integration into STEP 7 V14 TIA 
(https://support.industry.siemens.com/cs/ww/en/view/75854606) 

https://support.industry.siemens.com/cs/start?lc=en-US
https://support.industry.siemens.com/cs/ww/en/view/84977415
https://support.industry.siemens.com/cs/ww/en/view/109011420
https://support.industry.siemens.com/cs/ww/en/view/109091876
https://support.industry.siemens.com/cs/ww/en/view/45531107
https://support.industry.siemens.com/cs/ww/en/view/18796010
https://support.industry.siemens.com/cs/ww/en/view/102754925
https://support.industry.siemens.com/cs/ww/en/view/75854605
https://support.industry.siemens.com/cs/ww/en/view/75854606
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 Task 3 
 

 

Overview of the automation task 
The figure below provides an overview of the automation task. 

 
Figure 3-1   
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Task Description 
Your task is to equip the automation plant with Uninterruptible Power Supply (UPS).  
In the event of a power failure, critical process participants are to be protected. 

In the event of a power failure of the automation plant, process values are to be maintained 
and plant components be safeguarded against mechanical damage by means of a defined 
stopping process. 

UPS is integrated into the automation network via PROFINET. 

The status and diagnostic information of the UPS is displayed in the individual Human 
Machine Interfaces (HMI) stations. 
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 Structure 4 
4.1 Solution overview 

Structure 
The figure below shows a schematic overview of the most important components of the 
solution: 

 
Figure 4-1   
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Scope of this application example 
This application example provides FB162 function block for communication between the 
controller and SITOP UPS1600. 

It also provides faceplates and screen windows for monitoring and operation. 
 

 Note 

SITOP UPS1600 is termed as UPS1600 throughout this document. 
 

Function of the hardware components 
The table below describes the function of the Hardware (HW) components used in figure 4-1. 

Table 4- 1   

Name Function 
SITOP Power Supply Central 24 V power supply for all process devices. 
Non-critical process devices Symbol for other non-critical process devices.  

(Devices that can be switched off when there is  
sufficient pressure, for example: compressors.) 

SITOP UPS1600 and SITOP UPS1100 UPS with buffer (example, battery module). 
S7-1214 Automation controller 
Comfort Panel TP1200 Control panel for process visualization. 
Other critical process devices Symbol for other critical process devices. 
PROFINET Central process bus of all automation devices. 

Advantages 
This application offers the following advantages: 

● Time and cost saving by means of FB162, HMI faceplates and screen windows. 

● Easy and comprehensive introduction to integrating UPS1600 within a PROFINET 
network. 

Scope 
This application does not include description of: 

● Creating program blocks in SIMATIC STEP 7 V5.5/STEP 7 Professional V14 SP1. 

● Creating screens and objects in WinCC flexible/WinCC TIA Portal/WinCC. 

● Configuring communication between the described terminal devices. 

● Handling all the described SIMATIC terminal devices. 
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Assumed knowledge 
The user is assumed to have knowledge on the mentioned points: 

● Using SIMATIC STEP 7 V5.5, STEP 7 Professional V14 SP1, WinCC flexible, WinCC, 
and WinCC TIA Portal. 

● Operating, handling, and configuring SIMATIC S7 controllers (S7-300/400 and  
S7-1200/1500). 

● Operating, handling, and configuring HMI control panels (Multi Panels, Comfort Panels) 
and Runtime systems (WinCC flexible Runtime, WinCC Runtime Advanced, WinCC 
Runtime, WinCC Runtime Professional). 

● Handling and operating SITOP UPS1600. 
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4.2 Description of the core functionality 

Sequence of the core functionality 
Communication between UPS1600 and controller runs via PROFINET. The UPS1600 is 
connected to the controller as PROFINET IO node. Thus, the entire UPS1600 information 
(voltage, power, possible buffer time, battery state) is available in the controller. 

In this application example, two scenarios are realized. 

● The Programmable Logic Controller (PLC) via the supplied program block FB162 
recognizes power failure. The information is made permanently available in the control 
program which can be then evaluated. This allows your process to respond and switch off 
your process devices in a defined manner. 

● The Programmable Logic Controller (PLC) via the supplied program block FB164 
recognizes diagnostic interrupts and generates alarm messages to WinCC. 

● With the provided faceplates and screen windows, relevant information and important 
parameters are displayed on the HMI control panel. 

 

 Note 

FB164 is applicable only to SIMATIC STEP7 V5.5 
 

Overview and description of the user interface 

 
Figure 4-2   



 Structure 
 4.2 Description of the core functionality 

SITOP UPS1600 Firmware V2.2 : Faceplates and Communication Blocks V2.2 
Function Manual, 01.2018, A5E39439812-02-76 15 

The application example provides the following views in the faceplate: 

● UPS state 

● General Device information 

● Output Data 

● Voltage and power trend curves 

● Currently pending alarms/alarm history 
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4.3 Hardware and software components used 

Hardware components 

Table 4- 2   

Component No. Article number Note 
SITOP UPS1600 20 A 
 

1 6EP4136-3AB00-2AY0 Alternatively, 
SITOP UPS1600 10 A  
6EP4134-3AB00-2AY0 
or  
SITOP UPS1600 40 A  
6EP4137-3AB00-2AY0 is 
used. 

MP277 8" Touch 1 6AV6643-0CB01-1AX5 Refer to Requirements 
(Page 71). 

Comfort Panel TP1200 1 6AV2124-0MC01-0AX0 Refer to Requirements 
(Page 95). 

CPU 1214C DC/DC/RLY PN/DP 1 6ES7214-1HG40-0XB0 Or other 
S7-1200/1500 CPU 

CPU 317-2 PN/DP 1 6ES7317-2EK14-0AB0 Or other S7-300 CPU 
SITOP UPS1100 3.2 Ah (Battery 
module) 

1 6EP4133-0GB00-0AY0  

 

 

 Note 

The UPS1600 is upgraded with Firmware (FW) version 2.1 or higher. 
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Standard software components 

Table 4- 3   

Component No. Article number Note 
WinCC Flexible 2008 SP3 Advanced 1 6AV6613-0AA51-3CA5 Alternatively, WinCC 

flexible 2008 SP3 
Standard 

WinCC Advanced V14 SP1 1 6AV2102-4AA03-0AE5 Alternatively, WinCC 
Comfort V13 SP1 

STEP 7 Professional V5.5 1 6ES7810-4CC10-0YA5 - 
STEP 7 Professional V14 SP1 1 6ES7822-1AA03-2YA6 - 
WinCC Professional V14 SP1 1 6AV2103-0DA03-0AA5 - 
WinCC V7.3 update 4 1 6AV6381-2BD07-3AH0 - 

Sample files and projects 
The following list in the table includes all files and projects that are used in this example. 

Table 4- 4   

Component Note 
UPS1600 V2.2 library TIA Portal V14 
SP1.zip 

This zip file contains the library for TIA Portal V14 SP1 
and master copies for STEP 7 V14 SP1 and WinCC 
V14 SP1. 

Library_STEP7-V5_SITOP-UPS1600_V2-2-
1.zip 

This zip file contains the following subfolders. 
• UPS1600_STEP7_V5_5 
• UPS1600_lib_WinCC_flexible_2008 
• UPS1600_lib_WinCC_V7_3 
• UPS1600_lib_WinCC_V7_4 

UPS1600_STEP7_V5_5 This zip file contains the library of the function blocks 
(FB) for SIMATIC STEP 7 V5.5. 

UPS1600_lib_WinCC_flexible_2008 This zip file contains the library of the faceplates for 
WinCC flexible 2008 SP3. 

UPS1600_lib_WinCC_V7_3 This zip file contains the library of the screen windows 
for WinCC V7.3. 

UPS1600_lib_WinCC_V7_4 This zip file contains the library of the screen windows 
for WinCC V7.4. 
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 Function blocks 5 
5.1 Function and task of the function blocks 

Overview 
This chapter describes the application and requirements of FB162 and FB164 and its 
integration into a SIMATIC STEP 7 project. 

Task description and application 
● In the event of a plant power failure, it is essential to safeguard certain machine 

components against damage and to back-up process relevant data in order to prevent 
data loss. The application of FB162 provides the option to bring your plant into a safe 
state and switch it off in a program-controlled manner while UPS1600 buffers the voltage. 

● The Programmable Logic Controller (PLC) via the supplied program block FB164 
recognizes diagnostic interrupts and generates alarm messages to WinCC. 

FB162 Function description 
The FB162 cyclically monitors the operating mode of the UPS1600. When UPS1600 is in 
buffer mode, a 10 s timer within the FB starts. This timer prevents the plant from being 
brought into a safe state in the event of just a short voltage dip/drop. If the UPS is still in 
buffer mode after expiry of the timer, the parameter UPS_ready_for_reset is set from FALSE 
to TRUE. Further, this parameter is also used to bring the plant components into a safe state 
(maintenance mode). When the plant is brought into a safe state, the parameter 
UPS_execute_reset is set from FALSE to TRUE. The FB162 then sends a command to the 
UPS1600, which then switches off autonomously. The following flow diagram displays the 
program sequence of the FB162. 
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Figure 5-1   

Notes regarding the FB162 
● If the UPS1600 returns to the normal mode when the timer is running, the parameter 

UPS_ready_for_reset is not set. 

The timer is then reset. 

● After the parameter UPS_execute_reset is set, the further program sequence is executed 
until UPS1600 is switched off via the FB162. 

● The buffer time of UPS1600 must be set such that there is sufficient time to bring the 
plant into a safe state and switch off the UPS via the FB162. 

Notes regarding the FB164 
● In Report system error system diagnostics blocks, alarm messages will not include 

extended error information. So in order to show detailed message of interrupt, FB164 is 
developed. If we use this block, no need to generate system diagnostic blocks using RSE 
(Report system error). 
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5.2 Operating conditions 

Configuration 
FB162 and FB164 are approved for the following configuration: 

● SIMATIC STEP 7 V5.5 and application of a CPU 300/400 

● STEP 7 V14 SP1 and application of a CPU 300/400 or CPU 1200/1500 
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 Faceplates 6 
 

 

The HMI faceplate displays actual values and various states of the UPS1600 on HMI control 
panel/runtime system. 

6.1 Description 

Overview 
This faceplate visualizes parameters of UPS1600 on a HMI control panel. 

 
Figure 6-1   

The parameters of UPS1600 are distributed over three tabs in the faceplate, clicking on the 
relevant tab displays specific information. The three tabs are: 

● State 

● Trends 

● Alarms 

The contents of the tabs and the parameters are described in detail in the following sections. 

To close the faceplate, press the "X" button provided at the top right corner of the faceplate. 
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6.2 State 

Introduction 
The "State" tab displays two menu options: 

● Information > Overview 

● Device > Information 

Information > Overview 
This menu item displays the operating state and battery state of UPS1600. 

 
Figure 6-2   

The following table shows all parameters displayed under this menu with its corresponding 
display names. 

Table 6- 1   

Display name Parameter of the UPS 
Input voltage Input_voltage 

Output voltage Output_voltage 

Output current Output_current 

Battery voltage Battery_voltage 

Battery charge Battery_charge_level 

End-of-charge voltage End_of_charge_voltage 

Charge current Measured_charge_current 

Normal mode/Buffer mode Buffer_mode 

Ready for buffering/Not ready for buffering Ready_for_buffering 

No new alarms pending/New alarms pending New_alarms_pending 
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The values of the parameters Buffer_mode, Ready_for_buffering, and New_alarms_pending 
are output via symbolic I/O fields. 

In addition to this output, a rectangle is displayed in front of each symbolic I/O field, which is 
subject to the color dynamization dependent on the parameter value. 

The following table shows the possible parameter states with its corresponding color 
dynamization. 

Table 6- 2   

Parameter State/display name Color 
Normal mode Normal mode Green 

Buffer mode Yellow 
Ready for buffering Ready for buffering Green 

Not ready for buffering Red 
No new alarms pending No new alarms pending Green 

New alarms pending Yellow 
 

 

 Note 

All the I/O fields in the faceplate are read only values. 
 

Device > Information 
This menu displays general device information about UPS1600. 

 
Figure 6-3   
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The following table shows all parameters displayed under this menu with its corresponding 
display names. 

Table 6- 3   

Display name Parameter of the UPS 
Device name Device_name 

Order number Order_number 

Serial number Serial_number 

HW revision HW_revision 

SW revision SW_revision 
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6.3 Trends 

Description 
The "Trends" tab displays the following attributes of UPS1600 in trend curves: 

● Input voltage 

● Output voltage 

● Output current 

● Battery voltage 

● Charge current 

 
Figure 6-4   

The time range of the X axis of the trend curve is 100 seconds. The trend variables used 
have an acquisition cycle of 1 second and are refreshed cyclically. 

The table below describes UPS1600 parameters with their respective display names, color 
and unit representation. 

Table 6- 4   

Display name Parameter of the UPS Color Unit 
Input voltage Input_voltage Green V 
Output voltage Output_voltage Black V 
Output current Output_current Red A 
Battery voltage Battery_voltage Orange V 
Charge current Measured_charge_current Blue A 
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6.4 Alarms 

Description 
The "Alarms" tab displays PROFINET diagnostic messages of SITOP UPS1600. 

 
Figure 6-5   

When you click on "show pending alarms" and "show alarm history" buttons, two separate 
message windows open. 

The message window for "Pending alarms" displays all currently pending PROFINET 
diagnostic messages of the UPS1600. The message window for "Alarm history" displays all 
PROFINET diagnostic messages of UPS1600 stored in the internal message buffer of the 
HMI control panel used. 

Prerequisites for displaying the PROFINET diagnostic messages  
In order to display PROFINET diagnostic messages of UPS1600 within the faceplate, the 
respective WinCC flexible/WinCC TIA Portal project must be configured. 

A list of the PROFINET diagnostic messages of UPS1600 is available in the chapter 4 of the 
SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415). 

https://support.industry.siemens.com/cs/ww/en/view/84977415
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 Application of the function blocks 7 
7.1 Application of the function blocks in SIMATIC STEP 7 V5.5 

7.1.1 Prerequisites 

FB162 requirements 
The following requirements must be met in order to use the FB in combination with UPS1600 
and SIMATIC STEP 7 V5.5. 

● The GSD file of the UPS1600 is installed in the Hardware (HW) configuration of  
SIMATIC STEP 7 V5.5 and the UPS is configured as PROFINET node in the HW 
configuration of the SIMATIC S7 controller. 

● S7 communication between UPS1600 and SIMATIC S7 controller is already configured. 

● The library UPS1600_STEP_7_V5_5 is available on your computer. 

Installation of GSD file 
The required information about installation of the GSD file of the UPS1600 in SIMATIC 
STEP 7 V5.5 is available in the chapter 3.4.2 of the SITOP UPS1600 User Manual. 
(https://support.industry.siemens.com/cs/ww/en/view/84977415) 

S7 communication 
The required information about establishing communication between a UPS1600 and a 
SIMATIC S7 controller is available in the chapter 3.4 of the SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415). 

7.1.2 Content of the library for SIMATIC STEP 7 V5.5 

Content of the library for SIMATIC STEP 7 V5.5 
The library UPS1600_STEP_7_V5_5 contains: 

● Blocks (FB162, FB164, UDT8, UDT4500, UDT4501 and UDT4502) 

● Symbol table Symbols_UPS1600 

● SCL source file of the code blocks FB162, FB164, UDT8, UDT4500, UDT4501 and 
UDT4502 

● "Text Libraries" 

https://support.industry.siemens.com/cs/ww/en/view/84977415
https://support.industry.siemens.com/cs/ww/en/view/84977415
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The table below shows the blocks available in the library. 

Table 7- 1   

Block Name Description 
FB162 UPS1600 FB for program-controlled switch-off of the 

UPS1600 
UDT4500 tUPS1600 strings V2_1 UDT which contains UPS1600 string variable 

declarations 
UDT4501 tUPS1600 mixed V2_1 UDT which contains all parameters of the 

UPS1600. 
UDT4502 UDT_UPS1600_Data_V2_1 Combined UDT of UDT4500 and UDT4501 
FB164 SITOP_UPS1600_DIAG FB to raise UPS1600 diagnostic alarms 
UDT8 SStartInf UDT structure of local data of OB82 

Opening the library in SIMATIC STEP 7 V5.5 
Follow the procedure to open the library in a SIMATIC STEP 7 V5.5 project: 

1. Open SIMATIC Manager. 

2. In the menu bar, click "File > Open". 
The "Open Project" dialog box opens. 

3. Select the "Libraries" tab. 

 
Figure 7-1   

4. Click "Browse". 
The "Browse" dialog box opens. 
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5. Navigate to the stored location of the library in your computer and open the folders 
"UPS1600_V2_2_Library > UPS1600_STEP7_V5_5". 

6. Select "UPS1600_" and click "OK". 

 
Figure 7-2   

7.1.3 Interfaces of the function block 

Block diagram 
The following figure shows the block diagram of FB162: 

 
Figure 7-3   
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Interface description 
The table below describes parameters of FB162. 

Table 7- 2   

Parameter Declaration Data type Description 
I_ADDRESS Input INT PROFINET diagnostic address of 

the UPS1600 within the project. 
The diagnostic address must be 
specified in decimal format. 

Cyclic_IO_Address Input INT Input address of the UPS1600 
within the project. 
The input address must be  
specified in decimal format. 

UPS_execute_reset Input BOOL Switch-off signal to the UPS1600. 
UPS_ready_for_reset Output BOOL Signal for plant shut-down. 
Data InOut UDT_UPS1600_Data Data area for data exchange to 

the HMI faceplate. 

 

The table below describes parameters of FB164. 

Table 7- 3   

Parameter Declaration Data type Description 
Diag_Address Input INT PROFINET diagnostic address of 

the UPS1600 within the project. 
The diagnostic address must be 
specified in decimal format. 

MsgEvId100_01 .. 
MsgEvId100_27 Input DWORD Message event ids for Device 

failures alarms 
MsgEvId101_01 .. 
MsgEvId101_27 Input DWORD Message event ids for Device 

Diagnostic alarms 
MsgEvId102_01 .. 
MsgEvId102_12 Input DWORD Message event ids for Battery 

Diagnostic alarms 

Input and diagnostic address of the UPS1600 module 
To fetch the input and diagnostic address of the UPS1600 module, follow the instructions 
given below: 

1. Open the hardware configuration settings of the PLC used in the project. The "HW Config 
- [SIMATIC 300(1) (Configuration)..." dialog box opens. 

2. Select the UPS1600 module. 

3. Note down the value in the "Diagnostic Address" column (A). We need to add value to the 
given parameter I_ADDRESS of FB162 and Diag_Address of FB164. 

4. Note down value in the "I Address" column (B), value given to the parameter 
Cyclic_IO_Address of FB162. 
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Figure 7-4   

In this case, 

● I_ADDRESS value is 8183. 

● Cyclic_IO_Address is 256. 

 

7.1.4 UDT_UPS1600_Data_V2_1 (UDT4502) 

Data block DB161 
The Data Block (DB) contains all the parameters of UPS1600 displayed within the HMI 
faceplate. 

The following table lists all the parameters in UDT4502: 

Table 7- 4   

Parameter Data type Remarks 
Order_number_string STRING [20] Char to string > Order_number 
Serial_number_string STRING [20] Char to string > Serial_number 
Device_name_string STRING [20] Char to string > Device_name 
Version_number_string STRING [30] Char to string > Version_number 
Battery_capacity REAL [Ah] 
End_of_charge_voltage REAL [V] 
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Parameter Data type Remarks 
Charge_current REAL [A] 
HW_revision1 BYTE - 
HW_revision2 BYTE - 
SW_revision1 BYTE - 
SW_revision2 BYTE - 
Max_output_current BYTE [A] 
Padding BYTE - 
Order_number ARRAY [0 to 29] Of CHAR [30 characters] 
Serial_number ARRAY [0 to 29] Of CHAR [30 characters] 
Device_name ARRAY [0 to 29] Of CHAR [30 characters] 
Version_number ARRAY [0 to 49] Of CHAR [50 characters] 
Input_voltage REAL [V] 
Input_current REAL [A] 
Output_voltage REAL [V] 
Load_current REAL [A] 
Measured_charge_current REAL [A] 
Battery_voltage REAL [V] 
Output_current REAL [A] 
Charge_voltage REAL [V] 
Buffer_mode BYTE Active = 255, Inactive = 0;  

Undefined = 127 
Ready_for_buffering BYTE Yes = 255; No = 0 
New_alarms_pending BYTE Yes = 255; No = 0 
Battery_charge_level BYTE 0 to100% = battery charging;  

255 = unknown battery 
Total_calculated_battery_ 
capacity REAL [Ah] 
Total_calculated_battery_health BYTE [%] 
Buffer_time INT [s] 
Buffer_threshold REAL [V] 
Buffering_allowed BYTE [0/255] 
CommandID INT Remote reset = 8195 
Parameter BYTE - 
Padding_command BYTE - 
Device-HWRevision INT - 
Device-SWRevision1 BYTE - 
Device-SWRevision2 BYTE - 
Device-SWRevision3 BYTE - 

 

 

 Note 

Further information about the system parameters is available in the SITOP UPS1600 User 
Manual (https://support.industry.siemens.com/cs/ww/en/view/84977415). 

 

https://support.industry.siemens.com/cs/ww/en/view/84977415
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7.1.5 Integrating the function block 

Integrating FB162 
The following sections describe all the steps required to integrate FB162 into a  
SIMATIC STEP 7 V5.5 project. 

Hardware used: 

● CPU 317-2 PN/DP 

● SITOP UPS1600 24 V/20 A 

The procedure for other SIMATIC S7 controllers is identical. 
 

 Note 

Please ensure that all requirements for the integration of the FB are met. The requirements 
are described in these Prerequisites (Page 29). 

 

Inserting blocks from the library into the program 
Follow the procedure to integrate FB162 and associated data blocks into a SIMATIC STEP 7 
V5.5 project. 

1. In the "SIMATIC Manager", open the required project. 

2. Open the "Blocks" folder available in the connected PLC. 

3. In the "SIMATIC Manager", open the global library UPS1600 V2_2 STEP7 V5_5 and 
select "UPS1600_V2_2 > Blocks''. 
The procedure for opening the library is described in Content of the library for  
SIMATIC STEP 7 V5.5 (Page 29). 

4. Select all the blocks in the library and drag-and-drop them into the "Blocks" folder of your 
target project folder. 

 
Figure 7-5   

5. Insert OB40 in order to avoid PLC going to stop mode in case of hardware interrupt. 
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Inserting Text libraries from the library into the program 
Follow the procedure to insert "Text Libraries" from the library into a SIMATIC STEP 7 V5.5 
project. 

1. In the "SIMATIC Manager", open the required project. 

2. Open the "S7 Program" folder available in the connected PLC. Insert Text Library folder 
under S7 Program folder if it doesn’t exist. 

3. In the "SIMATIC Manager", open the global library UPS1600 V2_2 STEP 7 V5_5 and 
select "UPS1600_V2_2". 

4. The procedure for opening the library is described in Content of the library for  
SIMATIC STEP 7 V5.5. 

5. Copy "SITOP_MODULES", "SITOP_UPS1600_DiagText", "SITOP_UPS1600_HlpText" 
which are present under "Text Libraries" folder in the library and paste them into the "Text 
Libraries" folder of target project folder. 

6. Open text library "SITOP_MODULES"  and make an entry to the text library with index as 
modules diagnostic address and PSU8600/UPS1600 device name under English/ 
German Language column as shown below. 

 
Figure 7-6   

7. Save and close text library. 
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Create a global data block with UDT structure 
Follow the procedure to create a global DB with UDT: 

1. In your project, open the "Blocks" folder available in the connected PLC folder. 

2. Right-click on the blocks element area and select "Insert New Object > Data Block". 

The "Properties - Data Block" dialog box opens to create a DB. 

3. In the "Properties - Data Block" dialog box, 

– Enter a name and number for the DB (DB15) in the "Name and type:" text box. 

– For the same field, open the first drop-down list and select "Shared DB". 

– Enter a symbolic name as desired (UPS_global) in the "Symbolic Name:" text box. 

 
Figure 7-7   

4. Click "OK". 
The created DB appears in the "Blocks" folder. 

5. Open the DB created in Step 2 (DB15). 

A new window opens. 
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6. At the address "+0.0", 

– In the "Name" column, enter a name for your tag (UPS). 

– In the "Type" column, replace INT with UDT_UPS1600_Data_V2_1. 

– In the "Initial" column, delete the initial value and remove the comment. 

 
Figure 7-8   

7. Save the settings and close the window. 

Calling the function block FB162 
Follow the procedure to call the FB within an organization block (OB). In this description, 
FB162 is called within OB33. 

1. In the "Blocks" folder of the controller, create an instance DB. 

2. Right click on the blocks element area and select "Insert New Object > Data block".  
The "Properties - Data Block" dialog box opens. 



 Application of the function blocks 
 7.1 Application of the function blocks in SIMATIC STEP 7 V5.5 

SITOP UPS1600 Firmware V2.2 : Faceplates and Communication Blocks V2.2 
Function Manual, 01.2018, A5E39439812-02-76 39 

3. In the "Properties - Data Block" dialog box, 

– Enter a name and number for the DB (DB12) in the "Name and type:" text box. 

– For the same field, select "Instance DB" and "FB162" from the drop-down lists. 

– Enter the symbolic name as "UPS1600_DB" in the "Symbolic name:" text box. 

– Click "OK" 

 
Figure 7-9   
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4. In the same "Blocks" folder, create an Organization Block (OB) with the name OB33. 
(Right click and select "Insert New Object > Organization block".) 

Open the created OB33. 

 
Figure 7-10   

5. In the "Program elements" tab, expand the "FB blocks" folder. 

6. Drag-and-drop "FB162 (UPS1600_V2_1)" onto the empty network area. 

 
Figure 7-11   
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7. For the block in the network area, 

– Interconnect FB162 with the instance DB created in step 1 (DB12). 

– For the parameter I_ADDRESS, enter the PROFINET diagnostic address of the  
SITOP UPS1600 within your STEP 7 project (8183). 

– For the parameter Cyclic_IO_Address, enter the input address of the SITOP UPS1600 
within your STEP 7 project (256). 

– Connect the parameter UPS_ready_for_reset to the tag through which you bring the 
plant into a safe state (flag M0.0 is used). 

– Connect the parameter UPS_execute_reset to the tag through which you switch off the 
UPS (flag M0.1 is used). 

 
Figure 7-12   

For further information about the block parameters, see Interfaces of the function 
block (Page 31). 

8. Save the changes and close the window. 

 

 Note 
I_ADDRESS and Cyclic_IO_Address of FB162 

To know the diagnostic and input address of FB162, refer section Input and diagnostic 
address of the UPS1600 module in Interfaces of the function block (Page 31). 
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Calling the function block FB164 
Follow the procedure to call the FB164 within an organization block (OB). In this description, 
FB164 is called within OB82. 

1. In the "Blocks" folder of the controller, create an instance DB. 

2. Right click on the blocks element area and select "Insert New Object > Data block".  
The "Properties - Data Block" dialog box opens. 

3. In the "Properties - Data Block" dialog box, 

– Enter a name and number for the DB (DB ) in the "Name and type:" text box. 

– For the same field, select "Instance DB" and "FB164" from the drop-down lists. 

– Enter the symbolic name as "UPS1600_Diag_DB" in the "Symbolic name:" text box. 

– Click "OK" 

 
Figure 7-13   



 Application of the function blocks 
 7.1 Application of the function blocks in SIMATIC STEP 7 V5.5 

SITOP UPS1600 Firmware V2.2 : Faceplates and Communication Blocks V2.2 
Function Manual, 01.2018, A5E39439812-02-76 43 

4. In the same "Blocks" folder, create an Organization Block (OB) with the name OB82. 
(Right click and select "Insert New Object > Organization block".) Open the created 
OB82. 

 
Figure 7-14   

5. In the "Program elements" tab, expand the "FB blocks" folder. 

6. Drag-and-drop "FB164 (SITOP_UPS1600_DIAG)" onto the empty network area. 

 
Figure 7-15   
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7. For the block in the network area, 

– Interconnect FB164 with the instance DB created in step 1 (DB). 

– For the parameter Diag_Address, enter the PROFINET diagnostic address of the 
SITOP UPS1600 within your SIMATIC STEP 7 project (8183). 

 
Figure 7-16   

8. Save the changes and close the window. 
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Follow the same procedure to call FB164 in OB86 and cyclic interrupt OB. In this example 
OB33 with the same instance DB which is created in step 3. 

 

 Note 
Diag_Address of FB164 

To know the diagnostic and input address of FB164, refer section Input and diagnostic 
address of the UPS1600 module in Interfaces of the function block (Page 31) 
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7.2 Application of the function blocks under STEP 7 Professional V14 
SP1 

7.2.1 Prerequisites 

Prerequisites 
The following requirements must be met in order to use the FB in combination with UPS1600 
and STEP 7 V14 SP1: 

● Hardware Support Package (HSP) for UPS1600 is installed in STEP 7 V14 SP1. 

● S7 communication between UPS1600 and SIMATIC S7 controller is already configured. 

● UPS1600 V2.2 library TIA Portal V14 SP1 is available on your computer. 

Installation of Hardware Support Package 
The required information about installation of Hardware Support Package of UPS1600 in 
STEP 7 V14 SP1 is available in the chapter 3.3.2 of the SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415). 

S7 communication 
The required information about establishing communication between UPS1600 and a 
SIMATIC S7 controller is available in the chapter 3.3 of the SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415). 

https://support.industry.siemens.com/cs/ww/en/view/84977415
https://support.industry.siemens.com/cs/ww/en/view/84977415
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7.2.2 Content of the library for STEP 7 V14 

Content of the library for STEP 7 V14 SP1 
The STEP 7 V14 SP1 library contains the library elements for: 

● S7-300/400 

● S7-1200/1500 

The following sections describes in detail about the library elements and how to open the 
library in STEP 7 V14 SP1. 

Library elements S7-300/400 and S7-1200/1500 
The following code blocks are present in this library element: 

Table 7- 5   

Folder Description 
Function Block It contains the UPS1600_V2.1 (FB162) function block for program-

controlled switch-off of the UPS1600. 
UDT It contains UDT_UPS1600 which is a master copy of the data types 

tUPS1600 mixed, tUPS1600 strings and UDT_UPS1600_V2_1. 

Opening the library in STEP 7 V14 SP1 
Follow the procedure to open the library in STEP 7 V14 SP1 project: 

1. Open STEP 7 V14 SP1 in the "Project view" and select the "Libraries" tab. 

2. Under the "Global libraries" palette, click on the highlighted icon to import the library.  
The "Open global library" dialog box opens. 

 
Figure 7-17   

3. In the "Look in:" drop-down list, navigate to the stored location of the library folder 
UPS1600 V2.2 library TIA Portal V14 SP1 on your computer and open it. 
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4. Select "UPS1600 V2.2 library TIA Portal V14 SP1.al13". 

 
Figure 7-18   

5. Click "Open". 

The library is displayed in the "Global libraries" palette. 

7.2.3 Interfaces of the function block FB162 

Function block FB162 for S7-300/400 
Block diagram 

The following figure shows the block diagram of FB162: 

 
Figure 7-19   
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Interface description 

Table 7- 6   

Parameter Declaration Data type Description 
I_ADDRESS Input DWORD PROFINET diagnostic address of 

the UPS1600 within the project 
Cyclic_IO_Address Input WORD I/O Data input address of 

UPS1600 within the project 
UPS_execute_reset Input BOOL Switch-off signal to the UPS1600 
Data InOut UDT_UPS1600_Data Data area for data exchange to 

the HMI faceplate. 
UPS_ready_for_reset Output BOOL Signal for plant shut-down 

I_Address and Cyclic_IO_Address of FB162 for S7-300/400 
To fetch the input and diagnostic address of the UPS1600 module for S7-300/400, follow the 
instructions given below: 

1. In the "Project tree", open "Devices and Networks". 

2. Select the UPS1600 module and go to "Device view > Device overview". 

3. Note down the value in the "I address" column (A), this value is given to the parameter 
I_Address. 

4. Select the UPS1600 module and go to "Properties > General > I/O data > I/O addresses 
> Input addresses" 

5. Note down the value in the "Start address" variable (B), this value is given to the 
parameter Cyclic_IO_Address. 
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Figure 7-20   

In this case, 

● Value of I_ADDRESS is 8186 (A). 

● Value of Cyclic_IO_Address is 256 (B). 
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Function block FB162 for S7-1200/1500 
Block diagram 

The following figure shows the block diagram of the FB162: 

 
Figure 7-21   

Interface description 

Table 7- 7   

Parameter Declaration Data type Description 
HW_IO Input HW_IO Hardware ID of the UPS1600 

within the project, for example: 
DC-UPS-20A_1~Head. 

Cyclic_IO_Address Input HW_IO IO Data submodule address of 
UPS1600 within the project 

UPS_execute_reset Input BOOL Switch-off signal to the UPS1600 
Data InOut UDT_UPS1600_Data Data area for data exchange to 

the HMI faceplate. 
UPS_ready_for_reset Output BOOL Signal for plant shut-down 

HW_IO and Cyclic_IO_Address of FB162 for S7-1200/1500 
To fetch the input and diagnostic address of the UPS1600 module for S7-1200/1500, follow 
the instructions given below: 

1. In the "Project tree", open "Devices and Networks". 

2. In the "Network view", select the UPS1600 module and go to "Properties > System 
constants". 

3. Note down the value in the "Hardware identifier" column of DC-UPS-20A_1~Head (A), 
value given to HW_IO. 

4. Note down the value in "Hardware identifier" column of DC-UPS-
20A_1~IO_Data_Submodule (B), value given to Cyclic_IO_Address. 
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Figure 7-22   

In this case, 

● Value of HW_IO is DC-UPS-20A_1~Head or 273 (A). 

● Value of Cyclic_IO_Address is DC-UPS-20A_1~IO-Data_Submodule or 274 (B). 
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7.2.4 UDT_UPS1600_Data 

UDT_UPS1600_Data 
The data block contains parameters of UPS1600 displayed within the HMI faceplate. 

The following table lists parameters present in UDT_UPS1600_Data. 

Table 7- 8   

Parameter Data type Remarks 
UPS_DataS tUPS1600 strings - 
Order_number_string STRING [20] Order number (String) 
Serial_number_string STRING [20] Serial number (String) 
Device_name_string STRING [20] Device name (String) 
Version_number_string STRING [30] Version number (String) 
UPS_DataM tUPS1600 mixed - 
Battery_capacity REAL [Ah] 
End_of_charge_voltage REAL [V] 
Charge_current REAL [A] 
HW_revision1 BYTE - 
HW_revision2 BYTE - 
SW_revision1 BYTE - 
SW_revision2 BYTE - 
Max_output_current BYTE [A] 
Padding BYTE - 
Order_number ARRAY [0 to 29] Of CHAR [30 characters] 
Serial_number ARRAY [0 to 29] Of CHAR [30 characters] 
Device_name ARRAY [0 to 29] Of CHAR [30 characters] 
Version_number ARRAY [0 to 49] Of CHAR [50 characters] 
Input_voltage REAL [V] 
Input_current REAL [A] 
Output_voltage REAL [V] 
Load_current REAL [A] 
Measured_charge_current REAL [A] 
Battery_voltage REAL [V] 
Output_current REAL [A] 
Charge_voltage REAL [V] 
Buffer_mode BYTE Active = 255 Inactive = 0;  

Undefined = 127 
Ready_for_buffering BYTE Yes = 255; No = 0 
New_alarms_pending BYTE Yes = 255; No = 0 
Battery_charge_level BYTE 0 to 100% = battery charging;  

255 = unknown battery 
Total_calculated_battery_capacity REAL [Ah] 
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Parameter Data type Remarks 
Total_calculated_battery_health BYTE [%] 
Buffer_time INT [s] 
Buffer_threshold REAL [V] 
Buffering_allowed BYTE [0/255] 
CommandID INT Remote reset = 8195 
Parameter BYTE - 
Padding_command BYTE - 
Device-HWRevision INT - 
Device-SWRevision1 BYTE - 
Device-SWRevision2 BYTE - 
Device-SWRevision3 BYTE - 

7.2.5 Integrating the function block 

7.2.5.1 Procedure when using an S7-300/400 

Overview 
Hardware used: 

● CPU 317-2 PN/DP 

● SITOP UPS1600 24V/20A 

The procedure for other SIMATIC S7-300/400 controllers is identical. 
 

 Note 

Please ensure that all the requirements for the integration of the FB are met.  
The requirements are described in the Prerequisites (Page 46). 
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Inserting blocks from the library into the program  
Follow the procedure to insert the FB162 and associated data blocks into a STEP 7 V14 SP1 
project. 

1. Open the required project in "Project view". 

2. In the "Libraries" window, under "Global libraries", open the library "UPS1600 2.2 library 
TIA Portal V14 SP1". 

The procedure for opening UPS1600 2.2 library TIA Portal V14 SP1 global library is 
described in Content of the library in STEP 7 V14 (Page 47). 

3. In the library, select "Master copies > UPS1600 TIA Library > UPS1600 Step7 > S7-
300/400 > UDT > UDT_UPS1600". 

 
Figure 7-23   
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4. Drag-and-drop "UDT_UPS1600" into the "PLC data types" folder in the "Project tree". 

 
Figure 7-24   
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5. In the library, select "Master copies > UPS1600 TIA Library > UPS1600 Step7 > S7-
300/400 > Function Blocks > UPS1600_V2.1". 

 
Figure 7-25   
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6. Drag-and-drop "UPS1600_V2.1" into the "Program blocks" folder in the "Project tree". 

 
Figure 7-26   

Calling the function block 
Follow the procedure to call FB162 within an Organization Block (OB). In this description, 
FB162 is called within OB33. 

1. In the "Project tree", open the "Program blocks" folder. 

2. Create a cyclic interrupt OB with the name "CYC_INT3[OB33]" and open it. This displays 
an empty network. 

3. From the "Program blocks" folder, drag-and-drop "UPS1600_2.1 [FB162]" to the empty 
network of OB33. The "Call options" dialog box opens. 

 
Figure 7-27   
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4. Keep the default settings of the dialog box and click "OK". 

5. Double click on "Add new block" to add a new DB. The "Add new block" window opens. 

6. In the "Add new block" window, 

– Select "Data block" 

– Enter a name as desired (UPS_Global). 

– In the "Type:" drop-down list, select "Global DB". 

– Click "OK". 

 
Figure 7-28   
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7. Open the global DB created in step 6 (UPS_Global). Add a new tag with data type as 
"UDT_UPS1600_Data". 

 
Figure 7-29   

8. In the network area of OB33, 

 
  Note 

OBs are called cyclically and in numerical order. Observe this when calling the 
communication blocks in an operation block. This ensures that you are reading the 
current data of the power supply. 

 

– For the parameter I_ADDRESS, enter the PROFINET diagnostic address of the 
UPS1600 module (8186). 

– For the parameter Cyclic_IO_Address, enter the start address of the UPS1600 module 
(256). 

– Connect the parameter UPS_ready_for_reset with a tag of your project that you use to 
bring the plant into a condition in which it can be shut down. 

– Connect the parameter UPS_execute_reset with a tag of your project that you use to 
switch off the UPS when the plant is in a condition in which it can be shut down. 

– Connect the parameter Data with Global DB UPS_Global. 
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Figure 7-30   

 
 

 Note 
I_ADDRESS and Cyclic_IO_Address parameters 

To know the I_ADDRESS and Cyclic_IO_Address parameter values of the UPS1600 module, 
refer Interfaces of the function FB162 (Page 48). 

 

7.2.5.2 Procedure when using an S7-1200/1500 

Overview 
Hardware used: 

● CPU 1214C DC/DC/Rly 

● SITOP UPS1600 24 V/20 A 

The procedure for other SIMATIC S7-1200/1500 controllers is identical. 
 

 Note 

Please ensure that all requirements for the integration of the FB are met. The requirements 
are described in the Prerequisites (Page 46). 
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Inserting blocks from the library into the program 
Follow the procedure to insert the blocks and the associated data blocks into a STEP 7 V14 
SP1 project: 

1. Open the required project in "Project view". 

2. In the "Libraries" tab, under "Global libraries", open the library "UPS1600 2.2 library TIA 
Portal V14 SP1". 
The procedure for opening the library is described in the Content of the library in STEP 7 
V14 (Page 47). 

3. Select "Master copies > UPS1600 TIA Library > UPS1600 Step7 > S7-1200/1500 > UDT 
> UDT_UPS1600". 

 
Figure 7-31   
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4. Drag-and-drop "UDT_UPS1600" into the "PLC data types" folder in the "Project tree". 

 
Figure 7-32   
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5. In the library, select "Master copies > UPS1600 TIA Library > UPS1600 Step7 > S7-
1200/1400 > Function Blocks > UPS1600_V2.1". 

 
Figure 7-33   
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6. Drag-and-drop "UPS1600_V2.1" into the "Program blocks" folder in the "Project tree". 

 
Figure 7-34   
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Calling the function block 
Follow the procedure to call the FB within an organization block (OB). In this description, 
FB162 is called within OB30. 

1. In the "Project tree", open the "Program blocks" in the controller. 

2. Create an OB with the name "Cyclic interrupt [OB30]" and open it. This displays an empty 
network. 

3. Drag-and-drop "UPS1600_V2.1 [FB162]" from the "Program blocks" folder to the empty 
network of OB30. The "Call options" dialog box opens. 

 
Figure 7-35   

4. Keep the default settings of the dialog box and click "OK". 

5. Double click on "Add new block" to add a new DB. The "Add new block" window opens. 
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6. In the "Add new block" window, 

– Select "Data block". 

– Enter a name as desired (UPS_Global). 

– In the "Type:" drop-down list, select "UDT_UPS1600_Data". 

– Click "OK". 

 
Figure 7-36   

7. Right click on the global DB created in step 5 (UPS_Global) and go to "Properties > 
General > Attributes". 
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8. Uncheck the attribute "Optimized block access" and click "OK". 

 
Figure 7-37   

9. In the network area of OB30 for FB162, 

– For the parameter HW_IO, enter the hardware ID of DC-UPS-20A_1~Head of the 
UPS1600 (273). 

– For the parameter Cyclic_IO_Address, enter the hardware ID of DC-UPS-20A_1~IO-
Data_Submodule of the UPS1600 (274). 

– Connect the parameter UPS_ready_for_reset with a tag of your project that you use to 
bring your plant into a condition in which it can be shut down. 

– Connect the parameter UPS_execute_reset with a tag of your project that you use to 
switch off the UPS when the plant is in a condition in which it can be shut down. 

– Connect the parameter Data with the global DB created in step 6, (UPS_Global). 
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Figure 7-38   

 

Further information about the block parameters, refer Interfaces of the function block 
FB162 (Page 31). 

 
 

 Note 
HW_IO and Cyclic_IO_Address parameters 

To know the HW_IO and Cyclic_IO_Address parameter values of your UPS1600 module, refer 
Interfaces of the function FB162. 
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 Application of the faceplates 8 
8.1 Application of the faceplates in WinCC flexible 2008 

8.1.1 Prerequisites 

Prerequisites 
The following requirements must be met to use the faceplates in WinCC flexible 2008 SP3: 

● The GSD file of the SITOP UPS1600 is installed in SIMATIC STEP 7 V5.5 and UPS is 
configured as PROFINET node in the HW configuration of the CPU. 

● S7 communication between SITOP UPS1600 and CPU is already configured. 

● All the program blocks from the library UPS1600 V2_2 STEP 7 V5_5 are integrated into 
the STEP 7 application program and executable. 

● The library 'UPS1600 V2_2 library WinCC Flexible 2008' for WinCC flexible 2008 SP3 is 
available on your computer. 

Supported control panels 
The faceplates are supported for the following control panels: 

● TP270 10" 

● OP270 10" 

● MP270 10" Touch 

● MP277 8" Touch/Key 

● MP277 10" Touch/Key 

● MP377 Touch/Key 

● WinCC flexible Runtime 2008 SP3 

Supported languages 
The faceplates support the following languages: 

● English (USA) 

● German (Germany) 

● Chinese (PR China) 
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8.1.2 Library for WinCC flexible 

Library for WinCC flexible 
The library 'UPS1600 V2_2 library WinCC flexible 2008' for WinCC flexible 2008 SP3 
comprises of the following objects: 

Table 8- 1   

Name Type Description 
UPS1600 V2_1 HMI Tag table Tag folder A tag folder with all the required tags 
Faceplate_UPS1600_V2_1 Faceplate Contains the faceplate 'Faceplate_ 

UPS1600_V2_1'. 
HMI Alarm views Message window Contains two message windows for  

displaying diagnostic messages of the 
UPS1600 

UPS1600_Data Structure Contains a group of structure elements 
required for UPS1600 faceplate 

8.1.3 Integrating the faceplates 

Overview 
The following sections describe all the steps required to integrate a faceplate into a WinCC 
flexible 2008 SP3 project. 

Hardware used: 

● MP277 8" Touch 

An overview of the supported HMI control panels is available in the Prerequisites (Page 71). 
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Opening the library 
The following procedure describes how to open the library in WinCC flexible 2008 SP3. 

1. Open the WinCC flexible project into which you want to insert the faceplate. 

2. In the "Tools" window, select the "Library" tab and click on the highlighted icon to open 
the library. The "Open global library" dialog box opens. 

 
Figure 8-1   
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3. Click the "Look in:" drop-down list and browse to the stored location of the library 
"UPS1600_V2_2_Library > UPS1600_lib_WinCC_flexible_2008" on your computer. 

 
Figure 8-2   

4. Select "UPS1600 V2_2 library WinCC flexible 2008.wlf" and click "Open". 

This imports the library into your project. 
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Inserting faceplates into a project 
The following procedure describes how to integrate the faceplate from the library into an 
existing WinCC flexible project. 

1. Open the required WinCC flexible project. 

2. In the "Project" window, open the screen into which you want to insert the faceplate 
(Screen_1). 

 
Figure 8-3   

3. In the "Tools" window, under the "Library" tab, select the faceplate element 
"Faceplate_UPS1600_V2_1". 

4. Drag-and-drop "Faceplate_UPS1600_V2_1" into the opened screen. 

 
Figure 8-4   
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5. In the "Project" window, select "Screens" and open "Template". 

 
Figure 8-5   

6. In the "Tools" window, select the "HMI Alarm views" element of the library. 

7. Drag-and-drop "HMI Alarm views" into the template. Two message windows are inserted. 

 
Figure 8-6   

8. Select "Alarmview_UPS_Pending" alarm window, right-click on the "Properties" and 
select "Properties > Display > Enable "ACK" button". Repeat the same procedure for 
enabling "ACK" button in "Alarmview_UPS_History" alarm window. 

9. In the "Project" window, select "Communication > Tags". 
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10.In the "Tools" window, select the "UPS1600 V2_1 HMI tag table" library element. 

 
Figure 8-7   

11.Drag-and-drop "UPS1600 V2_1 HMI tag table" into the "Tags" folder. 

 
Figure 8-8   
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12.Open the tag table "UPS1600 V2_1 HMI tag table", for the "UPS_Data" tag, 

– In the "Connection" column, select the required connection. (The connection name 
must be identical to the name of the connection created during configuring connection 
to the controller.) 

– Assign the global DB "UPS_Global" number to the tag (DB15). 

 
Figure 8-9   

13.In the tag table, select the tag "Faceplate_intern_alarmview_buffer". Check the properties 
of the tag where in the "ShowAlarmWindow" function is inserted and its variable "Object 
name" is assigned to the tag "Alarmview_UPS_History". 
If the "Properties" window does not open then right click on the tag and go to "Properties". 

 
Figure 8-10   

Similarly, check the properties of the tag "Faceplate_intern_alarmview_pending" where in 
the "ShowAlarmWindow" function is inserted and its variable "Object name" is assigned 
to the tag "Alarmview_UPS_Pending". 

If the "ShowAlarmWindow" function is not inserted for these two tags, refer the section 
Adding "ShowAlarmWindow" function to the tags described below. 
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14.Select the faceplate inserted in step 4 (Screen_1) and go to "Properties > Dynamic 
Interface". 

15.Under the "Data" section, for the "UPS_Data" property assign the "UPS_Data" tag created 
in step 11. 

 
Figure 8-11   

16.Under the "Visibility" section, for the "Faceplate_intern_alarmview_buffer" property insert 
the "Faceplate_intern_alarmview_buffer" tag from the "UPS1600 V2_1 HMI tag table" tag 
table. 

 
Figure 8-12   

Similarly, for the "Faceplate_intern_alarmview_pending" property insert the 
"Faceplate_intern_alarmview_pending" tag from the "UPS1600 V2_1 HMI tag table" tag 
table. 
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 Note 
Connection in the UPS1600 V2_1 HMI tag table 

A default connection is always created automatically when a project is created.  
Delete the default connection if you have created another connection for your project. 

 

Adding "ShowAlarmWindow" function to the tags 
The following procedure describes how to add the "ShowAlarmWindow" function to 
"Faceplate_intern_alarmview_buffer" and "Faceplate_intern_alarmview_pending" tags in the 
"UPS1600 V2_1 HMI tag table" tag table: 

1. Select the "Faceplate_intern_alarmview_buffer" tag. A new window opens. 

2. Go to "Events > Change value". 

3. Click on "<No function>". 

4. In the drop-down list select "System functions > Alarms > ShowAlarmWindow". 

 
Figure 8-13   

5. For the "Object name" variable click on "<No value>". 

6. In the drop-down list select "Alarmview_UPS_History". 

Follow the same procedure for the "Faceplate_intern_alarmview_pending" tag, add 
"ShowAlarmWindow" function and select "Alarmview_UPS_Pending" for the "Object name" 
variable. 
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Displaying the PROFINET diagnostic messages 
To display the PROFINET diagnostic messages of UPS1600 within the faceplate, the 
respective WinCC flexible project must already be configured. 

Information on the display and configuration of diagnostic messages in WinCC flexible is 
available in the entry ID: 22533916 
(https://support.industry.siemens.com/cs/ww/en/view/22319131). 

Further notes regarding the PROFINET diagnostic messages of the SITOP UPS1600 are 
available in the chapter 4 of the SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415). 

Connecting trends of the faceplates with data sources 
The following procedure describes how to create and connect trends to a faceplate. 

1. Open WinCC project and select "Communication > Tags > UPS1600 V2_1 HMI tag table" 
and open the tag table. 

 
Figure 8-14   

https://support.industry.siemens.com/cs/ww/en/view/22319131
https://support.industry.siemens.com/cs/ww/en/view/84977415


Application of the faceplates  
8.1 Application of the faceplates in WinCC flexible 2008 

 SITOP UPS1600 Firmware V2.2 : Faceplates and Communication Blocks V2.2 
82 Function Manual, 01.2018, A5E39439812-02-76 

2. In the tag table, create a new tag. 

In the "Symbol" column, click the drop down box, navigate to the global DB tag created in 
the project (UPS_Global) and select "Input_voltage" tag. (Here, select "Project > 
Project_UPS1600 > SIMATIC 300(1) > UPS 317-2 PN/DP > S7 Program(1) > DB > 
UPS_Global > UPS > UPS_DataM > Input_voltage".) 

 
Figure 8-15   

3. Repeat step 2 to create four more tags and assign the following symbols: 

– Output_voltage 

– Output_current 

– Battery_voltage 

– Measured_charged_current. 

 
Figure 8-16   

4. Select the faceplate in your screen and go to "Properties > General". 
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5. Under the "Trends" section, select the "Trends" variable to add trends to the faceplate. A 
new window appears. 

 
Figure 8-17   

6. In the window, add five trends. 

– In the "Samples" column, enter 600 points for the trend representation. 

– For "Trend type", select "Realtime Cyclic Triggered". 

– In the "Source settings" column, for each of the trends assign the data sources in the 
"Trend tag" variable: 
Trend 1: Input_voltage 

Trend 2: Output_voltage 

Trend 3: Output_current 

Trend 4: Battery_voltage 

Trend 5: Measured_charged_current 
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Figure 8-18   

Also, set the "Pulse" value to 0.5 s for each of the trends. 

 
Figure 8-19   

– In the "Foreground color" column, select the trend colors for the individual outputs 
according to the legend. 

 
Figure 8-20   
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– In the "Side" column, select the side as "Right" for voltage related tags (Volts scale) 
and "Left" for current related tags (Ampere scale). 

 
Figure 8-21   
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8.2 Application of screen windows in WinCC V7.3 

8.2.1 Prerequisites 

Prerequisites 
The following requirements must be met to use the screen windows in WinCC V7.3. 

● The GSD file of the SITOP UPS1600 is installed in SIMATIC STEP 7 V5.5 and the UPS is 
configured as PROFINET node in the HW configuration of the CPU. 

● S7 communication between the SITOP UPS1600 and CPU is already configured. 

● All program blocks from the library UPS1600 V2_2 STEP7 V5_5 are integrated into 
STEP 7 application program and executable. 

● The library UPS1600_lib_WinCC_V7_3 for WinCC V7.3 is available on your computer. 

● Existing WinCC OS (PC station) with already configured connection and active 
communication. 

PC Station 
The screen windows are supported for the following PC Station: 

● WinCC V7.3 Runtime 

Supported languages 
The screen windows support the following languages: 

● English (USA) 

● German (Germany) 

● Chinese (PR China) 
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8.2.2 Library for WinCC V7.3 

Library for WinCC V7.3 
The library UPS1600_lib_WinCC_V7_3 for WinCC V7.3 comprises the following file folders: 

Table 8- 2   

Name Type Description 
HMI Tag table (WinCC V7.3) Tags File for tag import 
HMI Screens (WinCC V7.3) Screens Comprises screen 'UPS1600_V2_1.pdl' 

HMI Tag table (WinCC V7.3) 
This folder contains the file UPS1600_HMIUDT.txt. This text file comprises all the tags and 
structure required for the functioning of UPS1600 screens. 

HMI Screens (WinCC V7.3) 
This folder contains the screen UPS1600_V2_1.pdl. 

8.2.3 Integrating the screen windows 

Overview 
Target system used: 

● WinCC V7.3 Runtime 

Inserting the project screens 
The following procedure describes how to insert the HMI screen from the library into the 
project directory of your WinCC project. 

1. Open "Windows Explorer" in your computer machine and navigate to the "GraCS" folder 
in your project directory. Here, path to the folder is:  "C:\Program 
Files(x86)\SIEMENS\STEP7\S7Proj\Ups1600\wincproj\OS(6)\GraCS". 

2. Open another instance of "Windows Explorer" in your computer machine and navigate to 
the stored location of the "UPS1600_V2_2_Library" library folder. 
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3. In the library folder, open "UPS1600_lib_WinCC_V7_3 > HMI Screens (WinCC V7.3)". 

4. Copy the "UPS1600_V2_1.pdl" screen element from the library and paste it into the 
"GraCS" folder. 

 
Figure 8-22   
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Importing tags 
The following procedure describes how to import the HMI tag table file from the library folder 
into your WinCC project. 

1. Open your WinCC project in WinCC Eplorer. 

2. Open the "Tag Management" element. The "Tag Management – WinCC Configuration 
Studio" window opens. 

 
Figure 8-23   
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3. In the "Tag Management" window, select "Structure tags". 

 
Figure 8-24   

4. In the menu bar, select "Edit > Import". The "Import" window opens. 

5. Browse to the stored location of "UPS1600_V2_2_Library" library folder in your machine 
and open "UPS1600_lib_WinCC_V7_3 > HMI Tag table (WinCC V7.3)". 
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6. Select "UPS1600_HMIUDT". 

 
Figure 8-25   

7. Click "Import". "UPS1600_Data" structure tag element appears under "Structure tags" in 
"Tag Management" window. 

 
Figure 8-26   

8. Close the window. 
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Configuring screen windows 
The following procedure describes how to configure a screen window: 

1. In the WinCC project, select "Graphics Designer". 

2. On its right window pane, right click on the empty space and select "New picture" option 
to add a new pdl file. 

 
Figure 8-27   

3. Rename the pdl created in step 2 as required (UPS_ScreenWindow) and open it. The 
"Graphics Designer" window opens. 

4. In the "Standard" window of the Graphics Designer go to "Smart Objects" folder and 
select "Picture Window". 
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5. Click on the "UPS_ScreenWindow.pdl" screen area to insert the "Picture Window". 

 
Figure 8-28   

6. Select the added screen window and go to "Properties > Miscellaneous". 

7. For the "Picture Name" attribute assign "UPS1600_V2_1.pdl" and for the "Tag Prefix" 
attribute assign the tag "UPS_Global" created during importing the HMI tag table  
(refer STEP 7 in Configuring Screen windows procedure). If your structure tag name is 
'StructureTag' then add a '.' at the end of your tag name, that is 'StructureTag.' 
(<Structure tag name>.). Here, "UPS_Global.". 

 
Figure 8-29   
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Displaying the PROFINET diagnostic messages 
In order to display the PROFINET diagnostic messages of the SITOP UPS1600 within the 
screen windows, the respective WinCC project must already be configured for the display of 
PROFINET diagnostic messages. 

Information on the display and configuration of diagnostic messages in WinCC is available 
under the entry ID: 245799373 
(https://support.industry.siemens.com/cs/ww/en/view/23730649). 

Further notes regarding the PROFINET diagnostic messages of the SITOP UPS1600 are 
available in the chapter 4 of the SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415). 

8.2.4 Application of screen windows in WinCC V7.4 

8.2.4.1 Overview 
To work with the library in WinCC V7.4 follow the similar process as mentioned in Application 
of screen windows in WinCC V7.3 (Page 86), except opening the library 
UPS1600_lib_WinCC_V7_4 in place of UPS1600_lib_WinCC_V7_3. 

https://support.industry.siemens.com/cs/ww/en/view/23730649
https://support.industry.siemens.com/cs/ww/en/view/84977415
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8.3 Application of faceplates in WinCC Comfort/Advanced V14 SP1 

8.3.1 Prerequisites 

Prerequisites 
The following requirements must be met to use the faceplates in WinCC Comfort/Advanced 
V14 SP1. 

● The HSP for the SITOP UPS1600 is installed in STEP 7 V14 SP1. 

● S7 communication between SITOP UPS1600 and SIMATIC S7 controller is already 
configured. 

● Program blocks for STEP 7 V14 SP1 from UPS1600 V2.2 library TIA Portal V14 SP1 are 
integrated into the application program and executable. 

● UPS1600 V2.2 library TIA Portal V14 SP1 is available on your computer. 

Supported control panels 
The faceplates are supported for the following control panels: 

● TP700 Comfort/KP700 Comfort 

● TP900 Comfort/KP900 Comfort 

● TP1200 Comfort/KP1200 Comfort 

● TP1500 Comfort/KP1500 Comfort 

● TP1900 Comfort 

● TP2200 Comfort 

● MP277 8" Touch/MP277 8" Key 

● MP277 10" Touch/MP277 10" Key 

● MP377 Touch/Key 

● WinCC RT Advanced V14 SP1 

Supported languages 
The faceplates support the following languages: 

● English (USA) 

● German (Germany) 

● Chinese (PR China) 
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8.3.2 Library for WinCC Comfort/Advanced 

Library for WinCC Comfort/Advanced 
The following objects are part of UPS1600 V2.2 library TIA Portal V14 SP1 for WinCC 
Comfort/Advanced. 

Table 8- 3   

Name Type Description 
Faceplate_Comfort/Advanced Faceplates Comprises three faceplates 

• Faceplate_SITOP_V2_1_300/400 
• Faceplate_SITOP_V2_1_1200 
• Faceplate_SITOP_V2_1_1500 
Selection of faceplate depends on the 
PLC that is used. 

Tag Table Comfort Panels/Advanced Tag folder Contains the tag table 'TagTable_ 
1200_UPS1600_Comfort'. 

Comfort panels/Advanced Alarm views Comprises 'Alarm windows' screen 
that has two message windows to 
display the PROFINET diagnostic 
messages of the UPS1600. 

8.3.3 Integrating the faceplates 

Overview 
Hardware used: 

● TP1200 Comfort 

An overview of the supported HMI control panels is available in the Precondition (Page 95). 

Opening the library in WinCC V14 SP1 
The procedure for opening the library in WinCC Professional V14 SP1 is explained in the 
Content of the library for STEP 7 V14 (Page 47). 

Inserting faceplates into a project 
The following procedure describes how to integrate the faceplates from UPS1600 V2.2 
library TIA Portal V14 SP1 into an existing WinCC project. 

1. Open the required project in "Project view". 

2. In the "Project tree", open the "Screens" folder. 
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3. Double click on "Add new screen" to add a new screen into your project. 

 
Figure 8-30   

Open the new screen (Screen_1). 

 
Figure 8-31   
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4. In the "Libraries" window, select "Global libraries > UPS1600 V2.2 library TIA Portal V14 
SP1 > Types > UPS1600 Wincc > Screens > Faceplate_Comfort/Advanced > 
Faceplate_SITOP_V2_1_1200". 

 
Figure 8-32   

5. Drag-and-drop "Faceplate_SITOP_V2_1_1200" into the opened screen in step 3. 
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Creating a connection to the data block for global data exchange 
The following procedure describes how to create a connection to the data block for global 
data exchange. 

1. In the "Libraries" window, select "Global libraries > UPS1600 V2.2 library TIA Portal V14 
SP1 > Master copies > UPS1600 TIA Library > UPS1600 Wincc > S7-1200 > Tag Table 
Comfort Panels/Advanced > TagTable_1200_UPS1600_Comfort". 

 
Figure 8-33   

 
  Note 

S7-300/400 PLC 

For S7-300/400 PLCs, go to the folder "S7-300/400" instead of "S7-1200". Similarly for 
S7-1500 PLCs go to the folder "S7-1500". 
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2. Drag-and-drop "TagTable_1200_UPS1600_Comfort" into the "HMI tags" folder in the 
"Project tree". 

 
Figure 8-34   

3. Open "TagTable_1200_UPS1600_Comfort" in the "HMI tags" folder. 

4. For the "UPS_Data" tag, 

– Select the "Connection" as required ("HMI_Connection_1"). 

– Assign the global DB number in the "Address" column (2). 

 
Figure 8-35   
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5. Select the "UPS_Data" tag and go to "Properties > Properties > Settings". 

– Change the "Acquisition mode" to "Cyclic continuous". 

– Set the "Acquisition cycle" value to "500 ms". 

 
Figure 8-36   

6. In the "Project tree", open the screen with the inserted faceplate (Screen_1). 
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7. Select the faceplate on the screen in the display area and go to "Properties > Interface > 
Data". 

8. Select the "UPS1600_Data" property and connect the "UPS_Data" tag in 
"TagTable_1200_UPS1600_Comfort" under the "Dynamization" column. 

 
Figure 8-37   
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Connecting trends of the faceplate with data sources 
The following procedure describes how to connect the trends of the faceplate with data 
sources. 

1. In the "Project tree", open the screen with the inserted faceplate (Screen_1) 

2. Select the faceplate and go to "Properties > Interface > Trends". 

3. Select "Trends" and click on the marked area in the "Static value" column to open the 
settings for the trends of the UPS1600 module. 

 
Figure 8-38   

The "Trend" window opens. 

4. In the "Trend" window, add five trends in the "Name" column. 

5. Set the "Trend value" to 600 to all the five trends. 

6. In the "Source settings" column, click the drop-down. "Data source" dialog box opens. 
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7. For the "Process values" click on the highlighted area to navigate to the HMI tags and 
assign the following tags to each of the trends 

– Input_Voltage 

– Output_Voltage 

– Output_Current 

– Battery_voltage 

– Measured_charge_current 

 
Figure 8-39   

8. Set the "Cyclic" value to 0.5. 

 
Figure 8-40   
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9. In the "Style" column, select the trend color for the individual trends according to the 
legend given below. 

 
Figure 8-41   

10.In the "Side" column, select the value as "Right" to voltage tags and select the value as 
"Left" to current tags assigned for the trends in step 6. 

 
Figure 8-42   
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Activating the alarms display 
1. In the "Project tree", double click on "Runtime settings" and select "Alarms". 

 
Figure 8-43   

2. Check the options "S7 diagnostic alarms" and "With event text". 

 
Figure 8-44   

 

 Note 

When configuring an S7-300/400 controller in TIA Portal, you also need to activate the S7 
diagnostic alarm on the controller side. 

The following entry describes how to proceed: 62121503 
(https://support.industry.siemens.com/cs/ww/en/view/62121503), see Chapter 3.2.2 
'Configuring CPU system diagnostic alarms', description 'Settings in STEP 7 Professional'. 

 

https://support.industry.siemens.com/cs/ww/en/view/62121503


 Application of the faceplates 
 8.3 Application of faceplates in WinCC Comfort/Advanced V14 SP1 

SITOP UPS1600 Firmware V2.2 : Faceplates and Communication Blocks V2.2 
Function Manual, 01.2018, A5E39439812-02-76 107 

Configuring the alarms display 
1. In the "Libraries" window, select "Global libraries > UPS1600 V2.2 library TIA Portal V14 

SP1 > Master copies > UPS1600 TIA Library > UPS1600 Wincc > Screens > Comfort 
Panels/Advanced > Alarm windows". 

 
Figure 8-45   
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2. In the "Project tree", select "Screen management" and open "Global screen". 

 
Figure 8-46   



 Application of the faceplates 
 8.3 Application of faceplates in WinCC Comfort/Advanced V14 SP1 

SITOP UPS1600 Firmware V2.2 : Faceplates and Communication Blocks V2.2 
Function Manual, 01.2018, A5E39439812-02-76 109 

3. Drag-and-drop "Alarm windows" into the global screen. 

 
Figure 8-47   
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Configuring the alarms display call 
1. In the "Project tree", under the "HMI tags" folder open 

"TagTable_1200_UPS1600_Comfort". 

 
Figure 8-48   

2. For the tags "alarmhistory" and "alarmpending", check if the assigned "Data type" is "Int" 
and the "Connection" is "Internal tag". 

 
Figure 8-49   



 Application of the faceplates 
 8.3 Application of faceplates in WinCC Comfort/Advanced V14 SP1 

SITOP UPS1600 Firmware V2.2 : Faceplates and Communication Blocks V2.2 
Function Manual, 01.2018, A5E39439812-02-76 111 

3. Select the "alarmpending" tag and go to "Properties > Events > Value change".  
Check the properties of the tag where in the "ShowAlarmWindow" function is inserted and 
its variable "Object name" is assigned to the tag "Alarmview_UPS_Pending". 

 
Figure 8-50   

Similarly, check the properties of the tag "alarmhistory" where in the "ShowAlarmWindow" 
function is inserted and its variable "Object name" is assigned to the tag 
"Alarmview_UPS_History". 

4. Open the screen (Screen_1) and select the faceplate. Go to "Properties > Interface > 
Data". 

5. Assign the "alarmhistory" tag to "Faceplate_intern_alarmview_buffer" element. 

 
Figure 8-51   

6. Assign the "alarmpending" tag to "Faceplate_intern_alarmview_pending" element. 



Application of the faceplates  
8.3 Application of faceplates in WinCC Comfort/Advanced V14 SP1 

 SITOP UPS1600 Firmware V2.2 : Faceplates and Communication Blocks V2.2 
112 Function Manual, 01.2018, A5E39439812-02-76 

Displaying the PROFINET diagnostic messages 
To display the PROFINET diagnostic messages of the SITOP UPS1600 within the faceplate, 
the respective WinCC TIA Portal project must already be configured. 

Information on the display and configuration of diagnostic messages in WinCC TIA Portal is 
available under the entry ID: 62121503 
(https://support.industry.siemens.com/cs/ww/en/view/62121503). 

Activation of the PROFINET diagnostic messages of the UPS1600 is found in the "Device 
view" of the UPS1600. 

 
Figure 8-52   

Further notes regarding the PROFINET diagnostic messages of the SITOP UPS1600 is 
available in the chapter 4 of the SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415). 

https://support.industry.siemens.com/cs/ww/en/view/62121503
https://support.industry.siemens.com/cs/ww/en/view/84977415
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8.4 Application of screen windows in WinCC Professional V14 SP1 

8.4.1 Prerequisites 

Prerequisites 
The following requirements must be met to use the screen windows in WinCC Professional 
V13 SP1. 

● The HSP for the SITOP UPS1600 is installed in STEP 7 V14 SP1. 

● S7 communication between the SITOP UPS1600 and SIMATIC S7 controller is already 
configured. 

● All program blocks for STEP 7 V14 SP1 from UPS1600 V2.2 library TIA Portal V14 SP1 
are integrated into the application program and executable. 

● UPS1600 V2.2 library TIA Portal V14 SP1 is available on your computer. 

Supported control panels 
The screen windows are supported for the following control panels: 

● WinCC RT Professional V14 SP1 

Supported languages 
The screen windows support the following languages: 

● English (USA) 

● German (Germany) 

● Chinese (PR China) 

8.4.2 Library for WinCC Professional 

Library for WinCC Professional 
The following objects are part of the master copy "UPS1600 TIA Library > UPS1600 Wincc > 
Screens > Professional" in UPS1600 V2.2 library TIA Portal V14 SP1. 

Table 8- 4   

Name Type Description 
Screen Windows Screen window Comprises the screen window 
UPS1600 Screen Comprises the screen 'UPS1600' 
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8.4.3 Integrating the screen windows 

Overview 
The following sections describe all the steps required to integrate the screen windows into a 
WinCC Professional V14 SP1 project. 

Target system used: 

● WinCC RT Professional V14 SP1 

Opening the library in WinCC V14 SP1 
The procedure for opening the library in WinCC Professional V14 SP1 is explained in the 
Content of the library for STEP 7 V14 (Page 47). 
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Inserting HMI tag table in WinCC 
The following procedure describes how to insert HMI tag table into the WinCC project. 

1. In the "Libraries" window, select "Global libraries > UPS1600 V2.2 library TIA Portal V14 
SP1 > Master copies > UPS1600 TIA Library > UPS1600 Wincc > S7-1200 > Tag Table 
Professional > TagTable_1200_UPS1600". 

 
Figure 8-53   

 
  Note 

S7-300/400 PLCs 

For S7-300/400 PLCs, go to the folder "S7-300/400" and for S7-1500 PLCs go to the 
folder "S7-1500". 

 

 



Application of the faceplates  
8.4 Application of screen windows in WinCC Professional V14 SP1 

 SITOP UPS1600 Firmware V2.2 : Faceplates and Communication Blocks V2.2 
116 Function Manual, 01.2018, A5E39439812-02-76 

2. Drag-and-drop "TagTable_1200_UPS1600" into the "HMI tags" folder in the "Project tree". 

 
Figure 8-54   



 Application of the faceplates 
 8.4 Application of screen windows in WinCC Professional V14 SP1 

SITOP UPS1600 Firmware V2.2 : Faceplates and Communication Blocks V2.2 
Function Manual, 01.2018, A5E39439812-02-76 117 

Configuring connections of HMI tag table 
The following procedure describes how to configure connections of HMI tag table. 

1. In the "Project tree", select "HMI tags > TagTable_1200_UPS1600" and open the tag 
table. 

 
Figure 8-55   
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2. Adjust the connections of the tag. 

– In the "Connection" column, select your HMI connection of the controller and Runtime 
Professional. 

– In the "Address" column define the address of the global DB number created in the 
PLC (DB2). 

 
Figure 8-56   
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Inserting screen windows into a project 
The following procedure describes how to integrate a screen from the library into an existing 
WinCC project. 

1. Open the project in "Project view". 

2. In the "Libraries" window, select "Global libraries > UPS1600 V2.2 library TIA Portal V14 
SP1 > Master copies > UPS1600 TIA Library > UPS1600 Wincc > Screens > 
Professional > UPS1600". 

 
Figure 8-57   
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3. In the "Project tree", open the "Screens" folder of the HMI used in the project. 

4. Drag-and-drop "UPS1600" into the "Screens" folder. 

 
Figure 8-58   
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Integrating screen windows into a project 
The following procedure describes how to integrate the screen window from the library into 
an existing WinCC project. 

1. In the "Project tree", open the screen into which you want to insert the screen windows 
(Screen_1). 

 
Figure 8-59   

2. In the "Libraries" window, select "Global libraries > UPS1600 V2.2 library TIA Portal V14 
SP1 > Master copies > UPS1600 TIA Library > UPS1600 Wincc > Screens > 
Professional > Screen Windows". 
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3. Drag-and-drop "Screen Windows" to the screen. 

 
Figure 8-60   

4. Select the screen window and go to "Properties > Properties > General". 

Assign "Tag prefix" variable with the "UPS_Data" tag present in "TagTable_1200_ 
UPS1600" folder. 

 
Figure 8-61   
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Displaying the PROFINET diagnostic messages 
To display the PROFINET diagnostic messages of the UPS1600 within the screen windows, 
the respective WinCC TIA Portal project must already be configured. 

Information on the display and configuration of diagnostic messages in WinCC TIA Portal is 
available under the entry ID: 62121503 
(https://support.industry.siemens.com/cs/ww/en/view/62121503). 

The activation of the PROFINET diagnostic messages of the UPS1600 is found in the 
"Device view" of the UPS1600. 

 
Figure 8-62   

https://support.industry.siemens.com/cs/ww/en/view/62121503
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 Note 
• When configuring an S7-300/400 controller in TIA Portal, you also need to activate the S7 

diagnostic alarm on the controller side. 
• The following entry describes how to proceed: 62121503, see Chapter 3.2.2 'Configuring 

CPU system diagnostic alarms', description 'Settings in STEP 7 Professional'. 
• There can be differences regarding the S7-1200 diagnosis with respect to the S7-1500 

 

Further notes regarding the PROFINET diagnostic messages of the SITOP UPS1600 are 
available in the chapter 4 of the SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415).  

 

https://support.industry.siemens.com/cs/ww/en/view/84977415
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