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Legal information 
Warning notice system 

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger. 

 DANGER 
indicates that death or severe personal injury will result if proper precautions are not taken. 

 
 WARNING 

indicates that death or severe personal injury may result if proper precautions are not taken. 
 

 CAUTION 
indicates that minor personal injury can result if proper precautions are not taken. 

 
 NOTICE 

indicates that property damage can result if proper precautions are not taken. 
If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
property damage. 

Qualified Personnel 
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. 
Qualified personnel are those who, based on their training and experience, are capable of identifying risks and 
avoiding potential hazards when working with these products/systems. 

Proper use of Siemens products 
Note the following: 

 WARNING 
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended 
or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be complied with. The information in the relevant documentation must be observed. 

Trademarks 
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication 
may be trademarks whose use by third parties for their own purposes could violate the rights of the owner. 

Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and software 
described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the 
information in this publication is reviewed regularly and any necessary corrections are included in subsequent 
editions. 
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Warranty and liability 1 
 
 

 Note 

The application examples are not binding and do not claim to be complete with regard to 
configuration, equipment or any contingencies. The application examples do not represent 
customer-specific solutions. They are only intended to provide support for typical 
applications, you are responsible for the correct operation of the described products. These 
application examples do not relieve you from responsibilities of using, installing, operating 
and servicing the equipment safely and professionally. When using these application 
examples, you recognize that we are not liable for any damage/claims beyond the liability 
clauses described. 

We reserve the right to make changes to these application examples at any time and without 
prior notice. If there are any deviations in the recommendations provided in this application 
example and other Siemens publications, for example catalogs, the contents of the other 
documents shall have priority. 

 

We do not accept any liability for the information contained in this document. Any claims 
against us – based on whatever legal reason – resulting from the use of the examples, 
information, programs, engineering and performance data etc., described in this application 
example shall be excluded. Such an exclusion shall not apply in the case of mandatory 
liability, for example under the German Product Liability Act ("Produkthaftungsgesetz"), in 
case of intent, gross negligence, or injury of life, body or health, guarantee for the quality of 
a product, fraudulent concealment of a deficiency or breach of fundamental contractual 
obligations ("wesentliche Vertragspflichten"). 

The compensation for damages due to a breach of a fundamental contractual obligation is, 
however, limited to the foreseeable damage, typical for the type of contract, except in the 
event of intent or gross negligence or injury to life, body or health. The above provisions do 
not imply a change of the burden of proof to your detriment. Any form of duplication or 
distribution of these application examples or excerpts hereof is prohibited without the 
expressed consent of Siemens AG. 
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1.1 Security information 
Siemens provides products and solutions with industrial security functions that support the 
secure operation of plants, systems, machines and networks. 

In order to protect plants, systems, machines and networks against cyber threats, it is 
necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial 
security concept. Siemens’ products and solutions constitute one element of such a concept. 

Customers are responsible for preventing unauthorized access to their plants, systems, 
machines and networks. Such systems, machines and components should only be connected 
to an enterprise network or the internet if and to the extent such a connection is necessary 
and only when appropriate security measures (e.g. firewalls and/or network segmentation) 
are in place. 

For additional information on industrial security measures that may be implemented, please 
visit  
https://www.siemens.com/industrialsecurity.  

Siemens’ products and solutions undergo continuous development to make them more 
secure. Siemens strongly recommends that product updates are applied as soon as they are 
available and that the latest product versions are used. Use of product versions that are no 
longer supported, and failure to apply the latest updates may increase customer’s exposure to 
cyber threats. 

To stay informed about product updates, subscribe to the Siemens Industrial Security RSS 
Feed under  
https://www.siemens.com/industrialsecurity.  
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Preface 2 
 

Purpose of this document 
This document describes LUPS1600 Block Library for SIMATIC STEP 7 V5.6, STEP 7 
Professional V18, WinCC Flexible, WinCC V7.4, WinCC V7.5, WinCC Comfort/Advanced V18, 
WinCC Professional V18, and WinCC Unified Comfort V18. The block library provides tested 
code with clearly defined interfaces. You can use it as the basis for the task you wish to 
realize. 

The main focus of this document is to describe: 

• All Function Blocks (FB) pertaining to the block library. 

• The functionality implemented through these blocks. 

The documentation furthermore illustrates the possible operating conditions and applications 
of the block library for SIMATIC STEP 7 V5.6, STEP 7 Professional V18, WinCC Flexible, WinCC 
V7.4, WinCC V7.5, WinCC Comfort/Advanced V18, WinCC Professional V18, and WinCC 
Unified Comfort V18. 



Preface  
 

 SITOP UPS1600 Firmware V2.5: Faceplates and Communication Blocks V3.3 for SIMATIC STEP7 

8 Function Manual, 04.2023, A5E39439812-07-76 

References 
For more information on SITOP UPS1600 manuals and related documentation, refer the 
following links: 

• Siemens Industry Online Support (https://support.industry.siemens.com) 

• SITOP UPS1600 Manual (https://support.industry.siemens.com/cs/ww/en/view/84977415) 

• SIMATIC STEP 7 Basic/Professional V17 and SIMATIC WinCC V17 System Manual 
(https://support.industry.siemens.com/cs/ww/en/view/109773506) 

• SIMATIC Programming with SIMATIC STEP 7 V5.5 
(https://support.industry.siemens.com/cs/ww/en/view/45531107) 

• WinCC flexible 2008 System Manual 
(https://support.industry.siemens.com/cs/ww/en/view/18796010) 

• WinCC 7.4 System Manual 
(https://support.industry.siemens.com/cs/ww/en/view/109736220) 

• WinCC 7.5 System Manual 
(https://support.industry.siemens.com/cs/ww/en/view/109760739) 

• GSD for SITOP UPS1600 for integration into SIMATIC STEP 7 V5.6 
(https://support.industry.siemens.com/cs/ww/en/view/75854605) 

• Support Packages for the hardware catalog in the TIA Portal (HSP) 
(https://support.industry.siemens.com/cs/ww/en/view/72341852) 

https://support.industry.siemens.com/
https://support.industry.siemens.com/cs/ww/en/view/84977415
https://support.industry.siemens.com/cs/ww/en/view/109773506
https://support.industry.siemens.com/cs/ww/en/view/45531107
https://support.industry.siemens.com/cs/ww/en/view/18796010
https://support.industry.siemens.com/cs/ww/en/view/109736220
https://support.industry.siemens.com/cs/ww/en/view/109760739
https://support.industry.siemens.com/cs/ww/en/view/75854605
https://support.industry.siemens.com/cs/ww/en/view/72341852
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Task 3 
 

Overview of the automation task 
The figure below provides an overview of the automation task: 
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Task Description 
Your task is to equip the automation plant with Uninterruptible Power Supply (UPS). In the 
event of a power failure, critical process participants are to be protected. 

In the event of a power failure of the automation plant, process values are to be maintained 
and plant components be safeguarded against mechanical damage by means of a defined 
stopping process. 

UPS is integrated into the automation network via PROFINET. 

The status and diagnostic information of the UPS is displayed in the individual Human 
Machine Interfaces (HMI) stations. 
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Structure 4 
4.1 Solution overview 

Structure 
The figure shows the schematic overview of the hardware components used in the solution. 

 

Scope of this application example 
This application example provides FB UPS1600 function block for communication between 
the controller and SITOP UPS1600. 
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It also provides faceplates and screen windows for monitoring and operation. 
 

 Note 

SITOP UPS1600 is termed as UPS1600 throughout this document. 
 

Function of the hardware components 
The table describes the function of the Hardware (HW) components used in the solution: 
 
Name Function 
SITOP Power Supply Central 24 V power supply for all process devices. 
Non-critical process devices Symbol for other non-critical process devices. (Devices that can 

be switched off when there is sufficient pressure, for example: 
compressors.) 

SITOP UPS1600 and SITOP UPS1100 UPS with buffer (example, battery module). 
S7-1214 Automation controller 
Comfort Panel TP1200 Control panel for process visualization. 
Other critical process devices Symbol for other critical process devices. 
PROFINET Central process bus of all automation devices. 

Advantages 
This application offers the following advantages: 

• Time and cost saving by means of FB UPS1600, HMI faceplates and screen windows. 

• Easy and comprehensive introduction to integrating UPS1600 within a PROFINET network. 

Scope 
This application does not include description of: 

• Creating program blocks in SIMATIC STEP 7 V5.6/STEP 7 Professional V18. 

• Creating screens and objects in WinCC flexible/WinCC TIA Portal/WinCC. 

• Configuring communication between the described terminal devices. 

• Handling all the described SIMATIC terminal devices. 
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Assumed knowledge 
The user is assumed to have knowledge on the mentioned points: 

• Using SIMATIC STEP 7 V5.6, STEP 7 Professional V18, WinCC flexible, WinCC V7.4, WinCC 
V7.5, WinCC Flexible 2008 SP5, WinCC Comfort/Advanced V18, WinCC Professional V18, 
WinCC Unified Comfort V18 and WinCC TIA Portal. 

• Operating, handling, and configuring SIMATIC S7 controllers (S7-300/400 and 
S7-1200/1500). 

• Operating, handling, and configuring HMI control panels (Multi Panels, Comfort Panels) 
and Runtime systems (WinCC flexible Runtime, WinCC Runtime Advanced, WinCC 
Runtime, WinCC Runtime Professional). 

• Handling and operating SITOP UPS1600. 
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4.2 Description of the core functionality 

Sequence of the core functionality 
Communication between UPS1600 and controller runs via PROFINET. The UPS1600 is 
connected to the controller as PROFINET IO node. Thus, the entire UPS1600 information 
(voltage, power, possible buffer time, battery state) is available in the controller. 

In this application example, two scenarios are realized. 

• The Programmable Logic Controller (PLC) via the supplied program block FB UPS1600 
recognizes power failure. The information is made permanently available in the control 
program which can be then evaluated. This allows your process to respond and switch off 
your process devices in a defined manner. 

• The Programmable Logic Controller (PLC) via the supplied program block FB UPS16Msg 
recognizes diagnostic interrupts and generates alarm messages to WinCC. 

• With the provided faceplates and screen windows, relevant information and important 
parameters are displayed on the HMI control panel. 

 

 Note 

FB UPS16Msg is applicable only to SIMATIC STEP7 V5.6. 
 

Overview and description of the user interface 
The application example provides the following views in the faceplate: 

• UPS state 

• General Device information 

• Output Data 

• Voltage and power trend curves 

• Currently pending alarms/alarm history 
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4.3 Hardware and software components used 

Hardware components 
 
Component No. Article number Note 
SITOP UPS1600 20 A 
 

1 6EP4136-3AB00-2AY0 Alternatively, 
SITOP UPS1600 10 A  
6EP4134-3AB00-2AY0 or  
SITOP UPS1600 40 A  
6EP4137-3AB00-2AY0 is 
used. 

MP277 8" Touch 1 6AV6643-0CB01-1AX5 Refer to Requirements 
(Page 95). 

Comfort Panel TP900 1 6AV2124-0JC01-0AX0 Refer to Requirements 
(Page 115). 

CPU 1214C DC/DC/RLY PN/DP 1 6ES7214-1HG40-0XB0 Or other 
S7-1200/1500 CPU 

CPU 315-2 PN/DP 1 6ES7315-2EH14-0AB0 Or other S7-300 CPU 
SITOP UPS1100 3.2 Ah (Battery 
module) 

1 6EP4133-0GB00-0AY0  

 

 

 Note 

The UPS1600 is upgraded with Firmware (FW) version 2.5 or higher. 
 

Standard software components 
 
Component No. Article number Note 
WinCC Flexible 2008 SP5 Advanced 1 6AV6613-0AA51-3CA5 Alternatively, WinCC 

flexible 2008 SP5 
Standard 

WinCC Advanced V18 1 6AV2102-4AA03-0AE5 Alternatively, WinCC 
Comfort V18 

STEP 7 Professional V5.6 1 6ES7810-4CC10-0YA5 - 
STEP 7 Professional V18 1 6ES7822-1AA03-2YA6 - 
WinCC Professional V18 1 6AV2103-0DA03-0AA5 - 
WinCC V7.4  1 6AV6381-2BD07-3AH0 - 
WinCC Comfort V18 (for 
configuring Comfort Panels) 

1 6AV2124-0JC01-0AAX0 - 

WinCC Unified (for configuring 
WinCC Unified Comfort Panels) 

1 6AV2 128-3GB06-0AXx - 
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Library contents 
The following table contains the library contents that are used in this example: 
 
Component Note 
LUPS1600  This folder contains the library for TIA Portal V18 and 

master copies for STEP 7 V18 and WinCC V18. 
SITOP-UPS1600_Library_STEP7-V5_V3-1.7z This folder contains the following subfolders: 

• UPS1600 V3-0 STEP7 V5.6 
• UPS1600 V3-0 library WinCC flexible 2008 
• UPS1600 V3-0 library WinCC V7.4 
• UPS1600 V3-0 library WinCC V7.5 

UPS1600 V3-1 STEP7 V5.6 This folder contains the library of the function blocks (FB) 
for SIMATIC STEP 7 V5.6. 

UPS1600 V3-1 library WinCC flexible 2008 This folder contains the library of the faceplates for 
WinCC flexible 2008 SP5. 

UPS1600 V3-1 library WinCC V7.4 This folder contains the library of the screen windows for 
WinCC V7.4. 

UPS1600 V3-1 library WinCC V7.5 Tins folder contains the library of the screen windows for 
WinCC V7.5. 
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Function blocks 5 
5.1 Function and task of the function blocks 

Overview 
This chapter describes the application and requirements of FB UPS1600 and FB UPS16Msg 
and its integration into a SIMATIC STEP 7 project. 

Task description and application 
• In the event of a plant power failure, it is essential to safeguard certain machine 

components against damage and to back-up process relevant data in order to prevent 
data loss. The application of FB UPS1600 provides the option to bring your plant into a 
safe state and switch it off in a program-controlled manner while UPS1600 buffers the 
voltage. 

• The Programmable Logic Controller (PLC) via the supplied program block FB UPS16Msg 
recognizes diagnostic interrupts and generates alarm messages to WinCC. 
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FB1 Function description 
The FB UPS1600 cyclically monitors the operating mode of the UPS1600. When UPS1600 is in 
buffer mode, a 10 s timer within the FB starts. This timer prevents the plant from being 
brought into a safe state in the event of just a short voltage dip/drop. If the UPS is still in 
buffer mode after expiry of the timer, the parameter UPSReadyForReset is set from FALSE 
to TRUE. Further, this parameter is also used to bring the plant components into a safe state 
(maintenance mode). When the plant is brought into a safe state, the parameter 
UPSExecuteReset is set from FALSE to TRUE. The FB UPS1600 then sends a command to 
the UPS1600, which then switches off autonomously. The following flow diagram displays 
the program sequence of the FB UPS1600. 
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Notes regarding the FB UPS1600 
• If the UPS1600 returns to the normal mode when the timer is running, the parameter 

UPSReadyForReset is not set. 

The timer is then reset. 

• When the UPS1600 returns to the normal mode from buffer mode, the parameter 
UPSReadyForReset is set to FALSE after wait time for stable input voltage is reached. 

• After the parameter UPSExecuteReset is set, the further program sequence is executed 
until UPS1600 is switched off via the FB UPS1600. 

• The buffer time of UPS1600 must be set such that there is sufficient time to bring the 
plant into a safe state and switch off the UPS via the FB UPS1600. 

Notes regarding the FB UPS16Msg 
• In Report system error system diagnostics blocks, alarm messages will not include 

extended error information. So in order to show detailed message of interrupt, FB 
UPS16Msg is developed. If we use this block, no need to generate system diagnostic 
blocks using RSE (Report system error). 
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5.2 Operating conditions 

Configuration 
• FB UPS1600 and FB UPS16Msg are approved for SIMATIC STEP 7 V5.6 and application of a 

CPU 300/400 

• LUPS1600_UPS1600 is approved for STEP 7 V18/STEP 7 Professional V18 and application 
of a CPU 300/400 or CPU 1200/1500 
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Faceplates 6 
 

The HMI faceplate displays actual values and various states of the UPS1600 on WinCC 
Comfort/Advanced V18, WinCC Unified Comfort, and WinCC Professional V18. 

6.1 WinCC Comfort/Advanced 

6.1.1 Description 

Overview 
This faceplate visualizes parameters of UPS1600 on a HMI control panel. 

 

The parameters of UPS1600 are distributed over four tabs in the faceplate, clicking on the 
relevant tab displays specific information. The four tabs are: 

• State 

• Information 

• Trends 

• Alarms 



Faceplates  
6.1 WinCC Comfort/Advanced 

 SITOP UPS1600 Firmware V2.5: Faceplates and Communication Blocks V3.3 for SIMATIC STEP7 

22 Function Manual, 04.2023, A5E39439812-07-76 

The contents of the tabs and the parameters are described in detail in the following sections. 

6.1.2 State 
This menu item displays the operating state and battery state of UPS1600. 

 

The following table shows all parameters displayed under this menu with its corresponding 
display names: 
 

Display name Parameter of the UPS 
Operating state bufferMode 
Buffer readiness readyForBuffering 
Charging operating state chargingOpState 
Input voltage inputVolt 
Output voltage outputVolt 
Battery charge current measuredChargeCur 
Output current outputCur 
Battery charge batteryChargeLevel 

The values of the parameters bufferMode and readyForBuffering are output via 
symbolic I/O fields. This has an indicator which is subject to the color dynamization and is 
dependent on the parameter value. 
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The following table shows the possible parameter states with its corresponding color 
dynamization: 
 

Parameter State/display name Color 
Normal mode Normal mode Green 

Buffer mode Yellow 
Off White 

Ready for buffering Ready for buffering Green 
Not ready for buffering Red 
Off White 

 

 

 Note 

All the I/O fields in the faceplate are read only values. 
 

 

State when Pb type BAT1600 module is connected 
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The following table shows all parameters displayed under this menu with its corresponding 
display names. 
 

Display name Parameter of the UPS 
Operating state batteryOpState 
End-of-charge voltage endOfChargeVolt 
Battery voltage batteryVolt 
Battery charge batteryChargeLevel 
Calculated battery health batteryCalcHealth 

The following table shows the possible parameter states with its corresponding color 
dynamization. 
 

Parameter State/display name Color 
Operating state Off White 

Startup White 
Normal operation Green 
Error Red 
Limited charge Yellow 
Critical battery lifetime Green 
End of battery lifetime Yellow 
Battery replacement required Red 
Battery replacement running Green 
Battery replacement completed Green 
Battery replacement abort Red 
Deep discharge recovery Yellow 

 

 

 Note 

All the I/O fields in the faceplate are read only values. 
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State when LiFe type BAT1600 module is connected 

 

The following table shows all parameters displayed under this menu with its corresponding 
display names. 
 

Display name Parameter of the UPS 
Operating state batteryOpState 
End-of-charge voltage endOfChargeVolt 
Battery voltage batteryVolt 
Battery charge batteryChargeLevel 
Calculated battery health batteryCalcHealth 

The following table shows the possible parameter states with its corresponding color 
dynamization. 
 

Parameter State/display name Color 
Operating state Off White 

Startup White 
Normal operation Green 
Error Red 
Limited charge Yellow 
Critical battery lifetime Green 
End of battery lifetime Yellow 
Battery replacement required Red 
Battery replacement running Green 
Battery replacement completed Green 
Battery replacement abort Red 
Deep discharge recovery Yellow 
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 Note 

All the I/O fields in the faceplate are read only values. 
 

State when UPS1100 is connected 

 

The following table shows all parameters displayed under this menu with its corresponding 
display names. 
 

Display name Parameter of the UPS 
Operating state batteryOpState 
End-of-charge voltage endOfChargeVolt 
Battery voltage batteryVolt 
Battery charge batteryChargeLevel 
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The following table shows the possible parameter states with its corresponding color 
dynamization. 
 

Parameter State/display name Color 
Operating state Off White 

Startup White 
Normal operation Green 
Error Red 
Limited charge Yellow 
Critical battery lifetime Green 
End of battery lifetime Yellow 
Battery replacement required Red 
Battery replacement running Green 
Battery replacement completed Green 
Battery replacement abort Red 
Deep discharge recovery Yellow 

State when a 3rd party battery is connected 

 
 

 Note 

All the I/O fields in the faceplate are read only values. 
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State when no battery is connected 
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6.1.3 Information 
This menu displays general device information about UPS1600. 

 

The following table shows all parameters displayed under this menu with its corresponding 
display names: 
 

Display name Parameter of the UPS 
Device name deviceName 
Article no. orderNumber 
Serial number serialNumber 
HW revision deviceHwRevision 
SW revision deviceSwRevision1, deviceSwRevision2, 

and deviceSwRevision3 
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6.1.4 Trends 

Description 
The "Trends" tab displays the following attributes of UPS1600 in trend curves: 

• UPS Input voltage 

• UPS Output voltage 

• UPS Output current 

• Battery voltage 

• Battery charge current 

 

The time range of the X axis of the trend curve is 100 seconds. The trend variables used have 
an acquisition cycle of 1 second and are refreshed cyclically. 

The table below describes UPS1600 parameters with their respective display names, color 
and unit representation: 
 

Display name Parameter of the UPS Color Unit 
UPS Input voltage inputVolt Green V 
UPS Output voltage outputVolt Black V 
UPS Output current outputCur Red A 
Battery voltage batteryVolt Yellow V 
Battery charge current measuredChargeCur Blue A 



 Faceplates 
 6.1 WinCC Comfort/Advanced 

SITOP UPS1600 Firmware V2.5: Faceplates and Communication Blocks V3.3 for SIMATIC STEP7 

Function Manual, 04.2023, A5E39439812-07-76 31 

6.1.5 Alarms 

Description 
The "Alarms" tab displays PROFINET diagnostic messages of SITOP UPS1600. 

 

When you click on "OPEN" for Pending alarms and Alarm history buttons, two separate 
message windows open. 

The message window for "Pending alarms" displays all currently pending PROFINET diagnostic 
messages of the UPS1600. The message window for "Alarm history" displays all PROFINET 
diagnostic messages of UPS1600 stored in the internal message buffer of the HMI control 
panel used. 

Prerequisites for displaying the PROFINET diagnostic messages  
In order to display PROFINET diagnostic messages of UPS1600 within the faceplate, the 
respective WinCC flexible/WinCC TIA Portal project must be configured. 

A list of the PROFINET diagnostic messages of UPS1600 is available in the chapter 4 of the 
SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415). 

https://support.industry.siemens.com/cs/ww/en/view/84977415
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6.2 WinCC Unified Comfort 

6.2.1 S7-300/400 

6.2.1.1 Description 

Overview 
There are two views in the faceplate. LUPS1600_Overview, in this view you can see the 
operating status. For other information, click the icon  to see the detailed view, 
LUPS1600_Detailed.  

LUPS1600_Overview 

 
 Click the icon  to view the below image. 
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LUPS1600_Detailed 

 

The parameters of UPS1600 are distributed over four tabs in the faceplate, clicking on the 
relevant tab displays specific information. The four tabs are: 

• State 

• Information 

• Trends 

• Alarms 

The contents of the tabs and the parameters are described in detail in the following sections. 
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6.2.1.2 State 
This menu item displays the operating state and battery state of UPS1600. 

 
The following table shows all parameters displayed under this menu with its corresponding 
display names: 
 

Display name Parameter of the UPS 
Operating state bufferMode 
Buffer readiness readyForBuffering 
Charging operating state chargingOpState 
Input voltage inputVolt 
Output voltage outputVolt 
Battery charge current measuredChargeCur 
Output current outputCur 
Battery charge batteryChargeLevel 

The values of the parameters bufferMode and readyForBuffering are output via 
symbolic I/O fields. This has an indicator which is subject to the color dynamization and is 
dependent on the parameter value. 
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The following table shows the possible parameter states with its corresponding color 
dynamization: 
 

Parameter State/display name Color 
Normal mode Normal mode Green 

Buffer mode Yellow 
Off White 

Ready for buffering Ready for buffering Green 
Not ready for buffering Red 
Off White 

 

 

 Note 

All the I/O fields in the faceplate are read only values. 
 

 

State when Pb type BAT1600 module is connected 
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The following table shows all parameters displayed under this menu with its corresponding 
display names. 
 

Display name Parameter of the UPS 
Operating state batteryOpState 
End-of-charge voltage endOfChargeVolt 
Battery voltage batteryVolt 
Battery charge batteryChargeLevel 
Calculated battery health batteryCalcHealth 

The following table shows the possible parameter states with its corresponding color 
dynamization. 
 

Parameter State/display name Color 
Operating state Off White 

Startup White 
Normal operation Green 
Error Red 
Limited charge Yellow 
Critical battery lifetime Green 
End of battery lifetime Yellow 
Battery replacement required Red 
Battery replacement running Green 
Battery replacement completed Green 
Battery replacement abort Red 
Deep discharge recovery Yellow 

 

 

 Note 

All the I/O fields in the faceplate are read only values. 
 



 Faceplates 
 6.2 WinCC Unified Comfort 

SITOP UPS1600 Firmware V2.5: Faceplates and Communication Blocks V3.3 for SIMATIC STEP7 

Function Manual, 04.2023, A5E39439812-07-76 37 

State when LiFe type BAT1600 module is connected 

 

The following table shows all parameters displayed under this menu with its corresponding 
display names. 
 

Display name Parameter of the UPS 
Operating state batteryOpState 
End-of-charge voltage endOfChargeVolt 
Battery voltage batteryVolt 
Battery charge batteryChargeLevel 
Calculated battery health batteryCalcHealth 

The following table shows the possible parameter states with its corresponding color 
dynamization. 
 

Parameter State/display name Color 
Operating state Off White 

Startup White 
Normal operation Green 
Error Red 
Limited charge Yellow 
Critical battery lifetime Green 
End of battery lifetime Yellow 
Battery replacement required Red 
Battery replacement running Green 
Battery replacement completed Green 
Battery replacement abort Red 
Deep discharge recovery Yellow 
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 Note 

All the I/O fields in the faceplate are read only values. 
 

State when UPS1100 is connected 

 

The following table shows all parameters displayed under this menu with its corresponding 
display names: 
 

Display name Parameter of the UPS 
Operating state batteryOpState 
End-of-charge voltage endOfChargeVolt 
Battery voltage batteryVolt 
Battery charge batteryChargeLevel 
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The following table shows the possible parameter states with its corresponding color 
dynamization. 
 

Parameter State/display name Color 
Operating state Off White 

Startup White 
Normal operation Green 
Error Red 
Limited charge Yellow 
Critical battery lifetime Green 
End of battery lifetime Yellow 
Battery replacement required Red 
Battery replacement running Green 
Battery replacement completed Green 
Battery replacement abort Red 
Deep discharge recovery Yellow 

State when a 3rd party battery is connected 

 
 

 Note 

All the I/O fields in the faceplate are read only values. 
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6.2.1.3 Information 
This menu displays general device information about UPS1600. 

 

The following table shows all parameters displayed under this menu with its corresponding 
display names: 
 

Display name Parameter of the UPS 
Device name deviceName 
Article no. orderNumber 
Serial number serialNumber 
HW revision deviceHwRevision 
SW revision deviceSwRevision1, deviceSwRevision2, 

and deviceSwRevision3 
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6.2.1.4 Trends 

Screen: Trends of main module 

 

Element 
 
Screen area Parameter Description 
Trend 
UPS1600 

HMI_RT_1::UPS_Data.inputVolt Input voltage in the UPS1600 module. 
HMI_RT_1::UPS_Data.outputVolt Output voltage in the UPS1600 module. 
HMI_RT_1::UPS_Data.outputCur Input current in the UPS1600 module. 
HMI_RT_1::UPS_Data.batteryVolt Battery voltage capacity in the UPS1600 

module. 
HMI_RT_1::UPS_Data.measuredChargeCur Measured charge current in the UPS1600 

module. 
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6.2.2 S7-1200/1500 

6.2.2.1 Description 

Overview 
There are two views in the faceplate. LUPS1600_Overview, in this view you can see the 
operating status. For other information, click the icon  to see the detailed view, 
LUPS1600_Detailed.  

LUPS1600_Overview 

 

 Click the icon  to view the below image. 
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LUPS1600_Detailed 

 

The parameters of UPS1600 are distributed over four tabs in the faceplate, clicking on the 
relevant tab displays specific information. The four tabs are: 

• State 

• Information 

• Trends 

• Alarms 

The contents of the tabs and the parameters are described in detail in the following sections. 
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6.2.2.2 State 
This menu item displays the operating state and battery state of UPS1600. 

 
The following table shows all parameters displayed under this menu with its corresponding 
display names: 
 

Display name Parameter of the UPS 
Operating state bufferMode 
Buffer readiness readyForBuffering 
Charging operating state chargingOpState 
Input voltage inputVolt 
Output voltage outputVolt 
Battery charge current measuredChargeCur 
Output current outputCur 
Battery charge batteryChargeLevel 

The values of the parameters bufferMode and readyForBuffering are output via 
symbolic I/O fields. This has an indicator which is subject to the color dynamization and is 
dependent on the parameter value. 



 Faceplates 
 6.2 WinCC Unified Comfort 

SITOP UPS1600 Firmware V2.5: Faceplates and Communication Blocks V3.3 for SIMATIC STEP7 

Function Manual, 04.2023, A5E39439812-07-76 45 

The following table shows the possible parameter states with its corresponding color 
dynamization: 
 

Parameter State/display name Color 
Normal mode Normal mode Green 

Buffer mode Yellow 
Off White 

Ready for buffering Ready for buffering Green 
Not ready for buffering Red 
Off White 

 

 

 Note 

All the I/O fields in the faceplate are read only values. 
 

 

State when Pb type BAT1600 module is connected 
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The following table shows all parameters displayed under this menu with its corresponding 
display names. 
 

Display name Parameter of the UPS 
Operating state batteryOpState 
End-of-charge voltage endOfChargeVolt 
Battery voltage batteryVolt 
Battery charge batteryChargeLevel 
Calculated battery health batteryCalcHealth 

The following table shows the possible parameter states with its corresponding color 
dynamization. 
 

Parameter State/display name Color 
Operating state Off White 

Startup White 
Normal operation Green 
Error Red 
Limited charge Yellow 
Critical battery lifetime Green 
End of battery lifetime Yellow 
Battery replacement required Red 
Battery replacement running Green 
Battery replacement completed Green 
Battery replacement abort Red 
Deep discharge recovery Yellow 

 

 

 Note 

All the I/O fields in the faceplate are read only values. 
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State when LiFe type BAT1600 module is connected 

 

The following table shows all parameters displayed under this menu with its corresponding 
display names. 
 

Display name Parameter of the UPS 
Operating state batteryOpState 
End-of-charge voltage endOfChargeVolt 
Battery voltage batteryVolt 
Battery charge batteryChargeLevel 
Calculated battery health batteryCalcHealth 

The following table shows the possible parameter states with its corresponding color 
dynamization. 
 

Parameter State/display name Color 
Operating state Off White 

Startup White 
Normal operation Green 
Error Red 
Limited charge Yellow 
Critical battery lifetime Green 
End of battery lifetime Yellow 
Battery replacement required Red 
Battery replacement running Green 
Battery replacement completed Green 
Battery replacement abort Red 
Deep discharge recovery Yellow 
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 Note 

All the I/O fields in the faceplate are read only values. 
 

State when UPS1100 is connected 

 

The following table shows all parameters displayed under this menu with its corresponding 
display names: 
 

Display name Parameter of the UPS 
Operating state batteryOpState 
End-of-charge voltage endOfChargeVolt 
Battery voltage batteryVolt 
Battery charge batteryChargeLevel 
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The following table shows the possible parameter states with its corresponding color 
dynamization. 
 

Parameter State/display name Color 
Operating state Off White 

Startup White 
Normal operation Green 
Error Red 
Limited charge Yellow 
Critical battery lifetime Green 
End of battery lifetime Yellow 
Battery replacement required Red 
Battery replacement running Green 
Battery replacement completed Green 
Battery replacement abort Red 
Deep discharge recovery Yellow 

State when a 3rd party battery is connected 

 
 

 Note 

All the I/O fields in the faceplate are read only values. 
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6.2.2.3 Information 
This menu displays general device information about UPS1600. 

 

The following table shows all parameters displayed under this menu with its corresponding 
display names: 
 

Display name Parameter of the UPS 
Device name deviceName 
Article no. orderNumber 
Serial number serialNumber 
HW revision deviceHwRevision 
SW revision deviceSwRevision1, deviceSwRevision2, 

and deviceSwRevision3 
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6.2.2.4 Alarms 

Screen: Alarms 

 
 

The table below describes the icons in the faceplate. 
 
Icon Icon Description 

 Display active alarms 

 Display logged alarms 

 Display and update logged alarms 

 First line 
 Previous line 

 Next line 

 Last line 

 Previous page 

 Next page 

 Single acknowledgement 

 Group acknowledgement 

 Selection display for filtering alarms 

 Sorting setup for displayed alarms 
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6.2.2.5 Trends 

Screen: Trends of main module 

 

Element 
 
Screen area Parameter Description 
Trend 
UPS1600 

HMI_RT_1::UPS_Data.inputVolt Input voltage in the UPS1600 module. 
HMI_RT_1::UPS_Data.outputVolt Output voltage in the UPS1600 module. 
HMI_RT_1::UPS_Data.outputCur Input current in the UPS1600 module. 
HMI_RT_1::UPS_Data.batteryVolt Battery voltage capacity in the UPS1600 

module. 
HMI_RT_1::UPS_Data.measuredChargeCur Measured charge current in the UPS1600 

module. 
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Application of the function blocks 7 
7.1 Application of the function blocks in SIMATIC STEP 7 V5.6 

7.1.1 Prerequisites 

FB UPS1600 requirements 
The following requirements must be met in order to use the FB in combination with UPS1600 
and SIMATIC STEP 7 V5.6: 

• The GSD file of the UPS1600 is installed in the Hardware (HW) configuration of SIMATIC 
STEP 7 V5.6 and the UPS is configured as PROFINET node in the HW configuration of the 
SIMATIC S7 controller. 

• S7 communication between UPS1600 and SIMATIC S7 controller is already configured. 

• The library UPS1600 V3-1 STEP7 V5.6 is available on your computer. 

Installation of GSD file 
The required information about installation of the GSD file of the UPS1600 in SIMATIC STEP 7 
V5.6 is available in the chapter 3.4.2 of the SITOP UPS1600 User Manual. 
(https://support.industry.siemens.com/cs/ww/en/view/84977415) 

S7 communication 
The required information about establishing communication between a UPS1600 and a 
SIMATIC S7 controller is available in the chapter 3.4 of the SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415). 

https://support.industry.siemens.com/cs/ww/en/view/84977415
https://support.industry.siemens.com/cs/ww/en/view/84977415
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7.1.2 Content of the library for SIMATIC STEP 7 V5.6 

Content of the library for SIMATIC STEP 7 V5.6 
The library UPS1600 V3-1 STEP7 V5.6 contains: 

• Blocks (FB1, FB2, UDT1 and UDT2) 

• Symbol table Symbols_UPS1600 

• SCL source file of the code blocks FB1, FB2, UDT1 and UDT2 

• "Text Libraries" 

The table below shows the blocks available in the library. 
 
Block Name Description 
FB1 UPS1600 FB for program-controlled switch-off of the 

UPS1600 
UDT1 LUPS1600_typeUPS1600Data UDT provides the structure in the global data block 

for data exchange 
FB2 UPS16Msg FB to raise UPS1600 diagnostic alarms 
UDT2 SStartInf UDT structure of local data of OB82 

Opening the library in SIMATIC STEP 7 V5.6 
Follow the procedure to open the library in a SIMATIC STEP 7 V5.6 project: 

1. Open SIMATIC Manager. 

2. In the menu bar, click "File > Open". 
The "Open Project" dialog box opens. 
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3. Select the "Libraries" tab. 

 
4. Click "Browse". 

The "Browse" dialog box opens. 

5. Navigate to the stored location of the library in your computer and open the folders "SITOP-
UPS1600_Library_STEP7-V5_V3-1 > UPS1600 V3-1 STEP7 V5.6". 

6. Select "UPS1600_" and click "OK". 
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7.1.3 Interfaces of the function block 

Block diagram 
The following figure shows the block diagram of FB1: 

 

Interface description 
The table below describes parameters of FB1: 
 
Parameter Declaration Data type Description 
addrIn Input DWORD PROFINET diagnostic 

address of the UPS1600 
within the project. 
The diagnostic address must 
be specified in hexadecimal 
format. 

cyclicIOAddr Input WORD Input address of the 
UPS1600 within the project. 
The input address must be 
specified in hexadecimal 
format. 

UPSExecuteReset Input BOOL Switch-off signal to the 
UPS1600. 

UPSReadyForReset Output BOOL Signal for plant shut-down. 
data InOut LUPS1600_typeUPS1600Data Data area for data exchange 

to the HMI faceplate. 
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The table below describes parameters of FB2: 
 
Parameter Declaration Data type Description 
Diag_Address Input INT PROFINET diagnostic 

address of the UPS1600 
within the project. The 
diagnostic address must 
be specified in decimal 
format. 

MsgEvId100_01 .. 
MsgEvId100_27 Input DWORD Message event ids for 

Device failures alarms 
MsgEvId101_01 .. 
MsgEvId101_27 Input DWORD Message event ids for 

Device Diagnostic 
alarms 

MsgEvId102_01 .. 
MsgEvId102_12 Input DWORD Message event ids for 

Battery Diagnostic 
alarms 

Input and diagnostic address of the UPS1600 module 
To fetch the input and diagnostic address of the UPS1600 module, follow the instructions 
given below: 

1. Open the hardware configuration settings of the PLC used in the project. The "HW Config - 
[SIMATIC 400(1) (Configuration)..." dialog box opens. 

2. Select the UPS1600 module. 

3. Note down the value in the "Diagnostic Address" column (A). We need to add value to the 
given parameter addrIn of FB1 and Diag_Address of FB2. 
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4. Note down value in the "I Address" column (B), value given to the parameter 
cyclicIOAddr of FB1. 

 

In this case, 

• addrIn value is 16375. 

• cyclicIOAddr is 512. 
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7.1.4 LUPS1600_typeUPS1600Data (UDT1) 

Data block DB15 
The Data Block (DB) contains all the parameters of UPS1600 displayed within the HMI 
faceplate. 

The following table lists all the parameters in UDT1: 
 
Parameter Data type Remarks 
orderNumber STRING [20] Order number  
serialNumber STRING [20] Serial number  
deviceName STRING [20] Device name  
versionNumber STRING [30] Version number  
chargingOpState BYTE Status of chraging unit/Value range: 0-4 
numOfBatteries BYTE Number of batteries/Value range: 0-6 
batFamily BYTE Battery family/ Value range: BAT1600 = 1, UPS1100 = 2, 

Third-party battery = 3 
batType BYTE Type of battery identifier/Value range: Pb = 0, Li = 1 
BAT1LEDState BYTE Signaling/ Value range: Bit0/1: Color 0 = Green/read 

alternating 1 = red, 2 = green, 3 = yellow, 
Bit2/3: State 0 = off 1 = on 

BAT1OpState BYTE Battery status/Value range: 0-11 
BAT1CalcHealth BYTE Calculated battery health/ Value range: 0-100 
BAT2LEDState BYTE Signaling/ Value range: Bit0/1: Color 0 = Green/read 

alternating 1 = red, 2 = green, 3 = yellow, 
Bit2/3: State 0 = off 1 = on 

BAT2OpState BYTE Battery status/Value range: 0-11 
BAT2CalcHealth BYTE Calculated battery health/ Value range: 0-100 
BAT3LEDState BYTE Signaling/ Value range: Bit0/1: Color 0 = Green/read 

alternating 1 = red, 2 = green, 3 = yellow, 
Bit2/3: State 0 = off 1 = on 

BAT3OpState BYTE Battery status/Value range: 0-11 
BAT3CalcHealth BYTE Calculated battery health/ Value range: 0-100 
BAT4LEDState BYTE Signaling/ Value range: Bit0/1: Color 0 = Green/read 

alternating 1 = red, 2 = green, 3 = yellow, 
Bit2/3: State 0 = off 1 = on 

BAT4OpState BYTE Battery status/Value range: 0-11 
BAT4CalcHealth BYTE Calculated battery health/ Value range: 0-100 
BAT5LEDState BYTE Signaling/ Value range: Bit0/1: Color 0 = Green/read 

alternating 1 = red, 2 = green, 3 = yellow, 
Bit2/3: State 0 = off 1 = on 

BAT5OpState BYTE Battery status/Value range: 0-11 
BAT5CalcHealth BYTE Calculated battery health/ Value range: 0-100 
BAT6LEDState BYTE Signaling/ Value range: Bit0/1: Color 0 = Green/read 

alternating 1 = red, 2 = green, 3 = yellow, 
Bit2/3: State 0 = off 1 = on 

BAT6OpState BYTE Battery status/Value range: 0-11 
BAT6CalcHealth BYTE Calculated battery health/ Value range: 0-100 
endOfChargeVolt REAL End of charge voltage [V] 
chargeCur REAL Charge current [A] 
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Parameter Data type Remarks 
maxOutCur BYTE Maximum output current [A] 
inputVolt REAL Input Voltage [V] 
inputCur REAL Input current [A] 
outputVolt REAL Output voltage [V] 
loadCur REAL Load current [A] 
measuredChargeCur REAL Measured charge current [A] 
batteryVolt REAL Battery voltage [V] 
outputCur REAL Output current [A] 
chargeVolt REAL Charge volatge [V] 
bufferMode BYTE Active = 255 Inactive = 0; Undefined = 127 
readyForBuffering BYTE Yes = 255; No = 0 
batteryChargeLevel BYTE 0 to 100% = battery charging; 255 = unknown battery 
totalCalcBatCap REAL Total calculated battery capacity [Ah] 
totalCalcBatHealth BYTE Total calculated battery health [%] 
bufferTime INT Buffer time [s] 
bufferThreshold REAL Buffer threshold [V] 
bufferingAllowed BYTE Buffering allowed [0/255] 
commandID INT Command ID (Remote reset = 8207) 
parameter1 BYTE Parameter value 1 
parameter2 BYTE Parameter value 2 
deviceHWRevision INT Device hardware revision 
deviceSWRevision1 BYTE Device software revision 1 
deviceSWRevision2 BYTE Device software revision 2 
deviceSWRevision3 BYTE Device software revision 3 

 

 

 Note 

Further information about the system parameters is available in the SITOP UPS1600 User 
Manual (https://support.industry.siemens.com/cs/ww/en/view/84977415). 

 

https://support.industry.siemens.com/cs/ww/en/view/84977415
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7.1.5 Integrating the function block 

Integrating FB1 
The following sections describe all the steps required to integrate FB1 into a SIMATIC STEP 7 
V5.6 project. 

Hardware used: 

• CPU 317-2 PN/DP 

• SITOP UPS1600 24 V/20 A 

The procedure for other SIMATIC S7 controllers is identical. 
 

 Note 

Please ensure that all requirements for the integration of the FB are met. The requirements 
are described in these Prerequisites (Page 53). 

 

Inserting blocks from the library into the program 
Follow the procedure to integrate FB1 and associated data blocks into a SIMATIC STEP 7 V5.6 
project: 

1. In the "SIMATIC Manager", open the required project. 

2. Open the "Blocks" folder available in the connected PLC. 

3. In the "SIMATIC Manager", open the global library UPS1600 V3_1 STEP7 V5_6 and select 
"UPS1600_V3_1 > Blocks''. 
The procedure for opening the library is described in Content of the library for SIMATIC 
STEP 7 V5.6 (Page 54). 
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4. Select all the blocks in the library and drag-and-drop them into the "Blocks" folder of your 
target project folder. 

 
 

  Note 

The function blocks work properly with both, English and German mnemonics. In case the 
source code of the function blocks is required for a project, consider the following 
constraints: 
• In case the language setting of your project is English, then the source code of the 

function blocks can be used as it is. 
• In case the language setting of your project is German, then the entries IB (Input Byte) 

and IW (Input Word) of the sources have to be replaced with EB (EingangsByte) and EW 
(EingangsWort). 

 

5. Insert OB40 in order to avoid PLC going to stop mode in case of hardware interrupt. 

Inserting Text libraries from the library into the program 
Follow the procedure to insert "Text Libraries" from the library into a SIMATIC STEP 7 V5.6 
project: 

1. In the "SIMATIC Manager", open the required project. 

2. Open the "S7 Program" folder available in the connected PLC. Insert Text Library folder under 
S7 Program folder if it doesn’t exist. 

3. In the "SIMATIC Manager", open the global library UPS1600 V3_1 STEP 7 V5_6 and select 
"UPS1600_V3_1". 

4. The procedure for opening the library is described in Content of the library for SIMATIC 
STEP 7 V5.6. 

5. Copy "SITOP_MODULES", "SITOP_UPS1600_DiagText", "SITOP_UPS1600_HlpText" which are 
present under "Text Libraries" folder in the library and paste them into the "Text Libraries" 
folder of target project folder. 
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6. Open text library "SITOP_MODULES" and make an entry to the text library with index as 
modules diagnostic address and PSU8600/UPS1600 device name under English/German 
Language column as shown below. 

 
7. Save and close text library. 

Create a global data block with UDT structure 
Follow the procedure to create a global DB with UDT: 

1. In your project, open the "Blocks" folder available in the connected PLC folder. 

2. Right-click on the blocks element area and select "Insert New Object > Data Block". 

The "Properties - Data Block" dialog box opens to create a DB. 

3. In the "Properties - Data Block" dialog box, 

– Enter a name and number for the DB (DB15) in the "Name and type:" text box. 

– For the same field, open the first drop-down list and select "Shared DB". 

– Enter a symbolic name as desired (UPS_Global) in the "Symbolic Name:" text box. 

 
4. Click "OK". 

The created DB appears in the "Blocks" folder. 

5. Open the DB created in Step 2 (DB15). 

A new window opens. 
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6. At the address "+0.0", 

– In the "Name" column, enter a name for your tag (UPS). 

– In the "Type" column, replace INT with LUPS1600_typeUPS1600Data. 

– In the "Initial" column, delete the initial value and remove the comment. 

 
7. Save the settings and close the window. 

Calling the function block FB1 
Follow the procedure to call the FB within an organization block (OB). In this description, FB1 
is called within OB33: 

1. In the "Blocks" folder of the controller, create an instance DB. 

2. Right click on the blocks element area and select "Insert New Object > Data block". The 
"Properties - Data Block" dialog box opens. 
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3. In the "Properties - Data Block" dialog box, 

– Enter a name and number for the DB (DB3) in the "Name and type:" text box. 

– For the same field, select "Instance DB" and "FB1" from the drop-down lists. 

– Enter the symbolic name as "UPS1600_DB" in the "Symbolic name:" text box. 

– Click "OK". 
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4. In the same "Blocks" folder, create an Organization Block (OB) with the name OB33. (Right 
click and select "Insert New Object > Organization block".) 

Open the created OB33. 

 
5. In the "Program elements" tab, expand the "FB blocks" folder. 
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6. Drag-and-drop "FB1 UPS1600 UPS1600" onto the empty network area. 
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7. For the block in the network area, 

– Interconnect FB1 with the instance DB created in step 1 (DB3). 

– For the parameter addrIn, enter the PROFINET diagnostic address of the SITOP 
UPS1600 within your STEP 7 project (DW#16#3FF7). 

– For the parameter cyclicIOAddr, enter the input address of the SITOP UPS1600 
within your STEP 7 project (W#16#200). 

– Connect the parameter UPSReadyForReset to the tag through which you bring the 
plant into a safe state (flag M0.0 is used). 

– Connect the parameter UPSExecuteReset to the tag through which you switch off 
the UPS (flag M0.1 is used). 

 
For further information about the block parameters, see Interfaces of the function block 
(Page 56). 

8. Save the changes and close the window. 

 

 Note 
addrIn and cyclicIOAddr of FB1 

To know the diagnostic and input address of FB1, refer to section Input and diagnostic 
address of the UPS1600 module in Interfaces of the function block (Page 56). 
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Calling the function block FB2 
Follow the procedure to call the FB2 within an organization block (OB). In this description, 
FB2 is called within OB82: 

1. In the "Blocks" folder of the controller, create an instance DB. 

2. Right click on the blocks element area and select "Insert New Object > Data block". The 
"Properties - Data Block" dialog box opens. 

3. In the "Properties - Data Block" dialog box, 

– Enter a name and number for the DB (DB2) in the "Name and type:" text box. 

– For the same field, select "Instance DB" and "FB2" from the drop-down lists. 

– Enter the symbolic name as "UPS1600Msg_DB" in the "Symbolic name:" text box. 

– Click "OK". 
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4. In the same "Blocks" folder, create an Organization Block (OB) with the name OB82. (Right 
click and select "Insert New Object > Organization block".) Open the created OB82. 

 
5. In the "Program elements" tab, expand the "FB blocks" folder. 

6. Drag-and-drop "FB2 UPS16Msg UPS1600" onto the empty network area. 
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7. For the block in the network area, 

– Interconnect FB2 with the instance DB created in step 1 (DB2). 

– For the parameter Diag_Address, enter the PROFINET diagnostic address of the 
SITOP UPS1600 within your SIMATIC STEP 7 project (16375). 

 
8. Save the changes and close the window. 

Follow the same procedure to call FB2 in OB86 and cyclic interrupt OB. In this example OB33 
with the same instance DB which is created in step 3. 

 

 Note 
Diag_Address of FB2 

To know the diagnostic and input address of FB2, refer to section Input and diagnostic 
address of the UPS1600 module in Interfaces of the function block (Page 56) 
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7.2 Application of the function blocks under STEP 7 Professional V18 

7.2.1 Prerequisites 

Requirements 
The following requirements must be met in order to use the FB in combination with UPS1600 
and STEP 7 V18: 

• S7 communication between UPS1600 and SIMATIC S7 controller is already configured. 

• LUPS1600 is available on your computer. 

S7 communication 
The required information about establishing communication between UPS1600 and a 
SIMATIC S7 controller is available in the chapter 3.3 of the SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415). 

See also 
SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415) 

https://support.industry.siemens.com/cs/ww/en/view/84977415
https://support.industry.siemens.com/cs/ww/en/view/84977415
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7.2.2 Content of the library for STEP 7 V18 

Content of the library for STEP 7 V18 
The STEP 7 V18 library contains the library elements for: 

• S7-300/400 

• S7-1200/1500 

The following sections describes in detail about the library elements and how to open the 
library in STEP 7 V18. 

Library elements S7-300/400 and S7-1200/1500 
The following code blocks are present in this library element: 
 
Folder Description 
FB It contains the LUPS1600_UPS1600 function block for program-controlled switch-off 

of the UPS1600. 
UDT LUPS1600_typeUPS1600Data UDT stores all parameters of UPS1600. 

Opening the library in STEP 7 V18 
Follow the procedure to open the library in STEP 7 V18 project: 

1. Open STEP 7 V18 in the "Project view" and select the "Libraries" tab. 

2. Under the "Global libraries" palette, click on the highlighted icon to import the library. The 
"Open global library" dialog box opens. 

 
3. In the "Look in:" drop-down list, navigate to the stored location of the library folder 

LUPS1600 on your computer and open it. 
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4. Select "LUPS1600". 

 
5. Click "Open". 

The library is displayed in the "Global libraries" palette. 
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7.2.3 Interfaces of the function block LUPS1600_UPS1600 

Function block LUPS1600_UPS1600 for S7-300/400 
Block diagram 

The following figure shows the block diagram of LUPS1600_UPS1600: 

 

Interface description 
 
Parameter Declaration Data type Description 
addrIn Input DWORD PROFINET diagnostic 

address of the UPS1600 
within the project. The input 
address can be specified in 
both hexadecimal and 
decimal format. 

cyclicIOAddr Input WORD I/O Data input address of 
UPS1600 within the project. 
The input address can be 
specified in both 
hexadecimal and decimal 
format. 

upsExecuteReset Input BOOL Switch-off signal to the 
UPS1600 

data InOut LUPS1600_typeUPS1600Data Data area for data exchange 
to the HMI faceplate. 

upsReadyForReset Output BOOL Signal for plant shut-down 
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addrIn and cyclicIOAddr of LUPS1600_UPS1600 for S7-300/400 
To fetch the input and diagnostic address of the UPS1600 module for S7-300/400, follow the 
instructions given below: 

1. In the "Project tree", open "Devices and Networks". 

2. Select the UPS1600 module and go to "Device view > Device overview". 

3. Note down the value in the "I address" column (A), this value is given to the parameter 
addrIn. 

4. Select the UPS1600 module and go to "Properties > General > I/O data > I/O addresses > 
Input addresses" 

5. Note down the value in the "Start address" variable (B), this value is given to the parameter 
cyclicIOAddr. 

 

In this case, 

• Value of addrIn is 2042 (A). 

• Value of cyclicIOAddr is 256 (B). 
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Function block LUPS1600_UPS1600 for S7-1200/1500 
Block diagram 

The following figure shows the block diagram of the LUPS1600_UPS1600: 

 

Interface description 
 
Parameter Declaration Data type Description 
addrIn Input HW_IO Hardware ID of the UPS1600 

within the project, for 
example: DC-UPS-
20A_1~Head. 

cyclicIOAddr Input HW_IO IO Data submodule address of 
UPS1600 within the project 

upsEecuteReset Input BOOL Switch-off signal to the 
UPS1600 

data InOut LUPS1600_typeUPS1600Data Data area for data exchange 
to the HMI faceplate. 

upsReadyForReset Output BOOL Signal for plant shut-down 
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addrIn and cyclicIOAddr of LUPS1600_UPS1600 for S7-1200/1500 
To fetch the input and diagnostic address of the UPS1600 module for S7-1200/1500, follow 
the instructions given below: 

1. In the "Project tree", open "Devices and Networks". 

2. In the "Network view", select the UPS1600 module and go to "Properties > System 
constants". 

3. Note down the value in the "Hardware identifier" column of DC-UPS-20A_1~Head (A), value 
given to addrIn. 

4. Note down the value in "Hardware identifier" column of DC-UPS-
20A_1~IO_Data_Submodule (B), value given to cyclicIOAddr. 

 

In this case, 

• Value of addrIn is DC-UPS-20A_1~Head or 273 (A). 

• Value of cyclicIOAddr is DC-UPS-20A_1~IO-Data_Submodule or 274 (B). 
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7.2.4 LUPS1600_typeUPS1600Data 
The data block contains parameters of UPS1600 displayed within the HMI faceplate. 

The following table lists parameters present in LUPS1600_typeUS1600Data for S7-300/400: 
 
Parameter Data type Remarks 
orderNumber STRING [20] Order number (String) 
serialNumber STRING [20] Serial number (String) 
deviceName STRING [20] Device name (String) 
versionNumber STRING [30] Version number (String) 
chargingOpState BYTE Status of charging unit //Value range: 0 -4 
numOfBatteries BYTE Number of batteries //Value range: 0 -6 
batFamily BYTE Battery family //Value range: BAT1600 = 1, 

UPS1100 = 2, Third-party battery = 3 
batteryType BYTE Type of battery identifier //Value range: Pb =0, Li = 1 
batteryDetails ARRAY [0...5]  
endOfChargeVolt REAL [V] 
chargeCur REAL [A] 
maxOutCur BYTE [A] 
inputVolt REAL [V] 
inputCur REAL [A] 
outputVolt REAL [V] 
loadCur REAL [A] 
measuredChargeCur REAL [A] 
batteryVolt REAL [V] 
outputCur REAL [A] 
chargeVolt REAL [V] 
bufferMode BYTE Active = 255 Inactive = 0; Undefined = 127 
readyForBuffering BYTE Yes = 255; No = 0 
batteryChargeLevel BYTE 0 to 100% = battery charging; 255 = unknown 

battery 
totalCalcBatCap REAL [Ah] 
bufferTime INT [s] 
bufferThreshold REAL [V] 
bufferingAllowed BYTE [0/255] 
commandID INT Remote reset = 8195 
parameter1 BYTE - 
parameter2 BYTE - 
deviceHWRevision INT - 
deviceSWRevision1 BYTE - 
deviceSWRevision2 BYTE - 
deviceSWRevision3 BYTE - 
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LUPS1600_typeUS1600Data for S7-1200/1500 
 
Parameter Data type Remarks 
orderNumber STRING[20] Article no. 
serialNumber STRING[20] Serial number 
deviceName STRING[20] Name of the device 
versionNumber STRING[30] Version number 
chargingOpState BYTE Status of charging unit //Value range: 0 -4 
numOfBatteries BYTE Number of batteries //Value range: 0 -6 
batFamily BYTE Battery family //Value range: BAT1600 = 1, UPS1100 = 2, 

Third-party battery = 3 
batteryType BYTE Type of battery identifier //Value range: Pb =0, Li = 1  
battery1LEDState BYTE Battery 1 LED state //Value range: 0-15 
battery1OpState BYTE Battery 1 Operating state //Value range: 0-11 
battery1CalcHealth BYTE Battery 1 Calculated battery health //Value range: 0-100 
battery2LEDState BYTE Battery 2 LED state //Value range: 0-15 
battery2OpState BYTE Battery 2 Operating state //Value range: 0-11 
battery2CalcHealth BYTE Battery 2 Calculated battery health //Value range: 0-100 
battery3LEDState BYTE Battery 3 LED state //Value range: 0-15 
battery3OpState BYTE Battery 3 Operating state //Value range: 0-11 
battery3CalcHealth BYTE Battery 3 Calculated battery health //Value range: 0-100 
battery4LEDState BYTE Battery 4 LED state //Value range: 0-15 
battery4OpState BYTE Battery 4 Operating state //Value range: 0-11 
battery4CalcHealth BYTE Battery 4 Calculated battery health //Value range: 0-100 
battery5LEDState BYTE Battery 5 LED state //Value range: 0-15 
battery5OpState BYTE Battery 5 Operating state //Value range: 0-11 
battery5CalcHealth BYTE Battery 5 Calculated battery health //Value range: 0-100 
battery6LEDState BYTE Battery 6 LED state //Value range: 0-15 
battery6OpState BYTE Battery 6 Operating state //Value range: 0-11 
battery6CalcHealth BYTE Battery 6 Calculated battery health //Value range: 0-100 
endOfChargeVolt REAL End of charge voltage //Value range: 24 - 30V 
maxOutCur BYTE Maximum output current //Value range: [mA] 
inputVolt REAL Input voltage //Value range: [0.01V] 
inputCur REAL Input current //Value range: [5mA] 
outputVolt REAL Output voltage //Value range: [0.01V] 
loadCur REAL Load current //Value range: [5mA] 
measuredChargeCur REAL Measured charge current //Value range: [1mA] 
batteryVolt REAL Battery voltage //Value range: [0.01V] 
outputCur REAL Output current //Value range: [5mA] 
chargeVolt REAL Current charge voltage //Value range: [0.01V] 
bufferMode BYTE Buffer mode //Value range: 0 = active, 255 = inactive 
readyForBuffering BYTE Buffer readiness //Value range: 0=FALSE, 255=TRUE 
batteryChargeLevel BYTE Battery charge level //Value range: 0 - 100%, 

255 - unknown battery 
totCalcBatCap REAL Calculated battery capacity [ 0.1Ah] 
bufferTime INT Buffer time //Value range: 1 - 32767s 
bufferThreshold REAL Connection threshold //Value range: 21 - 25V 
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Parameter Data type Remarks 
bufferingAllowed BYTE Buffering allowed //Value range: 0=FALSE, 255=TRUE 
commandID INT Remote reset : 8207 
parameter1 BYTE Waiting time after end of communication [s] 
parameter2 BYTE output voltage down time [s] 
deviceHwRevision INT HW revision 
deviceSwRevision1 BYTE SW revision1 
deviceSwRevision2 BYTE SW revision2 
deviceSwRevision3 BYTE Sw revision3 
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7.2.5 Integrating the function block 

7.2.5.1 Procedure when using an S7-300/400 

Overview 
Hardware used: 

• CPU 315-2 PN/DP 

• SITOP UPS1600 24V/20A 

The procedure for other SIMATIC S7-300/400 controllers is identical. 
 

 Note 

Please ensure that all the requirements for the integration of the FB are met. The 
requirements are described in the Prerequisites (Page 72). 

 

Inserting blocks from the library into the program  
Follow the procedure to insert the LUPS1600_UPS1600 and associated data blocks into a 
STEP 7 V18 project: 

1. Open the required project in "Project view". 

2. In the "Libraries" window, under "Global libraries", open the library "LUPS1600". 

The procedure for opening LUPS1600 global library is described in Content of the library in 
STEP 7 V18 (Page 73). 
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3. In the library, select "Types > LUPS1600 > STEP7 > S7-300/400 > FB > LUPS1600_UPS1600". 

 
4. Drag-and-drop "LUPS1600_UPS1600" into the "Program blocks" folder in the "Project tree". 
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 Note 

Even "LUPS1600_typeUPS1600Data" will be automatically copied to the "PLC data types" 
folder in the "Project tree". 
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Calling the function block 
Follow the procedure to call LUPS1600_UPS1600 within an Organization Block (OB). In this 
description, LUPS1600_UPS1600 is called within OB35: 

1. In the "Project tree", open the "Program blocks" folder. 

2. Create a cyclic interrupt OB with the name "CYC_INT5 [OB35]" and open it. This displays an 
empty network. 

3. From the "Program blocks" folder, drag-and-drop "LUPS1600_UPS1600 [FB165]" to the 
empty network of OB35. The "Call options" dialog box opens. 

 
4. Keep the default settings of the dialog box and click "OK". 

5. The following OBs must be added to the project to avoid PLC going to STOP mode in case of 
S7-300 & S7-400 PLC's:  

– OB 40: The hardware interrupt OBs interrupt the cyclic program processing at the 
occurrence of a hardware event.  

– OB 82: If the diagnostics-compatible module, for which you have enabled the 
diagnostic error interrupt, detects an error, the diagnostic error interrupt OB interrupts 
the cyclic program processing.  

– OB 83: The operating system of the CPU calls this OB when a configured and 
non-disabled module or submodule of the distributed IO is pulled or plugged.  

– OB 86: When a DP master system, slave or part of the submodules fails, the operating 
system of the CPU calls this OB. 

6. Double click on "Add new block" to add a new DB. The "Add new block" window opens. 
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7. In the "Add new block" window, 

– Select "Data block" 

– Enter a name as desired (UPS_Global). 

– In the "Type:" drop-down list, select "Global DB". 

– Click "OK". 
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8. Open the global DB created in step 6 (UPS_Global). Add a new tag with data type as 
"LUPS1600_typeUPS1600Data". 

 
9. In the network area of OB35, 

 
  Note 

OBs are called cyclically and in numerical order. Observe this when calling the 
communication blocks in an operation block. This ensures that you are reading the current 
data of the power supply. 

 

– For the parameter addrIn, enter the PROFINET diagnostic address of the UPS1600 
module (2042). 

– For the parameter cyclicIOAddr, enter the start address of the UPS1600 module 
(68). 

– Connect the parameter upsReadyForReset with a tag of your project that you use to 
bring the plant into a condition in which it can be shut down. 

– Connect the parameter upsExecuteReset with a tag of your project that you use to 
switch off the UPS when the plant is in a condition in which it can be shut down. 
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– Connect the parameter data with Global DB UPS_Global. 

 
 

 Note 
addrIn and cyclicIOAddr parameters 

To know the addrIn and cyclicIOAddr parameter values of the UPS1600 module, refer to 
Interfaces of the function block LUPS1600_UPS1600 (Page 75). 
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7.2.5.2 Procedure when using an S7-1200/1500 

Overview 
Hardware used: 

• CPU 1214C DC/DC/Rly 

• SITOP UPS1600 24 V/20 A 

The procedure for other SIMATIC S7-1200/1500 controllers is identical. 
 

 Note 

Please ensure that all requirements for the integration of the FB are met. The requirements 
are described in the Prerequisites (Page 72). 

 

Inserting blocks from the library into the program 
Follow the procedure to insert the blocks and the associated data blocks into a STEP 7 V18 
project: 

1. Open the required project in "Project view". 

2. In the "Libraries" tab, under "Global libraries", open the library "LUPS1600". 
The procedure for opening the library is described in the Content of the library in STEP 7 V18 
(Page 73). 
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3. In the library, select "Types > LUPS1600 > STEP7 > S7-1200/500 > FB > LUPS1600_UPS1600". 

 
4. Drag-and-drop "LUPS1600_UPS1600" into the "Program blocks" folder in the "Project tree". 

 
 

 Note 

Even "LUPS1600_typeUPS1600Data" will be automatically copied to the "PLC data types" 
folder in the "Project tree". 
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Calling the function block 
Follow the procedure to call the FB within an organization block (OB). In this description, 
LUPS1600_UPS1600 is called within OB30: 

1. In the "Project tree", open the "Program blocks" in the controller. 

2. Create an OB with the name "Cyclic interrupt [OB30]" and open it. This displays an empty 
network. 

3. Drag-and-drop "LUPS1600_UPS1600 [FB165]" from the "Program blocks" folder to the empty 
network of OB30. The "Call options" dialog box opens. 

 
4. Keep the default settings of the dialog box and click "OK". 
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5. Double click on "Add new block" to add a new DB. The "Add new block" window opens. 

6. In the "Add new block" window, 

– Select "Data block". 

– Enter a name as desired (UPS_Global). 

– In the "Type:" drop-down list, select "LUPS1600_typeUPS1600Data". 

– Click "OK". 
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7. Right click on the global DB created in step 5 (UPS_Global) and go to "Properties > General > 
Attributes". 

8. In the network area of OB30 for LUPS1600_UPS1600, 

– For the parameter addrIn, enter the hardware ID of DC-UPS-20A_1~Head of the 
UPS1600 (281). 

– For the parameter cyclicIOAddr enter the hardware ID of DC-UPS-
20A_1~Data_submodule of the UPS1600 (282). 

– Connect the parameter upsReadyForReset with a tag of your project that you use to 
bring your plant into a condition in which it can be shut down. 

– Connect the parameter upsExecuteReset with a tag of your project that you use to 
switch off the UPS when the plant is in a condition in which it can be shut down. 

– Connect the parameter data with the global DB created in step 6, (UPS_Global). 

 
 

Further information about the block parameters, refer to Interfaces of the function block 
FB165 (Page 75). 

 
 

 Note 
addrIn and cyclicIOAddr parameters 

To know the addrIn and cyclicIOAddr parameter values of your UPS1600 module, refer 
to Interfaces of the function FB165 (Page 75). 
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Application of the faceplates 8 
8.1 Application of the faceplates in WinCC flexible 2008 

8.1.1 Prerequisites 

Requirements 
The following requirements must be met to use the faceplates in WinCC flexible 2008 SP5: 

• The GSD file of the SITOP UPS1600 is installed in SIMATIC STEP 7 V5.6 and UPS is 
configured as PROFINET node in the HW configuration of the CPU. 

• S7 communication between SITOP UPS1600 and CPU is already configured. 

• All the program blocks from the library UPS1600 V3_1 STEP 7 V5_6 are integrated into the 
STEP 7 application program and executable. 

• The library 'UPS1600 V3_1 library WinCC Flexible 2008' for WinCC flexible 2008 SP5 is 
available on your computer. 

Supported control panels 
The faceplates are supported for the following control panels: 

• TP270 10" 

• OP270 10" 

• MP270 10" Touch 

• MP277 8" Touch/Key 

• MP277 10" Touch/Key 

• MP377 Touch/Key 

• WinCC flexible Runtime 2008 SP5 

Supported languages 
The faceplates support the following languages: 

• English (USA) 

• German (Germany) 

• Chinese (PR China) 
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8.1.2 Library for WinCC flexible 

Library for WinCC flexible 
The library 'UPS1600 V3_1 library WinCC flexible 2008' for WinCC flexible 2008 SP5 comprises 
of the following objects: 
 

Name Type Description 
UPS1600 V3_1 HMI Tag table Tag folder A tag folder with all the required tags 
Faceplate_UPS1600_V3_1 Faceplate Contains the faceplate 

'Faceplate_UPS1600_V3_1'. 
HMI Alarm views Message window Contains two message windows for displaying 

diagnostic messages of the UPS1600 
UPS1600_Data Structure Contains a group of structure elements required 

for UPS1600 faceplate 
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8.1.3 Integrating the faceplates 

Overview 
The following sections describe all the steps required to integrate a faceplate into a WinCC 
flexible 2008 SP5 project. 

Hardware used: 

• MP277 8" Touch 

An overview of the supported HMI control panels is available in the Prerequisites (Page 95). 

Opening the library 
The following procedure describes how to open the library in WinCC flexible 2008 SP5: 

1. Open the WinCC flexible project into which you want to insert the faceplate. 

2. In the "Tools" window, select the "Library" tab and click on the highlighted icon to open the 
library. The "Open global library" dialog box opens. 

 



Application of the faceplates  
8.1 Application of the faceplates in WinCC flexible 2008 

 SITOP UPS1600 Firmware V2.5: Faceplates and Communication Blocks V3.3 for SIMATIC STEP7 

98 Function Manual, 04.2023, A5E39439812-07-76 

3. Click the "Look in:" drop-down list and browse to the stored location of the library "SITOP-
UPS1600_Library_STEP7-V5_V3-1 > UPS1600 V3-1 library WinCC flexible 2008" on your 
computer. 

 
4. Select "UPS1600 V3_1 library WinCC flexible 2008.wlf" and click "Open". 

This imports the library into your project. 
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Inserting faceplates into a project 
The following procedure describes how to integrate the faceplate from the library into an 
existing WinCC flexible project: 

1. Open the required WinCC flexible project. 

2. In the "Project" window, open the screen into which you want to insert the faceplate 
(Screen_1). 

 
3. In the "Tools" window, under the "Library" tab, select the faceplate element 

"Faceplate_UPS1600_V3_1". 
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4. Drag-and-drop "Faceplate_UPS1600_V3_1" into the opened screen. 

 
5. In the "Project" window, select "Screens" and open "Template". 

 
6. In the "Tools" window, select the "HMI Alarm views" element of the library. 
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7. Drag-and-drop "HMI Alarm views" into the template. Two message windows are inserted. 

 
8. Select "Alarmview_UPS_Pending" alarm window, right-click on the "Properties" and select 

"Properties > Display > Enable "ACK" button". Repeat the same procedure for enabling "ACK" 
button in "Alarmview_UPS_History" alarm window. 

9. In the "Project" window, select "Communication > Tags". 

10. In the "Tools" window, select the "UPS1600 V3_1 HMI tag table" library element. 
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11. Drag-and-drop "UPS1600 V3_1 HMI tag table" into the "Tags" folder. 

 
12. Open the tag table "UPS1600 V3_1 HMI tag table", for the "UPS_Data" tag, 

– In the "Connection" column, select the required connection. (The connection name 
must be identical to the name of the connection created during configuring 
connection to the controller.) 

– Assign the global DB "UPS_Global" number to the tag (DB15). 
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13. In the tag table, select the tag "alarmhistory". Check the properties of the tag where in the 
"ShowAlarmWindow" function is inserted and its variable "Object name" is assigned to the 
tag "Alarmview_UPS_History". 
If the "Properties" window does not open then right click on the tag and go to "Properties". 

 
Similarly, check the properties of the tag "alarmpending" where in the 
"ShowAlarmWindow" function is inserted and its variable "Object name" is assigned to the 
tag "Alarmview_UPS_Pending". 

If the "ShowAlarmWindow" function is not inserted for these two tags, refer to the section 
Adding "ShowAlarmWindow" function to the tags described below. 

14. Select the faceplate inserted in step 4 (Screen_1) and go to "Properties > Dynamic Interface". 
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15. Under the "Data" section, for the "UPS_Data" property assign the "UPS_Data" tag created in 
step 11. 

 
16. Under the "Visibility" section, for the "Faceplate_intern_alarmview_buffer" property insert 

the "alarmhistory" tag from the "UPS1600 V3_1 HMI tag table" tag table. 

 
Similarly, for the "Faceplate_intern_alarmview_pending" property insert the 
"alarmpending" tag from the "UPS1600 V3_1 HMI tag table" tag table. 

 

 Note 
Connection in the UPS1600 V3_1 HMI tag table 

A default connection is always created automatically when a project is created. Delete the 
default connection if you have created another connection for your project. 
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Adding "ShowAlarmWindow" function to the tags 
The following procedure describes how to add the "ShowAlarmWindow" function to 
"alarmpending" and "alarmhistory" tags in the "UPS1600 V3_1 HMI tag table" tag table: 

1. Select the "alarmhistory" tag. A new window opens. 

2. Go to "Events > Change value". 

3. Click on "<No function>". 

4. In the drop-down list select "System functions > Alarms > ShowAlarmWindow". 

 
5. For the "Object name" variable click on "<No value>". 

6. In the drop-down list select "Alarmview_UPS_History". 

Follow the same procedure for the "alarmpending" tag, add "ShowAlarmWindow" function 
and select "Alarmview_UPS_Pending" for the "Object name" variable. 

Displaying the PROFINET diagnostic messages 
To display the PROFINET diagnostic messages of UPS1600 within the faceplate, the respective 
WinCC flexible project must already be configured. 

Information on the display and configuration of diagnostic messages in WinCC flexible is 
available in the entry ID 22319131 
(https://support.industry.siemens.com/cs/ww/en/view/22319131). 

Further notes regarding the PROFINET diagnostic messages of the SITOP UPS1600 are 
available in the chapter 4 of the SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415). 

https://support.industry.siemens.com/cs/ww/en/view/22319131
https://support.industry.siemens.com/cs/ww/en/view/84977415
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8.2 Application of screen windows in WinCC V7.4 

8.2.1 Prerequisites 

Requirements 
The following requirements must be met to use the screen windows in WinCC V7.4: 

• The GSD file of the SITOP UPS1600 is installed in SIMATIC STEP 7 V5.6 and the UPS is 
configured as PROFINET node in the HW configuration of the CPU. 

• S7 communication between the SITOP UPS1600 and CPU is already configured. 

• All program blocks from the library UPS1600 V3_1 STEP7 V5_6 are integrated into STEP 7 
application program and executable. 

• The library UPS1600 V3-1 library WinCC V7.4 is available on your computer. 

• Existing WinCC OS (PC station) with already configured connection and active 
communication. 

PC Station 
The screen windows are supported for the following PC Station: 

• WinCC V7.4 Runtime 

Supported languages 
The screen windows support the following languages: 

• English (USA) 

• German (Germany) 

• Chinese (PR China) 
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8.2.2 Library for WinCC V7.4 

Library for WinCC V7.4 
The library UPS1600 V3-1 library WinCC V7.4 for WinCC V7.4 comprises the following file 
folders: 
 
Name Type Description 
HMI Tag table (WinCC V7.4) Tags File for tag import 
HMI Screens (WinCC V7.4) Screens Comprises screen 'UPS1600_V3_1.pdl' 

HMI Tag table (WinCC V7.4) 
This folder contains the file UPS1600_HMIUDT.txt. This text file comprises all the tags and 
structure required for the functioning of UPS1600 screens. 

HMI Screens (WinCC V7.4) 
This folder contains the screen UPS1600_V3_1.pdl. 
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8.2.3 Integrating the screen windows 

Overview 
Target system used: 

• WinCC V7.4 Runtime 

Inserting the project screens 
The following procedure describes how to insert the HMI screen from the library into the 
project directory of your WinCC project: 

1. Open "Windows Explorer" in your computer machine and navigate to the "GraCS" folder in 
your project directory. Here, path to the folder is: "C:\Program 
Files(x86)\SIEMENS\STEP7\S7Proj\Ups1600\wincproj\OS(1)\GraCS". 

2. Open another instance of "Windows Explorer" in your computer machine and navigate to 
the stored location of the "SITOP-UPS1600_Library_STEP7-V5_V3-1" library folder. 

3. In the library folder, open "UPS1600 V3-1 library WinCC V7.4". 

4. Copy the "UPS1600_V3_1.pdl" screen element from the library and paste it into the "GraCS" 
folder. 
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Importing tags 
The following procedure describes how to import the HMI tag table file from the library folder 
into your WinCC project: 

1. Open your WinCC project in WinCC Explorer. 

2. Open the "Tag Management" element. The "Tag Management – WinCC Configuration 
Studio" window opens. 
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3. In the "Tag Management" window, select "Structure tags". 

 
4. In the menu bar, select "Edit > Import". The "Import" window opens. 

5. Browse to the stored location of "SITOP-UPS1600_Library_STEP7-V5_V3-1" library folder in 
your machine and open "UPS1600 V3-1 library WinCC V7.4 > HMI Tag table (WinCC V7.4)". 

6. Select "UPS1600_HMIUDT". 
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7. Click "Import". "UPS1600_Data" structure tag element appears under "Structure tags" in "Tag 
Management" window. 

 
8. Close the window. 
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Configuring screen windows 
The following procedure describes how to configure a screen window: 

1. In the WinCC project, select "Graphics Designer". 

2. On its right window pane, right click on the empty space and select "New picture" option to 
add a new pdl file. 

 
3. Rename the pdl created in step 2 as required (UPS_ScreenWindow) and open it. The 

"Graphics Designer" window opens. 

4. In the "Standard" window of the Graphics Designer go to "Smart Objects" folder and select 
"Picture Window". 
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5. Click on the "UPS_ScreenWindow.pdl" screen area to insert the "Picture Window". 

 
6. Select the added screen window and go to "Properties > Miscellaneous". 

7. For the "Picture Name" attribute assign "UPS1600_V3_1.pdl" and for the "Tag Prefix" attribute 
assign the tag "UPS_Global" created during importing the HMI tag table (refer to STEP 7 in 
Configuring Screen windows procedure). If your structure tag name is 'StructureTag' then 
add a '.' at the end of your tag name, that is 'StructureTag.' (<Structure tag name>.). Here, 
"UPS_Global.". 
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Displaying the PROFINET diagnostic messages 
In order to display the PROFINET diagnostic messages of the SITOP UPS1600 within the 
screen windows, the respective WinCC project must already be configured for the display of 
PROFINET diagnostic messages. 

Information on the display and configuration of diagnostic messages in WinCC is available 
under the entry ID 23730649 
(https://support.industry.siemens.com/cs/ww/en/view/23730649). 

Further notes regarding the PROFINET diagnostic messages of the SITOP UPS1600 are 
available in the chapter 4 of the SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415). 

8.2.4 Application of screen windows in WinCC V7.5 
To work with the library in WinCC V7.5 follow the similar process as mentioned in Application 
of screen windows in WinCC V7.4 (Page 106), except opening the library UPS1600 V3-1 
library WinCC V7.5 in place of UPS1600 V3-1 library WinCC V7.4. 

https://support.industry.siemens.com/cs/ww/en/view/23730649
https://support.industry.siemens.com/cs/ww/en/view/84977415
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8.3 Application of faceplates in WinCC Comfort/Advanced V18 

8.3.1 Prerequisites 

Requirements 
The following requirements must be met to use the faceplates in WinCC Comfort/Advanced 
V18: 

• S7 communication between SITOP UPS1600 and SIMATIC S7 controller is already 
configured. 

• Program blocks for STEP 7 V18 from LUPS1600 are integrated into the application 
program and executable. 

• LUPS1600 is available on your computer. 

Supported control panels 
The faceplates are supported for the following control panels: 

• TP700 Comfort/KP700 Comfort 

• TP900 Comfort/KP900 Comfort 

• TP1200 Comfort/KP1200 Comfort 

• TP1500 Comfort/KP1500 Comfort 

• TP1900 Comfort 

• TP2200 Comfort 

• MP277 8" Touch/MP277 8" Key 

• MP277 10" Touch/MP277 10" Key 

• MP377 Touch/Key 

• WinCC RT Advanced V18 

Supported languages 
The faceplates support the following languages: 

• English (USA) 

• German (Germany) 

• Chinese (PR China) 
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8.3.2 Library for WinCC Comfort/Advanced 

Library for WinCC Comfort/Advanced 
The following objects are part of LUPS1600 for WinCC Comfort/Advanced: 
 

Name Type Description 
Comfort/Advanced Faceplate from Types 

folder 
Comprises of "LUPS1600_FpS712001500RTAdv" 
faceplate and "LUPS1600_type300400RTAdv" HMI UDT  

TagTablesRTAdv Tag folder from Master 
copies 

Comprises LUPS1600_TagTableS7300400RTAdv and 
LUPS1600_TagTableS712001500RTAdv 

AlarmWindows Alarm views from 
Master copies 

Comprises 'Alarm windows' screen that has two 
message windows to display the PROFINET diagnostic 
messages of the UPS1600. 

8.3.3 Integrating the faceplates 

Overview 
Hardware used: 

• TP900 Comfort 

An overview of the supported HMI control panels is available in the Precondition (Page 115). 

Opening the library in WinCC V18 
The procedure for opening the library in WinCC Professional V18 is explained in the Content 
of the library for STEP 7 V18 (Page 73). 

Inserting faceplates into a project 
The following procedure describes how to integrate the faceplates from LUPS1600 into an 
existing WinCC project: 

1. Open the required project in "Project view". 

2. In the "Project tree", open the "Screens" folder. 
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3. Double click on "Add new screen" to add a new screen into your project. 

 
Open the new screen (Screen_1). 
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4. In the "Libraries" window, select "Global libraries > LUPS1600 > Types > LUPS1600 > WinCC > 
Comfort/Advanced > S7-1200/1500 > LUPS1600_FpS712001500RTAdv". 

 
5. Drag-and-drop "LUPS1600_FpS712001500RTAdv" into the opened screen in step 3. 
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Creating a connection to the data block for global data exchange 
The following procedure describes how to create a connection to the data block for global 
data exchange: 

1. In the "Libraries" window, select "Global libraries > LUPS1600 > Master copies > LUPS1600 > 
WinCC > Comfort/Advanced > TagTablesRTAdv > LUPS1600_TagTableS712001500RTAdv". 

 
 

  Note 
S7-300/400 PLC 

For S7-300/400 PLCs, select "LUPS1600_TagTableS7300400RTAdv" instead of 
"LUPS1600_TagTableS712001500RTAdv".  
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2. Drag-and-drop "LUPS1600_TagTableS712001500RTAdv" into the "HMI tags" folder in the 
"Project tree". 

 
3. Open "LUPS1600_TagTableS712001500RTAdv" in the "HMI tags" folder. 
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4. For the "UPS_Data" tag, set the global DB (UPS_Global) created in Procedure when using an 
S7-1200/1500 (Page 89) from the Program blocks. 

 
 

  Note 
For 300/400 PLCs, 
• For the "UPS_Data" tag, make sure: 

– the "Connection" is set to "HMI_Connection_1". 
– the global DB number in the "Address" column is set to 2. 
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5. Select the "UPS_Data" tag and go to "Properties > Properties > Settings" and make sure: 

– the "Acquisition mode" is set to "Cyclic continuous". 

– the "Acquisition cycle" value is set to "500 ms". 

 
6. In the "Project tree", open the screen with the inserted faceplate (Screen_1). 

7. Select the faceplate on the screen in the display area and go to "Properties > Interface > 
Data". 

8. Select the "UPS1600Data_S71200/1500" property and connect the "UPS_Data" tag in 
"LUPS1600_TagTableS712001500RTAdv" under the "Dynamization" column. 
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Connecting trends of the faceplate with data sources 
The following procedure describes how to connect the trends of the faceplate with data 
sources: 

1. In the "Project tree", open the screen with the inserted faceplate (Screen_1) 

2. Select the faceplate and go to "Properties > Interface > Trends". 

3. Select "Trends" and click on the marked area in the "Static value" column to open the 
settings for the trends of the UPS1600 module. 

 
The "Trend" window opens. 

4. In the "Trend" window, add five trends in the "Name" column. 

5. Set the "Trend value" to 600 to all the five trends. 

6. In the "Source settings" column, click the drop-down. "Data source" dialog box opens. 

7. For the "Process values" click on the highlighted area to navigate to the HMI tags and assign 
the following tags to each of the trends: 

– inputVolt 

– outputVolt 

– outputCur 

– batteryVolt 

– measuredChargeCur 
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8. Set the "Cyclic" value to 0.5. 

 
9. In the "Style" column, select the trend color for the individual trends according to the legend 

given below. 

 
10. In the "Side" column, select the value as "Right" to voltage tags and select the value as "Left" 

to current tags assigned for the trends in step 6. 
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Activating the alarms display 
1. In the "Project tree", double click on "Runtime settings" and select "Alarms". 

 
2. Check the options "S7 diagnostic alarms" and "With event text". 

 
 

 Note 

When configuring an S7-300/400 controller in TIA Portal, you also need to activate the S7 
diagnostic alarm on the controller side. 

Information on the display and configuration of diagnostic messages in WinCC TIA Portal is 
available under the entry ID 62121503 
(https://support.industry.siemens.com/cs/ww/en/view/62121503), see Chapter 3.2.2 
'Configuring CPU system diagnostic alarms', description 'Settings in STEP 7 Professional'. 

 

https://support.industry.siemens.com/cs/ww/en/view/62121503
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Configuring the alarms display 
1. In the "Libraries" window, select "Global libraries > LUPS1600 > Master copies > LUPS1600 > 

WinCC > Comfort/Advanced > AlarmWindows > LUPS1600_AlarmWindowsRTAdv". 
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2. In the "Project tree", select "Screen management" and open "Global screen". 
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3. Drag-and-drop "LUPS1600_AlarmWindowsRTAdv" into the global screen. 
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Configuring the alarms display call 
1. In the "Project tree", under the "HMI tags" folder open 

"LUPS1600_TagTableS712001500RTAdv". 

 
2. For the tags "alarmhistory" and "alarmpending", check if the assigned "Data type" is "Int" and 

the "Connection" is "Internal tag". 
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3. Select the "alarmpending" tag and go to "Properties > Events > Value change". Check the 
properties of the tag where in the "ShowAlarmWindow" function is inserted and its variable 
"Object name" is assigned to the tag "Alarmview_UPS_Pending". 

 
Similarly, check the properties of the tag "alarmhistory" where in the "ShowAlarmWindow" 
function is inserted and its variable "Object name" is assigned to the tag 
"Alarmview_UPS_History". 

4. Open the screen (Screen_1) and select the faceplate. Go to "Properties > Interface > Data". 

5. Assign the "alarmhistory" tag to "AlarmviewBuffer" element. 

 
6. Assign the "alarmpending" tag to "AlarmviewPending" element. 

 

 Note 

When using an S7-300 or S7-1200 CPU, no alarms are displayed on the HMI faceplate. Hence 
no messages are displayed in the "Alarm history" and "Alarm pending" window. 
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Displaying the PROFINET diagnostic messages 
To display the PROFINET diagnostic messages of the SITOP UPS1600 within the faceplate, the 
respective WinCC TIA Portal project must already be configured. 

Information on the display and configuration of diagnostic messages in WinCC TIA Portal is 
available under the entry ID 62121503 
(https://support.industry.siemens.com/cs/ww/en/view/62121503). 

Activation of the PROFINET diagnostic messages of the UPS1600 is found in the "Device view" 
of the UPS1600. 

 

Further notes regarding the PROFINET diagnostic messages of the SITOP UPS1600 is available 
in the chapter 4 of the SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415). 

https://support.industry.siemens.com/cs/ww/en/view/62121503
https://support.industry.siemens.com/cs/ww/en/view/84977415
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8.4 Application of screen windows in WinCC Unified Comfort 

8.4.1 Prerequisites 

Requirements 
The following requirements must be met to use the faceplates in WinCC Unified Comfort: 

• S7 communication between SITOP UPS1600 and SIMATIC S7 controller is already 
configured. 

• Program blocks for STEP 7 V18 from LUPS1600 are integrated into the application 
program and executable. 

• LUPS1600 is available on your computer. 

Supported control panels 
The faceplates are supported for the following control panels: 

• MTP700 Unified Comfort 

• MTP1000 Unified Comfort 

• MTP1200 Unified Comfort 

• MTP1500 Unified Comfort 

• MTP1900 Unified Comfort 

• MTP2200 Unified Comfort 

Supported languages 
The faceplates support the following languages: 

• English (USA) 

• German (Germany) 

• Chinese (PR China) 
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8.4.2 Library for WinCC Unified Comfort 

Library for WinCC Unified Comfort 
The following objects are part of LUPS1600 for WinCC Unified Comfort: 
 

Name Type Description 
Unified Comfort Faceplate from Types folder Comprises of "LUPS1600_Detailed" and 

"LUPS1600_Overview" faceplate  
TagTablesRTAdv Tag folder from Master copies Comprise of 

"LUPS1600_TagTableS712001500RTUni" 
TextLists Text lists folder form Master copies Comprise of "textListsUnified" 
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8.4.3 Integrating the faceplates 

Overview 
Hardware used: 

• TP900 Comfort 

An overview of the supported HMI control panels is available in the Precondition (Page 132). 

Opening the library in WinCC V18 
The procedure for opening the library in WinCC Professional V18 is explained in the Content 
of the library for STEP 7 V18 (Page 73). 

Inserting faceplates into a project 
The following procedure describes how to integrate the faceplates from LUPS1600 into an 
existing WinCC project: 

1. Open the required project in "Project view". 

2. In the "Project tree", open the "Screens" folder. 
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3. Double click on "Add new screen" to add a new screen into your project. 

 
Open the new screen (Screen_1). 
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4. In the "Libraries" window, select "Global libraries > LUPS1600 > Types > LUPS1600 > WinCC > 
Unified > S7-1200/1500 > Faceplates > LUPS1600_Overview". 

 
5. Drag-and-drop "LUPS1600_Overview" into the opened screen in step 3. 
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Creating a connection to the data block for global data exchange 
The following procedure describes how to create a connection to the data block for global 
data exchange: 

1. In the "Libraries" window, select "Global libraries > LUPS1600 > Master copies > LUPS1600 > 
WinCC > Unified > TagTablesRTUni > LUPS1600_TagTableS712001500RTUni". 
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2. Drag-and-drop "LUPS1600_TagTableS712001500RTUni" into the "HMI tags" folder in the 
"Project tree". 

 
3. Open "LUPS1600_TagTableS712001500RTUni" in the "HMI tags" folder. 

4. For the "UPS_Data" tag, set the global DB (UPS) created in Procedure when using an 
S7-1200/1500 (Page 89) from the Program blocks. 
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5. Select the "UPS_Data" tag and go to "Properties > Properties > Settings" and make sure the 
"Acquisition cycle" value is set to "T500 ms". 

 
6. In the "Project tree", open the screen with the inserted faceplate (Screen_1). 

7. Select the faceplate on the screen in the display area and go to "Properties > Properties > 
Interface > UPS_Data" and connect the "UPS_Data" tag in 
"LUPS1600_TagTableS712001500RTUni" 
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8. In the "Libraries" window, navigate to "Global libraries > LUPS1600 > Master copies > 
LUPS1600 > WinCC > Unified > TextLists" and select "textListsUnified". 

 
9. In the "Project tree", under the "HMI_1 [MTP1000 Unified Comfort]" folder, select and open 

"Text and graphic lists". 
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10. Drag-and-drop the "textListsUnified" from the "Libraries" window into "Text and graphic lists" 
under "Project tree". 
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11. In the "Project tree", under the "Screens" folder, select and open your screen. 

12. Select the screen, under the "Properties" tab, set the "Static value" for the text list. 

 
Similarly add the Static value for other text lists. 
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8.5 Application of screen windows in WinCC Professional V18 

8.5.1 Prerequisites 

Requirements 
The following requirements must be met to use the screen windows in WinCC Professional 
V18: 

• S7 communication between the SITOP UPS1600 and SIMATIC S7 controller is already 
configured. 

• All program blocks for STEP 7 V18 from LUPS1600 are integrated into the application 
program and executable. 

• LUPS1600 is available on your computer. 

Supported control panels 
The screen windows are supported for the following control panels: 

• WinCC RT Professional V18 

Supported languages 
The screen windows support the following languages: 

• English (USA) 

• German (Germany) 

• Chinese (PR China) 
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8.5.2 Library for WinCC Professional 

Library for WinCC Professional 
The following objects are part of the master copy "UPS1600 TIA Library > UPS1600 Wincc > 
Screens > Professional > ScreensRTProf" in LUPS1600: 
 
Name Type Description 
LUPS1600_ScrnWndwRTProf Screen window Comprises the screen window 
LUPS1600_ScrnRTProf Screen Comprises the screen 'LUPS1600_ScrnRTProf' 

8.5.3 Integrating the screen windows 

Overview 
The following sections describe all the steps required to integrate the screen windows into a 
WinCC Professional V18 project: 

Target system used: 

• WinCC RT Professional V18 

Opening the library in WinCC V18 
The procedure for opening the library in WinCC Professional V18 is explained in the Content 
of the library for STEP 7 V18 (Page 73). 
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Inserting HMI tag table in WinCC 
The following procedure describes how to insert HMI tag table into the WinCC project: 

1. In the "Libraries" window, select "Global libraries > LUPS1600 > Master copies > LUPS1600 > 
WinCC > Professional > TagTablesRTProf > LUPS1600_TagTableS712001500RTProf". 

 
 

  Note 
S7-300/400 PLCs 

For S7-300/400 PLCs, select "LUPS1600_TagTableS7300400RTProf". 
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2. Drag-and-drop "LUPS1600_TagTableS712001500RTProf" into the "HMI tags" folder in the 
"Project tree". 
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Configuring connections of HMI tag table 
The following procedure describes how to configure connections of HMI tag table: 

1. In the "Project tree", select "HMI tags > LUPS1600_TagTableS712001500RTProf" and open 
the tag table. 

 
2. For the "UPS_Data" tag, set the global DB (UPS_Global) created in Procedure when using an 

S7-1200/1500 (Page 89) from the Program blocks. 
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  Note 

For 300/400 PLCs, 
• For the "UPS_Data" tag, make sure: 

– the "Connection" is set to "HMI_Connection_1". 
– the global DB number in the "Address" column is set to 2. 
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Inserting screen windows into a project 
The following procedure describes how to integrate a screen from the library into an existing 
WinCC project: 

1. Open the project in "Project view". 

2. In the "Libraries" window, select "Global libraries > LUPS1600 > Master copies > LUPS1600 > 
WinCC > Professional > ScreensRTProf > LUPS1600_ScrnRTProf". 
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3. In the "Project tree", open the "Screens" folder of the HMI used in the project. 

4. Drag-and-drop "LUPS1600_ScrnRTProf" into the "Screens" folder. 
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Integrating screen windows into a project 
The following procedure describes how to integrate the screen window from the library into 
an existing WinCC project: 

1. In the "Project tree", open the screen into which you want to insert the screen windows 
(Screen_1). 

 
2. In the "Libraries" window, select "Global libraries > LUPS1600 > Master copies > LUPS1600 > 

WinCC > Professional > ScreensRTProf > LUPS1600_ScrnWndwRTProf". 
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3. Drag-and-drop "LUPS1600_ScrnWndwRTProf" to the screen. 

 
4. Select the screen window and go to "Properties > Properties > General". 

Assign "Tag prefix" variable with the "UPS_Data" tag present in 
"LUPS1600_TagTableS712001500RTProf" folder. 
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Displaying the PROFINET diagnostic messages 
To display the PROFINET diagnostic messages of the UPS1600 within the screen windows, the 
respective WinCC TIA Portal project must already be configured. 

Information on the display and configuration of diagnostic messages in WinCC TIA Portal is 
available under the entry ID: 62121503 
(https://support.industry.siemens.com/cs/ww/en/view/62121503). 

The activation of the PROFINET diagnostic messages of the UPS1600 is found in the "Device 
view" of the UPS1600. 

 

https://support.industry.siemens.com/cs/ww/en/view/62121503
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 Note 
• When configuring an S7-300/400 controller in TIA Portal, you also need to activate the S7 

diagnostic alarm on the controller side. 
• Information on the display and configuration of diagnostic messages in WinCC TIA Portal is 

available under the entry ID 62121503, see Chapter 3.2.2 'Configuring CPU system 
diagnostic alarms', description 'Settings in STEP 7 Professional'. 

• There can be differences regarding the S7-1200 diagnosis with respect to the S7-1500. 
 

Further notes regarding the PROFINET diagnostic messages of the SITOP UPS1600 are 
available in the chapter 4 of the SITOP UPS1600 User Manual 
(https://support.industry.siemens.com/cs/ww/en/view/84977415). 

https://support.industry.siemens.com/cs/ww/en/view/84977415
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