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2. BAFKERER

2.1. S7-CFC &/t
S7-CFC (Continuous Function Chart #ZETHRERIZR) EA LU FE: &
&I g T AR IR K H B A R T
< A SRR I TIHIRE P, RIS AT {3 STEPT o () bt Bk
e AT P 1 i 2 R PG T R AR I D i 1
MACEE R AESTEPT 1, 5STEPT %
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S7-CFC A{ULHA PLC SMIELER (Filln A /Hid, S8, T, #5523, mA

AH BRI S5 R, HIEE & T TS
> R
> RGELIE

2.2. CFC 5 SCL X% STL:

CFC £x/E Rl SCL ARAY, 24 STL. HARKLEAIXF T STL 4afeqa pridhn.
2.3. CFC Hj=E 5 H:

STEP7 ZANRA I HAMLIE CFC A MR, TSI . — MUl T, 16 S7 fFh, S7-
CFC &HZVBATH, JiFH e IS A M. o thnl LT B shgn S5 8or T S7-CFC [IfE
e, BT R A R, AE P 2 R SR R I
2.4. ST-CFC A1
ANF] ST-CFC B AhiuA 5 STEPT R R G A A ME: BIPE) X RRFE, - RnAHE

CFC STEP 7 V5.3 STEP 7 V5.4

Product Name | Version | Order Number Win | Win XP| Win XP | Win | Win XP|Win XP| Win Win
2000 SP1 SP: | X000 | SP1 SP2 2003 | 2003
SP4 SP4 SP1

CFC V7.0 6EST 638—1EX07-2YAS| X X X X X X X X

CFC Ve.1 6EST 638—1EX16-2YAS | X X XL b4 X XL X1 -

CFC Vo.0 6EST 638—1EX06-2YAD| X X X X X X - —

CFC V3.2 6EST 8130CC05-0YX0| X - - =) - - - —

% 2-1 S7-CFC At 3tk
¥ 1) YA S7-CFC V6.1+SP1 B DL G RA ST 45

2.5. S7-CFC I 3CIRVCXT R R
H TR 2 980 (R A R B B G — (0 T SR, T DATE A SC kg ofr, R R
FA A SCAE B o AR SO R D P SR AR S A, AR AR I P iR

X RUWT
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o Nested Charts REE®
e Sheet Bar ik
e 0S A Gk

e AS Bzl (g



3. ST-CFC EAMEE5EAMEH

3.1. S7-CFC BRIt ER

VBN STEPT ik Wi, S7-CFCHRIFAERELSE, Wk ERAE STEPT i H]. S7-CFC Zwfs i
NETESE, W& A Chart. FF7E Chart s U7 BN D abil i (fdk,  $i 52 X 2
ZIARERSC R, AT OIS Tl A bk o 7ERE S R T TR 7 25 BT H
G5 JE, RVATRIEIH . S7-CFC FR PR pl #e kg e, LB B AT LLLL SCL ARSI aCHE L (3
2R STLARES ) . FH P BRI R 3 3 PLC th BI AT $04T . 7 AT BLFS 5 3 e R 5 38 47 IR
7 I AT R .
3.1.1. Charts (E#)

VBN STEPT Wik Wi, S7-CFC #IT1ELE)E, WAEMAE STEPT i H. S7-CFC Zwik FtiH
NE G, HIEAITLE N Chart, F4 Chart /£ CPU H 4 FH#2EME—f). 7 LLYE SIMATIC
Manger £ CFC %% % 11 4= Bl Chart.
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GRAPH source

1] | CFC

Kl 3-1:4E Bl ST-CFC 27
Wit CFCHEF, FEF O RN T CFC A T Charts SC{h9% ) CFC Chart. 7] LL
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3.1.2. Chart Partitions (BE4X)
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3.1.5. Nested Charts (FREEZX)

FE—A Chart F ] DURA J34b—> Chart, F1 /7 AT LAFEE 1t Chart (U A/t SOEREC R, 184
JHERT LS Ja SE B I VEAN 4
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3.2.2. BEFBRMBERSE

R A ONAE CFC 4ifE I A AE AL B, W L@ IE Clean Up.. #2HIRIEER#E CFC g



REIE AR fIEk (CRC 2R rh 51 FIRI R TCIETERR) -

EI
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3.3.1. HEBEXNG)EH

JHP AT LA IS A e e D REB, 1B #% Object Properties-General, A BRKJEME. XL &P LL
BUE L2

= Name HTEREANEIRFAIME—IILHR, AR (K 16 NERF) Kbl BoRTEH L3

= Operator C and M possible (OCM Possible) 4IfH 75 S L ThREBRAEWE 4 0S IE AR Sk 4%
#, AL, IX Ak AT S << Operator Control and Monitoring”?““Messages””
Y240 K2 <“block icon””#ii AHE.

= Operator Control and Monitoring Ut4ZSHREHT T — AN omWib L4ai N /i R B s HR /425 )
(RXTEAE,  FH R PAE BB AR WinCC A i) JE 1k

= block icon # Wit/ F il fIH AT LAAE WinCC A LA AR RIE R~ F P i] AYE DR 2 T i
R EIFF -

» Messages MAZHIMEHT I —ANHAW B UEHE, AT LAZE b 483 B4, HacAmT L
T A1 B MIS/MES & HLR .

3.3.2. BEBMNEHHHEE

WUERAE P B W AR, [RIER SRR %N, i1 NAND, OR %545, I/ n] LA id fi f]
"Edit >Number of 1/Os..." iy & R S A HO . FEDYE . AND Dhfig e N i) S i,
BRI NECR A 2, BN 120,

x|

Block: CFC[1]s5
Type: AMD

Mumber: IE [2..120]

Cancel | Help |
& 3-11: X AND ZhfigHem N $ &
3.4. BEEN/ R E
F P AT ALE BRI & Mo i AE A AN A=, BE IHB OO E N g, el UL
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Properties - Block -- CFC{1)43

General  Inputs/Outputs |

# |Mame 1/0 | Type |¥alue|Comment | Invizible | Watched |Identifier |Unit |Text 0| Text 1 | Parameter | Signal
1 |EM IM |BOOL |1 | | L_| L
2 |ManN_0On IM |BOOL Select: 1= || | | Ll
3 |PYPER_OM |IN |BOOL |0 Enable: 1... || L_| L
4 |P_SEL IM |BOOL |1 1=Proparti... | | | | L_| |
5 |I_SEL IM |BOOL |1 Enable: 1... | | || || |
E |INT_HOLD |IN |BOOL |0 Integral & | | | | Ll L
7 O |{IITL_OM  |IN |BOOL (0 Initiglize: In... L | 2] L_| L
g8 |D_SEL IM |BOOL |1 1=Derivati.. L | | | L_| L
9 |SAMFLE_T |IN |REA&L (1.0 Sample Ti... | | L_| |
10 [SP_INT IN  |REAL Internal ge. . L | |
11 [P IN IN |REAL Process ... L | L | |
Kl 3-12: Hed A/ B JE 1

. # N B S

= Name N ) AR

= Value FH P AT DAAE I 15 B AR B ) (B

» Invisible  WURA AR E B RHAMHATE, W ATEEE I, XRE ] DL E )

ETZAPNGN

= Watched AR P BB EE

= Identifier 7] DLE /AR BOOL 2R AR B HYARIN, BEARIASCACKAH T-1E 0S iR

= Text0 X BOOL ZRAVAR &, MHH 0 i, AFERICA, #lun: Close

= Textl XFF BOOL ZRAVAR &, H{H A 1 W, AT ERISCA, #lin: Open

» Parameter  WURMFABEWAAEERNSE, AT, R0 H A

= Signal R P ABENREENES, RS, HRERA TIEECR

3.4.1. BUR—MREFIA

X B BOOL SRALMIHA, S7-CFC F2M T UK IIAE. F ™ n] DAXLEE BOOL fAAFR)E, £
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o ST RN B R AT DU, PR e I —AN NOT  BSiefif peax — i B,
3.4.2. FERABUERR
S7-CFC #&t VBB IRThAE . M 2 L VA FREE 2 bsii)E, BIRffER. an FEF

FINAZE IN_BOOL, Al A LLSE SCH M NEE <07 i Bor<“close”? M ANKE A =<17 "I BoR
““open”? HI'F BRI AT E IN_WORD, FH 7 AT LLE U AKEUE J9< <277 I 7R ©<in1234567 2

7
FCa0

inlz3456—IN WOLRD
closze—IN EOOL

K 3-14: HIPE SRR R R
A FE LAD/STL 4nfediBs N4 FB/ZFC B, StTFHAASEENE, Pl AR InEdEbs
. Ty FC60 Y BOOL KAV ASHH @ MBI S T . X~ BOOL f AN, SV 2 BiE L
LA FE"ST_string_0" K "S7_string_1".

|Hale Data Type |Cullent
= IN_WORD Word

[0 [
x|

Generall Information  Attibutes |

Attribute Value =
ST_string_ 0 cloze

ST_atring_1

3T_edit
ST_enum
3T_link
3T_measwal

ST param
!ST wizible ~
K] 3-15: BOOL % \Z%g 1t
M E LAD/STL 4mfedfitss R4k FB/FC B, XTTHEASEHEM, F) el LRI iEss

iH. FEA FC60 1) WORD SRV NS B A S T . %I+ BYTE, INT, DINT, WORD, DWORD %
NRM, VRIS HEE B NN ST_string_2" ZE"S7_string_25".

Oper

/ [r 4
;
M
|

= | onf e oo ral —

|
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|Ha.l_e Data Type Comment
= |II'I_WORD

= IN_BOOL Bool

Yariable Properties x|

Generall Information  Attnibutes I

Attribute Yalue t

ST _straing 2 inl23456

ST _string 3 in2348aT

a | A o oon] e cal o —

| | o

K] 3-16: WORD ¥ N Z ¥ 1t

I

= "S7_string_0" J "S7_string_1"T] LLHF BOOL gAY, A LU~ K 16 N FRFIISCAR

= "S7_string_2" %"S7_string_25"T] LLAF BYTE,INT, DINT, WORD, DWORD #i AAL, w]
PINECK 8 NERFIISCA

= "S7_enum" o ACZSEIEEA, EEHT PCS7 o, HAEFHMIAUE E X EAE Configuring
enumerations H5E . W LALAF BOOL, BYTE, INT, DINT, WORD, DWORD #i A%, wf
PUARK 16 DNFRFSCA . Hal A "S7_string 0" %"S7_string 25" [I{EH, BT
HFFAT PCST o, MM TACHEMERE, AR HIELN2H.

3.4.3. & X BHEIARY

H.#5 archiving 1 long_term archive (/)75 &4 75 4w % OS I [ 3h4: il A RS 28 &

= "No archiving" (S7_archive:= "false")#i A\ /% A2l 9y

= "Archiving" (S7_archive:= "shortterm®) 7E 0S %5 #3944

= "Long-term archiving" (S7_archive:= 'longterm’) 7&JAF4 AR %5 a5 KIHARY, FF HAZM%7E CD,

DVD, MOD, %55,

Firfr Hoa% ooM Cn] DL ML R 42D R PR #dE (Bde 8%y BOOL, BYTE, WORD, DWORD,
INT, DINT % REAL) #BwJ A%EA#Y.
3.5. Interconnections (G&E#XR)

1E—A™ CFC ] Chart #1, —“ Interconnections GER:EZR) 1] LLiERE::
= — block/chart B%H S5 AHE BB /) block/chart B—NELZ AN, WA SHH
(B 2R A A 25— 3



= —/> block % H 5 —4 run-time group ({¥ BOOL ##E5%)

= —> chart W block HI%A/fii i 5 chart B/t

= —/~block M4 5 CFC MR, #ilndt==thht

MR BAE Chart o, Zef i N /g 1, R bR, EFR e e
I _ETTRATERRbRAC B, RS8R TR R K RINIRAE

F4h, AP T U A B A SRS block A/, HE S HENRERLR, W
FEFR GERE: AEmABGEHE, SRAEERARD.

1—1
1— &N Inkerconnection to Address... F3

Inkerconneckion ko Runkime Group. ..

Interconnection to Chart I,

Delete Interconneckionis) Dl

Jump From Sheet Bar

Insert in Dynamic Display

Chbject Properties. .. Alk+Return

K 3-17: H&BERERZR

3.5.1. 53tk

M PR AS B R 1E$E T ““ Interconnection to Address...?7 )5, BIAIDLZIA L= H
R, Bltn. FLEEGEDL, 1/0 55, A, et iHEEE. A DL N RIS 2 bk
Hb, R AT AhE, kb O EFESR TS block H% N /g K e 2R T B,

MO.0 1
AND

MO.1

K] 3-18: HAIL=HbEER:
3.5.2. 5 Run-Time Groups HKJi#E#

P AT DS A GE sz 1. B P ml LK —> Block F% HiERE#]—4> Run-Time Group, iX
FERU AT DA H HE BT . X ME IR, Run-Time Group J&PE<<Active”” {)i%k B¥ Ry &,

B CFC(Z)
—{anD ENAELE ({0OEL}

K] 3-19: 417 Run-Time Groups &

3.5.3. XA&EE

I AT LU — /> block/chart % N 4135 SCA &, MIEHIR R CFC F 1 74— 4



block/chart [t . Wi PN BB RN IER (104 HARAAALE, RBUARILED ik
BT CATIR” BERES, ks RETEAARAE AN — A HIE R ER:.

G P A DA R AN R NE L, IR < “Textual Interconnection...”” )5, BIW]
DA SOARER:. HA%zUA: (chart\block.1/0), WS ER: K RIEH, CFC H3ITE U RHER .
Bilan N B NSO CFC (UNL.ERR, BEHC RSLFRAN CFC (1) (AL)\1.ERR (R CFC(1)
[ Sheet A, Sheet A 16 NMXIRAXIL 1, g5 H 1, Hith BRI ERR).

- CFC{1) (A1)31
M%E%%§E\:::=’i]iim =5m
i, CFC H#hT o N— |
s J x

Textual interconnection;
- |eFChpERR

Chart=CFC(1)
Block=Hgm 5 A4 1
Lﬁﬂzu=ERR Lings] J

|

Cancel | Help |

K 3-20: HE A ER
WHRAPFHNT —MERECARER, WRASKHERHEOH =M ERR, B2 8 SOE
Ak

HHR R

CFC(1) (a1)h1
ERE,

P
cFC i1y al]

B 3-21: AR SOARIERE
3.5.4. HEBIELE M B ZEE

WA RS, P DDA R BT B — N R, IR HE SO —A block (1
N/t o 7€ Block MR Rl sy, — ANSIa — AN/ f ik, BiEEAh<<sT?
—AMEMTTLEREZ N 0ER RKRERE N 8 2):
o JEARHEIA (BOOL, WORD...)

o 4y

— AR TNME R
o HUEIRM CEAKHEIA, HNN<ST™)
o MK

o Bl (MUEEALHEIEMAI
B



—> block Z5HZRAIRAN i WA AT A 55— AN EE e AR, AN AT DL S B AR R4 S Y
B EERNSERD B, OIS AN EAREAE R, Ny, AFR, #E8, H4h
TR B A4 FR AT AAS TR o 2 A P () 2 AR T8 AN P DA 5 g — N 5 1R o) R B A e R AT R 42,
SER AR T DUE Bk 5 e S R AE #
=tk g

—> block Z5HZRAIRHN i tH AN T LS — N e AR AT &R (DBx) , HrTBL 5 Hdf ik
RS — BRI S5 M AR TERE (DBx.name_st). 5 ZAHIMAL, X THAYHERA, H W LIS HEE
P i3 — B TR AHESRE (DBx.element).,

3.6. BATHS[A] J@ 1

PRI AT R B R U E T AR CPU 2544 RS AT T MbJE e 7 — N BAR RGN
Wi SEAS TR, BEIXIS [E), DA R S I AR SR RGE A e . %A block #Ad AN, RGEHIR T H
BRI RIS AT I [ 12k

3.6.1. HREIBATI[A] @ %

BR RIS AT IR 8] J& P LUt SRR

E
Q = —
| R 5 i MHSCALE
Th=scalin

1/5 F£oR
runtime group

A 54

IN LET T&L] e, XA
100.0—HI LIM OuUT A
0. ol FHE—NE
0—|BIPOLAR

K 3-22: Hpis T H] JE P
3.6.2. CPU Wjiz4TH 8] J@ 1

F P A] DL i 3% < “Edit>Run Sequence...” P)#: 4% run-time editor . ZEMLATE R, /AL
E CPU HyigfThf @t UMbt ~or N =)Z45#): {£5%/runtime group/block. FH /I LLETFME
X5 2 H SOk E B BATH iz 47 R @M.t ] PLEFEIHEAS runtime group/block J&, i F A
FEPLI 5 R AR H BT E AT 55 /runtime group H R



&, CFC - [Runtime editor -- book_CFC\SIMATIC 400({1)}CPU 414-2 DP'...]

-E Chart Edit Insert CPU Debug Miew Options Window Help

D 2| %[5 [ =)= 2] el 8] =]
= T CYC_INTS [Cyclic Interrupt « | | Gptents of 'OB14C... | Type | Pos
- (6 cFei) T\
|:—:|---- OB1 [FZ Free cydle] ﬂ- FIS(2)1 AR 1)1
=& ';’Eﬁi?l' F cecidveroiyt amp 12
o CRC(Z 5
e I croiencrcin t)]?ﬁ%eﬁdilt?ourntlme
(=
B eer 1, Block FJ run-
- [0 CFars) ~ Runtime group ] time J& 1%k editor
- [ <roi3) ¢
...... OB10 [Time-of-day interrup ‘Jiugéggﬁgg?gg]
[+ ¥ OB100 [Warm restart]

K 3-23: CPU fJiz 47 TR] J&@ 1tk

3.6.3. ARk Runtime Group

Y P A S T REAMESS S, B3 “Insert Runtime Group...” J&, A LAVSHIIETH Runtime
Group, 74k, MM P {E S7program/charts H3g FHEA—ANETH CFC f2/7H, RGN EIA{E OB35
FR AR AN Runtime Group. #0153 P R BE 24 chart (946 N\ 55, TP BIEEds N chart #0646 1
OB35 i) Runtime Group #1. WIS H 7 A EBAE L EAR S A BT chart, wfDLEFEILAES (4]
i OB1), JFfi$E““Predecessor for the Next Chart Insertion...”, |24 7 7% S7program/charts H 3%~
AN —HTH) CFC RPN, ik chart X7 2 4 §ifE 55 AL & filan (OBL).

&5 CFC - [Runtime editor - book_CFCYSIMATIC 400(1)4CPU 414-2 DPY...]
-E Chart Edit Insert CPI0 Debug View Options ‘Window Help

w2 =] WA B R =] ] M RN = R

ERRE -C_IMTS [Cyclic Interrupt 5 | | contents of 'cvc 1., | Tvoe
|:| CFC(1) (i

|:—:|---- DBl [FZ Free cycle] ':':'p""' WA P A ENR Cri+C
A [ Foi) Faste | chart ARG E, T S
- [ CFC(2) Find. .. PAYE I EX ChrleF
|:| CFCiE)

- [ <FoiaE)
...... OB10 [Time-of-day interrupt

Eel-- OBL00 Divarm restart] Predecessor For the Mext Chart IrTéertin:nn Shift+F11
------ ©E101 [Hot restart]

...... ©OB102 [Cold restart] (G b Chiart

...... OB11 [Time-of-day inkerrupt SEC External Wiew

______ OB12 [Time-of-day interrupt  ODiect Properties. .. Ale-Return

K] 3-24: 7N Runtime Group A 2%



3.6.4. Runtime Group KB

B E A RS runtime group JE, GERREENE, RTRUE BIQ0R A, HP T
HE R

x
Tazk: CvC_INTS
M arne;
Cormment: I
Scan rate: |1
Phase offzet: IEI
O phimize run sequence v
Active: v

Cancel | Help |

& 3-25: runtime group iz 4T A& 1%

e Scan rate: W& MESHEIATH, runtime group EEAEREMES AT R, LA
W AMES R BT . BUETE e 3t 16 M TR, 20, 20, 2%, . 2%,
0. 0B33 MIHAT AN 500 ms, JIATHEY scan rate ~N: 1s, 2s, 4s, 8s, 16s .
e Phase offset: #EJEM: KTET 0, /NTATIESR Scan rate. f7lil: 0B33 FIHAT
JEHAA 500 ms, Scan rate S 16,Phase offset & 3, it runtime group 447 KM
[d]°) 1.5s; 9.5s; 17.58 2%%,
o Active: /7 HTLLHRE £ EUELL runtime group
3.7. fwix
F P L chart 4midN— MEFEE —A FB. BRIMENL T, chart Kz — MR .
CFC {4 FH ) 9m 1454 SCL.

3.7.1. % chart wFENEF

FH P A] DL IS 32 84 < <Chart > Compile > Charts as Program...” #EAT2w 6, B0 B sk T AR
B 4 PE BB R e AR
% PRI, CFC AR R 88159 FC M DB.
TR FC IS
o T/MEMM OB FHE—AFC

e 4/ Runtime Group FH%—/>FC



A K DB RS L
o WENEA FB I S A A R — > DB
o NTRAFREAS FC PRI ZE 5L, 75 B CFC A &T DB, SRl it 28 A 7 38— DB, 243L
ISR KK EER (4 Kbytes), FEINEI) DB

VER. RGBS i R k< “Make Textual Interconnections?”’ iXSLiZEfiA
SR AR R E . XSS I 2 B0k 1 F BRI A .

3.7.2. ¥% chart 8%~ FB

FH AT DL TS 2% #< “Chart > Compile > Charts as Block Type...” ¥ chart 4% % ~A—1> FB.

Compile chart as block type - 5!

General I Attributes |

book_ CFCASIMATIC 40001 MCPU 414-2 DPASY Program(2)4Blocks
. (FB %= ) .
— Properties of Block Tupe L, | — Cormpile for CPL

FE number: |1V 57300 PN
N [F 7 am

% 57 400 .
Symbolic name; RNk

|

Project path:

Mame [header]: — Optimize Code for

i | ocal data requirements

" Downloading changes in RUN
Avthar:

|
|
Farily: I
l
|

Wersion [header]: [ Know-how pratected

& 3-26: runtime group iZ4TIN [a] &
Compile for CPU
H1F- S7 300 / S7 400 #iA5 AR R Zh 0B, i DAL AR PR 08 FKs 2 fak 25 196 A2 A FB AR AN o
Optimize code for (AL R)
- Local data requirements: (ASHiMEREER)
BB chart i, XMARREOLALTT sCANE I A s Bl HERR O 75 5K o T A i i A8 B
Wit T S BEE T (VAR X380, SR HI Bk chart I, A5S80S
BRI A, BRIk, P ek S AE 2 sl T3k
- Download changes in RUN
HH B chart I, XA AE AL T ORI I A2 B 4R A7 T VAR_TEMP X3 . T
VAR_TEMP #5341} CPU AUA BB HER o IXFE 4 7 BB chart I, A& S 20 SR Bun )



PRI A . Bk, FIPEZHUR LT W BLSR B BIUT TG (R 7 iR R sk 2 1 n
T AR R HE AR B T K

Know-how protection
P RELTIR, AXAN 2 SCL Y SCAFAAERT, AR BRI AT AR S BT

3.8. T#HFPFEFZBERRA

T CFC A7, T CFC mILARIE AS(HHIAe) - & s —8E, AU P 2ifd
CFC ffas THAEFEHAR RS, X TEHl/ N8R Lk Blocks SCIF 1 blocks 2 £E £k Sk 14
T, BARVFR . WERMPRERFIGERAATE WM E, KGR 34T B R A .

3.8.1. T&R7=EEERF (Entire program)

FH ] BAZE CPU 4bF STOP 5 RUN-P #550F, #E4T F#5e#F2F (Entire program) #1E. 7E
P e SR 5 HEHEfS, CPU AT B i b, U3 STOP #ix. £ NG, R4
WiEsH A 2538 CPU.

3.8.2. (X FHRHE (Changes only)

M ATEAE CPU 46T RUN-P #5230, #EATAU T3 (Changes only) #:fF. Jy T Bjik CPU
HBEN STOP RAS, RGUKIHHT — RV A . (HIEMIR CPU B e Aatiks] STOP . 1T H +
AEAER A — 3B 6L R, Bk T Change only T3k,

ERFE:

o HITRAHENLH AT REAT OO T B AR A
> M EDPATIE IR ERE T
> THOAE NHE RSN

e {ECFCHJ““Options>Customize>Compile/Download...”” 5+, 2L 7 ““Compress™~iL I,
NSRS T IR, W AT ACPUR 4 S Al ANR], AR gwiIERT, CFCKE H4iFC/DBH) J
SYUHE, B JCIAAEREAT AN i3 (Changes onlly) #:4E.

o TFEGEBMEFIFAEWE EgmFEBESF, WRERFCAHmFEIg N3 7 erPurth, FRT
PLFATA R84 2s (Changes only) #:1E

o P AILABEEHIFFEE (changes only or entire program) , BER{EARFZMH AR
PLFATAL F#22s (Changes onlly) F#/E

o R —MUTEH KA (Changes only) FIERVESRI, Ay PLEE B2l N ER x4y

o WIRFFNAR TR, JHARE RGBPLCSIME TR, B85 AN AT DR CPU L
HEATAU R 32442 (Changes only) FU#RAE.



3.8.3. BjIE CPU # A STOP RE

FEG RSN EERIERS, RGO IEAT — R — FMER A KBy 1HCPUTE ) 1E N STOPIR S .
9 1%
o HHATALIEILE I R TIARAE ) — B A A
o RO TR A M A HEAR 5 BT A CPUBIT IS A B IRAR XS L, o SR8 i i 7E
(Options > Customize > Compilation) 115 E A {E SCPUBT IR 1100%, I/~ — A~

P o}
= o

o MEMERE, WAGEL, WiTIEmFEFHRE.

o fufrOB, PRI IHARIFCOERCFCA R, 3 NPKRHRE .

o TEMIEZ G, RMASTIEEME RS, JFS5CPURVFR BB E ST BUE RS B, ik
HFH 1 E (Options > Customize > Compilation) 15 H{E BCPUZE IS 1 100%, Ij=
=N

JIT A P 5 30 SRR b L R B T B A
T

o FHATEIRIE U KON T BRI — Btk R A

o KA TR E AR ORA U HEAR IT S5 AEZRCPUIT I B UEAH T LG, dan SR8 H - 42
(Options > Customize > Compilation) A& FIHAE N, WP~ —AVEd  dniiE
CPUE IR f1100%, JUERIH F#Kk.

o Ky FEEMAEME A . Qo FEE HCPUBTIRI100%, IHGH T4, i@ P4 (Options >
Customize > Compilation) i@ FIEEN], WIF=A—AEd, H9Em =R /EiL .
> JE4HCPUNAF compress the CPU memory
> B EE 4k s N E (BH/EH T B4 skip compression and continue the

download (responsibility of the user)
> HUH F#kcancel the download

o AL HICPUBEUEFI100%, JU/HIH 4.

KR Z N (Type import)

2 AN R R I 1) bR A5 2 7 HARAT AN R RSN, 2R 0K 588 A b Bl 23 I B R ATE
AT DAZESE SRt . R SRT S, A s  HE T e oV E BT

fl4n: FB6L M FBA6, X NHAREH S AEW)E, M FB46 (1) FB202 r R BTAH BT,
FB202 W] REZxvjiMfEBud 4. LA P nl LU Id 2 < Options > Chart Reference Data...>
Block Call Hierarchy”; SREFKAHNMIHHMZIR, FH-ZAMBRIH,
SE#/#3) (Copying/moving)

P/ 8) 2 B R D RE PN, 7RI I BT A



. RFEH P EESR (Include user data blocks)
MRS, AR AR TR, CFC X ek A1 1 B ks i 2 1 2 R R0 A 3

o UNHLBIAINE N AR AN R AR, W EA TR R
o UNHAE ST program CAFIE FAAELE, PR CPU Hh ) H s B
ME PRI, W RE TR R, U CFC DX 3 A ) AR Bk e BE G R0 b
o UIREHRILAE ST program S FAEAE, (HAE CPUHANAELE, FHCK AL, IFRE.
o UNHAE ST program UM FAMEAE, {H CPU dfEAESE B, W ARSI, W R Bem Bt
IR, RGEMHIRE, F Ll Ao R .
3.9. [E[3k Chart

3.9.1. L HEFE Modified Data

MBI chart 280 OS B E Itk iE s, A~ v Ld i Al (read back) CFC charts
F 77 TR AR X S S H B -

3.9.2. [H]3E Reading Back

F P AT Ll 3 i< “Chart > Read Back.... >~ M EIEIhAE, Wid A ik <“Program on
the CPU™”{EREHRIE, W CPU Hh 47 (B K 284k (1152 3] chart SCfFJr,

FANH A LLEE SIMATIC Manager F<<Upload””#r4, st Lk CPU di%E, ik
BB I Bhi, HH 7 CRC IRl A i At n] LA < “Program Offline”” fE 4R 5

PAERAE LU T, F P ST DL B2 15 [l 5 i SR IT A A S8, B U S B B & R 4t
J& 1 <<operator control and monitoring (S7_m_c:="true®)?”HIZ%, =i AA BB MRS
#1(S7_read_back := "true").

i

CPU CFU 414-2 DF
Program:  SIMATIC 40001 5CPU 414-2 DPYSY Pragraml2]

After reading back, the entire program will be compiled. Howewver, it i ztill
pozzible to download changes without switching the CPU to STOF mode.

Source Scope
™ Program offline &l parameters
{*' Program on the CFU ' [CHM-capable parameters

Cancel Help

P 3-27: [Alis Reading Back

3.9.3. [HEZ )5

N T PRIE—tE, EREEEREIEE, B REE S BRI XA ERE R TR,



PR DU ATAL S 8 4 . Rl E 2 J5, F P ml LA IS S < “Options > Logs > Read
Back”; SKREBITLE 1/0 #lnlik, PAJAH AT &A1 B
HEEFE:

3.10.

AL Inout, input ZEAT DA [EIEE Coutput ZEATT LD

MEEE, ZERAIANY, ARRAY, POINTER, UDT #:Zm

it SFCAT LU AR ) Input 3 B £ 4 [l 52

G ARCPURP A B S E i, JF BRI, XEBSINBUES AR ENCE T E, HH I
B ZECPUR, X S H(E A FEE A

[l AT DASE B e A e (I nBATCHEY) |, XM AL ~ R4t J8 1:S7_read_back :="false"
XF H CPUs, IR H CPUALT-solofis, Hf HBLEFEXSIEHE, FI Al LU R E ICPU, 4N
RCPUAL T TURMES,  BEXTEHEA i B

UBATREAT T BERAER, AT TAENAFR SR S BER BN A I BdRE E & . iR
FE MBS Z AT 1 ISR, I n] DU R 58 3 7 SOk

U5 1k B (A3 < <0CM-capable parameters®?, FC ffjinput ik 2% .

W R R <All parameters®”, Schart 1/0s 4 % HIFCHTinput Kk A1,

A SR

CFC ZmiEgefit v W4 ThRE, WIS chart A%/ HAE MR R ml DAl e 4%, BRI
BN 2 B, H AT LLEE S S “Debug > Test Settings. ..~ ” K& XUtk $ifh .

3.10.1. MR R, Test Modes
/“Jﬁﬁ’l‘ﬁﬁ@ﬁﬁﬁﬁﬁ

Process Mode: HTHRIAELZNZS BRIE(E g 2 BIR S|, AU FECPELEZ FAAESR
BREEAE g . SRR BOE S, A AL T-““watch of 7 RZS, WA A
ARSI, SR/ fd, AT ARG R IE T B 5, SRS I8 S “Debug > watch on””
i e i =T e

Laboratory Mode: i tbF-Process Mode, U775 2GS S ANSZPRE, 24300 bk s
Jes FTH HIRHAAL T “watch on” > IRZs.

AR EAAN R J5, ATRUE S “Debug > Test Mode”” R0l i X

3.10.2.

B S BRI 4 H

P AT U 7 T e 0 B R st R 5 M chart sh AN G S8 0 s e
CECTERTN

o WHEHWRMBEOLET: MEIENHELR
o REHRMMBEOLME: BUEBHT CPU



o LIS i BUALILER
LA RN UG, R SORER KA GE S HEME. WU A E G, i
rige, Fmn 2% T .

prrE | bt i avall B IR
[ 1 ] B B AR T
-- book CFCYSIMATIC 400(1 4-2 DP%... OMLINE

Insert CPU Debug “iew Options v Help

ple(el (@ slE 2] eldNT akoe|=pA 52| BT [
"PIDGE E{H" MD 100 ]
"IIDF R 2" IZ-0 =
‘_I—-—II-I OUTH 5
it R E S Wl pIVELZ
/

frgp— = \,//
AR [ FE1 —
TIU 1N SCALED |1
100.0—{HI_LIM I | [ SCALED F
0.0—LU LIE I {[__  ERE|-
0—{BIPOLAR

P 3-28: Mg Stim

ERE:
P T i an & B

o RAFMHETEDBA iblock %I /it

o RIEFLHIFCELBOP (FEAHRAE, BIHAIAND, OR) ZFHIHIA,

o HIEANSTRING, DATE AND TIME, ANYH)%
MRS, aRThRee (FB) MEN=0, NIDREHUERIMAAN TR, HERAIReEE —
AR OB s 4ThREERAIENE 0 288 1 i, IXUBUEE i mlEr . 1%t FFCLZBOPHISAN ,
— H SR IR R TR A

3.10.3. A E~ (Dynamic Display)
AT, block A& chart B% A/t o DAES AL & N P sl A R . Al SCRPEARE AR

A (BOOL, WORD %) R ghtt B A% 2R A . F Frdid 2 #i: <“View -> Dynamic Display””
Haf AT R .



Er{crc - [Dynamic Display -- book_CFC}SIMATIC 400(1),CPU 414-2 DPY,... ONLINE]
ﬁ Chart Edit Insert CPU Debug Miew Options Window Help

D& & |=|@] (B =8 &= 6l
[N o o] =] 2| 3¢ 1 [ = e =Em s

Statuz | Watch [Chart |[Block: 1/0 Yalue Uit Comment
CFC1 1 SCALED 'Wal |0.1593929
CFC[] |3 P SEL 1 1=Fropaortional Act...
] CFC] |3 INT _HOLD Integral Action Hold
CFC) |3 |_SEL Enable: 1=lntegral...
pd
AR B REHBIE
T, BH TR S K] 3-29: Zh& B H

O A B PN AR B, W DU T A s AR B, %k #% << Insert in Dynamic
Display”; NItk AR S 4 i N BIBh A WMALE 11, [RI 204 A0 o O g 4T 7. Sk O g oc i
W, TR R AR BN, AT E ), X AR B A R .

4. CFC MATREHITRE

4.1. BRI ITRETZEXR

N IHRE LA RE LA 077 i 5 BRIA T R 251 Y CFC AOAE M, B M1 2K
&SRB RN A A

< HINIRBOE R
< PID &I (F3h/ A shigkiEHD
> LR
4.2. CFC f&j s
FE R, #4495 —A CFC AT PID £l F27

< PID R4S E 0B35 f, R T2 SHA T HISCLIEF KL STEPT FruEThREL
> ERER TR RS 0BL b (FRTRIE, &%

FE PR
<> OBBRIEASEST WORD & INT [k, 1% B UEThEEEL
> RERLET TR R, R TR, 75 UK SER{E X 2P IDREER
< URBE/SERHME R TREEAE NI R AR Bk 2P IDT)RE bk
< PID MR HIEE FCL06 HEAT 4 H{E i 45
< FC106 F%ar B 2E4T INT SEWORDA. #e, 306 28 ABL4DL R HH AEAR

1) #shn CFC #2F¢



=alx

£ Fle Edit Insert PLC Wiew Options Window Help =18 =
BT e | & g|ﬁ|l?iﬁ|5g - '|-||<NDFllter>
% tonlz_example Ohbject name | Symbaolic name | Tur
=l SIMATIC 40001) Ems7? Program(] 57
= lmm A i
ﬁ 57 (Cuk Ctrl+><
iﬁ Paste Chr{
Celete Del
Insert Mew Objeck S7 Program

PLC v

Source Folder
Run-Time Properties, ., Block Folder Cffline
Chart Folder

Rename Fz
Chject Propetties. ., Alk+Return STL Source
Special Object Properties k SCL Source
SCL Compile Control File
GRAPH source
1] | CFC

K 4-1: ¥shn CFC 2+

2) FEFSCAETHANT Charts U3k % CFC SCA:, XXEE%T 3f CFC

epTisTp =10 x|
%Flle Edit Insert PLC View Options Window Help =18 x|
w37 | 2 R dei2 %
E--% tools_example Dbject name
El-- SIMATIC 400(1) [}‘[:[1]

=-[@ cPu#12:2DP
@ 57 Program{1])

&3] Charts

~{@] Sources

“-ifH Blocks « | N
K 4-2: 9TJF CFC

3) CFC Uit A

=101 |

[ Chart Edit Insert CPU Debug  Wiew Dptiu:uns inu:l;:u.l.-;l. Help =& x|
D||a| &2 Blo]E 2] el
W e =2 | BT [ 2 ||l BEm

2 sheet view ] ﬂ

N, BN T AR
L%k, BoniER:
1 E’Jﬁlﬂﬁ—k‘ﬁﬁﬁlﬂﬁ ]
1

<lha/lLel

E 4-3: CFC TR



4) CFC 47l il &

5. CFC - [Runtime editor - tools_example’}SIMATIC 4001} -0 x|

“[E chart Edit Insert CPU Debug Yiew Options ‘Window Help  _|&] %]

D22 #l=2 m=FE 2] 6l

I ] T ] el ] o R K i = [ma 04

4

- T CYC_INTS [Cychic Interrupt 5] « NCortents of 'CYC_INTSYCRC(1IY
1) o
OBl [FZ Free u:*;.ﬂ:le

QB0 [Time-of-day interrupt TOD_INTO]

. [¥] ©B10O [Warm restart] _|:J
| »

Al run sequence
Al A 41T CFC 1£
i H AL E
|

5) ML EIIRESR

Kl 4-4: CFC 4R fTAbAL &

25 CFC - [CFC(1) - tools_example’,SIMATIC 400{1)}\CPL 412°2 o m] 4
ar I NSer! 20uUg ([=10H] prions (| (= {ult] =] u] =
[ chart Edit Insert CPU Debug View Options ‘Window Hel & x

D& &2 [BotE 2] el

W o || =% 58] BRI [ =] &la =S|m|

6) R I Be bk $%

[ -y SHIFT ]
-y WRD_LGC
-4y Other blocks
=I-[Z8 57 Program(1)
L {0} FB1 [FB1]
PIW_TIH = ..... i3 FEZ [FE?]
HI _LIf_IM=CALED_F i
Th_LIM T 3 O FCL [FCL]
EIFPOLAR_ {0k SCALE [FCIIZIEv
‘I I o TTRAC -|i.d-|.z£i_|
11 FB1 N
! i)
| FE1 £
1 3 TR 3 &

K 4-5: CFC i FH H e ohRebh



ES.CFC - [CFC(1) — tools_example’, SIMATIC 400(1),CPU 412°2 ¢ =10| x|
[ Chart Edit Imsert CPU Debug Miew Options ‘Window  Help _|5|5|

D& #5278 &[] ekl
1 oo =a| %] BT [ 2 &lal =Em] K

Interconnection ko Address., ..
Textual Interconneckion. ..

£ CONVERT 4
HiH ] WORD #%
INT ZhRER,
F 45 e Hu ik

Insert in Dynamic Display

Obijeck Properties. .. AlE+Return
i Q COther blocks

FE4 :
=l-[H 57 Program(l)
@—|FIW_IM _J [CALED_U|— .43 FB1 [FB1]
10® .o—{HI_LIM_I| [SCALED_F|- _Ij
| »

: 1% o B = = T O I == =T N |
@ @—L0_LIN_I EEE | 4|
o—{BEIPOLAR_

T e [BEc. | WL |
Bl 4-6: I BoHbhi g
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14) K J5 k) 0B35,0B100 H HIFE M kR, #E&%d:, 47JF3¢ 5 Options -> Customize ->
Compile/Download i£1, iXHKf FC number from A 1-150.

Settings for Eumpilatinnﬂ)mnﬁal‘ij x|
CPU: CPU 4122 D%{i)ﬂ {1 CPU I
Warming Limits
) | =l Communications jobs: [3) IE“] =
Local data [%) 50 = jobs [3) =
Load memarny [%] |EH:I _% Wiork memon ] an =
e 2 A
Areas Reserved for Other Applications Eilﬁh%%%ﬁ)ﬂ;ﬁ‘: 1
R R R E
DE numbers from: |1 o |EIII et
FC numbers from: IEEI to I.':f [ Compress
- ::ir.i”‘ E3 |
Statistic % CPU [ITERE eV
| i v I use | Highest
| number
DB 511 451 B 66
FC 250 G0 56 55
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15) i&F¥¢ File->Compile, &t dmifi A 45 1%)5, WiH Blocks H N HNAEMIRE SCL H'E
(RIRE e b Bed B, 0B35,0B100 135 54 SCL 4’5 «

Compile I Check Conzistency I Download I Block Types I

Fiter. [ <No fiter> =l Detafs |

Compiling all charts az program SIMATIC 40001 CPU 412-2 DPAST Program(1] on 84942007 2:34:36 PM
The optiohz are set az follaws:
Generate block drivers: off
Ilpdate zampling time: off
Delete empty runtime groups: off
Make textual interconnections: off
The empty OB35 at the beginning was deleted. It will be created again if it iz included in automatic blo
The address 'TEFEEAEW" of parameter CFCI2IN used for the access [readAwite) to the process
The address PRWHS12 of parameter CFC[1).4.0UT uzed for the access [readAwnte] to the process im.
End of code generator: 8/19/2007 2:34:40 P
Start SCL compiler: 8/19/2007 2:34:40 P
End SCL compiler; 8/19/2007 2:34:54 P

[ errorfz] and 3 warning(z] found
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Settings for Compilation,/Download X

CPL: CPU 412-2 DF'%1§H§ {1 CPU I

Wwharning Limnits

Local data [Z]: |E||:| _I: Commurications jobs (2] |30 =5

Load memaony [Z]: IEEI _|: Wiork mermary [Z]: |E!EI :_l
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BT IR E
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BEGIN;
ff—— Block:
DES1.DW11G

CEC{1}).?2
:=PIWS12;

ff—— Beginming: Funtime group CFC{1)
FORCTION FCE55 :WOID
ENOW_HOW_PROTECT
ATTHOR : ES_MAP
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e —H, ¥ CFC BRI SCL Y5 STA-MIRR -

Compile chart as block type

General | Attributes |
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Project path: |KnDWhnwschutz\SlM.ﬁ.Tll: 40001 MCPU 4124185 F-Programm(114E austeine

FB number:
Mame [header]:
Eamily:

Authar:

Wersion [header]:

— Properties of Block Type

|1

— Compile for FLC

||:F|:1

57300
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— Optimize Code for

% Local data requirements

" Downloading changes in RN

¥ Enow How protected
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