×
Siemens Industry Online Support
Siemens AG
Entry type: FAQ Entry ID: 14844050, Entry date: 05/10/2011
(0)
Rate

What are the advantages of the "Multiproject" function for large networked projects?

  • Entry
  • Associated product(s)

Configuration Notes:
From STEP 7 version V5.2 you have the option of combining multiple projects into one using the "Multiproject" function. This permits you to divide one large project into multiple smaller projects and configure them together in one multiproject.

Example:
You have one STEP 7 project with multiple networked S7 stations and a size of more than 100 MB. You wish to split this project into two projects entitled "Plant_1" and "Plant_2". Without the "Multiproject" function the stations configured in the "Plant_2" project would be unknown in the "Plant_1" project, for example. If you configure the two split projects in a multiproject, then, for example for transfer of AS-OS connection data, not all the objects have to be in one project. Using the cross-project functions such as "Save As...", "Archiving", "Adjustment of the cross-project network" and "Update of views" you can handle a multiproject just like a single project.

More information on the "Multiproject" function is available in the STEP 7 Online Help under

  • "Networking Stations from Different Projects",
  • "What you should know about Multiprojects",
  • "Multiproject - Requirements and Recommendations",
  • "Handling Multiprojects",
  • "Adjusting Projects in the Multiprojects".

This information is also available in the manual

  • "Configuring Hardware and Communication Connections with STEP 7 V5.5" (chapter 15 "Working With Projects in the Multiproject")
    in Entry ID: 45531110.

If you have several people working on a STEP 7 project, you can use the multiproject to create a project for each person for distributed editing, for example, and split up the stations according to the people working on the project. Please note the following here:

  • Apply the information from the STEP 7 Online Help "Multi-User Configuration in a Network".
  • Ensure that the same software version (e.g. STEP 7 V5.5) is installed on all the SIMATIC workstations concerned.

Inserting a project in a multiproject when the two objects are not on the same server
The table below describes how to proceed to insert a project in a multiproject when the projects are not on the same server.
 

No. Procedure
1 Open the multiproject in the SIMATIC Manager using the menu command "File > Open... > Tab: Multiprojects". You can open the multiproject either on the computer on which the multiproject is stored, or on the other server where the project to be integrated is located. It is important that the folder with the projects to be inserted is enabled.


Fig. 01
2 In order to insert the project into the multiproject from the other server you must open the "Add to Multiproject" dialog
  • via "File > Multiproject > Add to Multiproject..."
3 Now insert your project into your multiproject from the other server. Mark the relevant project as shown here in Fig. 02 and then acknowledge with OK.


Fig. 02
4 It is not necessary to store the objects in the same folder or on the same server. Both objects then receive a reference to each other once the link has been established. The newly added project is then displayed in the multiproject. If you open the project separately, the multiproject appears as the top entry in the project path (Fig. 03).


Fig. 03

Deleting multiprojects and projects contained in them
The table below describes the options for deleting multiprojects and projects contained in multiprojects.
 

No. Deleting multiprojects and projects contained in them
1 If neither the multiproject nor the project to be deleted is open, in the SIMATIC Manager you can select the menu item "File > Delete..." and in the "User Projects" tab simply select and delete the project. Even if you have already opened the multiproject, you can still use this method to delete the project integrated in the multiproject.
2 If, however, you have opened the project separately, then you must first remove the project from the multiproject before deleting the project. You remove the project from the multiproject by marking it and right-clicking. In the pop-up menu that opens you select the menu item "Multiproject". Here you have a choice of two menu commands: "Remove From Multiproject" and "Remove for Editing...".


Fig. 04

The menu command "Remove From Multiproject" removes the objects marked from the multiproject. The marked objects are not deleted, but just removed from the multiproject. You can then use the menu item "File > Delete..." and in the "User Projects" tab select and delete the project concerned.

The menu command "Remove for Editing..." opens another dialog in which you can export the project from the multiproject. As long as the exported objects are present in the multiproject you cannot execute the functions "Archiving" and "Save As..." for the multiproject. The exported project is marked in the multiproject with the note "<Project removed for editing>".


Fig. 05

Here too you can remove the exported project via the menu command "File > Multiproject > Remove From Multiproject" and then delete it. With the menu command "File > Multiproject > Reapply after Editing..." you can reinsert the exported project in the multiproject as long as the multiproject has not been renamed or relocated.

3 Please proceed as follows to delete a multiproject.
  • To delete the multiproject without deleting the subprojects, in the SIMATIC Manager you open the dialog "File > Delete..." and select the "Multiprojects" tab. Mark the multiproject to be deleted and acknowledge with OK.
  • To delete the multiproject with all subprojects, please proceed as described in Point 1 and first delete all the subprojects contained in the multiproject. Then you delete the multiproject.

If you get the error message as shown in Fig. 06 when deleting a multiproject or a subproject, then click on the "Details" button.


Fig. 06

If under Details you are informed that the file is being used by another application, then check that you haven't opened the application somewhere. If the project is not opened, then close the SIMATIC Manager (and all STEP 7 applications) and then reopen the SIMATIC Manager. Then you should be able to delete the project.

Archiving multiprojects on a removable data medium (USB stick):
First archive your multiproject on the hard disk and then copy the Zip file onto the USB stick. Then copy the Zip file from the USB stick onto the hard disk of the target computer so that you can then dearchive the multiproject from the hard disk.

Note:
If a project in a multiproject is saved in an area of Windows 2000 with the menu command "File > Save as..." and the settings as shown in Fig. 07, then "Project not available" might appear in the multiproject.


Fig. 07

If, the above-mentioned display appears instead of the project or project name, then you must update the screen display in the SIMATIC Manager either via the menu command "View > Update" or via the "F5" key. The project is then available again in the multiproject and can be opened.

Keywords:
Multi-user system, Multi-user operation, Error message 258:15

Security information
In order to protect technical infrastructures, systems, machines and networks against cyber threats, it is necessary to implement – and continuously maintain – a holistic, state-of-the-art IT security concept. Siemens’ products and solutions constitute one element of such a concept. For more information about cyber security, please visit
https://www.siemens.com/cybersecurity#Ouraspiration.