×
Siemens Industry Online Support
Siemens AG
Beitragstyp: FAQ Beitrags-ID: 15087296, Beitragsdatum: 14.09.2007
(0)
Bewerten

Wie ändere ich eine Simultanverzweigung in eine Alternativverzweigung um, ohne die betroffenen Schritte alle neu eingeben zu müssen?

  • Beitrag
  • Betrifft Produkt(e)

Anleitung:  
Die nachstehende Tabelle beschreibt Ihnen die Vorgehensweise, wie Sie eine Simultanverzweigung in eine Alternativverzweigung umwandeln können, ohne die betroffenen Schritte neu eingeben zu müssen:
 

Nr. Vorgehensweise:
1 Öffnen Sie den S7-GRAPH-Editor mit der zu ändernden Schrittkette und wählen Sie im linken Teilfenster das Register "Graphik" (linkes Register).
2 Das rechte Fenster stellen Sie bitte auf die Ansicht "Kettendarstellung" ("Ansicht > Kette") und markieren Sie den Schritt vor der Simultanverzweigung, die Sie durch eine Alternativverzweigung ersetzen wollen.


Bild 01

Klicken Sie auf die rechte Maustaste und wählen Sie im anschließend sich öffnenden Kontextmenü den Menübefehl "Neues Element einfügen > Alt-Verzweigung > Auf". Eine Alternativverzweigung wird somit eingefügt.

3 Markieren Sie im linken Fenster die Schritte, die Sie in die neue Alternativverzweigung einfügen wollen und führen Sie den Menübefehl "Bearbeiten > Ausschneiden" durch.


Bild 02

Die markierten Schritte werden im rechten Fenster blau dargestellt. Den Menübefehl "Kopieren" können Sie an dieser Stelle nicht verwenden, da diese Funktion einen Schritt nicht zweimal in einer Schrittkette einfügen kann.


Bild 03
4 Gehen Sie zu dem zuvor angelegten Alternativzweig und fügen Sie die ausgeschnittenen Schrittkettenteile ein, indem Sie die Transition markieren und den Menübefehl "Bearbeiten > Einfügen" ausführen.


Bild 04

Wenn Sie auch das Schließen der Simultanverzweigung auf eine Alternativverzweigung umstellen möchten, markieren Sie die zu entfernende Verbindung und löschen Sie diese.

5 Um eine Alternativverbindung schließen zu können, muss als Abschluss des Zweiges eine Transition vorhanden sein. Da nach dem Entfernen der Verbindung jedoch ein Schritt als Abschluss des Zweiges steht, ist ein "Schritt mit Transition" einzufügen und der gerade eingefügte Schritt wieder zu löschen - die Transition bleibt erhalten.
6 Nachdem der Schritt gelöscht wurde, können Sie hinter der Transition mit der Funktion "Einfügen > Alt-Verzweigung > Zu" den Zweig zurückführen.


Bild 05

Haben Sie noch weitere Unterzweige, die Sie ebenfalls ändern möchten, dann wiederholen Sie die angegebenen Schritte.

Securityhinweise
Um technische Infrastruktur, Systeme, Maschinen und Netzwerke gegen Cyber-Bedrohungen zu sichern, ist es erforderlich, ein ganzheitliches IT Security-Konzept zu implementieren (und kontinuierlich aufrechtzuerhalten), das dem aktuellen Stand der Technik entspricht. Die Produkte und Lösungen von Siemens formen nur einen Bestandteil eines solchen Konzepts. Weitergehende Informationen über Cyber Security finden Sie unter
https://www.siemens.com/cybersecurity#Ouraspiration.