Beitragstyp: FAQ, Beitrags-ID: 18778977, Beitragsdatum: 16.05.2012
(1)
Bewerten

Wie können die Aktualwerte von DBs und die der Merker gesichert werden?

  • Beitrag
  • Betrifft Produkt(e)

Anleitung 
Die Aktualwerte von Datenbausteinen können Sie im Offline-Projekt speichern. Das Speichern von Merkern im Offline-Projekt ist allerdings nicht möglich. Wenn Sie die Aktualwerte sichern möchten, z.B. weil Sie die CPU tauschen müssen, so erfolgt das Sichern der DB-Aktualwerte mit dem Kopieren der Datenbausteine aus der Online-Ansicht in die Offline-Ansicht.

Die nachstehende Tabelle beschreibt hierzu die Vorgehensweise:
 

Nr. Vorgehensweise zur Sicherung der Aktualwerte:
1 Öffnen Sie im SIMATIC Manager den Dialog "Öffnen Projekt" mit dem Menübefehl "Datei > Öffnen..." und wählen Sie das Projekt, dessen Programm in der CPU geladen ist.
2 Öffnen Sie anschließend im SIMATIC Manager die Online-Ansicht mit dem Menübefehl "Ansicht > Online". Für eine bessere Übersicht empfehlen wir die Fensteranordnung (Online- und Offline-Ansicht) untereinander zu ordnen, wählen Sie hierzu den Menübefehl "Fenster > Anordnen > Untereinander".
3 Nun können Sie die Datenbausteine per Drag & Drop aus der Online-Ansicht in die Offline-Ansicht ziehen bzw. kopieren. Die Aktualwerte werden somit in das Offline-Projekt übertragen.


Bild 01

Stellen Sie sicher, dass Sie nur auf diesem Weg den DB kopieren, es besteht ansonsten die Gefahr, dass die Bezeichnungen der Variablen Ihres Datenbausteins verloren gehen.

Hinweis
ProfiSafe-Datenbausteine dürfen nicht aus der CPU in das Offline-Projekt kopiert werden. In diesem Fall würde die FailSafe-Signatur verloren gehen bzw. nach erneuter Übersetzung nicht mehr die der Originalen entsprechen, obwohl die Programmierung nicht geändert wurde.

Bei den Merkern haben Sie die Möglichkeit, einen Teil der Merker remanent einzustellen. Diese Merker behalten dann auch im spannungslosen Zustand den Signalzustand bei. Die Remanenz beginnt immer mit dem Merkerbyte 0 und endet bei der eingestellten Obergrenze.
 

Nr. Vorgehensweise
1 Markieren Sie in der Hardwarekonfiguration die CPU-Baugruppe und öffnen Sie die Eigenschaften der CPU, indem Sie den Menübefehl "Station > Eigenschaften..." ausführen oder mit der linken Maustaste auf die CPU-Baugruppe doppelklicken.
2 Wählen Sie im folgenden Dialog "Eigenschaften - CPU..." das Register "Remanenz". Im Register "Remanenz" können Sie festlegen, welche Spannungsbereiche nach einem Netzausfall bzw. nach einem Übergang der CPU von STOP nach RUN auch ohne Batteriepufferung erhalten bleiben.


Bild 02

3 Bild 02 zeigt ein Beispiel für die Einstellung von 16 remanenten Merkerbytes (MB 0 bis einschließlich MB15) für die CPU 417-4. Speichern Sie die Einstellung mit OK.
4 Anschließend müssen Sie die Hardwarekonfiguration speichern und übersetzen und in die CPU laden.

Hinweise
Beachten Sie auch die Informationen aus der STEP 7 Onlinehilfe, unter "Einschränkungen beim Laden aus dem Zielsystem." Für die aus dem Zielsystem in das PG geladenen Daten gelten folgende Einschränkungen:

  • Die Bausteine enthalten keine symbolischen Namen für Parameter, Variablen und Marken.
  • Die Bausteine enthalten keine Kommentare.

Eine Beschreibung zum remanenten Speichern von Werten in der CPU finden Sie in dem zu Ihrer CPU gehörenden Handbuch.

  • S7-300er CPUs mit Micro Memory Card (MMC): 
    "CPU 31xC und CPU 31x, Technische Daten" - Beitrags-ID: 12996906
    Kapitel "5.1 Speicherbereiche und Remanenz"
  • S7-300er CPUs ohne MMC: 
    "SIMATIC Automatisierungssystem S7-300, CPU-Daten, CPU 312IFM bis CPU 318-2 DP" - Beitrags-ID: 8860591
  • S7-400er CPUs: 
    "SIMATIC Automatisierungssystem S7-400 CPU-Daten" - Beitrags-ID: 14016796