×
Siemens Industry Online Support
Siemens AG
Beitragstyp: FAQ Beitrags-ID: 23782899, Beitragsdatum: 27.09.2018
(3)
Bewerten

Wie werden die Diagnosedaten des Windows-System Monitors (Performance Monitor) in eine Datei gespeichert?

  • Beitrag
  • Betrifft Produkt(e)
Verwendung des Windows Performance Monitors zu Diagnosezwecken.

Vorgehensweise für Windows 10, Windows Server 2012 und Windows Server 2016


Anleitung
Der im Windows-Betriebssystem integrierte System Monitor (Performance Monitor) ist dazu geeignet, um Ressourcenengpässe im System ausfindig zu machen. Der Systemmonitor unterstützt die detaillierte Überwachung der genutzten Betriebssystemressourcen. Er bietet die Möglichkeit, die Systemressourcen zyklisch aufzuzeichnen und in eine Datei zu speichern. Die gesammelten Daten können als Kurvenverlauf in Abhängigkeit der Zeit grafisch angezeigt werden. Detaillierte Informationen finden Sie in der Online-Hilfe von Microsoft.

Nr.Vorgehensweise
1

Starten Sie den Windows-Systemmonitor mit "Start > Suchen> Leistungsüberwachung. 
Es öffnet sich die Leistungsüberwachung (auch als Performance Monitor bezeichnet).

2

Öffnen Sie im linken Teilfenster Datensammlersätze > Benutzerdefiniert > Neu > Datensammlersatz. Geben Sie einen Namen ein, selektieren Sie die Option "Manuell erstellen (Erweitert)" und drücken Sie die "Weiter" Taste.
Selektieren Sie Datenprotokolle erstellen > Leistungsindikatoren und drücken Sie die "Fertig stellen" Taste.

Alternative

Verwendung einer Sammlungssatzvorlage
 Registrierung notwendig  process_instance_all_120sec.xml (4,8 KB) 

Laden Sie die beiliegende Sammlungssatzvorlage herunter. Klären Sie mit unserem Technical Support, ob diese Vorlage für Ihre Belange passend ist. Notfalls erhalten Sie eine für Sie angepasste Vorlage von unserem Technical Support.

Öffnen Sie im linken Teilfenster Sammlungssätze > Benutzerdefiniert > Neu > Datensammlersatz. Geben Sie einen Namen ein, selektieren Sie die Option "Aus Vorlage erstellen (empfohlen)" und drücken Sie die "Weiter" Taste. Drücken Sie die "Durchsuchen..." Taste. Wählen Sie den Pfad, an dem Sie die Vorlage abgespeichert haben. Selektieren Sie die Vorlage und Drücken Sie die Taste "Öffnen". Drücken Sie die Taste "Weiter". Selektieren Sie das Stammverzeichnis, wo die Daten gespeichert werden sollen und anschliessend die Taste "Fertig stellen". In dieser Vorlage sind die Schritte 3 bis 7 bereits voreingestellt.

Fahren Sie fort mit Punkt 8.

3Öffnen Sie mit der rechten Maustatse die Eigenschaften Ihres neu angelegten Sammlungssatzes.
Wählen Sie die Lasche Verzeichnis.
Selektieren Sie das Stammverzeichnis, lassen Sie das Unterverzeichnis leer, lassen Sie das Format für den Unterverzeichnisnamen leer, markieren Sie nicht die Option "Computernamen dem Unterverzeichnis voranstellen" und tragen Sie unter Seriennummer "1" ein.
Wählen Sie die Lasche Stoppbedingungen.
Selektieren Sie unter Limits die Option Datensammlersatz bei Erreichen eines Limits neu starten und die Option Maximale Größe: 20 MB.
Sichern Sie die Einstellungen mit der "OK" Taste.
4Wählen Sie im rechten fenster Ihrem erstellten Datensammlersatz aus. Öffnen Sie mit der rechten Maustaste die Eigenschaften der Datei DataCollector01. Öffnen Sie die Lasche Leistungsindikatoren. Drücken Sie die Taste "Hinzufügen...".
5Wählen Sie im neu aufgeblendeten Fenster im linken Teilfenster im oberen Teil den Leistungsindikator "Prozess" und im unteren Teil <Alle Instanzen> aus. Drücken Sie die Taste "Hinzufügen >>". Schließen Sie den Dialog mit der "OK" Taste ab.
6Damit befinden Sie sich wieder im Eigenschaftsdialog der Datei DataCollector01 in der Lasche Leistungsindikatoren.
Stellen Sie in der Option Protokollformat: "Binär" und in der Option Abtastintervall: "120 Sekunden" ein.
7Öffnen Sie die Lasche Datei. Stellen Sie die Option Dateinamenformat auf "yyyyMMddN" ein. Wählen Sie die Option Computernamen der Datei voranstellen. Wählen Sie in der Option Protokollmodus alle Auswahlmöglichkeiten (Überschreiben, Anhängen, Zirkulär...) ab.
Schließen Sie den Eigenschaftsdialog mit der "OK" Taste.

Hinweis
Wenn Zirkulär gemeinsam mit "Maximal Größe" ausgewählt ist wird eine Umlauf-Performance-Monitoraufzeichnung erreicht - es wird NUR eine Datei wie mit "Maximale Größe" angegeben, aufgezeichnet. Die Aufzeichnung läuft auch dauerhaft(endlos), aber es wird nur soviel "Historie" aufgezeichnet, wie in der definierten Dateigröße Platz hat.). 
8

Starten Sie den Performance Monitor über die Taste "Aktion > Starten" in der Toolbaranzeige.
Stoppen Sie den Performance Monitor über die Taste "Aktion > Beenden" in der Toolbaranzeige.

Wichtig
Da schnell eine große Menge an Daten zusammenkommen kann, sollte nicht das Systemlaufwerk als Ablageort verwendet werden, sondern ein Laufwerk auf welchem ausreichend Speicherplatz zur Verfügung steht.
Es wir empfohlen die Aufzeichnung für ein paar Aufzeichnungsintervalle (20 Intervalle) zu starten und dann zu stoppen. Danach kann der Speicherbedarf aus der aktuellen Dateigröße für Langzeitaufzeichnungen hochgerechnet werden.

Weitere Informationen
Welche Diagnosemöglichkeiten stehen Ihnen für WinCC und PCS 7 OS zur Verfügung? 48698507

Vorgehensweise für Windows 7 und Windows Server 2008


Anleitung
Der im Windows-Betriebssystem integrierte System Monitor (Performance Monitor) ist dazu geeignet, um Ressourcenengpässe im System ausfindig zu machen. Der Systemmonitor unterstützt die detaillierte Überwachung der genutzten Betriebssystemressourcen. Er bietet die Möglichkeit, die Systemressourcen zyklisch aufzuzeichnen und in eine Datei zu speichern. Die gesammelten Daten können als Kurvenverlauf in Abhängigkeit der Zeit grafisch angezeigt werden. Detaillierte Informationen finden Sie in der Online-Hilfe von Microsoft.
 

Nr. Vorgehensweise
1 Starten Sie den Windows-Systemmonitor mit "Start > Alle Programme > Zubehör > Ausführen. Geben Sie in der Zeile "Öffnen:" perfmon ein und klicken Sie anschließend die "OK" Taste.
Drücken Sie die Windows Start  Taste und geben im Suchfeld "perfmon" ein. Starten Sie das Programm "perfmon".
Es öffnet sich die Leistungsüberwachung (auch als Performance Monitor bezeichnet).
2

Öffnen Sie im linken Teilfenster Sammlungssätze > Benutzerdefiniert > Neu > Sammlungssatz. Geben Sie einen Namen ein, selektieren Sie die Option "Manuell erstellen (Erweitert)" und drücken Sie die "Weiter" Taste.
Selektieren Sie Datenprotokolle erstellen > Leistungsindikatoren und drücken Sie die "Fertig stellen" Taste.


Alternative

Verwendung einer Sammlungssatzvorlage
 Registrierung notwendig  process_instance_all_120sec.xml (4,8 KB)

Laden Sie die beiliegende Sammlungssatzvorlage herunter. Klären Sie mit unserem Technical Support, ob diese Vorlage für Ihre Belange passend ist. Notfalls erhalten Sie eine für Sie angepasste Vorlage von unserem Technical Support.

Öffnen Sie im linken Teilfenster Sammlungssätze > Benutzerdefiniert > Neu > Sammlungssatz. Geben Sie einen Namen ein, selektieren Sie die Option "Aus Vorlage erstellen (empfohlen)" und drücken Sie die "Weiter" Taste. Drücken Sie die "Durchsuchen..." Taste. Wählen Sie den Pfad, an dem Sie die Vorlage abgespeichert haben. Selektieren Sie die Vorlage und Drücken Sie die Taste "Öffnen". Drücken Sie die Taste "Weiter" und anschliessend die Taste "Fertig stellen". In dieser Vorlage sind die Schritte 3 bis 7 bereits voreingestellt.

Fahren Sie fort mit Punkt 8.

3 Öffnen Sie mit der rechten Maustatse die Eigenschaften Ihres neu angelegten Sammlungssatzes.
Wählen Sie die Lasche Verzeichnis.
Selektieren Sie das Stammverzeichnis, lassen Sie das Unterverzeichnis leer, lassen Sie das Format für den Unterverzeichnisnamen leer, markieren Sie nicht die Option "Computernamen dem Unterverzeichnis voranstellen" und tragen Sie unter Seriennummer "1" ein.
Wählen Sie die Lasche Stoppbedingungen.
Selektieren Sie unter Limits die Option Sammlungssatz bei Erreichen eines Limits neu starten und die Option Maximale Größe: 20 MB.
Sichern Sie die Einstellungen mit der "OK" Taste.
4 Öffnen Sie im rechten Teilfenster mit der rechten Maustaste die Eigenschaften der Datei DataCollector01. Öffnen Sie die Lasche Leistungsindikatoren. Drücken Sie die Taste "Hinzufügen...".
5 Wählen Sie im neu aufgeblendeten Fenster im linken Teilfenster im oberen Teil den Leistungsindikator "Prozess" und im unteren Teil <Alle Instanzen> aus. Drücken Sie die Taste "Hinzufügen >>". Schließen Sie den Dialog mit der "OK" Taste ab.
6 Damit befinden Sie sich wieder im Eigenschaftsdialog der Datei DataCollector01 in der Lasche Leistungsindikatoren.
Stellen Sie in der Option Protokollformat: "Binär" und in der Option Abtastintervall: "120 Sekunden" ein.
7 Öffnen Sie die Lasche Datei. Stellen Sie die Option Dateinamenformat auf "yyyyMMddN" ein. Wählen Sie die Option Computernamen der Datei voranstellen. Wählen Sie in der Option Protokollmodus alle Auswahlmöglichkeiten (Überschreiben, Anhängen, Zirkulär...) ab.
Schließen Sie den Eigenschaftsdialog mit der "OK" Taste.

Hinweis
Wenn Zirkulär gemeinsam mit "Maximal Größe" ausgewählt ist wird eine Umlauf-Performance-Monitoraufzeichnung erreicht - es wird NUR eine Datei wie mit "Maximale Größe" angegeben, aufgezeichnet. Die Aufzeichnung läuft auch dauerhaft(endlos), aber es wird nur soviel "Historie" aufgezeichnet, wie in der definierten Dateigröße Platz hat.). 
8 Starten Sie den Performance Monitor über die Taste "Sammlungssatz starten" in der Toolbaranzeige.
Stoppen Sie den Performance Monitor über die Taste "Sammlungssatz anhalten" in der Toolbaranzeige.

Wichtig
Da schnell eine große Menge an Daten zusammenkommen kann, sollte nicht das Systemlaufwerk als Ablageort verwendet werden, sondern ein Laufwerk auf welchem ausreichend Speicherplatz zur Verfügung steht.
Es wir empfohlen die Aufzeichnung für ein paar Aufzeichnungsintervalle (20 Intervalle) zu starten und dann zu stoppen. Danach kann der Speicherbedarf aus der aktuellen Dateigröße für Langzeitaufzeichnungen hochgerechnet werden.


Vorgehensweise unter Windows 2000/2003 Server/XP

Anleitung
Der im Windows-Betriebssystem integrierte System Monitor (Performance Monitor) ist dazu geeignet, um Ressourcenengpässe im System ausfindig zu machen. Der Systemmonitor unterstützt die detaillierte Überwachung der genutzten Betriebssystemressourcen. Er bietet die Möglichkeit, die Systemressourcen zyklisch aufzuzeichnen und in eine Datei zu speichern. Die gesammelten Daten können als Kurvenverlauf in Abhängigkeit der Zeit grafisch angezeigt werden. Detaillierte Informationen finden Sie in der Online-Hilfe von Microsoft.
 

Nr. Vorgehensweise
1 System Monitor starten
Starten Sie den Windows-Systemmonitor mit "Start > Einstellungen > Systemsteuerung > Verwaltung > Leistung".  Es öffnet sich der System Monitor (auch als Performance Monitor bezeichnet).

 


Bild 01
2 Neues Leistungsindikatorenprotokoll anlegen
Wählen Sie im linken Fenster in der Baumdarstellung den Eintrag "Console Root > Performance Logs and Alerts > Leistungsindikatorenprotokolle". Öffnen Sie mit der rechten Maustaste das Kontextmenü im Arbeitsbereich (rechtes Fenster) und wählen Sie den Eintrag "Neue Protokolleinstellungen...". Es öffnet sich der  Dialog "Neue Protokolleinstellungen". Geben Sie im Feld "Name" den Namen des Protokolls ein und bestätigen Sie mit der Schaltfläche "OK".

 


Bild 02
 

Im Arbeitsbereich wird das neu angelegte Leistungsindikatorenprotokoll angezeigt.

3 Leistungsindikatorenprotokoll parametrieren
Doppelklicken Sie im Arbeitsbereich auf das zu parametrierende Leistungsindikatorenprotokoll.Es öffnet sich der Dialog zum Parametrieren des Leistungsindikatorenprotokolls.
  • Register "Allgemein"
    Legen Sie im Register "Allgemein" im Bereich "Daten erfassen alle" das Intervall fest, mit welchem die Daten zyklisch in die Datei geschrieben werden.

    Fügen Sie im Register "Allgemein" die gewünschten Leistungsindikatoren hinzu. Benutzen Sie dazu die Schaltflächen "Objekte hinzufügen..." und/oder "Indikatoren".
     

    Bild 03
      
    Beispiel
    Drücken Sie im Register "Allgemein" die Schaltfläche "Objekte hinzufügen...". Es öffnet sich der Dialog "Objekte hinzufügen".
     

    Bild 04
      
    Wenn Datenobjekte von anderen Rechnern im Netzwerk protokolliert werden sollen, wählen Sie das Auswahlfeld "Datenobjekte auswählen von" aus und tragen im zugehörigen Auswahlfeld den Namen des entsprechenden Rechners ein. Wenn Datenobjekte des eigenen Rechners protokolliert werden sollen, können Sie das Auswahlfeld "Lokale Datenobjekte verwenden" anwählen.

    Beispiel
    Wählen Sie z.B. die Einträge "Process", "Processor", "Memory" und "LogicalDisk" aus der Auswahlliste "Datenobjekte" aus und drücken Sie die Schaltfläche "Hinzufügen". Halten Sie die Taste "CTRL" oder "SHIFT" beim Auswählen mit der Maus gedrückt, um gleichzeitig mehrere Einträge in der Liste auszuwählen. Schließen Sie den Dialog "Objekte hinzufügen". Die zur Protokollierung ausgewählten Indikatoren werden in der Liste "Leistungsindikatoren" angezeigt.
     

    Bild 05
     
  • Register "Protokolldateien"
    Im Register "Protokolldateien" können Sie Einstellungen zur Protokolldatei (z.B. Dateityp, Name, Ablageort, maximale Dateigröße) vornehmen.
     

    Bild 06
     
  • Register "Zeitplan"
    Im Register "Zeitplan" können Sie festlegen, wann die Protokollierung gestartet und wann die Protokollierung gestoppt wird.
     

    Bild 07
     
    Für dieses Beispiel wurde ein "manuelles Starten" und "Stoppen" der Protokolldatei gewählt.
    Schließen Sie den Dialog mit der Schaltfläche "OK"
4 System Monitor zur Anzeige der protokollierten Leistungsindikatoren konfigurieren
Wählen Sie im linken Fenster in der Baumdarstellung den Eintrag "System Monitor"Im Arbeitsbereich wird ein Kurvenfenster zur grafischen Anzeige der Leistungsindikatoren angezeigt. Öffnen Sie mit der rechten Maustaste das Kontextmenü innerhalb des Bereiches zur Kurvendarstellung (Arbeitsbereich des System Monitors). Wählen Sie den Eintrag "Eigenschaften..." an.

 


Bild 08
 

Es öffnet sich der Dialog "Eigenschaften von Systemmonitor".

  • Register "Quelle"
    Wechseln Sie in das Register "Quelle". Wählen Sie im Bereich "Datenquelle" das Auswahlfeld "Protokolldateien". Drücken Sie anschließend die Schaltfläche "Hinzufügen" und wählen Sie im Dialog "Protokolldatei auswählen" die gewünschte Protokolldatei aus.
     

    Bild 09
     
  • Register Daten
    Wechseln Sie in das Register Daten. Fügen Sie die von Ihnen zur Anzeige gewünschten Leistungsindikatoren hinzu.
     

    Bild 10
     

Über die Taste "Aktuellen Vorgang anzeigen" in der Symbolleiste des "System Monitor" können Sie sich den aktuellen Verlauf des Systemminitors anzeigen lassen.
 

Bild 11
 

Über die Taste "Protokolldaten anzeigen" in der Symbolleiste des "System Monitor" können Sie sich den aufgezeichneten Verlauf des Systemminitors anzeigen lassen.
 

Bild 12
 

Hinweise

  • Es stehen nur die Leistungsindikatoren zur Verfügung, die im verwendeten Leistungsindikatorenprotokoll verwendet wurden. Sollen Leistungsindikatoren bestimmter Prozesse bzw. Programme (z.B. script.exe) angezeigt werden, so müssen diese Prozesse gestartet sein, damit deren Indikatoren zur Anzeige ausgewählt werden können.
  • Passen Sie ggf. den Wertebereich der y-Achse (Vertikale Skalierung) den Faktor zur Darstellung der einzelnen Leistungsindikatoren an.
5 Speichern der Einstellungen des System Monitors
Mit dem Menübefehl "Datei > Speichern unter..." speichern Sie die aktuelle Einstellung des System Monitors ab. Die Einstellungen werden dabei als *.msc-Datei (Microsoft Managment Console File) abgelegt.
6 Starten/Stoppen und Anzeige der Protokollierung
Wählen Sie im linken Fenster in der Baumdarstellung den Eintrag "Console Root > Performance Logs and Alerts > Leistungsindikatorenprotokolle". Öffnen Sie das Kontextmenu zu einem Leistungsindikatorenprotokoll im Arbeitsbereich. Wählen Sie den Eintrag Starten bzw. Beenden.  

Die Aufzeichnung eines Leistungsindikatorenprotokolls kann durch den Benutzer ein- und wieder ausgeschaltet werden. Der Zustand, ob ein Leistungsindikatorenprotokoll gestartet oder beendet ist, wird durch unterschiedliche Farben des Symbols neben dem Namen des Protokolls angezeigt:
  •  Rot bedeutet, das Leistungsindikatorenprotokoll ist beendet
  •  Grün bedeutet, das Leistungsindikatorenprotokoll ist gestartet

 


Bild 13
 

Nach dem Starten eines Leistungsindikatorenprotokolls kann der System Monitor (Performance Monitor) geschlossen werden. Die Daten für die gestarteten Leistungsindikatorenprotokolle werden weiter erfasst, auch wenn der System Monitor geschlossen ist. Sollen die Daten angezeigt werden, können Sie den System Monitor erneut starten und die im Schritt 4 gespeicherte Konfigurationsdatei mit dem Menüeintrag "Datei > Öffnen..." auswählen.
 

Hinweis
Nach dem Öffnen der Microsoft Management Console-Datei sollten Sie ggf. den Zeitbereich zur Anzeige aktualisieren, da u. U. neue Daten seit der letzten Konfiguration in die Protokolldatei geschrieben wurden.

 


Bild 14

Hinweise

  • Anzeige der aktuellen Protokollindikatoren, auch wenn die Aufzeichnung in die Datei gestoppt ist
    Auch wenn ein Leistungsindikatorenprotokoll gerade gestoppt ist (also momentan keine Datenerfassung in der Protokolldatei erfolgt), können die momentanen Werte der konfigurierten Leistungsindikatoren im System Monitor grafisch angezeigt werden. Öffnen Sie dazu den Dialog "Eigenschaften von Systemmonitor" (wie in Schritt 4 beschrieben) und wechseln Sie in das Register "Allgemein". Setzen Sie das Optionskästchen "Beispiel automatisch alle 1 Sekunden erfassen". Im zugehörigen Eingabefeld können Sie die Aktualisierungszeit ändern.
  • Schneller Zugriff auf Steuerfunktionen über die Menüleiste im Arbeitsbereich des System Monitors
    Im Arbeitsbereich des Systemmonitors kann eine Menüleiste angezeigt werden. Mit dieser Menüleiste ist ein schneller Zugriff auf Steuerfunktionen des System Monitors möglich. 
  • Steuerung der Protokollierung mittels der Windows-Kommandozeile
    Die Leistungsindikatorenprotokolle lassen sich auch über die Windows Kommandozeile erstellen, konfigurieren, starten und stoppen. Ausführliche Informationen dazu erhalten Sie in der Online-Hilfe von Microsoft oder geben Sie in der DOS-Eingabeaufforderung den Befehl "logman /?" ein, um eine Beschreibung der möglichen Befehle zu erhalten.
    Die Kommandozeilenbefehle der Leistungsindikatorenprotokolle können in einem WinCC-Bild im Script aufgerufen werden, um die Leistungsindikatorenprotokolle zur WinCC-Runtime aus einem WinCC-Bild heraus zu konfigurieren, zu starten und zu stoppen.
  • Erfassungszyklus festlegen
    Der Erfassungszyklus muss auf den jeweiligen Anwendungsfall abgestimmt werden. Der Erfassungszyklus sollte nur so klein wie nötig eingestellt werden, um die Systemressourcen nicht unnötig zu belasten.
  • Größe der Protokolldatei beachten
    Achten Sie darauf, dass die Protokolldatei nicht den verfügbaren Speicherplatz überschreitet. Sichern Sie aus diesem Grund in ausreichend kurzen Abständen die aufgezeichneten Daten und löschen Sie dann die Protokolldatei, um den Speicherplatz wieder freizugeben. Der Beitrag 23757729 beschreibt, wie Sie den benötigten Speicherplatz für eine Protokolldatei ermitteln können. Beachten Sie, dass kurze Erfassungszyklen ein stärkeres Anwachsen der Dateigröße verursachen.
  • Diagnose über Netzwerk
    Da die Diagnose mit dem System Monitor das System zusätzlich belasten kann, kann es sinnvoll sein, die Diagnose von einem anderen Rechner im Netzwerk durchzuführen. Beachten Sie dazu die Hinweise im Schritt 3 der Anleitung.
  • Leistungsindikatoren von Prozessen
    Sollen Leistungsindikatoren von bestimmten Prozessen protokolliert werden, müssen diese Prozesse zum Zeitpunkt des Einrichtens des Protokolls gestartet sein. Damit werden die Prozesse und deren Leistungsindikatoren bei der Konfiguration des Protokolls zur Auswahl angeboten.
Securityhinweise
Um technische Infrastruktur, Systeme, Maschinen und Netzwerke gegen Cyber-Bedrohungen zu sichern, ist es erforderlich, ein ganzheitliches IT Security-Konzept zu implementieren (und kontinuierlich aufrechtzuerhalten), das dem aktuellen Stand der Technik entspricht. Die Produkte und Lösungen von Siemens formen nur einen Bestandteil eines solchen Konzepts. Weitergehende Informationen über Cyber Security finden Sie unter
https://www.siemens.com/cybersecurity#Ouraspiration.