Entry type: FAQ, Entry ID: 24435650, Entry date: 09/08/2008
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What might be the causes of unsuccessful MSDE installation (Microsoft Desktop Engine)?

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Configuration Notes:
There are many possible causes for a defective or damaged database installation.

If installation or configuration of the MSDE (Microsoft Desktop Engine) was unsuccessful or damaged (e.g. by another installation), then usually all you need to do is reinstall/reconfigure the MSDE.

How to do this is described below under "Restarting the MSDE Installation".

Contents:

1. Restarting the MSDE Installation

1.1 Preparing to install
1.2 Notes for WinCC flexible 2007
     
(Micro/Compact/Standard/Advanced)
1.3 Notes for WinCC flexible 2005 with SP1
     
(Compact/Standard/Advanced)
1.4 Notes for WinCC flexible 2005 Micro with SP1

      (Micro)
1.5 Notes for WinCC flexible 2004 and 2005 without SP1
      (Micro/Compact/Standard/Advanced)

2. Messages when starting WinCC flexible

2.1 Defective database installation

3. Messages during installation of WinCC flexible 2007

3.1 Abortion of installation with Microsoft SQL Server Desktop Engine

4. Messages during installation of the MSDE

4.1 Interruption of the wizard when installing the MSDE
4.2 Failed configuration of the SQL server

4.3 Abortion of installation with automatic deinstallation
4.4 MSDE installation stops with running hourglass
4.5 SQL server does not exist or access is denied
4.6 Problems with already installed SQL server editions

1. Restarting the MSDE Installation
 

No. Restarting the MSDE Installation 
Preparing to install
Make sure that when you install the MSDE the "Server" service is enabled and started. After installing the MSDE you can stop/disable the service again (if not required any further).

The "Server" service is available under "Start > Control Panel > Administrative Tools > Services". Here you double-click on the "Server" service. Select "Automatic" or "Manual" for the Startup setting. Start the service by clicking on the "Start" button.

You must uninstall the old MSDE from your system before reinstalling WinCC flexible. Please use the "Cleanup Support Tool" for uninstalling the MSDE. The tool can be downloaded free of charge in Entry ID What can cause the installation to abort or prevent successful starting of WinCC flexible?.

1.2

Notes for WinCC flexible 2007
(Compact/Standard/Advanced and Micro)

  • On CD1 you start the application
    "MSDE DISK1\MSDE_WCF_setup.exe".
  • In the case of Windows 2000 you must reboot in addition.
  • Then, on CD1 you start the application "MDSE\DISK1\MSDE_WCF_Conf.exe".

    Note:
    Configuration of the SQL server is necessary to protect it.
1.3

Notes for WinCC flexible 2005 with SP1
(Compact/Standard/Advanced)

  • You must be logged on to the system as administrator.
  • On CD2 you start the application "WinCCflexible\Setup\MSDE\DISK1\setup.exe".
    After successful installation the database is also configured.

Alternative:
On CD2 you start "WinCCflexible\Setup\MSDE\DISK1\MSDE\setup.exe".
This reinstalls the MSDE. After successful installation and reboot, from CD2 you start "WinCCflexible\Setup\MSDE\DISK1\setup.exe" to configure the database.

1.4

Notes for WinCC flexible 2005 Micro with SP1

  • On CD1 you start "WinCCflexible\Setup\MSDE\DISK1\setup.exe".
    After successful installation the database is also configured.

Alternative:
On CD1 you start "WinCCflexible\Setup\MSDE\DISK1\MSDE\setup.exe".
This reinstalls the MSDE.

After successful installation and reboot, from CD1 you start "WinCCflexible\Setup\MSDE\DISK1\setup.exe" to configure the database.

1.5

Notes for WinCC flexible 2004 and 2005 without SP1
(Compact/Standard/Advanced and Micro)

  • Download the SQL server directly from Microsoft (approx. 70 MB): Link to the Microsoft pages
  • WinCC flexible only supports the English language (EN-US) version of MSDE.
  • You must be logged on to the system as administrator during installation and configuration of the MSDE.
  • Executing the application "sql2kdesksp3.exe".
    Enter a local target directory of your choice where the installation data is to be unpacked.
  • Now restart your computer before proceeding with the next step.
  • In a DOS input window you switch to the target directory just specified and from there you go to the "MSDE" subdirectory.
  • Execute the following command to install the WinCC flexible instance of the SQL server.

    Setup.exe BLANKSAPWD=1 SECURITYMODE=SQL DISABLENETWORKPROTOCOLS=0 INSTANCENAME="WinCCflexible"

Using BLANKSAPWD means that the SQL server is still unprotected (without password). Therefore you must proceed as follows.

  • Start the SQL server by entering the commando:
    Net.exe start MSSQL$WinCCflexible
  • Store the file WinCCflexibleSetup.dts in a directory of your choice. In that directory you execute the following command:
    Dtsrun.exe /FWinCCflexibleSetup.dts /MWinCCFlexibleSetup /L%WINDIR%\WinCCFlexibleMSDE.log

This configures the SQL server for WinCC flexible and a password is given for the administrator.

2. Messages when starting WinCC flexible
Below we show messages that might be issued with regard to the MSDE as well as their causes and remedies.
  

No. Messages

2.1

Defective database installation

Description:
  • When WinCC flexible starts, the message
    "The MSSQL$WinCCflexible service is not installed" is displayed.
  • If you open an existing project, the message
    "The SQLDMO server class cannot be installed" is displayed.

Possible causes:
These messages normally indicate that the database installation is defective.

Remedy:
Reinstall the WinCC flexible database server.
(See "Restarting the MSDE Installation").

Note:
If the Cleanup Support Tool cannot clear the error, then you should refer to the remedies in Point 4 - Messages during installation of the MSDE.

3. Messages during installation of WinCC flexible 2007
Below we show messages that might be issued with regard to the MSDE during installation of WinCC flexible 2007, as well as their causes and remedies.

Important:
Some changes are made in the "Registry" in the course of this description. Please note here that in general, no warranty can be given for direct changes in the Registry because this is entirely the responsibility of the user.
In any event, you are advised to make a backup of the Registry before undertaking the actions described here.
 

No. Messages
Abortion of installation with Microsoft SQL Server Desktop Engine

Description:
  • During installation of WinCC flexible 2007, the following error message is displayed when the MSDE is installed from the "Microsoft Tool & ServicePacks for WinCC flexible 2007" CD.


Fig. 01
  • The following message is displayed during installation of WinCC flexible from the WinCC flexible 2007 DVD.


Fig. 02

Possible causes:
There is an earlier version of MSDE installed on the computer. This prevents Microsoft SQL Server Desktop Engine 2000 SP4 from being installed.

Remedy:

  1. Run the "Cleanup Support Tool" that you can download in Entry ID What can cause the installation to abort or prevent successful starting of WinCC flexible?.
    Unpack the file and then execute the "CleanupSupportTool.exe" file.
  2. Then restart the computer and install SIMATIC WinCC flexible 2007 following the procedure described in the Booklet or in the Installation Instructions.

Note:
If the Cleanup Support Tool cannot clear the error, then you should refer to the remedies in Point 4 - Messages during installation of the MSDE.

4. Messages during installation of the MSDE
Below we show messages that might be issued with regard to the MSDE as well as their causes and remedies. The error messages listed are not cleared with the "Cleanup Support Tool".

Important:
Some changes are made in the "Registry" in the course of this description. Please note here that in general, no warranty can be given for direct changes in the Registry because this is entirely the responsibility of the user.
In any event, you are advised to make a backup of the Registry before undertaking the actions described here.
 

No. Messages

4.1

Interruption of the wizard when installing the MSDE

Description:
The MSDE installation routine aborts with the following message:
"The wizard was interrupted before MSDE could be successfully installed"

Possible causes:
The reason for the message might be that there is an earlier or defective/damaged installation of the MSDE.

Remedy:
Deinstall the MSDE and then restart the Installation of MSDE.
Please note that you must be logged on to the system as administrator during deinstallation and installation.

Links to further information on this topic (Microsoft Support pages):
English: http://support.microsoft.com/kb/275309/en-us
German: http://support.microsoft.com/kb/275309/de

Note:
Please note that the links of other manufacturers might change. In this case go directly to the home page of the other manufacturer and search for the topic there.

4.2

Failed configuration of the SQL server

Description:

The MSDE installation routine aborts with the following message:
"Setup failed to configure the server. Refer to the server error logs and setup error logs for more information."

Possible causes:

  1. During installation, functions are used that read out the computer name and then convert the name into uppercase letters. With computer names that include lowercase letters this might lead to abortion of the installation.

Remedy:
Change the computer name (don't use lowercase letters) and restart the Installation of MSDE

Links to further information on this topic (Microsoft Support pages):
English: http://support.microsoft.com/kb/285100/en-us
German: http://support.microsoft.com/kb/285100/de

  1. There is already a directory entitled:
    "Microsoft SQL Server\ MSSQL$WINCCFLEXIBLE"  in the installation path.
    The directory might be from an incomplete deinstallation of the MSDE.

Remedy:
Rename the directory.
Example:
"C:\Program Files\Microsoft SQL Server\MSSQL$WINCCFLEXIBLE" in
"C:\Program Files\Microsoft SQL Server\MSSQL$WINCCFLEXIBLE _old"

Then restart the installation of MSDE

Links to further information on this topic (Microsoft Support pages):
English: http://support.microsoft.com/kb/816499/en-us
German: http://support.microsoft.com/kb/816499/de

Note:
Please note that the links of other manufacturers might change. In this case go directly to the home page of the other manufacturer and search for the topic there.

4.3

Abortion of installation with automatic deinstallation

Description:

The MSDE installation routine aborts again with an automatic deinstallation (rollback).
With "rollback" you see the installation bar running "backwards" after it had almost reached the end running "forwards".

Possible causes:

  1. The "Server" service is disabled or not active during the MSDE installation.

Remedy:
Make sure that when you install the MSDE the "Server" service is enabled and started. After installing the MSDE you can stop/disable the service again (if not required any further).

The "Server" service is available under "Start > Control Panel > Administrative Tools > Services". Here you double-click on the "Server" service. Select "Automatic" or "Manual" for the Startup setting. Start the service by clicking on the "Start" button.

  1. Problems with the Performance Monitor Counter.

Remedy:
Possible remedies are available on the Microsoft Support pages.
Execute the following command in the command line ("Start > Run...") to repair the Registry at this point: 

lodctr/r:PerfStringBackup.ini 

Furthermore you need full user rights to the Registry Key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Perflib\009

After repairing the Registry you must restart the installation of MSDE

Links to further information on this topic (Microsoft Support pages):
English: http://support.microsoft.com/kb/315083/en-us
German: http://support.microsoft.com/kb/315083/de

  1. This behavior might occur when you want to install the MSDE from a Microsoft Terminal Server Client on the Terminal Server. Here there might be a conflict with the temporary environment variable.
    The same behavior can also occur if the
    paths set for the user environment variables TMP and TEMP are not the same as for the system environment variables.

Remedy:
Start the MSDE installation from a Terminal Server and not from a Terminal Client. Make sure that the system and local environment variables TEMP and TMP are identical.

The "TMP" and "TEMP" variables are to be found under: "Start > Settings > Control Panel > System".
Open the "Advance" folder. Then open the subfolder "Environment Variables". Now the "User variables" and the "System variables" are displayed.

Links to further information on this topic (Microsoft Support pages):
English: http://support.microsoft.com/kb/830629/en-us
German: http://support.microsoft.com/kb/830629/de 

Note:
Please note that the links of other manufacturers might change. In this case go directly to the home page of the other manufacturer and search for the topic there.

  1. The following Registry entry is missing or its subentries are missing:
    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI.

Remedy:
Please consult your system administrator for the links specified.

Links to further information on this topic (Microsoft Support pages):
English: http://support.microsoft.com/kb/818954/en-us
German: http://support.microsoft.com/kb/818954/de

Note:
Please note that the links of other manufacturers might change. In this case go directly to the home page of the other manufacturer and search for the topic there.

4.4

MSDE installation stops with running hourglass

Description:
The MSDE installation routine stops with running hourglass after copying the files.

Cause:
This behavior might be caused by a resource conflict with services that also use ODBC (Open Database Connectivity).

Remedy:

  1. Stop all services that also use ODBC.
  • Microsoft Internet Information Server (IIS) services
    - Certificate Authority
    - Content Index
    - FTP Publishing Service 
    - Gopher
    - IIS Admin Service
    - World Wide Web (WWW) Publishing
    - Microsoft NNTP Service
    - Microsoft SMTP Service
    - Microsoft Message Queue Service (MMSQ)
    - MSDTC
  • Microsoft Exchange Server 
  • DBWeb
  • ARCserve backup
  • InocuLAN virus protection
  • McAfee antivirus services
  • UniCenter system monitoring
  1. If you have not aborted the Setup, then it should now continue running and successfully install the MSDE. If you have aborted the Setup, then you restart the installation of MSDE

Links to further information on this topic (Microsoft Support pages):
English: http://support.microsoft.com/kb/183692/en-us
German: http://support.microsoft.com/kb/183692/de

Note:
Please note that the links of other manufacturers might change. In this case go directly to the home page of the other manufacturer and search for the topic there.

4.5

SQL server does not exist or access is denied

Description:
You get the following message during the MSDE installation routine:
"SQL Server does not exist or access denied".
After installation you can work with the database, but keep on getting messages. 

Cause:
The MSDE was not configured correctly during installation.

Remedy:

  • For WinCC flexible 2007 you start "MDSE\DISK1\MSDE_WCF_Conf.exe" on CD1.
  • For WinCC flexible 2005 with SP1 - reconfiguration after reboot
    For WinCC flexible 2005 SP1 start "WinCCflexible\Setup\MSDE\DISK1\setup.exe" on CD2.
  • For WinCC flexible 2005 SP1 Micro start "WinCCflexible\Setup\MSDE\DISK1\setup.exe" on CD1.
4.6 Problems with already-installed SQL server editions

Description:
If any edition of SQL Server 2000 with Service Pack 1 or Service Pack 2 is already installed, the installation of SQL Server 2000 Desktop Engine RTM (and MSDE 2000) fails on systems.

Cause:
On a system that already has the Service Pack 1 or Service Pack 2 of the SQL Server 2000 installed, important files are not copied into the required folder.

Remedy:
Execute a full installation of the relevant SQL Server 2000 Desktop Engine Service Pack to clear this problem. There is a more exact description under the following links:

Links to further information on this topic (Microsoft Support pages):
English: http://support.microsoft.com/kb/299351/en-us
German: http://support.microsoft.com/kb/299351/de