文献类型: 常问问题, 条目ID: 60997327, 文献编写日期: 2012年6月18日
(0)
评估

当一个项目不能从 STEP 7 V10.5 移植至 STEP 7 V11 有什么补救措施?

  • 文献
  • 涉及产品

描述
表 01 包含了把一个项目从 STEP 7 V10.5 移植为 STEP 7 (TIA Portal) V11 的步骤。如果用这种方法不能完成移植,表 02 给出了一些补救办法。在移植之前,首先检查已安装的 STEP7 版本,需要安装 STEP 7 V11 的 Sp2(补丁包 2)。SP2 补丁包的下载参看条目:58112582
 

序号 步骤
1 在 STEP 7 (TIA Portal) V11 中,使用菜单命令 "Project > Open..." 打开需要移植的项目。

注意
如果电脑中安装有 STEP 7 Basic V10.5 并且在其中已经打开了需要移植的项目,首先应在 STEP 7 Basic V10.5 中关闭此项目,否则不能进行移植。

2 在打开项目前,会提示你此项目是由先前的 TIA portal V10.5 版本创建的,并询问是否将其移植为当前版本。必须将其移植到V11 版本,才能打开和编辑此项目。在随后的消息中点击“OK” 以确认移植。
3 移植结束后,你会得到使用菜单命令 "Edit > Compile" 来对项目中每个 CPU 进行编译的提示,同样点击“OK” 来确认这个消息。
4 为了能完整的编译项目,在项目导航中必须依次对每个 CPU 执行以下步骤:
  1. 右键点击 CPU(例如:"PLC_1[CPU 1214C...])。
  2. 在弹出的菜单中选择菜单命令 "Compile > All"。
  3. 点击工具栏中 "Save project"  按钮保存项目。

注意
留意在巡视窗口中给出的信息,一般情况下,编译结束后会有 0 条错误。然而,某些情况下,你也许会需要打来某个块来修正错误,例如,数据类型与标签参数不符。

5 下载程序至 CPU 前,检查固件版本。硬件配置中的固件版本必须与实际的 CUP 固件版本一致。 更新模块的固件版本步骤如下:
  1. 在项目导航中打开 "Device Configuration" 。
  2. 在 "Device configuration" 中双击 "CPU module"。然后在巡视窗口中,会有对此模块的描述,包括订货号和固件版本为 V1.0。
  3. 在 "Hardware Catalog" 打开 "CPU" 目录并开始配置 CPU。硬件目录中的 CPU 的订货号必须与已经配置的模块(巡视窗口)中的一致。
  4. 点击硬件目录中的模块的订货号,则这个模块的信息会出现在下方的 "Information" 窗口中,下拉此窗口滚动条会出现 "Version" 对话框,在其中选择固件版本号。
  5. 将 CPU 从硬件目录中拖拽至设备组态窗口中的此模块的位置上。
  6. 此时弹出 "Change device - CPU..." 对话框并有 "Current device" 和 "New device" 的预览,点击 "OK" 来更新 CPU 的配置。
  7. 重新编译并保存后,可以下载项目至 CPU 中。
表 01

如果移植 STEP 7 项目 (如表 01)  没有成功,则得到了在移植过程中发生了一个错误的提示,如下图,那么点击 "Log file"。


图. 01

在日志文件中能够找到发生错误的原因,必须在 STEP 7 V10.5 中修正所有的导致错误的原因。 在 V10.5 中保存和编译成功后,才能够将项目移植为 TIA Portal V11 版本。

图. 02 显示了一个日志文件的样例,第 7 行指出丢失了一个功能块。这种情况下,必须更新调用这个 FB 和它的背景数据块并且重新编译此项目。


图. 02

表 02 包含一些在 STEP 7 项目(如表 01)转换中不成功时,一些补救措施和注意事项。
 

序号 补救措施
1 删除监控表
在 STEP 7 Basic V10.5 中打开项目,在项目导航中打开 "Watch tables" 目录。删除部分或者所有的监控表。保存并关闭项目后,再移植为 STEP 7 V11 版本。 


图. 03

2 移除 know-how protection
在将项目转换成 STEP 7 V11 版本前,应该在 STEP 7 V10.5 版本中移除块中的 know-how protection。转换完成后,可以在 STEP 7 Professional V11 中通过菜单命令 "Edit > Know-How Protection" 重新对块设置保护。
3 剪切和粘贴块中所有的程序段
如果在项目中仅有少量的块,建议进行如下操作:
  1. 在 STEP 7 V10.5 中打开项目并依次打开程序块。
  2. 打开块 (FB, FC or OB)并且在工具栏点击 "Open all networks" 按钮。
  3. 按下组合键 <Ctrl>+<A> 来选择块中所有的程序段。
  4. 按下组合键 <Ctrl>+<X> 来剪切块中所有的程序段。
  5. 按下组合键 <Ctrl>+<V> 来将程序段粘贴回这个块中。
  6. 保存并关闭块编辑器。
  7. 对下一个块重复上述操作。
  8. 在 STEP 7 V10.5 中编译项目后关闭项目,然后再将项目移植为 STEP 7 V11 版本。
4 创建一个新项目
如果上述补救措施都无效的话,那么创建一个新项目并且把块和变量表拷贝至新项目中,过程如下:
  1. 打开 STEP 7 V10.5 软件并打开项目。
  2. 再次打开 STEP 7 V10.5 软件并创建一个新项目。
  3. 在新项目中创建设备组态。
  4. 将 PLC 变量从旧项目中拷贝至新建项目中。
  5. 将块 (FBs, FCs, DBs 和 OBs) 从旧项目中拷贝至新建项目中。
  6. 保存并编译新项目。 
  7. 关闭这两个 STEP 7 V10.5 对话框,并将新建的项目移植为 STEP 7 (TIA Portal) V11 版本的项目。
Table 02

关键字
输入,移植

错误细节
错误详细描述
请帮助我们改进在线支持。
所请求的页面无法显示。请联系网站管理员。
请联系网站管理员