Beitragstyp: FAQ, Beitrags-ID: 62100731, Beitragsdatum: 22.09.2015
(6)
Bewerten

Welche Voraussetzungen müssen erfüllt sein, um ein STEP 7 V5.x Projekt in STEP 7 Professional (TIA Portal) zu migrieren?

  • Beitrag
  • Betrifft Produkt(e)
Wenn Sie ein STEP 7 V5.x Projekt in STEP 7 Professional (TIA Portal) migrieren wollen, müssen Sie die nachfolgenden beschriebenen Softwarevoraussetzungen erfüllen.
1. Softwarevoraussetzungen
Auf dem Rechner, auf dem Sie die Migration durchführen wollen, müssen die folgenden Softwarekomponenten installiert sein:
  • STEP 7 Professional (TIA Portal) ab V11
  • STEP 7 V5.4+SP5 oder höher mit der zugehörigen Lizenz
  • Alle STEP 7 Optionspakete, die in den zu migrierenden Projekten verwendet werden
 
2. Konsistentes Projekt
Das gesamte STEP 7 V5.x Projekt (S7-Programm, HW- und Netzkonfiguration) muss konsistent sein. Um die Konsistenz zu prüfen bzw. sicher zu stellen, führen Sie die jeweilige Funktion zur Konsistenzprüfung aus.
Informationen zur Konsistenzprüfung finden Sie auch unter der Beitrags-ID: 5416540 und im jeweiligen Hilfemenü von STEP 7 V5.x.

Im SIMATIC Manager von STEP 7 V5.x haben Sie auch die Möglichkeit, das STEP 7 Programm nur in einem Programmordner (ohne CPU) abzulegen. Nach der Migration wird in STEP 7 (TIA Portal) für das konsistente Programm eine nicht spezifizierte CPU angelegt.

Hinweis
Die Übersetzung in der Bausteinkonsistenzprüfung führt dazu, dass die Variablen in den Instanz-DBs für die Technologiebausteine (z.B. PID-Funktionsbausteine) wieder auf ihre Defaultwerte zurückgesetzt werden. Das gilt auch für die Datenbausteine, in denen Rezepturen projektiert wurden.

Bevor Sie das Projekt im TIA Portal migrieren, empfehlen wir Ihnen,
  • die Instanzdatenbausteine vorher zu sichern und nach der Übersetzung in der Bausteinkonsistenzprüfung die Instanz-DBs wieder in den Bausteinordner zurück zu kopieren,
  • oder die Konsistenz der Bausteine ohne die Übersetzung in der Bausteinkonsistenzprüfung wieder herzustellen. Erzeugen Sie einen neuen Instanz-DB und kopieren Sie die Daten aus dem alten (inkonsistenten) DB in den neuen (konsistenten) DB.

Projekte aus früheren STEP 7 Versionen
Wenn Sie Projekte aus früheren STEP 7 Versionen (z.B. mit V5.3) in STEP 7 Professional (TIA Portal) migrieren wollen, müssen Sie diese Projekte  vorher in STEP 7 V5.4+SP5 (oder höher) neu übersetzen.

3. Hardware Komponenten
Bei der Migration wird standardmäßig nur die Software migriert und für die im Ausgangsprojekt enthaltenen Geräte wird jeweils ein unspezifiziertes Gerät im migrierten Projekt erzeugt. Hardware- und Netzkonfigurationen und Verbindungen werden nicht mit migriert.

Wenn Sie auch die Hardware Komponenten aus Ihrem STEP 7 V5.x Projekt mit migrieren wollen, müssen Sie im Dialog "Projekt migrieren" die Option "Hardwarekonfiguration einschließen" aktivieren.
 


Bild 1

Hinweis
Wenn Sie bei der Migration die Hardwarekonfiguration mit einschließen, müssen alle Hardware Komponenten in Ihrem STEP 7 V5.x Projekt im Hardware-Katalog des TIA Portals enthalten sein. Die Baugruppen, die zum Stichtag 1.10.2007 bestellbar und nicht abgekündigt waren, werden vom TIA Portal unterstützt und sind im Hardwarekatalog von STEP 7 (TIA Portal) hinterlegt. Enthält Ihr Projekt HW-Komponenten, die im HW-Katalog von STEP 7 (TIA Portal) nicht enthalten sind, wird die Migration abgebrochen.
 
4. Bausteinschutz
Sie können Projekte mit geschützten Bausteinen in TIA Portal migrieren und anschließend in die CPU laden. Dabei werden die aus STEP 7 V5.5 mit S7-Block Privacy verschlüsselten Bausteine als nicht unterstützt gekennzeichnet. Beachten Sie dabei die folgenden Einschränkungen:
  • Der Bausteinschutz aus STEP 7 V5.x (KNOW_HOW_PROTECT oder die Verschlüsselung mit S7-Block Privacy) wird im TIA Portal nicht unterstützt. In STEP 7 Professional steht ein veränderter Bausteinschutz zur Verfügung.
  • Sie können diese Bausteine nicht öffnen und nicht mehr bearbeiten.
  • Der Bausteinschutz aus STEP 7 V5.x kann im TIA Portal nicht mehr entfernt werden.

Empfehlung
Bevor Sie das Projekt migrieren, sollten Sie den Bausteinschutz Ihrer Bausteine in STEP 7 V5.x entfernen. Nach der Migration können Sie ihre Bausteine im Menü "Bearbeiten > Know-how-Schutz" mit dem Schutzmechanismus von STEP 7 Professional (TIA Portal) wieder schützen.

5. Safety
Projekte mit Sicherheitsprogrammen, die Sie mit S7 Distributed Safety erstellt haben, müssen Sie vor der Migration mit S7 Distributed Safety V5.4 SP5 übersetzen. Anschließend können Sie die Projekte in STEP 7 Safety Advanced  weiter verwenden. Auf dem zu migrierenden Rechner müssen die folgenden Softwaretools installiert sein:
  • STEP 7 Safety Advanced
  • S7 Distributed Safety V5.4 SP5
  • F-Configuration-Pack V5.4 SP5 bis V5.5 SP11.

Nach der Migration erhalten Sie ein vollständiges Projekt mit einem Sicherheitsprogramm, welches die Programmstruktur von S7 Distributed Safety und die F-Gesamtsignatur beibehalten hat. F-Bausteine aus der F-Bibliothek S7 Distributed Safety (V1) sind in Anweisungen, die STEP 7 Safety Advanced zur Verfügung stellt, konvertiert.
 


Bild 2

Mit der Übersetzung des migrierten Projekts mit STEP 7 Safety Advanced wird die bisherige Programmstruktur (1: mit F‑CALL) in die neue Programmstruktur von STEP 7 Safety Advanced (2: mit Main-Safety-Block) überführt. Damit ändert sich die F‑Gesamtsignatur und das Sicherheitsprogramm muss ggf. neu abgenommen werden.

6. Migrierbare und nicht migrierbare Komponenten/Softwaretools
Nachfolgende Tabelle enthält die Komponenten/Softwaretools, die Sie in STEP 7 Professional (TIA Portal) migrieren oder nicht migrieren können.
 
Migrierbar Nicht migrierbar 
KOPS7-HiGraph
(Bausteine werden migriert, aber als nicht unterstützt gekennzeichnet.)
FUPiMap
AWLFMS Verbindungen
S7-GRAPH und S7-SCL
Die Bausteine müssen konsistent und nach der Migration im TIA Portal neu übersetzt werden. Anschließend müssen Sie das Projekt neu laden. Die Onlinesicht auf die Bausteine ist erst nach dem Übersetzen und dem Download möglich.

Mit STEP 7 V5.x erstellte Bibliotheken.
 
Abhilfe
Kopieren Sie die Bausteine in ein STEP 7 V5.x Projekt. Nach der Migration können Sie im TIA Portal für die Bausteine eine Bibliothek erstellen.

 S7-PDIAG
Die Bausteine (FB44, DB44, …) werden migriert, aber als nicht unterstützt gekennzeichnet. Sie können die Bausteine laden, aber nicht bearbeiten. Meldetexte und Operandenüberwachungen sind im TIA Portal Projekt nicht mehr vorhanden.
 H-Systeme
 

Multiprojekte
Sie können nur die einzelnen Projekte migrieren.

 

7. Migration von SCL-Programmen
Die S7-SCL-Bausteine können Sie mit oder ohne zugehörige "STEP 7 V5.x - SCL-Quelle" migrieren. Aber eine vollständige Migration wird nur durchgeführt, wenn die zugehörigen Quellen im Quellordner des Ausgangsprojekts vorhanden sind.

 AusgangsprojektNach Migration 
SCL-Bausteine mit QuelleEditierbare SCL-Bausteine
Know-how-geschützte SCL-Bausteine mit QuelleEditierbare SCL-Bausteine. Der Know-how-Schutz wird während der Migration entfernt und kann mit STEP 7 (TIA Portal) wieder aktiviert werden.
SCL-Bausteine ohne QuelleKnow-how-geschützte Bausteine*
Know-how-geschützte SCL-Bausteine ohne QuelleKnow-how-geschützte Bausteine*

*Der Bausteinschutz kann nicht entfernt werden und die SCL-Bausteine sind in STEP 7 (TIA Portal) nicht editierbar.

Beachten Sie auch die Hinweise aus der STEP 7 (TIA Portal) Onlinehilfe, unter "Migration von SCL-Programmen".

Weitere Informationen zu migrierbare Anweisungen finden Sie unter der Beitrags-ID: 59784005. Eine Reihe von Anweisungen können Sie nicht übernehmen und müssen Sie nach der Migration händisch eingeben.

 

8. Systemdiagnose (Systemfehler melden - SFM/RSE)
Die SFM-Bausteine (FB49, DB49, FB50 und FC49) werden nicht migriert. Nach der Migration ist
  • in den CPU-Eigenschaften die Systemdiagnose aktiviert.
  • die Übersetzung der Hardwarekonfiguration in STEP 7 (TIA Portal) erforderlich, um die neuen SFM-Bausteine einschließlich neuer Alarme und Textlisten zu erzeugen.

Anschließend müssen Sie das Projekt in die CPU neu laden.

9. PLC-Meldungen (Alarm_S, Alarm_D, Alarm_8, …)
PLC-Meldungen werden mit allen Parametern und inklusive aller Meldeklassen migriert. Meldungstypen und Meldungsinstanzen werden ebenfalls migriert und unter den PLC-Meldungen im TIA Portal abgelegt. Als Voraussetzung muss im Ausgangsprojekt die CPU-weite Vergabe der Meldenummern gewählt sein. Diese Einstellung können Sie im STEP 7 V5.x Projekt nachträglich aktivieren. Gehen Sie vor der Migration wie folgt vor:
  1. Markieren Sie im SIMATIC Manager Ihres STEP 7 V5.x Projektes Ihre Station (z.B. "SIMATIC 300").
  2. Wählen Sie aus der Menüleiste den Dialog "Extras > Einstellungen...". 
  3. Wechseln Sie in das Register "Meldenummern" und aktivieren Sie die Einstellung "Meldenummern immer CPU-weit eindeutig vergeben".
  4. Speichern Sie anschließend Ihr Projekt mit der Funktion "Datei > Speichern unter..." zusammen mit der Option "Mit Reorganisation (langsam)".

Erst mit dieser Einstellung wie im Bild 3 werden die Meldungen migriert.
 


Bild 3

10. TIA Portal Readiness Check Tool
Mit dem TIA Portal Readiness Check Tool können Sie auf einfache Weise prüfen, ob die in Projekten enthaltene Hardware vom TIA Portal unterstützt wird. Das Tool ist einsetzbar für:
  • STEP 7 V5.4
  • STEP 7 V5.5
  • WinCC V7
  • WinCC flexible 2008

Weitere Informationen finden Sie unter der Beitrags-ID: 60162195.

11. Projektierungen fehlender/nicht unterstützter Optionspakete
Enthält Ihr Projekt Projektierungen aus Optionspaketen, die mit Ihrer aktuellen STEP 7 Version nicht kompatibel, oder die auf Ihrem Rechner nicht installiert sind, können Sie das Projekt in STEP 7 (TIA Portal) nicht migrieren. Wenn Sie das Projekt in STEP 7 V5.x öffnen, erhalten Sie die Meldung auf die fehlenden Optionspakete.

Für den Fall, dass diese Projektierungen weiterhin obligatorisch sind, müssen Sie die fehlenden Optionspakete installieren. Beachten Sie dabei die Voraussetzungen, die für die Installation mit der aktuellen STEP 7 Version erforderlich sind. Zum Beispiel benötigen Sie für SIMOTION SCOUT mit STEP 7 V5.5+SP2 unter Windows 7 (32 Bit) die Version 4.2.1 (oder höher). Weitere Informationen zur Kompatibilität finden Sie unter der Beitrags-ID: 18734363. Nach der Installation der fehlenden Optionspakete müssen Sie ihr Projekt nochmal übersetzen.

Sollten Sie die Projektierungen der fehlenden Optionspakete nicht mehr benötigen, müssen Sie das Projekt in STEP 7 V5.x reorganisieren. Öffnen Sie dazu im SIMATIC Manager den Dialog "Datei > Speichern unter..." und aktivieren Sie die Option "Mit Reorganisation (langsam)". Ändern Sie den Projektnamen oder den Pfad und bestätigen Sie mit OK. Nach dem Speichern und Reorganisieren können Sie das neu angelegte Projekt in STEP 7 (TIA Portal) migrieren.
 

 
Bild 4

Mit dieser Option wird das Projekt während dem Speichern zusätzlich überprüft und reorganisiert. Unter Umständen wird auch der Speicherbedarf des Projektes verringert. Alle Elemente der fehlenden Optionspakete werden aus dem Projekt gelöscht. Weitere Informationen finden Sie in der STEP 7 V5.5 Onlinehilfe, unter "Projekt speichern unter".

12. PLC-Migration nach S7-1500 ab STEP 7 (TIA Portal) V12
Programmierempfehlungen und Informationen zur Migration nach S7-1500 ab STEP 7 (TIA Portal) V12 finden Sie unter der
  • Beitrags-ID: 67858106 (Migration nach S7-1500)
  • Beitrags-ID: 67582299 (Programmierempfehlungen für die Migration nach S7-1500

Weiterführende Informationen
finden Sie in der STEP 7 (TIA Portal) Onlinehilfe, unter "Allgemeine Hinweise zur Migration von Programmbausteinen".

Erstellumgebung
Bilder in diesem FAQ sind mit STEP 7 V5.5 und mit STEP 7 (TIA Portal) V13 erstellt worden.