×
Siemens Industry Online Support
Siemens AG
Entry type: FAQ Entry ID: 73108209, Entry date: 07/02/2015
(16)
Rate

Why can you not open a project created with a previous version of STEP 7 Safety Advanced in the current version of STEP 7 (TIA Portal)?

  • Entry
  • Associated product(s)
When you attempt to open the project, you get the error message "You cannot work fully with Project because necessary products are missing".
Description
If you have created a STEP 7 Safety Advanced project with a previous version and want to open it in the current version of STEP 7 (TIA Portal), you get the message shown in Fig. 01. This message informs you that the project cannot be opened because the necessary products are missing.

In Compatibility mode, however, this message refers to the required version of STEP 7 Safety Advanced and without these missing safety components you cannot open or edit the project.
   


Fig. 01

The sample message shown in Fig. 01 indicates that STEP 7 (TIA Portal) V13 SP1 is installed on your computer, but only version V12 of STEP 7 Safety Advanced is installed. If you upgrade STEP 7 (TIA Portal) on your computer from V12 to V13, then you must also upgrade any existing optional software packages. To be able to process a project in STEP 7 (TIA Portal) V13 SP1 which includes configurations with the Safety Advanced option package, it is necessary to have Safety Advanced V13 SP1.

Remedy
Install Safety Advanced V13 SP1 on your computer and open the project again.

Creation Environment
The screens in this FAQ response were created with STEP 7 (TIA Portal) V13 SP1.

 

Security information
In order to protect technical infrastructures, systems, machines and networks against cyber threats, it is necessary to implement – and continuously maintain – a holistic, state-of-the-art IT security concept. Siemens’ products and solutions constitute one element of such a concept. For more information about cyber security, please visit
http://www.siemens.com/industrialsecurity.