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Legal information
Warning notice system

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger.

DANGER
indicates that death or severe personal injury will result if proper precautions are not taken.

WARNING
indicates that death or severe personal injury may result if proper precautions are not taken.

CAUTION
indicates that minor personal injury can result if proper precautions are not taken.

NOTICE
indicates that property damage can result if proper precautions are not taken.
If more than one degree of danger is present, the warning notice representing the highest degree of danger will be 
used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to property 
damage.

Qualified Personnel
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. Qualified 
personnel are those who, based on their training and experience, are capable of identifying risks and avoiding 
potential hazards when working with these products/systems.

Proper use of Siemens products
Note the following:

WARNING
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended or 
approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be complied with. The information in the relevant documentation must be observed.

Trademarks
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication 
may be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

Disclaimer of Liability
We have reviewed the contents of this publication to ensure consistency with the hardware and software described. 
Since variance cannot be precluded entirely, we cannot guarantee full consistency.  However, the information in 
this publication is reviewed regularly and any necessary corrections are included in subsequent editions.

Siemens AG
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GERMANY
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Security information 1
Siemens provides products and solutions with industrial security functions that support the 
secure operation of plants, systems, machines, and networks.

In order to protect plants, systems, machines and networks against cyber threats, it is 
necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial 
security concept. Siemens’ products and solutions constitute one element of such a concept.

Customers are responsible for preventing unauthorized access to their plants, systems, 
machines and networks. Such systems, machines and components should only be connected 
to an enterprise network or the internet if and to the extent such a connection is necessary 
and only when appropriate security measures (e.g. firewalls and/or network segmentation) are 
in place.

For additional information on industrial security measures that may be implemented, please 
visit:
https://www.siemens.com/industrialsecurity

Siemens’ products and solutions undergo continuous development to make them more secure. 
Siemens strongly recommends that product updates are applied as soon as they are available 
and that the latest product versions are used. Use of product versions that are no longer 
supported, and failure to apply the latest updates may increase customer’s exposure to cyber 
threats.

To stay informed about product updates, subscribe to the Siemens Industrial Security RSS 
Feed under
https://www.siemens.com/industrialsecurity.
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Preface 2
About this document

PCS 7  SMART Getting Started - Part 1 (V9.0 with APL) gives you an overview of the PCS 7 
SMART process control system, enabling you to create a simple project. You can configure 
the project on an existing SIMATIC PC station.

PCS 7 SMART is suitable for companies that need cost efficient automation for small plant 
configurations.

This Getting Started document is aimed at beginners who work on the following areas:

● Configuration

● Commissioning and service

In the rest of the document, we address the document as Getting Started - Part 1.

Prerequisites
You must have knowledge in the following areas:

● The following Microsoft operating systems:

– Windows 7 Ultimate / Enterprise SP1 (64-Bit)

– Windows 7 Professional SP1 (64-Bit, English version only)

– Windows 10 Enterprise 2015 LTSB (64-Bit)

● Basic knowledge in the field of process automation

● Functions and configuration of SIMATIC S7 (S7-410, STEP 7)

● Functions and configuration of SIMATIC NET (network components, transmission media)

Note
● SIMATIC PCS 7 SMART is based on PCS 7 Asia. PCS 7 SMART is specifically designed 

for smaller projects with up to 2400 Process Objects (PO) within the Chinese and Indian 
markets. With PCS 7 SMART portfolio, we offer a custom-fit product for projects with up to 
eight PCS 7 SMART OS Single Stations. Specifically, the combination of SMART software 
and SMART hardware increases functionality and, therefore, makes PCS 7 SMART a 
suitable software for such projects in China and India.

● PCS 7 SMART does not come with a trial version. A USB hardlock must be plugged in 
permanently for configuration and runtime.

PCS 7 SMART Getting Started - Part 1 (V9.0 with APL)
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Accessing PCS 7 SMART documentation
You can find the PCS 7 SMART documentation at the following locations:

● On the Process Control System; SIMATIC PCS 7 SMART DVD 

● On the computer, in the installation folder 

● On the Internet:

– Region India (https://support.industry.siemens.com/cs/in/en/ps/21144)

– Region China (https://support.industry.siemens.com/cs/cn/zh/ps/21144)

In this entry, you can also find the manual on PCS 7 SMART, which shows the differences 
between PCS 7 SMART and PCS 7.

Information about PCS 7 basic system on the Internet
All product and order information regarding PCS 7:

● Internet link (https://www.siemens.com/PCS7)

Overview of the most important technical information and solutions for PCS 7 in the Industry 
Online Support:

● Internet link (https://support.industry.siemens.com/cs/document/63481413)

All information on Support and Service in the Industry Online Support:

● Internet link (https://support.industry.siemens.com)

Note

We recommend you to subscribe to the newsletter, which keeps you constantly updated with 
current information about our products.

Preface
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Contents of the PCS 7 Readme files
The PCS 7 V9.0 SMART Readme file is available in various versions:

1. PCS 7 SMART Readme (offline)
It is installed during the PCS 7 setup and it contains general notes and links to documents 
on the internet.

2. PCS 7 SMART Readme (online)
This document contains specific information on the installation and use of PCS 7 SMART.
It is only available on the internet so that we can keep it up to date.
You can download the current version of the document under the entry ID 109744321 in 
the Industry Online Support:

– Region India (https://support.industry.siemens.com/cs/in/en/view/109744321)

– Region China (https://support.industry.siemens.com/cs/cn/zh/view/109744321)

3. PCS 7 Readme (online)
This document contains general information on the installation and use of PCS 7.
You can download the current version of the document under the entry ID 109744312 in 
the Industry Online Support:

– Internet link (https://support.industry.siemens.com/cs/ww/en/view/109744312)

Note

It is vital that you use the information from the most recent version of the SMART and PCS 7 
Readme (online) before you begin the installation or use of PCS 7 V9.0 SMART version.

The information in the PCS 7 SMART Readme (online) supersedes the information in the 
PCS 7 Readme (online).

Each of the products comes with product-specific information in the form of readme files.

The information contained in these readme files also applies to using products in PCS 7 
SMART.

Electronic manuals and help system for the basic system PCS 7

Pre-installed manuals
Once you have installed PCS 7 on your computer, the following PCS 7 documentation is 
immediately available. 

● You can find this documentation in the section SIEMENS Automation > SIMATIC > 
Documentation or the product information in the "Start" menu of Windows:

– PCS 7 - Catalog Overview (PDF)

– PCS 7 - Operating Instructions - OS Process Control (PDF)

– PCS 7 - Installation Manual - PC Configuration (PDF)

– PCS 7 - Configuration Manual - Engineering System (PDF)

– PCS 7 - Configuration Manual - Operator Station (PDF)
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Complete documentation for PCS 7 on the internet and document updates
The complete PCS 7 documentation is available in multiple languages at the following Internet 
site:

● Internet link (https://www.siemens.com/pcs7-documentation)

You also have the option of updating the installed PCS 7 help system and post-installing the 
PCS 7 system documentation. The "PCS 7 Documentation Portal Setup" required for this is 
available for download under the entry ID 109744320 in the Industry Online Support:

● Download link (https://support.industry.siemens.com/cs/ww/en/view/109744320)

Note
Timeliness of online documents

Documents available online may be up-to-date than the version of documents installed with 
PCS 7 Setup. The statements in documents available online should therefore be given priority 
over installed documents.
Information on modified documents

In order to keep yourself informed about changes to the PCS 7 readme and the other PCS 7 
documentation, we recommend that you activate the relevant notification in the Industry Online 
Support:
● Internet link (https://support.industry.siemens.com)

Guide
Getting Started - Part 1 explains the individual steps required to create the color_gs project. 
You will find important information required to understand the steps in this Getting Started as 
well as detailed instructions on how to work through them.

Getting Started - Part 2 is a continuation of Getting Started - Part 1. In this Getting Started, 
you will configure a unit for the color project and become familiar with the functions of rational 
engineering.

You can download the completed PCS 7 SMART project color_gs and the documentation 
Getting Started - Part 1 and Getting Started - Part 2  from the internet:

● Getting Started - Part 1 (https://support.industry.siemens.com/cs/in/en/view/109751150)

● Getting Started - Part 2 (https://support.industry.siemens.com/cs/in/en/view/109751151)

● To download the project, click the icon: 

Open the projects on the Engineering Station (ES) to view the configuration data and compare 
the data with your own configuration data. Activate the project on an Operator Station (OS) in 
order to operate and monitor the process.
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Note
● To test the color_gs project in process mode, the hardware configuration of the project must 

correspond to your actual hardware configuration. If necessary, replace the hardware 
components of the color_gs project with the actual hardware components present.

● You will find additional information about opening and adapting the color_gs project in the 
"Starting and adapting the color gs project" chapter.

Conventions
In this document, all the instructions are given using their full menu commands. You can also 
access virtually all of the functions through the shortcut menu or by double-clicking.

Note

In this documentation, the versions of profiles, libraries and modules are always displayed as 
Vxx.

Ensure that you use an appropriate version for your hardware or software.

Example:
● Profile: PCS7_Vxx
● PCS 7 AP Library Vxx
● IE General: SW Vxx

Note

The names of elements in the software interface are specified in the language of this 
documentation. If you have installed a multi-language package for the operating system, some 
of the designations will be displayed in the base language of the operating system after a 
language switch and will, therefore, differ from the designations used in the documentation.

In PCS 7 SMART, you can use standard Windows functions in many situations:

● Multiple selection using the "Ctrl" and "Shift" keys

● Column sorting in tables by clicking on the column header

● Use of "drag and drop" instead of "copy and paste"

The individual tutorials in this document build on each other to create a complete PCS 7 
SMART project step-by-step by working through all the modules in the specified sequence. 
For this reason, please work through all the tutorials in the given sequence.

PCS 7 SMART glossary
The PCS 7 SMART glossary containing the definitions of important technical terms used in 
the documentation are available within the PCS 7 SMART software through the Help menu in 
the SIMATIC Manager ( Help>Contents).

Preface

PCS 7 SMART Getting Started - Part 1 (V9.0 with APL)
Getting Started, 12/2017, A5E42181435-AA 15



Additional information
You can find detailed background information and general context in the following 
documentation, which you can use for reference purposes: 

● Configuration manual; Process Control System PCS 7; Engineering System
● Configuration manual; Process Control System PCS 7; Operator Station
This documentation is available as an online help and in the PDF format.

● Online help

– In the PCS 7 software in SIMATIC Manager, select Help > Topics.

● PDF file

– In the "Start" menu, under the SIEMENS Automation > SIMATIC > Documentation 
folder, in the preferred language.

– In the _Manuals folder of the SIMATIC PCS 7  SMART DVD.

If you wish to familiarize yourself with specific topics, refer to the appropriate manuals. For 
example: SFC and CFC.

Preface
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Requirements for Getting Started 3
3.1 Hardware requirements for Getting Started - Part 1

Hardware components         
The list below shows the hardware components you need for Getting Started. For some 
hardware components, you must use a specific version because it is not possible to work on 
Getting Started with an older version.

Hardware Component Version Used in Getting Started Other Version Possible
PG or PC with a standard 
network card

Intel® PRO/1000 Yes

Rack UR2 Yes
Power supply PS 407 4A Yes
CPU CPU 410 SMART Firmware V8.2 Yes
Crossover cable  No
USB hardlock PCS 7 SMART V9.0 No (Hardlocks are version 

specific)

Use of other hardware components
If you are using other hardware components, you must place them in the relevant places. For 
example, in HW Config, we recommend the usage of same components that are used in 
Getting Started.

If you have different hardware, you can find additional information in the "ES Configuration 
Manual".

PCS 7 SMART Getting Started - Part 1 (V9.0 with APL)
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3.2 Software requirements for Getting Started - Part 1

Software requirements    
● Information about installation and operation of the PCS 7 SMART software is available in 

the Process Control System PCS 7; PCS 7 Readme file (see "Preface (Page 11)").

● You will find information on the installation of the PCS 7 SMART software in these 
documents: Process Control System PCS 7; PCS 7  PC Configuration.

Note
Engineering system

PC stations with a pre-installed Engineering System contain all the necessary software 
components. However, you must transfer the license keys to PC stations.

Requirements for Getting Started
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3.3 Required configuration for Getting Started - Part 1
If you have not purchased a bundle PC with the Getting Started, note the PC settings to be 
performed for PCS 7 SMART.

For more information, refer to Process Control System; PCS 7  PC Configuration manual.

Requirements for Getting Started
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PCS 7 SMART overview 4
4.1 PCS 7 SMART overview

Description
PCS 7 SMART is a powerful process control system with many automatic functions to assist 
you during configuration of a plant. It enables you to create a project quickly and conveniently. 
You will get to know about the automatic functions in this Getting Started document. PCS 7 
SMART also provides many options for creating individual, project-specific solutions 
customized to your requirements. These individual solutions are not part of this Getting Started 
document. For more information, refer to the configuration manuals.

A PCS 7 SMART project includes the following objects:

● Hardware configuration

● Blocks

● CFC charts and SFC charts

These objects are always included regardless of the number of operator stations, modules, 
and networks.
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4.2 PCS 7 SMART inclusions

PCS 7 SMART applications
You create a smart project on an Engineering Station (ES), which provides various 
applications. All applications have simplified user interface to ease your operations and display 
your configuration data. When you work through Getting Started project, you will use the 
following applications:

● SIMATIC Manager - the central application and gateway to all other applications that you 
use to create a PCS 7 SMART project. SIMATIC Manager is the starting point for creating 
your entire project.

● HW Config - used to configure entire hardware of a system, for example, CPUs, power 
supply, and communications processors.

● Continuous Function Chart (CFC) and Sequential Function Chart (SFC) Editors - used to 
create CFCs and SFCs. 

● Operator Station (OS) - used to configure the OS.

PCS 7 SMART overview
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4.3 Introduction to SIMATIC Manager

SIMATIC Manager
SIMATIC Manager is the central application within the PCS 7 SMART system and is used to 
access all the other applications to configure your PCS 7 SMART project. 

SIMATIC Manager and all other applications are linked. For example, all the blocks you have 
inserted into a CFC chart using the CFC editor.

This linking provides convenient access to all the data created in SIMATIC Manager and its 
applications. For example, you can visualize a process tag from a CFC chart quickly and easily 
when configuring the OS.

Due to the central function of SIMATIC Manager within PCS 7 SMART, it is worth taking time 
to become familiar with its structure and functions.

PCS 7 SMART overview
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4.4 Basic Structure of SIMATIC Manager

Structure of SIMATIC Manager 
SIMATIC Manager has a split window similar to Windows Explorer:

● In the left pane, a tree view is displayed with different content depending on the View 
(Page 25) selected.

● In the right pane, the detail window, you can view details of the object you have selected 
in the tree view.

PCS 7 SMART overview
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4.5 Different views of SIMATIC Manager

Different views of SIMATIC manager
SIMATIC Manager provides you with three views. An important feature of these views is that 
the objects they contain exist only once in reality but can be displayed and edited in the various 
views. 

The structural principle of the views is the same. The left pane displays the tree view and the 
right pane displays the detail view. Each view has advantages for performing certain tasks:

● Component view : Displays the physical memory location of the individual objects. For 
example, charts and blocks. In this view, you can view the mapping of  blocks and charts 
to the relevant AS.

● Plant view: Displays the exact hierarchical structure of your plant. You can divide the plant 
into units and see which charts and which process pictures belong to which unit.

● Process object view : Displays the details of individual objects from the plant view. This is 
applicable when you want to assign the same parameter value to a large number of objects 
or if you want to add the same comments or make the same interconnections for these 
objects.

The Getting Started step by step instructions guide you in selecting the SIMATIC Manager 
views. PCS 7 SMART automatically saves all the work that you perform.
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4.6 Procedure

4.6.1 Opening SIMATIC Manager

Procedure            
You can start SIMATIC Manager in two ways:

● Double-click the STEP 7 icon  on your desktop.
Or

● On the "Start" menu, select Siemens Automation > SIMATIC > SIMATIC Manager.

When you start SIMATIC Manager, the previously opened project automatically appears. 

PCS 7 SMART overview
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Initial work for the project 5
5.1 Planning the project

5.1.1 The "color_gs" project

Introduction        
After a brief overview of PCS 7 SMART (Page 21), you can start creating the  color_gs project. 
Additional theoretical knowledge is required to understand these instructions. Hence, each 
topic is provided with some background information.

Plant description
Only a small part of the entire plant will be configured for automatic dye production since 
configuring the entire plant will be out of scope for this Getting Started project. This minimal 
plant configuration will be integrated with the entire plant to understand the overall context in 
a better way.

The individual phases of the production process are:

Phase I - Raw Materials
The liquid raw materials for the product are stored in two raw material tanks and are pumped 
from these tanks to the reactors. 

The solid raw materials are stored in three silos. Screw conveyors are used to measure out 
the solid raw materials from the silos to a weigh hopper for weighing. Another screw conveyor 
and a blower are used to blow the raw materials into one of the two mixing tanks in the correct 
mixing ratio.

Phase II – Production
The required quantities of liquid material are fed from the two raw material tanks to Reactor 1 
or Reactor 2 by means of valves. The solid materials from the mixing containers are transported 
via screw conveyors to the reactors where they are blended using an agitator. The product is 
produced in the reactors by agitating, heating and cooling the raw materials together with the 
additives. Valves and actuators control the temperature in the reactors. If required, water from 
a filtration plant can be introduced into the reactors using a flow controller.

Phase III - Holding Phase
The product is pumped to a holding tank for post processing. Here, it is stirred slowly and kept 
at a constant temperature.
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Phase IV – Filling
After the holding phase, the product is temporarily stored in a filling tank. From there, it is filled 
into bulk tank trucks or small packing drums.

Phase V – Cleaning
The reactors, piping, valves, actuators, holding tank, and filling tank can be cleaned by a 
cleaning-in-place (CIP) system. The resulting wastewater is collected in a separate effluent 
tank and disposed.

5.1.2 Task list for Getting Started

Specific Configuration Task   
You will now configure part of Phase I – Raw Materials:

Specifically, you will configure the storage of the liquid raw materials in two raw material tanks 
and the pump control used to pump these raw materials to the two reactors.

Initial work for the project
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Piping and Instrumentation Diagram (P&ID)
The piping and instrumentation diagram illustrates the precise sequence of the configuration 
task and displays all the associated relevant process tags:

Explanation of the piping and instrumentation flow diagram
The terms used have the following meanings:

● LI111 (level indicator): measurement of the current fill level of the raw material tank.

● NK111 and NK112 (customer-specific identifier for valves): shut-off valves which must 
always be opened for dosing raw materials.

● NP111 (customer-specific identifier for motors): pump that transports the raw material to 
the reactors.

● NK113 or NK114 (customer-specific identifier for valves): valves, of which only one may 
be open at a given time, in order to transport the raw material to either reactor 1 or reactor 
2.

● FC111 (flow control) : actuator which regulates quantities for the raw material.

The states of the valves NK111 to NK114 can be displayed and monitored in the operator 
station. You also have the possibility to influence the dosing via FC111.
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5.1.3 System configuration for the 'color_gs' project

Structure       
The color_gs project will be implemented on a minimum system consisting of a single 
automation system with a combined engineering station and operator station. The operator 
station is designed as a single station system. The following figure illustrates the system 
configuration.

Description
In Getting Started, you will build a control system which contains the following components:

● Automation system (AS):
The individual components are described in the section "Requirements for performing the 
Getting Started".

● Program, which controls the "color_gs" plant: 
You create this program in the ES and download it to the CPU. The CPU executes the 
loaded program and displays the process values.

● Operator station (OS): 
The plant operator controls and monitors the plant during runtime. You can create the 
process picture seen by the plant operator on the OS.

Note

Plant configuration and hardware settings that result from it need to be especially adapted 
to the requirements of this Getting Started. 

When you configure a real project, you will use more automation systems and also operate 
the engineering station and operator station(s) on several computers. In this case, the 
hardware settings will be more complex. This will no longer correspond to the Getting 
Started descriptions.
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5.1.4 Configuration tasks overview

Configuration Sequence
You will configure the system components in the following configuration steps:

● Setting the Parameters for the Network (Page 32)

● Creating the Project (Page 34)

● Configuring the Stations (Page 41)

● Working in the Plant Hierarchy (Page 52)

● Creating CFC Charts (Page 61)

● Creating SFC Charts (Page 107)

● Compiling, Downloading, and Testing Charts (Page 129)

● Configuring operator stations (Page 141)

● Creating the Process Pictures (Page 153)

● Working in Process Mode (Page 171)

● Performing the Additional Task (Page 185)
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5.2 Preparational settings for the network

5.2.1 Network and Interface settings

Settings         
Before you configure the color_gs project, perform the following settings:

● Network adapter settings on the configuration console (Page 32)
PCS 7 SMART automatically identifies the network adapters installed on your computer 
during startup. You can use this information to program the interfaces on the configuration 
console.

Note

These settings are usually made immediately after PCS 7 SMART is installed. Verify the 
settings and make necessary modifications if required.

● Selecting the network adapter
Select the network adapter used to communicate.

5.2.2 Procedure

5.2.2.1 Configuration console settings

Prerequisites                   
● All the necessary hardware components must be inserted on the rack and switched on.

● The crossover cable must be connected between the 3Com network adapter of your ES 
computer and the Ethernet connection of the CPU.

Procedure
1. On the "Start" menu, Select Siemens Automation > SIMATIC > SIMATIC NET > 

Communication Settings. The "Siemens Communication Settings" dialog box is displayed.

2. Open the "Modules" folder in the tree view.

3. Select the network adapter by which communication between the automation system and 
the OS takes place.

4. Double-click the "General" entry in the detail view. The detail view for "General" is displayed.

5. In the detail view, select the "Configured mode" entry from the "Mode of the module" drop-
down list.

6. Click "Apply". This button is only active if you have made changes. Your settings are now 
saved. The network adapter is activated now.
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7. Select the "Access points" folder in the tree view.

8. Double-click the "S7ONLINE" access point in the detail view. The detail view for "Access 
point" is displayed.

9. In the "Associated interface parameter assignment" drop-down list, select "PC internal.local.
1". Click "Apply" to save your settings.

10.Specify "PG mode" as the "Mode of the module" for all other network adapters.

11.Close the configuration console.
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5.3 Creating the project

5.3.1 "New Project" Wizard usage

PCS 7 "New Project" Wizard
The PCS 7 New Project wizard starts automatically when you open SIMATIC Manager using 
default settings. You can enable or disable this option in the PCS 7 New Project wizard.

The New Project wizard guides you in creating a new project and offers default settings. The 
PCS 7 wizard automatically creates various objects according to the default settings or user 
defined settings. 

color_gs objects
The following objects are essential for the color_gs project:

● Hardware objects: SIMATIC stations, for example a SIMATIC 400 station for the AS, a 
SIMATIC PC station for the OS.

● Hierarchy folders representing the hierarchy levels of the plant structure. The number of 
hierarchy folders created corresponds to the setting you enter in the PCS 7 wizard.

● A CFC chart

● An SFC chart

● One picture per plant hierarchy folder

● A master data library

5.3.2 Background knowledge for the PCS 7 Wizard

What happens in the background when a new project is created? 
The next two sections provide you with some theoretical background knowledge for the 
PCS 7 New Project wizard. Two objects that are of great importance for working with PCS 7 
SMART are:

● Multiproject

● Master data library

How does a multiproject function?
When you create a new project with the PCS 7 wizard, a multiproject is created automatically. 
A multiproject consists of a number of single projects. 

In the context of the color_gs project, the multiproject is structured as follows: The multiproject 
represents the entire plant and all of the single projects within this multiproject based on the 
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individual phases of the process for producing paint. Since you are configuring only one phase 
of the overall plant in this Getting Started, your multiproject contains only a single project. 

Multiprojects give you an advantage to distribute single projects to different configuration 
engineers who can then edit them. Once the configuration of the single projects is complete, 
they can be merged to form a complete project. 

In Getting Started, although you will be working within a multiproject, you will not be using the 
wide range of functions provided by this multiproject engineering. 

Detailed information is available in the Process Control System PCS 7; Engineering System 
Manual. 

What is a master data library?
When you create a new project with the PCS 7 wizard, a master data library is created 
automatically. You store all the blocks required for the entire project in this library. Before you 
create a CFC, for example, you first store all the standard blocks you will insert in this CFC in 
your master data library. 

A master data library provides the following advantages: 

● When you archive a project, the master data library is automatically archived along with it.

● You can also adapt the blocks and use copies (instances) of these adapted blocks 
repeatedly in the project.

In the context of a multiproject, the master data library is important because it allows you to 
provide all the project engineers who are involved with blocks of a defined version so that you 
can ensure that only this version is used in the project.
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5.3.3 Procedure

5.3.3.1 Creating the color_gs Project

Procedure     
The PCS 7 Wizard assists you in creating the "color_gs" project. To create the "color_gs" 
project:

1. Open SIMATIC Manager.

2. Select File > 'New Project' Wizard.
The "PCS 7  Wizard: 'New Project'" is displayed.

3. In step 2(4) "Which CPU are you using in your project?", in the "CPU" drop-down list, select 
the required CPU.
All available automation systems of the selected CPU type is listed with MLFB numbers 
and brief descriptions.
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4. In the "Bundle" section, select the required "MLFB" entry, and then click "Next".

5. In Step 3(4) "Which objects are you still using?", perform the following settings: 

– Select "4" from the "Number of levels" drop-down list.

– Under "AS objects", verify that the "CFC" and "SFC" check boxes are selected.

– Select the "PCS 7 OS" check box under "OS objects". The "Single station system" option 
is automatically selected.

6. Click "Next".

7. In Step 4(4), enter the name "color_gs_prj" in the "Directory name" box and accept the 
default storage location.
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8. Click "Preview >>>" to see a preview of your current configuration status. 
This preview corresponds to the appearance of the project in SIMATIC Manager.

9. Click "Finish". 

Note
● When you start SIMATIC Manager, the previously opened project is displayed, to close the 

previous project and to open the "color_gs_prj" project, follow the instructions provided in 
the section "How to close and open the "color_gs" project (Page 39)".

● To activate different views, follow the instructions provided in the section "How to work with 
the various views (Page 39)".
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Result
The project is displayed in the plant view of the SIMATIC Manager as follows:

5.3.3.2 Opening and Closing the "color_gs" Project

Procedure for Closing a Project              
1. If you have other projects open in SIMATIC Manager, close these projects.

2. Select Window > [Name of project] and select the project you want to close. 
SIMATIC Manager displays the project in the foreground.

3. Select File > Close. The project is closed.

Procedure for Opening a Project
1. Open SIMATIC Manager.

2. If your project "color_gs" does not open automatically, select File > Open. The "Open 
Project" dialog box is displayed.

3. Select the "Multiprojects" tab and select "color_gs_prj_MP".

4. Click "OK".  The project with the associated master data library is displayed.

5.3.3.3 How to Work in the Various Views

Introduction   
Once you have opened your project in SIMATIC Manager, you can display the project in various 
views and switch between these views.

Procedure
Select View > [Name of the desired view] in SIMATIC Manager:

● Component view

● Plant view

● Process object view
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or

Select  Window > [Name of the project (name of the view)] if you have already opened several 
projects.
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5.4 Configuring the stations

5.4.1 Configuration overview

Overview
Configure the control system components which the PCS 7 wizard: 'New Project' has 
automatically inserted. This includes components such as the AS, the OS, and the associated 
connections. 

For this purpose you must perform the following configuration steps:

Step Action
 1 Configure AS (Page 42)
 2 Rename PC station (Page 44)
 3 Configure OS (Page 45)
 4 Set connection in NetPro (Page 47)
 5 Download hardware configuration (Page 50)

Local PC station
The plant configuration for this Getting Started is a single station system; the ES and OS are 
on one computer. In this way, the local PC station you configure represents the ES and the 
OS at the same time.
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5.4.2 Procedure

5.4.2.1 AS configuration

Procedure
1. In SIMATIC Manger, in "Component View", select "color_gs_prj_MP\color_gs_prj_Prj

\SIMATIC 400(1)"  folder in the tree view.

2. Select  "Hardware" object in the detail view. Click Edit > Open Object. 
HW Config opens and the hardware structure of your plant is displayed.

Note

Select  View > Catalog if the hardware catalog is not displayed.
The hardware catalog opens and the "PCS7_Vxx_SMART" profile is enabled.

3. Select the X5 slot (PN-IO-X5 module) and then select the menu command Edit  > Object 
Properties. 
The "Properties - PN-IO-X5(R0/S2.5)" dialog box is displayed.
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4. In the "General" tab, in the "Interface" group, click "Properties".

The "Properties - Ethernet interface PN-IO-X5(R0/S2.5)" dialog box is displayed.

5. In the "IP address" box, enter an available IP address within the address range of your 
computer.

Note

To find an appropriate IP address, in SIMATIC Manager, use the PLC > Edit Ethernet 
Node option.

6. In the "Subnet mask" box, enter the correct subnet mask for your computer. 

7. Click "New" to create a new network connection. The CPU uses this network connection 
to communicate with the ES. 
The "Properties - New subnet Industrial Ethernet" dialog box is displayed.
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8. Click "OK" to apply all the default settings.
The "Ethernet(1)" entry is entered in the "Subnet" list and is already selected.

9. Click "OK". 
Your settings are applied and the dialog box closes.

10.Click "OK". 
Your settings are applied and the dialog box closes.

11.Select Station > Save and Compile.

12.Close HW Config.

5.4.2.2 Renaming the PC Station

Prerequisites         
● The color_gs project is open in SIMATIC Manager.

● The component view is activated.

Procedure
1. Select the "color_gs_prj_MP\color_gs_prj_Prj\SIMATIC PC Station(1)" object in the tree 

view.

2. Click Edit > Object Properties. The "Properties - SIMATIC PC Station" dialog box is 
displayed.
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3. In the "Name" input box, enter the name of the local computer as it is displayed in the 
network.

Note

To find the computer name, select Control Panel > System and view the "Computer name, 
domain, and workgroup settings" section.

4. In the "Computer name" area, select the "Computer name identical to PC station name" 
check box.
The computer name is automatically entered in the "Computer name" field at the bottom of 
the dialog box.

5. Click "OK". 
Your settings are applied and the dialog box closes. 
The component view identifies the PC station icon with a yellow arrow.

Note

If the PC station is not labeled with a yellow arrow, press F5 to refresh the screen.

5.4.2.3 Configuring the PC station of the OS

Prerequisites            
● The color_gs project is open in SIMATIC Manager.

● The component view is activated.

Procedure
1. Select the "color_gs_prj_MP\color_gs_prj_Prj\[name of the PC station]" folder in the tree 

view.

2. Select the "Configuration" object in the detail view, and select Edit > Open Object. 
HW Config opens and the OS components are displayed. 
HW Config opens with the settings you made when configuring the AS:

– The hardware catalog is open.

– The "PCS7_Vxx" profile is active.

3. Select the following CP from the hardware catalog: "SIMATIC PC Station\CP Industrial 
Ethernet\IE General/SW Vxx..." and move it to slot 1 using drag-and-drop. 
The "Properties - Ethernet Interface IE General (R0/S1)" dialog box is displayed.

4. Verify that the "Set MAC address/use ISO protocol" check box is not selected.

5. Verify that the "IP protocol is being used" check box is selected.

6. In the "IP address" box, enter the IP address of your computer.
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7. Select "Ethernet(1)" from the "Subnet" list.
This is the connection that you have already configured for the CPU.
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8. Click "OK" to apply your settings. 
The dialog box closes and the HW Config window is displayed.

9. Select Station > Save and Compile.

10.Close HW Config.

5.4.2.4 NetPro settings

Prerequisites           
● The color_gs project is open in SIMATIC Manager.

● The component view is activated.

Procedure
1. Select the "color_gs_prj_MP\color_gs_prj_Prj\[name of the local computer]\WinCC Appl." 

object in the tree view.

2. Select "Connections" in the detail view. Now, select Edit > Open Object. 
NetPro opens.

3. Select the "WinCC Appl." object for the SIMATIC PC station. 

4. Select the first line in the detail view at the bottom. Now, select Insert > New Connection.
The "Insert New Connection" dialog box opens.
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5. Select your project's CPU in the tree view.
This CPU is the communication partner of the OS, which means that the OS receives the 
data of this automation system.

6. In the "Connection" group, ensure that "S7 connection" type is set and the "Display 
properties before inserting" check box is selected.

7. Click "OK". 
The "Properties - S7 connection" dialog box opens with the "General" tab activated.
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8. Select the following connection partners for the connection between the CPU and OS:

– Local: Interface "[Network adapter of the OS]", e.g., IE General

– Partner: Interface "[CP of the AS]", e.g., CPU 410 SMART

9. Click "OK". 
The new connection is shown in the list. This connection is also displayed if you select the 
CPU for the AS.

10.Select Network > Save and Compile.
The "Save and Compile" dialog box opens.

11.Activate the "Compile and check everything" option button and click "OK". 
When the compilation operation is completed, the "Outputs for consistency check" window 
opens.

12.If the compilation was executed without errors, close the window. If any errors are displayed, 
correct them based on the information in the error messages and repeat the compilation 
operation.

13.Close NetPro.

5.4.2.5 Configuring and downloading the PC station of the OS

Procedure
1. In SIMATIC Manager, select the PC station, and then select  PLC > Configure. 

The "Configure" dialog box is displayed.

2. Click "Configure". 
The dialog box "Configure: <Selected PC Station>" is displayed.
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3. To perform and complete remote configuration, follow the instructions in the online help of 
the "Configure: <Selected PC Station>" dialog box.

4. Click "OK" and acknowledge the subsequent information windows by clicking "OK".
The configuration data is transferred to the PC station.

5. When the "Transfer completed successfully" message is displayed, click "Close" on the 
"Configure" dialog box. You must still download the network settings to this PC station in 
order to activate the network connections.

6. Select the PC station, and select PLC > Download. 
The "Download" dialog box is displayed.

7. Click "Yes". 
The "Stop Target Modules" dialog box is displayed.

8. Click "OK". 
The download is complete.

5.4.2.6 Downloading the hardware configuration of the AS

Introduction         
This section describes how to download the hardware configuration for the AS. After you have 
configured and set the hardware, this information must be available to the CPU. Therefore, 
download the hardware configuration to the CPU.

Prerequisites
● The CPU is in "STOP" mode.

● The color_gs project is open in SIMATIC Manager.

● The component view is activated.

Procedure
1. Select the "color_gs_prj_MP\color_gs_prj_Prj\SIMATIC 400(1)" folder in the tree view.

2. Select PLC > Compile and Download Objects. 
The "Compile and Download Objects" dialog box opens.

3. Select the check boxes in the "Compile" and "Download" columns of the "color_gs\SIMATIC 
400(1)\Hardware" object.

4. Click "Start". 
 "Downloading program changes during operation can, in the case of malfunctions or 
program errors, cause serious damage to personnel and equipment! Make sure..."  
message pops up.

5. Click "OK". 
The compile and download operation starts. The log file is opened in the text editor when 
the function is complete.

6. Close the text editor.
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7. Click "Close" in the "Compile and Download Objects" dialog box. 
The dialog box closes.

8. Start the CPU.
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5.5 Working in the plant hierarchy

5.5.1 Introduction to plant hierarchy

Plant hierarchy
The plant hierarchy (PH) maps the hierarchical structure of your plant. For example, a plant, 
unit or function. PH provides you with many settings. The most important ones are:

● Number of hierarchy levels:
The nesting depth of these levels is determined by the plant structure. Rule: If your plant 
structure is complex, you will require higher number of hierarchy levels to reflect it. With 
PCS 7 wizard, hierarchy folders with default names are created according to your 
specification.

● Determination of the hierarchy level(s) which influence the name of plant ID (HID):
The PCS 7 SMART project contains many instances of the HID. Messages generated in 
the active process and tag names contain this HID in order to allow operators to quickly 
recognize a specific plant unit associated with a message or tag. Rule: If your individual 
HID part is longer and if you define more hierarchy levels, the entire HID becomes less 
recoginizable.

● Deriving the picture hierarchy from the PH:
The process pictures are grouped in a specific hierarchy. This allows you to change from 
an overview picture to a lower level picture in process mode. The subordinate pictures 
represent a portion of the overview picture that is very accurate. The hierarchy of the 
process pictures corresponds with how they are stored in the plant hierarchy.

5.5.2 Plant hierarchy settings

Prerequisites           
● The color_gs project is open in SIMATIC Manager.

● The plant view is activated.

Procedure
1. Select the "color_gs_prj_MP\color_gs_prj_Prj" hierarchy level in the tree view.

2. Select Options > Plant Hierarchy > Settings 
The "Customize Plant Hierarchy" dialog box opens where you can set the plant hierarchy 
options.

3. Enter the value "4" in the "Number of hierarchy levels" field. 
This setting allows up to four hierarchy levels to be defined.

4. Enter the value "10" in the "Max. number of characters" boxes for all four hierarchy levels. 
This setting limits the length of the HID string to 10 characters per hierarchy level.
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5. Select the "Included in HID" check boxes for levels 1 to 4.

6. Select the "OS area" option for level 2.

7. Select the "Derive picture hierarchy from the plant hierarchy" check box. 
The dialog box now appears as follows:

8. Click "OK" to apply your settings. 
The "You have changed the "Included in HID" property. Do you want the changes to be 
applied to the already existing hierarchy folders?" message dialog is displayed.

9. Click "Yes". 
This accepts all the settings.
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5.5.3 Plant view structure

Plant hierarchy of the color_gs project                   
You have now specified four hierarchy levels with the PCS 7 Wizard 'New Project'. As a result, 
you will find the following hierarchy folders in the tree view of your project:

● Process cell - level 1

● Unit - level 2

● Function - level 3

● Device - level 4

The names of the hierarchy folders are default names assigned automatically by PCS 7 
SMART when the project is created.

For your "color_gs_prj_MP" project, you must adapt this structure to the individual requirements 
of the "color_gs"  project, change the default names, and insert new hierarchy folders. This 
gives you a clear structure and makes it easier to navigate through your project. You can also 
treat all the objects as individual units.

The following hierarchy folder names are specified in the Getting Started for the various 
components of the plant:

Default name Hierarchy folder Technological assignment
Process cell Plant1 Complete plant
Unit RMT1 Raw materials tank 1
Function FC111 Flow control (dosing)
Function LI 111 Level indicator for raw material tank 1
Function NP 111 Pump control
Function NK 111 Valve control
Function NK 112 Valve control
Function NK 113 Valve control
Function NK 114 Valve control
Device ADDIT Support chart for checking the process values

5.5.4 Adapting default names

Prerequisites             
● The color_gs project is open in SIMATIC Manager.

● The plant view is activated.
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Procedure for renaming the "Plant" folder
1. Select the hierarchy folder "color_gs_prj_MP\color_gs_prj_Prj\Process cell(1)".

2. Select Edit > Object Properties.
The "Properties - Hierarchy Folder" dialog box opens with the "General" tab activated.

3. Enter "Plant1" in the "Name" input box.

4. Click "OK" to apply your settings.
The dialog box closes and the name of the hierarchy folder is changed to "Plant1".

Procedure for renaming the "Unit" folder
1. Select the hierarchy folder "Unit (1)".

2. Select Edit > Object Properties.
The "Properties - Hierarchy Folder" dialog box opens with the "General" tab activated.

3. Enter "RMT1" in the "Name" input box.
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4. Switch to the "Control and Monitoring Attributes" tab. 
The "No modification when renaming the hierarchy folder" check box is deactivated by 
default. This ensures that the text for the OS area ID is always changed according to the 
name of the hierarchy folder.

5. Click "OK" to apply your settings. 
The dialog box closes and the name of the hierarchy folder is changed to "RMT1".

Procedure for renaming additional folders
1. Select the hierarchy folder "color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1\Function(1)".

2. Select Edit > Object Properties. 
The "Properties - Hierarchy Folder" dialog box opens.

3. Enter "FC111" in the "Name" input box.

4. Click "OK". 
Your settings are applied and the dialog box closes.

5. Select "color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1\FC111\Device(1)" folder.

6. Select Edit > Object Properties. 
The "Properties - Hierarchy Folder" dialog box opens.

7. Enter "ADDIT" in the "Name" input box.

8. Click "OK". 
Your settings are applied and the dialog box closes.
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5.5.5 Inserting additional hierarchy folders

Prerequisites            
● The color_gs project is open in SIMATIC Manager.

● The Plant View is activated.

Procedure
1. Select the "RMT1" folder.

2. Select Insert > Technological Objects > Hierarchy Folder. 
The program generates a new hierarchy folder named "Function [consecutive number]".

3. Change name of the newly created folder to "LI111".

4. Press "Enter".

5. Repeat steps 1 to 4 to create additional hierarchy folders:

– NP111 – motor control

– NK111 – valve control

– NK112 – valve control

– NK113 – valve control

– NK114 – valve control

Result
Your plant hierarchy must now appear as follows: 
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5.5.6 Checking the assignment of AS/OS to the plant hierarchy

Hierarchy folders assignment    
The individual components of the plant are assigned to specific automation systems and 
specific operator stations. This information is provided to each hierarchy folder of the plant 
hierarchy. This is only important if you have more than one automation system or operator 
station in your project. 

In the "color_gs" project, you have only one automation system and one operator station. As 
a result, all the hierarchy folders are automatically assigned. 

Procedure for checking the assignment
1. Select the "RMT1" hierarchy folder, and select Edit > Object Properties.

The "Properties - Hierarchy Folder" dialog box opens.

2. Select the "AS-OS Assignment" tab. 
Here you will find the following assignment:

– In the "Assigned AS (chart folder)" list, you will see the automation system that 
processes the data.

– In the "Assigned OS" list, you will see the operator station where data is displayed.

3. Click "OK" to close the dialog box.
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5.6 Current status

5.6.1 Current state of your project

Completed Configuration Tasks
So far, you have made the following settings for your project:

● You have created the "color_gs" project in SIMATIC Manager.

● You have configured the hardware components in HW Config.

● You have downloaded the hardware configuration from HW Config to the CPU.

● You have configured and loaded the PC station of the OS.

● You have entered settings in the plant hierarchy.

● You have mapped the plant structure of the "color_gs" project in the plant hierarchy.
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Creating CFCs 6
6.1 CFC Charts and the CFC Editor

Introduction         
CFCs assist you in creating the entire proces of a plant by continuous sequences. You can 
create them in the PCS 7 CFC Editor.

You can create CFCs by inserting blocks from the PCS 7 Library Vxx into the CFCs. These 
include single blocks. For example, blocks for closed-loop control of a process or for monitoring 
measured values. The inputs and outputs of these blocks are then interconnected and 
assigned parameters directly in the CFC Editor. The user-friendly graphic user interface of the 
CFC Editor assists you in this task.

PCS 7 SMART also provides process tag types in the standard library. They represent  full 
CFCs for various process tags such as motors and valves.

You can retrieve the CFCs in the plant hierarchy. To keep the project structure clear, CFCs 
are always stored in the hierarchy folders according to their relevance in the process.

Identification of CFCs
CFCs are identified by the icon:
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6.2 Working with libraries

6.2.1 CFC Charts and the master data library

Introduction to the master data library
When creating CFC charts, you will be working with the master data library. Do not copy any 
blocks and process tag types directly from the PCS 7 AP library to the CFC charts of your 
project. Instead, create the blocks and process tags as required in the master data library and 
copy these objects from this library to the CFC charts.

Advantages of the master data library
The advantages of using the master data library is:

● Ensures that the the same version of a block is used in a project without any confusion. 
This is important if there is more than one project engineer working on a project with a 
multiproject. 

● Provides you with the convenience of hiding libraries. This function allows you to hide all 
libraries except for the master data library, in order to prevent inconsistency and errors 
within the project. 

● They are archived automatically when you archive the multiproject.

6.2.2 Storing objects in the master data library

Changes to blocks       
You can change the properties of the block in the master data library. For example, you can 
adapt messages specifically to your project requirements. Each block instance that is created 
when you insert a block in a CFC automatically has the modified properties. 

This means that you only have to modify the block once in the master data library and not 
repeatedly for each individual block instance. 

Modifications to blocks intended for a specific CFC are made directly in the CFC block instance. 
For example, parameters for inputs and outputs, such as setpoints and limit values. 

Master data library and process tag types
You can also store the process tag types provided by PCS 7 SMART in your master data 
library. All the blocks included in this process tag type are automatically entered in the block 
folder of your master data library at the background.
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Basic procedure

Step Action
 1 Open library (Page 64)
 2 Store all blocks in your master data library (Page 65)

The PCS 7 wizard automatically generates the master data library when you create a 
project.

 3 Store process tag types in the master data library (Page 67)

6.2.3 Working with the master data library
Creating a master data library for a large project requires detailed planning before the CFC 
charts are actually created. In this Getting Started, we will provide you with all the blocks you 
require for the "color_gs" project. These objects are listed in the table below. 

Legend for the tables
● Object name: This is an alphanumeric code for the block that is displayed in PCS 7 SMART.

● Symbolic name: Short descriptive name for the block.

● Meaning: Short description of the purpose of this block.

● Type of block: Defines the block category.

● Associated CFC: Returns all CFCs where the block is installed.

Master data library blocks
Store the required blocks in your master data library. You need the following blocks for the 
"color_gs" project:

Object 
name

Symbolic 
name

Meaning Type of 
block

Associated 
CFC

FB1809 DoseL Dosing of materials (quantity and flow) Dosing block CFC_FC111
FB1823 Integral Generates the time integral of an input 

value
Mathematical 
block

CFC_LI111
CFC_FC111

FB1828 Lag Smoothing the input value (low-pass 
filter)

Mathematical 
block

CFC_LI111

FB1845 MonAnL Monitors an analog measured value Monitoring block CFC_LI111
FB1866 OpDi01 Manipulates a digital value Operator control 

block
CFC_FC111
CFC_SETP

FB1869 Pcs7AnIn Processes an analog input value sig‐
nal

Channel block CFC_LI111
CFC_FC111

FB1870 Pcs7AnOu Processes an analog output value sig‐
nal

Channel block CFC_FC111
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Object 
name

Symbolic 
name

Meaning Type of 
block

Associated 
CFC

FB1874 PIDConL Continuous PID controller Controller block CFC_FC111
FC360 Mul04 Multiplies input values and returns the 

result at the output
Mathematical 
block

CFC_FC111
CFC_LI111

Process tag types in the master data library
Store the required process tag types in your master data library. You need the following process 
tag types for the "color_gs" project:

Process tag type (CFC) Meaning Assigned CFC
Motor_Lean CFC for a motor CFC_NP111
Valve_Lean CFC for a valve CFC_NK111

6.2.4 Opening the libraries

Prerequisites         
SIMATIC Manager is open.

Procedure
1. Select File > Open.... 

The "Open Project" dialog box opens.

2. Select "Libraries" tab.
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3. Select "PCS 7 AP Library Vxx" and "color_gs_prj_Lib" libraries in the list.

4. Click "OK". 
Both libraries appear in the component view.

6.2.5 Storing blocks

Prerequisites               
● SIMATIC Manager is open.

● The PCS 7 library "PCS 7 AP Library Vxx" is open and the component view is activated.

● The "color_gs_prj_Lib" master data library is open and the component view is activated.

Procedure
1. The PCS 7 AP Library Vxx (Component view) window is open by default, if not, select 

Window > PCS 7 AP Library Vxx (Component view). 
The PCS 7 AP library opens.

2. Select the "PCS 7 AP Library Vxx\Blocks + Templates\Blocks" item in the tree view. 
The detailed view shows all the standard blocks provided by PCS 7 AP library Vx.x.

3. Select View > Details. 
Both the object names (short names and symbolic names of the blocks) are displayed which 
gives you more information.
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4. In the detailed view, select the required blocks according to the following list:

– FB1809 - DoseL

– FB1823 - Integral

– FB1828 - Lag

– FB1845 - MonAnL

– FB1866 - OpDi01

– FB1869 - Pcs7AnIn

– FB1870 - Pcs7AnOu

– FB1874 - PIDConL

– FC260 - ChkREAL

– FC360 - Mul04

5. Select Edit > Copy.

6. Select Window > color_gs_prj_Lib (Component view). 
The master data library opens.
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7. Select "In <color_gs_prj_MP>\color_gs_prj_Lib\S7 program(1)\Blocks" in the tree view.

8. Select Edit > Paste. 
The selected blocks are inserted.

6.2.6 Storing process tag types

Introduction
This section will guide you in storing process tag types. You can store process tag types in the 
"Charts" directory of your master data library in the Component view. Later, you can copy your 
master data library from the "Templates" directory to the "Process tag types" directory in the 
Plant View.

Prerequisites               
● SIMATIC Manager is open.

● The PCS 7 library "PCS 7 AP Library Vxx" is open and the Component view is activated.

● The "color_gs_prj_Lib" master data library is open and the Component view is activated.

Procedure
1. Select Window > PCS 7 AP Library Vxx (Component view). PCS 7 AP library opens in 

Component view.

2. Select the "PCS 7 AP Library Vxx\Blocks + Templates\ Templates" folder in the tree view.  
The detailed view shows all the chart templates available in the PCS 7 AP library.
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3. Select the following charts in the detail view:

– "Motor_Lean"

– "Valve_Lean"

4. Select Edit > Copy.

5. Select  Window > color_gs_prj_Lib (Component view). 
The master data library opens.

6. Select "<color_gs_prj_MP>\color_gs_prj_Lib\S7 program(1)\Charts" in the tree view.

7. Select Edit > Paste. 
All the  selected process tag types are inserted.

8. Close the "PCS 7 AP Library Vxx".

9. Open "color_gs_prj_lib" in Plant View.

10.Select "<color_gs_prj_MP>\color_gs_prj_Lib\ Process tag types" folder in the tree view.

11.Switch to the Component view.

12.Select the "<color_gs_prj_MP>\color_gs_prj_Lib\S7 Program(1)\Charts" folder in the tree 
view.

13.Select the "Motor_Lean" and "Valve_Lean" charts in the detail view.

14.Select Edit > Cut.

15.Select the "<color_gs_prj_MP> \ color_gs_prj_Lib \ Process tag types" folder in the plant 
view.

16.Select Edit > Paste.

Note

As soon as a process tag type is stored in the master data library, all the individual blocks 
present in this process tag type are automatically stored in the "Blocks" folder. 
If you select the "<color_gs_prj_MP>\color_gs_prj_Lib\ S7 program(1)\ Blocks" folder in the 
tree view, you can see all the blocks you have inserted or that were automatically stored 
there when process tag types were copied in the detail window .

6.2.7 Showing and hiding libraries

Introduction
You can hide unwanted libraries in SIMATIC Manager. Hence, working with the CFC Editor 
catalog is more clear and less prone to errors. Since you have stored all the necessary blocks 
and process tag types in your master data library, you can work exclusively with this master 
data library when creating the "color_gs" project.

You can show libraries quickly if you need them again.

Creating CFCs
6.2 Working with libraries

PCS 7 SMART Getting Started - Part 1 (V9.0 with APL)
68 Getting Started, 12/2017, A5E42181435-AA



6.2.8 Process to hide and show libraries

Prerequisites
1. SIMATIC Manager is open.

2.  All the required blocks and charts in your master data library. 

Procedure for Hiding Libraries
1. Select File > Manage.

The "Manage" dialog box opens.

2. Select the "Libraries" tab.

3. Select all the libraries in the list excluding the following:

– Master data library "color_gs_Prj_Lib"

– PCS 7 library "PCS 7 AP Library Vxx"

– SFC Library (x3)

– Standard library

4. Click "Hide". 
All selected libraries are removed from the list.

5. Click "Close". 
You have now hidden all the libraries that you do not want to use. They will no longer be 
displayed in the CFC Editor catalog.
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Procedure for Showing Libraries
1. Select File > Manage.

The "Manage" dialog box opens.

2. Select the "Libraries" tab.

3. Click "Display". 
The "Browse" dialog box opens.

4. Select the "...\SIEMENS\STEP7\S7LIBS\ [Name of the library] object in the tree view. 
The library is displayed in the right pane.

5. Click "OK". 
The dialog box closes and the selected library is displayed and selected in the list of libraries 
in the "Manage" dialog box.

6. Repeat steps 3 to 5 if you wish to show other libraries again.

7. Click "Close". The dialog box closes.
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6.3 Technological significance of the charts in the project

6.3.1 Charts in "color_gs" project

CFC Charts in the color_gs Project  
The following CFCs are required for the "color_gs" project:

● CFC_SETP: Specification of process values.

● CFC_FC111: Closed-loop control of dosing amount and dosing speed.

● CFC_LI111: Control and simulation of the liquid level.

● CFC_NP111: Motor control.

● CFC_NK111 to CFC_NK114: Valve control.

Each chart has a process related meaning. To fully understand the part of the plant you are 
configuring in Getting Started, you should understand the process related meaning of the 
individual CFCs. A brief description of each individual chart is given below.

Details about Creating CFC Charts
You will create the CFC_SETP, CFC_FC111 and CFC_LI111 charts. PCS 7 SMART makes 
the CFC_NP111 and CFC_NK11x available to you as a complete CFC in the form of a process 
tag type. This will give you the advantage of using process tag types, which is stored in your 
master data library.

Note

In the "color_gs" project, the CFC names are assigned according to the associated hierarchy 
folder name and the process tag name. As a result, unique identification is always possible.

6.3.2 Process-Related meaning of the "CFC_SETP" CFC chart

CFC_SETP       
CFC_SETP is used to check the process value. In this case, the blocks mean the following :

● The PARA_DOS_RM1_QTY block is a substitute block. It sets the flow and should be 
connected to DOSE and to CTRL_PID.

● The PARA_DOS_RM1_SEL block specifies the target reactor.
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6.3.3 Process-Related meaning of the "CFC_FC111" CFC chart

CFC_FC111       
CFC_FC111 is used to control the dosing quantity and dosing speed. In this case, the blocks 
mean the following:

● The "Pcs7AnIn" block provides the currently dosed volume at the "PV_Out" output and 
transfers this measured value to the "PV (process value) input of the "DoseL" block.

● The "PIDConL" block delivers the manipulated variable of the flow.

● "DoseL" delivers the setpoint for the flow (manipulated value for the "PIDConL" block) and 
checks the dosing quantity.

● The manipulated variable for the valve is sent to the "MV" output of the "PIDConL" block. 
Then, it is fed to the "MV_Trk" input of the "PIDConL" block in the absence of manipulated 
variable feedback from the process.

● The "Pcs7AnOu" block sends out the manipulated variable to the valve.

6.3.4 Process-Related meaning of the "CFC_LI111" CFC chart

CFC_LI111       
CFC_LI111 is used for controlling and simulating the fill level. In this case, the blocks mean 
the following:

● The Pcs7AnIn" block reads the fill level of the raw material tank and outputs the current 
value at "PV_Out" output.

● The "PV_Out" output is interconnected with the "OutTrk" input of the "Integral" block.

● The "Out" output is interconnected with the "PV" input of the "MonAnL" block.

● The "Mul04" block is used to simulate the quantity which is taken from the reservoir at the 
given point of time.

6.3.5 Process-Related meaning of the "CFC_NP111" CFC chart

CFC_NP111      
CFC_NP111 is used for pump controlling. In this case, the blocks mean the following:

● The "Pcs7DiIn" block supplies the current state of the pump - on or off, at the "PV_Out" 
output.

● This value is interconnected to the "MotL" input (feedback ON) of the "FbkRun" block where 
it is evaluated.
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● The plant operator or an upstream controller controls the "MotL" block.

● The "Pcs7DiOu" block takes the control command from the "OosAct" output of the "MotL" 
block and outputs this to the pump in the process.

6.3.6 Process-Related meaning of the "CFC_NK11x" CFC chart

CFC_NK11x       
CFC_NK11x is used for valve control. The blocks mean the following in this case:

● The "Pcs7DiIn" block provides feedback on the status of the valve - open or closed, to the 
"VlvL" block.

● The "VlvL" block switches the valve according to the external controller settings or operator 
settings. The control command is passed on from the "OosAct" output via the "Pcs7DiOu" 
output driver to the valve.
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6.4 CFCs in the Plant Hierarchy

6.4.1 Working with CFC charts

Introduction
Once you have made the preparations for creating the CFC charts by filling your master data 
library, you can  start creating the CFC charts.

Basic procedure for creating CFC charts

Step Action
 1 Create empty CFC charts in the plant hierarchy
 2 Insert individual blocks in an empty CFC chart
 3 Interconnect the inputs and outputs of blocks and assign parameters to them

CFC Charts in the Plant Hierarchy
The PCS 7 "New Project" wizard has already created a CFC chart in your plant hierarchy. This 
is stored in the "ADDIT" folder. It does not yet contain any blocks. You have to insert them in 
the CFC Editor.

In addition, you require other charts for the "color_gs" project , which you insert in the plant 
hierarchy and then edit in the CFC Editor.

It is important that you assign brief descriptive names for all CFC charts of the "color_gs" project 
to understand your project in a better way. 

6.4.2 Procedure

6.4.2.1 Renaming CFC charts in the Plant Hierarchy

Prerequisites          
● The color_gs project is open in SIMATIC Manager.

● Plant View is activated.
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Procedure
To rename a CFC present in ADDIT folder:

1. Select the "color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1\FC111\ADDIT" folder in the 
tree view.

2. Select the "CFC(1)" object in the detail window.

3. Select Edit > Object Properties. 
The "Properties CFC" dialog box opens with the "General" tab activated.

4. Enter "CFC_SETP" in the "Name" input box. 
Chart names in real projects usually relate to a user-specified system for the identification 
of process tags.

5. Click "OK" to apply your settings.

6.4.2.2 Inserting new CFC charts in the Plant Hierarchy

Inserting CFCs            
Insert the following CFCs in the form of new, empty CFCs:

● "CFC_FC111"

● "CFC_LI111"
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Prerequisites
● The color_gs project is open in SIMATIC Manager.

● Plant View is activated.

Procedure
1. Select the "color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1\FC111" folder in the tree view.

2. Select Insert > Technological Objects > 2 CFC. 
The CFC "CFC(1)" is inserted. When you insert new charts, PCS 7 first assigns the default 
name "CFC" followed by a consecutive number and activates the input mode for a new 
name.

3. Enter "CFC_FC111" and press "Enter".

4. Select the "color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1\ LI111"  folder in the tree view.

5. Select Insert > Technological Objects > 2 CFC. The CFC "CFC(1)" is inserted.

6. Enter "CFC_LI111" and press Enter.

6.4.2.3 Inserting the "Motor_Lean" process tag type

Introduction             
You have already stored the "Motor_Lean" process tag type in your master data library. Now, 
insert this process tag type into the plant hierarchy in your "color_gs" project.

Prerequisites
● The color_gs project is open in SIMATIC Manager.

● Plant View is activated.

Procedure
1. Select the "color_gs_prj_MP\color_gs_prj_Lib\Process tag types" item in the tree view. 

The detail window displays the process tag types you have added to the master data library.

2. Select the "Motor_Lean" CFC, and select Edit > Copy.

3. Select the "color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1\ NP111" folder in the tree view, 
and select Edit > Paste. The "Motor_Lean" CFC chart is inserted in the hierarchy folder and 
selected.

4. Select Edit > Object Properties. 
The "Properties CFC" dialog box opens.

5. Change the default name "Motor_Lean" to "CFC_NP111" in the "Name" input box.

6. Click "OK" to apply your settings.
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6.5 The current status...

6.5.1 Current status of your project

Completed Configuration Tasks
After creating CFCs, the following tasks are complete:

● You have stored all the necessary blocks and process tag types in the master data library.

● You have hidden unwanted libraries for the "color_gs" project so that only the 
"color_gs_prj_Lib" master data library is visible.

● You have renamed and inserted new CFCs in the plant hierarchy.

● You have inserted the "Motor_Lean" process tag type in the plant hierarchy.
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6.6 Working with the CFC Editor

6.6.1 Introduction to the CFC Editor

CFC Editor            
CFC Editor is used to edit CFCs, insert and assign parameters to blocks. When you double 
click a CFC, CFC Editor opens. The editor always opens in the last worked view.

The CFC Editor is separated into the following display areas:

● CFC 
When you open an empty CFC, you can insert blocks required to describe continuous 
processes. Later, you can assign parameters and interconnect the blocks.

● Catalog with blocks, libraries and CFCs

        PCS 7 SMART saves all your work in the CFC Editor.

Additional information
Detailed information about the CFC Editor is available in the CFC online help and in the Process 
Control System PCS 7, CFC for SIMATIC S7  Manual.

6.6.2 CFC Chart in the CFC Editor

CFC         
Each CFC can consist of up to 26 chart partitions. A new CFC consists of only one chart 
partition. Only one chart partition is necessary for the "color_gs" project. Each chart partition 
consists of six sheets. 

You can select between two different views using buttons in the toolbar:

● A single sheet: 

● Overview with six sheets: 

The status bar shows you the location of your sheet and chart partition.

Changing from the overview to a single sheet
Double-click the required sheet to change from the overview to the single view.

The single sheets in the overview are arranged in the displayed order:
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Additional information
Detailed information is available in the CFC online help and in the Process Control System 
PCS 7, CFC for SIMATIC S7 Manual.

6.6.3 Catalog in the CFC Editor

Opening the catalog           
To open the catalog in CFC Editor, select View > Catalog. 

Organization of the catalog
The catalog contains four tabs namely:

● Blocks: Sorted according to block families. You can work with this tab in the "color_gs" 
project in order to place the PARA_DOS_RM1_QTY block from the "Operate" directory in 
the "CFC_SETP" chart.

● Charts: You can find all the charts you have created in the plant hierarchy. For example, 
CFC_FC111, CFC_LI111. The CFC that is currently open and displayed in the CFC Editor 
is labeled by a small open folder.

● Libraries: Contains all PCS 7 SMART standard libraries and your master data library. 
You have already executed the "hide" function to hide all libraries that are not required to 
configure the system in the ""color_gs" project. This means that you can only see the 
"color_gs_prj_Lib" library.

● Unplaced blocks: You can find blocks that are not displayed in a CFC. Within the "color_gs" 
project, this tab is not displayed since there are no "unplaced blocks" in your project.
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Additional information
Detailed information is available in the CFC online help and in the Process Control System 
PCS 7, CFC for SIMATIC S7 Manual.

6.6.4 Configuration steps for CFC charts overview

Overview  
To create CFC charts, complete the following steps in the same order given below:

Step What?
 1 Open chart (Page 80) 
 2 Insert blocks

Options:
● Insert blocks in "CFC_SETP" (Page 81) 
● Insert blocks in "CFC_FC111" (Page 84) 
● Insert blocks in "CFC_LI111" (Page 88) 

 3 Assign parameters to blocks
● Rename blocks
● Specify input/output values

 4 Interconnect blocks (Page 92) 

The "Insert blocks" step is skipped for process tag types. Now, you only have to configure and 
interconnect the process tag types.

Information from the online help for the block

Note

If you need additional information on the blocks, (for example, the functions of the individual 
block inputs), select a block in the library or directly in the CFC chart and press "F1". The online 
help for this block opens immediately.

6.6.5 Opening the "CFC_SETP" CFC chart

Introduction        
Open CFCs in order to place blocks.
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Prerequisites
● The color_gs project is open in SIMATIC Manager.

● The plant view is activated.

Procedure
1. Select the "color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1\ FC111\ ADDIT" folder in the 

tree view.

2. Select the "CFC_SETP" object in the detail window and then select Edit  > Open Object. 
The CFC editor opens and you can now edit the open chart.

6.6.6 Assignment of block parameters in CFC charts

Assignment of Block Parameters
Each block has a number of different I/Os that are displayed in the properties dialog box table. 
Click the column heading of the table to quickly find the inputs/outputs in this dialog box. The 
column is then sorted in ascending or descending order.

The I/Os of a block can be visible or invisible. You can only see invisible parameters in the 
properties of the block but not in the CFC chart representation. In the properties of the block, 
you can specify which I/Os in the CFC chart will be visible and invisible. In the "Not Displayed" 
column, you need to deactivate the check box of the relevant I/O to make the I/O visible in the 
CFC chart. This function makes it easy to read a CFC chart. In the "color_gs" project, you will 
accept the default settings.

6.6.7 Inserting the blocks into the "CFC_SETP"

Prerequisites        
● The "CFC_SETP" CFC chart is open in the CFC Editor - 

Storage in the "color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1\ FC111\ ADDIT" folder.

● The catalog is open.

Procedure
1. Select the "Libraries" tab in the catalog. 

This is where the "color_gs_prj_Lib" library is displayed.

2. Open the "color_gs_prj_Lib\S7 program(1)\Blocks\Operate" folder in the tree view.
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3. Drag and drop the "OpDi01 - FB1866" block to the CFC. It is used to select the reactor 
where the raw material is pumped.

4. Close the chart.

Note

If a block is displayed in pink color after you have inserted it and if no block I/Os are 
displayed, it is covering an underlying block or extends beyond the edge of the sheet. In 
this case, you must move the block with the mouse so that it does not cover any other block 
and is within the sheet limits.

6.6.8 Assigning parameters for the blocks in "CFC_SETP"

Prerequisites         
● The "CFC_SETP" CFC is open in the CFC Editor and is saved in the "color_gs_prj_MP\ 

color_gs_prj_Prj\Plant1\RMT1\FC111\ADDIT" folder.

● All blocks are inserted.
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Procedure
1. Select the "OpDi01" block and then select Edit > Object Properties.

The "Properties - Block" dialog box opens with the "General" tab activated.

2. Enter "PARA_DOS_RM1_SEL" in the "Name" input box. 
The "OCM possible" check box is selected by default.

3. Switch to the "I/Os" tab. 
Here you can assign parameters for all the I/Os of a block. The names of all inputs and 
outputs are found in the "Name" column.

4. Position the cursor in the "Value" column of the "Out.Value" I/O and enter "0".
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5. Click "OK" to apply the settings.
"PARA_DOS_RM1_SEL" name is displayed in the CFC block header. When you create the 
process pictures, you will interconnect the I/Os of the blocks from the CFCs with objects in 
the process pictures. The tag name is formed from the plant hierarchy, the CFC name, and 
the block name. You will find the "PARA_DOS_RM1_SEL" name again as part of the tag 
name. 
The values of the inputs/outputs are applied.

Block Block name in the project I/O Meaning Value Unit
OpDi01 PARA_DOS_RM1_SEL Out.Value* The output of the proc‐

ess value is verified. 
0  

* Invisible in CFC.

6. Close the CFC.

Do not create unnecessary block icons
In the "Properties - Block" dialog box of the the "General" tab, "Create block icons" determines 
whether a block icon is created for use in WinCC. Do not set the check mark for blocks with 
inputs and outputs that cannot be configured. 

6.6.9 Inserting the blocks into the "CFC_FC111"

Prerequisites         
● The "CFC_FC111" CFC is open in the CFC Editor and is saved in the "color_gs_prj_MP

\color_gs_prj_Prj\Plant1\RMT1\ FC111\" folder.

● The catalog is open, and the "Libraries" tab is visible.

● The "color_gs_prj_Lib\S7 program(1)\Blocks" folder is open in the tree view.
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Procedure
1. Drag and drop the following blocks:

– "Channel" folder: Pcs7AnIn - FB1869: Signal processing of an analog input value.

– "Dosage" folder: DoseL - FB1809: Dosing of raw material.

– "Math" folder: Mul04 - FC360: Multiplies input values and returns the result at the output.

– "Control" folder: PIDConL - FB1874 : Fill level monitoring and visualization of the level 
in the process mode.

– "Channel" folder: Pcs7AnOu - FB1870: Processes an analog output value signal.

– Folder "Operate": OpDi01 - FB1866: Manipulating a digital value.

2. Arrange the blocks in the CFC as shown below:

3. Close the chart.

6.6.10 Assigning parameters for the blocks in the "CFC_FC111"

Prerequisites           
● The "CFC_FC111" CFC is open in the CFC Editor - 

Save in folder: "color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1\ FC111\".

● All blocks are inserted.

Creating CFCs
6.6 Working with the CFC Editor

PCS 7 SMART Getting Started - Part 1 (V9.0 with APL)
Getting Started, 12/2017, A5E42181435-AA 85



Procedure
1.  For every block listed, open the "General" tab and the "I\Os" tab in the "Object Properties" 

dialog box.

2. Enter the parameters for all blocks according to the table below.

Block Block name in 
the project

I/O Meaning Value

Pcs7AnIn INPUT_U Mode Value status and measur‐
ing type

16#00000203

  PV_In Process value (raw value) 16#0203
  PV_InUnit Unit of measure for process 

value
1348

  SimOn.Value 1 = Simulation on 1
  SubsPV_In Substitute value 15.0
DoseL DOSE CR_A_DC Creep flow: Delay time for 

incoming alarms [s]
5.0

  CR_AH_Lim Creep flow: Limit high alarm 5.0
  CR_Hyst Creep flow: Hysteresis for 

alarm limit
0.2

  DQ_AH_Tol Overdosage: Limit high 
alarm

3.0

  DQ_ExHiAct.Value Default for the internal\ex‐
ternal switchover

1

  DQ_Ext.Value Dosing quantity: External 
setpoint

111.0

  DQ_HiLim.Value Limit dosing quantity 500.0
  DQ_Int End value dosing quantity 20.0
  DQ_OpScale.High Dosing quantity: High scale 

limit of bar graph
550.0

  DQ_Unit Unit of dosing in m³ 1034
  DQ2_ExHiAct.Value Dosing quantity: 1 = High 

limit for external setpoint 
factor for fine dosing has 
been reached

1

  DQ2_Ext.Value External fine dosing quanti‐
ty 

15.0

  DQ2_HiLim.Value Fine dosing: Limit high set‐
point

350.0

  DQ2_Int Fine dosing quantity 11.0
  Feature.Bit16  1
  Feature.Bit4 Set switch or button mode 1
  Feature.Bit6 Reset dosing quantity when 

dosing starts
1

  PV_AH_Lim High display limit of the 
process value for the dos‐
ing volume

700.0

  PV_OpScale.High Process value: High scale 
limit of bar graph

350.0
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Block Block name in 
the project

I/O Meaning Value

  SP.Value Active flow setpoint 70.0
  SP_Ext.Value External manipulated value 120.0
  SP_ExtAct.Value Active external setpoint 1
  SP_HiLim.Value Coarse dosing: High limit 

setpoint flow
70.0

  SP_Int Coarse dosing setpoint 70.0
  SP_LiOp.Value 1=Linking, 0=Operator Ac‐

tive
1

  SP_TrkExt 1 = Bumpless switchover 
from external to internal set‐
point active

0

  SP2_Ext.Value Fine dosing external set‐
point

15.0

  SP2_HiLim.Value Fine dosing: High limit set‐
point flow

15.0

  SP2_Int Fine dosing setpoint 9.0
  TI.Value Reset time 30.0
Mul04 MUL In2.Value Value to be multiplied 1
  In3.Value The value to be multiplied 

(value as percentage)
0.01

PIDConL CTRL_PID AutModLi.Value Interconnection to automat‐
ic

1

  ModLiOp.Value Interconnection automatic/
manual active

1

  MV_HiLim.Value High limit for manipulated 
value

99.0

  PV_AH_Lim Process value alarm: High 
limit

70.0

  PV_AH_En 1 = Enable PV alarm limit 
(high)

1

  PV_AL_En 1 = Enable PV alarm limit 
(low)

0

  PV_WH_En 1 = Enable PV warning limit 
(high)

0

  PV_WL_En 1 = Enable PV warning limit 
(low)

0

  PV_TH_En 1 = Enable PV alarm limit 
(high)

0

  PV_TL_En 1 = Enable PV alarm limit 
(low)

0

  PV_OpScale.High Process value: High scale 
limit of bar graph

70.0

  SP_Ext.Value External manipulated value 70.0
  SP_ExtLi.Value Interconnection for the in‐

ternal/external switchover 
active

1
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Block Block name in 
the project

I/O Meaning Value

  SP_Int Internal manipulated value 33.0
  SP_LiOp.Value Operator control is always 

enabled
1

  TI.Value Integral action time [s] 8.0
Pcs7AnOu OUTPUT_LMN PV_InUnit Unit of measure for process 

value
1348

OpDi01 SP_INT_EXT SetLi.Value Connected digital input 1
* Invisible in the CFC (parameters in structure, set with shortcut menu command Edit> Object 
Properties >Select Structural Element > Properties > Value)

3. Once you have entered the parameters for all the I/Os relating to a particular block, click 
"OK" for that block. 
Your settings are applied.

4. Close the chart.

Note
● Use a period as the decimal separator. For few input boxes, PCS 7 SMART provides 

predetermined values that you can select from a drop-down list. This drop-down list is 
activated automatically when you position the cursor in the input box.

● Assign parameters for the "Pcs7AnIn" I/O in the "Mode" block. You can assign this 
parameter only because you have not configured any external I/O modules in this 
Getting Started.

6.6.11 Inserting the blocks in the "CFC_LI111"

Introduction         
This section guides you to create the "CFC_LI111" chart. The procedure is exactly the same 
as for the "CFC_FC111" chart.

Prerequisites
● The "CFC_LI111" CFC is open in the CFC Editor - 

Save in "color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1\ LI111" folder.

● The catalog is open.

● The "color_gs_prj_Lib\S7 program(1)\Blocks" folder is open in the tree view ("Libraries" tab).
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Procedure
Drag-and-drop the following blocks to insert them, arrange them as shown in the figure and 
then close the chart:

● "Channel" folder: Pcs7AnIn - FB1869: This block provides a simulation value.

● "Math" folder: Integral - FB1823: This block is part of the fill level simulation in the raw 
materials tank. This block is used to simulate the fill level of the raw material tank.

● "Monitor" folder: MonAnL - FB1845: Fill level monitoring and visualization of the level in the 
process mode.

● "Math" folder: Mul04 - FC360: This block is part of the fill level simulation in the raw materials 
tank. This block is used to invert the sign for the flow value.

6.6.12 Assigning parameters for the blocks in the "CFC_LI111"

Prerequisites         
● The "CFC_LI111" CFC is open in the CFC Editor nd is saved in the "color_gs_prj_MP

\color_gs_prj_Prj\Plant1\RMT1\ LI111 folder".

● All blocks are inserted.
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Procedure
1. Open the "General" tab and "Inputs/Outputs" tab in the "Object Properties" dialog box for 

each block.

2. Enter the parameters for all blocks according to the table below.

Block Block 
name in 
the project

I/O Meaning Value

Mul04 4 In1.ST Value 1 to multiply (BYTE) 0
  In1.Value Value 1 to multiply (REAL) 0
  In4.Value Invert sign for flow rate (proc‐

ess value) - Part of the fill level 
simulation in raw materials tank

-1.0

Pcs7AnIn INPUT_U Feature.Bit29 Enables a substitute value  1
  Mode Measuring range 4 to 20 mA  16#0203
  Scale.High High measuring range  550
  SimOn.Value Simulation value active  1
  SimPV_In.Value Raw materials tank level  500
  SubsPV_In Substitute value for SimPV_In  500
Integral INT_P In.ST Analog input value (BYTE) 0
  In.Value Simulation of the raw material 

tank level
0.0

  OutHiLim High limit of the output value  500
  OutTrk.ST Predefined value used for Out‐

TrkOn = 1 (BYTE)
 

0

  OutTrk.Value Predefined value used for Out‐
TrkOn = 1 (REAL)

0

  TI Integration time 30
MonAnL LIA GradHDnEn Gradient monitoring (high) for 

negative changes
0

  GradHUpEn Gradient monitoring (high) for 
positive changes

0

  PV.ST Process value (BYTE) 0
  PV.Value Process value (REAL) 0
  PV_AH_En PV alarm limit (high) deactiva‐

ted
0

  PV_AH_Lim High alarm limit = 490 m3  490
  PV_AL_Lim Low alarm limit = 5 m3  25
  PV_Hyst Hysteresis  1
  PV_OpScale.High High display limit of the proc‐

ess value in the container
 550

  PV_Unit Unit of the PV in m3 1034
  PV_WH_En PV warning limit (high) deacti‐

vated
0

  PV_WH_Lim High warning limit = 450  m3  450
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Block Block 
name in 
the project

I/O Meaning Value

  PV_WL_Lim Low warning limit = 7  m3  27
  SimPV Simulated process value 300

3. Once you have entered the parameters for all the I/Os relating to a block, click "OK" for that 
block. 
Your settings are applied.

4. Close the CFC.

Note

Assign parameters for the "Mode" I/O for the "Pcs7AnIn" block. You can assign this 
parameter only because you have not configured any external I/O modules in this Getting 
Started.

6.6.13 Assigning Parameters for blocks in the "CFC_NP111"

Introduction         
You have already inserted the "CFC_NP111" CFC as a process tag type. For this chart, you 
still need to adapt the default parameter values to your "color_gs" project.

Note

When using process tag types, do not  adapt the names of the individual blocks.

Prerequisites
The "CFC_NP111" CFC is open in the CFC Editor - Save in  "color_gs_prj_MP\color_gs_prj_Prj
\Plant1\RMT1\ NP111" folder.
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Procedure
1. Open the "General" tab and the "I\Os" tab in the "Object Properties" dialog box for each 

listed block.

– Enter the parameters for all blocks according to the table below.

Note

For the "STRUCT" data type (e.g., "SimOn.Value"):
● Select the "Open structure" command from the shortcut menu.

The "Structure - <I/O name>" dialog box opens.
● Double click "Value".

Block Block 
name in 
the project

I/O Meaning Value

Pcs7DiIn FbkRun SimOn.Value * Switch simulation active 1
Feature.Bit29 Enables a substitute value 1
SimPV_In.Value * Simulation value PV 0

MotL Motor Monitor Deactivate monitoring 0
ModLiOp.Value * Automatic/manual mode selection 0
AutModOp Disable automatic mode 0
Feature.Bit4 Set switch or button mode (switch 

mode)
1

* Invisible in CFC, see "Note"

– Do not set a check mark for "Create block icons" in the "General" tab for the following 
blocks: Interloc, Permit, Protect.

2. Click "OK" for each block. 
Your settings are applied.

3. Close the chart.

6.6.14 Interconnection of blocks in the CFC charts

Interconnection of Blocks      
Now, you can interconnect the inputs and outputs in the charts. To interconnect the blocks:

1.  Click on the graphic user interface of the CFC editor. 

2. Click on the output of a block and on the input that you want to interconnect.

3. After clicking on the input, the interconnection is displayed as a line. The CFC Editor 
automatically draws lines in the best position. The position of the lines has no impact on 
the function of the interconnection.
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Note

If you draw a connection incorrectly:

Click on the line of the incorrect interconnection and select Edit > Delete.

6.6.15 Interconnecting blocks in the "CFC_NP111"

Prerequisites
● The "CFC_NP111" CFC is open in the CFC Editor.

● All blocks are inserted, renamed and configured.

Procedure
1. Click "Start" output in the middle block "Motor".

2. Now, click "SimPV_in" input on the "FbkRun" block. The CFC Editor automatically creates 
a line indicating the interconnection. The CFC should now appear as follows:
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6.6.16 Interconnecting blocks in the "CFC_FC111"

Prerequisites         
● The "CFC_FC111" CFC is open in the CFC Editor.

● All blocks are inserted, renamed and configured.

Procedure
1. Click the "Out" output on the "SP_INT_EXT" block.

2. Now click the "SP_LiOp" input on the "DOSE" block. 
The CFC Editor automatically creates a line indicating the interconnection.

3. Following the same procedure, interconnect additional blocks according to the table below. 
(The "4" block is located on the CFC_LI111 chart. To do this, place the two charts side by 
side.)

Block description Output Block description Input
SP_INT_EXT Out DOSE SP_ExtLi

Out DOSE SP_IntLi (Inver‐
ted)

DOSE SP CTRL_PID MV_TRK
INPUT_U PV_Out DOSE PV

PV_Out CTRL_PID PV
PV_Out 4 (in chart CFC_LI111) In1
PV_OutUnit DOSE PV_Unit
PV_OutUnit CTRL_PID PV_Unit

CTRL_PID MV OUTPUT_LMN PV_In
MV MUL In1
SP MUL In4

MUL Out INPUT_U SimPV_In
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4. The CFC should now appear as follows:

5. Close the chart.

6.6.17 Interconnecting blocks in the "CFC_LI111"

Prerequisites         
● The "CFC_LI111" CFC is open in the CFC Editor.

● All blocks are inserted, renamed and configured.
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Procedure
1. Interconnect the blocks according to the table below.

Block description Output Block description Input
INPUT_U PV_Out INT_P OutTrk
INT_P Out LIA PV
4 Out INT_P In

2. The CFC should now appear as follows:

3. Close the chart.

6.6.18 Assigning parameters for the blocks in "Valve_Lean"
In PCS 7 SMART, you can prepare process tag types for the specific plant. 

Prerequisites
The "Valve_Lean" CFC chart is open in the CFC Editor - saved in the "color_gs_prj_Lib\Process 
tag types\Valve_Lean" folder.
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Procedure
1. Open the "General" tab and "Inputs/Outputs" tab in the "Object Properties" dialog box for 

each block.

– Enter the parameters for all blocks according to the table below.

Block Name in project I/O Meaning Value
Pcs7DiIn FbkClose SimOn.Value Simulation ena‐

bled
1

Pcs7DiIn FbkClose SimPV_In.Value 
(inverted after in‐
terconnection)

Simulation value 
PV

0

Pcs7DiIn FbkOpen SimOn.Value Simulation ena‐
bled

1

Pcs7DiIn FbkOpen SimPV_In.Value Simulation value 
PV

0

VlvL Valve Feature.Bit4 Set switch or but‐
ton mode (switch 
mode)

1

– In the "General" tab, accept the default setting for "Create block icons" (no checkmark 
for the blocks Interloc, Permit and Protect).

2. Click "OK" for each block. Your settings are applied.

6.6.19 Interconnecting the blocks in "Valve_Lean"

Prerequisites
● The "Valve_Lean" CFC chart is open in the CFC Editor.

● The blocks have been created in the project library and parameters are assigned.

Procedure
1. Interconnect the blocks for each chart according to the table below.

Block description I/O Block description I/O
Valve Ctrl FbkOpen SimPV_in
Valve Ctrl FbkClose SimPV_In (inverted)

2. Close the chart.
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6.7 CFCs in the process object view

6.7.1 Use of the Process Object View for valve control

Introduction  
Now, work on the CFC_NK111 to CFC_NK114 charts. So far, you have stored the 
"VALVE_Lean" process tag type in your master data library and created the four hierarchy 
folders in the plant hierarchy.

Working with the process object view
To handle identical charts, PCS 7 SMART provides you with a convenient function, namely 
the process object view. This means that you do not need open each individual chart in the 
CFC Editor and assign parameters; rather, you can modify values quickly in a table within the 
process object view.

The following preparations are necessary for this:

● Specify I/Os in the process tag type for the process object view (Page 98)
As the process object view does not visualize all I/Os for reasons of clarity, you must define 
the I/Os to be shown. You define this once in the process tag type in the master data library.

● Insert the process tag type in the individual hierarchy folders and rename them (Page 100)
You are going to copy the process tag type from the master data library to all the hierarchy 
folders in which you require the valve control.

● Adapt the values of the parameters in the process object view (Page 98)
The significant advantage of the process object view is that you can edit values quickly and 
easily in a table.

See also
Adapting the parameters for "CFC_NK11x" (Page 101)

6.7.2 Procedure

6.7.2.1 Defining Inputs/Outputs for the Process Object View

Prerequisites             
● The color_gs project is open in SIMATIC Manager.

● The process object view is activated.
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Procedure
1. Select the "color_gs_prj_Lib\Process tag types\Valve_Lean" object in the tree view.

2. Select Options > Process Objects > Select I/Os.
The "Filter: Select I/Os" dialog box opens.

3. Enable the "Block" check box and enter "VALVE" in the input box. 
By making this setting, only "VALVE" block connections will be shown.

4. Click "OK". 
The "Select I/Os" dialog box opens.

5. Click the column header of the "Parameter" column. 
This will display all connections in the upper lines that are activated in the "Parameters" 
column.

6. Deactivate all the checkboxes.

7. Activate the checkboxes in the "Parameters" column for the following I/Os:

– AutModLi

– Feature.Bit16

– Monitor

Note

If you click on the title of the "I/O" column, the I/Os are sorted in ascending or descending 
order. This makes it easier to find what you are looking for.
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8. Click "OK". 
The "Select I/Os" dialog box closes.

9. Exit the process object view.

6.7.2.2 Inserting the "Valve_Lean" process tag type

Prerequisites         
● The color_gs project is open in SIMATIC Manager.

● The Plant View is activated.

Procedure
Follow exactly the same procedure as defined for the "Motor_Lean" process tag type:

1. Select the "Valve_Lean" process tag type in the detail window of the "color_gs_prj_MP
\color_gs_prj_Lib\Process tag types" folder.

2. Insert the "Valve_Lean" process tag type in the following folders using Edit > Copy and 
Edit > Paste:

– color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1\NK111

– color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1\NK112

– color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1\NK113

– color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1\NK114

3. Rename the inserted process tag types according to the table below.

Hierarchy folder Rename to:
../RMT1/NK111 CFC_NK111
../RMT1/NK112 CFC_NK112
../RMT1/NK113 CFC_NK113
../RMT1/NK114 CFC_NK114

4. Exit the plant view.

Additional information
A detailed description is available in the section:
"How to insert the "Motor_Lean" process tag type" (Page 76).
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6.7.2.3 Adapting the parameters for "CFC_NK11x"

Requirements                         
● The example project is open in SIMATIC Manager.

● The process object view is activated.

Procedure
1. Select the "color_gs_MP\color_gs_Prj\Plant1\ RMT1" folder in the tree view.

2. Select the "Blocks" tab. The program updates the data.

3. Select the "Block" entry from the "Filter by column:" drop-down list.
This activates the "Display" box.

4. Enter the name of the block in the "Display" input box: "VALVE". 
The program updates the table and shows you the "Valve" block for all four CFCs.

Note

If the name of the CFC is not fully displayed in the column, position the cursor between the 
"Chart" column and "Chart Comment" column and double-click. This adapts the column 
width automatically to the width of the entries.

5. Enter the name "stop_valve1" in the "Block Comment" column for the "CFC_NK111" chart, 
and press Enter. 
This updates the block comment at all connections of this chart.

6. Change the block comment for the other CFCs in the way shown in the table below.

CFC Block comment
CFC_NK112 stop_valve2
CFC_NK113 stop_valve3
CFC_NK114 stop_valve4

7. Select the "Parameters" tab. 
The program updates the data.

8. Select the "Block" entry from the "Filter by column:" drop-down list. 
The program activates the "Display" field.
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9. Enter the name of the block in the "Display" input box: "VALVE". 
The program updates the table. You see exactly three I/Os for each chart.

10.Go to the "Value" column and enter the values as listed in the table below. 
The following applies to the "Value" column:

– Position the cursor in the appropriate field. This changes the field into a drop-down list.

– Select the desired item in the drop-down list.

CFC I/O Meaning Value
CFC_NK111 Feature.Bit16 Specify the initial valve state (open/

closed)
0

 Monitor Disable monitoring of feedback from the 
process for the example

0

 AutModLi Switch the valve to automatic mode 1
CFC_NK112 Feature.Bit16 See above 0
 Monitor See above 0
 AutModLi See above 1
CFC_NK113 Feature.Bit16 See above 1
 Monitor See above 0
 AutModLi See above 1
CFC_NK114 Feature.Bit16 See above 1
 Monitor See above 0
 AutModLi See above 1
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Note on the Display

Note

Depending on the size of your monitor, you may not be able to see the "Chart" column any 
more and, as a result, the assignment of the individual I/Os to a chart becomes difficult. 

The process object view offers you the following options: 
1. Position the cursor on the small box on the left next to the horizontal scroll bar and click.

This makes a vertical marker visible in the table.
2. Hold down the mouse button and drag this vertical marker behind the "I/O" column.
3. Release the mouse button.

This splits the table window and you can navigate in the right side with the horizontal scroll 
bar in the table, while the chart names are displayed on the left side.

6.7.2.4 Deleting Interconnections to addresses

Introduction             
You can use process tag types from the PCS 7 AP Library in your project for the NK111  to 
NK114 valve controls and the NP111  motor control. These process tag types have default 
interconnections to input/output modules. Because you are working without real input/output 
modules in this Getting Started, a warning message appears during compilation. You have to 
delete these interconnections to avoid the warnings.
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Prerequisites
● The color_gs project is open in SIMATIC Manager.

● The process object view is activated.

Procedure
1. Select the "color_gs_prj_MP\color_gs_prj_Prj\Plant1\ RMT1" folder in the tree view.

2. Open the "Signals" tab. 
The program updates the data.

3. Click in the column header of the "Signal" column to sort the entries in the column.

4. Select all entries in the column "Signal" and press <DEL>.

5. Close the process object view.

6.7.2.5 Selecting block icons

Prerequisite
● The color_gs project is open in SIMATIC Manager.

● The process object view is activated.

Procedure
Follow these steps to select the desired block icons to use them later when you are creating 
the process picture:

1. Select the VlvL or MotL block on the respective charts in the CFC Editor.

2. Open the "Object properties" using the shortcut menu.

3. In the "Create block icon" box in the "OCM possible" area of the "General" tab, enter a 
number as shown below. The number indicates the orientation of the icon in relation to its 
text.

Chart Block Number Meaning
CFC_NK111 VlvL 2 Right of the text
CFC_NK112 VlvL 2 Right of the text
CFC_NK113 VlvL 1 Below the text
CFC_NK114 VlvL 1 Below the text
CFC_NP111 MotL 2 Right of the text

Alternatively, the desired block icons can also be selected in the process view from the "Blocks" 
tab or removed from one of the template charts in WinCC .
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6.8 The current status...

6.8.1 Current status of your project

Completed Configuration Tasks
You have completed the following tasks during CFC configuration:

● You have inserted blocks in the CFC Editor, assigned parameters for the blocks and 
interconnected them.

● You have used the process object view to assign parameters to the same process tag types.
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Creating SFCs 7
7.1 Overview of Sequential Function Charts (SFCs)

Introduction 
The SFC editor enables you to graphically configure and commission sequential control 
systems. A sequential control system enables a status-driven or event-driven sequence of 
production processes. The sequential control system controls the functions created with CFC 
based on sequences and executes them selectively.
An SFC offers two independent versions of sequential control systems for different application 
scenarios:

● SFC

● SFC type with SFC instances

SFC
An SFC is a standardized interface for controlling the SFC with the user program or by the 
operator. The sequential control system accesses the blocks and signals directly and is 
therefore not reusable.

SFC type/SFC instance
An SFC type is a standardized interface for controlling the SFC with the user program or by 
the operator. You can extend the interface. The SFC type accesses only its own interface and 
can therefore be used as often as required as an SFC instance.

Sequencer
Sequencers enable status-dependent and event-driven execution in the SFC. The sequencers 
of an SFC can be controlled through start conditions defined in various ways, such as:

● An SFC can include up to 8 sequencers. 

● An SFC type can include up to 32 sequencers.

You can find additional information in the SFC documentation.
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7.2 Working with the SFC Editor

7.2.1 Introduction to the SFC Editor

SFC Editor
As soon as you open an SFC, the SFC Editor opens. The SFC Editor is always opened in the 
last worked view.

Like the CFC Editor, the SFC Editor provides you with a graphic user interface that allows you 
to conveniently create sequential control systems.

A sequential control system essentially consists of two basic elements: 

● Transition: A condition which controls the execution of the subsequent step. Transitions 
are represented by small rectangles in the SFC.

● Step: Consists of actions that are performed in three phases:

– Initialization: This step is performed once, as soon as the step becomes active or if the 
processing is canceled.

– Processing: This step continues until the follow-up transition is satisfied. In this case, 
the completion phase of the step is performed once.

– Completion: When this phase is over, the step becomes inactive and the follow-up step 
becomes active.

  Steps are represented by large rectangles in the SFC.

7.2.2 Important functions in the SFC Editor

Important Functions in the SFC Editor        
This section gives you information about the main functions of the SFC Editor for configuring 
the SFCs in your "color_gs" project.

You can find the buttons required to build the sequencer in the toolbar of the SFC Editor. The 
buttons have the following meaning:

Button Meaning
When this button is activated, you can select individual objects from 
the SFC, such as steps and transitions. A step or transition selected 
is highlighted in blue."Activate selection" button
When this button is activated, the cursor transforms into a small 
cross and a circle with a bar. If you move the cross to a point in the 
chart where it is possible to insert a step or a transition, the cross 
becomes a "step with transition" symbol. At the same time, a green 
line indicates where the "step with transition" is to be inserted.

"Insert step + transition" button

Creating SFCs
7.2 Working with the SFC Editor

PCS 7 SMART Getting Started - Part 1 (V9.0 with APL)
108 Getting Started, 12/2017, A5E42181435-AA



Button Meaning
When this button is activated, you can insert an alternative branch. 
This means that either one or the other branch is executed, depend‐
ing on the transition defined."Insert alternative branch" button

None of the other buttons are used in the "color_gs" project.

Additional information
Detailed information about the SFC Editor is available in the corresponding SFC Editor online 
help and in the Process Control System PCS 7, SFC for SIMATIC S7 Manual.

7.2.3 Properties of steps and transitions

Introduction              
In order to edit the names and values of the steps and transitions, you will work in the 
"Properties" dialog box. You need not reopen the dialog box every time for each step and 
transition. Instead, you can move directly to the next transition or the next step and to transitions 
and steps of an alternative branch in this dialog box.

Navigation Buttons
The following navigation buttons are available to you:

Button Meaning
Change to the next transition/step

"Down arrow" button
Change to the previous transition/step

"Up arrow" button
Change to the adjacent transition/step

"Right arrow" button

"Left arrow" button

"Properties" dialog box
The dialog box has different tabs. The tabs are introduced briefly below.
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Tab in "Properties" dialog box for a step:

● General: Here you make general settings, such as changing the name of the step.

● Initialization: The action you define here will be processed only once when you activate the 
step.

● Processing: The action you define here will be processed cyclically until the next transition 
is met.

● Termination: The action you define here will be processed only once when you complete 
the step.

Tab in "Properties" dialog box for a transition:

● General: Here you make general settings, such as changing the name of the transition.

● Condition: In this tab you enter the condition at which the sequencer moves to the next 
transition.

7.2.4 Overview of the configuration steps for SFC charts

Overview
To create SFCs, perform the steps listed below:

Step What?
 1 Move SFC (Page 110)
 2 Rename SFC (Page 111)
 3 Open SFC (Page 112)
 4 Define the technological structure of the sequential control system (Page 112)
 5 Rename steps (Page 115)
 6 Name transitions (Page 117)
 7 Configure steps (Page 119)
 8 Configure transitions (Page 124)
 9 Optimize the run sequence (Page 127)

7.2.5 Moving an SFC chart

Introduction         
The "SFC(1)" SFC, which is manufactured by the PCS 7 "New Project" wizard when you 
created the "color_gs" project, is stored in the "ADDIT" hierarchy folder. Since the charts are 
stored in the plant hierarchy according to their relevance, you must  move the SFC created 
automatically by the PCS 7 "New Project" Wizard to the relevant hierarchy folder.
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Prerequisites
● The color_gs project is open in SIMATIC Manager.

● The plant view is activated.

Procedure
1. Select the "color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1\ FC111\ ADDIT" folder in the 

tree view.

2. Select the  "SFC(1)"  object in the detail window.

3. Select Edit > Cut.

4. Select the "color_gs_prj_MP\color_gs_prj_Prj\Plant1\RMT1" folder in the tree view.

5. Select Edit > Paste. 
The SFC is added to the selected folder.

7.2.6 Renaming the SFC chart

Introduction         
You must change the default names to keep the naming consistent and clear within your project

Prerequisites
● The color_gs project is open in SIMATIC Manager.

● The Plant View is activated.

Procedure
1. Select the "color_gs_prj_MP\color_gs_prj_Prj\Plant1\ RMT1" folder in the tree view.

2. Select the "SFC(1)"  object in the detail window.

3. Select Edit > Object Properties.
The "Properties SFC Chart" dialog box opens and the "General" tab is selected.

4. Change the default name "SFC(1)" to "SFC_RMT1" in the "Name" box.

5. Click "OK" to apply your settings.
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7.2.7 Opening the "SFC_RMT1" SFC Chart

Prerequisites         
● The color_gs project is open in SIMATIC Manager.

● The Plant View is activated.

Procedure
1. Select the "color_gs_prj_MP\color_gs_prj_Prj\Plant1\ RMT1" folder in the tree view.

2. Select the "SFC_RMT1" object in the detail view, and select Edit > Open Object. The SFC 
Editor opens the "Start" and "End" steps. Transition 1 already exists.

7.2.8 Technological structure of the sequential control system

Technological Sequence  
The following section provides you with an overview of the technological sequence of the 
individual steps and transitions in the sequential control system for the "color_gs" project:

Name of the Step Function
START Defaults: 

Start the dosing controller in automatic mode
Set aggregates to automatic mode

DOSE_REA1
DOSE_REA2

Query: 
Should reactor 1 or reactor 2 be dosed? 

INIT_LINE1
INIT_LINE2

Controllers:
Open the valves of the relevant branch
Turn the pump on

INIT_1_OK
INIT_2_OK

Query:
Is the pump switched on?
Is the controller set to "External setpoint"?

INIT_DOSE Controllers:
Specify dosing rate setpoint
Set dosing controller to automatic mode
Specify dosing volume setpoint
Start dosing procedure

INIT_OK Query:
Is the setpoint of the course dosing quantity less than the dosing quantity?

SLOW_DOWN Checking whether the engine is still running
END_DOSE Query:

Dosing ended?
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Name of the Step Function
CLOSE_LINE Controllers:

Close all valves
Turn the pump off
Switch dosing controller to manual mode 
Set dosing rate to 0
Stop dosing

CLOSE_OK Query:
Is the pump switched on?

END Reset:
Close valves
Switch off motor

The plant operator can use the operator station to start, control and monitor this chart.

7.2.9 Creating the sequential control system in the SFC chart

Introduction         
When you have completed creating the "color_gs" project with the PCS 7 "New Project" wizard, 
PCS 7 SMART automatically creates an SFC. 

When you open a new SFC in the SFC Editor, a sequencer with the following elements is 
displayed in the SFC:

● START" step

● Transition 1

● END" step

When you insert steps and transitions, the SFC Editor assigns continuous numbers. Later, you 
can replace these numbers with descriptive, plant-specific names. Now, you can edit the 
"SFC_RMT1 SFC from the "color_gs"project with the SFC Editor.

Procedure
1. Select the "SFC_RMT1" SFC in the SFC Editor.

2. Select View > Toolbar if the toolbar buttons for inserting steps and transitions are hidden. 
This opens the toolbar.

3. Select Insert > Step + Transition.

 The cursor transforms into a small cross and a circle with a bar.

4. Position the cursor under transition 1, wait until a green line appears. Now, click the relevant 
object to insert.
Step "3" and transition "2" are then incorporated into the SFC.

Creating SFCs
7.2 Working with the SFC Editor

PCS 7 SMART Getting Started - Part 1 (V9.0 with APL)
Getting Started, 12/2017, A5E42181435-AA 113



5. Click "Insert alternative branch".

6. Position the cursor under step "START", wait until a green line appears, and then insert the 
object by clicking it.
An alternative branch is inserted directly below step "START": In doing so, the transitions 
"3" and "4" are parallel and step "4" is set underneath.

7. Click "Insert step + transition".

8. Place the cursor at the following positions and insert a step and transition:

– Underneath transition 3: Step 5 and transition 5 are inserted

– Underneath transition 4: Step 6 and transition 6 are inserted

– Underneath transition 2: Step 7 and transition 7 are inserted

Result
Your SFC should now appear as follows: 
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7.2.10 Renaming steps

Prerequisites         
● The "SFC_RMT1" SFC is open in the SFC Editor.

● All steps and transitions have been inserted.

Procedure
1. Click "Select".

2. Select step "5".

3. Select Edit > Object Properties.
The "Properties" dialog box opens and the "General" tab is selected.
The default entry "5" is already selected in the "Name" box.

4. Change the entry "5" in the "Name" input box to "INIT_LINE1".

5. Click "Apply".
The new name is saved.

6. Click the "Down arrow".
This brings you to step "4".

7. Change the "4" in the "Name" input box to "INIT_DOSE" and click "Apply".
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8. Navigate to the other steps using the arrow buttons and change the names in accordance 
with the table below. Each time you enter a new name, complete the change by clicking 
"Apply":

Default name New name
 3 SLOW_DOWN
 7 CLOSE_LINE
 6 INIT_LINE2

9. Click "Close".
This saves your settings and closes the "Properties" dialog box.

Result
The changed names of the individual steps are displayed in the SFC as shown below:
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7.2.11 Renaming transitions

Introduction         
Just as you renamed the steps, you must also replace the default names of all transitions with 
descriptive, plant-specific names. Use the same procedure as you did for changing the names 
of the steps.

Prerequisite
The "SFC_RMT1" SFC is open in the SFC Editor.

Procedure
1. Select transition "3", and select Edit > Object Properties.

The "Properties" dialog box opens and the "General" tab is selected.

2. Change the default name in the "Name" box to a plant-specific name.
The plant-specific names are listed in the table below:

Default name New name
 3 DOSE_REA1
 5 INIT_1_OK
 1 INIT_OK
 2 END_DOSE
 7 CLOSE_OK
 4 DOSE_REA2
 6 INIT_2_OK

3. Each time you enter a name, complete the change by clicking "Apply".

4. Use the arrow buttons to move from one transition to the next.

5. Click "Close".
This saves your settings and closes the "Properties" dialog box.

Result
The changed names of the transitions are displayed in the SFC.

Your SFC should now appear as follows: 
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7.3 Setting parameters

7.3.1 Assigning parameters to the steps of the SFC chart

Introduction             
Using an SFC, you can assign values to the block inputs of the CFCs. The initial settings for 
the sequence of the dosing process are made with the first "START" step.

Each step for which you have defined an action is displayed in dark gray. This indicates that 
you can see whether a  a step has been assigned parameters or not at a glance.

Prerequisites
● The "SFC_RMT1" SFC is open in the SFC Editor.

● The names of the steps and transitions have been adapted.

Procedure
1. Double-click "START".

The "Properties" dialog box opens and the "General" tab is selected.

2. Switch to the "Initialization" tab.
This tab displays an empty list known as statement lines; the cursor is positioned in the left 
column of the first line.

3. Click "Browse".
The "Browse" dialog box opens with the "Plant View" tab activated. In this dialog, the plant 
hierarchy is displayed in the left section and the I/Os of the block you have selected in the 
plant hierarchy are shown in the right section.
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4. Select the "Plant1\RMT1\FC111\CFC_FC111\ CTRL_PID" block in the tree view. The 
section on the right side shows all corresponding block connections.

5. Right-click the "ModLiOp" input and select "Open structure" from the shortcut menu.

6. Select the "Value" line in the "Structure - ModLiOp" dialog box and click "Apply".
The "Browse" dialog box goes to the background and the selected block interface along 
with its full path is entered in line 1. The cursor is automatically positioned in the right column 
of line 1.

Note

If you cannot read the names of the block I/Os, increase the width of the column.

7. Enter the value "1" in this input box.
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8. Click "Apply".
The value "1" is automatically replaced by "TRUE". The first assignment in the "Start" step 
is now complete. The dialog box now appears as follows:

9. Click the number "2" button.
This button appears directly before the statement line. The cursor is then positioned in the 
left column of the second line.

10.Repeat steps 3 through 9 to define the remaining addresses for step "START". You will find 
the information you require in the below table 'Entries in the "Properties - START" dialog 
box'.

11.Click "Apply".

12.Click the arrow button to navigate to the other steps and enter the addresses according to 
the tables below.

Note

The addresses in the table are specified in the following format:

[chart folder\chart name\block.I/O].

The"Plant1\RMT1" component is omitted because it is identical for all objects. This keeps 
the table easy to understand. As soon as you insert an additional plant or unit in the 
"color_gs" project, you must also pay attention to the assignment of the chart to the plant 
hierarchy.

Note

When entering the addresses, verify that you have selected the required step based on the 
title bar of the "Properties" dialog box.

If you have inadvertently closed the "Properties" dialog box, double click on the step you 
are currently editing to reopen the dialog box. 
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Table 7-1 Entries in the "Properties - START" dialog box

No. Column 1 Column 2 Meaning
1 FC111\CFC_FC111\ CTRL_PID.ModLiOp.Value TRUE Activate automatic mode
2 FC111\CFC_FC111\ CTRL_PID.AutModLi.Value TRUE Controller automatic mode
3 FC111\CFC_FC111\ CTRL_PID.SP_ExtLi.Value TRUE Select external setpoint
4 FC111\CFC_FC111\ DOSE.ModLiOp.Value TRUE Activate automatic mode
5 FC111\CFC_FC111\ DOSE.AutModLi.Value TRUE Dosing automatic mode 
6 FC111\CFC_FC111\ DOSE.StartAut.Value FALSE Dosing stop; no start
7 FC111\CFC_FC111\DOSE.RstDQ_Li.Value TRUE Reset dosing quantity via intercon‐

nection
8 LI111\CFC_LI111\INT_P.OutTrkOn.Value TRUE Tracking
9 LI111\CFC_LI111\INT_P.Hold.Value FALSE Hold output value
10 NK111\CFC_NK111\ Valve.AutModOp TRUE Valve in automatic mode
11 NK112\CFC_NK112\ Valve.AutModOp TRUE Valve in automatic mode
12 NK113\CFC_NK113\ Valve.AutModOp TRUE Valve in automatic mode
13 NK114\CFC_NK114\ Valve.AutModOp TRUE Valve in automatic mode
14 NP111\CFC_NP111\ Motor. AutModOp TRUE Motor in automatic mode

7.3.2 Parameters for the steps

Parameters for the step "INIT_LINE1" in the "Initialization" tab         
The following table shows the parameters for the "INIT_LINE1" step:

No. Column 1 Column 2 Meaning
 1 NK111\CFC_NK111\Valve.OpenAut.Value TRUE Open valve
 2 NK112\CFC_NK112\Valve.OpenAut.Value TRUE Open valve
 3 NK113\CFC_NK113\Valve.OpenAut.Value TRUE Open valve
 4 NP111\CFC_NP111\Motor.StartAut.Value TRUE Switch on motor
 5 FC111\\CFC_FC111\DOSE.RstDQ_Li.Value FALSE Do not reset dosing quantity 

via interconnection

Parameters for the step "INIT_LINE2" in the "Initialization" tab
The following table shows the parameters for the "INIT_LINE2" step:

No. Column 1 Column 2 Meaning
 1 NK111\CFC_NK111\Valve.OpenAut.Value TRUE Open valve
 2 NK112\CFC_NK112\Valve.OpenAut.Value TRUE Open valve
 3 NK114\CFC_NK114\Valve.OpenAut.Value TRUE Open valve
 4 NP111\CFC_NP111\Motor.StartAut.Value TRUE Switch on motor
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Parameters for the step "INIT_DOSE" in the "Initialization" tab
The following table shows the parameters for the "INIT_DOSE" step:

No. Column 1 Column 2 Meaning
1 FC111\CFC_FC111\CTRL_PID.AutMod‐

Li.Value
TRUE Controller to automatic

2 FC111\CFC_FC111\DOSE.StartAut.Value TRUE Dosing to automatic
3 LI111\CFC_LI111\INT_P.OutTrkOn.Value FALSE No tracking for integrator
4 NP111\CFC_NP111\Motor.StartAut.Value TRUE Motor to automatic
5 FC111\CFC_FC111\CTRL_PID.MV_TrkOn.V

alue
FALSE Manipulated value tracking

Parameters for the step "INIT_DOSE" in the "Processing" tab
The following table shows the parameters for the "INIT_DOSE" step:

No. Column 1 Column 2 Meaning
1 FC111\CFC_FC111\CTRL_PID.SP_Ext.Val‐

ue
FC111\CFC_FC111\DOSE.SP1.Val
ue

Controller's external setpoint 
is the coarse dosing flow set‐
point of the dosing block

Specify run time - "INIT_DOSE" Step
1. Switch to the "General" tab.

2. Enter the value "8s" in the "Minimum" input box in the "Run times" group.

3. Click "Apply". 

       PCS 7 SMART automatically changes the value to "T#8s".

Parameters for the step "SLOW_DOWN" in the "Processing" tab
The following table shows the parameters for the "SLOW_DOWN" step:

No. Column 1 Column 2 Meaning
1 Plant1\RMT1\FC111\

\CFC_FC111\CTRL_PID.MV_TrkOn.Value
FALSE Controller to automatic

2 Plant1\RMT1\FC111\
\CFC_FC111\CTRL_PID.SP_Ext.Value

Plant1\RMT1\FC111\
\CFC_FC111\DOSE.SP2.Value

Controller's external setpoint 
is the fine dosing flow setpoint 
of the dosing block

Specify run time - "SLOW_DOWN" Step 
1. Switch to the "General" tab.

2. Enter the value "2s" in the "Minimum" input box in the "Run times" group.

3. Click "Apply". 

       PCS 7 SMART automatically changes the value to "T#2s".
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Parameters for the "CLOSE_LINE" step in the "Initialization" tab
The following table shows the parameters for the "CLOSE_LINE" step:

No. Column 1 Column 2 Meaning
1 NK111\CFC_NK111\Valve.OpenAut.Value FALSE Close valve
2 NK112\CFC_NK112\Valve.OpenAut.Value FALSE Close valve
3 NK113\CFC_NK113\Valve.OpenAut.Value FALSE Close valve
4 NK114\CFC_NK114\Valve.OpenAut.Value FALSE Close valve
5 FC111\CFC_FC111\DOSE.StartAut.Value FALSE Switch off dosing
6 NP111\CFC_NP111\Motor.StartAut.Value FALSE Switch off motor
7 LI111\CFC_LI111\INT_P.Hold.Value TRUE Stop integrator
8 FC111\CFC_FC111\DOSE.AutModLi.Value FALSE Dosing: Automatic off
9 FC111\CFC_FC111\DOSE.ModLiOp.Value FALSE Dosing in manual mode
10 FC111\CFC_FC111\CTRL_PID.ManModLi.Value TRUE Controller in manual mode
11 FC111\CFC_FC111\CTRL_PID.MV_TrkOn.Value TRUE Manipulated value tracking

Parameters for the step "END" in the "Initialization" tab
The following table shows the parameters for the "END" step:

No. Column 1 Column 2 Meaning
1 NK111\CFC_NK111\Valve.OpenAut.Value FALSE Close valve
2 NK112\CFC_NK112\Valve.OpenAut.Value FALSE Close valve
3 NK113\CFC_NK113\Valve.OpenAut.Value FALSE Close valve
4 NK114\CFC_NK114\Valve.OpenAut.Value FALSE Close valve
5 NP111\CFC_NP111\Motor.AutModOp FALSE Switch off motor
6 FC111\CFC_FC111\CTRL_PID.AutModLi.Value FALSE Controller in manual mode
7 FC111\CFC_FC111\CTRL_PID.ModLiOp.Value FALSE Controller in manual mode
8 FC111\CFC_FC111\CTRL_PID.ManModLi.Value FALSE Controller in manual mode
9 FC111\\CFC_FC111\CTRL_PID.Man 0.0 Manual specification for the 

manipulated variable

7.3.3 Assigning parameters to the transitions of the SFC chart

Introduction         
A transition contains the conditions according to which a sequential control system passes 
control from one step to the next. In principle, you assign parameters for the transitions in the 
same way as for the steps. 
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Prerequisites
● The "SFC_RMT1" SFC is open in the SFC Editor.

● The default names of the steps and transitions have been adapted.

Procedure
1. Double-click "DOSE_REA1" transition.

The "Properties" dialog box opens and the "General" tab is selected.

2. Switch to the "Condition" tab.
This tab displays a blank list (the statement lines). The cursor is positioned in the left column 
of the first line. The layout of the dialog box is the same as you saw when assigning 
parameters for the steps.

3. Assign the parameters for "DOSE_REA1" transition.
The entries required for this are listed in the tables below. Below you can see an overview 
of the steps as a reminder:

– For address 1: click the "Browse" to open the "Browse" dialog box and select the relevant 
I/O

– Enter address 2

– Apply your settings

– Select a new line

4. Select the new transition and enter the addresses.

Note

When entering the addresses, verify that you have selected the required transition based 
on the title bar of the "Properties" dialog box.

Similar to parameters for steps, the addresses in the table are specified in the following 
format:

[chart folder\chart name\block.I/O].

The plant hierarchy is omitted.

7.3.4 Parameters for the transitions

Parameters for the "DOSE_REA1" transition         
The following table shows the parameters for the "DOSE_REA1" transition:

No. Column 1 Column 2 Column 3 Meaning
1 FC111\ADDIT\CFC_SETP\

PARA_DOS_RM1_SEL.Out.Value
= 0 Dosing in reactor 1?
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Parameters for the "INIT_1_OK" transition
The following table shows the parameters for the "INIT_1_OK" transition:

No. Column 1 Column 2 Column 3 Meaning
1 NP111\CFC_NP111\Motor.FbkRunOut.Value = TRUE Motor on?
2 FC111\CFC_FC111\CTRL_PID.SP_ExtAct.Val‐

ue
= TRUE External setpoint active?

Parameters for the "DOSE_REA2" transition
The following table shows the parameters for the "DOSE_REA2" transition:

No. Address 1 Operator Address 2 Meaning
 1 FC111\ADDIT\CFC_SETP\

PARA_DOS_RM1_SEL.Out.Value
= 1 Dosing in reactor 2?

Parameters for the "INIT_2_OK" transition
The following table shows the parameters for the "INIT_2_OK" transition:

No. Column 1 Column 2 Column 3 Meaning
1 NP111\CFC_NP111\Motor.FbkRunOut.Value = TRUE Motor on?
2 FC111\CFC_FC111\CTRL_PID.SP_ExtAct.Val‐

ue
= TRUE External setpoint active?

Parameters for the "INIT_OK" transition
The following table shows the parameters for the "INIT_OK" transition:

No. Column 1 Column 2 Column 3 Meaning
1 FC111\CFC_FC111\DOSE.DQ1_

SP.Value
< FC111\CFC_FC111\DOSE.DQ_

Out.Value
Setpoint of coarse dos‐
ing is less than the dos‐
ing quantity?

Parameters for the "END_DOSE" transition
The following table shows the parameters for the "END_DOSE" transition:

No. Column 1 Column 2 Column 3 Meaning
1 FC111\CFC_FC111\DOSE.DosEnd.Value = TRUE Dosing ended? 

Parameters for the "CLOSE_OK" transition
The following table shows the parameters for the "CLOSE_OK" transition:

No. Column 1 Column 2 Column 3 Meaning
1 NP111\CFC_NP111\Motor.FbkRunOut.Value = FALSE Motor off?
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7.3.5 Optimizing the run sequence

Introduction         
PCS 7 SMART provides you with a function for optimizing the run sequence based on the data 
flow. You can use this function when you have completed the CFC and SFC configuration.

Note
Optimizing the run sequence of the blocks

If there is more than one automation system in a project, follow the steps outlined below for 
each automation system.

Prerequisites
● The color_gs project is open in SIMATIC Manager.

● The plant view is activated.

Procedure
1. In the tree view, select any folder where you have saved a CFC.

2. Select a CFC chart from the detail view and then select the menu command Options > 
Charts > Run Sequence.
The chart opens in the CFC Editor.

3. Select Options > Optimize Run Sequence.
The message dialog "The run sequence of the blocks will be changed...." opens.

4. Click "OK".
The run sequence is optimized.

5. Close the CFC Editor.
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7.4 The current status...

7.4.1 Current status of your project

Completed configuration tasks
You have learnt the following when configuring SFCs:

● Worked with standard functions such as renaming and opening.

● Created a sequential control system with graphic support.

● Renamed and assigned parameters to the steps and transitions of the sequential control 
system.

● Optimized the run sequence.
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Compiling, downloading and testing the charts 8
8.1 Overview of compiling, downloading, and testing

Overview
This section guides you through the following:

● Compiling the program you have created with CFC and SFC.

● Downloading your program to the CPU.

● Running your program in test mode. 

This allows you to check the correct functionality of the charts. You have already been 
introduced to the "Download" function when you downloaded the hardware configuration.

You can perform two steps in conjunction with creating the chart:

1. Compile and download the blocks and charts. For this task, you can use the "Compile and 
Download Objects" function.

2. Test the program in the SFC Editor and CFC Editor.
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8.2 Procedure

8.2.1 Compiling and Downloading CFC and SFC charts

Introduction                                       
You have already created the CFC and SFCs for your "color_gs" project. These charts must 
be compiled and loaded in a CPU for the automation functions to be executed by the AS. The 
compile and download operation are started in a common dialog box and run one after the 
other.

Prerequisites
● The CPU is in "STOP" mode.

● The color_gs project is open in SIMATIC Manager.

● The Component view is activated.

Procedure
1. Select the "color_gs_prj_MP\color_gs_prj_Prj\SIMATIC 400(1)" folder in the tree view.

2. Select PLC > Compile and Download Objects.
The "Compile and Download Objects" dialog box opens.
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3. Click "+" to expand the tree view.
The view shows a structure of the "color_gs" project that is essentially the same as the 
component view in SIMATIC Manager.
The view shows status or operating state information for each object:

4. Select the "Compile" and "Download" check boxes for the "Charts" object.

5. Select the "Charts" entry and click "Edit..." in the "Settings for Compilation/Download" area.
The "Compile Program/Download to Target System" dialog box opens with the "Compile 
Charts as Program" tab activated. The "Entire program" option is automatically selected 
because you are starting the compile and download operation for the first time.

Note

If you have found errors in your program during testing, you must correct your CFC and 
SFCs to eliminate the errors. Thereafter, when you restart the compiling and downloading, 
ensure that you select the "Changes only" option. 

This will save time when compiling and downloading.
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6. Activate the "Generate module drivers" check box. 
This option generates the module drivers for the signal-processing blocks.

Note

You can remove empty runtime groups by selecting Edit > Delete Empty Runtime Groups.

7. Click "OK" to apply your settings.
The dialog box closes and the message "Remember that if you download later (...), the 
blocks will be deleted on the CPU" opens.

8. Click "OK".

9. Check the settings of the following check boxes in the lower area of the "Compile and 
Download Objects" dialog box:

– Compile only: deactivated

– Do not load if compilation error is detected: activated
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10.Click "Start" to start the compile and download operation.
The message dialog "Downloading program changes during operation can, in the case of 
malfunctions or program errors, cause serious damage to personnel and equipment! Make 
sure..." opens.

11.Click "OK". The message dialog "If you want to download changes online, please make 
sure that ... Do you want to continue?"  opens.

12.Click "Yes". The compile and download operation starts.

Note

The progress display indicates which step PCS 7 SMART is currently performing, for 
example:
● "Compiling and downloading object"
● "Compiling charts as program"

When the operation is finished, the log file opens in a text editor.

13.Ignore the message: "...-> Object compilation was executed (with warnings)".
This message is generated because you have not yet integrated I/O modules in your project.

14.Close the text editor. The status in the "Charts" line is now "downloaded".

Note

If warnings or errors are shown in the log file following compilation, select the "Charts" 
object in the tree view and click "Single Object". This opens the "Logs" dialog box. There 
you can view the detailed warnings and error messages.

15.Click "Close" in the "Compile and Download Objects" dialog box.
The dialog box closes.

16.Start the CPU.

8.2.2 Testing the program

Introduction
You can test your program both in the SFC Editor and in the CFC Editor. In test mode, you 
can watch how the values change during the course of the process. Using test mode, you can 
make sure that your configured sequential control system runs free of errors.

Test mode in SFC
The testing operation is peformed in the SFC Editor. The "Properties" dialog box plays a central 
role in test mode.
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If you double-click on a step or a transition in the SFC chart, the "Properties" dialog box opens. 
Just as during creation of the SFC chart, you can use the arrow buttons to change from one 
step or transition to the next. In test mode, the dialog boxes also provide additional information:

● In the properties dialog of a step, you can see the actual values on the left, beside address 
1 and the setpoints on the right, beside address 2.

● In the properties dialog of a transition, you see the respective current values to the left of 
address 1 and to the right of address 2.

Note

You can modify all values in the white fields. Remember, however, that these values are 
written directly into your configuration data and therefore change the parameters of your 
SFC chart.

While working through the Getting Started document, you will not change any values; rather, 
you will use the "Properties" dialog boxes only for the purpose of monitoring.

Test mode in CFC
You start the test mode in CFC in the CFC Editor. You will be able to have the process values 
displayed at the individual block I/Os and to monitor the changes.

8.2.3 Testing the program in the SFC Editor

Introduction                 
After you have compiled and downloaded the program, you can run it in test mode. This way 
you can check if the sequential control system is working and the program is running correctly.

Prerequisites
● The color_gs project is open in SIMATIC Manager.

● The "SFC_RMT1" SFC is open in the SFC Editor.

● The CPU is in "RUN" mode.
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Working in test mode
1. In the SFC-Editor, select  Debug > Test Mode.

Test mode is activated.

– In the title bar of the SFC Editor, "SFC_RMT1 - color_gs_Prj\Plant1\RMT1 ONLINE" is 
shown on a colored background.

– In the lower part of the SFC Editor, you can see the status of the program, the operating 
mode, and the step control mode. The operating mode is set to "MANUAL" by default. 
The current step control mode is displayed in the drop-down list and is set to "T" by 
default.

– In the lower part of the SFC Editor, there are also buttons for controlling the SFC. For 
example: starting, holding, and resuming. 

2. Select Debug > Step Control Mode > T or O.
This mode activates an additional "O" command button next to the transition while the SFC 
is running.
The sequential control system reacts as described in the table below.

3. Click "Start" to run the program.
The SFC starts.

– Each step that is currently being executed is displayed in light green, with a small arrow 
pointing right.

– Steps that have already been worked through are displayed in dark green, with a small 
check mark.

– Transitions that are active but not yet satisfied are shown on a brown background.

– If you performed your configuration correctly, the entire SFC will be worked through to 
the end and all the steps will turn dark green and have a check mark beside them. 
Otherwise, you can click the "O" button to manually enable the next sequential control 
step although the transition is not met.

4. Select Debug > Test Mode. Test mode closes.

Characteristics of the sequential control system

Chart Status Sequential control system action
1. Free of errors The sequential control system is executed step-by-step according to the configured pa‐

rameters. You do not need the button.
2. Contains errors The sequential control system stops if the transition is not satisfied. You can click the "C" 

button to pass control to the next step regardless of whether the transition is satisfied.

8.2.4 Testing the program in the CFC Editor

Introduction        
You can test CFCs in the CFC Editor in the same way as SFCs.
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Prerequisites
● The color_gs project is open in SIMATIC Manager.

● The plant view is activated.

● The "SFC_RMT1" SFC is open in the SFC Editor.

● The "CFC_FC111" CFC is open in the CFC Editor.

Procedure
1. Select Debug > Test Mode in the CFC Editor.

Test mode is activated.

2. Press "CTRL" key and select the following blocks:

– CTRL_PID

– INPUT_U

– DOSE

3. Select Debug > Watch On.
All block interfaces enabled for test mode in the properties of the respective block are 
displayed on a yellow background.

4. Switch to the "SFC_RMT1" SFC.

5. Click the "Start" toolbar button.
This starts the program.

6. Switch to the "CFC_FC111" chart.
You can monitor all changes to values in this chart. For example, the current value of the 
dosed volume is displayed at the  "PV_Out" output of the "INPUT_U" block.

Note

Arrange the windows one beside the other to be able to watch the CFC and the SFC at the 
same time in test mode.

7. Select Debug > Test Mode.
This closes test mode.

8. Close the SFC Editor and the CFC Editor.
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8.3 The current status...

8.3.1 Current status of your project

Completed Configuration Tasks
By this stage, you have completed almost all of the configuration steps in SIMATIC Manager 
and in the CFC Editor and SFC Editor. You have compiled and downloaded this configuration, 
and you have observed the project execute in the SFC and CFC Editors.

This ensures that your configuration has no errors. If you find that your project has errors when 
it runs in the test mode, it is much easier to locate the error at this stage than after the entire 
project is completed.
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Configuring the operator station 9
9.1 Introduction to the OS project editor

Introduction
The "OS Project Editor" is used to configure the OS. This needs to be adapted so that the 
computer settings match. Otherwise, the "button set" at the bottom of the screen cannot be 
seen in PCS 7 SMART . 

Prerequisites
● WinCC Explorer is open.

Procedure
1. In the WinCC Explorer, select OS(1) > OS Project Editor to open the editor.

2. Select the "Layout" tab.

3. Select the screen resolution and "Monitor configuration" of your monitor.

4. Click "OK".
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9.2 Operator station in process mode

Purpose of the operator station   
The plant operator can operate and monitor the process on the operator station (OS) in process 
mode. So-called process pictures are displayed to the operator for this purpose. The 
automation system (AS) controls the process (open-loop and closed-loop control) and the OS 
reads the process values from the AS and displays the values graphically in the process 
pictures. Warnings and alarms are also displayed in the process pictures as soon as process 
values reach or exceed certain specified limits. This allows the operator to identify the location 
in the plant at which a problem occurs.

You will create one process picture for your "color_gs" project that will allow you to monitor the 
fill level of the raw material tank, the status of the valves etc. 
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9.3 Configuration of the operator station

The operator station in the project              
After you have created a project with the PCS 7 "New Project" wizard, PCS 7 SMART 
automatically creates an operator station. You have already configured this operator station 
in HW Config. But, you have not created a network connection for this OS as you did for the 
communication between the automation system and the engineering station to enable you to 
download data from the ES to the AS. This is not necessary for the "color_gs" project because 
the engineering station and the operator station are on the same computer. The operator 
station uses the same connection to the AS just like ES.

Process pictures in the project
PCS 7 "New Project" wizard also creates pictures automatically in the plant hierarchy, which 
you then configure in the OS. Larger projects have multiple process pictures for the various 
components of the plant. For the "color_gs" project, you have to only configure a single picture. 
During configuration, you will become familiar with all the basic functions of the OS.
Pictures are labeled with the following icon: 
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9.4 Working in the SIMATIC Manager

9.4.1 Preparations in SIMATIC Manager

Prerequisites       
Before you start configuring in the OS, there are a few preliminary steps to be performed in 
SIMATIC Manager:

Step Procedure
 1 Adapt picture names and activate the function for creating block icons (Page 143)
 2 Delete unnecessary pictures (Page 144)
 3 Create block icons (Page 145)
 4 Compile OS  (Page 147)

Editing the picture properties
Since the PCS 7 "New Project" wizard has already created pictures, they have default names  
similar to CFCs. You must first adapt these default names to suit your project requirements by 
assigning short descriptive names to them.

You also need to activate the function for creating block icons.

Deleting unnecessary pictures
When you create a project with the PCS 7 "New Project" wizard, pictures are automatically 
inserted in every hierarchy folder of the plant hierarchy. Since you require only one picture in 
your "color_gs" project, you must remove the unnecessary pictures from the Plant Hierarchy.

Creating block icons
PCS 7 SMART provides you with the "Create block icons" function. Block icons are inserted 
in process pictures and  they provide the operator with the most important information on a 
process tag at a glance. For example, in the block icon for a controller, the operator sees the 
process value (PV), the setpoint (SP) and the manipulated value (MV). The block icon for a 
controller is displayed in a process picture as shown below:
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Compiling the OS
You must execute the "Compiles OS" function after you finish configuring all of the data in 
SIMATIC Manager and before you start configuring the OS data of the OS. All the data from 
SIMATIC  Manager such as variables, messages, texts, hardware and connection 
configurations must be known to the OS.

Starting the OS
You have to start the OS to continue configuring it. Then, perform other steps in the WinCC 
Explorer.

9.4.2 Procedure

9.4.2.1 Editing picture properties

Introduction                   
To edit the picture properties:

● Change the name of the picture.

● Select the option for creating block icons.

Prerequisites 
● The color_gs project is open in SIMATIC Manager.

● The plant view is activated.

Procedure for Changing the Picture Name
1. Select the "color_gs_prj_MP\color_gs_prj_Prj\Plant1\ RMT1" folder in the tree view.

2. Select  "Picture(3)" in the detail view.

3. Select Edit > Object Properties.
The "Properties - WinCC Picture: Picture(3)" dialog box  opens with the "General" tab active.
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4. Change the default name "Picture(3)" to "RMT1" in the "Name" input box.

5. Click "Apply" to apply your settings.

Procedure for activating the option for creating block icons
1. Switch to the "Block icons" tab.

2. Select the "Derive the block icons from the plant hierarchy" check box, if not selected by 
default.

3. Click "OK" to apply your settings. 
The dialog box closes and the new name of the picture is displayed in the plant hierarchy.

9.4.2.2 Deleting unnecessary pictures

Introduction         
By default, the PCS 7 "New Project" wizard creates a picture in every hierarchy folder. In the 
"color_gs" project, you require only one picture since all the required data can be represented 
clearly in one picture.

Prerequisites
● The color_gs project is open in SIMATIC Manager.

● The Plant View is activated.
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Procedure
1. Select the "Plant1" folder in the tree view.

2. Select  "Picture(2)" in the detail view.

3. Press the <DEL> key.
The "Delete" message dialog opens.

4. Click "Yes".
The picture is deleted.

5. Repeat steps 1 through 4 for the following folders in the plant hierarchy:

Name of the Folder Name of the Picture
FC111 Picture(4)
ADDIT Picture(5)

9.4.2.3 Creating block icons

Prerequisites             
● The color_gs project is open in SIMATIC Manager.

● The Plant View is activated.

● The option for creating block icons is selected.

You can find information about these settings in the section "How to Work with Picture 
Properties (Page 143)".

Procedure
1. Select the "color_gs_prj_MP\color_gs_prj_Prj\Plant1\ RMT1" folder in the tree view.

2. Select Options > Plant Hierarchy > Create/Update Block Icons.... 
The "Create/update block icons" dialog box opens. The list contains the pictures for which 
block icons have been created. In this Getting Started document, the picture is called 
"Plant1\RMT1\RMT1".
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3. Check the following settings:
- Check box in front of the "Plant1\RMT1\RMT1" picture is selected.
- The value "2" is entered in the "Lower hierarchy levels included" drop-down list.

4. Click "OK".
This triggers generation of the block icons. The message dialog "To ensure possible ..., 
you must subsequently compile the associated operator stations... Do you want to view the 
function log now?" opens.

5. Click "No". 
The message window closes and block icon generation ends.
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Result
At this point, you will not see any evident results of this function. You can see the generated 
block icons only when you open the process picture for the "color_gs" project .

Note

If an MS Office message appears during the generation and wants to install something, cancel 
the messages. The generation then continues.

9.4.2.4 Compiling the OS

Introduction                     
Before configuring the data in the OS, you have to compile the OS. With this function, all the 
data from SIMATIC Manager, such as variables, messages, texts, hardware, and connection 
configurations are "made known" to the OS. Do not confuse compiling with downloading: When 
you compile, the data remains on the engineering system computer. It is simply made known 
to the OS so that you can access this data during configuration.

Prerequisites
● The color_gs project is open in SIMATIC Manager.

● The Component View is activated.

Procedure
1. Select the "color_gs_prj_MP\color_gs_prj_Prj\ [Name of the SIMATIC PC-Station]" item in 

the tree view.

2. Select PLC > Compile and Download Objects.... 
The "Compile and Download Objects" dialog box opens.

3. Open the tree view and select the "Compile" check box for the "OS(1)" object.

4. Select the "OS(1)" object and click "Edit".
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5. The "Settings:Compile OS" opens. You can ignore this setting as you have not yet created 
more than one area / one OS in this project.
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6. Click "Next >". 
The "Select the network connections for the S7 programs associated with the areas" dialog 
box opens. In the "S7 programs and network connections" group. You will find the "s7 
PROGRAM(1)" entry and the "S7 connection_1" subnet. This connection is used by the 
automation system and operator station for communication, which you have already 
created in NetPro.

7. If no connection is displayed here, click "Connection...". Select the S7 connection you have 
made in NetPro from the "Select network connection" dialog box and then click "OK". The 
selected connection is entered.

8. Click "Next". 
The "Select the data you want to compile and the scope of the compilation" step is displayed.

9. Activate the following check boxes and option buttons as shown in the figure below:
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10.Click "Apply".

11.Click "Start" in the "Compile and Download Objects" dialog box. 
The message dialog "If you want to download changes online, ...Do you want to continue?" 
opens.

12.Click "Yes". 
Compilation begins and a progress bar is displayed. When the compilation is complete, the 
log file opens in a text editor to display whether the execution was error-free or not.

13.Close the text editor.

14.Click "Close" in the "Compile and Download Objects" dialog box.

9.4.2.5 Starting the PCS7 SMART OS

Introduction         
You have now completed all the preparation steps for configuring the OS in SIMATIC Manager. 
Now, you can start to configure the OS. To do so, first open the OS.

Prerequisites
● The color_gs project is open in SIMATIC Manager.

● The Component view is activated.

Procedure
1. Select  "color_gs_prj_MP\color_gs_prj_Prj\<Name der SIMATIC PC-Station>\WinCC 

Applikation\ OS(1)" in the tree view.

2. Select Edit > Open Object. The PCS 7 OS - WinCC Explorer opens.
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9.5 Working on the OS

9.5.1 Structure of the OS - WinCC Explorer

Introduction              
The WinCC Explorer provides you with a series of editors that you can use to configure an 
OS. To configure the OS, you will use only a few of these editors.

Basic structure of WinCC Explorer
In principle, the structure of WinCC Explorer is very similar to Windows Explorer:

● In the left pane, there is a navigation window. Here, you will find all the editors for configuring 
the PCS 7 SMART OS.

● In the right pane, there is a detailed window in which detailed information on the entry 
selected in the navigation window is displayed.

You will only work with Graphics Designer in the "color_gs" project. This is the tool you use to 
create process pictures. You will not require any other editors to configure the OS.

9.5.2 Function of process pictures

Process pictures  
Process pictures are an image of the process plant for the operator. The process is operated 
here and system states are displayed.

The process picture you will create for the "color_gs" project already exists in the plant 
hierarchy in SIMATIC Manager.

You can edit the process picture in the "Graphics Designer" editor. You can insert the desired 
static and dynamic objects and interconnect them.

9.5.3 Setting the OS activation for the ES

Prerequisites
● WinCC is open.
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Procedure
If you want to visualize the process mode on an engineering station, perform the following 
settings.

1. Select OS(1).

2. Select the menu command Edit > Properties.

3. The "Project Properties" dialog window opens.

4. Select the "Options" tab.

5. Select the "Allow activation on ES" check box, if not already selected by default.

6. Click "OK".
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9.6 Working in general with the Graphics Designer

9.6.1 Introduction to the Graphics Designer

User Interface         
The Graphics Designer is one of the OS editors. The user interface of the Graphics Designer 
is displayed as follows:

Menu bar
Alignment palette - Layer palette - Color palette - Object palette - Font palette - Standard palette - Zoom 
palette
Drawing area on which you insert the objects for the process picture
.
.
.

Standard objects
● Standard
● Controls
● Style

Libraries - Object properties - Dynamic wizard - Tags
Status bar

Libraries
The libraries of the Graphics Designer contain a wide selection of ready-to-use graphic 
elements, such as piping and valves. You can modify these elements or add to them and store 
them in your own project libraries so that they are available to you at any time.

Objects
The Graphics Designer distinguishes between two different types of objects:

● Static objects: These objects are purely drawing objects like those that you would find in a 
drawing program. For example: lines, circles, polygons or static text.

● Dynamic objects: These objects are made dynamic via a connection to a block I/O (tag). 
In process mode, dynamic objects show the current values of a measuring point of the 
plant. In the "color_gs" project, you will get to know various dynamic objects.

9.6.2 Opening a Process Picture

Introduction         
You can edit the process picture in the OS using the "Graphics Designer" editor.

Prerequisites
The color_gs project is open in WinCC Explorer.
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Procedure
1. Select the "Graphics Designer" entry in the navigation window. 

The detail view shows all the pictures belonging to the project. The pictures displayed also 
include the default pictures and template pictures provided by PCS 7 SMART.
Default pictures and template pictures are designated with the "@" character before the 
name.

2. Double-click the "RMT1.pdl" picture in the detail view. 
The process picture opens in Graphics Designer. The view shows that this process picture 
already contains objects although you have not yet inserted any. These are the block icons 
that you created in the process picture with the "Create block icons" function in SIMATIC 
Manager. You can also see that the block icon for the valve has been inserted both in the 
horizontal alignment and vertical alignment variants. These two variants are influenced by 
the setting in the process object view in the "Picture Objects" tab that you made when 
assigning parameters for the CFCs.

Note

In the example, the automatically inserted block icons (for example, for the "CTRL_PID" 
controller) were moved.

9.6.3 Opening various toolbars

Introduction                
The most important toolbars and dialog boxes are open by default. If you inadvertently close 
toolbars or dialog boxes, you should know how to make them visible again.

Prerequisites
The process picture is open in the Graphics Designer.
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Procedure
1. Select View > Toolbars. 

The submenu opens. Here, you see the toolbars and dialog boxes that you can show and 
hide in the Graphics Designer.

2. Select the check box as shown in the figure:

Result
You can find the following tab on the right-hand side of the dialog window:

● "Standard" tab

● "Controls" tab

In Getting Started, you will only use the "Standard" tab.

9.6.4 Objects in the Graphics Designer

Objects in the Graphics Designer     
Before you get started on the actual configuration in the Graphics Designer, it is time for some 
theory relating to the various objects that you will use to create the "RMT1.pdl" process picture. 
These objects include the following:

● Static Objects

● Text Fields
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You also receive some background information on interconnecting tags. In this way, you can 
create the relationship between the process picture and the process tag.

9.6.5 Static objects

Static Objects
To visualize equipment, such as a pipe or a tank, you require static objects.  These objects do 
not change while they are in process mode. In other words, they are not influenced by a status 
or by a value of a process tag.

9.6.6 Text fields

Text Fields
In a text field, you can enter any information that you want the plant operator to see in the 
process picture. For example, you can insert a text field to allow you to label objects and to 
simplify the assignment of the picture objects to the process for the operator. You can enter 
any text in these text fields and can position the text fields anywhere in the process picture. 

For the "color_gs" project, you will insert text fields with appropriate labels for all the process 
tags.

9.6.7 Working with tag interconnection

Tag interconnection
Tag interconnection is a central function when you create process pictures: Objects are entered 
in the process picture that represent the process values of a process tag in the process mode. 
With the tag interconnection, you can create the connection between the object in the process 
picture and the actual process tag. This enables the OS to receive data from the AS, to display 
the data in the process picture and to update the data.
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9.7 Creating the process picture

9.7.1 Inserting pipes and a tank into the process picture
Block icons are already available in your process picture. PCS 7 SMART has inserted these 
symbols using the "Create/update block icons" function in the SIMATIC Manager.

This section will guide you to add static icons and assign them along with the automatically 
generated block icons.

Prerequisites           
● The "RMT1" process picture is open in the Graphics Designer.

● The block icons are available.

Procedure
1. Select the "Library" tab above the status bar. The available libraries are displayed in the 

dialog box.

2. Select the "Global Library/PlantElements\Tanks\Tank4" object and move it to the drawing 
area using drag-and-drop. Click on the "Eyeglasses" button in the toolbar to obtain a 
preview of the graphic objects.
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3. Drag additional objects to the drawing area as per the table below.

Name of the ob‐
ject

Total Path in the library ; 
Object

Symbol

Horizontal pipes  3 x Global library/Plant elements/Pipes - Smart Objects ; 
3D Pipe Horizontal

Vertical pipes  5 x Global library/Plant elements/Pipes- Smart Objects ; 
3D Pipe Vertical

Angle  1 x Global library/Plant elements/Pipes - Smart Objects ;
3D Pipe Elbow 1

Angle  1 x Global library/Plant elementsPipes - Smart Objects ;
3D Pipe Elbow 2

Angle  1 x Global library/Plant elements/Pipes - Smart Objects ; 
3D Pipe Elbow 3

Angle  1 x Global library/Plant elementsPipes - Smart Objects ; 
3D Pipe Elbow 4

Control valve  1 x Global library/Symbols/Valves ; 
30

Tanks represent‐
ing reactors

 2 x Global library/Siemens HMI Symbol Library/Tanks ; 
Tank1
Note: The icon is reduced.
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4. Close the library.

5. Select an object and adjust its size and position to match the following figure:

– You can move the object by positioning the cursor on the object, holding down the mouse 
button and dragging the object to the required location.

– You can increase or decrease the size of the object by positioning the mouse pointer 
on the corner handles of the object, holding down the mouse button, and dragging to 
make the object larger or smaller.

– Position the automatically created icons according to the following figure (see section 
"Opening a Process Picture (Page 153)").
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9.7.2 Labeling the parts of the plant

Overview
The parts of the plant are labeled in three separate steps:

Step Action
 1 Insert and Format Text Field (Page 160)
 2 Set Text Field (Page 160)
 3 Duplicate Text Field (Page 161)

9.7.3 Step 1 - Inserting a text field

Prerequisites                    
● The "RMT1.pdl" process picture is open in the Graphics Designer.

● The static objects have been inserted.

Procedure
1. Select "Standard Objects/Static Text" in the object palette.

2. Use the mouse to navigate to the drawing area.
The cursor transforms into a small text input symbol.

3. Draw a text field to the left of the reactor.
A rectangle is inserted and the text within it is already selected.

4. Change this text to "Reactor 1".

5. Press the Enter key to apply the text.

6. Now, format the text field using the style palette:

– Select the text field and click  "Line Weight/Invisible". This hides the text field frame.

– Select the text field and click  "Fill pattern / Transparent". The text field color is now 
transparent.

9.7.4 Step 2 - Setting the text field

Prerequisites     
● The "RMT1.pdl" process picture is open in the Graphics Designer.

● The text field is inserted and selected.
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Procedure
1. Select View > Toolbar > Object Properties. 

The "Properties" tab is enabled in the detail field.

2. Select the "Static Text" entry in the "Standard" tab. 
The detail view shows the name of the text field and the layer.

3. Switch to the detail view and then double-click the "Static Text 1" field in the "Static" column. 
You can now edit text in this field.

4. Enter "Reactor 1" and then press Enter.
This applies the name and displays it in the top line. 

Note
If you are working on the drawing board, this name will be displayed as a tooltip whenever 
you hover the mouse over the object.

5. Select the Static Text > Font entry in the tree view.

6. Switch to the detail view and then double-click the value "No" for the "Bold" attribute values. 
The value changes from "No" to "Yes" and the text is assigned the "Bold" attribute.

7. Close the "Object Properties" dialog box. 

Result
All changes are shown.

9.7.5 Step3 - Duplicating the text field

Prerequisites        
● The "RMT1.pdl" process picture is open in the Graphics Designer.

● The text field is inserted.

● The settings for text fields have been made.

Procedure
To avoid repeating all the settings you made for the first text field, you can duplicate the existing 
text field and overwrite the existing text. 

1. Select the text field if it is no longer selected, and select Edit > Duplicate. 
The program duplicates the text field.

2. Double-click the text field and change the text to "Reactor 2". 
The duplication function automatically applies all other formats.

3. In the "Properties" tab, select "Static Text" and change the object name.

4. Change the object name to "Reactor 2" in the detail view.
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5. Position the text field next to the object.

6. Repeat steps 1 to 5 to create the following text fields:

– Raw materials tank

– Plant unit RMT 1

7. Open the properties for the text field "Plant unit RMT 1" and select the "Static Text/Font" 
entry in the tree view.

8. Switch to the detail view and enter the value "16" for the "Font Size" attribute.

9. Close the "Object Properties" dialog box.

10.Position the text fields as follows:

– Raw materials tank: on the left, next to the raw material tank

– Plant unit RMT 1: in the upper left-hand corner of the process picture

11.Select File > Save to save the process picture.
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9.7.6 Current status of the process picture...

Result
Now that you have inserted the tank, the pipes, and the labeling, your process picture should 
look like the one below:

9.7.7 Adapting process pictures

Introduction               
To operate and monitor the process, open the OS in SIMATIC Manager and activate the OS 
project. 
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You can make any changes or expansions for the process pictures in the Graphics Designer 
of the WinCC Explorer.

It is possible that object names are not shown in process pictures. In view of this, insert the 
"Show/Hide Tag" button from the "@TemplateAPLV8.PDL" template picture in the process 
picture. Use this button to show/hide the object name. 

Prerequisites
● The "RMT1.pdl" process picture is open in the Graphics Designer.

Procedure
1. Select  "File > Open". 

The "Open" dialog window opens.

2. Double-click the "@TemplateAPLV8.PDL" object in the list in the "Name" column. 
The "@TemplateAPLV8.PDL" template picture opens.

3. Select the "Show/Hide Tag" objects.

4. Select Copy in the shortcut menu.

5. Click on the open picture "RMT1.pdl".

6. Select Edit > Paste.

7. Select File > Save.

8. Select File > Exit to close the Graphics Designer.

Result
During the subsequent process operation, you can show or hide the object names by clicking 
the "Show/Hide Tag" button.

9.7.8 Connecting the raw material tank with the process value

Introduction         
The tank you inserted in your process picture represents the raw material tank. To display the 
current fill level of the raw material tank in process mode, connect this tank with the relevant 
block.
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Prerequisites
● The "RMT1.pdl" process picture is open in the Graphics Designer.

● The static objects have been inserted.

Procedure
1. Select the "Tank4" object that depicts the raw material tank.

The name of the object is shown in the tooltip that appears when you position the cursor 
on the object.

2. If the "Object properties" dialog box is not visible at the bottom of the screen, select View > 
Toolbars > Object Properties.
The "Properties" tab is enabled. Tank4" is selected in the tree view and the "Object name" 
and "Layer" attributes are displayed in the detailed window.

3. Switch to the detail view and then double-click the "Tank4" field in the "Static" column.
You can now edit text in this field.

4. Enter "Raw material tank1" and press the Enter key.

5. Select "Tank4/Tag Assignment" in the tree view.

6. Switch to the detail view and position the cursor on the "Light Bulb" symbol next to the "Fill 
Level" attribute and open the shortcut menu.

7. Select "Tag". The tag selection dialog opens.

8. Select the "ES Variables" check box in the "Data source" group and clear the "WinCC Tags" 
check box. 
The tree view displays the ES variables.

9. Select the "ES Variables/ Plant1/RMT1/LI111/ CFC_LI111/ LIA" item in the tree view. 
All ES variables are displayed in the detail view.
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10.Select the "PV_Out#Value" tag in the detail view.

11.Click "OK". 
This accepts the variable and its entire path in the "Dynamic" column.

12.Double-click "100" in the "Static" column for the "Max" attribute. 
The "Enter Value" dialog box opens.

13.Enter "600" in the "Max" input box and then click "OK". 
This applies the value.

14.Apply the parameters for the minimum value.

15.Close the "Object Properties" dialog box.

16.Select File > Save to save the process picture.
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9.7.9 Step 3 - Adding explanatory text

Prerequisites         
● The "RMT1.pdl" process picture is open in the Graphics Designer.

● The block icon for "PARA_DOS_RM1_SEL" is available.

Procedure
The plant operator needs to be able to understand the setting for selecting the respective 
reactor. You use a text field in order to provide this explanation. You have already used text 
fields when labeling the plant.

1. Insert a text field – use the "Standard Objects/Static Text" object to do this.

2. Enter the following text: "Select reactor: white = Reactor 1, green = Reactor 2". 
Press <Shift + Return> to create a line break.

3. Format the text fields using the style palette:

– Frame invisible - "Line weight/Invisible" setting

– Fill transparent - "Fill Pattern/Transparent" setting

4. Select the "Properties" tab.

5. Select "Effect".

6. Double-click the "Global color scheme" attribute in the right-hand area of the window.
"No" is now entered in the "Static" column.

7. Close the "Object Properties" window.

8. Drag a frame around the explanatory text. Use the "Standard Objects/Rectangle" object for 
this purpose.

9. Format the text fields using the style palette:

– Thickness of the frame – "Line Weight/3 Pixel" setting

– Fill transparent - "Fill Pattern/Transparent" setting

10.Position the objects as shown in the figure below:

11.Drag a frame around all the objects using the mouse.

12.Select Edit > Group > Group. 
This groups all the objects into one single object and makes it easier to move them.

13.Position the objects between the reactors.
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9.7.10 Step 4 - Configuring the setpoint default

Prerequisites
● Graphics Designer is open.

● The block icon for "SP_INT_EXT" is available.

Procedure         
1. Insert an explanatory text field: "Input setpoint, white = internal (operator), green = external 

(CFC-chart)".

2. Format the text field using the style palette:

– Frame: invisible – "Line Weight/Invisible" setting

– Fill: Transparent – "Fill Pattern/Transparent" setting

3.  Insert a whole frame from the object palette: "Standard Objects/ Rectangle" object.

4. Format the whole frame using the style palette:

– Line weight of frame -- "Line Weight/3 Pixel" setting

– Fill: Transparent – "Fill Pattern/Transparent" setting

5. Position the block icon for "SP_INT_EXT" under the frame.

6. Position the grouped objects in the lower section on the left side.
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9.7.11 Completing the work

Procedure
1. Complete the positioning of all objects.

The process picture will now appear as follows:

2. Select File > Save to save your process picture with all changes and additions.

3. Close the Graphics Designer.
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9.8 The current status...

9.8.1 Current status of your project

Completed Configuration Tasks
At this point, your project is complete, thus enabling you to activate process mode. You have 
become acquainted with the following functions during the OS configuration:

● Setting the picture properties in SIMATIC Manager.

● Creating block icons.

● Compiling the operator station.

● Creating a process picture in the Graphics Designer with a variety of objects. for example, 
static and dynamic objects. 
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Working in runtime 10
10.1 Planning the user interface

10.1.1 Operator station in process mode

Operator control and monitoring options in process mode  
In process mode, the "color_gs" project provides various options for operator control and 
monitoring of the process.

With the block icons, you can perform the following:

● Observe the state of the valve: valve open or closed.

● Observe the state of the pump: pump active or inactive.

● Changing from a block icon to the associated faceplate.

● Creating the dosing quantity in the faceplate.

The block icons and associated text boxes provide you with the following options:

● Selecting the reactor.

● Selecting whether the setpoint is read from the CFC or whether the plant operator can 
specify the setpoint externally.

You can also monitor the CFC and SFCs. You were already introduced to this function when 
testing the charts.

10.1.2 User interface in process mode

Structure
To allow you to monitor and operate the process, a brief explanation of the user interface of 
PCS 7 SMART in process mode is explained below.

PCS 7 SMART Getting Started - Part 1 (V9.0 with APL)
Getting Started, 12/2017, A5E42181435-AA 171



The user interface in process mode is divided into four areas:

● Message line: Displays the most recent message with the highest priority.

● Overview area: You can select the areas of a plant and view them using various command 
buttons. In your "color_gs" project, you have only one button, namely "RMT1", because 
your plant consists of only one part. 
Next to each button there are four other small buttons which you can use to view alarms 
and warnings from the sublevel hierarchy. If you click in this area, you can automatically 
change to the process picture in which the alarm or warning originated. 
The arrow key on the extreme right opens a tree view in which you can select a sublevel 
of the hierarchy.

● Process picture: Returns the associated process picture, depending on the area you 
selected in the overview. In your "color_gs" project, the plant picture you created in the 
Graphics Designer is displayed.

● Button set: Can be used to call various functions which you can select in process mode. In 
the "color_gs" project, you will only get to know the buttons that are important for this project.
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10.2 Operator control and monitoring in process mode

10.2.1 WinCC language settings

Introduction
If the language selected in WinCC is not used, the corresponding text content will not appear 
in PCS 7 SMART. Question marks are displayed instead.

Prerequisites
● WinCC Explorer is open.

Procedure
1. Navigate to "OS (1) > Computer" and double-click the computer name to open the 

"Computer properties" dialog.

2. Select the "Parameters" tab.

3. Select the "English" language in both boxes.

4. Click "OK".

5. Close the window.

10.2.2 Activating process mode

Prerequisites        
● WinCC Explorer is open.

● The color_gs project is open.
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Procedure for Activating Process Mode
1. Select File > Activate. 

The progress bar and start screen open.

2. Click "RMT1" in the overview area. 
This displays the process picture which you created in the Graphics Designer.

10.2.3 Starting the process

Introduction           
To enable operator control and monitoring of all functions you have configured, start the dosing 
process.

Dosing is started using the SFC. You start the SFC directly in process mode without having 
to change back to SIMATIC Manager.

There are two ways to start the process:

● Using the block icon "..../RMT1/SFC_RMT1".

● Using a button in the button set.

Using the block icon
1. Click the block icon "..../RMT1/SFC_RMT1". 

The corresponding faceplate opens.

2. Click "Start". 
The "SFC Operation" dialog box opens.

3. Click "OK". 
The sequential control system starts and you can follow the process in your process picture.

4. Double-click a step in the SFC to view additional details about the current status of the SFC.
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Using the button set
1. Click "Change Button Set":

The second button set is displayed.

2. Click "SFC Visualization".

The "Open SFC" dialog box opens. Since you only have one OS and one SFC in your 
project, only this OS is displayed in the tree view and only the SFC in the detail window.

3. Select the "RMT1/SFC_RMT1"chart in the detail view and click "OK".
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4. This view is similar to the display that you worked when testing the SFC in the SFC 
Editor.

5. Position this detailed display so that you can see your entire process picture.

6. Click "Start". 
The "SFC Operation" dialog box opens.

7. Click "OK". 
The sequential control system starts: You can monitor the process in your process picture 
and in the detailed display of the SFC. The representation in the SFC is identical to the 
representation of the test mode.

Note

A simulated value is used, beginning with "INPUT_U", since a real value is not yet available. 

The use of a simulated value is then indicated in WinCC by a yellow hand (icon) and by a 
warning triangle on the tank.

Note

The symbols for alarm and warning on the block icons flash at the beginning, since the tank 
is slightly overfilled.
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10.2.4 Stopping the process

Procedure        
To stop the running proces manually:

1. Click "Stop" in the detailed display of the SFC chart. 
The "SFC Operation" dialog box opens.

2. Click "OK". 
This stops the process.

3. Now, click "Reset" and then "OK" in the "SFC Operation" dialog box. 
This resets all values to the input values.

10.2.5 Controlling the process by means of the process picture

Operator process control
There are several ways of influencing the process in the process mode using the process 
picture:

● Select Reactor (Page 177)

● Open Faceplate (Page 178)

● Define Setpoint Value (Page 178)

10.2.6 Specifying the reactor

Procedure         
1. Click on the "PARA_DOS_RM1_SEL" block icon.

The associated faceplate opens.

2. Click "Command".

3. Check the reactor in which you want to dose the raw material:

– Reactor 1 selected: "Off" command

– Reactor 2 selected: "On" command

If you want to select the other reactor, proceed as follows:

– Click "..." next to "Command".
The faceplate is expanded.

– Click "On" if Reactor 2 should be selected.
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4. Click "OK". 
The new value is applied and displayed in the faceplate.

5. Close the faceplate.
Result is as shown below: 

Command Reactor selection Block icon
"Off" Reactor 1 selected

"On" Reactor 2 selected

10.2.7 Opening the faceplates

Procedure           
1. Start the process.

2. Click "..._FC111/CTRL_PID" block icon. 
The associated faceplate opens with the "Standard" tab activated.

3. Select other tabs from the toolbar. 
The following views are of relevance to your "color_gs" project. Each view is explained in 
brief with an example here.

– Standard: You can view the setpoint and actual value of the controller, displayed as 
specific values and in graphic form.

– Parameters: You can modify certain values. You can change the limits for the graphic 
representation in the "Default" tab.

– Limits: You can  view the alarm limits that you defined in the CFC for this block.

4. Close the faceplate.

10.2.8 Changing the setpoint

Introduction         
This section guides you to change the setpoint. To change the setpoint:

● Define whether the process uses the external or internal setpoint.

● Then, enter the specific setpoint.
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Step 1: Specify setpoint output
1. Click on the "SP_INT_EXT" block icon.

The associated faceplate opens.

2. In the Command row, click the "..." button on the far right.

3. Check which setpoint is enabled:

– Setpoint selected internally: "Off" command

– Setpoint selected externally: "On" command

If you want to select the other setpoint, proceed as follows:

– In the Command row, click the "..." button on the far right.
The faceplate is expanded.

– Click "On" if the setpoint should be selected by an external source.

4. Click "OK". 
The new value is applied and displayed in the faceplate.

5. Close the faceplate.
Result: 

Command Setpoint default Block icon
"Off" Setpoint selected internally

"On" Setpoint selected externally
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Step 2: Enter the setpoint
1. Click on the ".../CFC_FC111/DOSE" block icon. 

The faceplate opens.

2. Check which setpoint default is enabled:
If you want to select the other setpoint default, proceed as follows:

– Click "..." next to the display for the setpoint default.
The faceplate is expanded.

– Click "External" if the external setpoint should be selected or the "Internal" if the internal 
setpoint should be selected.
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3. Click on the "internal" box and then click "OK".

4. If you have selected the "Internal" setpoint as default, you can change the setpoint.
To do this, click on the numerical display of setpoint.
The faceplate is expanded.
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5. Change the position of the controller or enter the desired setpoint.

6. Click "OK". 
The value is entered in the input box.

7. Close the faceplate. 
The modified value is displayed in the block icon.

8. Restart the process and review the results.

10.2.9 Working with messages

Introduction                   
This section guides you to work with messages. Messages are displayed as follows:

● In the message line.

● In a separate message list.
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Message line
While the process is running, warnings and alarms with messages are displayed in the 
message line of your screen. The message line contains the latest message with the highest 
priority.

Click the button to the right of the message line to acknowledge the messages.

Message list
You can also view all the messages and alarms in a list. 

1. Click "Change Button Set":

2. Click on "Message System":

The message list is displayed.

3. Acknowledge the messages as shown in the table below.

Ste
p 
No

Step Action

1. Acknowledge a single message Click "Acknowledge single messages".

This acknowledges the message that is highlighted in 
color at the start of the line.

2. Acknowledge all messages Click "Acknowledge all visible messages".

4. Click the buttons in the key area to navigate to the various message and alarm lists.

5. Click the "Previous Graphic" button in the button area:

This returns you to the "RMT1" process picture.
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10.2.10 Process mode exit

Procedure         
1. Click "Change keyset" in the keyset area:

2. Click "Leave Runtime".

The "End Runtime" dialog box opens.

3. Click "Deactivate". 
This is used to exit process mode.

4. Exit WinCC Explorer.
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Performing the additional task 11
11.1 Introduction to the additional task

Additional Task
In the "color_gs" project, two identically configured raw material tanks are required. The 
additional task is to configure the second raw material tank "RMT2". You do not need to work 
through all steps again but you will use the automatic functions of PCS 7 SMART. You will find 
that the copying function of PCS 7 SMART will save you many steps by performing these steps 
for you automatically in the background.

When you create the second raw material tank, you will work on your own. You have already 
become familiar with many of the required dialog boxes during configuration of the first raw 
material tank. In this section, we will not prescribe detailed step-by-step instructions but will 
specify the order in which you must make the configuration. This gives you a general guideline 
to proceed.
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11.2 Copying the existing 'RMT1' part of the plant

Prerequisites                         
● The color_gs project is open in SIMATIC Manager.

● The Plant View is activated.

● Configuration of the RMT1 plant component is complete and error-free.

Procedure
1. Use the "Copy/Paste" function in Windows to copy the complete "RMT1" hierarchy folder 

to the "Plant1" hierarchy folder.
SIMATIC Manager generates a copy of the "RMT1" hierarchy folder, names it "RMT1(1)" 
and saves it to the "Plant1" hierarchy folder. The names of the objects, for example, CFCs 
and SFCs, are also appended with a sequential number.
When you copy/move hierarchy folders which contain CFCs and process pictures, the 
references of dynamic objects  are also copied from OS pictures to CFC blocks in the target 
hierarchy folder.

Note

If you copy or move charts and pictures individually, they are not copied or moved within 
the hierarchy folder. The references of the dynamic objects are lost and they must be linked 
to the blocks again in the pictures.

2. Change the names of the hierarchy folder and the objects in the individual hierarchy folders 
according to the table below:

Hierarchy folder New name Object contained – old 
name

New name

RMT1(1) RMT2 RMT1(1)" process picture RMT2
  SFC_RMT1(1) SFC_RMT2
FC111 FC112 CFC_FC111(1) CFC_FC112
ADDIT ADDIT2 CFC_SETP(1) CFC_SETP2
LI111 LI112 CFC_LI111(1) CFC_LI112
NK 111 NK115 CFC_NK111(1) CFC_NK115
NK112 NK116 CFC_NK112(1) CFC_NK116
NK113 NK117 CFC_NK113(1) CFC_NK117
NK114 NK118 CFC_NK114(1) CFC_NK118
NP111 NP112 CFC_NP111(1) CFC_NP112
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Result
Your plant hierarchy should now appear as follows:
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11.3 Process mode preparation

Preparation
New charts and a new process picture were created when plant component RMT1 was copied 
to create RMT2. This new information must now be downloaded to the automation system and 
"made known" to the OS.

You use the central "Compile and Download Objects" function for this purpose. In this situation, 
PCS 7 SMART provides you with the option of compiling and downloading only the changed 
information. This reduces the time required for the compile and download operation. Since 
your "color_gs" project is small, there is no problem. When configuring large plants, this option 
gains insignificance.

Once the compile and download operation is complete, you need to adapt the RMT2 process 
picture.

Then you can activate process mode and test the functions.
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11.4 Compile and download the changes

Prerequisites         
● The color_gs project is open in SIMATIC Manager.

● The Plant View is activated.

● The CPU is in "RUN" mode.

Procedure
1. Select the "color_gs_prj_Prj" object in the tree view.

2. Select PLC > Compile and Download Objects.. 
The "Charts" object status is "changed".

3. Activate the check boxes as follows:

Note

If you see "undefined" for all objects in the "Compile and Download Objects" dialog box 
status, click "Status" in the "Update" area.
This updates the status.

4. Select the "Charts" object and click "Edit". 
The "Compile Program/Download to Target System" dialog box opens.
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5. Make the following settings:

– Activate the "Changes only" option button in the "Scope" group. 
The CPU only remains in process mode if you activate this option.

– Activate the "Generate module drivers" check box.

6. Switch to the tab "S7 download".

Performing the additional task
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7. Make the following settings:

– Select the "Changes only" option button in the "Download mode" group.

– Select the check box "Include user data blocks".

8. Click "OK". 
The settings are applied.

Performing the additional task
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9. Select the "OS(1)" object and click "Edit". 
The "Which areas do you want to assign to the operator station OS(1)?" dialog box opens, 
with the existing "RMT1" plant unit and the new "RMT2" plant unit displayed in the list. Both 
are automatically assigned to the OS(1).

10.Click "Next >". 
The "Select the network connections for the S7 Programs associated with the areas" dialog 
box opens. Both OS areas are shown in the left pane and the network connection that you 
have created in NetPro is shown in the right pane.

Performing the additional task
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11.Click "Next >".

12.The "Select the compilation data and scope of compilation" dialog is displayed.

13.Activate the following check boxes and option buttons:

– "Data" group: "Tags and messages"

– "Data" group: "SFC visualization"

– "Data" group: "Picture tree"

– "Scope" group: "Changes"

14.Click "Apply". 
The dialog box closes.

15.Click "Start". 
The compile and download operation starts and the message dialog "Downloading program 
changes during operation ...." opens.

16.Click "OK". 
The message dialog "If you want to download changes online, please make sure that ... 
Do you want to continue?" opens.

17.Click "Yes".
The compile and download operation starts and the log file is opened in the text editor.

18.Close the text editor.

19.Click "Close" in the "Compile and Download Objects" dialog box.

Performing the additional task
11.4 Compile and download the changes
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11.5 Adapting the OS configuration

Prerequisite    
The color_gs project is open in WinCC Explorer.

Procedure
1. Open "RMT2" in the Graphics Designer.

2. Change the header text to "Plant unit RMT2".

3. Save the process picture.

4. Close the Graphics Designer.

Additional changes are not necessary because all the block icons in the process picture along 
with their associated interconnections were updated by the copy operation and the subsequent 
compilation operation.

Performing the additional task
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11.6 Starting process mode

Prerequisites         
● The OS is compiled.

● The color_gs project is open in WinCC Explorer.

● The follow-up work has been performed in the "RMT2" process picture.

Procedure
1. Select File > Activate in WinCC Explorer. 

This function changes to operation in process mode. The overview area displays a button 
named "RMT2". You monitor the units separately by toggling the views using the "RMT1" 
and "RMT2" buttons. The button of the unit which is currently visualized is marked with a 
color.

2. Click "RMT2" in the overview area.

3. Change the button set, followed by "SFC Visualization". 
The "Open SFC" dialog box opens. The detail view shows two SFC charts: the SFC chart 
from "RMT1" and the SFC chart from "RMT2".

4. Select SFC chart "../RMT2" and start the sequential control system.
For more information, refer to AUTOHOTSPOT.

5. Perform the following steps in process mode:

– Switch between the plant units.

– Change the setpoint presetting.

– Specify the reactor selection.

6. For more information, refer to AUTOHOTSPOT.
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Starting and adapting the color_gs project 12
12.1 color_gs project

Downloading the color_gs project 
You can download the completely configured PCS 7 SMART color_gs project from the Internet 
(https://support.industry.siemens.com/cs/in/en/view/109478794). 

Use this project to gain an insight into working with SIMATIC PCS 7 SMART or to compare 
the project you have created with this color_gs project.

You can open and start this project on your computer. Since we assumed a specific hardware 
configuration when creating the project, you will need to adapt the hardware configuration if 
you use different hardware components.

The overview shows you how to open and adapt the color_gs project:

● Open the color_gs project (Page 198) 

● Adapt the hardware of the color_gs project (Page 198) 

● Adapt the blocks for the color_gs project (Page 199) 

● Adapt the project data for the color_gs project (Page 200) 

● Compile and download the color_gs project (Page 201) 
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12.2 Procedure

12.2.1 Opening the color_gs project

Introduction        
This step is necessary only if you want to work with the color_gs project of the "color_gs.zip" 
file. You can extract the zip file using a SIMATIC Manager function.

Prerequisite
SIMATIC Manager is open.

Procedure
1. Select File > Retrieve.

2. Open the folder in which you have stored the "color_gs.zip" file.

3. Select file "color_gs.zip" and click "Open".

4. If you want to accept the default folder, click "OK".

5. If you have created a separate folder for the color_gs project, navigate to this folder and 
then click "OK".
Retrieval from the archive is then started. After retrieval from the archive, the "Retrieve from 
Archive" message window opens.

6. Click "OK".
 "The multiproject 'color_gs_prj_MP' has been retrieved from the archive. Do you want to 
start it now?" dialog box opens.

7. Click "Yes".

12.2.2 Adapting the hardware for the color_gs project

Prerequisites
● The color_gs project is open in SIMATIC Manager.

● The component view is activated.

Starting and adapting the color_gs project
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Procedure
1. Activate the required network adapter in the configuration console.

For more information, refer to  "Configuration console settings" (Page 32).

2. To configure the AS:

– Select your existing component from the hardware catalog and drag it to the correct slot. 
A number of the components we used are placed intentionally on correct slots.

– Make the settings for the network connections (Ethernet).
For more information, refer to "AS configuration" (Page 42).

3. Rename the PC station in the SIMATIC Manager: 

– In the tree view, select the object with the symbol .

– Enter the name of your computer in the object properties.
For more information, refer to  "Renaming the PC station" (Page 44).

4. Configure the OS:

– Check the Station Configuration Editor to see if it matches the preset configuration. Set 
the network adapter and network connections.
For more information, refer to  "Configuring the PC station of the OS" (Page 45).

5. Configure the network connection in NetPro and download to the PC station.
For more information, refer to "NetPro Settings" (Page 47).

12.2.3 Adapting the blocks for the color_gs project

Prerequisites   
● The color_gs project is open in SIMATIC Manager.

● The "PCS 7 AP Library V90" library is open and selected.

Procedure
1. Select the "PCS 7 AP Library V90\Blocks+Templates\Blocks" item in the tree view. The 

detail view displays all the blocks.

2. Select all blocks that are also contained in your library.

3. Insert the blocks in the "color_gs_prj_MP\color_gs_prj_Lib\S7 Program(1)\Blocks" master 
data library using drag-and-drop. 
The "Insert function block" dialog box opens.

4. Click "All". 
This replaces all blocks in the master data library with the blocks from the current version 
of the PCS 7 library.

5. Select "color_gs_prj_MP\color_gs_prj_Lib\S7 program(1)\Charts" in the tree view.

6. Select the process tag type "VALVE_Lean".

Starting and adapting the color_gs project
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7. Select Edit > Open Object. 
The process tag type opens in the CFC Editor.

8. Select Options > Block Types.
The "Block Types" dialog box opens.

9. Select all blocks in the "Chart Folder" group and click "New Version".
The "Set Format" dialog box opens.

10.Click "Yes" to implement the formats. 
The "Import New Version" dialog box opens if the process tag types still contain blocks from 
an older version.

11.Click "Yes" to update the blocks. 
The "Import New Version" dialog box opens and displays all the identical block types.

12.Click "Yes". 
The dialog box closes.

13.Click "Close".

14.Close the CFC Editor.

15.Select  "color_gs_prj_MP\color_gs_prj_Lib\S7 program(1)\Blocks" in the tree view.

16.Select Options > Charts > Update Block Types
The "Update Block Types" wizard opens.

– In the "Select the S7 programs to be checked" step, select all the files of the "color_gs" 
project. The check boxes for all folders of all S7 programs are activated by default.

– Click "Next".

– All block types are activated by default in the step "Select the block type to be updated".

– Click "Finish". The "Set Format" dialog box opens.

– Click "Yes" to implement the formats. The log file opens when the update of the blocks 
and block instances is completed.

17.Click "Close" in the log.

18.Compile the AS after the block import.

12.2.4 Adapting the project data for the color_gs project

Prerequisites   
● The color_gs project is open in SIMATIC Manager.

● OS(1) is selected in the Component view.

Starting and adapting the color_gs project
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Procedure
1. Select Edit > Open Object. 

The "s7omwinx" dialog box opens.

2. Click "Yes" to open the project on a local computer which operates in server mode. 
WinCC Explorer opens.

Note
Configured server 
● Confirmation with "Yes" is necessary only if the computer name configured in the 

color_gs project does not match the name of the computer on which you have created 
the color_gs project.

● The computer name will be adapted automatically. You will be informed by a message 
box.

● Exit WinCC Explorer and start these steps once again.

3. Select the OS(1)\Computer item in the navigation window.

4. Double-click the computer symbol in the detail view.

5. Enter the name of the computer on which you have opened the project in the "Computer 
name" input box. 
You can find this name in the Station Configuration Editor.

6. Click "OK".

7. Respond to the "Change computer name" message with "OK". 
The computer symbol will now be crossed out in red in the dialog box.

8. Exit WinCC Explorer and open it again. 
The computer name is applied now.

9. Select "OS Project Editor".

10.In the shortcut menu, select "Open". 
The OS project editor opens.

11.Check whether the monitor configuration matches your system and modify, if necessary. 
Apply the other default settings and click "OK". 
The OS project editor configures the project.

12.Exit WinCC Explorer.

12.2.5 Compiling and downloading the color_gs project

Prerequisites                   
● The color_gs project is open in the component view of the SIMATIC Manager.

● The CPU is in "STOP" mode.

● The hardware is adapted.

● The blocks and project data are adapted.

Starting and adapting the color_gs project
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Procedure
1. Select the "color_gs_Prj" object in the tree view.

2. Select PLC > Compile and Download Objects.. 
The "Compile and Download Objects" dialog box opens.

3. Activate the following check boxes:

– color_gs_Prj\[name of the PC station]\Configuration: "Compile"

– color_gs_Prj\[name of the PC station]\WinCC application\OS(1): "Compile"

– color_gs_Prj\SIMATIC 400(1)\Hardware: "Compile" and "Download"

– color_gs_Prj\SIMATIC 400(1)\[Name of the CPU]\Charts: "Compile" and "Download"

4. Select the "Charts" object and click "Edit". 
The "Compile Program\Download to Target System" dialog box opens.

5. Activate the following option buttons and check boxes:

– "Scope" group: "Entire program"

– Additional settings: "Generate module drivers"

6. Click "OK".

7. Select the "OS(1)" object and click "Edit".

8. In the "Which areas do you want to assign to the operator station OS(1)?" dialog box, assign 
the preset plant units to OS (1).

9. Select the S7 connection in the "Select the network connections for the S7 Programs 
associated with the areas" dialog box.

10.In the "Select the data you want to compile and the scope of the compilation" dialog box, 
select the following check boxes:

– "Data" group: "Tags and messages"

– "Data" group: "SFC Visualization"

– "Data" group: "Picture Tree"

– "Scope" group: "Entire OS with memory reset"

11.Click "Apply".

12.Click "Start". 
The compile and download operation starts. The message "Downloading program changes 
during operation can, in the case of malfunctions or program errors, cause serious damage 
to personnel and equipment! Make sure..." opens.

13.Click "OK". 
The message dialog "If you want to download changes online, please make sure that ... 
Do you want to continue?" opens.

14.Click "Yes". 
The log file opens in the text editor to show you whether or not the compilation and download 
operation was successfully completed.

15.Close the text editor.

16.Start the CPU of the AS.
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Working in the OS
1. Switch to the component view of SIMATIC Manager.

2. Open the OS.
 For more information, refer to "Starting the PCS7 OS (Page 150)".

3. Activate process mode.

Additional information
 For more information, refer to  "Operator station in process mode (Page 171)".
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